Introduction

[image]

VIBlend Controls for WinForms Help Documentation
Introduction
Send Feedback
VIBlend Controls for WinForms ver. 8.0 Help Documentation

Introduction Image 1

Send comments on this topic to support@viblend.com

Copyright © 2008-2011 VIBlend, All Rights Reserved.


API Reference

[image]

VIBlend Controls for WinForms Help Documentation
API Reference
Send Feedback
VIBlend Controls for WinForms

The application programming interface (API) is the foundation for all of our WinForms controls and components. This topic provides detailed reference documentation for the VIBlend Controls for WinForms.

It covers the classes, methods, events, enumerations, interfaces, and delegates of the following controls:

  • vDataGridView
  • vComboBox
  • vListBox
  • vMenuExtender
  • vButton
  • vSplitButton
  • vSplitContainer
  • vRepeatButton
  • vRadioButton
  • vToggleButton
  • vCheckBox
  • RibbonForm
  • vVScrollBar
  • vHScrollBar
  • vNumericUpDown
  • vTreeView
  • vTreeViewBox
  • vTrackBar
  • vProgressBar
  • vCircularProgressBar
  • vDateTimePicker
  • vTabControl
  • vTextBox
  • vContextMenu
  • vNavPane
  • vExplorerBarPane
  • vOutlookNavPane
  • vMonthCalendar
  • vDateTimeEditor
  • vMaskedTextBox
  • vRibbonBar
  • vColorPicker
  • vBubbleBar
  • vFieldSet
  • vGroupBox
  • vToolTip
  • vLabel
  • vRatingControl
  • vHorizontalLayoutPanel
  • vPanel
  • vVerticalLayoutPanel
  • vFlowLayoutPanel
  • vImageReflectionControl
  • vControlBox
  • vCheckedListBox
  • vPercentageEditor
  • vCurrencyEditor
  • vFixedPointEditor
  • vDecimalEditor
  • vRadioListBox
  • vNumberEditor


VIBlend.Utilities Namespace

[image]

VIBlend Controls for WinForms Help Documentation
VIBlend.Utilities Namespace
Send Feedback

Classes

 | Class | Description
Public class | ControlTheme | Represents a VIBlend control theme
Public class | FillStyle | Represents a fill style
Public class | FillStyleGradient | Represents a two colors gredient fill style
Public class | FillStyleGradientEx | Represents a four color gradient fill style
Public class | FillStyleSolid | Represents a solid fill style
Public class | GridCellStyle | Represents a style of a data grid cell
Public class | GridTheme | Represents a GridView Theme
Public class | HierarchyItemStyle | Represents a style of a HierarchyItem
Public class | Licensing |
Public class | NamedColor | Represents a Named Color. This class is used in the VIBlend themes definition
Public class | NamedFillStyle | Represents a Named fill style. This class is used in the VIBlend themes definition
Public class | NamedValue | Represents a Name and Value pair. This class is used to define setter properties in VIBlend themes
Public class | ThemeCache |
Public class | vColors |
Public class | vDropDownControlBase |
Public class | vDropDownForm |
Public class | VisualStyle | Represents a visual style of a UI element

Enumerations

 | Enumeration | Description
Public enumeration | RoundedCornersMask | Enumeration of the rounded cornerners mask values
Public enumeration | VIBLEND_THEME | Enumeration of the standard VIBlend themes


ControlTheme Class

[image]

VIBlend Controls for WinForms Help Documentation
ControlTheme Class
Members See Also Send Feedback
Represents a VIBlend control theme

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[SerializableAttribute]
public class ControlTheme
Visual Basic
<SerializableAttribute> _
Public Class ControlTheme
Visual C++
[SerializableAttribute]
public ref class ControlTheme

Inheritance Hierarchy

System..::..Object
VIBlend.Utilities..::..ControlTheme

See Also

ControlTheme Members
VIBlend.Utilities Namespace


ControlTheme Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
ControlTheme Members
ControlTheme Class Constructors Methods Properties See Also Send Feedback

The ControlTheme type exposes the following members.

Constructors

 | Name | Description
Public method | ControlTheme | Constructor

Methods

 | Name | Description
Public method | CreateCopy | Creates a new ControlTheme object which is a copy of the current one
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefaultTheme | Creates and returns an instance of one of the default VIBlend themes
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFromXml | Loads the Theme from a XML file
Public method | LoadFromXmlStream | Loads the theme from a XML stream
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveToXml | Saves the theme to a XML file
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | StyleDisabled | Visual style for disabled state
Public property | StyleDisabledPressed | Visual style for disabled state
Public property | StyleHighlight | Visual style for highlight state
Public property | StyleNormal | Visual style for normal state
Public property | StylePressed | Visual style for pressed state

See Also

ControlTheme Class
VIBlend.Utilities Namespace


ControlTheme Constructor

[image]

VIBlend Controls for WinForms Help Documentation
ControlTheme Constructor
ControlTheme Class See Also Send Feedback
Constructor

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme()
Visual Basic
Public Sub New
Visual C++
public:
ControlTheme()

See Also

ControlTheme Class
VIBlend.Utilities Namespace


ControlTheme Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
ControlTheme Methods
ControlTheme Class See Also Send Feedback

The ControlTheme type exposes the following members.

Methods

 | Name | Description
Public method | CreateCopy | Creates a new ControlTheme object which is a copy of the current one
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefaultTheme | Creates and returns an instance of one of the default VIBlend themes
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFromXml | Loads the Theme from a XML file
Public method | LoadFromXmlStream | Loads the theme from a XML stream
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveToXml | Saves the theme to a XML file
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ControlTheme Class
VIBlend.Utilities Namespace


CreateCopy Method

[image]

VIBlend Controls for WinForms Help Documentation
ControlTheme..::..CreateCopy Method
ControlTheme Class See Also Send Feedback
Creates a new ControlTheme object which is a copy of the current one

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme CreateCopy()
Visual Basic
Public Function CreateCopy As ControlTheme
Visual C++
public:
ControlTheme^ CreateCopy()

Return Value

See Also

ControlTheme Class
VIBlend.Utilities Namespace


GetDefaultTheme Method

[image]

VIBlend Controls for WinForms Help Documentation
ControlTheme..::..GetDefaultTheme Method
ControlTheme Class See Also Send Feedback
Creates and returns an instance of one of the default VIBlend themes

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static ControlTheme GetDefaultTheme(
    VIBLEND_THEME theme
)
Visual Basic
Public Shared Function GetDefaultTheme ( _
    theme As VIBLEND_THEME _
) As ControlTheme
Visual C++
public:
static ControlTheme^ GetDefaultTheme(
    VIBLEND_THEME theme
)

Parameters

theme
Type: VIBlend.Utilities..::..VIBLEND_THEME

See Also

ControlTheme Class
VIBlend.Utilities Namespace


LoadFromXml Method

[image]

VIBlend Controls for WinForms Help Documentation
ControlTheme..::..LoadFromXml Method
ControlTheme Class See Also Send Feedback
Loads the Theme from a XML file

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool LoadFromXml(
    string fileName
)
Visual Basic
Public Function LoadFromXml ( _
    fileName As String _
) As Boolean
Visual C++
public:
bool LoadFromXml(
    String^ fileName
)

Parameters

fileName
Type: System..::..String

See Also

ControlTheme Class
VIBlend.Utilities Namespace


LoadFromXmlStream Method

[image]

VIBlend Controls for WinForms Help Documentation
ControlTheme..::..LoadFromXmlStream Method
ControlTheme Class See Also Send Feedback
Loads the theme from a XML stream

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool LoadFromXmlStream(
    Stream stream
)
Visual Basic
Public Function LoadFromXmlStream ( _
    stream As Stream _
) As Boolean
Visual C++
public:
bool LoadFromXmlStream(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream

See Also

ControlTheme Class
VIBlend.Utilities Namespace


SaveToXml Method

[image]

VIBlend Controls for WinForms Help Documentation
ControlTheme..::..SaveToXml Method
ControlTheme Class See Also Send Feedback
Saves the theme to a XML file

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool SaveToXml(
    string fileName
)
Visual Basic
Public Function SaveToXml ( _
    fileName As String _
) As Boolean
Visual C++
public:
bool SaveToXml(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
Name of the XML file

See Also

ControlTheme Class
VIBlend.Utilities Namespace


ControlTheme Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
ControlTheme Properties
ControlTheme Class See Also Send Feedback

The ControlTheme type exposes the following members.

Properties

 | Name | Description
Public property | StyleDisabled | Visual style for disabled state
Public property | StyleDisabledPressed | Visual style for disabled state
Public property | StyleHighlight | Visual style for highlight state
Public property | StyleNormal | Visual style for normal state
Public property | StylePressed | Visual style for pressed state

See Also

ControlTheme Class
VIBlend.Utilities Namespace


StyleDisabled Property

[image]

VIBlend Controls for WinForms Help Documentation
ControlTheme..::..StyleDisabled Property
ControlTheme Class See Also Send Feedback
Visual style for disabled state

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VisualStyle StyleDisabled { get; set; }
Visual Basic
Public Property StyleDisabled As VisualStyle
    Get
    Set
Visual C++
public:
property VisualStyle^ StyleDisabled {
    VisualStyle^ get ();
    void set (VisualStyle^ value);
}

See Also

ControlTheme Class
VIBlend.Utilities Namespace


StyleDisabledPressed Property

[image]

VIBlend Controls for WinForms Help Documentation
ControlTheme..::..StyleDisabledPressed Property
ControlTheme Class See Also Send Feedback
Visual style for disabled state

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VisualStyle StyleDisabledPressed { get; set; }
Visual Basic
Public Property StyleDisabledPressed As VisualStyle
    Get
    Set
Visual C++
public:
property VisualStyle^ StyleDisabledPressed {
    VisualStyle^ get ();
    void set (VisualStyle^ value);
}

See Also

ControlTheme Class
VIBlend.Utilities Namespace


StyleHighlight Property

[image]

VIBlend Controls for WinForms Help Documentation
ControlTheme..::..StyleHighlight Property
ControlTheme Class See Also Send Feedback
Visual style for highlight state

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VisualStyle StyleHighlight { get; set; }
Visual Basic
Public Property StyleHighlight As VisualStyle
    Get
    Set
Visual C++
public:
property VisualStyle^ StyleHighlight {
    VisualStyle^ get ();
    void set (VisualStyle^ value);
}

See Also

ControlTheme Class
VIBlend.Utilities Namespace


StyleNormal Property

[image]

VIBlend Controls for WinForms Help Documentation
ControlTheme..::..StyleNormal Property
ControlTheme Class See Also Send Feedback
Visual style for normal state

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VisualStyle StyleNormal { get; set; }
Visual Basic
Public Property StyleNormal As VisualStyle
    Get
    Set
Visual C++
public:
property VisualStyle^ StyleNormal {
    VisualStyle^ get ();
    void set (VisualStyle^ value);
}

See Also

ControlTheme Class
VIBlend.Utilities Namespace


StylePressed Property

[image]

VIBlend Controls for WinForms Help Documentation
ControlTheme..::..StylePressed Property
ControlTheme Class See Also Send Feedback
Visual style for pressed state

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VisualStyle StylePressed { get; set; }
Visual Basic
Public Property StylePressed As VisualStyle
    Get
    Set
Visual C++
public:
property VisualStyle^ StylePressed {
    VisualStyle^ get ();
    void set (VisualStyle^ value);
}

See Also

ControlTheme Class
VIBlend.Utilities Namespace


FillStyle Class

[image]

VIBlend Controls for WinForms Help Documentation
FillStyle Class
Members See Also Send Feedback
Represents a fill style

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[SerializableAttribute]
public abstract class FillStyle
Visual Basic
<SerializableAttribute> _
Public MustInherit Class FillStyle
Visual C++
[SerializableAttribute]
public ref class FillStyle abstract

Inheritance Hierarchy

System..::..Object
VIBlend.Utilities..::..FillStyle
VIBlend.Utilities..::..FillStyleGradient
VIBlend.Utilities..::..FillStyleGradientEx
VIBlend.Utilities..::..FillStyleSolid

See Also

FillStyle Members
VIBlend.Utilities Namespace


FillStyle Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
FillStyle Members
FillStyle Class Constructors Methods Properties See Also Send Feedback

The FillStyle type exposes the following members.

Constructors

 | Name | Description
Protected method | FillStyle | Initializes a new instance of the FillStyle class

Methods

 | Name | Description
Public method | Clone | Creates a copy of the fill style object
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrush | Gets a brush for painting the fill area
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Colors | Gets the fill colors
Public property | ColorsNumber | Gets the number of fill colors

See Also

FillStyle Class
VIBlend.Utilities Namespace


FillStyle Constructor

[image]

VIBlend Controls for WinForms Help Documentation
FillStyle Constructor
FillStyle Class See Also Send Feedback
Initializes a new instance of the FillStyle class

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected FillStyle()
Visual Basic
Protected Sub New
Visual C++
protected:
FillStyle()

See Also

FillStyle Class
VIBlend.Utilities Namespace


FillStyle Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
FillStyle Methods
FillStyle Class See Also Send Feedback

The FillStyle type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the fill style object
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrush | Gets a brush for painting the fill area
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillStyle Class
VIBlend.Utilities Namespace


Clone Method

[image]

VIBlend Controls for WinForms Help Documentation
FillStyle..::..Clone Method
FillStyle Class See Also Send Feedback
Creates a copy of the fill style object

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public abstract FillStyle Clone()
Visual Basic
Public MustOverride Function Clone As FillStyle
Visual C++
public:
virtual FillStyle^ Clone() abstract

See Also

FillStyle Class
VIBlend.Utilities Namespace


GetBrush Method

[image]

VIBlend Controls for WinForms Help Documentation
FillStyle..::..GetBrush Method
FillStyle Class See Also Send Feedback
Gets a brush for painting the fill area

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public abstract Brush GetBrush(
    Rectangle rect
)
Visual Basic
Public MustOverride Function GetBrush ( _
    rect As Rectangle _
) As Brush
Visual C++
public:
virtual Brush^ GetBrush(
    Rectangle rect
) abstract

Parameters

rect
Type: System.Drawing..::..Rectangle

Return Value

See Also

FillStyle Class
VIBlend.Utilities Namespace


FillStyle Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
FillStyle Properties
FillStyle Class See Also Send Feedback

The FillStyle type exposes the following members.

Properties

 | Name | Description
Public property | Colors | Gets the fill colors
Public property | ColorsNumber | Gets the number of fill colors

See Also

FillStyle Class
VIBlend.Utilities Namespace


Colors Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyle..::..Colors Property
FillStyle Class See Also Send Feedback
Gets the fill colors

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public abstract Color[] Colors { get; }
Visual Basic
Public MustOverride ReadOnly Property Colors As Color()
    Get
Visual C++
public:
virtual property array<Color>^ Colors {
    array<Color>^ get () abstract;
}

See Also

FillStyle Class
VIBlend.Utilities Namespace


ColorsNumber Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyle..::..ColorsNumber Property
FillStyle Class See Also Send Feedback
Gets the number of fill colors

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public abstract int ColorsNumber { get; }
Visual Basic
Public MustOverride ReadOnly Property ColorsNumber As Integer
    Get
Visual C++
public:
virtual property int ColorsNumber {
    int get () abstract;
}

See Also

FillStyle Class
VIBlend.Utilities Namespace


FillStyleGradient Class

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradient Class
Members See Also Send Feedback
Represents a two colors gredient fill style

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[SerializableAttribute]
public class FillStyleGradient : FillStyle
Visual Basic
<SerializableAttribute> _
Public Class FillStyleGradient _
    Inherits FillStyle
Visual C++
[SerializableAttribute]
public ref class FillStyleGradient : public FillStyle

Inheritance Hierarchy

System..::..Object
VIBlend.Utilities..::..FillStyle
VIBlend.Utilities..::..FillStyleGradient

See Also

FillStyleGradient Members
VIBlend.Utilities Namespace


FillStyleGradient Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradient Members
FillStyleGradient Class Constructors Methods Properties See Also Send Feedback

The FillStyleGradient type exposes the following members.

Constructors

 | Name | Description
Public method | FillStyleGradient | Constructor

Methods

 | Name | Description
Public method | Clone | Creates a copy of the style (Overrides FillStyle..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetBrush | Gets a brush for painting the fill area (Inherited from FillStyle.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color1 | Start gradient color
Public property | Color2 | End gradient color
Public property | Colors | Gets the gradient colors (Overrides FillStyle..::..Colors.)
Public property | ColorsNumber | Gets the number of gradient colors (Overrides FillStyle..::..ColorsNumber.)
Public property | LinearGradientMode | Gets or sets the Gradient mode

See Also

FillStyleGradient Class
VIBlend.Utilities Namespace


FillStyleGradient Constructor

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradient Constructor
FillStyleGradient Class See Also Send Feedback
Constructor

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public FillStyleGradient(
    Color color1,
    Color color2,
    LinearGradientMode gradientMode
)
Visual Basic
Public Sub New ( _
    color1 As Color, _
    color2 As Color, _
    gradientMode As LinearGradientMode _
)
Visual C++
public:
FillStyleGradient(
    Color color1,
    Color color2,
    LinearGradientMode gradientMode
)

Parameters

color1
Type: System.Drawing..::..Color
Color1
color2
Type: System.Drawing..::..Color
Color2
gradientMode
Type: System.Drawing.Drawing2D..::..LinearGradientMode
Gradient mode

See Also

FillStyleGradient Class
VIBlend.Utilities Namespace


FillStyleGradient Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradient Methods
FillStyleGradient Class See Also Send Feedback

The FillStyleGradient type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the style (Overrides FillStyle..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetBrush | Gets a brush for painting the fill area (Inherited from FillStyle.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillStyleGradient Class
VIBlend.Utilities Namespace


Clone Method

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradient..::..Clone Method
FillStyleGradient Class See Also Send Feedback
Creates a copy of the style

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override FillStyle Clone()
Visual Basic
Public Overrides Function Clone As FillStyle
Visual C++
public:
virtual FillStyle^ Clone() override

See Also

FillStyleGradient Class
VIBlend.Utilities Namespace


Finalize Method

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradient..::..Finalize Method
FillStyleGradient Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

FillStyleGradient Class
VIBlend.Utilities Namespace


FillStyleGradient Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradient Properties
FillStyleGradient Class See Also Send Feedback

The FillStyleGradient type exposes the following members.

Properties

 | Name | Description
Public property | Color1 | Start gradient color
Public property | Color2 | End gradient color
Public property | Colors | Gets the gradient colors (Overrides FillStyle..::..Colors.)
Public property | ColorsNumber | Gets the number of gradient colors (Overrides FillStyle..::..ColorsNumber.)
Public property | LinearGradientMode | Gets or sets the Gradient mode

See Also

FillStyleGradient Class
VIBlend.Utilities Namespace


Color1 Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradient..::..Color1 Property
FillStyleGradient Class See Also Send Feedback
Start gradient color

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color Color1 { get; set; }
Visual Basic
Public Property Color1 As Color
    Get
    Set
Visual C++
public:
property Color Color1 {
    Color get ();
    void set (Color value);
}

See Also

FillStyleGradient Class
VIBlend.Utilities Namespace


Color2 Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradient..::..Color2 Property
FillStyleGradient Class See Also Send Feedback
End gradient color

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color Color2 { get; set; }
Visual Basic
Public Property Color2 As Color
    Get
    Set
Visual C++
public:
property Color Color2 {
    Color get ();
    void set (Color value);
}

See Also

FillStyleGradient Class
VIBlend.Utilities Namespace


Colors Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradient..::..Colors Property
FillStyleGradient Class See Also Send Feedback
Gets the gradient colors

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color[] Colors { get; }
Visual Basic
Public Overrides ReadOnly Property Colors As Color()
    Get
Visual C++
public:
virtual property array<Color>^ Colors {
    array<Color>^ get () override;
}

See Also

FillStyleGradient Class
VIBlend.Utilities Namespace


ColorsNumber Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradient..::..ColorsNumber Property
FillStyleGradient Class See Also Send Feedback
Gets the number of gradient colors

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override int ColorsNumber { get; }
Visual Basic
Public Overrides ReadOnly Property ColorsNumber As Integer
    Get
Visual C++
public:
virtual property int ColorsNumber {
    int get () override;
}

See Also

FillStyleGradient Class
VIBlend.Utilities Namespace


LinearGradientMode Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradient..::..LinearGradientMode Property
FillStyleGradient Class See Also Send Feedback
Gets or sets the Gradient mode

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public LinearGradientMode LinearGradientMode { get; set; }
Visual Basic
Public Property LinearGradientMode As LinearGradientMode
    Get
    Set
Visual C++
public:
property LinearGradientMode LinearGradientMode {
    LinearGradientMode get ();
    void set (LinearGradientMode value);
}

See Also

FillStyleGradient Class
VIBlend.Utilities Namespace


FillStyleGradientEx Class

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradientEx Class
Members See Also Send Feedback
Represents a four color gradient fill style

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[SerializableAttribute]
public class FillStyleGradientEx : FillStyle
Visual Basic
<SerializableAttribute> _
Public Class FillStyleGradientEx _
    Inherits FillStyle
Visual C++
[SerializableAttribute]
public ref class FillStyleGradientEx : public FillStyle

Inheritance Hierarchy

System..::..Object
VIBlend.Utilities..::..FillStyle
VIBlend.Utilities..::..FillStyleGradientEx

See Also

FillStyleGradientEx Members
VIBlend.Utilities Namespace


FillStyleGradientEx Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradientEx Members
FillStyleGradientEx Class Constructors Methods Properties See Also Send Feedback

The FillStyleGradientEx type exposes the following members.

Constructors

 | Name | Description
Public method | FillStyleGradientEx | Constructor

Methods

 | Name | Description
Public method | Clone | Creates a copy of the fill style (Overrides FillStyle..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrush | Gets a brush for painting the fill area (Inherited from FillStyle.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color1 | Gradient Color1
Public property | Color2 | Gradient Color2
Public property | Color3 | Gradient Color3
Public property | Color4 | Gradient Color4
Public property | Colors | Gets the gradient colors (Overrides FillStyle..::..Colors.)
Public property | ColorsNumber | Gets the number of colors (Overrides FillStyle..::..ColorsNumber.)
Public property | GradientAngle | Gets or sets the Gradient Angle
Public property | GradientOffset | Gets or sets the Gradient Percentage 1
Public property | GradientOffset2 | Gets or sets the Gradient Percentage 2

See Also

FillStyleGradientEx Class
VIBlend.Utilities Namespace


FillStyleGradientEx Constructor

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradientEx Constructor
FillStyleGradientEx Class See Also Send Feedback
Constructor

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public FillStyleGradientEx(
    Color color1,
    Color color2,
    Color color3,
    Color color4,
    float gradientAngle,
    float gradientOffset,
    float gradientOffset2
)
Visual Basic
Public Sub New ( _
    color1 As Color, _
    color2 As Color, _
    color3 As Color, _
    color4 As Color, _
    gradientAngle As Single, _
    gradientOffset As Single, _
    gradientOffset2 As Single _
)
Visual C++
public:
FillStyleGradientEx(
    Color color1,
    Color color2,
    Color color3,
    Color color4,
    float gradientAngle,
    float gradientOffset,
    float gradientOffset2
)

Parameters

color1
Type: System.Drawing..::..Color
Color1
color2
Type: System.Drawing..::..Color
Color2
color3
Type: System.Drawing..::..Color
Color3
color4
Type: System.Drawing..::..Color
Color4
gradientAngle
Type: System..::..Single
Gradient angle
gradientOffset
Type: System..::..Single
gradientOffset2
Type: System..::..Single

See Also

FillStyleGradientEx Class
VIBlend.Utilities Namespace


FillStyleGradientEx Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradientEx Methods
FillStyleGradientEx Class See Also Send Feedback

The FillStyleGradientEx type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the fill style (Overrides FillStyle..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrush | Gets a brush for painting the fill area (Inherited from FillStyle.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillStyleGradientEx Class
VIBlend.Utilities Namespace


Clone Method

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradientEx..::..Clone Method
FillStyleGradientEx Class See Also Send Feedback
Creates a copy of the fill style

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override FillStyle Clone()
Visual Basic
Public Overrides Function Clone As FillStyle
Visual C++
public:
virtual FillStyle^ Clone() override

See Also

FillStyleGradientEx Class
VIBlend.Utilities Namespace


FillStyleGradientEx Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradientEx Properties
FillStyleGradientEx Class See Also Send Feedback

The FillStyleGradientEx type exposes the following members.

Properties

 | Name | Description
Public property | Color1 | Gradient Color1
Public property | Color2 | Gradient Color2
Public property | Color3 | Gradient Color3
Public property | Color4 | Gradient Color4
Public property | Colors | Gets the gradient colors (Overrides FillStyle..::..Colors.)
Public property | ColorsNumber | Gets the number of colors (Overrides FillStyle..::..ColorsNumber.)
Public property | GradientAngle | Gets or sets the Gradient Angle
Public property | GradientOffset | Gets or sets the Gradient Percentage 1
Public property | GradientOffset2 | Gets or sets the Gradient Percentage 2

See Also

FillStyleGradientEx Class
VIBlend.Utilities Namespace


Color1 Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradientEx..::..Color1 Property
FillStyleGradientEx Class See Also Send Feedback
Gradient Color1

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color Color1 { get; set; }
Visual Basic
Public Property Color1 As Color
    Get
    Set
Visual C++
public:
property Color Color1 {
    Color get ();
    void set (Color value);
}

See Also

FillStyleGradientEx Class
VIBlend.Utilities Namespace


Color2 Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradientEx..::..Color2 Property
FillStyleGradientEx Class See Also Send Feedback
Gradient Color2

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color Color2 { get; set; }
Visual Basic
Public Property Color2 As Color
    Get
    Set
Visual C++
public:
property Color Color2 {
    Color get ();
    void set (Color value);
}

See Also

FillStyleGradientEx Class
VIBlend.Utilities Namespace


Color3 Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradientEx..::..Color3 Property
FillStyleGradientEx Class See Also Send Feedback
Gradient Color3

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color Color3 { get; set; }
Visual Basic
Public Property Color3 As Color
    Get
    Set
Visual C++
public:
property Color Color3 {
    Color get ();
    void set (Color value);
}

See Also

FillStyleGradientEx Class
VIBlend.Utilities Namespace


Color4 Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradientEx..::..Color4 Property
FillStyleGradientEx Class See Also Send Feedback
Gradient Color4

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color Color4 { get; set; }
Visual Basic
Public Property Color4 As Color
    Get
    Set
Visual C++
public:
property Color Color4 {
    Color get ();
    void set (Color value);
}

See Also

FillStyleGradientEx Class
VIBlend.Utilities Namespace


Colors Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradientEx..::..Colors Property
FillStyleGradientEx Class See Also Send Feedback
Gets the gradient colors

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color[] Colors { get; }
Visual Basic
Public Overrides ReadOnly Property Colors As Color()
    Get
Visual C++
public:
virtual property array<Color>^ Colors {
    array<Color>^ get () override;
}

See Also

FillStyleGradientEx Class
VIBlend.Utilities Namespace


ColorsNumber Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradientEx..::..ColorsNumber Property
FillStyleGradientEx Class See Also Send Feedback
Gets the number of colors

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override int ColorsNumber { get; }
Visual Basic
Public Overrides ReadOnly Property ColorsNumber As Integer
    Get
Visual C++
public:
virtual property int ColorsNumber {
    int get () override;
}

See Also

FillStyleGradientEx Class
VIBlend.Utilities Namespace


GradientAngle Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradientEx..::..GradientAngle Property
FillStyleGradientEx Class See Also Send Feedback
Gets or sets the Gradient Angle

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public float GradientAngle { get; set; }
Visual Basic
Public Property GradientAngle As Single
    Get
    Set
Visual C++
public:
property float GradientAngle {
    float get ();
    void set (float value);
}

See Also

FillStyleGradientEx Class
VIBlend.Utilities Namespace


GradientOffset Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradientEx..::..GradientOffset Property
FillStyleGradientEx Class See Also Send Feedback
Gets or sets the Gradient Percentage 1

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public float GradientOffset { get; set; }
Visual Basic
Public Property GradientOffset As Single
    Get
    Set
Visual C++
public:
property float GradientOffset {
    float get ();
    void set (float value);
}

See Also

FillStyleGradientEx Class
VIBlend.Utilities Namespace


GradientOffset2 Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleGradientEx..::..GradientOffset2 Property
FillStyleGradientEx Class See Also Send Feedback
Gets or sets the Gradient Percentage 2

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public float GradientOffset2 { get; set; }
Visual Basic
Public Property GradientOffset2 As Single
    Get
    Set
Visual C++
public:
property float GradientOffset2 {
    float get ();
    void set (float value);
}

See Also

FillStyleGradientEx Class
VIBlend.Utilities Namespace


FillStyleSolid Class

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleSolid Class
Members See Also Send Feedback
Represents a solid fill style

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[SerializableAttribute]
public class FillStyleSolid : FillStyle
Visual Basic
<SerializableAttribute> _
Public Class FillStyleSolid _
    Inherits FillStyle
Visual C++
[SerializableAttribute]
public ref class FillStyleSolid : public FillStyle

Inheritance Hierarchy

System..::..Object
VIBlend.Utilities..::..FillStyle
VIBlend.Utilities..::..FillStyleSolid

See Also

FillStyleSolid Members
VIBlend.Utilities Namespace


FillStyleSolid Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
FillStyleSolid Members
FillStyleSolid Class Methods Fields Properties See Also Send Feedback

The FillStyleSolid type exposes the following members.

Methods

 | Name | Description
Public method | Clone | (Overrides FillStyle..::..Clone()()()().)
Protected method | CreateBrush | (Overrides FillStyleCreateBrush()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrush | (Overrides FillStyle..::..GetBrush(Rectangle).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | color |

Properties

 | Name | Description
Public property | Color |
Public property | Colors | (Overrides FillStyle..::..Colors.)
Public property | ColorsNumber | (Overrides FillStyle..::..ColorsNumber.)

See Also

FillStyleSolid Class
VIBlend.Utilities Namespace


FillStyleSolid Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
FillStyleSolid Fields
FillStyleSolid Class See Also Send Feedback

The FillStyleSolid type exposes the following members.

Fields

 | Name | Description
Protected field | color |

See Also

FillStyleSolid Class
VIBlend.Utilities Namespace


color Field

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleSolid..::..color Field
FillStyleSolid Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected Color color
Visual Basic
Protected color As Color
Visual C++
protected:
Color color

See Also

FillStyleSolid Class
VIBlend.Utilities Namespace


FillStyleSolid Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
FillStyleSolid Methods
FillStyleSolid Class See Also Send Feedback

The FillStyleSolid type exposes the following members.

Methods

 | Name | Description
Public method | Clone | (Overrides FillStyle..::..Clone()()()().)
Protected method | CreateBrush | (Overrides FillStyleCreateBrush()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrush | (Overrides FillStyle..::..GetBrush(Rectangle).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillStyleSolid Class
VIBlend.Utilities Namespace


Clone Method

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleSolid..::..Clone Method
FillStyleSolid Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override FillStyle Clone()
Visual Basic
Public Overrides Function Clone As FillStyle
Visual C++
public:
virtual FillStyle^ Clone() override

See Also

FillStyleSolid Class
VIBlend.Utilities Namespace


CreateBrush Method

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleSolid..::..CreateBrush Method
FillStyleSolid Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void CreateBrush()
Visual Basic
Protected Overrides Sub CreateBrush
Visual C++
protected:
virtual void CreateBrush() override

See Also

FillStyleSolid Class
VIBlend.Utilities Namespace


GetBrush Method

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleSolid..::..GetBrush Method
FillStyleSolid Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Brush GetBrush(
    Rectangle rect
)
Visual Basic
Public Overrides Function GetBrush ( _
    rect As Rectangle _
) As Brush
Visual C++
public:
virtual Brush^ GetBrush(
    Rectangle rect
) override

Parameters

rect
Type: System.Drawing..::..Rectangle

See Also

FillStyleSolid Class
VIBlend.Utilities Namespace


FillStyleSolid Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
FillStyleSolid Properties
FillStyleSolid Class See Also Send Feedback

The FillStyleSolid type exposes the following members.

Properties

 | Name | Description
Public property | Color |
Public property | Colors | (Overrides FillStyle..::..Colors.)
Public property | ColorsNumber | (Overrides FillStyle..::..ColorsNumber.)

See Also

FillStyleSolid Class
VIBlend.Utilities Namespace


Color Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleSolid..::..Color Property
FillStyleSolid Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color Color { get; set; }
Visual Basic
Public Property Color As Color
    Get
    Set
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

FillStyleSolid Class
VIBlend.Utilities Namespace


Colors Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleSolid..::..Colors Property
FillStyleSolid Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color[] Colors { get; }
Visual Basic
Public Overrides ReadOnly Property Colors As Color()
    Get
Visual C++
public:
virtual property array<Color>^ Colors {
    array<Color>^ get () override;
}

See Also

FillStyleSolid Class
VIBlend.Utilities Namespace


ColorsNumber Property

[image]

VIBlend Controls for WinForms Help Documentation
FillStyleSolid..::..ColorsNumber Property
FillStyleSolid Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override int ColorsNumber { get; }
Visual Basic
Public Overrides ReadOnly Property ColorsNumber As Integer
    Get
Visual C++
public:
virtual property int ColorsNumber {
    int get () override;
}

See Also

FillStyleSolid Class
VIBlend.Utilities Namespace


GridCellStyle Class

[image]

VIBlend Controls for WinForms Help Documentation
GridCellStyle Class
Members See Also Send Feedback
Represents a style of a data grid cell

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[SerializableAttribute]
public class GridCellStyle
Visual Basic
<SerializableAttribute> _
Public Class GridCellStyle
Visual C++
[SerializableAttribute]
public ref class GridCellStyle

Inheritance Hierarchy

System..::..Object
VIBlend.Utilities..::..GridCellStyle

See Also

GridCellStyle Members
VIBlend.Utilities Namespace


GridCellStyle Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
GridCellStyle Members
GridCellStyle Class Constructors Methods Properties See Also Send Feedback

The GridCellStyle type exposes the following members.

Constructors

 | Name | Description
Public method | GridCellStyle()()()() | Default constructor
Public method | GridCellStyle(FillStyle, FillStyle, Color, Color, Color, Color) | Constructor
Public method | GridCellStyle(FillStyle, FillStyle, Color, Color, Color, Color, Font) | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BorderColor | Border color
Public property | BorderColorSelected | Border color in selected state
Public property | FillStyle | FillStyle in normal state
Public property | FillStyleSelected | FillStyle in selected sate
Public property | Font | Gets or sets the text font of grid cell
Public property | TextColor | Text color
Public property | TextColorSelected | Text color in selected state

See Also

GridCellStyle Class
VIBlend.Utilities Namespace


GridCellStyle Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
GridCellStyle Constructor
GridCellStyle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridCellStyle()()()() | Default constructor
Public method | GridCellStyle(FillStyle, FillStyle, Color, Color, Color, Color) | Constructor
Public method | GridCellStyle(FillStyle, FillStyle, Color, Color, Color, Color, Font) | Constructor

See Also

GridCellStyle Class
GridCellStyle Members
VIBlend.Utilities Namespace


GridCellStyle Constructor

[image]

VIBlend Controls for WinForms Help Documentation
GridCellStyle Constructor
GridCellStyle Class See Also Send Feedback
Default constructor

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCellStyle()
Visual Basic
Public Sub New
Visual C++
public:
GridCellStyle()

See Also

GridCellStyle Class
GridCellStyle Overload
VIBlend.Utilities Namespace


GridCellStyle Constructor (FillStyle, FillStyle, Color, Color, Color, Color)

[image]

VIBlend Controls for WinForms Help Documentation
GridCellStyle Constructor (FillStyle, FillStyle, Color, Color, Color, Color)
GridCellStyle Class See Also Send Feedback
Constructor

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCellStyle(
    FillStyle fillStyle,
    FillStyle fillStyleSelected,
    Color borderColor,
    Color borderColorSelected,
    Color textColor,
    Color textColorSelected
)
Visual Basic
Public Sub New ( _
    fillStyle As FillStyle, _
    fillStyleSelected As FillStyle, _
    borderColor As Color, _
    borderColorSelected As Color, _
    textColor As Color, _
    textColorSelected As Color _
)
Visual C++
public:
GridCellStyle(
    FillStyle^ fillStyle,
    FillStyle^ fillStyleSelected,
    Color borderColor,
    Color borderColorSelected,
    Color textColor,
    Color textColorSelected
)

Parameters

fillStyle
Type: VIBlend.Utilities..::..FillStyle
FillStyle in normal state
fillStyleSelected
Type: VIBlend.Utilities..::..FillStyle
FillStyle in selected state
borderColor
Type: System.Drawing..::..Color
Border color in normal state
borderColorSelected
Type: System.Drawing..::..Color
Border color in selected state
textColor
Type: System.Drawing..::..Color
Text color in normal state
textColorSelected
Type: System.Drawing..::..Color
Text color in selected state

See Also

GridCellStyle Class
GridCellStyle Overload
VIBlend.Utilities Namespace


GridCellStyle Constructor (FillStyle, FillStyle, Color, Color, Color, Color, Font)

[image]

VIBlend Controls for WinForms Help Documentation
GridCellStyle Constructor (FillStyle, FillStyle, Color, Color, Color, Color, Font)
GridCellStyle Class See Also Send Feedback
Constructor

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCellStyle(
    FillStyle fillStyle,
    FillStyle fillStyleSelected,
    Color borderColor,
    Color borderColorSelected,
    Color textColor,
    Color textColorSelected,
    Font font
)
Visual Basic
Public Sub New ( _
    fillStyle As FillStyle, _
    fillStyleSelected As FillStyle, _
    borderColor As Color, _
    borderColorSelected As Color, _
    textColor As Color, _
    textColorSelected As Color, _
    font As Font _
)
Visual C++
public:
GridCellStyle(
    FillStyle^ fillStyle,
    FillStyle^ fillStyleSelected,
    Color borderColor,
    Color borderColorSelected,
    Color textColor,
    Color textColorSelected,
    Font^ font
)

Parameters

fillStyle
Type: VIBlend.Utilities..::..FillStyle
FillStyle in normal state
fillStyleSelected
Type: VIBlend.Utilities..::..FillStyle
FillStyle in selected state
borderColor
Type: System.Drawing..::..Color
Border color in normal state
borderColorSelected
Type: System.Drawing..::..Color
Border color in selected state
textColor
Type: System.Drawing..::..Color
Text color in normal state
textColorSelected
Type: System.Drawing..::..Color
Text color in selected state
font
Type: System.Drawing..::..Font
Text font

See Also

GridCellStyle Class
GridCellStyle Overload
VIBlend.Utilities Namespace


GridCellStyle Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
GridCellStyle Methods
GridCellStyle Class See Also Send Feedback

The GridCellStyle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridCellStyle Class
VIBlend.Utilities Namespace


GridCellStyle Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
GridCellStyle Properties
GridCellStyle Class See Also Send Feedback

The GridCellStyle type exposes the following members.

Properties

 | Name | Description
Public property | BorderColor | Border color
Public property | BorderColorSelected | Border color in selected state
Public property | FillStyle | FillStyle in normal state
Public property | FillStyleSelected | FillStyle in selected sate
Public property | Font | Gets or sets the text font of grid cell
Public property | TextColor | Text color
Public property | TextColorSelected | Text color in selected state

See Also

GridCellStyle Class
VIBlend.Utilities Namespace


BorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCellStyle..::..BorderColor Property
GridCellStyle Class See Also Send Feedback
Border color

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BorderColor { get; set; }
Visual Basic
Public Property BorderColor As Color
    Get
    Set
Visual C++
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}

See Also

GridCellStyle Class
VIBlend.Utilities Namespace


BorderColorSelected Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCellStyle..::..BorderColorSelected Property
GridCellStyle Class See Also Send Feedback
Border color in selected state

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BorderColorSelected { get; set; }
Visual Basic
Public Property BorderColorSelected As Color
    Get
    Set
Visual C++
public:
property Color BorderColorSelected {
    Color get ();
    void set (Color value);
}

See Also

GridCellStyle Class
VIBlend.Utilities Namespace


FillStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCellStyle..::..FillStyle Property
GridCellStyle Class See Also Send Feedback
FillStyle in normal state

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public FillStyle FillStyle { get; set; }
Visual Basic
Public Property FillStyle As FillStyle
    Get
    Set
Visual C++
public:
property FillStyle^ FillStyle {
    FillStyle^ get ();
    void set (FillStyle^ value);
}

See Also

GridCellStyle Class
VIBlend.Utilities Namespace


FillStyleSelected Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCellStyle..::..FillStyleSelected Property
GridCellStyle Class See Also Send Feedback
FillStyle in selected sate

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public FillStyle FillStyleSelected { get; set; }
Visual Basic
Public Property FillStyleSelected As FillStyle
    Get
    Set
Visual C++
public:
property FillStyle^ FillStyleSelected {
    FillStyle^ get ();
    void set (FillStyle^ value);
}

See Also

GridCellStyle Class
VIBlend.Utilities Namespace


Font Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCellStyle..::..Font Property
GridCellStyle Class See Also Send Feedback
Gets or sets the text font of grid cell

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font Font { get; set; }
Visual Basic
Public Property Font As Font
    Get
    Set
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

See Also

GridCellStyle Class
VIBlend.Utilities Namespace


TextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCellStyle..::..TextColor Property
GridCellStyle Class See Also Send Feedback
Text color

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color TextColor { get; set; }
Visual Basic
Public Property TextColor As Color
    Get
    Set
Visual C++
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}

See Also

GridCellStyle Class
VIBlend.Utilities Namespace


TextColorSelected Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCellStyle..::..TextColorSelected Property
GridCellStyle Class See Also Send Feedback
Text color in selected state

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color TextColorSelected { get; set; }
Visual Basic
Public Property TextColorSelected As Color
    Get
    Set
Visual C++
public:
property Color TextColorSelected {
    Color get ();
    void set (Color value);
}

See Also

GridCellStyle Class
VIBlend.Utilities Namespace


GridTheme Class

[image]

VIBlend Controls for WinForms Help Documentation
GridTheme Class
Members See Also Send Feedback
Represents a GridView Theme

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[SerializableAttribute]
public class GridTheme
Visual Basic
<SerializableAttribute> _
Public Class GridTheme
Visual C++
[SerializableAttribute]
public ref class GridTheme

Inheritance Hierarchy

System..::..Object
VIBlend.Utilities..::..GridTheme

See Also

GridTheme Members
VIBlend.Utilities Namespace


GridTheme Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
GridTheme Members
GridTheme Class Constructors Methods Properties See Also Send Feedback

The GridTheme type exposes the following members.

Constructors

 | Name | Description
Public method | GridTheme | Default constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefaultTheme | Creates an instance of one of the default VIBlend themes
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFromXml | Loads the theme from a XML file
Public method | LoadFromXmlStream | Loads the theme from a XML stream
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveToXml | Saves the theme in a XML file
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GridCellStyle | The style of the data grid cells
Public property | HierarchyAttributeItemStyleDisabled | The style of summary HierarchyItems in disabled state
Public property | HierarchyAttributeItemStyleNormal | The style of summary HierarchyItems in normal state
Public property | HierarchyAttributeItemStyleSelected | The style of summary HierarchyItems in selected state
Public property | HierarchyItemStyleDisabled | The style of HierarchyItems in disabled state
Public property | HierarchyItemStyleNormal | The style of HierarchyItems in normal state
Public property | HierarchyItemStyleSelected | The style of HierarchyItems in selected state

See Also

GridTheme Class
VIBlend.Utilities Namespace


GridTheme Constructor

[image]

VIBlend Controls for WinForms Help Documentation
GridTheme Constructor
GridTheme Class See Also Send Feedback
Default constructor

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridTheme()
Visual Basic
Public Sub New
Visual C++
public:
GridTheme()

See Also

GridTheme Class
VIBlend.Utilities Namespace


GridTheme Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
GridTheme Methods
GridTheme Class See Also Send Feedback

The GridTheme type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefaultTheme | Creates an instance of one of the default VIBlend themes
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFromXml | Loads the theme from a XML file
Public method | LoadFromXmlStream | Loads the theme from a XML stream
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveToXml | Saves the theme in a XML file
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridTheme Class
VIBlend.Utilities Namespace


GetDefaultTheme Method

[image]

VIBlend Controls for WinForms Help Documentation
GridTheme..::..GetDefaultTheme Method
GridTheme Class See Also Send Feedback
Creates an instance of one of the default VIBlend themes

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static GridTheme GetDefaultTheme(
    VIBLEND_THEME theme
)
Visual Basic
Public Shared Function GetDefaultTheme ( _
    theme As VIBLEND_THEME _
) As GridTheme
Visual C++
public:
static GridTheme^ GetDefaultTheme(
    VIBLEND_THEME theme
)

Parameters

theme
Type: VIBlend.Utilities..::..VIBLEND_THEME

See Also

GridTheme Class
VIBlend.Utilities Namespace


LoadFromXml Method

[image]

VIBlend Controls for WinForms Help Documentation
GridTheme..::..LoadFromXml Method
GridTheme Class See Also Send Feedback
Loads the theme from a XML file

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool LoadFromXml(
    string fileName
)
Visual Basic
Public Function LoadFromXml ( _
    fileName As String _
) As Boolean
Visual C++
public:
bool LoadFromXml(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The name of the XML file which contains the theme definition

Return Value

True if the load is successful

See Also

GridTheme Class
VIBlend.Utilities Namespace


LoadFromXmlStream Method

[image]

VIBlend Controls for WinForms Help Documentation
GridTheme..::..LoadFromXmlStream Method
GridTheme Class See Also Send Feedback
Loads the theme from a XML stream

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool LoadFromXmlStream(
    Stream stream
)
Visual Basic
Public Function LoadFromXmlStream ( _
    stream As Stream _
) As Boolean
Visual C++
public:
bool LoadFromXmlStream(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
The input XML stream which contains the theme definition

Return Value

True if the load is successful

See Also

GridTheme Class
VIBlend.Utilities Namespace


SaveToXml Method

[image]

VIBlend Controls for WinForms Help Documentation
GridTheme..::..SaveToXml Method
GridTheme Class See Also Send Feedback
Saves the theme in a XML file

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool SaveToXml(
    string fileName
)
Visual Basic
Public Function SaveToXml ( _
    fileName As String _
) As Boolean
Visual C++
public:
bool SaveToXml(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The output file name

Return Value

This method returns true when the theme was successfully saved. Otherwise it returns false

See Also

GridTheme Class
VIBlend.Utilities Namespace


GridTheme Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
GridTheme Properties
GridTheme Class See Also Send Feedback

The GridTheme type exposes the following members.

Properties

 | Name | Description
Public property | GridCellStyle | The style of the data grid cells
Public property | HierarchyAttributeItemStyleDisabled | The style of summary HierarchyItems in disabled state
Public property | HierarchyAttributeItemStyleNormal | The style of summary HierarchyItems in normal state
Public property | HierarchyAttributeItemStyleSelected | The style of summary HierarchyItems in selected state
Public property | HierarchyItemStyleDisabled | The style of HierarchyItems in disabled state
Public property | HierarchyItemStyleNormal | The style of HierarchyItems in normal state
Public property | HierarchyItemStyleSelected | The style of HierarchyItems in selected state

See Also

GridTheme Class
VIBlend.Utilities Namespace


GridCellStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
GridTheme..::..GridCellStyle Property
GridTheme Class See Also Send Feedback
The style of the data grid cells

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCellStyle GridCellStyle { get; set; }
Visual Basic
Public Property GridCellStyle As GridCellStyle
    Get
    Set
Visual C++
public:
property GridCellStyle^ GridCellStyle {
    GridCellStyle^ get ();
    void set (GridCellStyle^ value);
}

See Also

GridTheme Class
VIBlend.Utilities Namespace


HierarchyAttributeItemStyleDisabled Property

[image]

VIBlend Controls for WinForms Help Documentation
GridTheme..::..HierarchyAttributeItemStyleDisabled Property
GridTheme Class See Also Send Feedback
The style of summary HierarchyItems in disabled state

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemStyle HierarchyAttributeItemStyleDisabled { get; set; }
Visual Basic
Public Property HierarchyAttributeItemStyleDisabled As HierarchyItemStyle
    Get
    Set
Visual C++
public:
property HierarchyItemStyle^ HierarchyAttributeItemStyleDisabled {
    HierarchyItemStyle^ get ();
    void set (HierarchyItemStyle^ value);
}

See Also

GridTheme Class
VIBlend.Utilities Namespace


HierarchyAttributeItemStyleNormal Property

[image]

VIBlend Controls for WinForms Help Documentation
GridTheme..::..HierarchyAttributeItemStyleNormal Property
GridTheme Class See Also Send Feedback
The style of summary HierarchyItems in normal state

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemStyle HierarchyAttributeItemStyleNormal { get; set; }
Visual Basic
Public Property HierarchyAttributeItemStyleNormal As HierarchyItemStyle
    Get
    Set
Visual C++
public:
property HierarchyItemStyle^ HierarchyAttributeItemStyleNormal {
    HierarchyItemStyle^ get ();
    void set (HierarchyItemStyle^ value);
}

See Also

GridTheme Class
VIBlend.Utilities Namespace


HierarchyAttributeItemStyleSelected Property

[image]

VIBlend Controls for WinForms Help Documentation
GridTheme..::..HierarchyAttributeItemStyleSelected Property
GridTheme Class See Also Send Feedback
The style of summary HierarchyItems in selected state

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemStyle HierarchyAttributeItemStyleSelected { get; set; }
Visual Basic
Public Property HierarchyAttributeItemStyleSelected As HierarchyItemStyle
    Get
    Set
Visual C++
public:
property HierarchyItemStyle^ HierarchyAttributeItemStyleSelected {
    HierarchyItemStyle^ get ();
    void set (HierarchyItemStyle^ value);
}

See Also

GridTheme Class
VIBlend.Utilities Namespace


HierarchyItemStyleDisabled Property

[image]

VIBlend Controls for WinForms Help Documentation
GridTheme..::..HierarchyItemStyleDisabled Property
GridTheme Class See Also Send Feedback
The style of HierarchyItems in disabled state

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemStyle HierarchyItemStyleDisabled { get; set; }
Visual Basic
Public Property HierarchyItemStyleDisabled As HierarchyItemStyle
    Get
    Set
Visual C++
public:
property HierarchyItemStyle^ HierarchyItemStyleDisabled {
    HierarchyItemStyle^ get ();
    void set (HierarchyItemStyle^ value);
}

See Also

GridTheme Class
VIBlend.Utilities Namespace


HierarchyItemStyleNormal Property

[image]

VIBlend Controls for WinForms Help Documentation
GridTheme..::..HierarchyItemStyleNormal Property
GridTheme Class See Also Send Feedback
The style of HierarchyItems in normal state

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemStyle HierarchyItemStyleNormal { get; set; }
Visual Basic
Public Property HierarchyItemStyleNormal As HierarchyItemStyle
    Get
    Set
Visual C++
public:
property HierarchyItemStyle^ HierarchyItemStyleNormal {
    HierarchyItemStyle^ get ();
    void set (HierarchyItemStyle^ value);
}

See Also

GridTheme Class
VIBlend.Utilities Namespace


HierarchyItemStyleSelected Property

[image]

VIBlend Controls for WinForms Help Documentation
GridTheme..::..HierarchyItemStyleSelected Property
GridTheme Class See Also Send Feedback
The style of HierarchyItems in selected state

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemStyle HierarchyItemStyleSelected { get; set; }
Visual Basic
Public Property HierarchyItemStyleSelected As HierarchyItemStyle
    Get
    Set
Visual C++
public:
property HierarchyItemStyle^ HierarchyItemStyleSelected {
    HierarchyItemStyle^ get ();
    void set (HierarchyItemStyle^ value);
}

See Also

GridTheme Class
VIBlend.Utilities Namespace


HierarchyItemStyle Class

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemStyle Class
Members See Also Send Feedback
Represents a style of a HierarchyItem

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[SerializableAttribute]
public class HierarchyItemStyle
Visual Basic
<SerializableAttribute> _
Public Class HierarchyItemStyle
Visual C++
[SerializableAttribute]
public ref class HierarchyItemStyle

Inheritance Hierarchy

System..::..Object
VIBlend.Utilities..::..HierarchyItemStyle

See Also

HierarchyItemStyle Members
VIBlend.Utilities Namespace


HierarchyItemStyle Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemStyle Members
HierarchyItemStyle Class Constructors Methods Properties See Also Send Feedback

The HierarchyItemStyle type exposes the following members.

Constructors

 | Name | Description
Public method | HierarchyItemStyle | Initializes a new instance of the HierarchyItemStyle class

Methods

 | Name | Description
Public method | Clone | Creates a new HierarchyItemStyle object with is an exact copy of this HierarchyItemStyle
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BorderColor | Border color when the item is in normal state
Public property | BorderColorHighlighted | Border color when the item is highlighted
Public property | FillStyle | Fill style when the item is in normal state
Public property | FillStyleHighlight | Fill style when the item is highlighted
Public property | Font | Gets or sets the text font of grid cell
Public property | TextColor | Text color when the item is in normal state
Public property | TextColorHighlighed | Text color when the item is highlighted

See Also

HierarchyItemStyle Class
VIBlend.Utilities Namespace


HierarchyItemStyle Constructor

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemStyle Constructor
HierarchyItemStyle Class See Also Send Feedback
Initializes a new instance of the HierarchyItemStyle class

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemStyle(
    FillStyle fillStyle,
    FillStyle fillStyleHighlighted,
    Color borderColor,
    Color borderColorHighlighted,
    Color textColor,
    Color textColorHighlighted
)
Visual Basic
Public Sub New ( _
    fillStyle As FillStyle, _
    fillStyleHighlighted As FillStyle, _
    borderColor As Color, _
    borderColorHighlighted As Color, _
    textColor As Color, _
    textColorHighlighted As Color _
)
Visual C++
public:
HierarchyItemStyle(
    FillStyle^ fillStyle,
    FillStyle^ fillStyleHighlighted,
    Color borderColor,
    Color borderColorHighlighted,
    Color textColor,
    Color textColorHighlighted
)

Parameters

fillStyle
Type: VIBlend.Utilities..::..FillStyle
fillStyleHighlighted
Type: VIBlend.Utilities..::..FillStyle
borderColor
Type: System.Drawing..::..Color
borderColorHighlighted
Type: System.Drawing..::..Color
textColor
Type: System.Drawing..::..Color
textColorHighlighted
Type: System.Drawing..::..Color

See Also

HierarchyItemStyle Class
VIBlend.Utilities Namespace


HierarchyItemStyle Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemStyle Methods
HierarchyItemStyle Class See Also Send Feedback

The HierarchyItemStyle type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new HierarchyItemStyle object with is an exact copy of this HierarchyItemStyle
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HierarchyItemStyle Class
VIBlend.Utilities Namespace


Clone Method

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemStyle..::..Clone Method
HierarchyItemStyle Class See Also Send Feedback
Creates a new HierarchyItemStyle object with is an exact copy of this HierarchyItemStyle

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemStyle Clone()
Visual Basic
Public Function Clone As HierarchyItemStyle
Visual C++
public:
HierarchyItemStyle^ Clone()

See Also

HierarchyItemStyle Class
VIBlend.Utilities Namespace


HierarchyItemStyle Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemStyle Properties
HierarchyItemStyle Class See Also Send Feedback

The HierarchyItemStyle type exposes the following members.

Properties

 | Name | Description
Public property | BorderColor | Border color when the item is in normal state
Public property | BorderColorHighlighted | Border color when the item is highlighted
Public property | FillStyle | Fill style when the item is in normal state
Public property | FillStyleHighlight | Fill style when the item is highlighted
Public property | Font | Gets or sets the text font of grid cell
Public property | TextColor | Text color when the item is in normal state
Public property | TextColorHighlighed | Text color when the item is highlighted

See Also

HierarchyItemStyle Class
VIBlend.Utilities Namespace


BorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemStyle..::..BorderColor Property
HierarchyItemStyle Class See Also Send Feedback
Border color when the item is in normal state

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BorderColor { get; set; }
Visual Basic
Public Property BorderColor As Color
    Get
    Set
Visual C++
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}

See Also

HierarchyItemStyle Class
VIBlend.Utilities Namespace


BorderColorHighlighted Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemStyle..::..BorderColorHighlighted Property
HierarchyItemStyle Class See Also Send Feedback
Border color when the item is highlighted

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BorderColorHighlighted { get; set; }
Visual Basic
Public Property BorderColorHighlighted As Color
    Get
    Set
Visual C++
public:
property Color BorderColorHighlighted {
    Color get ();
    void set (Color value);
}

See Also

HierarchyItemStyle Class
VIBlend.Utilities Namespace


FillStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemStyle..::..FillStyle Property
HierarchyItemStyle Class See Also Send Feedback
Fill style when the item is in normal state

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public FillStyle FillStyle { get; set; }
Visual Basic
Public Property FillStyle As FillStyle
    Get
    Set
Visual C++
public:
property FillStyle^ FillStyle {
    FillStyle^ get ();
    void set (FillStyle^ value);
}

See Also

HierarchyItemStyle Class
VIBlend.Utilities Namespace


FillStyleHighlight Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemStyle..::..FillStyleHighlight Property
HierarchyItemStyle Class See Also Send Feedback
Fill style when the item is highlighted

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public FillStyle FillStyleHighlight { get; set; }
Visual Basic
Public Property FillStyleHighlight As FillStyle
    Get
    Set
Visual C++
public:
property FillStyle^ FillStyleHighlight {
    FillStyle^ get ();
    void set (FillStyle^ value);
}

See Also

HierarchyItemStyle Class
VIBlend.Utilities Namespace


Font Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemStyle..::..Font Property
HierarchyItemStyle Class See Also Send Feedback
Gets or sets the text font of grid cell

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font Font { get; set; }
Visual Basic
Public Property Font As Font
    Get
    Set
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

See Also

HierarchyItemStyle Class
VIBlend.Utilities Namespace


TextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemStyle..::..TextColor Property
HierarchyItemStyle Class See Also Send Feedback
Text color when the item is in normal state

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color TextColor { get; set; }
Visual Basic
Public Property TextColor As Color
    Get
    Set
Visual C++
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}

See Also

HierarchyItemStyle Class
VIBlend.Utilities Namespace


TextColorHighlighed Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemStyle..::..TextColorHighlighed Property
HierarchyItemStyle Class See Also Send Feedback
Text color when the item is highlighted

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color TextColorHighlighed { get; set; }
Visual Basic
Public Property TextColorHighlighed As Color
    Get
    Set
Visual C++
public:
property Color TextColorHighlighed {
    Color get ();
    void set (Color value);
}

See Also

HierarchyItemStyle Class
VIBlend.Utilities Namespace


Licensing Class

[image]

VIBlend Controls for WinForms Help Documentation
Licensing Class
Members See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static class Licensing
Visual Basic
Public NotInheritable Class Licensing
Visual C++
public ref class Licensing abstract sealed

Inheritance Hierarchy

System..::..Object
VIBlend.Utilities..::..Licensing

See Also

Licensing Members
VIBlend.Utilities Namespace


Licensing Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
Licensing Members
Licensing Class Methods Properties See Also Send Feedback

The Licensing type exposes the following members.

Methods

Name | Description
LICheck |
ValidateLicense | Checks if the license status of a control.

Properties

Name | Description
LicenseContent |

See Also

Licensing Class
VIBlend.Utilities Namespace


Licensing Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
Licensing Methods
Licensing Class See Also Send Feedback

The Licensing type exposes the following members.

Methods

Name | Description
LICheck |
ValidateLicense | Checks if the license status of a control.

See Also

Licensing Class
VIBlend.Utilities Namespace


LICheck Method

[image]

VIBlend Controls for WinForms Help Documentation
Licensing..::..LICheck Method
Licensing Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static bool LICheck(
    Control control
)
Visual Basic
Public Shared Function LICheck ( _
    control As Control _
) As Boolean
Visual C++
public:
static bool LICheck(
    Control^ control
)

Parameters

control
Type: System.Windows.Forms..::..Control

See Also

Licensing Class
VIBlend.Utilities Namespace


ValidateLicense Method

[image]

VIBlend Controls for WinForms Help Documentation
Licensing..::..ValidateLicense Method
Licensing Class See Also Send Feedback
Checks if the license status of a control.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static bool ValidateLicense(
    Control control
)
Visual Basic
Public Shared Function ValidateLicense ( _
    control As Control _
) As Boolean
Visual C++
public:
static bool ValidateLicense(
    Control^ control
)

Parameters

control
Type: System.Windows.Forms..::..Control
Control to check.

Return Value

True if the control passes the license validation.

See Also

Licensing Class
VIBlend.Utilities Namespace


Licensing Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
Licensing Properties
Licensing Class See Also Send Feedback

The Licensing type exposes the following members.

Properties

Name | Description
LicenseContent |

See Also

Licensing Class
VIBlend.Utilities Namespace


LicenseContent Property

[image]

VIBlend Controls for WinForms Help Documentation
Licensing..::..LicenseContent Property
Licensing Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static string LicenseContent { get; set; }
Visual Basic
Public Shared Property LicenseContent As String
    Get
    Set
Visual C++
public:
static property String^ LicenseContent {
    String^ get ();
    void set (String^ value);
}

See Also

Licensing Class
VIBlend.Utilities Namespace


NamedColor Class

[image]

VIBlend Controls for WinForms Help Documentation
NamedColor Class
Members See Also Send Feedback
Represents a Named Color. This class is used in the VIBlend themes definition

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[SerializableAttribute]
public class NamedColor
Visual Basic
<SerializableAttribute> _
Public Class NamedColor
Visual C++
[SerializableAttribute]
public ref class NamedColor

Inheritance Hierarchy

System..::..Object
VIBlend.Utilities..::..NamedColor

See Also

NamedColor Members
VIBlend.Utilities Namespace


NamedColor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
NamedColor Members
NamedColor Class Constructors Methods Properties See Also Send Feedback

The NamedColor type exposes the following members.

Constructors

 | Name | Description
Public method | NamedColor | Initializes a new instance of the NamedColor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color | Color
Public property | Name | Name

See Also

NamedColor Class
VIBlend.Utilities Namespace


NamedColor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
NamedColor Constructor
NamedColor Class See Also Send Feedback
Initializes a new instance of the NamedColor class

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public NamedColor()
Visual Basic
Public Sub New
Visual C++
public:
NamedColor()

See Also

NamedColor Class
VIBlend.Utilities Namespace


NamedColor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
NamedColor Methods
NamedColor Class See Also Send Feedback

The NamedColor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NamedColor Class
VIBlend.Utilities Namespace


NamedColor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
NamedColor Properties
NamedColor Class See Also Send Feedback

The NamedColor type exposes the following members.

Properties

 | Name | Description
Public property | Color | Color
Public property | Name | Name

See Also

NamedColor Class
VIBlend.Utilities Namespace


Color Property

[image]

VIBlend Controls for WinForms Help Documentation
NamedColor..::..Color Property
NamedColor Class See Also Send Feedback
Color

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color Color { get; set; }
Visual Basic
Public Property Color As Color
    Get
    Set
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

NamedColor Class
VIBlend.Utilities Namespace


Name Property

[image]

VIBlend Controls for WinForms Help Documentation
NamedColor..::..Name Property
NamedColor Class See Also Send Feedback
Name

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

NamedColor Class
VIBlend.Utilities Namespace


NamedFillStyle Class

[image]

VIBlend Controls for WinForms Help Documentation
NamedFillStyle Class
Members See Also Send Feedback
Represents a Named fill style. This class is used in the VIBlend themes definition

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[SerializableAttribute]
public class NamedFillStyle
Visual Basic
<SerializableAttribute> _
Public Class NamedFillStyle
Visual C++
[SerializableAttribute]
public ref class NamedFillStyle

Inheritance Hierarchy

System..::..Object
VIBlend.Utilities..::..NamedFillStyle

See Also

NamedFillStyle Members
VIBlend.Utilities Namespace


NamedFillStyle Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
NamedFillStyle Members
NamedFillStyle Class Constructors Methods Properties See Also Send Feedback

The NamedFillStyle type exposes the following members.

Constructors

 | Name | Description
Public method | NamedFillStyle | Initializes a new instance of the NamedFillStyle class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FillStyle | FillStyle of the NamedFillStyle
Public property | Name | Name of the NamedFillStyle

See Also

NamedFillStyle Class
VIBlend.Utilities Namespace


NamedFillStyle Constructor

[image]

VIBlend Controls for WinForms Help Documentation
NamedFillStyle Constructor
NamedFillStyle Class See Also Send Feedback
Initializes a new instance of the NamedFillStyle class

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public NamedFillStyle()
Visual Basic
Public Sub New
Visual C++
public:
NamedFillStyle()

See Also

NamedFillStyle Class
VIBlend.Utilities Namespace


NamedFillStyle Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
NamedFillStyle Methods
NamedFillStyle Class See Also Send Feedback

The NamedFillStyle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NamedFillStyle Class
VIBlend.Utilities Namespace


NamedFillStyle Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
NamedFillStyle Properties
NamedFillStyle Class See Also Send Feedback

The NamedFillStyle type exposes the following members.

Properties

 | Name | Description
Public property | FillStyle | FillStyle of the NamedFillStyle
Public property | Name | Name of the NamedFillStyle

See Also

NamedFillStyle Class
VIBlend.Utilities Namespace


FillStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
NamedFillStyle..::..FillStyle Property
NamedFillStyle Class See Also Send Feedback
FillStyle of the NamedFillStyle

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public FillStyle FillStyle { get; set; }
Visual Basic
Public Property FillStyle As FillStyle
    Get
    Set
Visual C++
public:
property FillStyle^ FillStyle {
    FillStyle^ get ();
    void set (FillStyle^ value);
}

See Also

NamedFillStyle Class
VIBlend.Utilities Namespace


Name Property

[image]

VIBlend Controls for WinForms Help Documentation
NamedFillStyle..::..Name Property
NamedFillStyle Class See Also Send Feedback
Name of the NamedFillStyle

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

NamedFillStyle Class
VIBlend.Utilities Namespace


NamedValue Class

[image]

VIBlend Controls for WinForms Help Documentation
NamedValue Class
Members See Also Send Feedback
Represents a Name and Value pair. This class is used to define setter properties in VIBlend themes

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[SerializableAttribute]
public class NamedValue
Visual Basic
<SerializableAttribute> _
Public Class NamedValue
Visual C++
[SerializableAttribute]
public ref class NamedValue

Inheritance Hierarchy

System..::..Object
VIBlend.Utilities..::..NamedValue

See Also

NamedValue Members
VIBlend.Utilities Namespace


NamedValue Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
NamedValue Members
NamedValue Class Constructors Methods Properties See Also Send Feedback

The NamedValue type exposes the following members.

Constructors

 | Name | Description
Public method | NamedValue | Initializes a new instance of the NamedValue class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | String represeting the Name of the NameValue pair
Public property | Value | String represeting the Value of the NameValue pair

See Also

NamedValue Class
VIBlend.Utilities Namespace


NamedValue Constructor

[image]

VIBlend Controls for WinForms Help Documentation
NamedValue Constructor
NamedValue Class See Also Send Feedback
Initializes a new instance of the NamedValue class

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public NamedValue()
Visual Basic
Public Sub New
Visual C++
public:
NamedValue()

See Also

NamedValue Class
VIBlend.Utilities Namespace


NamedValue Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
NamedValue Methods
NamedValue Class See Also Send Feedback

The NamedValue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NamedValue Class
VIBlend.Utilities Namespace


NamedValue Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
NamedValue Properties
NamedValue Class See Also Send Feedback

The NamedValue type exposes the following members.

Properties

 | Name | Description
Public property | Name | String represeting the Name of the NameValue pair
Public property | Value | String represeting the Value of the NameValue pair

See Also

NamedValue Class
VIBlend.Utilities Namespace


Name Property

[image]

VIBlend Controls for WinForms Help Documentation
NamedValue..::..Name Property
NamedValue Class See Also Send Feedback
String represeting the Name of the NameValue pair

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

NamedValue Class
VIBlend.Utilities Namespace


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
NamedValue..::..Value Property
NamedValue Class See Also Send Feedback
String represeting the Value of the NameValue pair

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

NamedValue Class
VIBlend.Utilities Namespace


RoundedCornersMask Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
RoundedCornersMask Enumeration
See Also Send Feedback
Enumeration of the rounded cornerners mask values

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum RoundedCornersMask
Visual Basic
Public Enumeration RoundedCornersMask
Visual C++
public enum class RoundedCornersMask

Members

Member name | Description
TOP_LEFT |
TOP_RIGHT |
BOTTOM_LEFT |
BOTTOM_RIGHT |

See Also

VIBlend.Utilities Namespace


ThemeCache Class

[image]

VIBlend Controls for WinForms Help Documentation
ThemeCache Class
Members See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static class ThemeCache
Visual Basic
Public NotInheritable Class ThemeCache
Visual C++
public ref class ThemeCache abstract sealed

Inheritance Hierarchy

System..::..Object
VIBlend.Utilities..::..ThemeCache

See Also

ThemeCache Members
VIBlend.Utilities Namespace


ThemeCache Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
ThemeCache Members
ThemeCache Class Methods Fields See Also Send Feedback

The ThemeCache type exposes the following members.

Methods

Name | Description
ClearCache | Clears the cache.
ClearCacheByKey | Clears the cache by key.
GetTheme(String, VIBLEND_THEME) | Gets the theme.
GetTheme(String, VIBLEND_THEME, ControlTheme) | Gets the theme.

Fields

Name | Description
CacheLimit |

See Also

ThemeCache Class
VIBlend.Utilities Namespace


ThemeCache Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
ThemeCache Fields
ThemeCache Class See Also Send Feedback

The ThemeCache type exposes the following members.

Fields

Name | Description
CacheLimit |

See Also

ThemeCache Class
VIBlend.Utilities Namespace


CacheLimit Field

[image]

VIBlend Controls for WinForms Help Documentation
ThemeCache..::..CacheLimit Field
ThemeCache Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int CacheLimit
Visual Basic
Public Shared CacheLimit As Integer
Visual C++
public:
static int CacheLimit

See Also

ThemeCache Class
VIBlend.Utilities Namespace


ThemeCache Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
ThemeCache Methods
ThemeCache Class See Also Send Feedback

The ThemeCache type exposes the following members.

Methods

Name | Description
ClearCache | Clears the cache.
ClearCacheByKey | Clears the cache by key.
GetTheme(String, VIBLEND_THEME) | Gets the theme.
GetTheme(String, VIBLEND_THEME, ControlTheme) | Gets the theme.

See Also

ThemeCache Class
VIBlend.Utilities Namespace


ClearCache Method

[image]

VIBlend Controls for WinForms Help Documentation
ThemeCache..::..ClearCache Method
ThemeCache Class See Also Send Feedback
Clears the cache.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static void ClearCache()
Visual Basic
Public Shared Sub ClearCache
Visual C++
public:
static void ClearCache()

See Also

ThemeCache Class
VIBlend.Utilities Namespace


ClearCacheByKey Method

[image]

VIBlend Controls for WinForms Help Documentation
ThemeCache..::..ClearCacheByKey Method
ThemeCache Class See Also Send Feedback
Clears the cache by key.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static void ClearCacheByKey(
    string styleKey,
    VIBLEND_THEME theme
)
Visual Basic
Public Shared Sub ClearCacheByKey ( _
    styleKey As String, _
    theme As VIBLEND_THEME _
)
Visual C++
public:
static void ClearCacheByKey(
    String^ styleKey,
    VIBLEND_THEME theme
)

Parameters

styleKey
Type: System..::..String
The style key.
theme
Type: VIBlend.Utilities..::..VIBLEND_THEME
The theme.

See Also

ThemeCache Class
VIBlend.Utilities Namespace


GetTheme Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ThemeCache..::..GetTheme Method
ThemeCache Class See Also Send Feedback

Overload List

Name | Description
GetTheme(String, VIBLEND_THEME) | Gets the theme.
GetTheme(String, VIBLEND_THEME, ControlTheme) | Gets the theme.

See Also

ThemeCache Class
ThemeCache Members
VIBlend.Utilities Namespace


GetTheme Method (String, VIBLEND_THEME)

[image]

VIBlend Controls for WinForms Help Documentation
ThemeCache..::..GetTheme Method (String, VIBLEND_THEME)
ThemeCache Class See Also Send Feedback
Gets the theme.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static ControlTheme GetTheme(
    string styleKey,
    VIBLEND_THEME value
)
Visual Basic
Public Shared Function GetTheme ( _
    styleKey As String, _
    value As VIBLEND_THEME _
) As ControlTheme
Visual C++
public:
static ControlTheme^ GetTheme(
    String^ styleKey,
    VIBLEND_THEME value
)

Parameters

styleKey
Type: System..::..String
The style key.
value
Type: VIBlend.Utilities..::..VIBLEND_THEME
The value.

Return Value

See Also

ThemeCache Class
GetTheme Overload
VIBlend.Utilities Namespace


GetTheme Method (String, VIBLEND_THEME, ControlTheme)

[image]

VIBlend Controls for WinForms Help Documentation
ThemeCache..::..GetTheme Method (String, VIBLEND_THEME, ControlTheme)
ThemeCache Class See Also Send Feedback
Gets the theme.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static ControlTheme GetTheme(
    string styleKey,
    VIBLEND_THEME value,
    ControlTheme controlTheme
)
Visual Basic
Public Shared Function GetTheme ( _
    styleKey As String, _
    value As VIBLEND_THEME, _
    controlTheme As ControlTheme _
) As ControlTheme
Visual C++
public:
static ControlTheme^ GetTheme(
    String^ styleKey,
    VIBLEND_THEME value,
    ControlTheme^ controlTheme
)

Parameters

styleKey
Type: System..::..String
The style key.
value
Type: VIBlend.Utilities..::..VIBLEND_THEME
The value.
controlTheme
Type: VIBlend.Utilities..::..ControlTheme
The control theme.

Return Value

See Also

ThemeCache Class
GetTheme Overload
VIBlend.Utilities Namespace


vColors Class

[image]

VIBlend Controls for WinForms Help Documentation
vColors Class
Members See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public sealed class vColors
Visual Basic
Public NotInheritable Class vColors
Visual C++
public ref class vColors sealed

Inheritance Hierarchy

System..::..Object
VIBlend.Utilities..::..vColors

See Also

vColors Members
VIBlend.Utilities Namespace


vColors Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColors Members
vColors Class Methods Properties See Also Send Feedback

The vColors type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorName | Gets or sets the name of the color.
Colors | Gets the colors.
CustomColors | Gets the custom colors.
CustomString | Gets or sets the custom string.
LocalizableColors | Gets the localizable colors.
LocalizableSystemColors | Gets the localizable system colors.
OtherString | Gets or sets the other string.
SystemColors | Gets the system colors.
SystemString | Gets or sets the system string.
WebString | Gets or sets the web string.

See Also

vColors Class
VIBlend.Utilities Namespace


vColors Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColors Methods
vColors Class See Also Send Feedback

The vColors type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vColors Class
VIBlend.Utilities Namespace


vColors Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColors Properties
vColors Class See Also Send Feedback

The vColors type exposes the following members.

Properties

Name | Description
ColorName | Gets or sets the name of the color.
Colors | Gets the colors.
CustomColors | Gets the custom colors.
CustomString | Gets or sets the custom string.
LocalizableColors | Gets the localizable colors.
LocalizableSystemColors | Gets the localizable system colors.
OtherString | Gets or sets the other string.
SystemColors | Gets the system colors.
SystemString | Gets or sets the system string.
WebString | Gets or sets the web string.

See Also

vColors Class
VIBlend.Utilities Namespace


ColorName Property

[image]

VIBlend Controls for WinForms Help Documentation
vColors..::..ColorName Property
vColors Class See Also Send Feedback
Gets or sets the name of the color.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static string ColorName { get; set; }
Visual Basic
Public Shared Property ColorName As String
    Get
    Set
Visual C++
public:
static property String^ ColorName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the color.

See Also

vColors Class
VIBlend.Utilities Namespace


Colors Property

[image]

VIBlend Controls for WinForms Help Documentation
vColors..::..Colors Property
vColors Class See Also Send Feedback
Gets the colors.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color[] Colors { get; }
Visual Basic
Public Shared ReadOnly Property Colors As Color()
    Get
Visual C++
public:
static property array<Color>^ Colors {
    array<Color>^ get ();
}

Field Value

The colors.

See Also

vColors Class
VIBlend.Utilities Namespace


CustomColors Property

[image]

VIBlend Controls for WinForms Help Documentation
vColors..::..CustomColors Property
vColors Class See Also Send Feedback
Gets the custom colors.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color[] CustomColors { get; }
Visual Basic
Public Shared ReadOnly Property CustomColors As Color()
    Get
Visual C++
public:
static property array<Color>^ CustomColors {
    array<Color>^ get ();
}

Field Value

The custom colors.

See Also

vColors Class
VIBlend.Utilities Namespace


CustomString Property

[image]

VIBlend Controls for WinForms Help Documentation
vColors..::..CustomString Property
vColors Class See Also Send Feedback
Gets or sets the custom string.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static string CustomString { get; set; }
Visual Basic
Public Shared Property CustomString As String
    Get
    Set
Visual C++
public:
static property String^ CustomString {
    String^ get ();
    void set (String^ value);
}

Field Value

The custom string.

See Also

vColors Class
VIBlend.Utilities Namespace


LocalizableColors Property

[image]

VIBlend Controls for WinForms Help Documentation
vColors..::..LocalizableColors Property
vColors Class See Also Send Feedback
Gets the localizable colors.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Hashtable LocalizableColors { get; }
Visual Basic
Public Shared ReadOnly Property LocalizableColors As Hashtable
    Get
Visual C++
public:
static property Hashtable^ LocalizableColors {
    Hashtable^ get ();
}

Field Value

The localizable colors.

See Also

vColors Class
VIBlend.Utilities Namespace


LocalizableSystemColors Property

[image]

VIBlend Controls for WinForms Help Documentation
vColors..::..LocalizableSystemColors Property
vColors Class See Also Send Feedback
Gets the localizable system colors.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Hashtable LocalizableSystemColors { get; }
Visual Basic
Public Shared ReadOnly Property LocalizableSystemColors As Hashtable
    Get
Visual C++
public:
static property Hashtable^ LocalizableSystemColors {
    Hashtable^ get ();
}

Field Value

The localizable system colors.

See Also

vColors Class
VIBlend.Utilities Namespace


OtherString Property

[image]

VIBlend Controls for WinForms Help Documentation
vColors..::..OtherString Property
vColors Class See Also Send Feedback
Gets or sets the other string.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static string OtherString { get; set; }
Visual Basic
Public Shared Property OtherString As String
    Get
    Set
Visual C++
public:
static property String^ OtherString {
    String^ get ();
    void set (String^ value);
}

Field Value

The other string.

See Also

vColors Class
VIBlend.Utilities Namespace


SystemColors Property

[image]

VIBlend Controls for WinForms Help Documentation
vColors..::..SystemColors Property
vColors Class See Also Send Feedback
Gets the system colors.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color[] SystemColors { get; }
Visual Basic
Public Shared ReadOnly Property SystemColors As Color()
    Get
Visual C++
public:
static property array<Color>^ SystemColors {
    array<Color>^ get ();
}

Field Value

The system colors.

See Also

vColors Class
VIBlend.Utilities Namespace


SystemString Property

[image]

VIBlend Controls for WinForms Help Documentation
vColors..::..SystemString Property
vColors Class See Also Send Feedback
Gets or sets the system string.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static string SystemString { get; set; }
Visual Basic
Public Shared Property SystemString As String
    Get
    Set
Visual C++
public:
static property String^ SystemString {
    String^ get ();
    void set (String^ value);
}

Field Value

The system string.

See Also

vColors Class
VIBlend.Utilities Namespace


WebString Property

[image]

VIBlend Controls for WinForms Help Documentation
vColors..::..WebString Property
vColors Class See Also Send Feedback
Gets or sets the web string.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static string WebString { get; set; }
Visual Basic
Public Shared Property WebString As String
    Get
    Set
Visual C++
public:
static property String^ WebString {
    String^ get ();
    void set (String^ value);
}

Field Value

The web string.

See Also

vColors Class
VIBlend.Utilities Namespace


vDropDownControlBase Class

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase Class
Members See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vDropDownControlBase : vControlBase
Visual Basic
Public Class vDropDownControlBase _
    Inherits vControlBase
Visual C++
public ref class vDropDownControlBase : public vControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
vControlBase
VIBlend.Utilities..::..vDropDownControlBase

See Also

vDropDownControlBase Members
VIBlend.Utilities Namespace


vDropDownControlBase Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase Members
vDropDownControlBase Class Constructors Methods Properties Events See Also Send Feedback

The vDropDownControlBase type exposes the following members.

Constructors

 | Name | Description
Public method | vDropDownControlBase | Initializes a new instance of the vDropDownControlBase class

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Protected method | InnerRect()()()() |
Protected method | InnerRect(Rectangle) |
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnButtonClick |
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Overrides Control..::..OnClick(EventArgs).)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawvButton |
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformBoundsCalculations | Performs the bounds calculations.
Protected method | PerformEditLayout |
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentControl | Gets or sets the content control.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Protected property | Hover |
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | OverrideBackColor |
Public property | OverrideBorderColor |
Public property | OverrideFont |
Public property | OverrideForeColor |
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackColor |
Public property | UseThemeBorderColor |
Public property | UseThemeFont |
Public property | UseThemeForeColor |
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VButtonWidth |
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawvButton |
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintEditBox |
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | vButtonClick |
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


vDropDownControlBase Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase Constructor
vDropDownControlBase Class See Also Send Feedback
Initializes a new instance of the vDropDownControlBase class

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDropDownControlBase()
Visual Basic
Public Sub New
Visual C++
public:
vDropDownControlBase()

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


vDropDownControlBase Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase Methods
vDropDownControlBase Class See Also Send Feedback

The vDropDownControlBase type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Protected method | InnerRect()()()() |
Protected method | InnerRect(Rectangle) |
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnButtonClick |
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Overrides Control..::..OnClick(EventArgs).)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawvButton |
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformBoundsCalculations | Performs the bounds calculations.
Protected method | PerformEditLayout |
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..AccessibilityNotifyClients Method
vDropDownControlBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vDropDownControlBase Class
vDropDownControlBase Members
VIBlend.Utilities Namespace


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..BeginInvoke Method
vDropDownControlBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vDropDownControlBase Class
vDropDownControlBase Members
VIBlend.Utilities Namespace


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..Dispose Method
vDropDownControlBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vDropDownControlBase Class
vDropDownControlBase Members
VIBlend.Utilities Namespace


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..GetChildAtPoint Method
vDropDownControlBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vDropDownControlBase Class
vDropDownControlBase Members
VIBlend.Utilities Namespace


InnerRect Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..InnerRect Method
vDropDownControlBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | InnerRect()()()() |
Protected method | InnerRect(Rectangle) |

See Also

vDropDownControlBase Class
vDropDownControlBase Members
VIBlend.Utilities Namespace


InnerRect Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..InnerRect Method
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected Rectangle InnerRect()
Visual Basic
Protected Function InnerRect As Rectangle
Visual C++
protected:
Rectangle InnerRect()

See Also

vDropDownControlBase Class
InnerRect Overload
VIBlend.Utilities Namespace


InnerRect Method (Rectangle)

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..InnerRect Method (Rectangle)
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected Rectangle InnerRect(
    Rectangle bounds
)
Visual Basic
Protected Function InnerRect ( _
    bounds As Rectangle _
) As Rectangle
Visual C++
protected:
Rectangle InnerRect(
    Rectangle bounds
)

Parameters

bounds
Type: System.Drawing..::..Rectangle

See Also

vDropDownControlBase Class
InnerRect Overload
VIBlend.Utilities Namespace


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..Invalidate Method
vDropDownControlBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vDropDownControlBase Class
vDropDownControlBase Members
VIBlend.Utilities Namespace


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..Invoke Method
vDropDownControlBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vDropDownControlBase Class
vDropDownControlBase Members
VIBlend.Utilities Namespace


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..MemberwiseClone Method
vDropDownControlBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vDropDownControlBase Class
vDropDownControlBase Members
VIBlend.Utilities Namespace


OnButtonClick Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..OnButtonClick Method
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnButtonClick(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnButtonClick ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnButtonClick(
    EventArgs^ e
)

Parameters

e
Type: System..::..EventArgs

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


OnClick Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..OnClick Method
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnClick(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnClick ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnClick(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


OnDrawvButton Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..OnDrawvButton Method
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnDrawvButton()
Visual Basic
Protected Overridable Sub OnDrawvButton
Visual C++
protected:
virtual void OnDrawvButton()

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..OnMouseDown Method
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..OnMouseMove Method
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..OnMouseUp Method
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..OnPaint Method
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


OnSizeChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..OnSizeChanged Method
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnSizeChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnSizeChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSizeChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


PerformBoundsCalculations Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..PerformBoundsCalculations Method
vDropDownControlBase Class See Also Send Feedback
Performs the bounds calculations.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle PerformBoundsCalculations(
    Rectangle bounds
)
Visual Basic
Public Function PerformBoundsCalculations ( _
    bounds As Rectangle _
) As Rectangle
Visual C++
public:
Rectangle PerformBoundsCalculations(
    Rectangle bounds
)

Parameters

bounds
Type: System.Drawing..::..Rectangle
The bounds.

Return Value

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


PerformEditLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..PerformEditLayout Method
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void PerformEditLayout()
Visual Basic
Protected Overridable Sub PerformEditLayout
Visual C++
protected:
virtual void PerformEditLayout()

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..PerformLayout Method
vDropDownControlBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vDropDownControlBase Class
vDropDownControlBase Members
VIBlend.Utilities Namespace


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..ResumeLayout Method
vDropDownControlBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vDropDownControlBase Class
vDropDownControlBase Members
VIBlend.Utilities Namespace


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..RtlTranslateAlignment Method
vDropDownControlBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vDropDownControlBase Class
vDropDownControlBase Members
VIBlend.Utilities Namespace


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..Scale Method
vDropDownControlBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vDropDownControlBase Class
vDropDownControlBase Members
VIBlend.Utilities Namespace


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..Select Method
vDropDownControlBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vDropDownControlBase Class
vDropDownControlBase Members
VIBlend.Utilities Namespace


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..SetBounds Method
vDropDownControlBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vDropDownControlBase Class
vDropDownControlBase Members
VIBlend.Utilities Namespace


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..UpdateBounds Method
vDropDownControlBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vDropDownControlBase Class
vDropDownControlBase Members
VIBlend.Utilities Namespace


vDropDownControlBase Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase Properties
vDropDownControlBase Class See Also Send Feedback

The vDropDownControlBase type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentControl | Gets or sets the content control.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Protected property | Hover |
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | OverrideBackColor |
Public property | OverrideBorderColor |
Public property | OverrideFont |
Public property | OverrideForeColor |
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackColor |
Public property | UseThemeBorderColor |
Public property | UseThemeFont |
Public property | UseThemeForeColor |
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VButtonWidth |
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


ContentControl Property

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..ContentControl Property
vDropDownControlBase Class See Also Send Feedback
Gets or sets the content control.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control ContentControl { get; set; }
Visual Basic
Public Property ContentControl As Control
    Get
    Set
Visual C++
public:
property Control^ ContentControl {
    Control^ get ();
    void set (Control^ value);
}

Field Value

The content control.

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


Hover Property

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..Hover Property
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected bool Hover { get; }
Visual Basic
Protected ReadOnly Property Hover As Boolean
    Get
Visual C++
protected:
property bool Hover {
    bool get ();
}

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


OverrideBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..OverrideBackColor Property
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color OverrideBackColor { get; set; }
Visual Basic
Public Property OverrideBackColor As Color
    Get
    Set
Visual C++
public:
property Color OverrideBackColor {
    Color get ();
    void set (Color value);
}

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


OverrideBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..OverrideBorderColor Property
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color OverrideBorderColor { get; set; }
Visual Basic
Public Property OverrideBorderColor As Color
    Get
    Set
Visual C++
public:
property Color OverrideBorderColor {
    Color get ();
    void set (Color value);
}

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


OverrideFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..OverrideFont Property
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font OverrideFont { get; set; }
Visual Basic
Public Property OverrideFont As Font
    Get
    Set
Visual C++
public:
property Font^ OverrideFont {
    Font^ get ();
    void set (Font^ value);
}

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


OverrideForeColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..OverrideForeColor Property
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color OverrideForeColor { get; set; }
Visual Basic
Public Property OverrideForeColor As Color
    Get
    Set
Visual C++
public:
property Color OverrideForeColor {
    Color get ();
    void set (Color value);
}

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..Theme Property
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


UseThemeBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..UseThemeBackColor Property
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBackColor { get; set; }
Visual Basic
Public Property UseThemeBackColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBackColor {
    bool get ();
    void set (bool value);
}

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


UseThemeBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..UseThemeBorderColor Property
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBorderColor { get; set; }
Visual Basic
Public Property UseThemeBorderColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBorderColor {
    bool get ();
    void set (bool value);
}

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


UseThemeFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..UseThemeFont Property
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeFont { get; set; }
Visual Basic
Public Property UseThemeFont As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeFont {
    bool get ();
    void set (bool value);
}

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


UseThemeForeColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..UseThemeForeColor Property
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeForeColor { get; set; }
Visual Basic
Public Property UseThemeForeColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeForeColor {
    bool get ();
    void set (bool value);
}

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


VButtonWidth Property

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..VButtonWidth Property
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual int VButtonWidth { get; set; }
Visual Basic
Public Overridable Property VButtonWidth As Integer
    Get
    Set
Visual C++
public:
virtual property int VButtonWidth {
    int get ();
    void set (int value);
}

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


vDropDownControlBase Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase Events
vDropDownControlBase Class See Also Send Feedback

The vDropDownControlBase type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawvButton |
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintEditBox |
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | vButtonClick |
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


DrawvButton Event

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..DrawvButton Event
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler DrawvButton
Visual Basic
Public Event DrawvButton As EventHandler
Visual C++
public:
 event EventHandler^ DrawvButton {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


PaintEditBox Event

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..PaintEditBox Event
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event PaintEventHandler PaintEditBox
Visual Basic
Public Event PaintEditBox As PaintEventHandler
Visual C++
public:
 event PaintEventHandler^ PaintEditBox {
    void add (PaintEventHandler^ value);
    void remove (PaintEventHandler^ value);
}

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


vButtonClick Event

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownControlBase..::..vButtonClick Event
vDropDownControlBase Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler vButtonClick
Visual Basic
Public Event vButtonClick As EventHandler
Visual C++
public:
 event EventHandler^ vButtonClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vDropDownControlBase Class
VIBlend.Utilities Namespace


vDropDownForm Class

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm Class
Members See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vDropDownForm : Form
Visual Basic
Public Class vDropDownForm _
    Inherits Form
Visual C++
public ref class vDropDownForm : public Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
VIBlend.Utilities..::..vDropDownForm

See Also

vDropDownForm Members
VIBlend.Utilities Namespace


vDropDownForm Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm Members
vDropDownForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The vDropDownForm type exposes the following members.

Constructors

 | Name | Description
Public method | vDropDownForm()()()() | Initializes a new instance of the vDropDownForm class.
Public method | vDropDownForm(Control) | Initializes a new instance of the vDropDownForm class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CallHideForm | Calls the hide form.
Public method | CallShowForm | Calls the show form.
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | (Overrides Form..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HideFormAndActivateParent | Hides the form and activate parent.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnHideForm | Raises the [E:HideForm] event.
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShowForm | Raises the [E:ShowForm] event.
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show()()()() | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | ShowPopupForm | Shows the popup form.
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)

Fields

 | Name | Description
Public field | AllowHideForm |
Protected field | ParentControl |

Properties

 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets the form's window state. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HideForm | Occurs when form is to be hidden
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | ShowForm | Occurs when form is shown
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDropDownForm Class
VIBlend.Utilities Namespace


vDropDownForm Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm Constructor
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | vDropDownForm()()()() | Initializes a new instance of the vDropDownForm class.
Public method | vDropDownForm(Control) | Initializes a new instance of the vDropDownForm class.

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


vDropDownForm Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm Constructor
vDropDownForm Class See Also Send Feedback
Initializes a new instance of the vDropDownForm class.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDropDownForm()
Visual Basic
Public Sub New
Visual C++
public:
vDropDownForm()

See Also

vDropDownForm Class
vDropDownForm Overload
VIBlend.Utilities Namespace


vDropDownForm Constructor (Control)

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm Constructor (Control)
vDropDownForm Class See Also Send Feedback
Initializes a new instance of the vDropDownForm class.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDropDownForm(
    Control parentControl
)
Visual Basic
Public Sub New ( _
    parentControl As Control _
)
Visual C++
public:
vDropDownForm(
    Control^ parentControl
)

Parameters

parentControl
Type: System.Windows.Forms..::..Control
The parent control.

See Also

vDropDownForm Class
vDropDownForm Overload
VIBlend.Utilities Namespace


vDropDownForm Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm Fields
vDropDownForm Class See Also Send Feedback

The vDropDownForm type exposes the following members.

Fields

 | Name | Description
Public field | AllowHideForm |
Protected field | ParentControl |

See Also

vDropDownForm Class
VIBlend.Utilities Namespace


AllowHideForm Field

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..AllowHideForm Field
vDropDownForm Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowHideForm
Visual Basic
Public AllowHideForm As Boolean
Visual C++
public:
bool AllowHideForm

See Also

vDropDownForm Class
VIBlend.Utilities Namespace


ParentControl Field

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..ParentControl Field
vDropDownForm Class See Also Send Feedback

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected Control ParentControl
Visual Basic
Protected ParentControl As Control
Visual C++
protected:
Control^ ParentControl

See Also

vDropDownForm Class
VIBlend.Utilities Namespace


vDropDownForm Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm Methods
vDropDownForm Class See Also Send Feedback

The vDropDownForm type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CallHideForm | Calls the hide form.
Public method | CallShowForm | Calls the show form.
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | (Overrides Form..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HideFormAndActivateParent | Hides the form and activate parent.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnHideForm | Raises the [E:HideForm] event.
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShowForm | Raises the [E:ShowForm] event.
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show()()()() | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | ShowPopupForm | Shows the popup form.
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)

See Also

vDropDownForm Class
VIBlend.Utilities Namespace


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..AccessibilityNotifyClients Method
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..BeginInvoke Method
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


CallHideForm Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..CallHideForm Method
vDropDownForm Class See Also Send Feedback
Calls the hide form.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void CallHideForm(
    EventArgs e
)
Visual Basic
Public Sub CallHideForm ( _
    e As EventArgs _
)
Visual C++
public:
void CallHideForm(
    EventArgs^ e
)

Parameters

e
Type: System..::..EventArgs
The EventArgs instance containing the event data.

See Also

vDropDownForm Class
VIBlend.Utilities Namespace


CallShowForm Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..CallShowForm Method
vDropDownForm Class See Also Send Feedback
Calls the show form.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void CallShowForm(
    EventArgs e
)
Visual Basic
Public Sub CallShowForm ( _
    e As EventArgs _
)
Visual C++
public:
void CallShowForm(
    EventArgs^ e
)

Parameters

e
Type: System..::..EventArgs
The EventArgs instance containing the event data.

See Also

vDropDownForm Class
VIBlend.Utilities Namespace


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..Dispose Method
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the vDropDownForm and optionally releases the managed resources (Overrides Form..::..Dispose(Boolean).)

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..Dispose Method (Boolean)
vDropDownForm Class See Also Send Feedback
Releases the unmanaged resources used by the vDropDownForm and optionally releases the managed resources

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vDropDownForm Class
Dispose Overload
VIBlend.Utilities Namespace


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..GetChildAtPoint Method
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


HideFormAndActivateParent Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..HideFormAndActivateParent Method
vDropDownForm Class See Also Send Feedback
Hides the form and activate parent.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void HideFormAndActivateParent()
Visual Basic
Public Overridable Sub HideFormAndActivateParent
Visual C++
public:
virtual void HideFormAndActivateParent()

See Also

vDropDownForm Class
VIBlend.Utilities Namespace


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..Invalidate Method
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..Invoke Method
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..MemberwiseClone Method
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


OnHideForm Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..OnHideForm Method
vDropDownForm Class See Also Send Feedback
Raises the [E:HideForm] event.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnHideForm(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnHideForm ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnHideForm(
    EventArgs^ e
)

Parameters

e
Type: System..::..EventArgs
The EventArgs instance containing the event data.

See Also

vDropDownForm Class
VIBlend.Utilities Namespace


OnShowForm Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..OnShowForm Method
vDropDownForm Class See Also Send Feedback
Raises the [E:ShowForm] event.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnShowForm(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnShowForm ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnShowForm(
    EventArgs^ e
)

Parameters

e
Type: System..::..EventArgs
The EventArgs instance containing the event data.

See Also

vDropDownForm Class
VIBlend.Utilities Namespace


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..PerformLayout Method
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..ResumeLayout Method
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..RtlTranslateAlignment Method
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..Scale Method
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..Select Method
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..SetBounds Method
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


Show Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..Show Method
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Show()()()() | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


ShowDialog Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..ShowDialog Method
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


ShowPopupForm Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..ShowPopupForm Method
vDropDownForm Class See Also Send Feedback
Shows the popup form.

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void ShowPopupForm()
Visual Basic
Public Overridable Sub ShowPopupForm
Visual C++
public:
virtual void ShowPopupForm()

See Also

vDropDownForm Class
VIBlend.Utilities Namespace


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..UpdateBounds Method
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


Validate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..Validate Method
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


ValidateChildren Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..ValidateChildren Method
vDropDownForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

vDropDownForm Class
vDropDownForm Members
VIBlend.Utilities Namespace


vDropDownForm Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm Properties
vDropDownForm Class See Also Send Feedback

The vDropDownForm type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets the form's window state. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vDropDownForm Class
VIBlend.Utilities Namespace


vDropDownForm Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm Events
vDropDownForm Class See Also Send Feedback

The vDropDownForm type exposes the following members.

Events

 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HideForm | Occurs when form is to be hidden
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | ShowForm | Occurs when form is shown
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDropDownForm Class
VIBlend.Utilities Namespace


HideForm Event

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..HideForm Event
vDropDownForm Class See Also Send Feedback
Occurs when form is to be hidden

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler HideForm
Visual Basic
Public Event HideForm As EventHandler
Visual C++
public:
 event EventHandler^ HideForm {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vDropDownForm Class
VIBlend.Utilities Namespace


ShowForm Event

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownForm..::..ShowForm Event
vDropDownForm Class See Also Send Feedback
Occurs when form is shown

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ShowForm
Visual Basic
Public Event ShowForm As EventHandler
Visual C++
public:
 event EventHandler^ ShowForm {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vDropDownForm Class
VIBlend.Utilities Namespace


VIBLEND_THEME Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
VIBLEND_THEME Enumeration
See Also Send Feedback
Enumeration of the standard VIBlend themes

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum VIBLEND_THEME
Visual Basic
Public Enumeration VIBLEND_THEME
Visual C++
public enum class VIBLEND_THEME

Members

Member name | Description
OFFICEBLACK |
OFFICEBLUE |
OFFICESILVER |
OFFICEGREEN |
VISTABLUE |
BLUEBLEND |
ULTRABLUE |
ORANGEFRESH |
ECOGREEN |
BLACKPEARL |
OFFICE2003BLUE |
OFFICE2003OLIVE |
OFFICE2003SILVER |
RETRO |
RETROBLUE |
OFFICE2010BLACK |
OFFICE2010BLUE |
OFFICE2010SILVER |
NERO |
EXPRESSIONDARK |

See Also

VIBlend.Utilities Namespace


VisualStyle Class

[image]

VIBlend Controls for WinForms Help Documentation
VisualStyle Class
Members See Also Send Feedback
Represents a visual style of a UI element

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[SerializableAttribute]
public class VisualStyle
Visual Basic
<SerializableAttribute> _
Public Class VisualStyle
Visual C++
[SerializableAttribute]
public ref class VisualStyle

Inheritance Hierarchy

System..::..Object
VIBlend.Utilities..::..VisualStyle

See Also

VisualStyle Members
VIBlend.Utilities Namespace


VisualStyle Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
VisualStyle Members
VisualStyle Class Constructors Methods Properties See Also Send Feedback

The VisualStyle type exposes the following members.

Constructors

 | Name | Description
Public method | VisualStyle | Initializes a new instance of the VisualStyle class

Methods

 | Name | Description
Public method | CreateCopy | Creates a new VisualStyle object with the exact same property values
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFromXmlStream | Loads the VisualStyle from a XML stream
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BorderColor | Border color
Public property | FillStyle | Fill property of the visual style
Public property | Font | Text font
Public property | TextAlignment | Text alignment
Public property | TextColor | Text color
Public property | TextWrap | Text wrap mode

See Also

VisualStyle Class
VIBlend.Utilities Namespace


VisualStyle Constructor

[image]

VIBlend Controls for WinForms Help Documentation
VisualStyle Constructor
VisualStyle Class See Also Send Feedback
Initializes a new instance of the VisualStyle class

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VisualStyle()
Visual Basic
Public Sub New
Visual C++
public:
VisualStyle()

See Also

VisualStyle Class
VIBlend.Utilities Namespace


VisualStyle Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
VisualStyle Methods
VisualStyle Class See Also Send Feedback

The VisualStyle type exposes the following members.

Methods

 | Name | Description
Public method | CreateCopy | Creates a new VisualStyle object with the exact same property values
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFromXmlStream | Loads the VisualStyle from a XML stream
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VisualStyle Class
VIBlend.Utilities Namespace


CreateCopy Method

[image]

VIBlend Controls for WinForms Help Documentation
VisualStyle..::..CreateCopy Method
VisualStyle Class See Also Send Feedback
Creates a new VisualStyle object with the exact same property values

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VisualStyle CreateCopy()
Visual Basic
Public Function CreateCopy As VisualStyle
Visual C++
public:
VisualStyle^ CreateCopy()

Return Value

See Also

VisualStyle Class
VIBlend.Utilities Namespace


LoadFromXmlStream Method

[image]

VIBlend Controls for WinForms Help Documentation
VisualStyle..::..LoadFromXmlStream Method
VisualStyle Class See Also Send Feedback
Loads the VisualStyle from a XML stream

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool LoadFromXmlStream(
    Stream stream
)
Visual Basic
Public Function LoadFromXmlStream ( _
    stream As Stream _
) As Boolean
Visual C++
public:
bool LoadFromXmlStream(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
Input XML stream

Return Value

The method returns true if the load is successful.

See Also

VisualStyle Class
VIBlend.Utilities Namespace


VisualStyle Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
VisualStyle Properties
VisualStyle Class See Also Send Feedback

The VisualStyle type exposes the following members.

Properties

 | Name | Description
Public property | BorderColor | Border color
Public property | FillStyle | Fill property of the visual style
Public property | Font | Text font
Public property | TextAlignment | Text alignment
Public property | TextColor | Text color
Public property | TextWrap | Text wrap mode

See Also

VisualStyle Class
VIBlend.Utilities Namespace


BorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
VisualStyle..::..BorderColor Property
VisualStyle Class See Also Send Feedback
Border color

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BorderColor { get; set; }
Visual Basic
Public Property BorderColor As Color
    Get
    Set
Visual C++
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}

See Also

VisualStyle Class
VIBlend.Utilities Namespace


FillStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
VisualStyle..::..FillStyle Property
VisualStyle Class See Also Send Feedback
Fill property of the visual style

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public FillStyle FillStyle { get; set; }
Visual Basic
Public Property FillStyle As FillStyle
    Get
    Set
Visual C++
public:
property FillStyle^ FillStyle {
    FillStyle^ get ();
    void set (FillStyle^ value);
}

See Also

VisualStyle Class
VIBlend.Utilities Namespace


Font Property

[image]

VIBlend Controls for WinForms Help Documentation
VisualStyle..::..Font Property
VisualStyle Class See Also Send Feedback
Text font

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font Font { get; set; }
Visual Basic
Public Property Font As Font
    Get
    Set
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

See Also

VisualStyle Class
VIBlend.Utilities Namespace


TextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
VisualStyle..::..TextAlignment Property
VisualStyle Class See Also Send Feedback
Text alignment

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment TextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

VisualStyle Class
VIBlend.Utilities Namespace


TextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
VisualStyle..::..TextColor Property
VisualStyle Class See Also Send Feedback
Text color

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color TextColor { get; set; }
Visual Basic
Public Property TextColor As Color
    Get
    Set
Visual C++
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}

See Also

VisualStyle Class
VIBlend.Utilities Namespace


TextWrap Property

[image]

VIBlend Controls for WinForms Help Documentation
VisualStyle..::..TextWrap Property
VisualStyle Class See Also Send Feedback
Text wrap mode

Namespace: VIBlend.Utilities
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool TextWrap { get; set; }
Visual Basic
Public Property TextWrap As Boolean
    Get
    Set
Visual C++
public:
property bool TextWrap {
    bool get ();
    void set (bool value);
}

See Also

VisualStyle Class
VIBlend.Utilities Namespace


VIBlend.WinForms.Controls Namespace

[image]

VIBlend Controls for WinForms Help Documentation
VIBlend.WinForms.Controls Namespace
Send Feedback

Classes

 | Class | Description
Public class | CalendarPaintEventArgs |
Public class | ColorPickerPanel | Represents a ColorPicker panel control
Public class | ColorStringFormatEventArgs | Represents a color text formatting event arguments
Public class | DateCancelEventArgs |
Public class | DateTimeEditorFormatItem |
Public class | DateTimeFormatBaseEditor |
Public class | DateTimeFormatDayMonthYearEditor |
Public class | DayPattern |
Public class | DayPatternConverter |
Public class | DesignerAttributeTypeDescriptor |
Public class | DisabledEditor |
Public class | DragCancelEventArgs | Represents a drag and drop cancel event argument
Public class | DrawExplorerBarEventArgs |
Public class | DrawNavPaneEventArgs |
Public class | DrawNodeEventArgs |
Public class | DrawOutlookNavPaneEventArgs |
Public class | DrawOutlookNavPaneResizeItemEventArgs |
Public class | DrawOutlookNavPaneStatusEventArgs |
Public class | DynamicDesignerProvider |
Public class | EditorAmPmItem |
Public class | EditorState |
Public class | GalleryButton |
Public class | GalleryButtonCollection |
Public class | GlassFormUtility |
Public class | GlobalHook |
Public class | ImageAndTextHelper |
Public class | InputBase |
Public class | KeyTip | Represents a KeyTip component
Public class | LineStates | Represents a class which calculates the tree node lines.
Public class | ListItem | Represents a vListBox item
Public class | ListItemComparer |
Public class | ListItemsCollection | Represents a collection of ListItemsCollection
Public class | MonthPattern |
Public class | MouseAndKeyboardFilter | Represents a MouseAndKeyboardFilter
Public class | OfficeRibbonForm |
Public class | QuickAccessToolbar | Represents a QuickAccessToolbar control which is often used in ribbon interfaces.
Public class | RecurrenceRange |
Public class | RibbonBarGalleryGroup | Represents a RibbonBarGalleryGroup component
Public class | RibbonForm | Represents a Form that supports VIBlend Themes.
Public class | RibbonGroupPanel |
Public class | RibbonPaintHelper |
Public class | SelectionCancelEventArgs |
Public class | SelectionEventArgs |
Public class | SplitContainerBase |
Public class | SplitterControl | Represents a splitter control.
Public class | StringUtility |
Public class | TabContext |
Public class | UndoRedoManager |
Public class | ValueChangedEditorEventArgs |
Public class | ValueChangingEditorEventArgs |
Public class | vApplicationMenuItem | Represents a vApplicationMenuItem control.
Public class | vApplicationMenuItemCollection |
Public class | vAppointment |
Public class | vArrowButton | Represents a Button control that show an arrow with configurable direction.
Public class | vBubbleBar | Represents a vBubbleBar control
Public class | vButton | Represents a vButton control
Public class | vCheckBox | Represents a vCheckBox control which allows the user to indicate whether an item is selected or not.
Public class | vCheckedListBox | Represents a vCheckedListBox control
Public class | vCircularButton | Represents a vCircularButton control
Public class | vCircularProgressBar | Represents a vCircularProgressBar control
Public class | vColorPicker | Represents a vColorPicker control.
Public class | vColorTable |
Public class | vComboBox | Represents vComboBox control
Public class | vContextMenu | Represents a vContextMenu control
Public class | vControlBoundsHelper |
Public class | vControlBox | Represents a vControlBox control
Public class | vCurrencyEditor |
Public class | vDatePicker | Represents a vDatePicker control. The control contains a DropDown calendar, and allows you to select a date.
Public class | vDateTimeEditor | Represents a vDateTimeEditor control.
Public class | vDateTimePicker | Represents a vDateTimePicker control
Public class | vDecimalEditor |
Public class | vDropDownBase | Represents a vDropDownBase control
Public class | vExplorerBar | Represents a ExplorerBar control which allows the user to select from a list of container controls that can host other controls.
Public class | vExplorerBarCancelEventArgs | Represents a vNavPane event arguments
Public class | vExplorerBarEventArgs | Represents a vNavPane event arguments
Public class | vExplorerBarItem | Represents a vNavPane item
Public class | vFieldSet | Represents a vFieldSet control that displays and drop-down list of multi-choice items.
Public class | vFixedPointEditor |
Public class | vFlowLayoutPanel | Represents a vFlowLayoutPanel control where the user can arrange multiple controls.
Public class | vFontComboBox | Represents a vFontComboBox control
Public class | vForm |
Public class | vForm..::..MINMAXINFO |
Public class | vForm..::..POINT |
Public class | vForm..::..Util |
Public class | vFormButton |
Public class | vGroupBox | Represents a vGroupBox control which displays a frame around other controls, and allows the user to expand/collapse the entire group.
Public class | vHorizontalLayoutPanel | Represents a vHorizontalLayoutPanel control where the user can arrange multiple controls.
Public class | vHScrollBar | Represents a horizontal scroll bar control
Public class | vImageReflectionControl | Represents a vImageReflectionControl control
Public class | vLabel | Represents a vLabel control
Public class | vLabelItem | Represents a vLabelItem
Public class | vListBox | Represents a vListBox control
Public class | vMaskedTextBox | Represents a vMaskedTextBox control
Public class | vMenuControl | Represents a vMenuControl
Public class | vMenuExtender |
Public class | vMonthCalendar | Represents a month calendar control.
Public class | vMultiLabel | Represents a vMultiLabel control.
Public class | vNavItemCancelEventArgs |
Public class | vNavItemEventArgs | Represents a vNavPane event arguments
Public class | vNavPane | Represents a NavigationPane control, which allows the user to select from a list of container controls that can host other controls.
Public class | vNavPaneItem | Represents a vNavPane item
Public class | vNumberEditor |
Public class | vNumericUpDown | Represents a vNumericUpDown control
Public class | vOptionsFieldSet | Represents an vOptionsFieldSet control that displays a drop-down list of single-choice items.
Public class | vOutlookItem | Represents a vOutlookNavPane item
Public class | vOutlookNavItemCancelEventArgs |
Public class | vOutlookNavItemEventArgs | Represents a vNavPane event arguments
Public class | vOutlookNavPane | Represents an Outlook style NavigationPane control, which allows the user to select from a list of container controls that can host other controls.
Public class | vOutlookResizeItem |
Public class | vOutlookStatusItem |
Public class | vPanel | Represents a vPanel control
Public class | vPercentageEditor |
Public class | vProgressBar | Represents a vProgressBar control. The control displays a bar that fills to indicate to the user the progress of an operation.
Public class | vRadioButton | Represents a vRadioButton control.
Public class | vRadioListBox | Represents a vCheckedListBox control
Public class | vRatingControl | Represents a vRatingControl
Public class | vRepeatButton | Represents a vRepeatButton control
Public class | vRibbonApplicationButton | Represents a vRibbonApplicationButton control.
Public class | vRibbonBar | Represents a vRibbonBar control.
Public class | vRibbonBarGallery | Represents a vRibbonBarGallery control
Public class | vRibbonButton | Represents a vRibbonButton control
Public class | vRibbonFooterButton |
Public class | vRibbonGroup | Represents a vRibbonGroup control
Public class | vRibbonGroupContent |
Public class | vRibbonGroupFooter |
Public class | vRibbonHorizontalLayoutPanel |
Public class | vRichTextBox | Represents a vRichTextBox control, that provides advanced text editing and formatting capabilities.
Public class | vRichTextBoxBase |
Public class | vScrollBar | Represents a base class for the vHScrollBar and vVScrollBar controls
Public class | vSeparator | Represents a vSeparator control
Public class | vSizeType | Represents an extension of the standard Size class.
Public class | vSizingControl |
Public class | vSplitButton | Represents a vSplitButton control
Public class | vSplitContainer | Represents a control consisting of a movable bar that divides a container's display area into two resizable panels.
Public class | vSplitterPanel |
Public class | vStripsRenderer | Represents a vStripsRenderer component
Public class | vTabCancelEventArgs | Represents a tab control cancel event arguments
Public class | vTabControl |
Public class | vTabEventArgs | Represent a vTabControl event arguments for drag and drop operations.
Public class | vTabPage | Represents a tab page in the vTabControl
Public class | vTextBox | Represents a vTextBox control which
Public class | vToggleButton | Represents a vToggleButton control
Public class | vToggleCircularButton |
Public class | vToolStripDropDown |
Public class | vToolTip | Represents a vTooltip control.
Public class | vTrackBar | Represents a vTrackBar control.
Public class | vTreeNode | Represents a tree node in a vTreeView control.
Public class | vTreeNodeCollection | Represents a collection of tree nodes.
Public class | vTreeNodeLabelEditEventArgs | Represents a vTreeNode label edit event arguments
Public class | vTreeView | Represents a vTreeView control
Public class | vTreeViewBox | Represents a vTreeViewBox control.
Public class | vTreeViewCancelEventArgs | Represents a vTreeView cancel event arguments
Public class | vTreeViewDragCancelEventArgs | Represents vTreeView drag and drop cancel event arguments
Public class | vTreeViewDragEventArgs | Represents vTreeView drag and drop event arguments
Public class | vTreeViewEventArgs | Represents vTreeView event arguments
Public class | vTreeViewLayoutEventArgs |
Public class | vTreeViewMouseEventArgs |
Public class | vVerticalLayoutPanel | Represents a vVerticalLayoutPanel control where the user can arrange multiple controls.
Public class | vVScrollBar | Represents a vertical scroll bar control
Public class | WeekPattern |
Public class | WindowsAPI |
Public class | YearPattern |
Public class | YearPatternConverter |

Structures

 | Structure | Description
Public structure | RECT |
Public structure | vForm..::..MARGINS |
Public structure | vForm..::..NCCALCSIZE_PARAMS |
Public structure | vForm..::..RECT |
Public structure | WindowsAPI..::..NCCALCSIZE_PARAMS | The NCCALCSIZE_PARAMS structure contains information that an application can use while processing the WM_NCCALCSIZE message to calculate the size, position, and valid contents of the client area of a window.
Public structure | WindowsAPI..::..RECT | Describes the width, height, and location of a rectangle.

Interfaces

 | Interface | Description
Public interface | IDateTimeEditor | Base Class For All Editors

Delegates

 | Delegate | Description
Public delegate | CalendarPaintHandler |
Public delegate | ValueChangedEditorEventHandler | Represents a ValueChangedEditor delegate.
Public delegate | ValueChangingEditorEventHandler | Represents a ValueChangingEditor.
Public delegate | vColorPicker..::..ColorStringFormatEventHandler |
Public delegate | vTabControl..::..DragCancelEventHandler |
Public delegate | vTabControl..::..DragEventHandler |
Public delegate | vTabControl..::..vTabCancelEventHandler |
Public delegate | vTreeViewCancelEventHandler |
Public delegate | vTreeViewDragCancelEventHandler |
Public delegate | vTreeViewDragEventHandler |
Public delegate | vTreeViewEventHandler |
Public delegate | vTreeViewLabelEditEventHandler |
Public delegate | vTreeViewMouseEventHandler |

Enumerations

 | Enumeration | Description
Public enumeration | BubbleBarPosition |
Public enumeration | ButtonBorderStyle | Enumeration of the Button border styles
Public enumeration | ButtonDefaultColorSchemes |
Public enumeration | DateTimeItemType | Enumaration of the DateTime item types
Public enumeration | DayNameFormat |
Public enumeration | EdgeBehaviorEnum |
Public enumeration | EditorStateType |
Public enumeration | GlassFormUtility..::..NonClientHitTestResult | Possible results of a hit test on the non client area of a form
Public enumeration | GlobalHook..::..HookTypes | Types of available hooks
Public enumeration | InsertType |
Public enumeration | LabelItemStyle | Enumaration of the vLabel styles
Public enumeration | LineState | Represents a LineState enum.
Public enumeration | RecurrenceRule |
Public enumeration | RibbonStyle | Enumeration of the vRubbonBar styles
Public enumeration | SizeUnitType |
Public enumeration | SizingDirection | Enumeration of the Drop-down controls resize flags
Public enumeration | SpinType | Represents spin type enumeration.
Public enumeration | StartDayOfWeek |
Public enumeration | TabsShape | Enumeration of the tab shapes
Public enumeration | vCalendarView |
Public enumeration | vFormButtonType |
Public enumeration | vProgressBar..::..vProgressBarFillStyle | Enumeration of the vProgressBar fill styles
Public enumeration | vRatingControlShapes | Enumaration of the rating control shape types
Public enumeration | vTabPageAlignment | Enumerates the tab pages' alignment
Public enumeration | vTabPageTextOrientation | Enumerates the tab pages' text orientation
Public enumeration | vTreeViewAction | Enumerates the vTreeView actions


BubbleBarPosition Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
BubbleBarPosition Enumeration
See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum BubbleBarPosition
Visual Basic
Public Enumeration BubbleBarPosition
Visual C++
public enum class BubbleBarPosition

Members

Member name | Description
Near |
Center |
Far |

See Also

VIBlend.WinForms.Controls Namespace


ButtonBorderStyle Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
ButtonBorderStyle Enumeration
See Also Send Feedback
Enumeration of the Button border styles

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum ButtonBorderStyle
Visual Basic
Public Enumeration ButtonBorderStyle
Visual C++
public enum class ButtonBorderStyle

Members

Member name | Description
SOLID |
NONE |

See Also


ButtonDefaultColorSchemes Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
ButtonDefaultColorSchemes Enumeration
See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum ButtonDefaultColorSchemes
Visual Basic
Public Enumeration ButtonDefaultColorSchemes
Visual C++
public enum class ButtonDefaultColorSchemes

Members

Member name | Description
Blue |
Green |
Orange |

See Also


CalendarPaintEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
CalendarPaintEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class CalendarPaintEventArgs
Visual Basic
Public Class CalendarPaintEventArgs
Visual C++
public ref class CalendarPaintEventArgs

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..CalendarPaintEventArgs

See Also

CalendarPaintEventArgs Members


CalendarPaintEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
CalendarPaintEventArgs Members
CalendarPaintEventArgs Class Constructors Methods Properties See Also Send Feedback

The CalendarPaintEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CalendarPaintEventArgs | Initializes a new instance of the CalendarPaintEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bounds | Gets the bounds.
Public property | Calendar |
Public property | CurrentDate | Gets the current date.
Public property | Graphics | Gets the graphics.

See Also

CalendarPaintEventArgs Class


CalendarPaintEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
CalendarPaintEventArgs Constructor
CalendarPaintEventArgs Class See Also Send Feedback
Initializes a new instance of the CalendarPaintEventArgs class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CalendarPaintEventArgs(
    vMonthCalendar calendar,
    Graphics graphics,
    DateTime currentDate,
    Rectangle bounds
)
Visual Basic
Public Sub New ( _
    calendar As vMonthCalendar, _
    graphics As Graphics, _
    currentDate As DateTime, _
    bounds As Rectangle _
)
Visual C++
public:
CalendarPaintEventArgs(
    vMonthCalendar^ calendar,
    Graphics^ graphics,
    DateTime currentDate,
    Rectangle bounds
)

Parameters

calendar
Type: VIBlend.WinForms.Controls..::..vMonthCalendar
graphics
Type: System.Drawing..::..Graphics
The graphics.
currentDate
Type: System..::..DateTime
The current date.
bounds
Type: System.Drawing..::..Rectangle
The bounds.

See Also

CalendarPaintEventArgs Class


CalendarPaintEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
CalendarPaintEventArgs Methods
CalendarPaintEventArgs Class See Also Send Feedback

The CalendarPaintEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CalendarPaintEventArgs Class


CalendarPaintEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
CalendarPaintEventArgs Properties
CalendarPaintEventArgs Class See Also Send Feedback

The CalendarPaintEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Bounds | Gets the bounds.
Public property | Calendar |
Public property | CurrentDate | Gets the current date.
Public property | Graphics | Gets the graphics.

See Also

CalendarPaintEventArgs Class


Bounds Property

[image]

VIBlend Controls for WinForms Help Documentation
CalendarPaintEventArgs..::..Bounds Property
CalendarPaintEventArgs Class See Also Send Feedback
Gets the bounds.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle Bounds { get; }
Visual Basic
Public ReadOnly Property Bounds As Rectangle
    Get
Visual C++
public:
property Rectangle Bounds {
    Rectangle get ();
}

Field Value

The bounds.

See Also

CalendarPaintEventArgs Class


Calendar Property

[image]

VIBlend Controls for WinForms Help Documentation
CalendarPaintEventArgs..::..Calendar Property
CalendarPaintEventArgs Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vMonthCalendar Calendar { get; }
Visual Basic
Public ReadOnly Property Calendar As vMonthCalendar
    Get
Visual C++
public:
property vMonthCalendar^ Calendar {
    vMonthCalendar^ get ();
}

See Also

CalendarPaintEventArgs Class


CurrentDate Property

[image]

VIBlend Controls for WinForms Help Documentation
CalendarPaintEventArgs..::..CurrentDate Property
CalendarPaintEventArgs Class See Also Send Feedback
Gets the current date.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime CurrentDate { get; }
Visual Basic
Public ReadOnly Property CurrentDate As DateTime
    Get
Visual C++
public:
property DateTime CurrentDate {
    DateTime get ();
}

Field Value

The current date.

See Also

CalendarPaintEventArgs Class


Graphics Property

[image]

VIBlend Controls for WinForms Help Documentation
CalendarPaintEventArgs..::..Graphics Property
CalendarPaintEventArgs Class See Also Send Feedback
Gets the graphics.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Graphics Graphics { get; }
Visual Basic
Public ReadOnly Property Graphics As Graphics
    Get
Visual C++
public:
property Graphics^ Graphics {
    Graphics^ get ();
}

Field Value

The graphics.

See Also

CalendarPaintEventArgs Class


CalendarPaintHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
CalendarPaintHandler Delegate
See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void CalendarPaintHandler(
    Object sender,
    CalendarPaintEventArgs e
)
Visual Basic
Public Delegate Sub CalendarPaintHandler ( _
    sender As Object, _
    e As CalendarPaintEventArgs _
)
Visual C++
public delegate void CalendarPaintHandler(
    Object^ sender,
    CalendarPaintEventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: VIBlend.WinForms.Controls..::..CalendarPaintEventArgs

See Also


ColorPickerPanel Class

[image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel Class
Members See Also Send Feedback
Represents a ColorPicker panel control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class ColorPickerPanel : Panel
Visual Basic
Public Class ColorPickerPanel _
    Inherits Panel
Visual C++
public ref class ColorPickerPanel : public Panel

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..Panel
VIBlend.WinForms.Controls..::..ColorPickerPanel

See Also

ColorPickerPanel Members


ColorPickerPanel Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel Members
ColorPickerPanel Class Constructors Methods Properties Events See Also Send Feedback

The ColorPickerPanel type exposes the following members.

Constructors

 | Name | Description
Public method | ColorPickerPanel | Initializes a new instance of the ColorPickerPanel class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ScrollableControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedColor |
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SelectedColorChanged | Occurs when a color is changed.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ColorPickerPanel Class


ColorPickerPanel Constructor

[image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel Constructor
ColorPickerPanel Class See Also Send Feedback
Initializes a new instance of the ColorPickerPanel class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ColorPickerPanel()
Visual Basic
Public Sub New
Visual C++
public:
ColorPickerPanel()

See Also

ColorPickerPanel Class


ColorPickerPanel Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel Methods
ColorPickerPanel Class See Also Send Feedback

The ColorPickerPanel type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ScrollableControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

See Also

ColorPickerPanel Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..AccessibilityNotifyClients Method
ColorPickerPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ColorPickerPanel Class
ColorPickerPanel Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..BeginInvoke Method
ColorPickerPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ColorPickerPanel Class
ColorPickerPanel Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..Dispose Method
ColorPickerPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

ColorPickerPanel Class
ColorPickerPanel Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..GetChildAtPoint Method
ColorPickerPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ColorPickerPanel Class
ColorPickerPanel Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..Invalidate Method
ColorPickerPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ColorPickerPanel Class
ColorPickerPanel Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..Invoke Method
ColorPickerPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ColorPickerPanel Class
ColorPickerPanel Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..MemberwiseClone Method
ColorPickerPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ColorPickerPanel Class
ColorPickerPanel Members


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..OnPaint Method
ColorPickerPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

ColorPickerPanel Class


OnSizeChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..OnSizeChanged Method
ColorPickerPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnSizeChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnSizeChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSizeChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

ColorPickerPanel Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..PerformLayout Method
ColorPickerPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ColorPickerPanel Class
ColorPickerPanel Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..ResumeLayout Method
ColorPickerPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ColorPickerPanel Class
ColorPickerPanel Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..RtlTranslateAlignment Method
ColorPickerPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ColorPickerPanel Class
ColorPickerPanel Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..Scale Method
ColorPickerPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ColorPickerPanel Class
ColorPickerPanel Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..Select Method
ColorPickerPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

ColorPickerPanel Class
ColorPickerPanel Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..SetBounds Method
ColorPickerPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ColorPickerPanel Class
ColorPickerPanel Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..UpdateBounds Method
ColorPickerPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ColorPickerPanel Class
ColorPickerPanel Members


ColorPickerPanel Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel Properties
ColorPickerPanel Class See Also Send Feedback

The ColorPickerPanel type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedColor |
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

ColorPickerPanel Class


SelectedColor Property

[image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..SelectedColor Property
ColorPickerPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color SelectedColor { get; set; }
Visual Basic
Public Property SelectedColor As Color
    Get
    Set
Visual C++
public:
property Color SelectedColor {
    Color get ();
    void set (Color value);
}

See Also

ColorPickerPanel Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..Theme Property
ColorPickerPanel Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

ColorPickerPanel Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..VIBlendTheme Property
ColorPickerPanel Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

ColorPickerPanel Class


ColorPickerPanel Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel Events
ColorPickerPanel Class See Also Send Feedback

The ColorPickerPanel type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SelectedColorChanged | Occurs when a color is changed.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ColorPickerPanel Class


SelectedColorChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
ColorPickerPanel..::..SelectedColorChanged Event
ColorPickerPanel Class See Also Send Feedback
Occurs when a color is changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler SelectedColorChanged
Visual Basic
Public Event SelectedColorChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectedColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ColorPickerPanel Class


ColorStringFormatEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
ColorStringFormatEventArgs Class
Members See Also Send Feedback
Represents a color text formatting event arguments

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class ColorStringFormatEventArgs
Visual Basic
Public Class ColorStringFormatEventArgs
Visual C++
public ref class ColorStringFormatEventArgs

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..ColorStringFormatEventArgs

See Also

ColorStringFormatEventArgs Members


ColorStringFormatEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorStringFormatEventArgs Members
ColorStringFormatEventArgs Class Constructors Methods Properties See Also Send Feedback

The ColorStringFormatEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ColorStringFormatEventArgs | Initializes a new instance of the ColorStringFormatEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color | Gets the color being formatted
Public property | FormattedText | Gets or sets the formatted text that represents the color

See Also

ColorStringFormatEventArgs Class


ColorStringFormatEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
ColorStringFormatEventArgs Constructor
ColorStringFormatEventArgs Class See Also Send Feedback
Initializes a new instance of the ColorStringFormatEventArgs class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ColorStringFormatEventArgs(
    Color Color,
    string FormattedText
)
Visual Basic
Public Sub New ( _
    Color As Color, _
    FormattedText As String _
)
Visual C++
public:
ColorStringFormatEventArgs(
    Color Color,
    String^ FormattedText
)

Parameters

Color
Type: System.Drawing..::..Color
FormattedText
Type: System..::..String

See Also

ColorStringFormatEventArgs Class


ColorStringFormatEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorStringFormatEventArgs Methods
ColorStringFormatEventArgs Class See Also Send Feedback

The ColorStringFormatEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorStringFormatEventArgs Class


ColorStringFormatEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColorStringFormatEventArgs Properties
ColorStringFormatEventArgs Class See Also Send Feedback

The ColorStringFormatEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Color | Gets the color being formatted
Public property | FormattedText | Gets or sets the formatted text that represents the color

See Also

ColorStringFormatEventArgs Class


Color Property

[image]

VIBlend Controls for WinForms Help Documentation
ColorStringFormatEventArgs..::..Color Property
ColorStringFormatEventArgs Class See Also Send Feedback
Gets the color being formatted

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color Color { get; internal set; }
Visual Basic
Public Property Color As Color
    Get
    Friend Set
Visual C++
public:
property Color Color {
    Color get ();
    internal: void set (Color value);
}

See Also

ColorStringFormatEventArgs Class


FormattedText Property

[image]

VIBlend Controls for WinForms Help Documentation
ColorStringFormatEventArgs..::..FormattedText Property
ColorStringFormatEventArgs Class See Also Send Feedback
Gets or sets the formatted text that represents the color

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string FormattedText { get; set; }
Visual Basic
Public Property FormattedText As String
    Get
    Set
Visual C++
public:
property String^ FormattedText {
    String^ get ();
    void set (String^ value);
}

See Also

ColorStringFormatEventArgs Class


DateCancelEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
DateCancelEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class DateCancelEventArgs : CancelEventArgs
Visual Basic
Public Class DateCancelEventArgs _
    Inherits CancelEventArgs
Visual C++
public ref class DateCancelEventArgs : public CancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
VIBlend.WinForms.Controls..::..DateCancelEventArgs

See Also

DateCancelEventArgs Members


DateCancelEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateCancelEventArgs Members
DateCancelEventArgs Class Constructors Methods Properties See Also Send Feedback

The DateCancelEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DateCancelEventArgs | Initializes a new instance of the DateCancelEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | NewDate | Gets the new selected date.
Public property | OldDate | Gets the old selected date.

See Also

DateCancelEventArgs Class


DateCancelEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
DateCancelEventArgs Constructor
DateCancelEventArgs Class See Also Send Feedback
Initializes a new instance of the DateCancelEventArgs class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateCancelEventArgs(
    Nullable<DateTime> oldDate,
    Nullable<DateTime> newDate
)
Visual Basic
Public Sub New ( _
    oldDate As Nullable(Of DateTime), _
    newDate As Nullable(Of DateTime) _
)
Visual C++
public:
DateCancelEventArgs(
    Nullable<DateTime> oldDate,
    Nullable<DateTime> newDate
)

Parameters

oldDate
Type: System..::..Nullable <(Of <(<' DateTime >)>)>
newDate
Type: System..::..Nullable <(Of <(<' DateTime >)>)>

See Also

DateCancelEventArgs Class


DateCancelEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateCancelEventArgs Methods
DateCancelEventArgs Class See Also Send Feedback

The DateCancelEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateCancelEventArgs Class


DateCancelEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateCancelEventArgs Properties
DateCancelEventArgs Class See Also Send Feedback

The DateCancelEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | NewDate | Gets the new selected date.
Public property | OldDate | Gets the old selected date.

See Also

DateCancelEventArgs Class


NewDate Property

[image]

VIBlend Controls for WinForms Help Documentation
DateCancelEventArgs..::..NewDate Property
DateCancelEventArgs Class See Also Send Feedback
Gets the new selected date.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Nullable<DateTime> NewDate { get; }
Visual Basic
Public ReadOnly Property NewDate As Nullable(Of DateTime)
    Get
Visual C++
public:
property Nullable<DateTime> NewDate {
    Nullable<DateTime> get ();
}

See Also

DateCancelEventArgs Class


OldDate Property

[image]

VIBlend Controls for WinForms Help Documentation
DateCancelEventArgs..::..OldDate Property
DateCancelEventArgs Class See Also Send Feedback
Gets the old selected date.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Nullable<DateTime> OldDate { get; }
Visual Basic
Public ReadOnly Property OldDate As Nullable(Of DateTime)
    Get
Visual C++
public:
property Nullable<DateTime> OldDate {
    Nullable<DateTime> get ();
}

See Also

DateCancelEventArgs Class


DateTimeEditorFormatItem Class

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeEditorFormatItem Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class DateTimeEditorFormatItem
Visual Basic
Public Class DateTimeEditorFormatItem
Visual C++
public ref class DateTimeEditorFormatItem

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..DateTimeEditorFormatItem

See Also

DateTimeEditorFormatItem Members


DateTimeEditorFormatItem Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimeEditorFormatItem Members
DateTimeEditorFormatItem Class Constructors Methods Properties See Also Send Feedback

The DateTimeEditorFormatItem type exposes the following members.

Constructors

 | Name | Description
Public method | DateTimeEditorFormatItem | Initializes a new instance of the DateTimeEditorFormatItem class.

Methods

 | Name | Description
Public method | DateParser | Dates the parser.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDateTimeEditorByItemType | Gets the editor.
Public method | GetDateTimeWithOffset | Gets the date time with offset.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DateTimeInfo | Gets the date time info.
Public property | FormatValue | Gets the format value.
Public property | ItemType | Gets the type of the item.
Public property | ItemValue | Gets the item value.
Public property | MaximumValue | Gets the maximum value.

See Also

DateTimeEditorFormatItem Class


DateTimeEditorFormatItem Constructor

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeEditorFormatItem Constructor
DateTimeEditorFormatItem Class See Also Send Feedback
Initializes a new instance of the DateTimeEditorFormatItem class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTimeEditorFormatItem(
    string formatValue,
    DateTimeFormatInfo info,
    DateTimeItemType type
)
Visual Basic
Public Sub New ( _
    formatValue As String, _
    info As DateTimeFormatInfo, _
    type As DateTimeItemType _
)
Visual C++
public:
DateTimeEditorFormatItem(
    String^ formatValue,
    DateTimeFormatInfo^ info,
    DateTimeItemType type
)

Parameters

formatValue
Type: System..::..String
The format value.
info
Type: System.Globalization..::..DateTimeFormatInfo
The info.
type
Type: VIBlend.WinForms.Controls..::..DateTimeItemType
The type.

See Also

DateTimeEditorFormatItem Class


DateTimeEditorFormatItem Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimeEditorFormatItem Methods
DateTimeEditorFormatItem Class See Also Send Feedback

The DateTimeEditorFormatItem type exposes the following members.

Methods

 | Name | Description
Public method | DateParser | Dates the parser.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDateTimeEditorByItemType | Gets the editor.
Public method | GetDateTimeWithOffset | Gets the date time with offset.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeEditorFormatItem Class


DateParser Method

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeEditorFormatItem..::..DateParser Method
DateTimeEditorFormatItem Class See Also Send Feedback
Dates the parser.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string DateParser(
    Nullable<DateTime> formattedDateTime
)
Visual Basic
Public Function DateParser ( _
    formattedDateTime As Nullable(Of DateTime) _
) As String
Visual C++
public:
String^ DateParser(
    Nullable<DateTime> formattedDateTime
)

Parameters

formattedDateTime
Type: System..::..Nullable <(Of <(<' DateTime >)>)>
The formatted date time.

Return Value

See Also

DateTimeEditorFormatItem Class


GetDateTimeEditorByItemType Method

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeEditorFormatItem..::..GetDateTimeEditorByItemType Method
DateTimeEditorFormatItem Class See Also Send Feedback
Gets the editor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public IDateTimeEditor GetDateTimeEditorByItemType(
    DateTime value
)
Visual Basic
Public Function GetDateTimeEditorByItemType ( _
    value As DateTime _
) As IDateTimeEditor
Visual C++
public:
IDateTimeEditor^ GetDateTimeEditorByItemType(
    DateTime value
)

Parameters

value
Type: System..::..DateTime
The value.

Return Value

See Also

DateTimeEditorFormatItem Class


GetDateTimeWithOffset Method

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeEditorFormatItem..::..GetDateTimeWithOffset Method
DateTimeEditorFormatItem Class See Also Send Feedback
Gets the date time with offset.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime GetDateTimeWithOffset(
    int offset,
    DateTime value
)
Visual Basic
Public Function GetDateTimeWithOffset ( _
    offset As Integer, _
    value As DateTime _
) As DateTime
Visual C++
public:
DateTime GetDateTimeWithOffset(
    int offset,
    DateTime value
)

Parameters

offset
Type: System..::..Int32
The offset.
value
Type: System..::..DateTime
The value.

Return Value

See Also

DateTimeEditorFormatItem Class


DateTimeEditorFormatItem Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimeEditorFormatItem Properties
DateTimeEditorFormatItem Class See Also Send Feedback

The DateTimeEditorFormatItem type exposes the following members.

Properties

 | Name | Description
Public property | DateTimeInfo | Gets the date time info.
Public property | FormatValue | Gets the format value.
Public property | ItemType | Gets the type of the item.
Public property | ItemValue | Gets the item value.
Public property | MaximumValue | Gets the maximum value.

See Also

DateTimeEditorFormatItem Class


DateTimeInfo Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeEditorFormatItem..::..DateTimeInfo Property
DateTimeEditorFormatItem Class See Also Send Feedback
Gets the date time info.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTimeFormatInfo DateTimeInfo { get; }
Visual Basic
Public ReadOnly Property DateTimeInfo As DateTimeFormatInfo
    Get
Visual C++
public:
property DateTimeFormatInfo^ DateTimeInfo {
    DateTimeFormatInfo^ get ();
}

Field Value

The date time info.

See Also

DateTimeEditorFormatItem Class


FormatValue Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeEditorFormatItem..::..FormatValue Property
DateTimeEditorFormatItem Class See Also Send Feedback
Gets the format value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string FormatValue { get; }
Visual Basic
Public ReadOnly Property FormatValue As String
    Get
Visual C++
public:
property String^ FormatValue {
    String^ get ();
}

Field Value

The format value.

See Also

DateTimeEditorFormatItem Class


ItemType Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeEditorFormatItem..::..ItemType Property
DateTimeEditorFormatItem Class See Also Send Feedback
Gets the type of the item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTimeItemType ItemType { get; }
Visual Basic
Public ReadOnly Property ItemType As DateTimeItemType
    Get
Visual C++
public:
property DateTimeItemType ItemType {
    DateTimeItemType get ();
}

Field Value

The type of the item.

See Also

DateTimeEditorFormatItem Class


ItemValue Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeEditorFormatItem..::..ItemValue Property
DateTimeEditorFormatItem Class See Also Send Feedback
Gets the item value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ItemValue { get; }
Visual Basic
Public ReadOnly Property ItemValue As Integer
    Get
Visual C++
public:
property int ItemValue {
    int get ();
}

Field Value

The item value.

See Also

DateTimeEditorFormatItem Class


MaximumValue Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeEditorFormatItem..::..MaximumValue Property
DateTimeEditorFormatItem Class See Also Send Feedback
Gets the maximum value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int MaximumValue { get; }
Visual Basic
Public ReadOnly Property MaximumValue As Integer
    Get
Visual C++
public:
property int MaximumValue {
    int get ();
}

Field Value

The maximum value.

See Also

DateTimeEditorFormatItem Class


DateTimeFormatBaseEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class DateTimeFormatBaseEditor : IDateTimeEditor
Visual Basic
Public Class DateTimeFormatBaseEditor _
    Implements IDateTimeEditor
Visual C++
public ref class DateTimeFormatBaseEditor : IDateTimeEditor

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..DateTimeFormatBaseEditor
VIBlend.WinForms.Controls..::..DateTimeFormatDayMonthYearEditor

See Also

DateTimeFormatBaseEditor Members


DateTimeFormatBaseEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor Members
DateTimeFormatBaseEditor Class Constructors Methods Fields Properties See Also Send Feedback

The DateTimeFormatBaseEditor type exposes the following members.

Constructors

 | Name | Description
Public method | DateTimeFormatBaseEditor(Int64, Int64, Int64, Int64, DateTimeEditorFormatItem) | Initializes a new instance of the DateTimeFormatBaseEditor class.
Public method | DateTimeFormatBaseEditor(Int64, Int64, Int64, Int64, Int64, DateTimeEditorFormatItem) | Initializes a new instance of the DateTimeFormatBaseEditor class.

Methods

 | Name | Description
Public method | Delete | Deletes this instance.
Public method | Down | Downs this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDateTimeItem |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTextValue | Gets the text.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertString | Inserts the specified insered value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Up | Ups this instance.
Protected method | UpdateActiveEditor | Updates the current value

Fields

 | Name | Description
Protected field | positions |

Properties

 | Name | Description
Protected property | HasDigits |
Public property | MaximumValue | Gets the max available value
Public property | MaxPositions | Gets the maximum amount of digits
Public property | MinimumValue | Gets the min available value
Public property | MinPositions | Gets the minimum amount of digits
Public property | TextValue | Updates editor's text
Public property | Value | Gets or sets the current value

See Also

DateTimeFormatBaseEditor Class


DateTimeFormatBaseEditor Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor Constructor
DateTimeFormatBaseEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DateTimeFormatBaseEditor(Int64, Int64, Int64, Int64, DateTimeEditorFormatItem) | Initializes a new instance of the DateTimeFormatBaseEditor class.
Public method | DateTimeFormatBaseEditor(Int64, Int64, Int64, Int64, Int64, DateTimeEditorFormatItem) | Initializes a new instance of the DateTimeFormatBaseEditor class.

See Also

DateTimeFormatBaseEditor Class
DateTimeFormatBaseEditor Members


DateTimeFormatBaseEditor Constructor (Int64, Int64, Int64, Int64, DateTimeEditorFormatItem)

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor Constructor (Int64, Int64, Int64, Int64, DateTimeEditorFormatItem)
DateTimeFormatBaseEditor Class See Also Send Feedback
Initializes a new instance of the DateTimeFormatBaseEditor class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTimeFormatBaseEditor(
    long minValue,
    long maxValue,
    long minEditPositions,
    long maxEditPositions,
    DateTimeEditorFormatItem item
)
Visual Basic
Public Sub New ( _
    minValue As Long, _
    maxValue As Long, _
    minEditPositions As Long, _
    maxEditPositions As Long, _
    item As DateTimeEditorFormatItem _
)
Visual C++
public:
DateTimeFormatBaseEditor(
    long long minValue,
    long long maxValue,
    long long minEditPositions,
    long long maxEditPositions,
    DateTimeEditorFormatItem^ item
)

Parameters

minValue
Type: System..::..Int64
The min value.
maxValue
Type: System..::..Int64
The max value.
minEditPositions
Type: System..::..Int64
The min edit positions.
maxEditPositions
Type: System..::..Int64
The max edit positions.
item
Type: VIBlend.WinForms.Controls..::..DateTimeEditorFormatItem
The item.

See Also

DateTimeFormatBaseEditor Class
DateTimeFormatBaseEditor Overload


DateTimeFormatBaseEditor Constructor (Int64, Int64, Int64, Int64, Int64, DateTimeEditorFormatItem)

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor Constructor (Int64, Int64, Int64, Int64, Int64, DateTimeEditorFormatItem)
DateTimeFormatBaseEditor Class See Also Send Feedback
Initializes a new instance of the DateTimeFormatBaseEditor class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTimeFormatBaseEditor(
    long initialValue,
    long minValue,
    long maxValue,
    long minEditPositions,
    long maxEditPositions,
    DateTimeEditorFormatItem item
)
Visual Basic
Public Sub New ( _
    initialValue As Long, _
    minValue As Long, _
    maxValue As Long, _
    minEditPositions As Long, _
    maxEditPositions As Long, _
    item As DateTimeEditorFormatItem _
)
Visual C++
public:
DateTimeFormatBaseEditor(
    long long initialValue,
    long long minValue,
    long long maxValue,
    long long minEditPositions,
    long long maxEditPositions,
    DateTimeEditorFormatItem^ item
)

Parameters

initialValue
Type: System..::..Int64
The initial value.
minValue
Type: System..::..Int64
The min value.
maxValue
Type: System..::..Int64
The max value.
minEditPositions
Type: System..::..Int64
The min edit positions.
maxEditPositions
Type: System..::..Int64
The max edit positions.
item
Type: VIBlend.WinForms.Controls..::..DateTimeEditorFormatItem
The item.

See Also

DateTimeFormatBaseEditor Class
DateTimeFormatBaseEditor Overload


DateTimeFormatBaseEditor Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor Fields
DateTimeFormatBaseEditor Class See Also Send Feedback

The DateTimeFormatBaseEditor type exposes the following members.

Fields

 | Name | Description
Protected field | positions |

See Also

DateTimeFormatBaseEditor Class


positions Field

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor..::..positions Field
DateTimeFormatBaseEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal long positions
Visual Basic
Protected Friend positions As Long
Visual C++
protected public:
long long positions

See Also

DateTimeFormatBaseEditor Class


DateTimeFormatBaseEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor Methods
DateTimeFormatBaseEditor Class See Also Send Feedback

The DateTimeFormatBaseEditor type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Deletes this instance.
Public method | Down | Downs this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDateTimeItem |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTextValue | Gets the text.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertString | Inserts the specified insered value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Up | Ups this instance.
Protected method | UpdateActiveEditor | Updates the current value

See Also

DateTimeFormatBaseEditor Class


Delete Method

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor..::..Delete Method
DateTimeFormatBaseEditor Class See Also Send Feedback
Deletes this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Delete()
Visual Basic
Public Function Delete As Boolean
Visual C++
public:
bool Delete()

Return Value

See Also

DateTimeFormatBaseEditor Class


Down Method

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor..::..Down Method
DateTimeFormatBaseEditor Class See Also Send Feedback
Downs this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Down()
Visual Basic
Public Function Down As Boolean
Visual C++
public:
virtual bool Down() sealed

Return Value

Implements

IDateTimeEditor..::..Down()()()()

See Also

DateTimeFormatBaseEditor Class


GetDateTimeItem Method

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor..::..GetDateTimeItem Method
DateTimeFormatBaseEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTimeEditorFormatItem GetDateTimeItem()
Visual Basic
Public Function GetDateTimeItem As DateTimeEditorFormatItem
Visual C++
public:
virtual DateTimeEditorFormatItem^ GetDateTimeItem() sealed

Implements

IDateTimeEditor..::..GetDateTimeItem()()()()

See Also

DateTimeFormatBaseEditor Class


GetTextValue Method

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor..::..GetTextValue Method
DateTimeFormatBaseEditor Class See Also Send Feedback
Gets the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public long GetTextValue()
Visual Basic
Public Function GetTextValue As Long
Visual C++
public:
virtual long long GetTextValue() sealed

Return Value

Implements

IDateTimeEditor..::..GetTextValue()()()()

See Also

DateTimeFormatBaseEditor Class


InsertString Method

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor..::..InsertString Method
DateTimeFormatBaseEditor Class See Also Send Feedback
Inserts the specified insered value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool InsertString(
    string inseredValue
)
Visual Basic
Public Function InsertString ( _
    inseredValue As String _
) As Boolean
Visual C++
public:
virtual bool InsertString(
    String^ inseredValue
) sealed

Parameters

inseredValue
Type: System..::..String
The insered value.

Return Value

Implements

IDateTimeEditor..::..InsertString(String)

See Also

DateTimeFormatBaseEditor Class


Up Method

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor..::..Up Method
DateTimeFormatBaseEditor Class See Also Send Feedback
Ups this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Up()
Visual Basic
Public Function Up As Boolean
Visual C++
public:
virtual bool Up() sealed

Return Value

Implements

IDateTimeEditor..::..Up()()()()

See Also

DateTimeFormatBaseEditor Class


UpdateActiveEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor..::..UpdateActiveEditor Method
DateTimeFormatBaseEditor Class See Also Send Feedback
Updates the current value

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected void UpdateActiveEditor(
    long newValue
)
Visual Basic
Protected Sub UpdateActiveEditor ( _
    newValue As Long _
)
Visual C++
protected:
void UpdateActiveEditor(
    long long newValue
)

Parameters

newValue
Type: System..::..Int64

See Also

DateTimeFormatBaseEditor Class


DateTimeFormatBaseEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor Properties
DateTimeFormatBaseEditor Class See Also Send Feedback

The DateTimeFormatBaseEditor type exposes the following members.

Properties

 | Name | Description
Protected property | HasDigits |
Public property | MaximumValue | Gets the max available value
Public property | MaxPositions | Gets the maximum amount of digits
Public property | MinimumValue | Gets the min available value
Public property | MinPositions | Gets the minimum amount of digits
Public property | TextValue | Updates editor's text
Public property | Value | Gets or sets the current value

See Also

DateTimeFormatBaseEditor Class


HasDigits Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor..::..HasDigits Property
DateTimeFormatBaseEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected bool HasDigits { get; }
Visual Basic
Protected ReadOnly Property HasDigits As Boolean
    Get
Visual C++
protected:
property bool HasDigits {
    bool get ();
}

See Also

DateTimeFormatBaseEditor Class


MaximumValue Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor..::..MaximumValue Property
DateTimeFormatBaseEditor Class See Also Send Feedback
Gets the max available value

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public long MaximumValue { get; set; }
Visual Basic
Public Property MaximumValue As Long
    Get
    Set
Visual C++
public:
property long long MaximumValue {
    long long get ();
    void set (long long value);
}

See Also

DateTimeFormatBaseEditor Class


MaxPositions Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor..::..MaxPositions Property
DateTimeFormatBaseEditor Class See Also Send Feedback
Gets the maximum amount of digits

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public long MaxPositions { get; }
Visual Basic
Public ReadOnly Property MaxPositions As Long
    Get
Visual C++
public:
property long long MaxPositions {
    long long get ();
}

See Also

DateTimeFormatBaseEditor Class


MinimumValue Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor..::..MinimumValue Property
DateTimeFormatBaseEditor Class See Also Send Feedback
Gets the min available value

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public long MinimumValue { get; set; }
Visual Basic
Public Property MinimumValue As Long
    Get
    Set
Visual C++
public:
property long long MinimumValue {
    long long get ();
    void set (long long value);
}

See Also

DateTimeFormatBaseEditor Class


MinPositions Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor..::..MinPositions Property
DateTimeFormatBaseEditor Class See Also Send Feedback
Gets the minimum amount of digits

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual long MinPositions { get; }
Visual Basic
Public Overridable ReadOnly Property MinPositions As Long
    Get
Visual C++
public:
virtual property long long MinPositions {
    long long get ();
}

See Also

DateTimeFormatBaseEditor Class


TextValue Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor..::..TextValue Property
DateTimeFormatBaseEditor Class See Also Send Feedback
Updates editor's text

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual string TextValue { get; }
Visual Basic
Public Overridable ReadOnly Property TextValue As String
    Get
Visual C++
public:
virtual property String^ TextValue {
    String^ get ();
}

Implements

IDateTimeEditor..::..TextValue

See Also

DateTimeFormatBaseEditor Class


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatBaseEditor..::..Value Property
DateTimeFormatBaseEditor Class See Also Send Feedback
Gets or sets the current value

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public long Value { get; set; }
Visual Basic
Public Property Value As Long
    Get
    Set
Visual C++
public:
property long long Value {
    long long get ();
    void set (long long value);
}

See Also

DateTimeFormatBaseEditor Class


DateTimeFormatDayMonthYearEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatDayMonthYearEditor Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class DateTimeFormatDayMonthYearEditor : DateTimeFormatBaseEditor
Visual Basic
Public Class DateTimeFormatDayMonthYearEditor _
    Inherits DateTimeFormatBaseEditor
Visual C++
public ref class DateTimeFormatDayMonthYearEditor : public DateTimeFormatBaseEditor

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..DateTimeFormatBaseEditor
VIBlend.WinForms.Controls..::..DateTimeFormatDayMonthYearEditor

See Also

DateTimeFormatDayMonthYearEditor Members


DateTimeFormatDayMonthYearEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatDayMonthYearEditor Members
DateTimeFormatDayMonthYearEditor Class Constructors Methods Fields Properties See Also Send Feedback

The DateTimeFormatDayMonthYearEditor type exposes the following members.

Constructors

 | Name | Description
Public method | DateTimeFormatDayMonthYearEditor(Int32, Int32, DateTimeFormatInfo, DateTimeEditorFormatItem, Boolean) | Initializes a new instance of the DateTimeFormatDayMonthYearEditor class.
Public method | DateTimeFormatDayMonthYearEditor(Int32, Int32, array<String>[]()[][], DateTimeEditorFormatItem, Boolean) |
Public method | DateTimeFormatDayMonthYearEditor(Object, Int32, Int32, Int32, Int32, Int32, array<String>[]()[][], DateTimeEditorFormatItem, Boolean) | Initializes a new instance of the DateTimeFormatDayMonthYearEditor class.

Methods

 | Name | Description
Public method | Delete | Deletes this instance. (Inherited from DateTimeFormatBaseEditor.)
Public method | Down | Downs this instance. (Inherited from DateTimeFormatBaseEditor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDateTimeItem | (Inherited from DateTimeFormatBaseEditor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTextValue | Gets the text. (Inherited from DateTimeFormatBaseEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Inserts the specified input.
Public method | InsertString | Inserts the specified insered value. (Inherited from DateTimeFormatBaseEditor.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Up | Ups this instance. (Inherited from DateTimeFormatBaseEditor.)
Protected method | UpdateActiveEditor | Updates the current value (Inherited from DateTimeFormatBaseEditor.)

Fields

 | Name | Description
Protected field | positions | (Inherited from DateTimeFormatBaseEditor.)

Properties

 | Name | Description
Protected property | HasDigits | (Inherited from DateTimeFormatBaseEditor.)
Public property | MaximumValue | Gets the max available value (Inherited from DateTimeFormatBaseEditor.)
Public property | MaxPositions | Gets the maximum amount of digits (Inherited from DateTimeFormatBaseEditor.)
Public property | MinimumValue | Gets the min available value (Inherited from DateTimeFormatBaseEditor.)
Public property | MinPositions | Gets the minimum amount of digits (Overrides DateTimeFormatBaseEditor..::..MinPositions.)
Public property | TextValue | Gets editor's text (Overrides DateTimeFormatBaseEditor..::..TextValue.)
Public property | Value | Gets or sets the current value (Inherited from DateTimeFormatBaseEditor.)

See Also

DateTimeFormatDayMonthYearEditor Class


DateTimeFormatDayMonthYearEditor Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatDayMonthYearEditor Constructor
DateTimeFormatDayMonthYearEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DateTimeFormatDayMonthYearEditor(Int32, Int32, DateTimeFormatInfo, DateTimeEditorFormatItem, Boolean) | Initializes a new instance of the DateTimeFormatDayMonthYearEditor class.
Public method | DateTimeFormatDayMonthYearEditor(Int32, Int32, array<String>[]()[][], DateTimeEditorFormatItem, Boolean) | Initializes a new instance of the DateTimeFormatDayMonthYearEditor class
Public method | DateTimeFormatDayMonthYearEditor(Object, Int32, Int32, Int32, Int32, Int32, array<String>[]()[][], DateTimeEditorFormatItem, Boolean) | Initializes a new instance of the DateTimeFormatDayMonthYearEditor class.

See Also

DateTimeFormatDayMonthYearEditor Class
DateTimeFormatDayMonthYearEditor Members


DateTimeFormatDayMonthYearEditor Constructor (Int32, Int32, DateTimeFormatInfo, DateTimeEditorFormatItem, Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatDayMonthYearEditor Constructor (Int32, Int32, DateTimeFormatInfo, DateTimeEditorFormatItem, Boolean)
DateTimeFormatDayMonthYearEditor Class See Also Send Feedback
Initializes a new instance of the DateTimeFormatDayMonthYearEditor class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTimeFormatDayMonthYearEditor(
    int baseYear,
    int formatValueLength,
    DateTimeFormatInfo info,
    DateTimeEditorFormatItem item,
    bool val
)
Visual Basic
Public Sub New ( _
    baseYear As Integer, _
    formatValueLength As Integer, _
    info As DateTimeFormatInfo, _
    item As DateTimeEditorFormatItem, _
    val As Boolean _
)
Visual C++
public:
DateTimeFormatDayMonthYearEditor(
    int baseYear,
    int formatValueLength,
    DateTimeFormatInfo^ info,
    DateTimeEditorFormatItem^ item,
    bool val
)

Parameters

baseYear
Type: System..::..Int32
The base year.
formatValueLength
Type: System..::..Int32
Length of the format value.
info
Type: System.Globalization..::..DateTimeFormatInfo
The info.
item
Type: VIBlend.WinForms.Controls..::..DateTimeEditorFormatItem
The item.
val
Type: System..::..Boolean
if set to true [val].

See Also

DateTimeFormatDayMonthYearEditor Class
DateTimeFormatDayMonthYearEditor Overload


DateTimeFormatDayMonthYearEditor Constructor (Int32, Int32, String[], DateTimeEditorFormatItem, Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatDayMonthYearEditor Constructor (Int32, Int32, array<String>[]()[][], DateTimeEditorFormatItem, Boolean)
DateTimeFormatDayMonthYearEditor Class See Also Send Feedback
Initializes a new instance of the DateTimeFormatDayMonthYearEditor class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTimeFormatDayMonthYearEditor(
    int baseValue,
    int positions,
    string[] monthsNames,
    DateTimeEditorFormatItem item,
    bool val
)
Visual Basic
Public Sub New ( _
    baseValue As Integer, _
    positions As Integer, _
    monthsNames As String(), _
    item As DateTimeEditorFormatItem, _
    val As Boolean _
)
Visual C++
public:
DateTimeFormatDayMonthYearEditor(
    int baseValue,
    int positions,
    array<String^>^ monthsNames,
    DateTimeEditorFormatItem^ item,
    bool val
)

Parameters

baseValue
Type: System..::..Int32
positions
Type: System..::..Int32
monthsNames
Type: array< System..::..String >[]()[][]
item
Type: VIBlend.WinForms.Controls..::..DateTimeEditorFormatItem
val
Type: System..::..Boolean

See Also

DateTimeFormatDayMonthYearEditor Class
DateTimeFormatDayMonthYearEditor Overload


DateTimeFormatDayMonthYearEditor Constructor (Object, Int32, Int32, Int32, Int32, Int32, String[], DateTimeEditorFormatItem, Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatDayMonthYearEditor Constructor (Object, Int32, Int32, Int32, Int32, Int32, array<String>[]()[][], DateTimeEditorFormatItem, Boolean)
DateTimeFormatDayMonthYearEditor Class See Also Send Feedback
Initializes a new instance of the DateTimeFormatDayMonthYearEditor class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTimeFormatDayMonthYearEditor(
    Object editedValue,
    int initialValue,
    int minValue,
    int maxValue,
    int minEditingPositions,
    int maxEditingPositions,
    string[] dayKeys,
    DateTimeEditorFormatItem item,
    bool val
)
Visual Basic
Public Sub New ( _
    editedValue As Object, _
    initialValue As Integer, _
    minValue As Integer, _
    maxValue As Integer, _
    minEditingPositions As Integer, _
    maxEditingPositions As Integer, _
    dayKeys As String(), _
    item As DateTimeEditorFormatItem, _
    val As Boolean _
)
Visual C++
public:
DateTimeFormatDayMonthYearEditor(
    Object^ editedValue,
    int initialValue,
    int minValue,
    int maxValue,
    int minEditingPositions,
    int maxEditingPositions,
    array<String^>^ dayKeys,
    DateTimeEditorFormatItem^ item,
    bool val
)

Parameters

editedValue
Type: System..::..Object
The edited value.
initialValue
Type: System..::..Int32
The initial value.
minValue
Type: System..::..Int32
The min value.
maxValue
Type: System..::..Int32
The max value.
minEditingPositions
Type: System..::..Int32
The min editing positions.
maxEditingPositions
Type: System..::..Int32
The max editing positions.
dayKeys
Type: array< System..::..String >[]()[][]
The day keys.
item
Type: VIBlend.WinForms.Controls..::..DateTimeEditorFormatItem
The item.
val
Type: System..::..Boolean
if set to true [val].

See Also

DateTimeFormatDayMonthYearEditor Class
DateTimeFormatDayMonthYearEditor Overload


DateTimeFormatDayMonthYearEditor Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatDayMonthYearEditor Fields
DateTimeFormatDayMonthYearEditor Class See Also Send Feedback

The DateTimeFormatDayMonthYearEditor type exposes the following members.

Fields

 | Name | Description
Protected field | positions | (Inherited from DateTimeFormatBaseEditor.)

See Also

DateTimeFormatDayMonthYearEditor Class


DateTimeFormatDayMonthYearEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatDayMonthYearEditor Methods
DateTimeFormatDayMonthYearEditor Class See Also Send Feedback

The DateTimeFormatDayMonthYearEditor type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Deletes this instance. (Inherited from DateTimeFormatBaseEditor.)
Public method | Down | Downs this instance. (Inherited from DateTimeFormatBaseEditor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDateTimeItem | (Inherited from DateTimeFormatBaseEditor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTextValue | Gets the text. (Inherited from DateTimeFormatBaseEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Inserts the specified input.
Public method | InsertString | Inserts the specified insered value. (Inherited from DateTimeFormatBaseEditor.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Up | Ups this instance. (Inherited from DateTimeFormatBaseEditor.)
Protected method | UpdateActiveEditor | Updates the current value (Inherited from DateTimeFormatBaseEditor.)

See Also

DateTimeFormatDayMonthYearEditor Class


Insert Method

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatDayMonthYearEditor..::..Insert Method
DateTimeFormatDayMonthYearEditor Class See Also Send Feedback
Inserts the specified input.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Insert(
    string input
)
Visual Basic
Public Function Insert ( _
    input As String _
) As Boolean
Visual C++
public:
bool Insert(
    String^ input
)

Parameters

input
Type: System..::..String
The input.

Return Value

See Also

DateTimeFormatDayMonthYearEditor Class


DateTimeFormatDayMonthYearEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatDayMonthYearEditor Properties
DateTimeFormatDayMonthYearEditor Class See Also Send Feedback

The DateTimeFormatDayMonthYearEditor type exposes the following members.

Properties

 | Name | Description
Protected property | HasDigits | (Inherited from DateTimeFormatBaseEditor.)
Public property | MaximumValue | Gets the max available value (Inherited from DateTimeFormatBaseEditor.)
Public property | MaxPositions | Gets the maximum amount of digits (Inherited from DateTimeFormatBaseEditor.)
Public property | MinimumValue | Gets the min available value (Inherited from DateTimeFormatBaseEditor.)
Public property | MinPositions | Gets the minimum amount of digits (Overrides DateTimeFormatBaseEditor..::..MinPositions.)
Public property | TextValue | Gets editor's text (Overrides DateTimeFormatBaseEditor..::..TextValue.)
Public property | Value | Gets or sets the current value (Inherited from DateTimeFormatBaseEditor.)

See Also

DateTimeFormatDayMonthYearEditor Class


MinPositions Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatDayMonthYearEditor..::..MinPositions Property
DateTimeFormatDayMonthYearEditor Class See Also Send Feedback
Gets the minimum amount of digits

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override long MinPositions { get; }
Visual Basic
Public Overrides ReadOnly Property MinPositions As Long
    Get
Visual C++
public:
virtual property long long MinPositions {
    long long get () override;
}

Field Value

See Also

DateTimeFormatDayMonthYearEditor Class


TextValue Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFormatDayMonthYearEditor..::..TextValue Property
DateTimeFormatDayMonthYearEditor Class See Also Send Feedback
Gets editor's text

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string TextValue { get; }
Visual Basic
Public Overrides ReadOnly Property TextValue As String
    Get
Visual C++
public:
virtual property String^ TextValue {
    String^ get () override;
}

Implements

IDateTimeEditor..::..TextValue

See Also

DateTimeFormatDayMonthYearEditor Class


DateTimeItemType Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeItemType Enumeration
See Also Send Feedback
Enumaration of the DateTime item types

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum DateTimeItemType
Visual Basic
Public Enumeration DateTimeItemType
Visual C++
public enum class DateTimeItemType

Members

Member name | Description
Year |
Month |
Day |
Minute |
Second |
Millisecond |
FORMAT_hh |
FORMAT_HH |
FORMAT_AMPM |
Character |
Readonly |

See Also


DayNameFormat Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
DayNameFormat Enumeration
See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum DayNameFormat
Visual Basic
Public Enumeration DayNameFormat
Visual C++
public enum class DayNameFormat

Members

Member name | Description
Full |
Short |
FirstLetter |
FirstTwoLetters |
Shortest |

See Also


DayPattern Class

[image]

VIBlend Controls for WinForms Help Documentation
DayPattern Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class DayPattern
Visual Basic
Public Class DayPattern
Visual C++
public ref class DayPattern

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..DayPattern

See Also

DayPattern Members


DayPattern Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPattern Members
DayPattern Class Constructors Methods Properties See Also Send Feedback

The DayPattern type exposes the following members.

Constructors

 | Name | Description
Public method | DayPattern()()()() | Initializes a new instance of the DayPattern class.
Public method | DayPattern(Int32) | Initializes a new instance of the DayPattern class.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | DaysToNextOccurence | Gets or sets the days to next occurence.

See Also

DayPattern Class


DayPattern Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPattern Constructor
DayPattern Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DayPattern()()()() | Initializes a new instance of the DayPattern class.
Public method | DayPattern(Int32) | Initializes a new instance of the DayPattern class.

See Also

DayPattern Class
DayPattern Members


DayPattern Constructor

[image]

VIBlend Controls for WinForms Help Documentation
DayPattern Constructor
DayPattern Class See Also Send Feedback
Initializes a new instance of the DayPattern class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DayPattern()
Visual Basic
Public Sub New
Visual C++
public:
DayPattern()

See Also

DayPattern Class
DayPattern Overload


DayPattern Constructor (Int32)

[image]

VIBlend Controls for WinForms Help Documentation
DayPattern Constructor (Int32)
DayPattern Class See Also Send Feedback
Initializes a new instance of the DayPattern class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DayPattern(
    int numberOfDaysToNextOccurence
)
Visual Basic
Public Sub New ( _
    numberOfDaysToNextOccurence As Integer _
)
Visual C++
public:
DayPattern(
    int numberOfDaysToNextOccurence
)

Parameters

numberOfDaysToNextOccurence
Type: System..::..Int32
The number of days to next occurence.

See Also

DayPattern Class
DayPattern Overload


DayPattern Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPattern Methods
DayPattern Class See Also Send Feedback

The DayPattern type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

DayPattern Class


Clone Method

[image]

VIBlend Controls for WinForms Help Documentation
DayPattern..::..Clone Method
DayPattern Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DayPattern Clone()
Visual Basic
Public Function Clone As DayPattern
Visual C++
public:
DayPattern^ Clone()

See Also

DayPattern Class


ToString Method

[image]

VIBlend Controls for WinForms Help Documentation
DayPattern..::..ToString Method
DayPattern Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

DayPattern Class


DayPattern Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPattern Properties
DayPattern Class See Also Send Feedback

The DayPattern type exposes the following members.

Properties

 | Name | Description
Public property | DaysToNextOccurence | Gets or sets the days to next occurence.

See Also

DayPattern Class


DaysToNextOccurence Property

[image]

VIBlend Controls for WinForms Help Documentation
DayPattern..::..DaysToNextOccurence Property
DayPattern Class See Also Send Feedback
Gets or sets the days to next occurence.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int DaysToNextOccurence { get; set; }
Visual Basic
Public Property DaysToNextOccurence As Integer
    Get
    Set
Visual C++
public:
property int DaysToNextOccurence {
    int get ();
    void set (int value);
}

Field Value

The days to next occurence.

See Also

DayPattern Class


DayPatternConverter Class

[image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class DayPatternConverter : ExpandableObjectConverter
Visual Basic
Public Class DayPatternConverter _
    Inherits ExpandableObjectConverter
Visual C++
public ref class DayPatternConverter : public ExpandableObjectConverter

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..TypeConverter
System.ComponentModel..::..ExpandableObjectConverter
VIBlend.WinForms.Controls..::..DayPatternConverter

See Also

DayPatternConverter Members


DayPatternConverter Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter Members
DayPatternConverter Class Constructors Methods See Also Send Feedback

The DayPatternConverter type exposes the following members.

Constructors

 | Name | Description
Public method | DayPatternConverter | Initializes a new instance of the DayPatternConverter class

Methods

 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | (Overrides TypeConverter..::..CreateInstance(ITypeDescriptorContext, IDictionary).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported()()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)
Public method | GetPropertiesSupported()()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)
Public method | GetStandardValues()()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | (Overrides TypeConverter..::..GetStandardValues(ITypeDescriptorContext).)
Public method | GetStandardValuesExclusive()()()() | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported()()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DayPatternConverter Class


DayPatternConverter Constructor

[image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter Constructor
DayPatternConverter Class See Also Send Feedback
Initializes a new instance of the DayPatternConverter class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DayPatternConverter()
Visual Basic
Public Sub New
Visual C++
public:
DayPatternConverter()

See Also

DayPatternConverter Class


DayPatternConverter Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter Methods
DayPatternConverter Class See Also Send Feedback

The DayPatternConverter type exposes the following members.

Methods

 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | (Overrides TypeConverter..::..CreateInstance(ITypeDescriptorContext, IDictionary).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported()()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)
Public method | GetPropertiesSupported()()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)
Public method | GetStandardValues()()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | (Overrides TypeConverter..::..GetStandardValues(ITypeDescriptorContext).)
Public method | GetStandardValuesExclusive()()()() | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported()()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DayPatternConverter Class


CanConvertFrom Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..CanConvertFrom Method
DayPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

DayPatternConverter Class
DayPatternConverter Members


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..CanConvertFrom Method (ITypeDescriptorContext, Type)
DayPatternConverter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
sourceType
Type: System..::..Type

See Also

DayPatternConverter Class
CanConvertFrom Overload


CanConvertTo Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..CanConvertTo Method
DayPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)

See Also

DayPatternConverter Class
DayPatternConverter Members


ConvertFrom Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..ConvertFrom Method
DayPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

DayPatternConverter Class
DayPatternConverter Members


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
DayPatternConverter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo info,
    Object value
)
Visual Basic
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    info As CultureInfo, _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ info,
    Object^ value
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
info
Type: System.Globalization..::..CultureInfo
value
Type: System..::..Object

See Also

DayPatternConverter Class
ConvertFrom Overload


ConvertFromInvariantString Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..ConvertFromInvariantString Method
DayPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)

See Also

DayPatternConverter Class
DayPatternConverter Members


ConvertFromString Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..ConvertFromString Method
DayPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

DayPatternConverter Class
DayPatternConverter Members


ConvertTo Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..ConvertTo Method
DayPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

DayPatternConverter Class
DayPatternConverter Members


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
DayPatternConverter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
Visual C++
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
culture
Type: System.Globalization..::..CultureInfo
value
Type: System..::..Object
destinationType
Type: System..::..Type

See Also

DayPatternConverter Class
ConvertTo Overload


ConvertToInvariantString Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..ConvertToInvariantString Method
DayPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

DayPatternConverter Class
DayPatternConverter Members


ConvertToString Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..ConvertToString Method
DayPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

DayPatternConverter Class
DayPatternConverter Members


CreateInstance Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..CreateInstance Method
DayPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | (Overrides TypeConverter..::..CreateInstance(ITypeDescriptorContext, IDictionary).)

See Also

DayPatternConverter Class
DayPatternConverter Members


CreateInstance Method (ITypeDescriptorContext, IDictionary)

[image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..CreateInstance Method (ITypeDescriptorContext, IDictionary)
DayPatternConverter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Object CreateInstance(
    ITypeDescriptorContext context,
    IDictionary propertyValues
)
Visual Basic
Public Overrides Function CreateInstance ( _
    context As ITypeDescriptorContext, _
    propertyValues As IDictionary _
) As Object
Visual C++
public:
virtual Object^ CreateInstance(
    ITypeDescriptorContext^ context,
    IDictionary^ propertyValues
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
propertyValues
Type: System.Collections..::..IDictionary

See Also

DayPatternConverter Class
CreateInstance Overload


GetCreateInstanceSupported Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..GetCreateInstanceSupported Method
DayPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCreateInstanceSupported()()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)

See Also

DayPatternConverter Class
DayPatternConverter Members


GetProperties Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..GetProperties Method
DayPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)

See Also

DayPatternConverter Class
DayPatternConverter Members


GetPropertiesSupported Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..GetPropertiesSupported Method
DayPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPropertiesSupported()()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)

See Also

DayPatternConverter Class
DayPatternConverter Members


GetStandardValues Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..GetStandardValues Method
DayPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetStandardValues()()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | (Overrides TypeConverter..::..GetStandardValues(ITypeDescriptorContext).)

See Also

DayPatternConverter Class
DayPatternConverter Members


GetStandardValues Method (ITypeDescriptorContext)

[image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..GetStandardValues Method (ITypeDescriptorContext)
DayPatternConverter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override TypeConverter..::..StandardValuesCollection GetStandardValues(
    ITypeDescriptorContext context
)
Visual Basic
Public Overrides Function GetStandardValues ( _
    context As ITypeDescriptorContext _
) As TypeConverter..::..StandardValuesCollection
Visual C++
public:
virtual TypeConverter..::..StandardValuesCollection^ GetStandardValues(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext

See Also

DayPatternConverter Class
GetStandardValues Overload


GetStandardValuesExclusive Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..GetStandardValuesExclusive Method
DayPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetStandardValuesExclusive()()()() | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)

See Also

DayPatternConverter Class
DayPatternConverter Members


GetStandardValuesSupported Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..GetStandardValuesSupported Method
DayPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetStandardValuesSupported()()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)

See Also

DayPatternConverter Class
DayPatternConverter Members


IsValid Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DayPatternConverter..::..IsValid Method
DayPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

DayPatternConverter Class
DayPatternConverter Members


DesignerAttributeTypeDescriptor Class

[image]

VIBlend Controls for WinForms Help Documentation
DesignerAttributeTypeDescriptor Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public sealed class DesignerAttributeTypeDescriptor : CustomTypeDescriptor
Visual Basic
Public NotInheritable Class DesignerAttributeTypeDescriptor _
    Inherits CustomTypeDescriptor
Visual C++
public ref class DesignerAttributeTypeDescriptor sealed : public CustomTypeDescriptor

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..CustomTypeDescriptor
VIBlend.WinForms.Controls..::..DesignerAttributeTypeDescriptor

See Also

DesignerAttributeTypeDescriptor Members


DesignerAttributeTypeDescriptor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DesignerAttributeTypeDescriptor Members
DesignerAttributeTypeDescriptor Class Methods See Also Send Feedback

The DesignerAttributeTypeDescriptor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributes | (Overrides CustomTypeDescriptor..::..GetAttributes()()()().)
Public method | GetClassName | Returns the fully qualified name of the class represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetComponentName | Returns the name of the class represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetConverter | Returns a type converter for the type represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetDefaultEvent | Returns the event descriptor for the default event of the object represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetDefaultProperty | Returns the property descriptor for the default property of the object represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetEditor | Returns an editor of the specified type that is to be associated with the class represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetEvents()()()() | Returns a collection of event descriptors for the object represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetEvents(array<Attribute>[]()[][]) | Returns a filtered collection of event descriptors for the object represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperties()()()() | Returns a collection of property descriptors for the object represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetProperties(array<Attribute>[]()[][]) | Returns a filtered collection of property descriptors for the object represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DesignerAttributeTypeDescriptor Class


DesignerAttributeTypeDescriptor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DesignerAttributeTypeDescriptor Methods
DesignerAttributeTypeDescriptor Class See Also Send Feedback

The DesignerAttributeTypeDescriptor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributes | (Overrides CustomTypeDescriptor..::..GetAttributes()()()().)
Public method | GetClassName | Returns the fully qualified name of the class represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetComponentName | Returns the name of the class represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetConverter | Returns a type converter for the type represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetDefaultEvent | Returns the event descriptor for the default event of the object represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetDefaultProperty | Returns the property descriptor for the default property of the object represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetEditor | Returns an editor of the specified type that is to be associated with the class represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetEvents()()()() | Returns a collection of event descriptors for the object represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetEvents(array<Attribute>[]()[][]) | Returns a filtered collection of event descriptors for the object represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperties()()()() | Returns a collection of property descriptors for the object represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetProperties(array<Attribute>[]()[][]) | Returns a filtered collection of property descriptors for the object represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DesignerAttributeTypeDescriptor Class


GetAttributes Method

[image]

VIBlend Controls for WinForms Help Documentation
DesignerAttributeTypeDescriptor..::..GetAttributes Method
DesignerAttributeTypeDescriptor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override AttributeCollection GetAttributes()
Visual Basic
Public Overrides Function GetAttributes As AttributeCollection
Visual C++
public:
virtual AttributeCollection^ GetAttributes() override

Implements

ICustomTypeDescriptor..::..GetAttributes()()()()

See Also

DesignerAttributeTypeDescriptor Class


GetEvents Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DesignerAttributeTypeDescriptor..::..GetEvents Method
DesignerAttributeTypeDescriptor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEvents()()()() | Returns a collection of event descriptors for the object represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetEvents(array<Attribute>[]()[][]) | Returns a filtered collection of event descriptors for the object represented by this type descriptor. (Inherited from CustomTypeDescriptor.)

See Also

DesignerAttributeTypeDescriptor Class
DesignerAttributeTypeDescriptor Members


GetProperties Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DesignerAttributeTypeDescriptor..::..GetProperties Method
DesignerAttributeTypeDescriptor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperties()()()() | Returns a collection of property descriptors for the object represented by this type descriptor. (Inherited from CustomTypeDescriptor.)
Public method | GetProperties(array<Attribute>[]()[][]) | Returns a filtered collection of property descriptors for the object represented by this type descriptor. (Inherited from CustomTypeDescriptor.)

See Also

DesignerAttributeTypeDescriptor Class
DesignerAttributeTypeDescriptor Members


DisabledEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
DisabledEditor Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class DisabledEditor : IDateTimeEditor
Visual Basic
Public Class DisabledEditor _
    Implements IDateTimeEditor
Visual C++
public ref class DisabledEditor : IDateTimeEditor

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..DisabledEditor

See Also

DisabledEditor Members


DisabledEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DisabledEditor Members
DisabledEditor Class Constructors Methods Properties See Also Send Feedback

The DisabledEditor type exposes the following members.

Constructors

 | Name | Description
Public method | DisabledEditor | Initializes a new instance of the DisabledEditor class

Methods

 | Name | Description
Public method | Down | Downs this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDateTimeItem | Gets the item.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTextValue | Gets the text.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertString | Inserts the specified inserted.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Up | Ups this instance.

Properties

 | Name | Description
Public property | TextValue |

See Also

DisabledEditor Class


DisabledEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
DisabledEditor Constructor
DisabledEditor Class See Also Send Feedback
Initializes a new instance of the DisabledEditor class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DisabledEditor(
    string formatValue,
    int baseValue,
    DateTimeEditorFormatItem item
)
Visual Basic
Public Sub New ( _
    formatValue As String, _
    baseValue As Integer, _
    item As DateTimeEditorFormatItem _
)
Visual C++
public:
DisabledEditor(
    String^ formatValue,
    int baseValue,
    DateTimeEditorFormatItem^ item
)

Parameters

formatValue
Type: System..::..String
baseValue
Type: System..::..Int32
item
Type: VIBlend.WinForms.Controls..::..DateTimeEditorFormatItem

See Also

DisabledEditor Class


DisabledEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DisabledEditor Methods
DisabledEditor Class See Also Send Feedback

The DisabledEditor type exposes the following members.

Methods

 | Name | Description
Public method | Down | Downs this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDateTimeItem | Gets the item.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTextValue | Gets the text.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertString | Inserts the specified inserted.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Up | Ups this instance.

See Also

DisabledEditor Class


Down Method

[image]

VIBlend Controls for WinForms Help Documentation
DisabledEditor..::..Down Method
DisabledEditor Class See Also Send Feedback
Downs this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Down()
Visual Basic
Public Function Down As Boolean
Visual C++
public:
virtual bool Down() sealed

Return Value

Implements

IDateTimeEditor..::..Down()()()()

See Also

DisabledEditor Class


GetDateTimeItem Method

[image]

VIBlend Controls for WinForms Help Documentation
DisabledEditor..::..GetDateTimeItem Method
DisabledEditor Class See Also Send Feedback
Gets the item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTimeEditorFormatItem GetDateTimeItem()
Visual Basic
Public Function GetDateTimeItem As DateTimeEditorFormatItem
Visual C++
public:
virtual DateTimeEditorFormatItem^ GetDateTimeItem() sealed

Return Value

Implements

IDateTimeEditor..::..GetDateTimeItem()()()()

See Also

DisabledEditor Class


GetTextValue Method

[image]

VIBlend Controls for WinForms Help Documentation
DisabledEditor..::..GetTextValue Method
DisabledEditor Class See Also Send Feedback
Gets the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public long GetTextValue()
Visual Basic
Public Function GetTextValue As Long
Visual C++
public:
virtual long long GetTextValue() sealed

Return Value

Implements

IDateTimeEditor..::..GetTextValue()()()()

See Also

DisabledEditor Class


InsertString Method

[image]

VIBlend Controls for WinForms Help Documentation
DisabledEditor..::..InsertString Method
DisabledEditor Class See Also Send Feedback
Inserts the specified inserted.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool InsertString(
    string inserted
)
Visual Basic
Public Function InsertString ( _
    inserted As String _
) As Boolean
Visual C++
public:
virtual bool InsertString(
    String^ inserted
) sealed

Parameters

inserted
Type: System..::..String
The inserted.

Return Value

Implements

IDateTimeEditor..::..InsertString(String)

See Also

DisabledEditor Class


Up Method

[image]

VIBlend Controls for WinForms Help Documentation
DisabledEditor..::..Up Method
DisabledEditor Class See Also Send Feedback
Ups this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Up()
Visual Basic
Public Function Up As Boolean
Visual C++
public:
virtual bool Up() sealed

Return Value

Implements

IDateTimeEditor..::..Up()()()()

See Also

DisabledEditor Class


DisabledEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
DisabledEditor Properties
DisabledEditor Class See Also Send Feedback

The DisabledEditor type exposes the following members.

Properties

 | Name | Description
Public property | TextValue |

See Also

DisabledEditor Class


TextValue Property

[image]

VIBlend Controls for WinForms Help Documentation
DisabledEditor..::..TextValue Property
DisabledEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string TextValue { get; }
Visual Basic
Public ReadOnly Property TextValue As String
    Get
Visual C++
public:
virtual property String^ TextValue {
    String^ get () sealed;
}

Implements

IDateTimeEditor..::..TextValue

See Also

DisabledEditor Class


DragCancelEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
DragCancelEventArgs Class
Members See Also Send Feedback
Represents a drag and drop cancel event argument

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class DragCancelEventArgs : vTabEventArgs
Visual Basic
Public Class DragCancelEventArgs _
    Inherits vTabEventArgs
Visual C++
public ref class DragCancelEventArgs : public vTabEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..vTabEventArgs
VIBlend.WinForms.Controls..::..DragCancelEventArgs

See Also

DragCancelEventArgs Members


DragCancelEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DragCancelEventArgs Members
DragCancelEventArgs Class Constructors Methods Properties See Also Send Feedback

The DragCancelEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DragCancelEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets whether the even is canceled
Public property | TabPage | Gets the drag source tab page. (Inherited from vTabEventArgs.)
Public property | TargetTabPage | The drop target tab page.

See Also

DragCancelEventArgs Class


DragCancelEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
DragCancelEventArgs Constructor
DragCancelEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DragCancelEventArgs(
    vTabPage sourcePage,
    vTabPage targetPage
)
Visual Basic
Public Sub New ( _
    sourcePage As vTabPage, _
    targetPage As vTabPage _
)
Visual C++
public:
DragCancelEventArgs(
    vTabPage^ sourcePage,
    vTabPage^ targetPage
)

Parameters

sourcePage
Type: VIBlend.WinForms.Controls..::..vTabPage
Drag source tab page.
targetPage
Type: VIBlend.WinForms.Controls..::..vTabPage
Drop target tab page.

See Also

DragCancelEventArgs Class


DragCancelEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DragCancelEventArgs Methods
DragCancelEventArgs Class See Also Send Feedback

The DragCancelEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DragCancelEventArgs Class


DragCancelEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
DragCancelEventArgs Properties
DragCancelEventArgs Class See Also Send Feedback

The DragCancelEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets whether the even is canceled
Public property | TabPage | Gets the drag source tab page. (Inherited from vTabEventArgs.)
Public property | TargetTabPage | The drop target tab page.

See Also

DragCancelEventArgs Class


Cancel Property

[image]

VIBlend Controls for WinForms Help Documentation
DragCancelEventArgs..::..Cancel Property
DragCancelEventArgs Class See Also Send Feedback
Gets or sets whether the even is canceled

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic
Public Property Cancel As Boolean
    Get
    Set
Visual C++
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}

See Also

DragCancelEventArgs Class


TargetTabPage Property

[image]

VIBlend Controls for WinForms Help Documentation
DragCancelEventArgs..::..TargetTabPage Property
DragCancelEventArgs Class See Also Send Feedback
The drop target tab page.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTabPage TargetTabPage { get; }
Visual Basic
Public ReadOnly Property TargetTabPage As vTabPage
    Get
Visual C++
public:
property vTabPage^ TargetTabPage {
    vTabPage^ get ();
}

See Also

DragCancelEventArgs Class


DrawExplorerBarEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
DrawExplorerBarEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class DrawExplorerBarEventArgs : EventArgs
Visual Basic
Public Class DrawExplorerBarEventArgs _
    Inherits EventArgs
Visual C++
public ref class DrawExplorerBarEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..DrawExplorerBarEventArgs

See Also

DrawExplorerBarEventArgs Members


DrawExplorerBarEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DrawExplorerBarEventArgs Members
DrawExplorerBarEventArgs Class Constructors Methods Properties See Also Send Feedback

The DrawExplorerBarEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DrawExplorerBarEventArgs | Initializes a new instance of the DrawNavPaneEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Graphics | Gets the graphics.
Public property | Handled | Gets or sets a value indicating whether this DrawNavPaneEventArgs is handled.
Public property | Header | Gets the header.
Public property | State | Gets the state.

See Also

DrawExplorerBarEventArgs Class


DrawExplorerBarEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
DrawExplorerBarEventArgs Constructor
DrawExplorerBarEventArgs Class See Also Send Feedback
Initializes a new instance of the DrawNavPaneEventArgs class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DrawExplorerBarEventArgs(
    Graphics g,
    ControlState state,
    vExplorerBarItemHeader header
)
Visual Basic
Public Sub New ( _
    g As Graphics, _
    state As ControlState, _
    header As vExplorerBarItemHeader _
)
Visual C++
public:
DrawExplorerBarEventArgs(
    Graphics^ g,
    ControlState state,
    vExplorerBarItemHeader^ header
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
state
Type: ControlState
The state.
header
Type: vExplorerBarItemHeader
The header.

See Also

DrawExplorerBarEventArgs Class


DrawExplorerBarEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DrawExplorerBarEventArgs Methods
DrawExplorerBarEventArgs Class See Also Send Feedback

The DrawExplorerBarEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DrawExplorerBarEventArgs Class


DrawExplorerBarEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
DrawExplorerBarEventArgs Properties
DrawExplorerBarEventArgs Class See Also Send Feedback

The DrawExplorerBarEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Graphics | Gets the graphics.
Public property | Handled | Gets or sets a value indicating whether this DrawNavPaneEventArgs is handled.
Public property | Header | Gets the header.
Public property | State | Gets the state.

See Also

DrawExplorerBarEventArgs Class


Graphics Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawExplorerBarEventArgs..::..Graphics Property
DrawExplorerBarEventArgs Class See Also Send Feedback
Gets the graphics.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Graphics Graphics { get; }
Visual Basic
Public ReadOnly Property Graphics As Graphics
    Get
Visual C++
public:
property Graphics^ Graphics {
    Graphics^ get ();
}

Field Value

The graphics.

See Also

DrawExplorerBarEventArgs Class


Handled Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawExplorerBarEventArgs..::..Handled Property
DrawExplorerBarEventArgs Class See Also Send Feedback
Gets or sets a value indicating whether this DrawNavPaneEventArgs is handled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Handled { get; set; }
Visual Basic
Public Property Handled As Boolean
    Get
    Set
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

Field Value

true if handled; otherwise, false.

See Also

DrawExplorerBarEventArgs Class


Header Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawExplorerBarEventArgs..::..Header Property
DrawExplorerBarEventArgs Class See Also Send Feedback
Gets the header.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vExplorerBarItemHeader Header { get; }
Visual Basic
Public ReadOnly Property Header As vExplorerBarItemHeader
    Get
Visual C++
public:
property vExplorerBarItemHeader^ Header {
    vExplorerBarItemHeader^ get ();
}

Field Value

The header.

See Also

DrawExplorerBarEventArgs Class


State Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawExplorerBarEventArgs..::..State Property
DrawExplorerBarEventArgs Class See Also Send Feedback
Gets the state.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlState State { get; }
Visual Basic
Public ReadOnly Property State As ControlState
    Get
Visual C++
public:
property ControlState State {
    ControlState get ();
}

Field Value

The state.

See Also

DrawExplorerBarEventArgs Class


DrawNavPaneEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
DrawNavPaneEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class DrawNavPaneEventArgs : EventArgs
Visual Basic
Public Class DrawNavPaneEventArgs _
    Inherits EventArgs
Visual C++
public ref class DrawNavPaneEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..DrawNavPaneEventArgs

See Also

DrawNavPaneEventArgs Members


DrawNavPaneEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DrawNavPaneEventArgs Members
DrawNavPaneEventArgs Class Constructors Methods Properties See Also Send Feedback

The DrawNavPaneEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DrawNavPaneEventArgs | Initializes a new instance of the DrawNavPaneEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Graphics | Gets the graphics.
Public property | Handled | Gets or sets a value indicating whether this DrawNavPaneEventArgs is handled.
Public property | Header | Gets the header.
Public property | State | Gets the state.

See Also

DrawNavPaneEventArgs Class


DrawNavPaneEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
DrawNavPaneEventArgs Constructor
DrawNavPaneEventArgs Class See Also Send Feedback
Initializes a new instance of the DrawNavPaneEventArgs class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DrawNavPaneEventArgs(
    Graphics g,
    ControlState state,
    vNavPaneHeader header
)
Visual Basic
Public Sub New ( _
    g As Graphics, _
    state As ControlState, _
    header As vNavPaneHeader _
)
Visual C++
public:
DrawNavPaneEventArgs(
    Graphics^ g,
    ControlState state,
    vNavPaneHeader^ header
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
state
Type: ControlState
The state.
header
Type: vNavPaneHeader
The header.

See Also

DrawNavPaneEventArgs Class


DrawNavPaneEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DrawNavPaneEventArgs Methods
DrawNavPaneEventArgs Class See Also Send Feedback

The DrawNavPaneEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DrawNavPaneEventArgs Class


DrawNavPaneEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
DrawNavPaneEventArgs Properties
DrawNavPaneEventArgs Class See Also Send Feedback

The DrawNavPaneEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Graphics | Gets the graphics.
Public property | Handled | Gets or sets a value indicating whether this DrawNavPaneEventArgs is handled.
Public property | Header | Gets the header.
Public property | State | Gets the state.

See Also

DrawNavPaneEventArgs Class


Graphics Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawNavPaneEventArgs..::..Graphics Property
DrawNavPaneEventArgs Class See Also Send Feedback
Gets the graphics.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Graphics Graphics { get; }
Visual Basic
Public ReadOnly Property Graphics As Graphics
    Get
Visual C++
public:
property Graphics^ Graphics {
    Graphics^ get ();
}

Field Value

The graphics.

See Also

DrawNavPaneEventArgs Class


Handled Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawNavPaneEventArgs..::..Handled Property
DrawNavPaneEventArgs Class See Also Send Feedback
Gets or sets a value indicating whether this DrawNavPaneEventArgs is handled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Handled { get; set; }
Visual Basic
Public Property Handled As Boolean
    Get
    Set
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

Field Value

true if handled; otherwise, false.

See Also

DrawNavPaneEventArgs Class


Header Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawNavPaneEventArgs..::..Header Property
DrawNavPaneEventArgs Class See Also Send Feedback
Gets the header.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vNavPaneHeader Header { get; }
Visual Basic
Public ReadOnly Property Header As vNavPaneHeader
    Get
Visual C++
public:
property vNavPaneHeader^ Header {
    vNavPaneHeader^ get ();
}

Field Value

The header.

See Also

DrawNavPaneEventArgs Class


State Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawNavPaneEventArgs..::..State Property
DrawNavPaneEventArgs Class See Also Send Feedback
Gets the state.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlState State { get; }
Visual Basic
Public ReadOnly Property State As ControlState
    Get
Visual C++
public:
property ControlState State {
    ControlState get ();
}

Field Value

The state.

See Also

DrawNavPaneEventArgs Class


DrawNodeEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
DrawNodeEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class DrawNodeEventArgs : EventArgs
Visual Basic
Public Class DrawNodeEventArgs _
    Inherits EventArgs
Visual C++
public ref class DrawNodeEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..DrawNodeEventArgs

See Also

DrawNodeEventArgs Members


DrawNodeEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DrawNodeEventArgs Members
DrawNodeEventArgs Class Constructors Methods Properties See Also Send Feedback

The DrawNodeEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DrawNodeEventArgs | Initializes a new instance of the DrawNodeEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Background |
Public property | Graphics | Gets the graphics.
Public property | Handled | Gets or sets a value indicating whether this DrawNodeEventArgs is handled.
Public property | IsMouseOver | Gets a value indicating whether this instance is mouse over.
Public property | IsSelected | Gets a value indicating whether this instance is selected.
Public property | Node | Gets the node.

See Also

DrawNodeEventArgs Class


DrawNodeEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
DrawNodeEventArgs Constructor
DrawNodeEventArgs Class See Also Send Feedback
Initializes a new instance of the DrawNodeEventArgs class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DrawNodeEventArgs(
    Graphics g,
    vTreeNode node,
    bool isMouseOver,
    bool isSelected,
    TreeBackGroundElement background
)
Visual Basic
Public Sub New ( _
    g As Graphics, _
    node As vTreeNode, _
    isMouseOver As Boolean, _
    isSelected As Boolean, _
    background As TreeBackGroundElement _
)
Visual C++
public:
DrawNodeEventArgs(
    Graphics^ g,
    vTreeNode^ node,
    bool isMouseOver,
    bool isSelected,
    TreeBackGroundElement^ background
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
node
Type: VIBlend.WinForms.Controls..::..vTreeNode
The node.
isMouseOver
Type: System..::..Boolean
if set to true [is mouse over].
isSelected
Type: System..::..Boolean
if set to true [is selected].
background
Type: TreeBackGroundElement
The background.

See Also

DrawNodeEventArgs Class


DrawNodeEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DrawNodeEventArgs Methods
DrawNodeEventArgs Class See Also Send Feedback

The DrawNodeEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DrawNodeEventArgs Class


DrawNodeEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
DrawNodeEventArgs Properties
DrawNodeEventArgs Class See Also Send Feedback

The DrawNodeEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Background |
Public property | Graphics | Gets the graphics.
Public property | Handled | Gets or sets a value indicating whether this DrawNodeEventArgs is handled.
Public property | IsMouseOver | Gets a value indicating whether this instance is mouse over.
Public property | IsSelected | Gets a value indicating whether this instance is selected.
Public property | Node | Gets the node.

See Also

DrawNodeEventArgs Class


Background Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawNodeEventArgs..::..Background Property
DrawNodeEventArgs Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public TreeBackGroundElement Background { get; }
Visual Basic
Public ReadOnly Property Background As TreeBackGroundElement
    Get
Visual C++
public:
property TreeBackGroundElement^ Background {
    TreeBackGroundElement^ get ();
}

See Also

DrawNodeEventArgs Class


Graphics Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawNodeEventArgs..::..Graphics Property
DrawNodeEventArgs Class See Also Send Feedback
Gets the graphics.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Graphics Graphics { get; }
Visual Basic
Public ReadOnly Property Graphics As Graphics
    Get
Visual C++
public:
property Graphics^ Graphics {
    Graphics^ get ();
}

Field Value

The graphics.

See Also

DrawNodeEventArgs Class


Handled Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawNodeEventArgs..::..Handled Property
DrawNodeEventArgs Class See Also Send Feedback
Gets or sets a value indicating whether this DrawNodeEventArgs is handled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Handled { get; set; }
Visual Basic
Public Property Handled As Boolean
    Get
    Set
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

Field Value

true if handled; otherwise, false.

See Also

DrawNodeEventArgs Class


IsMouseOver Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawNodeEventArgs..::..IsMouseOver Property
DrawNodeEventArgs Class See Also Send Feedback
Gets a value indicating whether this instance is mouse over.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsMouseOver { get; }
Visual Basic
Public ReadOnly Property IsMouseOver As Boolean
    Get
Visual C++
public:
property bool IsMouseOver {
    bool get ();
}

Field Value

true if this instance is mouse over; otherwise, false.

See Also

DrawNodeEventArgs Class


IsSelected Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawNodeEventArgs..::..IsSelected Property
DrawNodeEventArgs Class See Also Send Feedback
Gets a value indicating whether this instance is selected.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsSelected { get; }
Visual Basic
Public ReadOnly Property IsSelected As Boolean
    Get
Visual C++
public:
property bool IsSelected {
    bool get ();
}

Field Value

true if this instance is selected; otherwise, false.

See Also

DrawNodeEventArgs Class


Node Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawNodeEventArgs..::..Node Property
DrawNodeEventArgs Class See Also Send Feedback
Gets the node.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode Node { get; }
Visual Basic
Public ReadOnly Property Node As vTreeNode
    Get
Visual C++
public:
property vTreeNode^ Node {
    vTreeNode^ get ();
}

Field Value

The node.

See Also

DrawNodeEventArgs Class


DrawOutlookNavPaneEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class DrawOutlookNavPaneEventArgs : EventArgs
Visual Basic
Public Class DrawOutlookNavPaneEventArgs _
    Inherits EventArgs
Visual C++
public ref class DrawOutlookNavPaneEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..DrawOutlookNavPaneEventArgs

See Also

DrawOutlookNavPaneEventArgs Members


DrawOutlookNavPaneEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneEventArgs Members
DrawOutlookNavPaneEventArgs Class Constructors Methods Properties See Also Send Feedback

The DrawOutlookNavPaneEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DrawOutlookNavPaneEventArgs | Initializes a new instance of the DrawNavPaneEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Graphics | Gets the graphics.
Public property | Handled | Gets or sets a value indicating whether this DrawNavPaneEventArgs is handled.
Public property | Header | Gets the header.
Public property | State | Gets the state.

See Also

DrawOutlookNavPaneEventArgs Class


DrawOutlookNavPaneEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneEventArgs Constructor
DrawOutlookNavPaneEventArgs Class See Also Send Feedback
Initializes a new instance of the DrawNavPaneEventArgs class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DrawOutlookNavPaneEventArgs(
    Graphics g,
    ControlState state,
    vOutlookHeader header
)
Visual Basic
Public Sub New ( _
    g As Graphics, _
    state As ControlState, _
    header As vOutlookHeader _
)
Visual C++
public:
DrawOutlookNavPaneEventArgs(
    Graphics^ g,
    ControlState state,
    vOutlookHeader^ header
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
state
Type: ControlState
The state.
header
Type: vOutlookHeader
The header.

See Also

DrawOutlookNavPaneEventArgs Class


DrawOutlookNavPaneEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneEventArgs Methods
DrawOutlookNavPaneEventArgs Class See Also Send Feedback

The DrawOutlookNavPaneEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DrawOutlookNavPaneEventArgs Class


DrawOutlookNavPaneEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneEventArgs Properties
DrawOutlookNavPaneEventArgs Class See Also Send Feedback

The DrawOutlookNavPaneEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Graphics | Gets the graphics.
Public property | Handled | Gets or sets a value indicating whether this DrawNavPaneEventArgs is handled.
Public property | Header | Gets the header.
Public property | State | Gets the state.

See Also

DrawOutlookNavPaneEventArgs Class


Graphics Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneEventArgs..::..Graphics Property
DrawOutlookNavPaneEventArgs Class See Also Send Feedback
Gets the graphics.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Graphics Graphics { get; }
Visual Basic
Public ReadOnly Property Graphics As Graphics
    Get
Visual C++
public:
property Graphics^ Graphics {
    Graphics^ get ();
}

Field Value

The graphics.

See Also

DrawOutlookNavPaneEventArgs Class


Handled Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneEventArgs..::..Handled Property
DrawOutlookNavPaneEventArgs Class See Also Send Feedback
Gets or sets a value indicating whether this DrawNavPaneEventArgs is handled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Handled { get; set; }
Visual Basic
Public Property Handled As Boolean
    Get
    Set
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

Field Value

true if handled; otherwise, false.

See Also

DrawOutlookNavPaneEventArgs Class


Header Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneEventArgs..::..Header Property
DrawOutlookNavPaneEventArgs Class See Also Send Feedback
Gets the header.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOutlookHeader Header { get; }
Visual Basic
Public ReadOnly Property Header As vOutlookHeader
    Get
Visual C++
public:
property vOutlookHeader^ Header {
    vOutlookHeader^ get ();
}

Field Value

The header.

See Also

DrawOutlookNavPaneEventArgs Class


State Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneEventArgs..::..State Property
DrawOutlookNavPaneEventArgs Class See Also Send Feedback
Gets the state.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlState State { get; }
Visual Basic
Public ReadOnly Property State As ControlState
    Get
Visual C++
public:
property ControlState State {
    ControlState get ();
}

Field Value

The state.

See Also

DrawOutlookNavPaneEventArgs Class


DrawOutlookNavPaneResizeItemEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneResizeItemEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class DrawOutlookNavPaneResizeItemEventArgs : EventArgs
Visual Basic
Public Class DrawOutlookNavPaneResizeItemEventArgs _
    Inherits EventArgs
Visual C++
public ref class DrawOutlookNavPaneResizeItemEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..DrawOutlookNavPaneResizeItemEventArgs

See Also

DrawOutlookNavPaneResizeItemEventArgs Members


DrawOutlookNavPaneResizeItemEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneResizeItemEventArgs Members
DrawOutlookNavPaneResizeItemEventArgs Class Constructors Methods Properties See Also Send Feedback

The DrawOutlookNavPaneResizeItemEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DrawOutlookNavPaneResizeItemEventArgs | Initializes a new instance of the DrawOutlookNavPaneStatusEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Graphics | Gets the graphics.
Public property | Handled | Gets or sets a value indicating whether this DrawOutlookNavPaneStatusEventArgs is handled.
Public property | ResizeItem | Gets the header.
Public property | State | Gets the state.

See Also

DrawOutlookNavPaneResizeItemEventArgs Class


DrawOutlookNavPaneResizeItemEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneResizeItemEventArgs Constructor
DrawOutlookNavPaneResizeItemEventArgs Class See Also Send Feedback
Initializes a new instance of the DrawOutlookNavPaneStatusEventArgs class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DrawOutlookNavPaneResizeItemEventArgs(
    Graphics g,
    ControlState state,
    vOutlookResizeItem resizeItem
)
Visual Basic
Public Sub New ( _
    g As Graphics, _
    state As ControlState, _
    resizeItem As vOutlookResizeItem _
)
Visual C++
public:
DrawOutlookNavPaneResizeItemEventArgs(
    Graphics^ g,
    ControlState state,
    vOutlookResizeItem^ resizeItem
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
state
Type: ControlState
The state.
resizeItem
Type: VIBlend.WinForms.Controls..::..vOutlookResizeItem

See Also

DrawOutlookNavPaneResizeItemEventArgs Class


DrawOutlookNavPaneResizeItemEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneResizeItemEventArgs Methods
DrawOutlookNavPaneResizeItemEventArgs Class See Also Send Feedback

The DrawOutlookNavPaneResizeItemEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DrawOutlookNavPaneResizeItemEventArgs Class


DrawOutlookNavPaneResizeItemEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneResizeItemEventArgs Properties
DrawOutlookNavPaneResizeItemEventArgs Class See Also Send Feedback

The DrawOutlookNavPaneResizeItemEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Graphics | Gets the graphics.
Public property | Handled | Gets or sets a value indicating whether this DrawOutlookNavPaneStatusEventArgs is handled.
Public property | ResizeItem | Gets the header.
Public property | State | Gets the state.

See Also

DrawOutlookNavPaneResizeItemEventArgs Class


Graphics Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneResizeItemEventArgs..::..Graphics Property
DrawOutlookNavPaneResizeItemEventArgs Class See Also Send Feedback
Gets the graphics.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Graphics Graphics { get; }
Visual Basic
Public ReadOnly Property Graphics As Graphics
    Get
Visual C++
public:
property Graphics^ Graphics {
    Graphics^ get ();
}

Field Value

The graphics.

See Also

DrawOutlookNavPaneResizeItemEventArgs Class


Handled Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneResizeItemEventArgs..::..Handled Property
DrawOutlookNavPaneResizeItemEventArgs Class See Also Send Feedback
Gets or sets a value indicating whether this DrawOutlookNavPaneStatusEventArgs is handled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Handled { get; set; }
Visual Basic
Public Property Handled As Boolean
    Get
    Set
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

Field Value

true if handled; otherwise, false.

See Also

DrawOutlookNavPaneResizeItemEventArgs Class


ResizeItem Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneResizeItemEventArgs..::..ResizeItem Property
DrawOutlookNavPaneResizeItemEventArgs Class See Also Send Feedback
Gets the header.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOutlookResizeItem ResizeItem { get; }
Visual Basic
Public ReadOnly Property ResizeItem As vOutlookResizeItem
    Get
Visual C++
public:
property vOutlookResizeItem^ ResizeItem {
    vOutlookResizeItem^ get ();
}

Field Value

The header.

See Also

DrawOutlookNavPaneResizeItemEventArgs Class


State Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneResizeItemEventArgs..::..State Property
DrawOutlookNavPaneResizeItemEventArgs Class See Also Send Feedback
Gets the state.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlState State { get; }
Visual Basic
Public ReadOnly Property State As ControlState
    Get
Visual C++
public:
property ControlState State {
    ControlState get ();
}

Field Value

The state.

See Also

DrawOutlookNavPaneResizeItemEventArgs Class


DrawOutlookNavPaneStatusEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneStatusEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class DrawOutlookNavPaneStatusEventArgs : EventArgs
Visual Basic
Public Class DrawOutlookNavPaneStatusEventArgs _
    Inherits EventArgs
Visual C++
public ref class DrawOutlookNavPaneStatusEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..DrawOutlookNavPaneStatusEventArgs

See Also

DrawOutlookNavPaneStatusEventArgs Members


DrawOutlookNavPaneStatusEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneStatusEventArgs Members
DrawOutlookNavPaneStatusEventArgs Class Constructors Methods Properties See Also Send Feedback

The DrawOutlookNavPaneStatusEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DrawOutlookNavPaneStatusEventArgs | Initializes a new instance of the DrawOutlookNavPaneStatusEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Graphics | Gets the graphics.
Public property | Handled | Gets or sets a value indicating whether this DrawOutlookNavPaneStatusEventArgs is handled.
Public property | State | Gets the state.
Public property | Status | Gets the header.

See Also

DrawOutlookNavPaneStatusEventArgs Class


DrawOutlookNavPaneStatusEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneStatusEventArgs Constructor
DrawOutlookNavPaneStatusEventArgs Class See Also Send Feedback
Initializes a new instance of the DrawOutlookNavPaneStatusEventArgs class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DrawOutlookNavPaneStatusEventArgs(
    Graphics g,
    ControlState state,
    vOutlookStatusItem statusItem
)
Visual Basic
Public Sub New ( _
    g As Graphics, _
    state As ControlState, _
    statusItem As vOutlookStatusItem _
)
Visual C++
public:
DrawOutlookNavPaneStatusEventArgs(
    Graphics^ g,
    ControlState state,
    vOutlookStatusItem^ statusItem
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
state
Type: ControlState
The state.
statusItem
Type: VIBlend.WinForms.Controls..::..vOutlookStatusItem
The status item.

See Also

DrawOutlookNavPaneStatusEventArgs Class


DrawOutlookNavPaneStatusEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneStatusEventArgs Methods
DrawOutlookNavPaneStatusEventArgs Class See Also Send Feedback

The DrawOutlookNavPaneStatusEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DrawOutlookNavPaneStatusEventArgs Class


DrawOutlookNavPaneStatusEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneStatusEventArgs Properties
DrawOutlookNavPaneStatusEventArgs Class See Also Send Feedback

The DrawOutlookNavPaneStatusEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Graphics | Gets the graphics.
Public property | Handled | Gets or sets a value indicating whether this DrawOutlookNavPaneStatusEventArgs is handled.
Public property | State | Gets the state.
Public property | Status | Gets the header.

See Also

DrawOutlookNavPaneStatusEventArgs Class


Graphics Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneStatusEventArgs..::..Graphics Property
DrawOutlookNavPaneStatusEventArgs Class See Also Send Feedback
Gets the graphics.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Graphics Graphics { get; }
Visual Basic
Public ReadOnly Property Graphics As Graphics
    Get
Visual C++
public:
property Graphics^ Graphics {
    Graphics^ get ();
}

Field Value

The graphics.

See Also

DrawOutlookNavPaneStatusEventArgs Class


Handled Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneStatusEventArgs..::..Handled Property
DrawOutlookNavPaneStatusEventArgs Class See Also Send Feedback
Gets or sets a value indicating whether this DrawOutlookNavPaneStatusEventArgs is handled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Handled { get; set; }
Visual Basic
Public Property Handled As Boolean
    Get
    Set
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

Field Value

true if handled; otherwise, false.

See Also

DrawOutlookNavPaneStatusEventArgs Class


State Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneStatusEventArgs..::..State Property
DrawOutlookNavPaneStatusEventArgs Class See Also Send Feedback
Gets the state.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlState State { get; }
Visual Basic
Public ReadOnly Property State As ControlState
    Get
Visual C++
public:
property ControlState State {
    ControlState get ();
}

Field Value

The state.

See Also

DrawOutlookNavPaneStatusEventArgs Class


Status Property

[image]

VIBlend Controls for WinForms Help Documentation
DrawOutlookNavPaneStatusEventArgs..::..Status Property
DrawOutlookNavPaneStatusEventArgs Class See Also Send Feedback
Gets the header.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOutlookStatusItem Status { get; }
Visual Basic
Public ReadOnly Property Status As vOutlookStatusItem
    Get
Visual C++
public:
property vOutlookStatusItem^ Status {
    vOutlookStatusItem^ get ();
}

Field Value

The header.

See Also

DrawOutlookNavPaneStatusEventArgs Class


DynamicDesignerProvider Class

[image]

VIBlend Controls for WinForms Help Documentation
DynamicDesignerProvider Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public sealed class DynamicDesignerProvider : TypeDescriptionProvider
Visual Basic
Public NotInheritable Class DynamicDesignerProvider _
    Inherits TypeDescriptionProvider
Visual C++
public ref class DynamicDesignerProvider sealed : public TypeDescriptionProvider

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..TypeDescriptionProvider
VIBlend.WinForms.Controls..::..DynamicDesignerProvider

See Also

DynamicDesignerProvider Members


DynamicDesignerProvider Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DynamicDesignerProvider Members
DynamicDesignerProvider Class Constructors Methods See Also Send Feedback

The DynamicDesignerProvider type exposes the following members.

Constructors

 | Name | Description
Public method | DynamicDesignerProvider | Initializes a new instance of the DynamicDesignerProvider class

Methods

 | Name | Description
Public method | CreateInstance | Creates an object that can substitute for another data type. (Inherited from TypeDescriptionProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCache | Gets a per-object cache, accessed as an IDictionary of key/value pairs. (Inherited from TypeDescriptionProvider.)
Public method | GetExtendedTypeDescriptor | Gets an extended custom type descriptor for the given object. (Inherited from TypeDescriptionProvider.)
Public method | GetFullComponentName | Gets the name of the specified component, or null if the component has no name. (Inherited from TypeDescriptionProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetReflectionType(Type) | Performs normal reflection against a type. (Inherited from TypeDescriptionProvider.)
Public method | GetReflectionType(Object) | Performs normal reflection against the given object. (Inherited from TypeDescriptionProvider.)
Public method | GetReflectionType(Type, Object) | Performs normal reflection against the given object with the given type. (Inherited from TypeDescriptionProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeDescriptor(Type) | Gets a custom type descriptor for the given type. (Inherited from TypeDescriptionProvider.)
Public method | GetTypeDescriptor(Object) | Gets a custom type descriptor for the given object. (Inherited from TypeDescriptionProvider.)
Public method | GetTypeDescriptor(Type, Object) | (Overrides TypeDescriptionProvider..::..GetTypeDescriptor(Type, Object).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DynamicDesignerProvider Class


DynamicDesignerProvider Constructor

[image]

VIBlend Controls for WinForms Help Documentation
DynamicDesignerProvider Constructor
DynamicDesignerProvider Class See Also Send Feedback
Initializes a new instance of the DynamicDesignerProvider class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DynamicDesignerProvider(
    TypeDescriptionProvider parent
)
Visual Basic
Public Sub New ( _
    parent As TypeDescriptionProvider _
)
Visual C++
public:
DynamicDesignerProvider(
    TypeDescriptionProvider^ parent
)

Parameters

parent
Type: System.ComponentModel..::..TypeDescriptionProvider

See Also

DynamicDesignerProvider Class


DynamicDesignerProvider Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DynamicDesignerProvider Methods
DynamicDesignerProvider Class See Also Send Feedback

The DynamicDesignerProvider type exposes the following members.

Methods

 | Name | Description
Public method | CreateInstance | Creates an object that can substitute for another data type. (Inherited from TypeDescriptionProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCache | Gets a per-object cache, accessed as an IDictionary of key/value pairs. (Inherited from TypeDescriptionProvider.)
Public method | GetExtendedTypeDescriptor | Gets an extended custom type descriptor for the given object. (Inherited from TypeDescriptionProvider.)
Public method | GetFullComponentName | Gets the name of the specified component, or null if the component has no name. (Inherited from TypeDescriptionProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetReflectionType(Type) | Performs normal reflection against a type. (Inherited from TypeDescriptionProvider.)
Public method | GetReflectionType(Object) | Performs normal reflection against the given object. (Inherited from TypeDescriptionProvider.)
Public method | GetReflectionType(Type, Object) | Performs normal reflection against the given object with the given type. (Inherited from TypeDescriptionProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeDescriptor(Type) | Gets a custom type descriptor for the given type. (Inherited from TypeDescriptionProvider.)
Public method | GetTypeDescriptor(Object) | Gets a custom type descriptor for the given object. (Inherited from TypeDescriptionProvider.)
Public method | GetTypeDescriptor(Type, Object) | (Overrides TypeDescriptionProvider..::..GetTypeDescriptor(Type, Object).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DynamicDesignerProvider Class


GetReflectionType Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DynamicDesignerProvider..::..GetReflectionType Method
DynamicDesignerProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetReflectionType(Type) | Performs normal reflection against a type. (Inherited from TypeDescriptionProvider.)
Public method | GetReflectionType(Object) | Performs normal reflection against the given object. (Inherited from TypeDescriptionProvider.)
Public method | GetReflectionType(Type, Object) | Performs normal reflection against the given object with the given type. (Inherited from TypeDescriptionProvider.)

See Also

DynamicDesignerProvider Class
DynamicDesignerProvider Members


GetTypeDescriptor Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DynamicDesignerProvider..::..GetTypeDescriptor Method
DynamicDesignerProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDescriptor(Type) | Gets a custom type descriptor for the given type. (Inherited from TypeDescriptionProvider.)
Public method | GetTypeDescriptor(Object) | Gets a custom type descriptor for the given object. (Inherited from TypeDescriptionProvider.)
Public method | GetTypeDescriptor(Type, Object) | (Overrides TypeDescriptionProvider..::..GetTypeDescriptor(Type, Object).)

See Also

DynamicDesignerProvider Class
DynamicDesignerProvider Members


GetTypeDescriptor Method (Type, Object)

[image]

VIBlend Controls for WinForms Help Documentation
DynamicDesignerProvider..::..GetTypeDescriptor Method (Type, Object)
DynamicDesignerProvider Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override ICustomTypeDescriptor GetTypeDescriptor(
    Type objectType,
    Object instance
)
Visual Basic
Public Overrides Function GetTypeDescriptor ( _
    objectType As Type, _
    instance As Object _
) As ICustomTypeDescriptor
Visual C++
public:
virtual ICustomTypeDescriptor^ GetTypeDescriptor(
    Type^ objectType,
    Object^ instance
) override

Parameters

objectType
Type: System..::..Type
instance
Type: System..::..Object

See Also

DynamicDesignerProvider Class
GetTypeDescriptor Overload


EdgeBehaviorEnum Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
EdgeBehaviorEnum Enumeration
See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum EdgeBehaviorEnum
Visual Basic
Public Enumeration EdgeBehaviorEnum
Visual C++
public enum class EdgeBehaviorEnum

See Also


EditorAmPmItem Class

[image]

VIBlend Controls for WinForms Help Documentation
EditorAmPmItem Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class EditorAmPmItem : IDateTimeEditor
Visual Basic
Public Class EditorAmPmItem _
    Implements IDateTimeEditor
Visual C++
public ref class EditorAmPmItem : IDateTimeEditor

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..EditorAmPmItem

See Also

EditorAmPmItem Members


EditorAmPmItem Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
EditorAmPmItem Members
EditorAmPmItem Class Constructors Methods Fields Properties See Also Send Feedback

The EditorAmPmItem type exposes the following members.

Constructors

 | Name | Description
Public method | EditorAmPmItem | Initializes a new instance of the EditorAmPmItem class.

Methods

 | Name | Description
Public method | Delete | Deletes this instance.
Public method | Down | Downs this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDateTimeItem | Gets the item.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTextValue | Gets the text.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertString | Inserts the specified inserted.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Up | Ups this instance.

Fields

 | Name | Description
Protected field | amString |
Protected field | pmString |

Properties

 | Name | Description
Public property | TextValue | Gets the text.

See Also

EditorAmPmItem Class


EditorAmPmItem Constructor

[image]

VIBlend Controls for WinForms Help Documentation
EditorAmPmItem Constructor
EditorAmPmItem Class See Also Send Feedback
Initializes a new instance of the EditorAmPmItem class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorAmPmItem(
    string formatValue,
    int baseValue,
    string am,
    string pm,
    DateTimeEditorFormatItem item
)
Visual Basic
Public Sub New ( _
    formatValue As String, _
    baseValue As Integer, _
    am As String, _
    pm As String, _
    item As DateTimeEditorFormatItem _
)
Visual C++
public:
EditorAmPmItem(
    String^ formatValue,
    int baseValue,
    String^ am,
    String^ pm,
    DateTimeEditorFormatItem^ item
)

Parameters

formatValue
Type: System..::..String
The format value.
baseValue
Type: System..::..Int32
The base value.
am
Type: System..::..String
The am.
pm
Type: System..::..String
The pm.
item
Type: VIBlend.WinForms.Controls..::..DateTimeEditorFormatItem
The item.

See Also

EditorAmPmItem Class


EditorAmPmItem Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
EditorAmPmItem Fields
EditorAmPmItem Class See Also Send Feedback

The EditorAmPmItem type exposes the following members.

Fields

 | Name | Description
Protected field | amString |
Protected field | pmString |

See Also

EditorAmPmItem Class


amString Field

[image]

VIBlend Controls for WinForms Help Documentation
EditorAmPmItem..::..amString Field
EditorAmPmItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected string amString
Visual Basic
Protected amString As String
Visual C++
protected:
String^ amString

See Also

EditorAmPmItem Class


pmString Field

[image]

VIBlend Controls for WinForms Help Documentation
EditorAmPmItem..::..pmString Field
EditorAmPmItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected string pmString
Visual Basic
Protected pmString As String
Visual C++
protected:
String^ pmString

See Also

EditorAmPmItem Class


EditorAmPmItem Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
EditorAmPmItem Methods
EditorAmPmItem Class See Also Send Feedback

The EditorAmPmItem type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Deletes this instance.
Public method | Down | Downs this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDateTimeItem | Gets the item.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTextValue | Gets the text.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertString | Inserts the specified inserted.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Up | Ups this instance.

See Also

EditorAmPmItem Class


Delete Method

[image]

VIBlend Controls for WinForms Help Documentation
EditorAmPmItem..::..Delete Method
EditorAmPmItem Class See Also Send Feedback
Deletes this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Delete()
Visual Basic
Public Function Delete As Boolean
Visual C++
public:
bool Delete()

Return Value

See Also

EditorAmPmItem Class


Down Method

[image]

VIBlend Controls for WinForms Help Documentation
EditorAmPmItem..::..Down Method
EditorAmPmItem Class See Also Send Feedback
Downs this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Down()
Visual Basic
Public Function Down As Boolean
Visual C++
public:
virtual bool Down() sealed

Return Value

Implements

IDateTimeEditor..::..Down()()()()

See Also

EditorAmPmItem Class


GetDateTimeItem Method

[image]

VIBlend Controls for WinForms Help Documentation
EditorAmPmItem..::..GetDateTimeItem Method
EditorAmPmItem Class See Also Send Feedback
Gets the item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTimeEditorFormatItem GetDateTimeItem()
Visual Basic
Public Function GetDateTimeItem As DateTimeEditorFormatItem
Visual C++
public:
virtual DateTimeEditorFormatItem^ GetDateTimeItem() sealed

Return Value

Implements

IDateTimeEditor..::..GetDateTimeItem()()()()

See Also

EditorAmPmItem Class


GetTextValue Method

[image]

VIBlend Controls for WinForms Help Documentation
EditorAmPmItem..::..GetTextValue Method
EditorAmPmItem Class See Also Send Feedback
Gets the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public long GetTextValue()
Visual Basic
Public Function GetTextValue As Long
Visual C++
public:
virtual long long GetTextValue() sealed

Return Value

Implements

IDateTimeEditor..::..GetTextValue()()()()

See Also

EditorAmPmItem Class


InsertString Method

[image]

VIBlend Controls for WinForms Help Documentation
EditorAmPmItem..::..InsertString Method
EditorAmPmItem Class See Also Send Feedback
Inserts the specified inserted.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool InsertString(
    string inserted
)
Visual Basic
Public Function InsertString ( _
    inserted As String _
) As Boolean
Visual C++
public:
virtual bool InsertString(
    String^ inserted
) sealed

Parameters

inserted
Type: System..::..String
The inserted.

Return Value

Implements

IDateTimeEditor..::..InsertString(String)

See Also

EditorAmPmItem Class


Up Method

[image]

VIBlend Controls for WinForms Help Documentation
EditorAmPmItem..::..Up Method
EditorAmPmItem Class See Also Send Feedback
Ups this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Up()
Visual Basic
Public Function Up As Boolean
Visual C++
public:
virtual bool Up() sealed

Return Value

Implements

IDateTimeEditor..::..Up()()()()

See Also

EditorAmPmItem Class


EditorAmPmItem Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
EditorAmPmItem Properties
EditorAmPmItem Class See Also Send Feedback

The EditorAmPmItem type exposes the following members.

Properties

 | Name | Description
Public property | TextValue | Gets the text.

See Also

EditorAmPmItem Class


TextValue Property

[image]

VIBlend Controls for WinForms Help Documentation
EditorAmPmItem..::..TextValue Property
EditorAmPmItem Class See Also Send Feedback
Gets the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string TextValue { get; }
Visual Basic
Public ReadOnly Property TextValue As String
    Get
Visual C++
public:
virtual property String^ TextValue {
    String^ get () sealed;
}

Field Value

The text.

Implements

IDateTimeEditor..::..TextValue

See Also

EditorAmPmItem Class


EditorState Class

[image]

VIBlend Controls for WinForms Help Documentation
EditorState Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class EditorState
Visual Basic
Public Class EditorState
Visual C++
public ref class EditorState

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..EditorState

See Also

EditorState Members


EditorState Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
EditorState Members
EditorState Class Constructors Methods Properties See Also Send Feedback

The EditorState type exposes the following members.

Constructors

 | Name | Description
Public method | EditorState | Initializes a new instance of the EditorState class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | SelectionLength | Gets or sets selection length
Public property | SelectionStart | Gets or sets selection start.
Public property | StateType | Gets or sets editor's state type.
Public property | Text | Gets or sets editor's text
Public property | Value | Gets or sets editor's value.

See Also

EditorState Class


EditorState Constructor

[image]

VIBlend Controls for WinForms Help Documentation
EditorState Constructor
EditorState Class See Also Send Feedback
Initializes a new instance of the EditorState class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorState()
Visual Basic
Public Sub New
Visual C++
public:
EditorState()

See Also

EditorState Class


EditorState Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
EditorState Methods
EditorState Class See Also Send Feedback

The EditorState type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EditorState Class


EditorState Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
EditorState Properties
EditorState Class See Also Send Feedback

The EditorState type exposes the following members.

Properties

 | Name | Description
Public property | SelectionLength | Gets or sets selection length
Public property | SelectionStart | Gets or sets selection start.
Public property | StateType | Gets or sets editor's state type.
Public property | Text | Gets or sets editor's text
Public property | Value | Gets or sets editor's value.

See Also

EditorState Class


SelectionLength Property

[image]

VIBlend Controls for WinForms Help Documentation
EditorState..::..SelectionLength Property
EditorState Class See Also Send Feedback
Gets or sets selection length

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int SelectionLength { get; set; }
Visual Basic
Public Property SelectionLength As Integer
    Get
    Set
Visual C++
public:
property int SelectionLength {
    int get ();
    void set (int value);
}

See Also

EditorState Class


SelectionStart Property

[image]

VIBlend Controls for WinForms Help Documentation
EditorState..::..SelectionStart Property
EditorState Class See Also Send Feedback
Gets or sets selection start.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int SelectionStart { get; set; }
Visual Basic
Public Property SelectionStart As Integer
    Get
    Set
Visual C++
public:
property int SelectionStart {
    int get ();
    void set (int value);
}

See Also

EditorState Class


StateType Property

[image]

VIBlend Controls for WinForms Help Documentation
EditorState..::..StateType Property
EditorState Class See Also Send Feedback
Gets or sets editor's state type.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorStateType StateType { get; set; }
Visual Basic
Public Property StateType As EditorStateType
    Get
    Set
Visual C++
public:
property EditorStateType StateType {
    EditorStateType get ();
    void set (EditorStateType value);
}

See Also

EditorState Class


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
EditorState..::..Text Property
EditorState Class See Also Send Feedback
Gets or sets editor's text

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

EditorState Class


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
EditorState..::..Value Property
EditorState Class See Also Send Feedback
Gets or sets editor's value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public decimal Value { get; set; }
Visual Basic
Public Property Value As Decimal
    Get
    Set
Visual C++
public:
property Decimal Value {
    Decimal get ();
    void set (Decimal value);
}

See Also

EditorState Class


EditorStateType Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
EditorStateType Enumeration
See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum EditorStateType
Visual Basic
Public Enumeration EditorStateType
Visual C++
public enum class EditorStateType

Members

Member name | Description
Insert |
Delete |
Selection |

See Also


GalleryButton Class

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButton Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class GalleryButton : vRibbonButton
Visual Basic
Public Class GalleryButton _
    Inherits vRibbonButton
Visual C++
public ref class GalleryButton : public vRibbonButton

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ButtonBase
System.Windows.Forms..::..Button
VIBlend.WinForms.Controls..::..vButton
VIBlend.WinForms.Controls..::..vRibbonButton
VIBlend.WinForms.Controls..::..GalleryButton

See Also

GalleryButton Members


GalleryButton Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton Members
GalleryButton Class Constructors Methods Fields Properties Events See Also Send Feedback

The GalleryButton type exposes the following members.

Constructors

 | Name | Description
Public method | GalleryButton | Initializes a new instance of the GalleryButton class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder | (Inherited from vRibbonButton.)
Protected method | DrawControl | (Inherited from vRibbonButton.)
Protected method | DrawFocusRectangle | (Inherited from vButton.)
Protected method | DrawImageAndText | (Inherited from vButton.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect | (Inherited from vButton.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from vButton.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from vButton.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vButton.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Inherited from vButton.)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vButton.)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Inherited from vButton.)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vButton.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vButton.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

Fields

 | Name | Description
Protected field | buttonBorderStyle | (Inherited from vButton.)
Protected field | opacity | (Inherited from vButton.)
Protected field | paintHelper | (Inherited from vButton.)
Protected field | theme | (Inherited from vButton.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vButton.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button (Inherited from vButton.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Inherited from vButton.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GalleryGroup | Gets or sets the gallery group.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled. (Inherited from vButton.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control. (Inherited from vButton.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsSelected | Gets a value indicating whether this instance is selected.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity. (Inherited from vButton.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vButton.)
Public property | PaintDefaultBorder | Gets or sets a value indicating whether to paint a border when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultFill | Gets or sets a value indicating whether to paint a background when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultStateBorder | Gets or sets a value indicating whether to paint a border (Inherited from vRibbonButton.)
Public property | PaintDefaultStateFill | Gets or sets a value indicating whether to paint a background (Inherited from vRibbonButton.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vButton.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded (Inherited from vButton.)
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control. (Inherited from vButton.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused (Inherited from vButton.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image (Inherited from vButton.)
Public property | StyleKey | Gets or sets the style key. (Inherited from vButton.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control. (Inherited from vButton.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable (Inherited from vButton.)
Public property | Theme | Gets or sets the theme of the control (Inherited from vButton.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control. (Inherited from vButton.)
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control. (Inherited from vButton.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color. (Inherited from vButton.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vButton.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

GalleryButton Class


GalleryButton Constructor

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButton Constructor
GalleryButton Class See Also Send Feedback
Initializes a new instance of the GalleryButton class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GalleryButton()
Visual Basic
Public Sub New
Visual C++
public:
GalleryButton()

See Also

GalleryButton Class


GalleryButton Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton Fields
GalleryButton Class See Also Send Feedback

The GalleryButton type exposes the following members.

Fields

 | Name | Description
Protected field | buttonBorderStyle | (Inherited from vButton.)
Protected field | opacity | (Inherited from vButton.)
Protected field | paintHelper | (Inherited from vButton.)
Protected field | theme | (Inherited from vButton.)

See Also

GalleryButton Class


GalleryButton Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton Methods
GalleryButton Class See Also Send Feedback

The GalleryButton type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder | (Inherited from vRibbonButton.)
Protected method | DrawControl | (Inherited from vRibbonButton.)
Protected method | DrawFocusRectangle | (Inherited from vButton.)
Protected method | DrawImageAndText | (Inherited from vButton.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect | (Inherited from vButton.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from vButton.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from vButton.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vButton.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Inherited from vButton.)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vButton.)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Inherited from vButton.)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vButton.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vButton.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

See Also

GalleryButton Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton..::..AccessibilityNotifyClients Method
GalleryButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

GalleryButton Class
GalleryButton Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton..::..BeginInvoke Method
GalleryButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

GalleryButton Class
GalleryButton Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton..::..Dispose Method
GalleryButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)

See Also

GalleryButton Class
GalleryButton Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton..::..GetChildAtPoint Method
GalleryButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

GalleryButton Class
GalleryButton Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton..::..Invalidate Method
GalleryButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

GalleryButton Class
GalleryButton Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton..::..Invoke Method
GalleryButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

GalleryButton Class
GalleryButton Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton..::..MemberwiseClone Method
GalleryButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

GalleryButton Class
GalleryButton Members


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton..::..PerformLayout Method
GalleryButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

GalleryButton Class
GalleryButton Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton..::..ResumeLayout Method
GalleryButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

GalleryButton Class
GalleryButton Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton..::..RtlTranslateAlignment Method
GalleryButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

GalleryButton Class
GalleryButton Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton..::..Scale Method
GalleryButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

GalleryButton Class
GalleryButton Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton..::..Select Method
GalleryButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

GalleryButton Class
GalleryButton Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton..::..SetBounds Method
GalleryButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

GalleryButton Class
GalleryButton Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton..::..UpdateBounds Method
GalleryButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

GalleryButton Class
GalleryButton Members


GalleryButton Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton Properties
GalleryButton Class See Also Send Feedback

The GalleryButton type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vButton.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button (Inherited from vButton.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Inherited from vButton.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GalleryGroup | Gets or sets the gallery group.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled. (Inherited from vButton.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control. (Inherited from vButton.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsSelected | Gets a value indicating whether this instance is selected.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity. (Inherited from vButton.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vButton.)
Public property | PaintDefaultBorder | Gets or sets a value indicating whether to paint a border when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultFill | Gets or sets a value indicating whether to paint a background when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultStateBorder | Gets or sets a value indicating whether to paint a border (Inherited from vRibbonButton.)
Public property | PaintDefaultStateFill | Gets or sets a value indicating whether to paint a background (Inherited from vRibbonButton.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vButton.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded (Inherited from vButton.)
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control. (Inherited from vButton.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused (Inherited from vButton.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image (Inherited from vButton.)
Public property | StyleKey | Gets or sets the style key. (Inherited from vButton.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control. (Inherited from vButton.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable (Inherited from vButton.)
Public property | Theme | Gets or sets the theme of the control (Inherited from vButton.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control. (Inherited from vButton.)
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control. (Inherited from vButton.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color. (Inherited from vButton.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vButton.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

GalleryButton Class


GalleryGroup Property

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButton..::..GalleryGroup Property
GalleryButton Class See Also Send Feedback
Gets or sets the gallery group.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RibbonBarGalleryGroup GalleryGroup { get; set; }
Visual Basic
Public Property GalleryGroup As RibbonBarGalleryGroup
    Get
    Set
Visual C++
public:
property RibbonBarGalleryGroup^ GalleryGroup {
    RibbonBarGalleryGroup^ get ();
    void set (RibbonBarGalleryGroup^ value);
}

Field Value

The gallery group.

See Also

GalleryButton Class


IsSelected Property

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButton..::..IsSelected Property
GalleryButton Class See Also Send Feedback
Gets a value indicating whether this instance is selected.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsSelected { get; }
Visual Basic
Public ReadOnly Property IsSelected As Boolean
    Get
Visual C++
public:
property bool IsSelected {
    bool get ();
}

Field Value

true if this instance is selected; otherwise, false.

See Also

GalleryButton Class


GalleryButton Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButton Events
GalleryButton Class See Also Send Feedback

The GalleryButton type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

GalleryButton Class


GalleryButtonCollection Class

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class GalleryButtonCollection : IList<GalleryButton>,
    ICollection<GalleryButton>, IEnumerable<GalleryButton>, IList,
    ICollection, IEnumerable
Visual Basic
Public Class GalleryButtonCollection _
    Implements IList(Of GalleryButton), ICollection(Of GalleryButton),  _
    IEnumerable(Of GalleryButton), IList, ICollection, IEnumerable
Visual C++
public ref class GalleryButtonCollection : IList<GalleryButton^>,
    ICollection<GalleryButton^>, IEnumerable<GalleryButton^>, IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..GalleryButtonCollection

See Also

GalleryButtonCollection Members


GalleryButtonCollection Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection Members
GalleryButtonCollection Class Constructors Methods Properties Events See Also Send Feedback

The GalleryButtonCollection type exposes the following members.

Constructors

 | Name | Description
Public method | GalleryButtonCollection | Initializes a new instance of the GalleryButtonCollection class

Methods

 | Name | Description
Public method | Add(Object) | Adds an item to the IList.
Public method | Add(GalleryButton) | Adds an item to the ICollection<(Of <(<'T>)>)>.
Public method | Clear | Removes all items from the ICollection<(Of <(<'T>)>)>.
Public method | Contains(Object) | Determines whether the IList contains a specific value.
Public method | Contains(GalleryButton) | Determines whether the ICollection<(Of <(<'T>)>)> contains a specific value.
Public method | CopyTo(Array, Int32) | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | CopyTo(array<GalleryButton>[]()[][], Int32) | Copies the elements of the ICollection<(Of <(<'T>)>)> to an Array, starting at a particular Array index.
Public method | Dispose | Releases all resources used by the GalleryButtonCollection
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(Object) | Determines the index of a specific item in the IList.
Public method | IndexOf(GalleryButton) | Determines the index of a specific item in the IList<(Of <(<'T>)>)>.
Public method | Insert(Int32, Object) | Inserts an item to the IList at the specified index.
Public method | Insert(Int32, GalleryButton) | Inserts an item to the IList<(Of <(<'T>)>)> at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnButtonsChanged |
Public method | Remove(Object) | Removes the first occurrence of a specific object from the IList.
Public method | Remove(GalleryButton) | Removes the first occurrence of a specific object from the ICollection<(Of <(<'T>)>)>.
Public method | RemoveAt | Removes the IList<(Of <(<'T>)>)> item at the specified index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(<'T>)>)>.
Public property | IsFixedSize | Gets a value indicating whether the IList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(<'T>)>)> is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Public property | Item | Gets or sets the GalleryButton at the specified index.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.

Events

 | Name | Description
Public event | ButtonsChanged |

See Also

GalleryButtonCollection Class


GalleryButtonCollection Constructor

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection Constructor
GalleryButtonCollection Class See Also Send Feedback
Initializes a new instance of the GalleryButtonCollection class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GalleryButtonCollection(
    vRibbonBarGallery gallery
)
Visual Basic
Public Sub New ( _
    gallery As vRibbonBarGallery _
)
Visual C++
public:
GalleryButtonCollection(
    vRibbonBarGallery^ gallery
)

Parameters

gallery
Type: VIBlend.WinForms.Controls..::..vRibbonBarGallery

See Also

GalleryButtonCollection Class


GalleryButtonCollection Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection Methods
GalleryButtonCollection Class See Also Send Feedback

The GalleryButtonCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add(Object) | Adds an item to the IList.
Public method | Add(GalleryButton) | Adds an item to the ICollection<(Of <(<'T>)>)>.
Public method | Clear | Removes all items from the ICollection<(Of <(<'T>)>)>.
Public method | Contains(Object) | Determines whether the IList contains a specific value.
Public method | Contains(GalleryButton) | Determines whether the ICollection<(Of <(<'T>)>)> contains a specific value.
Public method | CopyTo(Array, Int32) | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | CopyTo(array<GalleryButton>[]()[][], Int32) | Copies the elements of the ICollection<(Of <(<'T>)>)> to an Array, starting at a particular Array index.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(Object) | Determines the index of a specific item in the IList.
Public method | IndexOf(GalleryButton) | Determines the index of a specific item in the IList<(Of <(<'T>)>)>.
Public method | Insert(Int32, Object) | Inserts an item to the IList at the specified index.
Public method | Insert(Int32, GalleryButton) | Inserts an item to the IList<(Of <(<'T>)>)> at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnButtonsChanged |
Public method | Remove(Object) | Removes the first occurrence of a specific object from the IList.
Public method | Remove(GalleryButton) | Removes the first occurrence of a specific object from the ICollection<(Of <(<'T>)>)>.
Public method | RemoveAt | Removes the IList<(Of <(<'T>)>)> item at the specified index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GalleryButtonCollection Class


Add Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..Add Method
GalleryButtonCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(Object) | Adds an item to the IList.
Public method | Add(GalleryButton) | Adds an item to the ICollection<(Of <(<'T>)>)>.

See Also

GalleryButtonCollection Class
GalleryButtonCollection Members


Add Method (Object)

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..Add Method (Object)
GalleryButtonCollection Class See Also Send Feedback
Adds an item to the IList.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Add(
    Object value
)
Visual Basic
Public Function Add ( _
    value As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ value
) sealed

Parameters

value
Type: System..::..Object
The Object to add to the IList.

Return Value

The position into which the new element was inserted.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | The IList is read-only. -or- The IList has a fixed size.

See Also

GalleryButtonCollection Class
Add Overload


Add Method (GalleryButton)

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..Add Method (GalleryButton)
GalleryButtonCollection Class See Also Send Feedback
Adds an item to the ICollection<(Of <(<'T>)>)>.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Add(
    GalleryButton item
)
Visual Basic
Public Sub Add ( _
    item As GalleryButton _
)
Visual C++
public:
virtual void Add(
    GalleryButton^ item
) sealed

Parameters

item
Type: VIBlend.WinForms.Controls..::..GalleryButton
The object to add to the ICollection<(Of <(<'T>)>)>.

Implements

ICollection<(Of <(<'T>)>)>..::..Add(T)

Exceptions

Exception | Condition
System..::..NotSupportedException | The ICollection<(Of <(<'T>)>)> is read-only.

See Also

GalleryButtonCollection Class
Add Overload


Clear Method

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..Clear Method
GalleryButtonCollection Class See Also Send Feedback
Removes all items from the ICollection<(Of <(<'T>)>)>.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(<'T>)>)>..::..Clear()()()()
IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | The ICollection<(Of <(<'T>)>)> is read-only.

See Also

GalleryButtonCollection Class


Contains Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..Contains Method
GalleryButtonCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Contains(Object) | Determines whether the IList contains a specific value.
Public method | Contains(GalleryButton) | Determines whether the ICollection<(Of <(<'T>)>)> contains a specific value.

See Also

GalleryButtonCollection Class
GalleryButtonCollection Members


Contains Method (Object)

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..Contains Method (Object)
GalleryButtonCollection Class See Also Send Feedback
Determines whether the IList contains a specific value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Contains(
    Object value
)
Visual Basic
Public Function Contains ( _
    value As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ value
) sealed

Parameters

value
Type: System..::..Object
The Object to locate in the IList.

Return Value

true if the Object is found in the IList; otherwise, false.

Implements

IList..::..Contains(Object)

See Also

GalleryButtonCollection Class
Contains Overload


Contains Method (GalleryButton)

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..Contains Method (GalleryButton)
GalleryButtonCollection Class See Also Send Feedback
Determines whether the ICollection<(Of <(<'T>)>)> contains a specific value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Contains(
    GalleryButton item
)
Visual Basic
Public Function Contains ( _
    item As GalleryButton _
) As Boolean
Visual C++
public:
virtual bool Contains(
    GalleryButton^ item
) sealed

Parameters

item
Type: VIBlend.WinForms.Controls..::..GalleryButton
The object to locate in the ICollection<(Of <(<'T>)>)>.

Return Value

true if item is found in the ICollection<(Of <(<'T>)>)>; otherwise, false.

Implements

ICollection<(Of <(<'T>)>)>..::..Contains(T)

See Also

GalleryButtonCollection Class
Contains Overload


CopyTo Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..CopyTo Method
GalleryButtonCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(Array, Int32) | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | CopyTo(array<GalleryButton>[]()[][], Int32) | Copies the elements of the ICollection<(Of <(<'T>)>)> to an Array, starting at a particular Array index.

See Also

GalleryButtonCollection Class
GalleryButtonCollection Members


CopyTo Method (Array, Int32)

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..CopyTo Method (Array, Int32)
GalleryButtonCollection Class See Also Send Feedback
Copies the elements of the ICollection to an Array, starting at a particular Array index.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from ICollection. The Array must have zero-based indexing.
index
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is null.
System..::..ArgumentOutOfRangeException | index is less than zero.
System..::..ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of elements in the source ICollection is greater than the available space from index to the end of the destination array.
System..::..ArgumentException | The type of the source ICollection cannot be cast automatically to the type of the destination array.

See Also

GalleryButtonCollection Class
CopyTo Overload


CopyTo Method (GalleryButton[], Int32)

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..CopyTo Method (array<GalleryButton>[]()[][], Int32)
GalleryButtonCollection Class See Also Send Feedback
Copies the elements of the ICollection<(Of <(<'T>)>)> to an Array, starting at a particular Array index.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void CopyTo(
    GalleryButton[] array,
    int arrayIndex
)
Visual Basic
Public Sub CopyTo ( _
    array As GalleryButton(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<GalleryButton^>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array< VIBlend.WinForms.Controls..::..GalleryButton >[]()[][]
The one-dimensional Array that is the destination of the elements copied from ICollection<(Of <(<'T>)>)>. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(<'T>)>)>..::..CopyTo(array<T>[]()[][], Int32)

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is null.
System..::..ArgumentOutOfRangeException | arrayIndex is less than 0.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ICollection<(Of <(<'T>)>)> is greater than the available space from arrayIndex to the end of the destination array. -or- Type T cannot be cast automatically to the type of the destination array.

See Also

GalleryButtonCollection Class
CopyTo Overload


Dispose Method

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..Dispose Method
GalleryButtonCollection Class See Also Send Feedback
Releases all resources used by the GalleryButtonCollection

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
void Dispose()

See Also

GalleryButtonCollection Class


GetEnumerator Method

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..GetEnumerator Method
GalleryButtonCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public IEnumerator<GalleryButton> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of GalleryButton)
Visual C++
public:
virtual IEnumerator<GalleryButton^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

GalleryButtonCollection Class


IndexOf Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..IndexOf Method
GalleryButtonCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(Object) | Determines the index of a specific item in the IList.
Public method | IndexOf(GalleryButton) | Determines the index of a specific item in the IList<(Of <(<'T>)>)>.

See Also

GalleryButtonCollection Class
GalleryButtonCollection Members


IndexOf Method (Object)

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..IndexOf Method (Object)
GalleryButtonCollection Class See Also Send Feedback
Determines the index of a specific item in the IList.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int IndexOf(
    Object value
)
Visual Basic
Public Function IndexOf ( _
    value As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ value
) sealed

Parameters

value
Type: System..::..Object
The Object to locate in the IList.

Return Value

The index of value if found in the list; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

GalleryButtonCollection Class
IndexOf Overload


IndexOf Method (GalleryButton)

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..IndexOf Method (GalleryButton)
GalleryButtonCollection Class See Also Send Feedback
Determines the index of a specific item in the IList<(Of <(<'T>)>)>.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int IndexOf(
    GalleryButton item
)
Visual Basic
Public Function IndexOf ( _
    item As GalleryButton _
) As Integer
Visual C++
public:
virtual int IndexOf(
    GalleryButton^ item
) sealed

Parameters

item
Type: VIBlend.WinForms.Controls..::..GalleryButton
The object to locate in the IList<(Of <(<'T>)>)>.

Return Value

The index of item if found in the list; otherwise, -1.

Implements

IList<(Of <(<'T>)>)>..::..IndexOf(T)

See Also

GalleryButtonCollection Class
IndexOf Overload


Insert Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..Insert Method
GalleryButtonCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Insert(Int32, Object) | Inserts an item to the IList at the specified index.
Public method | Insert(Int32, GalleryButton) | Inserts an item to the IList<(Of <(<'T>)>)> at the specified index.

See Also

GalleryButtonCollection Class
GalleryButtonCollection Members


Insert Method (Int32, Object)

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..Insert Method (Int32, Object)
GalleryButtonCollection Class See Also Send Feedback
Inserts an item to the IList at the specified index.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Insert(
    int index,
    Object value
)
Visual Basic
Public Sub Insert ( _
    index As Integer, _
    value As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ value
) sealed

Parameters

index
Type: System..::..Int32
The zero-based index at which value should be inserted.
value
Type: System..::..Object
The Object to insert into the IList.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is not a valid index in the IList.
System..::..NotSupportedException | The IList is read-only. -or- The IList has a fixed size.
System..::..NullReferenceException | value is null reference in the IList.

See Also

GalleryButtonCollection Class
Insert Overload


Insert Method (Int32, GalleryButton)

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..Insert Method (Int32, GalleryButton)
GalleryButtonCollection Class See Also Send Feedback
Inserts an item to the IList<(Of <(<'T>)>)> at the specified index.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Insert(
    int index,
    GalleryButton item
)
Visual Basic
Public Sub Insert ( _
    index As Integer, _
    item As GalleryButton _
)
Visual C++
public:
virtual void Insert(
    int index,
    GalleryButton^ item
) sealed

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: VIBlend.WinForms.Controls..::..GalleryButton
The object to insert into the IList<(Of <(<'T>)>)>.

Implements

IList<(Of <(<'T>)>)>..::..Insert(Int32, T)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is not a valid index in the IList<(Of <(<'T>)>)>.
System..::..NotSupportedException | The IList<(Of <(<'T>)>)> is read-only.

See Also

GalleryButtonCollection Class
Insert Overload


OnButtonsChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..OnButtonsChanged Method
GalleryButtonCollection Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnButtonsChanged()
Visual Basic
Protected Overridable Sub OnButtonsChanged
Visual C++
protected:
virtual void OnButtonsChanged()

See Also

GalleryButtonCollection Class


Remove Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..Remove Method
GalleryButtonCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(Object) | Removes the first occurrence of a specific object from the IList.
Public method | Remove(GalleryButton) | Removes the first occurrence of a specific object from the ICollection<(Of <(<'T>)>)>.

See Also

GalleryButtonCollection Class
GalleryButtonCollection Members


Remove Method (Object)

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..Remove Method (Object)
GalleryButtonCollection Class See Also Send Feedback
Removes the first occurrence of a specific object from the IList.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Remove(
    Object value
)
Visual Basic
Public Sub Remove ( _
    value As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ value
) sealed

Parameters

value
Type: System..::..Object
The Object to remove from the IList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | The IList is read-only. -or- The IList has a fixed size.

See Also

GalleryButtonCollection Class
Remove Overload


Remove Method (GalleryButton)

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..Remove Method (GalleryButton)
GalleryButtonCollection Class See Also Send Feedback
Removes the first occurrence of a specific object from the ICollection<(Of <(<'T>)>)>.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Remove(
    GalleryButton item
)
Visual Basic
Public Function Remove ( _
    item As GalleryButton _
) As Boolean
Visual C++
public:
virtual bool Remove(
    GalleryButton^ item
) sealed

Parameters

item
Type: VIBlend.WinForms.Controls..::..GalleryButton
The object to remove from the ICollection<(Of <(<'T>)>)>.

Return Value

true if item was successfully removed from the ICollection<(Of <(<'T>)>)>; otherwise, false. This method also returns false if item is not found in the original ICollection<(Of <(<'T>)>)>.

Implements

ICollection<(Of <(<'T>)>)>..::..Remove(T)

Exceptions

Exception | Condition
System..::..NotSupportedException | The ICollection<(Of <(<'T>)>)> is read-only.

See Also

GalleryButtonCollection Class
Remove Overload


RemoveAt Method

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..RemoveAt Method
GalleryButtonCollection Class See Also Send Feedback
Removes the IList<(Of <(<'T>)>)> item at the specified index.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
) sealed

Parameters

index
Type: System..::..Int32
The zero-based index of the item to remove.

Implements

IList<(Of <(<'T>)>)>..::..RemoveAt(Int32)
IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is not a valid index in the IList<(Of <(<'T>)>)>.
System..::..NotSupportedException | The IList<(Of <(<'T>)>)> is read-only.

See Also

GalleryButtonCollection Class


GalleryButtonCollection Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection Properties
GalleryButtonCollection Class See Also Send Feedback

The GalleryButtonCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(<'T>)>)>.
Public property | IsFixedSize | Gets a value indicating whether the IList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(<'T>)>)> is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Public property | Item | Gets or sets the GalleryButton at the specified index.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.

See Also

GalleryButtonCollection Class


Count Property

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..Count Property
GalleryButtonCollection Class See Also Send Feedback
Gets the number of elements contained in the ICollection<(Of <(<'T>)>)>.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Field Value

Return Value

The number of elements contained in the ICollection<(Of <(<'T>)>)>.

Implements

ICollection<(Of <(<'T>)>)>..::..Count
ICollection..::..Count

See Also

GalleryButtonCollection Class


IsFixedSize Property

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..IsFixedSize Property
GalleryButtonCollection Class See Also Send Feedback
Gets a value indicating whether the IList has a fixed size.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsFixedSize { get; }
Visual Basic
Public ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get () sealed;
}

Field Value

Return Value

true if the IList has a fixed size; otherwise, false.

Implements

IList..::..IsFixedSize

See Also

GalleryButtonCollection Class


IsReadOnly Property

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..IsReadOnly Property
GalleryButtonCollection Class See Also Send Feedback
Gets a value indicating whether the ICollection<(Of <(<'T>)>)> is read-only.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic
Public ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Field Value

Return Value

true if the ICollection<(Of <(<'T>)>)> is read-only; otherwise, false.

Implements

ICollection<(Of <(<'T>)>)>..::..IsReadOnly
IList..::..IsReadOnly

See Also

GalleryButtonCollection Class


IsSynchronized Property

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..IsSynchronized Property
GalleryButtonCollection Class See Also Send Feedback
Gets a value indicating whether access to the ICollection is synchronized (thread safe).

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic
Public ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Field Value

Return Value

true if access to the ICollection is synchronized (thread safe); otherwise, false.

Implements

ICollection..::..IsSynchronized

See Also

GalleryButtonCollection Class


Item Property

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..Item Property
GalleryButtonCollection Class See Also Send Feedback
Gets or sets the GalleryButton at the specified index.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GalleryButton this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item ( _
    index As Integer _
) As GalleryButton
    Get
    Set
Visual C++
public:
virtual property GalleryButton^ default[int index] {
    GalleryButton^ get (int index) sealed;
    void set (int index, GalleryButton^ value) sealed;
}

Parameters

index
Type: System..::..Int32

Field Value

Implements

IList<(Of <(<'T>)>)>..::..Item[([( Int32])])

See Also

GalleryButtonCollection Class


SyncRoot Property

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..SyncRoot Property
GalleryButtonCollection Class See Also Send Feedback
Gets an object that can be used to synchronize access to the ICollection.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic
Public ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}

Field Value

Return Value

An object that can be used to synchronize access to the ICollection.

Implements

ICollection..::..SyncRoot

See Also

GalleryButtonCollection Class


GalleryButtonCollection Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection Events
GalleryButtonCollection Class See Also Send Feedback

The GalleryButtonCollection type exposes the following members.

Events

 | Name | Description
Public event | ButtonsChanged |

See Also

GalleryButtonCollection Class


ButtonsChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
GalleryButtonCollection..::..ButtonsChanged Event
GalleryButtonCollection Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ButtonsChanged
Visual Basic
Public Event ButtonsChanged As EventHandler
Visual C++
public:
 event EventHandler^ ButtonsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

GalleryButtonCollection Class


GlassFormUtility Class

[image]

VIBlend Controls for WinForms Help Documentation
GlassFormUtility Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class GlassFormUtility
Visual Basic
Public Class GlassFormUtility
Visual C++
public ref class GlassFormUtility

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..GlassFormUtility

See Also

GlassFormUtility Members


GlassFormUtility Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
GlassFormUtility Members
GlassFormUtility Class Constructors Methods Properties See Also Send Feedback

The GlassFormUtility type exposes the following members.

Constructors

 | Name | Description
Public method | GlassFormUtility | Creates a new helper for the specified form

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Form_Activated | Called when helped form is activated
Public method | Form_Paint | Called when helped form is activated
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPointFromPtr |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetWindowRect |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NonClientHitTest | Performs hit test for mouse on the non client area of the form
 | RoundRectangle | Creates a rectangle with the specified corners rounded
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WndProc | Processes the WndProc for a form with a Ribbbon. Returns true if message has been handled

Properties

 | Name | Description
Public property | Form | Gets the form this class is helping
Public property | Margins | Gets the margins of the non-client area
Public property | Ribbon | Gets or sets the Ribbon related with the form

See Also

GlassFormUtility Class


GlassFormUtility Constructor

[image]

VIBlend Controls for WinForms Help Documentation
GlassFormUtility Constructor
GlassFormUtility Class See Also Send Feedback
Creates a new helper for the specified form

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GlassFormUtility(
    OfficeRibbonForm f
)
Visual Basic
Public Sub New ( _
    f As OfficeRibbonForm _
)
Visual C++
public:
GlassFormUtility(
    OfficeRibbonForm^ f
)

Parameters

f
Type: VIBlend.WinForms.Controls..::..OfficeRibbonForm

See Also

GlassFormUtility Class


GlassFormUtility Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
GlassFormUtility Methods
GlassFormUtility Class See Also Send Feedback

The GlassFormUtility type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | Form_Activated | Called when helped form is activated
Public method | Form_Paint | Called when helped form is activated
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPointFromPtr |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetWindowRect |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NonClientHitTest | Performs hit test for mouse on the non client area of the form
 | RoundRectangle | Creates a rectangle with the specified corners rounded
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WndProc | Processes the WndProc for a form with a Ribbbon. Returns true if message has been handled

See Also

GlassFormUtility Class


Form_Activated Method

[image]

VIBlend Controls for WinForms Help Documentation
GlassFormUtility..::..Form_Activated Method
GlassFormUtility Class See Also Send Feedback
Called when helped form is activated

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void Form_Activated(
    Object sender,
    EventArgs e
)
Visual Basic
Protected Overridable Sub Form_Activated ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
protected:
virtual void Form_Activated(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::..Object
Object that raised the event
e
Type: System..::..EventArgs
Event data

See Also

GlassFormUtility Class


Form_Paint Method

[image]

VIBlend Controls for WinForms Help Documentation
GlassFormUtility..::..Form_Paint Method
GlassFormUtility Class See Also Send Feedback
Called when helped form is activated

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Form_Paint(
    Object sender,
    PaintEventArgs e
)
Visual Basic
Public Sub Form_Paint ( _
    sender As Object, _
    e As PaintEventArgs _
)
Visual C++
public:
void Form_Paint(
    Object^ sender,
    PaintEventArgs^ e
)

Parameters

sender
Type: System..::..Object
Object that raised the event
e
Type: System.Windows.Forms..::..PaintEventArgs
Event data

See Also

GlassFormUtility Class


GetPointFromPtr Method

[image]

VIBlend Controls for WinForms Help Documentation
GlassFormUtility..::..GetPointFromPtr Method
GlassFormUtility Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Point GetPointFromPtr(
    IntPtr ptr
)
Visual Basic
Public Function GetPointFromPtr ( _
    ptr As IntPtr _
) As Point
Visual C++
public:
Point GetPointFromPtr(
    IntPtr ptr
)

Parameters

ptr
Type: System..::..IntPtr

See Also

GlassFormUtility Class


GetWindowRect Method

[image]

VIBlend Controls for WinForms Help Documentation
GlassFormUtility..::..GetWindowRect Method
GlassFormUtility Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static bool GetWindowRect(
    IntPtr hWnd,
    ref RECT lpRect
)
Visual Basic
Public Shared Function GetWindowRect ( _
    hWnd As IntPtr, _
    ByRef lpRect As RECT _
) As Boolean
Visual C++
public:
static bool GetWindowRect(
    IntPtr hWnd,
    RECT% lpRect
)

Parameters

hWnd
Type: System..::..IntPtr
lpRect
Type: VIBlend.WinForms.Controls..::..RECT %

See Also

GlassFormUtility Class


NonClientHitTest Method

[image]

VIBlend Controls for WinForms Help Documentation
GlassFormUtility..::..NonClientHitTest Method
GlassFormUtility Class See Also Send Feedback
Performs hit test for mouse on the non client area of the form

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual GlassFormUtility..::..NonClientHitTestResult NonClientHitTest(
    Point hitPoint
)
Visual Basic
Public Overridable Function NonClientHitTest ( _
    hitPoint As Point _
) As GlassFormUtility..::..NonClientHitTestResult
Visual C++
public:
virtual GlassFormUtility..::..NonClientHitTestResult NonClientHitTest(
    Point hitPoint
)

Parameters

hitPoint
Type: System.Drawing..::..Point

Return Value

See Also

GlassFormUtility Class


RoundRectangle Method

[image]

VIBlend Controls for WinForms Help Documentation
GlassFormUtility..::..RoundRectangle Method
GlassFormUtility Class See Also Send Feedback
Creates a rectangle with the specified corners rounded

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static GraphicsPath RoundRectangle(
    Rectangle r,
    int radius
)
Visual Basic
Public Shared Function RoundRectangle ( _
    r As Rectangle, _
    radius As Integer _
) As GraphicsPath
Visual C++
public:
static GraphicsPath^ RoundRectangle(
    Rectangle r,
    int radius
)

Parameters

r
Type: System.Drawing..::..Rectangle
radius
Type: System..::..Int32

Return Value

See Also

GlassFormUtility Class


WndProc Method

[image]

VIBlend Controls for WinForms Help Documentation
GlassFormUtility..::..WndProc Method
GlassFormUtility Class See Also Send Feedback
Processes the WndProc for a form with a Ribbbon. Returns true if message has been handled

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool WndProc(
    ref Message m
)
Visual Basic
Public Overridable Function WndProc ( _
    ByRef m As Message _
) As Boolean
Visual C++
public:
virtual bool WndProc(
    Message% m
)

Parameters

m
Type: System.Windows.Forms..::..Message %
Message to process

Return Value

true if message has been handled. false otherwise

See Also

GlassFormUtility Class


GlassFormUtility Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
GlassFormUtility Properties
GlassFormUtility Class See Also Send Feedback

The GlassFormUtility type exposes the following members.

Properties

 | Name | Description
Public property | Form | Gets the form this class is helping
Public property | Margins | Gets the margins of the non-client area
Public property | Ribbon | Gets or sets the Ribbon related with the form

See Also

GlassFormUtility Class


Form Property

[image]

VIBlend Controls for WinForms Help Documentation
GlassFormUtility..::..Form Property
GlassFormUtility Class See Also Send Feedback
Gets the form this class is helping

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public OfficeRibbonForm Form { get; }
Visual Basic
Public ReadOnly Property Form As OfficeRibbonForm
    Get
Visual C++
public:
property OfficeRibbonForm^ Form {
    OfficeRibbonForm^ get ();
}

See Also

GlassFormUtility Class


Margins Property

[image]

VIBlend Controls for WinForms Help Documentation
GlassFormUtility..::..Margins Property
GlassFormUtility Class See Also Send Feedback
Gets the margins of the non-client area

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Padding Margins { get; }
Visual Basic
Public ReadOnly Property Margins As Padding
    Get
Visual C++
public:
property Padding Margins {
    Padding get ();
}

See Also

GlassFormUtility Class


Ribbon Property

[image]

VIBlend Controls for WinForms Help Documentation
GlassFormUtility..::..Ribbon Property
GlassFormUtility Class See Also Send Feedback
Gets or sets the Ribbon related with the form

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonBar Ribbon { get; internal set; }
Visual Basic
Public Property Ribbon As vRibbonBar
    Get
    Friend Set
Visual C++
public:
property vRibbonBar^ Ribbon {
    vRibbonBar^ get ();
    internal: void set (vRibbonBar^ value);
}

See Also

GlassFormUtility Class


GlassFormUtility.NonClientHitTestResult Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
GlassFormUtility..::..NonClientHitTestResult Enumeration
GlassFormUtility Class See Also Send Feedback
Possible results of a hit test on the non client area of a form

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum NonClientHitTestResult
Visual Basic
Public Enumeration NonClientHitTestResult
Visual C++
public enum class NonClientHitTestResult

Members

Member name | Description
Nowhere |
Client |
Caption |
GrowBox |
MinimizeButton |
MaximizeButton |
Left |
Right |
Top |
TopLeft |
TopRight |
Bottom |
BottomLeft |
BottomRight |

See Also


GlobalHook Class

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class GlobalHook : IDisposable
Visual Basic
Public Class GlobalHook _
    Implements IDisposable
Visual C++
public ref class GlobalHook : IDisposable

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..GlobalHook

See Also

GlobalHook Members


GlobalHook Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
GlobalHook Members
GlobalHook Class Constructors Methods Properties Events See Also Send Feedback

The GlobalHook type exposes the following members.

Constructors

 | Name | Description
Public method | GlobalHook | Creates a new Hook of the specified type

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the GlobalHook
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnKeyDown | Raises the KeyDown event
Protected method | OnKeyPress | Raises the KeyPress event
Protected method | OnKeyUp | Raises the KeyUp event
Protected method | OnMouseClick | Raises the MouseClick event
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event
Protected method | OnMouseDown | Raises the MouseDown event
Protected method | OnMouseMove | Raises the MouseMove event
Protected method | OnMouseUp | Raises the MouseUp event
Protected method | OnMouseWheel | Raises the MouseWheel event
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Handle | Gets the handle of the hook
Public property | HookType | Gets the type of this hook

Events

 | Name | Description
Public event | KeyDown | Occours when a key is pressed
Public event | KeyPress | Occours when a key is pressed
Public event | KeyUp | Occours when a key is released
Public event | MouseClick | Occours when the hook captures a mouse click
Public event | MouseDoubleClick | Occours when the hook captures a mouse double click
Public event | MouseDown | Occours when the hook captures the press of a mouse button
Public event | MouseMove | Occours when the hook captures the mouse moving over the screen
Public event | MouseUp | Occours when the hook captures the release of a mouse button
Public event | MouseWheel | Occours when the hook captures the mouse wheel

See Also

GlobalHook Class


GlobalHook Constructor

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook Constructor
GlobalHook Class See Also Send Feedback
Creates a new Hook of the specified type

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GlobalHook(
    GlobalHook..::..HookTypes hookType
)
Visual Basic
Public Sub New ( _
    hookType As GlobalHook..::..HookTypes _
)
Visual C++
public:
GlobalHook(
    GlobalHook..::..HookTypes hookType
)

Parameters

hookType
Type: VIBlend.WinForms.Controls..::..GlobalHook..::..HookTypes

See Also

GlobalHook Class


GlobalHook Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
GlobalHook Methods
GlobalHook Class See Also Send Feedback

The GlobalHook type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnKeyDown | Raises the KeyDown event
Protected method | OnKeyPress | Raises the KeyPress event
Protected method | OnKeyUp | Raises the KeyUp event
Protected method | OnMouseClick | Raises the MouseClick event
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event
Protected method | OnMouseDown | Raises the MouseDown event
Protected method | OnMouseMove | Raises the MouseMove event
Protected method | OnMouseUp | Raises the MouseUp event
Protected method | OnMouseWheel | Raises the MouseWheel event
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GlobalHook Class


Dispose Method

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..Dispose Method
GlobalHook Class See Also Send Feedback
Releases all resources used by the GlobalHook

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

GlobalHook Class


Finalize Method

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..Finalize Method
GlobalHook Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

GlobalHook Class


OnKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..OnKeyDown Method
GlobalHook Class See Also Send Feedback
Raises the KeyDown event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overridable Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
Event Data

See Also

GlobalHook Class


OnKeyPress Method

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..OnKeyPress Method
GlobalHook Class See Also Send Feedback
Raises the KeyPress event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnKeyPress(
    KeyPressEventArgs e
)
Visual Basic
Protected Overridable Sub OnKeyPress ( _
    e As KeyPressEventArgs _
)
Visual C++
protected:
virtual void OnKeyPress(
    KeyPressEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..KeyPressEventArgs
Event Data

See Also

GlobalHook Class


OnKeyUp Method

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..OnKeyUp Method
GlobalHook Class See Also Send Feedback
Raises the KeyUp event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnKeyUp(
    KeyEventArgs e
)
Visual Basic
Protected Overridable Sub OnKeyUp ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyUp(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
Event Data

See Also

GlobalHook Class


OnMouseClick Method

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..OnMouseClick Method
GlobalHook Class See Also Send Feedback
Raises the MouseClick event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnMouseClick(
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub OnMouseClick ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseClick(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

GlobalHook Class


OnMouseDoubleClick Method

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..OnMouseDoubleClick Method
GlobalHook Class See Also Send Feedback
Raises the MouseDoubleClick event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnMouseDoubleClick(
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub OnMouseDoubleClick ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDoubleClick(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

GlobalHook Class


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..OnMouseDown Method
GlobalHook Class See Also Send Feedback
Raises the MouseDown event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

GlobalHook Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..OnMouseMove Method
GlobalHook Class See Also Send Feedback
Raises the MouseMove event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

GlobalHook Class


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..OnMouseUp Method
GlobalHook Class See Also Send Feedback
Raises the MouseUp event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

GlobalHook Class


OnMouseWheel Method

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..OnMouseWheel Method
GlobalHook Class See Also Send Feedback
Raises the MouseWheel event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnMouseWheel(
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub OnMouseWheel ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseWheel(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

GlobalHook Class


GlobalHook Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
GlobalHook Properties
GlobalHook Class See Also Send Feedback

The GlobalHook type exposes the following members.

Properties

 | Name | Description
Public property | Handle | Gets the handle of the hook
Public property | HookType | Gets the type of this hook

See Also

GlobalHook Class


Handle Property

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..Handle Property
GlobalHook Class See Also Send Feedback
Gets the handle of the hook

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Handle { get; }
Visual Basic
Public ReadOnly Property Handle As Integer
    Get
Visual C++
public:
property int Handle {
    int get ();
}

See Also

GlobalHook Class


HookType Property

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..HookType Property
GlobalHook Class See Also Send Feedback
Gets the type of this hook

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GlobalHook..::..HookTypes HookType { get; }
Visual Basic
Public ReadOnly Property HookType As GlobalHook..::..HookTypes
    Get
Visual C++
public:
property GlobalHook..::..HookTypes HookType {
    GlobalHook..::..HookTypes get ();
}

See Also

GlobalHook Class


GlobalHook Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
GlobalHook Events
GlobalHook Class See Also Send Feedback

The GlobalHook type exposes the following members.

Events

 | Name | Description
Public event | KeyDown | Occours when a key is pressed
Public event | KeyPress | Occours when a key is pressed
Public event | KeyUp | Occours when a key is released
Public event | MouseClick | Occours when the hook captures a mouse click
Public event | MouseDoubleClick | Occours when the hook captures a mouse double click
Public event | MouseDown | Occours when the hook captures the press of a mouse button
Public event | MouseMove | Occours when the hook captures the mouse moving over the screen
Public event | MouseUp | Occours when the hook captures the release of a mouse button
Public event | MouseWheel | Occours when the hook captures the mouse wheel

See Also

GlobalHook Class


KeyDown Event

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..KeyDown Event
GlobalHook Class See Also Send Feedback
Occours when a key is pressed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event KeyEventHandler KeyDown
Visual Basic
Public Event KeyDown As KeyEventHandler
Visual C++
public:
 event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}

See Also

GlobalHook Class


KeyPress Event

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..KeyPress Event
GlobalHook Class See Also Send Feedback
Occours when a key is pressed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event KeyPressEventHandler KeyPress
Visual Basic
Public Event KeyPress As KeyPressEventHandler
Visual C++
public:
 event KeyPressEventHandler^ KeyPress {
    void add (KeyPressEventHandler^ value);
    void remove (KeyPressEventHandler^ value);
}

See Also

GlobalHook Class


KeyUp Event

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..KeyUp Event
GlobalHook Class See Also Send Feedback
Occours when a key is released

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event KeyEventHandler KeyUp
Visual Basic
Public Event KeyUp As KeyEventHandler
Visual C++
public:
 event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}

See Also

GlobalHook Class


MouseClick Event

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..MouseClick Event
GlobalHook Class See Also Send Feedback
Occours when the hook captures a mouse click

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event MouseEventHandler MouseClick
Visual Basic
Public Event MouseClick As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseClick {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

GlobalHook Class


MouseDoubleClick Event

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..MouseDoubleClick Event
GlobalHook Class See Also Send Feedback
Occours when the hook captures a mouse double click

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event MouseEventHandler MouseDoubleClick
Visual Basic
Public Event MouseDoubleClick As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseDoubleClick {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

GlobalHook Class


MouseDown Event

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..MouseDown Event
GlobalHook Class See Also Send Feedback
Occours when the hook captures the press of a mouse button

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event MouseEventHandler MouseDown
Visual Basic
Public Event MouseDown As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseDown {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

GlobalHook Class


MouseMove Event

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..MouseMove Event
GlobalHook Class See Also Send Feedback
Occours when the hook captures the mouse moving over the screen

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event MouseEventHandler MouseMove
Visual Basic
Public Event MouseMove As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseMove {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

GlobalHook Class


MouseUp Event

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..MouseUp Event
GlobalHook Class See Also Send Feedback
Occours when the hook captures the release of a mouse button

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event MouseEventHandler MouseUp
Visual Basic
Public Event MouseUp As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseUp {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

GlobalHook Class


MouseWheel Event

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..MouseWheel Event
GlobalHook Class See Also Send Feedback
Occours when the hook captures the mouse wheel

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event MouseEventHandler MouseWheel
Visual Basic
Public Event MouseWheel As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseWheel {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

GlobalHook Class


GlobalHook.HookTypes Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
GlobalHook..::..HookTypes Enumeration
GlobalHook Class See Also Send Feedback
Types of available hooks

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum HookTypes
Visual Basic
Public Enumeration HookTypes
Visual C++
public enum class HookTypes

Members

Member name | Description
Mouse |
Keyboard |

See Also


IDateTimeEditor Interface

[image]

VIBlend Controls for WinForms Help Documentation
IDateTimeEditor Interface
Members See Also Send Feedback
Base Class For All Editors

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public interface IDateTimeEditor
Visual Basic
Public Interface IDateTimeEditor
Visual C++
public interface class IDateTimeEditor

See Also

IDateTimeEditor Members


IDateTimeEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
IDateTimeEditor Members
IDateTimeEditor Interface Methods Properties See Also Send Feedback

The IDateTimeEditor type exposes the following members.

Methods

 | Name | Description
Public method | Down |
Public method | GetDateTimeItem |
Public method | GetTextValue |
Public method | InsertString |
Public method | Up |

Properties

 | Name | Description
Public property | TextValue |

See Also

IDateTimeEditor Interface


IDateTimeEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
IDateTimeEditor Methods
IDateTimeEditor Interface See Also Send Feedback

The IDateTimeEditor type exposes the following members.

Methods

 | Name | Description
Public method | Down |
Public method | GetDateTimeItem |
Public method | GetTextValue |
Public method | InsertString |
Public method | Up |

See Also

IDateTimeEditor Interface


Down Method

[image]

VIBlend Controls for WinForms Help Documentation
IDateTimeEditor..::..Down Method
IDateTimeEditor Interface See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
bool Down()
Visual Basic
Function Down As Boolean
Visual C++
bool Down()

See Also

IDateTimeEditor Interface


GetDateTimeItem Method

[image]

VIBlend Controls for WinForms Help Documentation
IDateTimeEditor..::..GetDateTimeItem Method
IDateTimeEditor Interface See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
DateTimeEditorFormatItem GetDateTimeItem()
Visual Basic
Function GetDateTimeItem As DateTimeEditorFormatItem
Visual C++
DateTimeEditorFormatItem^ GetDateTimeItem()

See Also

IDateTimeEditor Interface


GetTextValue Method

[image]

VIBlend Controls for WinForms Help Documentation
IDateTimeEditor..::..GetTextValue Method
IDateTimeEditor Interface See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
long GetTextValue()
Visual Basic
Function GetTextValue As Long
Visual C++
long long GetTextValue()

See Also

IDateTimeEditor Interface


InsertString Method

[image]

VIBlend Controls for WinForms Help Documentation
IDateTimeEditor..::..InsertString Method
IDateTimeEditor Interface See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
bool InsertString(
    string inserted
)
Visual Basic
Function InsertString ( _
    inserted As String _
) As Boolean
Visual C++
bool InsertString(
    String^ inserted
)

Parameters

inserted
Type: System..::..String

See Also

IDateTimeEditor Interface


Up Method

[image]

VIBlend Controls for WinForms Help Documentation
IDateTimeEditor..::..Up Method
IDateTimeEditor Interface See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
bool Up()
Visual Basic
Function Up As Boolean
Visual C++
bool Up()

See Also

IDateTimeEditor Interface


IDateTimeEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
IDateTimeEditor Properties
IDateTimeEditor Interface See Also Send Feedback

The IDateTimeEditor type exposes the following members.

Properties

 | Name | Description
Public property | TextValue |

See Also

IDateTimeEditor Interface


TextValue Property

[image]

VIBlend Controls for WinForms Help Documentation
IDateTimeEditor..::..TextValue Property
IDateTimeEditor Interface See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
string TextValue { get; }
Visual Basic
ReadOnly Property TextValue As String
    Get
Visual C++
property String^ TextValue {
    String^ get ();
}

See Also

IDateTimeEditor Interface


ImageAndTextHelper Class

[image]

VIBlend Controls for WinForms Help Documentation
ImageAndTextHelper Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class ImageAndTextHelper
Visual Basic
Public Class ImageAndTextHelper
Visual C++
public ref class ImageAndTextHelper

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..ImageAndTextHelper

See Also

ImageAndTextHelper Members


ImageAndTextHelper Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
ImageAndTextHelper Members
ImageAndTextHelper Class Constructors Methods See Also Send Feedback

The ImageAndTextHelper type exposes the following members.

Constructors

 | Name | Description
Public method | ImageAndTextHelper | Initializes a new instance of the ImageAndTextHelper class

Methods

 | Name | Description
 | DrawDisabledText |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBackgroundImageRectangle |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetImageRectangle |
 | GetStringFormat |
 | GetTextImageRectangle |
 | GetTextSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeTextAndImageRectangles |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageAndTextHelper Class


ImageAndTextHelper Constructor

[image]

VIBlend Controls for WinForms Help Documentation
ImageAndTextHelper Constructor
ImageAndTextHelper Class See Also Send Feedback
Initializes a new instance of the ImageAndTextHelper class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ImageAndTextHelper()
Visual Basic
Public Sub New
Visual C++
public:
ImageAndTextHelper()

See Also

ImageAndTextHelper Class


ImageAndTextHelper Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
ImageAndTextHelper Methods
ImageAndTextHelper Class See Also Send Feedback

The ImageAndTextHelper type exposes the following members.

Methods

 | Name | Description
 | DrawDisabledText |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBackgroundImageRectangle |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetImageRectangle |
 | GetStringFormat |
 | GetTextImageRectangle |
 | GetTextSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeTextAndImageRectangles |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageAndTextHelper Class


DrawDisabledText Method

[image]

VIBlend Controls for WinForms Help Documentation
ImageAndTextHelper..::..DrawDisabledText Method
ImageAndTextHelper Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static void DrawDisabledText(
    Graphics graphics,
    string s,
    Font font,
    Color color,
    RectangleF layoutRectangle,
    StringFormat format
)
Visual Basic
Public Shared Sub DrawDisabledText ( _
    graphics As Graphics, _
    s As String, _
    font As Font, _
    color As Color, _
    layoutRectangle As RectangleF, _
    format As StringFormat _
)
Visual C++
public:
static void DrawDisabledText(
    Graphics^ graphics,
    String^ s,
    Font^ font,
    Color color,
    RectangleF layoutRectangle,
    StringFormat^ format
)

Parameters

graphics
Type: System.Drawing..::..Graphics
s
Type: System..::..String
font
Type: System.Drawing..::..Font
color
Type: System.Drawing..::..Color
layoutRectangle
Type: System.Drawing..::..RectangleF
format
Type: System.Drawing..::..StringFormat

See Also

ImageAndTextHelper Class


GetBackgroundImageRectangle Method

[image]

VIBlend Controls for WinForms Help Documentation
ImageAndTextHelper..::..GetBackgroundImageRectangle Method
ImageAndTextHelper Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Rectangle GetBackgroundImageRectangle(
    Rectangle bounds,
    Image backgroundImage,
    ImageLayout imageLayout
)
Visual Basic
Public Shared Function GetBackgroundImageRectangle ( _
    bounds As Rectangle, _
    backgroundImage As Image, _
    imageLayout As ImageLayout _
) As Rectangle
Visual C++
public:
static Rectangle GetBackgroundImageRectangle(
    Rectangle bounds,
    Image^ backgroundImage,
    ImageLayout imageLayout
)

Parameters

bounds
Type: System.Drawing..::..Rectangle
backgroundImage
Type: System.Drawing..::..Image
imageLayout
Type: System.Windows.Forms..::..ImageLayout

See Also

ImageAndTextHelper Class


GetImageRectangle Method

[image]

VIBlend Controls for WinForms Help Documentation
ImageAndTextHelper..::..GetImageRectangle Method
ImageAndTextHelper Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Rectangle GetImageRectangle(
    Image image,
    Rectangle r,
    ContentAlignment imageAlignment
)
Visual Basic
Public Shared Function GetImageRectangle ( _
    image As Image, _
    r As Rectangle, _
    imageAlignment As ContentAlignment _
) As Rectangle
Visual C++
public:
static Rectangle GetImageRectangle(
    Image^ image,
    Rectangle r,
    ContentAlignment imageAlignment
)

Parameters

image
Type: System.Drawing..::..Image
r
Type: System.Drawing..::..Rectangle
imageAlignment
Type: System.Drawing..::..ContentAlignment

See Also

ImageAndTextHelper Class


GetStringFormat Method

[image]

VIBlend Controls for WinForms Help Documentation
ImageAndTextHelper..::..GetStringFormat Method
ImageAndTextHelper Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static StringFormat GetStringFormat(
    Control ctl,
    ContentAlignment textAlign,
    bool showEllipsis,
    bool useMnemonic
)
Visual Basic
Public Shared Function GetStringFormat ( _
    ctl As Control, _
    textAlign As ContentAlignment, _
    showEllipsis As Boolean, _
    useMnemonic As Boolean _
) As StringFormat
Visual C++
public:
static StringFormat^ GetStringFormat(
    Control^ ctl,
    ContentAlignment textAlign,
    bool showEllipsis,
    bool useMnemonic
)

Parameters

ctl
Type: System.Windows.Forms..::..Control
textAlign
Type: System.Drawing..::..ContentAlignment
showEllipsis
Type: System..::..Boolean
useMnemonic
Type: System..::..Boolean

See Also

ImageAndTextHelper Class


GetTextImageRectangle Method

[image]

VIBlend Controls for WinForms Help Documentation
ImageAndTextHelper..::..GetTextImageRectangle Method
ImageAndTextHelper Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static void GetTextImageRectangle(
    Rectangle bounds,
    TextImageRelation relation,
    ContentAlignment imageAlignment,
    ContentAlignment textAlignment,
    out Rectangle imageRectangle,
    out Rectangle textRectangle
)
Visual Basic
Public Shared Sub GetTextImageRectangle ( _
    bounds As Rectangle, _
    relation As TextImageRelation, _
    imageAlignment As ContentAlignment, _
    textAlignment As ContentAlignment, _
    <OutAttribute> ByRef imageRectangle As Rectangle, _
    <OutAttribute> ByRef textRectangle As Rectangle _
)
Visual C++
public:
static void GetTextImageRectangle(
    Rectangle bounds,
    TextImageRelation relation,
    ContentAlignment imageAlignment,
    ContentAlignment textAlignment,
    [OutAttribute] Rectangle% imageRectangle,
    [OutAttribute] Rectangle% textRectangle
)

Parameters

bounds
Type: System.Drawing..::..Rectangle
relation
Type: System.Windows.Forms..::..TextImageRelation
imageAlignment
Type: System.Drawing..::..ContentAlignment
textAlignment
Type: System.Drawing..::..ContentAlignment
imageRectangle
Type: System.Drawing..::..Rectangle %
textRectangle
Type: System.Drawing..::..Rectangle %

See Also

ImageAndTextHelper Class


GetTextSize Method

[image]

VIBlend Controls for WinForms Help Documentation
ImageAndTextHelper..::..GetTextSize Method
ImageAndTextHelper Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Size GetTextSize(
    Graphics graphics,
    string text,
    Font font,
    Size proposedSize
)
Visual Basic
Public Shared Function GetTextSize ( _
    graphics As Graphics, _
    text As String, _
    font As Font, _
    proposedSize As Size _
) As Size
Visual C++
public:
static Size GetTextSize(
    Graphics^ graphics,
    String^ text,
    Font^ font,
    Size proposedSize
)

Parameters

graphics
Type: System.Drawing..::..Graphics
text
Type: System..::..String
font
Type: System.Drawing..::..Font
proposedSize
Type: System.Drawing..::..Size

See Also

ImageAndTextHelper Class


InitializeTextAndImageRectangles Method

[image]

VIBlend Controls for WinForms Help Documentation
ImageAndTextHelper..::..InitializeTextAndImageRectangles Method
ImageAndTextHelper Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static void InitializeTextAndImageRectangles(
    Graphics g,
    Rectangle bounds,
    Image image,
    string Text,
    Font TextFont,
    TextImageRelation relation,
    ContentAlignment imageAlignment,
    ContentAlignment textAlignment,
    Padding textMargin,
    Padding imageMargin,
    out Rectangle imageRectangle,
    out Rectangle textRectangle
)
Visual Basic
Public Shared Sub InitializeTextAndImageRectangles ( _
    g As Graphics, _
    bounds As Rectangle, _
    image As Image, _
    Text As String, _
    TextFont As Font, _
    relation As TextImageRelation, _
    imageAlignment As ContentAlignment, _
    textAlignment As ContentAlignment, _
    textMargin As Padding, _
    imageMargin As Padding, _
    <OutAttribute> ByRef imageRectangle As Rectangle, _
    <OutAttribute> ByRef textRectangle As Rectangle _
)
Visual C++
public:
static void InitializeTextAndImageRectangles(
    Graphics^ g,
    Rectangle bounds,
    Image^ image,
    String^ Text,
    Font^ TextFont,
    TextImageRelation relation,
    ContentAlignment imageAlignment,
    ContentAlignment textAlignment,
    Padding textMargin,
    Padding imageMargin,
    [OutAttribute] Rectangle% imageRectangle,
    [OutAttribute] Rectangle% textRectangle
)

Parameters

g
Type: System.Drawing..::..Graphics
bounds
Type: System.Drawing..::..Rectangle
image
Type: System.Drawing..::..Image
Text
Type: System..::..String
TextFont
Type: System.Drawing..::..Font
relation
Type: System.Windows.Forms..::..TextImageRelation
imageAlignment
Type: System.Drawing..::..ContentAlignment
textAlignment
Type: System.Drawing..::..ContentAlignment
textMargin
Type: System.Windows.Forms..::..Padding
imageMargin
Type: System.Windows.Forms..::..Padding
imageRectangle
Type: System.Drawing..::..Rectangle %
textRectangle
Type: System.Drawing..::..Rectangle %

See Also

ImageAndTextHelper Class


InputBase Class

[image]

VIBlend Controls for WinForms Help Documentation
InputBase Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class InputBase : vTextBox, INotifyPropertyChanged
Visual Basic
Public Class InputBase _
    Inherits vTextBox _
    Implements INotifyPropertyChanged
Visual C++
public ref class InputBase : public vTextBox,
    INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vTextBox
VIBlend.WinForms.Controls..::..InputBase
VIBlend.WinForms.Controls..::..vCurrencyEditor
VIBlend.WinForms.Controls..::..vDecimalEditor
VIBlend.WinForms.Controls..::..vFixedPointEditor
VIBlend.WinForms.Controls..::..vNumberEditor
VIBlend.WinForms.Controls..::..vPercentageEditor

See Also

InputBase Members


InputBase Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase Members
InputBase Class Constructors Methods Fields Properties Events See Also Send Feedback

The InputBase type exposes the following members.

Constructors

 | Name | Description
Public method | InputBase | Initializes a new instance of InputBase.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | Simulates BackSpace.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Overrides Control..::..CreateHandle()()()().)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | Executes the Ctrl + C command.
Protected method | CtrlV | Executes the Ctrl + V command.
Protected method | CtrlX | Executes the Ctrl + X command.
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | Deletes the selected value.
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key.
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text.
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | Inserts a string into the editor.
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown |
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed.
Public method | LeftKey | Moves the cursor one position left.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | (Overrides Control..::..OnKeyPress(KeyPressEventArgs).)
Protected method | OnKeyUp | Raises the KeyUp event. (Overrides Control..::..OnKeyUp(KeyEventArgs).)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | (Overrides Control..::..OnMouseWheel(MouseEventArgs).)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged |
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Overrides vTextBox..::..OnTextChanged(EventArgs).)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event.
Protected method | OnValueChanged | Calls the ValueChanged event.
Protected method | OnValueChanging | Calls the ValueChanging event.
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | Parses editor's value.
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo |
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key.
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | Formats editor's text.
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit |
Protected method | SpinDigitWithWrap | Spins the digit with wrap.
Public method | SpinValue | Increases or decreases the current value.
Protected method | SpinValueBeforeDigit | Spins the value before digit.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | Makes undo of the current value.
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key.
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | baseFormatString |
Protected field | cultureInfo |
Protected field | decimalPlaces |
Protected field | decimalPossibleChars |
Protected field | emptyValue |
Protected field | formatString |
Protected field | isLessThanZero |
Protected field | manager |
Protected field | maximum |
Protected field | minimum |
Protected field | undoValue |
Protected field | value |
Protected field | valueString |

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DecimalPlaces | Gets or sets editor's decimal places.
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator |
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength |
Public property | Minimum | Gets or sets editor's Minimum value.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | Gets the current separator character.
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type.
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation.
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string.
Public property | Value | Gets or sets editor's value.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed.
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event.
Public event | ValueChanged | Represents the ValueChanged event.
Public event | ValueChanging | Represents the ValueChanging event.
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

InputBase Class


InputBase Constructor

[image]

VIBlend Controls for WinForms Help Documentation
InputBase Constructor
InputBase Class See Also Send Feedback
Initializes a new instance of InputBase.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public InputBase()
Visual Basic
Public Sub New
Visual C++
public:
InputBase()

See Also

InputBase Class


InputBase Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase Fields
InputBase Class See Also Send Feedback

The InputBase type exposes the following members.

Fields

 | Name | Description
Protected field | baseFormatString |
Protected field | cultureInfo |
Protected field | decimalPlaces |
Protected field | decimalPossibleChars |
Protected field | emptyValue |
Protected field | formatString |
Protected field | isLessThanZero |
Protected field | manager |
Protected field | maximum |
Protected field | minimum |
Protected field | undoValue |
Protected field | value |
Protected field | valueString |

See Also

InputBase Class


baseFormatString Field

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..baseFormatString Field
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected string baseFormatString
Visual Basic
Protected baseFormatString As String
Visual C++
protected:
String^ baseFormatString

See Also

InputBase Class


cultureInfo Field

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..cultureInfo Field
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected CultureInfo cultureInfo
Visual Basic
Protected cultureInfo As CultureInfo
Visual C++
protected:
CultureInfo^ cultureInfo

See Also

InputBase Class


decimalPlaces Field

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..decimalPlaces Field
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected int decimalPlaces
Visual Basic
Protected decimalPlaces As Integer
Visual C++
protected:
int decimalPlaces

See Also

InputBase Class


decimalPossibleChars Field

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..decimalPossibleChars Field
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected int decimalPossibleChars
Visual Basic
Protected decimalPossibleChars As Integer
Visual C++
protected:
int decimalPossibleChars

See Also

InputBase Class


emptyValue Field

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..emptyValue Field
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected string emptyValue
Visual Basic
Protected emptyValue As String
Visual C++
protected:
String^ emptyValue

See Also

InputBase Class


formatString Field

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..formatString Field
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected string formatString
Visual Basic
Protected formatString As String
Visual C++
protected:
String^ formatString

See Also

InputBase Class


isLessThanZero Field

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..isLessThanZero Field
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected bool isLessThanZero
Visual Basic
Protected isLessThanZero As Boolean
Visual C++
protected:
bool isLessThanZero

See Also

InputBase Class


manager Field

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..manager Field
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected UndoRedoManager manager
Visual Basic
Protected manager As UndoRedoManager
Visual C++
protected:
UndoRedoManager^ manager

See Also

InputBase Class


maximum Field

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..maximum Field
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected decimal maximum
Visual Basic
Protected maximum As Decimal
Visual C++
protected:
Decimal maximum

See Also

InputBase Class


minimum Field

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..minimum Field
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected decimal minimum
Visual Basic
Protected minimum As Decimal
Visual C++
protected:
Decimal minimum

See Also

InputBase Class


undoValue Field

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..undoValue Field
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected string undoValue
Visual Basic
Protected undoValue As String
Visual C++
protected:
String^ undoValue

See Also

InputBase Class


value Field

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..value Field
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected decimal value
Visual Basic
Protected value As Decimal
Visual C++
protected:
Decimal value

See Also

InputBase Class


valueString Field

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..valueString Field
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected string valueString
Visual Basic
Protected valueString As String
Visual C++
protected:
String^ valueString

See Also

InputBase Class


InputBase Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase Methods
InputBase Class See Also Send Feedback

The InputBase type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | Simulates BackSpace.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Overrides Control..::..CreateHandle()()()().)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | Executes the Ctrl + C command.
Protected method | CtrlV | Executes the Ctrl + V command.
Protected method | CtrlX | Executes the Ctrl + X command.
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | Deletes the selected value.
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key.
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text.
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | Inserts a string into the editor.
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown |
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed.
Public method | LeftKey | Moves the cursor one position left.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | (Overrides Control..::..OnKeyPress(KeyPressEventArgs).)
Protected method | OnKeyUp | Raises the KeyUp event. (Overrides Control..::..OnKeyUp(KeyEventArgs).)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | (Overrides Control..::..OnMouseWheel(MouseEventArgs).)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged |
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Overrides vTextBox..::..OnTextChanged(EventArgs).)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event.
Protected method | OnValueChanged | Calls the ValueChanged event.
Protected method | OnValueChanging | Calls the ValueChanging event.
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | Parses editor's value.
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo |
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key.
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | Formats editor's text.
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit |
Protected method | SpinDigitWithWrap | Spins the digit with wrap.
Public method | SpinValue | Increases or decreases the current value.
Protected method | SpinValueBeforeDigit | Spins the value before digit.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | Makes undo of the current value.
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key.
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

InputBase Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..AccessibilityNotifyClients Method
InputBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

InputBase Class
InputBase Members


Backspace Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..Backspace Method
InputBase Class See Also Send Feedback
Simulates BackSpace.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void Backspace()
Visual Basic
Public Overridable Sub Backspace
Visual C++
public:
virtual void Backspace()

See Also

InputBase Class


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..BeginInvoke Method
InputBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

InputBase Class
InputBase Members


CreateHandle Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..CreateHandle Method
InputBase Class See Also Send Feedback
Creates a handle for the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void CreateHandle()
Visual Basic
Protected Overrides Sub CreateHandle
Visual C++
protected:
virtual void CreateHandle() override

Exceptions

Exception | Condition
System..::..ObjectDisposedException | The object is in a disposed state.

See Also

InputBase Class


CtrlC Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..CtrlC Method
InputBase Class See Also Send Feedback
Executes the Ctrl + C command.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void CtrlC()
Visual Basic
Protected Overridable Sub CtrlC
Visual C++
protected:
virtual void CtrlC()

See Also

InputBase Class


CtrlV Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..CtrlV Method
InputBase Class See Also Send Feedback
Executes the Ctrl + V command.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void CtrlV()
Visual Basic
Protected Overridable Sub CtrlV
Visual C++
protected:
virtual void CtrlV()

See Also

InputBase Class


CtrlX Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..CtrlX Method
InputBase Class See Also Send Feedback
Executes the Ctrl + X command.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void CtrlX()
Visual Basic
Protected Overridable Sub CtrlX
Visual C++
protected:
virtual void CtrlX()

See Also

InputBase Class


Delete Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..Delete Method
InputBase Class See Also Send Feedback
Deletes the selected value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void Delete()
Visual Basic
Public Overridable Sub Delete
Visual C++
public:
virtual void Delete()

See Also

InputBase Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..Dispose Method
InputBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

InputBase Class
InputBase Members


DownKey Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..DownKey Method
InputBase Class See Also Send Feedback
Simulates pressing of down arrow key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void DownKey()
Visual Basic
Public Overridable Sub DownKey
Visual C++
public:
virtual void DownKey()

See Also

InputBase Class


EndKey Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..EndKey Method
InputBase Class See Also Send Feedback
Simulates pressing of End key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void EndKey()
Visual Basic
Public Sub EndKey
Visual C++
public:
void EndKey()

See Also

InputBase Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..GetChildAtPoint Method
InputBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

InputBase Class
InputBase Members


GetDefaultValidationErrorProvider Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..GetDefaultValidationErrorProvider Method
InputBase Class See Also Send Feedback
Gets the default validation error provider.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ErrorProvider GetDefaultValidationErrorProvider()
Visual Basic
Public Function GetDefaultValidationErrorProvider As ErrorProvider
Visual C++
public:
ErrorProvider^ GetDefaultValidationErrorProvider()

Return Value

See Also

InputBase Class


GetPureText Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..GetPureText Method
InputBase Class See Also Send Feedback
Gets editor's text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual string GetPureText()
Visual Basic
Protected Overridable Function GetPureText As String
Visual C++
protected:
virtual String^ GetPureText()

Return Value

See Also

InputBase Class


HomeKey Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..HomeKey Method
InputBase Class See Also Send Feedback
Simulates pressing of Home key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void HomeKey()
Visual Basic
Public Sub HomeKey
Visual C++
public:
void HomeKey()

See Also

InputBase Class


Insert Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..Insert Method
InputBase Class See Also Send Feedback
Inserts a string into the editor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void Insert(
    string insertion
)
Visual Basic
Public Overridable Sub Insert ( _
    insertion As String _
)
Visual C++
public:
virtual void Insert(
    String^ insertion
)

Parameters

insertion
Type: System..::..String

See Also

InputBase Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..Invalidate Method
InputBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

InputBase Class
InputBase Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..Invoke Method
InputBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

InputBase Class
InputBase Members


IsCtrlDown Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..IsCtrlDown Method
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsCtrlDown()
Visual Basic
Public Function IsCtrlDown As Boolean
Visual C++
public:
bool IsCtrlDown()

See Also

InputBase Class


IsShiftDown Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..IsShiftDown Method
InputBase Class See Also Send Feedback
Determines whether the shift key is pressed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsShiftDown()
Visual Basic
Public Function IsShiftDown As Boolean
Visual C++
public:
bool IsShiftDown()

See Also

InputBase Class


LeftKey Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..LeftKey Method
InputBase Class See Also Send Feedback
Moves the cursor one position left.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void LeftKey()
Visual Basic
Public Sub LeftKey
Visual C++
public:
void LeftKey()

See Also

InputBase Class


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..MemberwiseClone Method
InputBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

InputBase Class
InputBase Members


OnKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..OnKeyDown Method
InputBase Class See Also Send Feedback
Raises the KeyDown event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
A KeyEventArgs that contains the event data.

See Also

InputBase Class


OnKeyPress Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..OnKeyPress Method
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyPress(
    KeyPressEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyPress ( _
    e As KeyPressEventArgs _
)
Visual C++
protected:
virtual void OnKeyPress(
    KeyPressEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyPressEventArgs

See Also

InputBase Class


OnKeyUp Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..OnKeyUp Method
InputBase Class See Also Send Feedback
Raises the KeyUp event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyUp(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyUp ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyUp(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
A KeyEventArgs that contains the event data.

See Also

InputBase Class


OnMouseWheel Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..OnMouseWheel Method
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseWheel(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseWheel ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseWheel(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

InputBase Class


OnPropertyChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..OnPropertyChanged Method
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String

See Also

InputBase Class


OnTextChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..OnTextChanged Method
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnTextChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnTextChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnTextChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

InputBase Class


OnValidationFailed Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..OnValidationFailed Method
InputBase Class See Also Send Feedback
Calls the ValidationFailed event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnValidationFailed()
Visual Basic
Protected Friend Overridable Sub OnValidationFailed
Visual C++
protected public:
virtual void OnValidationFailed()

See Also

InputBase Class


OnValueChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..OnValueChanged Method
InputBase Class See Also Send Feedback
Calls the ValueChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnValueChanged(
    ValueChangedEditorEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnValueChanged ( _
    args As ValueChangedEditorEventArgs _
)
Visual C++
protected public:
virtual void OnValueChanged(
    ValueChangedEditorEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.Controls..::..ValueChangedEditorEventArgs

See Also

InputBase Class


OnValueChanging Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..OnValueChanging Method
InputBase Class See Also Send Feedback
Calls the ValueChanging event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnValueChanging(
    ValueChangingEditorEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnValueChanging ( _
    args As ValueChangingEditorEventArgs _
)
Visual C++
protected public:
virtual void OnValueChanging(
    ValueChangingEditorEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.Controls..::..ValueChangingEditorEventArgs

See Also

InputBase Class


ParseValue Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..ParseValue Method
InputBase Class See Also Send Feedback
Parses editor's value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual bool ParseValue()
Visual Basic
Protected Overridable Function ParseValue As Boolean
Visual C++
protected:
virtual bool ParseValue()

Return Value

See Also

InputBase Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..PerformLayout Method
InputBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

InputBase Class
InputBase Members


Redo Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..Redo Method
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void Redo()
Visual Basic
Public Overridable Sub Redo
Visual C++
public:
virtual void Redo()

See Also

InputBase Class


RemoveRange Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..RemoveRange Method
InputBase Class See Also Send Feedback
Removes a range of characters.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected int RemoveRange(
    int start,
    int length,
    string text,
    string separatorChar,
    bool updateText
)
Visual Basic
Protected Function RemoveRange ( _
    start As Integer, _
    length As Integer, _
    text As String, _
    separatorChar As String, _
    updateText As Boolean _
) As Integer
Visual C++
protected:
int RemoveRange(
    int start,
    int length,
    String^ text,
    String^ separatorChar,
    bool updateText
)

Parameters

start
Type: System..::..Int32
length
Type: System..::..Int32
text
Type: System..::..String
separatorChar
Type: System..::..String
updateText
Type: System..::..Boolean

Return Value

See Also

InputBase Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..ResumeLayout Method
InputBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

InputBase Class
InputBase Members


RightKey Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..RightKey Method
InputBase Class See Also Send Feedback
Simulates pressing of down key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void RightKey()
Visual Basic
Public Sub RightKey
Visual C++
public:
void RightKey()

See Also

InputBase Class


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..RtlTranslateAlignment Method
InputBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

InputBase Class
InputBase Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..Scale Method
InputBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

InputBase Class
InputBase Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..Select Method
InputBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

InputBase Class
InputBase Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..SetBounds Method
InputBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

InputBase Class
InputBase Members


SetFormattedText Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..SetFormattedText Method
InputBase Class See Also Send Feedback
Formats editor's text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual bool SetFormattedText()
Visual Basic
Protected Overridable Function SetFormattedText As Boolean
Visual C++
protected:
virtual bool SetFormattedText()

Return Value

See Also

InputBase Class


SpinDigit Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..SpinDigit Method
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void SpinDigit(
    bool spinUp
)
Visual Basic
Protected Overridable Sub SpinDigit ( _
    spinUp As Boolean _
)
Visual C++
protected:
virtual void SpinDigit(
    bool spinUp
)

Parameters

spinUp
Type: System..::..Boolean

See Also

InputBase Class


SpinDigitWithWrap Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..SpinDigitWithWrap Method
InputBase Class See Also Send Feedback
Spins the digit with wrap.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void SpinDigitWithWrap(
    bool spinUp
)
Visual Basic
Protected Overridable Sub SpinDigitWithWrap ( _
    spinUp As Boolean _
)
Visual C++
protected:
virtual void SpinDigitWithWrap(
    bool spinUp
)

Parameters

spinUp
Type: System..::..Boolean
if set to true [spin up].

See Also

InputBase Class


SpinValue Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..SpinValue Method
InputBase Class See Also Send Feedback
Increases or decreases the current value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SpinValue(
    bool spinUp
)
Visual Basic
Public Sub SpinValue ( _
    spinUp As Boolean _
)
Visual C++
public:
void SpinValue(
    bool spinUp
)

Parameters

spinUp
Type: System..::..Boolean

See Also

InputBase Class


SpinValueBeforeDigit Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..SpinValueBeforeDigit Method
InputBase Class See Also Send Feedback
Spins the value before digit.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void SpinValueBeforeDigit(
    bool spinUp
)
Visual Basic
Protected Overridable Sub SpinValueBeforeDigit ( _
    spinUp As Boolean _
)
Visual C++
protected:
virtual void SpinValueBeforeDigit(
    bool spinUp
)

Parameters

spinUp
Type: System..::..Boolean
if set to true [spin up].

See Also

InputBase Class


Undo Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..Undo Method
InputBase Class See Also Send Feedback
Makes undo of the current value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void Undo()
Visual Basic
Public Overridable Sub Undo
Visual C++
public:
virtual void Undo()

See Also

InputBase Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..UpdateBounds Method
InputBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

InputBase Class
InputBase Members


UpKey Method

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..UpKey Method
InputBase Class See Also Send Feedback
Simulates pressing of up arrow key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void UpKey()
Visual Basic
Public Overridable Sub UpKey
Visual C++
public:
virtual void UpKey()

See Also

InputBase Class


InputBase Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase Properties
InputBase Class See Also Send Feedback

The InputBase type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DecimalPlaces | Gets or sets editor's decimal places.
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator |
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength |
Public property | Minimum | Gets or sets editor's Minimum value.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | Gets the current separator character.
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type.
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation.
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string.
Public property | Value | Gets or sets editor's value.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

InputBase Class


CultureInfo Property

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..CultureInfo Property
InputBase Class See Also Send Feedback
Gets or sets editor's culture information.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CultureInfo CultureInfo { get; set; }
Visual Basic
Public Property CultureInfo As CultureInfo
    Get
    Set
Visual C++
public:
property CultureInfo^ CultureInfo {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}

See Also

InputBase Class


DecimalPlaces Property

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..DecimalPlaces Property
InputBase Class See Also Send Feedback
Gets or sets editor's decimal places.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual int DecimalPlaces { get; set; }
Visual Basic
Public Overridable Property DecimalPlaces As Integer
    Get
    Set
Visual C++
public:
virtual property int DecimalPlaces {
    int get ();
    void set (int value);
}

See Also

InputBase Class


HasSeparator Property

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..HasSeparator Property
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual bool HasSeparator { get; }
Visual Basic
Protected Friend Overridable ReadOnly Property HasSeparator As Boolean
    Get
Visual C++
protected public:
virtual property bool HasSeparator {
    bool get ();
}

See Also

InputBase Class


LastValue Property

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..LastValue Property
InputBase Class See Also Send Feedback
Gets editor's last value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual decimal LastValue { get; internal set; }
Visual Basic
Public Overridable Property LastValue As Decimal
    Get
    Friend Set
Visual C++
public:
virtual property Decimal LastValue {
    Decimal get ();
    internal: void set (Decimal value);
}

See Also

InputBase Class


Maximum Property

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..Maximum Property
InputBase Class See Also Send Feedback
Gets or sets editor's Maximum value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public decimal Maximum { get; set; }
Visual Basic
Public Property Maximum As Decimal
    Get
    Set
Visual C++
public:
property Decimal Maximum {
    Decimal get ();
    void set (Decimal value);
}

See Also

InputBase Class


MaxLength Property

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..MaxLength Property
InputBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int MaxLength { get; set; }
Visual Basic
Public Property MaxLength As Integer
    Get
    Set
Visual C++
public:
property int MaxLength {
    int get ();
    void set (int value);
}

See Also

InputBase Class


Minimum Property

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..Minimum Property
InputBase Class See Also Send Feedback
Gets or sets editor's Minimum value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public decimal Minimum { get; set; }
Visual Basic
Public Property Minimum As Decimal
    Get
    Set
Visual C++
public:
property Decimal Minimum {
    Decimal get ();
    void set (Decimal value);
}

See Also

InputBase Class


SeparatorChar Property

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..SeparatorChar Property
InputBase Class See Also Send Feedback
Gets the current separator character.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual string SeparatorChar { get; }
Visual Basic
Public Overridable ReadOnly Property SeparatorChar As String
    Get
Visual C++
public:
virtual property String^ SeparatorChar {
    String^ get ();
}

See Also

InputBase Class


SpinType Property

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..SpinType Property
InputBase Class See Also Send Feedback
Gets or sets editor's spin type.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public SpinType SpinType { get; set; }
Visual Basic
Public Property SpinType As SpinType
    Get
    Set
Visual C++
public:
property SpinType SpinType {
    SpinType get ();
    void set (SpinType value);
}

See Also

InputBase Class


UseDefaultValidation Property

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..UseDefaultValidation Property
InputBase Class See Also Send Feedback
Gets or sets a value indicating whether to use the built-in validation.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseDefaultValidation { get; set; }
Visual Basic
Public Property UseDefaultValidation As Boolean
    Get
    Set
Visual C++
public:
property bool UseDefaultValidation {
    bool get ();
    void set (bool value);
}

See Also

InputBase Class


ValidationString Property

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..ValidationString Property
InputBase Class See Also Send Feedback
Gets or sets the validation string.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string ValidationString { get; set; }
Visual Basic
Public Property ValidationString As String
    Get
    Set
Visual C++
public:
property String^ ValidationString {
    String^ get ();
    void set (String^ value);
}

Field Value

The validation string.

See Also

InputBase Class


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..Value Property
InputBase Class See Also Send Feedback
Gets or sets editor's value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual decimal Value { get; set; }
Visual Basic
Public Overridable Property Value As Decimal
    Get
    Set
Visual C++
public:
virtual property Decimal Value {
    Decimal get ();
    void set (Decimal value);
}

See Also

InputBase Class


InputBase Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
InputBase Events
InputBase Class See Also Send Feedback

The InputBase type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed.
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event.
Public event | ValueChanged | Represents the ValueChanged event.
Public event | ValueChanging | Represents the ValueChanging event.
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

InputBase Class


PropertyChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..PropertyChanged Event
InputBase Class See Also Send Feedback
Occurs when a property has changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

InputBase Class


ValidationFailed Event

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..ValidationFailed Event
InputBase Class See Also Send Feedback
Represents the ValidationFailed event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ValidationFailed
Visual Basic
Public Event ValidationFailed As EventHandler
Visual C++
public:
 event EventHandler^ ValidationFailed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

InputBase Class


ValueChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..ValueChanged Event
InputBase Class See Also Send Feedback
Represents the ValueChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event ValueChangedEditorEventHandler ValueChanged
Visual Basic
Public Event ValueChanged As ValueChangedEditorEventHandler
Visual C++
public:
 event ValueChangedEditorEventHandler^ ValueChanged {
    void add (ValueChangedEditorEventHandler^ value);
    void remove (ValueChangedEditorEventHandler^ value);
}

See Also

InputBase Class


ValueChanging Event

[image]

VIBlend Controls for WinForms Help Documentation
InputBase..::..ValueChanging Event
InputBase Class See Also Send Feedback
Represents the ValueChanging event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event ValueChangingEditorEventHandler ValueChanging
Visual Basic
Public Event ValueChanging As ValueChangingEditorEventHandler
Visual C++
public:
 event ValueChangingEditorEventHandler^ ValueChanging {
    void add (ValueChangingEditorEventHandler^ value);
    void remove (ValueChangingEditorEventHandler^ value);
}

See Also

InputBase Class


InsertType Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
InsertType Enumeration
See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum InsertType
Visual Basic
Public Enumeration InsertType
Visual C++
public enum class InsertType

Members

Member name | Description
BeforeSeparator |
AfterSeparator |

See Also


KeyTip Class

[image]

VIBlend Controls for WinForms Help Documentation
KeyTip Class
Members See Also Send Feedback
Represents a KeyTip component

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class KeyTip : Component
Visual Basic
Public Class KeyTip _
    Inherits Component
Visual C++
public ref class KeyTip : public Component

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
VIBlend.WinForms.Controls..::..KeyTip

See Also

KeyTip Members


KeyTip Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
KeyTip Members
KeyTip Class Constructors Methods Properties Events See Also Send Feedback

The KeyTip type exposes the following members.

Constructors

 | Name | Description
Public method | KeyTip()()()() | Initializes a new instance of the KeyTip class.
Public method | KeyTip(Control, String) | Initializes a new instance of the KeyTip class.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | (Overrides Component..::..Dispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnKeyTipActivationKeyPressed |
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

 | Name | Description
Public property | ActivationKey | Gets or sets the activation key.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContentControl | Gets or sets the content control.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | KeyTipSize | Gets or sets the size of the key tip.
Public property | PreferredLocation | Gets or sets the preferred location.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Text | Gets or sets the text.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | KeyTipActivationKeyPressed | Occurs when keytip activation key is pressed

See Also

KeyTip Class


KeyTip Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
KeyTip Constructor
KeyTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KeyTip()()()() | Initializes a new instance of the KeyTip class.
Public method | KeyTip(Control, String) | Initializes a new instance of the KeyTip class.

See Also

KeyTip Class
KeyTip Members


KeyTip Constructor

[image]

VIBlend Controls for WinForms Help Documentation
KeyTip Constructor
KeyTip Class See Also Send Feedback
Initializes a new instance of the KeyTip class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public KeyTip()
Visual Basic
Public Sub New
Visual C++
public:
KeyTip()

See Also

KeyTip Class
KeyTip Overload


KeyTip Constructor (Control, String)

[image]

VIBlend Controls for WinForms Help Documentation
KeyTip Constructor (Control, String)
KeyTip Class See Also Send Feedback
Initializes a new instance of the KeyTip class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public KeyTip(
    Control contentControl,
    string text
)
Visual Basic
Public Sub New ( _
    contentControl As Control, _
    text As String _
)
Visual C++
public:
KeyTip(
    Control^ contentControl,
    String^ text
)

Parameters

contentControl
Type: System.Windows.Forms..::..Control
The content control.
text
Type: System..::..String
The text.

See Also

KeyTip Class
KeyTip Overload


KeyTip Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
KeyTip Methods
KeyTip Class See Also Send Feedback

The KeyTip type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | (Overrides Component..::..Dispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnKeyTipActivationKeyPressed |
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

KeyTip Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
KeyTip..::..Dispose Method
KeyTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the KeyTip and optionally releases the managed resources (Overrides Component..::..Dispose(Boolean).)

See Also

KeyTip Class
KeyTip Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
KeyTip..::..Dispose Method (Boolean)
KeyTip Class See Also Send Feedback
Releases the unmanaged resources used by the KeyTip and optionally releases the managed resources

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

KeyTip Class
Dispose Overload


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
KeyTip..::..MemberwiseClone Method
KeyTip Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

KeyTip Class
KeyTip Members


OnKeyTipActivationKeyPressed Method

[image]

VIBlend Controls for WinForms Help Documentation
KeyTip..::..OnKeyTipActivationKeyPressed Method
KeyTip Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnKeyTipActivationKeyPressed()
Visual Basic
Protected Overridable Sub OnKeyTipActivationKeyPressed
Visual C++
protected:
virtual void OnKeyTipActivationKeyPressed()

See Also

KeyTip Class


KeyTip Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
KeyTip Properties
KeyTip Class See Also Send Feedback

The KeyTip type exposes the following members.

Properties

 | Name | Description
Public property | ActivationKey | Gets or sets the activation key.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContentControl | Gets or sets the content control.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | KeyTipSize | Gets or sets the size of the key tip.
Public property | PreferredLocation | Gets or sets the preferred location.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Text | Gets or sets the text.

See Also

KeyTip Class


ActivationKey Property

[image]

VIBlend Controls for WinForms Help Documentation
KeyTip..::..ActivationKey Property
KeyTip Class See Also Send Feedback
Gets or sets the activation key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Keys ActivationKey { get; set; }
Visual Basic
Public Property ActivationKey As Keys
    Get
    Set
Visual C++
public:
property Keys ActivationKey {
    Keys get ();
    void set (Keys value);
}

Field Value

The activation key.

See Also

KeyTip Class


ContentControl Property

[image]

VIBlend Controls for WinForms Help Documentation
KeyTip..::..ContentControl Property
KeyTip Class See Also Send Feedback
Gets or sets the content control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control ContentControl { get; set; }
Visual Basic
Public Property ContentControl As Control
    Get
    Set
Visual C++
public:
property Control^ ContentControl {
    Control^ get ();
    void set (Control^ value);
}

Field Value

The content control.

See Also

KeyTip Class


KeyTipSize Property

[image]

VIBlend Controls for WinForms Help Documentation
KeyTip..::..KeyTipSize Property
KeyTip Class See Also Send Feedback
Gets or sets the size of the key tip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Size KeyTipSize { get; set; }
Visual Basic
Public Property KeyTipSize As Size
    Get
    Set
Visual C++
public:
property Size KeyTipSize {
    Size get ();
    void set (Size value);
}

Field Value

The size of the key tip.

See Also

KeyTip Class


PreferredLocation Property

[image]

VIBlend Controls for WinForms Help Documentation
KeyTip..::..PreferredLocation Property
KeyTip Class See Also Send Feedback
Gets or sets the preferred location.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Point PreferredLocation { get; set; }
Visual Basic
Public Property PreferredLocation As Point
    Get
    Set
Visual C++
public:
property Point PreferredLocation {
    Point get ();
    void set (Point value);
}

Field Value

The preferred location.

See Also

KeyTip Class


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
KeyTip..::..Text Property
KeyTip Class See Also Send Feedback
Gets or sets the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Field Value

The text.

See Also

KeyTip Class


KeyTip Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
KeyTip Events
KeyTip Class See Also Send Feedback

The KeyTip type exposes the following members.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | KeyTipActivationKeyPressed | Occurs when keytip activation key is pressed

See Also

KeyTip Class


KeyTipActivationKeyPressed Event

[image]

VIBlend Controls for WinForms Help Documentation
KeyTip..::..KeyTipActivationKeyPressed Event
KeyTip Class See Also Send Feedback
Occurs when keytip activation key is pressed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event KeyTipEventHandler KeyTipActivationKeyPressed
Visual Basic
Public Event KeyTipActivationKeyPressed As KeyTipEventHandler
Visual C++
public:
 event KeyTipEventHandler^ KeyTipActivationKeyPressed {
    void add (KeyTipEventHandler^ value);
    void remove (KeyTipEventHandler^ value);
}

See Also

KeyTip Class


LabelItemStyle Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
LabelItemStyle Enumeration
See Also Send Feedback
Enumaration of the vLabel styles

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum LabelItemStyle
Visual Basic
Public Enumeration LabelItemStyle
Visual C++
public enum class LabelItemStyle

Members

Member name | Description
TextOnly |
ImageOnly |

See Also


LineState Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
LineState Enumeration
See Also Send Feedback
Represents a LineState enum.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum LineState
Visual Basic
Public Enumeration LineState
Visual C++
public enum class LineState

Members

Member name | Description
First |
HasParent |
Last |
None |

See Also


LineStates Class

[image]

VIBlend Controls for WinForms Help Documentation
LineStates Class
Members See Also Send Feedback
Represents a class which calculates the tree node lines.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class LineStates
Visual Basic
Public Class LineStates
Visual C++
public ref class LineStates

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..LineStates

See Also

LineStates Members


LineStates Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
LineStates Members
LineStates Class Constructors Methods Properties See Also Send Feedback

The LineStates type exposes the following members.

Constructors

 | Name | Description
Public method | LineStates | Initializes a new instance of the LineStates class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pop |
Public method | Push | Pushes the specified state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Depth |
Public property | Item |

See Also

LineStates Class


LineStates Constructor

[image]

VIBlend Controls for WinForms Help Documentation
LineStates Constructor
LineStates Class See Also Send Feedback
Initializes a new instance of the LineStates class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public LineStates()
Visual Basic
Public Sub New
Visual C++
public:
LineStates()

See Also

LineStates Class


LineStates Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
LineStates Methods
LineStates Class See Also Send Feedback

The LineStates type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pop |
Public method | Push | Pushes the specified state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineStates Class


Pop Method

[image]

VIBlend Controls for WinForms Help Documentation
LineStates..::..Pop Method
LineStates Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Pop()
Visual Basic
Public Sub Pop
Visual C++
public:
void Pop()

See Also

LineStates Class


Push Method

[image]

VIBlend Controls for WinForms Help Documentation
LineStates..::..Push Method
LineStates Class See Also Send Feedback
Pushes the specified state.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Push(
    LineState state
)
Visual Basic
Public Sub Push ( _
    state As LineState _
)
Visual C++
public:
void Push(
    LineState state
)

Parameters

state
Type: VIBlend.WinForms.Controls..::..LineState
The state.

See Also

LineStates Class


LineStates Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
LineStates Properties
LineStates Class See Also Send Feedback

The LineStates type exposes the following members.

Properties

 | Name | Description
Public property | Depth |
Public property | Item |

See Also

LineStates Class


Depth Property

[image]

VIBlend Controls for WinForms Help Documentation
LineStates..::..Depth Property
LineStates Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Depth { get; }
Visual Basic
Public ReadOnly Property Depth As Integer
    Get
Visual C++
public:
property int Depth {
    int get ();
}

See Also

LineStates Class


Item Property

[image]

VIBlend Controls for WinForms Help Documentation
LineStates..::..Item Property
LineStates Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public LineState this[
    int depth
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    depth As Integer _
) As LineState
    Get
Visual C++
public:
property LineState default[int depth] {
    LineState get (int depth);
}

Parameters

depth
Type: System..::..Int32

See Also

LineStates Class


ListItem Class

[image]

VIBlend Controls for WinForms Help Documentation
ListItem Class
Members See Also Send Feedback
Represents a vListBox item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class ListItem : INotifyPropertyChanged
Visual Basic
Public Class ListItem _
    Implements INotifyPropertyChanged
Visual C++
public ref class ListItem : INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..ListItem

See Also

ListItem Members


ListItem Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
ListItem Members
ListItem Class Constructors Methods Properties Events See Also Send Feedback

The ListItem type exposes the following members.

Constructors

 | Name | Description
Public method | ListItem | Initializes a new instance of the ListItem class

Methods

 | Name | Description
Public method | Clone | Clones this instance.
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged |
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AbsoluteTopLeftEdgeTextOffset | Gets or sets the absolute top left edge text offset.
Public property | BackgroundBorder | Gets or sets the background border.
Public property | BackgroundBrush | Gets or sets the background brush.
Public property | Description | Gets or sets the description of the item. In a ListItem the description appears as a detailed text under the main item's text.
Public property | DescriptionStringAlignment | Gets or sets the description string alignment.
Public property | DescriptionStringLineAlignment | Gets or sets the description string line alignment.
Public property | DescriptionTextColor | Gets or sets the color of the description text.
Public property | DisabledBackgroundBorder | Gets or sets the disabledBackgroundBorder border.
Public property | DisabledBackgroundBrush | Gets or sets the disabled background brush.
Public property | DisabledTextColor | Gets or sets the color of the disabled text.
Public property | Enabled | Gets or sets a value indicating whether this ListItem is enabled.
Public property | Font | Gets or sets the font.
Public property | HighlightBackgroundBorder | Gets or sets the highlightBackground border.
Public property | HighlightBackgroundBrush | Gets or sets the HighlightBackground brush.
Public property | HighlightTextColor | Gets or sets the color of the highlight text.
Public property | ImageBeforeText | Gets or sets whether the item's image is displayed before or after the item's text and description
Public property | ImageIndex | Gets or sets the image list index value of the item's image in the normal state.
Public property | ImageIndexHover | Gets or sets the image list index value of the item's image in the hover state
Public property | ImageIndexSelected | Gets or sets the image list index value of the item's image in the selected state.
Public property | IsChecked | Gets or sets a value indicating whether the item is checked.
Public property | IsThreeState | Gets or sets a value indicating whether the ListItem supports 3 check states.
Public property | ItemLeftAndRightOffset | Gets or sets the item's left and right border offset.
Public property | RenderBounds | Gets the render bounds.
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the ListItem.
Public property | SelectedBackgroundBorder | Gets or sets the selectedBackground border.
Public property | SelectedBackgroundBrush | Gets or sets the background brush.
Public property | SelectedTextColor | Gets or sets the color of the selected text.
Public property | StringAlignment | Gets or sets the string alignment.
Public property | StringLineAlignment | Gets or sets the string line alignment.
Public property | Tag | Gets or sets the tag.
Public property | Text | Gets or sets the text of the item.
Public property | TextColor | Gets or sets the color of the text.
Public property | UseThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the default text color of the theme.
Public property | Value | Gets or sets a user defined value
Public property | Visible | Gets or sets a value indicating whether this ListItem is visible.

Events

 | Name | Description
Public event | PropertyChanged |

See Also

ListItem Class


ListItem Constructor

[image]

VIBlend Controls for WinForms Help Documentation
ListItem Constructor
ListItem Class See Also Send Feedback
Initializes a new instance of the ListItem class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ListItem()
Visual Basic
Public Sub New
Visual C++
public:
ListItem()

See Also

ListItem Class


ListItem Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
ListItem Methods
ListItem Class See Also Send Feedback

The ListItem type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this instance.
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged |
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

See Also

ListItem Class


Clone Method

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..Clone Method
ListItem Class See Also Send Feedback
Clones this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ListItem Clone()
Visual Basic
Public Function Clone As ListItem
Visual C++
public:
ListItem^ Clone()

Return Value

See Also

ListItem Class


Equals Method

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..Equals Method
ListItem Class See Also Send Feedback
Determines whether the specified Object is equal to this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The Object to compare with this instance.

Return Value

true if the specified Object is equal to this instance; otherwise, false.

Exceptions

Exception | Condition
System..::..NullReferenceException | The obj parameter is null.

See Also

ListItem Class


OnPropertyChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..OnPropertyChanged Method
ListItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String

See Also

ListItem Class


ToString Method

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..ToString Method
ListItem Class See Also Send Feedback
Returns a String that represents this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents this instance.

See Also

ListItem Class


ListItem Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
ListItem Properties
ListItem Class See Also Send Feedback

The ListItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteTopLeftEdgeTextOffset | Gets or sets the absolute top left edge text offset.
Public property | BackgroundBorder | Gets or sets the background border.
Public property | BackgroundBrush | Gets or sets the background brush.
Public property | Description | Gets or sets the description of the item. In a ListItem the description appears as a detailed text under the main item's text.
Public property | DescriptionStringAlignment | Gets or sets the description string alignment.
Public property | DescriptionStringLineAlignment | Gets or sets the description string line alignment.
Public property | DescriptionTextColor | Gets or sets the color of the description text.
Public property | DisabledBackgroundBorder | Gets or sets the disabledBackgroundBorder border.
Public property | DisabledBackgroundBrush | Gets or sets the disabled background brush.
Public property | DisabledTextColor | Gets or sets the color of the disabled text.
Public property | Enabled | Gets or sets a value indicating whether this ListItem is enabled.
Public property | Font | Gets or sets the font.
Public property | HighlightBackgroundBorder | Gets or sets the highlightBackground border.
Public property | HighlightBackgroundBrush | Gets or sets the HighlightBackground brush.
Public property | HighlightTextColor | Gets or sets the color of the highlight text.
Public property | ImageBeforeText | Gets or sets whether the item's image is displayed before or after the item's text and description
Public property | ImageIndex | Gets or sets the image list index value of the item's image in the normal state.
Public property | ImageIndexHover | Gets or sets the image list index value of the item's image in the hover state
Public property | ImageIndexSelected | Gets or sets the image list index value of the item's image in the selected state.
Public property | IsChecked | Gets or sets a value indicating whether the item is checked.
Public property | IsThreeState | Gets or sets a value indicating whether the ListItem supports 3 check states.
Public property | ItemLeftAndRightOffset | Gets or sets the item's left and right border offset.
Public property | RenderBounds | Gets the render bounds.
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the ListItem.
Public property | SelectedBackgroundBorder | Gets or sets the selectedBackground border.
Public property | SelectedBackgroundBrush | Gets or sets the background brush.
Public property | SelectedTextColor | Gets or sets the color of the selected text.
Public property | StringAlignment | Gets or sets the string alignment.
Public property | StringLineAlignment | Gets or sets the string line alignment.
Public property | Tag | Gets or sets the tag.
Public property | Text | Gets or sets the text of the item.
Public property | TextColor | Gets or sets the color of the text.
Public property | UseThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the default text color of the theme.
Public property | Value | Gets or sets a user defined value
Public property | Visible | Gets or sets a value indicating whether this ListItem is visible.

See Also

ListItem Class


AbsoluteTopLeftEdgeTextOffset Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..AbsoluteTopLeftEdgeTextOffset Property
ListItem Class See Also Send Feedback
Gets or sets the absolute top left edge text offset.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Point AbsoluteTopLeftEdgeTextOffset { get; set; }
Visual Basic
Public Property AbsoluteTopLeftEdgeTextOffset As Point
    Get
    Set
Visual C++
public:
property Point AbsoluteTopLeftEdgeTextOffset {
    Point get ();
    void set (Point value);
}

Field Value

The absolute top left edge text offset.

See Also

ListItem Class


BackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..BackgroundBorder Property
ListItem Class See Also Send Feedback
Gets or sets the background border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BackgroundBorder { get; set; }
Visual Basic
Public Property BackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color BackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The background border.

See Also

ListItem Class


BackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..BackgroundBrush Property
ListItem Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush BackgroundBrush { get; set; }
Visual Basic
Public Property BackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ BackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

ListItem Class


Description Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..Description Property
ListItem Class See Also Send Feedback
Gets or sets the description of the item. In a ListItem the description appears as a detailed text under the main item's text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

ListItem Class


DescriptionStringAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..DescriptionStringAlignment Property
ListItem Class See Also Send Feedback
Gets or sets the description string alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public StringAlignment DescriptionStringAlignment { get; set; }
Visual Basic
Public Property DescriptionStringAlignment As StringAlignment
    Get
    Set
Visual C++
public:
property StringAlignment DescriptionStringAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}

Field Value

The description string alignment.

See Also

ListItem Class


DescriptionStringLineAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..DescriptionStringLineAlignment Property
ListItem Class See Also Send Feedback
Gets or sets the description string line alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public StringAlignment DescriptionStringLineAlignment { get; set; }
Visual Basic
Public Property DescriptionStringLineAlignment As StringAlignment
    Get
    Set
Visual C++
public:
property StringAlignment DescriptionStringLineAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}

Field Value

The description string line alignment.

See Also

ListItem Class


DescriptionTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..DescriptionTextColor Property
ListItem Class See Also Send Feedback
Gets or sets the color of the description text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DescriptionTextColor { get; set; }
Visual Basic
Public Property DescriptionTextColor As Color
    Get
    Set
Visual C++
public:
property Color DescriptionTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the description text.

See Also

ListItem Class


DisabledBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..DisabledBackgroundBorder Property
ListItem Class See Also Send Feedback
Gets or sets the disabledBackgroundBorder border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DisabledBackgroundBorder { get; set; }
Visual Basic
Public Property DisabledBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color DisabledBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The disabledBackgroundBorder border.

See Also

ListItem Class


DisabledBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..DisabledBackgroundBrush Property
ListItem Class See Also Send Feedback
Gets or sets the disabled background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush DisabledBackgroundBrush { get; set; }
Visual Basic
Public Property DisabledBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ DisabledBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The disabled background brush.

See Also

ListItem Class


DisabledTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..DisabledTextColor Property
ListItem Class See Also Send Feedback
Gets or sets the color of the disabled text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DisabledTextColor { get; set; }
Visual Basic
Public Property DisabledTextColor As Color
    Get
    Set
Visual C++
public:
property Color DisabledTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the disabled text.

See Also

ListItem Class


Enabled Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..Enabled Property
ListItem Class See Also Send Feedback
Gets or sets a value indicating whether this ListItem is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Field Value

true if enabled; otherwise, false.

See Also

ListItem Class


Font Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..Font Property
ListItem Class See Also Send Feedback
Gets or sets the font.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font Font { get; set; }
Visual Basic
Public Property Font As Font
    Get
    Set
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

Field Value

The font.

See Also

ListItem Class


HighlightBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..HighlightBackgroundBorder Property
ListItem Class See Also Send Feedback
Gets or sets the highlightBackground border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color HighlightBackgroundBorder { get; set; }
Visual Basic
Public Property HighlightBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color HighlightBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The highlightBackground border.

See Also

ListItem Class


HighlightBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..HighlightBackgroundBrush Property
ListItem Class See Also Send Feedback
Gets or sets the HighlightBackground brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush HighlightBackgroundBrush { get; set; }
Visual Basic
Public Property HighlightBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ HighlightBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The HighlightBackground brush.

See Also

ListItem Class


HighlightTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..HighlightTextColor Property
ListItem Class See Also Send Feedback
Gets or sets the color of the highlight text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color HighlightTextColor { get; set; }
Visual Basic
Public Property HighlightTextColor As Color
    Get
    Set
Visual C++
public:
property Color HighlightTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the highlight text.

See Also

ListItem Class


ImageBeforeText Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..ImageBeforeText Property
ListItem Class See Also Send Feedback
Gets or sets whether the item's image is displayed before or after the item's text and description

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ImageBeforeText { get; set; }
Visual Basic
Public Property ImageBeforeText As Boolean
    Get
    Set
Visual C++
public:
property bool ImageBeforeText {
    bool get ();
    void set (bool value);
}

See Also

ListItem Class


ImageIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..ImageIndex Property
ListItem Class See Also Send Feedback
Gets or sets the image list index value of the item's image in the normal state.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ImageIndex { get; set; }
Visual Basic
Public Property ImageIndex As Integer
    Get
    Set
Visual C++
public:
property int ImageIndex {
    int get ();
    void set (int value);
}

See Also

ListItem Class


ImageIndexHover Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..ImageIndexHover Property
ListItem Class See Also Send Feedback
Gets or sets the image list index value of the item's image in the hover state

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ImageIndexHover { get; set; }
Visual Basic
Public Property ImageIndexHover As Integer
    Get
    Set
Visual C++
public:
property int ImageIndexHover {
    int get ();
    void set (int value);
}

See Also

ListItem Class


ImageIndexSelected Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..ImageIndexSelected Property
ListItem Class See Also Send Feedback
Gets or sets the image list index value of the item's image in the selected state.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ImageIndexSelected { get; set; }
Visual Basic
Public Property ImageIndexSelected As Integer
    Get
    Set
Visual C++
public:
property int ImageIndexSelected {
    int get ();
    void set (int value);
}

See Also

ListItem Class


IsChecked Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..IsChecked Property
ListItem Class See Also Send Feedback
Gets or sets a value indicating whether the item is checked.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Nullable<bool> IsChecked { get; set; }
Visual Basic
Public Property IsChecked As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> IsChecked {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Field Value

true if the item is checked; otherwise, false.

See Also

ListItem Class


IsThreeState Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..IsThreeState Property
ListItem Class See Also Send Feedback
Gets or sets a value indicating whether the ListItem supports 3 check states.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsThreeState { get; set; }
Visual Basic
Public Property IsThreeState As Boolean
    Get
    Set
Visual C++
public:
property bool IsThreeState {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance is three state; otherwise, false.

See Also

ListItem Class


ItemLeftAndRightOffset Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..ItemLeftAndRightOffset Property
ListItem Class See Also Send Feedback
Gets or sets the item's left and right border offset.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ItemLeftAndRightOffset { get; set; }
Visual Basic
Public Property ItemLeftAndRightOffset As Integer
    Get
    Set
Visual C++
public:
property int ItemLeftAndRightOffset {
    int get ();
    void set (int value);
}

Field Value

The item left and right spacing.

See Also

ListItem Class


RenderBounds Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..RenderBounds Property
ListItem Class See Also Send Feedback
Gets the render bounds.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle RenderBounds { get; internal set; }
Visual Basic
Public Property RenderBounds As Rectangle
    Get
    Friend Set
Visual C++
public:
property Rectangle RenderBounds {
    Rectangle get ();
    internal: void set (Rectangle value);
}

Field Value

The render bounds.

See Also

ListItem Class


RoundedCornersMask Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..RoundedCornersMask Property
ListItem Class See Also Send Feedback
Gets or sets the mask that determines which corners are rounded

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public byte RoundedCornersMask { get; set; }
Visual Basic
Public Property RoundedCornersMask As Byte
    Get
    Set
Visual C++
public:
property unsigned char RoundedCornersMask {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

ListItem Class


RoundedCornersRadius Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..RoundedCornersRadius Property
ListItem Class See Also Send Feedback
Gets or sets the rounded corners radius of the ListItem.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int RoundedCornersRadius { get; set; }
Visual Basic
Public Property RoundedCornersRadius As Integer
    Get
    Set
Visual C++
public:
property int RoundedCornersRadius {
    int get ();
    void set (int value);
}

See Also

ListItem Class


SelectedBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..SelectedBackgroundBorder Property
ListItem Class See Also Send Feedback
Gets or sets the selectedBackground border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color SelectedBackgroundBorder { get; set; }
Visual Basic
Public Property SelectedBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color SelectedBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The selectedBackground border.

See Also

ListItem Class


SelectedBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..SelectedBackgroundBrush Property
ListItem Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush SelectedBackgroundBrush { get; set; }
Visual Basic
Public Property SelectedBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ SelectedBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

ListItem Class


SelectedTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..SelectedTextColor Property
ListItem Class See Also Send Feedback
Gets or sets the color of the selected text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color SelectedTextColor { get; set; }
Visual Basic
Public Property SelectedTextColor As Color
    Get
    Set
Visual C++
public:
property Color SelectedTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the selected text.

See Also

ListItem Class


StringAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..StringAlignment Property
ListItem Class See Also Send Feedback
Gets or sets the string alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public StringAlignment StringAlignment { get; set; }
Visual Basic
Public Property StringAlignment As StringAlignment
    Get
    Set
Visual C++
public:
property StringAlignment StringAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}

Field Value

The string alignment.

See Also

ListItem Class


StringLineAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..StringLineAlignment Property
ListItem Class See Also Send Feedback
Gets or sets the string line alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public StringAlignment StringLineAlignment { get; set; }
Visual Basic
Public Property StringLineAlignment As StringAlignment
    Get
    Set
Visual C++
public:
property StringAlignment StringLineAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}

Field Value

The string line alignment.

See Also

ListItem Class


Tag Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..Tag Property
ListItem Class See Also Send Feedback
Gets or sets the tag.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object Tag { get; set; }
Visual Basic
Public Property Tag As Object
    Get
    Set
Visual C++
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Field Value

The tag.

See Also

ListItem Class


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..Text Property
ListItem Class See Also Send Feedback
Gets or sets the text of the item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

ListItem Class


TextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..TextColor Property
ListItem Class See Also Send Feedback
Gets or sets the color of the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color TextColor { get; set; }
Visual Basic
Public Property TextColor As Color
    Get
    Set
Visual C++
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the text.

See Also

ListItem Class


UseThemeBackground Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..UseThemeBackground Property
ListItem Class See Also Send Feedback
Gets or sets a value indicating whether to use theme's background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBackground { get; set; }
Visual Basic
Public Property UseThemeBackground As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBackground {
    bool get ();
    void set (bool value);
}

See Also

ListItem Class


UseThemeTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..UseThemeTextColor Property
ListItem Class See Also Send Feedback
Gets or sets a value indicating whether to use the default text color of the theme.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeTextColor { get; set; }
Visual Basic
Public Property UseThemeTextColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeTextColor {
    bool get ();
    void set (bool value);
}

See Also

ListItem Class


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..Value Property
ListItem Class See Also Send Feedback
Gets or sets a user defined value

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object Value { get; set; }
Visual Basic
Public Property Value As Object
    Get
    Set
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Remarks

Use this property to associate the ListItem with a specific object.

See Also

ListItem Class


Visible Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..Visible Property
ListItem Class See Also Send Feedback
Gets or sets a value indicating whether this ListItem is visible.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Visible { get; set; }
Visual Basic
Public Property Visible As Boolean
    Get
    Set
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Field Value

true if visible; otherwise, false.

See Also

ListItem Class


ListItem Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
ListItem Events
ListItem Class See Also Send Feedback

The ListItem type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged |

See Also

ListItem Class


PropertyChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
ListItem..::..PropertyChanged Event
ListItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

ListItem Class


ListItemComparer Class

[image]

VIBlend Controls for WinForms Help Documentation
ListItemComparer Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class ListItemComparer : IComparer<ListItem>
Visual Basic
Public Class ListItemComparer _
    Implements IComparer(Of ListItem)
Visual C++
public ref class ListItemComparer : IComparer<ListItem^>

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..ListItemComparer

See Also

ListItemComparer Members


ListItemComparer Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
ListItemComparer Members
ListItemComparer Class Constructors Methods See Also Send Feedback

The ListItemComparer type exposes the following members.

Constructors

 | Name | Description
Public method | ListItemComparer | Initializes a new instance of the ListItemComparer class

Methods

 | Name | Description
Public method | Compare | Compares the specified item1.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ListItemComparer Class


ListItemComparer Constructor

[image]

VIBlend Controls for WinForms Help Documentation
ListItemComparer Constructor
ListItemComparer Class See Also Send Feedback
Initializes a new instance of the ListItemComparer class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ListItemComparer(
    bool ascending
)
Visual Basic
Public Sub New ( _
    ascending As Boolean _
)
Visual C++
public:
ListItemComparer(
    bool ascending
)

Parameters

ascending
Type: System..::..Boolean

See Also

ListItemComparer Class


ListItemComparer Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
ListItemComparer Methods
ListItemComparer Class See Also Send Feedback

The ListItemComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares the specified item1.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ListItemComparer Class


Compare Method

[image]

VIBlend Controls for WinForms Help Documentation
ListItemComparer..::..Compare Method
ListItemComparer Class See Also Send Feedback
Compares the specified item1.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Compare(
    ListItem item1,
    ListItem item2
)
Visual Basic
Public Function Compare ( _
    item1 As ListItem, _
    item2 As ListItem _
) As Integer
Visual C++
public:
virtual int Compare(
    ListItem^ item1,
    ListItem^ item2
) sealed

Parameters

item1
Type: VIBlend.WinForms.Controls..::..ListItem
The item1.
item2
Type: VIBlend.WinForms.Controls..::..ListItem
The item2.

Return Value

Implements

IComparer<(Of <(<'T>)>)>..::..Compare(T, T)

See Also

ListItemComparer Class


ListItemsCollection Class

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection Class
Members See Also Send Feedback
Represents a collection of ListItemsCollection

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[SerializableAttribute]
public class ListItemsCollection : IEnumerable<ListItem>,
    IList, ICollection, IEnumerable
Visual Basic
<SerializableAttribute> _
Public Class ListItemsCollection _
    Implements IEnumerable(Of ListItem), IList,  _
    ICollection, IEnumerable
Visual C++
[SerializableAttribute]
public ref class ListItemsCollection : IEnumerable<ListItem^>,
    IList, ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..ListItemsCollection

See Also

ListItemsCollection Members


ListItemsCollection Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection Members
ListItemsCollection Class Constructors Methods Properties Events See Also Send Feedback

The ListItemsCollection type exposes the following members.

Constructors

 | Name | Description
Public method | ListItemsCollection | Constructor

Methods

 | Name | Description
Public method | Add(String) | Adds a new item to the collection
Public method | Add(ListItem) | Adds a new item to the collection
Public method | AddRange | Adds the range.
Public method | Clear | Removes all items from the collection
Public method | Contains | Determines whether the specified item is in the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified Item and returns the zero-based index of the first occurrence within the entire collection
Public method | Insert(String, Int32) | Inserts a ListItem into the collection at the specified index
Public method | Insert(ListItem, Int32) | Inserts a ListItem into the collection at the specified index
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event.
Public method | Remove | Removes the first occurrence of a specific ListItem from the collection
Public method | RemoveAt | Removes the ListItem at the specified index of the collection
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the collection
Public property | InnerList | Gets the inner list.
Public property | Item | Gets or sets the element at the specified index.
Public property | List | Gets the un sorted list.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when the collection has changed

See Also

ListItemsCollection Class


ListItemsCollection Constructor

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection Constructor
ListItemsCollection Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ListItemsCollection()
Visual Basic
Public Sub New
Visual C++
public:
ListItemsCollection()

See Also

ListItemsCollection Class


ListItemsCollection Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection Methods
ListItemsCollection Class See Also Send Feedback

The ListItemsCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add(String) | Adds a new item to the collection
Public method | Add(ListItem) | Adds a new item to the collection
Public method | AddRange | Adds the range.
Public method | Clear | Removes all items from the collection
Public method | Contains | Determines whether the specified item is in the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified Item and returns the zero-based index of the first occurrence within the entire collection
Public method | Insert(String, Int32) | Inserts a ListItem into the collection at the specified index
Public method | Insert(ListItem, Int32) | Inserts a ListItem into the collection at the specified index
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event.
Public method | Remove | Removes the first occurrence of a specific ListItem from the collection
Public method | RemoveAt | Removes the ListItem at the specified index of the collection
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ListItemsCollection Class


Add Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..Add Method
ListItemsCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(String) | Adds a new item to the collection
Public method | Add(ListItem) | Adds a new item to the collection

See Also

ListItemsCollection Class
ListItemsCollection Members


Add Method (String)

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..Add Method (String)
ListItemsCollection Class See Also Send Feedback
Adds a new item to the collection

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ListItem Add(
    string ItemText
)
Visual Basic
Public Overridable Function Add ( _
    ItemText As String _
) As ListItem
Visual C++
public:
virtual ListItem^ Add(
    String^ ItemText
)

Parameters

ItemText
Type: System..::..String
Item text

Return Value

The method returns a reference to the ListItem object which is added

See Also

ListItemsCollection Class
Add Overload


Add Method (ListItem)

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..Add Method (ListItem)
ListItemsCollection Class See Also Send Feedback
Adds a new item to the collection

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ListItem Add(
    ListItem item
)
Visual Basic
Public Overridable Function Add ( _
    item As ListItem _
) As ListItem
Visual C++
public:
virtual ListItem^ Add(
    ListItem^ item
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..ListItem
Reference to the ListItem object to add

Return Value

The method returns a reference to the ListItem object which is added

See Also

ListItemsCollection Class
Add Overload


AddRange Method

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..AddRange Method
ListItemsCollection Class See Also Send Feedback
Adds the range.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void AddRange(
    IEnumerable<ListItem> collection
)
Visual Basic
Public Overridable Sub AddRange ( _
    collection As IEnumerable(Of ListItem) _
)
Visual C++
public:
virtual void AddRange(
    IEnumerable<ListItem^>^ collection
)

Parameters

collection
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ListItem >)>)>
The collection.

See Also

ListItemsCollection Class


Clear Method

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..Clear Method
ListItemsCollection Class See Also Send Feedback
Removes all items from the collection

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

ListItemsCollection Class


Contains Method

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..Contains Method
ListItemsCollection Class See Also Send Feedback
Determines whether the specified item is in the collection.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Contains(
    ListItem item
)
Visual Basic
Public Function Contains ( _
    item As ListItem _
) As Boolean
Visual C++
public:
bool Contains(
    ListItem^ item
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..ListItem

See Also

ListItemsCollection Class


GetEnumerator Method

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..GetEnumerator Method
ListItemsCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual IEnumerator<ListItem> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of ListItem)
Visual C++
public:
virtual IEnumerator<ListItem^>^ GetEnumerator()

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

ListItemsCollection Class


IndexOf Method

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..IndexOf Method
ListItemsCollection Class See Also Send Feedback
Searches for the specified Item and returns the zero-based index of the first occurrence within the entire collection

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual int IndexOf(
    ListItem item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As ListItem _
) As Integer
Visual C++
public:
virtual int IndexOf(
    ListItem^ item
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..ListItem
The item to location in the collection

Return Value

The zero-based index of the first occurrence of item within the entire collection, if found; otherwise, -1.

See Also

ListItemsCollection Class


Insert Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..Insert Method
ListItemsCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Insert(String, Int32) | Inserts a ListItem into the collection at the specified index
Public method | Insert(ListItem, Int32) | Inserts a ListItem into the collection at the specified index

See Also

ListItemsCollection Class
ListItemsCollection Members


Insert Method (String, Int32)

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..Insert Method (String, Int32)
ListItemsCollection Class See Also Send Feedback
Inserts a ListItem into the collection at the specified index

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void Insert(
    string item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As String, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    String^ item,
    int index
)

Parameters

item
Type: System..::..String
ListItem to insert
index
Type: System..::..Int32
The zero-based index at which item should be inserted

See Also

ListItemsCollection Class
Insert Overload


Insert Method (ListItem, Int32)

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..Insert Method (ListItem, Int32)
ListItemsCollection Class See Also Send Feedback
Inserts a ListItem into the collection at the specified index

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void Insert(
    ListItem item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As ListItem, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    ListItem^ item,
    int index
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..ListItem
ListItem to insert
index
Type: System..::..Int32
The zero-based index at which item should be inserted

See Also

ListItemsCollection Class
Insert Overload


OnCollectionChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..OnCollectionChanged Method
ListItemsCollection Class See Also Send Feedback
Raises the CollectionChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected void OnCollectionChanged()
Visual Basic
Protected Sub OnCollectionChanged
Visual C++
protected:
void OnCollectionChanged()

See Also

ListItemsCollection Class


Remove Method

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..Remove Method
ListItemsCollection Class See Also Send Feedback
Removes the first occurrence of a specific ListItem from the collection

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void Remove(
    ListItem item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As ListItem _
)
Visual C++
public:
virtual void Remove(
    ListItem^ item
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..ListItem
The ListItem to remove from the collection

See Also

ListItemsCollection Class


RemoveAt Method

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..RemoveAt Method
ListItemsCollection Class See Also Send Feedback
Removes the ListItem at the specified index of the collection

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the ListItem to remove

See Also

ListItemsCollection Class


ListItemsCollection Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection Properties
ListItemsCollection Class See Also Send Feedback

The ListItemsCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the collection
Public property | InnerList | Gets the inner list.
Public property | Item | Gets or sets the element at the specified index.
Public property | List | Gets the un sorted list.

See Also

ListItemsCollection Class


Count Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..Count Property
ListItemsCollection Class See Also Send Feedback
Gets the number of elements actually contained in the collection

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Implements

ICollection..::..Count

See Also

ListItemsCollection Class


InnerList Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..InnerList Property
ListItemsCollection Class See Also Send Feedback
Gets the inner list.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<ListItem> InnerList { get; }
Visual Basic
Public ReadOnly Property InnerList As List(Of ListItem)
    Get
Visual C++
public:
property List<ListItem^>^ InnerList {
    List<ListItem^>^ get ();
}

Field Value

The inner list.

See Also

ListItemsCollection Class


Item Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..Item Property
ListItemsCollection Class See Also Send Feedback
Gets or sets the element at the specified index.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ListItem this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As ListItem
    Get
    Set
Visual C++
public:
virtual property ListItem^ default[int index] {
    ListItem^ get (int index);
    void set (int index, ListItem^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get or set.

Return Value

The element at the specified index.

See Also

ListItemsCollection Class


List Property

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..List Property
ListItemsCollection Class See Also Send Feedback
Gets the un sorted list.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<ListItem> List { get; }
Visual Basic
Public ReadOnly Property List As List(Of ListItem)
    Get
Visual C++
public:
property List<ListItem^>^ List {
    List<ListItem^>^ get ();
}

Field Value

The un sorted list.

See Also

ListItemsCollection Class


ListItemsCollection Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection Events
ListItemsCollection Class See Also Send Feedback

The ListItemsCollection type exposes the following members.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when the collection has changed

See Also

ListItemsCollection Class


CollectionChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
ListItemsCollection..::..CollectionChanged Event
ListItemsCollection Class See Also Send Feedback
Occurs when the collection has changed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler CollectionChanged
Visual Basic
Public Event CollectionChanged As EventHandler
Visual C++
public:
 event EventHandler^ CollectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ListItemsCollection Class


MonthPattern Class

[image]

VIBlend Controls for WinForms Help Documentation
MonthPattern Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class MonthPattern
Visual Basic
Public Class MonthPattern
Visual C++
public ref class MonthPattern

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..MonthPattern

See Also

MonthPattern Members


MonthPattern Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
MonthPattern Members
MonthPattern Class Constructors Methods Properties See Also Send Feedback

The MonthPattern type exposes the following members.

Constructors

 | Name | Description
Public method | MonthPattern | Initializes a new instance of the MonthPattern class.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | MonthsToNextOccurence | Gets or sets the month.
Public property | OccurenceDay | Gets or sets the day.

See Also

MonthPattern Class


MonthPattern Constructor

[image]

VIBlend Controls for WinForms Help Documentation
MonthPattern Constructor
MonthPattern Class See Also Send Feedback
Initializes a new instance of the MonthPattern class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public MonthPattern(
    int month,
    int day
)
Visual Basic
Public Sub New ( _
    month As Integer, _
    day As Integer _
)
Visual C++
public:
MonthPattern(
    int month,
    int day
)

Parameters

month
Type: System..::..Int32
The month.
day
Type: System..::..Int32
The day.

See Also

MonthPattern Class


MonthPattern Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
MonthPattern Methods
MonthPattern Class See Also Send Feedback

The MonthPattern type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

MonthPattern Class


Clone Method

[image]

VIBlend Controls for WinForms Help Documentation
MonthPattern..::..Clone Method
MonthPattern Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public MonthPattern Clone()
Visual Basic
Public Function Clone As MonthPattern
Visual C++
public:
MonthPattern^ Clone()

See Also

MonthPattern Class


ToString Method

[image]

VIBlend Controls for WinForms Help Documentation
MonthPattern..::..ToString Method
MonthPattern Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

MonthPattern Class


MonthPattern Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
MonthPattern Properties
MonthPattern Class See Also Send Feedback

The MonthPattern type exposes the following members.

Properties

 | Name | Description
Public property | MonthsToNextOccurence | Gets or sets the month.
Public property | OccurenceDay | Gets or sets the day.

See Also

MonthPattern Class


MonthsToNextOccurence Property

[image]

VIBlend Controls for WinForms Help Documentation
MonthPattern..::..MonthsToNextOccurence Property
MonthPattern Class See Also Send Feedback
Gets or sets the month.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int MonthsToNextOccurence { get; set; }
Visual Basic
Public Property MonthsToNextOccurence As Integer
    Get
    Set
Visual C++
public:
property int MonthsToNextOccurence {
    int get ();
    void set (int value);
}

Field Value

The month.

See Also

MonthPattern Class


OccurenceDay Property

[image]

VIBlend Controls for WinForms Help Documentation
MonthPattern..::..OccurenceDay Property
MonthPattern Class See Also Send Feedback
Gets or sets the day.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int OccurenceDay { get; set; }
Visual Basic
Public Property OccurenceDay As Integer
    Get
    Set
Visual C++
public:
property int OccurenceDay {
    int get ();
    void set (int value);
}

Field Value

The day.

See Also

MonthPattern Class


MouseAndKeyboardFilter Class

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter Class
Members See Also Send Feedback
Represents a MouseAndKeyboardFilter

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class MouseAndKeyboardFilter : IMessageFilter
Visual Basic
Public Class MouseAndKeyboardFilter _
    Implements IMessageFilter
Visual C++
public ref class MouseAndKeyboardFilter : IMessageFilter

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..MouseAndKeyboardFilter

See Also

MouseAndKeyboardFilter Members


MouseAndKeyboardFilter Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter Members
MouseAndKeyboardFilter Class Constructors Methods Fields Events See Also Send Feedback

The MouseAndKeyboardFilter type exposes the following members.

Constructors

 | Name | Description
Public method | MouseAndKeyboardFilter | Initializes a new instance of the MouseAndKeyboardFilter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnKeyDown |
Protected method | OnKeyUp |
Protected method | OnMouseEventFired |
Public method | PreFilterMessage |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
WM_KEYDOWN |
WM_KEYUP |
WM_LBUTTONDBLCLK |
WM_LBUTTONDOWN |
WM_LBUTTONUP |
WM_MBUTTONDBLCLK |
WM_MBUTTONDOWN |
WM_MBUTTONUP |
WM_NCLBUTTONDOWN |
WM_NCLBUTTONUP |
WM_RBUTTONDBLCLK |
WM_RBUTTONDOWN |
WM_RBUTTONUP |

Events

 | Name | Description
Public event | KeyDown |
Public event | KeyUp |
Public event | MouseEventFired |

See Also

MouseAndKeyboardFilter Class


MouseAndKeyboardFilter Constructor

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter Constructor
MouseAndKeyboardFilter Class See Also Send Feedback
Initializes a new instance of the MouseAndKeyboardFilter class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public MouseAndKeyboardFilter()
Visual Basic
Public Sub New
Visual C++
public:
MouseAndKeyboardFilter()

See Also

MouseAndKeyboardFilter Class


MouseAndKeyboardFilter Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter Fields
MouseAndKeyboardFilter Class See Also Send Feedback

The MouseAndKeyboardFilter type exposes the following members.

Fields

Name | Description
WM_KEYDOWN |
WM_KEYUP |
WM_LBUTTONDBLCLK |
WM_LBUTTONDOWN |
WM_LBUTTONUP |
WM_MBUTTONDBLCLK |
WM_MBUTTONDOWN |
WM_MBUTTONUP |
WM_NCLBUTTONDOWN |
WM_NCLBUTTONUP |
WM_RBUTTONDBLCLK |
WM_RBUTTONDOWN |
WM_RBUTTONUP |

See Also

MouseAndKeyboardFilter Class


WM_KEYDOWN Field

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..WM_KEYDOWN Field
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_KEYDOWN
Visual Basic
Public Const WM_KEYDOWN As Integer
Visual C++
public:
literal int WM_KEYDOWN

See Also

MouseAndKeyboardFilter Class


WM_KEYUP Field

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..WM_KEYUP Field
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_KEYUP
Visual Basic
Public Const WM_KEYUP As Integer
Visual C++
public:
literal int WM_KEYUP

See Also

MouseAndKeyboardFilter Class


WM_LBUTTONDBLCLK Field

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..WM_LBUTTONDBLCLK Field
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_LBUTTONDBLCLK
Visual Basic
Public Const WM_LBUTTONDBLCLK As Integer
Visual C++
public:
literal int WM_LBUTTONDBLCLK

See Also

MouseAndKeyboardFilter Class


WM_LBUTTONDOWN Field

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..WM_LBUTTONDOWN Field
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_LBUTTONDOWN
Visual Basic
Public Const WM_LBUTTONDOWN As Integer
Visual C++
public:
literal int WM_LBUTTONDOWN

See Also

MouseAndKeyboardFilter Class


WM_LBUTTONUP Field

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..WM_LBUTTONUP Field
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_LBUTTONUP
Visual Basic
Public Const WM_LBUTTONUP As Integer
Visual C++
public:
literal int WM_LBUTTONUP

See Also

MouseAndKeyboardFilter Class


WM_MBUTTONDBLCLK Field

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..WM_MBUTTONDBLCLK Field
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_MBUTTONDBLCLK
Visual Basic
Public Const WM_MBUTTONDBLCLK As Integer
Visual C++
public:
literal int WM_MBUTTONDBLCLK

See Also

MouseAndKeyboardFilter Class


WM_MBUTTONDOWN Field

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..WM_MBUTTONDOWN Field
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_MBUTTONDOWN
Visual Basic
Public Const WM_MBUTTONDOWN As Integer
Visual C++
public:
literal int WM_MBUTTONDOWN

See Also

MouseAndKeyboardFilter Class


WM_MBUTTONUP Field

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..WM_MBUTTONUP Field
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_MBUTTONUP
Visual Basic
Public Const WM_MBUTTONUP As Integer
Visual C++
public:
literal int WM_MBUTTONUP

See Also

MouseAndKeyboardFilter Class


WM_NCLBUTTONDOWN Field

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..WM_NCLBUTTONDOWN Field
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_NCLBUTTONDOWN
Visual Basic
Public Const WM_NCLBUTTONDOWN As Integer
Visual C++
public:
literal int WM_NCLBUTTONDOWN

See Also

MouseAndKeyboardFilter Class


WM_NCLBUTTONUP Field

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..WM_NCLBUTTONUP Field
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_NCLBUTTONUP
Visual Basic
Public Const WM_NCLBUTTONUP As Integer
Visual C++
public:
literal int WM_NCLBUTTONUP

See Also

MouseAndKeyboardFilter Class


WM_RBUTTONDBLCLK Field

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..WM_RBUTTONDBLCLK Field
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_RBUTTONDBLCLK
Visual Basic
Public Const WM_RBUTTONDBLCLK As Integer
Visual C++
public:
literal int WM_RBUTTONDBLCLK

See Also

MouseAndKeyboardFilter Class


WM_RBUTTONDOWN Field

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..WM_RBUTTONDOWN Field
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_RBUTTONDOWN
Visual Basic
Public Const WM_RBUTTONDOWN As Integer
Visual C++
public:
literal int WM_RBUTTONDOWN

See Also

MouseAndKeyboardFilter Class


WM_RBUTTONUP Field

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..WM_RBUTTONUP Field
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_RBUTTONUP
Visual Basic
Public Const WM_RBUTTONUP As Integer
Visual C++
public:
literal int WM_RBUTTONUP

See Also

MouseAndKeyboardFilter Class


MouseAndKeyboardFilter Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter Methods
MouseAndKeyboardFilter Class See Also Send Feedback

The MouseAndKeyboardFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnKeyDown |
Protected method | OnKeyUp |
Protected method | OnMouseEventFired |
Public method | PreFilterMessage |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MouseAndKeyboardFilter Class


OnKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..OnKeyDown Method
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overridable Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs

See Also

MouseAndKeyboardFilter Class


OnKeyUp Method

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..OnKeyUp Method
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnKeyUp(
    KeyEventArgs e
)
Visual Basic
Protected Overridable Sub OnKeyUp ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyUp(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs

See Also

MouseAndKeyboardFilter Class


OnMouseEventFired Method

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..OnMouseEventFired Method
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnMouseEventFired()
Visual Basic
Protected Overridable Sub OnMouseEventFired
Visual C++
protected:
virtual void OnMouseEventFired()

See Also

MouseAndKeyboardFilter Class


PreFilterMessage Method

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..PreFilterMessage Method
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PreFilterMessage(
    ref Message m
)
Visual Basic
Public Function PreFilterMessage ( _
    ByRef m As Message _
) As Boolean
Visual C++
public:
virtual bool PreFilterMessage(
    Message% m
) sealed

Parameters

m
Type: System.Windows.Forms..::..Message %

Implements

IMessageFilter..::..PreFilterMessage(Message%)

See Also

MouseAndKeyboardFilter Class


MouseAndKeyboardFilter Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter Events
MouseAndKeyboardFilter Class See Also Send Feedback

The MouseAndKeyboardFilter type exposes the following members.

Events

 | Name | Description
Public event | KeyDown |
Public event | KeyUp |
Public event | MouseEventFired |

See Also

MouseAndKeyboardFilter Class


KeyDown Event

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..KeyDown Event
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event KeyEventHandler KeyDown
Visual Basic
Public Event KeyDown As KeyEventHandler
Visual C++
public:
 event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}

See Also

MouseAndKeyboardFilter Class


KeyUp Event

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..KeyUp Event
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event KeyEventHandler KeyUp
Visual Basic
Public Event KeyUp As KeyEventHandler
Visual C++
public:
 event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}

See Also

MouseAndKeyboardFilter Class


MouseEventFired Event

[image]

VIBlend Controls for WinForms Help Documentation
MouseAndKeyboardFilter..::..MouseEventFired Event
MouseAndKeyboardFilter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler MouseEventFired
Visual Basic
Public Event MouseEventFired As EventHandler
Visual C++
public:
 event EventHandler^ MouseEventFired {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

MouseAndKeyboardFilter Class


OfficeRibbonForm Class

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class OfficeRibbonForm : Form,
    IScrollableControlBase
Visual Basic
Public Class OfficeRibbonForm _
    Inherits Form _
    Implements IScrollableControlBase
Visual C++
public ref class OfficeRibbonForm : public Form,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
VIBlend.WinForms.Controls..::..OfficeRibbonForm

See Also

OfficeRibbonForm Members


OfficeRibbonForm Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm Members
OfficeRibbonForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The OfficeRibbonForm type exposes the following members.

Constructors

 | Name | Description
Public method | OfficeRibbonForm | Initializes a new instance of the OfficeRibbonForm class

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes of the resources (other than memory) used by the Form. (Inherited from Form.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawText |
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleMaximize | Handles the maximize.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the [E:Layout] event. (Overrides Form..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | (Overrides Form..::..OnLoad(EventArgs).)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Overrides Form..::..OnTextChanged(EventArgs).)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show()()()() | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | Overrides the WndProc funciton (Overrides Form..::..WndProc(Message%).)

Fields

 | Name | Description
Public field | quickAccessToolbar1 |
Public field | vRibbonApplicationButton1 |

Properties

 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CloseBox | Gets or sets a value indicating whether to show the close box.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | Helper |
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Ribbon | Gets or set the RibbonBar's instance.
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | TextAlignment | Gets or sets the text alignment.
Public property | Theme | Gets or sets the theme of the control.
Public property | TitleHeight | Gets or sets the height of the title.
Public property | TitleRectangle | Gets the title rectangle.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets the form's window state. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

OfficeRibbonForm Class


OfficeRibbonForm Constructor

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm Constructor
OfficeRibbonForm Class See Also Send Feedback
Initializes a new instance of the OfficeRibbonForm class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public OfficeRibbonForm()
Visual Basic
Public Sub New
Visual C++
public:
OfficeRibbonForm()

See Also

OfficeRibbonForm Class


OfficeRibbonForm Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm Fields
OfficeRibbonForm Class See Also Send Feedback

The OfficeRibbonForm type exposes the following members.

Fields

 | Name | Description
Public field | quickAccessToolbar1 |
Public field | vRibbonApplicationButton1 |

See Also

OfficeRibbonForm Class


quickAccessToolbar1 Field

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..quickAccessToolbar1 Field
OfficeRibbonForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public QuickAccessToolbar quickAccessToolbar1
Visual Basic
Public quickAccessToolbar1 As QuickAccessToolbar
Visual C++
public:
QuickAccessToolbar^ quickAccessToolbar1

See Also

OfficeRibbonForm Class


vRibbonApplicationButton1 Field

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..vRibbonApplicationButton1 Field
OfficeRibbonForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonApplicationButton vRibbonApplicationButton1
Visual Basic
Public vRibbonApplicationButton1 As vRibbonApplicationButton
Visual C++
public:
vRibbonApplicationButton^ vRibbonApplicationButton1

See Also

OfficeRibbonForm Class


OfficeRibbonForm Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm Methods
OfficeRibbonForm Class See Also Send Feedback

The OfficeRibbonForm type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes of the resources (other than memory) used by the Form. (Inherited from Form.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawText |
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleMaximize | Handles the maximize.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the [E:Layout] event. (Overrides Form..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | (Overrides Form..::..OnLoad(EventArgs).)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Overrides Form..::..OnTextChanged(EventArgs).)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show()()()() | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | Overrides the WndProc funciton (Overrides Form..::..WndProc(Message%).)

See Also

OfficeRibbonForm Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..AccessibilityNotifyClients Method
OfficeRibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

OfficeRibbonForm Class
OfficeRibbonForm Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..BeginInvoke Method
OfficeRibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

OfficeRibbonForm Class
OfficeRibbonForm Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..Dispose Method
OfficeRibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes of the resources (other than memory) used by the Form. (Inherited from Form.)

See Also

OfficeRibbonForm Class
OfficeRibbonForm Members


DrawText Method

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..DrawText Method
OfficeRibbonForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void DrawText(
    PaintEventArgs e,
    int shadowOffset,
    int borderOffset
)
Visual Basic
Protected Friend Overridable Sub DrawText ( _
    e As PaintEventArgs, _
    shadowOffset As Integer, _
    borderOffset As Integer _
)
Visual C++
protected public:
virtual void DrawText(
    PaintEventArgs^ e,
    int shadowOffset,
    int borderOffset
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
shadowOffset
Type: System..::..Int32
borderOffset
Type: System..::..Int32

See Also

OfficeRibbonForm Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..GetChildAtPoint Method
OfficeRibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

OfficeRibbonForm Class
OfficeRibbonForm Members


HandleMaximize Method

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..HandleMaximize Method
OfficeRibbonForm Class See Also Send Feedback
Handles the maximize.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void HandleMaximize()
Visual Basic
Public Sub HandleMaximize
Visual C++
public:
void HandleMaximize()

See Also

OfficeRibbonForm Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..Invalidate Method
OfficeRibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

OfficeRibbonForm Class
OfficeRibbonForm Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..Invoke Method
OfficeRibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

OfficeRibbonForm Class
OfficeRibbonForm Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..MemberwiseClone Method
OfficeRibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

OfficeRibbonForm Class
OfficeRibbonForm Members


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..OnLayout Method
OfficeRibbonForm Class See Also Send Feedback
Raises the [E:Layout] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
The LayoutEventArgs instance containing the event data.

See Also

OfficeRibbonForm Class


OnLoad Method

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..OnLoad Method
OfficeRibbonForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

OfficeRibbonForm Class


OnSizeChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..OnSizeChanged Method
OfficeRibbonForm Class See Also Send Feedback
Raises the SizeChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnSizeChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnSizeChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSizeChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

OfficeRibbonForm Class


OnTextChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..OnTextChanged Method
OfficeRibbonForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnTextChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnTextChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnTextChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

OfficeRibbonForm Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..PerformLayout Method
OfficeRibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

OfficeRibbonForm Class
OfficeRibbonForm Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..ResumeLayout Method
OfficeRibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

OfficeRibbonForm Class
OfficeRibbonForm Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..RtlTranslateAlignment Method
OfficeRibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

OfficeRibbonForm Class
OfficeRibbonForm Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..Scale Method
OfficeRibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

OfficeRibbonForm Class
OfficeRibbonForm Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..Select Method
OfficeRibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

OfficeRibbonForm Class
OfficeRibbonForm Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..SetBounds Method
OfficeRibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

OfficeRibbonForm Class
OfficeRibbonForm Members


Show Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..Show Method
OfficeRibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Show()()()() | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

OfficeRibbonForm Class
OfficeRibbonForm Members


ShowDialog Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..ShowDialog Method
OfficeRibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

OfficeRibbonForm Class
OfficeRibbonForm Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..UpdateBounds Method
OfficeRibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

OfficeRibbonForm Class
OfficeRibbonForm Members


Validate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..Validate Method
OfficeRibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

OfficeRibbonForm Class
OfficeRibbonForm Members


ValidateChildren Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..ValidateChildren Method
OfficeRibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

OfficeRibbonForm Class
OfficeRibbonForm Members


WndProc Method

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..WndProc Method
OfficeRibbonForm Class See Also Send Feedback
Overrides the WndProc funciton

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void WndProc(
    ref Message m
)
Visual Basic
Protected Overrides Sub WndProc ( _
    ByRef m As Message _
)
Visual C++
protected:
virtual void WndProc(
    Message% m
) override

Parameters

m
Type: System.Windows.Forms..::..Message %

See Also

OfficeRibbonForm Class


OfficeRibbonForm Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm Properties
OfficeRibbonForm Class See Also Send Feedback

The OfficeRibbonForm type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CloseBox | Gets or sets a value indicating whether to show the close box.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | Helper |
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Ribbon | Gets or set the RibbonBar's instance.
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | TextAlignment | Gets or sets the text alignment.
Public property | Theme | Gets or sets the theme of the control.
Public property | TitleHeight | Gets or sets the height of the title.
Public property | TitleRectangle | Gets the title rectangle.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets the form's window state. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

OfficeRibbonForm Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..AllowAnimations Property
OfficeRibbonForm Class See Also Send Feedback
Gets or sets whether the control is animated

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

OfficeRibbonForm Class


CloseBox Property

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..CloseBox Property
OfficeRibbonForm Class See Also Send Feedback
Gets or sets a value indicating whether to show the close box.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool CloseBox { get; set; }
Visual Basic
Public Property CloseBox As Boolean
    Get
    Set
Visual C++
public:
property bool CloseBox {
    bool get ();
    void set (bool value);
}

See Also

OfficeRibbonForm Class


Helper Property

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..Helper Property
OfficeRibbonForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GlassFormUtility Helper { get; }
Visual Basic
Public ReadOnly Property Helper As GlassFormUtility
    Get
Visual C++
public:
property GlassFormUtility^ Helper {
    GlassFormUtility^ get ();
}

See Also

OfficeRibbonForm Class


Ribbon Property

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..Ribbon Property
OfficeRibbonForm Class See Also Send Feedback
Gets or set the RibbonBar's instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonBar Ribbon { get; set; }
Visual Basic
Public Property Ribbon As vRibbonBar
    Get
    Set
Visual C++
public:
property vRibbonBar^ Ribbon {
    vRibbonBar^ get ();
    void set (vRibbonBar^ value);
}

See Also

OfficeRibbonForm Class


TextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..TextAlignment Property
OfficeRibbonForm Class See Also Send Feedback
Gets or sets the text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment TextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The text alignment.

See Also

OfficeRibbonForm Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..Theme Property
OfficeRibbonForm Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ControlTheme Theme { get; set; }
Visual Basic
Public Overridable Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
virtual property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

OfficeRibbonForm Class


TitleHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..TitleHeight Property
OfficeRibbonForm Class See Also Send Feedback
Gets or sets the height of the title.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int TitleHeight { get; internal set; }
Visual Basic
Public Property TitleHeight As Integer
    Get
    Friend Set
Visual C++
public:
property int TitleHeight {
    int get ();
    internal: void set (int value);
}

Field Value

The height of the title.

See Also

OfficeRibbonForm Class


TitleRectangle Property

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..TitleRectangle Property
OfficeRibbonForm Class See Also Send Feedback
Gets the title rectangle.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle TitleRectangle { get; }
Visual Basic
Public ReadOnly Property TitleRectangle As Rectangle
    Get
Visual C++
public:
property Rectangle TitleRectangle {
    Rectangle get ();
}

Field Value

The title rectangle.

See Also

OfficeRibbonForm Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm..::..VIBlendTheme Property
OfficeRibbonForm Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

OfficeRibbonForm Class


OfficeRibbonForm Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
OfficeRibbonForm Events
OfficeRibbonForm Class See Also Send Feedback

The OfficeRibbonForm type exposes the following members.

Events

 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

OfficeRibbonForm Class


QuickAccessToolbar Class

[image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar Class
Members See Also Send Feedback
Represents a QuickAccessToolbar control which is often used in ribbon interfaces.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class QuickAccessToolbar : ScrollableControlMiniBase
Visual Basic
Public Class QuickAccessToolbar _
    Inherits ScrollableControlMiniBase
Visual C++
public ref class QuickAccessToolbar : public ScrollableControlMiniBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
ScrollableControlMiniBase
VIBlend.WinForms.Controls..::..QuickAccessToolbar

See Also

QuickAccessToolbar Members


QuickAccessToolbar Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar Members
QuickAccessToolbar Class Constructors Methods Fields Properties Events See Also Send Feedback

The QuickAccessToolbar type exposes the following members.

Constructors

 | Name | Description
Public method | QuickAccessToolbar | Initializes a new instance of the QuickAccessToolbar class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawQatBackground |
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | backFill |

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content | Gets the content.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets the drop down.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | ` Gets or sets the theme of the control.
Public property | ToolbarStyle | Gets or sets the toolbar style.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

QuickAccessToolbar Class


QuickAccessToolbar Constructor

[image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar Constructor
QuickAccessToolbar Class See Also Send Feedback
Initializes a new instance of the QuickAccessToolbar class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public QuickAccessToolbar()
Visual Basic
Public Sub New
Visual C++
public:
QuickAccessToolbar()

See Also

QuickAccessToolbar Class


QuickAccessToolbar Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar Fields
QuickAccessToolbar Class See Also Send Feedback

The QuickAccessToolbar type exposes the following members.

Fields

 | Name | Description
Protected field | backFill |

See Also

QuickAccessToolbar Class


backFill Field

[image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..backFill Field
QuickAccessToolbar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected BackgroundElement backFill
Visual Basic
Protected backFill As BackgroundElement
Visual C++
protected:
BackgroundElement^ backFill

See Also

QuickAccessToolbar Class


QuickAccessToolbar Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar Methods
QuickAccessToolbar Class See Also Send Feedback

The QuickAccessToolbar type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawQatBackground |
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

QuickAccessToolbar Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..AccessibilityNotifyClients Method
QuickAccessToolbar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

QuickAccessToolbar Class
QuickAccessToolbar Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..BeginInvoke Method
QuickAccessToolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

QuickAccessToolbar Class
QuickAccessToolbar Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..Dispose Method
QuickAccessToolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

QuickAccessToolbar Class
QuickAccessToolbar Members


DrawQatBackground Method

[image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..DrawQatBackground Method
QuickAccessToolbar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void DrawQatBackground(
    Graphics graphics,
    Rectangle bounds,
    Point roundPoint
)
Visual Basic
Protected Friend Overridable Sub DrawQatBackground ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    roundPoint As Point _
)
Visual C++
protected public:
virtual void DrawQatBackground(
    Graphics^ graphics,
    Rectangle bounds,
    Point roundPoint
)

Parameters

graphics
Type: System.Drawing..::..Graphics
bounds
Type: System.Drawing..::..Rectangle
roundPoint
Type: System.Drawing..::..Point

See Also

QuickAccessToolbar Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..GetChildAtPoint Method
QuickAccessToolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

QuickAccessToolbar Class
QuickAccessToolbar Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..Invalidate Method
QuickAccessToolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

QuickAccessToolbar Class
QuickAccessToolbar Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..Invoke Method
QuickAccessToolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

QuickAccessToolbar Class
QuickAccessToolbar Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..MemberwiseClone Method
QuickAccessToolbar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

QuickAccessToolbar Class
QuickAccessToolbar Members


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..OnLayout Method
QuickAccessToolbar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs

See Also

QuickAccessToolbar Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..OnPaint Method
QuickAccessToolbar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

QuickAccessToolbar Class


OnSizeChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..OnSizeChanged Method
QuickAccessToolbar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnSizeChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnSizeChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSizeChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

QuickAccessToolbar Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..PerformLayout Method
QuickAccessToolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

QuickAccessToolbar Class
QuickAccessToolbar Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..ResumeLayout Method
QuickAccessToolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

QuickAccessToolbar Class
QuickAccessToolbar Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..RtlTranslateAlignment Method
QuickAccessToolbar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

QuickAccessToolbar Class
QuickAccessToolbar Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..Scale Method
QuickAccessToolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

QuickAccessToolbar Class
QuickAccessToolbar Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..Select Method
QuickAccessToolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

QuickAccessToolbar Class
QuickAccessToolbar Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..SetBounds Method
QuickAccessToolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

QuickAccessToolbar Class
QuickAccessToolbar Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..UpdateBounds Method
QuickAccessToolbar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

QuickAccessToolbar Class
QuickAccessToolbar Members


QuickAccessToolbar Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar Properties
QuickAccessToolbar Class See Also Send Feedback

The QuickAccessToolbar type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content | Gets the content.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets the drop down.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | ` Gets or sets the theme of the control.
Public property | ToolbarStyle | Gets or sets the toolbar style.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

QuickAccessToolbar Class


Content Property

[image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..Content Property
QuickAccessToolbar Class See Also Send Feedback
Gets the content.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vHorizontalLayoutPanel Content { get; }
Visual Basic
Public ReadOnly Property Content As vHorizontalLayoutPanel
    Get
Visual C++
public:
property vHorizontalLayoutPanel^ Content {
    vHorizontalLayoutPanel^ get ();
}

Field Value

The content.

See Also

QuickAccessToolbar Class


DropDown Property

[image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..DropDown Property
QuickAccessToolbar Class See Also Send Feedback
Gets the drop down.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vApplicationMenuItem DropDown { get; }
Visual Basic
Public ReadOnly Property DropDown As vApplicationMenuItem
    Get
Visual C++
public:
property vApplicationMenuItem^ DropDown {
    vApplicationMenuItem^ get ();
}

Field Value

The drop down.

See Also

QuickAccessToolbar Class


StyleKey Property

[image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..StyleKey Property
QuickAccessToolbar Class See Also Send Feedback
Gets or sets the style key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual string StyleKey { get; set; }
Visual Basic
Protected Overridable Property StyleKey As String
    Get
    Set
Visual C++
protected:
virtual property String^ StyleKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The style key.

See Also

QuickAccessToolbar Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..Theme Property
QuickAccessToolbar Class See Also Send Feedback
` Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

QuickAccessToolbar Class


ToolbarStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..ToolbarStyle Property
QuickAccessToolbar Class See Also Send Feedback
Gets or sets the toolbar style.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RibbonStyle ToolbarStyle { get; set; }
Visual Basic
Public Property ToolbarStyle As RibbonStyle
    Get
    Set
Visual C++
public:
property RibbonStyle ToolbarStyle {
    RibbonStyle get ();
    void set (RibbonStyle value);
}

Field Value

The toolbar style.

See Also

QuickAccessToolbar Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar..::..VIBlendTheme Property
QuickAccessToolbar Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

QuickAccessToolbar Class


QuickAccessToolbar Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
QuickAccessToolbar Events
QuickAccessToolbar Class See Also Send Feedback

The QuickAccessToolbar type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

QuickAccessToolbar Class


RECT Structure

[image]

VIBlend Controls for WinForms Help Documentation
RECT Structure
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public struct RECT
Visual Basic
Public Structure RECT
Visual C++
public value class RECT

See Also

RECT Members


RECT Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
RECT Members
RECT Structure Methods See Also Send Feedback

The RECT type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

RECT Structure


RECT Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
RECT Methods
RECT Structure See Also Send Feedback

The RECT type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

RECT Structure


RecurrenceRange Class

[image]

VIBlend Controls for WinForms Help Documentation
RecurrenceRange Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class RecurrenceRange
Visual Basic
Public Class RecurrenceRange
Visual C++
public ref class RecurrenceRange

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..RecurrenceRange

See Also

RecurrenceRange Members


RecurrenceRange Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
RecurrenceRange Members
RecurrenceRange Class Constructors Methods Properties See Also Send Feedback

The RecurrenceRange type exposes the following members.

Constructors

 | Name | Description
Public method | RecurrenceRange | Initializes a new instance of the RecurrenceRange class.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | EndDate | Gets or sets the end date.
Public property | NumberOfOccurences | Gets or sets a value indicating the number of occurences
Public property | StartDate | Gets or sets the start date.

See Also

RecurrenceRange Class


RecurrenceRange Constructor

[image]

VIBlend Controls for WinForms Help Documentation
RecurrenceRange Constructor
RecurrenceRange Class See Also Send Feedback
Initializes a new instance of the RecurrenceRange class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RecurrenceRange()
Visual Basic
Public Sub New
Visual C++
public:
RecurrenceRange()

See Also

RecurrenceRange Class


RecurrenceRange Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
RecurrenceRange Methods
RecurrenceRange Class See Also Send Feedback

The RecurrenceRange type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

RecurrenceRange Class


Clone Method

[image]

VIBlend Controls for WinForms Help Documentation
RecurrenceRange..::..Clone Method
RecurrenceRange Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RecurrenceRange Clone()
Visual Basic
Public Function Clone As RecurrenceRange
Visual C++
public:
RecurrenceRange^ Clone()

See Also

RecurrenceRange Class


ToString Method

[image]

VIBlend Controls for WinForms Help Documentation
RecurrenceRange..::..ToString Method
RecurrenceRange Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

RecurrenceRange Class


RecurrenceRange Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
RecurrenceRange Properties
RecurrenceRange Class See Also Send Feedback

The RecurrenceRange type exposes the following members.

Properties

 | Name | Description
Public property | EndDate | Gets or sets the end date.
Public property | NumberOfOccurences | Gets or sets a value indicating the number of occurences
Public property | StartDate | Gets or sets the start date.

See Also

RecurrenceRange Class


EndDate Property

[image]

VIBlend Controls for WinForms Help Documentation
RecurrenceRange..::..EndDate Property
RecurrenceRange Class See Also Send Feedback
Gets or sets the end date.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime EndDate { get; set; }
Visual Basic
Public Property EndDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime EndDate {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The end date.

See Also

RecurrenceRange Class


NumberOfOccurences Property

[image]

VIBlend Controls for WinForms Help Documentation
RecurrenceRange..::..NumberOfOccurences Property
RecurrenceRange Class See Also Send Feedback
Gets or sets a value indicating the number of occurences

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int NumberOfOccurences { get; set; }
Visual Basic
Public Property NumberOfOccurences As Integer
    Get
    Set
Visual C++
public:
property int NumberOfOccurences {
    int get ();
    void set (int value);
}

See Also

RecurrenceRange Class


StartDate Property

[image]

VIBlend Controls for WinForms Help Documentation
RecurrenceRange..::..StartDate Property
RecurrenceRange Class See Also Send Feedback
Gets or sets the start date.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime StartDate { get; set; }
Visual Basic
Public Property StartDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The start date.

See Also

RecurrenceRange Class


RecurrenceRule Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
RecurrenceRule Enumeration
See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum RecurrenceRule
Visual Basic
Public Enumeration RecurrenceRule
Visual C++
public enum class RecurrenceRule

Members

Member name | Description
Daily |
Weekly |
Monthly |
Yearly |
None |

See Also


RibbonBarGalleryGroup Class

[image]

VIBlend Controls for WinForms Help Documentation
RibbonBarGalleryGroup Class
Members See Also Send Feedback
Represents a RibbonBarGalleryGroup component

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class RibbonBarGalleryGroup : Component
Visual Basic
Public Class RibbonBarGalleryGroup _
    Inherits Component
Visual C++
public ref class RibbonBarGalleryGroup : public Component

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
VIBlend.WinForms.Controls..::..RibbonBarGalleryGroup

See Also

RibbonBarGalleryGroup Members


RibbonBarGalleryGroup Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonBarGalleryGroup Members
RibbonBarGalleryGroup Class Constructors Methods Properties Events See Also Send Feedback

The RibbonBarGalleryGroup type exposes the following members.

Constructors

 | Name | Description
Public method | RibbonBarGalleryGroup | Initializes a new instance of the RibbonBarGalleryGroup class.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | GroupHeight | Gets or sets the height of the group.
Public property | GroupName | Gets or sets the name of the group.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

RibbonBarGalleryGroup Class


RibbonBarGalleryGroup Constructor

[image]

VIBlend Controls for WinForms Help Documentation
RibbonBarGalleryGroup Constructor
RibbonBarGalleryGroup Class See Also Send Feedback
Initializes a new instance of the RibbonBarGalleryGroup class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RibbonBarGalleryGroup()
Visual Basic
Public Sub New
Visual C++
public:
RibbonBarGalleryGroup()

See Also

RibbonBarGalleryGroup Class


RibbonBarGalleryGroup Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonBarGalleryGroup Methods
RibbonBarGalleryGroup Class See Also Send Feedback

The RibbonBarGalleryGroup type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

RibbonBarGalleryGroup Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonBarGalleryGroup..::..Dispose Method
RibbonBarGalleryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

RibbonBarGalleryGroup Class
RibbonBarGalleryGroup Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonBarGalleryGroup..::..MemberwiseClone Method
RibbonBarGalleryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

RibbonBarGalleryGroup Class
RibbonBarGalleryGroup Members


RibbonBarGalleryGroup Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonBarGalleryGroup Properties
RibbonBarGalleryGroup Class See Also Send Feedback

The RibbonBarGalleryGroup type exposes the following members.

Properties

 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | GroupHeight | Gets or sets the height of the group.
Public property | GroupName | Gets or sets the name of the group.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

RibbonBarGalleryGroup Class


GroupHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
RibbonBarGalleryGroup..::..GroupHeight Property
RibbonBarGalleryGroup Class See Also Send Feedback
Gets or sets the height of the group.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int GroupHeight { get; set; }
Visual Basic
Public Property GroupHeight As Integer
    Get
    Set
Visual C++
public:
property int GroupHeight {
    int get ();
    void set (int value);
}

Field Value

The height of the group.

See Also

RibbonBarGalleryGroup Class


GroupName Property

[image]

VIBlend Controls for WinForms Help Documentation
RibbonBarGalleryGroup..::..GroupName Property
RibbonBarGalleryGroup Class See Also Send Feedback
Gets or sets the name of the group.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string GroupName { get; set; }
Visual Basic
Public Property GroupName As String
    Get
    Set
Visual C++
public:
property String^ GroupName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the group.

See Also

RibbonBarGalleryGroup Class


RibbonBarGalleryGroup Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonBarGalleryGroup Events
RibbonBarGalleryGroup Class See Also Send Feedback

The RibbonBarGalleryGroup type exposes the following members.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

RibbonBarGalleryGroup Class


RibbonForm Class

[image]

VIBlend Controls for WinForms Help Documentation
RibbonForm Class
Members See Also Send Feedback
Represents a Form that supports VIBlend Themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class RibbonForm : vForm
Visual Basic
Public Class RibbonForm _
    Inherits vForm
Visual C++
public ref class RibbonForm : public vForm

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
VIBlend.WinForms.Controls..::..vForm
VIBlend.WinForms.Controls..::..RibbonForm
VIBlend.WinForms.DataGridView..::..ColumnChooser

See Also

RibbonForm Members


RibbonForm Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm Members
RibbonForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The RibbonForm type exposes the following members.

Constructors

 | Name | Description
Public method | RibbonForm | Initializes a new instance of the RibbonForm class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vForm.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawText | (Inherited from vForm.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetFocusControl | (Inherited from vForm.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPointFromPtr | (Inherited from vForm.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleMaximize | Handles the maximize. (Inherited from vForm.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Protected method | InvalidateFrame | (Overrides vForm..::..InvalidateFrame()()()().)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NCHitTest | (Inherited from vForm.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from vForm.)
Protected method | OnActivating | (Inherited from vForm.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from vForm.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the [E:Layout] event. (Overrides vForm..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from vForm.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from vForm.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from vForm.)
Protected method | OnMouseEnter | (Inherited from vForm.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from vForm.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Overrides vForm..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | (Inherited from vForm.)
Protected method | OnResizeEnd | (Inherited from vForm.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from vForm.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetPadding | Sets the padding. (Inherited from vForm.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show()()()() | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Public method | WMNCHitTest | (Inherited from vForm.)
Protected method | WndProc | (Inherited from vForm.)

Fields

 | Name | Description
Protected field | boundsHelper | (Inherited from vForm.)
Protected field | closeButton | (Inherited from vForm.)
Protected field | helper | (Inherited from vForm.)
Protected field | maximizeButton | (Inherited from vForm.)
Protected field | minimizeButton | (Inherited from vForm.)
Protected field | titleFill | (Inherited from vForm.)

Properties

 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vForm.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowMaximize | Gets or sets a value indicating whether form is maximized on double click (Inherited from vForm.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderWidth | Gets or sets the width of the border. (Inherited from vForm.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsHelper | (Inherited from vForm.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CloseBox | Gets or sets a value indicating whether to show the close box. (Inherited from vForm.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from vForm.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | HasRibbon | Gets or sets a value indicating whether this instance has ribbon.
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsActiveWindow | Gets a value indicating whether this instance is active window. (Inherited from vForm.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from vForm.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from vForm.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | RoundRadius | Gets or sets the round radius. (Inherited from vForm.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ShadowColor | Gets or sets the color of the shadow. (Inherited from vForm.)
Public property | ShadowWidth | Gets or sets the width of the shadow. (Inherited from vForm.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | TextAlignment | Gets or sets the text alignment. (Inherited from vForm.)
Public property | Theme | Gets or sets the theme of the control. (Overrides vForm..::..Theme.)
Public property | TitleHeight | Gets or sets the height of the title. (Inherited from vForm.)
Public property | TitleOpacity | Gets or sets the title opacity. (Inherited from vForm.)
Public property | TitleRectangle | Gets the title rectangle. (Inherited from vForm.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vForm.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets the form's window state. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | Activating | Occurs when form is activating. (Inherited from vForm.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

RibbonForm Class


RibbonForm Constructor

[image]

VIBlend Controls for WinForms Help Documentation
RibbonForm Constructor
RibbonForm Class See Also Send Feedback
Initializes a new instance of the RibbonForm class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RibbonForm()
Visual Basic
Public Sub New
Visual C++
public:
RibbonForm()

See Also

RibbonForm Class


RibbonForm Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm Fields
RibbonForm Class See Also Send Feedback

The RibbonForm type exposes the following members.

Fields

 | Name | Description
Protected field | boundsHelper | (Inherited from vForm.)
Protected field | closeButton | (Inherited from vForm.)
Protected field | helper | (Inherited from vForm.)
Protected field | maximizeButton | (Inherited from vForm.)
Protected field | minimizeButton | (Inherited from vForm.)
Protected field | titleFill | (Inherited from vForm.)

See Also

RibbonForm Class


RibbonForm Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm Methods
RibbonForm Class See Also Send Feedback

The RibbonForm type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vForm.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawText | (Inherited from vForm.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetFocusControl | (Inherited from vForm.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPointFromPtr | (Inherited from vForm.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleMaximize | Handles the maximize. (Inherited from vForm.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Protected method | InvalidateFrame | (Overrides vForm..::..InvalidateFrame()()()().)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NCHitTest | (Inherited from vForm.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from vForm.)
Protected method | OnActivating | (Inherited from vForm.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from vForm.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the [E:Layout] event. (Overrides vForm..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from vForm.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from vForm.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from vForm.)
Protected method | OnMouseEnter | (Inherited from vForm.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from vForm.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Overrides vForm..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | (Inherited from vForm.)
Protected method | OnResizeEnd | (Inherited from vForm.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from vForm.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetPadding | Sets the padding. (Inherited from vForm.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show()()()() | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Public method | WMNCHitTest | (Inherited from vForm.)
Protected method | WndProc | (Inherited from vForm.)

See Also

RibbonForm Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..AccessibilityNotifyClients Method
RibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

RibbonForm Class
RibbonForm Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..BeginInvoke Method
RibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

RibbonForm Class
RibbonForm Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..Dispose Method
RibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vForm.)

See Also

RibbonForm Class
RibbonForm Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..GetChildAtPoint Method
RibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

RibbonForm Class
RibbonForm Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..Invalidate Method
RibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

RibbonForm Class
RibbonForm Members


InvalidateFrame Method

[image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..InvalidateFrame Method
RibbonForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void InvalidateFrame()
Visual Basic
Protected Overrides Sub InvalidateFrame
Visual C++
protected:
virtual void InvalidateFrame() override

See Also

RibbonForm Class


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..Invoke Method
RibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

RibbonForm Class
RibbonForm Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..MemberwiseClone Method
RibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

RibbonForm Class
RibbonForm Members


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..OnLayout Method
RibbonForm Class See Also Send Feedback
Raises the [E:Layout] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
The LayoutEventArgs instance containing the event data.

See Also

RibbonForm Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..OnPaint Method
RibbonForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

RibbonForm Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..PerformLayout Method
RibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

RibbonForm Class
RibbonForm Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..ResumeLayout Method
RibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

RibbonForm Class
RibbonForm Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..RtlTranslateAlignment Method
RibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

RibbonForm Class
RibbonForm Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..Scale Method
RibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

RibbonForm Class
RibbonForm Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..Select Method
RibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

RibbonForm Class
RibbonForm Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..SetBounds Method
RibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

RibbonForm Class
RibbonForm Members


Show Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..Show Method
RibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Show()()()() | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

RibbonForm Class
RibbonForm Members


ShowDialog Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..ShowDialog Method
RibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

RibbonForm Class
RibbonForm Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..UpdateBounds Method
RibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

RibbonForm Class
RibbonForm Members


Validate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..Validate Method
RibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

RibbonForm Class
RibbonForm Members


ValidateChildren Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..ValidateChildren Method
RibbonForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

RibbonForm Class
RibbonForm Members


RibbonForm Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm Properties
RibbonForm Class See Also Send Feedback

The RibbonForm type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vForm.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowMaximize | Gets or sets a value indicating whether form is maximized on double click (Inherited from vForm.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderWidth | Gets or sets the width of the border. (Inherited from vForm.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsHelper | (Inherited from vForm.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CloseBox | Gets or sets a value indicating whether to show the close box. (Inherited from vForm.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from vForm.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | HasRibbon | Gets or sets a value indicating whether this instance has ribbon.
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsActiveWindow | Gets a value indicating whether this instance is active window. (Inherited from vForm.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from vForm.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from vForm.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | RoundRadius | Gets or sets the round radius. (Inherited from vForm.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ShadowColor | Gets or sets the color of the shadow. (Inherited from vForm.)
Public property | ShadowWidth | Gets or sets the width of the shadow. (Inherited from vForm.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | TextAlignment | Gets or sets the text alignment. (Inherited from vForm.)
Public property | Theme | Gets or sets the theme of the control. (Overrides vForm..::..Theme.)
Public property | TitleHeight | Gets or sets the height of the title. (Inherited from vForm.)
Public property | TitleOpacity | Gets or sets the title opacity. (Inherited from vForm.)
Public property | TitleRectangle | Gets the title rectangle. (Inherited from vForm.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vForm.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets the form's window state. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

RibbonForm Class


HasRibbon Property

[image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..HasRibbon Property
RibbonForm Class See Also Send Feedback
Gets or sets a value indicating whether this instance has ribbon.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool HasRibbon { get; set; }
Visual Basic
Public Property HasRibbon As Boolean
    Get
    Set
Visual C++
public:
property bool HasRibbon {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance has ribbon; otherwise, false.

See Also

RibbonForm Class


StyleKey Property

[image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..StyleKey Property
RibbonForm Class See Also Send Feedback
Gets or sets the style key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual string StyleKey { get; set; }
Visual Basic
Protected Overridable Property StyleKey As String
    Get
    Set
Visual C++
protected:
virtual property String^ StyleKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The style key.

See Also

RibbonForm Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
RibbonForm..::..Theme Property
RibbonForm Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override ControlTheme Theme { get; set; }
Visual Basic
Public Overrides Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
virtual property ControlTheme^ Theme {
    ControlTheme^ get () override;
    void set (ControlTheme^ value) override;
}

Field Value

See Also

RibbonForm Class


RibbonForm Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonForm Events
RibbonForm Class See Also Send Feedback

The RibbonForm type exposes the following members.

Events

 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | Activating | Occurs when form is activating. (Inherited from vForm.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

RibbonForm Class


RibbonGroupPanel Class

[image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class RibbonGroupPanel : Panel
Visual Basic
Public Class RibbonGroupPanel _
    Inherits Panel
Visual C++
public ref class RibbonGroupPanel : public Panel

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..Panel
VIBlend.WinForms.Controls..::..RibbonGroupPanel

See Also

RibbonGroupPanel Members


RibbonGroupPanel Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel Members
RibbonGroupPanel Class Constructors Methods Properties Events See Also Send Feedback

The RibbonGroupPanel type exposes the following members.

Constructors

 | Name | Description
Public method | RibbonGroupPanel | Initializes a new instance of the RibbonGroupPanel class

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ScrollableControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

RibbonGroupPanel Class


RibbonGroupPanel Constructor

[image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel Constructor
RibbonGroupPanel Class See Also Send Feedback
Initializes a new instance of the RibbonGroupPanel class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RibbonGroupPanel()
Visual Basic
Public Sub New
Visual C++
public:
RibbonGroupPanel()

See Also

RibbonGroupPanel Class


RibbonGroupPanel Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel Methods
RibbonGroupPanel Class See Also Send Feedback

The RibbonGroupPanel type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ScrollableControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

See Also

RibbonGroupPanel Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel..::..AccessibilityNotifyClients Method
RibbonGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

RibbonGroupPanel Class
RibbonGroupPanel Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel..::..BeginInvoke Method
RibbonGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

RibbonGroupPanel Class
RibbonGroupPanel Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel..::..Dispose Method
RibbonGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

RibbonGroupPanel Class
RibbonGroupPanel Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel..::..GetChildAtPoint Method
RibbonGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

RibbonGroupPanel Class
RibbonGroupPanel Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel..::..Invalidate Method
RibbonGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

RibbonGroupPanel Class
RibbonGroupPanel Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel..::..Invoke Method
RibbonGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

RibbonGroupPanel Class
RibbonGroupPanel Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel..::..MemberwiseClone Method
RibbonGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

RibbonGroupPanel Class
RibbonGroupPanel Members


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel..::..PerformLayout Method
RibbonGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

RibbonGroupPanel Class
RibbonGroupPanel Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel..::..ResumeLayout Method
RibbonGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

RibbonGroupPanel Class
RibbonGroupPanel Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel..::..RtlTranslateAlignment Method
RibbonGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

RibbonGroupPanel Class
RibbonGroupPanel Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel..::..Scale Method
RibbonGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

RibbonGroupPanel Class
RibbonGroupPanel Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel..::..Select Method
RibbonGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

RibbonGroupPanel Class
RibbonGroupPanel Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel..::..SetBounds Method
RibbonGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

RibbonGroupPanel Class
RibbonGroupPanel Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel..::..UpdateBounds Method
RibbonGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

RibbonGroupPanel Class
RibbonGroupPanel Members


RibbonGroupPanel Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel Properties
RibbonGroupPanel Class See Also Send Feedback

The RibbonGroupPanel type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

RibbonGroupPanel Class


RibbonGroupPanel Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonGroupPanel Events
RibbonGroupPanel Class See Also Send Feedback

The RibbonGroupPanel type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

RibbonGroupPanel Class


RibbonPaintHelper Class

[image]

VIBlend Controls for WinForms Help Documentation
RibbonPaintHelper Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class RibbonPaintHelper
Visual Basic
Public Class RibbonPaintHelper
Visual C++
public ref class RibbonPaintHelper

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..RibbonPaintHelper

See Also

RibbonPaintHelper Members


RibbonPaintHelper Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonPaintHelper Members
RibbonPaintHelper Class Constructors Methods See Also Send Feedback

The RibbonPaintHelper type exposes the following members.

Constructors

 | Name | Description
Public method | RibbonPaintHelper | Initializes a new instance of the RibbonPaintHelper class

Methods

 | Name | Description
Public method | DrawArrowWithShadow | Draws the ribbon arrow shaded.
Public method | DrawFooterButton(Graphics, Color, Rectangle) | Draws the footer button.
Public method | DrawFooterButton(Graphics, Point, Color) | Draws the footer button.
Public method | DrawRibbonArrow | Draws an arrow on the specified bounds
Public method | DrawRibbonDropDownButtonArrow | Draws the ribbon drop down button arrow.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArrowSize | Gets the size of the arrow.
Public method | GetColorFromHexString | Gets the color from hex string.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMiddleCenterRectangle |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RibbonPaintHelper Class


RibbonPaintHelper Constructor

[image]

VIBlend Controls for WinForms Help Documentation
RibbonPaintHelper Constructor
RibbonPaintHelper Class See Also Send Feedback
Initializes a new instance of the RibbonPaintHelper class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RibbonPaintHelper()
Visual Basic
Public Sub New
Visual C++
public:
RibbonPaintHelper()

See Also

RibbonPaintHelper Class


RibbonPaintHelper Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonPaintHelper Methods
RibbonPaintHelper Class See Also Send Feedback

The RibbonPaintHelper type exposes the following members.

Methods

 | Name | Description
Public method | DrawArrowWithShadow | Draws the ribbon arrow shaded.
Public method | DrawFooterButton(Graphics, Color, Rectangle) | Draws the footer button.
Public method | DrawFooterButton(Graphics, Point, Color) | Draws the footer button.
Public method | DrawRibbonArrow | Draws an arrow on the specified bounds
Public method | DrawRibbonDropDownButtonArrow | Draws the ribbon drop down button arrow.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArrowSize | Gets the size of the arrow.
Public method | GetColorFromHexString | Gets the color from hex string.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMiddleCenterRectangle |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RibbonPaintHelper Class


DrawArrowWithShadow Method

[image]

VIBlend Controls for WinForms Help Documentation
RibbonPaintHelper..::..DrawArrowWithShadow Method
RibbonPaintHelper Class See Also Send Feedback
Draws the ribbon arrow shaded.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawArrowWithShadow(
    Graphics g,
    Rectangle b,
    Color arrowColor,
    ArrowDirection direction,
    bool enabled
)
Visual Basic
Public Sub DrawArrowWithShadow ( _
    g As Graphics, _
    b As Rectangle, _
    arrowColor As Color, _
    direction As ArrowDirection, _
    enabled As Boolean _
)
Visual C++
public:
void DrawArrowWithShadow(
    Graphics^ g,
    Rectangle b,
    Color arrowColor,
    ArrowDirection direction,
    bool enabled
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
b
Type: System.Drawing..::..Rectangle
The b.
arrowColor
Type: System.Drawing..::..Color
Color of the arrow.
direction
Type: System.Windows.Forms..::..ArrowDirection
The direction.
enabled
Type: System..::..Boolean
if set to true [enabled].

See Also

RibbonPaintHelper Class


DrawFooterButton Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RibbonPaintHelper..::..DrawFooterButton Method
RibbonPaintHelper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawFooterButton(Graphics, Color, Rectangle) | Draws the footer button.
Public method | DrawFooterButton(Graphics, Point, Color) | Draws the footer button.

See Also

RibbonPaintHelper Class
RibbonPaintHelper Members


DrawFooterButton Method (Graphics, Color, Rectangle)

[image]

VIBlend Controls for WinForms Help Documentation
RibbonPaintHelper..::..DrawFooterButton Method (Graphics, Color, Rectangle)
RibbonPaintHelper Class See Also Send Feedback
Draws the footer button.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawFooterButton(
    Graphics g,
    Color color,
    Rectangle b
)
Visual Basic
Public Sub DrawFooterButton ( _
    g As Graphics, _
    color As Color, _
    b As Rectangle _
)
Visual C++
public:
void DrawFooterButton(
    Graphics^ g,
    Color color,
    Rectangle b
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
color
Type: System.Drawing..::..Color
The color.
b
Type: System.Drawing..::..Rectangle
The b.

See Also

RibbonPaintHelper Class
DrawFooterButton Overload


DrawFooterButton Method (Graphics, Point, Color)

[image]

VIBlend Controls for WinForms Help Documentation
RibbonPaintHelper..::..DrawFooterButton Method (Graphics, Point, Color)
RibbonPaintHelper Class See Also Send Feedback
Draws the footer button.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawFooterButton(
    Graphics gr,
    Point p,
    Color color
)
Visual Basic
Public Sub DrawFooterButton ( _
    gr As Graphics, _
    p As Point, _
    color As Color _
)
Visual C++
public:
void DrawFooterButton(
    Graphics^ gr,
    Point p,
    Color color
)

Parameters

gr
Type: System.Drawing..::..Graphics
The gr.
p
Type: System.Drawing..::..Point
The p.
color
Type: System.Drawing..::..Color
The color.

See Also

RibbonPaintHelper Class
DrawFooterButton Overload


DrawRibbonArrow Method

[image]

VIBlend Controls for WinForms Help Documentation
RibbonPaintHelper..::..DrawRibbonArrow Method
RibbonPaintHelper Class See Also Send Feedback
Draws an arrow on the specified bounds

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawRibbonArrow(
    Graphics g,
    Rectangle b,
    Color c,
    ArrowDirection d
)
Visual Basic
Public Sub DrawRibbonArrow ( _
    g As Graphics, _
    b As Rectangle, _
    c As Color, _
    d As ArrowDirection _
)
Visual C++
public:
void DrawRibbonArrow(
    Graphics^ g,
    Rectangle b,
    Color c,
    ArrowDirection d
)

Parameters

g
Type: System.Drawing..::..Graphics
b
Type: System.Drawing..::..Rectangle
c
Type: System.Drawing..::..Color
d
Type: System.Windows.Forms..::..ArrowDirection

See Also

RibbonPaintHelper Class


DrawRibbonDropDownButtonArrow Method

[image]

VIBlend Controls for WinForms Help Documentation
RibbonPaintHelper..::..DrawRibbonDropDownButtonArrow Method
RibbonPaintHelper Class See Also Send Feedback
Draws the ribbon drop down button arrow.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawRibbonDropDownButtonArrow(
    Graphics g,
    Rectangle buttonBounds,
    Color arrowColor
)
Visual Basic
Public Sub DrawRibbonDropDownButtonArrow ( _
    g As Graphics, _
    buttonBounds As Rectangle, _
    arrowColor As Color _
)
Visual C++
public:
void DrawRibbonDropDownButtonArrow(
    Graphics^ g,
    Rectangle buttonBounds,
    Color arrowColor
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
buttonBounds
Type: System.Drawing..::..Rectangle
The button bounds.
arrowColor
Type: System.Drawing..::..Color
Color of the arrow.

See Also

RibbonPaintHelper Class


GetArrowSize Method

[image]

VIBlend Controls for WinForms Help Documentation
RibbonPaintHelper..::..GetArrowSize Method
RibbonPaintHelper Class See Also Send Feedback
Gets the size of the arrow.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Size GetArrowSize()
Visual Basic
Public Function GetArrowSize As Size
Visual C++
public:
Size GetArrowSize()

Return Value

See Also

RibbonPaintHelper Class


GetColorFromHexString Method

[image]

VIBlend Controls for WinForms Help Documentation
RibbonPaintHelper..::..GetColorFromHexString Method
RibbonPaintHelper Class See Also Send Feedback
Gets the color from hex string.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color GetColorFromHexString(
    string hex
)
Visual Basic
Public Function GetColorFromHexString ( _
    hex As String _
) As Color
Visual C++
public:
Color GetColorFromHexString(
    String^ hex
)

Parameters

hex
Type: System..::..String
The hex.

Return Value

See Also

RibbonPaintHelper Class


GetMiddleCenterRectangle Method

[image]

VIBlend Controls for WinForms Help Documentation
RibbonPaintHelper..::..GetMiddleCenterRectangle Method
RibbonPaintHelper Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle GetMiddleCenterRectangle(
    Rectangle parent,
    Rectangle child
)
Visual Basic
Public Function GetMiddleCenterRectangle ( _
    parent As Rectangle, _
    child As Rectangle _
) As Rectangle
Visual C++
public:
Rectangle GetMiddleCenterRectangle(
    Rectangle parent,
    Rectangle child
)

Parameters

parent
Type: System.Drawing..::..Rectangle
child
Type: System.Drawing..::..Rectangle

See Also

RibbonPaintHelper Class


RibbonStyle Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
RibbonStyle Enumeration
See Also Send Feedback
Enumeration of the vRubbonBar styles

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum RibbonStyle
Visual Basic
Public Enumeration RibbonStyle
Visual C++
public enum class RibbonStyle

Members

Member name | Description
Office2007 |
Office2010 |

See Also


SelectionCancelEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
SelectionCancelEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class SelectionCancelEventArgs : CancelEventArgs
Visual Basic
Public Class SelectionCancelEventArgs _
    Inherits CancelEventArgs
Visual C++
public ref class SelectionCancelEventArgs : public CancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
VIBlend.WinForms.Controls..::..SelectionCancelEventArgs

See Also

SelectionCancelEventArgs Members


SelectionCancelEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
SelectionCancelEventArgs Members
SelectionCancelEventArgs Class Constructors Methods Properties See Also Send Feedback

The SelectionCancelEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SelectionCancelEventArgs | Initializes a new instance of the SelectionCancelEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | NewDate | Gets the new selected date.
Public property | OldDate | Gets the old selected date.

See Also

SelectionCancelEventArgs Class


SelectionCancelEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
SelectionCancelEventArgs Constructor
SelectionCancelEventArgs Class See Also Send Feedback
Initializes a new instance of the SelectionCancelEventArgs class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public SelectionCancelEventArgs(
    DateTime oldDate,
    DateTime newDate
)
Visual Basic
Public Sub New ( _
    oldDate As DateTime, _
    newDate As DateTime _
)
Visual C++
public:
SelectionCancelEventArgs(
    DateTime oldDate,
    DateTime newDate
)

Parameters

oldDate
Type: System..::..DateTime
newDate
Type: System..::..DateTime

See Also

SelectionCancelEventArgs Class


SelectionCancelEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
SelectionCancelEventArgs Methods
SelectionCancelEventArgs Class See Also Send Feedback

The SelectionCancelEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectionCancelEventArgs Class


SelectionCancelEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
SelectionCancelEventArgs Properties
SelectionCancelEventArgs Class See Also Send Feedback

The SelectionCancelEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | NewDate | Gets the new selected date.
Public property | OldDate | Gets the old selected date.

See Also

SelectionCancelEventArgs Class


NewDate Property

[image]

VIBlend Controls for WinForms Help Documentation
SelectionCancelEventArgs..::..NewDate Property
SelectionCancelEventArgs Class See Also Send Feedback
Gets the new selected date.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime NewDate { get; }
Visual Basic
Public ReadOnly Property NewDate As DateTime
    Get
Visual C++
public:
property DateTime NewDate {
    DateTime get ();
}

See Also

SelectionCancelEventArgs Class


OldDate Property

[image]

VIBlend Controls for WinForms Help Documentation
SelectionCancelEventArgs..::..OldDate Property
SelectionCancelEventArgs Class See Also Send Feedback
Gets the old selected date.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime OldDate { get; }
Visual Basic
Public ReadOnly Property OldDate As DateTime
    Get
Visual C++
public:
property DateTime OldDate {
    DateTime get ();
}

See Also

SelectionCancelEventArgs Class


SelectionEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
SelectionEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class SelectionEventArgs : EventArgs
Visual Basic
Public Class SelectionEventArgs _
    Inherits EventArgs
Visual C++
public ref class SelectionEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..SelectionEventArgs

See Also

SelectionEventArgs Members


SelectionEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
SelectionEventArgs Members
SelectionEventArgs Class Constructors Methods Properties See Also Send Feedback

The SelectionEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SelectionEventArgs | Initializes a new instance of the SelectionEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NewDate | Gets the new selected date.
Public property | OldDate | Gets the old selected date.

See Also

SelectionEventArgs Class


SelectionEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
SelectionEventArgs Constructor
SelectionEventArgs Class See Also Send Feedback
Initializes a new instance of the SelectionEventArgs class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public SelectionEventArgs(
    DateTime oldDate,
    DateTime newDate
)
Visual Basic
Public Sub New ( _
    oldDate As DateTime, _
    newDate As DateTime _
)
Visual C++
public:
SelectionEventArgs(
    DateTime oldDate,
    DateTime newDate
)

Parameters

oldDate
Type: System..::..DateTime
newDate
Type: System..::..DateTime

See Also

SelectionEventArgs Class


SelectionEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
SelectionEventArgs Methods
SelectionEventArgs Class See Also Send Feedback

The SelectionEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectionEventArgs Class


SelectionEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
SelectionEventArgs Properties
SelectionEventArgs Class See Also Send Feedback

The SelectionEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | NewDate | Gets the new selected date.
Public property | OldDate | Gets the old selected date.

See Also

SelectionEventArgs Class


NewDate Property

[image]

VIBlend Controls for WinForms Help Documentation
SelectionEventArgs..::..NewDate Property
SelectionEventArgs Class See Also Send Feedback
Gets the new selected date.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime NewDate { get; }
Visual Basic
Public ReadOnly Property NewDate As DateTime
    Get
Visual C++
public:
property DateTime NewDate {
    DateTime get ();
}

See Also

SelectionEventArgs Class


OldDate Property

[image]

VIBlend Controls for WinForms Help Documentation
SelectionEventArgs..::..OldDate Property
SelectionEventArgs Class See Also Send Feedback
Gets the old selected date.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime OldDate { get; }
Visual Basic
Public ReadOnly Property OldDate As DateTime
    Get
Visual C++
public:
property DateTime OldDate {
    DateTime get ();
}

See Also

SelectionEventArgs Class


SizeUnitType Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
SizeUnitType Enumeration
See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum SizeUnitType
Visual Basic
Public Enumeration SizeUnitType
Visual C++
public enum class SizeUnitType

Members

Member name | Description
Pixel |
Star |

See Also


SizingDirection Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
SizingDirection Enumeration
See Also Send Feedback
Enumeration of the Drop-down controls resize flags

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum SizingDirection
Visual Basic
Public Enumeration SizingDirection
Visual C++
public enum class SizingDirection

Members

Member name | Description
Horizontal |
Vertical |
Both |
None |

See Also


SpinType Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
SpinType Enumeration
See Also Send Feedback
Represents spin type enumeration.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum SpinType
Visual Basic
Public Enumeration SpinType
Visual C++
public enum class SpinType

Members

Member name | Description
None |
SpinDigit |
SpinValueBeforeDigit |
SpinDigitWithWrap |

See Also


SplitContainerBase Class

[image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public abstract class SplitContainerBase : ContainerControl
Visual Basic
Public MustInherit Class SplitContainerBase _
    Inherits ContainerControl
Visual C++
public ref class SplitContainerBase abstract : public ContainerControl

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
VIBlend.WinForms.Controls..::..SplitContainerBase
VIBlend.WinForms.Controls..::..vSplitContainer

See Also

SplitContainerBase Members


SplitContainerBase Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase Members
SplitContainerBase Class Constructors Methods Fields Properties Events See Also Send Feedback

The SplitContainerBase type exposes the following members.

Constructors

 | Name | Description
Protected method | SplitContainerBase | Initializes a new instance of the SplitContainerBase class

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AddControl |
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | (Inherited from ContainerControl.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetControlSize |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Protected method | InsertControl |
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from ContainerControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RefreshSplitters |
Protected method | RemoveControl |
Protected method | RemoveControlAt |
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | ResumeSuspendedLayout | Resumes the suspended layout.
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Public method | SetControlSize |
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | SuspendLayout(Boolean) | Suspends the layout.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | Causes all of the child controls within a control that support validation to validate their data. (Inherited from ContainerControl.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from ContainerControl.)
Protected method | WndProc | (Inherited from ContainerControl.)

Fields

 | Name | Description
Protected field | controlSize |
Protected field | orientation |

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from ContainerControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from ContainerControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | Gets or sets the orientation.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowSplitters | Gets or sets a value indicating whether to show splitters.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SplitterSize | Gets or sets the size of the splitter.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from ContainerControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SplitContainerBase Class


SplitContainerBase Constructor

[image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase Constructor
SplitContainerBase Class See Also Send Feedback
Initializes a new instance of the SplitContainerBase class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected SplitContainerBase()
Visual Basic
Protected Sub New
Visual C++
protected:
SplitContainerBase()

See Also

SplitContainerBase Class


SplitContainerBase Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase Fields
SplitContainerBase Class See Also Send Feedback

The SplitContainerBase type exposes the following members.

Fields

 | Name | Description
Protected field | controlSize |
Protected field | orientation |

See Also

SplitContainerBase Class


controlSize Field

[image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..controlSize Field
SplitContainerBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected Dictionary<Control, vSizeType> controlSize
Visual Basic
Protected controlSize As Dictionary(Of Control, vSizeType)
Visual C++
protected:
Dictionary<Control^, vSizeType^>^ controlSize

See Also

SplitContainerBase Class


orientation Field

[image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..orientation Field
SplitContainerBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected Orientation orientation
Visual Basic
Protected orientation As Orientation
Visual C++
protected:
Orientation orientation

See Also

SplitContainerBase Class


SplitContainerBase Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase Methods
SplitContainerBase Class See Also Send Feedback

The SplitContainerBase type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AddControl |
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | (Inherited from ContainerControl.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetControlSize |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Protected method | InsertControl |
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from ContainerControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RefreshSplitters |
Protected method | RemoveControl |
Protected method | RemoveControlAt |
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | ResumeSuspendedLayout | Resumes the suspended layout.
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Public method | SetControlSize |
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | SuspendLayout(Boolean) | Suspends the layout.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | Causes all of the child controls within a control that support validation to validate their data. (Inherited from ContainerControl.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from ContainerControl.)
Protected method | WndProc | (Inherited from ContainerControl.)

See Also

SplitContainerBase Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..AccessibilityNotifyClients Method
SplitContainerBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

SplitContainerBase Class
SplitContainerBase Members


AddControl Method

[image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..AddControl Method
SplitContainerBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected abstract void AddControl(
    Control control,
    vSizeType sizeType
)
Visual Basic
Protected MustOverride Sub AddControl ( _
    control As Control, _
    sizeType As vSizeType _
)
Visual C++
protected:
virtual void AddControl(
    Control^ control,
    vSizeType^ sizeType
) abstract

Parameters

control
Type: System.Windows.Forms..::..Control
sizeType
Type: VIBlend.WinForms.Controls..::..vSizeType

See Also

SplitContainerBase Class


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..BeginInvoke Method
SplitContainerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

SplitContainerBase Class
SplitContainerBase Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..Dispose Method
SplitContainerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

SplitContainerBase Class
SplitContainerBase Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..GetChildAtPoint Method
SplitContainerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

SplitContainerBase Class
SplitContainerBase Members


GetControlSize Method

[image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..GetControlSize Method
SplitContainerBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public abstract vSizeType GetControlSize(
    Control control
)
Visual Basic
Public MustOverride Function GetControlSize ( _
    control As Control _
) As vSizeType
Visual C++
public:
virtual vSizeType^ GetControlSize(
    Control^ control
) abstract

Parameters

control
Type: System.Windows.Forms..::..Control

See Also

SplitContainerBase Class


InsertControl Method

[image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..InsertControl Method
SplitContainerBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected abstract void InsertControl(
    int index,
    Control control,
    vSizeType sizeType
)
Visual Basic
Protected MustOverride Sub InsertControl ( _
    index As Integer, _
    control As Control, _
    sizeType As vSizeType _
)
Visual C++
protected:
virtual void InsertControl(
    int index,
    Control^ control,
    vSizeType^ sizeType
) abstract

Parameters

index
Type: System..::..Int32
control
Type: System.Windows.Forms..::..Control
sizeType
Type: VIBlend.WinForms.Controls..::..vSizeType

See Also

SplitContainerBase Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..Invalidate Method
SplitContainerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

SplitContainerBase Class
SplitContainerBase Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..Invoke Method
SplitContainerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

SplitContainerBase Class
SplitContainerBase Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..MemberwiseClone Method
SplitContainerBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SplitContainerBase Class
SplitContainerBase Members


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..PerformLayout Method
SplitContainerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

SplitContainerBase Class
SplitContainerBase Members


RefreshSplitters Method

[image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..RefreshSplitters Method
SplitContainerBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected abstract void RefreshSplitters()
Visual Basic
Protected MustOverride Sub RefreshSplitters
Visual C++
protected:
virtual void RefreshSplitters() abstract

See Also

SplitContainerBase Class


RemoveControl Method

[image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..RemoveControl Method
SplitContainerBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected abstract void RemoveControl(
    Control control
)
Visual Basic
Protected MustOverride Sub RemoveControl ( _
    control As Control _
)
Visual C++
protected:
virtual void RemoveControl(
    Control^ control
) abstract

Parameters

control
Type: System.Windows.Forms..::..Control

See Also

SplitContainerBase Class


RemoveControlAt Method

[image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..RemoveControlAt Method
SplitContainerBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected abstract void RemoveControlAt(
    int index
)
Visual Basic
Protected MustOverride Sub RemoveControlAt ( _
    index As Integer _
)
Visual C++
protected:
virtual void RemoveControlAt(
    int index
) abstract

Parameters

index
Type: System..::..Int32

See Also

SplitContainerBase Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..ResumeLayout Method
SplitContainerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

SplitContainerBase Class
SplitContainerBase Members


ResumeSuspendedLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..ResumeSuspendedLayout Method
SplitContainerBase Class See Also Send Feedback
Resumes the suspended layout.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void ResumeSuspendedLayout(
    bool resumeChildren
)
Visual Basic
Public Overridable Sub ResumeSuspendedLayout ( _
    resumeChildren As Boolean _
)
Visual C++
public:
virtual void ResumeSuspendedLayout(
    bool resumeChildren
)

Parameters

resumeChildren
Type: System..::..Boolean
if set to true [resume children].

See Also

SplitContainerBase Class


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..RtlTranslateAlignment Method
SplitContainerBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

SplitContainerBase Class
SplitContainerBase Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..Scale Method
SplitContainerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

SplitContainerBase Class
SplitContainerBase Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..Select Method
SplitContainerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

SplitContainerBase Class
SplitContainerBase Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..SetBounds Method
SplitContainerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

SplitContainerBase Class
SplitContainerBase Members


SetControlSize Method

[image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..SetControlSize Method
SplitContainerBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public abstract void SetControlSize(
    Control control,
    vSizeType sizeType
)
Visual Basic
Public MustOverride Sub SetControlSize ( _
    control As Control, _
    sizeType As vSizeType _
)
Visual C++
public:
virtual void SetControlSize(
    Control^ control,
    vSizeType^ sizeType
) abstract

Parameters

control
Type: System.Windows.Forms..::..Control
sizeType
Type: VIBlend.WinForms.Controls..::..vSizeType

See Also

SplitContainerBase Class


SuspendLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..SuspendLayout Method
SplitContainerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | SuspendLayout(Boolean) | Suspends the layout.

See Also

SplitContainerBase Class
SplitContainerBase Members


SuspendLayout Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..SuspendLayout Method (Boolean)
SplitContainerBase Class See Also Send Feedback
Suspends the layout.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void SuspendLayout(
    bool suspendChildren
)
Visual Basic
Public Overridable Sub SuspendLayout ( _
    suspendChildren As Boolean _
)
Visual C++
public:
virtual void SuspendLayout(
    bool suspendChildren
)

Parameters

suspendChildren
Type: System..::..Boolean
if set to true [suspend children].

See Also

SplitContainerBase Class
SuspendLayout Overload


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..UpdateBounds Method
SplitContainerBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

SplitContainerBase Class
SplitContainerBase Members


Validate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..Validate Method
SplitContainerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

SplitContainerBase Class
SplitContainerBase Members


ValidateChildren Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..ValidateChildren Method
SplitContainerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateChildren()()()() | Causes all of the child controls within a control that support validation to validate their data. (Inherited from ContainerControl.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from ContainerControl.)

See Also

SplitContainerBase Class
SplitContainerBase Members


SplitContainerBase Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase Properties
SplitContainerBase Class See Also Send Feedback

The SplitContainerBase type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from ContainerControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from ContainerControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | Gets or sets the orientation.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowSplitters | Gets or sets a value indicating whether to show splitters.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SplitterSize | Gets or sets the size of the splitter.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

SplitContainerBase Class


Orientation Property

[image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..Orientation Property
SplitContainerBase Class See Also Send Feedback
Gets or sets the orientation.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic
Public Property Orientation As Orientation
    Get
    Set
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

Field Value

The orientation.

See Also

SplitContainerBase Class


ShowSplitters Property

[image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..ShowSplitters Property
SplitContainerBase Class See Also Send Feedback
Gets or sets a value indicating whether to show splitters.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowSplitters { get; set; }
Visual Basic
Public Property ShowSplitters As Boolean
    Get
    Set
Visual C++
public:
property bool ShowSplitters {
    bool get ();
    void set (bool value);
}

See Also

SplitContainerBase Class


SplitterSize Property

[image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase..::..SplitterSize Property
SplitContainerBase Class See Also Send Feedback
Gets or sets the size of the splitter.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int SplitterSize { get; set; }
Visual Basic
Public Property SplitterSize As Integer
    Get
    Set
Visual C++
public:
property int SplitterSize {
    int get ();
    void set (int value);
}

Field Value

The size of the splitter.

See Also

SplitContainerBase Class


SplitContainerBase Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitContainerBase Events
SplitContainerBase Class See Also Send Feedback

The SplitContainerBase type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from ContainerControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SplitContainerBase Class


SplitterControl Class

[image]

VIBlend Controls for WinForms Help Documentation
SplitterControl Class
Members See Also Send Feedback
Represents a splitter control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class SplitterControl : Control,
    IScrollableControlBase
Visual Basic
Public Class SplitterControl _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class SplitterControl : public Control,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..SplitterControl

See Also

SplitterControl Members


SplitterControl Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl Members
SplitterControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The SplitterControl type exposes the following members.

Constructors

 | Name | Description
Public method | SplitterControl | Initializes a new instance of the SplitterControl class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | theme |

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control1 | Gets or sets the control1.
Public property | Control2 | Gets or sets the control2.
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SplitContainerBase | Gets the workspace layout.
Public property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SplitterControl Class


SplitterControl Constructor

[image]

VIBlend Controls for WinForms Help Documentation
SplitterControl Constructor
SplitterControl Class See Also Send Feedback
Initializes a new instance of the SplitterControl class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public SplitterControl()
Visual Basic
Public Sub New
Visual C++
public:
SplitterControl()

See Also

SplitterControl Class


SplitterControl Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl Fields
SplitterControl Class See Also Send Feedback

The SplitterControl type exposes the following members.

Fields

 | Name | Description
Protected field | theme |

See Also

SplitterControl Class


theme Field

[image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..theme Field
SplitterControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected ControlTheme theme
Visual Basic
Protected theme As ControlTheme
Visual C++
protected:
ControlTheme^ theme

See Also

SplitterControl Class


SplitterControl Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl Methods
SplitterControl Class See Also Send Feedback

The SplitterControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

SplitterControl Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..AccessibilityNotifyClients Method
SplitterControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

SplitterControl Class
SplitterControl Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..BeginInvoke Method
SplitterControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

SplitterControl Class
SplitterControl Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..Dispose Method
SplitterControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

SplitterControl Class
SplitterControl Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..GetChildAtPoint Method
SplitterControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

SplitterControl Class
SplitterControl Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..Invalidate Method
SplitterControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

SplitterControl Class
SplitterControl Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..Invoke Method
SplitterControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

SplitterControl Class
SplitterControl Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..MemberwiseClone Method
SplitterControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SplitterControl Class
SplitterControl Members


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..OnMouseDown Method
SplitterControl Class See Also Send Feedback
Raises the MouseDown event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

SplitterControl Class


OnMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..OnMouseLeave Method
SplitterControl Class See Also Send Feedback
Raises the MouseLeave event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

SplitterControl Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..OnMouseMove Method
SplitterControl Class See Also Send Feedback
Raises the MouseMove event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

SplitterControl Class


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..OnMouseUp Method
SplitterControl Class See Also Send Feedback
Raises the MouseUp event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

SplitterControl Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..OnPaint Method
SplitterControl Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

SplitterControl Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..PerformLayout Method
SplitterControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

SplitterControl Class
SplitterControl Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..ResumeLayout Method
SplitterControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

SplitterControl Class
SplitterControl Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..RtlTranslateAlignment Method
SplitterControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

SplitterControl Class
SplitterControl Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..Scale Method
SplitterControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

SplitterControl Class
SplitterControl Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..Select Method
SplitterControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

SplitterControl Class
SplitterControl Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..SetBounds Method
SplitterControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

SplitterControl Class
SplitterControl Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..UpdateBounds Method
SplitterControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

SplitterControl Class
SplitterControl Members


SplitterControl Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl Properties
SplitterControl Class See Also Send Feedback

The SplitterControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control1 | Gets or sets the control1.
Public property | Control2 | Gets or sets the control2.
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SplitContainerBase | Gets the workspace layout.
Public property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

SplitterControl Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..AllowAnimations Property
SplitterControl Class See Also Send Feedback
Determines whether to use animations

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

SplitterControl Class


Control1 Property

[image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..Control1 Property
SplitterControl Class See Also Send Feedback
Gets or sets the control1.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control Control1 { get; set; }
Visual Basic
Public Property Control1 As Control
    Get
    Set
Visual C++
public:
property Control^ Control1 {
    Control^ get ();
    void set (Control^ value);
}

Field Value

The control1.

See Also

SplitterControl Class


Control2 Property

[image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..Control2 Property
SplitterControl Class See Also Send Feedback
Gets or sets the control2.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control Control2 { get; set; }
Visual Basic
Public Property Control2 As Control
    Get
    Set
Visual C++
public:
property Control^ Control2 {
    Control^ get ();
    void set (Control^ value);
}

Field Value

The control2.

See Also

SplitterControl Class


SplitContainerBase Property

[image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..SplitContainerBase Property
SplitterControl Class See Also Send Feedback
Gets the workspace layout.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public SplitContainerBase SplitContainerBase { get; internal set; }
Visual Basic
Public Property SplitContainerBase As SplitContainerBase
    Get
    Friend Set
Visual C++
public:
property SplitContainerBase^ SplitContainerBase {
    SplitContainerBase^ get ();
    internal: void set (SplitContainerBase^ value);
}

See Also

SplitterControl Class


StyleKey Property

[image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..StyleKey Property
SplitterControl Class See Also Send Feedback
Gets or sets the style key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual string StyleKey { get; set; }
Visual Basic
Public Overridable Property StyleKey As String
    Get
    Set
Visual C++
public:
virtual property String^ StyleKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The style key.

See Also

SplitterControl Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..Theme Property
SplitterControl Class See Also Send Feedback
Gets or sets the theme of the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ControlTheme Theme { get; set; }
Visual Basic
Public Overridable Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
virtual property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

SplitterControl Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
SplitterControl..::..VIBlendTheme Property
SplitterControl Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

SplitterControl Class


SplitterControl Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
SplitterControl Events
SplitterControl Class See Also Send Feedback

The SplitterControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SplitterControl Class


StartDayOfWeek Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
StartDayOfWeek Enumeration
See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum StartDayOfWeek
Visual Basic
Public Enumeration StartDayOfWeek
Visual C++
public enum class StartDayOfWeek

Members

Member name | Description
Sunday |
Monday |
Tuesday |
Wednesday |
Thursday |
Friday |
Saturday |
Default |

See Also


StringUtility Class

[image]

VIBlend Controls for WinForms Help Documentation
StringUtility Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class StringUtility
Visual Basic
Public Class StringUtility
Visual C++
public ref class StringUtility

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..StringUtility

See Also

StringUtility Members


StringUtility Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
StringUtility Members
StringUtility Class Constructors Methods See Also Send Feedback

The StringUtility type exposes the following members.

Constructors

 | Name | Description
Public method | StringUtility | Initializes a new instance of StringUtility

Methods

 | Name | Description
 | ContainsDigits |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCurrencySeparator | Gets a currency separator specific to a given culture.
 | GetDecimalSeparator | Gets a decimal separator specific to a given culture.
 | GetDigitsCountAfterSeparator | Gets the number of digits after the separator character.
 | GetDigitsToSeparator | Gets the digits count before the separator character.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInsertType | Gets the insert type.
 | GetInsertTypeByPositionInValue | Gets the insert type by position.
 | GetMaximumValueInDecimalPlaces | Gets the maximum value length.
 | GetPercentageSeparator | Gets a percentage separator specific to a given culture.
 | GetPercentageValueString | Gets the percentage value string in a text.
 | GetSelectionInValue | Gets the selection position in the value string.
 | GetSelectionLengthInValue | Gets the selection length in the value string.
 | GetSelectionPositionFromValuePosition | Gets selection position from the value string.
 | GetSeparatorPositionInText | Gets the position of the separator in a string.
 | GetStringToSeparator | Gets the substring before the separator character.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetValueString | Gets the value string in a text.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringUtility Class


StringUtility Constructor

[image]

VIBlend Controls for WinForms Help Documentation
StringUtility Constructor
StringUtility Class See Also Send Feedback
Initializes a new instance of StringUtility

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public StringUtility()
Visual Basic
Public Sub New
Visual C++
public:
StringUtility()

See Also

StringUtility Class


StringUtility Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
StringUtility Methods
StringUtility Class See Also Send Feedback

The StringUtility type exposes the following members.

Methods

 | Name | Description
 | ContainsDigits |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCurrencySeparator | Gets a currency separator specific to a given culture.
 | GetDecimalSeparator | Gets a decimal separator specific to a given culture.
 | GetDigitsCountAfterSeparator | Gets the number of digits after the separator character.
 | GetDigitsToSeparator | Gets the digits count before the separator character.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInsertType | Gets the insert type.
 | GetInsertTypeByPositionInValue | Gets the insert type by position.
 | GetMaximumValueInDecimalPlaces | Gets the maximum value length.
 | GetPercentageSeparator | Gets a percentage separator specific to a given culture.
 | GetPercentageValueString | Gets the percentage value string in a text.
 | GetSelectionInValue | Gets the selection position in the value string.
 | GetSelectionLengthInValue | Gets the selection length in the value string.
 | GetSelectionPositionFromValuePosition | Gets selection position from the value string.
 | GetSeparatorPositionInText | Gets the position of the separator in a string.
 | GetStringToSeparator | Gets the substring before the separator character.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetValueString | Gets the value string in a text.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringUtility Class


ContainsDigits Method

[image]

VIBlend Controls for WinForms Help Documentation
StringUtility..::..ContainsDigits Method
StringUtility Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static bool ContainsDigits(
    string text
)
Visual Basic
Public Shared Function ContainsDigits ( _
    text As String _
) As Boolean
Visual C++
public:
static bool ContainsDigits(
    String^ text
)

Parameters

text
Type: System..::..String

See Also

StringUtility Class


GetCurrencySeparator Method

[image]

VIBlend Controls for WinForms Help Documentation
StringUtility..::..GetCurrencySeparator Method
StringUtility Class See Also Send Feedback
Gets a currency separator specific to a given culture.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static string GetCurrencySeparator(
    CultureInfo info
)
Visual Basic
Public Shared Function GetCurrencySeparator ( _
    info As CultureInfo _
) As String
Visual C++
public:
static String^ GetCurrencySeparator(
    CultureInfo^ info
)

Parameters

info
Type: System.Globalization..::..CultureInfo

Return Value

See Also

StringUtility Class


GetDecimalSeparator Method

[image]

VIBlend Controls for WinForms Help Documentation
StringUtility..::..GetDecimalSeparator Method
StringUtility Class See Also Send Feedback
Gets a decimal separator specific to a given culture.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static string GetDecimalSeparator(
    CultureInfo info
)
Visual Basic
Public Shared Function GetDecimalSeparator ( _
    info As CultureInfo _
) As String
Visual C++
public:
static String^ GetDecimalSeparator(
    CultureInfo^ info
)

Parameters

info
Type: System.Globalization..::..CultureInfo

Return Value

See Also

StringUtility Class


GetDigitsCountAfterSeparator Method

[image]

VIBlend Controls for WinForms Help Documentation
StringUtility..::..GetDigitsCountAfterSeparator Method
StringUtility Class See Also Send Feedback
Gets the number of digits after the separator character.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int GetDigitsCountAfterSeparator(
    string separator,
    string text
)
Visual Basic
Public Shared Function GetDigitsCountAfterSeparator ( _
    separator As String, _
    text As String _
) As Integer
Visual C++
public:
static int GetDigitsCountAfterSeparator(
    String^ separator,
    String^ text
)

Parameters

separator
Type: System..::..String
text
Type: System..::..String

Return Value

See Also

StringUtility Class


GetDigitsToSeparator Method

[image]

VIBlend Controls for WinForms Help Documentation
StringUtility..::..GetDigitsToSeparator Method
StringUtility Class See Also Send Feedback
Gets the digits count before the separator character.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int GetDigitsToSeparator(
    int digitsToSeparator,
    string valueString
)
Visual Basic
Public Shared Function GetDigitsToSeparator ( _
    digitsToSeparator As Integer, _
    valueString As String _
) As Integer
Visual C++
public:
static int GetDigitsToSeparator(
    int digitsToSeparator,
    String^ valueString
)

Parameters

digitsToSeparator
Type: System..::..Int32
valueString
Type: System..::..String

Return Value

See Also

StringUtility Class


GetInsertType Method

[image]

VIBlend Controls for WinForms Help Documentation
StringUtility..::..GetInsertType Method
StringUtility Class See Also Send Feedback
Gets the insert type.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static InsertType GetInsertType(
    int positionInText,
    string separator,
    string text
)
Visual Basic
Public Shared Function GetInsertType ( _
    positionInText As Integer, _
    separator As String, _
    text As String _
) As InsertType
Visual C++
public:
static InsertType GetInsertType(
    int positionInText,
    String^ separator,
    String^ text
)

Parameters

positionInText
Type: System..::..Int32
separator
Type: System..::..String
text
Type: System..::..String

Return Value

See Also

StringUtility Class


GetInsertTypeByPositionInValue Method

[image]

VIBlend Controls for WinForms Help Documentation
StringUtility..::..GetInsertTypeByPositionInValue Method
StringUtility Class See Also Send Feedback
Gets the insert type by position.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static InsertType GetInsertTypeByPositionInValue(
    int positionInValue,
    string separator,
    string text,
    bool hasSeparator
)
Visual Basic
Public Shared Function GetInsertTypeByPositionInValue ( _
    positionInValue As Integer, _
    separator As String, _
    text As String, _
    hasSeparator As Boolean _
) As InsertType
Visual C++
public:
static InsertType GetInsertTypeByPositionInValue(
    int positionInValue,
    String^ separator,
    String^ text,
    bool hasSeparator
)

Parameters

positionInValue
Type: System..::..Int32
separator
Type: System..::..String
text
Type: System..::..String
hasSeparator
Type: System..::..Boolean

Return Value

See Also

StringUtility Class


GetMaximumValueInDecimalPlaces Method

[image]

VIBlend Controls for WinForms Help Documentation
StringUtility..::..GetMaximumValueInDecimalPlaces Method
StringUtility Class See Also Send Feedback
Gets the maximum value length.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static long GetMaximumValueInDecimalPlaces(
    int decimalPlaces
)
Visual Basic
Public Shared Function GetMaximumValueInDecimalPlaces ( _
    decimalPlaces As Integer _
) As Long
Visual C++
public:
static long long GetMaximumValueInDecimalPlaces(
    int decimalPlaces
)

Parameters

decimalPlaces
Type: System..::..Int32

Return Value

See Also

StringUtility Class


GetPercentageSeparator Method

[image]

VIBlend Controls for WinForms Help Documentation
StringUtility..::..GetPercentageSeparator Method
StringUtility Class See Also Send Feedback
Gets a percentage separator specific to a given culture.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static string GetPercentageSeparator(
    CultureInfo info
)
Visual Basic
Public Shared Function GetPercentageSeparator ( _
    info As CultureInfo _
) As String
Visual C++
public:
static String^ GetPercentageSeparator(
    CultureInfo^ info
)

Parameters

info
Type: System.Globalization..::..CultureInfo

Return Value

See Also

StringUtility Class


GetPercentageValueString Method

[image]

VIBlend Controls for WinForms Help Documentation
StringUtility..::..GetPercentageValueString Method
StringUtility Class See Also Send Feedback
Gets the percentage value string in a text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static string GetPercentageValueString(
    string text,
    string separator,
    bool hasSeparator
)
Visual Basic
Public Shared Function GetPercentageValueString ( _
    text As String, _
    separator As String, _
    hasSeparator As Boolean _
) As String
Visual C++
public:
static String^ GetPercentageValueString(
    String^ text,
    String^ separator,
    bool hasSeparator
)

Parameters

text
Type: System..::..String
separator
Type: System..::..String
hasSeparator
Type: System..::..Boolean

Return Value

See Also

StringUtility Class


GetSelectionInValue Method

[image]

VIBlend Controls for WinForms Help Documentation
StringUtility..::..GetSelectionInValue Method
StringUtility Class See Also Send Feedback
Gets the selection position in the value string.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int GetSelectionInValue(
    int selectionPosition,
    string text,
    string separator,
    bool hasSeparator
)
Visual Basic
Public Shared Function GetSelectionInValue ( _
    selectionPosition As Integer, _
    text As String, _
    separator As String, _
    hasSeparator As Boolean _
) As Integer
Visual C++
public:
static int GetSelectionInValue(
    int selectionPosition,
    String^ text,
    String^ separator,
    bool hasSeparator
)

Parameters

selectionPosition
Type: System..::..Int32
text
Type: System..::..String
separator
Type: System..::..String
hasSeparator
Type: System..::..Boolean

Return Value

See Also

StringUtility Class


GetSelectionLengthInValue Method

[image]

VIBlend Controls for WinForms Help Documentation
StringUtility..::..GetSelectionLengthInValue Method
StringUtility Class See Also Send Feedback
Gets the selection length in the value string.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int GetSelectionLengthInValue(
    int selectionPosition,
    int selectionLength,
    string text,
    string separator
)
Visual Basic
Public Shared Function GetSelectionLengthInValue ( _
    selectionPosition As Integer, _
    selectionLength As Integer, _
    text As String, _
    separator As String _
) As Integer
Visual C++
public:
static int GetSelectionLengthInValue(
    int selectionPosition,
    int selectionLength,
    String^ text,
    String^ separator
)

Parameters

selectionPosition
Type: System..::..Int32
selectionLength
Type: System..::..Int32
text
Type: System..::..String
separator
Type: System..::..String

Return Value

See Also

StringUtility Class


GetSelectionPositionFromValuePosition Method

[image]

VIBlend Controls for WinForms Help Documentation
StringUtility..::..GetSelectionPositionFromValuePosition Method
StringUtility Class See Also Send Feedback
Gets selection position from the value string.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int GetSelectionPositionFromValuePosition(
    int valuePosition,
    string text,
    string separator,
    bool hasSeparator
)
Visual Basic
Public Shared Function GetSelectionPositionFromValuePosition ( _
    valuePosition As Integer, _
    text As String, _
    separator As String, _
    hasSeparator As Boolean _
) As Integer
Visual C++
public:
static int GetSelectionPositionFromValuePosition(
    int valuePosition,
    String^ text,
    String^ separator,
    bool hasSeparator
)

Parameters

valuePosition
Type: System..::..Int32
text
Type: System..::..String
separator
Type: System..::..String
hasSeparator
Type: System..::..Boolean

Return Value

See Also

StringUtility Class


GetSeparatorPositionInText Method

[image]

VIBlend Controls for WinForms Help Documentation
StringUtility..::..GetSeparatorPositionInText Method
StringUtility Class See Also Send Feedback
Gets the position of the separator in a string.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int GetSeparatorPositionInText(
    string separator,
    string text
)
Visual Basic
Public Shared Function GetSeparatorPositionInText ( _
    separator As String, _
    text As String _
) As Integer
Visual C++
public:
static int GetSeparatorPositionInText(
    String^ separator,
    String^ text
)

Parameters

separator
Type: System..::..String
text
Type: System..::..String

Return Value

See Also

StringUtility Class


GetStringToSeparator Method

[image]

VIBlend Controls for WinForms Help Documentation
StringUtility..::..GetStringToSeparator Method
StringUtility Class See Also Send Feedback
Gets the substring before the separator character.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static string GetStringToSeparator(
    string text,
    string separator,
    bool hasSeparator
)
Visual Basic
Public Shared Function GetStringToSeparator ( _
    text As String, _
    separator As String, _
    hasSeparator As Boolean _
) As String
Visual C++
public:
static String^ GetStringToSeparator(
    String^ text,
    String^ separator,
    bool hasSeparator
)

Parameters

text
Type: System..::..String
separator
Type: System..::..String
hasSeparator
Type: System..::..Boolean

Return Value

See Also

StringUtility Class


GetValueString Method

[image]

VIBlend Controls for WinForms Help Documentation
StringUtility..::..GetValueString Method
StringUtility Class See Also Send Feedback
Gets the value string in a text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static string GetValueString(
    string text,
    string separator,
    bool hasSeparator
)
Visual Basic
Public Shared Function GetValueString ( _
    text As String, _
    separator As String, _
    hasSeparator As Boolean _
) As String
Visual C++
public:
static String^ GetValueString(
    String^ text,
    String^ separator,
    bool hasSeparator
)

Parameters

text
Type: System..::..String
separator
Type: System..::..String
hasSeparator
Type: System..::..Boolean

Return Value

See Also

StringUtility Class


TabContext Class

[image]

VIBlend Controls for WinForms Help Documentation
TabContext Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class TabContext : Component, INotifyPropertyChanged
Visual Basic
Public Class TabContext _
    Inherits Component _
    Implements INotifyPropertyChanged
Visual C++
public ref class TabContext : public Component,
    INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
VIBlend.WinForms.Controls..::..TabContext

See Also

TabContext Members


TabContext Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
TabContext Members
TabContext Class Constructors Methods Properties Events See Also Send Feedback

The TabContext type exposes the following members.

Constructors

 | Name | Description
Public method | TabContext()()()() | Initializes a new instance of the TabContext class.
Public method | TabContext(Color, String, Boolean) |

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnPropertyChanged |
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ForeColor | Gets or sets the foreColor of the tab.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | TabColor | Gets or sets the color of the tab.
Public property | Text | Gets or sets the name.
Public property | Visible | Gets or sets a value indicating whether this TabContext is visible.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | PropertyChanged |

See Also

TabContext Class


TabContext Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
TabContext Constructor
TabContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TabContext()()()() | Initializes a new instance of the TabContext class.
Public method | TabContext(Color, String, Boolean) | Initializes a new instance of the TabContext class

See Also

TabContext Class
TabContext Members


TabContext Constructor

[image]

VIBlend Controls for WinForms Help Documentation
TabContext Constructor
TabContext Class See Also Send Feedback
Initializes a new instance of the TabContext class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public TabContext()
Visual Basic
Public Sub New
Visual C++
public:
TabContext()

See Also

TabContext Class
TabContext Overload


TabContext Constructor (Color, String, Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
TabContext Constructor (Color, String, Boolean)
TabContext Class See Also Send Feedback
Initializes a new instance of the TabContext class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public TabContext(
    Color color,
    string name,
    bool visible
)
Visual Basic
Public Sub New ( _
    color As Color, _
    name As String, _
    visible As Boolean _
)
Visual C++
public:
TabContext(
    Color color,
    String^ name,
    bool visible
)

Parameters

color
Type: System.Drawing..::..Color
name
Type: System..::..String
visible
Type: System..::..Boolean

See Also

TabContext Class
TabContext Overload


TabContext Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
TabContext Methods
TabContext Class See Also Send Feedback

The TabContext type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnPropertyChanged |
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

TabContext Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
TabContext..::..Dispose Method
TabContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

TabContext Class
TabContext Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
TabContext..::..MemberwiseClone Method
TabContext Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TabContext Class
TabContext Members


OnPropertyChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
TabContext..::..OnPropertyChanged Method
TabContext Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String

See Also

TabContext Class


TabContext Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
TabContext Properties
TabContext Class See Also Send Feedback

The TabContext type exposes the following members.

Properties

 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ForeColor | Gets or sets the foreColor of the tab.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | TabColor | Gets or sets the color of the tab.
Public property | Text | Gets or sets the name.
Public property | Visible | Gets or sets a value indicating whether this TabContext is visible.

See Also

TabContext Class


ForeColor Property

[image]

VIBlend Controls for WinForms Help Documentation
TabContext..::..ForeColor Property
TabContext Class See Also Send Feedback
Gets or sets the foreColor of the tab.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color ForeColor { get; set; }
Visual Basic
Public Property ForeColor As Color
    Get
    Set
Visual C++
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}

Field Value

The foreColor of the tab.

See Also

TabContext Class


TabColor Property

[image]

VIBlend Controls for WinForms Help Documentation
TabContext..::..TabColor Property
TabContext Class See Also Send Feedback
Gets or sets the color of the tab.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color TabColor { get; set; }
Visual Basic
Public Property TabColor As Color
    Get
    Set
Visual C++
public:
property Color TabColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the tab.

See Also

TabContext Class


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
TabContext..::..Text Property
TabContext Class See Also Send Feedback
Gets or sets the name.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

TabContext Class


Visible Property

[image]

VIBlend Controls for WinForms Help Documentation
TabContext..::..Visible Property
TabContext Class See Also Send Feedback
Gets or sets a value indicating whether this TabContext is visible.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Visible { get; set; }
Visual Basic
Public Property Visible As Boolean
    Get
    Set
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Field Value

true if visible; otherwise, false.

See Also

TabContext Class


TabContext Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
TabContext Events
TabContext Class See Also Send Feedback

The TabContext type exposes the following members.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | PropertyChanged |

See Also

TabContext Class


PropertyChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
TabContext..::..PropertyChanged Event
TabContext Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

TabContext Class


TabsShape Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
TabsShape Enumeration
See Also Send Feedback
Enumeration of the tab shapes

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum TabsShape
Visual Basic
Public Enumeration TabsShape
Visual C++
public enum class TabsShape

Members

Member name | Description
RoundedCorners |
Office2007 |
OneNote |
VisualStudio |
Chrome |

See Also


UndoRedoManager Class

[image]

VIBlend Controls for WinForms Help Documentation
UndoRedoManager Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class UndoRedoManager
Visual Basic
Public Class UndoRedoManager
Visual C++
public ref class UndoRedoManager

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..UndoRedoManager

See Also

UndoRedoManager Members


UndoRedoManager Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
UndoRedoManager Members
UndoRedoManager Class Constructors Methods See Also Send Feedback

The UndoRedoManager type exposes the following members.

Constructors

 | Name | Description
Public method | UndoRedoManager | Initializes a new instance of the UndoRedoManager class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetState | Gets the current state.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Redo | Redo current state.
Public method | SaveChanges | Saves the current state and adds it to the states collection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Undo | Undo current state.

See Also

UndoRedoManager Class


UndoRedoManager Constructor

[image]

VIBlend Controls for WinForms Help Documentation
UndoRedoManager Constructor
UndoRedoManager Class See Also Send Feedback
Initializes a new instance of the UndoRedoManager class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public UndoRedoManager()
Visual Basic
Public Sub New
Visual C++
public:
UndoRedoManager()

See Also

UndoRedoManager Class


UndoRedoManager Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
UndoRedoManager Methods
UndoRedoManager Class See Also Send Feedback

The UndoRedoManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetState | Gets the current state.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Redo | Redo current state.
Public method | SaveChanges | Saves the current state and adds it to the states collection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Undo | Undo current state.

See Also

UndoRedoManager Class


GetState Method

[image]

VIBlend Controls for WinForms Help Documentation
UndoRedoManager..::..GetState Method
UndoRedoManager Class See Also Send Feedback
Gets the current state.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorState GetState()
Visual Basic
Public Function GetState As EditorState
Visual C++
public:
EditorState^ GetState()

Return Value

See Also

UndoRedoManager Class


Redo Method

[image]

VIBlend Controls for WinForms Help Documentation
UndoRedoManager..::..Redo Method
UndoRedoManager Class See Also Send Feedback
Redo current state.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorState Redo()
Visual Basic
Public Function Redo As EditorState
Visual C++
public:
EditorState^ Redo()

Return Value

See Also

UndoRedoManager Class


SaveChanges Method

[image]

VIBlend Controls for WinForms Help Documentation
UndoRedoManager..::..SaveChanges Method
UndoRedoManager Class See Also Send Feedback
Saves the current state and adds it to the states collection.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SaveChanges(
    EditorState state
)
Visual Basic
Public Sub SaveChanges ( _
    state As EditorState _
)
Visual C++
public:
void SaveChanges(
    EditorState^ state
)

Parameters

state
Type: VIBlend.WinForms.Controls..::..EditorState

See Also

UndoRedoManager Class


Undo Method

[image]

VIBlend Controls for WinForms Help Documentation
UndoRedoManager..::..Undo Method
UndoRedoManager Class See Also Send Feedback
Undo current state.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorState Undo()
Visual Basic
Public Function Undo As EditorState
Visual C++
public:
EditorState^ Undo()

Return Value

See Also

UndoRedoManager Class


ValueChangedEditorEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
ValueChangedEditorEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class ValueChangedEditorEventArgs : EventArgs
Visual Basic
Public Class ValueChangedEditorEventArgs _
    Inherits EventArgs
Visual C++
public ref class ValueChangedEditorEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..ValueChangedEditorEventArgs

See Also

ValueChangedEditorEventArgs Members


ValueChangedEditorEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
ValueChangedEditorEventArgs Members
ValueChangedEditorEventArgs Class Constructors Methods Properties See Also Send Feedback

The ValueChangedEditorEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ValueChangedEditorEventArgs | Initializes a new instance of the ValueChangedEditorEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Value | Gets the decimal value.

See Also

ValueChangedEditorEventArgs Class


ValueChangedEditorEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
ValueChangedEditorEventArgs Constructor
ValueChangedEditorEventArgs Class See Also Send Feedback
Initializes a new instance of the ValueChangedEditorEventArgs class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ValueChangedEditorEventArgs(
    decimal value
)
Visual Basic
Public Sub New ( _
    value As Decimal _
)
Visual C++
public:
ValueChangedEditorEventArgs(
    Decimal value
)

Parameters

value
Type: System..::..Decimal

See Also

ValueChangedEditorEventArgs Class


ValueChangedEditorEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
ValueChangedEditorEventArgs Methods
ValueChangedEditorEventArgs Class See Also Send Feedback

The ValueChangedEditorEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValueChangedEditorEventArgs Class


ValueChangedEditorEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
ValueChangedEditorEventArgs Properties
ValueChangedEditorEventArgs Class See Also Send Feedback

The ValueChangedEditorEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Value | Gets the decimal value.

See Also

ValueChangedEditorEventArgs Class


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
ValueChangedEditorEventArgs..::..Value Property
ValueChangedEditorEventArgs Class See Also Send Feedback
Gets the decimal value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public decimal Value { get; }
Visual Basic
Public ReadOnly Property Value As Decimal
    Get
Visual C++
public:
property Decimal Value {
    Decimal get ();
}

See Also

ValueChangedEditorEventArgs Class


ValueChangedEditorEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
ValueChangedEditorEventHandler Delegate
See Also Send Feedback
Represents a ValueChangedEditor delegate.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void ValueChangedEditorEventHandler(
    Object sender,
    ValueChangedEditorEventArgs args
)
Visual Basic
Public Delegate Sub ValueChangedEditorEventHandler ( _
    sender As Object, _
    args As ValueChangedEditorEventArgs _
)
Visual C++
public delegate void ValueChangedEditorEventHandler(
    Object^ sender,
    ValueChangedEditorEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.Controls..::..ValueChangedEditorEventArgs

See Also


ValueChangingEditorEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
ValueChangingEditorEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class ValueChangingEditorEventArgs : CancelEventArgs
Visual Basic
Public Class ValueChangingEditorEventArgs _
    Inherits CancelEventArgs
Visual C++
public ref class ValueChangingEditorEventArgs : public CancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
VIBlend.WinForms.Controls..::..ValueChangingEditorEventArgs

See Also

ValueChangingEditorEventArgs Members


ValueChangingEditorEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
ValueChangingEditorEventArgs Members
ValueChangingEditorEventArgs Class Constructors Methods Properties See Also Send Feedback

The ValueChangingEditorEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ValueChangingEditorEventArgs | Initializes a new instance of the ValueChangingEditorEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Value | Gets the decimal value.

See Also

ValueChangingEditorEventArgs Class


ValueChangingEditorEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
ValueChangingEditorEventArgs Constructor
ValueChangingEditorEventArgs Class See Also Send Feedback
Initializes a new instance of the ValueChangingEditorEventArgs class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ValueChangingEditorEventArgs(
    decimal value
)
Visual Basic
Public Sub New ( _
    value As Decimal _
)
Visual C++
public:
ValueChangingEditorEventArgs(
    Decimal value
)

Parameters

value
Type: System..::..Decimal

See Also

ValueChangingEditorEventArgs Class


ValueChangingEditorEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
ValueChangingEditorEventArgs Methods
ValueChangingEditorEventArgs Class See Also Send Feedback

The ValueChangingEditorEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValueChangingEditorEventArgs Class


ValueChangingEditorEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
ValueChangingEditorEventArgs Properties
ValueChangingEditorEventArgs Class See Also Send Feedback

The ValueChangingEditorEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Value | Gets the decimal value.

See Also

ValueChangingEditorEventArgs Class


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
ValueChangingEditorEventArgs..::..Value Property
ValueChangingEditorEventArgs Class See Also Send Feedback
Gets the decimal value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public decimal Value { get; }
Visual Basic
Public ReadOnly Property Value As Decimal
    Get
Visual C++
public:
property Decimal Value {
    Decimal get ();
}

See Also

ValueChangingEditorEventArgs Class


ValueChangingEditorEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
ValueChangingEditorEventHandler Delegate
See Also Send Feedback
Represents a ValueChangingEditor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void ValueChangingEditorEventHandler(
    Object sender,
    ValueChangingEditorEventArgs args
)
Visual Basic
Public Delegate Sub ValueChangingEditorEventHandler ( _
    sender As Object, _
    args As ValueChangingEditorEventArgs _
)
Visual C++
public delegate void ValueChangingEditorEventHandler(
    Object^ sender,
    ValueChangingEditorEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.Controls..::..ValueChangingEditorEventArgs

See Also


vApplicationMenuItem Class

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem Class
Members See Also Send Feedback
Represents a vApplicationMenuItem control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vApplicationMenuItem : ScrollableControlMiniBase
Visual Basic
Public Class vApplicationMenuItem _
    Inherits ScrollableControlMiniBase
Visual C++
public ref class vApplicationMenuItem : public ScrollableControlMiniBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
ScrollableControlMiniBase
VIBlend.WinForms.Controls..::..vApplicationMenuItem

See Also

vApplicationMenuItem Members


vApplicationMenuItem Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem Members
vApplicationMenuItem Class Constructors Methods Properties Events See Also Send Feedback

The vApplicationMenuItem type exposes the following members.

Constructors

 | Name | Description
Public method | vApplicationMenuItem | Initializes a new instance of the vApplicationMenuItem class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | AnyOpenedChildMenu |
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnArrowButtonClicked |
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContentButtonClicked |
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | (Overrides Control..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | (Overrides Control..::..OnMouseHover(EventArgs).)
Protected method | OnMouseLeave | (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectionChanged |
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown | Shows the drop down.
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | ArrowAreaWidth | Gets or sets the width of the arrow area.
Public property | AutoOpen | Gets or sets a value indicating whether the dropdown is opened automatically
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckBoxSize | Gets or sets the size of the check box.
Public property | CheckBoxTickColor | Gets or sets the color of the check box tick.
Public property | Checked | Gets or sets a value indicating whether this vApplicationMenuItem is checked.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentBackColor | Gets or sets the color of the content back.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Overrides Control..::..DefaultSize.)
Public property | DescriptionText | Gets or sets the description text.
Public property | DescriptionTextAlignment | Gets or sets the description text alignment.
Public property | DescriptionTextColor | Gets or sets the color of the description text.
Public property | DescriptionTextFont | Gets or sets the description text font.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets the drop down.
Public property | DropDownHeight | Gets or sets the height of the drop down.
Public property | DropDownPosition | Gets or sets the width of the drop down.
Public property | DropDownWidth | Gets or sets the width of the drop down.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightArrow | Gets or sets a value indicating whether to highlight the arrow
Public property | Image | Gets or sets the image.
Public property | ImageAlignment | Gets or sets the image alignment.
Public property | ImageAreaWidth | Gets or sets the width of the image area.
Public property | ImageIndex | Gets or sets the index of the image.
Public property | ImageList | Gets or sets the image list.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsDropDownOpened | Gets a value indicating whether drop down is opened.
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets the items.
Public property | ItemType | Gets or sets the type of the item.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint item's border
Public property | PaintFill | Gets or sets a value indicating whether to paint item's background
Public property | PaintImageAreaBorder | Gets or sets a value indicating whether to paint image's area border
Public property | PaintImageAreaFill | Gets or sets a value indicating whether to paint image's area background
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentMenuItem | Gets the parent menu item.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Radius | Gets or sets the radius.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RootMenuItem | Gets the root menu item.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedChildMenuItem | Gets or sets the selected menu item.
Public property | ShowArrow | Gets or sets a value indicating whether to show an arrow
Public property | ShowCheckBox | Gets or sets a value indicating whether to show a checkbox.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment.
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the text color coming from the theme
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | ArrowButtonClicked | Occurs when arrow button is clicked.
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContentButtonClicked | Occurs when content button is clicked.
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectionChanged | Occurs when a selection has been changed
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vApplicationMenuItem Class


vApplicationMenuItem Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem Constructor
vApplicationMenuItem Class See Also Send Feedback
Initializes a new instance of the vApplicationMenuItem class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vApplicationMenuItem()
Visual Basic
Public Sub New
Visual C++
public:
vApplicationMenuItem()

See Also

vApplicationMenuItem Class


vApplicationMenuItem Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem Methods
vApplicationMenuItem Class See Also Send Feedback

The vApplicationMenuItem type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | AnyOpenedChildMenu |
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnArrowButtonClicked |
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContentButtonClicked |
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | (Overrides Control..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | (Overrides Control..::..OnMouseHover(EventArgs).)
Protected method | OnMouseLeave | (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectionChanged |
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown | Shows the drop down.
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vApplicationMenuItem Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..AccessibilityNotifyClients Method
vApplicationMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vApplicationMenuItem Class
vApplicationMenuItem Members


AnyOpenedChildMenu Method

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..AnyOpenedChildMenu Method
vApplicationMenuItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AnyOpenedChildMenu(
    vApplicationMenuItemCollection items
)
Visual Basic
Public Function AnyOpenedChildMenu ( _
    items As vApplicationMenuItemCollection _
) As Boolean
Visual C++
public:
bool AnyOpenedChildMenu(
    vApplicationMenuItemCollection^ items
)

Parameters

items
Type: VIBlend.WinForms.Controls..::..vApplicationMenuItemCollection

See Also

vApplicationMenuItem Class


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..BeginInvoke Method
vApplicationMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vApplicationMenuItem Class
vApplicationMenuItem Members


CloseDropDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..CloseDropDown Method
vApplicationMenuItem Class See Also Send Feedback
Closes the drop down.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void CloseDropDown()
Visual Basic
Public Sub CloseDropDown
Visual C++
public:
void CloseDropDown()

See Also

vApplicationMenuItem Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..Dispose Method
vApplicationMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)

See Also

vApplicationMenuItem Class
vApplicationMenuItem Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..Dispose Method (Boolean)
vApplicationMenuItem Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vApplicationMenuItem Class
Dispose Overload


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..GetChildAtPoint Method
vApplicationMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vApplicationMenuItem Class
vApplicationMenuItem Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..Invalidate Method
vApplicationMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vApplicationMenuItem Class
vApplicationMenuItem Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..Invoke Method
vApplicationMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vApplicationMenuItem Class
vApplicationMenuItem Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..MemberwiseClone Method
vApplicationMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vApplicationMenuItem Class
vApplicationMenuItem Members


OnArrowButtonClicked Method

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..OnArrowButtonClicked Method
vApplicationMenuItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnArrowButtonClicked()
Visual Basic
Protected Overridable Sub OnArrowButtonClicked
Visual C++
protected:
virtual void OnArrowButtonClicked()

See Also

vApplicationMenuItem Class


OnContentButtonClicked Method

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..OnContentButtonClicked Method
vApplicationMenuItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnContentButtonClicked()
Visual Basic
Protected Overridable Sub OnContentButtonClicked
Visual C++
protected:
virtual void OnContentButtonClicked()

See Also

vApplicationMenuItem Class


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..OnMouseDown Method
vApplicationMenuItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vApplicationMenuItem Class


OnMouseEnter Method

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..OnMouseEnter Method
vApplicationMenuItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseEnter(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseEnter ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseEnter(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vApplicationMenuItem Class


OnMouseHover Method

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..OnMouseHover Method
vApplicationMenuItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseHover(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseHover ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseHover(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vApplicationMenuItem Class


OnMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..OnMouseLeave Method
vApplicationMenuItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vApplicationMenuItem Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..OnMouseMove Method
vApplicationMenuItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vApplicationMenuItem Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..OnPaint Method
vApplicationMenuItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vApplicationMenuItem Class


OnSelectionChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..OnSelectionChanged Method
vApplicationMenuItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnSelectionChanged()
Visual Basic
Protected Overridable Sub OnSelectionChanged
Visual C++
protected:
virtual void OnSelectionChanged()

See Also

vApplicationMenuItem Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..PerformLayout Method
vApplicationMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vApplicationMenuItem Class
vApplicationMenuItem Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..ResumeLayout Method
vApplicationMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vApplicationMenuItem Class
vApplicationMenuItem Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..RtlTranslateAlignment Method
vApplicationMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vApplicationMenuItem Class
vApplicationMenuItem Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..Scale Method
vApplicationMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vApplicationMenuItem Class
vApplicationMenuItem Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..Select Method
vApplicationMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vApplicationMenuItem Class
vApplicationMenuItem Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..SetBounds Method
vApplicationMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vApplicationMenuItem Class
vApplicationMenuItem Members


ShowDropDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..ShowDropDown Method
vApplicationMenuItem Class See Also Send Feedback
Shows the drop down.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ShowDropDown()
Visual Basic
Public Sub ShowDropDown
Visual C++
public:
void ShowDropDown()

See Also

vApplicationMenuItem Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..UpdateBounds Method
vApplicationMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vApplicationMenuItem Class
vApplicationMenuItem Members


vApplicationMenuItem Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem Properties
vApplicationMenuItem Class See Also Send Feedback

The vApplicationMenuItem type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | ArrowAreaWidth | Gets or sets the width of the arrow area.
Public property | AutoOpen | Gets or sets a value indicating whether the dropdown is opened automatically
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckBoxSize | Gets or sets the size of the check box.
Public property | CheckBoxTickColor | Gets or sets the color of the check box tick.
Public property | Checked | Gets or sets a value indicating whether this vApplicationMenuItem is checked.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentBackColor | Gets or sets the color of the content back.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Overrides Control..::..DefaultSize.)
Public property | DescriptionText | Gets or sets the description text.
Public property | DescriptionTextAlignment | Gets or sets the description text alignment.
Public property | DescriptionTextColor | Gets or sets the color of the description text.
Public property | DescriptionTextFont | Gets or sets the description text font.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets the drop down.
Public property | DropDownHeight | Gets or sets the height of the drop down.
Public property | DropDownPosition | Gets or sets the width of the drop down.
Public property | DropDownWidth | Gets or sets the width of the drop down.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightArrow | Gets or sets a value indicating whether to highlight the arrow
Public property | Image | Gets or sets the image.
Public property | ImageAlignment | Gets or sets the image alignment.
Public property | ImageAreaWidth | Gets or sets the width of the image area.
Public property | ImageIndex | Gets or sets the index of the image.
Public property | ImageList | Gets or sets the image list.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsDropDownOpened | Gets a value indicating whether drop down is opened.
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets the items.
Public property | ItemType | Gets or sets the type of the item.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint item's border
Public property | PaintFill | Gets or sets a value indicating whether to paint item's background
Public property | PaintImageAreaBorder | Gets or sets a value indicating whether to paint image's area border
Public property | PaintImageAreaFill | Gets or sets a value indicating whether to paint image's area background
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentMenuItem | Gets the parent menu item.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Radius | Gets or sets the radius.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RootMenuItem | Gets the root menu item.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedChildMenuItem | Gets or sets the selected menu item.
Public property | ShowArrow | Gets or sets a value indicating whether to show an arrow
Public property | ShowCheckBox | Gets or sets a value indicating whether to show a checkbox.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment.
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the text color coming from the theme
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vApplicationMenuItem Class


ArrowAreaWidth Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..ArrowAreaWidth Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the width of the arrow area.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ArrowAreaWidth { get; set; }
Visual Basic
Public Property ArrowAreaWidth As Integer
    Get
    Set
Visual C++
public:
property int ArrowAreaWidth {
    int get ();
    void set (int value);
}

Field Value

The width of the arrow area.

See Also

vApplicationMenuItem Class


AutoOpen Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..AutoOpen Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets a value indicating whether the dropdown is opened automatically

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AutoOpen { get; set; }
Visual Basic
Public Property AutoOpen As Boolean
    Get
    Set
Visual C++
public:
property bool AutoOpen {
    bool get ();
    void set (bool value);
}

See Also

vApplicationMenuItem Class


CheckBoxSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..CheckBoxSize Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the size of the check box.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Size CheckBoxSize { get; set; }
Visual Basic
Public Property CheckBoxSize As Size
    Get
    Set
Visual C++
public:
property Size CheckBoxSize {
    Size get ();
    void set (Size value);
}

Field Value

The size of the check box.

See Also

vApplicationMenuItem Class


CheckBoxTickColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..CheckBoxTickColor Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the color of the check box tick.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color CheckBoxTickColor { get; set; }
Visual Basic
Public Property CheckBoxTickColor As Color
    Get
    Set
Visual C++
public:
property Color CheckBoxTickColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the check box tick.

See Also

vApplicationMenuItem Class


Checked Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..Checked Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets a value indicating whether this vApplicationMenuItem is checked.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Checked { get; set; }
Visual Basic
Public Property Checked As Boolean
    Get
    Set
Visual C++
public:
property bool Checked {
    bool get ();
    void set (bool value);
}

Field Value

true if checked; otherwise, false.

See Also

vApplicationMenuItem Class


ContentBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..ContentBackColor Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the color of the content back.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color ContentBackColor { get; set; }
Visual Basic
Public Property ContentBackColor As Color
    Get
    Set
Visual C++
public:
property Color ContentBackColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the content.

See Also

vApplicationMenuItem Class


DefaultSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..DefaultSize Property
vApplicationMenuItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override Size DefaultSize { get; }
Visual Basic
Protected Overrides ReadOnly Property DefaultSize As Size
    Get
Visual C++
protected:
virtual property Size DefaultSize {
    Size get () override;
}

See Also

vApplicationMenuItem Class


DescriptionText Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..DescriptionText Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the description text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string DescriptionText { get; set; }
Visual Basic
Public Property DescriptionText As String
    Get
    Set
Visual C++
public:
property String^ DescriptionText {
    String^ get ();
    void set (String^ value);
}

Field Value

The description text.

See Also

vApplicationMenuItem Class


DescriptionTextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..DescriptionTextAlignment Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the description text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment DescriptionTextAlignment { get; set; }
Visual Basic
Public Property DescriptionTextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment DescriptionTextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The description text alignment.

See Also

vApplicationMenuItem Class


DescriptionTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..DescriptionTextColor Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the color of the description text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DescriptionTextColor { get; set; }
Visual Basic
Public Property DescriptionTextColor As Color
    Get
    Set
Visual C++
public:
property Color DescriptionTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the description text.

See Also

vApplicationMenuItem Class


DescriptionTextFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..DescriptionTextFont Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the description text font.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font DescriptionTextFont { get; set; }
Visual Basic
Public Property DescriptionTextFont As Font
    Get
    Set
Visual C++
public:
property Font^ DescriptionTextFont {
    Font^ get ();
    void set (Font^ value);
}

Field Value

The description text font.

See Also

vApplicationMenuItem Class


DropDown Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..DropDown Property
vApplicationMenuItem Class See Also Send Feedback
Gets the drop down.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ToolStripDropDown DropDown { get; }
Visual Basic
Public ReadOnly Property DropDown As ToolStripDropDown
    Get
Visual C++
public:
property ToolStripDropDown^ DropDown {
    ToolStripDropDown^ get ();
}

Field Value

The drop down.

See Also

vApplicationMenuItem Class


DropDownHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..DropDownHeight Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the height of the drop down.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int DropDownHeight { get; set; }
Visual Basic
Public Property DropDownHeight As Integer
    Get
    Set
Visual C++
public:
property int DropDownHeight {
    int get ();
    void set (int value);
}

Field Value

The height of the drop down.

See Also

vApplicationMenuItem Class


DropDownPosition Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..DropDownPosition Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the width of the drop down.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Point DropDownPosition { get; set; }
Visual Basic
Public Property DropDownPosition As Point
    Get
    Set
Visual C++
public:
property Point DropDownPosition {
    Point get ();
    void set (Point value);
}

Field Value

The width of the drop down.

See Also

vApplicationMenuItem Class


DropDownWidth Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..DropDownWidth Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the width of the drop down.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int DropDownWidth { get; set; }
Visual Basic
Public Property DropDownWidth As Integer
    Get
    Set
Visual C++
public:
property int DropDownWidth {
    int get ();
    void set (int value);
}

Field Value

The width of the drop down.

See Also

vApplicationMenuItem Class


HighlightArrow Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..HighlightArrow Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets a value indicating whether to highlight the arrow

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool HighlightArrow { get; set; }
Visual Basic
Public Property HighlightArrow As Boolean
    Get
    Set
Visual C++
public:
property bool HighlightArrow {
    bool get ();
    void set (bool value);
}

See Also

vApplicationMenuItem Class


Image Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..Image Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the image.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Image Image { get; set; }
Visual Basic
Public Property Image As Image
    Get
    Set
Visual C++
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}

Field Value

The image.

See Also

vApplicationMenuItem Class


ImageAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..ImageAlignment Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the image alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment ImageAlignment { get; set; }
Visual Basic
Public Property ImageAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment ImageAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The image alignment.

See Also

vApplicationMenuItem Class


ImageAreaWidth Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..ImageAreaWidth Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the width of the image area.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ImageAreaWidth { get; set; }
Visual Basic
Public Property ImageAreaWidth As Integer
    Get
    Set
Visual C++
public:
property int ImageAreaWidth {
    int get ();
    void set (int value);
}

Field Value

The width of the image area.

See Also

vApplicationMenuItem Class


ImageIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..ImageIndex Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the index of the image.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ImageIndex { get; set; }
Visual Basic
Public Property ImageIndex As Integer
    Get
    Set
Visual C++
public:
property int ImageIndex {
    int get ();
    void set (int value);
}

Field Value

The index of the image.

See Also

vApplicationMenuItem Class


ImageList Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..ImageList Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the image list.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ImageList ImageList { get; set; }
Visual Basic
Public Property ImageList As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ ImageList {
    ImageList^ get ();
    void set (ImageList^ value);
}

Field Value

The image list.

See Also

vApplicationMenuItem Class


IsDropDownOpened Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..IsDropDownOpened Property
vApplicationMenuItem Class See Also Send Feedback
Gets a value indicating whether drop down is opened.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsDropDownOpened { get; }
Visual Basic
Public ReadOnly Property IsDropDownOpened As Boolean
    Get
Visual C++
public:
property bool IsDropDownOpened {
    bool get ();
}

Field Value

true if this instance the drop down is opened; otherwise, false.

See Also

vApplicationMenuItem Class


Items Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..Items Property
vApplicationMenuItem Class See Also Send Feedback
Gets the items.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vApplicationMenuItemCollection Items { get; }
Visual Basic
Public ReadOnly Property Items As vApplicationMenuItemCollection
    Get
Visual C++
public:
property vApplicationMenuItemCollection^ Items {
    vApplicationMenuItemCollection^ get ();
}

Field Value

The items.

See Also

vApplicationMenuItem Class


ItemType Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..ItemType Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the type of the item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vApplicationMenuItemType ItemType { get; set; }
Visual Basic
Public Property ItemType As vApplicationMenuItemType
    Get
    Set
Visual C++
public:
property vApplicationMenuItemType ItemType {
    vApplicationMenuItemType get ();
    void set (vApplicationMenuItemType value);
}

Field Value

The type of the item.

See Also

vApplicationMenuItem Class


PaintBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..PaintBorder Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets a value indicating whether to paint item's border

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintBorder { get; set; }
Visual Basic
Public Property PaintBorder As Boolean
    Get
    Set
Visual C++
public:
property bool PaintBorder {
    bool get ();
    void set (bool value);
}

See Also

vApplicationMenuItem Class


PaintFill Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..PaintFill Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets a value indicating whether to paint item's background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintFill { get; set; }
Visual Basic
Public Property PaintFill As Boolean
    Get
    Set
Visual C++
public:
property bool PaintFill {
    bool get ();
    void set (bool value);
}

See Also

vApplicationMenuItem Class


PaintImageAreaBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..PaintImageAreaBorder Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets a value indicating whether to paint image's area border

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintImageAreaBorder { get; set; }
Visual Basic
Public Property PaintImageAreaBorder As Boolean
    Get
    Set
Visual C++
public:
property bool PaintImageAreaBorder {
    bool get ();
    void set (bool value);
}

See Also

vApplicationMenuItem Class


PaintImageAreaFill Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..PaintImageAreaFill Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets a value indicating whether to paint image's area background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintImageAreaFill { get; set; }
Visual Basic
Public Property PaintImageAreaFill As Boolean
    Get
    Set
Visual C++
public:
property bool PaintImageAreaFill {
    bool get ();
    void set (bool value);
}

See Also

vApplicationMenuItem Class


ParentMenuItem Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..ParentMenuItem Property
vApplicationMenuItem Class See Also Send Feedback
Gets the parent menu item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vApplicationMenuItem ParentMenuItem { get; }
Visual Basic
Public ReadOnly Property ParentMenuItem As vApplicationMenuItem
    Get
Visual C++
public:
property vApplicationMenuItem^ ParentMenuItem {
    vApplicationMenuItem^ get ();
}

Field Value

The parent menu item.

See Also

vApplicationMenuItem Class


Radius Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..Radius Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the radius.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Radius { get; set; }
Visual Basic
Public Property Radius As Integer
    Get
    Set
Visual C++
public:
property int Radius {
    int get ();
    void set (int value);
}

Field Value

The radius.

See Also

vApplicationMenuItem Class


RootMenuItem Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..RootMenuItem Property
vApplicationMenuItem Class See Also Send Feedback
Gets the root menu item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vApplicationMenuItem RootMenuItem { get; }
Visual Basic
Public ReadOnly Property RootMenuItem As vApplicationMenuItem
    Get
Visual C++
public:
property vApplicationMenuItem^ RootMenuItem {
    vApplicationMenuItem^ get ();
}

Field Value

The root menu item.

See Also

vApplicationMenuItem Class


SelectedChildMenuItem Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..SelectedChildMenuItem Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the selected menu item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vApplicationMenuItem SelectedChildMenuItem { get; set; }
Visual Basic
Public Property SelectedChildMenuItem As vApplicationMenuItem
    Get
    Set
Visual C++
public:
property vApplicationMenuItem^ SelectedChildMenuItem {
    vApplicationMenuItem^ get ();
    void set (vApplicationMenuItem^ value);
}

Field Value

The selected item.

See Also

vApplicationMenuItem Class


ShowArrow Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..ShowArrow Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets a value indicating whether to show an arrow

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowArrow { get; set; }
Visual Basic
Public Property ShowArrow As Boolean
    Get
    Set
Visual C++
public:
property bool ShowArrow {
    bool get ();
    void set (bool value);
}

See Also

vApplicationMenuItem Class


ShowCheckBox Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..ShowCheckBox Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets a value indicating whether to show a checkbox.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowCheckBox { get; set; }
Visual Basic
Public Property ShowCheckBox As Boolean
    Get
    Set
Visual C++
public:
property bool ShowCheckBox {
    bool get ();
    void set (bool value);
}

See Also

vApplicationMenuItem Class


StyleKey Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..StyleKey Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the style key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual string StyleKey { get; set; }
Visual Basic
Protected Overridable Property StyleKey As String
    Get
    Set
Visual C++
protected:
virtual property String^ StyleKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The style key.

See Also

vApplicationMenuItem Class


TextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..TextAlignment Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment TextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The text alignment.

See Also

vApplicationMenuItem Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..Theme Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vApplicationMenuItem Class


UseThemeTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..UseThemeTextColor Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets a value indicating whether to use the text color coming from the theme

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeTextColor { get; set; }
Visual Basic
Public Property UseThemeTextColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeTextColor {
    bool get ();
    void set (bool value);
}

See Also

vApplicationMenuItem Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..VIBlendTheme Property
vApplicationMenuItem Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vApplicationMenuItem Class


vApplicationMenuItem Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem Events
vApplicationMenuItem Class See Also Send Feedback

The vApplicationMenuItem type exposes the following members.

Events

 | Name | Description
Public event | ArrowButtonClicked | Occurs when arrow button is clicked.
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContentButtonClicked | Occurs when content button is clicked.
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectionChanged | Occurs when a selection has been changed
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vApplicationMenuItem Class


ArrowButtonClicked Event

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..ArrowButtonClicked Event
vApplicationMenuItem Class See Also Send Feedback
Occurs when arrow button is clicked.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ArrowButtonClicked
Visual Basic
Public Event ArrowButtonClicked As EventHandler
Visual C++
public:
 event EventHandler^ ArrowButtonClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vApplicationMenuItem Class


ContentButtonClicked Event

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..ContentButtonClicked Event
vApplicationMenuItem Class See Also Send Feedback
Occurs when content button is clicked.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ContentButtonClicked
Visual Basic
Public Event ContentButtonClicked As EventHandler
Visual C++
public:
 event EventHandler^ ContentButtonClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vApplicationMenuItem Class


SelectionChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItem..::..SelectionChanged Event
vApplicationMenuItem Class See Also Send Feedback
Occurs when a selection has been changed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler SelectionChanged
Visual Basic
Public Event SelectionChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vApplicationMenuItem Class


vApplicationMenuItemCollection Class

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vApplicationMenuItemCollection : IList<vApplicationMenuItem>,
    ICollection<vApplicationMenuItem>, IEnumerable<vApplicationMenuItem>, IList,
    ICollection, IEnumerable
Visual Basic
Public Class vApplicationMenuItemCollection _
    Implements IList(Of vApplicationMenuItem), ICollection(Of vApplicationMenuItem),  _
    IEnumerable(Of vApplicationMenuItem), IList, ICollection, IEnumerable
Visual C++
public ref class vApplicationMenuItemCollection : IList<vApplicationMenuItem^>,
    ICollection<vApplicationMenuItem^>, IEnumerable<vApplicationMenuItem^>, IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..vApplicationMenuItemCollection

See Also

vApplicationMenuItemCollection Members


vApplicationMenuItemCollection Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection Members
vApplicationMenuItemCollection Class Constructors Methods Properties Events See Also Send Feedback

The vApplicationMenuItemCollection type exposes the following members.

Constructors

 | Name | Description
Public method | vApplicationMenuItemCollection | Initializes a new instance of the vApplicationMenuItemCollection class.

Methods

 | Name | Description
Public method | Add(Object) | Adds an item to the IList.
Public method | Add(vApplicationMenuItem) | Adds an item to the ICollection<(Of <(<'T>)>)>.
Public method | Clear | Removes all items from the ICollection<(Of <(<'T>)>)>.
Public method | Contains(Object) | Determines whether the IList contains a specific value.
Public method | Contains(vApplicationMenuItem) | Determines whether the ICollection<(Of <(<'T>)>)> contains a specific value.
Public method | CopyTo(Array, Int32) | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | CopyTo(array<vApplicationMenuItem>[]()[][], Int32) | Copies the elements of the ICollection<(Of <(<'T>)>)> to an Array, starting at a particular Array index.
Public method | Dispose | Releases all resources used by the vApplicationMenuItemCollection
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(Object) | Determines the index of a specific item in the IList.
Public method | IndexOf(vApplicationMenuItem) | Determines the index of a specific item in the IList<(Of <(<'T>)>)>.
Public method | Insert(Int32, Object) | Inserts an item to the IList at the specified index.
Public method | Insert(Int32, vApplicationMenuItem) | Inserts an item to the IList<(Of <(<'T>)>)> at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnMenuItemsChanged |
Public method | Remove(Object) | Removes the first occurrence of a specific object from the IList.
Public method | Remove(vApplicationMenuItem) | Removes the first occurrence of a specific object from the ICollection<(Of <(<'T>)>)>.
Public method | RemoveAt | Removes the IList<(Of <(<'T>)>)> item at the specified index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(<'T>)>)>.
Public property | IsFixedSize | Gets a value indicating whether the IList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(<'T>)>)> is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Public property | Item | Gets or sets the vApplicationMenuItem at the specified index.
Public property | Owner | Gets the owner.
Public property | OwnerDropDown | Gets the owner drop down.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.

Events

 | Name | Description
Public event | MenuItemsChanged |

See Also

vApplicationMenuItemCollection Class


vApplicationMenuItemCollection Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection Constructor
vApplicationMenuItemCollection Class See Also Send Feedback
Initializes a new instance of the vApplicationMenuItemCollection class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vApplicationMenuItemCollection(
    vApplicationMenuItem owner,
    Control ownerDropDown
)
Visual Basic
Public Sub New ( _
    owner As vApplicationMenuItem, _
    ownerDropDown As Control _
)
Visual C++
public:
vApplicationMenuItemCollection(
    vApplicationMenuItem^ owner,
    Control^ ownerDropDown
)

Parameters

owner
Type: VIBlend.WinForms.Controls..::..vApplicationMenuItem
The owner.
ownerDropDown
Type: System.Windows.Forms..::..Control
The owner drop down.

See Also

vApplicationMenuItemCollection Class


vApplicationMenuItemCollection Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection Methods
vApplicationMenuItemCollection Class See Also Send Feedback

The vApplicationMenuItemCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add(Object) | Adds an item to the IList.
Public method | Add(vApplicationMenuItem) | Adds an item to the ICollection<(Of <(<'T>)>)>.
Public method | Clear | Removes all items from the ICollection<(Of <(<'T>)>)>.
Public method | Contains(Object) | Determines whether the IList contains a specific value.
Public method | Contains(vApplicationMenuItem) | Determines whether the ICollection<(Of <(<'T>)>)> contains a specific value.
Public method | CopyTo(Array, Int32) | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | CopyTo(array<vApplicationMenuItem>[]()[][], Int32) | Copies the elements of the ICollection<(Of <(<'T>)>)> to an Array, starting at a particular Array index.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(Object) | Determines the index of a specific item in the IList.
Public method | IndexOf(vApplicationMenuItem) | Determines the index of a specific item in the IList<(Of <(<'T>)>)>.
Public method | Insert(Int32, Object) | Inserts an item to the IList at the specified index.
Public method | Insert(Int32, vApplicationMenuItem) | Inserts an item to the IList<(Of <(<'T>)>)> at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnMenuItemsChanged |
Public method | Remove(Object) | Removes the first occurrence of a specific object from the IList.
Public method | Remove(vApplicationMenuItem) | Removes the first occurrence of a specific object from the ICollection<(Of <(<'T>)>)>.
Public method | RemoveAt | Removes the IList<(Of <(<'T>)>)> item at the specified index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vApplicationMenuItemCollection Class


Add Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..Add Method
vApplicationMenuItemCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(Object) | Adds an item to the IList.
Public method | Add(vApplicationMenuItem) | Adds an item to the ICollection<(Of <(<'T>)>)>.

See Also

vApplicationMenuItemCollection Class
vApplicationMenuItemCollection Members


Add Method (Object)

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..Add Method (Object)
vApplicationMenuItemCollection Class See Also Send Feedback
Adds an item to the IList.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Add(
    Object value
)
Visual Basic
Public Function Add ( _
    value As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ value
) sealed

Parameters

value
Type: System..::..Object
The Object to add to the IList.

Return Value

The position into which the new element was inserted.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | The IList is read-only. -or- The IList has a fixed size.

See Also

vApplicationMenuItemCollection Class
Add Overload


Add Method (vApplicationMenuItem)

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..Add Method (vApplicationMenuItem)
vApplicationMenuItemCollection Class See Also Send Feedback
Adds an item to the ICollection<(Of <(<'T>)>)>.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Add(
    vApplicationMenuItem item
)
Visual Basic
Public Sub Add ( _
    item As vApplicationMenuItem _
)
Visual C++
public:
virtual void Add(
    vApplicationMenuItem^ item
) sealed

Parameters

item
Type: VIBlend.WinForms.Controls..::..vApplicationMenuItem
The object to add to the ICollection<(Of <(<'T>)>)>.

Implements

ICollection<(Of <(<'T>)>)>..::..Add(T)

Exceptions

Exception | Condition
System..::..NotSupportedException | The ICollection<(Of <(<'T>)>)> is read-only.

See Also

vApplicationMenuItemCollection Class
Add Overload


Clear Method

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..Clear Method
vApplicationMenuItemCollection Class See Also Send Feedback
Removes all items from the ICollection<(Of <(<'T>)>)>.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(<'T>)>)>..::..Clear()()()()
IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | The ICollection<(Of <(<'T>)>)> is read-only.

See Also

vApplicationMenuItemCollection Class


Contains Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..Contains Method
vApplicationMenuItemCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Contains(Object) | Determines whether the IList contains a specific value.
Public method | Contains(vApplicationMenuItem) | Determines whether the ICollection<(Of <(<'T>)>)> contains a specific value.

See Also

vApplicationMenuItemCollection Class
vApplicationMenuItemCollection Members


Contains Method (Object)

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..Contains Method (Object)
vApplicationMenuItemCollection Class See Also Send Feedback
Determines whether the IList contains a specific value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Contains(
    Object value
)
Visual Basic
Public Function Contains ( _
    value As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ value
) sealed

Parameters

value
Type: System..::..Object
The Object to locate in the IList.

Return Value

true if the Object is found in the IList; otherwise, false.

Implements

IList..::..Contains(Object)

See Also

vApplicationMenuItemCollection Class
Contains Overload


Contains Method (vApplicationMenuItem)

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..Contains Method (vApplicationMenuItem)
vApplicationMenuItemCollection Class See Also Send Feedback
Determines whether the ICollection<(Of <(<'T>)>)> contains a specific value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Contains(
    vApplicationMenuItem item
)
Visual Basic
Public Function Contains ( _
    item As vApplicationMenuItem _
) As Boolean
Visual C++
public:
virtual bool Contains(
    vApplicationMenuItem^ item
) sealed

Parameters

item
Type: VIBlend.WinForms.Controls..::..vApplicationMenuItem
The object to locate in the ICollection<(Of <(<'T>)>)>.

Return Value

true if item is found in the ICollection<(Of <(<'T>)>)>; otherwise, false.

Implements

ICollection<(Of <(<'T>)>)>..::..Contains(T)

See Also

vApplicationMenuItemCollection Class
Contains Overload


CopyTo Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..CopyTo Method
vApplicationMenuItemCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(Array, Int32) | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | CopyTo(array<vApplicationMenuItem>[]()[][], Int32) | Copies the elements of the ICollection<(Of <(<'T>)>)> to an Array, starting at a particular Array index.

See Also

vApplicationMenuItemCollection Class
vApplicationMenuItemCollection Members


CopyTo Method (Array, Int32)

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..CopyTo Method (Array, Int32)
vApplicationMenuItemCollection Class See Also Send Feedback
Copies the elements of the ICollection to an Array, starting at a particular Array index.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from ICollection. The Array must have zero-based indexing.
index
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is null.
System..::..ArgumentOutOfRangeException | index is less than zero.
System..::..ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of elements in the source ICollection is greater than the available space from index to the end of the destination array.
System..::..ArgumentException | The type of the source ICollection cannot be cast automatically to the type of the destination array.

See Also

vApplicationMenuItemCollection Class
CopyTo Overload


CopyTo Method (vApplicationMenuItem[], Int32)

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..CopyTo Method (array<vApplicationMenuItem>[]()[][], Int32)
vApplicationMenuItemCollection Class See Also Send Feedback
Copies the elements of the ICollection<(Of <(<'T>)>)> to an Array, starting at a particular Array index.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void CopyTo(
    vApplicationMenuItem[] array,
    int arrayIndex
)
Visual Basic
Public Sub CopyTo ( _
    array As vApplicationMenuItem(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<vApplicationMenuItem^>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array< VIBlend.WinForms.Controls..::..vApplicationMenuItem >[]()[][]
The one-dimensional Array that is the destination of the elements copied from ICollection<(Of <(<'T>)>)>. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(<'T>)>)>..::..CopyTo(array<T>[]()[][], Int32)

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is null.
System..::..ArgumentOutOfRangeException | arrayIndex is less than 0.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ICollection<(Of <(<'T>)>)> is greater than the available space from arrayIndex to the end of the destination array. -or- Type T cannot be cast automatically to the type of the destination array.

See Also

vApplicationMenuItemCollection Class
CopyTo Overload


Dispose Method

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..Dispose Method
vApplicationMenuItemCollection Class See Also Send Feedback
Releases all resources used by the vApplicationMenuItemCollection

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
void Dispose()

See Also

vApplicationMenuItemCollection Class


GetEnumerator Method

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..GetEnumerator Method
vApplicationMenuItemCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public IEnumerator<vApplicationMenuItem> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of vApplicationMenuItem)
Visual C++
public:
virtual IEnumerator<vApplicationMenuItem^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

vApplicationMenuItemCollection Class


IndexOf Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..IndexOf Method
vApplicationMenuItemCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(Object) | Determines the index of a specific item in the IList.
Public method | IndexOf(vApplicationMenuItem) | Determines the index of a specific item in the IList<(Of <(<'T>)>)>.

See Also

vApplicationMenuItemCollection Class
vApplicationMenuItemCollection Members


IndexOf Method (Object)

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..IndexOf Method (Object)
vApplicationMenuItemCollection Class See Also Send Feedback
Determines the index of a specific item in the IList.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int IndexOf(
    Object value
)
Visual Basic
Public Function IndexOf ( _
    value As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ value
) sealed

Parameters

value
Type: System..::..Object
The Object to locate in the IList.

Return Value

The index of value if found in the list; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

vApplicationMenuItemCollection Class
IndexOf Overload


IndexOf Method (vApplicationMenuItem)

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..IndexOf Method (vApplicationMenuItem)
vApplicationMenuItemCollection Class See Also Send Feedback
Determines the index of a specific item in the IList<(Of <(<'T>)>)>.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int IndexOf(
    vApplicationMenuItem item
)
Visual Basic
Public Function IndexOf ( _
    item As vApplicationMenuItem _
) As Integer
Visual C++
public:
virtual int IndexOf(
    vApplicationMenuItem^ item
) sealed

Parameters

item
Type: VIBlend.WinForms.Controls..::..vApplicationMenuItem
The object to locate in the IList<(Of <(<'T>)>)>.

Return Value

The index of item if found in the list; otherwise, -1.

Implements

IList<(Of <(<'T>)>)>..::..IndexOf(T)

See Also

vApplicationMenuItemCollection Class
IndexOf Overload


Insert Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..Insert Method
vApplicationMenuItemCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Insert(Int32, Object) | Inserts an item to the IList at the specified index.
Public method | Insert(Int32, vApplicationMenuItem) | Inserts an item to the IList<(Of <(<'T>)>)> at the specified index.

See Also

vApplicationMenuItemCollection Class
vApplicationMenuItemCollection Members


Insert Method (Int32, Object)

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..Insert Method (Int32, Object)
vApplicationMenuItemCollection Class See Also Send Feedback
Inserts an item to the IList at the specified index.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Insert(
    int index,
    Object value
)
Visual Basic
Public Sub Insert ( _
    index As Integer, _
    value As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ value
) sealed

Parameters

index
Type: System..::..Int32
The zero-based index at which value should be inserted.
value
Type: System..::..Object
The Object to insert into the IList.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is not a valid index in the IList.
System..::..NotSupportedException | The IList is read-only. -or- The IList has a fixed size.
System..::..NullReferenceException | value is null reference in the IList.

See Also

vApplicationMenuItemCollection Class
Insert Overload


Insert Method (Int32, vApplicationMenuItem)

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..Insert Method (Int32, vApplicationMenuItem)
vApplicationMenuItemCollection Class See Also Send Feedback
Inserts an item to the IList<(Of <(<'T>)>)> at the specified index.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Insert(
    int index,
    vApplicationMenuItem item
)
Visual Basic
Public Sub Insert ( _
    index As Integer, _
    item As vApplicationMenuItem _
)
Visual C++
public:
virtual void Insert(
    int index,
    vApplicationMenuItem^ item
) sealed

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: VIBlend.WinForms.Controls..::..vApplicationMenuItem
The object to insert into the IList<(Of <(<'T>)>)>.

Implements

IList<(Of <(<'T>)>)>..::..Insert(Int32, T)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is not a valid index in the IList<(Of <(<'T>)>)>.
System..::..NotSupportedException | The IList<(Of <(<'T>)>)> is read-only.

See Also

vApplicationMenuItemCollection Class
Insert Overload


OnMenuItemsChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..OnMenuItemsChanged Method
vApplicationMenuItemCollection Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnMenuItemsChanged()
Visual Basic
Protected Overridable Sub OnMenuItemsChanged
Visual C++
protected:
virtual void OnMenuItemsChanged()

See Also

vApplicationMenuItemCollection Class


Remove Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..Remove Method
vApplicationMenuItemCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(Object) | Removes the first occurrence of a specific object from the IList.
Public method | Remove(vApplicationMenuItem) | Removes the first occurrence of a specific object from the ICollection<(Of <(<'T>)>)>.

See Also

vApplicationMenuItemCollection Class
vApplicationMenuItemCollection Members


Remove Method (Object)

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..Remove Method (Object)
vApplicationMenuItemCollection Class See Also Send Feedback
Removes the first occurrence of a specific object from the IList.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Remove(
    Object value
)
Visual Basic
Public Sub Remove ( _
    value As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ value
) sealed

Parameters

value
Type: System..::..Object
The Object to remove from the IList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | The IList is read-only. -or- The IList has a fixed size.

See Also

vApplicationMenuItemCollection Class
Remove Overload


Remove Method (vApplicationMenuItem)

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..Remove Method (vApplicationMenuItem)
vApplicationMenuItemCollection Class See Also Send Feedback
Removes the first occurrence of a specific object from the ICollection<(Of <(<'T>)>)>.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Remove(
    vApplicationMenuItem item
)
Visual Basic
Public Function Remove ( _
    item As vApplicationMenuItem _
) As Boolean
Visual C++
public:
virtual bool Remove(
    vApplicationMenuItem^ item
) sealed

Parameters

item
Type: VIBlend.WinForms.Controls..::..vApplicationMenuItem
The object to remove from the ICollection<(Of <(<'T>)>)>.

Return Value

true if item was successfully removed from the ICollection<(Of <(<'T>)>)>; otherwise, false. This method also returns false if item is not found in the original ICollection<(Of <(<'T>)>)>.

Implements

ICollection<(Of <(<'T>)>)>..::..Remove(T)

Exceptions

Exception | Condition
System..::..NotSupportedException | The ICollection<(Of <(<'T>)>)> is read-only.

See Also

vApplicationMenuItemCollection Class
Remove Overload


RemoveAt Method

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..RemoveAt Method
vApplicationMenuItemCollection Class See Also Send Feedback
Removes the IList<(Of <(<'T>)>)> item at the specified index.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
) sealed

Parameters

index
Type: System..::..Int32
The zero-based index of the item to remove.

Implements

IList<(Of <(<'T>)>)>..::..RemoveAt(Int32)
IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is not a valid index in the IList<(Of <(<'T>)>)>.
System..::..NotSupportedException | The IList<(Of <(<'T>)>)> is read-only.

See Also

vApplicationMenuItemCollection Class


vApplicationMenuItemCollection Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection Properties
vApplicationMenuItemCollection Class See Also Send Feedback

The vApplicationMenuItemCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(<'T>)>)>.
Public property | IsFixedSize | Gets a value indicating whether the IList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(<'T>)>)> is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Public property | Item | Gets or sets the vApplicationMenuItem at the specified index.
Public property | Owner | Gets the owner.
Public property | OwnerDropDown | Gets the owner drop down.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.

See Also

vApplicationMenuItemCollection Class


Count Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..Count Property
vApplicationMenuItemCollection Class See Also Send Feedback
Gets the number of elements contained in the ICollection<(Of <(<'T>)>)>.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Field Value

Return Value

The number of elements contained in the ICollection<(Of <(<'T>)>)>.

Implements

ICollection<(Of <(<'T>)>)>..::..Count
ICollection..::..Count

See Also

vApplicationMenuItemCollection Class


IsFixedSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..IsFixedSize Property
vApplicationMenuItemCollection Class See Also Send Feedback
Gets a value indicating whether the IList has a fixed size.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsFixedSize { get; }
Visual Basic
Public ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get () sealed;
}

Field Value

Return Value

true if the IList has a fixed size; otherwise, false.

Implements

IList..::..IsFixedSize

See Also

vApplicationMenuItemCollection Class


IsReadOnly Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..IsReadOnly Property
vApplicationMenuItemCollection Class See Also Send Feedback
Gets a value indicating whether the ICollection<(Of <(<'T>)>)> is read-only.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic
Public ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Field Value

Return Value

true if the ICollection<(Of <(<'T>)>)> is read-only; otherwise, false.

Implements

ICollection<(Of <(<'T>)>)>..::..IsReadOnly
IList..::..IsReadOnly

See Also

vApplicationMenuItemCollection Class


IsSynchronized Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..IsSynchronized Property
vApplicationMenuItemCollection Class See Also Send Feedback
Gets a value indicating whether access to the ICollection is synchronized (thread safe).

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic
Public ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Field Value

Return Value

true if access to the ICollection is synchronized (thread safe); otherwise, false.

Implements

ICollection..::..IsSynchronized

See Also

vApplicationMenuItemCollection Class


Item Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..Item Property
vApplicationMenuItemCollection Class See Also Send Feedback
Gets or sets the vApplicationMenuItem at the specified index.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vApplicationMenuItem this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item ( _
    index As Integer _
) As vApplicationMenuItem
    Get
    Set
Visual C++
public:
virtual property vApplicationMenuItem^ default[int index] {
    vApplicationMenuItem^ get (int index) sealed;
    void set (int index, vApplicationMenuItem^ value) sealed;
}

Parameters

index
Type: System..::..Int32

Field Value

Implements

IList<(Of <(<'T>)>)>..::..Item[([( Int32])])

See Also

vApplicationMenuItemCollection Class


Owner Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..Owner Property
vApplicationMenuItemCollection Class See Also Send Feedback
Gets the owner.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control Owner { get; }
Visual Basic
Public ReadOnly Property Owner As Control
    Get
Visual C++
public:
property Control^ Owner {
    Control^ get ();
}

Field Value

The owner.

See Also

vApplicationMenuItemCollection Class


OwnerDropDown Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..OwnerDropDown Property
vApplicationMenuItemCollection Class See Also Send Feedback
Gets the owner drop down.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control OwnerDropDown { get; }
Visual Basic
Public ReadOnly Property OwnerDropDown As Control
    Get
Visual C++
public:
property Control^ OwnerDropDown {
    Control^ get ();
}

Field Value

The owner drop down.

See Also

vApplicationMenuItemCollection Class


SyncRoot Property

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..SyncRoot Property
vApplicationMenuItemCollection Class See Also Send Feedback
Gets an object that can be used to synchronize access to the ICollection.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic
Public ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}

Field Value

Return Value

An object that can be used to synchronize access to the ICollection.

Implements

ICollection..::..SyncRoot

See Also

vApplicationMenuItemCollection Class


vApplicationMenuItemCollection Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection Events
vApplicationMenuItemCollection Class See Also Send Feedback

The vApplicationMenuItemCollection type exposes the following members.

Events

 | Name | Description
Public event | MenuItemsChanged |

See Also

vApplicationMenuItemCollection Class


MenuItemsChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vApplicationMenuItemCollection..::..MenuItemsChanged Event
vApplicationMenuItemCollection Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler MenuItemsChanged
Visual Basic
Public Event MenuItemsChanged As EventHandler
Visual C++
public:
 event EventHandler^ MenuItemsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vApplicationMenuItemCollection Class


vAppointment Class

[image]

VIBlend Controls for WinForms Help Documentation
vAppointment Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vAppointment
Visual Basic
Public Class vAppointment
Visual C++
public ref class vAppointment

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..vAppointment

See Also

vAppointment Members


vAppointment Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vAppointment Members
vAppointment Class Constructors Methods Properties Events See Also Send Feedback

The vAppointment type exposes the following members.

Constructors

 | Name | Description
Public method | vAppointment | Initializes a new instance of the [!:vCalendarDay] class.

Methods

 | Name | Description
Public method | Clone | Clones this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCellPaint | Raises the [E:CellPaint] event.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Date | Gets or sets the date time.
Public property | DayPattern | Gets or sets the day pattern.
Public property | MonthPattern | Gets or sets the month pattern.
Public property | RecurrenceRange | Gets or sets the recurrence range.
Public property | RecurrenceRule | Gets or sets the recurrence rule.
Public property | Tag | Gets or sets the tag.
Public property | ToolTipContainer |
Public property | vToolTip | Gets or sets the v tool tip.
Public property | WeekPattern | Gets or sets the week pattern.
Public property | YearPattern | Gets or sets the year pattern.

Events

 | Name | Description
Public event | CellPaint | Occurs when cell is painted.

See Also

vAppointment Class


vAppointment Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vAppointment Constructor
vAppointment Class See Also Send Feedback
Initializes a new instance of the [!:vCalendarDay] class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vAppointment()
Visual Basic
Public Sub New
Visual C++
public:
vAppointment()

See Also

vAppointment Class


vAppointment Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vAppointment Methods
vAppointment Class See Also Send Feedback

The vAppointment type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCellPaint | Raises the [E:CellPaint] event.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

vAppointment Class


Clone Method

[image]

VIBlend Controls for WinForms Help Documentation
vAppointment..::..Clone Method
vAppointment Class See Also Send Feedback
Clones this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vAppointment Clone()
Visual Basic
Public Function Clone As vAppointment
Visual C++
public:
vAppointment^ Clone()

Return Value

See Also

vAppointment Class


OnCellPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vAppointment..::..OnCellPaint Method
vAppointment Class See Also Send Feedback
Raises the [E:CellPaint] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnCellPaint(
    CalendarPaintEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnCellPaint ( _
    args As CalendarPaintEventArgs _
)
Visual C++
protected public:
virtual void OnCellPaint(
    CalendarPaintEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.Controls..::..CalendarPaintEventArgs
The CalendarPaintEventArgs instance containing the event data.

See Also

vAppointment Class


ToString Method

[image]

VIBlend Controls for WinForms Help Documentation
vAppointment..::..ToString Method
vAppointment Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

vAppointment Class


vAppointment Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vAppointment Properties
vAppointment Class See Also Send Feedback

The vAppointment type exposes the following members.

Properties

 | Name | Description
Public property | Date | Gets or sets the date time.
Public property | DayPattern | Gets or sets the day pattern.
Public property | MonthPattern | Gets or sets the month pattern.
Public property | RecurrenceRange | Gets or sets the recurrence range.
Public property | RecurrenceRule | Gets or sets the recurrence rule.
Public property | Tag | Gets or sets the tag.
Public property | ToolTipContainer |
Public property | vToolTip | Gets or sets the v tool tip.
Public property | WeekPattern | Gets or sets the week pattern.
Public property | YearPattern | Gets or sets the year pattern.

See Also

vAppointment Class


Date Property

[image]

VIBlend Controls for WinForms Help Documentation
vAppointment..::..Date Property
vAppointment Class See Also Send Feedback
Gets or sets the date time.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime Date { get; set; }
Visual Basic
Public Property Date As DateTime
    Get
    Set
Visual C++
public:
property DateTime Date {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The date time.

See Also

vAppointment Class


DayPattern Property

[image]

VIBlend Controls for WinForms Help Documentation
vAppointment..::..DayPattern Property
vAppointment Class See Also Send Feedback
Gets or sets the day pattern.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DayPattern DayPattern { get; set; }
Visual Basic
Public Property DayPattern As DayPattern
    Get
    Set
Visual C++
public:
property DayPattern^ DayPattern {
    DayPattern^ get ();
    void set (DayPattern^ value);
}

Field Value

The day pattern.

See Also

vAppointment Class


MonthPattern Property

[image]

VIBlend Controls for WinForms Help Documentation
vAppointment..::..MonthPattern Property
vAppointment Class See Also Send Feedback
Gets or sets the month pattern.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public MonthPattern MonthPattern { get; set; }
Visual Basic
Public Property MonthPattern As MonthPattern
    Get
    Set
Visual C++
public:
property MonthPattern^ MonthPattern {
    MonthPattern^ get ();
    void set (MonthPattern^ value);
}

Field Value

The month pattern.

See Also

vAppointment Class


RecurrenceRange Property

[image]

VIBlend Controls for WinForms Help Documentation
vAppointment..::..RecurrenceRange Property
vAppointment Class See Also Send Feedback
Gets or sets the recurrence range.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RecurrenceRange RecurrenceRange { get; set; }
Visual Basic
Public Property RecurrenceRange As RecurrenceRange
    Get
    Set
Visual C++
public:
property RecurrenceRange^ RecurrenceRange {
    RecurrenceRange^ get ();
    void set (RecurrenceRange^ value);
}

Field Value

The recurrence range.

See Also

vAppointment Class


RecurrenceRule Property

[image]

VIBlend Controls for WinForms Help Documentation
vAppointment..::..RecurrenceRule Property
vAppointment Class See Also Send Feedback
Gets or sets the recurrence rule.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RecurrenceRule RecurrenceRule { get; set; }
Visual Basic
Public Property RecurrenceRule As RecurrenceRule
    Get
    Set
Visual C++
public:
property RecurrenceRule RecurrenceRule {
    RecurrenceRule get ();
    void set (RecurrenceRule value);
}

Field Value

The recurrence rule.

See Also

vAppointment Class


Tag Property

[image]

VIBlend Controls for WinForms Help Documentation
vAppointment..::..Tag Property
vAppointment Class See Also Send Feedback
Gets or sets the tag.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object Tag { get; set; }
Visual Basic
Public Property Tag As Object
    Get
    Set
Visual C++
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Field Value

The tag.

See Also

vAppointment Class


ToolTipContainer Property

[image]

VIBlend Controls for WinForms Help Documentation
vAppointment..::..ToolTipContainer Property
vAppointment Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control ToolTipContainer { get; }
Visual Basic
Public ReadOnly Property ToolTipContainer As Control
    Get
Visual C++
public:
property Control^ ToolTipContainer {
    Control^ get ();
}

See Also

vAppointment Class


vToolTip Property

[image]

VIBlend Controls for WinForms Help Documentation
vAppointment..::..vToolTip Property
vAppointment Class See Also Send Feedback
Gets or sets the v tool tip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vToolTip vToolTip { get; set; }
Visual Basic
Public Property vToolTip As vToolTip
    Get
    Set
Visual C++
public:
property vToolTip^ vToolTip {
    vToolTip^ get ();
    void set (vToolTip^ value);
}

Field Value

The v tool tip.

See Also

vAppointment Class


WeekPattern Property

[image]

VIBlend Controls for WinForms Help Documentation
vAppointment..::..WeekPattern Property
vAppointment Class See Also Send Feedback
Gets or sets the week pattern.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public WeekPattern WeekPattern { get; set; }
Visual Basic
Public Property WeekPattern As WeekPattern
    Get
    Set
Visual C++
public:
property WeekPattern^ WeekPattern {
    WeekPattern^ get ();
    void set (WeekPattern^ value);
}

Field Value

The week pattern.

See Also

vAppointment Class


YearPattern Property

[image]

VIBlend Controls for WinForms Help Documentation
vAppointment..::..YearPattern Property
vAppointment Class See Also Send Feedback
Gets or sets the year pattern.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public YearPattern YearPattern { get; set; }
Visual Basic
Public Property YearPattern As YearPattern
    Get
    Set
Visual C++
public:
property YearPattern^ YearPattern {
    YearPattern^ get ();
    void set (YearPattern^ value);
}

Field Value

The year pattern.

See Also

vAppointment Class


vAppointment Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vAppointment Events
vAppointment Class See Also Send Feedback

The vAppointment type exposes the following members.

Events

 | Name | Description
Public event | CellPaint | Occurs when cell is painted.

See Also

vAppointment Class


CellPaint Event

[image]

VIBlend Controls for WinForms Help Documentation
vAppointment..::..CellPaint Event
vAppointment Class See Also Send Feedback
Occurs when cell is painted.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event CalendarPaintHandler CellPaint
Visual Basic
Public Event CellPaint As CalendarPaintHandler
Visual C++
public:
 event CalendarPaintHandler^ CellPaint {
    void add (CalendarPaintHandler^ value);
    void remove (CalendarPaintHandler^ value);
}

See Also

vAppointment Class


vArrowButton Class

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton Class
Members See Also Send Feedback
Represents a Button control that show an arrow with configurable direction.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vArrowButton : ScrollableControlMiniBase
Visual Basic
Public Class vArrowButton _
    Inherits ScrollableControlMiniBase
Visual C++
public ref class vArrowButton : public ScrollableControlMiniBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
ScrollableControlMiniBase
VIBlend.WinForms.Controls..::..vArrowButton

See Also

vArrowButton Members


vArrowButton Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton Members
vArrowButton Class Constructors Methods Fields Properties Events See Also Send Feedback

The vArrowButton type exposes the following members.

Constructors

 | Name | Description
Public method | vArrowButton | Initializes a new instance of the vArrowButton class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateScrollElements |
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Overrides Control..::..OnLostFocus(EventArgs).)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Called when [value changed].
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | button |
Protected field | scrollElement |

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | ArrowDirection | Gets or sets the arrow direction.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the Maximum value of the vArrowButton control.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the Minimum value of the vArrowButton control.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the current position of the vArrowButton control.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when value is changed
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vArrowButton Class


vArrowButton Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton Constructor
vArrowButton Class See Also Send Feedback
Initializes a new instance of the vArrowButton class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vArrowButton()
Visual Basic
Public Sub New
Visual C++
public:
vArrowButton()

See Also

vArrowButton Class


vArrowButton Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton Fields
vArrowButton Class See Also Send Feedback

The vArrowButton type exposes the following members.

Fields

 | Name | Description
Protected field | button |
Protected field | scrollElement |

See Also

vArrowButton Class


button Field

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..button Field
vArrowButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected BackgroundElement button
Visual Basic
Protected button As BackgroundElement
Visual C++
protected:
BackgroundElement^ button

See Also

vArrowButton Class


scrollElement Field

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..scrollElement Field
vArrowButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected BackgroundElement scrollElement
Visual Basic
Protected scrollElement As BackgroundElement
Visual C++
protected:
BackgroundElement^ scrollElement

See Also

vArrowButton Class


vArrowButton Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton Methods
vArrowButton Class See Also Send Feedback

The vArrowButton type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateScrollElements |
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Overrides Control..::..OnLostFocus(EventArgs).)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Called when [value changed].
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vArrowButton Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..AccessibilityNotifyClients Method
vArrowButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vArrowButton Class
vArrowButton Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..BeginInvoke Method
vArrowButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vArrowButton Class
vArrowButton Members


CreateScrollElements Method

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..CreateScrollElements Method
vArrowButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected void CreateScrollElements()
Visual Basic
Protected Sub CreateScrollElements
Visual C++
protected:
void CreateScrollElements()

See Also

vArrowButton Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..Dispose Method
vArrowButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vArrowButton Class
vArrowButton Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..GetChildAtPoint Method
vArrowButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vArrowButton Class
vArrowButton Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..Invalidate Method
vArrowButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vArrowButton Class
vArrowButton Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..Invoke Method
vArrowButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vArrowButton Class
vArrowButton Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..MemberwiseClone Method
vArrowButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vArrowButton Class
vArrowButton Members


OnLostFocus Method

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..OnLostFocus Method
vArrowButton Class See Also Send Feedback
Raises the LostFocus event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLostFocus(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnLostFocus ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLostFocus(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vArrowButton Class


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..OnMouseDown Method
vArrowButton Class See Also Send Feedback
Raises the MouseDown event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vArrowButton Class


OnMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..OnMouseLeave Method
vArrowButton Class See Also Send Feedback
Raises the MouseLeave event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vArrowButton Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..OnMouseMove Method
vArrowButton Class See Also Send Feedback
Raises the MouseMove event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vArrowButton Class


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..OnMouseUp Method
vArrowButton Class See Also Send Feedback
Raises the MouseUp event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vArrowButton Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..OnPaint Method
vArrowButton Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vArrowButton Class


OnValueChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..OnValueChanged Method
vArrowButton Class See Also Send Feedback
Called when [value changed].

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnValueChanged()
Visual Basic
Protected Overridable Sub OnValueChanged
Visual C++
protected:
virtual void OnValueChanged()

See Also

vArrowButton Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..PerformLayout Method
vArrowButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vArrowButton Class
vArrowButton Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..ResumeLayout Method
vArrowButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vArrowButton Class
vArrowButton Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..RtlTranslateAlignment Method
vArrowButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vArrowButton Class
vArrowButton Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..Scale Method
vArrowButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vArrowButton Class
vArrowButton Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..Select Method
vArrowButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vArrowButton Class
vArrowButton Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..SetBounds Method
vArrowButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vArrowButton Class
vArrowButton Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..UpdateBounds Method
vArrowButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vArrowButton Class
vArrowButton Members


vArrowButton Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton Properties
vArrowButton Class See Also Send Feedback

The vArrowButton type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | ArrowDirection | Gets or sets the arrow direction.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the Maximum value of the vArrowButton control.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the Minimum value of the vArrowButton control.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the current position of the vArrowButton control.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vArrowButton Class


ArrowDirection Property

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..ArrowDirection Property
vArrowButton Class See Also Send Feedback
Gets or sets the arrow direction.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ArrowDirection ArrowDirection { get; set; }
Visual Basic
Public Property ArrowDirection As ArrowDirection
    Get
    Set
Visual C++
public:
property ArrowDirection ArrowDirection {
    ArrowDirection get ();
    void set (ArrowDirection value);
}

Field Value

The arrow direction.

See Also

vArrowButton Class


Enabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..Enabled Property
vArrowButton Class See Also Send Feedback
Gets or sets a value indicating whether the control can respond to user interaction.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Field Value

Return Value

true if the control can respond to user interaction; otherwise, false. The default is true.

See Also

vArrowButton Class


Maximum Property

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..Maximum Property
vArrowButton Class See Also Send Feedback
Gets or sets the Maximum value of the vArrowButton control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Maximum { get; set; }
Visual Basic
Public Property Maximum As Integer
    Get
    Set
Visual C++
public:
property int Maximum {
    int get ();
    void set (int value);
}

See Also

vArrowButton Class


Minimum Property

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..Minimum Property
vArrowButton Class See Also Send Feedback
Gets or sets the Minimum value of the vArrowButton control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Minimum { get; set; }
Visual Basic
Public Property Minimum As Integer
    Get
    Set
Visual C++
public:
property int Minimum {
    int get ();
    void set (int value);
}

See Also

vArrowButton Class


StyleKey Property

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..StyleKey Property
vArrowButton Class See Also Send Feedback
Gets or sets the style key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual string StyleKey { get; set; }
Visual Basic
Protected Overridable Property StyleKey As String
    Get
    Set
Visual C++
protected:
virtual property String^ StyleKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The style key.

See Also

vArrowButton Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..Theme Property
vArrowButton Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vArrowButton Class


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..Value Property
vArrowButton Class See Also Send Feedback
Gets or sets the current position of the vArrowButton control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Value { get; set; }
Visual Basic
Public Property Value As Integer
    Get
    Set
Visual C++
public:
property int Value {
    int get ();
    void set (int value);
}

Remarks

The minimum and maximum values of the Value property are specified by the Minimum and Maximum properties. This property enables you to increment or decrement the value of the vProgressBar.

See Also

vArrowButton Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..VIBlendTheme Property
vArrowButton Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vArrowButton Class


vArrowButton Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vArrowButton Events
vArrowButton Class See Also Send Feedback

The vArrowButton type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when value is changed
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vArrowButton Class


ValueChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vArrowButton..::..ValueChanged Event
vArrowButton Class See Also Send Feedback
Occurs when value is changed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ValueChanged
Visual Basic
Public Event ValueChanged As EventHandler
Visual C++
public:
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vArrowButton Class


vBubbleBar Class

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar Class
Members See Also Send Feedback
Represents a vBubbleBar control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vBubbleBar : Panel, IScrollableControlBase
Visual Basic
Public Class vBubbleBar _
    Inherits Panel _
    Implements IScrollableControlBase
Visual C++
public ref class vBubbleBar : public Panel,
    IScrollableControlBase

Remarks

A vBubbleBar can host and arrange multiple rectangular controls (usually buttons with images) in an animated selection list.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..Panel
VIBlend.WinForms.Controls..::..vBubbleBar

See Also

vBubbleBar Members


vBubbleBar Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar Members
vBubbleBar Class Constructors Methods Properties Events See Also Send Feedback

The vBubbleBar type exposes the following members.

Constructors

 | Name | Description
Public method | vBubbleBar | Initializes a new instance of the vBubbleBar class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAnimationFinished | Raises the AnimationFinished event
Protected method | OnAnimationStarted | Raises the AnimationStarted event
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlClicked | Raises the ControlClicked event
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides ScrollableControl..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | (Overrides Control..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoAdjustBounds | Gets or sets a value indicating whether to auto adjust control bounds
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundFillEnabled | Determines whether to fill the background of the panel control
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayBorder | Gets or sets a value indicating whether to display the panel's border
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsAnimating | Checks if the control is currently animating
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemsPosition | Gets or sets the items position.
Public property | ItemsSize | Gets or sets the width of an item.
Public property | ItemsSpacing | Determines the space in pixels between the items of the bubble bar
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Theme | Gets or sets the theme of the control
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AnimationFinished | Occurs when animation has finished
Public event | AnimationStarted | Occurs when animation has started
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlClicked | Occurs when a control is clicked
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vBubbleBar Class


vBubbleBar Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar Constructor
vBubbleBar Class See Also Send Feedback
Initializes a new instance of the vBubbleBar class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vBubbleBar()
Visual Basic
Public Sub New
Visual C++
public:
vBubbleBar()

See Also

vBubbleBar Class


vBubbleBar Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar Methods
vBubbleBar Class See Also Send Feedback

The vBubbleBar type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAnimationFinished | Raises the AnimationFinished event
Protected method | OnAnimationStarted | Raises the AnimationStarted event
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlClicked | Raises the ControlClicked event
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides ScrollableControl..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | (Overrides Control..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

See Also

vBubbleBar Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..AccessibilityNotifyClients Method
vBubbleBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vBubbleBar Class
vBubbleBar Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..BeginInvoke Method
vBubbleBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vBubbleBar Class
vBubbleBar Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..Dispose Method
vBubbleBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)

See Also

vBubbleBar Class
vBubbleBar Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..Dispose Method (Boolean)
vBubbleBar Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vBubbleBar Class
Dispose Overload


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..GetChildAtPoint Method
vBubbleBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vBubbleBar Class
vBubbleBar Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..Invalidate Method
vBubbleBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vBubbleBar Class
vBubbleBar Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..Invoke Method
vBubbleBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vBubbleBar Class
vBubbleBar Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..MemberwiseClone Method
vBubbleBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vBubbleBar Class
vBubbleBar Members


OnAnimationFinished Method

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..OnAnimationFinished Method
vBubbleBar Class See Also Send Feedback
Raises the AnimationFinished event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnAnimationFinished()
Visual Basic
Protected Overridable Sub OnAnimationFinished
Visual C++
protected:
virtual void OnAnimationFinished()

See Also

vBubbleBar Class


OnAnimationStarted Method

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..OnAnimationStarted Method
vBubbleBar Class See Also Send Feedback
Raises the AnimationStarted event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnAnimationStarted()
Visual Basic
Protected Overridable Sub OnAnimationStarted
Visual C++
protected:
virtual void OnAnimationStarted()

See Also

vBubbleBar Class


OnControlClicked Method

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..OnControlClicked Method
vBubbleBar Class See Also Send Feedback
Raises the ControlClicked event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnControlClicked(
    Control control
)
Visual Basic
Protected Overridable Sub OnControlClicked ( _
    control As Control _
)
Visual C++
protected:
virtual void OnControlClicked(
    Control^ control
)

Parameters

control
Type: System.Windows.Forms..::..Control

See Also

vBubbleBar Class


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..OnLayout Method
vBubbleBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
A LayoutEventArgs that contains the event data.

See Also

vBubbleBar Class


OnMouseEnter Method

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..OnMouseEnter Method
vBubbleBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseEnter(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseEnter ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseEnter(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vBubbleBar Class


OnMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..OnMouseLeave Method
vBubbleBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vBubbleBar Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..OnMouseMove Method
vBubbleBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vBubbleBar Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..OnPaint Method
vBubbleBar Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vBubbleBar Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..PerformLayout Method
vBubbleBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vBubbleBar Class
vBubbleBar Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..ResumeLayout Method
vBubbleBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vBubbleBar Class
vBubbleBar Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..RtlTranslateAlignment Method
vBubbleBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vBubbleBar Class
vBubbleBar Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..Scale Method
vBubbleBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vBubbleBar Class
vBubbleBar Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..Select Method
vBubbleBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vBubbleBar Class
vBubbleBar Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..SetBounds Method
vBubbleBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vBubbleBar Class
vBubbleBar Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..UpdateBounds Method
vBubbleBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vBubbleBar Class
vBubbleBar Members


vBubbleBar Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar Properties
vBubbleBar Class See Also Send Feedback

The vBubbleBar type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoAdjustBounds | Gets or sets a value indicating whether to auto adjust control bounds
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundFillEnabled | Determines whether to fill the background of the panel control
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayBorder | Gets or sets a value indicating whether to display the panel's border
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsAnimating | Checks if the control is currently animating
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemsPosition | Gets or sets the items position.
Public property | ItemsSize | Gets or sets the width of an item.
Public property | ItemsSpacing | Determines the space in pixels between the items of the bubble bar
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Theme | Gets or sets the theme of the control
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vBubbleBar Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..AllowAnimations Property
vBubbleBar Class See Also Send Feedback
Determines whether to use animations

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vBubbleBar Class


AutoAdjustBounds Property

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..AutoAdjustBounds Property
vBubbleBar Class See Also Send Feedback
Gets or sets a value indicating whether to auto adjust control bounds

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AutoAdjustBounds { get; set; }
Visual Basic
Public Property AutoAdjustBounds As Boolean
    Get
    Set
Visual C++
public:
property bool AutoAdjustBounds {
    bool get ();
    void set (bool value);
}

See Also

vBubbleBar Class


BackgroundFillEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..BackgroundFillEnabled Property
vBubbleBar Class See Also Send Feedback
Determines whether to fill the background of the panel control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool BackgroundFillEnabled { get; set; }
Visual Basic
Public Property BackgroundFillEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool BackgroundFillEnabled {
    bool get ();
    void set (bool value);
}

See Also

vBubbleBar Class


DisplayBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..DisplayBorder Property
vBubbleBar Class See Also Send Feedback
Gets or sets a value indicating whether to display the panel's border

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool DisplayBorder { get; set; }
Visual Basic
Public Property DisplayBorder As Boolean
    Get
    Set
Visual C++
public:
property bool DisplayBorder {
    bool get ();
    void set (bool value);
}

See Also

vBubbleBar Class


IsAnimating Property

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..IsAnimating Property
vBubbleBar Class See Also Send Feedback
Checks if the control is currently animating

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsAnimating { get; }
Visual Basic
Public ReadOnly Property IsAnimating As Boolean
    Get
Visual C++
public:
property bool IsAnimating {
    bool get ();
}

See Also

vBubbleBar Class


ItemsPosition Property

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..ItemsPosition Property
vBubbleBar Class See Also Send Feedback
Gets or sets the items position.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BubbleBarPosition ItemsPosition { get; set; }
Visual Basic
Public Property ItemsPosition As BubbleBarPosition
    Get
    Set
Visual C++
public:
property BubbleBarPosition ItemsPosition {
    BubbleBarPosition get ();
    void set (BubbleBarPosition value);
}

Field Value

The items position.

See Also

vBubbleBar Class


ItemsSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..ItemsSize Property
vBubbleBar Class See Also Send Feedback
Gets or sets the width of an item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ItemsSize { get; set; }
Visual Basic
Public Property ItemsSize As Integer
    Get
    Set
Visual C++
public:
property int ItemsSize {
    int get ();
    void set (int value);
}

Remarks

vBubbleBar control may contain multiple items. All items have equal width and height.

See Also

vBubbleBar Class


ItemsSpacing Property

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..ItemsSpacing Property
vBubbleBar Class See Also Send Feedback
Determines the space in pixels between the items of the bubble bar

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ItemsSpacing { get; set; }
Visual Basic
Public Property ItemsSpacing As Integer
    Get
    Set
Visual C++
public:
property int ItemsSpacing {
    int get ();
    void set (int value);
}

See Also

vBubbleBar Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..Theme Property
vBubbleBar Class See Also Send Feedback
Gets or sets the theme of the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vBubbleBar Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..VIBlendTheme Property
vBubbleBar Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vBubbleBar Class


vBubbleBar Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar Events
vBubbleBar Class See Also Send Feedback

The vBubbleBar type exposes the following members.

Events

 | Name | Description
Public event | AnimationFinished | Occurs when animation has finished
Public event | AnimationStarted | Occurs when animation has started
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlClicked | Occurs when a control is clicked
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vBubbleBar Class


AnimationFinished Event

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..AnimationFinished Event
vBubbleBar Class See Also Send Feedback
Occurs when animation has finished

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler AnimationFinished
Visual Basic
Public Event AnimationFinished As EventHandler
Visual C++
public:
 event EventHandler^ AnimationFinished {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vBubbleBar Class


AnimationStarted Event

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..AnimationStarted Event
vBubbleBar Class See Also Send Feedback
Occurs when animation has started

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler AnimationStarted
Visual Basic
Public Event AnimationStarted As EventHandler
Visual C++
public:
 event EventHandler^ AnimationStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vBubbleBar Class


ControlClicked Event

[image]

VIBlend Controls for WinForms Help Documentation
vBubbleBar..::..ControlClicked Event
vBubbleBar Class See Also Send Feedback
Occurs when a control is clicked

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ControlClicked
Visual Basic
Public Event ControlClicked As EventHandler
Visual C++
public:
 event EventHandler^ ControlClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vBubbleBar Class


vButton Class

[image]

VIBlend Controls for WinForms Help Documentation
vButton Class
Members See Also Send Feedback
Represents a vButton control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vButton : Button, IScrollableControlBase
Visual Basic
Public Class vButton _
    Inherits Button _
    Implements IScrollableControlBase
Visual C++
public ref class vButton : public Button,
    IScrollableControlBase

Remarks

A vButton control represents a standard button control raises an event when the user clicks it, and provides customizable visual appearance, and themes.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ButtonBase
System.Windows.Forms..::..Button
VIBlend.WinForms.Controls..::..vButton
VIBlend.WinForms.Controls..::..vCircularButton
VIBlend.WinForms.Controls..::..vFormButton
VIBlend.WinForms.Controls..::..vRepeatButton
VIBlend.WinForms.Controls..::..vRibbonButton
VIBlend.WinForms.Controls..::..vRibbonFooterButton
VIBlend.WinForms.Controls..::..vSplitButton
VIBlend.WinForms.Controls..::..vToggleButton

See Also

vButton Members


vButton Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton Members
vButton Class Constructors Methods Fields Properties Events See Also Send Feedback

The vButton type exposes the following members.

Constructors

 | Name | Description
Public method | vButton | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder |
Protected method | DrawControl | Draws the control.
Protected method | DrawFocusRectangle |
Protected method | DrawImageAndText |
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect |
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Overrides ButtonBase..::..OnEnabledChanged(EventArgs).)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Overrides ButtonBase..::..OnGotFocus(EventArgs).)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Overrides ButtonBase..::..OnLostFocus(EventArgs).)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Overrides ButtonBase..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Overrides Button..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Overrides ButtonBase..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Overrides Button..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Overrides ButtonBase..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

Fields

 | Name | Description
Protected field | buttonBorderStyle |
Protected field | opacity |
Protected field | paintHelper |
Protected field | theme |

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Overrides Control..::..Font.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled.
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control.
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border
Public property | PaintDefaultBorder | Gets or sets a value indicating whether to paint a border when the control state is default.
Public property | PaintDefaultFill | Gets or sets a value indicating whether to paint a background when the control state is default.
Public property | PaintFill | Gets or sets a value indicating whether to paint a background
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image
Public property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control.
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable
Public property | Theme | Gets or sets the theme of the control
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control.
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control.
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color.
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vButton Class


vButton Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vButton Constructor
vButton Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vButton()
Visual Basic
Public Sub New
Visual C++
public:
vButton()

See Also

vButton Class


vButton Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton Fields
vButton Class See Also Send Feedback

The vButton type exposes the following members.

Fields

 | Name | Description
Protected field | buttonBorderStyle |
Protected field | opacity |
Protected field | paintHelper |
Protected field | theme |

See Also

vButton Class


buttonBorderStyle Field

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..buttonBorderStyle Field
vButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected ButtonBorderStyle buttonBorderStyle
Visual Basic
Protected buttonBorderStyle As ButtonBorderStyle
Visual C++
protected:
ButtonBorderStyle buttonBorderStyle

See Also

vButton Class


opacity Field

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..opacity Field
vButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected float opacity
Visual Basic
Protected opacity As Single
Visual C++
protected:
float opacity

See Also

vButton Class


paintHelper Field

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..paintHelper Field
vButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected PaintHelper paintHelper
Visual Basic
Protected paintHelper As PaintHelper
Visual C++
protected:
PaintHelper^ paintHelper

See Also

vButton Class


theme Field

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..theme Field
vButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected ControlTheme theme
Visual Basic
Protected theme As ControlTheme
Visual C++
protected:
ControlTheme^ theme

See Also

vButton Class


vButton Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton Methods
vButton Class See Also Send Feedback

The vButton type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder |
Protected method | DrawControl | Draws the control.
Protected method | DrawFocusRectangle |
Protected method | DrawImageAndText |
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect |
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Overrides ButtonBase..::..OnEnabledChanged(EventArgs).)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Overrides ButtonBase..::..OnGotFocus(EventArgs).)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Overrides ButtonBase..::..OnLostFocus(EventArgs).)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Overrides ButtonBase..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Overrides Button..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Overrides ButtonBase..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Overrides Button..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Overrides ButtonBase..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

See Also

vButton Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton..::..AccessibilityNotifyClients Method
vButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vButton Class
vButton Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton..::..BeginInvoke Method
vButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vButton Class
vButton Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton..::..Dispose Method
vButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)

See Also

vButton Class
vButton Members


DrawBorder Method

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..DrawBorder Method
vButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual Rectangle DrawBorder(
    Graphics graphics,
    ControlState controlState,
    Rectangle drawRect
)
Visual Basic
Protected Overridable Function DrawBorder ( _
    graphics As Graphics, _
    controlState As ControlState, _
    drawRect As Rectangle _
) As Rectangle
Visual C++
protected:
virtual Rectangle DrawBorder(
    Graphics^ graphics,
    ControlState controlState,
    Rectangle drawRect
)

Parameters

graphics
Type: System.Drawing..::..Graphics
controlState
Type: ControlState
drawRect
Type: System.Drawing..::..Rectangle

See Also

vButton Class


DrawControl Method

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..DrawControl Method
vButton Class See Also Send Feedback
Draws the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DrawControl(
    Graphics graphics,
    Rectangle bounds,
    ControlState controlState,
    bool isFocused,
    byte roundedCornersMask
)
Visual Basic
Protected Overridable Sub DrawControl ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    controlState As ControlState, _
    isFocused As Boolean, _
    roundedCornersMask As Byte _
)
Visual C++
protected:
virtual void DrawControl(
    Graphics^ graphics,
    Rectangle bounds,
    ControlState controlState,
    bool isFocused,
    unsigned char roundedCornersMask
)

Parameters

graphics
Type: System.Drawing..::..Graphics
The graphics.
bounds
Type: System.Drawing..::..Rectangle
The bounds.
controlState
Type: ControlState
State of the control.
isFocused
Type: System..::..Boolean
if set to true [is focused].
roundedCornersMask
Type: System..::..Byte
The rounded corners mask.

See Also

vButton Class


DrawFocusRectangle Method

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..DrawFocusRectangle Method
vButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected Rectangle DrawFocusRectangle(
    Graphics graphics,
    bool isFocused,
    Rectangle drawRect,
    byte roundedCornersMask
)
Visual Basic
Protected Function DrawFocusRectangle ( _
    graphics As Graphics, _
    isFocused As Boolean, _
    drawRect As Rectangle, _
    roundedCornersMask As Byte _
) As Rectangle
Visual C++
protected:
Rectangle DrawFocusRectangle(
    Graphics^ graphics,
    bool isFocused,
    Rectangle drawRect,
    unsigned char roundedCornersMask
)

Parameters

graphics
Type: System.Drawing..::..Graphics
isFocused
Type: System..::..Boolean
drawRect
Type: System.Drawing..::..Rectangle
roundedCornersMask
Type: System..::..Byte

See Also

vButton Class


DrawImageAndText Method

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..DrawImageAndText Method
vButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DrawImageAndText(
    Graphics graphics,
    ControlState controlState,
    Rectangle imageTextRect
)
Visual Basic
Protected Overridable Sub DrawImageAndText ( _
    graphics As Graphics, _
    controlState As ControlState, _
    imageTextRect As Rectangle _
)
Visual C++
protected:
virtual void DrawImageAndText(
    Graphics^ graphics,
    ControlState controlState,
    Rectangle imageTextRect
)

Parameters

graphics
Type: System.Drawing..::..Graphics
controlState
Type: ControlState
imageTextRect
Type: System.Drawing..::..Rectangle

See Also

vButton Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton..::..GetChildAtPoint Method
vButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vButton Class
vButton Members


GetImageAndTextRect Method

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..GetImageAndTextRect Method
vButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected Rectangle GetImageAndTextRect(
    ref Rectangle bounds,
    ControlState controlState
)
Visual Basic
Protected Function GetImageAndTextRect ( _
    ByRef bounds As Rectangle, _
    controlState As ControlState _
) As Rectangle
Visual C++
protected:
Rectangle GetImageAndTextRect(
    Rectangle% bounds,
    ControlState controlState
)

Parameters

bounds
Type: System.Drawing..::..Rectangle %
controlState
Type: ControlState

See Also

vButton Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton..::..Invalidate Method
vButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vButton Class
vButton Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton..::..Invoke Method
vButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vButton Class
vButton Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton..::..MemberwiseClone Method
vButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vButton Class
vButton Members


OnEnabledChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..OnEnabledChanged Method
vButton Class See Also Send Feedback
Raises the EnabledChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnEnabledChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnEnabledChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnEnabledChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vButton Class


OnGotFocus Method

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..OnGotFocus Method
vButton Class See Also Send Feedback
Raises the GotFocus event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnGotFocus(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnGotFocus ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnGotFocus(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vButton Class


OnLostFocus Method

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..OnLostFocus Method
vButton Class See Also Send Feedback
Raises the OnLostFocus event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLostFocus(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnLostFocus ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLostFocus(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vButton Class


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..OnMouseDown Method
vButton Class See Also Send Feedback
Raises the OnMouseDown event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs mevent
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    mevent As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ mevent
) override

Parameters

mevent
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vButton Class


OnMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..OnMouseLeave Method
vButton Class See Also Send Feedback
Raises the OnMouseLeave event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
A EventArgs that contains the event data.

See Also

vButton Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..OnMouseMove Method
vButton Class See Also Send Feedback
Raises the OnMouseMove event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs mevent
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    mevent As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ mevent
) override

Parameters

mevent
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vButton Class


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..OnMouseUp Method
vButton Class See Also Send Feedback
Raises the OnMouseUp event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs mevent
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    mevent As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ mevent
) override

Parameters

mevent
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vButton Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..OnPaint Method
vButton Class See Also Send Feedback
Raises the OnPaint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vButton Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton..::..PerformLayout Method
vButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vButton Class
vButton Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton..::..ResumeLayout Method
vButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vButton Class
vButton Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton..::..RtlTranslateAlignment Method
vButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vButton Class
vButton Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton..::..Scale Method
vButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vButton Class
vButton Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton..::..Select Method
vButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vButton Class
vButton Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton..::..SetBounds Method
vButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vButton Class
vButton Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton..::..UpdateBounds Method
vButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vButton Class
vButton Members


vButton Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton Properties
vButton Class See Also Send Feedback

The vButton type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Overrides Control..::..Font.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled.
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control.
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border
Public property | PaintDefaultBorder | Gets or sets a value indicating whether to paint a border when the control state is default.
Public property | PaintDefaultFill | Gets or sets a value indicating whether to paint a background when the control state is default.
Public property | PaintFill | Gets or sets a value indicating whether to paint a background
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image
Public property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control.
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable
Public property | Theme | Gets or sets the theme of the control
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control.
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control.
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color.
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vButton Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..AllowAnimations Property
vButton Class See Also Send Feedback
Determines whether to use animations

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vButton Class


BorderStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..BorderStyle Property
vButton Class See Also Send Feedback
Gets or sets the border style of the button

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ButtonBorderStyle BorderStyle { get; set; }
Visual Basic
Public Overridable Property BorderStyle As ButtonBorderStyle
    Get
    Set
Visual C++
public:
virtual property ButtonBorderStyle BorderStyle {
    ButtonBorderStyle get ();
    void set (ButtonBorderStyle value);
}

See Also

vButton Class


Font Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..Font Property
vButton Class See Also Send Feedback
Gets or sets the font of the vButton

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Font Font { get; set; }
Visual Basic
Public Overrides Property Font As Font
    Get
    Set
Visual C++
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}

See Also

vButton Class


HighlightTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..HighlightTextColor Property
vButton Class See Also Send Feedback
Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color HighlightTextColor { get; set; }
Visual Basic
Public Property HighlightTextColor As Color
    Get
    Set
Visual C++
public:
property Color HighlightTextColor {
    Color get ();
    void set (Color value);
}

See Also

vButton Class


HoverEffectsEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..HoverEffectsEnabled Property
vButton Class See Also Send Feedback
Gets or sets a value indicating whether mouse hover effects are enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool HoverEffectsEnabled { get; set; }
Visual Basic
Public Property HoverEffectsEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool HoverEffectsEnabled {
    bool get ();
    void set (bool value);
}

See Also

vButton Class


ImageAbsolutePosition Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..ImageAbsolutePosition Property
vButton Class See Also Send Feedback
Gets or sets the position of the image on the button control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Point ImageAbsolutePosition { get; set; }
Visual Basic
Public Property ImageAbsolutePosition As Point
    Get
    Set
Visual C++
public:
property Point ImageAbsolutePosition {
    Point get ();
    void set (Point value);
}

Remarks

This property has effect only when UseAbsoluteImagePositioning is set to true.

See Also

vButton Class


Opacity Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..Opacity Property
vButton Class See Also Send Feedback
Gets or sets a value indicating whether this [!:BackGroundElement] has opacity.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public float Opacity { get; set; }
Visual Basic
Public Property Opacity As Single
    Get
    Set
Visual C++
public:
property float Opacity {
    float get ();
    void set (float value);
}

Field Value

true if has opacity draw with opacity; otherwise not, false.

See Also

vButton Class


PaintBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..PaintBorder Property
vButton Class See Also Send Feedback
Gets or sets a value indicating whether to paint a border

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintBorder { get; set; }
Visual Basic
Public Property PaintBorder As Boolean
    Get
    Set
Visual C++
public:
property bool PaintBorder {
    bool get ();
    void set (bool value);
}

Field Value

true if [paint border]; otherwise, false.

See Also

vButton Class


PaintDefaultBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..PaintDefaultBorder Property
vButton Class See Also Send Feedback
Gets or sets a value indicating whether to paint a border when the control state is default.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool PaintDefaultBorder { get; set; }
Visual Basic
Public Overridable Property PaintDefaultBorder As Boolean
    Get
    Set
Visual C++
public:
virtual property bool PaintDefaultBorder {
    bool get ();
    void set (bool value);
}

See Also

vButton Class


PaintDefaultFill Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..PaintDefaultFill Property
vButton Class See Also Send Feedback
Gets or sets a value indicating whether to paint a background when the control state is default.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool PaintDefaultFill { get; set; }
Visual Basic
Public Overridable Property PaintDefaultFill As Boolean
    Get
    Set
Visual C++
public:
virtual property bool PaintDefaultFill {
    bool get ();
    void set (bool value);
}

Field Value

true if [paint fill]; otherwise, false.

See Also

vButton Class


PaintFill Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..PaintFill Property
vButton Class See Also Send Feedback
Gets or sets a value indicating whether to paint a background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintFill { get; set; }
Visual Basic
Public Property PaintFill As Boolean
    Get
    Set
Visual C++
public:
property bool PaintFill {
    bool get ();
    void set (bool value);
}

Field Value

true if [paint fill]; otherwise, false.

See Also

vButton Class


PressedTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..PressedTextColor Property
vButton Class See Also Send Feedback
Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color PressedTextColor { get; set; }
Visual Basic
Public Property PressedTextColor As Color
    Get
    Set
Visual C++
public:
property Color PressedTextColor {
    Color get ();
    void set (Color value);
}

See Also

vButton Class


RoundedCornersMask Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..RoundedCornersMask Property
vButton Class See Also Send Feedback
Gets or sets the mask that determines which corners are rounded

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public byte RoundedCornersMask { get; set; }
Visual Basic
Public Property RoundedCornersMask As Byte
    Get
    Set
Visual C++
public:
property unsigned char RoundedCornersMask {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

vButton Class


RoundedCornersRadius Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..RoundedCornersRadius Property
vButton Class See Also Send Feedback
Gets or sets the rounded corners radius of the vButton control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int RoundedCornersRadius { get; set; }
Visual Basic
Public Property RoundedCornersRadius As Integer
    Get
    Set
Visual C++
public:
property int RoundedCornersRadius {
    int get ();
    void set (int value);
}

See Also

vButton Class


ShowFocusRectangle Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..ShowFocusRectangle Property
vButton Class See Also Send Feedback
Determines whether to show the focus rectangle when the button is Focused

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowFocusRectangle { get; set; }
Visual Basic
Public Property ShowFocusRectangle As Boolean
    Get
    Set
Visual C++
public:
property bool ShowFocusRectangle {
    bool get ();
    void set (bool value);
}

See Also

vButton Class


StretchImage Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..StretchImage Property
vButton Class See Also Send Feedback
Gets or sets a value indicating whether to stretch the associated Image

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool StretchImage { get; set; }
Visual Basic
Public Property StretchImage As Boolean
    Get
    Set
Visual C++
public:
property bool StretchImage {
    bool get ();
    void set (bool value);
}

Field Value

true if StretchImage; otherwise, false.

See Also

vButton Class


StyleKey Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..StyleKey Property
vButton Class See Also Send Feedback
Gets or sets the style key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual string StyleKey { get; set; }
Visual Basic
Public Overridable Property StyleKey As String
    Get
    Set
Visual C++
public:
virtual property String^ StyleKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The style key.

See Also

vButton Class


TextAbsolutePosition Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..TextAbsolutePosition Property
vButton Class See Also Send Feedback
Gets or sets the position of the text on the button control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Point TextAbsolutePosition { get; set; }
Visual Basic
Public Property TextAbsolutePosition As Point
    Get
    Set
Visual C++
public:
property Point TextAbsolutePosition {
    Point get ();
    void set (Point value);
}

Remarks

This property has effect only when UseAbsoluteTextPositioning is set to true.

See Also

vButton Class


TextWrap Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..TextWrap Property
vButton Class See Also Send Feedback
Gets or sets whether the button's text is wrappable

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool TextWrap { get; set; }
Visual Basic
Public Property TextWrap As Boolean
    Get
    Set
Visual C++
public:
property bool TextWrap {
    bool get ();
    void set (bool value);
}

See Also

vButton Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..Theme Property
vButton Class See Also Send Feedback
Gets or sets the theme of the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ControlTheme Theme { get; set; }
Visual Basic
Public Overridable Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
virtual property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vButton Class


UseAbsoluteImagePositioning Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..UseAbsoluteImagePositioning Property
vButton Class See Also Send Feedback
Gets or sets the positioning mode of the image on the button control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseAbsoluteImagePositioning { get; set; }
Visual Basic
Public Property UseAbsoluteImagePositioning As Boolean
    Get
    Set
Visual C++
public:
property bool UseAbsoluteImagePositioning {
    bool get ();
    void set (bool value);
}

See Also

vButton Class


UseAbsoluteTextPositioning Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..UseAbsoluteTextPositioning Property
vButton Class See Also Send Feedback
Gets or sets the positioning mode of the text on the button control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseAbsoluteTextPositioning { get; set; }
Visual Basic
Public Property UseAbsoluteTextPositioning As Boolean
    Get
    Set
Visual C++
public:
property bool UseAbsoluteTextPositioning {
    bool get ();
    void set (bool value);
}

See Also

vButton Class


UseThemeTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..UseThemeTextColor Property
vButton Class See Also Send Feedback
Gets or sets a value indicating whether to use the theme text color.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeTextColor { get; set; }
Visual Basic
Public Property UseThemeTextColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeTextColor {
    bool get ();
    void set (bool value);
}

See Also

vButton Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vButton..::..VIBlendTheme Property
vButton Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vButton Class


vButton Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vButton Events
vButton Class See Also Send Feedback

The vButton type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vButton Class


vCalendarView Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
vCalendarView Enumeration
See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum vCalendarView
Visual Basic
Public Enumeration vCalendarView
Visual C++
public enum class vCalendarView

Members

Member name | Description
Day |
Month |
Year |
Century |

See Also


vCheckBox Class

[image]

VIBlend Controls for WinForms Help Documentation
vCheckBox Class
Members See Also Send Feedback
Represents a vCheckBox control which allows the user to indicate whether an item is selected or not.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vCheckBox : CheckBox, IScrollableControlBase,
    INotifyPropertyChanged
Visual Basic
Public Class vCheckBox _
    Inherits CheckBox _
    Implements IScrollableControlBase, INotifyPropertyChanged
Visual C++
public ref class vCheckBox : public CheckBox,
    IScrollableControlBase, INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ButtonBase
System.Windows.Forms..::..CheckBox
VIBlend.WinForms.Controls..::..vCheckBox
VIBlend.WinForms.Controls..::..vFieldSet
VIBlend.WinForms.Controls..::..vOptionsFieldSet

See Also

vCheckBox Members


vCheckBox Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckBox Members
vCheckBox Class Constructors Methods Properties Events See Also Send Feedback

The vCheckBox type exposes the following members.

Constructors

 | Name | Description
Public method | vCheckBox | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the CheckBox control. (Inherited from CheckBox.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawCheck |
Protected method | DrawCheckBox |
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from CheckBox.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnCheckedChanged | Raises the CheckedChanged event. (Inherited from CheckBox.)
Protected method | OnCheckStateChanged | Raises the CheckStateChanged event. (Inherited from CheckBox.)
Protected method | OnClick | Raises the Click event. (Inherited from CheckBox.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from ButtonBase.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from ButtonBase.)
Protected method | OnHandleCreated | (Inherited from CheckBox.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from CheckBox.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus(EventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown(MouseEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseEnter | Raises the OnMouseEnter(EventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave(EventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Raises the OnMouseMove(MouseEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseUp | (Inherited from CheckBox.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint(PaintEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Public method | OnPropertyChanged | Called when a property is changed
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from ButtonBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from CheckBox.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the current CheckBox control. (Inherited from CheckBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ButtonBase.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Appearance | Gets or sets the value that determines the appearance of a CheckBox control. (Inherited from CheckBox.)
Public property | AutoCheck | Gets or set a value indicating whether the Checked or CheckState values and the CheckBox's appearance are automatically changed when the CheckBox is clicked. (Inherited from CheckBox.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckAlign | Gets or sets the horizontal and vertical alignment of the check mark on a CheckBox control. (Inherited from CheckBox.)
Public property | Checked | Gets or set a value indicating whether the CheckBox is in the checked state. (Inherited from CheckBox.)
Public property | CheckMarkColor | Gets or sets the color of the check mark
Public property | CheckMarkColorIntermidiate | Gets or sets the color of the check mark in intermediate state
Public property | CheckState | Gets or sets the state of the CheckBox. (Inherited from CheckBox.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from CheckBox.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from CheckBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAlign | Gets or sets the alignment of the text on the CheckBox control. (Inherited from CheckBox.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the checkbutton's text is wrappable
Public property | Theme | Gets or sets the theme of the control.
Public property | ThreeState | Gets or sets a value indicating whether the CheckBox will allow three check states rather than two. (Inherited from CheckBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeCheckMarkColors | Gets or sets whether the check mark will use the Theme colors or the colors defined through the control properties
Public property | UseThemeFont | Determines whether to use the Font from the Theme or a custom value
Public property | UseThemeTextColor | Determines whether to use the text color from the Theme or a custom value
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control to one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AppearanceChanged | Occurs when the value of the Appearance property changes. (Inherited from CheckBox.)
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | CheckedChanged | Occurs when the value of the Checked property changes. (Inherited from CheckBox.)
Public event | CheckStateChanged | Occurs when the value of the CheckState property changes. (Inherited from CheckBox.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the CheckBox control. (Inherited from CheckBox.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the CheckBox control. (Inherited from CheckBox.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property is changed.
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vCheckBox Class


vCheckBox Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vCheckBox Constructor
vCheckBox Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vCheckBox()
Visual Basic
Public Sub New
Visual C++
public:
vCheckBox()

See Also

vCheckBox Class


vCheckBox Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckBox Methods
vCheckBox Class See Also Send Feedback

The vCheckBox type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the CheckBox control. (Inherited from CheckBox.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawCheck |
Protected method | DrawCheckBox |
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from CheckBox.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnCheckedChanged | Raises the CheckedChanged event. (Inherited from CheckBox.)
Protected method | OnCheckStateChanged | Raises the CheckStateChanged event. (Inherited from CheckBox.)
Protected method | OnClick | Raises the Click event. (Inherited from CheckBox.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from ButtonBase.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from ButtonBase.)
Protected method | OnHandleCreated | (Inherited from CheckBox.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from CheckBox.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus(EventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown(MouseEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseEnter | Raises the OnMouseEnter(EventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave(EventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Raises the OnMouseMove(MouseEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseUp | (Inherited from CheckBox.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint(PaintEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Public method | OnPropertyChanged | Called when a property is changed
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from ButtonBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from CheckBox.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the current CheckBox control. (Inherited from CheckBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ButtonBase.)

See Also

vCheckBox Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..AccessibilityNotifyClients Method
vCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vCheckBox Class
vCheckBox Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..BeginInvoke Method
vCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vCheckBox Class
vCheckBox Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..Dispose Method
vCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)

See Also

vCheckBox Class
vCheckBox Members


DrawCheck Method

[image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..DrawCheck Method
vCheckBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void DrawCheck(
    Graphics graphics,
    int x,
    int y
)
Visual Basic
Protected Friend Overridable Sub DrawCheck ( _
    graphics As Graphics, _
    x As Integer, _
    y As Integer _
)
Visual C++
protected public:
virtual void DrawCheck(
    Graphics^ graphics,
    int x,
    int y
)

Parameters

graphics
Type: System.Drawing..::..Graphics
x
Type: System..::..Int32
y
Type: System..::..Int32

See Also

vCheckBox Class


DrawCheckBox Method

[image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..DrawCheckBox Method
vCheckBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void DrawCheckBox(
    Graphics g,
    Rectangle rect,
    ControlState controlState
)
Visual Basic
Protected Friend Overridable Sub DrawCheckBox ( _
    g As Graphics, _
    rect As Rectangle, _
    controlState As ControlState _
)
Visual C++
protected public:
virtual void DrawCheckBox(
    Graphics^ g,
    Rectangle rect,
    ControlState controlState
)

Parameters

g
Type: System.Drawing..::..Graphics
rect
Type: System.Drawing..::..Rectangle
controlState
Type: ControlState

See Also

vCheckBox Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..GetChildAtPoint Method
vCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vCheckBox Class
vCheckBox Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..Invalidate Method
vCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vCheckBox Class
vCheckBox Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..Invoke Method
vCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vCheckBox Class
vCheckBox Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..MemberwiseClone Method
vCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vCheckBox Class
vCheckBox Members


OnPropertyChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..OnPropertyChanged Method
vCheckBox Class See Also Send Feedback
Called when a property is changed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnPropertyChanged(
    string propertyName
)
Visual Basic
Public Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
public:
void OnPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String
Name of the property.

See Also

vCheckBox Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..PerformLayout Method
vCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vCheckBox Class
vCheckBox Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..ResumeLayout Method
vCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vCheckBox Class
vCheckBox Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..RtlTranslateAlignment Method
vCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vCheckBox Class
vCheckBox Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..Scale Method
vCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vCheckBox Class
vCheckBox Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..Select Method
vCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vCheckBox Class
vCheckBox Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..SetBounds Method
vCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vCheckBox Class
vCheckBox Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..UpdateBounds Method
vCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vCheckBox Class
vCheckBox Members


vCheckBox Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckBox Properties
vCheckBox Class See Also Send Feedback

The vCheckBox type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Appearance | Gets or sets the value that determines the appearance of a CheckBox control. (Inherited from CheckBox.)
Public property | AutoCheck | Gets or set a value indicating whether the Checked or CheckState values and the CheckBox's appearance are automatically changed when the CheckBox is clicked. (Inherited from CheckBox.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckAlign | Gets or sets the horizontal and vertical alignment of the check mark on a CheckBox control. (Inherited from CheckBox.)
Public property | Checked | Gets or set a value indicating whether the CheckBox is in the checked state. (Inherited from CheckBox.)
Public property | CheckMarkColor | Gets or sets the color of the check mark
Public property | CheckMarkColorIntermidiate | Gets or sets the color of the check mark in intermediate state
Public property | CheckState | Gets or sets the state of the CheckBox. (Inherited from CheckBox.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from CheckBox.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from CheckBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAlign | Gets or sets the alignment of the text on the CheckBox control. (Inherited from CheckBox.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the checkbutton's text is wrappable
Public property | Theme | Gets or sets the theme of the control.
Public property | ThreeState | Gets or sets a value indicating whether the CheckBox will allow three check states rather than two. (Inherited from CheckBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeCheckMarkColors | Gets or sets whether the check mark will use the Theme colors or the colors defined through the control properties
Public property | UseThemeFont | Determines whether to use the Font from the Theme or a custom value
Public property | UseThemeTextColor | Determines whether to use the text color from the Theme or a custom value
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control to one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vCheckBox Class


CheckMarkColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..CheckMarkColor Property
vCheckBox Class See Also Send Feedback
Gets or sets the color of the check mark

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color CheckMarkColor { get; set; }
Visual Basic
Public Property CheckMarkColor As Color
    Get
    Set
Visual C++
public:
property Color CheckMarkColor {
    Color get ();
    void set (Color value);
}

See Also

vCheckBox Class
vCheckBox..::..UseThemeCheckMarkColors


CheckMarkColorIntermidiate Property

[image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..CheckMarkColorIntermidiate Property
vCheckBox Class See Also Send Feedback
Gets or sets the color of the check mark in intermediate state

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color CheckMarkColorIntermidiate { get; set; }
Visual Basic
Public Property CheckMarkColorIntermidiate As Color
    Get
    Set
Visual C++
public:
property Color CheckMarkColorIntermidiate {
    Color get ();
    void set (Color value);
}

See Also

vCheckBox Class


TextWrap Property

[image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..TextWrap Property
vCheckBox Class See Also Send Feedback
Gets or sets whether the checkbutton's text is wrappable

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool TextWrap { get; set; }
Visual Basic
Public Property TextWrap As Boolean
    Get
    Set
Visual C++
public:
property bool TextWrap {
    bool get ();
    void set (bool value);
}

See Also

vCheckBox Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..Theme Property
vCheckBox Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vCheckBox Class


UseThemeCheckMarkColors Property

[image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..UseThemeCheckMarkColors Property
vCheckBox Class See Also Send Feedback
Gets or sets whether the check mark will use the Theme colors or the colors defined through the control properties

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeCheckMarkColors { get; set; }
Visual Basic
Public Property UseThemeCheckMarkColors As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeCheckMarkColors {
    bool get ();
    void set (bool value);
}

See Also

vCheckBox Class


UseThemeFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..UseThemeFont Property
vCheckBox Class See Also Send Feedback
Determines whether to use the Font from the Theme or a custom value

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeFont { get; set; }
Visual Basic
Public Property UseThemeFont As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeFont {
    bool get ();
    void set (bool value);
}

See Also

vCheckBox Class


UseThemeTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..UseThemeTextColor Property
vCheckBox Class See Also Send Feedback
Determines whether to use the text color from the Theme or a custom value

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeTextColor { get; set; }
Visual Basic
Public Property UseThemeTextColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeTextColor {
    bool get ();
    void set (bool value);
}

See Also

vCheckBox Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..VIBlendTheme Property
vCheckBox Class See Also Send Feedback
Gets or sets the theme of the control to one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vCheckBox Class


vCheckBox Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckBox Events
vCheckBox Class See Also Send Feedback

The vCheckBox type exposes the following members.

Events

 | Name | Description
Public event | AppearanceChanged | Occurs when the value of the Appearance property changes. (Inherited from CheckBox.)
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | CheckedChanged | Occurs when the value of the Checked property changes. (Inherited from CheckBox.)
Public event | CheckStateChanged | Occurs when the value of the CheckState property changes. (Inherited from CheckBox.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the CheckBox control. (Inherited from CheckBox.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the CheckBox control. (Inherited from CheckBox.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property is changed.
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vCheckBox Class


PropertyChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vCheckBox..::..PropertyChanged Event
vCheckBox Class See Also Send Feedback
Occurs when a property is changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

vCheckBox Class


vCheckedListBox Class

[image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox Class
Members See Also Send Feedback
Represents a vCheckedListBox control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vCheckedListBox : vListBox
Visual Basic
Public Class vCheckedListBox _
    Inherits vListBox
Visual C++
public ref class vCheckedListBox : public vListBox

Remarks

A vCheckedListBox displays a collection of items. The control allows you to use images, check boxes and detailed description for each item.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vListBox
VIBlend.WinForms.Controls..::..vCheckedListBox

See Also

vCheckedListBox Members


vCheckedListBox Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox Members
vCheckedListBox Class Constructors Methods Fields Properties Events See Also Send Feedback

The vCheckedListBox type exposes the following members.

Constructors

 | Name | Description
Public method | vCheckedListBox | Initializes a new instance of the vCheckedListBox class

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | BeginDrag | Begins the drag. (Inherited from vListBox.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Begins a batch of changes on the items collection (Inherited from vListBox.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CanSelectMultipleItems | Determines whether this instance can select multiple items. (Inherited from vListBox.)
Public method | CheckAllItems | Checks all items.
Public method | CheckItem | check item.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawCheckBox | Draws the check box.
Protected method | DrawDragFeedback(Graphics) | (Inherited from vListBox.)
Public method | DrawItem | (Inherited from vListBox.)
Public method | DrawItemImage | Draws the item image. (Inherited from vListBox.)
Public method | DrawListItemBackGroundAndBorder | Draws the list item back ground and border. (Inherited from vListBox.)
Public method | DrawListItemTextAndDescription | Draws the list item text and description. (Inherited from vListBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Protected method | EndDrag | Ends the drag. (Inherited from vListBox.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Begins a batch of changes on the items collection previously started by BeginUpdate() (Inherited from vListBox.)
Public method | EnsureVisible | Ensures that a list view item is visible. (Inherited from vListBox.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FilterItemOnProperty | (Inherited from vListBox.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindItem(Point) | Get ListItem at specific point. (Inherited from vListBox.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Protected method | GetBackFillColor | Gets the color of the back fill. (Inherited from vListBox.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemFont | Gets the item font. (Inherited from vListBox.)
Public method | GetItemForeColor | Gets the color of the item fore. (Inherited from vListBox.)
Public method | GetItemImage | Gets the item image. (Inherited from vListBox.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest | Performs a HitTest at a specific point (Inherited from vListBox.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from vListBox.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDataSourceChanged | Raises the DataSourceChanged event (Inherited from vListBox.)
Protected method | OnDisplayMemberChanged | Raises the OnDisplayMemberChanged event (Inherited from vListBox.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawItem | Raises the DrawItem event. (Inherited from vListBox.)
Protected method | OnDrawListItem | (Inherited from vListBox.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemChecked | Raises the [E:ItemChecked] event.
Protected method | OnItemChecking | Raises the [E:ItemChecking] event.
Protected method | OnItemDragEnded | (Inherited from vListBox.)
Protected method | OnItemDragEnding | (Inherited from vListBox.)
Protected method | OnItemDragging | (Inherited from vListBox.)
Protected method | OnItemDragStarted | (Inherited from vListBox.)
Protected method | OnItemDragStarting | (Inherited from vListBox.)
Protected method | OnItemFormat | Raises the [E:ItemFormat] event. (Inherited from vListBox.)
Protected method | OnItemMouseDown | Raises the [E:ItemMouseDown] event. (Inherited from vListBox.)
Protected method | OnItemMouseUp | Raises the [E:ItemMouseUp] event. (Inherited from vListBox.)
Protected method | OnKeyDown | (Overrides vListBox..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from vListBox.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vListBox.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Overrides vListBox..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vListBox.)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Inherited from vListBox.)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vListBox.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from vListBox.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vListBox.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from vListBox.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectedIndexChanged | Raises the SelectedIndexChanged event (Inherited from vListBox.)
Protected method | OnSelectedItemChanged | (Inherited from vListBox.)
Protected method | OnSelectedItemChanging | (Inherited from vListBox.)
Protected method | OnSelectedValueChanged | Raises the SelectedValueChanged event. (Inherited from vListBox.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | This member overrides Control.ProcessCmdKey. (Inherited from vListBox.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Public method | ReBind | Rebinds the ListBox control. (Inherited from vListBox.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveSort | Removes the sort. (Inherited from vListBox.)
Protected method | RenderListBox | Renders the list box. (Overrides vListBox..::..RenderListBox(PaintEventArgs).)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Reverse | Reverses this instance. (Inherited from vListBox.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetItemCore | Sets the object with the specified index in the derived class. (Inherited from vListBox.)
Protected method | SetItemsCore | Sets the object with the specified index in the derived class. (Inherited from vListBox.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort(Boolean) | Sorts the specified ascending. (Inherited from vListBox.)
Public method | Sort(IComparer<(Of <<'(ListItem>)>>)) | Sorts the specified comparer. (Inherited from vListBox.)
Public method | Sort(Comparison<(Of <<'(ListItem>)>>)) | Sorts the specified comparison. (Inherited from vListBox.)
Public method | StartDraggingTimer | Starts the dragging timer. (Inherited from vListBox.)
Public method | StopDraggingTimer | Stops the dragging timer. (Inherited from vListBox.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnCheckAllItems | Uns the check all items.
Public method | UnCheckItem | uncheck item.
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | backFill | (Inherited from vListBox.)
Protected field | displayBounds | (Inherited from vListBox.)
Protected field | isScrollBarUpdateRequired | (Inherited from vListBox.)
Protected field | theme | (Inherited from vListBox.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether animations are enabled for the control (Inherited from vListBox.)
Public property | AllowDragDrop | Gets or sets whether the Drag drop operation is enabled (Inherited from vListBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowMultipleSelection | Obsolete. Gets or sets a value indicating whether the multiple selection is enabled. (Inherited from vListBox.)
Public property | AllowSelection | Obsolete. Gets a value indicating whether the vListBox currently enables selection of list items. (Inherited from vListBox.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the BackColor property for the control (Inherited from vListBox.)
Public property | BackgroundImage | Gets or sets the BackgroundImage for the control (Inherited from vListBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the BorderColor of the ListBox. (Inherited from vListBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckOnClick | Gets or sets a value indicating whether the item is checked when it is clicked.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for the vListBox control (Inherited from vListBox.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayMember | Gets or sets the display member associated to the vListBox. (Inherited from vListBox.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropFeedbackColor | Gets or sets the color of the drop feedback. (Inherited from vListBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HotTrack | Gets or sets whether the items change in appearance when the mouse passes over them (Inherited from vListBox.)
Public property | ImageList | Gets or sets the images to display on the vListBox items. (Inherited from vListBox.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsUpdating | (Inherited from vListBox.)
Public property | ItemHeight | Gets or sets the height of the vListBox items. (Inherited from vListBox.)
Public property | Items | Gets the vListBox items collection. (Inherited from vListBox.)
Public property | ItemsSpacing | (Inherited from vListBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMaskListItem | Gets or sets the mask that determines which corners of a ListItem are rounded (Inherited from vListBox.)
Public property | RoundedCornersRadiusListItem | Gets or sets the rounded corners radius of the ListItems. (Inherited from vListBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the selected index. (Inherited from vListBox.)
Public property | SelectedIndices | Gets the collection of selected indices. (Inherited from vListBox.)
Public property | SelectedItem | Gets or sets the selected item. (Inherited from vListBox.)
Public property | SelectedItems | Gets the collection of selected items. (Inherited from vListBox.)
Public property | SelectedValue | (Inherited from vListBox.)
Public property | SelectionMode | Gets or sets the selection mode. (Overrides vListBox..::..SelectionMode.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmartScrollEnabled | Determines whether to use Smart scrolling (Inherited from vListBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the Theme of the control. (Inherited from vListBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property. (Inherited from vListBox.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the BorderColor (Inherited from vListBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets a string that specifies the property of the data source from which to draw the value. (Inherited from vListBox.)
Public property | VIBlendScrollBarsTheme | Gets or sets the theme of the treeview scrollbars using one of the built-in themes. (Inherited from vListBox.)
Public property | VIBlendTheme | Gets or sets the theme of the control to one of the built-in themes. (Inherited from vListBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs Data Source is changed. (Inherited from vListBox.)
Public event | DisplayMemberChanged | Occurs when the DisplayMember has been changed. (Inherited from vListBox.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawListItem | Occurs when an item is being painted. (Inherited from vListBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemChecked | Occurs when item is checked.
Public event | ItemChecking | Occurs when item's check state is changing.
Public event | ItemDragEnded | Occurs when item's drag operation has ended. (Inherited from vListBox.)
Public event | ItemDragEnding | Occurs when item's drag operation is ending. (Inherited from vListBox.)
Public event | ItemDragging | Occurs when the drag item changes its location. (Inherited from vListBox.)
Public event | ItemDragStarted | Occurs when item's drag operation has started. (Inherited from vListBox.)
Public event | ItemDragStarting | Occurs when item's drag operation is starting. (Inherited from vListBox.)
Public event | ItemFormat | Occurs when the control's DataSource property is set and before the item is added to the Items collection. You can use this event to format the item's string. (Inherited from vListBox.)
Public event | ItemMouseDown | Occurs when the mouse is clicked over a ListItem. (Inherited from vListBox.)
Public event | ItemMouseUp | Occurs when the mouse is clicked over a ListItem. (Inherited from vListBox.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the selected index changes (Inherited from vListBox.)
Public event | SelectedItemChanged | occurs when the selection is changed. (Inherited from vListBox.)
Public event | SelectedItemChanging | Occurs when the selection is changing. (Inherited from vListBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue has changed. (Inherited from vListBox.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vCheckedListBox Class


vCheckedListBox Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox Constructor
vCheckedListBox Class See Also Send Feedback
Initializes a new instance of the vCheckedListBox class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vCheckedListBox()
Visual Basic
Public Sub New
Visual C++
public:
vCheckedListBox()

See Also

vCheckedListBox Class


vCheckedListBox Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox Fields
vCheckedListBox Class See Also Send Feedback

The vCheckedListBox type exposes the following members.

Fields

 | Name | Description
Protected field | backFill | (Inherited from vListBox.)
Protected field | displayBounds | (Inherited from vListBox.)
Protected field | isScrollBarUpdateRequired | (Inherited from vListBox.)
Protected field | theme | (Inherited from vListBox.)

See Also

vCheckedListBox Class


vCheckedListBox Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox Methods
vCheckedListBox Class See Also Send Feedback

The vCheckedListBox type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | BeginDrag | Begins the drag. (Inherited from vListBox.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Begins a batch of changes on the items collection (Inherited from vListBox.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CanSelectMultipleItems | Determines whether this instance can select multiple items. (Inherited from vListBox.)
Public method | CheckAllItems | Checks all items.
Public method | CheckItem | check item.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawCheckBox | Draws the check box.
Protected method | DrawDragFeedback(Graphics) | (Inherited from vListBox.)
Public method | DrawItem | (Inherited from vListBox.)
Public method | DrawItemImage | Draws the item image. (Inherited from vListBox.)
Public method | DrawListItemBackGroundAndBorder | Draws the list item back ground and border. (Inherited from vListBox.)
Public method | DrawListItemTextAndDescription | Draws the list item text and description. (Inherited from vListBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Protected method | EndDrag | Ends the drag. (Inherited from vListBox.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Begins a batch of changes on the items collection previously started by BeginUpdate() (Inherited from vListBox.)
Public method | EnsureVisible | Ensures that a list view item is visible. (Inherited from vListBox.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FilterItemOnProperty | (Inherited from vListBox.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindItem(Point) | Get ListItem at specific point. (Inherited from vListBox.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Protected method | GetBackFillColor | Gets the color of the back fill. (Inherited from vListBox.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemFont | Gets the item font. (Inherited from vListBox.)
Public method | GetItemForeColor | Gets the color of the item fore. (Inherited from vListBox.)
Public method | GetItemImage | Gets the item image. (Inherited from vListBox.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest | Performs a HitTest at a specific point (Inherited from vListBox.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from vListBox.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDataSourceChanged | Raises the DataSourceChanged event (Inherited from vListBox.)
Protected method | OnDisplayMemberChanged | Raises the OnDisplayMemberChanged event (Inherited from vListBox.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawItem | Raises the DrawItem event. (Inherited from vListBox.)
Protected method | OnDrawListItem | (Inherited from vListBox.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemChecked | Raises the [E:ItemChecked] event.
Protected method | OnItemChecking | Raises the [E:ItemChecking] event.
Protected method | OnItemDragEnded | (Inherited from vListBox.)
Protected method | OnItemDragEnding | (Inherited from vListBox.)
Protected method | OnItemDragging | (Inherited from vListBox.)
Protected method | OnItemDragStarted | (Inherited from vListBox.)
Protected method | OnItemDragStarting | (Inherited from vListBox.)
Protected method | OnItemFormat | Raises the [E:ItemFormat] event. (Inherited from vListBox.)
Protected method | OnItemMouseDown | Raises the [E:ItemMouseDown] event. (Inherited from vListBox.)
Protected method | OnItemMouseUp | Raises the [E:ItemMouseUp] event. (Inherited from vListBox.)
Protected method | OnKeyDown | (Overrides vListBox..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from vListBox.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vListBox.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Overrides vListBox..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vListBox.)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Inherited from vListBox.)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vListBox.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from vListBox.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vListBox.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from vListBox.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectedIndexChanged | Raises the SelectedIndexChanged event (Inherited from vListBox.)
Protected method | OnSelectedItemChanged | (Inherited from vListBox.)
Protected method | OnSelectedItemChanging | (Inherited from vListBox.)
Protected method | OnSelectedValueChanged | Raises the SelectedValueChanged event. (Inherited from vListBox.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | This member overrides Control.ProcessCmdKey. (Inherited from vListBox.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Public method | ReBind | Rebinds the ListBox control. (Inherited from vListBox.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveSort | Removes the sort. (Inherited from vListBox.)
Protected method | RenderListBox | Renders the list box. (Overrides vListBox..::..RenderListBox(PaintEventArgs).)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Reverse | Reverses this instance. (Inherited from vListBox.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetItemCore | Sets the object with the specified index in the derived class. (Inherited from vListBox.)
Protected method | SetItemsCore | Sets the object with the specified index in the derived class. (Inherited from vListBox.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort(Boolean) | Sorts the specified ascending. (Inherited from vListBox.)
Public method | Sort(IComparer<(Of <<'(ListItem>)>>)) | Sorts the specified comparer. (Inherited from vListBox.)
Public method | Sort(Comparison<(Of <<'(ListItem>)>>)) | Sorts the specified comparison. (Inherited from vListBox.)
Public method | StartDraggingTimer | Starts the dragging timer. (Inherited from vListBox.)
Public method | StopDraggingTimer | Stops the dragging timer. (Inherited from vListBox.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnCheckAllItems | Uns the check all items.
Public method | UnCheckItem | uncheck item.
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vCheckedListBox Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..AccessibilityNotifyClients Method
vCheckedListBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vCheckedListBox Class
vCheckedListBox Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..BeginInvoke Method
vCheckedListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vCheckedListBox Class
vCheckedListBox Members


CheckAllItems Method

[image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..CheckAllItems Method
vCheckedListBox Class See Also Send Feedback
Checks all items.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void CheckAllItems()
Visual Basic
Public Sub CheckAllItems
Visual C++
public:
void CheckAllItems()

See Also

vCheckedListBox Class


CheckItem Method

[image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..CheckItem Method
vCheckedListBox Class See Also Send Feedback
check item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void CheckItem(
    ListItem item
)
Visual Basic
Public Sub CheckItem ( _
    item As ListItem _
)
Visual C++
public:
void CheckItem(
    ListItem^ item
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..ListItem

See Also

vCheckedListBox Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..Dispose Method
vCheckedListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vCheckedListBox Class
vCheckedListBox Members


DrawCheckBox Method

[image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..DrawCheckBox Method
vCheckedListBox Class See Also Send Feedback
Draws the check box.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void DrawCheckBox(
    Graphics g,
    Rectangle rect,
    bool isEnabled,
    bool isMouseOver,
    bool isFocused,
    bool drawLine,
    CheckState checkState
)
Visual Basic
Protected Friend Overridable Sub DrawCheckBox ( _
    g As Graphics, _
    rect As Rectangle, _
    isEnabled As Boolean, _
    isMouseOver As Boolean, _
    isFocused As Boolean, _
    drawLine As Boolean, _
    checkState As CheckState _
)
Visual C++
protected public:
virtual void DrawCheckBox(
    Graphics^ g,
    Rectangle rect,
    bool isEnabled,
    bool isMouseOver,
    bool isFocused,
    bool drawLine,
    CheckState checkState
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
rect
Type: System.Drawing..::..Rectangle
The rect.
isEnabled
Type: System..::..Boolean
if set to true [is enabled].
isMouseOver
Type: System..::..Boolean
if set to true [is mouse over].
isFocused
Type: System..::..Boolean
if set to true [is focused].
drawLine
Type: System..::..Boolean
if set to true [draw line].
checkState
Type: System.Windows.Forms..::..CheckState
State of the check.

See Also

vCheckedListBox Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..GetChildAtPoint Method
vCheckedListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vCheckedListBox Class
vCheckedListBox Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..Invalidate Method
vCheckedListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vCheckedListBox Class
vCheckedListBox Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..Invoke Method
vCheckedListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vCheckedListBox Class
vCheckedListBox Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..MemberwiseClone Method
vCheckedListBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vCheckedListBox Class
vCheckedListBox Members


OnItemChecked Method

[image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..OnItemChecked Method
vCheckedListBox Class See Also Send Feedback
Raises the [E:ItemChecked] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnItemChecked(
    ItemCheckChangedEventArgs args
)
Visual Basic
Protected Overridable Sub OnItemChecked ( _
    args As ItemCheckChangedEventArgs _
)
Visual C++
protected:
virtual void OnItemChecked(
    ItemCheckChangedEventArgs^ args
)

Parameters

args
Type: ItemCheckChangedEventArgs
The ItemCheckChangedEventArgs instance containing the event data.

See Also

vCheckedListBox Class


OnItemChecking Method

[image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..OnItemChecking Method
vCheckedListBox Class See Also Send Feedback
Raises the [E:ItemChecking] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnItemChecking(
    ItemCheckChangingEventArgs args
)
Visual Basic
Protected Overridable Sub OnItemChecking ( _
    args As ItemCheckChangingEventArgs _
)
Visual C++
protected:
virtual void OnItemChecking(
    ItemCheckChangingEventArgs^ args
)

Parameters

args
Type: ItemCheckChangingEventArgs
The ItemCheckChangingEventArgs instance containing the event data.

See Also

vCheckedListBox Class


OnKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..OnKeyDown Method
vCheckedListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs

See Also

vCheckedListBox Class


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..OnMouseDown Method
vCheckedListBox Class See Also Send Feedback
Raises the OnMouseDown event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs mevent
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    mevent As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ mevent
) override

Parameters

mevent
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vCheckedListBox Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..PerformLayout Method
vCheckedListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vCheckedListBox Class
vCheckedListBox Members


RenderListBox Method

[image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..RenderListBox Method
vCheckedListBox Class See Also Send Feedback
Renders the list box.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void RenderListBox(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub RenderListBox ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void RenderListBox(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
The PaintEventArgs instance containing the event data.

See Also

vCheckedListBox Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..ResumeLayout Method
vCheckedListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vCheckedListBox Class
vCheckedListBox Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..RtlTranslateAlignment Method
vCheckedListBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vCheckedListBox Class
vCheckedListBox Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..Scale Method
vCheckedListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vCheckedListBox Class
vCheckedListBox Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..Select Method
vCheckedListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vCheckedListBox Class
vCheckedListBox Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..SetBounds Method
vCheckedListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vCheckedListBox Class
vCheckedListBox Members


Sort Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..Sort Method
vCheckedListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort(Boolean) | Sorts the specified ascending. (Inherited from vListBox.)
Public method | Sort(IComparer<(Of <<'(ListItem>)>>)) | Sorts the specified comparer. (Inherited from vListBox.)
Public method | Sort(Comparison<(Of <<'(ListItem>)>>)) | Sorts the specified comparison. (Inherited from vListBox.)

See Also

vCheckedListBox Class
vCheckedListBox Members


UnCheckAllItems Method

[image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..UnCheckAllItems Method
vCheckedListBox Class See Also Send Feedback
Uns the check all items.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void UnCheckAllItems()
Visual Basic
Public Sub UnCheckAllItems
Visual C++
public:
void UnCheckAllItems()

See Also

vCheckedListBox Class


UnCheckItem Method

[image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..UnCheckItem Method
vCheckedListBox Class See Also Send Feedback
uncheck item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void UnCheckItem(
    ListItem item
)
Visual Basic
Public Sub UnCheckItem ( _
    item As ListItem _
)
Visual C++
public:
void UnCheckItem(
    ListItem^ item
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..ListItem

See Also

vCheckedListBox Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..UpdateBounds Method
vCheckedListBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vCheckedListBox Class
vCheckedListBox Members


vCheckedListBox Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox Properties
vCheckedListBox Class See Also Send Feedback

The vCheckedListBox type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether animations are enabled for the control (Inherited from vListBox.)
Public property | AllowDragDrop | Gets or sets whether the Drag drop operation is enabled (Inherited from vListBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowMultipleSelection | Obsolete. Gets or sets a value indicating whether the multiple selection is enabled. (Inherited from vListBox.)
Public property | AllowSelection | Obsolete. Gets a value indicating whether the vListBox currently enables selection of list items. (Inherited from vListBox.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the BackColor property for the control (Inherited from vListBox.)
Public property | BackgroundImage | Gets or sets the BackgroundImage for the control (Inherited from vListBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the BorderColor of the ListBox. (Inherited from vListBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckOnClick | Gets or sets a value indicating whether the item is checked when it is clicked.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for the vListBox control (Inherited from vListBox.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayMember | Gets or sets the display member associated to the vListBox. (Inherited from vListBox.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropFeedbackColor | Gets or sets the color of the drop feedback. (Inherited from vListBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HotTrack | Gets or sets whether the items change in appearance when the mouse passes over them (Inherited from vListBox.)
Public property | ImageList | Gets or sets the images to display on the vListBox items. (Inherited from vListBox.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsUpdating | (Inherited from vListBox.)
Public property | ItemHeight | Gets or sets the height of the vListBox items. (Inherited from vListBox.)
Public property | Items | Gets the vListBox items collection. (Inherited from vListBox.)
Public property | ItemsSpacing | (Inherited from vListBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMaskListItem | Gets or sets the mask that determines which corners of a ListItem are rounded (Inherited from vListBox.)
Public property | RoundedCornersRadiusListItem | Gets or sets the rounded corners radius of the ListItems. (Inherited from vListBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the selected index. (Inherited from vListBox.)
Public property | SelectedIndices | Gets the collection of selected indices. (Inherited from vListBox.)
Public property | SelectedItem | Gets or sets the selected item. (Inherited from vListBox.)
Public property | SelectedItems | Gets the collection of selected items. (Inherited from vListBox.)
Public property | SelectedValue | (Inherited from vListBox.)
Public property | SelectionMode | Gets or sets the selection mode. (Overrides vListBox..::..SelectionMode.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmartScrollEnabled | Determines whether to use Smart scrolling (Inherited from vListBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the Theme of the control. (Inherited from vListBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property. (Inherited from vListBox.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the BorderColor (Inherited from vListBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets a string that specifies the property of the data source from which to draw the value. (Inherited from vListBox.)
Public property | VIBlendScrollBarsTheme | Gets or sets the theme of the treeview scrollbars using one of the built-in themes. (Inherited from vListBox.)
Public property | VIBlendTheme | Gets or sets the theme of the control to one of the built-in themes. (Inherited from vListBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vCheckedListBox Class


CheckOnClick Property

[image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..CheckOnClick Property
vCheckedListBox Class See Also Send Feedback
Gets or sets a value indicating whether the item is checked when it is clicked.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool CheckOnClick { get; set; }
Visual Basic
Public Property CheckOnClick As Boolean
    Get
    Set
Visual C++
public:
property bool CheckOnClick {
    bool get ();
    void set (bool value);
}

See Also

vCheckedListBox Class


SelectionMode Property

[image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..SelectionMode Property
vCheckedListBox Class See Also Send Feedback
Gets or sets the selection mode.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override SelectionMode SelectionMode { get; set; }
Visual Basic
Public Overrides Property SelectionMode As SelectionMode
    Get
    Set
Visual C++
public:
virtual property SelectionMode SelectionMode {
    SelectionMode get () override;
    void set (SelectionMode value) override;
}

Field Value

The selection mode.

See Also

vCheckedListBox Class


vCheckedListBox Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox Events
vCheckedListBox Class See Also Send Feedback

The vCheckedListBox type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs Data Source is changed. (Inherited from vListBox.)
Public event | DisplayMemberChanged | Occurs when the DisplayMember has been changed. (Inherited from vListBox.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawListItem | Occurs when an item is being painted. (Inherited from vListBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemChecked | Occurs when item is checked.
Public event | ItemChecking | Occurs when item's check state is changing.
Public event | ItemDragEnded | Occurs when item's drag operation has ended. (Inherited from vListBox.)
Public event | ItemDragEnding | Occurs when item's drag operation is ending. (Inherited from vListBox.)
Public event | ItemDragging | Occurs when the drag item changes its location. (Inherited from vListBox.)
Public event | ItemDragStarted | Occurs when item's drag operation has started. (Inherited from vListBox.)
Public event | ItemDragStarting | Occurs when item's drag operation is starting. (Inherited from vListBox.)
Public event | ItemFormat | Occurs when the control's DataSource property is set and before the item is added to the Items collection. You can use this event to format the item's string. (Inherited from vListBox.)
Public event | ItemMouseDown | Occurs when the mouse is clicked over a ListItem. (Inherited from vListBox.)
Public event | ItemMouseUp | Occurs when the mouse is clicked over a ListItem. (Inherited from vListBox.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the selected index changes (Inherited from vListBox.)
Public event | SelectedItemChanged | occurs when the selection is changed. (Inherited from vListBox.)
Public event | SelectedItemChanging | Occurs when the selection is changing. (Inherited from vListBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue has changed. (Inherited from vListBox.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vCheckedListBox Class


ItemChecked Event

[image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..ItemChecked Event
vCheckedListBox Class See Also Send Feedback
Occurs when item is checked.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event ItemCheckChangedEventHandler ItemChecked
Visual Basic
Public Event ItemChecked As ItemCheckChangedEventHandler
Visual C++
public:
 event ItemCheckChangedEventHandler^ ItemChecked {
    void add (ItemCheckChangedEventHandler^ value);
    void remove (ItemCheckChangedEventHandler^ value);
}

See Also

vCheckedListBox Class


ItemChecking Event

[image]

VIBlend Controls for WinForms Help Documentation
vCheckedListBox..::..ItemChecking Event
vCheckedListBox Class See Also Send Feedback
Occurs when item's check state is changing.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event ItemCheckChangingEventHandler ItemChecking
Visual Basic
Public Event ItemChecking As ItemCheckChangingEventHandler
Visual C++
public:
 event ItemCheckChangingEventHandler^ ItemChecking {
    void add (ItemCheckChangingEventHandler^ value);
    void remove (ItemCheckChangingEventHandler^ value);
}

See Also

vCheckedListBox Class


vCircularButton Class

[image]

VIBlend Controls for WinForms Help Documentation
vCircularButton Class
Members See Also Send Feedback
Represents a vCircularButton control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vCircularButton : vButton
Visual Basic
Public Class vCircularButton _
    Inherits vButton
Visual C++
public ref class vCircularButton : public vButton

Remarks

A circular button control raises an event when the user clicks it, and provides customizable visual appearance, and themes.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ButtonBase
System.Windows.Forms..::..Button
VIBlend.WinForms.Controls..::..vButton
VIBlend.WinForms.Controls..::..vCircularButton

See Also

vCircularButton Members


vCircularButton Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton Members
vCircularButton Class Constructors Methods Fields Properties Events See Also Send Feedback

The vCircularButton type exposes the following members.

Constructors

 | Name | Description
Public method | vCircularButton | vCircularButton constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder | (Inherited from vButton.)
Protected method | DrawControl | (Overrides vButton..::..DrawControl(Graphics, Rectangle, ControlState, Boolean, Byte).)
Protected method | DrawFocusRectangle | (Inherited from vButton.)
Protected method | DrawImageAndText | (Inherited from vButton.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect | (Inherited from vButton.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from vButton.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from vButton.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vButton.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Inherited from vButton.)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vButton.)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Inherited from vButton.)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vButton.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vButton.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

Fields

 | Name | Description
Protected field | buttonBorderStyle | (Inherited from vButton.)
Protected field | opacity | (Inherited from vButton.)
Protected field | paintHelper | (Inherited from vButton.)
Protected field | theme | (Inherited from vButton.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vButton.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button (Inherited from vButton.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Inherited from vButton.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled. (Inherited from vButton.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control. (Inherited from vButton.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity. (Inherited from vButton.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vButton.)
Public property | PaintDefaultBorder | Gets or sets a value indicating whether to paint a border when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultFill | Gets or sets a value indicating whether to paint a background when the control state is default. (Inherited from vButton.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vButton.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded (Inherited from vButton.)
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control. (Inherited from vButton.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused (Inherited from vButton.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image (Inherited from vButton.)
Public property | StyleKey | Gets or sets the style key. (Inherited from vButton.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control. (Inherited from vButton.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable (Inherited from vButton.)
Public property | Theme | Gets or sets the theme of the control (Overrides vButton..::..Theme.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control. (Inherited from vButton.)
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control. (Inherited from vButton.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color. (Inherited from vButton.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vButton.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vCircularButton Class


vCircularButton Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vCircularButton Constructor
vCircularButton Class See Also Send Feedback
vCircularButton constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vCircularButton()
Visual Basic
Public Sub New
Visual C++
public:
vCircularButton()

See Also

vCircularButton Class


vCircularButton Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton Fields
vCircularButton Class See Also Send Feedback

The vCircularButton type exposes the following members.

Fields

 | Name | Description
Protected field | buttonBorderStyle | (Inherited from vButton.)
Protected field | opacity | (Inherited from vButton.)
Protected field | paintHelper | (Inherited from vButton.)
Protected field | theme | (Inherited from vButton.)

See Also

vCircularButton Class


vCircularButton Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton Methods
vCircularButton Class See Also Send Feedback

The vCircularButton type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder | (Inherited from vButton.)
Protected method | DrawControl | (Overrides vButton..::..DrawControl(Graphics, Rectangle, ControlState, Boolean, Byte).)
Protected method | DrawFocusRectangle | (Inherited from vButton.)
Protected method | DrawImageAndText | (Inherited from vButton.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect | (Inherited from vButton.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from vButton.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from vButton.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vButton.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Inherited from vButton.)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vButton.)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Inherited from vButton.)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vButton.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vButton.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

See Also

vCircularButton Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton..::..AccessibilityNotifyClients Method
vCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vCircularButton Class
vCircularButton Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton..::..BeginInvoke Method
vCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vCircularButton Class
vCircularButton Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton..::..Dispose Method
vCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)

See Also

vCircularButton Class
vCircularButton Members


DrawControl Method

[image]

VIBlend Controls for WinForms Help Documentation
vCircularButton..::..DrawControl Method
vCircularButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void DrawControl(
    Graphics graphics,
    Rectangle bounds,
    ControlState controlState,
    bool isFocused,
    byte roundedCornersMask
)
Visual Basic
Protected Overrides Sub DrawControl ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    controlState As ControlState, _
    isFocused As Boolean, _
    roundedCornersMask As Byte _
)
Visual C++
protected:
virtual void DrawControl(
    Graphics^ graphics,
    Rectangle bounds,
    ControlState controlState,
    bool isFocused,
    unsigned char roundedCornersMask
) override

Parameters

graphics
Type: System.Drawing..::..Graphics
bounds
Type: System.Drawing..::..Rectangle
controlState
Type: ControlState
isFocused
Type: System..::..Boolean
roundedCornersMask
Type: System..::..Byte

See Also

vCircularButton Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton..::..GetChildAtPoint Method
vCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vCircularButton Class
vCircularButton Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton..::..Invalidate Method
vCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vCircularButton Class
vCircularButton Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton..::..Invoke Method
vCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vCircularButton Class
vCircularButton Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton..::..MemberwiseClone Method
vCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vCircularButton Class
vCircularButton Members


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton..::..PerformLayout Method
vCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vCircularButton Class
vCircularButton Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton..::..ResumeLayout Method
vCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vCircularButton Class
vCircularButton Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton..::..RtlTranslateAlignment Method
vCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vCircularButton Class
vCircularButton Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton..::..Scale Method
vCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vCircularButton Class
vCircularButton Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton..::..Select Method
vCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vCircularButton Class
vCircularButton Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton..::..SetBounds Method
vCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vCircularButton Class
vCircularButton Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton..::..UpdateBounds Method
vCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vCircularButton Class
vCircularButton Members


vCircularButton Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton Properties
vCircularButton Class See Also Send Feedback

The vCircularButton type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vButton.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button (Inherited from vButton.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Inherited from vButton.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled. (Inherited from vButton.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control. (Inherited from vButton.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity. (Inherited from vButton.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vButton.)
Public property | PaintDefaultBorder | Gets or sets a value indicating whether to paint a border when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultFill | Gets or sets a value indicating whether to paint a background when the control state is default. (Inherited from vButton.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vButton.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded (Inherited from vButton.)
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control. (Inherited from vButton.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused (Inherited from vButton.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image (Inherited from vButton.)
Public property | StyleKey | Gets or sets the style key. (Inherited from vButton.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control. (Inherited from vButton.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable (Inherited from vButton.)
Public property | Theme | Gets or sets the theme of the control (Overrides vButton..::..Theme.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control. (Inherited from vButton.)
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control. (Inherited from vButton.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color. (Inherited from vButton.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vButton.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vCircularButton Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vCircularButton..::..Theme Property
vCircularButton Class See Also Send Feedback
Gets or sets the theme of the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override ControlTheme Theme { get; set; }
Visual Basic
Public Overrides Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
virtual property ControlTheme^ Theme {
    ControlTheme^ get () override;
    void set (ControlTheme^ value) override;
}

See Also

vCircularButton Class


vCircularButton Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularButton Events
vCircularButton Class See Also Send Feedback

The vCircularButton type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vCircularButton Class


vCircularProgressBar Class

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar Class
Members See Also Send Feedback
Represents a vCircularProgressBar control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vCircularProgressBar : Control,
    IScrollableControlBase
Visual Basic
Public Class vCircularProgressBar _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class vCircularProgressBar : public Control,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vCircularProgressBar

See Also

vCircularProgressBar Members


vCircularProgressBar Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar Members
vCircularProgressBar Class Constructors Methods Properties Events See Also Send Feedback

The vCircularProgressBar type exposes the following members.

Constructors

 | Name | Description
Public method | vCircularProgressBar | Initializes a new instance of the vCircularProgressBar class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Decrement | Decrements the current position of the vCircularProgressBar bar by the specified amount.
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Increment | Advances the current position of the vCircularProgressBar bar by the specified amount.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged |
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start | Starts the progress bar. When the value reaches the Maximum the progress indication is stopped.
Public method | Stop | Stops the progress bar.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | IndicationSpeed | Gets or sets the indication speed.
Public property | IndicatorsCount | Gets or sets the number of indicators in the Circular ProgressBar control
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the Maximum value of the vCircularProgressBar control.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the Minimum value of the vCircularProgressBar control.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ProgressIndicatorsScaleFactor | Gets or sets the scale range from 0.1 to 1.0.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackground | Determines whether the control's background is painted using the Theme colors
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets the current position of the vCircularProgressBar control.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when value is changed
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vCircularProgressBar Class


vCircularProgressBar Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar Constructor
vCircularProgressBar Class See Also Send Feedback
Initializes a new instance of the vCircularProgressBar class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vCircularProgressBar()
Visual Basic
Public Sub New
Visual C++
public:
vCircularProgressBar()

See Also

vCircularProgressBar Class


vCircularProgressBar Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar Methods
vCircularProgressBar Class See Also Send Feedback

The vCircularProgressBar type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Decrement | Decrements the current position of the vCircularProgressBar bar by the specified amount.
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Increment | Advances the current position of the vCircularProgressBar bar by the specified amount.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged |
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start | Starts the progress bar. When the value reaches the Maximum the progress indication is stopped.
Public method | Stop | Stops the progress bar.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vCircularProgressBar Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..AccessibilityNotifyClients Method
vCircularProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vCircularProgressBar Class
vCircularProgressBar Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..BeginInvoke Method
vCircularProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vCircularProgressBar Class
vCircularProgressBar Members


Decrement Method

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..Decrement Method
vCircularProgressBar Class See Also Send Feedback
Decrements the current position of the vCircularProgressBar bar by the specified amount.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Decrement(
    int value
)
Visual Basic
Public Sub Decrement ( _
    value As Integer _
)
Visual C++
public:
void Decrement(
    int value
)

Parameters

value
Type: System..::..Int32
The amount by which to decrement the vCircularProgressBar's current position.

See Also

vCircularProgressBar Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..Dispose Method
vCircularProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)

See Also

vCircularProgressBar Class
vCircularProgressBar Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..Dispose Method (Boolean)
vCircularProgressBar Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vCircularProgressBar Class
Dispose Overload


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..GetChildAtPoint Method
vCircularProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vCircularProgressBar Class
vCircularProgressBar Members


Increment Method

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..Increment Method
vCircularProgressBar Class See Also Send Feedback
Advances the current position of the vCircularProgressBar bar by the specified amount.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Increment(
    int value
)
Visual Basic
Public Sub Increment ( _
    value As Integer _
)
Visual C++
public:
void Increment(
    int value
)

Parameters

value
Type: System..::..Int32
The amount by which to increment the vCircularProgressBar's current position.

See Also

vCircularProgressBar Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..Invalidate Method
vCircularProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vCircularProgressBar Class
vCircularProgressBar Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..Invoke Method
vCircularProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vCircularProgressBar Class
vCircularProgressBar Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..MemberwiseClone Method
vCircularProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vCircularProgressBar Class
vCircularProgressBar Members


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..OnPaint Method
vCircularProgressBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vCircularProgressBar Class


OnValueChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..OnValueChanged Method
vCircularProgressBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnValueChanged()
Visual Basic
Protected Overridable Sub OnValueChanged
Visual C++
protected:
virtual void OnValueChanged()

See Also

vCircularProgressBar Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..PerformLayout Method
vCircularProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vCircularProgressBar Class
vCircularProgressBar Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..ResumeLayout Method
vCircularProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vCircularProgressBar Class
vCircularProgressBar Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..RtlTranslateAlignment Method
vCircularProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vCircularProgressBar Class
vCircularProgressBar Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..Scale Method
vCircularProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vCircularProgressBar Class
vCircularProgressBar Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..Select Method
vCircularProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vCircularProgressBar Class
vCircularProgressBar Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..SetBounds Method
vCircularProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vCircularProgressBar Class
vCircularProgressBar Members


Start Method

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..Start Method
vCircularProgressBar Class See Also Send Feedback
Starts the progress bar. When the value reaches the Maximum the progress indication is stopped.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Start()
Visual Basic
Public Sub Start
Visual C++
public:
void Start()

See Also

vCircularProgressBar Class


Stop Method

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..Stop Method
vCircularProgressBar Class See Also Send Feedback
Stops the progress bar.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Stop()
Visual Basic
Public Sub Stop
Visual C++
public:
void Stop()

See Also

vCircularProgressBar Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..UpdateBounds Method
vCircularProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vCircularProgressBar Class
vCircularProgressBar Members


vCircularProgressBar Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar Properties
vCircularProgressBar Class See Also Send Feedback

The vCircularProgressBar type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | IndicationSpeed | Gets or sets the indication speed.
Public property | IndicatorsCount | Gets or sets the number of indicators in the Circular ProgressBar control
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the Maximum value of the vCircularProgressBar control.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the Minimum value of the vCircularProgressBar control.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ProgressIndicatorsScaleFactor | Gets or sets the scale range from 0.1 to 1.0.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackground | Determines whether the control's background is painted using the Theme colors
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets the current position of the vCircularProgressBar control.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vCircularProgressBar Class


IndicationSpeed Property

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..IndicationSpeed Property
vCircularProgressBar Class See Also Send Feedback
Gets or sets the indication speed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int IndicationSpeed { get; set; }
Visual Basic
Public Property IndicationSpeed As Integer
    Get
    Set
Visual C++
public:
property int IndicationSpeed {
    int get ();
    void set (int value);
}

See Also

vCircularProgressBar Class


IndicatorsCount Property

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..IndicatorsCount Property
vCircularProgressBar Class See Also Send Feedback
Gets or sets the number of indicators in the Circular ProgressBar control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int IndicatorsCount { get; set; }
Visual Basic
Public Property IndicatorsCount As Integer
    Get
    Set
Visual C++
public:
property int IndicatorsCount {
    int get ();
    void set (int value);
}

Field Value

Gets or sets the number of indicators in the Circular ProgressBar control

See Also

vCircularProgressBar Class


Maximum Property

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..Maximum Property
vCircularProgressBar Class See Also Send Feedback
Gets or sets the Maximum value of the vCircularProgressBar control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Maximum { get; set; }
Visual Basic
Public Property Maximum As Integer
    Get
    Set
Visual C++
public:
property int Maximum {
    int get ();
    void set (int value);
}

See Also

vCircularProgressBar Class


Minimum Property

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..Minimum Property
vCircularProgressBar Class See Also Send Feedback
Gets or sets the Minimum value of the vCircularProgressBar control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Minimum { get; set; }
Visual Basic
Public Property Minimum As Integer
    Get
    Set
Visual C++
public:
property int Minimum {
    int get ();
    void set (int value);
}

See Also

vCircularProgressBar Class


ProgressIndicatorsScaleFactor Property

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..ProgressIndicatorsScaleFactor Property
vCircularProgressBar Class See Also Send Feedback
Gets or sets the scale range from 0.1 to 1.0.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public float ProgressIndicatorsScaleFactor { get; set; }
Visual Basic
Public Property ProgressIndicatorsScaleFactor As Single
    Get
    Set
Visual C++
public:
property float ProgressIndicatorsScaleFactor {
    float get ();
    void set (float value);
}

See Also

vCircularProgressBar Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..Theme Property
vCircularProgressBar Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vCircularProgressBar Class


UseThemeBackground Property

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..UseThemeBackground Property
vCircularProgressBar Class See Also Send Feedback
Determines whether the control's background is painted using the Theme colors

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBackground { get; set; }
Visual Basic
Public Property UseThemeBackground As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBackground {
    bool get ();
    void set (bool value);
}

See Also

vCircularProgressBar Class


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..Value Property
vCircularProgressBar Class See Also Send Feedback
Gets the current position of the vCircularProgressBar control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Value { get; set; }
Visual Basic
Public Property Value As Integer
    Get
    Set
Visual C++
public:
property int Value {
    int get ();
    void set (int value);
}

Remarks

The minimum and maximum values of the Value property are specified by the Minimum and Maximum properties. This property enables you to increment or decrement the value of the vCircularProgressBar.

See Also

vCircularProgressBar Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..VIBlendTheme Property
vCircularProgressBar Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vCircularProgressBar Class


vCircularProgressBar Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar Events
vCircularProgressBar Class See Also Send Feedback

The vCircularProgressBar type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when value is changed
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vCircularProgressBar Class


ValueChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vCircularProgressBar..::..ValueChanged Event
vCircularProgressBar Class See Also Send Feedback
Occurs when value is changed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ValueChanged
Visual Basic
Public Event ValueChanged As EventHandler
Visual C++
public:
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vCircularProgressBar Class


vColorPicker Class

[image]

VIBlend Controls for WinForms Help Documentation
vColorPicker Class
Members See Also Send Feedback
Represents a vColorPicker control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vColorPicker : vControlBox
Visual Basic
Public Class vColorPicker _
    Inherits vControlBox
Visual C++
public ref class vColorPicker : public vControlBox

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vControlBox
VIBlend.WinForms.Controls..::..vColorPicker

See Also

vColorPicker Members


vColorPicker Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorPicker Members
vColorPicker Class Constructors Methods Properties Events See Also Send Feedback

The vColorPicker type exposes the following members.

Constructors

 | Name | Description
Public method | vColorPicker | Initializes a new instance of the vColorPicker class

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down. (Inherited from vControlBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vControlBox.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrow | Draws the arrow. (Inherited from vControlBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from vControlBox.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when property is changed. (Inherited from vControlBox.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectedColorChanged |
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown | (Inherited from vControlBox.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from vControlBox.)
Public property | BackColorDropDown | Gets or sets the background color for the dropdown control. (Inherited from vControlBox.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color which is used when the UseThemeBorderColor property is false. (Inherited from vControlBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentControl | Gets or sets the content control which is displayed when the dropdown is opened (Inherited from vControlBox.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets a reference to the DropDown of the ControlBox (Inherited from vControlBox.)
Public property | DropDownArrowBackgroundEnabled | Determines whether to the drop-down arrow's background is painted (Inherited from vControlBox.)
Public property | DropDownArrowColor | Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false. (Inherited from vControlBox.)
Public property | DropDownButtonBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownButtonDisabledBackgroundBrush | Gets or sets the disabled background brush. (Inherited from vControlBox.)
Public property | DropDownButtonHighlightBackgroundBrush | Gets or sets the HighlightBackground brush. (Inherited from vControlBox.)
Public property | DropDownButtonPressedBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMaximumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMinimumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownResizeDirection | (Overrides vControlBox..::..DropDownResizeDirection.)
Public property | DropDownWidth | Gets or sets the width in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | EditBase | Gets a reference to the EditBox of the vControlBox control (Inherited from vControlBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font that is used to display the text in the editbox of the control (Inherited from vControlBox.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color which is used to display the text (Inherited from vControlBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedColor | Gets or sets the selected color.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowGrip | Gets or sets a value indicating whether grip is shown (Inherited from vControlBox.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text displayed in the editbox of the control (Inherited from vControlBox.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDropDownButtonThemeBackground | Gets or sets a value indicating whether to use theme's background (Inherited from vControlBox.)
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeBorderColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeDropDownArrowColor | Gets or sets whether to use the Theme default arrow color. (Inherited from vControlBox.)
Public property | UseThemeFont | Gets or sets whether to use the Theme Font or the control's Font property. (Inherited from vControlBox.)
Public property | UseThemeForeColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ColorTextFormat | Occurs when the selected color has changed and vColorPicker updates text in the textbox portion of the control
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from vControlBox.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedColorChanged | Occurs when a color is changed.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vColorPicker Class


vColorPicker Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vColorPicker Constructor
vColorPicker Class See Also Send Feedback
Initializes a new instance of the vColorPicker class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vColorPicker()
Visual Basic
Public Sub New
Visual C++
public:
vColorPicker()

See Also

vColorPicker Class


vColorPicker Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorPicker Methods
vColorPicker Class See Also Send Feedback

The vColorPicker type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down. (Inherited from vControlBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vControlBox.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrow | Draws the arrow. (Inherited from vControlBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from vControlBox.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when property is changed. (Inherited from vControlBox.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectedColorChanged |
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown | (Inherited from vControlBox.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vColorPicker Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..AccessibilityNotifyClients Method
vColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vColorPicker Class
vColorPicker Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..BeginInvoke Method
vColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vColorPicker Class
vColorPicker Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..Dispose Method
vColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vControlBox.)

See Also

vColorPicker Class
vColorPicker Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..GetChildAtPoint Method
vColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vColorPicker Class
vColorPicker Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..Invalidate Method
vColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vColorPicker Class
vColorPicker Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..Invoke Method
vColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vColorPicker Class
vColorPicker Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..MemberwiseClone Method
vColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vColorPicker Class
vColorPicker Members


OnSelectedColorChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..OnSelectedColorChanged Method
vColorPicker Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnSelectedColorChanged()
Visual Basic
Protected Overridable Sub OnSelectedColorChanged
Visual C++
protected:
virtual void OnSelectedColorChanged()

See Also

vColorPicker Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..PerformLayout Method
vColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vColorPicker Class
vColorPicker Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..ResumeLayout Method
vColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vColorPicker Class
vColorPicker Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..RtlTranslateAlignment Method
vColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vColorPicker Class
vColorPicker Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..Scale Method
vColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vColorPicker Class
vColorPicker Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..Select Method
vColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vColorPicker Class
vColorPicker Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..SetBounds Method
vColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vColorPicker Class
vColorPicker Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..UpdateBounds Method
vColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vColorPicker Class
vColorPicker Members


vColorPicker Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorPicker Properties
vColorPicker Class See Also Send Feedback

The vColorPicker type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from vControlBox.)
Public property | BackColorDropDown | Gets or sets the background color for the dropdown control. (Inherited from vControlBox.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color which is used when the UseThemeBorderColor property is false. (Inherited from vControlBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentControl | Gets or sets the content control which is displayed when the dropdown is opened (Inherited from vControlBox.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets a reference to the DropDown of the ControlBox (Inherited from vControlBox.)
Public property | DropDownArrowBackgroundEnabled | Determines whether to the drop-down arrow's background is painted (Inherited from vControlBox.)
Public property | DropDownArrowColor | Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false. (Inherited from vControlBox.)
Public property | DropDownButtonBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownButtonDisabledBackgroundBrush | Gets or sets the disabled background brush. (Inherited from vControlBox.)
Public property | DropDownButtonHighlightBackgroundBrush | Gets or sets the HighlightBackground brush. (Inherited from vControlBox.)
Public property | DropDownButtonPressedBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMaximumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMinimumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownResizeDirection | (Overrides vControlBox..::..DropDownResizeDirection.)
Public property | DropDownWidth | Gets or sets the width in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | EditBase | Gets a reference to the EditBox of the vControlBox control (Inherited from vControlBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font that is used to display the text in the editbox of the control (Inherited from vControlBox.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color which is used to display the text (Inherited from vControlBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedColor | Gets or sets the selected color.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowGrip | Gets or sets a value indicating whether grip is shown (Inherited from vControlBox.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text displayed in the editbox of the control (Inherited from vControlBox.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDropDownButtonThemeBackground | Gets or sets a value indicating whether to use theme's background (Inherited from vControlBox.)
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeBorderColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeDropDownArrowColor | Gets or sets whether to use the Theme default arrow color. (Inherited from vControlBox.)
Public property | UseThemeFont | Gets or sets whether to use the Theme Font or the control's Font property. (Inherited from vControlBox.)
Public property | UseThemeForeColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vColorPicker Class


DropDownResizeDirection Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..DropDownResizeDirection Property
vColorPicker Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override SizingDirection DropDownResizeDirection { get; set; }
Visual Basic
Public Overrides Property DropDownResizeDirection As SizingDirection
    Get
    Set
Visual C++
public:
virtual property SizingDirection DropDownResizeDirection {
    SizingDirection get () override;
    void set (SizingDirection value) override;
}

See Also

vColorPicker Class


SelectedColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..SelectedColor Property
vColorPicker Class See Also Send Feedback
Gets or sets the selected color.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color SelectedColor { get; set; }
Visual Basic
Public Property SelectedColor As Color
    Get
    Set
Visual C++
public:
property Color SelectedColor {
    Color get ();
    void set (Color value);
}

See Also

vColorPicker Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..Theme Property
vColorPicker Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vColorPicker Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..VIBlendTheme Property
vColorPicker Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vColorPicker Class


vColorPicker Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorPicker Events
vColorPicker Class See Also Send Feedback

The vColorPicker type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ColorTextFormat | Occurs when the selected color has changed and vColorPicker updates text in the textbox portion of the control
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from vControlBox.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedColorChanged | Occurs when a color is changed.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vColorPicker Class


ColorTextFormat Event

[image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..ColorTextFormat Event
vColorPicker Class See Also Send Feedback
Occurs when the selected color has changed and vColorPicker updates text in the textbox portion of the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vColorPicker..::..ColorStringFormatEventHandler ColorTextFormat
Visual Basic
Public Event ColorTextFormat As vColorPicker..::..ColorStringFormatEventHandler
Visual C++
public:
 event vColorPicker..::..ColorStringFormatEventHandler^ ColorTextFormat {
    void add (vColorPicker..::..ColorStringFormatEventHandler^ value);
    void remove (vColorPicker..::..ColorStringFormatEventHandler^ value);
}

Remarks

Use this event to specify custom formatting for the selected color

See Also

vColorPicker Class


SelectedColorChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..SelectedColorChanged Event
vColorPicker Class See Also Send Feedback
Occurs when a color is changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler SelectedColorChanged
Visual Basic
Public Event SelectedColorChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectedColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vColorPicker Class


vColorPicker.ColorStringFormatEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vColorPicker..::..ColorStringFormatEventHandler Delegate
vColorPicker Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void ColorStringFormatEventHandler(
    Object sender,
    ColorStringFormatEventArgs e
)
Visual Basic
Public Delegate Sub ColorStringFormatEventHandler ( _
    sender As Object, _
    e As ColorStringFormatEventArgs _
)
Visual C++
public delegate void ColorStringFormatEventHandler(
    Object^ sender,
    ColorStringFormatEventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: VIBlend.WinForms.Controls..::..ColorStringFormatEventArgs

See Also


vColorTable Class

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vColorTable : ProfessionalColorTable
Visual Basic
Public Class vColorTable _
    Inherits ProfessionalColorTable
Visual C++
public ref class vColorTable : public ProfessionalColorTable

Inheritance Hierarchy

System..::..Object
System.Windows.Forms..::..ProfessionalColorTable
VIBlend.WinForms.Controls..::..vColorTable

See Also

vColorTable Members


vColorTable Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorTable Members
vColorTable Class Constructors Methods Fields Properties See Also Send Feedback

The vColorTable type exposes the following members.

Constructors

 | Name | Description
Public method | vColorTable | Initializes a new instance of the vColorTable class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
buttonBorder |
buttonPressedColor1 |
buttonPressedColor2 |
buttonPressedColor3 |
buttonSelectedColor1 |
buttonSelectedColor2 |
buttonSelectedColor3 |
checkBoxBackGround |
contextMenuBackGround |
gripColor1 |
gripColor2 |
imageAreaColor1 |
imageAreaColor2 |
imageAreaColor3 |
itemSelectedColor1 |
itemSelectedColor2 |
menuBorder |
menuToolBackColor1 |
menuToolBackColor2 |
overflowColor1 |
overflowColor2 |
overflowColor3 |
separatorColor1 |
separatorColor2 |
statusStripBackColor1 |
statusStripBackColor2 |
toolStripBackColor1 |
toolStripBackColor2 |
toolStripBackColor3 |
toolStripBorderColor |
toolStripInnerColor |

Properties

 | Name | Description
Public property | ButtonCheckedGradientBegin | Gets the starting color of the gradient used when the button is checked. (Inherited from ProfessionalColorTable.)
Public property | ButtonCheckedGradientEnd | Gets the end color of the gradient used when the button is checked. (Inherited from ProfessionalColorTable.)
Public property | ButtonCheckedGradientMiddle | Gets the middle color of the gradient used when the button is checked. (Inherited from ProfessionalColorTable.)
Public property | ButtonCheckedHighlight | Gets the solid color used when the button is checked. (Inherited from ProfessionalColorTable.)
Public property | ButtonCheckedHighlightBorder | Gets the border color to use with ButtonCheckedHighlight. (Inherited from ProfessionalColorTable.)
Public property | ButtonPressedBorder | Gets the border color to use with the ButtonPressedGradientBegin, ButtonPressedGradientMiddle, and ButtonPressedGradientEnd colors. (Inherited from ProfessionalColorTable.)
Public property | ButtonPressedGradientBegin | Gets the starting color of the gradient used when the button is pressed. (Overrides ProfessionalColorTable..::..ButtonPressedGradientBegin.)
Public property | ButtonPressedGradientEnd | Gets the end color of the gradient used when the button is pressed. (Overrides ProfessionalColorTable..::..ButtonPressedGradientEnd.)
Public property | ButtonPressedGradientMiddle | Gets the middle color of the gradient used when the button is pressed. (Overrides ProfessionalColorTable..::..ButtonPressedGradientMiddle.)
Public property | ButtonPressedHighlight | Gets the solid color used when the button is pressed. (Inherited from ProfessionalColorTable.)
Public property | ButtonPressedHighlightBorder | Gets the border color to use with ButtonPressedHighlight. (Inherited from ProfessionalColorTable.)
Public property | ButtonSelectedBorder | Gets the border color to use with the ButtonSelectedGradientBegin, ButtonSelectedGradientMiddle, and ButtonSelectedGradientEnd colors. (Inherited from ProfessionalColorTable.)
Public property | ButtonSelectedGradientBegin | Gets the starting color of the gradient used when the button is selected. (Overrides ProfessionalColorTable..::..ButtonSelectedGradientBegin.)
Public property | ButtonSelectedGradientEnd | Gets the end color of the gradient used when the button is selected. (Overrides ProfessionalColorTable..::..ButtonSelectedGradientEnd.)
Public property | ButtonSelectedGradientMiddle | Gets the middle color of the gradient used when the button is selected. (Overrides ProfessionalColorTable..::..ButtonSelectedGradientMiddle.)
Public property | ButtonSelectedHighlight | Gets the solid color used when the button is selected. (Inherited from ProfessionalColorTable.)
Public property | ButtonSelectedHighlightBorder | Gets the border color to use with ButtonSelectedHighlight. (Overrides ProfessionalColorTable..::..ButtonSelectedHighlightBorder.)
Public property | CheckBackground | Gets the solid color to use when the button is checked and gradients are being used. (Overrides ProfessionalColorTable..::..CheckBackground.)
Public property | CheckPressedBackground | Gets the solid color to use when the button is checked and selected and gradients are being used. (Inherited from ProfessionalColorTable.)
Public property | CheckSelectedBackground | Gets the solid color to use when the button is checked and selected and gradients are being used. (Inherited from ProfessionalColorTable.)
Public property | GripDark | Gets the color to use for shadow effects on the grip (move handle). (Overrides ProfessionalColorTable..::..GripDark.)
Public property | GripLight | Gets the color to use for highlight effects on the grip (move handle). (Overrides ProfessionalColorTable..::..GripLight.)
Public property | ImageMarginGradientBegin | Gets the starting color of the gradient used in the image margin of a ToolStripDropDownMenu. (Overrides ProfessionalColorTable..::..ImageMarginGradientBegin.)
Public property | ImageMarginGradientEnd | Gets the end color of the gradient used in the image margin of a ToolStripDropDownMenu. (Overrides ProfessionalColorTable..::..ImageMarginGradientEnd.)
Public property | ImageMarginGradientMiddle | Gets the middle color of the gradient used in the image margin of a ToolStripDropDownMenu. (Inherited from ProfessionalColorTable.)
Public property | ImageMarginRevealedGradientBegin | Gets the starting color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed. (Inherited from ProfessionalColorTable.)
Public property | ImageMarginRevealedGradientEnd | Gets the end color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed. (Inherited from ProfessionalColorTable.)
Public property | ImageMarginRevealedGradientMiddle | Gets the middle color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed. (Overrides ProfessionalColorTable..::..ImageMarginRevealedGradientMiddle.)
Public property | MenuBorder | Gets the color that is the border color to use on a MenuStrip. (Overrides ProfessionalColorTable..::..MenuBorder.)
Public property | MenuItemBorder | Gets the border color to use with a ToolStripMenuItem. (Inherited from ProfessionalColorTable.)
Public property | MenuItemPressedGradientBegin | Gets the starting color of the gradient used when a top-level ToolStripMenuItem is pressed. (Overrides ProfessionalColorTable..::..MenuItemPressedGradientBegin.)
Public property | MenuItemPressedGradientEnd | Gets the end color of the gradient used when a top-level ToolStripMenuItem is pressed. (Overrides ProfessionalColorTable..::..MenuItemPressedGradientEnd.)
Public property | MenuItemPressedGradientMiddle | Gets the middle color of the gradient used when a top-level ToolStripMenuItem is pressed. (Overrides ProfessionalColorTable..::..MenuItemPressedGradientMiddle.)
Public property | MenuItemSelected | Gets the solid color to use when a ToolStripMenuItem other than the top-level ToolStripMenuItem is selected. (Overrides ProfessionalColorTable..::..MenuItemSelected.)
Public property | MenuItemSelectedGradientBegin | Gets the starting color of the gradient used when the ToolStripMenuItem is selected. (Overrides ProfessionalColorTable..::..MenuItemSelectedGradientBegin.)
Public property | MenuItemSelectedGradientEnd | Gets the end color of the gradient used when the ToolStripMenuItem is selected. (Overrides ProfessionalColorTable..::..MenuItemSelectedGradientEnd.)
Public property | MenuStripGradientBegin | Gets the starting color of the gradient used in the MenuStrip. (Overrides ProfessionalColorTable..::..MenuStripGradientBegin.)
Public property | MenuStripGradientEnd | Gets the end color of the gradient used in the MenuStrip. (Overrides ProfessionalColorTable..::..MenuStripGradientEnd.)
Public property | OverflowButtonGradientBegin | Gets the starting color of the gradient used in the ToolStripOverflowButton. (Overrides ProfessionalColorTable..::..OverflowButtonGradientBegin.)
Public property | OverflowButtonGradientEnd | Gets the end color of the gradient used in the ToolStripOverflowButton. (Overrides ProfessionalColorTable..::..OverflowButtonGradientEnd.)
Public property | OverflowButtonGradientMiddle | Gets the middle color of the gradient used in the ToolStripOverflowButton. (Overrides ProfessionalColorTable..::..OverflowButtonGradientMiddle.)
Public property | RaftingContainerGradientBegin | Gets the starting color of the gradient used in the ToolStripContainer. (Overrides ProfessionalColorTable..::..RaftingContainerGradientBegin.)
Public property | RaftingContainerGradientEnd | Gets the end color of the gradient used in the ToolStripContainer. (Overrides ProfessionalColorTable..::..RaftingContainerGradientEnd.)
Public property | SeparatorDark | Gets the color to use to for shadow effects on the ToolStripSeparator. (Overrides ProfessionalColorTable..::..SeparatorDark.)
Public property | SeparatorLight | Gets the color to use to for highlight effects on the ToolStripSeparator. (Overrides ProfessionalColorTable..::..SeparatorLight.)
Public property | StatusStripGradientBegin | Gets the starting color of the gradient used on the StatusStrip. (Overrides ProfessionalColorTable..::..StatusStripGradientBegin.)
Public property | StatusStripGradientEnd | Gets the end color of the gradient used on the StatusStrip. (Overrides ProfessionalColorTable..::..StatusStripGradientEnd.)
Public property | ToolStripBorder | Gets the border color to use on the bottom edge of the ToolStrip. (Overrides ProfessionalColorTable..::..ToolStripBorder.)
Public property | ToolStripContentPanelGradientBegin | Gets the starting color of the gradient used in the ToolStripContentPanel. (Overrides ProfessionalColorTable..::..ToolStripContentPanelGradientBegin.)
Public property | ToolStripContentPanelGradientEnd | Gets the end color of the gradient used in the ToolStripContentPanel. (Overrides ProfessionalColorTable..::..ToolStripContentPanelGradientEnd.)
Public property | ToolStripDropDownBackground | Gets the solid background color of the ToolStripDropDown. (Overrides ProfessionalColorTable..::..ToolStripDropDownBackground.)
Public property | ToolStripGradientBegin | Gets the starting color of the gradient used in the ToolStrip background. (Overrides ProfessionalColorTable..::..ToolStripGradientBegin.)
Public property | ToolStripGradientEnd | Gets the end color of the gradient used in the ToolStrip background. (Overrides ProfessionalColorTable..::..ToolStripGradientEnd.)
Public property | ToolStripGradientMiddle | Gets the middle color of the gradient used in the ToolStrip background. (Overrides ProfessionalColorTable..::..ToolStripGradientMiddle.)
Public property | ToolStripPanelGradientBegin | Gets the starting color of the gradient used in the ToolStripPanel. (Overrides ProfessionalColorTable..::..ToolStripPanelGradientBegin.)
Public property | ToolStripPanelGradientEnd | Gets the end color of the gradient used in the ToolStripPanel. (Overrides ProfessionalColorTable..::..ToolStripPanelGradientEnd.)
Public property | UseSystemColors | Gets or sets a value indicating whether to use SystemColors rather than colors that match the current visual style. (Inherited from ProfessionalColorTable.)

See Also

vColorTable Class


vColorTable Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable Constructor
vColorTable Class See Also Send Feedback
Initializes a new instance of the vColorTable class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vColorTable()
Visual Basic
Public Sub New
Visual C++
public:
vColorTable()

See Also

vColorTable Class


vColorTable Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorTable Fields
vColorTable Class See Also Send Feedback

The vColorTable type exposes the following members.

Fields

Name | Description
buttonBorder |
buttonPressedColor1 |
buttonPressedColor2 |
buttonPressedColor3 |
buttonSelectedColor1 |
buttonSelectedColor2 |
buttonSelectedColor3 |
checkBoxBackGround |
contextMenuBackGround |
gripColor1 |
gripColor2 |
imageAreaColor1 |
imageAreaColor2 |
imageAreaColor3 |
itemSelectedColor1 |
itemSelectedColor2 |
menuBorder |
menuToolBackColor1 |
menuToolBackColor2 |
overflowColor1 |
overflowColor2 |
overflowColor3 |
separatorColor1 |
separatorColor2 |
statusStripBackColor1 |
statusStripBackColor2 |
toolStripBackColor1 |
toolStripBackColor2 |
toolStripBackColor3 |
toolStripBorderColor |
toolStripInnerColor |

See Also

vColorTable Class


buttonBorder Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..buttonBorder Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color buttonBorder
Visual Basic
Public Shared buttonBorder As Color
Visual C++
public:
static Color buttonBorder

See Also

vColorTable Class


buttonPressedColor1 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..buttonPressedColor1 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color buttonPressedColor1
Visual Basic
Public Shared buttonPressedColor1 As Color
Visual C++
public:
static Color buttonPressedColor1

See Also

vColorTable Class


buttonPressedColor2 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..buttonPressedColor2 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color buttonPressedColor2
Visual Basic
Public Shared buttonPressedColor2 As Color
Visual C++
public:
static Color buttonPressedColor2

See Also

vColorTable Class


buttonPressedColor3 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..buttonPressedColor3 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color buttonPressedColor3
Visual Basic
Public Shared buttonPressedColor3 As Color
Visual C++
public:
static Color buttonPressedColor3

See Also

vColorTable Class


buttonSelectedColor1 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..buttonSelectedColor1 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color buttonSelectedColor1
Visual Basic
Public Shared buttonSelectedColor1 As Color
Visual C++
public:
static Color buttonSelectedColor1

See Also

vColorTable Class


buttonSelectedColor2 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..buttonSelectedColor2 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color buttonSelectedColor2
Visual Basic
Public Shared buttonSelectedColor2 As Color
Visual C++
public:
static Color buttonSelectedColor2

See Also

vColorTable Class


buttonSelectedColor3 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..buttonSelectedColor3 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color buttonSelectedColor3
Visual Basic
Public Shared buttonSelectedColor3 As Color
Visual C++
public:
static Color buttonSelectedColor3

See Also

vColorTable Class


checkBoxBackGround Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..checkBoxBackGround Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color checkBoxBackGround
Visual Basic
Public Shared checkBoxBackGround As Color
Visual C++
public:
static Color checkBoxBackGround

See Also

vColorTable Class


contextMenuBackGround Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..contextMenuBackGround Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color contextMenuBackGround
Visual Basic
Public Shared contextMenuBackGround As Color
Visual C++
public:
static Color contextMenuBackGround

See Also

vColorTable Class


gripColor1 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..gripColor1 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color gripColor1
Visual Basic
Public Shared gripColor1 As Color
Visual C++
public:
static Color gripColor1

See Also

vColorTable Class


gripColor2 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..gripColor2 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color gripColor2
Visual Basic
Public Shared gripColor2 As Color
Visual C++
public:
static Color gripColor2

See Also

vColorTable Class


imageAreaColor1 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..imageAreaColor1 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color imageAreaColor1
Visual Basic
Public Shared imageAreaColor1 As Color
Visual C++
public:
static Color imageAreaColor1

See Also

vColorTable Class


imageAreaColor2 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..imageAreaColor2 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color imageAreaColor2
Visual Basic
Public Shared imageAreaColor2 As Color
Visual C++
public:
static Color imageAreaColor2

See Also

vColorTable Class


imageAreaColor3 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..imageAreaColor3 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color imageAreaColor3
Visual Basic
Public Shared imageAreaColor3 As Color
Visual C++
public:
static Color imageAreaColor3

See Also

vColorTable Class


itemSelectedColor1 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..itemSelectedColor1 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color itemSelectedColor1
Visual Basic
Public Shared itemSelectedColor1 As Color
Visual C++
public:
static Color itemSelectedColor1

See Also

vColorTable Class


itemSelectedColor2 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..itemSelectedColor2 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color itemSelectedColor2
Visual Basic
Public Shared itemSelectedColor2 As Color
Visual C++
public:
static Color itemSelectedColor2

See Also

vColorTable Class


menuBorder Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..menuBorder Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color menuBorder
Visual Basic
Public Shared menuBorder As Color
Visual C++
public:
static Color menuBorder

See Also

vColorTable Class


menuToolBackColor1 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..menuToolBackColor1 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color menuToolBackColor1
Visual Basic
Public Shared menuToolBackColor1 As Color
Visual C++
public:
static Color menuToolBackColor1

See Also

vColorTable Class


menuToolBackColor2 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..menuToolBackColor2 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color menuToolBackColor2
Visual Basic
Public Shared menuToolBackColor2 As Color
Visual C++
public:
static Color menuToolBackColor2

See Also

vColorTable Class


overflowColor1 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..overflowColor1 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color overflowColor1
Visual Basic
Public Shared overflowColor1 As Color
Visual C++
public:
static Color overflowColor1

See Also

vColorTable Class


overflowColor2 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..overflowColor2 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color overflowColor2
Visual Basic
Public Shared overflowColor2 As Color
Visual C++
public:
static Color overflowColor2

See Also

vColorTable Class


overflowColor3 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..overflowColor3 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color overflowColor3
Visual Basic
Public Shared overflowColor3 As Color
Visual C++
public:
static Color overflowColor3

See Also

vColorTable Class


separatorColor1 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..separatorColor1 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color separatorColor1
Visual Basic
Public Shared separatorColor1 As Color
Visual C++
public:
static Color separatorColor1

See Also

vColorTable Class


separatorColor2 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..separatorColor2 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color separatorColor2
Visual Basic
Public Shared separatorColor2 As Color
Visual C++
public:
static Color separatorColor2

See Also

vColorTable Class


statusStripBackColor1 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..statusStripBackColor1 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color statusStripBackColor1
Visual Basic
Public Shared statusStripBackColor1 As Color
Visual C++
public:
static Color statusStripBackColor1

See Also

vColorTable Class


statusStripBackColor2 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..statusStripBackColor2 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color statusStripBackColor2
Visual Basic
Public Shared statusStripBackColor2 As Color
Visual C++
public:
static Color statusStripBackColor2

See Also

vColorTable Class


toolStripBackColor1 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..toolStripBackColor1 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color toolStripBackColor1
Visual Basic
Public Shared toolStripBackColor1 As Color
Visual C++
public:
static Color toolStripBackColor1

See Also

vColorTable Class


toolStripBackColor2 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..toolStripBackColor2 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color toolStripBackColor2
Visual Basic
Public Shared toolStripBackColor2 As Color
Visual C++
public:
static Color toolStripBackColor2

See Also

vColorTable Class


toolStripBackColor3 Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..toolStripBackColor3 Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color toolStripBackColor3
Visual Basic
Public Shared toolStripBackColor3 As Color
Visual C++
public:
static Color toolStripBackColor3

See Also

vColorTable Class


toolStripBorderColor Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..toolStripBorderColor Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color toolStripBorderColor
Visual Basic
Public Shared toolStripBorderColor As Color
Visual C++
public:
static Color toolStripBorderColor

See Also

vColorTable Class


toolStripInnerColor Field

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..toolStripInnerColor Field
vColorTable Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Color toolStripInnerColor
Visual Basic
Public Shared toolStripInnerColor As Color
Visual C++
public:
static Color toolStripInnerColor

See Also

vColorTable Class


vColorTable Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorTable Methods
vColorTable Class See Also Send Feedback

The vColorTable type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vColorTable Class


vColorTable Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vColorTable Properties
vColorTable Class See Also Send Feedback

The vColorTable type exposes the following members.

Properties

 | Name | Description
Public property | ButtonCheckedGradientBegin | Gets the starting color of the gradient used when the button is checked. (Inherited from ProfessionalColorTable.)
Public property | ButtonCheckedGradientEnd | Gets the end color of the gradient used when the button is checked. (Inherited from ProfessionalColorTable.)
Public property | ButtonCheckedGradientMiddle | Gets the middle color of the gradient used when the button is checked. (Inherited from ProfessionalColorTable.)
Public property | ButtonCheckedHighlight | Gets the solid color used when the button is checked. (Inherited from ProfessionalColorTable.)
Public property | ButtonCheckedHighlightBorder | Gets the border color to use with ButtonCheckedHighlight. (Inherited from ProfessionalColorTable.)
Public property | ButtonPressedBorder | Gets the border color to use with the ButtonPressedGradientBegin, ButtonPressedGradientMiddle, and ButtonPressedGradientEnd colors. (Inherited from ProfessionalColorTable.)
Public property | ButtonPressedGradientBegin | Gets the starting color of the gradient used when the button is pressed. (Overrides ProfessionalColorTable..::..ButtonPressedGradientBegin.)
Public property | ButtonPressedGradientEnd | Gets the end color of the gradient used when the button is pressed. (Overrides ProfessionalColorTable..::..ButtonPressedGradientEnd.)
Public property | ButtonPressedGradientMiddle | Gets the middle color of the gradient used when the button is pressed. (Overrides ProfessionalColorTable..::..ButtonPressedGradientMiddle.)
Public property | ButtonPressedHighlight | Gets the solid color used when the button is pressed. (Inherited from ProfessionalColorTable.)
Public property | ButtonPressedHighlightBorder | Gets the border color to use with ButtonPressedHighlight. (Inherited from ProfessionalColorTable.)
Public property | ButtonSelectedBorder | Gets the border color to use with the ButtonSelectedGradientBegin, ButtonSelectedGradientMiddle, and ButtonSelectedGradientEnd colors. (Inherited from ProfessionalColorTable.)
Public property | ButtonSelectedGradientBegin | Gets the starting color of the gradient used when the button is selected. (Overrides ProfessionalColorTable..::..ButtonSelectedGradientBegin.)
Public property | ButtonSelectedGradientEnd | Gets the end color of the gradient used when the button is selected. (Overrides ProfessionalColorTable..::..ButtonSelectedGradientEnd.)
Public property | ButtonSelectedGradientMiddle | Gets the middle color of the gradient used when the button is selected. (Overrides ProfessionalColorTable..::..ButtonSelectedGradientMiddle.)
Public property | ButtonSelectedHighlight | Gets the solid color used when the button is selected. (Inherited from ProfessionalColorTable.)
Public property | ButtonSelectedHighlightBorder | Gets the border color to use with ButtonSelectedHighlight. (Overrides ProfessionalColorTable..::..ButtonSelectedHighlightBorder.)
Public property | CheckBackground | Gets the solid color to use when the button is checked and gradients are being used. (Overrides ProfessionalColorTable..::..CheckBackground.)
Public property | CheckPressedBackground | Gets the solid color to use when the button is checked and selected and gradients are being used. (Inherited from ProfessionalColorTable.)
Public property | CheckSelectedBackground | Gets the solid color to use when the button is checked and selected and gradients are being used. (Inherited from ProfessionalColorTable.)
Public property | GripDark | Gets the color to use for shadow effects on the grip (move handle). (Overrides ProfessionalColorTable..::..GripDark.)
Public property | GripLight | Gets the color to use for highlight effects on the grip (move handle). (Overrides ProfessionalColorTable..::..GripLight.)
Public property | ImageMarginGradientBegin | Gets the starting color of the gradient used in the image margin of a ToolStripDropDownMenu. (Overrides ProfessionalColorTable..::..ImageMarginGradientBegin.)
Public property | ImageMarginGradientEnd | Gets the end color of the gradient used in the image margin of a ToolStripDropDownMenu. (Overrides ProfessionalColorTable..::..ImageMarginGradientEnd.)
Public property | ImageMarginGradientMiddle | Gets the middle color of the gradient used in the image margin of a ToolStripDropDownMenu. (Inherited from ProfessionalColorTable.)
Public property | ImageMarginRevealedGradientBegin | Gets the starting color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed. (Inherited from ProfessionalColorTable.)
Public property | ImageMarginRevealedGradientEnd | Gets the end color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed. (Inherited from ProfessionalColorTable.)
Public property | ImageMarginRevealedGradientMiddle | Gets the middle color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed. (Overrides ProfessionalColorTable..::..ImageMarginRevealedGradientMiddle.)
Public property | MenuBorder | Gets the color that is the border color to use on a MenuStrip. (Overrides ProfessionalColorTable..::..MenuBorder.)
Public property | MenuItemBorder | Gets the border color to use with a ToolStripMenuItem. (Inherited from ProfessionalColorTable.)
Public property | MenuItemPressedGradientBegin | Gets the starting color of the gradient used when a top-level ToolStripMenuItem is pressed. (Overrides ProfessionalColorTable..::..MenuItemPressedGradientBegin.)
Public property | MenuItemPressedGradientEnd | Gets the end color of the gradient used when a top-level ToolStripMenuItem is pressed. (Overrides ProfessionalColorTable..::..MenuItemPressedGradientEnd.)
Public property | MenuItemPressedGradientMiddle | Gets the middle color of the gradient used when a top-level ToolStripMenuItem is pressed. (Overrides ProfessionalColorTable..::..MenuItemPressedGradientMiddle.)
Public property | MenuItemSelected | Gets the solid color to use when a ToolStripMenuItem other than the top-level ToolStripMenuItem is selected. (Overrides ProfessionalColorTable..::..MenuItemSelected.)
Public property | MenuItemSelectedGradientBegin | Gets the starting color of the gradient used when the ToolStripMenuItem is selected. (Overrides ProfessionalColorTable..::..MenuItemSelectedGradientBegin.)
Public property | MenuItemSelectedGradientEnd | Gets the end color of the gradient used when the ToolStripMenuItem is selected. (Overrides ProfessionalColorTable..::..MenuItemSelectedGradientEnd.)
Public property | MenuStripGradientBegin | Gets the starting color of the gradient used in the MenuStrip. (Overrides ProfessionalColorTable..::..MenuStripGradientBegin.)
Public property | MenuStripGradientEnd | Gets the end color of the gradient used in the MenuStrip. (Overrides ProfessionalColorTable..::..MenuStripGradientEnd.)
Public property | OverflowButtonGradientBegin | Gets the starting color of the gradient used in the ToolStripOverflowButton. (Overrides ProfessionalColorTable..::..OverflowButtonGradientBegin.)
Public property | OverflowButtonGradientEnd | Gets the end color of the gradient used in the ToolStripOverflowButton. (Overrides ProfessionalColorTable..::..OverflowButtonGradientEnd.)
Public property | OverflowButtonGradientMiddle | Gets the middle color of the gradient used in the ToolStripOverflowButton. (Overrides ProfessionalColorTable..::..OverflowButtonGradientMiddle.)
Public property | RaftingContainerGradientBegin | Gets the starting color of the gradient used in the ToolStripContainer. (Overrides ProfessionalColorTable..::..RaftingContainerGradientBegin.)
Public property | RaftingContainerGradientEnd | Gets the end color of the gradient used in the ToolStripContainer. (Overrides ProfessionalColorTable..::..RaftingContainerGradientEnd.)
Public property | SeparatorDark | Gets the color to use to for shadow effects on the ToolStripSeparator. (Overrides ProfessionalColorTable..::..SeparatorDark.)
Public property | SeparatorLight | Gets the color to use to for highlight effects on the ToolStripSeparator. (Overrides ProfessionalColorTable..::..SeparatorLight.)
Public property | StatusStripGradientBegin | Gets the starting color of the gradient used on the StatusStrip. (Overrides ProfessionalColorTable..::..StatusStripGradientBegin.)
Public property | StatusStripGradientEnd | Gets the end color of the gradient used on the StatusStrip. (Overrides ProfessionalColorTable..::..StatusStripGradientEnd.)
Public property | ToolStripBorder | Gets the border color to use on the bottom edge of the ToolStrip. (Overrides ProfessionalColorTable..::..ToolStripBorder.)
Public property | ToolStripContentPanelGradientBegin | Gets the starting color of the gradient used in the ToolStripContentPanel. (Overrides ProfessionalColorTable..::..ToolStripContentPanelGradientBegin.)
Public property | ToolStripContentPanelGradientEnd | Gets the end color of the gradient used in the ToolStripContentPanel. (Overrides ProfessionalColorTable..::..ToolStripContentPanelGradientEnd.)
Public property | ToolStripDropDownBackground | Gets the solid background color of the ToolStripDropDown. (Overrides ProfessionalColorTable..::..ToolStripDropDownBackground.)
Public property | ToolStripGradientBegin | Gets the starting color of the gradient used in the ToolStrip background. (Overrides ProfessionalColorTable..::..ToolStripGradientBegin.)
Public property | ToolStripGradientEnd | Gets the end color of the gradient used in the ToolStrip background. (Overrides ProfessionalColorTable..::..ToolStripGradientEnd.)
Public property | ToolStripGradientMiddle | Gets the middle color of the gradient used in the ToolStrip background. (Overrides ProfessionalColorTable..::..ToolStripGradientMiddle.)
Public property | ToolStripPanelGradientBegin | Gets the starting color of the gradient used in the ToolStripPanel. (Overrides ProfessionalColorTable..::..ToolStripPanelGradientBegin.)
Public property | ToolStripPanelGradientEnd | Gets the end color of the gradient used in the ToolStripPanel. (Overrides ProfessionalColorTable..::..ToolStripPanelGradientEnd.)
Public property | UseSystemColors | Gets or sets a value indicating whether to use SystemColors rather than colors that match the current visual style. (Inherited from ProfessionalColorTable.)

See Also

vColorTable Class


ButtonPressedGradientBegin Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ButtonPressedGradientBegin Property
vColorTable Class See Also Send Feedback
Gets the starting color of the gradient used when the button is pressed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ButtonPressedGradientBegin { get; }
Visual Basic
Public Overrides ReadOnly Property ButtonPressedGradientBegin As Color
    Get
Visual C++
public:
virtual property Color ButtonPressedGradientBegin {
    Color get () override;
}

Field Value

Return Value

A Color that is the starting color of the gradient used when the button is pressed.

See Also

vColorTable Class


ButtonPressedGradientEnd Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ButtonPressedGradientEnd Property
vColorTable Class See Also Send Feedback
Gets the end color of the gradient used when the button is pressed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ButtonPressedGradientEnd { get; }
Visual Basic
Public Overrides ReadOnly Property ButtonPressedGradientEnd As Color
    Get
Visual C++
public:
virtual property Color ButtonPressedGradientEnd {
    Color get () override;
}

Field Value

Return Value

A Color that is the end color of the gradient used when the button is pressed.

See Also

vColorTable Class


ButtonPressedGradientMiddle Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ButtonPressedGradientMiddle Property
vColorTable Class See Also Send Feedback
Gets the middle color of the gradient used when the button is pressed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ButtonPressedGradientMiddle { get; }
Visual Basic
Public Overrides ReadOnly Property ButtonPressedGradientMiddle As Color
    Get
Visual C++
public:
virtual property Color ButtonPressedGradientMiddle {
    Color get () override;
}

Field Value

Return Value

A Color that is the middle color of the gradient used when the button is pressed.

See Also

vColorTable Class


ButtonSelectedGradientBegin Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ButtonSelectedGradientBegin Property
vColorTable Class See Also Send Feedback
Gets the starting color of the gradient used when the button is selected.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ButtonSelectedGradientBegin { get; }
Visual Basic
Public Overrides ReadOnly Property ButtonSelectedGradientBegin As Color
    Get
Visual C++
public:
virtual property Color ButtonSelectedGradientBegin {
    Color get () override;
}

Field Value

Return Value

A Color that is the starting color of the gradient used when the button is selected.

See Also

vColorTable Class


ButtonSelectedGradientEnd Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ButtonSelectedGradientEnd Property
vColorTable Class See Also Send Feedback
Gets the end color of the gradient used when the button is selected.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ButtonSelectedGradientEnd { get; }
Visual Basic
Public Overrides ReadOnly Property ButtonSelectedGradientEnd As Color
    Get
Visual C++
public:
virtual property Color ButtonSelectedGradientEnd {
    Color get () override;
}

Field Value

Return Value

A Color that is the end color of the gradient used when the button is selected.

See Also

vColorTable Class


ButtonSelectedGradientMiddle Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ButtonSelectedGradientMiddle Property
vColorTable Class See Also Send Feedback
Gets the middle color of the gradient used when the button is selected.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ButtonSelectedGradientMiddle { get; }
Visual Basic
Public Overrides ReadOnly Property ButtonSelectedGradientMiddle As Color
    Get
Visual C++
public:
virtual property Color ButtonSelectedGradientMiddle {
    Color get () override;
}

Field Value

Return Value

A Color that is the middle color of the gradient used when the button is selected.

See Also

vColorTable Class


ButtonSelectedHighlightBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ButtonSelectedHighlightBorder Property
vColorTable Class See Also Send Feedback
Gets the border color to use with ButtonSelectedHighlight.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ButtonSelectedHighlightBorder { get; }
Visual Basic
Public Overrides ReadOnly Property ButtonSelectedHighlightBorder As Color
    Get
Visual C++
public:
virtual property Color ButtonSelectedHighlightBorder {
    Color get () override;
}

Field Value

Return Value

A Color that is the border color to use with ButtonSelectedHighlight.

See Also

vColorTable Class


CheckBackground Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..CheckBackground Property
vColorTable Class See Also Send Feedback
Gets the solid color to use when the button is checked and gradients are being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color CheckBackground { get; }
Visual Basic
Public Overrides ReadOnly Property CheckBackground As Color
    Get
Visual C++
public:
virtual property Color CheckBackground {
    Color get () override;
}

Field Value

Return Value

A Color that is the solid color to use when the button is checked and gradients are being used.

See Also

vColorTable Class


GripDark Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..GripDark Property
vColorTable Class See Also Send Feedback
Gets the color to use for shadow effects on the grip (move handle).

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color GripDark { get; }
Visual Basic
Public Overrides ReadOnly Property GripDark As Color
    Get
Visual C++
public:
virtual property Color GripDark {
    Color get () override;
}

Field Value

Return Value

A Color that is the color to use for shadow effects on the grip (move handle).

See Also

vColorTable Class


GripLight Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..GripLight Property
vColorTable Class See Also Send Feedback
Gets the color to use for highlight effects on the grip (move handle).

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color GripLight { get; }
Visual Basic
Public Overrides ReadOnly Property GripLight As Color
    Get
Visual C++
public:
virtual property Color GripLight {
    Color get () override;
}

Field Value

Return Value

A Color that is the color to use for highlight effects on the grip (move handle).

See Also

vColorTable Class


ImageMarginGradientBegin Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ImageMarginGradientBegin Property
vColorTable Class See Also Send Feedback
Gets the starting color of the gradient used in the image margin of a ToolStripDropDownMenu.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ImageMarginGradientBegin { get; }
Visual Basic
Public Overrides ReadOnly Property ImageMarginGradientBegin As Color
    Get
Visual C++
public:
virtual property Color ImageMarginGradientBegin {
    Color get () override;
}

Field Value

Return Value

A Color that is the starting color of the gradient used in the image margin of a ToolStripDropDownMenu.

See Also

vColorTable Class


ImageMarginGradientEnd Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ImageMarginGradientEnd Property
vColorTable Class See Also Send Feedback
Gets the end color of the gradient used in the image margin of a ToolStripDropDownMenu.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ImageMarginGradientEnd { get; }
Visual Basic
Public Overrides ReadOnly Property ImageMarginGradientEnd As Color
    Get
Visual C++
public:
virtual property Color ImageMarginGradientEnd {
    Color get () override;
}

Field Value

Return Value

A Color that is the end color of the gradient used in the image margin of a ToolStripDropDownMenu.

See Also

vColorTable Class


ImageMarginRevealedGradientMiddle Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ImageMarginRevealedGradientMiddle Property
vColorTable Class See Also Send Feedback
Gets the middle color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ImageMarginRevealedGradientMiddle { get; }
Visual Basic
Public Overrides ReadOnly Property ImageMarginRevealedGradientMiddle As Color
    Get
Visual C++
public:
virtual property Color ImageMarginRevealedGradientMiddle {
    Color get () override;
}

Field Value

Return Value

A Color that is the middle color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.

See Also

vColorTable Class


MenuBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..MenuBorder Property
vColorTable Class See Also Send Feedback
Gets the color that is the border color to use on a MenuStrip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color MenuBorder { get; }
Visual Basic
Public Overrides ReadOnly Property MenuBorder As Color
    Get
Visual C++
public:
virtual property Color MenuBorder {
    Color get () override;
}

Field Value

Return Value

A Color that is the border color to use on a MenuStrip.

See Also

vColorTable Class


MenuItemPressedGradientBegin Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..MenuItemPressedGradientBegin Property
vColorTable Class See Also Send Feedback
Gets the starting color of the gradient used when a top-level ToolStripMenuItem is pressed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color MenuItemPressedGradientBegin { get; }
Visual Basic
Public Overrides ReadOnly Property MenuItemPressedGradientBegin As Color
    Get
Visual C++
public:
virtual property Color MenuItemPressedGradientBegin {
    Color get () override;
}

Field Value

Return Value

A Color that is the starting color of the gradient used when a top-level ToolStripMenuItem is pressed.

See Also

vColorTable Class


MenuItemPressedGradientEnd Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..MenuItemPressedGradientEnd Property
vColorTable Class See Also Send Feedback
Gets the end color of the gradient used when a top-level ToolStripMenuItem is pressed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color MenuItemPressedGradientEnd { get; }
Visual Basic
Public Overrides ReadOnly Property MenuItemPressedGradientEnd As Color
    Get
Visual C++
public:
virtual property Color MenuItemPressedGradientEnd {
    Color get () override;
}

Field Value

Return Value

A Color that is the end color of the gradient used when a top-level ToolStripMenuItem is pressed.

See Also

vColorTable Class


MenuItemPressedGradientMiddle Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..MenuItemPressedGradientMiddle Property
vColorTable Class See Also Send Feedback
Gets the middle color of the gradient used when a top-level ToolStripMenuItem is pressed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color MenuItemPressedGradientMiddle { get; }
Visual Basic
Public Overrides ReadOnly Property MenuItemPressedGradientMiddle As Color
    Get
Visual C++
public:
virtual property Color MenuItemPressedGradientMiddle {
    Color get () override;
}

Field Value

Return Value

A Color that is the middle color of the gradient used when a top-level ToolStripMenuItem is pressed.

See Also

vColorTable Class


MenuItemSelected Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..MenuItemSelected Property
vColorTable Class See Also Send Feedback
Gets the solid color to use when a ToolStripMenuItem other than the top-level ToolStripMenuItem is selected.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color MenuItemSelected { get; }
Visual Basic
Public Overrides ReadOnly Property MenuItemSelected As Color
    Get
Visual C++
public:
virtual property Color MenuItemSelected {
    Color get () override;
}

Field Value

Return Value

A Color that is the solid color to use when a ToolStripMenuItem other than the top-level ToolStripMenuItem is selected.

See Also

vColorTable Class


MenuItemSelectedGradientBegin Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..MenuItemSelectedGradientBegin Property
vColorTable Class See Also Send Feedback
Gets the starting color of the gradient used when the ToolStripMenuItem is selected.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color MenuItemSelectedGradientBegin { get; }
Visual Basic
Public Overrides ReadOnly Property MenuItemSelectedGradientBegin As Color
    Get
Visual C++
public:
virtual property Color MenuItemSelectedGradientBegin {
    Color get () override;
}

Field Value

Return Value

A Color that is the starting color of the gradient used when the ToolStripMenuItem is selected.

See Also

vColorTable Class


MenuItemSelectedGradientEnd Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..MenuItemSelectedGradientEnd Property
vColorTable Class See Also Send Feedback
Gets the end color of the gradient used when the ToolStripMenuItem is selected.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color MenuItemSelectedGradientEnd { get; }
Visual Basic
Public Overrides ReadOnly Property MenuItemSelectedGradientEnd As Color
    Get
Visual C++
public:
virtual property Color MenuItemSelectedGradientEnd {
    Color get () override;
}

Field Value

Return Value

A Color that is the end color of the gradient used when the ToolStripMenuItem is selected.

See Also

vColorTable Class


MenuStripGradientBegin Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..MenuStripGradientBegin Property
vColorTable Class See Also Send Feedback
Gets the starting color of the gradient used in the MenuStrip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color MenuStripGradientBegin { get; }
Visual Basic
Public Overrides ReadOnly Property MenuStripGradientBegin As Color
    Get
Visual C++
public:
virtual property Color MenuStripGradientBegin {
    Color get () override;
}

Field Value

Return Value

A Color that is the starting color of the gradient used in the MenuStrip.

See Also

vColorTable Class


MenuStripGradientEnd Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..MenuStripGradientEnd Property
vColorTable Class See Also Send Feedback
Gets the end color of the gradient used in the MenuStrip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color MenuStripGradientEnd { get; }
Visual Basic
Public Overrides ReadOnly Property MenuStripGradientEnd As Color
    Get
Visual C++
public:
virtual property Color MenuStripGradientEnd {
    Color get () override;
}

See Also

vColorTable Class


OverflowButtonGradientBegin Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..OverflowButtonGradientBegin Property
vColorTable Class See Also Send Feedback
Gets the starting color of the gradient used in the ToolStripOverflowButton.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color OverflowButtonGradientBegin { get; }
Visual Basic
Public Overrides ReadOnly Property OverflowButtonGradientBegin As Color
    Get
Visual C++
public:
virtual property Color OverflowButtonGradientBegin {
    Color get () override;
}

Field Value

Return Value

A Color that is the starting color of the gradient used in the ToolStripOverflowButton.

See Also

vColorTable Class


OverflowButtonGradientEnd Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..OverflowButtonGradientEnd Property
vColorTable Class See Also Send Feedback
Gets the end color of the gradient used in the ToolStripOverflowButton.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color OverflowButtonGradientEnd { get; }
Visual Basic
Public Overrides ReadOnly Property OverflowButtonGradientEnd As Color
    Get
Visual C++
public:
virtual property Color OverflowButtonGradientEnd {
    Color get () override;
}

See Also

vColorTable Class


OverflowButtonGradientMiddle Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..OverflowButtonGradientMiddle Property
vColorTable Class See Also Send Feedback
Gets the middle color of the gradient used in the ToolStripOverflowButton.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color OverflowButtonGradientMiddle { get; }
Visual Basic
Public Overrides ReadOnly Property OverflowButtonGradientMiddle As Color
    Get
Visual C++
public:
virtual property Color OverflowButtonGradientMiddle {
    Color get () override;
}

See Also

vColorTable Class


RaftingContainerGradientBegin Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..RaftingContainerGradientBegin Property
vColorTable Class See Also Send Feedback
Gets the starting color of the gradient used in the ToolStripContainer.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color RaftingContainerGradientBegin { get; }
Visual Basic
Public Overrides ReadOnly Property RaftingContainerGradientBegin As Color
    Get
Visual C++
public:
virtual property Color RaftingContainerGradientBegin {
    Color get () override;
}

Field Value

Return Value

A Color that is the starting color of the gradient used in the ToolStripContainer.

See Also

vColorTable Class


RaftingContainerGradientEnd Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..RaftingContainerGradientEnd Property
vColorTable Class See Also Send Feedback
Gets the end color of the gradient used in the ToolStripContainer.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color RaftingContainerGradientEnd { get; }
Visual Basic
Public Overrides ReadOnly Property RaftingContainerGradientEnd As Color
    Get
Visual C++
public:
virtual property Color RaftingContainerGradientEnd {
    Color get () override;
}

See Also

vColorTable Class


SeparatorDark Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..SeparatorDark Property
vColorTable Class See Also Send Feedback
Gets the color to use to for shadow effects on the ToolStripSeparator.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color SeparatorDark { get; }
Visual Basic
Public Overrides ReadOnly Property SeparatorDark As Color
    Get
Visual C++
public:
virtual property Color SeparatorDark {
    Color get () override;
}

Field Value

Return Value

A Color that is the color to use to for shadow effects on the ToolStripSeparator.

See Also

vColorTable Class


SeparatorLight Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..SeparatorLight Property
vColorTable Class See Also Send Feedback
Gets the color to use to for highlight effects on the ToolStripSeparator.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color SeparatorLight { get; }
Visual Basic
Public Overrides ReadOnly Property SeparatorLight As Color
    Get
Visual C++
public:
virtual property Color SeparatorLight {
    Color get () override;
}

See Also

vColorTable Class


StatusStripGradientBegin Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..StatusStripGradientBegin Property
vColorTable Class See Also Send Feedback
Gets the starting color of the gradient used on the StatusStrip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color StatusStripGradientBegin { get; }
Visual Basic
Public Overrides ReadOnly Property StatusStripGradientBegin As Color
    Get
Visual C++
public:
virtual property Color StatusStripGradientBegin {
    Color get () override;
}

Field Value

Return Value

A Color that is the starting color of the gradient used on the StatusStrip.

See Also

vColorTable Class


StatusStripGradientEnd Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..StatusStripGradientEnd Property
vColorTable Class See Also Send Feedback
Gets the end color of the gradient used on the StatusStrip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color StatusStripGradientEnd { get; }
Visual Basic
Public Overrides ReadOnly Property StatusStripGradientEnd As Color
    Get
Visual C++
public:
virtual property Color StatusStripGradientEnd {
    Color get () override;
}

See Also

vColorTable Class


ToolStripBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ToolStripBorder Property
vColorTable Class See Also Send Feedback
Gets the border color to use on the bottom edge of the ToolStrip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ToolStripBorder { get; }
Visual Basic
Public Overrides ReadOnly Property ToolStripBorder As Color
    Get
Visual C++
public:
virtual property Color ToolStripBorder {
    Color get () override;
}

Field Value

Return Value

A Color that is the border color to use on the bottom edge of the ToolStrip.

See Also

vColorTable Class


ToolStripContentPanelGradientBegin Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ToolStripContentPanelGradientBegin Property
vColorTable Class See Also Send Feedback
Gets the starting color of the gradient used in the ToolStripContentPanel.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ToolStripContentPanelGradientBegin { get; }
Visual Basic
Public Overrides ReadOnly Property ToolStripContentPanelGradientBegin As Color
    Get
Visual C++
public:
virtual property Color ToolStripContentPanelGradientBegin {
    Color get () override;
}

Field Value

Return Value

A Color that is the starting color of the gradient used in the ToolStripContentPanel.

See Also

vColorTable Class


ToolStripContentPanelGradientEnd Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ToolStripContentPanelGradientEnd Property
vColorTable Class See Also Send Feedback
Gets the end color of the gradient used in the ToolStripContentPanel.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ToolStripContentPanelGradientEnd { get; }
Visual Basic
Public Overrides ReadOnly Property ToolStripContentPanelGradientEnd As Color
    Get
Visual C++
public:
virtual property Color ToolStripContentPanelGradientEnd {
    Color get () override;
}

Field Value

Return Value

A Color that is the end color of the gradient used in the ToolStripContentPanel.

See Also

vColorTable Class


ToolStripDropDownBackground Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ToolStripDropDownBackground Property
vColorTable Class See Also Send Feedback
Gets the solid background color of the ToolStripDropDown.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ToolStripDropDownBackground { get; }
Visual Basic
Public Overrides ReadOnly Property ToolStripDropDownBackground As Color
    Get
Visual C++
public:
virtual property Color ToolStripDropDownBackground {
    Color get () override;
}

Field Value

Return Value

A Color that is the solid background color of the ToolStripDropDown.

See Also

vColorTable Class


ToolStripGradientBegin Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ToolStripGradientBegin Property
vColorTable Class See Also Send Feedback
Gets the starting color of the gradient used in the ToolStrip background.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ToolStripGradientBegin { get; }
Visual Basic
Public Overrides ReadOnly Property ToolStripGradientBegin As Color
    Get
Visual C++
public:
virtual property Color ToolStripGradientBegin {
    Color get () override;
}

Field Value

Return Value

A Color that is the starting color of the gradient used in the ToolStrip background.

See Also

vColorTable Class


ToolStripGradientEnd Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ToolStripGradientEnd Property
vColorTable Class See Also Send Feedback
Gets the end color of the gradient used in the ToolStrip background.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ToolStripGradientEnd { get; }
Visual Basic
Public Overrides ReadOnly Property ToolStripGradientEnd As Color
    Get
Visual C++
public:
virtual property Color ToolStripGradientEnd {
    Color get () override;
}

Field Value

Return Value

A Color that is the end color of the gradient used in the ToolStrip background.

See Also

vColorTable Class


ToolStripGradientMiddle Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ToolStripGradientMiddle Property
vColorTable Class See Also Send Feedback
Gets the middle color of the gradient used in the ToolStrip background.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ToolStripGradientMiddle { get; }
Visual Basic
Public Overrides ReadOnly Property ToolStripGradientMiddle As Color
    Get
Visual C++
public:
virtual property Color ToolStripGradientMiddle {
    Color get () override;
}

Field Value

Return Value

A Color that is the middle color of the gradient used in the ToolStrip background.

See Also

vColorTable Class


ToolStripPanelGradientBegin Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ToolStripPanelGradientBegin Property
vColorTable Class See Also Send Feedback
Gets the starting color of the gradient used in the ToolStripPanel.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ToolStripPanelGradientBegin { get; }
Visual Basic
Public Overrides ReadOnly Property ToolStripPanelGradientBegin As Color
    Get
Visual C++
public:
virtual property Color ToolStripPanelGradientBegin {
    Color get () override;
}

Field Value

Return Value

A Color that is the starting color of the gradient used in the ToolStripPanel.

See Also

vColorTable Class


ToolStripPanelGradientEnd Property

[image]

VIBlend Controls for WinForms Help Documentation
vColorTable..::..ToolStripPanelGradientEnd Property
vColorTable Class See Also Send Feedback
Gets the end color of the gradient used in the ToolStripPanel.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Utilities (in VIBlend.WinForms.Utilities.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ToolStripPanelGradientEnd { get; }
Visual Basic
Public Overrides ReadOnly Property ToolStripPanelGradientEnd As Color
    Get
Visual C++
public:
virtual property Color ToolStripPanelGradientEnd {
    Color get () override;
}

Field Value

Return Value

A Color that is the end color of the gradient used in the ToolStripPanel.

See Also

vColorTable Class


vComboBox Class

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox Class
Members See Also Send Feedback
Represents vComboBox control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vComboBox : Control, IScrollableControlBase
Visual Basic
Public Class vComboBox _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class vComboBox : public Control,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vComboBox
VIBlend.WinForms.Controls..::..vFontComboBox
VIBlend.WinForms.DataGridView..::..ComboBoxEditor

See Also

vComboBox Members


vComboBox Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox Members
vComboBox Class Constructors Methods Properties Events See Also Send Feedback

The vComboBox type exposes the following members.

Constructors

 | Name | Description
Public method | vComboBox | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrow | Draws the arrow.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDropDownClosed | Called when the drop down is closed.
Protected method | OnDropDownOpened | Called when the drop down is opened.
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemMouseDown | Raises the [E:ItemMouseDown] event.
Protected method | OnItemMouseUp | Raises the [E:ItemMouseUp] event.
Protected method | OnKeyDown | Raises the KeyDown event. (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectedIndexChanged | Raises the SelectedIndexChanged event
Protected method | OnSelectedItemChanged |
Protected method | OnSelectedItemChanging |
Protected method | OnSelectedValueChanged | Raises the SelectedValueChanged event.
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | This member overrides Control.ProcessCmdKey. (Overrides Control..::..ProcessCmdKey(Message%, Keys).)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveSort | Removes the sort.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Reverse | Reverses this instance.
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown | Shows the drop down.
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort(Boolean) | Sorts the specified ascending.
Public method | Sort(IComparer<(Of <<'(ListItem>)>>)) | Sorts the specified comparer.
Public method | Sort(Comparison<(Of <<'(ListItem>)>>)) | Sorts the specified comparison.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoCompleteEnabled | Gets or sets a value indicating whether auto complete is enabled.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Overrides Control..::..BackColor.)
Public property | BackgroundImage | Gets or sets the background image of the control (Overrides Control..::..BackgroundImage.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color which is used when the UseThemeBorderColor property is false.
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the DataSource of the vComboBox
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text.
Public property | DefaultTextColor | Gets or sets the default color of the text.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayMember | Gets or sets the display member associated to the vComboBox.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets the drop down.
Public property | DropDownArrowBackgroundEnabled | Determines whether to the drop-down arrow's background is painted
Public property | DropDownArrowColor | Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false.
Public property | DropDownButtonBackgroundBrush | Gets or sets the background brush.
Public property | DropDownButtonDisabledBackgroundBrush | Gets or sets the disabled background brush.
Public property | DropDownButtonHighlightBackgroundBrush | Gets or sets the HighlightBackground brush.
Public property | DropDownButtonPressedBackgroundBrush | Gets or sets the background brush.
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ComboBox
Public property | DropDownList | Gets or sets whether the combo box is a drop down list.
Public property | DropDownMaximumSize | Gets or sets the maximum size of the drop-down portion of the ComboBox
Public property | DropDownMinimumSize | Gets or sets the maximum size of the drop-down portion of the ComboBox
Public property | DropDownResizeDirection | Gets or sets a value indicating the possible drop-down resize directions
Public property | DropDownWidth | Gets or sets the width in pixels of the drop-down portion of the ComboBox
Public property | EditBase | Gets the edit base.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font that is used to display the text in the editbox of the control (Overrides Control..::..Font.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color which is used to display the text (Overrides Control..::..ForeColor.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImageList | Gets or sets the images list of the vComboBox
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of the items inside the dropdown list of the vComboBox
Public property | Items | Gets the ComboBox Items collection.
Public property | ItemsSpacing |
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | ListBox | Gets the vListBox inside the vComboBox.
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Indicates whether the control should draw right-to-left for RTL langauges (Overrides Control..::..RightToLeft.)
Public property | RoundedCornersMaskListItem | Gets or sets the mask that determines which corners of a ListItem are rounded
Public property | RoundedCornersRadiusListItem | Gets or sets the rounded corners radius of the ListItems.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the currently selected item. Returns -1 if there is no item selected
Public property | SelectedItem | Gets or sets the currently selected item of the drop down list of the combo box control.
Public property | SelectedValue | Gets or sets the selected value.
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowGrip | Gets or sets a value indicating whether grip is shown
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text displayed in the editbox of the control (Overrides Control..::..Text.)
Public property | Theme | Gets or sets the Theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultDropDownWidth | Gets or sets a value indicating whether to use the default drop down width.
Public property | UseDropDownButtonThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property.
Public property | UseThemeBorderColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property.
Public property | UseThemeDropDownArrowColor | Gets or sets whether to use the Theme default arrow color.
Public property | UseThemeFont | Gets or sets whether to use the Theme Font or the control's Font property.
Public property | UseThemeForeColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets a string that specifies the property of the data source from which to draw the value.
Public property | VIBlendScrollBarsTheme | Gets or sets the theme of the treeview scrollbars using one of the built-in themes.
Public property | VIBlendTheme | Gets or sets the theme of the control to one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DropDownClose |
Public event | DropDownOpen | Occurs when the DropDown is opened.
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemMouseDown | Occurs when the mouse is clicked over a ListItem.
Public event | ItemMouseUp | Occurs when the mouse is clicked over a ListItem.
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the selected index has changed
Public event | SelectedItemChanged | occurs when the selection is changed.
Public event | SelectedItemChanging | Occurs when the selection is changing.
Public event | SelectedValueChanged | Occurs when the SelectedValue has changed.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vComboBox Class


vComboBox Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox Constructor
vComboBox Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vComboBox()
Visual Basic
Public Sub New
Visual C++
public:
vComboBox()

See Also

vComboBox Class


vComboBox Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox Methods
vComboBox Class See Also Send Feedback

The vComboBox type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrow | Draws the arrow.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDropDownClosed | Called when the drop down is closed.
Protected method | OnDropDownOpened | Called when the drop down is opened.
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemMouseDown | Raises the [E:ItemMouseDown] event.
Protected method | OnItemMouseUp | Raises the [E:ItemMouseUp] event.
Protected method | OnKeyDown | Raises the KeyDown event. (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectedIndexChanged | Raises the SelectedIndexChanged event
Protected method | OnSelectedItemChanged |
Protected method | OnSelectedItemChanging |
Protected method | OnSelectedValueChanged | Raises the SelectedValueChanged event.
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | This member overrides Control.ProcessCmdKey. (Overrides Control..::..ProcessCmdKey(Message%, Keys).)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveSort | Removes the sort.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Reverse | Reverses this instance.
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown | Shows the drop down.
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort(Boolean) | Sorts the specified ascending.
Public method | Sort(IComparer<(Of <<'(ListItem>)>>)) | Sorts the specified comparer.
Public method | Sort(Comparison<(Of <<'(ListItem>)>>)) | Sorts the specified comparison.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vComboBox Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..AccessibilityNotifyClients Method
vComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vComboBox Class
vComboBox Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..BeginInvoke Method
vComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vComboBox Class
vComboBox Members


CloseDropDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..CloseDropDown Method
vComboBox Class See Also Send Feedback
Closes the drop down.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void CloseDropDown()
Visual Basic
Public Sub CloseDropDown
Visual C++
public:
void CloseDropDown()

See Also

vComboBox Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..Dispose Method
vComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vComboBox Class
vComboBox Members


DrawArrow Method

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DrawArrow Method
vComboBox Class See Also Send Feedback
Draws the arrow.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DrawArrow(
    PaintEventArgs e
)
Visual Basic
Protected Overridable Sub DrawArrow ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void DrawArrow(
    PaintEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
The PaintEventArgs instance containing the event data.

See Also

vComboBox Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..GetChildAtPoint Method
vComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vComboBox Class
vComboBox Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..Invalidate Method
vComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vComboBox Class
vComboBox Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..Invoke Method
vComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vComboBox Class
vComboBox Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..MemberwiseClone Method
vComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vComboBox Class
vComboBox Members


OnDropDownClosed Method

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..OnDropDownClosed Method
vComboBox Class See Also Send Feedback
Called when the drop down is closed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnDropDownClosed()
Visual Basic
Protected Overridable Sub OnDropDownClosed
Visual C++
protected:
virtual void OnDropDownClosed()

See Also

vComboBox Class


OnDropDownOpened Method

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..OnDropDownOpened Method
vComboBox Class See Also Send Feedback
Called when the drop down is opened.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnDropDownOpened()
Visual Basic
Protected Overridable Sub OnDropDownOpened
Visual C++
protected:
virtual void OnDropDownOpened()

See Also

vComboBox Class


OnItemMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..OnItemMouseDown Method
vComboBox Class See Also Send Feedback
Raises the [E:ItemMouseDown] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnItemMouseDown(
    ListItemMouseEventArgs args
)
Visual Basic
Protected Overridable Sub OnItemMouseDown ( _
    args As ListItemMouseEventArgs _
)
Visual C++
protected:
virtual void OnItemMouseDown(
    ListItemMouseEventArgs^ args
)

Parameters

args
Type: ListItemMouseEventArgs
The ListItemMouseEventArgs instance containing the event data.

See Also

vComboBox Class


OnItemMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..OnItemMouseUp Method
vComboBox Class See Also Send Feedback
Raises the [E:ItemMouseUp] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnItemMouseUp(
    ListItemMouseEventArgs args
)
Visual Basic
Protected Overridable Sub OnItemMouseUp ( _
    args As ListItemMouseEventArgs _
)
Visual C++
protected:
virtual void OnItemMouseUp(
    ListItemMouseEventArgs^ args
)

Parameters

args
Type: ListItemMouseEventArgs
The ListItemMouseEventArgs instance containing the event data.

See Also

vComboBox Class


OnKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..OnKeyDown Method
vComboBox Class See Also Send Feedback
Raises the KeyDown event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
A KeyEventArgs that contains the event data.

See Also

vComboBox Class


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..OnLayout Method
vComboBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs

See Also

vComboBox Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..OnPaint Method
vComboBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vComboBox Class


OnSelectedIndexChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..OnSelectedIndexChanged Method
vComboBox Class See Also Send Feedback
Raises the SelectedIndexChanged event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnSelectedIndexChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnSelectedIndexChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSelectedIndexChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vComboBox Class


OnSelectedItemChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..OnSelectedItemChanged Method
vComboBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnSelectedItemChanged()
Visual Basic
Protected Friend Overridable Sub OnSelectedItemChanged
Visual C++
protected public:
virtual void OnSelectedItemChanged()

See Also

vComboBox Class


OnSelectedItemChanging Method

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..OnSelectedItemChanging Method
vComboBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnSelectedItemChanging(
    ListItemChangingEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnSelectedItemChanging ( _
    args As ListItemChangingEventArgs _
)
Visual C++
protected public:
virtual void OnSelectedItemChanging(
    ListItemChangingEventArgs^ args
)

Parameters

args
Type: ListItemChangingEventArgs

See Also

vComboBox Class


OnSelectedValueChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..OnSelectedValueChanged Method
vComboBox Class See Also Send Feedback
Raises the SelectedValueChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnSelectedValueChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnSelectedValueChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSelectedValueChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vComboBox Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..PerformLayout Method
vComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vComboBox Class
vComboBox Members


ProcessCmdKey Method

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..ProcessCmdKey Method
vComboBox Class See Also Send Feedback
This member overrides Control.ProcessCmdKey.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override bool ProcessCmdKey(
    ref Message msg,
    Keys keyData
)
Visual Basic
Protected Overrides Function ProcessCmdKey ( _
    ByRef msg As Message, _
    keyData As Keys _
) As Boolean
Visual C++
protected:
virtual bool ProcessCmdKey(
    Message% msg,
    Keys keyData
) override

Parameters

msg
Type: System.Windows.Forms..::..Message %
A Message, passed by reference, that represents the window message to process.
keyData
Type: System.Windows.Forms..::..Keys
One of the Keys values that represents the key to process.

Return Value

true if the character was processed by the control; otherwise, false.

See Also

vComboBox Class


RemoveSort Method

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..RemoveSort Method
vComboBox Class See Also Send Feedback
Removes the sort.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void RemoveSort()
Visual Basic
Public Sub RemoveSort
Visual C++
public:
void RemoveSort()

See Also

vComboBox Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..ResumeLayout Method
vComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vComboBox Class
vComboBox Members


Reverse Method

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..Reverse Method
vComboBox Class See Also Send Feedback
Reverses this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Reverse()
Visual Basic
Public Sub Reverse
Visual C++
public:
void Reverse()

See Also

vComboBox Class


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..RtlTranslateAlignment Method
vComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vComboBox Class
vComboBox Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..Scale Method
vComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vComboBox Class
vComboBox Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..Select Method
vComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vComboBox Class
vComboBox Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..SetBounds Method
vComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vComboBox Class
vComboBox Members


ShowDropDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..ShowDropDown Method
vComboBox Class See Also Send Feedback
Shows the drop down.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void ShowDropDown(
    Point location
)
Visual Basic
Public Overridable Sub ShowDropDown ( _
    location As Point _
)
Visual C++
public:
virtual void ShowDropDown(
    Point location
)

Parameters

location
Type: System.Drawing..::..Point
The location.

See Also

vComboBox Class


Sort Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..Sort Method
vComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort(Boolean) | Sorts the specified ascending.
Public method | Sort(IComparer<(Of <<'(ListItem>)>>)) | Sorts the specified comparer.
Public method | Sort(Comparison<(Of <<'(ListItem>)>>)) | Sorts the specified comparison.

See Also

vComboBox Class
vComboBox Members


Sort Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..Sort Method (Boolean)
vComboBox Class See Also Send Feedback
Sorts the specified ascending.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Sort(
    bool ascending
)
Visual Basic
Public Sub Sort ( _
    ascending As Boolean _
)
Visual C++
public:
void Sort(
    bool ascending
)

Parameters

ascending
Type: System..::..Boolean
if set to true ascending.

See Also

vComboBox Class
Sort Overload


Sort Method (IComparer(ListItem))

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..Sort Method (IComparer<(Of <(<'ListItem>)>)>)
vComboBox Class See Also Send Feedback
Sorts the specified comparer.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Sort(
    IComparer<ListItem> comparer
)
Visual Basic
Public Sub Sort ( _
    comparer As IComparer(Of ListItem) _
)
Visual C++
public:
void Sort(
    IComparer<ListItem^>^ comparer
)

Parameters

comparer
Type: System.Collections.Generic..::..IComparer <(Of <(<' ListItem >)>)>
The comparer.

See Also

vComboBox Class
Sort Overload


Sort Method (Comparison(ListItem))

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..Sort Method (Comparison<(Of <(<'ListItem>)>)>)
vComboBox Class See Also Send Feedback
Sorts the specified comparison.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Sort(
    Comparison<ListItem> comparison
)
Visual Basic
Public Sub Sort ( _
    comparison As Comparison(Of ListItem) _
)
Visual C++
public:
void Sort(
    Comparison<ListItem^>^ comparison
)

Parameters

comparison
Type: System..::..Comparison <(Of <(<' ListItem >)>)>
The comparison.

See Also

vComboBox Class
Sort Overload


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..UpdateBounds Method
vComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vComboBox Class
vComboBox Members


vComboBox Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox Properties
vComboBox Class See Also Send Feedback

The vComboBox type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoCompleteEnabled | Gets or sets a value indicating whether auto complete is enabled.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Overrides Control..::..BackColor.)
Public property | BackgroundImage | Gets or sets the background image of the control (Overrides Control..::..BackgroundImage.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color which is used when the UseThemeBorderColor property is false.
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the DataSource of the vComboBox
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text.
Public property | DefaultTextColor | Gets or sets the default color of the text.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayMember | Gets or sets the display member associated to the vComboBox.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets the drop down.
Public property | DropDownArrowBackgroundEnabled | Determines whether to the drop-down arrow's background is painted
Public property | DropDownArrowColor | Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false.
Public property | DropDownButtonBackgroundBrush | Gets or sets the background brush.
Public property | DropDownButtonDisabledBackgroundBrush | Gets or sets the disabled background brush.
Public property | DropDownButtonHighlightBackgroundBrush | Gets or sets the HighlightBackground brush.
Public property | DropDownButtonPressedBackgroundBrush | Gets or sets the background brush.
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ComboBox
Public property | DropDownList | Gets or sets whether the combo box is a drop down list.
Public property | DropDownMaximumSize | Gets or sets the maximum size of the drop-down portion of the ComboBox
Public property | DropDownMinimumSize | Gets or sets the maximum size of the drop-down portion of the ComboBox
Public property | DropDownResizeDirection | Gets or sets a value indicating the possible drop-down resize directions
Public property | DropDownWidth | Gets or sets the width in pixels of the drop-down portion of the ComboBox
Public property | EditBase | Gets the edit base.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font that is used to display the text in the editbox of the control (Overrides Control..::..Font.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color which is used to display the text (Overrides Control..::..ForeColor.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImageList | Gets or sets the images list of the vComboBox
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of the items inside the dropdown list of the vComboBox
Public property | Items | Gets the ComboBox Items collection.
Public property | ItemsSpacing |
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | ListBox | Gets the vListBox inside the vComboBox.
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Indicates whether the control should draw right-to-left for RTL langauges (Overrides Control..::..RightToLeft.)
Public property | RoundedCornersMaskListItem | Gets or sets the mask that determines which corners of a ListItem are rounded
Public property | RoundedCornersRadiusListItem | Gets or sets the rounded corners radius of the ListItems.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the currently selected item. Returns -1 if there is no item selected
Public property | SelectedItem | Gets or sets the currently selected item of the drop down list of the combo box control.
Public property | SelectedValue | Gets or sets the selected value.
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowGrip | Gets or sets a value indicating whether grip is shown
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text displayed in the editbox of the control (Overrides Control..::..Text.)
Public property | Theme | Gets or sets the Theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultDropDownWidth | Gets or sets a value indicating whether to use the default drop down width.
Public property | UseDropDownButtonThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property.
Public property | UseThemeBorderColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property.
Public property | UseThemeDropDownArrowColor | Gets or sets whether to use the Theme default arrow color.
Public property | UseThemeFont | Gets or sets whether to use the Theme Font or the control's Font property.
Public property | UseThemeForeColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets a string that specifies the property of the data source from which to draw the value.
Public property | VIBlendScrollBarsTheme | Gets or sets the theme of the treeview scrollbars using one of the built-in themes.
Public property | VIBlendTheme | Gets or sets the theme of the control to one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vComboBox Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..AllowAnimations Property
vComboBox Class See Also Send Feedback
Determines whether to use animations

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vComboBox Class


AutoCompleteEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..AutoCompleteEnabled Property
vComboBox Class See Also Send Feedback
Gets or sets a value indicating whether auto complete is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AutoCompleteEnabled { get; set; }
Visual Basic
Public Property AutoCompleteEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool AutoCompleteEnabled {
    bool get ();
    void set (bool value);
}

See Also

vComboBox Class


BackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..BackColor Property
vComboBox Class See Also Send Feedback
Gets or sets the background color for the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color BackColor { get; set; }
Visual Basic
Public Overrides Property BackColor As Color
    Get
    Set
Visual C++
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}

See Also

vComboBox Class


BackgroundImage Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..BackgroundImage Property
vComboBox Class See Also Send Feedback
Gets or sets the background image of the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Image BackgroundImage { get; set; }
Visual Basic
Public Overrides Property BackgroundImage As Image
    Get
    Set
Visual C++
public:
virtual property Image^ BackgroundImage {
    Image^ get () override;
    void set (Image^ value) override;
}

See Also

vComboBox Class


BorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..BorderColor Property
vComboBox Class See Also Send Feedback
Gets or sets the border color which is used when the UseThemeBorderColor property is false.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BorderColor { get; set; }
Visual Basic
Public Property BorderColor As Color
    Get
    Set
Visual C++
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}

See Also

vComboBox Class


DataSource Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DataSource Property
vComboBox Class See Also Send Feedback
Gets or sets the DataSource of the vComboBox

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object DataSource { get; set; }
Visual Basic
Public Property DataSource As Object
    Get
    Set
Visual C++
public:
property Object^ DataSource {
    Object^ get ();
    void set (Object^ value);
}

See Also

vComboBox Class


DefaultText Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DefaultText Property
vComboBox Class See Also Send Feedback
Gets or sets the default text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string DefaultText { get; set; }
Visual Basic
Public Property DefaultText As String
    Get
    Set
Visual C++
public:
property String^ DefaultText {
    String^ get ();
    void set (String^ value);
}

Field Value

The default text.

See Also

vComboBox Class


DefaultTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DefaultTextColor Property
vComboBox Class See Also Send Feedback
Gets or sets the default color of the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DefaultTextColor { get; set; }
Visual Basic
Public Property DefaultTextColor As Color
    Get
    Set
Visual C++
public:
property Color DefaultTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The default color of the text.

See Also

vComboBox Class


DisplayMember Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DisplayMember Property
vComboBox Class See Also Send Feedback
Gets or sets the display member associated to the vComboBox.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string DisplayMember { get; set; }
Visual Basic
Public Property DisplayMember As String
    Get
    Set
Visual C++
public:
property String^ DisplayMember {
    String^ get ();
    void set (String^ value);
}

See Also

vComboBox Class


DropDown Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DropDown Property
vComboBox Class See Also Send Feedback
Gets the drop down.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDropDownBase DropDown { get; }
Visual Basic
Public ReadOnly Property DropDown As vDropDownBase
    Get
Visual C++
public:
property vDropDownBase^ DropDown {
    vDropDownBase^ get ();
}

Field Value

The drop down.

See Also

vComboBox Class


DropDownArrowBackgroundEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DropDownArrowBackgroundEnabled Property
vComboBox Class See Also Send Feedback
Determines whether to the drop-down arrow's background is painted

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool DropDownArrowBackgroundEnabled { get; set; }
Visual Basic
Public Property DropDownArrowBackgroundEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool DropDownArrowBackgroundEnabled {
    bool get ();
    void set (bool value);
}

See Also

vComboBox Class


DropDownArrowColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DropDownArrowColor Property
vComboBox Class See Also Send Feedback
Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DropDownArrowColor { get; set; }
Visual Basic
Public Property DropDownArrowColor As Color
    Get
    Set
Visual C++
public:
property Color DropDownArrowColor {
    Color get ();
    void set (Color value);
}

See Also

vComboBox Class


DropDownButtonBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DropDownButtonBackgroundBrush Property
vComboBox Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush DropDownButtonBackgroundBrush { get; set; }
Visual Basic
Public Property DropDownButtonBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ DropDownButtonBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vComboBox Class


DropDownButtonDisabledBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DropDownButtonDisabledBackgroundBrush Property
vComboBox Class See Also Send Feedback
Gets or sets the disabled background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush DropDownButtonDisabledBackgroundBrush { get; set; }
Visual Basic
Public Property DropDownButtonDisabledBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ DropDownButtonDisabledBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The disabled background brush.

See Also

vComboBox Class


DropDownButtonHighlightBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DropDownButtonHighlightBackgroundBrush Property
vComboBox Class See Also Send Feedback
Gets or sets the HighlightBackground brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush DropDownButtonHighlightBackgroundBrush { get; set; }
Visual Basic
Public Property DropDownButtonHighlightBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ DropDownButtonHighlightBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The HighlightBackground brush.

See Also

vComboBox Class


DropDownButtonPressedBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DropDownButtonPressedBackgroundBrush Property
vComboBox Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush DropDownButtonPressedBackgroundBrush { get; set; }
Visual Basic
Public Property DropDownButtonPressedBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ DropDownButtonPressedBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vComboBox Class


DropDownHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DropDownHeight Property
vComboBox Class See Also Send Feedback
Gets or sets the height in pixels of the drop-down portion of the ComboBox

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int DropDownHeight { get; set; }
Visual Basic
Public Property DropDownHeight As Integer
    Get
    Set
Visual C++
public:
property int DropDownHeight {
    int get ();
    void set (int value);
}

See Also

vComboBox Class


DropDownList Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DropDownList Property
vComboBox Class See Also Send Feedback
Gets or sets whether the combo box is a drop down list.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool DropDownList { get; set; }
Visual Basic
Public Property DropDownList As Boolean
    Get
    Set
Visual C++
public:
property bool DropDownList {
    bool get ();
    void set (bool value);
}

See Also

vComboBox Class


DropDownMaximumSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DropDownMaximumSize Property
vComboBox Class See Also Send Feedback
Gets or sets the maximum size of the drop-down portion of the ComboBox

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Size DropDownMaximumSize { get; set; }
Visual Basic
Public Property DropDownMaximumSize As Size
    Get
    Set
Visual C++
public:
property Size DropDownMaximumSize {
    Size get ();
    void set (Size value);
}

See Also

vComboBox Class


DropDownMinimumSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DropDownMinimumSize Property
vComboBox Class See Also Send Feedback
Gets or sets the maximum size of the drop-down portion of the ComboBox

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Size DropDownMinimumSize { get; set; }
Visual Basic
Public Property DropDownMinimumSize As Size
    Get
    Set
Visual C++
public:
property Size DropDownMinimumSize {
    Size get ();
    void set (Size value);
}

See Also

vComboBox Class


DropDownResizeDirection Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DropDownResizeDirection Property
vComboBox Class See Also Send Feedback
Gets or sets a value indicating the possible drop-down resize directions

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public SizingDirection DropDownResizeDirection { get; set; }
Visual Basic
Public Property DropDownResizeDirection As SizingDirection
    Get
    Set
Visual C++
public:
property SizingDirection DropDownResizeDirection {
    SizingDirection get ();
    void set (SizingDirection value);
}

See Also

vComboBox Class


DropDownWidth Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DropDownWidth Property
vComboBox Class See Also Send Feedback
Gets or sets the width in pixels of the drop-down portion of the ComboBox

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int DropDownWidth { get; set; }
Visual Basic
Public Property DropDownWidth As Integer
    Get
    Set
Visual C++
public:
property int DropDownWidth {
    int get ();
    void set (int value);
}

See Also

vComboBox Class


EditBase Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..EditBase Property
vComboBox Class See Also Send Feedback
Gets the edit base.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vButtonEditBase EditBase { get; }
Visual Basic
Public ReadOnly Property EditBase As vButtonEditBase
    Get
Visual C++
public:
property vButtonEditBase^ EditBase {
    vButtonEditBase^ get ();
}

Field Value

The edit base.

See Also

vComboBox Class


Font Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..Font Property
vComboBox Class See Also Send Feedback
Gets or sets the font that is used to display the text in the editbox of the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Font Font { get; set; }
Visual Basic
Public Overrides Property Font As Font
    Get
    Set
Visual C++
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}

See Also

vComboBox Class


ForeColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..ForeColor Property
vComboBox Class See Also Send Feedback
Gets or sets the foreground color which is used to display the text

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ForeColor { get; set; }
Visual Basic
Public Overrides Property ForeColor As Color
    Get
    Set
Visual C++
public:
virtual property Color ForeColor {
    Color get () override;
    void set (Color value) override;
}

See Also

vComboBox Class


ImageList Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..ImageList Property
vComboBox Class See Also Send Feedback
Gets or sets the images list of the vComboBox

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ImageList ImageList { get; set; }
Visual Basic
Public Property ImageList As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ ImageList {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

vComboBox Class


ItemHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..ItemHeight Property
vComboBox Class See Also Send Feedback
Gets or sets the height of the items inside the dropdown list of the vComboBox

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ItemHeight { get; set; }
Visual Basic
Public Property ItemHeight As Integer
    Get
    Set
Visual C++
public:
property int ItemHeight {
    int get ();
    void set (int value);
}

See Also

vComboBox Class


Items Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..Items Property
vComboBox Class See Also Send Feedback
Gets the ComboBox Items collection.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ListItemsCollection Items { get; }
Visual Basic
Public ReadOnly Property Items As ListItemsCollection
    Get
Visual C++
public:
property ListItemsCollection^ Items {
    ListItemsCollection^ get ();
}

See Also

vComboBox Class


ItemsSpacing Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..ItemsSpacing Property
vComboBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ItemsSpacing { get; set; }
Visual Basic
Public Property ItemsSpacing As Integer
    Get
    Set
Visual C++
public:
property int ItemsSpacing {
    int get ();
    void set (int value);
}

See Also

vComboBox Class


ListBox Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..ListBox Property
vComboBox Class See Also Send Feedback
Gets the vListBox inside the vComboBox.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vListBox ListBox { get; set; }
Visual Basic
Public Property ListBox As vListBox
    Get
    Set
Visual C++
public:
property vListBox^ ListBox {
    vListBox^ get ();
    void set (vListBox^ value);
}

See Also

vComboBox Class


RightToLeft Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..RightToLeft Property
vComboBox Class See Also Send Feedback
Indicates whether the control should draw right-to-left for RTL langauges

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override RightToLeft RightToLeft { get; set; }
Visual Basic
Public Overrides Property RightToLeft As RightToLeft
    Get
    Set
Visual C++
public:
virtual property RightToLeft RightToLeft {
    RightToLeft get () override;
    void set (RightToLeft value) override;
}

See Also

vComboBox Class


RoundedCornersMaskListItem Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..RoundedCornersMaskListItem Property
vComboBox Class See Also Send Feedback
Gets or sets the mask that determines which corners of a ListItem are rounded

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public byte RoundedCornersMaskListItem { get; set; }
Visual Basic
Public Property RoundedCornersMaskListItem As Byte
    Get
    Set
Visual C++
public:
property unsigned char RoundedCornersMaskListItem {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

vComboBox Class


RoundedCornersRadiusListItem Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..RoundedCornersRadiusListItem Property
vComboBox Class See Also Send Feedback
Gets or sets the rounded corners radius of the ListItems.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int RoundedCornersRadiusListItem { get; set; }
Visual Basic
Public Property RoundedCornersRadiusListItem As Integer
    Get
    Set
Visual C++
public:
property int RoundedCornersRadiusListItem {
    int get ();
    void set (int value);
}

See Also

vComboBox Class


SelectedIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..SelectedIndex Property
vComboBox Class See Also Send Feedback
Gets or sets the index of the currently selected item. Returns -1 if there is no item selected

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic
Public Property SelectedIndex As Integer
    Get
    Set
Visual C++
public:
property int SelectedIndex {
    int get ();
    void set (int value);
}

See Also

vComboBox Class


SelectedItem Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..SelectedItem Property
vComboBox Class See Also Send Feedback
Gets or sets the currently selected item of the drop down list of the combo box control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ListItem SelectedItem { get; set; }
Visual Basic
Public Property SelectedItem As ListItem
    Get
    Set
Visual C++
public:
property ListItem^ SelectedItem {
    ListItem^ get ();
    void set (ListItem^ value);
}

See Also

vComboBox Class


SelectedValue Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..SelectedValue Property
vComboBox Class See Also Send Feedback
Gets or sets the selected value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object SelectedValue { get; set; }
Visual Basic
Public Property SelectedValue As Object
    Get
    Set
Visual C++
public:
property Object^ SelectedValue {
    Object^ get ();
    void set (Object^ value);
}

Field Value

The selected value.

See Also

vComboBox Class


ShowDefaultText Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..ShowDefaultText Property
vComboBox Class See Also Send Feedback
Gets or sets a value indicating whether to draw default text

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowDefaultText { get; set; }
Visual Basic
Public Property ShowDefaultText As Boolean
    Get
    Set
Visual C++
public:
property bool ShowDefaultText {
    bool get ();
    void set (bool value);
}

See Also

vComboBox Class


ShowGrip Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..ShowGrip Property
vComboBox Class See Also Send Feedback
Gets or sets a value indicating whether grip is shown

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowGrip { get; set; }
Visual Basic
Public Property ShowGrip As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGrip {
    bool get ();
    void set (bool value);
}

See Also

vComboBox Class


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..Text Property
vComboBox Class See Also Send Feedback
Gets or sets the text displayed in the editbox of the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string Text { get; set; }
Visual Basic
Public Overrides Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

See Also

vComboBox Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..Theme Property
vComboBox Class See Also Send Feedback
Gets or sets the Theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vComboBox Class


UseDefaultDropDownWidth Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..UseDefaultDropDownWidth Property
vComboBox Class See Also Send Feedback
Gets or sets a value indicating whether to use the default drop down width.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseDefaultDropDownWidth { get; set; }
Visual Basic
Public Property UseDefaultDropDownWidth As Boolean
    Get
    Set
Visual C++
public:
property bool UseDefaultDropDownWidth {
    bool get ();
    void set (bool value);
}

See Also

vComboBox Class


UseDropDownButtonThemeBackground Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..UseDropDownButtonThemeBackground Property
vComboBox Class See Also Send Feedback
Gets or sets a value indicating whether to use theme's background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseDropDownButtonThemeBackground { get; set; }
Visual Basic
Public Property UseDropDownButtonThemeBackground As Boolean
    Get
    Set
Visual C++
public:
property bool UseDropDownButtonThemeBackground {
    bool get ();
    void set (bool value);
}

See Also

vComboBox Class


UseThemeBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..UseThemeBackColor Property
vComboBox Class See Also Send Feedback
Gets or sets whether to use the Theme BackColor or the control's BackColor property.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBackColor { get; set; }
Visual Basic
Public Property UseThemeBackColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBackColor {
    bool get ();
    void set (bool value);
}

See Also

vComboBox Class


UseThemeBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..UseThemeBorderColor Property
vComboBox Class See Also Send Feedback
Gets or sets whether to use the Theme BorderColor or the control's BackColor property.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBorderColor { get; set; }
Visual Basic
Public Property UseThemeBorderColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBorderColor {
    bool get ();
    void set (bool value);
}

See Also

vComboBox Class


UseThemeDropDownArrowColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..UseThemeDropDownArrowColor Property
vComboBox Class See Also Send Feedback
Gets or sets whether to use the Theme default arrow color.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeDropDownArrowColor { get; set; }
Visual Basic
Public Property UseThemeDropDownArrowColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeDropDownArrowColor {
    bool get ();
    void set (bool value);
}

See Also

vComboBox Class


UseThemeFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..UseThemeFont Property
vComboBox Class See Also Send Feedback
Gets or sets whether to use the Theme Font or the control's Font property.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeFont { get; set; }
Visual Basic
Public Property UseThemeFont As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeFont {
    bool get ();
    void set (bool value);
}

See Also

vComboBox Class


UseThemeForeColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..UseThemeForeColor Property
vComboBox Class See Also Send Feedback
Gets or sets whether to use the Theme BorderColor or the control's BackColor property.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeForeColor { get; set; }
Visual Basic
Public Property UseThemeForeColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeForeColor {
    bool get ();
    void set (bool value);
}

See Also

vComboBox Class


ValueMember Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..ValueMember Property
vComboBox Class See Also Send Feedback
Gets or sets a string that specifies the property of the data source from which to draw the value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string ValueMember { get; set; }
Visual Basic
Public Property ValueMember As String
    Get
    Set
Visual C++
public:
property String^ ValueMember {
    String^ get ();
    void set (String^ value);
}

See Also

vComboBox Class


VIBlendScrollBarsTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..VIBlendScrollBarsTheme Property
vComboBox Class See Also Send Feedback
Gets or sets the theme of the treeview scrollbars using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendScrollBarsTheme { get; set; }
Visual Basic
Public Property VIBlendScrollBarsTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendScrollBarsTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vComboBox Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..VIBlendTheme Property
vComboBox Class See Also Send Feedback
Gets or sets the theme of the control to one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vComboBox Class


vComboBox Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vComboBox Events
vComboBox Class See Also Send Feedback

The vComboBox type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DropDownClose |
Public event | DropDownOpen | Occurs when the DropDown is opened.
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemMouseDown | Occurs when the mouse is clicked over a ListItem.
Public event | ItemMouseUp | Occurs when the mouse is clicked over a ListItem.
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the selected index has changed
Public event | SelectedItemChanged | occurs when the selection is changed.
Public event | SelectedItemChanging | Occurs when the selection is changing.
Public event | SelectedValueChanged | Occurs when the SelectedValue has changed.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vComboBox Class


DropDownClose Event

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DropDownClose Event
vComboBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler DropDownClose
Visual Basic
Public Event DropDownClose As EventHandler
Visual C++
public:
 event EventHandler^ DropDownClose {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vComboBox Class


DropDownOpen Event

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..DropDownOpen Event
vComboBox Class See Also Send Feedback
Occurs when the DropDown is opened.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler DropDownOpen
Visual Basic
Public Event DropDownOpen As EventHandler
Visual C++
public:
 event EventHandler^ DropDownOpen {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vComboBox Class


ItemMouseDown Event

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..ItemMouseDown Event
vComboBox Class See Also Send Feedback
Occurs when the mouse is clicked over a ListItem.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<ListItemMouseEventArgs> ItemMouseDown
Visual Basic
Public Event ItemMouseDown As EventHandler(Of ListItemMouseEventArgs)
Visual C++
public:
 event EventHandler<ListItemMouseEventArgs^>^ ItemMouseDown {
    void add (EventHandler<ListItemMouseEventArgs^>^ value);
    void remove (EventHandler<ListItemMouseEventArgs^>^ value);
}

See Also

vComboBox Class


ItemMouseUp Event

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..ItemMouseUp Event
vComboBox Class See Also Send Feedback
Occurs when the mouse is clicked over a ListItem.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<ListItemMouseEventArgs> ItemMouseUp
Visual Basic
Public Event ItemMouseUp As EventHandler(Of ListItemMouseEventArgs)
Visual C++
public:
 event EventHandler<ListItemMouseEventArgs^>^ ItemMouseUp {
    void add (EventHandler<ListItemMouseEventArgs^>^ value);
    void remove (EventHandler<ListItemMouseEventArgs^>^ value);
}

See Also

vComboBox Class


SelectedIndexChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..SelectedIndexChanged Event
vComboBox Class See Also Send Feedback
Occurs when the selected index has changed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler SelectedIndexChanged
Visual Basic
Public Event SelectedIndexChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectedIndexChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vComboBox Class


SelectedItemChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..SelectedItemChanged Event
vComboBox Class See Also Send Feedback
occurs when the selection is changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler SelectedItemChanged
Visual Basic
Public Event SelectedItemChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectedItemChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vComboBox Class


SelectedItemChanging Event

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..SelectedItemChanging Event
vComboBox Class See Also Send Feedback
Occurs when the selection is changing.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<ListItemChangingEventArgs> SelectedItemChanging
Visual Basic
Public Event SelectedItemChanging As EventHandler(Of ListItemChangingEventArgs)
Visual C++
public:
 event EventHandler<ListItemChangingEventArgs^>^ SelectedItemChanging {
    void add (EventHandler<ListItemChangingEventArgs^>^ value);
    void remove (EventHandler<ListItemChangingEventArgs^>^ value);
}

See Also

vComboBox Class


SelectedValueChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vComboBox..::..SelectedValueChanged Event
vComboBox Class See Also Send Feedback
Occurs when the SelectedValue has changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler SelectedValueChanged
Visual Basic
Public Event SelectedValueChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectedValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vComboBox Class


vContextMenu Class

[image]

VIBlend Controls for WinForms Help Documentation
vContextMenu Class
Members See Also Send Feedback
Represents a vContextMenu control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vContextMenu : ContextMenu
Visual Basic
Public Class vContextMenu _
    Inherits ContextMenu
Visual C++
public ref class vContextMenu : public ContextMenu

Remarks

Displays a shortcut menu when the user right-clicks on the associated control that supports context menu operations.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Menu
System.Windows.Forms..::..ContextMenu
VIBlend.WinForms.Controls..::..vContextMenu

See Also

vContextMenu Members


vContextMenu Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vContextMenu Members
vContextMenu Class Constructors Methods Properties Events See Also Send Feedback

The vContextMenu type exposes the following members.

Constructors

 | Name | Description
Public method | vContextMenu()()()() | vContextMenu constructor
Public method | vContextMenu(array<MenuItem>[]()[][]) | vContextMenu constructor

Methods

 | Name | Description
Protected method | CloneMenu | Copies the Menu that is passed as a parameter to the current Menu. (Inherited from Menu.)
Protected method | CreateMenuHandle | Creates a new handle to the Menu. (Inherited from Menu.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes of the resources, other than memory, used by the Menu. (Inherited from Menu.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindMenuItem | Gets the MenuItem that contains the value specified. (Inherited from Menu.)
Protected method | FindMergePosition | Returns the position at which a menu item should be inserted into the menu. (Inherited from Menu.)
Public method | GetContextMenu | Gets the ContextMenu that contains this menu. (Inherited from Menu.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMainMenu | Gets the MainMenu that contains this menu. (Inherited from Menu.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | MergeMenu | Merges the MenuItem objects of one menu with the current menu. (Inherited from Menu.)
Protected method | OnCollapse | Raises the Collapse event. (Inherited from ContextMenu.)
Protected method | OnPopup | Raises the Popup event (Inherited from ContextMenu.)
Protected method | ProcessCmdKey(Message%, Keys) | Processes a command key. (Inherited from Menu.)
Protected method | ProcessCmdKey(Message%, Keys, Control) | Processes a command key. (Inherited from ContextMenu.)
Public method | Show(Control, Point) | Displays the shortcut menu at the specified position. (Inherited from ContextMenu.)
Public method | Show(Control, Point, LeftRightAlignment) | Displays the shortcut menu at the specified position and with the specified alignment. (Inherited from ContextMenu.)
Public method | ToString | Returns a String that represents the Menu control. (Inherited from Menu.)

Properties

 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Handle | Gets a value representing the window handle for the menu. (Inherited from Menu.)
Public property | IsParent | Gets a value indicating whether this menu contains any menu items. This property is read-only. (Inherited from Menu.)
Public property | MdiListItem | Gets a value indicating the MenuItem that is used to display a list of multiple document interface (MDI) child forms. (Inherited from Menu.)
Public property | MenuItems | Gets a value indicating the collection of MenuItem objects associated with the menu. (Inherited from Menu.)
Public property | Name | Gets or sets the name of the Menu. (Inherited from Menu.)
Public property | RightToLeft | Gets or sets a value indicating whether text displayed by the control is displayed from right to left. (Inherited from ContextMenu.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SourceControl | Gets the control that is displaying the shortcut menu. (Inherited from ContextMenu.)
Public property | Tag | Gets or sets user-defined data associated with the control. (Inherited from Menu.)

Events

 | Name | Description
Public event | Collapse | Occurs when the shortcut menu collapses. (Inherited from ContextMenu.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | Popup | Occurs before the shortcut menu is displayed. (Inherited from ContextMenu.)

See Also

vContextMenu Class


vContextMenu Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
vContextMenu Constructor
vContextMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | vContextMenu()()()() | vContextMenu constructor
Public method | vContextMenu(array<MenuItem>[]()[][]) | vContextMenu constructor

See Also

vContextMenu Class
vContextMenu Members


vContextMenu Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vContextMenu Constructor
vContextMenu Class See Also Send Feedback
vContextMenu constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vContextMenu()
Visual Basic
Public Sub New
Visual C++
public:
vContextMenu()

See Also

vContextMenu Class
vContextMenu Overload


vContextMenu Constructor (MenuItem[])

[image]

VIBlend Controls for WinForms Help Documentation
vContextMenu Constructor (array<MenuItem>[]()[][])
vContextMenu Class See Also Send Feedback
vContextMenu constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vContextMenu(
    MenuItem[] items
)
Visual Basic
Public Sub New ( _
    items As MenuItem() _
)
Visual C++
public:
vContextMenu(
    array<MenuItem^>^ items
)

Parameters

items
Type: array< System.Windows.Forms..::..MenuItem >[]()[][]

See Also

vContextMenu Class
vContextMenu Overload


vContextMenu Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vContextMenu Methods
vContextMenu Class See Also Send Feedback

The vContextMenu type exposes the following members.

Methods

 | Name | Description
Protected method | CloneMenu | Copies the Menu that is passed as a parameter to the current Menu. (Inherited from Menu.)
Protected method | CreateMenuHandle | Creates a new handle to the Menu. (Inherited from Menu.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes of the resources, other than memory, used by the Menu. (Inherited from Menu.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindMenuItem | Gets the MenuItem that contains the value specified. (Inherited from Menu.)
Protected method | FindMergePosition | Returns the position at which a menu item should be inserted into the menu. (Inherited from Menu.)
Public method | GetContextMenu | Gets the ContextMenu that contains this menu. (Inherited from Menu.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMainMenu | Gets the MainMenu that contains this menu. (Inherited from Menu.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | MergeMenu | Merges the MenuItem objects of one menu with the current menu. (Inherited from Menu.)
Protected method | OnCollapse | Raises the Collapse event. (Inherited from ContextMenu.)
Protected method | OnPopup | Raises the Popup event (Inherited from ContextMenu.)
Protected method | ProcessCmdKey(Message%, Keys) | Processes a command key. (Inherited from Menu.)
Protected method | ProcessCmdKey(Message%, Keys, Control) | Processes a command key. (Inherited from ContextMenu.)
Public method | Show(Control, Point) | Displays the shortcut menu at the specified position. (Inherited from ContextMenu.)
Public method | Show(Control, Point, LeftRightAlignment) | Displays the shortcut menu at the specified position and with the specified alignment. (Inherited from ContextMenu.)
Public method | ToString | Returns a String that represents the Menu control. (Inherited from Menu.)

See Also

vContextMenu Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vContextMenu..::..Dispose Method
vContextMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes of the resources, other than memory, used by the Menu. (Inherited from Menu.)

See Also

vContextMenu Class
vContextMenu Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vContextMenu..::..MemberwiseClone Method
vContextMenu Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vContextMenu Class
vContextMenu Members


ProcessCmdKey Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vContextMenu..::..ProcessCmdKey Method
vContextMenu Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | ProcessCmdKey(Message%, Keys) | Processes a command key. (Inherited from Menu.)
Protected method | ProcessCmdKey(Message%, Keys, Control) | Processes a command key. (Inherited from ContextMenu.)

See Also

vContextMenu Class
vContextMenu Members


Show Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vContextMenu..::..Show Method
vContextMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Show(Control, Point) | Displays the shortcut menu at the specified position. (Inherited from ContextMenu.)
Public method | Show(Control, Point, LeftRightAlignment) | Displays the shortcut menu at the specified position and with the specified alignment. (Inherited from ContextMenu.)

See Also

vContextMenu Class
vContextMenu Members


vContextMenu Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vContextMenu Properties
vContextMenu Class See Also Send Feedback

The vContextMenu type exposes the following members.

Properties

 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Handle | Gets a value representing the window handle for the menu. (Inherited from Menu.)
Public property | IsParent | Gets a value indicating whether this menu contains any menu items. This property is read-only. (Inherited from Menu.)
Public property | MdiListItem | Gets a value indicating the MenuItem that is used to display a list of multiple document interface (MDI) child forms. (Inherited from Menu.)
Public property | MenuItems | Gets a value indicating the collection of MenuItem objects associated with the menu. (Inherited from Menu.)
Public property | Name | Gets or sets the name of the Menu. (Inherited from Menu.)
Public property | RightToLeft | Gets or sets a value indicating whether text displayed by the control is displayed from right to left. (Inherited from ContextMenu.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SourceControl | Gets the control that is displaying the shortcut menu. (Inherited from ContextMenu.)
Public property | Tag | Gets or sets user-defined data associated with the control. (Inherited from Menu.)

See Also

vContextMenu Class


vContextMenu Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vContextMenu Events
vContextMenu Class See Also Send Feedback

The vContextMenu type exposes the following members.

Events

 | Name | Description
Public event | Collapse | Occurs when the shortcut menu collapses. (Inherited from ContextMenu.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | Popup | Occurs before the shortcut menu is displayed. (Inherited from ContextMenu.)

See Also

vContextMenu Class


vControlBoundsHelper Class

[image]

VIBlend Controls for WinForms Help Documentation
vControlBoundsHelper Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vControlBoundsHelper
Visual Basic
Public Class vControlBoundsHelper
Visual C++
public ref class vControlBoundsHelper

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..vControlBoundsHelper

See Also

vControlBoundsHelper Members


vControlBoundsHelper Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBoundsHelper Members
vControlBoundsHelper Class Constructors Methods Properties See Also Send Feedback

The vControlBoundsHelper type exposes the following members.

Constructors

 | Name | Description
Public method | vControlBoundsHelper | Initializes a new instance of the vControlBoundsHelper class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnWire | Unwire events.
Public method | Wire | Wires to the content control events.

Properties

 | Name | Description
Public property | ContentControl | Gets the content control.
Public property | EnableMove | Gets or sets a value indicating whether the movement is enabled.
Public property | EnableResize | Gets or sets a value indicating whether the resizing is enabled.
Public property | MouseMoveArea | Gets or sets the mouse move area.

See Also

vControlBoundsHelper Class


vControlBoundsHelper Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vControlBoundsHelper Constructor
vControlBoundsHelper Class See Also Send Feedback
Initializes a new instance of the vControlBoundsHelper class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vControlBoundsHelper(
    Control content
)
Visual Basic
Public Sub New ( _
    content As Control _
)
Visual C++
public:
vControlBoundsHelper(
    Control^ content
)

Parameters

content
Type: System.Windows.Forms..::..Control
The content.

See Also

vControlBoundsHelper Class


vControlBoundsHelper Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBoundsHelper Methods
vControlBoundsHelper Class See Also Send Feedback

The vControlBoundsHelper type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnWire | Unwire events.
Public method | Wire | Wires to the content control events.

See Also

vControlBoundsHelper Class


UnWire Method

[image]

VIBlend Controls for WinForms Help Documentation
vControlBoundsHelper..::..UnWire Method
vControlBoundsHelper Class See Also Send Feedback
Unwire events.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void UnWire()
Visual Basic
Public Sub UnWire
Visual C++
public:
void UnWire()

See Also

vControlBoundsHelper Class


Wire Method

[image]

VIBlend Controls for WinForms Help Documentation
vControlBoundsHelper..::..Wire Method
vControlBoundsHelper Class See Also Send Feedback
Wires to the content control events.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Wire()
Visual Basic
Public Sub Wire
Visual C++
public:
void Wire()

See Also

vControlBoundsHelper Class


vControlBoundsHelper Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBoundsHelper Properties
vControlBoundsHelper Class See Also Send Feedback

The vControlBoundsHelper type exposes the following members.

Properties

 | Name | Description
Public property | ContentControl | Gets the content control.
Public property | EnableMove | Gets or sets a value indicating whether the movement is enabled.
Public property | EnableResize | Gets or sets a value indicating whether the resizing is enabled.
Public property | MouseMoveArea | Gets or sets the mouse move area.

See Also

vControlBoundsHelper Class


ContentControl Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBoundsHelper..::..ContentControl Property
vControlBoundsHelper Class See Also Send Feedback
Gets the content control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control ContentControl { get; }
Visual Basic
Public ReadOnly Property ContentControl As Control
    Get
Visual C++
public:
property Control^ ContentControl {
    Control^ get ();
}

Field Value

The content control.

See Also

vControlBoundsHelper Class


EnableMove Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBoundsHelper..::..EnableMove Property
vControlBoundsHelper Class See Also Send Feedback
Gets or sets a value indicating whether the movement is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableMove { get; set; }
Visual Basic
Public Property EnableMove As Boolean
    Get
    Set
Visual C++
public:
property bool EnableMove {
    bool get ();
    void set (bool value);
}

See Also

vControlBoundsHelper Class


EnableResize Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBoundsHelper..::..EnableResize Property
vControlBoundsHelper Class See Also Send Feedback
Gets or sets a value indicating whether the resizing is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableResize { get; set; }
Visual Basic
Public Property EnableResize As Boolean
    Get
    Set
Visual C++
public:
property bool EnableResize {
    bool get ();
    void set (bool value);
}

Field Value

true if [enable resize]; otherwise, false.

See Also

vControlBoundsHelper Class


MouseMoveArea Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBoundsHelper..::..MouseMoveArea Property
vControlBoundsHelper Class See Also Send Feedback
Gets or sets the mouse move area.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle MouseMoveArea { get; set; }
Visual Basic
Public Property MouseMoveArea As Rectangle
    Get
    Set
Visual C++
public:
property Rectangle MouseMoveArea {
    Rectangle get ();
    void set (Rectangle value);
}

Field Value

The mouse move area.

See Also

vControlBoundsHelper Class


vControlBox Class

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox Class
Members See Also Send Feedback
Represents a vControlBox control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vControlBox : Control,
    INotifyPropertyChanged
Visual Basic
Public Class vControlBox _
    Inherits Control _
    Implements INotifyPropertyChanged
Visual C++
public ref class vControlBox : public Control,
    INotifyPropertyChanged

Remarks

A vControlBox displays an editable text box, and a drop-down container that can host other controls and components.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vControlBox
VIBlend.WinForms.Controls..::..vColorPicker
VIBlend.WinForms.Controls..::..vDatePicker
VIBlend.WinForms.Controls..::..vTreeViewBox

See Also

vControlBox Members


vControlBox Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBox Members
vControlBox Class Constructors Methods Properties Events See Also Send Feedback

The vControlBox type exposes the following members.

Constructors

 | Name | Description
Public method | vControlBox | Initializes a new instance of the vControlBox class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrow | Draws the arrow.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when property is changed.
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown |
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Overrides Control..::..BackColor.)
Public property | BackColorDropDown | Gets or sets the background color for the dropdown control.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color which is used when the UseThemeBorderColor property is false.
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentControl | Gets or sets the content control which is displayed when the dropdown is opened
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets a reference to the DropDown of the ControlBox
Public property | DropDownArrowBackgroundEnabled | Determines whether to the drop-down arrow's background is painted
Public property | DropDownArrowColor | Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false.
Public property | DropDownButtonBackgroundBrush | Gets or sets the background brush.
Public property | DropDownButtonDisabledBackgroundBrush | Gets or sets the disabled background brush.
Public property | DropDownButtonHighlightBackgroundBrush | Gets or sets the HighlightBackground brush.
Public property | DropDownButtonPressedBackgroundBrush | Gets or sets the background brush.
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ControlBox
Public property | DropDownMaximumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox
Public property | DropDownMinimumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox
Public property | DropDownResizeDirection | Gets or sets a value indicating the possible drop-down resize directions
Public property | DropDownWidth | Gets or sets the width in pixels of the drop-down portion of the ControlBox
Public property | EditBase | Gets a reference to the EditBox of the vControlBox control
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font that is used to display the text in the editbox of the control (Overrides Control..::..Font.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color which is used to display the text (Overrides Control..::..ForeColor.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowGrip | Gets or sets a value indicating whether grip is shown
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text displayed in the editbox of the control (Overrides Control..::..Text.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDropDownButtonThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property.
Public property | UseThemeBorderColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property.
Public property | UseThemeDropDownArrowColor | Gets or sets whether to use the Theme default arrow color.
Public property | UseThemeFont | Gets or sets whether to use the Theme Font or the control's Font property.
Public property | UseThemeForeColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property value changes.
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vControlBox Class


vControlBox Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox Constructor
vControlBox Class See Also Send Feedback
Initializes a new instance of the vControlBox class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vControlBox()
Visual Basic
Public Sub New
Visual C++
public:
vControlBox()

See Also

vControlBox Class


vControlBox Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBox Methods
vControlBox Class See Also Send Feedback

The vControlBox type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrow | Draws the arrow.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when property is changed.
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown |
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vControlBox Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..AccessibilityNotifyClients Method
vControlBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vControlBox Class
vControlBox Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..BeginInvoke Method
vControlBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vControlBox Class
vControlBox Members


CloseDropDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..CloseDropDown Method
vControlBox Class See Also Send Feedback
Closes the drop down.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void CloseDropDown()
Visual Basic
Public Sub CloseDropDown
Visual C++
public:
void CloseDropDown()

See Also

vControlBox Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..Dispose Method
vControlBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)

See Also

vControlBox Class
vControlBox Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..Dispose Method (Boolean)
vControlBox Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vControlBox Class
Dispose Overload


DrawArrow Method

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..DrawArrow Method
vControlBox Class See Also Send Feedback
Draws the arrow.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DrawArrow(
    PaintEventArgs e
)
Visual Basic
Protected Overridable Sub DrawArrow ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void DrawArrow(
    PaintEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
The PaintEventArgs instance containing the event data.

See Also

vControlBox Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..GetChildAtPoint Method
vControlBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vControlBox Class
vControlBox Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..Invalidate Method
vControlBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vControlBox Class
vControlBox Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..Invoke Method
vControlBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vControlBox Class
vControlBox Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..MemberwiseClone Method
vControlBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vControlBox Class
vControlBox Members


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..OnPaint Method
vControlBox Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vControlBox Class


OnPropertyChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..OnPropertyChanged Method
vControlBox Class See Also Send Feedback
Called when property is changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String
Name of the property.

See Also

vControlBox Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..PerformLayout Method
vControlBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vControlBox Class
vControlBox Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..ResumeLayout Method
vControlBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vControlBox Class
vControlBox Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..RtlTranslateAlignment Method
vControlBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vControlBox Class
vControlBox Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..Scale Method
vControlBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vControlBox Class
vControlBox Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..Select Method
vControlBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vControlBox Class
vControlBox Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..SetBounds Method
vControlBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vControlBox Class
vControlBox Members


ShowDropDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..ShowDropDown Method
vControlBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void ShowDropDown(
    Point location
)
Visual Basic
Public Overridable Sub ShowDropDown ( _
    location As Point _
)
Visual C++
public:
virtual void ShowDropDown(
    Point location
)

Parameters

location
Type: System.Drawing..::..Point

See Also

vControlBox Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..UpdateBounds Method
vControlBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vControlBox Class
vControlBox Members


vControlBox Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBox Properties
vControlBox Class See Also Send Feedback

The vControlBox type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Overrides Control..::..BackColor.)
Public property | BackColorDropDown | Gets or sets the background color for the dropdown control.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color which is used when the UseThemeBorderColor property is false.
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentControl | Gets or sets the content control which is displayed when the dropdown is opened
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets a reference to the DropDown of the ControlBox
Public property | DropDownArrowBackgroundEnabled | Determines whether to the drop-down arrow's background is painted
Public property | DropDownArrowColor | Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false.
Public property | DropDownButtonBackgroundBrush | Gets or sets the background brush.
Public property | DropDownButtonDisabledBackgroundBrush | Gets or sets the disabled background brush.
Public property | DropDownButtonHighlightBackgroundBrush | Gets or sets the HighlightBackground brush.
Public property | DropDownButtonPressedBackgroundBrush | Gets or sets the background brush.
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ControlBox
Public property | DropDownMaximumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox
Public property | DropDownMinimumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox
Public property | DropDownResizeDirection | Gets or sets a value indicating the possible drop-down resize directions
Public property | DropDownWidth | Gets or sets the width in pixels of the drop-down portion of the ControlBox
Public property | EditBase | Gets a reference to the EditBox of the vControlBox control
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font that is used to display the text in the editbox of the control (Overrides Control..::..Font.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color which is used to display the text (Overrides Control..::..ForeColor.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowGrip | Gets or sets a value indicating whether grip is shown
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text displayed in the editbox of the control (Overrides Control..::..Text.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDropDownButtonThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property.
Public property | UseThemeBorderColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property.
Public property | UseThemeDropDownArrowColor | Gets or sets whether to use the Theme default arrow color.
Public property | UseThemeFont | Gets or sets whether to use the Theme Font or the control's Font property.
Public property | UseThemeForeColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vControlBox Class


BackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..BackColor Property
vControlBox Class See Also Send Feedback
Gets or sets the background color for the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color BackColor { get; set; }
Visual Basic
Public Overrides Property BackColor As Color
    Get
    Set
Visual C++
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}

See Also

vControlBox Class


BackColorDropDown Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..BackColorDropDown Property
vControlBox Class See Also Send Feedback
Gets or sets the background color for the dropdown control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BackColorDropDown { get; set; }
Visual Basic
Public Property BackColorDropDown As Color
    Get
    Set
Visual C++
public:
property Color BackColorDropDown {
    Color get ();
    void set (Color value);
}

See Also

vControlBox Class


BorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..BorderColor Property
vControlBox Class See Also Send Feedback
Gets or sets the border color which is used when the UseThemeBorderColor property is false.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BorderColor { get; set; }
Visual Basic
Public Property BorderColor As Color
    Get
    Set
Visual C++
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}

See Also

vControlBox Class


ContentControl Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..ContentControl Property
vControlBox Class See Also Send Feedback
Gets or sets the content control which is displayed when the dropdown is opened

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control ContentControl { get; set; }
Visual Basic
Public Property ContentControl As Control
    Get
    Set
Visual C++
public:
property Control^ ContentControl {
    Control^ get ();
    void set (Control^ value);
}

See Also

vControlBox Class


DropDown Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..DropDown Property
vControlBox Class See Also Send Feedback
Gets a reference to the DropDown of the ControlBox

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDropDownBase DropDown { get; }
Visual Basic
Public ReadOnly Property DropDown As vDropDownBase
    Get
Visual C++
public:
property vDropDownBase^ DropDown {
    vDropDownBase^ get ();
}

Field Value

The drop down.

See Also

vControlBox Class


DropDownArrowBackgroundEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..DropDownArrowBackgroundEnabled Property
vControlBox Class See Also Send Feedback
Determines whether to the drop-down arrow's background is painted

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool DropDownArrowBackgroundEnabled { get; set; }
Visual Basic
Public Property DropDownArrowBackgroundEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool DropDownArrowBackgroundEnabled {
    bool get ();
    void set (bool value);
}

See Also

vControlBox Class


DropDownArrowColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..DropDownArrowColor Property
vControlBox Class See Also Send Feedback
Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DropDownArrowColor { get; set; }
Visual Basic
Public Property DropDownArrowColor As Color
    Get
    Set
Visual C++
public:
property Color DropDownArrowColor {
    Color get ();
    void set (Color value);
}

See Also

vControlBox Class


DropDownButtonBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..DropDownButtonBackgroundBrush Property
vControlBox Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush DropDownButtonBackgroundBrush { get; set; }
Visual Basic
Public Property DropDownButtonBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ DropDownButtonBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vControlBox Class


DropDownButtonDisabledBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..DropDownButtonDisabledBackgroundBrush Property
vControlBox Class See Also Send Feedback
Gets or sets the disabled background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush DropDownButtonDisabledBackgroundBrush { get; set; }
Visual Basic
Public Property DropDownButtonDisabledBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ DropDownButtonDisabledBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The disabled background brush.

See Also

vControlBox Class


DropDownButtonHighlightBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..DropDownButtonHighlightBackgroundBrush Property
vControlBox Class See Also Send Feedback
Gets or sets the HighlightBackground brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush DropDownButtonHighlightBackgroundBrush { get; set; }
Visual Basic
Public Property DropDownButtonHighlightBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ DropDownButtonHighlightBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The HighlightBackground brush.

See Also

vControlBox Class


DropDownButtonPressedBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..DropDownButtonPressedBackgroundBrush Property
vControlBox Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush DropDownButtonPressedBackgroundBrush { get; set; }
Visual Basic
Public Property DropDownButtonPressedBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ DropDownButtonPressedBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vControlBox Class


DropDownHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..DropDownHeight Property
vControlBox Class See Also Send Feedback
Gets or sets the height in pixels of the drop-down portion of the ControlBox

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int DropDownHeight { get; set; }
Visual Basic
Public Property DropDownHeight As Integer
    Get
    Set
Visual C++
public:
property int DropDownHeight {
    int get ();
    void set (int value);
}

See Also

vControlBox Class


DropDownMaximumSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..DropDownMaximumSize Property
vControlBox Class See Also Send Feedback
Gets or sets the maximum size of the drop-down portion of the ControlBox

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Size DropDownMaximumSize { get; set; }
Visual Basic
Public Property DropDownMaximumSize As Size
    Get
    Set
Visual C++
public:
property Size DropDownMaximumSize {
    Size get ();
    void set (Size value);
}

See Also

vControlBox Class


DropDownMinimumSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..DropDownMinimumSize Property
vControlBox Class See Also Send Feedback
Gets or sets the maximum size of the drop-down portion of the ControlBox

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Size DropDownMinimumSize { get; set; }
Visual Basic
Public Property DropDownMinimumSize As Size
    Get
    Set
Visual C++
public:
property Size DropDownMinimumSize {
    Size get ();
    void set (Size value);
}

See Also

vControlBox Class


DropDownResizeDirection Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..DropDownResizeDirection Property
vControlBox Class See Also Send Feedback
Gets or sets a value indicating the possible drop-down resize directions

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual SizingDirection DropDownResizeDirection { get; set; }
Visual Basic
Public Overridable Property DropDownResizeDirection As SizingDirection
    Get
    Set
Visual C++
public:
virtual property SizingDirection DropDownResizeDirection {
    SizingDirection get ();
    void set (SizingDirection value);
}

See Also

vControlBox Class


DropDownWidth Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..DropDownWidth Property
vControlBox Class See Also Send Feedback
Gets or sets the width in pixels of the drop-down portion of the ControlBox

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int DropDownWidth { get; set; }
Visual Basic
Public Property DropDownWidth As Integer
    Get
    Set
Visual C++
public:
property int DropDownWidth {
    int get ();
    void set (int value);
}

See Also

vControlBox Class


EditBase Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..EditBase Property
vControlBox Class See Also Send Feedback
Gets a reference to the EditBox of the vControlBox control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vButtonEditBase EditBase { get; }
Visual Basic
Public ReadOnly Property EditBase As vButtonEditBase
    Get
Visual C++
public:
property vButtonEditBase^ EditBase {
    vButtonEditBase^ get ();
}

See Also

vControlBox Class


Font Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..Font Property
vControlBox Class See Also Send Feedback
Gets or sets the font that is used to display the text in the editbox of the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Font Font { get; set; }
Visual Basic
Public Overrides Property Font As Font
    Get
    Set
Visual C++
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}

See Also

vControlBox Class


ForeColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..ForeColor Property
vControlBox Class See Also Send Feedback
Gets or sets the foreground color which is used to display the text

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color ForeColor { get; set; }
Visual Basic
Public Overrides Property ForeColor As Color
    Get
    Set
Visual C++
public:
virtual property Color ForeColor {
    Color get () override;
    void set (Color value) override;
}

See Also

vControlBox Class


ShowGrip Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..ShowGrip Property
vControlBox Class See Also Send Feedback
Gets or sets a value indicating whether grip is shown

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowGrip { get; set; }
Visual Basic
Public Property ShowGrip As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGrip {
    bool get ();
    void set (bool value);
}

See Also

vControlBox Class


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..Text Property
vControlBox Class See Also Send Feedback
Gets or sets the text displayed in the editbox of the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string Text { get; set; }
Visual Basic
Public Overrides Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

See Also

vControlBox Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..Theme Property
vControlBox Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vControlBox Class


UseDropDownButtonThemeBackground Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..UseDropDownButtonThemeBackground Property
vControlBox Class See Also Send Feedback
Gets or sets a value indicating whether to use theme's background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseDropDownButtonThemeBackground { get; set; }
Visual Basic
Public Property UseDropDownButtonThemeBackground As Boolean
    Get
    Set
Visual C++
public:
property bool UseDropDownButtonThemeBackground {
    bool get ();
    void set (bool value);
}

See Also

vControlBox Class


UseThemeBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..UseThemeBackColor Property
vControlBox Class See Also Send Feedback
Gets or sets whether to use the Theme BackColor or the control's BackColor property.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBackColor { get; set; }
Visual Basic
Public Property UseThemeBackColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBackColor {
    bool get ();
    void set (bool value);
}

See Also

vControlBox Class


UseThemeBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..UseThemeBorderColor Property
vControlBox Class See Also Send Feedback
Gets or sets whether to use the Theme BorderColor or the control's BackColor property.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBorderColor { get; set; }
Visual Basic
Public Property UseThemeBorderColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBorderColor {
    bool get ();
    void set (bool value);
}

See Also

vControlBox Class


UseThemeDropDownArrowColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..UseThemeDropDownArrowColor Property
vControlBox Class See Also Send Feedback
Gets or sets whether to use the Theme default arrow color.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeDropDownArrowColor { get; set; }
Visual Basic
Public Property UseThemeDropDownArrowColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeDropDownArrowColor {
    bool get ();
    void set (bool value);
}

See Also

vControlBox Class


UseThemeFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..UseThemeFont Property
vControlBox Class See Also Send Feedback
Gets or sets whether to use the Theme Font or the control's Font property.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeFont { get; set; }
Visual Basic
Public Property UseThemeFont As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeFont {
    bool get ();
    void set (bool value);
}

See Also

vControlBox Class


UseThemeForeColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..UseThemeForeColor Property
vControlBox Class See Also Send Feedback
Gets or sets whether to use the Theme BorderColor or the control's BackColor property.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeForeColor { get; set; }
Visual Basic
Public Property UseThemeForeColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeForeColor {
    bool get ();
    void set (bool value);
}

See Also

vControlBox Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..VIBlendTheme Property
vControlBox Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vControlBox Class


vControlBox Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vControlBox Events
vControlBox Class See Also Send Feedback

The vControlBox type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property value changes.
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vControlBox Class


PropertyChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vControlBox..::..PropertyChanged Event
vControlBox Class See Also Send Feedback
Occurs when a property value changes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

vControlBox Class


vCurrencyEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vCurrencyEditor : InputBase
Visual Basic
Public Class vCurrencyEditor _
    Inherits InputBase
Visual C++
public ref class vCurrencyEditor : public InputBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vTextBox
VIBlend.WinForms.Controls..::..InputBase
VIBlend.WinForms.Controls..::..vCurrencyEditor
VIBlend.WinForms.DataGridView..::..CurrencyEditor

See Also

vCurrencyEditor Members


vCurrencyEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor Members
vCurrencyEditor Class Constructors Methods Fields Properties Events See Also Send Feedback

The vCurrencyEditor type exposes the following members.

Constructors

 | Name | Description
Public method | vCurrencyEditor | Initializes a new instance of currency editor.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | Simulates BackSpace. (Overrides InputBase..::..Backspace()()()().)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from InputBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | Executes the Ctrl + C command. (Overrides InputBase..::..CtrlC()()()().)
Protected method | CtrlV | Executes the Ctrl + V command. (Overrides InputBase..::..CtrlV()()()().)
Protected method | CtrlX | Executes the Ctrl + X command. (Overrides InputBase..::..CtrlX()()()().)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | Deletes the selected value. (Overrides InputBase..::..Delete()()()().)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key. (Inherited from InputBase.)
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key. (Inherited from InputBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider. (Inherited from InputBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text. (Overrides InputBase..::..GetPureText()()()().)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key. (Inherited from InputBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | Inserts a string into the editor. (Overrides InputBase..::..Insert(String).)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown | (Inherited from InputBase.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed. (Inherited from InputBase.)
Public method | LeftKey | Moves the cursor one position left. (Inherited from InputBase.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from InputBase.)
Protected method | OnKeyPress | (Inherited from InputBase.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from InputBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | (Inherited from InputBase.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | (Inherited from InputBase.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from InputBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event. (Inherited from InputBase.)
Protected method | OnValueChanged | Calls the ValueChanged event. (Inherited from InputBase.)
Protected method | OnValueChanging | Calls the ValueChanging event. (Inherited from InputBase.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | Parses editor's value. (Overrides InputBase..::..ParseValue()()()().)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | Redoes this instance. (Overrides InputBase..::..Redo()()()().)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters. (Inherited from InputBase.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key. (Inherited from InputBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | Formats editor's text. (Overrides InputBase..::..SetFormattedText()()()().)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit | (Inherited from InputBase.)
Protected method | SpinDigitWithWrap | Spins the digit with wrap. (Inherited from InputBase.)
Public method | SpinValue | Increases or decreases the current value. (Inherited from InputBase.)
Protected method | SpinValueBeforeDigit | Spins the value before digit. (Inherited from InputBase.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | Makes undo of the current value. (Overrides InputBase..::..Undo()()()().)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key. (Inherited from InputBase.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | baseFormatString | (Inherited from InputBase.)
Protected field | cultureInfo | (Inherited from InputBase.)
Protected field | decimalPlaces | (Inherited from InputBase.)
Protected field | decimalPossibleChars | (Inherited from InputBase.)
Protected field | emptyValue | (Inherited from InputBase.)
Protected field | formatString | (Inherited from InputBase.)
Protected field | isLessThanZero | (Inherited from InputBase.)
Protected field | manager | (Inherited from InputBase.)
Protected field | maximum | (Inherited from InputBase.)
Protected field | minimum | (Inherited from InputBase.)
Protected field | undoValue | (Inherited from InputBase.)
Protected field | value | (Inherited from InputBase.)
Protected field | valueString | (Inherited from InputBase.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information. (Inherited from InputBase.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DecimalPlaces | Gets or sets editor's decimal places. (Inherited from InputBase.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator | (Inherited from InputBase.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value. (Inherited from InputBase.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value. (Inherited from InputBase.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | (Inherited from InputBase.)
Public property | Minimum | Gets or sets editor's Minimum value. (Inherited from InputBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | Gets the current separator character. (Overrides InputBase..::..SeparatorChar.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type. (Inherited from InputBase.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from InputBase.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from InputBase.)
Public property | Value | Gets or sets editor's value. (Inherited from InputBase.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed. (Inherited from InputBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event. (Inherited from InputBase.)
Public event | ValueChanged | Represents the ValueChanged event. (Inherited from InputBase.)
Public event | ValueChanging | Represents the ValueChanging event. (Inherited from InputBase.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vCurrencyEditor Class


vCurrencyEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor Constructor
vCurrencyEditor Class See Also Send Feedback
Initializes a new instance of currency editor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vCurrencyEditor()
Visual Basic
Public Sub New
Visual C++
public:
vCurrencyEditor()

See Also

vCurrencyEditor Class


vCurrencyEditor Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor Fields
vCurrencyEditor Class See Also Send Feedback

The vCurrencyEditor type exposes the following members.

Fields

 | Name | Description
Protected field | baseFormatString | (Inherited from InputBase.)
Protected field | cultureInfo | (Inherited from InputBase.)
Protected field | decimalPlaces | (Inherited from InputBase.)
Protected field | decimalPossibleChars | (Inherited from InputBase.)
Protected field | emptyValue | (Inherited from InputBase.)
Protected field | formatString | (Inherited from InputBase.)
Protected field | isLessThanZero | (Inherited from InputBase.)
Protected field | manager | (Inherited from InputBase.)
Protected field | maximum | (Inherited from InputBase.)
Protected field | minimum | (Inherited from InputBase.)
Protected field | undoValue | (Inherited from InputBase.)
Protected field | value | (Inherited from InputBase.)
Protected field | valueString | (Inherited from InputBase.)

See Also

vCurrencyEditor Class


vCurrencyEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor Methods
vCurrencyEditor Class See Also Send Feedback

The vCurrencyEditor type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | Simulates BackSpace. (Overrides InputBase..::..Backspace()()()().)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from InputBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | Executes the Ctrl + C command. (Overrides InputBase..::..CtrlC()()()().)
Protected method | CtrlV | Executes the Ctrl + V command. (Overrides InputBase..::..CtrlV()()()().)
Protected method | CtrlX | Executes the Ctrl + X command. (Overrides InputBase..::..CtrlX()()()().)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | Deletes the selected value. (Overrides InputBase..::..Delete()()()().)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key. (Inherited from InputBase.)
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key. (Inherited from InputBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider. (Inherited from InputBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text. (Overrides InputBase..::..GetPureText()()()().)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key. (Inherited from InputBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | Inserts a string into the editor. (Overrides InputBase..::..Insert(String).)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown | (Inherited from InputBase.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed. (Inherited from InputBase.)
Public method | LeftKey | Moves the cursor one position left. (Inherited from InputBase.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from InputBase.)
Protected method | OnKeyPress | (Inherited from InputBase.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from InputBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | (Inherited from InputBase.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | (Inherited from InputBase.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from InputBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event. (Inherited from InputBase.)
Protected method | OnValueChanged | Calls the ValueChanged event. (Inherited from InputBase.)
Protected method | OnValueChanging | Calls the ValueChanging event. (Inherited from InputBase.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | Parses editor's value. (Overrides InputBase..::..ParseValue()()()().)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | Redoes this instance. (Overrides InputBase..::..Redo()()()().)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters. (Inherited from InputBase.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key. (Inherited from InputBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | Formats editor's text. (Overrides InputBase..::..SetFormattedText()()()().)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit | (Inherited from InputBase.)
Protected method | SpinDigitWithWrap | Spins the digit with wrap. (Inherited from InputBase.)
Public method | SpinValue | Increases or decreases the current value. (Inherited from InputBase.)
Protected method | SpinValueBeforeDigit | Spins the value before digit. (Inherited from InputBase.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | Makes undo of the current value. (Overrides InputBase..::..Undo()()()().)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key. (Inherited from InputBase.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vCurrencyEditor Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..AccessibilityNotifyClients Method
vCurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vCurrencyEditor Class
vCurrencyEditor Members


Backspace Method

[image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..Backspace Method
vCurrencyEditor Class See Also Send Feedback
Simulates BackSpace.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Backspace()
Visual Basic
Public Overrides Sub Backspace
Visual C++
public:
virtual void Backspace() override

See Also

vCurrencyEditor Class


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..BeginInvoke Method
vCurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vCurrencyEditor Class
vCurrencyEditor Members


CtrlC Method

[image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..CtrlC Method
vCurrencyEditor Class See Also Send Feedback
Executes the Ctrl + C command.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void CtrlC()
Visual Basic
Protected Overrides Sub CtrlC
Visual C++
protected:
virtual void CtrlC() override

See Also

vCurrencyEditor Class


CtrlV Method

[image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..CtrlV Method
vCurrencyEditor Class See Also Send Feedback
Executes the Ctrl + V command.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void CtrlV()
Visual Basic
Protected Overrides Sub CtrlV
Visual C++
protected:
virtual void CtrlV() override

See Also

vCurrencyEditor Class


CtrlX Method

[image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..CtrlX Method
vCurrencyEditor Class See Also Send Feedback
Executes the Ctrl + X command.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void CtrlX()
Visual Basic
Protected Overrides Sub CtrlX
Visual C++
protected:
virtual void CtrlX() override

See Also

vCurrencyEditor Class


Delete Method

[image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..Delete Method
vCurrencyEditor Class See Also Send Feedback
Deletes the selected value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Delete()
Visual Basic
Public Overrides Sub Delete
Visual C++
public:
virtual void Delete() override

See Also

vCurrencyEditor Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..Dispose Method
vCurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vCurrencyEditor Class
vCurrencyEditor Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..GetChildAtPoint Method
vCurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vCurrencyEditor Class
vCurrencyEditor Members


GetPureText Method

[image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..GetPureText Method
vCurrencyEditor Class See Also Send Feedback
Gets editor's text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override string GetPureText()
Visual Basic
Protected Overrides Function GetPureText As String
Visual C++
protected:
virtual String^ GetPureText() override

Return Value

See Also

vCurrencyEditor Class


Insert Method

[image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..Insert Method
vCurrencyEditor Class See Also Send Feedback
Inserts a string into the editor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Insert(
    string insertion
)
Visual Basic
Public Overrides Sub Insert ( _
    insertion As String _
)
Visual C++
public:
virtual void Insert(
    String^ insertion
) override

Parameters

insertion
Type: System..::..String

See Also

vCurrencyEditor Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..Invalidate Method
vCurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vCurrencyEditor Class
vCurrencyEditor Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..Invoke Method
vCurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vCurrencyEditor Class
vCurrencyEditor Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..MemberwiseClone Method
vCurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vCurrencyEditor Class
vCurrencyEditor Members


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..OnMouseUp Method
vCurrencyEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vCurrencyEditor Class


ParseValue Method

[image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..ParseValue Method
vCurrencyEditor Class See Also Send Feedback
Parses editor's value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override bool ParseValue()
Visual Basic
Protected Overrides Function ParseValue As Boolean
Visual C++
protected:
virtual bool ParseValue() override

Return Value

See Also

vCurrencyEditor Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..PerformLayout Method
vCurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vCurrencyEditor Class
vCurrencyEditor Members


Redo Method

[image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..Redo Method
vCurrencyEditor Class See Also Send Feedback
Redoes this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Redo()
Visual Basic
Public Overrides Sub Redo
Visual C++
public:
virtual void Redo() override

See Also

vCurrencyEditor Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..ResumeLayout Method
vCurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vCurrencyEditor Class
vCurrencyEditor Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..RtlTranslateAlignment Method
vCurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vCurrencyEditor Class
vCurrencyEditor Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..Scale Method
vCurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vCurrencyEditor Class
vCurrencyEditor Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..Select Method
vCurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vCurrencyEditor Class
vCurrencyEditor Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..SetBounds Method
vCurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vCurrencyEditor Class
vCurrencyEditor Members


SetFormattedText Method

[image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..SetFormattedText Method
vCurrencyEditor Class See Also Send Feedback
Formats editor's text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override bool SetFormattedText()
Visual Basic
Protected Overrides Function SetFormattedText As Boolean
Visual C++
protected:
virtual bool SetFormattedText() override

Return Value

See Also

vCurrencyEditor Class


Undo Method

[image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..Undo Method
vCurrencyEditor Class See Also Send Feedback
Makes undo of the current value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Undo()
Visual Basic
Public Overrides Sub Undo
Visual C++
public:
virtual void Undo() override

See Also

vCurrencyEditor Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..UpdateBounds Method
vCurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vCurrencyEditor Class
vCurrencyEditor Members


vCurrencyEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor Properties
vCurrencyEditor Class See Also Send Feedback

The vCurrencyEditor type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information. (Inherited from InputBase.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DecimalPlaces | Gets or sets editor's decimal places. (Inherited from InputBase.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator | (Inherited from InputBase.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value. (Inherited from InputBase.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value. (Inherited from InputBase.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | (Inherited from InputBase.)
Public property | Minimum | Gets or sets editor's Minimum value. (Inherited from InputBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | Gets the current separator character. (Overrides InputBase..::..SeparatorChar.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type. (Inherited from InputBase.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from InputBase.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from InputBase.)
Public property | Value | Gets or sets editor's value. (Inherited from InputBase.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vCurrencyEditor Class


SeparatorChar Property

[image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor..::..SeparatorChar Property
vCurrencyEditor Class See Also Send Feedback
Gets the current separator character.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string SeparatorChar { get; }
Visual Basic
Public Overrides ReadOnly Property SeparatorChar As String
    Get
Visual C++
public:
virtual property String^ SeparatorChar {
    String^ get () override;
}

Field Value

See Also

vCurrencyEditor Class


vCurrencyEditor Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vCurrencyEditor Events
vCurrencyEditor Class See Also Send Feedback

The vCurrencyEditor type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed. (Inherited from InputBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event. (Inherited from InputBase.)
Public event | ValueChanged | Represents the ValueChanged event. (Inherited from InputBase.)
Public event | ValueChanging | Represents the ValueChanging event. (Inherited from InputBase.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vCurrencyEditor Class


vDatePicker Class

[image]

VIBlend Controls for WinForms Help Documentation
vDatePicker Class
Members See Also Send Feedback
Represents a vDatePicker control. The control contains a DropDown calendar, and allows you to select a date.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vDatePicker : vControlBox
Visual Basic
Public Class vDatePicker _
    Inherits vControlBox
Visual C++
public ref class vDatePicker : public vControlBox

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vControlBox
VIBlend.WinForms.Controls..::..vDatePicker
VIBlend.WinForms.Controls..::..vDateTimePicker

See Also

vDatePicker Members


vDatePicker Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker Members
vDatePicker Class Constructors Methods Fields Properties Events See Also Send Feedback

The vDatePicker type exposes the following members.

Constructors

 | Name | Description
Public method | vDatePicker | vDatePicker Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down. (Inherited from vControlBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vControlBox.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrow | Draws the arrow. (Inherited from vControlBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from vControlBox.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when property is changed. (Inherited from vControlBox.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Called when the value has been changed
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown | (Inherited from vControlBox.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | dateTimeEditor |

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from vControlBox.)
Public property | BackColorDropDown | Gets or sets the background color for the dropdown control. (Inherited from vControlBox.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color which is used when the UseThemeBorderColor property is false. (Inherited from vControlBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | Calendar | Returns the calendar control hosted by the vDataTimePicker control
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentControl | Gets or sets the content control which is displayed when the dropdown is opened (Inherited from vControlBox.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Culture | Gets or sets the current culture settings of the control.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DateTimeEditor |
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets a reference to the DropDown of the ControlBox (Inherited from vControlBox.)
Public property | DropDownArrowBackgroundEnabled | Determines whether to the drop-down arrow's background is painted (Inherited from vControlBox.)
Public property | DropDownArrowColor | Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false. (Inherited from vControlBox.)
Public property | DropDownButtonBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownButtonDisabledBackgroundBrush | Gets or sets the disabled background brush. (Inherited from vControlBox.)
Public property | DropDownButtonHighlightBackgroundBrush | Gets or sets the HighlightBackground brush. (Inherited from vControlBox.)
Public property | DropDownButtonPressedBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMaximumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMinimumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownResizeDirection | Gets or sets a value indicating the possible drop-down resize directions (Inherited from vControlBox.)
Public property | DropDownWidth | Gets or sets the width in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | EditBase | Gets a reference to the EditBox of the vControlBox control (Inherited from vControlBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font that is used to display the text in the editbox of the control
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color which is used to display the text (Inherited from vControlBox.)
Public property | FormatValue | Gets or sets the text formatting applied to the text box of the DatePicker control
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaxDate | Gets or sets the maximum DateTime.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinDate | Gets or sets the minimum DateTime
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowGrip | Gets or sets a value indicating whether grip is shown (Inherited from vControlBox.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text displayed in the editbox of the control (Inherited from vControlBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vControlBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation.
Public property | UseDropDownButtonThemeBackground | Gets or sets a value indicating whether to use theme's background (Inherited from vControlBox.)
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeBorderColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeDropDownArrowColor | Gets or sets whether to use the Theme default arrow color. (Inherited from vControlBox.)
Public property | UseThemeFont | Gets or sets whether to use the Theme Font or the control's Font property. (Inherited from vControlBox.)
Public property | UseThemeForeColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string.
Public property | Value | Gets or sets the current DateTime for the control.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vControlBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from vControlBox.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when the value has been changed
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDatePicker Class


vDatePicker Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vDatePicker Constructor
vDatePicker Class See Also Send Feedback
vDatePicker Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDatePicker()
Visual Basic
Public Sub New
Visual C++
public:
vDatePicker()

See Also

vDatePicker Class


vDatePicker Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker Fields
vDatePicker Class See Also Send Feedback

The vDatePicker type exposes the following members.

Fields

 | Name | Description
Protected field | dateTimeEditor |

See Also

vDatePicker Class


dateTimeEditor Field

[image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..dateTimeEditor Field
vDatePicker Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected vDateTimeEditor dateTimeEditor
Visual Basic
Protected dateTimeEditor As vDateTimeEditor
Visual C++
protected:
vDateTimeEditor^ dateTimeEditor

See Also

vDatePicker Class


vDatePicker Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker Methods
vDatePicker Class See Also Send Feedback

The vDatePicker type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down. (Inherited from vControlBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vControlBox.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrow | Draws the arrow. (Inherited from vControlBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from vControlBox.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when property is changed. (Inherited from vControlBox.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Called when the value has been changed
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown | (Inherited from vControlBox.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vDatePicker Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..AccessibilityNotifyClients Method
vDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vDatePicker Class
vDatePicker Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..BeginInvoke Method
vDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vDatePicker Class
vDatePicker Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..Dispose Method
vDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vControlBox.)

See Also

vDatePicker Class
vDatePicker Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..GetChildAtPoint Method
vDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vDatePicker Class
vDatePicker Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..Invalidate Method
vDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vDatePicker Class
vDatePicker Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..Invoke Method
vDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vDatePicker Class
vDatePicker Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..MemberwiseClone Method
vDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vDatePicker Class
vDatePicker Members


OnValueChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..OnValueChanged Method
vDatePicker Class See Also Send Feedback
Called when the value has been changed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnValueChanged()
Visual Basic
Protected Overridable Sub OnValueChanged
Visual C++
protected:
virtual void OnValueChanged()

See Also

vDatePicker Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..PerformLayout Method
vDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vDatePicker Class
vDatePicker Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..ResumeLayout Method
vDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vDatePicker Class
vDatePicker Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..RtlTranslateAlignment Method
vDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vDatePicker Class
vDatePicker Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..Scale Method
vDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vDatePicker Class
vDatePicker Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..Select Method
vDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vDatePicker Class
vDatePicker Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..SetBounds Method
vDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vDatePicker Class
vDatePicker Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..UpdateBounds Method
vDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vDatePicker Class
vDatePicker Members


vDatePicker Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker Properties
vDatePicker Class See Also Send Feedback

The vDatePicker type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from vControlBox.)
Public property | BackColorDropDown | Gets or sets the background color for the dropdown control. (Inherited from vControlBox.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color which is used when the UseThemeBorderColor property is false. (Inherited from vControlBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | Calendar | Returns the calendar control hosted by the vDataTimePicker control
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentControl | Gets or sets the content control which is displayed when the dropdown is opened (Inherited from vControlBox.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Culture | Gets or sets the current culture settings of the control.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DateTimeEditor |
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets a reference to the DropDown of the ControlBox (Inherited from vControlBox.)
Public property | DropDownArrowBackgroundEnabled | Determines whether to the drop-down arrow's background is painted (Inherited from vControlBox.)
Public property | DropDownArrowColor | Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false. (Inherited from vControlBox.)
Public property | DropDownButtonBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownButtonDisabledBackgroundBrush | Gets or sets the disabled background brush. (Inherited from vControlBox.)
Public property | DropDownButtonHighlightBackgroundBrush | Gets or sets the HighlightBackground brush. (Inherited from vControlBox.)
Public property | DropDownButtonPressedBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMaximumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMinimumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownResizeDirection | Gets or sets a value indicating the possible drop-down resize directions (Inherited from vControlBox.)
Public property | DropDownWidth | Gets or sets the width in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | EditBase | Gets a reference to the EditBox of the vControlBox control (Inherited from vControlBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font that is used to display the text in the editbox of the control
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color which is used to display the text (Inherited from vControlBox.)
Public property | FormatValue | Gets or sets the text formatting applied to the text box of the DatePicker control
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaxDate | Gets or sets the maximum DateTime.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinDate | Gets or sets the minimum DateTime
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowGrip | Gets or sets a value indicating whether grip is shown (Inherited from vControlBox.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text displayed in the editbox of the control (Inherited from vControlBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vControlBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation.
Public property | UseDropDownButtonThemeBackground | Gets or sets a value indicating whether to use theme's background (Inherited from vControlBox.)
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeBorderColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeDropDownArrowColor | Gets or sets whether to use the Theme default arrow color. (Inherited from vControlBox.)
Public property | UseThemeFont | Gets or sets whether to use the Theme Font or the control's Font property. (Inherited from vControlBox.)
Public property | UseThemeForeColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string.
Public property | Value | Gets or sets the current DateTime for the control.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vControlBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vDatePicker Class


Calendar Property

[image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..Calendar Property
vDatePicker Class See Also Send Feedback
Returns the calendar control hosted by the vDataTimePicker control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vMonthCalendar Calendar { get; }
Visual Basic
Public ReadOnly Property Calendar As vMonthCalendar
    Get
Visual C++
public:
property vMonthCalendar^ Calendar {
    vMonthCalendar^ get ();
}

See Also

vDatePicker Class


Culture Property

[image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..Culture Property
vDatePicker Class See Also Send Feedback
Gets or sets the current culture settings of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CultureInfo Culture { get; set; }
Visual Basic
Public Property Culture As CultureInfo
    Get
    Set
Visual C++
public:
property CultureInfo^ Culture {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}

See Also

vDatePicker Class


DateTimeEditor Property

[image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..DateTimeEditor Property
vDatePicker Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDateTimeEditor DateTimeEditor { get; }
Visual Basic
Public ReadOnly Property DateTimeEditor As vDateTimeEditor
    Get
Visual C++
public:
property vDateTimeEditor^ DateTimeEditor {
    vDateTimeEditor^ get ();
}

See Also

vDatePicker Class


Font Property

[image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..Font Property
vDatePicker Class See Also Send Feedback
Gets or sets the font that is used to display the text in the editbox of the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font Font { get; set; }
Visual Basic
Public Property Font As Font
    Get
    Set
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

Field Value

See Also

vDatePicker Class


FormatValue Property

[image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..FormatValue Property
vDatePicker Class See Also Send Feedback
Gets or sets the text formatting applied to the text box of the DatePicker control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string FormatValue { get; set; }
Visual Basic
Public Property FormatValue As String
    Get
    Set
Visual C++
public:
property String^ FormatValue {
    String^ get ();
    void set (String^ value);
}

See Also

vDatePicker Class


MaxDate Property

[image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..MaxDate Property
vDatePicker Class See Also Send Feedback
Gets or sets the maximum DateTime.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime MaxDate { get; set; }
Visual Basic
Public Property MaxDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime MaxDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

vDatePicker Class


MinDate Property

[image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..MinDate Property
vDatePicker Class See Also Send Feedback
Gets or sets the minimum DateTime

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime MinDate { get; set; }
Visual Basic
Public Property MinDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime MinDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

vDatePicker Class


UseDefaultValidation Property

[image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..UseDefaultValidation Property
vDatePicker Class See Also Send Feedback
Gets or sets a value indicating whether to use the built-in validation.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseDefaultValidation { get; set; }
Visual Basic
Public Property UseDefaultValidation As Boolean
    Get
    Set
Visual C++
public:
property bool UseDefaultValidation {
    bool get ();
    void set (bool value);
}

See Also

vDatePicker Class


ValidationString Property

[image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..ValidationString Property
vDatePicker Class See Also Send Feedback
Gets or sets the validation string.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string ValidationString { get; set; }
Visual Basic
Public Property ValidationString As String
    Get
    Set
Visual C++
public:
property String^ ValidationString {
    String^ get ();
    void set (String^ value);
}

Field Value

The validation string.

See Also

vDatePicker Class


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..Value Property
vDatePicker Class See Also Send Feedback
Gets or sets the current DateTime for the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Nullable<DateTime> Value { get; set; }
Visual Basic
Public Property Value As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> Value {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

See Also

vDatePicker Class


vDatePicker Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDatePicker Events
vDatePicker Class See Also Send Feedback

The vDatePicker type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from vControlBox.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when the value has been changed
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDatePicker Class


ValueChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vDatePicker..::..ValueChanged Event
vDatePicker Class See Also Send Feedback
Occurs when the value has been changed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ValueChanged
Visual Basic
Public Event ValueChanged As EventHandler
Visual C++
public:
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vDatePicker Class


vDateTimeEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor Class
Members See Also Send Feedback
Represents a vDateTimeEditor control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vDateTimeEditor : vTextBox
Visual Basic
Public Class vDateTimeEditor _
    Inherits vTextBox
Visual C++
public ref class vDateTimeEditor : public vTextBox

Remarks

vDateTimeEditor provides an editable text field that allows the user to enter date, and time.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vTextBox
VIBlend.WinForms.Controls..::..vDateTimeEditor

See Also

vDateTimeEditor Members


vDateTimeEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor Members
vDateTimeEditor Class Constructors Methods Properties Events See Also Send Feedback

The vDateTimeEditor type exposes the following members.

Constructors

 | Name | Description
Public method | vDateTimeEditor | DateTimeEditor contructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Protected method | DoDownKey | Does down key.
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DoEndKey | Does the end key.
Protected method | DoF2Key | Does the f2 key.
Protected method | DoHomeKey | Does the home key.
Protected method | DoKeyDown |
Protected method | DoLeftKey | Does the left key.
Protected method | DoMouseWheel | Does the mouse wheel.
Protected method | DoRightKey | Does the right key.
Protected method | DoSpaceKey | Does the space key.
Protected method | DoUpKey | Does up key.
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | Format(Nullable<(Of <<'(DateTime>)>>)) | Formats the specified formatted.
Public method | Format(Nullable<(Of <<'(DateTime>)>>), Int32, Int32) | return a formatted date time string based on a start and end indeces
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider.
Public method | GetEditors | Gets the editors.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | Gets the items.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormatValueChanged | Called when the format value has been changed
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | (Overrides vTextBoxOnGotFocus(EventArgs).)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Called when KeyDown event occurs. (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | (Overrides Control..::..OnKeyPress(KeyPressEventArgs).)
Protected method | OnKeyUp | Called before KeyUp event occurs. (Overrides Control..::..OnKeyUp(KeyEventArgs).)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Overrides Control..::..OnMouseWheel(MouseEventArgs).)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when property is changed.
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the [E:TextChanged] event. (Overrides vTextBox..::..OnTextChanged(EventArgs).)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event.
Protected method | OnValueChanged | Called when the value has been changed
Protected method | OnValueChanging | Called when the value has been changed
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Public method | ParseValue | Parses the value.
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformSpin | Performs the spin.
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDown | Spins down.
Protected method | SpinUp | Spins up.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Public method | UpdateText | Updates the text.
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoAdvanceSelection | Gets or sets a value indicating whether the auto advance selection is enabled.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Culture | Gets or sets the culture.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Public property | DefaultDateTimeFormat | Gets or sets the default date time format.
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormatValue | Gets or sets a mask expression.
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets or sets the last datetime value
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the Maximum datetime value.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum length of the text in the textbox. (Inherited from vTextBox.)
Public property | Minimum | Gets or sets the Minimum datetime value.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NullText | Gets or sets the null text.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation.
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string.
Public property | Value | Gets or sets the value
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormatValueChanged | Occurs when the format value has been changed
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed.
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event.
Public event | ValueChanged | Occurs when the value has been changed
Public event | ValueChanging | Occurs when the value has been changing
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDateTimeEditor Class


vDateTimeEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor Constructor
vDateTimeEditor Class See Also Send Feedback
DateTimeEditor contructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDateTimeEditor()
Visual Basic
Public Sub New
Visual C++
public:
vDateTimeEditor()

See Also

vDateTimeEditor Class


vDateTimeEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor Methods
vDateTimeEditor Class See Also Send Feedback

The vDateTimeEditor type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Protected method | DoDownKey | Does down key.
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DoEndKey | Does the end key.
Protected method | DoF2Key | Does the f2 key.
Protected method | DoHomeKey | Does the home key.
Protected method | DoKeyDown |
Protected method | DoLeftKey | Does the left key.
Protected method | DoMouseWheel | Does the mouse wheel.
Protected method | DoRightKey | Does the right key.
Protected method | DoSpaceKey | Does the space key.
Protected method | DoUpKey | Does up key.
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | Format(Nullable<(Of <<'(DateTime>)>>)) | Formats the specified formatted.
Public method | Format(Nullable<(Of <<'(DateTime>)>>), Int32, Int32) | return a formatted date time string based on a start and end indeces
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider.
Public method | GetEditors | Gets the editors.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | Gets the items.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormatValueChanged | Called when the format value has been changed
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | (Overrides vTextBoxOnGotFocus(EventArgs).)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Called when KeyDown event occurs. (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | (Overrides Control..::..OnKeyPress(KeyPressEventArgs).)
Protected method | OnKeyUp | Called before KeyUp event occurs. (Overrides Control..::..OnKeyUp(KeyEventArgs).)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Overrides Control..::..OnMouseWheel(MouseEventArgs).)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when property is changed.
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the [E:TextChanged] event. (Overrides vTextBox..::..OnTextChanged(EventArgs).)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event.
Protected method | OnValueChanged | Called when the value has been changed
Protected method | OnValueChanging | Called when the value has been changed
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Public method | ParseValue | Parses the value.
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformSpin | Performs the spin.
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDown | Spins down.
Protected method | SpinUp | Spins up.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Public method | UpdateText | Updates the text.
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vDateTimeEditor Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..AccessibilityNotifyClients Method
vDateTimeEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vDateTimeEditor Class
vDateTimeEditor Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..BeginInvoke Method
vDateTimeEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vDateTimeEditor Class
vDateTimeEditor Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..Dispose Method
vDateTimeEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vDateTimeEditor Class
vDateTimeEditor Members


DoDownKey Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..DoDownKey Method
vDateTimeEditor Class See Also Send Feedback
Does down key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DoDownKey()
Visual Basic
Protected Overridable Sub DoDownKey
Visual C++
protected:
virtual void DoDownKey()

See Also

vDateTimeEditor Class


DoEndKey Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..DoEndKey Method
vDateTimeEditor Class See Also Send Feedback
Does the end key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DoEndKey()
Visual Basic
Protected Overridable Sub DoEndKey
Visual C++
protected:
virtual void DoEndKey()

See Also

vDateTimeEditor Class


DoF2Key Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..DoF2Key Method
vDateTimeEditor Class See Also Send Feedback
Does the f2 key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DoF2Key()
Visual Basic
Protected Overridable Sub DoF2Key
Visual C++
protected:
virtual void DoF2Key()

See Also

vDateTimeEditor Class


DoHomeKey Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..DoHomeKey Method
vDateTimeEditor Class See Also Send Feedback
Does the home key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DoHomeKey()
Visual Basic
Protected Overridable Sub DoHomeKey
Visual C++
protected:
virtual void DoHomeKey()

See Also

vDateTimeEditor Class


DoKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..DoKeyDown Method
vDateTimeEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DoKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overridable Sub DoKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void DoKeyDown(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs

See Also

vDateTimeEditor Class


DoLeftKey Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..DoLeftKey Method
vDateTimeEditor Class See Also Send Feedback
Does the left key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DoLeftKey()
Visual Basic
Protected Overridable Sub DoLeftKey
Visual C++
protected:
virtual void DoLeftKey()

See Also

vDateTimeEditor Class


DoMouseWheel Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..DoMouseWheel Method
vDateTimeEditor Class See Also Send Feedback
Does the mouse wheel.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DoMouseWheel(
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub DoMouseWheel ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void DoMouseWheel(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
The [!:System.Windows.Input.MouseWheelEventArgs] instance containing the event data.

See Also

vDateTimeEditor Class


DoRightKey Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..DoRightKey Method
vDateTimeEditor Class See Also Send Feedback
Does the right key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DoRightKey()
Visual Basic
Protected Overridable Sub DoRightKey
Visual C++
protected:
virtual void DoRightKey()

See Also

vDateTimeEditor Class


DoSpaceKey Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..DoSpaceKey Method
vDateTimeEditor Class See Also Send Feedback
Does the space key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DoSpaceKey()
Visual Basic
Protected Overridable Sub DoSpaceKey
Visual C++
protected:
virtual void DoSpaceKey()

See Also

vDateTimeEditor Class


DoUpKey Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..DoUpKey Method
vDateTimeEditor Class See Also Send Feedback
Does up key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DoUpKey()
Visual Basic
Protected Overridable Sub DoUpKey
Visual C++
protected:
virtual void DoUpKey()

See Also

vDateTimeEditor Class


Format Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..Format Method
vDateTimeEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Format(Nullable<(Of <<'(DateTime>)>>)) | Formats the specified formatted.
Public method | Format(Nullable<(Of <<'(DateTime>)>>), Int32, Int32) | return a formatted date time string based on a start and end indeces

See Also

vDateTimeEditor Class
vDateTimeEditor Members


Format Method (Nullable(DateTime))

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..Format Method (Nullable<(Of <(<'DateTime>)>)>)
vDateTimeEditor Class See Also Send Feedback
Formats the specified formatted.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Format(
    Nullable<DateTime> formatted
)
Visual Basic
Public Function Format ( _
    formatted As Nullable(Of DateTime) _
) As String
Visual C++
public:
String^ Format(
    Nullable<DateTime> formatted
)

Parameters

formatted
Type: System..::..Nullable <(Of <(<' DateTime >)>)>
The formatted.

Return Value

See Also

vDateTimeEditor Class
Format Overload


Format Method (Nullable(DateTime), Int32, Int32)

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..Format Method (Nullable<(Of <(<'DateTime>)>)>, Int32, Int32)
vDateTimeEditor Class See Also Send Feedback
return a formatted date time string based on a start and end indeces

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Format(
    Nullable<DateTime> formatted,
    int startFormatIndex,
    int endFormatIndex
)
Visual Basic
Public Function Format ( _
    formatted As Nullable(Of DateTime), _
    startFormatIndex As Integer, _
    endFormatIndex As Integer _
) As String
Visual C++
public:
String^ Format(
    Nullable<DateTime> formatted,
    int startFormatIndex,
    int endFormatIndex
)

Parameters

formatted
Type: System..::..Nullable <(Of <(<' DateTime >)>)>
The formatted.
startFormatIndex
Type: System..::..Int32
Start index of the format.
endFormatIndex
Type: System..::..Int32
End index of the format.

Return Value

See Also

vDateTimeEditor Class
Format Overload


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..GetChildAtPoint Method
vDateTimeEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vDateTimeEditor Class
vDateTimeEditor Members


GetDefaultValidationErrorProvider Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..GetDefaultValidationErrorProvider Method
vDateTimeEditor Class See Also Send Feedback
Gets the default validation error provider.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ErrorProvider GetDefaultValidationErrorProvider()
Visual Basic
Public Function GetDefaultValidationErrorProvider As ErrorProvider
Visual C++
public:
ErrorProvider^ GetDefaultValidationErrorProvider()

Return Value

See Also

vDateTimeEditor Class


GetEditors Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..GetEditors Method
vDateTimeEditor Class See Also Send Feedback
Gets the editors.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<IDateTimeEditor> GetEditors()
Visual Basic
Public Function GetEditors As List(Of IDateTimeEditor)
Visual C++
public:
List<IDateTimeEditor^>^ GetEditors()

Return Value

See Also

vDateTimeEditor Class


GetItems Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..GetItems Method
vDateTimeEditor Class See Also Send Feedback
Gets the items.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<DateTimeEditorFormatItem> GetItems()
Visual Basic
Public Function GetItems As List(Of DateTimeEditorFormatItem)
Visual C++
public:
List<DateTimeEditorFormatItem^>^ GetItems()

Return Value

See Also

vDateTimeEditor Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..Invalidate Method
vDateTimeEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vDateTimeEditor Class
vDateTimeEditor Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..Invoke Method
vDateTimeEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vDateTimeEditor Class
vDateTimeEditor Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..MemberwiseClone Method
vDateTimeEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vDateTimeEditor Class
vDateTimeEditor Members


OnFormatValueChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..OnFormatValueChanged Method
vDateTimeEditor Class See Also Send Feedback
Called when the format value has been changed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnFormatValueChanged()
Visual Basic
Protected Overridable Sub OnFormatValueChanged
Visual C++
protected:
virtual void OnFormatValueChanged()

See Also

vDateTimeEditor Class


OnGotFocus Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..OnGotFocus Method
vDateTimeEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnGotFocus(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnGotFocus ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnGotFocus(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vDateTimeEditor Class


OnKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..OnKeyDown Method
vDateTimeEditor Class See Also Send Feedback
Called when KeyDown event occurs.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
The data for the event.

See Also

vDateTimeEditor Class


OnKeyPress Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..OnKeyPress Method
vDateTimeEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyPress(
    KeyPressEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyPress ( _
    e As KeyPressEventArgs _
)
Visual C++
protected:
virtual void OnKeyPress(
    KeyPressEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyPressEventArgs

See Also

vDateTimeEditor Class


OnKeyUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..OnKeyUp Method
vDateTimeEditor Class See Also Send Feedback
Called before KeyUp event occurs.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyUp(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyUp ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyUp(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
The data for the event.

See Also

vDateTimeEditor Class


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..OnMouseDown Method
vDateTimeEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vDateTimeEditor Class


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..OnMouseUp Method
vDateTimeEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vDateTimeEditor Class


OnMouseWheel Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..OnMouseWheel Method
vDateTimeEditor Class See Also Send Feedback
Raises the MouseWheel event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseWheel(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseWheel ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseWheel(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vDateTimeEditor Class


OnPropertyChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..OnPropertyChanged Method
vDateTimeEditor Class See Also Send Feedback
Called when property is changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String
Name of the property.

See Also

vDateTimeEditor Class


OnTextChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..OnTextChanged Method
vDateTimeEditor Class See Also Send Feedback
Raises the [E:TextChanged] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnTextChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnTextChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnTextChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
The EventArgs instance containing the event data.

See Also

vDateTimeEditor Class


OnValidationFailed Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..OnValidationFailed Method
vDateTimeEditor Class See Also Send Feedback
Calls the ValidationFailed event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnValidationFailed()
Visual Basic
Protected Friend Overridable Sub OnValidationFailed
Visual C++
protected public:
virtual void OnValidationFailed()

See Also

vDateTimeEditor Class


OnValueChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..OnValueChanged Method
vDateTimeEditor Class See Also Send Feedback
Called when the value has been changed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnValueChanged()
Visual Basic
Protected Overridable Sub OnValueChanged
Visual C++
protected:
virtual void OnValueChanged()

See Also

vDateTimeEditor Class


OnValueChanging Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..OnValueChanging Method
vDateTimeEditor Class See Also Send Feedback
Called when the value has been changed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnValueChanging(
    CancelEventArgs args
)
Visual Basic
Protected Overridable Sub OnValueChanging ( _
    args As CancelEventArgs _
)
Visual C++
protected:
virtual void OnValueChanging(
    CancelEventArgs^ args
)

Parameters

args
Type: System.ComponentModel..::..CancelEventArgs

See Also

vDateTimeEditor Class


ParseValue Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..ParseValue Method
vDateTimeEditor Class See Also Send Feedback
Parses the value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ParseValue(
    string text
)
Visual Basic
Public Sub ParseValue ( _
    text As String _
)
Visual C++
public:
void ParseValue(
    String^ text
)

Parameters

text
Type: System..::..String
The text.

See Also

vDateTimeEditor Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..PerformLayout Method
vDateTimeEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vDateTimeEditor Class
vDateTimeEditor Members


PerformSpin Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..PerformSpin Method
vDateTimeEditor Class See Also Send Feedback
Performs the spin.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void PerformSpin(
    bool spinUp
)
Visual Basic
Public Overridable Sub PerformSpin ( _
    spinUp As Boolean _
)
Visual C++
public:
virtual void PerformSpin(
    bool spinUp
)

Parameters

spinUp
Type: System..::..Boolean
if set to true [spin up].

See Also

vDateTimeEditor Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..ResumeLayout Method
vDateTimeEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vDateTimeEditor Class
vDateTimeEditor Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..RtlTranslateAlignment Method
vDateTimeEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vDateTimeEditor Class
vDateTimeEditor Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..Scale Method
vDateTimeEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vDateTimeEditor Class
vDateTimeEditor Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..Select Method
vDateTimeEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vDateTimeEditor Class
vDateTimeEditor Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..SetBounds Method
vDateTimeEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vDateTimeEditor Class
vDateTimeEditor Members


SpinDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..SpinDown Method
vDateTimeEditor Class See Also Send Feedback
Spins down.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void SpinDown()
Visual Basic
Protected Friend Overridable Sub SpinDown
Visual C++
protected public:
virtual void SpinDown()

See Also

vDateTimeEditor Class


SpinUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..SpinUp Method
vDateTimeEditor Class See Also Send Feedback
Spins up.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void SpinUp()
Visual Basic
Protected Friend Overridable Sub SpinUp
Visual C++
protected public:
virtual void SpinUp()

See Also

vDateTimeEditor Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..UpdateBounds Method
vDateTimeEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vDateTimeEditor Class
vDateTimeEditor Members


UpdateText Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..UpdateText Method
vDateTimeEditor Class See Also Send Feedback
Updates the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void UpdateText()
Visual Basic
Public Overridable Sub UpdateText
Visual C++
public:
virtual void UpdateText()

See Also

vDateTimeEditor Class


vDateTimeEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor Properties
vDateTimeEditor Class See Also Send Feedback

The vDateTimeEditor type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoAdvanceSelection | Gets or sets a value indicating whether the auto advance selection is enabled.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Culture | Gets or sets the culture.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Public property | DefaultDateTimeFormat | Gets or sets the default date time format.
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormatValue | Gets or sets a mask expression.
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets or sets the last datetime value
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the Maximum datetime value.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum length of the text in the textbox. (Inherited from vTextBox.)
Public property | Minimum | Gets or sets the Minimum datetime value.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NullText | Gets or sets the null text.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation.
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string.
Public property | Value | Gets or sets the value
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vDateTimeEditor Class


AutoAdvanceSelection Property

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..AutoAdvanceSelection Property
vDateTimeEditor Class See Also Send Feedback
Gets or sets a value indicating whether the auto advance selection is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AutoAdvanceSelection { get; set; }
Visual Basic
Public Property AutoAdvanceSelection As Boolean
    Get
    Set
Visual C++
public:
property bool AutoAdvanceSelection {
    bool get ();
    void set (bool value);
}

See Also

vDateTimeEditor Class


Culture Property

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..Culture Property
vDateTimeEditor Class See Also Send Feedback
Gets or sets the culture.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CultureInfo Culture { get; set; }
Visual Basic
Public Property Culture As CultureInfo
    Get
    Set
Visual C++
public:
property CultureInfo^ Culture {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}

Field Value

The culture.

See Also

vDateTimeEditor Class


DefaultDateTimeFormat Property

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..DefaultDateTimeFormat Property
vDateTimeEditor Class See Also Send Feedback
Gets or sets the default date time format.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DefaultDateTimePatterns DefaultDateTimeFormat { get; set; }
Visual Basic
Public Property DefaultDateTimeFormat As DefaultDateTimePatterns
    Get
    Set
Visual C++
public:
property DefaultDateTimePatterns DefaultDateTimeFormat {
    DefaultDateTimePatterns get ();
    void set (DefaultDateTimePatterns value);
}

Field Value

The default date time format.

See Also

vDateTimeEditor Class


FormatValue Property

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..FormatValue Property
vDateTimeEditor Class See Also Send Feedback
Gets or sets a mask expression.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string FormatValue { get; set; }
Visual Basic
Public Property FormatValue As String
    Get
    Set
Visual C++
public:
property String^ FormatValue {
    String^ get ();
    void set (String^ value);
}

See Also

vDateTimeEditor Class


LastValue Property

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..LastValue Property
vDateTimeEditor Class See Also Send Feedback
Gets or sets the last datetime value

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Nullable<DateTime> LastValue { get; }
Visual Basic
Public ReadOnly Property LastValue As Nullable(Of DateTime)
    Get
Visual C++
public:
property Nullable<DateTime> LastValue {
    Nullable<DateTime> get ();
}

See Also

vDateTimeEditor Class


Maximum Property

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..Maximum Property
vDateTimeEditor Class See Also Send Feedback
Gets or sets the Maximum datetime value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime Maximum { get; set; }
Visual Basic
Public Property Maximum As DateTime
    Get
    Set
Visual C++
public:
property DateTime Maximum {
    DateTime get ();
    void set (DateTime value);
}

See Also

vDateTimeEditor Class


Minimum Property

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..Minimum Property
vDateTimeEditor Class See Also Send Feedback
Gets or sets the Minimum datetime value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime Minimum { get; set; }
Visual Basic
Public Property Minimum As DateTime
    Get
    Set
Visual C++
public:
property DateTime Minimum {
    DateTime get ();
    void set (DateTime value);
}

See Also

vDateTimeEditor Class


NullText Property

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..NullText Property
vDateTimeEditor Class See Also Send Feedback
Gets or sets the null text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string NullText { get; set; }
Visual Basic
Public Property NullText As String
    Get
    Set
Visual C++
public:
property String^ NullText {
    String^ get ();
    void set (String^ value);
}

Field Value

The null text.

See Also

vDateTimeEditor Class


UseDefaultValidation Property

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..UseDefaultValidation Property
vDateTimeEditor Class See Also Send Feedback
Gets or sets a value indicating whether to use the built-in validation.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseDefaultValidation { get; set; }
Visual Basic
Public Property UseDefaultValidation As Boolean
    Get
    Set
Visual C++
public:
property bool UseDefaultValidation {
    bool get ();
    void set (bool value);
}

See Also

vDateTimeEditor Class


ValidationString Property

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..ValidationString Property
vDateTimeEditor Class See Also Send Feedback
Gets or sets the validation string.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string ValidationString { get; set; }
Visual Basic
Public Property ValidationString As String
    Get
    Set
Visual C++
public:
property String^ ValidationString {
    String^ get ();
    void set (String^ value);
}

Field Value

The validation string.

See Also

vDateTimeEditor Class


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..Value Property
vDateTimeEditor Class See Also Send Feedback
Gets or sets the value

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Nullable<DateTime> Value { get; set; }
Visual Basic
Public Property Value As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> Value {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

See Also

vDateTimeEditor Class


vDateTimeEditor Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor Events
vDateTimeEditor Class See Also Send Feedback

The vDateTimeEditor type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormatValueChanged | Occurs when the format value has been changed
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed.
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event.
Public event | ValueChanged | Occurs when the value has been changed
Public event | ValueChanging | Occurs when the value has been changing
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDateTimeEditor Class


FormatValueChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..FormatValueChanged Event
vDateTimeEditor Class See Also Send Feedback
Occurs when the format value has been changed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler FormatValueChanged
Visual Basic
Public Event FormatValueChanged As EventHandler
Visual C++
public:
 event EventHandler^ FormatValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vDateTimeEditor Class


PropertyChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..PropertyChanged Event
vDateTimeEditor Class See Also Send Feedback
Occurs when a property has changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
 event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

See Also

vDateTimeEditor Class


ValidationFailed Event

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..ValidationFailed Event
vDateTimeEditor Class See Also Send Feedback
Represents the ValidationFailed event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ValidationFailed
Visual Basic
Public Event ValidationFailed As EventHandler
Visual C++
public:
 event EventHandler^ ValidationFailed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vDateTimeEditor Class


ValueChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..ValueChanged Event
vDateTimeEditor Class See Also Send Feedback
Occurs when the value has been changed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ValueChanged
Visual Basic
Public Event ValueChanged As EventHandler
Visual C++
public:
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vDateTimeEditor Class


ValueChanging Event

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimeEditor..::..ValueChanging Event
vDateTimeEditor Class See Also Send Feedback
Occurs when the value has been changing

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<CancelEventArgs> ValueChanging
Visual Basic
Public Event ValueChanging As EventHandler(Of CancelEventArgs)
Visual C++
public:
 event EventHandler<CancelEventArgs^>^ ValueChanging {
    void add (EventHandler<CancelEventArgs^>^ value);
    void remove (EventHandler<CancelEventArgs^>^ value);
}

See Also

vDateTimeEditor Class


vDateTimePicker Class

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker Class
Members See Also Send Feedback
Represents a vDateTimePicker control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vDateTimePicker : vDatePicker
Visual Basic
Public Class vDateTimePicker _
    Inherits vDatePicker
Visual C++
public ref class vDateTimePicker : public vDatePicker

Remarks

A vDateTimePicker displays an editable text box which allows the user to enter a time or date, or it select from a drop-down calendar.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vControlBox
VIBlend.WinForms.Controls..::..vDatePicker
VIBlend.WinForms.Controls..::..vDateTimePicker
VIBlend.WinForms.DataGridView..::..DateTimePickerEditor

See Also

vDateTimePicker Members


vDateTimePicker Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker Members
vDateTimePicker Class Constructors Methods Fields Properties Events See Also Send Feedback

The vDateTimePicker type exposes the following members.

Constructors

 | Name | Description
Public method | vDateTimePicker | Initializes a new instance of the vDateTimePicker class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down. (Inherited from vControlBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides vControlBox..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrow | Draws the arrow. (Inherited from vControlBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from vControlBox.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when property is changed. (Inherited from vControlBox.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Called when the value has been changed (Inherited from vDatePicker.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown | (Inherited from vControlBox.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | dateTimeEditor | (Inherited from vDatePicker.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from vControlBox.)
Public property | BackColorDropDown | Gets or sets the background color for the dropdown control. (Inherited from vControlBox.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color which is used when the UseThemeBorderColor property is false. (Inherited from vControlBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | Calendar | Returns the calendar control hosted by the vDataTimePicker control (Inherited from vDatePicker.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentControl | Gets or sets the content control which is displayed when the dropdown is opened (Inherited from vControlBox.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Culture | Gets or sets the current culture settings of the control. (Inherited from vDatePicker.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DateTimeEditor | (Inherited from vDatePicker.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Public property | DefaultDateTimeFormat | Gets or sets the default date time format.
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets a reference to the DropDown of the ControlBox (Inherited from vControlBox.)
Public property | DropDownArrowBackgroundEnabled | Determines whether to the drop-down arrow's background is painted (Inherited from vControlBox.)
Public property | DropDownArrowColor | Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false. (Inherited from vControlBox.)
Public property | DropDownButtonBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownButtonDisabledBackgroundBrush | Gets or sets the disabled background brush. (Inherited from vControlBox.)
Public property | DropDownButtonHighlightBackgroundBrush | Gets or sets the HighlightBackground brush. (Inherited from vControlBox.)
Public property | DropDownButtonPressedBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMaximumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMinimumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownResizeDirection | Gets or sets a value indicating the possible drop-down resize directions (Inherited from vControlBox.)
Public property | DropDownWidth | Gets or sets the width in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | EditBase | Gets a reference to the EditBox of the vControlBox control (Inherited from vControlBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font that is used to display the text in the editbox of the control (Inherited from vDatePicker.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color which is used to display the text (Inherited from vControlBox.)
Public property | FormatValue | Gets or sets the text formatting applied to the text box of the DatePicker control (Inherited from vDatePicker.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaxDate | Gets or sets the maximum DateTime. (Inherited from vDatePicker.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinDate | Gets or sets the minimum DateTime (Inherited from vDatePicker.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowGrip | Gets or sets a value indicating whether grip is shown (Inherited from vControlBox.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text displayed in the editbox of the control (Inherited from vControlBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vControlBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UpdateTimer | Gets the update timer.
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from vDatePicker.)
Public property | UseDropDownButtonThemeBackground | Gets or sets a value indicating whether to use theme's background (Inherited from vControlBox.)
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeBorderColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeDropDownArrowColor | Gets or sets whether to use the Theme default arrow color. (Inherited from vControlBox.)
Public property | UseThemeFont | Gets or sets whether to use the Theme Font or the control's Font property. (Inherited from vControlBox.)
Public property | UseThemeForeColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from vDatePicker.)
Public property | Value | Gets or sets the current DateTime for the control. (Inherited from vDatePicker.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vControlBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from vControlBox.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when the value has been changed (Inherited from vDatePicker.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDateTimePicker Class


vDateTimePicker Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker Constructor
vDateTimePicker Class See Also Send Feedback
Initializes a new instance of the vDateTimePicker class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDateTimePicker()
Visual Basic
Public Sub New
Visual C++
public:
vDateTimePicker()

See Also

vDateTimePicker Class


vDateTimePicker Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker Fields
vDateTimePicker Class See Also Send Feedback

The vDateTimePicker type exposes the following members.

Fields

 | Name | Description
Protected field | dateTimeEditor | (Inherited from vDatePicker.)

See Also

vDateTimePicker Class


vDateTimePicker Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker Methods
vDateTimePicker Class See Also Send Feedback

The vDateTimePicker type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down. (Inherited from vControlBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides vControlBox..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrow | Draws the arrow. (Inherited from vControlBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from vControlBox.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when property is changed. (Inherited from vControlBox.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Called when the value has been changed (Inherited from vDatePicker.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown | (Inherited from vControlBox.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vDateTimePicker Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker..::..AccessibilityNotifyClients Method
vDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vDateTimePicker Class
vDateTimePicker Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker..::..BeginInvoke Method
vDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vDateTimePicker Class
vDateTimePicker Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker..::..Dispose Method
vDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides vControlBox..::..Dispose(Boolean).)

See Also

vDateTimePicker Class
vDateTimePicker Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker..::..Dispose Method (Boolean)
vDateTimePicker Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vDateTimePicker Class
Dispose Overload


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker..::..GetChildAtPoint Method
vDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vDateTimePicker Class
vDateTimePicker Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker..::..Invalidate Method
vDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vDateTimePicker Class
vDateTimePicker Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker..::..Invoke Method
vDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vDateTimePicker Class
vDateTimePicker Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker..::..MemberwiseClone Method
vDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vDateTimePicker Class
vDateTimePicker Members


OnKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker..::..OnKeyDown Method
vDateTimePicker Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs

See Also

vDateTimePicker Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker..::..PerformLayout Method
vDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vDateTimePicker Class
vDateTimePicker Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker..::..ResumeLayout Method
vDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vDateTimePicker Class
vDateTimePicker Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker..::..RtlTranslateAlignment Method
vDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vDateTimePicker Class
vDateTimePicker Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker..::..Scale Method
vDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vDateTimePicker Class
vDateTimePicker Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker..::..Select Method
vDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vDateTimePicker Class
vDateTimePicker Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker..::..SetBounds Method
vDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vDateTimePicker Class
vDateTimePicker Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker..::..UpdateBounds Method
vDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vDateTimePicker Class
vDateTimePicker Members


vDateTimePicker Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker Properties
vDateTimePicker Class See Also Send Feedback

The vDateTimePicker type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from vControlBox.)
Public property | BackColorDropDown | Gets or sets the background color for the dropdown control. (Inherited from vControlBox.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color which is used when the UseThemeBorderColor property is false. (Inherited from vControlBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | Calendar | Returns the calendar control hosted by the vDataTimePicker control (Inherited from vDatePicker.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentControl | Gets or sets the content control which is displayed when the dropdown is opened (Inherited from vControlBox.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Culture | Gets or sets the current culture settings of the control. (Inherited from vDatePicker.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DateTimeEditor | (Inherited from vDatePicker.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Public property | DefaultDateTimeFormat | Gets or sets the default date time format.
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets a reference to the DropDown of the ControlBox (Inherited from vControlBox.)
Public property | DropDownArrowBackgroundEnabled | Determines whether to the drop-down arrow's background is painted (Inherited from vControlBox.)
Public property | DropDownArrowColor | Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false. (Inherited from vControlBox.)
Public property | DropDownButtonBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownButtonDisabledBackgroundBrush | Gets or sets the disabled background brush. (Inherited from vControlBox.)
Public property | DropDownButtonHighlightBackgroundBrush | Gets or sets the HighlightBackground brush. (Inherited from vControlBox.)
Public property | DropDownButtonPressedBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMaximumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMinimumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownResizeDirection | Gets or sets a value indicating the possible drop-down resize directions (Inherited from vControlBox.)
Public property | DropDownWidth | Gets or sets the width in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | EditBase | Gets a reference to the EditBox of the vControlBox control (Inherited from vControlBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font that is used to display the text in the editbox of the control (Inherited from vDatePicker.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color which is used to display the text (Inherited from vControlBox.)
Public property | FormatValue | Gets or sets the text formatting applied to the text box of the DatePicker control (Inherited from vDatePicker.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaxDate | Gets or sets the maximum DateTime. (Inherited from vDatePicker.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinDate | Gets or sets the minimum DateTime (Inherited from vDatePicker.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowGrip | Gets or sets a value indicating whether grip is shown (Inherited from vControlBox.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text displayed in the editbox of the control (Inherited from vControlBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vControlBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UpdateTimer | Gets the update timer.
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from vDatePicker.)
Public property | UseDropDownButtonThemeBackground | Gets or sets a value indicating whether to use theme's background (Inherited from vControlBox.)
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeBorderColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeDropDownArrowColor | Gets or sets whether to use the Theme default arrow color. (Inherited from vControlBox.)
Public property | UseThemeFont | Gets or sets whether to use the Theme Font or the control's Font property. (Inherited from vControlBox.)
Public property | UseThemeForeColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from vDatePicker.)
Public property | Value | Gets or sets the current DateTime for the control. (Inherited from vDatePicker.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vControlBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vDateTimePicker Class


DefaultDateTimeFormat Property

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker..::..DefaultDateTimeFormat Property
vDateTimePicker Class See Also Send Feedback
Gets or sets the default date time format.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DefaultDateTimePatterns DefaultDateTimeFormat { get; set; }
Visual Basic
Public Property DefaultDateTimeFormat As DefaultDateTimePatterns
    Get
    Set
Visual C++
public:
property DefaultDateTimePatterns DefaultDateTimeFormat {
    DefaultDateTimePatterns get ();
    void set (DefaultDateTimePatterns value);
}

Field Value

The default date time format.

See Also

vDateTimePicker Class


UpdateTimer Property

[image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker..::..UpdateTimer Property
vDateTimePicker Class See Also Send Feedback
Gets the update timer.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Timer UpdateTimer { get; }
Visual Basic
Public ReadOnly Property UpdateTimer As Timer
    Get
Visual C++
public:
property Timer^ UpdateTimer {
    Timer^ get ();
}

Field Value

The update timer.

See Also

vDateTimePicker Class


vDateTimePicker Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDateTimePicker Events
vDateTimePicker Class See Also Send Feedback

The vDateTimePicker type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from vControlBox.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when the value has been changed (Inherited from vDatePicker.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDateTimePicker Class


vDecimalEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vDecimalEditor : InputBase
Visual Basic
Public Class vDecimalEditor _
    Inherits InputBase
Visual C++
public ref class vDecimalEditor : public InputBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vTextBox
VIBlend.WinForms.Controls..::..InputBase
VIBlend.WinForms.Controls..::..vDecimalEditor

See Also

vDecimalEditor Members


vDecimalEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor Members
vDecimalEditor Class Constructors Methods Fields Properties Events See Also Send Feedback

The vDecimalEditor type exposes the following members.

Constructors

 | Name | Description
Public method | vDecimalEditor | Initializes a new instance of decimal editor.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | (Overrides InputBase..::..Backspace()()()().)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from InputBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | (Overrides InputBase..::..CtrlC()()()().)
Protected method | CtrlV | (Overrides InputBase..::..CtrlV()()()().)
Protected method | CtrlX | (Overrides InputBase..::..CtrlX()()()().)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | (Overrides InputBase..::..Delete()()()().)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key. (Inherited from InputBase.)
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key. (Inherited from InputBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider. (Inherited from InputBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text. (Inherited from InputBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key. (Inherited from InputBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | (Overrides InputBase..::..Insert(String).)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown | (Inherited from InputBase.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed. (Inherited from InputBase.)
Public method | LeftKey | Moves the cursor one position left. (Inherited from InputBase.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from InputBase.)
Protected method | OnKeyPress | (Inherited from InputBase.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from InputBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | (Inherited from InputBase.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | (Inherited from InputBase.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from InputBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event. (Inherited from InputBase.)
Protected method | OnValueChanged | Calls the ValueChanged event. (Inherited from InputBase.)
Protected method | OnValueChanging | Calls the ValueChanging event. (Inherited from InputBase.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | (Overrides InputBase..::..ParseValue()()()().)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | (Overrides InputBase..::..Redo()()()().)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters. (Inherited from InputBase.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key. (Inherited from InputBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | (Overrides InputBase..::..SetFormattedText()()()().)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit | (Inherited from InputBase.)
Protected method | SpinDigitWithWrap | Spins the digit with wrap. (Inherited from InputBase.)
Public method | SpinValue | Increases or decreases the current value. (Inherited from InputBase.)
Protected method | SpinValueBeforeDigit | Spins the value before digit. (Inherited from InputBase.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | (Overrides InputBase..::..Undo()()()().)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key. (Inherited from InputBase.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | baseFormatString | (Inherited from InputBase.)
Protected field | cultureInfo | (Inherited from InputBase.)
Protected field | decimalPlaces | (Inherited from InputBase.)
Protected field | decimalPossibleChars | (Inherited from InputBase.)
Protected field | emptyValue | (Inherited from InputBase.)
Protected field | formatString | (Inherited from InputBase.)
Protected field | isLessThanZero | (Inherited from InputBase.)
Protected field | manager | (Inherited from InputBase.)
Protected field | maximum | (Inherited from InputBase.)
Protected field | minimum | (Inherited from InputBase.)
Protected field | undoValue | (Inherited from InputBase.)
Protected field | value | (Inherited from InputBase.)
Protected field | valueString | (Inherited from InputBase.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information. (Inherited from InputBase.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DecimalPlaces | (Overrides InputBase..::..DecimalPlaces.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator | (Overrides InputBase..::..HasSeparator.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value. (Inherited from InputBase.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value. (Inherited from InputBase.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | (Inherited from InputBase.)
Public property | Minimum | Gets or sets editor's Minimum value. (Inherited from InputBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | Gets the current separator character. (Inherited from InputBase.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type. (Inherited from InputBase.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from InputBase.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from InputBase.)
Public property | Value | Gets or sets editor's value. (Inherited from InputBase.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed. (Inherited from InputBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event. (Inherited from InputBase.)
Public event | ValueChanged | Represents the ValueChanged event. (Inherited from InputBase.)
Public event | ValueChanging | Represents the ValueChanging event. (Inherited from InputBase.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDecimalEditor Class


vDecimalEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor Constructor
vDecimalEditor Class See Also Send Feedback
Initializes a new instance of decimal editor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDecimalEditor()
Visual Basic
Public Sub New
Visual C++
public:
vDecimalEditor()

See Also

vDecimalEditor Class


vDecimalEditor Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor Fields
vDecimalEditor Class See Also Send Feedback

The vDecimalEditor type exposes the following members.

Fields

 | Name | Description
Protected field | baseFormatString | (Inherited from InputBase.)
Protected field | cultureInfo | (Inherited from InputBase.)
Protected field | decimalPlaces | (Inherited from InputBase.)
Protected field | decimalPossibleChars | (Inherited from InputBase.)
Protected field | emptyValue | (Inherited from InputBase.)
Protected field | formatString | (Inherited from InputBase.)
Protected field | isLessThanZero | (Inherited from InputBase.)
Protected field | manager | (Inherited from InputBase.)
Protected field | maximum | (Inherited from InputBase.)
Protected field | minimum | (Inherited from InputBase.)
Protected field | undoValue | (Inherited from InputBase.)
Protected field | value | (Inherited from InputBase.)
Protected field | valueString | (Inherited from InputBase.)

See Also

vDecimalEditor Class


vDecimalEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor Methods
vDecimalEditor Class See Also Send Feedback

The vDecimalEditor type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | (Overrides InputBase..::..Backspace()()()().)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from InputBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | (Overrides InputBase..::..CtrlC()()()().)
Protected method | CtrlV | (Overrides InputBase..::..CtrlV()()()().)
Protected method | CtrlX | (Overrides InputBase..::..CtrlX()()()().)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | (Overrides InputBase..::..Delete()()()().)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key. (Inherited from InputBase.)
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key. (Inherited from InputBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider. (Inherited from InputBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text. (Inherited from InputBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key. (Inherited from InputBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | (Overrides InputBase..::..Insert(String).)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown | (Inherited from InputBase.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed. (Inherited from InputBase.)
Public method | LeftKey | Moves the cursor one position left. (Inherited from InputBase.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from InputBase.)
Protected method | OnKeyPress | (Inherited from InputBase.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from InputBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | (Inherited from InputBase.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | (Inherited from InputBase.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from InputBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event. (Inherited from InputBase.)
Protected method | OnValueChanged | Calls the ValueChanged event. (Inherited from InputBase.)
Protected method | OnValueChanging | Calls the ValueChanging event. (Inherited from InputBase.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | (Overrides InputBase..::..ParseValue()()()().)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | (Overrides InputBase..::..Redo()()()().)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters. (Inherited from InputBase.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key. (Inherited from InputBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | (Overrides InputBase..::..SetFormattedText()()()().)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit | (Inherited from InputBase.)
Protected method | SpinDigitWithWrap | Spins the digit with wrap. (Inherited from InputBase.)
Public method | SpinValue | Increases or decreases the current value. (Inherited from InputBase.)
Protected method | SpinValueBeforeDigit | Spins the value before digit. (Inherited from InputBase.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | (Overrides InputBase..::..Undo()()()().)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key. (Inherited from InputBase.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vDecimalEditor Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..AccessibilityNotifyClients Method
vDecimalEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vDecimalEditor Class
vDecimalEditor Members


Backspace Method

[image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..Backspace Method
vDecimalEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Backspace()
Visual Basic
Public Overrides Sub Backspace
Visual C++
public:
virtual void Backspace() override

See Also

vDecimalEditor Class


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..BeginInvoke Method
vDecimalEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vDecimalEditor Class
vDecimalEditor Members


CtrlC Method

[image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..CtrlC Method
vDecimalEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void CtrlC()
Visual Basic
Protected Overrides Sub CtrlC
Visual C++
protected:
virtual void CtrlC() override

See Also

vDecimalEditor Class


CtrlV Method

[image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..CtrlV Method
vDecimalEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void CtrlV()
Visual Basic
Protected Overrides Sub CtrlV
Visual C++
protected:
virtual void CtrlV() override

See Also

vDecimalEditor Class


CtrlX Method

[image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..CtrlX Method
vDecimalEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void CtrlX()
Visual Basic
Protected Overrides Sub CtrlX
Visual C++
protected:
virtual void CtrlX() override

See Also

vDecimalEditor Class


Delete Method

[image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..Delete Method
vDecimalEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Delete()
Visual Basic
Public Overrides Sub Delete
Visual C++
public:
virtual void Delete() override

See Also

vDecimalEditor Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..Dispose Method
vDecimalEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vDecimalEditor Class
vDecimalEditor Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..GetChildAtPoint Method
vDecimalEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vDecimalEditor Class
vDecimalEditor Members


Insert Method

[image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..Insert Method
vDecimalEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Insert(
    string insertion
)
Visual Basic
Public Overrides Sub Insert ( _
    insertion As String _
)
Visual C++
public:
virtual void Insert(
    String^ insertion
) override

Parameters

insertion
Type: System..::..String

See Also

vDecimalEditor Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..Invalidate Method
vDecimalEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vDecimalEditor Class
vDecimalEditor Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..Invoke Method
vDecimalEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vDecimalEditor Class
vDecimalEditor Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..MemberwiseClone Method
vDecimalEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vDecimalEditor Class
vDecimalEditor Members


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..OnMouseUp Method
vDecimalEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs mevent
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    mevent As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ mevent
) override

Parameters

mevent
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vDecimalEditor Class


ParseValue Method

[image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..ParseValue Method
vDecimalEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override bool ParseValue()
Visual Basic
Protected Overrides Function ParseValue As Boolean
Visual C++
protected:
virtual bool ParseValue() override

See Also

vDecimalEditor Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..PerformLayout Method
vDecimalEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vDecimalEditor Class
vDecimalEditor Members


Redo Method

[image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..Redo Method
vDecimalEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Redo()
Visual Basic
Public Overrides Sub Redo
Visual C++
public:
virtual void Redo() override

See Also

vDecimalEditor Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..ResumeLayout Method
vDecimalEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vDecimalEditor Class
vDecimalEditor Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..RtlTranslateAlignment Method
vDecimalEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vDecimalEditor Class
vDecimalEditor Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..Scale Method
vDecimalEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vDecimalEditor Class
vDecimalEditor Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..Select Method
vDecimalEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vDecimalEditor Class
vDecimalEditor Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..SetBounds Method
vDecimalEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vDecimalEditor Class
vDecimalEditor Members


SetFormattedText Method

[image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..SetFormattedText Method
vDecimalEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override bool SetFormattedText()
Visual Basic
Protected Overrides Function SetFormattedText As Boolean
Visual C++
protected:
virtual bool SetFormattedText() override

See Also

vDecimalEditor Class


Undo Method

[image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..Undo Method
vDecimalEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Undo()
Visual Basic
Public Overrides Sub Undo
Visual C++
public:
virtual void Undo() override

See Also

vDecimalEditor Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..UpdateBounds Method
vDecimalEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vDecimalEditor Class
vDecimalEditor Members


vDecimalEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor Properties
vDecimalEditor Class See Also Send Feedback

The vDecimalEditor type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information. (Inherited from InputBase.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DecimalPlaces | (Overrides InputBase..::..DecimalPlaces.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator | (Overrides InputBase..::..HasSeparator.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value. (Inherited from InputBase.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value. (Inherited from InputBase.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | (Inherited from InputBase.)
Public property | Minimum | Gets or sets editor's Minimum value. (Inherited from InputBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | Gets the current separator character. (Inherited from InputBase.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type. (Inherited from InputBase.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from InputBase.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from InputBase.)
Public property | Value | Gets or sets editor's value. (Inherited from InputBase.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vDecimalEditor Class


DecimalPlaces Property

[image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..DecimalPlaces Property
vDecimalEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override int DecimalPlaces { get; set; }
Visual Basic
Public Overrides Property DecimalPlaces As Integer
    Get
    Set
Visual C++
public:
virtual property int DecimalPlaces {
    int get () override;
    void set (int value) override;
}

See Also

vDecimalEditor Class


HasSeparator Property

[image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor..::..HasSeparator Property
vDecimalEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal override bool HasSeparator { get; }
Visual Basic
Protected Friend Overrides ReadOnly Property HasSeparator As Boolean
    Get
Visual C++
protected public:
virtual property bool HasSeparator {
    bool get () override;
}

See Also

vDecimalEditor Class


vDecimalEditor Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDecimalEditor Events
vDecimalEditor Class See Also Send Feedback

The vDecimalEditor type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed. (Inherited from InputBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event. (Inherited from InputBase.)
Public event | ValueChanged | Represents the ValueChanged event. (Inherited from InputBase.)
Public event | ValueChanging | Represents the ValueChanging event. (Inherited from InputBase.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDecimalEditor Class


vDropDownBase Class

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase Class
Members See Also Send Feedback
Represents a vDropDownBase control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vDropDownBase : Control,
    IMessageFilter
Visual Basic
Public Class vDropDownBase _
    Inherits Control _
    Implements IMessageFilter
Visual C++
public ref class vDropDownBase : public Control,
    IMessageFilter

Remarks

vDropDownBase is a base class for several drop-down controls

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vDropDownBase

See Also

vDropDownBase Members


vDropDownBase Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase Members
vDropDownBase Class Constructors Methods Properties Events See Also Send Feedback

The vDropDownBase type exposes the following members.

Constructors

 | Name | Description
Public method | vDropDownBase | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CalculateShowLocation |
Public method | CloseControl | Closes the DropDown
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDropDownClosed | Raises the DropDownClose event.
Protected method | OnDropDownClosing | Called when popup is closing
Protected method | OnDropDownOpened | Raises the DropDownOpen event.
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | OpenControl | Opens the DropDown
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreFilterMessage | Filters out a message before it is dispatched.
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RefreshVisibleArea | Updates the client ractangle for the control
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Overrides Control..::..SetVisibleCore(Boolean).)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Overrides Control..::..CreateParams.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets or sets the preferred size of the drop down control
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DropDownClose | Occurs when the Dropdown closes
Public event | DropDownClosing |
Public event | DropDownOpen | Occurs when the Dropdown opens
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDropDownBase Class


vDropDownBase Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase Constructor
vDropDownBase Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDropDownBase()
Visual Basic
Public Sub New
Visual C++
public:
vDropDownBase()

See Also

vDropDownBase Class


vDropDownBase Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase Methods
vDropDownBase Class See Also Send Feedback

The vDropDownBase type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CalculateShowLocation |
Public method | CloseControl | Closes the DropDown
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDropDownClosed | Raises the DropDownClose event.
Protected method | OnDropDownClosing | Called when popup is closing
Protected method | OnDropDownOpened | Raises the DropDownOpen event.
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | OpenControl | Opens the DropDown
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreFilterMessage | Filters out a message before it is dispatched.
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RefreshVisibleArea | Updates the client ractangle for the control
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Overrides Control..::..SetVisibleCore(Boolean).)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vDropDownBase Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..AccessibilityNotifyClients Method
vDropDownBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vDropDownBase Class
vDropDownBase Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..BeginInvoke Method
vDropDownBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vDropDownBase Class
vDropDownBase Members


CalculateShowLocation Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..CalculateShowLocation Method
vDropDownBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Point CalculateShowLocation(
    ArrowDirection direction,
    Point location,
    out Rectangle screenRect,
    out Rectangle popupRect
)
Visual Basic
Public Function CalculateShowLocation ( _
    direction As ArrowDirection, _
    location As Point, _
    <OutAttribute> ByRef screenRect As Rectangle, _
    <OutAttribute> ByRef popupRect As Rectangle _
) As Point
Visual C++
public:
Point CalculateShowLocation(
    ArrowDirection direction,
    Point location,
    [OutAttribute] Rectangle% screenRect,
    [OutAttribute] Rectangle% popupRect
)

Parameters

direction
Type: System.Windows.Forms..::..ArrowDirection
location
Type: System.Drawing..::..Point
screenRect
Type: System.Drawing..::..Rectangle %
popupRect
Type: System.Drawing..::..Rectangle %

See Also

vDropDownBase Class


CloseControl Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..CloseControl Method
vDropDownBase Class See Also Send Feedback
Closes the DropDown

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void CloseControl()
Visual Basic
Public Sub CloseControl
Visual C++
public:
void CloseControl()

See Also

vDropDownBase Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..Dispose Method
vDropDownBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vDropDownBase Class
vDropDownBase Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..GetChildAtPoint Method
vDropDownBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vDropDownBase Class
vDropDownBase Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..Invalidate Method
vDropDownBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vDropDownBase Class
vDropDownBase Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..Invoke Method
vDropDownBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vDropDownBase Class
vDropDownBase Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..MemberwiseClone Method
vDropDownBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vDropDownBase Class
vDropDownBase Members


OnDropDownClosed Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..OnDropDownClosed Method
vDropDownBase Class See Also Send Feedback
Raises the DropDownClose event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnDropDownClosed()
Visual Basic
Protected Overridable Sub OnDropDownClosed
Visual C++
protected:
virtual void OnDropDownClosed()

See Also

vDropDownBase Class


OnDropDownClosing Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..OnDropDownClosing Method
vDropDownBase Class See Also Send Feedback
Called when popup is closing

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnDropDownClosing()
Visual Basic
Protected Overridable Sub OnDropDownClosing
Visual C++
protected:
virtual void OnDropDownClosing()

See Also

vDropDownBase Class


OnDropDownOpened Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..OnDropDownOpened Method
vDropDownBase Class See Also Send Feedback
Raises the DropDownOpen event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnDropDownOpened()
Visual Basic
Protected Overridable Sub OnDropDownOpened
Visual C++
protected:
virtual void OnDropDownOpened()

See Also

vDropDownBase Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..OnPaint Method
vDropDownBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vDropDownBase Class


OpenControl Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..OpenControl Method
vDropDownBase Class See Also Send Feedback
Opens the DropDown

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OpenControl(
    ArrowDirection direction,
    Point point
)
Visual Basic
Public Sub OpenControl ( _
    direction As ArrowDirection, _
    point As Point _
)
Visual C++
public:
void OpenControl(
    ArrowDirection direction,
    Point point
)

Parameters

direction
Type: System.Windows.Forms..::..ArrowDirection
Determines whether to open the DropDown in a up or down direction.
point
Type: System.Drawing..::..Point
Locaion to show the DropDown

See Also

vDropDownBase Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..PerformLayout Method
vDropDownBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vDropDownBase Class
vDropDownBase Members


PreFilterMessage Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..PreFilterMessage Method
vDropDownBase Class See Also Send Feedback
Filters out a message before it is dispatched.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PreFilterMessage(
    ref Message m
)
Visual Basic
Public Function PreFilterMessage ( _
    ByRef m As Message _
) As Boolean
Visual C++
public:
virtual bool PreFilterMessage(
    Message% m
) sealed

Parameters

m
Type: System.Windows.Forms..::..Message %
The message to be dispatched. You cannot modify this message.

Return Value

Implements

IMessageFilter..::..PreFilterMessage(Message%)

See Also

vDropDownBase Class


RefreshVisibleArea Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..RefreshVisibleArea Method
vDropDownBase Class See Also Send Feedback
Updates the client ractangle for the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected void RefreshVisibleArea()
Visual Basic
Protected Sub RefreshVisibleArea
Visual C++
protected:
void RefreshVisibleArea()

See Also

vDropDownBase Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..ResumeLayout Method
vDropDownBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vDropDownBase Class
vDropDownBase Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..RtlTranslateAlignment Method
vDropDownBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vDropDownBase Class
vDropDownBase Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..Scale Method
vDropDownBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vDropDownBase Class
vDropDownBase Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..Select Method
vDropDownBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vDropDownBase Class
vDropDownBase Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..SetBounds Method
vDropDownBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vDropDownBase Class
vDropDownBase Members


SetVisibleCore Method

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..SetVisibleCore Method
vDropDownBase Class See Also Send Feedback
Sets the control to the specified visible state.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void SetVisibleCore(
    bool value
)
Visual Basic
Protected Overrides Sub SetVisibleCore ( _
    value As Boolean _
)
Visual C++
protected:
virtual void SetVisibleCore(
    bool value
) override

Parameters

value
Type: System..::..Boolean
true to make the control visible; otherwise, false.

See Also

vDropDownBase Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..UpdateBounds Method
vDropDownBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vDropDownBase Class
vDropDownBase Members


vDropDownBase Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase Properties
vDropDownBase Class See Also Send Feedback

The vDropDownBase type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Overrides Control..::..CreateParams.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets or sets the preferred size of the drop down control
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vDropDownBase Class


CreateParams Property

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..CreateParams Property
vDropDownBase Class See Also Send Feedback
Gets a CreateParams on the base class when creating a window.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override CreateParams CreateParams { get; }
Visual Basic
Protected Overrides ReadOnly Property CreateParams As CreateParams
    Get
Visual C++
protected:
virtual property CreateParams^ CreateParams {
    CreateParams^ get () override;
}

See Also

vDropDownBase Class


PreferredSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..PreferredSize Property
vDropDownBase Class See Also Send Feedback
Gets or sets the preferred size of the drop down control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Size PreferredSize { get; set; }
Visual Basic
Public Property PreferredSize As Size
    Get
    Set
Visual C++
public:
property Size PreferredSize {
    Size get ();
    void set (Size value);
}

See Also

vDropDownBase Class


vDropDownBase Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase Events
vDropDownBase Class See Also Send Feedback

The vDropDownBase type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DropDownClose | Occurs when the Dropdown closes
Public event | DropDownClosing |
Public event | DropDownOpen | Occurs when the Dropdown opens
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDropDownBase Class


DropDownClose Event

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..DropDownClose Event
vDropDownBase Class See Also Send Feedback
Occurs when the Dropdown closes

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler DropDownClose
Visual Basic
Public Event DropDownClose As EventHandler
Visual C++
public:
 event EventHandler^ DropDownClose {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vDropDownBase Class


DropDownClosing Event

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..DropDownClosing Event
vDropDownBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler DropDownClosing
Visual Basic
Public Event DropDownClosing As EventHandler
Visual C++
public:
 event EventHandler^ DropDownClosing {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vDropDownBase Class


DropDownOpen Event

[image]

VIBlend Controls for WinForms Help Documentation
vDropDownBase..::..DropDownOpen Event
vDropDownBase Class See Also Send Feedback
Occurs when the Dropdown opens

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler DropDownOpen
Visual Basic
Public Event DropDownOpen As EventHandler
Visual C++
public:
 event EventHandler^ DropDownOpen {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vDropDownBase Class


vExplorerBar Class

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar Class
Members See Also Send Feedback
Represents a ExplorerBar control which allows the user to select from a list of container controls that can host other controls.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vExplorerBar : vVerticalLayoutPanel,
    IScrollableControlBase
Visual Basic
Public Class vExplorerBar _
    Inherits vVerticalLayoutPanel _
    Implements IScrollableControlBase
Visual C++
public ref class vExplorerBar : public vVerticalLayoutPanel,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..Panel
VIBlend.WinForms.Controls..::..vVerticalLayoutPanel
VIBlend.WinForms.Controls..::..vExplorerBar

See Also

vExplorerBar Members


vExplorerBar Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar Members
vExplorerBar Class Constructors Methods Properties Events See Also Send Feedback

The vExplorerBar type exposes the following members.

Constructors

 | Name | Description
Public method | vExplorerBar | vExplorerBar constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CollapseItem | Collapses the item.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides vVerticalLayoutPanel..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandItem | Expands the item.
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest | HitTest to find whether on the point position there is nav pane item
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawItemHeader | Raises the [E:DrawItemHeader] event.
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Public method | OnExpandedChanged |
Public method | OnExpandedChanging |
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from vVerticalLayoutPanel.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides vVerticalLayoutPanel..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Overrides vVerticalLayoutPanel..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnToolTipShown |
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from vVerticalLayoutPanel.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollDown | (Inherited from vVerticalLayoutPanel.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Protected method | ScrollUp | (Inherited from vVerticalLayoutPanel.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectItem | Selects a specific navigation pane item
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vVerticalLayoutPanel.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowPressedItemState |
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | (Inherited from vVerticalLayoutPanel.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from vVerticalLayoutPanel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets whether the control is enabled.
Public property | EnableToggleAnimation | Gets or sets a value indicating whether toggle animation is enabled
Public property | EnableToolTips | Gets or sets a value indicating whether tool tips are enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImageList | Gets or sets the list of images to display on the control's items.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets the collection of panes in this navigationpane control.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vVerticalLayoutPanel.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vVerticalLayoutPanel.)
Public property | PanelBackColor | Gets or sets the BackColor of the Panel. (Inherited from vVerticalLayoutPanel.)
Public property | PanelBorderColor | Gets or sets the BorderColor of the Panel. (Inherited from vVerticalLayoutPanel.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Theme | Gets or sets the theme of the control.
Public property | ToolTipDuration | Gets or sets the duration of the tool tip.
Public property | ToolTipShowDelay | Gets or sets the tool tip show delay.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UsePanelBackColor | Gets or sets a value indicating whether to use the PanelBackColor (Inherited from vVerticalLayoutPanel.)
Public property | UsePanelBorderColor | Gets or sets a value indicating whether to use the PanelBorderColor (Inherited from vVerticalLayoutPanel.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItemHeader |
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | ExpandedChanged | Occurs when an item is expanded.
Public event | ExpandedChanging | Occurs when an item is expanding.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | TooltipShow | Occurs when tooltip shows.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vExplorerBar Class


vExplorerBar Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar Constructor
vExplorerBar Class See Also Send Feedback
vExplorerBar constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vExplorerBar()
Visual Basic
Public Sub New
Visual C++
public:
vExplorerBar()

See Also

vExplorerBar Class


vExplorerBar Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar Methods
vExplorerBar Class See Also Send Feedback

The vExplorerBar type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CollapseItem | Collapses the item.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides vVerticalLayoutPanel..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandItem | Expands the item.
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest | HitTest to find whether on the point position there is nav pane item
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawItemHeader | Raises the [E:DrawItemHeader] event.
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Public method | OnExpandedChanged |
Public method | OnExpandedChanging |
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from vVerticalLayoutPanel.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides vVerticalLayoutPanel..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Overrides vVerticalLayoutPanel..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnToolTipShown |
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from vVerticalLayoutPanel.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollDown | (Inherited from vVerticalLayoutPanel.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Protected method | ScrollUp | (Inherited from vVerticalLayoutPanel.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectItem | Selects a specific navigation pane item
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

See Also

vExplorerBar Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..AccessibilityNotifyClients Method
vExplorerBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vExplorerBar Class
vExplorerBar Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..BeginInvoke Method
vExplorerBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vExplorerBar Class
vExplorerBar Members


CollapseItem Method

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..CollapseItem Method
vExplorerBar Class See Also Send Feedback
Collapses the item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void CollapseItem(
    int index
)
Visual Basic
Public Sub CollapseItem ( _
    index As Integer _
)
Visual C++
public:
void CollapseItem(
    int index
)

Parameters

index
Type: System..::..Int32
The index.

See Also

vExplorerBar Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..Dispose Method
vExplorerBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides vVerticalLayoutPanel..::..Dispose(Boolean).)

See Also

vExplorerBar Class
vExplorerBar Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..Dispose Method (Boolean)
vExplorerBar Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vExplorerBar Class
Dispose Overload


ExpandItem Method

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..ExpandItem Method
vExplorerBar Class See Also Send Feedback
Expands the item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ExpandItem(
    int index
)
Visual Basic
Public Sub ExpandItem ( _
    index As Integer _
)
Visual C++
public:
void ExpandItem(
    int index
)

Parameters

index
Type: System..::..Int32
The index.

See Also

vExplorerBar Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..GetChildAtPoint Method
vExplorerBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vExplorerBar Class
vExplorerBar Members


HitTest Method

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..HitTest Method
vExplorerBar Class See Also Send Feedback
HitTest to find whether on the point position there is nav pane item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vExplorerBarItem HitTest()
Visual Basic
Public Function HitTest As vExplorerBarItem
Visual C++
public:
vExplorerBarItem^ HitTest()

Return Value

See Also

vExplorerBar Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..Invalidate Method
vExplorerBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vExplorerBar Class
vExplorerBar Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..Invoke Method
vExplorerBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vExplorerBar Class
vExplorerBar Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..MemberwiseClone Method
vExplorerBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vExplorerBar Class
vExplorerBar Members


OnDrawItemHeader Method

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..OnDrawItemHeader Method
vExplorerBar Class See Also Send Feedback
Raises the [E:DrawItemHeader] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnDrawItemHeader(
    DrawExplorerBarEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnDrawItemHeader ( _
    args As DrawExplorerBarEventArgs _
)
Visual C++
protected public:
virtual void OnDrawItemHeader(
    DrawExplorerBarEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.Controls..::..DrawExplorerBarEventArgs
The DrawExplorerBarEventArgs instance containing the event data.

See Also

vExplorerBar Class


OnExpandedChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..OnExpandedChanged Method
vExplorerBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnExpandedChanged(
    vExplorerBarEventArgs args
)
Visual Basic
Public Sub OnExpandedChanged ( _
    args As vExplorerBarEventArgs _
)
Visual C++
public:
void OnExpandedChanged(
    vExplorerBarEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.Controls..::..vExplorerBarEventArgs

See Also

vExplorerBar Class


OnExpandedChanging Method

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..OnExpandedChanging Method
vExplorerBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnExpandedChanging(
    vExplorerBarCancelEventArgs args
)
Visual Basic
Public Sub OnExpandedChanging ( _
    args As vExplorerBarCancelEventArgs _
)
Visual C++
public:
void OnExpandedChanging(
    vExplorerBarCancelEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.Controls..::..vExplorerBarCancelEventArgs

See Also

vExplorerBar Class


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..OnLayout Method
vExplorerBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs

See Also

vExplorerBar Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..OnPaint Method
vExplorerBar Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vExplorerBar Class


OnSizeChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..OnSizeChanged Method
vExplorerBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnSizeChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnSizeChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSizeChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vExplorerBar Class


OnToolTipShown Method

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..OnToolTipShown Method
vExplorerBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnToolTipShown(
    ToolTipEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnToolTipShown ( _
    args As ToolTipEventArgs _
)
Visual C++
protected public:
virtual void OnToolTipShown(
    ToolTipEventArgs^ args
)

Parameters

args
Type: ToolTipEventArgs

See Also

vExplorerBar Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..PerformLayout Method
vExplorerBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vExplorerBar Class
vExplorerBar Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..ResumeLayout Method
vExplorerBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vExplorerBar Class
vExplorerBar Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..RtlTranslateAlignment Method
vExplorerBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vExplorerBar Class
vExplorerBar Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..Scale Method
vExplorerBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vExplorerBar Class
vExplorerBar Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..Select Method
vExplorerBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vExplorerBar Class
vExplorerBar Members


SelectItem Method

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..SelectItem Method
vExplorerBar Class See Also Send Feedback
Selects a specific navigation pane item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SelectItem(
    vExplorerBarItem item
)
Visual Basic
Public Sub SelectItem ( _
    item As vExplorerBarItem _
)
Visual C++
public:
void SelectItem(
    vExplorerBarItem^ item
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..vExplorerBarItem
The Item to select

See Also

vExplorerBar Class


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..SetBounds Method
vExplorerBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vExplorerBar Class
vExplorerBar Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..UpdateBounds Method
vExplorerBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vExplorerBar Class
vExplorerBar Members


vExplorerBar Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar Properties
vExplorerBar Class See Also Send Feedback

The vExplorerBar type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vVerticalLayoutPanel.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowPressedItemState |
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | (Inherited from vVerticalLayoutPanel.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from vVerticalLayoutPanel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets whether the control is enabled.
Public property | EnableToggleAnimation | Gets or sets a value indicating whether toggle animation is enabled
Public property | EnableToolTips | Gets or sets a value indicating whether tool tips are enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImageList | Gets or sets the list of images to display on the control's items.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets the collection of panes in this navigationpane control.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vVerticalLayoutPanel.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vVerticalLayoutPanel.)
Public property | PanelBackColor | Gets or sets the BackColor of the Panel. (Inherited from vVerticalLayoutPanel.)
Public property | PanelBorderColor | Gets or sets the BorderColor of the Panel. (Inherited from vVerticalLayoutPanel.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Theme | Gets or sets the theme of the control.
Public property | ToolTipDuration | Gets or sets the duration of the tool tip.
Public property | ToolTipShowDelay | Gets or sets the tool tip show delay.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UsePanelBackColor | Gets or sets a value indicating whether to use the PanelBackColor (Inherited from vVerticalLayoutPanel.)
Public property | UsePanelBorderColor | Gets or sets a value indicating whether to use the PanelBorderColor (Inherited from vVerticalLayoutPanel.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vExplorerBar Class


AllowPressedItemState Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..AllowPressedItemState Property
vExplorerBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowPressedItemState { get; set; }
Visual Basic
Public Property AllowPressedItemState As Boolean
    Get
    Set
Visual C++
public:
property bool AllowPressedItemState {
    bool get ();
    void set (bool value);
}

See Also

vExplorerBar Class


Enabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..Enabled Property
vExplorerBar Class See Also Send Feedback
Gets or sets whether the control is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

vExplorerBar Class


EnableToggleAnimation Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..EnableToggleAnimation Property
vExplorerBar Class See Also Send Feedback
Gets or sets a value indicating whether toggle animation is enabled

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableToggleAnimation { get; set; }
Visual Basic
Public Property EnableToggleAnimation As Boolean
    Get
    Set
Visual C++
public:
property bool EnableToggleAnimation {
    bool get ();
    void set (bool value);
}

Field Value

true if true the animation is enabled; otherwise, false.

See Also

vExplorerBar Class


EnableToolTips Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..EnableToolTips Property
vExplorerBar Class See Also Send Feedback
Gets or sets a value indicating whether tool tips are enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool EnableToolTips { get; set; }
Visual Basic
Public Overridable Property EnableToolTips As Boolean
    Get
    Set
Visual C++
public:
virtual property bool EnableToolTips {
    bool get ();
    void set (bool value);
}

See Also

vExplorerBar Class


ImageList Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..ImageList Property
vExplorerBar Class See Also Send Feedback
Gets or sets the list of images to display on the control's items.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ImageList ImageList { get; set; }
Visual Basic
Public Overridable Property ImageList As ImageList
    Get
    Set
Visual C++
public:
virtual property ImageList^ ImageList {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

vExplorerBar Class


Items Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..Items Property
vExplorerBar Class See Also Send Feedback
Gets the collection of panes in this navigationpane control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ExplorerBarItemsCollection Items { get; }
Visual Basic
Public ReadOnly Property Items As ExplorerBarItemsCollection
    Get
Visual C++
public:
property ExplorerBarItemsCollection^ Items {
    ExplorerBarItemsCollection^ get ();
}

See Also

vExplorerBar Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..Theme Property
vExplorerBar Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vExplorerBar Class


ToolTipDuration Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..ToolTipDuration Property
vExplorerBar Class See Also Send Feedback
Gets or sets the duration of the tool tip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ToolTipDuration { get; set; }
Visual Basic
Public Property ToolTipDuration As Integer
    Get
    Set
Visual C++
public:
property int ToolTipDuration {
    int get ();
    void set (int value);
}

Field Value

The duration of the tool tip.

See Also

vExplorerBar Class


ToolTipShowDelay Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..ToolTipShowDelay Property
vExplorerBar Class See Also Send Feedback
Gets or sets the tool tip show delay.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ToolTipShowDelay { get; set; }
Visual Basic
Public Property ToolTipShowDelay As Integer
    Get
    Set
Visual C++
public:
property int ToolTipShowDelay {
    int get ();
    void set (int value);
}

Field Value

The tool tip show delay.

See Also

vExplorerBar Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..VIBlendTheme Property
vExplorerBar Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vExplorerBar Class


vExplorerBar Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar Events
vExplorerBar Class See Also Send Feedback

The vExplorerBar type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItemHeader |
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | ExpandedChanged | Occurs when an item is expanded.
Public event | ExpandedChanging | Occurs when an item is expanding.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | TooltipShow | Occurs when tooltip shows.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vExplorerBar Class


DrawItemHeader Event

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..DrawItemHeader Event
vExplorerBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<DrawExplorerBarEventArgs> DrawItemHeader
Visual Basic
Public Event DrawItemHeader As EventHandler(Of DrawExplorerBarEventArgs)
Visual C++
public:
 event EventHandler<DrawExplorerBarEventArgs^>^ DrawItemHeader {
    void add (EventHandler<DrawExplorerBarEventArgs^>^ value);
    void remove (EventHandler<DrawExplorerBarEventArgs^>^ value);
}

See Also

vExplorerBar Class


ExpandedChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..ExpandedChanged Event
vExplorerBar Class See Also Send Feedback
Occurs when an item is expanded.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<vExplorerBarEventArgs> ExpandedChanged
Visual Basic
Public Event ExpandedChanged As EventHandler(Of vExplorerBarEventArgs)
Visual C++
public:
 event EventHandler<vExplorerBarEventArgs^>^ ExpandedChanged {
    void add (EventHandler<vExplorerBarEventArgs^>^ value);
    void remove (EventHandler<vExplorerBarEventArgs^>^ value);
}

See Also

vExplorerBar Class


ExpandedChanging Event

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..ExpandedChanging Event
vExplorerBar Class See Also Send Feedback
Occurs when an item is expanding.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<vExplorerBarCancelEventArgs> ExpandedChanging
Visual Basic
Public Event ExpandedChanging As EventHandler(Of vExplorerBarCancelEventArgs)
Visual C++
public:
 event EventHandler<vExplorerBarCancelEventArgs^>^ ExpandedChanging {
    void add (EventHandler<vExplorerBarCancelEventArgs^>^ value);
    void remove (EventHandler<vExplorerBarCancelEventArgs^>^ value);
}

See Also

vExplorerBar Class


TooltipShow Event

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBar..::..TooltipShow Event
vExplorerBar Class See Also Send Feedback
Occurs when tooltip shows.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event ToolTipShownHandler TooltipShow
Visual Basic
Public Event TooltipShow As ToolTipShownHandler
Visual C++
public:
 event ToolTipShownHandler^ TooltipShow {
    void add (ToolTipShownHandler^ value);
    void remove (ToolTipShownHandler^ value);
}

See Also

vExplorerBar Class


vExplorerBarCancelEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarCancelEventArgs Class
Members See Also Send Feedback
Represents a vNavPane event arguments

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vExplorerBarCancelEventArgs : vExplorerBarEventArgs
Visual Basic
Public Class vExplorerBarCancelEventArgs _
    Inherits vExplorerBarEventArgs
Visual C++
public ref class vExplorerBarCancelEventArgs : public vExplorerBarEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..vExplorerBarEventArgs
VIBlend.WinForms.Controls..::..vExplorerBarCancelEventArgs

See Also

vExplorerBarCancelEventArgs Members


vExplorerBarCancelEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarCancelEventArgs Members
vExplorerBarCancelEventArgs Class Constructors Methods Properties See Also Send Feedback

The vExplorerBarCancelEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | vExplorerBarCancelEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets the cancel property.
Public property | Item | NavigationPane item associated with the event. (Inherited from vExplorerBarEventArgs.)

See Also

vExplorerBarCancelEventArgs Class


vExplorerBarCancelEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarCancelEventArgs Constructor
vExplorerBarCancelEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vExplorerBarCancelEventArgs(
    vExplorerBarItem item
)
Visual Basic
Public Sub New ( _
    item As vExplorerBarItem _
)
Visual C++
public:
vExplorerBarCancelEventArgs(
    vExplorerBarItem^ item
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..vExplorerBarItem
NavigationPane item associated with the event.

See Also

vExplorerBarCancelEventArgs Class


vExplorerBarCancelEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarCancelEventArgs Methods
vExplorerBarCancelEventArgs Class See Also Send Feedback

The vExplorerBarCancelEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vExplorerBarCancelEventArgs Class


vExplorerBarCancelEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarCancelEventArgs Properties
vExplorerBarCancelEventArgs Class See Also Send Feedback

The vExplorerBarCancelEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets the cancel property.
Public property | Item | NavigationPane item associated with the event. (Inherited from vExplorerBarEventArgs.)

See Also

vExplorerBarCancelEventArgs Class


Cancel Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarCancelEventArgs..::..Cancel Property
vExplorerBarCancelEventArgs Class See Also Send Feedback
Gets or sets the cancel property.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic
Public Property Cancel As Boolean
    Get
    Set
Visual C++
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}

See Also

vExplorerBarCancelEventArgs Class


vExplorerBarEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarEventArgs Class
Members See Also Send Feedback
Represents a vNavPane event arguments

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vExplorerBarEventArgs : EventArgs
Visual Basic
Public Class vExplorerBarEventArgs _
    Inherits EventArgs
Visual C++
public ref class vExplorerBarEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..vExplorerBarEventArgs
VIBlend.WinForms.Controls..::..vExplorerBarCancelEventArgs

See Also

vExplorerBarEventArgs Members


vExplorerBarEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarEventArgs Members
vExplorerBarEventArgs Class Constructors Methods Properties See Also Send Feedback

The vExplorerBarEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | vExplorerBarEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | NavigationPane item associated with the event.

See Also

vExplorerBarEventArgs Class


vExplorerBarEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarEventArgs Constructor
vExplorerBarEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vExplorerBarEventArgs(
    vExplorerBarItem item
)
Visual Basic
Public Sub New ( _
    item As vExplorerBarItem _
)
Visual C++
public:
vExplorerBarEventArgs(
    vExplorerBarItem^ item
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..vExplorerBarItem
NavigationPane item associated with the event.

See Also

vExplorerBarEventArgs Class


vExplorerBarEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarEventArgs Methods
vExplorerBarEventArgs Class See Also Send Feedback

The vExplorerBarEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vExplorerBarEventArgs Class


vExplorerBarEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarEventArgs Properties
vExplorerBarEventArgs Class See Also Send Feedback

The vExplorerBarEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Item | NavigationPane item associated with the event.

See Also

vExplorerBarEventArgs Class


Item Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarEventArgs..::..Item Property
vExplorerBarEventArgs Class See Also Send Feedback
NavigationPane item associated with the event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vExplorerBarItem Item { get; }
Visual Basic
Public ReadOnly Property Item As vExplorerBarItem
    Get
Visual C++
public:
property vExplorerBarItem^ Item {
    vExplorerBarItem^ get ();
}

See Also

vExplorerBarEventArgs Class


vExplorerBarItem Class

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem Class
Members See Also Send Feedback
Represents a vNavPane item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vExplorerBarItem : Control
Visual Basic
Public Class vExplorerBarItem _
    Inherits Control
Visual C++
public ref class vExplorerBarItem : public Control

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vExplorerBarItem

See Also

vExplorerBarItem Members


vExplorerBarItem Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem Members
vExplorerBarItem Class Constructors Methods Properties Events See Also Send Feedback

The vExplorerBarItem type exposes the following members.

Constructors

 | Name | Description
Public method | vExplorerBarItem | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | (Overrides Control..::..OnDoubleClick(EventArgs).)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnExpandedChanged |
Protected method | OnExpandedChanging |
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundBorder | Gets or sets the background border.
Public property | BackgroundBrush | Gets or sets the background brush.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisabledBackgroundBorder | Gets or sets the disabledBackgroundBorder border.
Public property | DisabledBackgroundBrush | Gets or sets the disabled background brush.
Public property | DisabledTextColor | Gets or sets the disabledTextColor TextColor.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Expanded | Gets or sets if the item is currently in expanded state
Public property | ExpandedHeight | Gets or sets the height when the item is epxanded.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | HeaderControl | Gets the header control.
Public property | HeaderFont | Gets or sets the font of the text to display in the item's header area
Public property | HeaderHeight | Gets or sets the height of the header area of the item
Public property | HeaderImageAlignment | Gets or sets the image alignment.
Public property | HeaderText | Gets or sets the text to display on the item's header area
Public property | HeaderTextAlignment | Gets or sets the text alignment.
Public property | HeaderTextImageRelation | Gets or sets the header text and image relation.
Public property | HeaderTheme | Gets or sets the theme of the item's header.
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightBackgroundBorder | Gets or sets the highlightBackground border.
Public property | HighlightBackgroundBrush | Gets or sets the HighlightBackground brush.
Public property | HighlightTextColor | Gets or sets the highlight TextColor.
Public property | Image | Gets or sets the image to display on the item's header
Public property | ImageIndex | Gets or sets the index of the image to display on the item's header
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemPanel | Gets a reference to the panel which hosts the controls within the navigation pane item
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavPane | Gets a reference to the NavigationPane control which hosts the item
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedBackgroundBorder | Gets or sets the selectedBackground border.
Public property | SelectedBackgroundBrush | Gets or sets the background brush.
Public property | SelectedTextColor | Gets or sets the selected TextColor.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | TextColor | Gets or sets the TextColor.
Public property | TooltipText | Gets or sets the tooltip text of the tab page.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use theme's text color
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | ExpandedChanged | Occurs when expanded property is changed.
Public event | ExpandedChanging | Occurs when expanded property is changing.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vExplorerBarItem Class


vExplorerBarItem Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem Constructor
vExplorerBarItem Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vExplorerBarItem()
Visual Basic
Public Sub New
Visual C++
public:
vExplorerBarItem()

See Also

vExplorerBarItem Class


vExplorerBarItem Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem Methods
vExplorerBarItem Class See Also Send Feedback

The vExplorerBarItem type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | (Overrides Control..::..OnDoubleClick(EventArgs).)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnExpandedChanged |
Protected method | OnExpandedChanging |
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vExplorerBarItem Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..AccessibilityNotifyClients Method
vExplorerBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vExplorerBarItem Class
vExplorerBarItem Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..BeginInvoke Method
vExplorerBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vExplorerBarItem Class
vExplorerBarItem Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..Dispose Method
vExplorerBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)

See Also

vExplorerBarItem Class
vExplorerBarItem Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..Dispose Method (Boolean)
vExplorerBarItem Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vExplorerBarItem Class
Dispose Overload


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..GetChildAtPoint Method
vExplorerBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vExplorerBarItem Class
vExplorerBarItem Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..Invalidate Method
vExplorerBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vExplorerBarItem Class
vExplorerBarItem Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..Invoke Method
vExplorerBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vExplorerBarItem Class
vExplorerBarItem Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..MemberwiseClone Method
vExplorerBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vExplorerBarItem Class
vExplorerBarItem Members


OnDoubleClick Method

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..OnDoubleClick Method
vExplorerBarItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnDoubleClick(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnDoubleClick ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnDoubleClick(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vExplorerBarItem Class


OnExpandedChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..OnExpandedChanged Method
vExplorerBarItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnExpandedChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnExpandedChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnExpandedChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::..EventArgs

See Also

vExplorerBarItem Class


OnExpandedChanging Method

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..OnExpandedChanging Method
vExplorerBarItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnExpandedChanging(
    CancelEventArgs e
)
Visual Basic
Protected Overridable Sub OnExpandedChanging ( _
    e As CancelEventArgs _
)
Visual C++
protected:
virtual void OnExpandedChanging(
    CancelEventArgs^ e
)

Parameters

e
Type: System.ComponentModel..::..CancelEventArgs

See Also

vExplorerBarItem Class


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..OnLayout Method
vExplorerBarItem Class See Also Send Feedback
Raises the Layout event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
A LayoutEventArgs that contains the event data.

See Also

vExplorerBarItem Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..OnMouseMove Method
vExplorerBarItem Class See Also Send Feedback
Raises the MouseMove event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vExplorerBarItem Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..OnPaint Method
vExplorerBarItem Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vExplorerBarItem Class


OnSizeChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..OnSizeChanged Method
vExplorerBarItem Class See Also Send Feedback
Raises the SizeChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnSizeChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnSizeChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSizeChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vExplorerBarItem Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..PerformLayout Method
vExplorerBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vExplorerBarItem Class
vExplorerBarItem Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..ResumeLayout Method
vExplorerBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vExplorerBarItem Class
vExplorerBarItem Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..RtlTranslateAlignment Method
vExplorerBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vExplorerBarItem Class
vExplorerBarItem Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..Scale Method
vExplorerBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vExplorerBarItem Class
vExplorerBarItem Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..Select Method
vExplorerBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vExplorerBarItem Class
vExplorerBarItem Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..SetBounds Method
vExplorerBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vExplorerBarItem Class
vExplorerBarItem Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..UpdateBounds Method
vExplorerBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vExplorerBarItem Class
vExplorerBarItem Members


vExplorerBarItem Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem Properties
vExplorerBarItem Class See Also Send Feedback

The vExplorerBarItem type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundBorder | Gets or sets the background border.
Public property | BackgroundBrush | Gets or sets the background brush.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisabledBackgroundBorder | Gets or sets the disabledBackgroundBorder border.
Public property | DisabledBackgroundBrush | Gets or sets the disabled background brush.
Public property | DisabledTextColor | Gets or sets the disabledTextColor TextColor.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Expanded | Gets or sets if the item is currently in expanded state
Public property | ExpandedHeight | Gets or sets the height when the item is epxanded.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | HeaderControl | Gets the header control.
Public property | HeaderFont | Gets or sets the font of the text to display in the item's header area
Public property | HeaderHeight | Gets or sets the height of the header area of the item
Public property | HeaderImageAlignment | Gets or sets the image alignment.
Public property | HeaderText | Gets or sets the text to display on the item's header area
Public property | HeaderTextAlignment | Gets or sets the text alignment.
Public property | HeaderTextImageRelation | Gets or sets the header text and image relation.
Public property | HeaderTheme | Gets or sets the theme of the item's header.
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightBackgroundBorder | Gets or sets the highlightBackground border.
Public property | HighlightBackgroundBrush | Gets or sets the HighlightBackground brush.
Public property | HighlightTextColor | Gets or sets the highlight TextColor.
Public property | Image | Gets or sets the image to display on the item's header
Public property | ImageIndex | Gets or sets the index of the image to display on the item's header
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemPanel | Gets a reference to the panel which hosts the controls within the navigation pane item
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavPane | Gets a reference to the NavigationPane control which hosts the item
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedBackgroundBorder | Gets or sets the selectedBackground border.
Public property | SelectedBackgroundBrush | Gets or sets the background brush.
Public property | SelectedTextColor | Gets or sets the selected TextColor.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | TextColor | Gets or sets the TextColor.
Public property | TooltipText | Gets or sets the tooltip text of the tab page.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use theme's text color
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vExplorerBarItem Class


BackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..BackgroundBorder Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the background border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BackgroundBorder { get; set; }
Visual Basic
Public Property BackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color BackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The background border.

See Also

vExplorerBarItem Class


BackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..BackgroundBrush Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush BackgroundBrush { get; set; }
Visual Basic
Public Property BackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ BackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vExplorerBarItem Class


DisabledBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..DisabledBackgroundBorder Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the disabledBackgroundBorder border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DisabledBackgroundBorder { get; set; }
Visual Basic
Public Property DisabledBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color DisabledBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The disabledBackgroundBorder border.

See Also

vExplorerBarItem Class


DisabledBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..DisabledBackgroundBrush Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the disabled background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush DisabledBackgroundBrush { get; set; }
Visual Basic
Public Property DisabledBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ DisabledBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The disabled background brush.

See Also

vExplorerBarItem Class


DisabledTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..DisabledTextColor Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the disabledTextColor TextColor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DisabledTextColor { get; set; }
Visual Basic
Public Property DisabledTextColor As Color
    Get
    Set
Visual C++
public:
property Color DisabledTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The disabledTextColor TextColor.

See Also

vExplorerBarItem Class


Expanded Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..Expanded Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets if the item is currently in expanded state

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Expanded { get; set; }
Visual Basic
Public Property Expanded As Boolean
    Get
    Set
Visual C++
public:
property bool Expanded {
    bool get ();
    void set (bool value);
}

See Also

vExplorerBarItem Class


ExpandedHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..ExpandedHeight Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the height when the item is epxanded.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ExpandedHeight { get; set; }
Visual Basic
Public Property ExpandedHeight As Integer
    Get
    Set
Visual C++
public:
property int ExpandedHeight {
    int get ();
    void set (int value);
}

See Also

vExplorerBarItem Class


HeaderControl Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..HeaderControl Property
vExplorerBarItem Class See Also Send Feedback
Gets the header control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vExplorerBarItemHeader HeaderControl { get; }
Visual Basic
Public ReadOnly Property HeaderControl As vExplorerBarItemHeader
    Get
Visual C++
public:
property vExplorerBarItemHeader^ HeaderControl {
    vExplorerBarItemHeader^ get ();
}

Field Value

The header control.

See Also

vExplorerBarItem Class


HeaderFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..HeaderFont Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the font of the text to display in the item's header area

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font HeaderFont { get; set; }
Visual Basic
Public Property HeaderFont As Font
    Get
    Set
Visual C++
public:
property Font^ HeaderFont {
    Font^ get ();
    void set (Font^ value);
}

See Also

vExplorerBarItem Class


HeaderHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..HeaderHeight Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the height of the header area of the item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int HeaderHeight { get; set; }
Visual Basic
Public Property HeaderHeight As Integer
    Get
    Set
Visual C++
public:
property int HeaderHeight {
    int get ();
    void set (int value);
}

See Also

vExplorerBarItem Class


HeaderImageAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..HeaderImageAlignment Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the image alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment HeaderImageAlignment { get; set; }
Visual Basic
Public Property HeaderImageAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment HeaderImageAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The image alignment.

See Also

vExplorerBarItem Class


HeaderText Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..HeaderText Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the text to display on the item's header area

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string HeaderText { get; set; }
Visual Basic
Public Property HeaderText As String
    Get
    Set
Visual C++
public:
property String^ HeaderText {
    String^ get ();
    void set (String^ value);
}

See Also

vExplorerBarItem Class


HeaderTextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..HeaderTextAlignment Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment HeaderTextAlignment { get; set; }
Visual Basic
Public Property HeaderTextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment HeaderTextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The text alignment.

See Also

vExplorerBarItem Class


HeaderTextImageRelation Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..HeaderTextImageRelation Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the header text and image relation.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public TextImageRelation HeaderTextImageRelation { get; set; }
Visual Basic
Public Property HeaderTextImageRelation As TextImageRelation
    Get
    Set
Visual C++
public:
property TextImageRelation HeaderTextImageRelation {
    TextImageRelation get ();
    void set (TextImageRelation value);
}

Field Value

The header text and image relation.

See Also

vExplorerBarItem Class


HeaderTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..HeaderTheme Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the theme of the item's header.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme HeaderTheme { get; set; }
Visual Basic
Public Property HeaderTheme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ HeaderTheme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vExplorerBarItem Class


HighlightBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..HighlightBackgroundBorder Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the highlightBackground border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color HighlightBackgroundBorder { get; set; }
Visual Basic
Public Property HighlightBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color HighlightBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The highlightBackground border.

See Also

vExplorerBarItem Class


HighlightBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..HighlightBackgroundBrush Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the HighlightBackground brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush HighlightBackgroundBrush { get; set; }
Visual Basic
Public Property HighlightBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ HighlightBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The HighlightBackground brush.

See Also

vExplorerBarItem Class


HighlightTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..HighlightTextColor Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the highlight TextColor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color HighlightTextColor { get; set; }
Visual Basic
Public Property HighlightTextColor As Color
    Get
    Set
Visual C++
public:
property Color HighlightTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The highlight TextColor.

See Also

vExplorerBarItem Class


Image Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..Image Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the image to display on the item's header

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Image Image { get; set; }
Visual Basic
Public Property Image As Image
    Get
    Set
Visual C++
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}

See Also

vExplorerBarItem Class


ImageIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..ImageIndex Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the index of the image to display on the item's header

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ImageIndex { get; set; }
Visual Basic
Public Property ImageIndex As Integer
    Get
    Set
Visual C++
public:
property int ImageIndex {
    int get ();
    void set (int value);
}

See Also

vExplorerBarItem Class


ItemPanel Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..ItemPanel Property
vExplorerBarItem Class See Also Send Feedback
Gets a reference to the panel which hosts the controls within the navigation pane item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Panel ItemPanel { get; internal set; }
Visual Basic
Public Property ItemPanel As Panel
    Get
    Friend Set
Visual C++
public:
property Panel^ ItemPanel {
    Panel^ get ();
    internal: void set (Panel^ value);
}

See Also

vExplorerBarItem Class


NavPane Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..NavPane Property
vExplorerBarItem Class See Also Send Feedback
Gets a reference to the NavigationPane control which hosts the item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vExplorerBar NavPane { get; }
Visual Basic
Public ReadOnly Property NavPane As vExplorerBar
    Get
Visual C++
public:
property vExplorerBar^ NavPane {
    vExplorerBar^ get ();
}

See Also

vExplorerBarItem Class


SelectedBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..SelectedBackgroundBorder Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the selectedBackground border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color SelectedBackgroundBorder { get; set; }
Visual Basic
Public Property SelectedBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color SelectedBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The selectedBackground border.

See Also

vExplorerBarItem Class


SelectedBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..SelectedBackgroundBrush Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush SelectedBackgroundBrush { get; set; }
Visual Basic
Public Property SelectedBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ SelectedBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vExplorerBarItem Class


SelectedTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..SelectedTextColor Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the selected TextColor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color SelectedTextColor { get; set; }
Visual Basic
Public Property SelectedTextColor As Color
    Get
    Set
Visual C++
public:
property Color SelectedTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The selected TextColor.

See Also

vExplorerBarItem Class


TextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..TextColor Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the TextColor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color TextColor { get; set; }
Visual Basic
Public Property TextColor As Color
    Get
    Set
Visual C++
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}

Field Value

The TextColor.

See Also

vExplorerBarItem Class


TooltipText Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..TooltipText Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets the tooltip text of the tab page.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string TooltipText { get; set; }
Visual Basic
Public Property TooltipText As String
    Get
    Set
Visual C++
public:
property String^ TooltipText {
    String^ get ();
    void set (String^ value);
}

See Also

vExplorerBarItem Class


UseThemeBackground Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..UseThemeBackground Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets a value indicating whether to use theme's background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBackground { get; set; }
Visual Basic
Public Property UseThemeBackground As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBackground {
    bool get ();
    void set (bool value);
}

See Also

vExplorerBarItem Class


UseThemeTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..UseThemeTextColor Property
vExplorerBarItem Class See Also Send Feedback
Gets or sets a value indicating whether to use theme's text color

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeTextColor { get; set; }
Visual Basic
Public Property UseThemeTextColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeTextColor {
    bool get ();
    void set (bool value);
}

See Also

vExplorerBarItem Class


vExplorerBarItem Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem Events
vExplorerBarItem Class See Also Send Feedback

The vExplorerBarItem type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | ExpandedChanged | Occurs when expanded property is changed.
Public event | ExpandedChanging | Occurs when expanded property is changing.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vExplorerBarItem Class


ExpandedChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..ExpandedChanged Event
vExplorerBarItem Class See Also Send Feedback
Occurs when expanded property is changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ExpandedChanged
Visual Basic
Public Event ExpandedChanged As EventHandler
Visual C++
public:
 event EventHandler^ ExpandedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vExplorerBarItem Class


ExpandedChanging Event

[image]

VIBlend Controls for WinForms Help Documentation
vExplorerBarItem..::..ExpandedChanging Event
vExplorerBarItem Class See Also Send Feedback
Occurs when expanded property is changing.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event CancelEventHandler ExpandedChanging
Visual Basic
Public Event ExpandedChanging As CancelEventHandler
Visual C++
public:
 event CancelEventHandler^ ExpandedChanging {
    void add (CancelEventHandler^ value);
    void remove (CancelEventHandler^ value);
}

See Also

vExplorerBarItem Class


vFieldSet Class

[image]

VIBlend Controls for WinForms Help Documentation
vFieldSet Class
Members See Also Send Feedback
Represents a vFieldSet control that displays and drop-down list of multi-choice items.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vFieldSet : vCheckBox
Visual Basic
Public Class vFieldSet _
    Inherits vCheckBox
Visual C++
public ref class vFieldSet : public vCheckBox

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ButtonBase
System.Windows.Forms..::..CheckBox
VIBlend.WinForms.Controls..::..vCheckBox
VIBlend.WinForms.Controls..::..vFieldSet

See Also

vFieldSet Members


vFieldSet Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFieldSet Members
vFieldSet Class Constructors Methods Properties Events See Also Send Feedback

The vFieldSet type exposes the following members.

Constructors

 | Name | Description
Public method | vFieldSet | Initializes a new instance of the vFieldSet class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the CheckBox control. (Inherited from CheckBox.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ButtonBase..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawCheck | (Overrides vCheckBox..::..DrawCheck(Graphics, Int32, Int32).)
Protected method | DrawCheckBox | (Overrides vCheckBox..::..DrawCheckBox(Graphics, Rectangle, ControlState).)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from CheckBox.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnCheckedChanged | Raises the CheckedChanged event. (Inherited from CheckBox.)
Protected method | OnCheckStateChanged | Raises the CheckStateChanged event. (Inherited from CheckBox.)
Protected method | OnClick | Raises the Click event. (Inherited from CheckBox.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from ButtonBase.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from ButtonBase.)
Protected method | OnHandleCreated | (Inherited from CheckBox.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from CheckBox.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus(EventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown(MouseEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseEnter | Raises the OnMouseEnter(EventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave(EventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Raises the OnMouseMove(MouseEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseUp | (Inherited from CheckBox.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint(PaintEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Public method | OnPropertyChanged | Called when a property is changed (Inherited from vCheckBox.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from ButtonBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from CheckBox.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
 | ShowWindow |
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the current CheckBox control. (Inherited from CheckBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ButtonBase.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Appearance | Gets or sets the value that determines the appearance of a CheckBox control. (Inherited from CheckBox.)
Public property | AutoCheck | Gets or set a value indicating whether the Checked or CheckState values and the CheckBox's appearance are automatically changed when the CheckBox is clicked. (Inherited from CheckBox.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckAlign | Gets or sets the horizontal and vertical alignment of the check mark on a CheckBox control. (Inherited from CheckBox.)
Public property | CheckBoxes | Gets a reference to the CheckBoxes list of the FieldSet control
Public property | Checked | Gets or set a value indicating whether the CheckBox is in the checked state. (Inherited from CheckBox.)
Public property | CheckMarkColor | Gets or sets the color of the check mark (Inherited from vCheckBox.)
Public property | CheckMarkColorIntermidiate | Gets or sets the color of the check mark in intermediate state (Inherited from vCheckBox.)
Public property | CheckState | Gets or sets the state of the CheckBox. (Inherited from CheckBox.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from CheckBox.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from CheckBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets a reference to the DropDown window of the vFieldSet control
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalSpacing | Gets or sets the the horizontal spacing for the FieldSet control.
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Panel | Gets or sets the container panel of the FieldSet control
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAlign | Gets or sets the alignment of the text on the CheckBox control. (Inherited from CheckBox.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the checkbutton's text is wrappable (Inherited from vCheckBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vCheckBox.)
Public property | ThreeState | Gets or sets a value indicating whether the CheckBox will allow three check states rather than two. (Inherited from CheckBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeCheckMarkColors | Gets or sets whether the check mark will use the Theme colors or the colors defined through the control properties (Inherited from vCheckBox.)
Public property | UseThemeFont | Determines whether to use the Font from the Theme or a custom value (Inherited from vCheckBox.)
Public property | UseThemeTextColor | Determines whether to use the text color from the Theme or a custom value (Inherited from vCheckBox.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalSpacing | Gets or sets the the vertical spacing for the FieldSet control.
Public property | VIBlendTheme | Gets or sets the theme of the control to one of the built-in themes. (Inherited from vCheckBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AppearanceChanged | Occurs when the value of the Appearance property changes. (Inherited from CheckBox.)
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | CheckedChanged | Occurs when the value of the Checked property changes. (Inherited from CheckBox.)
Public event | CheckStateChanged | Occurs when the value of the CheckState property changes. (Inherited from CheckBox.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the CheckBox control. (Inherited from CheckBox.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the CheckBox control. (Inherited from CheckBox.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property is changed. (Inherited from vCheckBox.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vFieldSet Class


vFieldSet Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vFieldSet Constructor
vFieldSet Class See Also Send Feedback
Initializes a new instance of the vFieldSet class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vFieldSet()
Visual Basic
Public Sub New
Visual C++
public:
vFieldSet()

See Also

vFieldSet Class


vFieldSet Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFieldSet Methods
vFieldSet Class See Also Send Feedback

The vFieldSet type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the CheckBox control. (Inherited from CheckBox.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ButtonBase..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawCheck | (Overrides vCheckBox..::..DrawCheck(Graphics, Int32, Int32).)
Protected method | DrawCheckBox | (Overrides vCheckBox..::..DrawCheckBox(Graphics, Rectangle, ControlState).)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from CheckBox.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnCheckedChanged | Raises the CheckedChanged event. (Inherited from CheckBox.)
Protected method | OnCheckStateChanged | Raises the CheckStateChanged event. (Inherited from CheckBox.)
Protected method | OnClick | Raises the Click event. (Inherited from CheckBox.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from ButtonBase.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from ButtonBase.)
Protected method | OnHandleCreated | (Inherited from CheckBox.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from CheckBox.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus(EventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown(MouseEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseEnter | Raises the OnMouseEnter(EventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave(EventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Raises the OnMouseMove(MouseEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseUp | (Inherited from CheckBox.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint(PaintEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Public method | OnPropertyChanged | Called when a property is changed (Inherited from vCheckBox.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from ButtonBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from CheckBox.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
 | ShowWindow |
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the current CheckBox control. (Inherited from CheckBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ButtonBase.)

See Also

vFieldSet Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..AccessibilityNotifyClients Method
vFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vFieldSet Class
vFieldSet Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..BeginInvoke Method
vFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vFieldSet Class
vFieldSet Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..Dispose Method
vFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ButtonBase..::..Dispose(Boolean).)

See Also

vFieldSet Class
vFieldSet Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..Dispose Method (Boolean)
vFieldSet Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vFieldSet Class
Dispose Overload


DrawCheck Method

[image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..DrawCheck Method
vFieldSet Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal override void DrawCheck(
    Graphics graphics,
    int x,
    int y
)
Visual Basic
Protected Friend Overrides Sub DrawCheck ( _
    graphics As Graphics, _
    x As Integer, _
    y As Integer _
)
Visual C++
protected public:
virtual void DrawCheck(
    Graphics^ graphics,
    int x,
    int y
) override

Parameters

graphics
Type: System.Drawing..::..Graphics
x
Type: System..::..Int32
y
Type: System..::..Int32

See Also

vFieldSet Class


DrawCheckBox Method

[image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..DrawCheckBox Method
vFieldSet Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal override void DrawCheckBox(
    Graphics g,
    Rectangle rect,
    ControlState controlState
)
Visual Basic
Protected Friend Overrides Sub DrawCheckBox ( _
    g As Graphics, _
    rect As Rectangle, _
    controlState As ControlState _
)
Visual C++
protected public:
virtual void DrawCheckBox(
    Graphics^ g,
    Rectangle rect,
    ControlState controlState
) override

Parameters

g
Type: System.Drawing..::..Graphics
rect
Type: System.Drawing..::..Rectangle
controlState
Type: ControlState

See Also

vFieldSet Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..GetChildAtPoint Method
vFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vFieldSet Class
vFieldSet Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..Invalidate Method
vFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vFieldSet Class
vFieldSet Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..Invoke Method
vFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vFieldSet Class
vFieldSet Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..MemberwiseClone Method
vFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vFieldSet Class
vFieldSet Members


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..PerformLayout Method
vFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vFieldSet Class
vFieldSet Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..ResumeLayout Method
vFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vFieldSet Class
vFieldSet Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..RtlTranslateAlignment Method
vFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vFieldSet Class
vFieldSet Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..Scale Method
vFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vFieldSet Class
vFieldSet Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..Select Method
vFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vFieldSet Class
vFieldSet Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..SetBounds Method
vFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vFieldSet Class
vFieldSet Members


ShowWindow Method

[image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..ShowWindow Method
vFieldSet Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static bool ShowWindow(
    HandleRef hWnd,
    int nCmdShow
)
Visual Basic
Public Shared Function ShowWindow ( _
    hWnd As HandleRef, _
    nCmdShow As Integer _
) As Boolean
Visual C++
public:
static bool ShowWindow(
    HandleRef hWnd,
    int nCmdShow
)

Parameters

hWnd
Type: System.Runtime.InteropServices..::..HandleRef
nCmdShow
Type: System..::..Int32

See Also

vFieldSet Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..UpdateBounds Method
vFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vFieldSet Class
vFieldSet Members


vFieldSet Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFieldSet Properties
vFieldSet Class See Also Send Feedback

The vFieldSet type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Appearance | Gets or sets the value that determines the appearance of a CheckBox control. (Inherited from CheckBox.)
Public property | AutoCheck | Gets or set a value indicating whether the Checked or CheckState values and the CheckBox's appearance are automatically changed when the CheckBox is clicked. (Inherited from CheckBox.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckAlign | Gets or sets the horizontal and vertical alignment of the check mark on a CheckBox control. (Inherited from CheckBox.)
Public property | CheckBoxes | Gets a reference to the CheckBoxes list of the FieldSet control
Public property | Checked | Gets or set a value indicating whether the CheckBox is in the checked state. (Inherited from CheckBox.)
Public property | CheckMarkColor | Gets or sets the color of the check mark (Inherited from vCheckBox.)
Public property | CheckMarkColorIntermidiate | Gets or sets the color of the check mark in intermediate state (Inherited from vCheckBox.)
Public property | CheckState | Gets or sets the state of the CheckBox. (Inherited from CheckBox.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from CheckBox.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from CheckBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets a reference to the DropDown window of the vFieldSet control
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalSpacing | Gets or sets the the horizontal spacing for the FieldSet control.
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Panel | Gets or sets the container panel of the FieldSet control
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAlign | Gets or sets the alignment of the text on the CheckBox control. (Inherited from CheckBox.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the checkbutton's text is wrappable (Inherited from vCheckBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vCheckBox.)
Public property | ThreeState | Gets or sets a value indicating whether the CheckBox will allow three check states rather than two. (Inherited from CheckBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeCheckMarkColors | Gets or sets whether the check mark will use the Theme colors or the colors defined through the control properties (Inherited from vCheckBox.)
Public property | UseThemeFont | Determines whether to use the Font from the Theme or a custom value (Inherited from vCheckBox.)
Public property | UseThemeTextColor | Determines whether to use the text color from the Theme or a custom value (Inherited from vCheckBox.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalSpacing | Gets or sets the the vertical spacing for the FieldSet control.
Public property | VIBlendTheme | Gets or sets the theme of the control to one of the built-in themes. (Inherited from vCheckBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vFieldSet Class


CheckBoxes Property

[image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..CheckBoxes Property
vFieldSet Class See Also Send Feedback
Gets a reference to the CheckBoxes list of the FieldSet control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<vCheckBox> CheckBoxes { get; }
Visual Basic
Public ReadOnly Property CheckBoxes As List(Of vCheckBox)
    Get
Visual C++
public:
property List<vCheckBox^>^ CheckBoxes {
    List<vCheckBox^>^ get ();
}

See Also

vFieldSet Class


DropDown Property

[image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..DropDown Property
vFieldSet Class See Also Send Feedback
Gets a reference to the DropDown window of the vFieldSet control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDropDownBase DropDown { get; }
Visual Basic
Public ReadOnly Property DropDown As vDropDownBase
    Get
Visual C++
public:
property vDropDownBase^ DropDown {
    vDropDownBase^ get ();
}

Field Value

The drop down.

See Also

vFieldSet Class


HorizontalSpacing Property

[image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..HorizontalSpacing Property
vFieldSet Class See Also Send Feedback
Gets or sets the the horizontal spacing for the FieldSet control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int HorizontalSpacing { get; set; }
Visual Basic
Public Property HorizontalSpacing As Integer
    Get
    Set
Visual C++
public:
property int HorizontalSpacing {
    int get ();
    void set (int value);
}

See Also

vFieldSet Class


Panel Property

[image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..Panel Property
vFieldSet Class See Also Send Feedback
Gets or sets the container panel of the FieldSet control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vPanel Panel { get; set; }
Visual Basic
Public Property Panel As vPanel
    Get
    Set
Visual C++
public:
property vPanel^ Panel {
    vPanel^ get ();
    void set (vPanel^ value);
}

See Also

vFieldSet Class


VerticalSpacing Property

[image]

VIBlend Controls for WinForms Help Documentation
vFieldSet..::..VerticalSpacing Property
vFieldSet Class See Also Send Feedback
Gets or sets the the vertical spacing for the FieldSet control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int VerticalSpacing { get; set; }
Visual Basic
Public Property VerticalSpacing As Integer
    Get
    Set
Visual C++
public:
property int VerticalSpacing {
    int get ();
    void set (int value);
}

See Also

vFieldSet Class


vFieldSet Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFieldSet Events
vFieldSet Class See Also Send Feedback

The vFieldSet type exposes the following members.

Events

 | Name | Description
Public event | AppearanceChanged | Occurs when the value of the Appearance property changes. (Inherited from CheckBox.)
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | CheckedChanged | Occurs when the value of the Checked property changes. (Inherited from CheckBox.)
Public event | CheckStateChanged | Occurs when the value of the CheckState property changes. (Inherited from CheckBox.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the CheckBox control. (Inherited from CheckBox.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the CheckBox control. (Inherited from CheckBox.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property is changed. (Inherited from vCheckBox.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vFieldSet Class


vFixedPointEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vFixedPointEditor : InputBase
Visual Basic
Public Class vFixedPointEditor _
    Inherits InputBase
Visual C++
public ref class vFixedPointEditor : public InputBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vTextBox
VIBlend.WinForms.Controls..::..InputBase
VIBlend.WinForms.Controls..::..vFixedPointEditor
VIBlend.WinForms.DataGridView..::..FixedPointEditor

See Also

vFixedPointEditor Members


vFixedPointEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor Members
vFixedPointEditor Class Constructors Methods Fields Properties Events See Also Send Feedback

The vFixedPointEditor type exposes the following members.

Constructors

 | Name | Description
Public method | vFixedPointEditor | Initializes a new instance of fixed point editor.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | (Overrides InputBase..::..Backspace()()()().)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from InputBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | (Overrides InputBase..::..CtrlC()()()().)
Protected method | CtrlV | (Overrides InputBase..::..CtrlV()()()().)
Protected method | CtrlX | (Overrides InputBase..::..CtrlX()()()().)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | (Overrides InputBase..::..Delete()()()().)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key. (Inherited from InputBase.)
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key. (Inherited from InputBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider. (Inherited from InputBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text. (Inherited from InputBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key. (Inherited from InputBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | (Overrides InputBase..::..Insert(String).)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown | (Inherited from InputBase.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed. (Inherited from InputBase.)
Public method | LeftKey | Moves the cursor one position left. (Inherited from InputBase.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from InputBase.)
Protected method | OnKeyPress | (Inherited from InputBase.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from InputBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | (Inherited from InputBase.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | (Inherited from InputBase.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from InputBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event. (Inherited from InputBase.)
Protected method | OnValueChanged | Calls the ValueChanged event. (Inherited from InputBase.)
Protected method | OnValueChanging | Calls the ValueChanging event. (Inherited from InputBase.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | (Overrides InputBase..::..ParseValue()()()().)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | (Overrides InputBase..::..Redo()()()().)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters. (Inherited from InputBase.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key. (Inherited from InputBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | (Overrides InputBase..::..SetFormattedText()()()().)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit | (Inherited from InputBase.)
Protected method | SpinDigitWithWrap | Spins the digit with wrap. (Inherited from InputBase.)
Public method | SpinValue | Increases or decreases the current value. (Inherited from InputBase.)
Protected method | SpinValueBeforeDigit | Spins the value before digit. (Inherited from InputBase.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | (Overrides InputBase..::..Undo()()()().)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key. (Inherited from InputBase.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | baseFormatString | (Inherited from InputBase.)
Protected field | cultureInfo | (Inherited from InputBase.)
Protected field | decimalPlaces | (Inherited from InputBase.)
Protected field | decimalPossibleChars | (Inherited from InputBase.)
Protected field | emptyValue | (Inherited from InputBase.)
Protected field | formatString | (Inherited from InputBase.)
Protected field | isLessThanZero | (Inherited from InputBase.)
Protected field | manager | (Inherited from InputBase.)
Protected field | maximum | (Inherited from InputBase.)
Protected field | minimum | (Inherited from InputBase.)
Protected field | undoValue | (Inherited from InputBase.)
Protected field | value | (Inherited from InputBase.)
Protected field | valueString | (Inherited from InputBase.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information. (Inherited from InputBase.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DecimalPlaces | Gets or sets editor's decimal places. (Inherited from InputBase.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator | (Inherited from InputBase.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value. (Inherited from InputBase.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value. (Inherited from InputBase.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | (Inherited from InputBase.)
Public property | Minimum | Gets or sets editor's Minimum value. (Inherited from InputBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | (Overrides InputBase..::..SeparatorChar.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type. (Inherited from InputBase.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from InputBase.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from InputBase.)
Public property | Value | Gets or sets editor's value. (Inherited from InputBase.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed. (Inherited from InputBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event. (Inherited from InputBase.)
Public event | ValueChanged | Represents the ValueChanged event. (Inherited from InputBase.)
Public event | ValueChanging | Represents the ValueChanging event. (Inherited from InputBase.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vFixedPointEditor Class


vFixedPointEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor Constructor
vFixedPointEditor Class See Also Send Feedback
Initializes a new instance of fixed point editor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vFixedPointEditor()
Visual Basic
Public Sub New
Visual C++
public:
vFixedPointEditor()

See Also

vFixedPointEditor Class


vFixedPointEditor Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor Fields
vFixedPointEditor Class See Also Send Feedback

The vFixedPointEditor type exposes the following members.

Fields

 | Name | Description
Protected field | baseFormatString | (Inherited from InputBase.)
Protected field | cultureInfo | (Inherited from InputBase.)
Protected field | decimalPlaces | (Inherited from InputBase.)
Protected field | decimalPossibleChars | (Inherited from InputBase.)
Protected field | emptyValue | (Inherited from InputBase.)
Protected field | formatString | (Inherited from InputBase.)
Protected field | isLessThanZero | (Inherited from InputBase.)
Protected field | manager | (Inherited from InputBase.)
Protected field | maximum | (Inherited from InputBase.)
Protected field | minimum | (Inherited from InputBase.)
Protected field | undoValue | (Inherited from InputBase.)
Protected field | value | (Inherited from InputBase.)
Protected field | valueString | (Inherited from InputBase.)

See Also

vFixedPointEditor Class


vFixedPointEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor Methods
vFixedPointEditor Class See Also Send Feedback

The vFixedPointEditor type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | (Overrides InputBase..::..Backspace()()()().)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from InputBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | (Overrides InputBase..::..CtrlC()()()().)
Protected method | CtrlV | (Overrides InputBase..::..CtrlV()()()().)
Protected method | CtrlX | (Overrides InputBase..::..CtrlX()()()().)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | (Overrides InputBase..::..Delete()()()().)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key. (Inherited from InputBase.)
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key. (Inherited from InputBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider. (Inherited from InputBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text. (Inherited from InputBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key. (Inherited from InputBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | (Overrides InputBase..::..Insert(String).)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown | (Inherited from InputBase.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed. (Inherited from InputBase.)
Public method | LeftKey | Moves the cursor one position left. (Inherited from InputBase.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from InputBase.)
Protected method | OnKeyPress | (Inherited from InputBase.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from InputBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | (Inherited from InputBase.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | (Inherited from InputBase.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from InputBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event. (Inherited from InputBase.)
Protected method | OnValueChanged | Calls the ValueChanged event. (Inherited from InputBase.)
Protected method | OnValueChanging | Calls the ValueChanging event. (Inherited from InputBase.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | (Overrides InputBase..::..ParseValue()()()().)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | (Overrides InputBase..::..Redo()()()().)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters. (Inherited from InputBase.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key. (Inherited from InputBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | (Overrides InputBase..::..SetFormattedText()()()().)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit | (Inherited from InputBase.)
Protected method | SpinDigitWithWrap | Spins the digit with wrap. (Inherited from InputBase.)
Public method | SpinValue | Increases or decreases the current value. (Inherited from InputBase.)
Protected method | SpinValueBeforeDigit | Spins the value before digit. (Inherited from InputBase.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | (Overrides InputBase..::..Undo()()()().)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key. (Inherited from InputBase.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vFixedPointEditor Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..AccessibilityNotifyClients Method
vFixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vFixedPointEditor Class
vFixedPointEditor Members


Backspace Method

[image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..Backspace Method
vFixedPointEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Backspace()
Visual Basic
Public Overrides Sub Backspace
Visual C++
public:
virtual void Backspace() override

See Also

vFixedPointEditor Class


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..BeginInvoke Method
vFixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vFixedPointEditor Class
vFixedPointEditor Members


CtrlC Method

[image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..CtrlC Method
vFixedPointEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void CtrlC()
Visual Basic
Protected Overrides Sub CtrlC
Visual C++
protected:
virtual void CtrlC() override

See Also

vFixedPointEditor Class


CtrlV Method

[image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..CtrlV Method
vFixedPointEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void CtrlV()
Visual Basic
Protected Overrides Sub CtrlV
Visual C++
protected:
virtual void CtrlV() override

See Also

vFixedPointEditor Class


CtrlX Method

[image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..CtrlX Method
vFixedPointEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void CtrlX()
Visual Basic
Protected Overrides Sub CtrlX
Visual C++
protected:
virtual void CtrlX() override

See Also

vFixedPointEditor Class


Delete Method

[image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..Delete Method
vFixedPointEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Delete()
Visual Basic
Public Overrides Sub Delete
Visual C++
public:
virtual void Delete() override

See Also

vFixedPointEditor Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..Dispose Method
vFixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vFixedPointEditor Class
vFixedPointEditor Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..GetChildAtPoint Method
vFixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vFixedPointEditor Class
vFixedPointEditor Members


Insert Method

[image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..Insert Method
vFixedPointEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Insert(
    string insertion
)
Visual Basic
Public Overrides Sub Insert ( _
    insertion As String _
)
Visual C++
public:
virtual void Insert(
    String^ insertion
) override

Parameters

insertion
Type: System..::..String

See Also

vFixedPointEditor Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..Invalidate Method
vFixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vFixedPointEditor Class
vFixedPointEditor Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..Invoke Method
vFixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vFixedPointEditor Class
vFixedPointEditor Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..MemberwiseClone Method
vFixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vFixedPointEditor Class
vFixedPointEditor Members


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..OnMouseUp Method
vFixedPointEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs mevent
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    mevent As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ mevent
) override

Parameters

mevent
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vFixedPointEditor Class


ParseValue Method

[image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..ParseValue Method
vFixedPointEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override bool ParseValue()
Visual Basic
Protected Overrides Function ParseValue As Boolean
Visual C++
protected:
virtual bool ParseValue() override

See Also

vFixedPointEditor Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..PerformLayout Method
vFixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vFixedPointEditor Class
vFixedPointEditor Members


Redo Method

[image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..Redo Method
vFixedPointEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Redo()
Visual Basic
Public Overrides Sub Redo
Visual C++
public:
virtual void Redo() override

See Also

vFixedPointEditor Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..ResumeLayout Method
vFixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vFixedPointEditor Class
vFixedPointEditor Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..RtlTranslateAlignment Method
vFixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vFixedPointEditor Class
vFixedPointEditor Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..Scale Method
vFixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vFixedPointEditor Class
vFixedPointEditor Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..Select Method
vFixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vFixedPointEditor Class
vFixedPointEditor Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..SetBounds Method
vFixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vFixedPointEditor Class
vFixedPointEditor Members


SetFormattedText Method

[image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..SetFormattedText Method
vFixedPointEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override bool SetFormattedText()
Visual Basic
Protected Overrides Function SetFormattedText As Boolean
Visual C++
protected:
virtual bool SetFormattedText() override

See Also

vFixedPointEditor Class


Undo Method

[image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..Undo Method
vFixedPointEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Undo()
Visual Basic
Public Overrides Sub Undo
Visual C++
public:
virtual void Undo() override

See Also

vFixedPointEditor Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..UpdateBounds Method
vFixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vFixedPointEditor Class
vFixedPointEditor Members


vFixedPointEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor Properties
vFixedPointEditor Class See Also Send Feedback

The vFixedPointEditor type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information. (Inherited from InputBase.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DecimalPlaces | Gets or sets editor's decimal places. (Inherited from InputBase.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator | (Inherited from InputBase.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value. (Inherited from InputBase.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value. (Inherited from InputBase.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | (Inherited from InputBase.)
Public property | Minimum | Gets or sets editor's Minimum value. (Inherited from InputBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | (Overrides InputBase..::..SeparatorChar.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type. (Inherited from InputBase.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from InputBase.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from InputBase.)
Public property | Value | Gets or sets editor's value. (Inherited from InputBase.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vFixedPointEditor Class


SeparatorChar Property

[image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor..::..SeparatorChar Property
vFixedPointEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string SeparatorChar { get; }
Visual Basic
Public Overrides ReadOnly Property SeparatorChar As String
    Get
Visual C++
public:
virtual property String^ SeparatorChar {
    String^ get () override;
}

See Also

vFixedPointEditor Class


vFixedPointEditor Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFixedPointEditor Events
vFixedPointEditor Class See Also Send Feedback

The vFixedPointEditor type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed. (Inherited from InputBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event. (Inherited from InputBase.)
Public event | ValueChanged | Represents the ValueChanged event. (Inherited from InputBase.)
Public event | ValueChanging | Represents the ValueChanging event. (Inherited from InputBase.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vFixedPointEditor Class


vFlowLayoutPanel Class

[image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel Class
Members See Also Send Feedback
Represents a vFlowLayoutPanel control where the user can arrange multiple controls.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vFlowLayoutPanel : vPanel
Visual Basic
Public Class vFlowLayoutPanel _
    Inherits vPanel
Visual C++
public ref class vFlowLayoutPanel : public vPanel

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vPanel
VIBlend.WinForms.Controls..::..vFlowLayoutPanel

See Also

vFlowLayoutPanel Members


vFlowLayoutPanel Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel Members
vFlowLayoutPanel Class Constructors Methods Properties Events See Also Send Feedback

The vFlowLayoutPanel type exposes the following members.

Constructors

 | Name | Description
Public method | vFlowLayoutPanel | Initializes a new instance of the vFlowLayoutPanel class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDesiredHeight | Gets the desired height.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides vPanel..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from vPanel.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Protected method | ScrollDown |
Protected method | ScrollUp |
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vPanel.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoHideControls | Gets or sets a value indicating whether control can auto hide controls
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderRadius | Gets or sets the border radius. (Inherited from vPanel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content | Gets the panel. (Inherited from vPanel.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | CustomScrollersIntersectionColor | Gets or sets the color of the scrollers intersection. (Inherited from vPanel.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Determines the opacity of the Panel control's background (Inherited from vPanel.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vPanel.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vPanel.)
Public property | PanelBorderColor | Gets or sets the BorderColor of the Panel. (Inherited from vPanel.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | (Inherited from vPanel.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UsePanelBorderColor | Gets or sets a value indicating whether to use the PanelBorderColor (Inherited from vPanel.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | (Inherited from vPanel.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vFlowLayoutPanel Class


vFlowLayoutPanel Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel Constructor
vFlowLayoutPanel Class See Also Send Feedback
Initializes a new instance of the vFlowLayoutPanel class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vFlowLayoutPanel()
Visual Basic
Public Sub New
Visual C++
public:
vFlowLayoutPanel()

See Also

vFlowLayoutPanel Class


vFlowLayoutPanel Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel Methods
vFlowLayoutPanel Class See Also Send Feedback

The vFlowLayoutPanel type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDesiredHeight | Gets the desired height.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides vPanel..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from vPanel.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Protected method | ScrollDown |
Protected method | ScrollUp |
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vFlowLayoutPanel Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..AccessibilityNotifyClients Method
vFlowLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vFlowLayoutPanel Class
vFlowLayoutPanel Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..BeginInvoke Method
vFlowLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vFlowLayoutPanel Class
vFlowLayoutPanel Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..Dispose Method
vFlowLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)

See Also

vFlowLayoutPanel Class
vFlowLayoutPanel Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..Dispose Method (Boolean)
vFlowLayoutPanel Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vFlowLayoutPanel Class
Dispose Overload


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..GetChildAtPoint Method
vFlowLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vFlowLayoutPanel Class
vFlowLayoutPanel Members


GetDesiredHeight Method

[image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..GetDesiredHeight Method
vFlowLayoutPanel Class See Also Send Feedback
Gets the desired height.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int GetDesiredHeight()
Visual Basic
Public Function GetDesiredHeight As Integer
Visual C++
public:
int GetDesiredHeight()

Return Value

See Also

vFlowLayoutPanel Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..Invalidate Method
vFlowLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vFlowLayoutPanel Class
vFlowLayoutPanel Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..Invoke Method
vFlowLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vFlowLayoutPanel Class
vFlowLayoutPanel Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..MemberwiseClone Method
vFlowLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vFlowLayoutPanel Class
vFlowLayoutPanel Members


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..OnLayout Method
vFlowLayoutPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs

See Also

vFlowLayoutPanel Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..PerformLayout Method
vFlowLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vFlowLayoutPanel Class
vFlowLayoutPanel Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..ResumeLayout Method
vFlowLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vFlowLayoutPanel Class
vFlowLayoutPanel Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..RtlTranslateAlignment Method
vFlowLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vFlowLayoutPanel Class
vFlowLayoutPanel Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..Scale Method
vFlowLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vFlowLayoutPanel Class
vFlowLayoutPanel Members


ScrollDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..ScrollDown Method
vFlowLayoutPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void ScrollDown()
Visual Basic
Protected Friend Overridable Sub ScrollDown
Visual C++
protected public:
virtual void ScrollDown()

See Also

vFlowLayoutPanel Class


ScrollUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..ScrollUp Method
vFlowLayoutPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void ScrollUp()
Visual Basic
Protected Friend Overridable Sub ScrollUp
Visual C++
protected public:
virtual void ScrollUp()

See Also

vFlowLayoutPanel Class


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..Select Method
vFlowLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vFlowLayoutPanel Class
vFlowLayoutPanel Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..SetBounds Method
vFlowLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vFlowLayoutPanel Class
vFlowLayoutPanel Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..UpdateBounds Method
vFlowLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vFlowLayoutPanel Class
vFlowLayoutPanel Members


vFlowLayoutPanel Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel Properties
vFlowLayoutPanel Class See Also Send Feedback

The vFlowLayoutPanel type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vPanel.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoHideControls | Gets or sets a value indicating whether control can auto hide controls
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderRadius | Gets or sets the border radius. (Inherited from vPanel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content | Gets the panel. (Inherited from vPanel.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | CustomScrollersIntersectionColor | Gets or sets the color of the scrollers intersection. (Inherited from vPanel.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Determines the opacity of the Panel control's background (Inherited from vPanel.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vPanel.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vPanel.)
Public property | PanelBorderColor | Gets or sets the BorderColor of the Panel. (Inherited from vPanel.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | (Inherited from vPanel.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UsePanelBorderColor | Gets or sets a value indicating whether to use the PanelBorderColor (Inherited from vPanel.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | (Inherited from vPanel.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vFlowLayoutPanel Class


AutoHideControls Property

[image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel..::..AutoHideControls Property
vFlowLayoutPanel Class See Also Send Feedback
Gets or sets a value indicating whether control can auto hide controls

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AutoHideControls { get; set; }
Visual Basic
Public Property AutoHideControls As Boolean
    Get
    Set
Visual C++
public:
property bool AutoHideControls {
    bool get ();
    void set (bool value);
}

See Also

vFlowLayoutPanel Class


vFlowLayoutPanel Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFlowLayoutPanel Events
vFlowLayoutPanel Class See Also Send Feedback

The vFlowLayoutPanel type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vFlowLayoutPanel Class


vFontComboBox Class

[image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox Class
Members See Also Send Feedback
Represents a vFontComboBox control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vFontComboBox : vComboBox
Visual Basic
Public Class vFontComboBox _
    Inherits vComboBox
Visual C++
public ref class vFontComboBox : public vComboBox

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vComboBox
VIBlend.WinForms.Controls..::..vFontComboBox

See Also

vFontComboBox Members


vFontComboBox Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox Members
vFontComboBox Class Constructors Methods Properties Events See Also Send Feedback

The vFontComboBox type exposes the following members.

Constructors

 | Name | Description
Public method | vFontComboBox | Initializes a new instance of the vFontComboBox class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down. (Inherited from vComboBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrow | Draws the arrow. (Inherited from vComboBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDropDownClosed | Called when the drop down is closed. (Inherited from vComboBox.)
Protected method | OnDropDownOpened | Called when the drop down is opened. (Inherited from vComboBox.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemMouseDown | Raises the [E:ItemMouseDown] event. (Inherited from vComboBox.)
Protected method | OnItemMouseUp | Raises the [E:ItemMouseUp] event. (Inherited from vComboBox.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from vComboBox.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides vComboBox..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Inherited from vComboBox.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectedIndexChanged | Raises the SelectedIndexChanged event (Inherited from vComboBox.)
Protected method | OnSelectedItemChanged | (Inherited from vComboBox.)
Protected method | OnSelectedItemChanging | (Inherited from vComboBox.)
Protected method | OnSelectedValueChanged | Raises the SelectedValueChanged event. (Inherited from vComboBox.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | This member overrides Control.ProcessCmdKey. (Inherited from vComboBox.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveSort | Removes the sort. (Inherited from vComboBox.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Reverse | Reverses this instance. (Inherited from vComboBox.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown | Shows the drop down. (Inherited from vComboBox.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort(Boolean) | Sorts the specified ascending. (Inherited from vComboBox.)
Public method | Sort(IComparer<(Of <<'(ListItem>)>>)) | Sorts the specified comparer. (Inherited from vComboBox.)
Public method | Sort(Comparison<(Of <<'(ListItem>)>>)) | Sorts the specified comparison. (Inherited from vComboBox.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vComboBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoCompleteEnabled | Gets or sets a value indicating whether auto complete is enabled. (Inherited from vComboBox.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from vComboBox.)
Public property | BackgroundImage | Gets or sets the background image of the control (Inherited from vComboBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color which is used when the UseThemeBorderColor property is false. (Inherited from vComboBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the DataSource of the vComboBox (Inherited from vComboBox.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vComboBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vComboBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayMember | Gets or sets the display member associated to the vComboBox. (Inherited from vComboBox.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets the drop down. (Inherited from vComboBox.)
Public property | DropDownArrowBackgroundEnabled | Determines whether to the drop-down arrow's background is painted (Inherited from vComboBox.)
Public property | DropDownArrowColor | Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false. (Inherited from vComboBox.)
Public property | DropDownButtonBackgroundBrush | Gets or sets the background brush. (Inherited from vComboBox.)
Public property | DropDownButtonDisabledBackgroundBrush | Gets or sets the disabled background brush. (Inherited from vComboBox.)
Public property | DropDownButtonHighlightBackgroundBrush | Gets or sets the HighlightBackground brush. (Inherited from vComboBox.)
Public property | DropDownButtonPressedBackgroundBrush | Gets or sets the background brush. (Inherited from vComboBox.)
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ComboBox (Inherited from vComboBox.)
Public property | DropDownList | Gets or sets whether the combo box is a drop down list. (Inherited from vComboBox.)
Public property | DropDownMaximumSize | Gets or sets the maximum size of the drop-down portion of the ComboBox (Inherited from vComboBox.)
Public property | DropDownMinimumSize | Gets or sets the maximum size of the drop-down portion of the ComboBox (Inherited from vComboBox.)
Public property | DropDownResizeDirection | Gets or sets a value indicating the possible drop-down resize directions (Inherited from vComboBox.)
Public property | DropDownWidth | Gets or sets the width in pixels of the drop-down portion of the ComboBox (Inherited from vComboBox.)
Public property | EditBase | Gets the edit base. (Inherited from vComboBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font that is used to display the text in the editbox of the control (Inherited from vComboBox.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color which is used to display the text (Inherited from vComboBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImageList | Gets or sets the images list of the vComboBox (Inherited from vComboBox.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of the items inside the dropdown list of the vComboBox (Inherited from vComboBox.)
Public property | Items | Gets the ComboBox Items collection. (Inherited from vComboBox.)
Public property | ItemsSpacing | (Inherited from vComboBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | ListBox | Gets the vListBox inside the vComboBox. (Inherited from vComboBox.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Indicates whether the control should draw right-to-left for RTL langauges (Inherited from vComboBox.)
Public property | RoundedCornersMaskListItem | Gets or sets the mask that determines which corners of a ListItem are rounded (Inherited from vComboBox.)
Public property | RoundedCornersRadiusListItem | Gets or sets the rounded corners radius of the ListItems. (Inherited from vComboBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedFont | Gets or sets the selected font.
Public property | SelectedIndex | Gets or sets the index of the currently selected item. Returns -1 if there is no item selected (Inherited from vComboBox.)
Public property | SelectedItem | Gets or sets the currently selected item of the drop down list of the combo box control. (Inherited from vComboBox.)
Public property | SelectedValue | Gets or sets the selected value. (Inherited from vComboBox.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vComboBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowGrip | Gets or sets a value indicating whether grip is shown (Inherited from vComboBox.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text displayed in the editbox of the control (Inherited from vComboBox.)
Public property | Theme | Gets or sets the Theme of the control. (Inherited from vComboBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultDropDownWidth | Gets or sets a value indicating whether to use the default drop down width. (Inherited from vComboBox.)
Public property | UseDropDownButtonThemeBackground | Gets or sets a value indicating whether to use theme's background (Inherited from vComboBox.)
Public property | UseDropDownDefaultSize | Gets or sets a value indicating whether to use the default size of the drop down
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property. (Inherited from vComboBox.)
Public property | UseThemeBorderColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vComboBox.)
Public property | UseThemeDropDownArrowColor | Gets or sets whether to use the Theme default arrow color. (Inherited from vComboBox.)
Public property | UseThemeFont | Gets or sets whether to use the Theme Font or the control's Font property. (Inherited from vComboBox.)
Public property | UseThemeForeColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vComboBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets a string that specifies the property of the data source from which to draw the value. (Inherited from vComboBox.)
Public property | VIBlendScrollBarsTheme | Gets or sets the theme of the treeview scrollbars using one of the built-in themes. (Inherited from vComboBox.)
Public property | VIBlendTheme | Gets or sets the theme of the control to one of the built-in themes. (Inherited from vComboBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DropDownClose | (Inherited from vComboBox.)
Public event | DropDownOpen | Occurs when the DropDown is opened. (Inherited from vComboBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemMouseDown | Occurs when the mouse is clicked over a ListItem. (Inherited from vComboBox.)
Public event | ItemMouseUp | Occurs when the mouse is clicked over a ListItem. (Inherited from vComboBox.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the selected index has changed (Inherited from vComboBox.)
Public event | SelectedItemChanged | occurs when the selection is changed. (Inherited from vComboBox.)
Public event | SelectedItemChanging | Occurs when the selection is changing. (Inherited from vComboBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue has changed. (Inherited from vComboBox.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vFontComboBox Class


vFontComboBox Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox Constructor
vFontComboBox Class See Also Send Feedback
Initializes a new instance of the vFontComboBox class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vFontComboBox()
Visual Basic
Public Sub New
Visual C++
public:
vFontComboBox()

See Also

vFontComboBox Class


vFontComboBox Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox Methods
vFontComboBox Class See Also Send Feedback

The vFontComboBox type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down. (Inherited from vComboBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrow | Draws the arrow. (Inherited from vComboBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDropDownClosed | Called when the drop down is closed. (Inherited from vComboBox.)
Protected method | OnDropDownOpened | Called when the drop down is opened. (Inherited from vComboBox.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemMouseDown | Raises the [E:ItemMouseDown] event. (Inherited from vComboBox.)
Protected method | OnItemMouseUp | Raises the [E:ItemMouseUp] event. (Inherited from vComboBox.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from vComboBox.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides vComboBox..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Inherited from vComboBox.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectedIndexChanged | Raises the SelectedIndexChanged event (Inherited from vComboBox.)
Protected method | OnSelectedItemChanged | (Inherited from vComboBox.)
Protected method | OnSelectedItemChanging | (Inherited from vComboBox.)
Protected method | OnSelectedValueChanged | Raises the SelectedValueChanged event. (Inherited from vComboBox.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | This member overrides Control.ProcessCmdKey. (Inherited from vComboBox.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveSort | Removes the sort. (Inherited from vComboBox.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Reverse | Reverses this instance. (Inherited from vComboBox.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown | Shows the drop down. (Inherited from vComboBox.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort(Boolean) | Sorts the specified ascending. (Inherited from vComboBox.)
Public method | Sort(IComparer<(Of <<'(ListItem>)>>)) | Sorts the specified comparer. (Inherited from vComboBox.)
Public method | Sort(Comparison<(Of <<'(ListItem>)>>)) | Sorts the specified comparison. (Inherited from vComboBox.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vFontComboBox Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox..::..AccessibilityNotifyClients Method
vFontComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vFontComboBox Class
vFontComboBox Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox..::..BeginInvoke Method
vFontComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vFontComboBox Class
vFontComboBox Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox..::..Dispose Method
vFontComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vFontComboBox Class
vFontComboBox Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox..::..GetChildAtPoint Method
vFontComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vFontComboBox Class
vFontComboBox Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox..::..Invalidate Method
vFontComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vFontComboBox Class
vFontComboBox Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox..::..Invoke Method
vFontComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vFontComboBox Class
vFontComboBox Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox..::..MemberwiseClone Method
vFontComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vFontComboBox Class
vFontComboBox Members


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox..::..OnLayout Method
vFontComboBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs

See Also

vFontComboBox Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox..::..PerformLayout Method
vFontComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vFontComboBox Class
vFontComboBox Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox..::..ResumeLayout Method
vFontComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vFontComboBox Class
vFontComboBox Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox..::..RtlTranslateAlignment Method
vFontComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vFontComboBox Class
vFontComboBox Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox..::..Scale Method
vFontComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vFontComboBox Class
vFontComboBox Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox..::..Select Method
vFontComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vFontComboBox Class
vFontComboBox Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox..::..SetBounds Method
vFontComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vFontComboBox Class
vFontComboBox Members


Sort Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox..::..Sort Method
vFontComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort(Boolean) | Sorts the specified ascending. (Inherited from vComboBox.)
Public method | Sort(IComparer<(Of <<'(ListItem>)>>)) | Sorts the specified comparer. (Inherited from vComboBox.)
Public method | Sort(Comparison<(Of <<'(ListItem>)>>)) | Sorts the specified comparison. (Inherited from vComboBox.)

See Also

vFontComboBox Class
vFontComboBox Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox..::..UpdateBounds Method
vFontComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vFontComboBox Class
vFontComboBox Members


vFontComboBox Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox Properties
vFontComboBox Class See Also Send Feedback

The vFontComboBox type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vComboBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoCompleteEnabled | Gets or sets a value indicating whether auto complete is enabled. (Inherited from vComboBox.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from vComboBox.)
Public property | BackgroundImage | Gets or sets the background image of the control (Inherited from vComboBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color which is used when the UseThemeBorderColor property is false. (Inherited from vComboBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the DataSource of the vComboBox (Inherited from vComboBox.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vComboBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vComboBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayMember | Gets or sets the display member associated to the vComboBox. (Inherited from vComboBox.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets the drop down. (Inherited from vComboBox.)
Public property | DropDownArrowBackgroundEnabled | Determines whether to the drop-down arrow's background is painted (Inherited from vComboBox.)
Public property | DropDownArrowColor | Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false. (Inherited from vComboBox.)
Public property | DropDownButtonBackgroundBrush | Gets or sets the background brush. (Inherited from vComboBox.)
Public property | DropDownButtonDisabledBackgroundBrush | Gets or sets the disabled background brush. (Inherited from vComboBox.)
Public property | DropDownButtonHighlightBackgroundBrush | Gets or sets the HighlightBackground brush. (Inherited from vComboBox.)
Public property | DropDownButtonPressedBackgroundBrush | Gets or sets the background brush. (Inherited from vComboBox.)
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ComboBox (Inherited from vComboBox.)
Public property | DropDownList | Gets or sets whether the combo box is a drop down list. (Inherited from vComboBox.)
Public property | DropDownMaximumSize | Gets or sets the maximum size of the drop-down portion of the ComboBox (Inherited from vComboBox.)
Public property | DropDownMinimumSize | Gets or sets the maximum size of the drop-down portion of the ComboBox (Inherited from vComboBox.)
Public property | DropDownResizeDirection | Gets or sets a value indicating the possible drop-down resize directions (Inherited from vComboBox.)
Public property | DropDownWidth | Gets or sets the width in pixels of the drop-down portion of the ComboBox (Inherited from vComboBox.)
Public property | EditBase | Gets the edit base. (Inherited from vComboBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font that is used to display the text in the editbox of the control (Inherited from vComboBox.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color which is used to display the text (Inherited from vComboBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImageList | Gets or sets the images list of the vComboBox (Inherited from vComboBox.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of the items inside the dropdown list of the vComboBox (Inherited from vComboBox.)
Public property | Items | Gets the ComboBox Items collection. (Inherited from vComboBox.)
Public property | ItemsSpacing | (Inherited from vComboBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | ListBox | Gets the vListBox inside the vComboBox. (Inherited from vComboBox.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Indicates whether the control should draw right-to-left for RTL langauges (Inherited from vComboBox.)
Public property | RoundedCornersMaskListItem | Gets or sets the mask that determines which corners of a ListItem are rounded (Inherited from vComboBox.)
Public property | RoundedCornersRadiusListItem | Gets or sets the rounded corners radius of the ListItems. (Inherited from vComboBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedFont | Gets or sets the selected font.
Public property | SelectedIndex | Gets or sets the index of the currently selected item. Returns -1 if there is no item selected (Inherited from vComboBox.)
Public property | SelectedItem | Gets or sets the currently selected item of the drop down list of the combo box control. (Inherited from vComboBox.)
Public property | SelectedValue | Gets or sets the selected value. (Inherited from vComboBox.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vComboBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowGrip | Gets or sets a value indicating whether grip is shown (Inherited from vComboBox.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text displayed in the editbox of the control (Inherited from vComboBox.)
Public property | Theme | Gets or sets the Theme of the control. (Inherited from vComboBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultDropDownWidth | Gets or sets a value indicating whether to use the default drop down width. (Inherited from vComboBox.)
Public property | UseDropDownButtonThemeBackground | Gets or sets a value indicating whether to use theme's background (Inherited from vComboBox.)
Public property | UseDropDownDefaultSize | Gets or sets a value indicating whether to use the default size of the drop down
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property. (Inherited from vComboBox.)
Public property | UseThemeBorderColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vComboBox.)
Public property | UseThemeDropDownArrowColor | Gets or sets whether to use the Theme default arrow color. (Inherited from vComboBox.)
Public property | UseThemeFont | Gets or sets whether to use the Theme Font or the control's Font property. (Inherited from vComboBox.)
Public property | UseThemeForeColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vComboBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets a string that specifies the property of the data source from which to draw the value. (Inherited from vComboBox.)
Public property | VIBlendScrollBarsTheme | Gets or sets the theme of the treeview scrollbars using one of the built-in themes. (Inherited from vComboBox.)
Public property | VIBlendTheme | Gets or sets the theme of the control to one of the built-in themes. (Inherited from vComboBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vFontComboBox Class


SelectedFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox..::..SelectedFont Property
vFontComboBox Class See Also Send Feedback
Gets or sets the selected font.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Font SelectedFont { get; set; }
Visual Basic
Public Overridable Property SelectedFont As Font
    Get
    Set
Visual C++
public:
virtual property Font^ SelectedFont {
    Font^ get ();
    void set (Font^ value);
}

Field Value

The selected font.

See Also

vFontComboBox Class


UseDropDownDefaultSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox..::..UseDropDownDefaultSize Property
vFontComboBox Class See Also Send Feedback
Gets or sets a value indicating whether to use the default size of the drop down

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseDropDownDefaultSize { get; set; }
Visual Basic
Public Property UseDropDownDefaultSize As Boolean
    Get
    Set
Visual C++
public:
property bool UseDropDownDefaultSize {
    bool get ();
    void set (bool value);
}

See Also

vFontComboBox Class


vFontComboBox Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFontComboBox Events
vFontComboBox Class See Also Send Feedback

The vFontComboBox type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DropDownClose | (Inherited from vComboBox.)
Public event | DropDownOpen | Occurs when the DropDown is opened. (Inherited from vComboBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemMouseDown | Occurs when the mouse is clicked over a ListItem. (Inherited from vComboBox.)
Public event | ItemMouseUp | Occurs when the mouse is clicked over a ListItem. (Inherited from vComboBox.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the selected index has changed (Inherited from vComboBox.)
Public event | SelectedItemChanged | occurs when the selection is changed. (Inherited from vComboBox.)
Public event | SelectedItemChanging | Occurs when the selection is changing. (Inherited from vComboBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue has changed. (Inherited from vComboBox.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vFontComboBox Class


vForm Class

[image]

VIBlend Controls for WinForms Help Documentation
vForm Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vForm : Form, IScrollableControlBase
Visual Basic
Public Class vForm _
    Inherits Form _
    Implements IScrollableControlBase
Visual C++
public ref class vForm : public Form,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
VIBlend.WinForms.Controls..::..vForm
VIBlend.WinForms.Controls..::..RibbonForm

See Also

vForm Members


vForm Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm Members
vForm Class Constructors Methods Fields Properties Events See Also Send Feedback

The vForm type exposes the following members.

Constructors

 | Name | Description
Public method | vForm | Initializes a new instance of the vForm class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | (Inherited from Form.)
 | AdjustWindowRectEx |
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
 | CallDwmBase |
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawText |
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
 | DwmDefWindowProc |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
 | FindWindow |
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
 | GetActiveWindow |
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetFocusControl |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPointFromPtr |
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetWindowRect(IntPtr, vForm..::..RECT%) |
 | GetWindowRect(HandleRef, RECT%) |
Public method | HandleMaximize | Handles the maximize.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Protected method | InvalidateFrame |
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NCHitTest |
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Overrides Form..::..OnActivated(EventArgs).)
Protected method | OnActivating |
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Overrides Form..::..OnDeactivate(EventArgs).)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the [E:Layout] event. (Overrides Form..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Overrides Control..::..OnLostFocus(EventArgs).)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Overrides Control..::..OnMouseDoubleClick(MouseEventArgs).)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | (Overrides Control..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Overrides Form..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | (Overrides Form..::..OnResizeBegin(EventArgs).)
Protected method | OnResizeEnd | (Overrides Form..::..OnResizeEnd(EventArgs).)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetPadding | Sets the padding.
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show()()()() | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Public method | WMNCHitTest |
Protected method | WndProc | (Overrides Form..::..WndProc(Message%).)

Fields

 | Name | Description
Protected field | boundsHelper |
Protected field | closeButton |
Protected field | helper |
Protected field | maximizeButton |
Protected field | minimizeButton |
Protected field | titleFill |

Properties

 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowMaximize | Gets or sets a value indicating whether form is maximized on double click
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderWidth | Gets or sets the width of the border.
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsHelper |
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CloseBox | Gets or sets a value indicating whether to show the close box.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle |
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsActiveWindow | Gets a value indicating whether this instance is active window.
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form.
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form.
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | RoundRadius | Gets or sets the round radius.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ShadowColor | Gets or sets the color of the shadow.
Public property | ShadowWidth | Gets or sets the width of the shadow.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | TextAlignment | Gets or sets the text alignment.
Public property | Theme | Gets or sets the theme of the control.
Public property | TitleHeight | Gets or sets the height of the title.
Public property | TitleOpacity | Gets or sets the title opacity.
Public property | TitleRectangle | Gets the title rectangle.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets the form's window state. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | Activating | Occurs when form is activating.
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vForm Class


vForm Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vForm Constructor
vForm Class See Also Send Feedback
Initializes a new instance of the vForm class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vForm()
Visual Basic
Public Sub New
Visual C++
public:
vForm()

See Also

vForm Class


vForm Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm Fields
vForm Class See Also Send Feedback

The vForm type exposes the following members.

Fields

 | Name | Description
Protected field | boundsHelper |
Protected field | closeButton |
Protected field | helper |
Protected field | maximizeButton |
Protected field | minimizeButton |
Protected field | titleFill |

See Also

vForm Class


boundsHelper Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..boundsHelper Field
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected vControlBoundsHelper boundsHelper
Visual Basic
Protected boundsHelper As vControlBoundsHelper
Visual C++
protected:
vControlBoundsHelper^ boundsHelper

See Also

vForm Class


closeButton Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..closeButton Field
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal vFormButton closeButton
Visual Basic
Protected Friend closeButton As vFormButton
Visual C++
protected public:
vFormButton^ closeButton

See Also

vForm Class


helper Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..helper Field
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected PaintHelper helper
Visual Basic
Protected helper As PaintHelper
Visual C++
protected:
PaintHelper^ helper

See Also

vForm Class


maximizeButton Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..maximizeButton Field
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal vFormButton maximizeButton
Visual Basic
Protected Friend maximizeButton As vFormButton
Visual C++
protected public:
vFormButton^ maximizeButton

See Also

vForm Class


minimizeButton Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..minimizeButton Field
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal vFormButton minimizeButton
Visual Basic
Protected Friend minimizeButton As vFormButton
Visual C++
protected public:
vFormButton^ minimizeButton

See Also

vForm Class


titleFill Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..titleFill Field
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected BackgroundElement titleFill
Visual Basic
Protected titleFill As BackgroundElement
Visual C++
protected:
BackgroundElement^ titleFill

See Also

vForm Class


vForm Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm Methods
vForm Class See Also Send Feedback

The vForm type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | (Inherited from Form.)
 | AdjustWindowRectEx |
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
 | CallDwmBase |
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawText |
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
 | DwmDefWindowProc |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
 | FindWindow |
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
 | GetActiveWindow |
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetFocusControl |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPointFromPtr |
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetWindowRect(IntPtr, vForm..::..RECT%) |
 | GetWindowRect(HandleRef, RECT%) |
Public method | HandleMaximize | Handles the maximize.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Protected method | InvalidateFrame |
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NCHitTest |
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Overrides Form..::..OnActivated(EventArgs).)
Protected method | OnActivating |
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Overrides Form..::..OnDeactivate(EventArgs).)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the [E:Layout] event. (Overrides Form..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Overrides Control..::..OnLostFocus(EventArgs).)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Overrides Control..::..OnMouseDoubleClick(MouseEventArgs).)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | (Overrides Control..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Overrides Form..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | (Overrides Form..::..OnResizeBegin(EventArgs).)
Protected method | OnResizeEnd | (Overrides Form..::..OnResizeEnd(EventArgs).)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetPadding | Sets the padding.
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show()()()() | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Public method | WMNCHitTest |
Protected method | WndProc | (Overrides Form..::..WndProc(Message%).)

See Also

vForm Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..AccessibilityNotifyClients Method
vForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vForm Class
vForm Members


AdjustWindowRectEx Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..AdjustWindowRectEx Method
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static bool AdjustWindowRectEx(
    ref RECT lpRect,
    int dwStyle,
    bool bMenu,
    int dwExStyle
)
Visual Basic
Public Shared Function AdjustWindowRectEx ( _
    ByRef lpRect As RECT, _
    dwStyle As Integer, _
    bMenu As Boolean, _
    dwExStyle As Integer _
) As Boolean
Visual C++
public:
static bool AdjustWindowRectEx(
    RECT% lpRect,
    int dwStyle,
    bool bMenu,
    int dwExStyle
)

Parameters

lpRect
Type: RECT%
dwStyle
Type: System..::..Int32
bMenu
Type: System..::..Boolean
dwExStyle
Type: System..::..Int32

See Also

vForm Class


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..BeginInvoke Method
vForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vForm Class
vForm Members


CallDwmBase Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..CallDwmBase Method
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static void CallDwmBase(
    ref Message m
)
Visual Basic
Public Shared Sub CallDwmBase ( _
    ByRef m As Message _
)
Visual C++
public:
static void CallDwmBase(
    Message% m
)

Parameters

m
Type: System.Windows.Forms..::..Message %

See Also

vForm Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Dispose Method
vForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)

See Also

vForm Class
vForm Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Dispose Method (Boolean)
vForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

vForm Class
Dispose Overload


DrawText Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..DrawText Method
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DrawText(
    PaintEventArgs e,
    int shadowOffset,
    int borderOffset
)
Visual Basic
Protected Overridable Sub DrawText ( _
    e As PaintEventArgs, _
    shadowOffset As Integer, _
    borderOffset As Integer _
)
Visual C++
protected:
virtual void DrawText(
    PaintEventArgs^ e,
    int shadowOffset,
    int borderOffset
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
shadowOffset
Type: System..::..Int32
borderOffset
Type: System..::..Int32

See Also

vForm Class


DwmDefWindowProc Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..DwmDefWindowProc Method
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int DwmDefWindowProc(
    IntPtr hWnd,
    int msg,
    IntPtr wParam,
    IntPtr lParam,
    out IntPtr result
)
Visual Basic
Public Shared Function DwmDefWindowProc ( _
    hWnd As IntPtr, _
    msg As Integer, _
    wParam As IntPtr, _
    lParam As IntPtr, _
    <OutAttribute> ByRef result As IntPtr _
) As Integer
Visual C++
public:
static int DwmDefWindowProc(
    IntPtr hWnd,
    int msg,
    IntPtr wParam,
    IntPtr lParam,
    [OutAttribute] IntPtr% result
)

Parameters

hWnd
Type: System..::..IntPtr
msg
Type: System..::..Int32
wParam
Type: System..::..IntPtr
lParam
Type: System..::..IntPtr
result
Type: System..::..IntPtr %

See Also

vForm Class


FindWindow Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..FindWindow Method
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static IntPtr FindWindow(
    string className,
    string windowName
)
Visual Basic
Public Shared Function FindWindow ( _
    className As String, _
    windowName As String _
) As IntPtr
Visual C++
public:
static IntPtr FindWindow(
    String^ className,
    String^ windowName
)

Parameters

className
Type: System..::..String
windowName
Type: System..::..String

See Also

vForm Class


GetActiveWindow Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..GetActiveWindow Method
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static IntPtr GetActiveWindow()
Visual Basic
Public Shared Function GetActiveWindow As IntPtr
Visual C++
public:
static IntPtr GetActiveWindow()

See Also

vForm Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..GetChildAtPoint Method
vForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vForm Class
vForm Members


GetFocusControl Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..GetFocusControl Method
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected Control GetFocusControl()
Visual Basic
Protected Function GetFocusControl As Control
Visual C++
protected:
Control^ GetFocusControl()

See Also

vForm Class


GetPointFromPtr Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..GetPointFromPtr Method
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Point GetPointFromPtr(
    IntPtr ptr
)
Visual Basic
Public Function GetPointFromPtr ( _
    ptr As IntPtr _
) As Point
Visual C++
public:
Point GetPointFromPtr(
    IntPtr ptr
)

Parameters

ptr
Type: System..::..IntPtr

See Also

vForm Class


GetWindowRect Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..GetWindowRect Method
vForm Class See Also Send Feedback

Overload List

Name | Description
GetWindowRect(IntPtr, vForm..::..RECT%) |
GetWindowRect(HandleRef, RECT%) |

See Also

vForm Class
vForm Members


GetWindowRect Method (IntPtr, vForm.RECT)

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..GetWindowRect Method (IntPtr, vForm..::..RECT%)
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static bool GetWindowRect(
    IntPtr hWnd,
    ref vForm..::..RECT lpRect
)
Visual Basic
Public Shared Function GetWindowRect ( _
    hWnd As IntPtr, _
    ByRef lpRect As vForm..::..RECT _
) As Boolean
Visual C++
public:
static bool GetWindowRect(
    IntPtr hWnd,
    vForm..::..RECT% lpRect
)

Parameters

hWnd
Type: System..::..IntPtr
lpRect
Type: VIBlend.WinForms.Controls..::..vForm..::..RECT %

See Also

vForm Class
GetWindowRect Overload


GetWindowRect Method (HandleRef, .)

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..GetWindowRect Method (HandleRef, ..::..%)
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static bool GetWindowRect(
    HandleRef hWnd,
    out RECT rect
)
Visual Basic
Public Shared Function GetWindowRect ( _
    hWnd As HandleRef, _
    <OutAttribute> ByRef rect As RECT _
) As Boolean
Visual C++
public:
static bool GetWindowRect(
    HandleRef hWnd,
    [InAttribute] [OutAttribute] RECT% rect
)

Parameters

hWnd
Type: System.Runtime.InteropServices..::..HandleRef
rect
Type: RECT%

See Also

vForm Class
GetWindowRect Overload


HandleMaximize Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..HandleMaximize Method
vForm Class See Also Send Feedback
Handles the maximize.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void HandleMaximize()
Visual Basic
Public Sub HandleMaximize
Visual C++
public:
void HandleMaximize()

See Also

vForm Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Invalidate Method
vForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vForm Class
vForm Members


InvalidateFrame Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..InvalidateFrame Method
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void InvalidateFrame()
Visual Basic
Protected Overridable Sub InvalidateFrame
Visual C++
protected:
virtual void InvalidateFrame()

See Also

vForm Class


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Invoke Method
vForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vForm Class
vForm Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MemberwiseClone Method
vForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vForm Class
vForm Members


NCHitTest Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..NCHitTest Method
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void NCHitTest(
    ref Message msg
)
Visual Basic
Protected Overridable Sub NCHitTest ( _
    ByRef msg As Message _
)
Visual C++
protected:
virtual void NCHitTest(
    Message% msg
)

Parameters

msg
Type: System.Windows.Forms..::..Message %

See Also

vForm Class


OnActivated Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..OnActivated Method
vForm Class See Also Send Feedback
Raises the Activated event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnActivated(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnActivated ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnActivated(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vForm Class


OnActivating Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..OnActivating Method
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnActivating(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnActivating ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnActivating(
    EventArgs^ e
)

Parameters

e
Type: System..::..EventArgs

See Also

vForm Class


OnDeactivate Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..OnDeactivate Method
vForm Class See Also Send Feedback
Raises the Deactivate event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnDeactivate(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnDeactivate ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnDeactivate(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
The EventArgs that contains the event data.

See Also

vForm Class


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..OnLayout Method
vForm Class See Also Send Feedback
Raises the [E:Layout] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
The LayoutEventArgs instance containing the event data.

See Also

vForm Class


OnLostFocus Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..OnLostFocus Method
vForm Class See Also Send Feedback
Raises the LostFocus event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLostFocus(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnLostFocus ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLostFocus(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vForm Class


OnMouseDoubleClick Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..OnMouseDoubleClick Method
vForm Class See Also Send Feedback
Raises the MouseDoubleClick event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDoubleClick(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDoubleClick ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDoubleClick(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
An MouseEventArgs that contains the event data.

See Also

vForm Class


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..OnMouseDown Method
vForm Class See Also Send Feedback
Raises the MouseDown event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vForm Class


OnMouseEnter Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..OnMouseEnter Method
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseEnter(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseEnter ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseEnter(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vForm Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..OnMouseMove Method
vForm Class See Also Send Feedback
Raises the MouseMove event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vForm Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..OnPaint Method
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vForm Class


OnResizeBegin Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..OnResizeBegin Method
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnResizeBegin(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnResizeBegin ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnResizeBegin(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vForm Class


OnResizeEnd Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..OnResizeEnd Method
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnResizeEnd(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnResizeEnd ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnResizeEnd(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vForm Class


OnSizeChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..OnSizeChanged Method
vForm Class See Also Send Feedback
Raises the SizeChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnSizeChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnSizeChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSizeChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vForm Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..PerformLayout Method
vForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vForm Class
vForm Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..ResumeLayout Method
vForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vForm Class
vForm Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..RtlTranslateAlignment Method
vForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vForm Class
vForm Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Scale Method
vForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vForm Class
vForm Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Select Method
vForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

vForm Class
vForm Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..SetBounds Method
vForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vForm Class
vForm Members


SetPadding Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..SetPadding Method
vForm Class See Also Send Feedback
Sets the padding.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void SetPadding()
Visual Basic
Protected Overridable Sub SetPadding
Visual C++
protected:
virtual void SetPadding()

See Also

vForm Class


Show Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Show Method
vForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Show()()()() | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

vForm Class
vForm Members


ShowDialog Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..ShowDialog Method
vForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

vForm Class
vForm Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..UpdateBounds Method
vForm Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vForm Class
vForm Members


Validate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Validate Method
vForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

vForm Class
vForm Members


ValidateChildren Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..ValidateChildren Method
vForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

vForm Class
vForm Members


WMNCHitTest Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..WMNCHitTest Method
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int WMNCHitTest(
    Point p,
    int hitTest
)
Visual Basic
Public Function WMNCHitTest ( _
    p As Point, _
    hitTest As Integer _
) As Integer
Visual C++
public:
int WMNCHitTest(
    Point p,
    int hitTest
)

Parameters

p
Type: System.Drawing..::..Point
hitTest
Type: System..::..Int32

See Also

vForm Class


WndProc Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..WndProc Method
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void WndProc(
    ref Message m
)
Visual Basic
Protected Overrides Sub WndProc ( _
    ByRef m As Message _
)
Visual C++
protected:
virtual void WndProc(
    Message% m
) override

Parameters

m
Type: System.Windows.Forms..::..Message %

See Also

vForm Class


vForm Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm Properties
vForm Class See Also Send Feedback

The vForm type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowMaximize | Gets or sets a value indicating whether form is maximized on double click
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderWidth | Gets or sets the width of the border.
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsHelper |
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CloseBox | Gets or sets a value indicating whether to show the close box.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle |
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsActiveWindow | Gets a value indicating whether this instance is active window.
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form.
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form.
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | RoundRadius | Gets or sets the round radius.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ShadowColor | Gets or sets the color of the shadow.
Public property | ShadowWidth | Gets or sets the width of the shadow.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | TextAlignment | Gets or sets the text alignment.
Public property | Theme | Gets or sets the theme of the control.
Public property | TitleHeight | Gets or sets the height of the title.
Public property | TitleOpacity | Gets or sets the title opacity.
Public property | TitleRectangle | Gets the title rectangle.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets the form's window state. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vForm Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..AllowAnimations Property
vForm Class See Also Send Feedback
Gets or sets whether the control is animated

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vForm Class


AllowMaximize Property

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..AllowMaximize Property
vForm Class See Also Send Feedback
Gets or sets a value indicating whether form is maximized on double click

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowMaximize { get; set; }
Visual Basic
Public Property AllowMaximize As Boolean
    Get
    Set
Visual C++
public:
property bool AllowMaximize {
    bool get ();
    void set (bool value);
}

See Also

vForm Class


BorderWidth Property

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..BorderWidth Property
vForm Class See Also Send Feedback
Gets or sets the width of the border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int BorderWidth { get; set; }
Visual Basic
Public Property BorderWidth As Integer
    Get
    Set
Visual C++
public:
property int BorderWidth {
    int get ();
    void set (int value);
}

Field Value

The width of the border.

See Also

vForm Class


BoundsHelper Property

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..BoundsHelper Property
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vControlBoundsHelper BoundsHelper { get; }
Visual Basic
Public ReadOnly Property BoundsHelper As vControlBoundsHelper
    Get
Visual C++
public:
property vControlBoundsHelper^ BoundsHelper {
    vControlBoundsHelper^ get ();
}

See Also

vForm Class


CloseBox Property

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..CloseBox Property
vForm Class See Also Send Feedback
Gets or sets a value indicating whether to show the close box.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool CloseBox { get; set; }
Visual Basic
Public Property CloseBox As Boolean
    Get
    Set
Visual C++
public:
property bool CloseBox {
    bool get ();
    void set (bool value);
}

See Also

vForm Class


FormBorderStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..FormBorderStyle Property
vForm Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public FormBorderStyle FormBorderStyle { get; set; }
Visual Basic
Public Property FormBorderStyle As FormBorderStyle
    Get
    Set
Visual C++
public:
property FormBorderStyle FormBorderStyle {
    FormBorderStyle get ();
    void set (FormBorderStyle value);
}

See Also

vForm Class


IsActiveWindow Property

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..IsActiveWindow Property
vForm Class See Also Send Feedback
Gets a value indicating whether this instance is active window.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsActiveWindow { get; }
Visual Basic
Public ReadOnly Property IsActiveWindow As Boolean
    Get
Visual C++
public:
property bool IsActiveWindow {
    bool get ();
}

Field Value

true if this instance is active window; otherwise, false.

See Also

vForm Class


MaximizeBox Property

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MaximizeBox Property
vForm Class See Also Send Feedback
Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool MaximizeBox { get; set; }
Visual Basic
Public Property MaximizeBox As Boolean
    Get
    Set
Visual C++
public:
property bool MaximizeBox {
    bool get ();
    void set (bool value);
}

Field Value

Return Value

true to display a Maximize button for the form; otherwise, false. The default is true.

See Also

vForm Class


MinimizeBox Property

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MinimizeBox Property
vForm Class See Also Send Feedback
Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool MinimizeBox { get; set; }
Visual Basic
Public Property MinimizeBox As Boolean
    Get
    Set
Visual C++
public:
property bool MinimizeBox {
    bool get ();
    void set (bool value);
}

Field Value

Return Value

true to display a Minimize button for the form; otherwise, false. The default is true.

See Also

vForm Class


RoundRadius Property

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..RoundRadius Property
vForm Class See Also Send Feedback
Gets or sets the round radius.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int RoundRadius { get; set; }
Visual Basic
Public Property RoundRadius As Integer
    Get
    Set
Visual C++
public:
property int RoundRadius {
    int get ();
    void set (int value);
}

Field Value

The round radius.

See Also

vForm Class


ShadowColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..ShadowColor Property
vForm Class See Also Send Feedback
Gets or sets the color of the shadow.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color ShadowColor { get; set; }
Visual Basic
Public Property ShadowColor As Color
    Get
    Set
Visual C++
public:
property Color ShadowColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the shadow.

See Also

vForm Class


ShadowWidth Property

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..ShadowWidth Property
vForm Class See Also Send Feedback
Gets or sets the width of the shadow.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ShadowWidth { get; set; }
Visual Basic
Public Property ShadowWidth As Integer
    Get
    Set
Visual C++
public:
property int ShadowWidth {
    int get ();
    void set (int value);
}

Field Value

The width of the shadow.

See Also

vForm Class


TextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..TextAlignment Property
vForm Class See Also Send Feedback
Gets or sets the text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment TextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The text alignment.

See Also

vForm Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Theme Property
vForm Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ControlTheme Theme { get; set; }
Visual Basic
Public Overridable Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
virtual property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vForm Class


TitleHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..TitleHeight Property
vForm Class See Also Send Feedback
Gets or sets the height of the title.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int TitleHeight { get; set; }
Visual Basic
Public Property TitleHeight As Integer
    Get
    Set
Visual C++
public:
property int TitleHeight {
    int get ();
    void set (int value);
}

Field Value

The height of the title.

See Also

vForm Class


TitleOpacity Property

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..TitleOpacity Property
vForm Class See Also Send Feedback
Gets or sets the title opacity.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual float TitleOpacity { get; set; }
Visual Basic
Public Overridable Property TitleOpacity As Single
    Get
    Set
Visual C++
public:
virtual property float TitleOpacity {
    float get ();
    void set (float value);
}

Field Value

The title opacity.

See Also

vForm Class


TitleRectangle Property

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..TitleRectangle Property
vForm Class See Also Send Feedback
Gets the title rectangle.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle TitleRectangle { get; }
Visual Basic
Public ReadOnly Property TitleRectangle As Rectangle
    Get
Visual C++
public:
property Rectangle TitleRectangle {
    Rectangle get ();
}

Field Value

The title rectangle.

See Also

vForm Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..VIBlendTheme Property
vForm Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vForm Class


vForm Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm Events
vForm Class See Also Send Feedback

The vForm type exposes the following members.

Events

 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | Activating | Occurs when form is activating.
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vForm Class


Activating Event

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Activating Event
vForm Class See Also Send Feedback
Occurs when form is activating.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler Activating
Visual Basic
Public Event Activating As EventHandler
Visual C++
public:
 event EventHandler^ Activating {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vForm Class


vForm.MARGINS Structure

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MARGINS Structure
vForm Class Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public struct MARGINS
Visual Basic
Public Structure MARGINS
Visual C++
public value class MARGINS

See Also

vForm..::..MARGINS Members


vForm.MARGINS Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MARGINS Members
vForm..::..MARGINS Structure Methods Fields See Also Send Feedback

The vForm..::..MARGINS type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | cxLeftWidth |
Public field | cxRightWidth |
Public field | cyBottomHeight |
Public field | cyTopHeight |

See Also

vForm..::..MARGINS Structure


vForm.MARGINS Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MARGINS Fields
vForm..::..MARGINS Structure See Also Send Feedback

The vForm..::..MARGINS type exposes the following members.

Fields

 | Name | Description
Public field | cxLeftWidth |
Public field | cxRightWidth |
Public field | cyBottomHeight |
Public field | cyTopHeight |

See Also

vForm..::..MARGINS Structure


cxLeftWidth Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MARGINS..::..cxLeftWidth Field
vForm..::..MARGINS Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int cxLeftWidth
Visual Basic
Public cxLeftWidth As Integer
Visual C++
public:
int cxLeftWidth

See Also

vForm..::..MARGINS Structure


cxRightWidth Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MARGINS..::..cxRightWidth Field
vForm..::..MARGINS Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int cxRightWidth
Visual Basic
Public cxRightWidth As Integer
Visual C++
public:
int cxRightWidth

See Also

vForm..::..MARGINS Structure


cyBottomHeight Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MARGINS..::..cyBottomHeight Field
vForm..::..MARGINS Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int cyBottomHeight
Visual Basic
Public cyBottomHeight As Integer
Visual C++
public:
int cyBottomHeight

See Also

vForm..::..MARGINS Structure


cyTopHeight Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MARGINS..::..cyTopHeight Field
vForm..::..MARGINS Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int cyTopHeight
Visual Basic
Public cyTopHeight As Integer
Visual C++
public:
int cyTopHeight

See Also

vForm..::..MARGINS Structure


vForm.MARGINS Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MARGINS Methods
vForm..::..MARGINS Structure See Also Send Feedback

The vForm..::..MARGINS type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

vForm..::..MARGINS Structure


vForm.MINMAXINFO Class

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MINMAXINFO Class
vForm Class Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class MINMAXINFO
Visual Basic
Public Class MINMAXINFO
Visual C++
public ref class MINMAXINFO

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..vForm..::..MINMAXINFO

See Also

vForm..::..MINMAXINFO Members


vForm.MINMAXINFO Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MINMAXINFO Members
vForm..::..MINMAXINFO Class Constructors Methods Fields See Also Send Feedback

The vForm..::..MINMAXINFO type exposes the following members.

Constructors

 | Name | Description
Public method | vForm..::..MINMAXINFO | Initializes a new instance of the vForm..::..MINMAXINFO class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ptMaxPosition |
Public field | ptMaxSize |
Public field | ptMaxTrackSize |
Public field | ptMinTrackSize |
Public field | ptReserved |

See Also

vForm..::..MINMAXINFO Class


vForm.MINMAXINFO Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MINMAXINFO Constructor
vForm..::..MINMAXINFO Class See Also Send Feedback
Initializes a new instance of the vForm..::..MINMAXINFO class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public MINMAXINFO()
Visual Basic
Public Sub New
Visual C++
public:
MINMAXINFO()

See Also

vForm..::..MINMAXINFO Class


vForm.MINMAXINFO Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MINMAXINFO Fields
vForm..::..MINMAXINFO Class See Also Send Feedback

The vForm..::..MINMAXINFO type exposes the following members.

Fields

 | Name | Description
Public field | ptMaxPosition |
Public field | ptMaxSize |
Public field | ptMaxTrackSize |
Public field | ptMinTrackSize |
Public field | ptReserved |

See Also

vForm..::..MINMAXINFO Class


ptMaxPosition Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MINMAXINFO..::..ptMaxPosition Field
vForm..::..MINMAXINFO Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vForm..::..POINT ptMaxPosition
Visual Basic
Public ptMaxPosition As vForm..::..POINT
Visual C++
public:
vForm..::..POINT^ ptMaxPosition

See Also

vForm..::..MINMAXINFO Class


ptMaxSize Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MINMAXINFO..::..ptMaxSize Field
vForm..::..MINMAXINFO Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vForm..::..POINT ptMaxSize
Visual Basic
Public ptMaxSize As vForm..::..POINT
Visual C++
public:
vForm..::..POINT^ ptMaxSize

See Also

vForm..::..MINMAXINFO Class


ptMaxTrackSize Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MINMAXINFO..::..ptMaxTrackSize Field
vForm..::..MINMAXINFO Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vForm..::..POINT ptMaxTrackSize
Visual Basic
Public ptMaxTrackSize As vForm..::..POINT
Visual C++
public:
vForm..::..POINT^ ptMaxTrackSize

See Also

vForm..::..MINMAXINFO Class


ptMinTrackSize Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MINMAXINFO..::..ptMinTrackSize Field
vForm..::..MINMAXINFO Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vForm..::..POINT ptMinTrackSize
Visual Basic
Public ptMinTrackSize As vForm..::..POINT
Visual C++
public:
vForm..::..POINT^ ptMinTrackSize

See Also

vForm..::..MINMAXINFO Class


ptReserved Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MINMAXINFO..::..ptReserved Field
vForm..::..MINMAXINFO Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vForm..::..POINT ptReserved
Visual Basic
Public ptReserved As vForm..::..POINT
Visual C++
public:
vForm..::..POINT^ ptReserved

See Also

vForm..::..MINMAXINFO Class


vForm.MINMAXINFO Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..MINMAXINFO Methods
vForm..::..MINMAXINFO Class See Also Send Feedback

The vForm..::..MINMAXINFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vForm..::..MINMAXINFO Class


vForm.NCCALCSIZE_PARAMS Structure

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..NCCALCSIZE_PARAMS Structure
vForm Class Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public struct NCCALCSIZE_PARAMS
Visual Basic
Public Structure NCCALCSIZE_PARAMS
Visual C++
public value class NCCALCSIZE_PARAMS

See Also

vForm..::..NCCALCSIZE_PARAMS Members


vForm.NCCALCSIZE_PARAMS Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..NCCALCSIZE_PARAMS Members
vForm..::..NCCALCSIZE_PARAMS Structure Methods Fields See Also Send Feedback

The vForm..::..NCCALCSIZE_PARAMS type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | lppos |
Public field | rgrc |

See Also

vForm..::..NCCALCSIZE_PARAMS Structure


vForm.NCCALCSIZE_PARAMS Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..NCCALCSIZE_PARAMS Fields
vForm..::..NCCALCSIZE_PARAMS Structure See Also Send Feedback

The vForm..::..NCCALCSIZE_PARAMS type exposes the following members.

Fields

 | Name | Description
Public field | lppos |
Public field | rgrc |

See Also

vForm..::..NCCALCSIZE_PARAMS Structure


lppos Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..NCCALCSIZE_PARAMS..::..lppos Field
vForm..::..NCCALCSIZE_PARAMS Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public IntPtr lppos
Visual Basic
Public lppos As IntPtr
Visual C++
public:
IntPtr lppos

See Also

vForm..::..NCCALCSIZE_PARAMS Structure


rgrc Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..NCCALCSIZE_PARAMS..::..rgrc Field
vForm..::..NCCALCSIZE_PARAMS Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RECT[] rgrc
Visual Basic
Public rgrc As RECT()
Visual C++
public:
array<RECT>^ rgrc

See Also

vForm..::..NCCALCSIZE_PARAMS Structure


vForm.NCCALCSIZE_PARAMS Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..NCCALCSIZE_PARAMS Methods
vForm..::..NCCALCSIZE_PARAMS Structure See Also Send Feedback

The vForm..::..NCCALCSIZE_PARAMS type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

vForm..::..NCCALCSIZE_PARAMS Structure


vForm.POINT Class

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..POINT Class
vForm Class Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class POINT
Visual Basic
Public Class POINT
Visual C++
public ref class POINT

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..vForm..::..POINT

See Also

vForm..::..POINT Members


vForm.POINT Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..POINT Members
vForm..::..POINT Class Constructors Methods Fields See Also Send Feedback

The vForm..::..POINT type exposes the following members.

Constructors

 | Name | Description
Public method | vForm..::..POINT()()()() |
Public method | vForm..::..POINT(Int32, Int32) |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | x |
Public field | y |

See Also

vForm..::..POINT Class


vForm.POINT Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..POINT Constructor
vForm..::..POINT Class See Also Send Feedback

Overload List

 | Name | Description
Public method | vForm..::..POINT()()()() | Initializes a new instance of the vForm..::..POINT class
Public method | vForm..::..POINT(Int32, Int32) | Initializes a new instance of the vForm..::..POINT class

See Also

vForm..::..POINT Class
vForm..::..POINT Members


vForm.POINT Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..POINT Constructor
vForm..::..POINT Class See Also Send Feedback
Initializes a new instance of the vForm..::..POINT class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public POINT()
Visual Basic
Public Sub New
Visual C++
public:
POINT()

See Also

vForm..::..POINT Class
vForm..::..POINT Overload


vForm.POINT Constructor (Int32, Int32)

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..POINT Constructor (Int32, Int32)
vForm..::..POINT Class See Also Send Feedback
Initializes a new instance of the vForm..::..POINT class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public POINT(
    int x,
    int y
)
Visual Basic
Public Sub New ( _
    x As Integer, _
    y As Integer _
)
Visual C++
public:
POINT(
    int x,
    int y
)

Parameters

x
Type: System..::..Int32
y
Type: System..::..Int32

See Also

vForm..::..POINT Class
vForm..::..POINT Overload


vForm.POINT Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..POINT Fields
vForm..::..POINT Class See Also Send Feedback

The vForm..::..POINT type exposes the following members.

Fields

 | Name | Description
Public field | x |
Public field | y |

See Also

vForm..::..POINT Class


x Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..POINT..::..x Field
vForm..::..POINT Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int x
Visual Basic
Public x As Integer
Visual C++
public:
int x

See Also

vForm..::..POINT Class


y Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..POINT..::..y Field
vForm..::..POINT Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int y
Visual Basic
Public y As Integer
Visual C++
public:
int y

See Also

vForm..::..POINT Class


vForm.POINT Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..POINT Methods
vForm..::..POINT Class See Also Send Feedback

The vForm..::..POINT type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vForm..::..POINT Class


vForm.RECT Structure

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..RECT Structure
vForm Class Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public struct RECT
Visual Basic
Public Structure RECT
Visual C++
public value class RECT

See Also

vForm..::..RECT Members


vForm.RECT Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..RECT Members
vForm..::..RECT Structure Constructors Methods Fields See Also Send Feedback

The vForm..::..RECT type exposes the following members.

Constructors

 | Name | Description
Public method | vForm..::..RECT(Rectangle) |
Public method | vForm..::..RECT(Int32, Int32, Int32, Int32) |

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToRectangle |
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | Bottom |
Public field | Left |
Public field | Right |
Public field | Top |

See Also

vForm..::..RECT Structure


vForm.RECT Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..RECT Constructor
vForm..::..RECT Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | vForm..::..RECT(Rectangle) | Initializes a new instance of the vForm..::..RECT class
Public method | vForm..::..RECT(Int32, Int32, Int32, Int32) | Initializes a new instance of the vForm..::..RECT class

See Also

vForm..::..RECT Structure
vForm..::..RECT Members


vForm.RECT Constructor (Rectangle)

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..RECT Constructor (Rectangle)
vForm..::..RECT Structure See Also Send Feedback
Initializes a new instance of the vForm..::..RECT class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RECT(
    Rectangle r
)
Visual Basic
Public Sub New ( _
    r As Rectangle _
)
Visual C++
public:
RECT(
    Rectangle r
)

Parameters

r
Type: System.Drawing..::..Rectangle

See Also

vForm..::..RECT Structure
vForm..::..RECT Overload


vForm.RECT Constructor (Int32, Int32, Int32, Int32)

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..RECT Constructor (Int32, Int32, Int32, Int32)
vForm..::..RECT Structure See Also Send Feedback
Initializes a new instance of the vForm..::..RECT class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RECT(
    int l,
    int t,
    int r,
    int b
)
Visual Basic
Public Sub New ( _
    l As Integer, _
    t As Integer, _
    r As Integer, _
    b As Integer _
)
Visual C++
public:
RECT(
    int l,
    int t,
    int r,
    int b
)

Parameters

l
Type: System..::..Int32
t
Type: System..::..Int32
r
Type: System..::..Int32
b
Type: System..::..Int32

See Also

vForm..::..RECT Structure
vForm..::..RECT Overload


vForm.RECT Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..RECT Fields
vForm..::..RECT Structure See Also Send Feedback

The vForm..::..RECT type exposes the following members.

Fields

 | Name | Description
Public field | Bottom |
Public field | Left |
Public field | Right |
Public field | Top |

See Also

vForm..::..RECT Structure


Bottom Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..RECT..::..Bottom Field
vForm..::..RECT Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Bottom
Visual Basic
Public Bottom As Integer
Visual C++
public:
int Bottom

See Also

vForm..::..RECT Structure


Left Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..RECT..::..Left Field
vForm..::..RECT Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Left
Visual Basic
Public Left As Integer
Visual C++
public:
int Left

See Also

vForm..::..RECT Structure


Right Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..RECT..::..Right Field
vForm..::..RECT Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Right
Visual Basic
Public Right As Integer
Visual C++
public:
int Right

See Also

vForm..::..RECT Structure


Top Field

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..RECT..::..Top Field
vForm..::..RECT Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Top
Visual Basic
Public Top As Integer
Visual C++
public:
int Top

See Also

vForm..::..RECT Structure


vForm.RECT Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..RECT Methods
vForm..::..RECT Structure See Also Send Feedback

The vForm..::..RECT type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToRectangle |
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

vForm..::..RECT Structure


ToRectangle Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..RECT..::..ToRectangle Method
vForm..::..RECT Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle ToRectangle()
Visual Basic
Public Function ToRectangle As Rectangle
Visual C++
public:
Rectangle ToRectangle()

See Also

vForm..::..RECT Structure


vForm.Util Class

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Util Class
vForm Class Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static class Util
Visual Basic
Public NotInheritable Class Util
Visual C++
public ref class Util abstract sealed

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..vForm..::..Util

See Also

vForm..::..Util Members


vForm.Util Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Util Members
vForm..::..Util Class Methods See Also Send Feedback

The vForm..::..Util type exposes the following members.

Methods

Name | Description
GetPInvokeStringLength |
HIWORD(Int32) |
HIWORD(IntPtr) |
LOWORD(Int32) |
LOWORD(IntPtr) |
MAKELONG |
MAKELPARAM |
SignedHIWORD(Int32) |
SignedHIWORD(IntPtr) |
SignedLOWORD(Int32) |
SignedLOWORD(IntPtr) |

See Also

vForm..::..Util Class


vForm.Util Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Util Methods
vForm..::..Util Class See Also Send Feedback

The vForm..::..Util type exposes the following members.

Methods

Name | Description
GetPInvokeStringLength |
HIWORD(Int32) |
HIWORD(IntPtr) |
LOWORD(Int32) |
LOWORD(IntPtr) |
MAKELONG |
MAKELPARAM |
SignedHIWORD(Int32) |
SignedHIWORD(IntPtr) |
SignedLOWORD(Int32) |
SignedLOWORD(IntPtr) |

See Also

vForm..::..Util Class


GetPInvokeStringLength Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Util..::..GetPInvokeStringLength Method
vForm..::..Util Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int GetPInvokeStringLength(
    string s
)
Visual Basic
Public Shared Function GetPInvokeStringLength ( _
    s As String _
) As Integer
Visual C++
public:
static int GetPInvokeStringLength(
    String^ s
)

Parameters

s
Type: System..::..String

See Also

vForm..::..Util Class


HIWORD Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Util..::..HIWORD Method
vForm..::..Util Class See Also Send Feedback

Overload List

Name | Description
HIWORD(Int32) |
HIWORD(IntPtr) |

See Also

vForm..::..Util Class
vForm..::..Util Members


HIWORD Method (Int32)

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Util..::..HIWORD Method (Int32)
vForm..::..Util Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int HIWORD(
    int n
)
Visual Basic
Public Shared Function HIWORD ( _
    n As Integer _
) As Integer
Visual C++
public:
static int HIWORD(
    int n
)

Parameters

n
Type: System..::..Int32

See Also

vForm..::..Util Class
HIWORD Overload


HIWORD Method (IntPtr)

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Util..::..HIWORD Method (IntPtr)
vForm..::..Util Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int HIWORD(
    IntPtr n
)
Visual Basic
Public Shared Function HIWORD ( _
    n As IntPtr _
) As Integer
Visual C++
public:
static int HIWORD(
    IntPtr n
)

Parameters

n
Type: System..::..IntPtr

See Also

vForm..::..Util Class
HIWORD Overload


LOWORD Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Util..::..LOWORD Method
vForm..::..Util Class See Also Send Feedback

Overload List

Name | Description
LOWORD(Int32) |
LOWORD(IntPtr) |

See Also

vForm..::..Util Class
vForm..::..Util Members


LOWORD Method (Int32)

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Util..::..LOWORD Method (Int32)
vForm..::..Util Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int LOWORD(
    int n
)
Visual Basic
Public Shared Function LOWORD ( _
    n As Integer _
) As Integer
Visual C++
public:
static int LOWORD(
    int n
)

Parameters

n
Type: System..::..Int32

See Also

vForm..::..Util Class
LOWORD Overload


LOWORD Method (IntPtr)

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Util..::..LOWORD Method (IntPtr)
vForm..::..Util Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int LOWORD(
    IntPtr n
)
Visual Basic
Public Shared Function LOWORD ( _
    n As IntPtr _
) As Integer
Visual C++
public:
static int LOWORD(
    IntPtr n
)

Parameters

n
Type: System..::..IntPtr

See Also

vForm..::..Util Class
LOWORD Overload


MAKELONG Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Util..::..MAKELONG Method
vForm..::..Util Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int MAKELONG(
    int low,
    int high
)
Visual Basic
Public Shared Function MAKELONG ( _
    low As Integer, _
    high As Integer _
) As Integer
Visual C++
public:
static int MAKELONG(
    int low,
    int high
)

Parameters

low
Type: System..::..Int32
high
Type: System..::..Int32

See Also

vForm..::..Util Class


MAKELPARAM Method

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Util..::..MAKELPARAM Method
vForm..::..Util Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static IntPtr MAKELPARAM(
    int low,
    int high
)
Visual Basic
Public Shared Function MAKELPARAM ( _
    low As Integer, _
    high As Integer _
) As IntPtr
Visual C++
public:
static IntPtr MAKELPARAM(
    int low,
    int high
)

Parameters

low
Type: System..::..Int32
high
Type: System..::..Int32

See Also

vForm..::..Util Class


SignedHIWORD Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Util..::..SignedHIWORD Method
vForm..::..Util Class See Also Send Feedback

Overload List

Name | Description
SignedHIWORD(Int32) |
SignedHIWORD(IntPtr) |

See Also

vForm..::..Util Class
vForm..::..Util Members


SignedHIWORD Method (Int32)

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Util..::..SignedHIWORD Method (Int32)
vForm..::..Util Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int SignedHIWORD(
    int n
)
Visual Basic
Public Shared Function SignedHIWORD ( _
    n As Integer _
) As Integer
Visual C++
public:
static int SignedHIWORD(
    int n
)

Parameters

n
Type: System..::..Int32

See Also

vForm..::..Util Class
SignedHIWORD Overload


SignedHIWORD Method (IntPtr)

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Util..::..SignedHIWORD Method (IntPtr)
vForm..::..Util Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int SignedHIWORD(
    IntPtr n
)
Visual Basic
Public Shared Function SignedHIWORD ( _
    n As IntPtr _
) As Integer
Visual C++
public:
static int SignedHIWORD(
    IntPtr n
)

Parameters

n
Type: System..::..IntPtr

See Also

vForm..::..Util Class
SignedHIWORD Overload


SignedLOWORD Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Util..::..SignedLOWORD Method
vForm..::..Util Class See Also Send Feedback

Overload List

Name | Description
SignedLOWORD(Int32) |
SignedLOWORD(IntPtr) |

See Also

vForm..::..Util Class
vForm..::..Util Members


SignedLOWORD Method (Int32)

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Util..::..SignedLOWORD Method (Int32)
vForm..::..Util Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int SignedLOWORD(
    int n
)
Visual Basic
Public Shared Function SignedLOWORD ( _
    n As Integer _
) As Integer
Visual C++
public:
static int SignedLOWORD(
    int n
)

Parameters

n
Type: System..::..Int32

See Also

vForm..::..Util Class
SignedLOWORD Overload


SignedLOWORD Method (IntPtr)

[image]

VIBlend Controls for WinForms Help Documentation
vForm..::..Util..::..SignedLOWORD Method (IntPtr)
vForm..::..Util Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int SignedLOWORD(
    IntPtr n
)
Visual Basic
Public Shared Function SignedLOWORD ( _
    n As IntPtr _
) As Integer
Visual C++
public:
static int SignedLOWORD(
    IntPtr n
)

Parameters

n
Type: System..::..IntPtr

See Also

vForm..::..Util Class
SignedLOWORD Overload


vFormButton Class

[image]

VIBlend Controls for WinForms Help Documentation
vFormButton Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vFormButton : vButton
Visual Basic
Public Class vFormButton _
    Inherits vButton
Visual C++
public ref class vFormButton : public vButton

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ButtonBase
System.Windows.Forms..::..Button
VIBlend.WinForms.Controls..::..vButton
VIBlend.WinForms.Controls..::..vFormButton

See Also

vFormButton Members


vFormButton Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton Members
vFormButton Class Constructors Methods Fields Properties Events See Also Send Feedback

The vFormButton type exposes the following members.

Constructors

 | Name | Description
Public method | vFormButton | Initializes a new instance of the vFormButton class

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder | (Inherited from vButton.)
Protected method | DrawControl | (Overrides vButton..::..DrawControl(Graphics, Rectangle, ControlState, Boolean, Byte).)
Protected method | DrawFocusRectangle | (Inherited from vButton.)
Protected method | DrawImageAndText | (Inherited from vButton.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect | (Inherited from vButton.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from vButton.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from vButton.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vButton.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Inherited from vButton.)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vButton.)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Inherited from vButton.)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vButton.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vButton.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

Fields

 | Name | Description
Protected field | buttonBorderStyle | (Inherited from vButton.)
Protected field | opacity | (Inherited from vButton.)
Protected field | paintHelper | (Inherited from vButton.)
Protected field | theme | (Inherited from vButton.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vButton.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button (Inherited from vButton.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | ButtonType | Gets or sets the type of the button.
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Inherited from vButton.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled. (Inherited from vButton.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control. (Inherited from vButton.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity. (Inherited from vButton.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vButton.)
Public property | PaintDefaultBorder | Gets or sets a value indicating whether to paint a border when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultFill | Gets or sets a value indicating whether to paint a background when the control state is default. (Inherited from vButton.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vButton.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RibbonStyle | Gets or sets a value indicating whether the button is drawn in ribbon style
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded (Inherited from vButton.)
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control. (Inherited from vButton.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused (Inherited from vButton.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image (Inherited from vButton.)
Public property | StyleKey | Gets or sets the style key. (Inherited from vButton.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control. (Inherited from vButton.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable (Inherited from vButton.)
Public property | Theme | Gets or sets the theme of the control (Inherited from vButton.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control. (Inherited from vButton.)
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control. (Inherited from vButton.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color. (Inherited from vButton.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vButton.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vFormButton Class


vFormButton Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vFormButton Constructor
vFormButton Class See Also Send Feedback
Initializes a new instance of the vFormButton class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vFormButton()
Visual Basic
Public Sub New
Visual C++
public:
vFormButton()

See Also

vFormButton Class


vFormButton Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton Fields
vFormButton Class See Also Send Feedback

The vFormButton type exposes the following members.

Fields

 | Name | Description
Protected field | buttonBorderStyle | (Inherited from vButton.)
Protected field | opacity | (Inherited from vButton.)
Protected field | paintHelper | (Inherited from vButton.)
Protected field | theme | (Inherited from vButton.)

See Also

vFormButton Class


vFormButton Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton Methods
vFormButton Class See Also Send Feedback

The vFormButton type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder | (Inherited from vButton.)
Protected method | DrawControl | (Overrides vButton..::..DrawControl(Graphics, Rectangle, ControlState, Boolean, Byte).)
Protected method | DrawFocusRectangle | (Inherited from vButton.)
Protected method | DrawImageAndText | (Inherited from vButton.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect | (Inherited from vButton.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from vButton.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from vButton.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vButton.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Inherited from vButton.)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vButton.)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Inherited from vButton.)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vButton.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vButton.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

See Also

vFormButton Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton..::..AccessibilityNotifyClients Method
vFormButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vFormButton Class
vFormButton Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton..::..BeginInvoke Method
vFormButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vFormButton Class
vFormButton Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton..::..Dispose Method
vFormButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)

See Also

vFormButton Class
vFormButton Members


DrawControl Method

[image]

VIBlend Controls for WinForms Help Documentation
vFormButton..::..DrawControl Method
vFormButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void DrawControl(
    Graphics graphics,
    Rectangle bounds,
    ControlState controlState,
    bool isFocused,
    byte mask
)
Visual Basic
Protected Overrides Sub DrawControl ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    controlState As ControlState, _
    isFocused As Boolean, _
    mask As Byte _
)
Visual C++
protected:
virtual void DrawControl(
    Graphics^ graphics,
    Rectangle bounds,
    ControlState controlState,
    bool isFocused,
    unsigned char mask
) override

Parameters

graphics
Type: System.Drawing..::..Graphics
bounds
Type: System.Drawing..::..Rectangle
controlState
Type: ControlState
isFocused
Type: System..::..Boolean
mask
Type: System..::..Byte

See Also

vFormButton Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton..::..GetChildAtPoint Method
vFormButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vFormButton Class
vFormButton Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton..::..Invalidate Method
vFormButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vFormButton Class
vFormButton Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton..::..Invoke Method
vFormButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vFormButton Class
vFormButton Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton..::..MemberwiseClone Method
vFormButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vFormButton Class
vFormButton Members


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton..::..PerformLayout Method
vFormButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vFormButton Class
vFormButton Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton..::..ResumeLayout Method
vFormButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vFormButton Class
vFormButton Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton..::..RtlTranslateAlignment Method
vFormButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vFormButton Class
vFormButton Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton..::..Scale Method
vFormButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vFormButton Class
vFormButton Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton..::..Select Method
vFormButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vFormButton Class
vFormButton Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton..::..SetBounds Method
vFormButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vFormButton Class
vFormButton Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton..::..UpdateBounds Method
vFormButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vFormButton Class
vFormButton Members


vFormButton Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton Properties
vFormButton Class See Also Send Feedback

The vFormButton type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vButton.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button (Inherited from vButton.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | ButtonType | Gets or sets the type of the button.
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Inherited from vButton.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled. (Inherited from vButton.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control. (Inherited from vButton.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity. (Inherited from vButton.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vButton.)
Public property | PaintDefaultBorder | Gets or sets a value indicating whether to paint a border when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultFill | Gets or sets a value indicating whether to paint a background when the control state is default. (Inherited from vButton.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vButton.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RibbonStyle | Gets or sets a value indicating whether the button is drawn in ribbon style
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded (Inherited from vButton.)
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control. (Inherited from vButton.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused (Inherited from vButton.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image (Inherited from vButton.)
Public property | StyleKey | Gets or sets the style key. (Inherited from vButton.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control. (Inherited from vButton.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable (Inherited from vButton.)
Public property | Theme | Gets or sets the theme of the control (Inherited from vButton.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control. (Inherited from vButton.)
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control. (Inherited from vButton.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color. (Inherited from vButton.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vButton.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vFormButton Class


ButtonType Property

[image]

VIBlend Controls for WinForms Help Documentation
vFormButton..::..ButtonType Property
vFormButton Class See Also Send Feedback
Gets or sets the type of the button.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vFormButtonType ButtonType { get; set; }
Visual Basic
Public Property ButtonType As vFormButtonType
    Get
    Set
Visual C++
public:
property vFormButtonType ButtonType {
    vFormButtonType get ();
    void set (vFormButtonType value);
}

Field Value

The type of the button.

See Also

vFormButton Class


RibbonStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
vFormButton..::..RibbonStyle Property
vFormButton Class See Also Send Feedback
Gets or sets a value indicating whether the button is drawn in ribbon style

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool RibbonStyle { get; set; }
Visual Basic
Public Property RibbonStyle As Boolean
    Get
    Set
Visual C++
public:
property bool RibbonStyle {
    bool get ();
    void set (bool value);
}

See Also

vFormButton Class


vFormButton Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vFormButton Events
vFormButton Class See Also Send Feedback

The vFormButton type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vFormButton Class


vFormButtonType Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
vFormButtonType Enumeration
See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum vFormButtonType
Visual Basic
Public Enumeration vFormButtonType
Visual C++
public enum class vFormButtonType

Members

Member name | Description
CloseButton |
MinimizeButton |
MaximizeButton |

See Also


vGroupBox Class

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox Class
Members See Also Send Feedback
Represents a vGroupBox control which displays a frame around other controls, and allows the user to expand/collapse the entire group.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vGroupBox : GroupBox, IScrollableControlBase
Visual Basic
Public Class vGroupBox _
    Inherits GroupBox _
    Implements IScrollableControlBase
Visual C++
public ref class vGroupBox : public GroupBox,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..GroupBox
VIBlend.WinForms.Controls..::..vGroupBox

See Also

vGroupBox Members


vGroupBox Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vGroupBox Members
vGroupBox Class Constructors Methods Properties Events See Also Send Feedback

The vGroupBox type exposes the following members.

Constructors

 | Name | Description
Public method | vGroupBox | Initializes a new instance of the vGroupBox class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the GroupBox. (Inherited from GroupBox.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawText | Draws the text.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnCollapsedChanged | Raises the CollapsedChanged event
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event (Overrides Control..::..OnControlAdded(ControlEventArgs).)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | (Inherited from GroupBox.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the OnMouseEnter event (Overrides Control..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the OnMouseMove event (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the [E:Paint] event. (Overrides GroupBox..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from GroupBox.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales the GroupBox by the specified factor and scaling instruction. (Inherited from GroupBox.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from GroupBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from GroupBox.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDrop | Gets or sets a value that indicates whether the control will allow drag-and-drop operations and events to be used. (Inherited from GroupBox.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the GroupBox resizes based on its contents. (Inherited from GroupBox.)
Public property | AutoSizeMode | Gets or sets how the GroupBox behaves when its AutoSize property is enabled. (Inherited from GroupBox.)
Public property | BackColor | Gets or sets the background color for the control. (Overrides Control..::..BackColor.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the BorderColor of the GroupBox.
Public property | BorderRadius | Gets or sets the border radius.
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CollapsedHeight | Gets or sets the Height of the vGroupBox control when the control is in a collapsed state.
Public property | CollapseGroupBox | Gets or sets a value indicating whether group box should be collapsed
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from GroupBox.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the Padding structure that contains the default padding settings for a GroupBox control. (Inherited from GroupBox.)
Protected property | DefaultSize | (Inherited from GroupBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets a rectangle that represents the dimensions of the GroupBox. (Inherited from GroupBox.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableGroupBoxCollapse | Gets or sets a value indicating whether group box is collapsible
Public property | EnableToggleAnimation | Gets or sets a value indicating whether toggle animation is enabled
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatStyle | Gets or sets the flat style appearance of the group box control. (Inherited from GroupBox.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value that indicates whether the user can press the TAB key to give the focus to the GroupBox. (Inherited from GroupBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the header text of the vGroupBox control (Overrides GroupBox..::..Text.)
Public property | Theme | Gets or sets the theme of the control.
Public property | TitleBackColor | Gets or sets the title backcolor
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCompatibleTextRendering | Gets or sets a value that indicates whether the text of the GroupBox is rendered using compatible text rendering (GDI+) or GDI. (Inherited from GroupBox.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the BorderColor
Public property | UseThemeTextColor | Determines whether to use the text color from the Theme or a custom value
Public property | UseTitleBackColor | Determines whether to use the title back color to draw the text's fill
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from GroupBox.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the user clicks the GroupBox control. (Inherited from GroupBox.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | CollapsedChanged | Occurs when group box is expanded/collapsed
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the GroupBox control. (Inherited from GroupBox.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when the user presses a key while the GroupBox control has focus. (Inherited from GroupBox.)
Public event | KeyPress | Occurs when the user presses a key while the GroupBox control has focus. (Inherited from GroupBox.)
Public event | KeyUp | Occurs when the user releases a key while the GroupBox control has focus. (Inherited from GroupBox.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the user clicks the GroupBox control with the mouse. (Inherited from GroupBox.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the GroupBox control with the mouse. (Inherited from GroupBox.)
Public event | MouseDown | Occurs when the user presses a mouse button while the mouse pointer is over the control. (Inherited from GroupBox.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from GroupBox.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from GroupBox.)
Public event | MouseMove | Occurs when the user moves the mouse pointer over the control. (Inherited from GroupBox.)
Public event | MouseUp | Occurs when the user releases a mouse button while the mouse pointer is over the control. (Inherited from GroupBox.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the value of the TabStop property changes. (Inherited from GroupBox.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vGroupBox Class


vGroupBox Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox Constructor
vGroupBox Class See Also Send Feedback
Initializes a new instance of the vGroupBox class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vGroupBox()
Visual Basic
Public Sub New
Visual C++
public:
vGroupBox()

See Also

vGroupBox Class


vGroupBox Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vGroupBox Methods
vGroupBox Class See Also Send Feedback

The vGroupBox type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the GroupBox. (Inherited from GroupBox.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawText | Draws the text.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnCollapsedChanged | Raises the CollapsedChanged event
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event (Overrides Control..::..OnControlAdded(ControlEventArgs).)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | (Inherited from GroupBox.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the OnMouseEnter event (Overrides Control..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the OnMouseMove event (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the [E:Paint] event. (Overrides GroupBox..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from GroupBox.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales the GroupBox by the specified factor and scaling instruction. (Inherited from GroupBox.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from GroupBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from GroupBox.)

See Also

vGroupBox Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..AccessibilityNotifyClients Method
vGroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vGroupBox Class
vGroupBox Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..BeginInvoke Method
vGroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vGroupBox Class
vGroupBox Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..Dispose Method
vGroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)

See Also

vGroupBox Class
vGroupBox Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..Dispose Method (Boolean)
vGroupBox Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vGroupBox Class
Dispose Overload


DrawText Method

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..DrawText Method
vGroupBox Class See Also Send Feedback
Draws the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DrawText(
    Graphics g,
    ref Rectangle rect,
    ref Color disabledColor
)
Visual Basic
Protected Overridable Sub DrawText ( _
    g As Graphics, _
    ByRef rect As Rectangle, _
    ByRef disabledColor As Color _
)
Visual C++
protected:
virtual void DrawText(
    Graphics^ g,
    Rectangle% rect,
    Color% disabledColor
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
rect
Type: System.Drawing..::..Rectangle %
The rect.
disabledColor
Type: System.Drawing..::..Color %
Color of the disabled.

See Also

vGroupBox Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..GetChildAtPoint Method
vGroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vGroupBox Class
vGroupBox Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..Invalidate Method
vGroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vGroupBox Class
vGroupBox Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..Invoke Method
vGroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vGroupBox Class
vGroupBox Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..MemberwiseClone Method
vGroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vGroupBox Class
vGroupBox Members


OnCollapsedChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..OnCollapsedChanged Method
vGroupBox Class See Also Send Feedback
Raises the CollapsedChanged event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCollapsedChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnCollapsedChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnCollapsedChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vGroupBox Class


OnControlAdded Method

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..OnControlAdded Method
vGroupBox Class See Also Send Feedback
Raises the ControlAdded event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnControlAdded(
    ControlEventArgs e
)
Visual Basic
Protected Overrides Sub OnControlAdded ( _
    e As ControlEventArgs _
)
Visual C++
protected:
virtual void OnControlAdded(
    ControlEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..ControlEventArgs
A ControlEventArgs that contains the event data.

See Also

vGroupBox Class


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..OnMouseDown Method
vGroupBox Class See Also Send Feedback
Raises the OnMouseDown event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
An MouseEventArgs that contains the event data.

See Also

vGroupBox Class


OnMouseEnter Method

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..OnMouseEnter Method
vGroupBox Class See Also Send Feedback
Raises the OnMouseEnter event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseEnter(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseEnter ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseEnter(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vGroupBox Class


OnMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..OnMouseLeave Method
vGroupBox Class See Also Send Feedback
Raises the OnMouseLeave event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vGroupBox Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..OnMouseMove Method
vGroupBox Class See Also Send Feedback
Raises the OnMouseMove event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
An MouseEventArgs that contains the event data.

See Also

vGroupBox Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..OnPaint Method
vGroupBox Class See Also Send Feedback
Raises the [E:Paint] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs p
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    p As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ p
) override

Parameters

p
Type: System.Windows.Forms..::..PaintEventArgs
The PaintEventArgs instance containing the event data.

See Also

vGroupBox Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..PerformLayout Method
vGroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vGroupBox Class
vGroupBox Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..ResumeLayout Method
vGroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vGroupBox Class
vGroupBox Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..RtlTranslateAlignment Method
vGroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vGroupBox Class
vGroupBox Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..Scale Method
vGroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vGroupBox Class
vGroupBox Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..Select Method
vGroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vGroupBox Class
vGroupBox Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..SetBounds Method
vGroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vGroupBox Class
vGroupBox Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..UpdateBounds Method
vGroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vGroupBox Class
vGroupBox Members


vGroupBox Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vGroupBox Properties
vGroupBox Class See Also Send Feedback

The vGroupBox type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDrop | Gets or sets a value that indicates whether the control will allow drag-and-drop operations and events to be used. (Inherited from GroupBox.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the GroupBox resizes based on its contents. (Inherited from GroupBox.)
Public property | AutoSizeMode | Gets or sets how the GroupBox behaves when its AutoSize property is enabled. (Inherited from GroupBox.)
Public property | BackColor | Gets or sets the background color for the control. (Overrides Control..::..BackColor.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the BorderColor of the GroupBox.
Public property | BorderRadius | Gets or sets the border radius.
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CollapsedHeight | Gets or sets the Height of the vGroupBox control when the control is in a collapsed state.
Public property | CollapseGroupBox | Gets or sets a value indicating whether group box should be collapsed
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from GroupBox.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the Padding structure that contains the default padding settings for a GroupBox control. (Inherited from GroupBox.)
Protected property | DefaultSize | (Inherited from GroupBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets a rectangle that represents the dimensions of the GroupBox. (Inherited from GroupBox.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableGroupBoxCollapse | Gets or sets a value indicating whether group box is collapsible
Public property | EnableToggleAnimation | Gets or sets a value indicating whether toggle animation is enabled
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatStyle | Gets or sets the flat style appearance of the group box control. (Inherited from GroupBox.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value that indicates whether the user can press the TAB key to give the focus to the GroupBox. (Inherited from GroupBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the header text of the vGroupBox control (Overrides GroupBox..::..Text.)
Public property | Theme | Gets or sets the theme of the control.
Public property | TitleBackColor | Gets or sets the title backcolor
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCompatibleTextRendering | Gets or sets a value that indicates whether the text of the GroupBox is rendered using compatible text rendering (GDI+) or GDI. (Inherited from GroupBox.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the BorderColor
Public property | UseThemeTextColor | Determines whether to use the text color from the Theme or a custom value
Public property | UseTitleBackColor | Determines whether to use the title back color to draw the text's fill
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vGroupBox Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..AllowAnimations Property
vGroupBox Class See Also Send Feedback
Gets or sets whether the control is animated

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vGroupBox Class


BackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..BackColor Property
vGroupBox Class See Also Send Feedback
Gets or sets the background color for the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color BackColor { get; set; }
Visual Basic
Public Overrides Property BackColor As Color
    Get
    Set
Visual C++
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}

Field Value

Return Value

A Color that represents the background color of the control. The default is the value of the DefaultBackColor property.

See Also

vGroupBox Class


BorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..BorderColor Property
vGroupBox Class See Also Send Feedback
Gets or sets the BorderColor of the GroupBox.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Color BorderColor { get; set; }
Visual Basic
Public Overridable Property BorderColor As Color
    Get
    Set
Visual C++
public:
virtual property Color BorderColor {
    Color get ();
    void set (Color value);
}

See Also

vGroupBox Class


BorderRadius Property

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..BorderRadius Property
vGroupBox Class See Also Send Feedback
Gets or sets the border radius.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int BorderRadius { get; set; }
Visual Basic
Public Property BorderRadius As Integer
    Get
    Set
Visual C++
public:
property int BorderRadius {
    int get ();
    void set (int value);
}

Field Value

The border radius.

See Also

vGroupBox Class


CollapsedHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..CollapsedHeight Property
vGroupBox Class See Also Send Feedback
Gets or sets the Height of the vGroupBox control when the control is in a collapsed state.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int CollapsedHeight { get; set; }
Visual Basic
Public Property CollapsedHeight As Integer
    Get
    Set
Visual C++
public:
property int CollapsedHeight {
    int get ();
    void set (int value);
}

See Also

vGroupBox Class


CollapseGroupBox Property

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..CollapseGroupBox Property
vGroupBox Class See Also Send Feedback
Gets or sets a value indicating whether group box should be collapsed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool CollapseGroupBox { get; set; }
Visual Basic
Public Property CollapseGroupBox As Boolean
    Get
    Set
Visual C++
public:
property bool CollapseGroupBox {
    bool get ();
    void set (bool value);
}

See Also

vGroupBox Class


EnableGroupBoxCollapse Property

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..EnableGroupBoxCollapse Property
vGroupBox Class See Also Send Feedback
Gets or sets a value indicating whether group box is collapsible

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableGroupBoxCollapse { get; set; }
Visual Basic
Public Property EnableGroupBoxCollapse As Boolean
    Get
    Set
Visual C++
public:
property bool EnableGroupBoxCollapse {
    bool get ();
    void set (bool value);
}

See Also

vGroupBox Class


EnableToggleAnimation Property

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..EnableToggleAnimation Property
vGroupBox Class See Also Send Feedback
Gets or sets a value indicating whether toggle animation is enabled

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableToggleAnimation { get; set; }
Visual Basic
Public Property EnableToggleAnimation As Boolean
    Get
    Set
Visual C++
public:
property bool EnableToggleAnimation {
    bool get ();
    void set (bool value);
}

Field Value

true if true the animation is enabled; otherwise, false.

See Also

vGroupBox Class


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..Text Property
vGroupBox Class See Also Send Feedback
Gets or sets the header text of the vGroupBox control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string Text { get; set; }
Visual Basic
Public Overrides Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

See Also

vGroupBox Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..Theme Property
vGroupBox Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vGroupBox Class


TitleBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..TitleBackColor Property
vGroupBox Class See Also Send Feedback
Gets or sets the title backcolor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color TitleBackColor { get; set; }
Visual Basic
Public Property TitleBackColor As Color
    Get
    Set
Visual C++
public:
property Color TitleBackColor {
    Color get ();
    void set (Color value);
}

See Also

vGroupBox Class


UseThemeBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..UseThemeBorderColor Property
vGroupBox Class See Also Send Feedback
Gets or sets a value indicating whether to use the BorderColor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool UseThemeBorderColor { get; set; }
Visual Basic
Public Overridable Property UseThemeBorderColor As Boolean
    Get
    Set
Visual C++
public:
virtual property bool UseThemeBorderColor {
    bool get ();
    void set (bool value);
}

See Also

vGroupBox Class


UseThemeTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..UseThemeTextColor Property
vGroupBox Class See Also Send Feedback
Determines whether to use the text color from the Theme or a custom value

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeTextColor { get; set; }
Visual Basic
Public Property UseThemeTextColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeTextColor {
    bool get ();
    void set (bool value);
}

See Also

vGroupBox Class


UseTitleBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..UseTitleBackColor Property
vGroupBox Class See Also Send Feedback
Determines whether to use the title back color to draw the text's fill

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseTitleBackColor { get; set; }
Visual Basic
Public Property UseTitleBackColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseTitleBackColor {
    bool get ();
    void set (bool value);
}

See Also

vGroupBox Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..VIBlendTheme Property
vGroupBox Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vGroupBox Class


vGroupBox Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vGroupBox Events
vGroupBox Class See Also Send Feedback

The vGroupBox type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from GroupBox.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the user clicks the GroupBox control. (Inherited from GroupBox.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | CollapsedChanged | Occurs when group box is expanded/collapsed
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the GroupBox control. (Inherited from GroupBox.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when the user presses a key while the GroupBox control has focus. (Inherited from GroupBox.)
Public event | KeyPress | Occurs when the user presses a key while the GroupBox control has focus. (Inherited from GroupBox.)
Public event | KeyUp | Occurs when the user releases a key while the GroupBox control has focus. (Inherited from GroupBox.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the user clicks the GroupBox control with the mouse. (Inherited from GroupBox.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the GroupBox control with the mouse. (Inherited from GroupBox.)
Public event | MouseDown | Occurs when the user presses a mouse button while the mouse pointer is over the control. (Inherited from GroupBox.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from GroupBox.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from GroupBox.)
Public event | MouseMove | Occurs when the user moves the mouse pointer over the control. (Inherited from GroupBox.)
Public event | MouseUp | Occurs when the user releases a mouse button while the mouse pointer is over the control. (Inherited from GroupBox.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the value of the TabStop property changes. (Inherited from GroupBox.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vGroupBox Class


CollapsedChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vGroupBox..::..CollapsedChanged Event
vGroupBox Class See Also Send Feedback
Occurs when group box is expanded/collapsed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler CollapsedChanged
Visual Basic
Public Event CollapsedChanged As EventHandler
Visual C++
public:
 event EventHandler^ CollapsedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vGroupBox Class


vHorizontalLayoutPanel Class

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel Class
Members See Also Send Feedback
Represents a vHorizontalLayoutPanel control where the user can arrange multiple controls.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vHorizontalLayoutPanel : Panel,
    IScrollableControlBase
Visual Basic
Public Class vHorizontalLayoutPanel _
    Inherits Panel _
    Implements IScrollableControlBase
Visual C++
public ref class vHorizontalLayoutPanel : public Panel,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..Panel
VIBlend.WinForms.Controls..::..vHorizontalLayoutPanel
VIBlend.WinForms.Controls..::..vRibbonHorizontalLayoutPanel

See Also

vHorizontalLayoutPanel Members


vHorizontalLayoutPanel Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel Members
vHorizontalLayoutPanel Class Constructors Methods Properties Events See Also Send Feedback

The vHorizontalLayoutPanel type exposes the following members.

Constructors

 | Name | Description
Public method | vHorizontalLayoutPanel | vHorizontalLayoutPanel constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides ScrollableControl..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Overrides Control..::..ProcessCmdKey(Message%, Keys).)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollLeft |
Protected method | ScrollRight |
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Overrides ScrollableControl..::..AutoScroll.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Overrides Panel..::..AutoSize.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border
Public property | PaintFill | Gets or sets a value indicating whether to paint a background
Public property | PanelBackColor | Gets or sets the BackColor of the Panel.
Public property | PanelBorderColor | Gets or sets the BorderColor of the Panel.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StartOffset | Gets or sets the start offset.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UsePanelBackColor | Gets or sets a value indicating whether to use the PanelBackColor
Public property | UsePanelBorderColor | Gets or sets a value indicating whether to use the PanelBorderColor
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vHorizontalLayoutPanel Class


vHorizontalLayoutPanel Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel Constructor
vHorizontalLayoutPanel Class See Also Send Feedback
vHorizontalLayoutPanel constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vHorizontalLayoutPanel()
Visual Basic
Public Sub New
Visual C++
public:
vHorizontalLayoutPanel()

See Also

vHorizontalLayoutPanel Class


vHorizontalLayoutPanel Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel Methods
vHorizontalLayoutPanel Class See Also Send Feedback

The vHorizontalLayoutPanel type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides ScrollableControl..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Overrides Control..::..ProcessCmdKey(Message%, Keys).)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollLeft |
Protected method | ScrollRight |
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

See Also

vHorizontalLayoutPanel Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..AccessibilityNotifyClients Method
vHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vHorizontalLayoutPanel Class
vHorizontalLayoutPanel Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..BeginInvoke Method
vHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vHorizontalLayoutPanel Class
vHorizontalLayoutPanel Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..Dispose Method
vHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)

See Also

vHorizontalLayoutPanel Class
vHorizontalLayoutPanel Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..Dispose Method (Boolean)
vHorizontalLayoutPanel Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vHorizontalLayoutPanel Class
Dispose Overload


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..GetChildAtPoint Method
vHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vHorizontalLayoutPanel Class
vHorizontalLayoutPanel Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..Invalidate Method
vHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vHorizontalLayoutPanel Class
vHorizontalLayoutPanel Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..Invoke Method
vHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vHorizontalLayoutPanel Class
vHorizontalLayoutPanel Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..MemberwiseClone Method
vHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vHorizontalLayoutPanel Class
vHorizontalLayoutPanel Members


OnKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..OnKeyDown Method
vHorizontalLayoutPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs

See Also

vHorizontalLayoutPanel Class


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..OnLayout Method
vHorizontalLayoutPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs

See Also

vHorizontalLayoutPanel Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..OnPaint Method
vHorizontalLayoutPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vHorizontalLayoutPanel Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..PerformLayout Method
vHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vHorizontalLayoutPanel Class
vHorizontalLayoutPanel Members


ProcessCmdKey Method

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..ProcessCmdKey Method
vHorizontalLayoutPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override bool ProcessCmdKey(
    ref Message msg,
    Keys keyData
)
Visual Basic
Protected Overrides Function ProcessCmdKey ( _
    ByRef msg As Message, _
    keyData As Keys _
) As Boolean
Visual C++
protected:
virtual bool ProcessCmdKey(
    Message% msg,
    Keys keyData
) override

Parameters

msg
Type: System.Windows.Forms..::..Message %
keyData
Type: System.Windows.Forms..::..Keys

See Also

vHorizontalLayoutPanel Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..ResumeLayout Method
vHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vHorizontalLayoutPanel Class
vHorizontalLayoutPanel Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..RtlTranslateAlignment Method
vHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vHorizontalLayoutPanel Class
vHorizontalLayoutPanel Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..Scale Method
vHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vHorizontalLayoutPanel Class
vHorizontalLayoutPanel Members


ScrollLeft Method

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..ScrollLeft Method
vHorizontalLayoutPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void ScrollLeft()
Visual Basic
Protected Overridable Sub ScrollLeft
Visual C++
protected:
virtual void ScrollLeft()

See Also

vHorizontalLayoutPanel Class


ScrollRight Method

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..ScrollRight Method
vHorizontalLayoutPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void ScrollRight()
Visual Basic
Protected Overridable Sub ScrollRight
Visual C++
protected:
virtual void ScrollRight()

See Also

vHorizontalLayoutPanel Class


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..Select Method
vHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vHorizontalLayoutPanel Class
vHorizontalLayoutPanel Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..SetBounds Method
vHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vHorizontalLayoutPanel Class
vHorizontalLayoutPanel Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..UpdateBounds Method
vHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vHorizontalLayoutPanel Class
vHorizontalLayoutPanel Members


vHorizontalLayoutPanel Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel Properties
vHorizontalLayoutPanel Class See Also Send Feedback

The vHorizontalLayoutPanel type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Overrides ScrollableControl..::..AutoScroll.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Overrides Panel..::..AutoSize.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border
Public property | PaintFill | Gets or sets a value indicating whether to paint a background
Public property | PanelBackColor | Gets or sets the BackColor of the Panel.
Public property | PanelBorderColor | Gets or sets the BorderColor of the Panel.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StartOffset | Gets or sets the start offset.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UsePanelBackColor | Gets or sets a value indicating whether to use the PanelBackColor
Public property | UsePanelBorderColor | Gets or sets a value indicating whether to use the PanelBorderColor
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vHorizontalLayoutPanel Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..AllowAnimations Property
vHorizontalLayoutPanel Class See Also Send Feedback
Determines whether to use animations

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vHorizontalLayoutPanel Class


AutoScroll Property

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..AutoScroll Property
vHorizontalLayoutPanel Class See Also Send Feedback
Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override bool AutoScroll { get; set; }
Visual Basic
Public Overrides Property AutoScroll As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AutoScroll {
    bool get () override;
    void set (bool value) override;
}

Field Value

Return Value

true if the container enables auto-scrolling; otherwise, false. The default value is false.

See Also

vHorizontalLayoutPanel Class


AutoSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..AutoSize Property
vHorizontalLayoutPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override bool AutoSize { get; set; }
Visual Basic
Public Overrides Property AutoSize As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AutoSize {
    bool get () override;
    void set (bool value) override;
}

Field Value

Return Value

true if enabled; otherwise, false.

See Also

vHorizontalLayoutPanel Class


PaintBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..PaintBorder Property
vHorizontalLayoutPanel Class See Also Send Feedback
Gets or sets a value indicating whether to paint a border

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintBorder { get; set; }
Visual Basic
Public Property PaintBorder As Boolean
    Get
    Set
Visual C++
public:
property bool PaintBorder {
    bool get ();
    void set (bool value);
}

Field Value

true if [paint border]; otherwise, false.

See Also

vHorizontalLayoutPanel Class


PaintFill Property

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..PaintFill Property
vHorizontalLayoutPanel Class See Also Send Feedback
Gets or sets a value indicating whether to paint a background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintFill { get; set; }
Visual Basic
Public Property PaintFill As Boolean
    Get
    Set
Visual C++
public:
property bool PaintFill {
    bool get ();
    void set (bool value);
}

Field Value

true if [paint fill]; otherwise, false.

See Also

vHorizontalLayoutPanel Class


PanelBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..PanelBackColor Property
vHorizontalLayoutPanel Class See Also Send Feedback
Gets or sets the BackColor of the Panel.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Color PanelBackColor { get; set; }
Visual Basic
Public Overridable Property PanelBackColor As Color
    Get
    Set
Visual C++
public:
virtual property Color PanelBackColor {
    Color get ();
    void set (Color value);
}

See Also

vHorizontalLayoutPanel Class


PanelBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..PanelBorderColor Property
vHorizontalLayoutPanel Class See Also Send Feedback
Gets or sets the BorderColor of the Panel.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Color PanelBorderColor { get; set; }
Visual Basic
Public Overridable Property PanelBorderColor As Color
    Get
    Set
Visual C++
public:
virtual property Color PanelBorderColor {
    Color get ();
    void set (Color value);
}

See Also

vHorizontalLayoutPanel Class


StartOffset Property

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..StartOffset Property
vHorizontalLayoutPanel Class See Also Send Feedback
Gets or sets the start offset.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int StartOffset { get; set; }
Visual Basic
Public Property StartOffset As Integer
    Get
    Set
Visual C++
public:
property int StartOffset {
    int get ();
    void set (int value);
}

Field Value

The start offset.

See Also

vHorizontalLayoutPanel Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..Theme Property
vHorizontalLayoutPanel Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vHorizontalLayoutPanel Class


UsePanelBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..UsePanelBackColor Property
vHorizontalLayoutPanel Class See Also Send Feedback
Gets or sets a value indicating whether to use the PanelBackColor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool UsePanelBackColor { get; set; }
Visual Basic
Public Overridable Property UsePanelBackColor As Boolean
    Get
    Set
Visual C++
public:
virtual property bool UsePanelBackColor {
    bool get ();
    void set (bool value);
}

See Also

vHorizontalLayoutPanel Class


UsePanelBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..UsePanelBorderColor Property
vHorizontalLayoutPanel Class See Also Send Feedback
Gets or sets a value indicating whether to use the PanelBorderColor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool UsePanelBorderColor { get; set; }
Visual Basic
Public Overridable Property UsePanelBorderColor As Boolean
    Get
    Set
Visual C++
public:
virtual property bool UsePanelBorderColor {
    bool get ();
    void set (bool value);
}

See Also

vHorizontalLayoutPanel Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel..::..VIBlendTheme Property
vHorizontalLayoutPanel Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vHorizontalLayoutPanel Class


vHorizontalLayoutPanel Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHorizontalLayoutPanel Events
vHorizontalLayoutPanel Class See Also Send Feedback

The vHorizontalLayoutPanel type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vHorizontalLayoutPanel Class


vHScrollBar Class

[image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar Class
Members See Also Send Feedback
Represents a horizontal scroll bar control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vHScrollBar : vScrollBar
Visual Basic
Public Class vHScrollBar _
    Inherits vScrollBar
Visual C++
public ref class vHScrollBar : public vScrollBar

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
ScrollableControlMiniBase
VIBlend.WinForms.Controls..::..vScrollBar
VIBlend.WinForms.Controls..::..vHScrollBar

See Also

vHScrollBar Members


vHScrollBar Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar Members
vHScrollBar Class Constructors Methods Properties Events See Also Send Feedback

The vHScrollBar type exposes the following members.

Constructors

 | Name | Description
Public method | vHScrollBar | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vScrollBar.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDiffFactor | (Inherited from vScrollBar.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnScroll | Raises the Scroll event (Inherited from vScrollBar.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Raises the ValueChanged event. (Inherited from vScrollBar.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Public method | SetDiffFactor | (Inherited from vScrollBar.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LargeChange | Gets or sets the large change value of the scroll bar. (Inherited from vScrollBar.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the maximum change value of the scroll bar. (Inherited from vScrollBar.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the minimum change value of the scroll bar. (Inherited from vScrollBar.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollButtonsRoundedCornersRadius | Gets or sets the rounded corners radius of the scroll bar buttons. (Inherited from vScrollBar.)
Public property | ScrollButtonsSemiRounded | Gets or sets whether the scrollbar buttons appear semirounded. (Inherited from vScrollBar.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmallChange | Gets or sets the small change value of the scroll bar. (Inherited from vScrollBar.)
Public property | SmartScrollEnabled | Gets or sets whether smart scrolling is enabled (Inherited from vScrollBar.)
Protected property | StyleKey | (Overrides vScrollBar..::..StyleKey.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vScrollBar.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the current value of the scroll bar. (Inherited from vScrollBar.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vScrollBar.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the thumb of the scroll bar has been moved by either a mouse or keyboard action. (Inherited from vScrollBar.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when the Value property is changed, either by a Scroll event or programmatically. (Inherited from vScrollBar.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vHScrollBar Class


vHScrollBar Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar Constructor
vHScrollBar Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vHScrollBar()
Visual Basic
Public Sub New
Visual C++
public:
vHScrollBar()

See Also

vHScrollBar Class


vHScrollBar Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar Methods
vHScrollBar Class See Also Send Feedback

The vHScrollBar type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vScrollBar.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDiffFactor | (Inherited from vScrollBar.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnScroll | Raises the Scroll event (Inherited from vScrollBar.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Raises the ValueChanged event. (Inherited from vScrollBar.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Public method | SetDiffFactor | (Inherited from vScrollBar.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vHScrollBar Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar..::..AccessibilityNotifyClients Method
vHScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vHScrollBar Class
vHScrollBar Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar..::..BeginInvoke Method
vHScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vHScrollBar Class
vHScrollBar Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar..::..Dispose Method
vHScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vScrollBar.)

See Also

vHScrollBar Class
vHScrollBar Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar..::..GetChildAtPoint Method
vHScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vHScrollBar Class
vHScrollBar Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar..::..Invalidate Method
vHScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vHScrollBar Class
vHScrollBar Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar..::..Invoke Method
vHScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vHScrollBar Class
vHScrollBar Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar..::..MemberwiseClone Method
vHScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vHScrollBar Class
vHScrollBar Members


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar..::..PerformLayout Method
vHScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vHScrollBar Class
vHScrollBar Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar..::..ResumeLayout Method
vHScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vHScrollBar Class
vHScrollBar Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar..::..RtlTranslateAlignment Method
vHScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vHScrollBar Class
vHScrollBar Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar..::..Scale Method
vHScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vHScrollBar Class
vHScrollBar Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar..::..Select Method
vHScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vHScrollBar Class
vHScrollBar Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar..::..SetBounds Method
vHScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vHScrollBar Class
vHScrollBar Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar..::..UpdateBounds Method
vHScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vHScrollBar Class
vHScrollBar Members


vHScrollBar Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar Properties
vHScrollBar Class See Also Send Feedback

The vHScrollBar type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LargeChange | Gets or sets the large change value of the scroll bar. (Inherited from vScrollBar.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the maximum change value of the scroll bar. (Inherited from vScrollBar.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the minimum change value of the scroll bar. (Inherited from vScrollBar.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollButtonsRoundedCornersRadius | Gets or sets the rounded corners radius of the scroll bar buttons. (Inherited from vScrollBar.)
Public property | ScrollButtonsSemiRounded | Gets or sets whether the scrollbar buttons appear semirounded. (Inherited from vScrollBar.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmallChange | Gets or sets the small change value of the scroll bar. (Inherited from vScrollBar.)
Public property | SmartScrollEnabled | Gets or sets whether smart scrolling is enabled (Inherited from vScrollBar.)
Protected property | StyleKey | (Overrides vScrollBar..::..StyleKey.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vScrollBar.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the current value of the scroll bar. (Inherited from vScrollBar.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vScrollBar.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vHScrollBar Class


StyleKey Property

[image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar..::..StyleKey Property
vHScrollBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal override string StyleKey { get; set; }
Visual Basic
Protected Friend Overrides Property StyleKey As String
    Get
    Set
Visual C++
protected public:
virtual property String^ StyleKey {
    String^ get () override;
    void set (String^ value) override;
}

See Also

vHScrollBar Class


vHScrollBar Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vHScrollBar Events
vHScrollBar Class See Also Send Feedback

The vHScrollBar type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the thumb of the scroll bar has been moved by either a mouse or keyboard action. (Inherited from vScrollBar.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when the Value property is changed, either by a Scroll event or programmatically. (Inherited from vScrollBar.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vHScrollBar Class


vImageReflectionControl Class

[image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl Class
Members See Also Send Feedback
Represents a vImageReflectionControl control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vImageReflectionControl : Control
Visual Basic
Public Class vImageReflectionControl _
    Inherits Control
Visual C++
public ref class vImageReflectionControl : public Control

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vImageReflectionControl

See Also

vImageReflectionControl Members


vImageReflectionControl Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl Members
vImageReflectionControl Class Constructors Methods Properties Events See Also Send Feedback

The vImageReflectionControl type exposes the following members.

Constructors

 | Name | Description
Public method | vImageReflectionControl | vImageReflectionControl constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content | Gets or sets the content.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DrawContentReflection | Gets or sets a value indicating whether to draw only content's reflection
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableOpacityEffect | Gets or sets a value indicating whether the image opacity effect is enabled
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | Image | Gets or sets the image.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | ReflectionFactor | Gets or sets the reflection factor.
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vImageReflectionControl Class


vImageReflectionControl Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl Constructor
vImageReflectionControl Class See Also Send Feedback
vImageReflectionControl constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vImageReflectionControl()
Visual Basic
Public Sub New
Visual C++
public:
vImageReflectionControl()

See Also

vImageReflectionControl Class


vImageReflectionControl Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl Methods
vImageReflectionControl Class See Also Send Feedback

The vImageReflectionControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vImageReflectionControl Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..AccessibilityNotifyClients Method
vImageReflectionControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vImageReflectionControl Class
vImageReflectionControl Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..BeginInvoke Method
vImageReflectionControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vImageReflectionControl Class
vImageReflectionControl Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..Dispose Method
vImageReflectionControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vImageReflectionControl Class
vImageReflectionControl Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..GetChildAtPoint Method
vImageReflectionControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vImageReflectionControl Class
vImageReflectionControl Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..Invalidate Method
vImageReflectionControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vImageReflectionControl Class
vImageReflectionControl Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..Invoke Method
vImageReflectionControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vImageReflectionControl Class
vImageReflectionControl Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..MemberwiseClone Method
vImageReflectionControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vImageReflectionControl Class
vImageReflectionControl Members


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..OnPaint Method
vImageReflectionControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vImageReflectionControl Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..PerformLayout Method
vImageReflectionControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vImageReflectionControl Class
vImageReflectionControl Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..ResumeLayout Method
vImageReflectionControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vImageReflectionControl Class
vImageReflectionControl Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..RtlTranslateAlignment Method
vImageReflectionControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vImageReflectionControl Class
vImageReflectionControl Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..Scale Method
vImageReflectionControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vImageReflectionControl Class
vImageReflectionControl Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..Select Method
vImageReflectionControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vImageReflectionControl Class
vImageReflectionControl Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..SetBounds Method
vImageReflectionControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vImageReflectionControl Class
vImageReflectionControl Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..UpdateBounds Method
vImageReflectionControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vImageReflectionControl Class
vImageReflectionControl Members


vImageReflectionControl Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl Properties
vImageReflectionControl Class See Also Send Feedback

The vImageReflectionControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content | Gets or sets the content.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DrawContentReflection | Gets or sets a value indicating whether to draw only content's reflection
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableOpacityEffect | Gets or sets a value indicating whether the image opacity effect is enabled
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | Image | Gets or sets the image.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | ReflectionFactor | Gets or sets the reflection factor.
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vImageReflectionControl Class


Content Property

[image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..Content Property
vImageReflectionControl Class See Also Send Feedback
Gets or sets the content.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control Content { get; set; }
Visual Basic
Public Property Content As Control
    Get
    Set
Visual C++
public:
property Control^ Content {
    Control^ get ();
    void set (Control^ value);
}

Field Value

The content.

See Also

vImageReflectionControl Class


DrawContentReflection Property

[image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..DrawContentReflection Property
vImageReflectionControl Class See Also Send Feedback
Gets or sets a value indicating whether to draw only content's reflection

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool DrawContentReflection { get; set; }
Visual Basic
Public Property DrawContentReflection As Boolean
    Get
    Set
Visual C++
public:
property bool DrawContentReflection {
    bool get ();
    void set (bool value);
}

See Also

vImageReflectionControl Class


EnableOpacityEffect Property

[image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..EnableOpacityEffect Property
vImageReflectionControl Class See Also Send Feedback
Gets or sets a value indicating whether the image opacity effect is enabled

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableOpacityEffect { get; set; }
Visual Basic
Public Property EnableOpacityEffect As Boolean
    Get
    Set
Visual C++
public:
property bool EnableOpacityEffect {
    bool get ();
    void set (bool value);
}

See Also

vImageReflectionControl Class


Image Property

[image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..Image Property
vImageReflectionControl Class See Also Send Feedback
Gets or sets the image.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Image Image { get; set; }
Visual Basic
Public Property Image As Image
    Get
    Set
Visual C++
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}

See Also

vImageReflectionControl Class


ReflectionFactor Property

[image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl..::..ReflectionFactor Property
vImageReflectionControl Class See Also Send Feedback
Gets or sets the reflection factor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ReflectionFactor { get; set; }
Visual Basic
Public Property ReflectionFactor As Integer
    Get
    Set
Visual C++
public:
property int ReflectionFactor {
    int get ();
    void set (int value);
}

See Also

vImageReflectionControl Class


vImageReflectionControl Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vImageReflectionControl Events
vImageReflectionControl Class See Also Send Feedback

The vImageReflectionControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vImageReflectionControl Class


vLabel Class

[image]

VIBlend Controls for WinForms Help Documentation
vLabel Class
Members See Also Send Feedback
Represents a vLabel control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vLabel : ScrollableControlMiniBase
Visual Basic
Public Class vLabel _
    Inherits ScrollableControlMiniBase
Visual C++
public ref class vLabel : public ScrollableControlMiniBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
ScrollableControlMiniBase
VIBlend.WinForms.Controls..::..vLabel
VIBlend.WinForms.Controls..::..vLabelItem

See Also

vLabel Members


vLabel Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabel Members
vLabel Class Constructors Methods Properties Events See Also Send Feedback

The vLabel type exposes the following members.

Constructors

 | Name | Description
Public method | vLabel | Initializes a new instance of the vLabelItem class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Overrides Control..::..DefaultSize.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | DisplayStyle | Gets or sets the style of the vLabel control
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Ellipsis | Gets or sets a value indicating whether this vLabel is drawn with elipsis.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | Image | Gets or sets the image of the vLabel control
Public property | ImageAlignment | Gets or sets the image alignment of the vLabel control
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets a value indicating whether this vLabel is multiline.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity of the vLabel control
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Determines whether the border will be painted
Public property | PaintFill | Determines whether the background will be painted
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RotationAngle | Gets or sets the rotation angle of the vLabel control
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Overrides Control..::..Text.)
Public property | TextAlignment | Gets or sets the text alignment of the vLabel control
Public property | Theme | Gets or sets the theme of the control
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseMnemonics | Gets or sets a value indicating whether mnemonic will be used
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vLabel Class


vLabel Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vLabel Constructor
vLabel Class See Also Send Feedback
Initializes a new instance of the vLabelItem class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vLabel()
Visual Basic
Public Sub New
Visual C++
public:
vLabel()

See Also

vLabel Class


vLabel Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabel Methods
vLabel Class See Also Send Feedback

The vLabel type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vLabel Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..AccessibilityNotifyClients Method
vLabel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vLabel Class
vLabel Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..BeginInvoke Method
vLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vLabel Class
vLabel Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..Dispose Method
vLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vLabel Class
vLabel Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..GetChildAtPoint Method
vLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vLabel Class
vLabel Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..Invalidate Method
vLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vLabel Class
vLabel Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..Invoke Method
vLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vLabel Class
vLabel Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..MemberwiseClone Method
vLabel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vLabel Class
vLabel Members


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..OnPaint Method
vLabel Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vLabel Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..PerformLayout Method
vLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vLabel Class
vLabel Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..ResumeLayout Method
vLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vLabel Class
vLabel Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..RtlTranslateAlignment Method
vLabel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vLabel Class
vLabel Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..Scale Method
vLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vLabel Class
vLabel Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..Select Method
vLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vLabel Class
vLabel Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..SetBounds Method
vLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vLabel Class
vLabel Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..UpdateBounds Method
vLabel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vLabel Class
vLabel Members


vLabel Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabel Properties
vLabel Class See Also Send Feedback

The vLabel type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Overrides Control..::..DefaultSize.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | DisplayStyle | Gets or sets the style of the vLabel control
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Ellipsis | Gets or sets a value indicating whether this vLabel is drawn with elipsis.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | Image | Gets or sets the image of the vLabel control
Public property | ImageAlignment | Gets or sets the image alignment of the vLabel control
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets a value indicating whether this vLabel is multiline.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity of the vLabel control
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Determines whether the border will be painted
Public property | PaintFill | Determines whether the background will be painted
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RotationAngle | Gets or sets the rotation angle of the vLabel control
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Overrides Control..::..Text.)
Public property | TextAlignment | Gets or sets the text alignment of the vLabel control
Public property | Theme | Gets or sets the theme of the control
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseMnemonics | Gets or sets a value indicating whether mnemonic will be used
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vLabel Class


DefaultSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..DefaultSize Property
vLabel Class See Also Send Feedback
Gets the default size of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override Size DefaultSize { get; }
Visual Basic
Protected Overrides ReadOnly Property DefaultSize As Size
    Get
Visual C++
protected:
virtual property Size DefaultSize {
    Size get () override;
}

Field Value

Return Value

The default Size of the control.

See Also

vLabel Class


DisplayStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..DisplayStyle Property
vLabel Class See Also Send Feedback
Gets or sets the style of the vLabel control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public LabelItemStyle DisplayStyle { get; set; }
Visual Basic
Public Property DisplayStyle As LabelItemStyle
    Get
    Set
Visual C++
public:
property LabelItemStyle DisplayStyle {
    LabelItemStyle get ();
    void set (LabelItemStyle value);
}

See Also

vLabel Class


Ellipsis Property

[image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..Ellipsis Property
vLabel Class See Also Send Feedback
Gets or sets a value indicating whether this vLabel is drawn with elipsis.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Ellipsis { get; set; }
Visual Basic
Public Property Ellipsis As Boolean
    Get
    Set
Visual C++
public:
property bool Ellipsis {
    bool get ();
    void set (bool value);
}

Field Value

true if multiline draws the text on multiple lines; otherwise, false.

See Also

vLabel Class


Image Property

[image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..Image Property
vLabel Class See Also Send Feedback
Gets or sets the image of the vLabel control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Image Image { get; set; }
Visual Basic
Public Property Image As Image
    Get
    Set
Visual C++
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}

See Also

vLabel Class


ImageAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..ImageAlignment Property
vLabel Class See Also Send Feedback
Gets or sets the image alignment of the vLabel control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment ImageAlignment { get; set; }
Visual Basic
Public Property ImageAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment ImageAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

vLabel Class


Multiline Property

[image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..Multiline Property
vLabel Class See Also Send Feedback
Gets or sets a value indicating whether this vLabel is multiline.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Multiline { get; set; }
Visual Basic
Public Property Multiline As Boolean
    Get
    Set
Visual C++
public:
property bool Multiline {
    bool get ();
    void set (bool value);
}

Field Value

true if multiline draws the text on multiple lines; otherwise, false.

See Also

vLabel Class


Opacity Property

[image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..Opacity Property
vLabel Class See Also Send Feedback
Gets or sets the opacity of the vLabel control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public float Opacity { get; set; }
Visual Basic
Public Property Opacity As Single
    Get
    Set
Visual C++
public:
property float Opacity {
    float get ();
    void set (float value);
}

Remarks

The opacity property must be a value between 0 and 1

See Also

vLabel Class


PaintBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..PaintBorder Property
vLabel Class See Also Send Feedback
Determines whether the border will be painted

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintBorder { get; set; }
Visual Basic
Public Property PaintBorder As Boolean
    Get
    Set
Visual C++
public:
property bool PaintBorder {
    bool get ();
    void set (bool value);
}

See Also

vLabel Class


PaintFill Property

[image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..PaintFill Property
vLabel Class See Also Send Feedback
Determines whether the background will be painted

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintFill { get; set; }
Visual Basic
Public Property PaintFill As Boolean
    Get
    Set
Visual C++
public:
property bool PaintFill {
    bool get ();
    void set (bool value);
}

See Also

vLabel Class


RotationAngle Property

[image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..RotationAngle Property
vLabel Class See Also Send Feedback
Gets or sets the rotation angle of the vLabel control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public double RotationAngle { get; set; }
Visual Basic
Public Property RotationAngle As Double
    Get
    Set
Visual C++
public:
property double RotationAngle {
    double get ();
    void set (double value);
}

See Also

vLabel Class


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..Text Property
vLabel Class See Also Send Feedback
Gets or sets the text associated with this control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string Text { get; set; }
Visual Basic
Public Overrides Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

Field Value

Return Value

The text associated with this control.

See Also

vLabel Class


TextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..TextAlignment Property
vLabel Class See Also Send Feedback
Gets or sets the text alignment of the vLabel control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment TextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The text alignment.

See Also

vLabel Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..Theme Property
vLabel Class See Also Send Feedback
Gets or sets the theme of the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vLabel Class


UseMnemonics Property

[image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..UseMnemonics Property
vLabel Class See Also Send Feedback
Gets or sets a value indicating whether mnemonic will be used

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseMnemonics { get; set; }
Visual Basic
Public Property UseMnemonics As Boolean
    Get
    Set
Visual C++
public:
property bool UseMnemonics {
    bool get ();
    void set (bool value);
}

Field Value

true if UseMnemonics a mnemonic characted is recognized; otherwise, false.

See Also

vLabel Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vLabel..::..VIBlendTheme Property
vLabel Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vLabel Class


vLabel Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabel Events
vLabel Class See Also Send Feedback

The vLabel type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vLabel Class


vLabelItem Class

[image]

VIBlend Controls for WinForms Help Documentation
vLabelItem Class
Members See Also Send Feedback
Represents a vLabelItem

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vLabelItem : vLabel
Visual Basic
Public Class vLabelItem _
    Inherits vLabel
Visual C++
public ref class vLabelItem : public vLabel

Remarks

vLabelItem represents a single label inside a vMultiLabel control

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
ScrollableControlMiniBase
VIBlend.WinForms.Controls..::..vLabel
VIBlend.WinForms.Controls..::..vLabelItem

See Also

vLabelItem Members


vLabelItem Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabelItem Members
vLabelItem Class Constructors Methods Properties Events See Also Send Feedback

The vLabelItem type exposes the following members.

Constructors

 | Name | Description
Public method | vLabelItem | Initializes a new instance of the vLabelItem class

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from vLabel.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from vLabel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | DisplayStyle | Gets or sets the style of the vLabel control (Inherited from vLabel.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Ellipsis | Gets or sets a value indicating whether this vLabel is drawn with elipsis. (Inherited from vLabel.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the Horizontal offset of the vLabelItem
Public property | Image | Gets or sets the image of the vLabel control (Inherited from vLabel.)
Public property | ImageAlignment | Gets or sets the image alignment of the vLabel control (Inherited from vLabel.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets a value indicating whether this vLabel is multiline. (Inherited from vLabel.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity of the vLabel control (Inherited from vLabel.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Determines whether the border will be painted (Inherited from vLabel.)
Public property | PaintFill | Determines whether the background will be painted (Inherited from vLabel.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RotationAngle | Gets or sets the rotation angle of the vLabel control (Inherited from vLabel.)
Public property | Row | Gets or sets the row of the vLabelItem within the vMultiLabel control
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from vLabel.)
Public property | TextAlignment | Gets or sets the text alignment of the vLabel control (Inherited from vLabel.)
Public property | Theme | Gets or sets the theme of the control (Inherited from vLabel.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseMnemonics | Gets or sets a value indicating whether mnemonic will be used (Inherited from vLabel.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vLabel.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vLabelItem Class


vLabelItem Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vLabelItem Constructor
vLabelItem Class See Also Send Feedback
Initializes a new instance of the vLabelItem class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vLabelItem()
Visual Basic
Public Sub New
Visual C++
public:
vLabelItem()

See Also

vLabelItem Class


vLabelItem Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabelItem Methods
vLabelItem Class See Also Send Feedback

The vLabelItem type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from vLabel.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vLabelItem Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabelItem..::..AccessibilityNotifyClients Method
vLabelItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vLabelItem Class
vLabelItem Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabelItem..::..BeginInvoke Method
vLabelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vLabelItem Class
vLabelItem Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabelItem..::..Dispose Method
vLabelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vLabelItem Class
vLabelItem Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabelItem..::..GetChildAtPoint Method
vLabelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vLabelItem Class
vLabelItem Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabelItem..::..Invalidate Method
vLabelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vLabelItem Class
vLabelItem Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabelItem..::..Invoke Method
vLabelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vLabelItem Class
vLabelItem Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabelItem..::..MemberwiseClone Method
vLabelItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vLabelItem Class
vLabelItem Members


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabelItem..::..PerformLayout Method
vLabelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vLabelItem Class
vLabelItem Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabelItem..::..ResumeLayout Method
vLabelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vLabelItem Class
vLabelItem Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabelItem..::..RtlTranslateAlignment Method
vLabelItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vLabelItem Class
vLabelItem Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabelItem..::..Scale Method
vLabelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vLabelItem Class
vLabelItem Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabelItem..::..Select Method
vLabelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vLabelItem Class
vLabelItem Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabelItem..::..SetBounds Method
vLabelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vLabelItem Class
vLabelItem Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabelItem..::..UpdateBounds Method
vLabelItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vLabelItem Class
vLabelItem Members


vLabelItem Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabelItem Properties
vLabelItem Class See Also Send Feedback

The vLabelItem type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from vLabel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | DisplayStyle | Gets or sets the style of the vLabel control (Inherited from vLabel.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Ellipsis | Gets or sets a value indicating whether this vLabel is drawn with elipsis. (Inherited from vLabel.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the Horizontal offset of the vLabelItem
Public property | Image | Gets or sets the image of the vLabel control (Inherited from vLabel.)
Public property | ImageAlignment | Gets or sets the image alignment of the vLabel control (Inherited from vLabel.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets a value indicating whether this vLabel is multiline. (Inherited from vLabel.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity of the vLabel control (Inherited from vLabel.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Determines whether the border will be painted (Inherited from vLabel.)
Public property | PaintFill | Determines whether the background will be painted (Inherited from vLabel.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RotationAngle | Gets or sets the rotation angle of the vLabel control (Inherited from vLabel.)
Public property | Row | Gets or sets the row of the vLabelItem within the vMultiLabel control
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from vLabel.)
Public property | TextAlignment | Gets or sets the text alignment of the vLabel control (Inherited from vLabel.)
Public property | Theme | Gets or sets the theme of the control (Inherited from vLabel.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseMnemonics | Gets or sets a value indicating whether mnemonic will be used (Inherited from vLabel.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vLabel.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vLabelItem Class


HorizontalOffset Property

[image]

VIBlend Controls for WinForms Help Documentation
vLabelItem..::..HorizontalOffset Property
vLabelItem Class See Also Send Feedback
Gets or sets the Horizontal offset of the vLabelItem

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int HorizontalOffset { get; set; }
Visual Basic
Public Property HorizontalOffset As Integer
    Get
    Set
Visual C++
public:
property int HorizontalOffset {
    int get ();
    void set (int value);
}

See Also

vLabelItem Class


Row Property

[image]

VIBlend Controls for WinForms Help Documentation
vLabelItem..::..Row Property
vLabelItem Class See Also Send Feedback
Gets or sets the row of the vLabelItem within the vMultiLabel control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Row { get; set; }
Visual Basic
Public Property Row As Integer
    Get
    Set
Visual C++
public:
property int Row {
    int get ();
    void set (int value);
}

See Also

vLabelItem Class


vLabelItem Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vLabelItem Events
vLabelItem Class See Also Send Feedback

The vLabelItem type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vLabelItem Class


vListBox Class

[image]

VIBlend Controls for WinForms Help Documentation
vListBox Class
Members See Also Send Feedback
Represents a vListBox control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vListBox : Control, IScrollableControlBase
Visual Basic
Public Class vListBox _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class vListBox : public Control,
    IScrollableControlBase

Remarks

A vListBox displays a collection of items. The control allows you to use images, and detailed description for each item.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vListBox
VIBlend.WinForms.Controls..::..vCheckedListBox
VIBlend.WinForms.Controls..::..vRadioListBox

See Also

vListBox Members


vListBox Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox Members
vListBox Class Constructors Methods Fields Properties Events See Also Send Feedback

The vListBox type exposes the following members.

Constructors

 | Name | Description
Public method | vListBox | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | BeginDrag | Begins the drag.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Begins a batch of changes on the items collection
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CanSelectMultipleItems | Determines whether this instance can select multiple items.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawDragFeedback(Graphics) |
 | DrawDragFeedback(Graphics, vListBox) | Draw
Public method | DrawItem |
Public method | DrawItemImage | Draws the item image.
Public method | DrawListItemBackGroundAndBorder | Draws the list item back ground and border.
Public method | DrawListItemTextAndDescription | Draws the list item text and description.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
 | DropItem(vListBox, vListBox, ListItem) | Drops the item.
 | DropItem(vListBox, vListBox, ListItem, ListBoxDropType) | Drops the item.
Protected method | EndDrag | Ends the drag.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Begins a batch of changes on the items collection previously started by BeginUpdate()
Public method | EnsureVisible | Ensures that a list view item is visible.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FilterItemOnProperty |
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindItem(Point) | Get ListItem at specific point.
 | FindItem(Point, vListBox) |
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Protected method | GetBackFillColor | Gets the color of the back fill.
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemFont | Gets the item font.
Public method | GetItemForeColor | Gets the color of the item fore.
Public method | GetItemImage | Gets the item image.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest | Performs a HitTest at a specific point
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Overrides Control..::..OnBindingContextChanged(EventArgs).)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDataSourceChanged | Raises the DataSourceChanged event
Protected method | OnDisplayMemberChanged | Raises the OnDisplayMemberChanged event
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawItem | Raises the DrawItem event.
Protected method | OnDrawListItem |
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemDragEnded |
Protected method | OnItemDragEnding |
Protected method | OnItemDragging |
Protected method | OnItemDragStarted |
Protected method | OnItemDragStarting |
Protected method | OnItemFormat | Raises the [E:ItemFormat] event.
Protected method | OnItemMouseDown | Raises the [E:ItemMouseDown] event.
Protected method | OnItemMouseUp | Raises the [E:ItemMouseUp] event.
Protected method | OnKeyDown | Raises the KeyDown event. (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Overrides Control..::..OnLostFocus(EventArgs).)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Overrides Control..::..OnMouseWheel(MouseEventArgs).)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Overrides Control..::..OnPaintBackground(PaintEventArgs).)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectedIndexChanged | Raises the SelectedIndexChanged event
Protected method | OnSelectedItemChanged |
Protected method | OnSelectedItemChanging |
Protected method | OnSelectedValueChanged | Raises the SelectedValueChanged event.
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | This member overrides Control.ProcessCmdKey. (Overrides Control..::..ProcessCmdKey(Message%, Keys).)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Public method | ReBind | Rebinds the ListBox control.
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveSort | Removes the sort.
Protected method | RenderListBox | Renders the list box.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Reverse | Reverses this instance.
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetItemCore | Sets the object with the specified index in the derived class.
Protected method | SetItemsCore | Sets the object with the specified index in the derived class.
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort(Boolean) | Sorts the specified ascending.
Public method | Sort(IComparer<(Of <<'(ListItem>)>>)) | Sorts the specified comparer.
Public method | Sort(Comparison<(Of <<'(ListItem>)>>)) | Sorts the specified comparison.
Public method | StartDraggingTimer | Starts the dragging timer.
Public method | StopDraggingTimer | Stops the dragging timer.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | backFill |
Protected field | displayBounds |
Protected field | isScrollBarUpdateRequired |
 | margin |
Protected field | theme |

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether animations are enabled for the control
Public property | AllowDragDrop | Gets or sets whether the Drag drop operation is enabled
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowMultipleSelection | Obsolete. Gets or sets a value indicating whether the multiple selection is enabled.
Public property | AllowSelection | Obsolete. Gets a value indicating whether the vListBox currently enables selection of list items.
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the BackColor property for the control (Overrides Control..::..BackColor.)
Public property | BackgroundImage | Gets or sets the BackgroundImage for the control (Overrides Control..::..BackgroundImage.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the BorderColor of the ListBox.
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for the vListBox control
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayMember | Gets or sets the display member associated to the vListBox.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropFeedbackColor | Gets or sets the color of the drop feedback.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HotTrack | Gets or sets whether the items change in appearance when the mouse passes over them
Public property | ImageList | Gets or sets the images to display on the vListBox items.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsUpdating |
Public property | ItemHeight | Gets or sets the height of the vListBox items.
Public property | Items | Gets the vListBox items collection.
Public property | ItemsSpacing |
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMaskListItem | Gets or sets the mask that determines which corners of a ListItem are rounded
Public property | RoundedCornersRadiusListItem | Gets or sets the rounded corners radius of the ListItems.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the selected index.
Public property | SelectedIndices | Gets the collection of selected indices.
Public property | SelectedItem | Gets or sets the selected item.
Public property | SelectedItems | Gets the collection of selected items.
Public property | SelectedValue |
Public property | SelectionMode | Gets or sets the selection mode.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmartScrollEnabled | Determines whether to use Smart scrolling
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the Theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property.
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the BorderColor
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets a string that specifies the property of the data source from which to draw the value.
Public property | VIBlendScrollBarsTheme | Gets or sets the theme of the treeview scrollbars using one of the built-in themes.
Public property | VIBlendTheme | Gets or sets the theme of the control to one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs Data Source is changed.
Public event | DisplayMemberChanged | Occurs when the DisplayMember has been changed.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawListItem | Occurs when an item is being painted.
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemDragEnded | Occurs when item's drag operation has ended.
Public event | ItemDragEnding | Occurs when item's drag operation is ending.
Public event | ItemDragging | Occurs when the drag item changes its location.
Public event | ItemDragStarted | Occurs when item's drag operation has started.
Public event | ItemDragStarting | Occurs when item's drag operation is starting.
Public event | ItemFormat | Occurs when the control's DataSource property is set and before the item is added to the Items collection. You can use this event to format the item's string.
Public event | ItemMouseDown | Occurs when the mouse is clicked over a ListItem.
Public event | ItemMouseUp | Occurs when the mouse is clicked over a ListItem.
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the selected index changes
Public event | SelectedItemChanged | occurs when the selection is changed.
Public event | SelectedItemChanging | Occurs when the selection is changing.
Public event | SelectedValueChanged | Occurs when the SelectedValue has changed.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vListBox Class


vListBox Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vListBox Constructor
vListBox Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vListBox()
Visual Basic
Public Sub New
Visual C++
public:
vListBox()

See Also

vListBox Class


vListBox Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox Fields
vListBox Class See Also Send Feedback

The vListBox type exposes the following members.

Fields

 | Name | Description
Protected field | backFill |
Protected field | displayBounds |
Protected field | isScrollBarUpdateRequired |
 | margin |
Protected field | theme |

See Also

vListBox Class


backFill Field

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..backFill Field
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected BackgroundElement backFill
Visual Basic
Protected backFill As BackgroundElement
Visual C++
protected:
BackgroundElement^ backFill

See Also

vListBox Class


displayBounds Field

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..displayBounds Field
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected Rectangle displayBounds
Visual Basic
Protected displayBounds As Rectangle
Visual C++
protected:
Rectangle displayBounds

See Also

vListBox Class


isScrollBarUpdateRequired Field

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..isScrollBarUpdateRequired Field
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected bool isScrollBarUpdateRequired
Visual Basic
Protected isScrollBarUpdateRequired As Boolean
Visual C++
protected:
bool isScrollBarUpdateRequired

See Also

vListBox Class


margin Field

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..margin Field
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected const int margin
Visual Basic
Protected Const margin As Integer
Visual C++
protected:
literal int margin

See Also

vListBox Class


theme Field

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..theme Field
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected ControlTheme theme
Visual Basic
Protected theme As ControlTheme
Visual C++
protected:
ControlTheme^ theme

See Also

vListBox Class


vListBox Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox Methods
vListBox Class See Also Send Feedback

The vListBox type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | BeginDrag | Begins the drag.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Begins a batch of changes on the items collection
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CanSelectMultipleItems | Determines whether this instance can select multiple items.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawDragFeedback(Graphics) |
 | DrawDragFeedback(Graphics, vListBox) | Draw
Public method | DrawItem |
Public method | DrawItemImage | Draws the item image.
Public method | DrawListItemBackGroundAndBorder | Draws the list item back ground and border.
Public method | DrawListItemTextAndDescription | Draws the list item text and description.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
 | DropItem(vListBox, vListBox, ListItem) | Drops the item.
 | DropItem(vListBox, vListBox, ListItem, ListBoxDropType) | Drops the item.
Protected method | EndDrag | Ends the drag.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Begins a batch of changes on the items collection previously started by BeginUpdate()
Public method | EnsureVisible | Ensures that a list view item is visible.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FilterItemOnProperty |
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindItem(Point) | Get ListItem at specific point.
 | FindItem(Point, vListBox) |
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Protected method | GetBackFillColor | Gets the color of the back fill.
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemFont | Gets the item font.
Public method | GetItemForeColor | Gets the color of the item fore.
Public method | GetItemImage | Gets the item image.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest | Performs a HitTest at a specific point
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Overrides Control..::..OnBindingContextChanged(EventArgs).)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDataSourceChanged | Raises the DataSourceChanged event
Protected method | OnDisplayMemberChanged | Raises the OnDisplayMemberChanged event
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawItem | Raises the DrawItem event.
Protected method | OnDrawListItem |
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemDragEnded |
Protected method | OnItemDragEnding |
Protected method | OnItemDragging |
Protected method | OnItemDragStarted |
Protected method | OnItemDragStarting |
Protected method | OnItemFormat | Raises the [E:ItemFormat] event.
Protected method | OnItemMouseDown | Raises the [E:ItemMouseDown] event.
Protected method | OnItemMouseUp | Raises the [E:ItemMouseUp] event.
Protected method | OnKeyDown | Raises the KeyDown event. (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Overrides Control..::..OnLostFocus(EventArgs).)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Overrides Control..::..OnMouseWheel(MouseEventArgs).)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Overrides Control..::..OnPaintBackground(PaintEventArgs).)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectedIndexChanged | Raises the SelectedIndexChanged event
Protected method | OnSelectedItemChanged |
Protected method | OnSelectedItemChanging |
Protected method | OnSelectedValueChanged | Raises the SelectedValueChanged event.
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | This member overrides Control.ProcessCmdKey. (Overrides Control..::..ProcessCmdKey(Message%, Keys).)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Public method | ReBind | Rebinds the ListBox control.
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveSort | Removes the sort.
Protected method | RenderListBox | Renders the list box.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Reverse | Reverses this instance.
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetItemCore | Sets the object with the specified index in the derived class.
Protected method | SetItemsCore | Sets the object with the specified index in the derived class.
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort(Boolean) | Sorts the specified ascending.
Public method | Sort(IComparer<(Of <<'(ListItem>)>>)) | Sorts the specified comparer.
Public method | Sort(Comparison<(Of <<'(ListItem>)>>)) | Sorts the specified comparison.
Public method | StartDraggingTimer | Starts the dragging timer.
Public method | StopDraggingTimer | Stops the dragging timer.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vListBox Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..AccessibilityNotifyClients Method
vListBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vListBox Class
vListBox Members


BeginDrag Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..BeginDrag Method
vListBox Class See Also Send Feedback
Begins the drag.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void BeginDrag(
    ListItem drag
)
Visual Basic
Protected Overridable Sub BeginDrag ( _
    drag As ListItem _
)
Visual C++
protected:
virtual void BeginDrag(
    ListItem^ drag
)

Parameters

drag
Type: VIBlend.WinForms.Controls..::..ListItem
The drag.

See Also

vListBox Class


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..BeginInvoke Method
vListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vListBox Class
vListBox Members


BeginUpdate Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..BeginUpdate Method
vListBox Class See Also Send Feedback
Begins a batch of changes on the items collection

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void BeginUpdate()
Visual Basic
Public Sub BeginUpdate
Visual C++
public:
void BeginUpdate()

See Also

vListBox Class


CanSelectMultipleItems Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..CanSelectMultipleItems Method
vListBox Class See Also Send Feedback
Determines whether this instance can select multiple items.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool CanSelectMultipleItems()
Visual Basic
Public Function CanSelectMultipleItems As Boolean
Visual C++
public:
bool CanSelectMultipleItems()

See Also

vListBox Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..Dispose Method
vListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vListBox Class
vListBox Members


DrawDragFeedback Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..DrawDragFeedback Method
vListBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | DrawDragFeedback(Graphics) |
 | DrawDragFeedback(Graphics, vListBox) | Draw

See Also

vListBox Class
vListBox Members


DrawDragFeedback Method (Graphics)

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..DrawDragFeedback Method (Graphics)
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void DrawDragFeedback(
    Graphics g
)
Visual Basic
Protected Friend Overridable Sub DrawDragFeedback ( _
    g As Graphics _
)
Visual C++
protected public:
virtual void DrawDragFeedback(
    Graphics^ g
)

Parameters

g
Type: System.Drawing..::..Graphics

See Also

vListBox Class
DrawDragFeedback Overload


DrawDragFeedback Method (Graphics, vListBox)

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..DrawDragFeedback Method (Graphics, vListBox)
vListBox Class See Also Send Feedback
Draw

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static void DrawDragFeedback(
    Graphics g,
    vListBox listBox
)
Visual Basic
Public Shared Sub DrawDragFeedback ( _
    g As Graphics, _
    listBox As vListBox _
)
Visual C++
public:
static void DrawDragFeedback(
    Graphics^ g,
    vListBox^ listBox
)

Parameters

g
Type: System.Drawing..::..Graphics
listBox
Type: VIBlend.WinForms.Controls..::..vListBox

See Also

vListBox Class
DrawDragFeedback Overload


DrawItem Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..DrawItem Method
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void DrawItem(
    Graphics graphics,
    Rectangle bounds,
    DrawItemState state,
    ListItem listItem
)
Visual Basic
Public Overridable Sub DrawItem ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    state As DrawItemState, _
    listItem As ListItem _
)
Visual C++
public:
virtual void DrawItem(
    Graphics^ graphics,
    Rectangle bounds,
    DrawItemState state,
    ListItem^ listItem
)

Parameters

graphics
Type: System.Drawing..::..Graphics
bounds
Type: System.Drawing..::..Rectangle
state
Type: System.Windows.Forms..::..DrawItemState
listItem
Type: VIBlend.WinForms.Controls..::..ListItem

See Also

vListBox Class


DrawItemImage Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..DrawItemImage Method
vListBox Class See Also Send Feedback
Draws the item image.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int DrawItemImage(
    Graphics graphics,
    Rectangle bounds,
    ListItem listItem,
    DrawItemState state
)
Visual Basic
Public Function DrawItemImage ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    listItem As ListItem, _
    state As DrawItemState _
) As Integer
Visual C++
public:
int DrawItemImage(
    Graphics^ graphics,
    Rectangle bounds,
    ListItem^ listItem,
    DrawItemState state
)

Parameters

graphics
Type: System.Drawing..::..Graphics
The graphics.
bounds
Type: System.Drawing..::..Rectangle
The bounds.
listItem
Type: VIBlend.WinForms.Controls..::..ListItem
The list item.
state
Type: System.Windows.Forms..::..DrawItemState
The state.

Return Value

See Also

vListBox Class


DrawListItemBackGroundAndBorder Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..DrawListItemBackGroundAndBorder Method
vListBox Class See Also Send Feedback
Draws the list item back ground and border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void DrawListItemBackGroundAndBorder(
    Graphics graphics,
    Rectangle bounds,
    ListItem listItem,
    DrawItemState drawState
)
Visual Basic
Public Overridable Sub DrawListItemBackGroundAndBorder ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    listItem As ListItem, _
    drawState As DrawItemState _
)
Visual C++
public:
virtual void DrawListItemBackGroundAndBorder(
    Graphics^ graphics,
    Rectangle bounds,
    ListItem^ listItem,
    DrawItemState drawState
)

Parameters

graphics
Type: System.Drawing..::..Graphics
The graphics.
bounds
Type: System.Drawing..::..Rectangle
The bounds.
listItem
Type: VIBlend.WinForms.Controls..::..ListItem
drawState
Type: System.Windows.Forms..::..DrawItemState
State of the draw.

See Also

vListBox Class


DrawListItemTextAndDescription Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..DrawListItemTextAndDescription Method
vListBox Class See Also Send Feedback
Draws the list item text and description.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void DrawListItemTextAndDescription(
    Graphics graphics,
    Rectangle bounds,
    ListItem listItem,
    DrawItemState state
)
Visual Basic
Public Overridable Sub DrawListItemTextAndDescription ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    listItem As ListItem, _
    state As DrawItemState _
)
Visual C++
public:
virtual void DrawListItemTextAndDescription(
    Graphics^ graphics,
    Rectangle bounds,
    ListItem^ listItem,
    DrawItemState state
)

Parameters

graphics
Type: System.Drawing..::..Graphics
The graphics.
bounds
Type: System.Drawing..::..Rectangle
The bounds.
listItem
Type: VIBlend.WinForms.Controls..::..ListItem
The list item.
state
Type: System.Windows.Forms..::..DrawItemState
The state.

See Also

vListBox Class


DropItem Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..DropItem Method
vListBox Class See Also Send Feedback

Overload List

Name | Description
DropItem(vListBox, vListBox, ListItem) | Drops the item.
DropItem(vListBox, vListBox, ListItem, ListBoxDropType) | Drops the item.

See Also

vListBox Class
vListBox Members


DropItem Method (vListBox, vListBox, ListItem)

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..DropItem Method (vListBox, vListBox, ListItem)
vListBox Class See Also Send Feedback
Drops the item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static void DropItem(
    vListBox sourceListBox,
    vListBox targetListBox,
    ListItem sourceItem
)
Visual Basic
Public Shared Sub DropItem ( _
    sourceListBox As vListBox, _
    targetListBox As vListBox, _
    sourceItem As ListItem _
)
Visual C++
public:
static void DropItem(
    vListBox^ sourceListBox,
    vListBox^ targetListBox,
    ListItem^ sourceItem
)

Parameters

sourceListBox
Type: VIBlend.WinForms.Controls..::..vListBox
The source list box.
targetListBox
Type: VIBlend.WinForms.Controls..::..vListBox
The target list box.
sourceItem
Type: VIBlend.WinForms.Controls..::..ListItem
The source item.

See Also

vListBox Class
DropItem Overload


DropItem Method (vListBox, vListBox, ListItem, )

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..DropItem Method (vListBox, vListBox, ListItem, )
vListBox Class See Also Send Feedback
Drops the item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static void DropItem(
    vListBox sourceListBox,
    vListBox targetListBox,
    ListItem sourceItem,
    ListBoxDropType dropType
)
Visual Basic
Public Shared Sub DropItem ( _
    sourceListBox As vListBox, _
    targetListBox As vListBox, _
    sourceItem As ListItem, _
    dropType As ListBoxDropType _
)
Visual C++
public:
static void DropItem(
    vListBox^ sourceListBox,
    vListBox^ targetListBox,
    ListItem^ sourceItem,
    ListBoxDropType dropType
)

Parameters

sourceListBox
Type: VIBlend.WinForms.Controls..::..vListBox
The source list box.
targetListBox
Type: VIBlend.WinForms.Controls..::..vListBox
The target list box.
sourceItem
Type: VIBlend.WinForms.Controls..::..ListItem
The source item.
dropType
Type: ListBoxDropType
Type of the drop.

See Also

vListBox Class
DropItem Overload


EndDrag Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..EndDrag Method
vListBox Class See Also Send Feedback
Ends the drag.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void EndDrag(
    ListItem dragItem,
    ListItem targetItem
)
Visual Basic
Protected Friend Overridable Sub EndDrag ( _
    dragItem As ListItem, _
    targetItem As ListItem _
)
Visual C++
protected public:
virtual void EndDrag(
    ListItem^ dragItem,
    ListItem^ targetItem
)

Parameters

dragItem
Type: VIBlend.WinForms.Controls..::..ListItem
The drag item.
targetItem
Type: VIBlend.WinForms.Controls..::..ListItem
The target item.

See Also

vListBox Class


EndUpdate Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..EndUpdate Method
vListBox Class See Also Send Feedback
Begins a batch of changes on the items collection previously started by BeginUpdate()

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void EndUpdate()
Visual Basic
Public Sub EndUpdate
Visual C++
public:
void EndUpdate()

See Also

vListBox Class


EnsureVisible Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..EnsureVisible Method
vListBox Class See Also Send Feedback
Ensures that a list view item is visible.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void EnsureVisible(
    int itemIndex
)
Visual Basic
Public Sub EnsureVisible ( _
    itemIndex As Integer _
)
Visual C++
public:
void EnsureVisible(
    int itemIndex
)

Parameters

itemIndex
Type: System..::..Int32
Index of the list view item that is to be visible.

See Also

vListBox Class


FilterItemOnProperty Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..FilterItemOnProperty Method
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected Object FilterItemOnProperty(
    Object item,
    string field
)
Visual Basic
Protected Function FilterItemOnProperty ( _
    item As Object, _
    field As String _
) As Object
Visual C++
protected:
Object^ FilterItemOnProperty(
    Object^ item,
    String^ field
)

Parameters

item
Type: System..::..Object
field
Type: System..::..String

See Also

vListBox Class


FindItem Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..FindItem Method
vListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindItem(Point) | Get ListItem at specific point.
 | FindItem(Point, vListBox) |

See Also

vListBox Class
vListBox Members


FindItem Method (Point)

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..FindItem Method (Point)
vListBox Class See Also Send Feedback
Get ListItem at specific point.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ListItem FindItem(
    Point point
)
Visual Basic
Public Function FindItem ( _
    point As Point _
) As ListItem
Visual C++
public:
ListItem^ FindItem(
    Point point
)

Parameters

point
Type: System.Drawing..::..Point

Return Value

See Also

vListBox Class
FindItem Overload


FindItem Method (Point, vListBox)

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..FindItem Method (Point, vListBox)
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static ListItem FindItem(
    Point point,
    vListBox listBox
)
Visual Basic
Public Shared Function FindItem ( _
    point As Point, _
    listBox As vListBox _
) As ListItem
Visual C++
public:
static ListItem^ FindItem(
    Point point,
    vListBox^ listBox
)

Parameters

point
Type: System.Drawing..::..Point
listBox
Type: VIBlend.WinForms.Controls..::..vListBox

See Also

vListBox Class
FindItem Overload


GetBackFillColor Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..GetBackFillColor Method
vListBox Class See Also Send Feedback
Gets the color of the back fill.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected Color GetBackFillColor()
Visual Basic
Protected Function GetBackFillColor As Color
Visual C++
protected:
Color GetBackFillColor()

Return Value

See Also

vListBox Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..GetChildAtPoint Method
vListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vListBox Class
vListBox Members


GetItemFont Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..GetItemFont Method
vListBox Class See Also Send Feedback
Gets the item font.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Font GetItemFont(
    ListItem item,
    DrawItemState state
)
Visual Basic
Public Overridable Function GetItemFont ( _
    item As ListItem, _
    state As DrawItemState _
) As Font
Visual C++
public:
virtual Font^ GetItemFont(
    ListItem^ item,
    DrawItemState state
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..ListItem
The item.
state
Type: System.Windows.Forms..::..DrawItemState
The state.

Return Value

See Also

vListBox Class


GetItemForeColor Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..GetItemForeColor Method
vListBox Class See Also Send Feedback
Gets the color of the item fore.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Color GetItemForeColor(
    ListItem item,
    DrawItemState state
)
Visual Basic
Public Overridable Function GetItemForeColor ( _
    item As ListItem, _
    state As DrawItemState _
) As Color
Visual C++
public:
virtual Color GetItemForeColor(
    ListItem^ item,
    DrawItemState state
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..ListItem
The item.
state
Type: System.Windows.Forms..::..DrawItemState
The state.

Return Value

See Also

vListBox Class


GetItemImage Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..GetItemImage Method
vListBox Class See Also Send Feedback
Gets the item image.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Image GetItemImage(
    ListItem listItem,
    DrawItemState state
)
Visual Basic
Public Function GetItemImage ( _
    listItem As ListItem, _
    state As DrawItemState _
) As Image
Visual C++
public:
Image^ GetItemImage(
    ListItem^ listItem,
    DrawItemState state
)

Parameters

listItem
Type: VIBlend.WinForms.Controls..::..ListItem
The list item.
state
Type: System.Windows.Forms..::..DrawItemState
The state.

Return Value

See Also

vListBox Class


HitTest Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..HitTest Method
vListBox Class See Also Send Feedback
Performs a HitTest at a specific point

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int HitTest(
    Point point
)
Visual Basic
Public Function HitTest ( _
    point As Point _
) As Integer
Visual C++
public:
int HitTest(
    Point point
)

Parameters

point
Type: System.Drawing..::..Point
The point where to perform the HitTest

Return Value

The zero-based index of the item located at the HitTest point. If there's no item at this point, the method returns -1.

See Also

vListBox Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..Invalidate Method
vListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vListBox Class
vListBox Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..Invoke Method
vListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vListBox Class
vListBox Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..MemberwiseClone Method
vListBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vListBox Class
vListBox Members


OnBindingContextChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnBindingContextChanged Method
vListBox Class See Also Send Feedback
Raises the BindingContextChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnBindingContextChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnBindingContextChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnBindingContextChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vListBox Class


OnDataSourceChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnDataSourceChanged Method
vListBox Class See Also Send Feedback
Raises the DataSourceChanged event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnDataSourceChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnDataSourceChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnDataSourceChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::..EventArgs
A EventArgs that contains the event data.

See Also

vListBox Class


OnDisplayMemberChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnDisplayMemberChanged Method
vListBox Class See Also Send Feedback
Raises the OnDisplayMemberChanged event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnDisplayMemberChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnDisplayMemberChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnDisplayMemberChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::..EventArgs
A EventArgs that contains the event data.

See Also

vListBox Class


OnDrawItem Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnDrawItem Method
vListBox Class See Also Send Feedback
Raises the DrawItem event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal void OnDrawItem(
    DrawItemEventArgs e
)
Visual Basic
Protected Friend Sub OnDrawItem ( _
    e As DrawItemEventArgs _
)
Visual C++
protected public:
void OnDrawItem(
    DrawItemEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..DrawItemEventArgs
A DrawItemEventArgs that contains the event data.

See Also

vListBox Class


OnDrawListItem Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnDrawListItem Method
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual bool OnDrawListItem(
    DrawItemEventArgs args
)
Visual Basic
Protected Overridable Function OnDrawListItem ( _
    args As DrawItemEventArgs _
) As Boolean
Visual C++
protected:
virtual bool OnDrawListItem(
    DrawItemEventArgs^ args
)

Parameters

args
Type: System.Windows.Forms..::..DrawItemEventArgs

See Also

vListBox Class


OnItemDragEnded Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnItemDragEnded Method
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnItemDragEnded(
    ListItemDragEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnItemDragEnded ( _
    args As ListItemDragEventArgs _
)
Visual C++
protected public:
virtual void OnItemDragEnded(
    ListItemDragEventArgs^ args
)

Parameters

args
Type: ListItemDragEventArgs

See Also

vListBox Class


OnItemDragEnding Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnItemDragEnding Method
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnItemDragEnding(
    ListItemDragCancelEventArgs args
)
Visual Basic
Protected Overridable Sub OnItemDragEnding ( _
    args As ListItemDragCancelEventArgs _
)
Visual C++
protected:
virtual void OnItemDragEnding(
    ListItemDragCancelEventArgs^ args
)

Parameters

args
Type: ListItemDragCancelEventArgs

See Also

vListBox Class


OnItemDragging Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnItemDragging Method
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnItemDragging(
    ListItemDragEventArgs args
)
Visual Basic
Protected Overridable Sub OnItemDragging ( _
    args As ListItemDragEventArgs _
)
Visual C++
protected:
virtual void OnItemDragging(
    ListItemDragEventArgs^ args
)

Parameters

args
Type: ListItemDragEventArgs

See Also

vListBox Class


OnItemDragStarted Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnItemDragStarted Method
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnItemDragStarted(
    ListItemDragEventArgs args
)
Visual Basic
Protected Overridable Sub OnItemDragStarted ( _
    args As ListItemDragEventArgs _
)
Visual C++
protected:
virtual void OnItemDragStarted(
    ListItemDragEventArgs^ args
)

Parameters

args
Type: ListItemDragEventArgs

See Also

vListBox Class


OnItemDragStarting Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnItemDragStarting Method
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnItemDragStarting(
    ListItemDragCancelEventArgs args
)
Visual Basic
Protected Overridable Sub OnItemDragStarting ( _
    args As ListItemDragCancelEventArgs _
)
Visual C++
protected:
virtual void OnItemDragStarting(
    ListItemDragCancelEventArgs^ args
)

Parameters

args
Type: ListItemDragCancelEventArgs

See Also

vListBox Class


OnItemFormat Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnItemFormat Method
vListBox Class See Also Send Feedback
Raises the [E:ItemFormat] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnItemFormat(
    ListItemFormatEventArgs args
)
Visual Basic
Protected Overridable Sub OnItemFormat ( _
    args As ListItemFormatEventArgs _
)
Visual C++
protected:
virtual void OnItemFormat(
    ListItemFormatEventArgs^ args
)

Parameters

args
Type: ListItemFormatEventArgs
The ListItemFormatEventArgs instance containing the event data.

See Also

vListBox Class


OnItemMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnItemMouseDown Method
vListBox Class See Also Send Feedback
Raises the [E:ItemMouseDown] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnItemMouseDown(
    ListItemMouseEventArgs args
)
Visual Basic
Protected Overridable Sub OnItemMouseDown ( _
    args As ListItemMouseEventArgs _
)
Visual C++
protected:
virtual void OnItemMouseDown(
    ListItemMouseEventArgs^ args
)

Parameters

args
Type: ListItemMouseEventArgs
The ListItemMouseEventArgs instance containing the event data.

See Also

vListBox Class


OnItemMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnItemMouseUp Method
vListBox Class See Also Send Feedback
Raises the [E:ItemMouseUp] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnItemMouseUp(
    ListItemMouseEventArgs args
)
Visual Basic
Protected Overridable Sub OnItemMouseUp ( _
    args As ListItemMouseEventArgs _
)
Visual C++
protected:
virtual void OnItemMouseUp(
    ListItemMouseEventArgs^ args
)

Parameters

args
Type: ListItemMouseEventArgs
The ListItemMouseEventArgs instance containing the event data.

See Also

vListBox Class


OnKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnKeyDown Method
vListBox Class See Also Send Feedback
Raises the KeyDown event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
A KeyEventArgs that contains the event data.

See Also

vListBox Class


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnLayout Method
vListBox Class See Also Send Feedback
Raises the Layout event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
A LayoutEventArgs that contains the event data.

See Also

vListBox Class


OnLostFocus Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnLostFocus Method
vListBox Class See Also Send Feedback
Raises the OnLostFocus event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLostFocus(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnLostFocus ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLostFocus(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vListBox Class


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnMouseDown Method
vListBox Class See Also Send Feedback
Raises the OnMouseDown event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs mevent
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    mevent As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ mevent
) override

Parameters

mevent
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vListBox Class


OnMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnMouseLeave Method
vListBox Class See Also Send Feedback
Raises the OnMouseLeave event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
A EventArgs that contains the event data.

See Also

vListBox Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnMouseMove Method
vListBox Class See Also Send Feedback
Raises the OnMouseMove event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs mevent
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    mevent As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ mevent
) override

Parameters

mevent
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vListBox Class


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnMouseUp Method
vListBox Class See Also Send Feedback
Raises the OnMouseUp event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs mevent
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    mevent As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ mevent
) override

Parameters

mevent
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vListBox Class


OnMouseWheel Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnMouseWheel Method
vListBox Class See Also Send Feedback
Raises the MouseWheel event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseWheel(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseWheel ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseWheel(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vListBox Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnPaint Method
vListBox Class See Also Send Feedback
Raises the OnPaint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vListBox Class


OnPaintBackground Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnPaintBackground Method
vListBox Class See Also Send Feedback
Paints the background of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaintBackground(
    PaintEventArgs pevent
)
Visual Basic
Protected Overrides Sub OnPaintBackground ( _
    pevent As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaintBackground(
    PaintEventArgs^ pevent
) override

Parameters

pevent
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains information about the control to paint.

See Also

vListBox Class


OnSelectedIndexChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnSelectedIndexChanged Method
vListBox Class See Also Send Feedback
Raises the SelectedIndexChanged event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnSelectedIndexChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnSelectedIndexChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSelectedIndexChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vListBox Class


OnSelectedItemChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnSelectedItemChanged Method
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnSelectedItemChanged()
Visual Basic
Protected Friend Overridable Sub OnSelectedItemChanged
Visual C++
protected public:
virtual void OnSelectedItemChanged()

See Also

vListBox Class


OnSelectedItemChanging Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnSelectedItemChanging Method
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnSelectedItemChanging(
    ListItemChangingEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnSelectedItemChanging ( _
    args As ListItemChangingEventArgs _
)
Visual C++
protected public:
virtual void OnSelectedItemChanging(
    ListItemChangingEventArgs^ args
)

Parameters

args
Type: ListItemChangingEventArgs

See Also

vListBox Class


OnSelectedValueChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..OnSelectedValueChanged Method
vListBox Class See Also Send Feedback
Raises the SelectedValueChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnSelectedValueChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnSelectedValueChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSelectedValueChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vListBox Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..PerformLayout Method
vListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vListBox Class
vListBox Members


ProcessCmdKey Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..ProcessCmdKey Method
vListBox Class See Also Send Feedback
This member overrides Control.ProcessCmdKey.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override bool ProcessCmdKey(
    ref Message msg,
    Keys keyData
)
Visual Basic
Protected Overrides Function ProcessCmdKey ( _
    ByRef msg As Message, _
    keyData As Keys _
) As Boolean
Visual C++
protected:
virtual bool ProcessCmdKey(
    Message% msg,
    Keys keyData
) override

Parameters

msg
Type: System.Windows.Forms..::..Message %
A Message, passed by reference, that represents the window message to process.
keyData
Type: System.Windows.Forms..::..Keys
One of the Keys values that represents the key to process.

Return Value

true if the character was processed by the control; otherwise, false.

See Also

vListBox Class


ReBind Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..ReBind Method
vListBox Class See Also Send Feedback
Rebinds the ListBox control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ReBind()
Visual Basic
Public Sub ReBind
Visual C++
public:
void ReBind()

See Also

vListBox Class


RemoveSort Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..RemoveSort Method
vListBox Class See Also Send Feedback
Removes the sort.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void RemoveSort()
Visual Basic
Public Sub RemoveSort
Visual C++
public:
void RemoveSort()

See Also

vListBox Class


RenderListBox Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..RenderListBox Method
vListBox Class See Also Send Feedback
Renders the list box.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void RenderListBox(
    PaintEventArgs e
)
Visual Basic
Protected Overridable Sub RenderListBox ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void RenderListBox(
    PaintEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
The PaintEventArgs instance containing the event data.

See Also

vListBox Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..ResumeLayout Method
vListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vListBox Class
vListBox Members


Reverse Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..Reverse Method
vListBox Class See Also Send Feedback
Reverses this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Reverse()
Visual Basic
Public Sub Reverse
Visual C++
public:
void Reverse()

See Also

vListBox Class


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..RtlTranslateAlignment Method
vListBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vListBox Class
vListBox Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..Scale Method
vListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vListBox Class
vListBox Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..Select Method
vListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vListBox Class
vListBox Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..SetBounds Method
vListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vListBox Class
vListBox Members


SetItemCore Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..SetItemCore Method
vListBox Class See Also Send Feedback
Sets the object with the specified index in the derived class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void SetItemCore(
    int index,
    Object value
)
Visual Basic
Protected Overridable Sub SetItemCore ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void SetItemCore(
    int index,
    Object^ value
)

Parameters

index
Type: System..::..Int32
The array index of the object.
value
Type: System..::..Object
The object.

See Also

vListBox Class


SetItemsCore Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..SetItemsCore Method
vListBox Class See Also Send Feedback
Sets the object with the specified index in the derived class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void SetItemsCore(
    IList list
)
Visual Basic
Protected Overridable Sub SetItemsCore ( _
    list As IList _
)
Visual C++
protected:
virtual void SetItemsCore(
    IList^ list
)

Parameters

list
Type: System.Collections..::..IList

See Also

vListBox Class


Sort Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..Sort Method
vListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort(Boolean) | Sorts the specified ascending.
Public method | Sort(IComparer<(Of <<'(ListItem>)>>)) | Sorts the specified comparer.
Public method | Sort(Comparison<(Of <<'(ListItem>)>>)) | Sorts the specified comparison.

See Also

vListBox Class
vListBox Members


Sort Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..Sort Method (Boolean)
vListBox Class See Also Send Feedback
Sorts the specified ascending.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Sort(
    bool ascending
)
Visual Basic
Public Sub Sort ( _
    ascending As Boolean _
)
Visual C++
public:
void Sort(
    bool ascending
)

Parameters

ascending
Type: System..::..Boolean
if set to true ascending.

See Also

vListBox Class
Sort Overload


Sort Method (IComparer(ListItem))

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..Sort Method (IComparer<(Of <(<'ListItem>)>)>)
vListBox Class See Also Send Feedback
Sorts the specified comparer.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Sort(
    IComparer<ListItem> comparer
)
Visual Basic
Public Sub Sort ( _
    comparer As IComparer(Of ListItem) _
)
Visual C++
public:
void Sort(
    IComparer<ListItem^>^ comparer
)

Parameters

comparer
Type: System.Collections.Generic..::..IComparer <(Of <(<' ListItem >)>)>
The comparer.

See Also

vListBox Class
Sort Overload


Sort Method (Comparison(ListItem))

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..Sort Method (Comparison<(Of <(<'ListItem>)>)>)
vListBox Class See Also Send Feedback
Sorts the specified comparison.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Sort(
    Comparison<ListItem> comparison
)
Visual Basic
Public Sub Sort ( _
    comparison As Comparison(Of ListItem) _
)
Visual C++
public:
void Sort(
    Comparison<ListItem^>^ comparison
)

Parameters

comparison
Type: System..::..Comparison <(Of <(<' ListItem >)>)>
The comparison.

See Also

vListBox Class
Sort Overload


StartDraggingTimer Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..StartDraggingTimer Method
vListBox Class See Also Send Feedback
Starts the dragging timer.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void StartDraggingTimer()
Visual Basic
Public Sub StartDraggingTimer
Visual C++
public:
void StartDraggingTimer()

See Also

vListBox Class


StopDraggingTimer Method

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..StopDraggingTimer Method
vListBox Class See Also Send Feedback
Stops the dragging timer.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void StopDraggingTimer()
Visual Basic
Public Sub StopDraggingTimer
Visual C++
public:
void StopDraggingTimer()

See Also

vListBox Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..UpdateBounds Method
vListBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vListBox Class
vListBox Members


vListBox Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox Properties
vListBox Class See Also Send Feedback

The vListBox type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether animations are enabled for the control
Public property | AllowDragDrop | Gets or sets whether the Drag drop operation is enabled
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowMultipleSelection | Obsolete. Gets or sets a value indicating whether the multiple selection is enabled.
Public property | AllowSelection | Obsolete. Gets a value indicating whether the vListBox currently enables selection of list items.
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the BackColor property for the control (Overrides Control..::..BackColor.)
Public property | BackgroundImage | Gets or sets the BackgroundImage for the control (Overrides Control..::..BackgroundImage.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the BorderColor of the ListBox.
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for the vListBox control
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayMember | Gets or sets the display member associated to the vListBox.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropFeedbackColor | Gets or sets the color of the drop feedback.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HotTrack | Gets or sets whether the items change in appearance when the mouse passes over them
Public property | ImageList | Gets or sets the images to display on the vListBox items.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsUpdating |
Public property | ItemHeight | Gets or sets the height of the vListBox items.
Public property | Items | Gets the vListBox items collection.
Public property | ItemsSpacing |
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMaskListItem | Gets or sets the mask that determines which corners of a ListItem are rounded
Public property | RoundedCornersRadiusListItem | Gets or sets the rounded corners radius of the ListItems.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the selected index.
Public property | SelectedIndices | Gets the collection of selected indices.
Public property | SelectedItem | Gets or sets the selected item.
Public property | SelectedItems | Gets the collection of selected items.
Public property | SelectedValue |
Public property | SelectionMode | Gets or sets the selection mode.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmartScrollEnabled | Determines whether to use Smart scrolling
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the Theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property.
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the BorderColor
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets a string that specifies the property of the data source from which to draw the value.
Public property | VIBlendScrollBarsTheme | Gets or sets the theme of the treeview scrollbars using one of the built-in themes.
Public property | VIBlendTheme | Gets or sets the theme of the control to one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vListBox Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..AllowAnimations Property
vListBox Class See Also Send Feedback
Determines whether animations are enabled for the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vListBox Class


AllowDragDrop Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..AllowDragDrop Property
vListBox Class See Also Send Feedback
Gets or sets whether the Drag drop operation is enabled

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowDragDrop { get; set; }
Visual Basic
Public Property AllowDragDrop As Boolean
    Get
    Set
Visual C++
public:
property bool AllowDragDrop {
    bool get ();
    void set (bool value);
}

See Also

vListBox Class


AllowMultipleSelection Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..AllowMultipleSelection Property
vListBox Class See Also Send Feedback
Gets or sets a value indicating whether the multiple selection is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[ObsoleteAttribute("Use the SelectionMode property instead.")]
public bool AllowMultipleSelection { get; set; }
Visual Basic
<ObsoleteAttribute("Use the SelectionMode property instead.")> _
Public Property AllowMultipleSelection As Boolean
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Use the SelectionMode property instead.")]
public:
property bool AllowMultipleSelection {
    bool get ();
    void set (bool value);
}

See Also

vListBox Class


AllowSelection Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..AllowSelection Property
vListBox Class See Also Send Feedback
Gets a value indicating whether the vListBox currently enables selection of list items.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[ObsoleteAttribute("Use the SelectionMode property instead.")]
public bool AllowSelection { get; set; }
Visual Basic
<ObsoleteAttribute("Use the SelectionMode property instead.")> _
Public Property AllowSelection As Boolean
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Use the SelectionMode property instead.")]
public:
property bool AllowSelection {
    bool get ();
    void set (bool value);
}

See Also

vListBox Class


BackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..BackColor Property
vListBox Class See Also Send Feedback
Gets or sets the BackColor property for the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color BackColor { get; set; }
Visual Basic
Public Overrides Property BackColor As Color
    Get
    Set
Visual C++
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}

See Also

vListBox Class


BackgroundImage Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..BackgroundImage Property
vListBox Class See Also Send Feedback
Gets or sets the BackgroundImage for the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Image BackgroundImage { get; set; }
Visual Basic
Public Overrides Property BackgroundImage As Image
    Get
    Set
Visual C++
public:
virtual property Image^ BackgroundImage {
    Image^ get () override;
    void set (Image^ value) override;
}

See Also

vListBox Class


BorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..BorderColor Property
vListBox Class See Also Send Feedback
Gets or sets the BorderColor of the ListBox.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Color BorderColor { get; set; }
Visual Basic
Public Overridable Property BorderColor As Color
    Get
    Set
Visual C++
public:
virtual property Color BorderColor {
    Color get ();
    void set (Color value);
}

See Also

vListBox Class


DataSource Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..DataSource Property
vListBox Class See Also Send Feedback
Gets or sets the data source for the vListBox control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object DataSource { get; set; }
Visual Basic
Public Property DataSource As Object
    Get
    Set
Visual C++
public:
property Object^ DataSource {
    Object^ get ();
    void set (Object^ value);
}

See Also

vListBox Class


DisplayMember Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..DisplayMember Property
vListBox Class See Also Send Feedback
Gets or sets the display member associated to the vListBox.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string DisplayMember { get; set; }
Visual Basic
Public Property DisplayMember As String
    Get
    Set
Visual C++
public:
property String^ DisplayMember {
    String^ get ();
    void set (String^ value);
}

See Also

vListBox Class


DropFeedbackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..DropFeedbackColor Property
vListBox Class See Also Send Feedback
Gets or sets the color of the drop feedback.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DropFeedbackColor { get; set; }
Visual Basic
Public Property DropFeedbackColor As Color
    Get
    Set
Visual C++
public:
property Color DropFeedbackColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the drop feedback.

See Also

vListBox Class


HotTrack Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..HotTrack Property
vListBox Class See Also Send Feedback
Gets or sets whether the items change in appearance when the mouse passes over them

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool HotTrack { get; set; }
Visual Basic
Public Property HotTrack As Boolean
    Get
    Set
Visual C++
public:
property bool HotTrack {
    bool get ();
    void set (bool value);
}

See Also

vListBox Class


ImageList Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..ImageList Property
vListBox Class See Also Send Feedback
Gets or sets the images to display on the vListBox items.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ImageList ImageList { get; set; }
Visual Basic
Public Property ImageList As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ ImageList {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

vListBox Class


IsUpdating Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..IsUpdating Property
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsUpdating { get; }
Visual Basic
Public ReadOnly Property IsUpdating As Boolean
    Get
Visual C++
public:
property bool IsUpdating {
    bool get ();
}

See Also

vListBox Class


ItemHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..ItemHeight Property
vListBox Class See Also Send Feedback
Gets or sets the height of the vListBox items.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ItemHeight { get; set; }
Visual Basic
Public Property ItemHeight As Integer
    Get
    Set
Visual C++
public:
property int ItemHeight {
    int get ();
    void set (int value);
}

See Also

vListBox Class


Items Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..Items Property
vListBox Class See Also Send Feedback
Gets the vListBox items collection.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ListItemsCollection Items { get; }
Visual Basic
Public ReadOnly Property Items As ListItemsCollection
    Get
Visual C++
public:
property ListItemsCollection^ Items {
    ListItemsCollection^ get ();
}

See Also

vListBox Class


ItemsSpacing Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..ItemsSpacing Property
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ItemsSpacing { get; set; }
Visual Basic
Public Property ItemsSpacing As Integer
    Get
    Set
Visual C++
public:
property int ItemsSpacing {
    int get ();
    void set (int value);
}

See Also

vListBox Class


RoundedCornersMaskListItem Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..RoundedCornersMaskListItem Property
vListBox Class See Also Send Feedback
Gets or sets the mask that determines which corners of a ListItem are rounded

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public byte RoundedCornersMaskListItem { get; set; }
Visual Basic
Public Property RoundedCornersMaskListItem As Byte
    Get
    Set
Visual C++
public:
property unsigned char RoundedCornersMaskListItem {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

vListBox Class


RoundedCornersRadiusListItem Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..RoundedCornersRadiusListItem Property
vListBox Class See Also Send Feedback
Gets or sets the rounded corners radius of the ListItems.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int RoundedCornersRadiusListItem { get; set; }
Visual Basic
Public Property RoundedCornersRadiusListItem As Integer
    Get
    Set
Visual C++
public:
property int RoundedCornersRadiusListItem {
    int get ();
    void set (int value);
}

See Also

vListBox Class


SelectedIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..SelectedIndex Property
vListBox Class See Also Send Feedback
Gets or sets the selected index.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic
Public Property SelectedIndex As Integer
    Get
    Set
Visual C++
public:
property int SelectedIndex {
    int get ();
    void set (int value);
}

See Also

vListBox Class


SelectedIndices Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..SelectedIndices Property
vListBox Class See Also Send Feedback
Gets the collection of selected indices.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<int> SelectedIndices { get; }
Visual Basic
Public ReadOnly Property SelectedIndices As List(Of Integer)
    Get
Visual C++
public:
property List<int>^ SelectedIndices {
    List<int>^ get ();
}

See Also

vListBox Class


SelectedItem Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..SelectedItem Property
vListBox Class See Also Send Feedback
Gets or sets the selected item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ListItem SelectedItem { get; set; }
Visual Basic
Public Property SelectedItem As ListItem
    Get
    Set
Visual C++
public:
property ListItem^ SelectedItem {
    ListItem^ get ();
    void set (ListItem^ value);
}

See Also

vListBox Class


SelectedItems Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..SelectedItems Property
vListBox Class See Also Send Feedback
Gets the collection of selected items.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ListItemsCollection SelectedItems { get; }
Visual Basic
Public ReadOnly Property SelectedItems As ListItemsCollection
    Get
Visual C++
public:
property ListItemsCollection^ SelectedItems {
    ListItemsCollection^ get ();
}

See Also

vListBox Class


SelectedValue Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..SelectedValue Property
vListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object SelectedValue { get; set; }
Visual Basic
Public Property SelectedValue As Object
    Get
    Set
Visual C++
public:
property Object^ SelectedValue {
    Object^ get ();
    void set (Object^ value);
}

See Also

vListBox Class


SelectionMode Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..SelectionMode Property
vListBox Class See Also Send Feedback
Gets or sets the selection mode.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual SelectionMode SelectionMode { get; set; }
Visual Basic
Public Overridable Property SelectionMode As SelectionMode
    Get
    Set
Visual C++
public:
virtual property SelectionMode SelectionMode {
    SelectionMode get ();
    void set (SelectionMode value);
}

Field Value

The selection mode.

See Also

vListBox Class


SmartScrollEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..SmartScrollEnabled Property
vListBox Class See Also Send Feedback
Determines whether to use Smart scrolling

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool SmartScrollEnabled { get; set; }
Visual Basic
Public Property SmartScrollEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool SmartScrollEnabled {
    bool get ();
    void set (bool value);
}

See Also

vListBox Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..Theme Property
vListBox Class See Also Send Feedback
Gets or sets the Theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vListBox Class


UseThemeBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..UseThemeBackColor Property
vListBox Class See Also Send Feedback
Gets or sets whether to use the Theme BackColor or the control's BackColor property.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBackColor { get; set; }
Visual Basic
Public Property UseThemeBackColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBackColor {
    bool get ();
    void set (bool value);
}

See Also

vListBox Class


UseThemeBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..UseThemeBorderColor Property
vListBox Class See Also Send Feedback
Gets or sets a value indicating whether to use the BorderColor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool UseThemeBorderColor { get; set; }
Visual Basic
Public Overridable Property UseThemeBorderColor As Boolean
    Get
    Set
Visual C++
public:
virtual property bool UseThemeBorderColor {
    bool get ();
    void set (bool value);
}

See Also

vListBox Class


ValueMember Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..ValueMember Property
vListBox Class See Also Send Feedback
Gets or sets a string that specifies the property of the data source from which to draw the value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string ValueMember { get; set; }
Visual Basic
Public Property ValueMember As String
    Get
    Set
Visual C++
public:
property String^ ValueMember {
    String^ get ();
    void set (String^ value);
}

See Also

vListBox Class


VIBlendScrollBarsTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..VIBlendScrollBarsTheme Property
vListBox Class See Also Send Feedback
Gets or sets the theme of the treeview scrollbars using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendScrollBarsTheme { get; set; }
Visual Basic
Public Property VIBlendScrollBarsTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendScrollBarsTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vListBox Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..VIBlendTheme Property
vListBox Class See Also Send Feedback
Gets or sets the theme of the control to one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vListBox Class


vListBox Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vListBox Events
vListBox Class See Also Send Feedback

The vListBox type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs Data Source is changed.
Public event | DisplayMemberChanged | Occurs when the DisplayMember has been changed.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawListItem | Occurs when an item is being painted.
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemDragEnded | Occurs when item's drag operation has ended.
Public event | ItemDragEnding | Occurs when item's drag operation is ending.
Public event | ItemDragging | Occurs when the drag item changes its location.
Public event | ItemDragStarted | Occurs when item's drag operation has started.
Public event | ItemDragStarting | Occurs when item's drag operation is starting.
Public event | ItemFormat | Occurs when the control's DataSource property is set and before the item is added to the Items collection. You can use this event to format the item's string.
Public event | ItemMouseDown | Occurs when the mouse is clicked over a ListItem.
Public event | ItemMouseUp | Occurs when the mouse is clicked over a ListItem.
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the selected index changes
Public event | SelectedItemChanged | occurs when the selection is changed.
Public event | SelectedItemChanging | Occurs when the selection is changing.
Public event | SelectedValueChanged | Occurs when the SelectedValue has changed.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vListBox Class


DataSourceChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..DataSourceChanged Event
vListBox Class See Also Send Feedback
Occurs Data Source is changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler DataSourceChanged
Visual Basic
Public Event DataSourceChanged As EventHandler
Visual C++
public:
 event EventHandler^ DataSourceChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vListBox Class


DisplayMemberChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..DisplayMemberChanged Event
vListBox Class See Also Send Feedback
Occurs when the DisplayMember has been changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler DisplayMemberChanged
Visual Basic
Public Event DisplayMemberChanged As EventHandler
Visual C++
public:
 event EventHandler^ DisplayMemberChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vListBox Class


DrawListItem Event

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..DrawListItem Event
vListBox Class See Also Send Feedback
Occurs when an item is being painted.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event DrawItemEventHandler DrawListItem
Visual Basic
Public Event DrawListItem As DrawItemEventHandler
Visual C++
public:
 event DrawItemEventHandler^ DrawListItem {
    void add (DrawItemEventHandler^ value);
    void remove (DrawItemEventHandler^ value);
}

See Also

vListBox Class


ItemDragEnded Event

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..ItemDragEnded Event
vListBox Class See Also Send Feedback
Occurs when item's drag operation has ended.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<ListItemDragEventArgs> ItemDragEnded
Visual Basic
Public Event ItemDragEnded As EventHandler(Of ListItemDragEventArgs)
Visual C++
public:
 event EventHandler<ListItemDragEventArgs^>^ ItemDragEnded {
    void add (EventHandler<ListItemDragEventArgs^>^ value);
    void remove (EventHandler<ListItemDragEventArgs^>^ value);
}

See Also

vListBox Class


ItemDragEnding Event

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..ItemDragEnding Event
vListBox Class See Also Send Feedback
Occurs when item's drag operation is ending.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<ListItemDragCancelEventArgs> ItemDragEnding
Visual Basic
Public Event ItemDragEnding As EventHandler(Of ListItemDragCancelEventArgs)
Visual C++
public:
 event EventHandler<ListItemDragCancelEventArgs^>^ ItemDragEnding {
    void add (EventHandler<ListItemDragCancelEventArgs^>^ value);
    void remove (EventHandler<ListItemDragCancelEventArgs^>^ value);
}

See Also

vListBox Class


ItemDragging Event

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..ItemDragging Event
vListBox Class See Also Send Feedback
Occurs when the drag item changes its location.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<ListItemDragEventArgs> ItemDragging
Visual Basic
Public Event ItemDragging As EventHandler(Of ListItemDragEventArgs)
Visual C++
public:
 event EventHandler<ListItemDragEventArgs^>^ ItemDragging {
    void add (EventHandler<ListItemDragEventArgs^>^ value);
    void remove (EventHandler<ListItemDragEventArgs^>^ value);
}

See Also

vListBox Class


ItemDragStarted Event

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..ItemDragStarted Event
vListBox Class See Also Send Feedback
Occurs when item's drag operation has started.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<ListItemDragEventArgs> ItemDragStarted
Visual Basic
Public Event ItemDragStarted As EventHandler(Of ListItemDragEventArgs)
Visual C++
public:
 event EventHandler<ListItemDragEventArgs^>^ ItemDragStarted {
    void add (EventHandler<ListItemDragEventArgs^>^ value);
    void remove (EventHandler<ListItemDragEventArgs^>^ value);
}

See Also

vListBox Class


ItemDragStarting Event

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..ItemDragStarting Event
vListBox Class See Also Send Feedback
Occurs when item's drag operation is starting.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<ListItemDragCancelEventArgs> ItemDragStarting
Visual Basic
Public Event ItemDragStarting As EventHandler(Of ListItemDragCancelEventArgs)
Visual C++
public:
 event EventHandler<ListItemDragCancelEventArgs^>^ ItemDragStarting {
    void add (EventHandler<ListItemDragCancelEventArgs^>^ value);
    void remove (EventHandler<ListItemDragCancelEventArgs^>^ value);
}

See Also

vListBox Class


ItemFormat Event

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..ItemFormat Event
vListBox Class See Also Send Feedback
Occurs when the control's DataSource property is set and before the item is added to the Items collection. You can use this event to format the item's string.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<ListItemFormatEventArgs> ItemFormat
Visual Basic
Public Event ItemFormat As EventHandler(Of ListItemFormatEventArgs)
Visual C++
public:
 event EventHandler<ListItemFormatEventArgs^>^ ItemFormat {
    void add (EventHandler<ListItemFormatEventArgs^>^ value);
    void remove (EventHandler<ListItemFormatEventArgs^>^ value);
}

See Also

vListBox Class


ItemMouseDown Event

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..ItemMouseDown Event
vListBox Class See Also Send Feedback
Occurs when the mouse is clicked over a ListItem.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<ListItemMouseEventArgs> ItemMouseDown
Visual Basic
Public Event ItemMouseDown As EventHandler(Of ListItemMouseEventArgs)
Visual C++
public:
 event EventHandler<ListItemMouseEventArgs^>^ ItemMouseDown {
    void add (EventHandler<ListItemMouseEventArgs^>^ value);
    void remove (EventHandler<ListItemMouseEventArgs^>^ value);
}

See Also

vListBox Class


ItemMouseUp Event

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..ItemMouseUp Event
vListBox Class See Also Send Feedback
Occurs when the mouse is clicked over a ListItem.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<ListItemMouseEventArgs> ItemMouseUp
Visual Basic
Public Event ItemMouseUp As EventHandler(Of ListItemMouseEventArgs)
Visual C++
public:
 event EventHandler<ListItemMouseEventArgs^>^ ItemMouseUp {
    void add (EventHandler<ListItemMouseEventArgs^>^ value);
    void remove (EventHandler<ListItemMouseEventArgs^>^ value);
}

See Also

vListBox Class


SelectedIndexChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..SelectedIndexChanged Event
vListBox Class See Also Send Feedback
Occurs when the selected index changes

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler SelectedIndexChanged
Visual Basic
Public Event SelectedIndexChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectedIndexChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vListBox Class


SelectedItemChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..SelectedItemChanged Event
vListBox Class See Also Send Feedback
occurs when the selection is changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler SelectedItemChanged
Visual Basic
Public Event SelectedItemChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectedItemChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vListBox Class


SelectedItemChanging Event

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..SelectedItemChanging Event
vListBox Class See Also Send Feedback
Occurs when the selection is changing.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<ListItemChangingEventArgs> SelectedItemChanging
Visual Basic
Public Event SelectedItemChanging As EventHandler(Of ListItemChangingEventArgs)
Visual C++
public:
 event EventHandler<ListItemChangingEventArgs^>^ SelectedItemChanging {
    void add (EventHandler<ListItemChangingEventArgs^>^ value);
    void remove (EventHandler<ListItemChangingEventArgs^>^ value);
}

See Also

vListBox Class


SelectedValueChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vListBox..::..SelectedValueChanged Event
vListBox Class See Also Send Feedback
Occurs when the SelectedValue has changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler SelectedValueChanged
Visual Basic
Public Event SelectedValueChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectedValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vListBox Class


vMaskedTextBox Class

[image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox Class
Members See Also Send Feedback
Represents a vMaskedTextBox control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vMaskedTextBox : Control,
    IScrollableControlBase
Visual Basic
Public Class vMaskedTextBox _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class vMaskedTextBox : public Control,
    IScrollableControlBase

Remarks

Displays an editable text field, which contains a mask that allows the control to distinguish between proper and improper input.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vMaskedTextBox
VIBlend.WinForms.DataGridView..::..MaskEditor

See Also

vMaskedTextBox Members


vMaskedTextBox Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox Members
vMaskedTextBox Class Constructors Methods Properties Events See Also Send Feedback

The vMaskedTextBox type exposes the following members.

Constructors

 | Name | Description
Public method | vMaskedTextBox | vMaskedTextBox Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Public property | DefaultMask | Gets or sets the default mask of the vMaskedTextBox control.
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamRadius | Gets or sets the radius of the gleam.
Public property | GleamWidth | Gets or sets the width of the gleam.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Mask | Gets or sets the mask.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum length of the text in the textbox.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | PromptChar | Gets or sets the prompt char.
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Overrides Control..::..RightToLeft.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SyncBackColorWithParentBackColor | Gets or sets a value indicating whether to sync the back color with parent's back color.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Overrides Control..::..Text.)
Public property | TextBox | Gets a reference to the TextBox of the vMaskBox control
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vMaskedTextBox Class


vMaskedTextBox Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox Constructor
vMaskedTextBox Class See Also Send Feedback
vMaskedTextBox Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vMaskedTextBox()
Visual Basic
Public Sub New
Visual C++
public:
vMaskedTextBox()

See Also

vMaskedTextBox Class


vMaskedTextBox Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox Methods
vMaskedTextBox Class See Also Send Feedback

The vMaskedTextBox type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vMaskedTextBox Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..AccessibilityNotifyClients Method
vMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vMaskedTextBox Class
vMaskedTextBox Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..BeginInvoke Method
vMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vMaskedTextBox Class
vMaskedTextBox Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..Dispose Method
vMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vMaskedTextBox Class
vMaskedTextBox Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..GetChildAtPoint Method
vMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vMaskedTextBox Class
vMaskedTextBox Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..Invalidate Method
vMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vMaskedTextBox Class
vMaskedTextBox Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..Invoke Method
vMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vMaskedTextBox Class
vMaskedTextBox Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..MemberwiseClone Method
vMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vMaskedTextBox Class
vMaskedTextBox Members


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..PerformLayout Method
vMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vMaskedTextBox Class
vMaskedTextBox Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..ResumeLayout Method
vMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vMaskedTextBox Class
vMaskedTextBox Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..RtlTranslateAlignment Method
vMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vMaskedTextBox Class
vMaskedTextBox Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..Scale Method
vMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vMaskedTextBox Class
vMaskedTextBox Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..Select Method
vMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vMaskedTextBox Class
vMaskedTextBox Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..SetBounds Method
vMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vMaskedTextBox Class
vMaskedTextBox Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..UpdateBounds Method
vMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vMaskedTextBox Class
vMaskedTextBox Members


vMaskedTextBox Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox Properties
vMaskedTextBox Class See Also Send Feedback

The vMaskedTextBox type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Public property | DefaultMask | Gets or sets the default mask of the vMaskedTextBox control.
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamRadius | Gets or sets the radius of the gleam.
Public property | GleamWidth | Gets or sets the width of the gleam.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Mask | Gets or sets the mask.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum length of the text in the textbox.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | PromptChar | Gets or sets the prompt char.
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Overrides Control..::..RightToLeft.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SyncBackColorWithParentBackColor | Gets or sets a value indicating whether to sync the back color with parent's back color.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Overrides Control..::..Text.)
Public property | TextBox | Gets a reference to the TextBox of the vMaskBox control
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vMaskedTextBox Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..AllowAnimations Property
vMaskedTextBox Class See Also Send Feedback
Gets or sets whether the control is animated

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vMaskedTextBox Class


DefaultMask Property

[image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..DefaultMask Property
vMaskedTextBox Class See Also Send Feedback
Gets or sets the default mask of the vMaskedTextBox control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DefaultMasks DefaultMask { get; set; }
Visual Basic
Public Property DefaultMask As DefaultMasks
    Get
    Set
Visual C++
public:
property DefaultMasks DefaultMask {
    DefaultMasks get ();
    void set (DefaultMasks value);
}

See Also

vMaskedTextBox Class


GleamRadius Property

[image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..GleamRadius Property
vMaskedTextBox Class See Also Send Feedback
Gets or sets the radius of the gleam.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int GleamRadius { get; set; }
Visual Basic
Public Property GleamRadius As Integer
    Get
    Set
Visual C++
public:
property int GleamRadius {
    int get ();
    void set (int value);
}

See Also

vMaskedTextBox Class


GleamWidth Property

[image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..GleamWidth Property
vMaskedTextBox Class See Also Send Feedback
Gets or sets the width of the gleam.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int GleamWidth { get; set; }
Visual Basic
Public Property GleamWidth As Integer
    Get
    Set
Visual C++
public:
property int GleamWidth {
    int get ();
    void set (int value);
}

See Also

vMaskedTextBox Class


Mask Property

[image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..Mask Property
vMaskedTextBox Class See Also Send Feedback
Gets or sets the mask.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Mask { get; set; }
Visual Basic
Public Property Mask As String
    Get
    Set
Visual C++
public:
property String^ Mask {
    String^ get ();
    void set (String^ value);
}

Field Value

The mask.

See Also

vMaskedTextBox Class


MaxLength Property

[image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..MaxLength Property
vMaskedTextBox Class See Also Send Feedback
Gets or sets the maximum length of the text in the textbox.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int MaxLength { get; set; }
Visual Basic
Public Property MaxLength As Integer
    Get
    Set
Visual C++
public:
property int MaxLength {
    int get ();
    void set (int value);
}

See Also

vMaskedTextBox Class


Multiline Property

[image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..Multiline Property
vMaskedTextBox Class See Also Send Feedback
Gets or sets whether the vTextBox has multiple lines.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Multiline { get; set; }
Visual Basic
Public Property Multiline As Boolean
    Get
    Set
Visual C++
public:
property bool Multiline {
    bool get ();
    void set (bool value);
}

See Also

vMaskedTextBox Class


PasswordChar Property

[image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..PasswordChar Property
vMaskedTextBox Class See Also Send Feedback
Gets or sets textbox's password character.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public char PasswordChar { get; set; }
Visual Basic
Public Property PasswordChar As Char
    Get
    Set
Visual C++
public:
property wchar_t PasswordChar {
    wchar_t get ();
    void set (wchar_t value);
}

See Also

vMaskedTextBox Class


PromptChar Property

[image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..PromptChar Property
vMaskedTextBox Class See Also Send Feedback
Gets or sets the prompt char.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public char PromptChar { get; set; }
Visual Basic
Public Property PromptChar As Char
    Get
    Set
Visual C++
public:
property wchar_t PromptChar {
    wchar_t get ();
    void set (wchar_t value);
}

Field Value

The prompt char.

See Also

vMaskedTextBox Class


Readonly Property

[image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..Readonly Property
vMaskedTextBox Class See Also Send Feedback
Gets or sets whether the vTextBox is in read only mode.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Readonly { get; set; }
Visual Basic
Public Property Readonly As Boolean
    Get
    Set
Visual C++
public:
property bool Readonly {
    bool get ();
    void set (bool value);
}

See Also

vMaskedTextBox Class


RightToLeft Property

[image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..RightToLeft Property
vMaskedTextBox Class See Also Send Feedback
Gets or sets whether the vTextBox is in right-to-left mode.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override RightToLeft RightToLeft { get; set; }
Visual Basic
Public Overrides Property RightToLeft As RightToLeft
    Get
    Set
Visual C++
public:
virtual property RightToLeft RightToLeft {
    RightToLeft get () override;
    void set (RightToLeft value) override;
}

See Also

vMaskedTextBox Class


SyncBackColorWithParentBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..SyncBackColorWithParentBackColor Property
vMaskedTextBox Class See Also Send Feedback
Gets or sets a value indicating whether to sync the back color with parent's back color.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool SyncBackColorWithParentBackColor { get; set; }
Visual Basic
Public Property SyncBackColorWithParentBackColor As Boolean
    Get
    Set
Visual C++
public:
property bool SyncBackColorWithParentBackColor {
    bool get ();
    void set (bool value);
}

See Also

vMaskedTextBox Class


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..Text Property
vMaskedTextBox Class See Also Send Feedback
Gets or sets the text of the vTextBox control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string Text { get; set; }
Visual Basic
Public Overrides Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

See Also

vMaskedTextBox Class


TextBox Property

[image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..TextBox Property
vMaskedTextBox Class See Also Send Feedback
Gets a reference to the TextBox of the vMaskBox control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public MaskedTextBox TextBox { get; }
Visual Basic
Public ReadOnly Property TextBox As MaskedTextBox
    Get
Visual C++
public:
property MaskedTextBox^ TextBox {
    MaskedTextBox^ get ();
}

Field Value

The text box.

See Also

vMaskedTextBox Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..Theme Property
vMaskedTextBox Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vMaskedTextBox Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox..::..VIBlendTheme Property
vMaskedTextBox Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vMaskedTextBox Class


vMaskedTextBox Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMaskedTextBox Events
vMaskedTextBox Class See Also Send Feedback

The vMaskedTextBox type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vMaskedTextBox Class


vMenuControl Class

[image]

VIBlend Controls for WinForms Help Documentation
vMenuControl Class
Members See Also Send Feedback
Represents a vMenuControl

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vMenuControl : MainMenu
Visual Basic
Public Class vMenuControl _
    Inherits MainMenu
Visual C++
public ref class vMenuControl : public MainMenu

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Menu
System.Windows.Forms..::..MainMenu
VIBlend.WinForms.Controls..::..vMenuControl

See Also

vMenuControl Members


vMenuControl Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMenuControl Members
vMenuControl Class Constructors Methods Properties Events See Also Send Feedback

The vMenuControl type exposes the following members.

Constructors

 | Name | Description
Public method | vMenuControl()()()() | vMenuControl constructor
Public method | vMenuControl(array<MenuItem>[]()[][]) | vMenuControl constructor

Methods

 | Name | Description
Public method | CloneMenu()()()() | Creates a new MainMenu that is a duplicate of the current MainMenu. (Inherited from MainMenu.)
Protected method | CloneMenu(Menu) | Copies the Menu that is passed as a parameter to the current Menu. (Inherited from Menu.)
Protected method | CreateMenuHandle | (Inherited from MainMenu.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes of the resources, other than memory, used by the MainMenu. (Inherited from MainMenu.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindMenuItem | Gets the MenuItem that contains the value specified. (Inherited from Menu.)
Protected method | FindMergePosition | Returns the position at which a menu item should be inserted into the menu. (Inherited from Menu.)
Public method | GetContextMenu | Gets the ContextMenu that contains this menu. (Inherited from Menu.)
Public method | GetForm | Gets the Form that contains this control. (Inherited from MainMenu.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMainMenu | Gets the MainMenu that contains this menu. (Inherited from Menu.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | MergeMenu | Merges the MenuItem objects of one menu with the current menu. (Inherited from Menu.)
Protected method | OnCollapse | Raises the Collapse event. (Inherited from MainMenu.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Menu.)
Public method | ToString | Returns a string that represents the MainMenu. (Inherited from MainMenu.)

Properties

 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Handle | Gets a value representing the window handle for the menu. (Inherited from Menu.)
Public property | IsParent | Gets a value indicating whether this menu contains any menu items. This property is read-only. (Inherited from Menu.)
Public property | MdiListItem | Gets a value indicating the MenuItem that is used to display a list of multiple document interface (MDI) child forms. (Inherited from Menu.)
Public property | MenuItems | Gets a value indicating the collection of MenuItem objects associated with the menu. (Inherited from Menu.)
Public property | Name | Gets or sets the name of the Menu. (Inherited from Menu.)
Public property | RightToLeft | Gets or sets whether the text displayed by the control is displayed from right to left. (Inherited from MainMenu.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Tag | Gets or sets user-defined data associated with the control. (Inherited from Menu.)

Events

 | Name | Description
Public event | Collapse | Occurs when the main menu collapses. (Inherited from MainMenu.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

vMenuControl Class


vMenuControl Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMenuControl Constructor
vMenuControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | vMenuControl()()()() | vMenuControl constructor
Public method | vMenuControl(array<MenuItem>[]()[][]) | vMenuControl constructor

See Also

vMenuControl Class
vMenuControl Members


vMenuControl Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vMenuControl Constructor
vMenuControl Class See Also Send Feedback
vMenuControl constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vMenuControl()
Visual Basic
Public Sub New
Visual C++
public:
vMenuControl()

See Also

vMenuControl Class
vMenuControl Overload


vMenuControl Constructor (MenuItem[])

[image]

VIBlend Controls for WinForms Help Documentation
vMenuControl Constructor (array<MenuItem>[]()[][])
vMenuControl Class See Also Send Feedback
vMenuControl constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vMenuControl(
    MenuItem[] items
)
Visual Basic
Public Sub New ( _
    items As MenuItem() _
)
Visual C++
public:
vMenuControl(
    array<MenuItem^>^ items
)

Parameters

items
Type: array< System.Windows.Forms..::..MenuItem >[]()[][]

See Also

vMenuControl Class
vMenuControl Overload


vMenuControl Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMenuControl Methods
vMenuControl Class See Also Send Feedback

The vMenuControl type exposes the following members.

Methods

 | Name | Description
Public method | CloneMenu()()()() | Creates a new MainMenu that is a duplicate of the current MainMenu. (Inherited from MainMenu.)
Protected method | CloneMenu(Menu) | Copies the Menu that is passed as a parameter to the current Menu. (Inherited from Menu.)
Protected method | CreateMenuHandle | (Inherited from MainMenu.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes of the resources, other than memory, used by the MainMenu. (Inherited from MainMenu.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindMenuItem | Gets the MenuItem that contains the value specified. (Inherited from Menu.)
Protected method | FindMergePosition | Returns the position at which a menu item should be inserted into the menu. (Inherited from Menu.)
Public method | GetContextMenu | Gets the ContextMenu that contains this menu. (Inherited from Menu.)
Public method | GetForm | Gets the Form that contains this control. (Inherited from MainMenu.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMainMenu | Gets the MainMenu that contains this menu. (Inherited from Menu.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | MergeMenu | Merges the MenuItem objects of one menu with the current menu. (Inherited from Menu.)
Protected method | OnCollapse | Raises the Collapse event. (Inherited from MainMenu.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Menu.)
Public method | ToString | Returns a string that represents the MainMenu. (Inherited from MainMenu.)

See Also

vMenuControl Class


CloneMenu Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMenuControl..::..CloneMenu Method
vMenuControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CloneMenu()()()() | Creates a new MainMenu that is a duplicate of the current MainMenu. (Inherited from MainMenu.)
Protected method | CloneMenu(Menu) | Copies the Menu that is passed as a parameter to the current Menu. (Inherited from Menu.)

See Also

vMenuControl Class
vMenuControl Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMenuControl..::..Dispose Method
vMenuControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes of the resources, other than memory, used by the MainMenu. (Inherited from MainMenu.)

See Also

vMenuControl Class
vMenuControl Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMenuControl..::..MemberwiseClone Method
vMenuControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vMenuControl Class
vMenuControl Members


vMenuControl Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMenuControl Properties
vMenuControl Class See Also Send Feedback

The vMenuControl type exposes the following members.

Properties

 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Handle | Gets a value representing the window handle for the menu. (Inherited from Menu.)
Public property | IsParent | Gets a value indicating whether this menu contains any menu items. This property is read-only. (Inherited from Menu.)
Public property | MdiListItem | Gets a value indicating the MenuItem that is used to display a list of multiple document interface (MDI) child forms. (Inherited from Menu.)
Public property | MenuItems | Gets a value indicating the collection of MenuItem objects associated with the menu. (Inherited from Menu.)
Public property | Name | Gets or sets the name of the Menu. (Inherited from Menu.)
Public property | RightToLeft | Gets or sets whether the text displayed by the control is displayed from right to left. (Inherited from MainMenu.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Tag | Gets or sets user-defined data associated with the control. (Inherited from Menu.)

See Also

vMenuControl Class


vMenuControl Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMenuControl Events
vMenuControl Class See Also Send Feedback

The vMenuControl type exposes the following members.

Events

 | Name | Description
Public event | Collapse | Occurs when the main menu collapses. (Inherited from MainMenu.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

vMenuControl Class


vMenuExtender Class

[image]

VIBlend Controls for WinForms Help Documentation
vMenuExtender Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vMenuExtender : Component,
    IExtenderProvider
Visual Basic
Public Class vMenuExtender _
    Inherits Component _
    Implements IExtenderProvider
Visual C++
public ref class vMenuExtender : public Component,
    IExtenderProvider

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
VIBlend.WinForms.Controls..::..vMenuExtender

See Also

vMenuExtender Members


vMenuExtender Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMenuExtender Members
vMenuExtender Class Constructors Methods Properties Events See Also Send Feedback

The vMenuExtender type exposes the following members.

Constructors

 | Name | Description
Public method | vMenuExtender(IContainer) | vMenuExtender constructor
Public method | vMenuExtender(Menu) | vMenuExtender constructor

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | (Overrides Component..::..Dispose(Boolean).)
Public method | DrawToBitmap |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ImageList |
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Theme |
Public property | VIBlendTheme |

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

vMenuExtender Class


vMenuExtender Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMenuExtender Constructor
vMenuExtender Class See Also Send Feedback

Overload List

 | Name | Description
Public method | vMenuExtender(IContainer) | vMenuExtender constructor
Public method | vMenuExtender(Menu) | vMenuExtender constructor

See Also

vMenuExtender Class
vMenuExtender Members


vMenuExtender Constructor (IContainer)

[image]

VIBlend Controls for WinForms Help Documentation
vMenuExtender Constructor (IContainer)
vMenuExtender Class See Also Send Feedback
vMenuExtender constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vMenuExtender(
    IContainer container
)
Visual Basic
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
vMenuExtender(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::..IContainer

See Also

vMenuExtender Class
vMenuExtender Overload


vMenuExtender Constructor (Menu)

[image]

VIBlend Controls for WinForms Help Documentation
vMenuExtender Constructor (Menu)
vMenuExtender Class See Also Send Feedback
vMenuExtender constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vMenuExtender(
    Menu mainMenu
)
Visual Basic
Public Sub New ( _
    mainMenu As Menu _
)
Visual C++
public:
vMenuExtender(
    Menu^ mainMenu
)

Parameters

mainMenu
Type: System.Windows.Forms..::..Menu

See Also

vMenuExtender Class
vMenuExtender Overload


vMenuExtender Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMenuExtender Methods
vMenuExtender Class See Also Send Feedback

The vMenuExtender type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | (Overrides Component..::..Dispose(Boolean).)
Public method | DrawToBitmap |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

vMenuExtender Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMenuExtender..::..Dispose Method
vMenuExtender Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the vMenuExtender and optionally releases the managed resources (Overrides Component..::..Dispose(Boolean).)

See Also

vMenuExtender Class
vMenuExtender Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vMenuExtender..::..Dispose Method (Boolean)
vMenuExtender Class See Also Send Feedback
Releases the unmanaged resources used by the vMenuExtender and optionally releases the managed resources

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vMenuExtender Class
Dispose Overload


DrawToBitmap Method

[image]

VIBlend Controls for WinForms Help Documentation
vMenuExtender..::..DrawToBitmap Method
vMenuExtender Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawToBitmap()
Visual Basic
Public Sub DrawToBitmap
Visual C++
public:
void DrawToBitmap()

See Also

vMenuExtender Class


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMenuExtender..::..MemberwiseClone Method
vMenuExtender Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vMenuExtender Class
vMenuExtender Members


vMenuExtender Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMenuExtender Properties
vMenuExtender Class See Also Send Feedback

The vMenuExtender type exposes the following members.

Properties

 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ImageList |
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Theme |
Public property | VIBlendTheme |

See Also

vMenuExtender Class


ImageList Property

[image]

VIBlend Controls for WinForms Help Documentation
vMenuExtender..::..ImageList Property
vMenuExtender Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ImageList ImageList { get; set; }
Visual Basic
Public Property ImageList As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ ImageList {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

vMenuExtender Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vMenuExtender..::..Theme Property
vMenuExtender Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vMenuExtender Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vMenuExtender..::..VIBlendTheme Property
vMenuExtender Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vMenuExtender Class


vMenuExtender Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMenuExtender Events
vMenuExtender Class See Also Send Feedback

The vMenuExtender type exposes the following members.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

vMenuExtender Class


vMonthCalendar Class

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar Class
Members See Also Send Feedback
Represents a month calendar control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vMonthCalendar : Control,
    IScrollableControlBase
Visual Basic
Public Class vMonthCalendar _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class vMonthCalendar : public Control,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vMonthCalendar

See Also

vMonthCalendar Members


vMonthCalendar Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar Members
vMonthCalendar Class Constructors Methods Fields Properties Events See Also Send Feedback

The vMonthCalendar type exposes the following members.

Constructors

 | Name | Description
Public method | vMonthCalendar | Initializes a new instance of the [!:vCalendar] class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Public method | GetAppointmentsInMonth |
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVisibleDate | Specifies the day to display as the first day of the week on the Calendar control.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NavigateTo | Navigates to.
Public method | NavigateToToday | Navigates to today.
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCalendarNavigated |
Protected method | OnCalendarViewChanged |
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnCellPaint |
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectionChanged |
Protected method | OnSelectionChanging |
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Overrides Control..::..ProcessCmdKey(Message%, Keys).)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RenderAppointments | Renders the appointments.
Protected method | RenderCenturiesView |
Protected method | RenderColumnHeader |
Protected method | RenderDaysView |
Protected method | RenderMonthsView |
Protected method | RenderNavigationTitle | Renders the navigation title.
Protected method | RenderRowHeader |
Protected method | RenderYearsView | Renders the years view.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Public method | SetCalendarView | Sets the calendar view.
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Overrides Component..::..ToString()()()().)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | backFill |
Protected field | theme |
Protected field | titleFill |

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Appointments | Gets the list of calendar events
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | Calendar | Gets the calendar.
Public property | CalendarView | Gets or sets the calendar view.
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CellAlignment | Gets or sets the cell alignment.
Public property | CellDefaultTextColor | Gets or sets the color of the default cells text.
Public property | CellFont | Gets or sets the cell font.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColumnHeaderFont | Gets or sets the column header font.
Public property | ColumnHeaderHorizontalLineColor | Gets or sets the color of the column header horizontal line.
Public property | ColumnHeaderSize | Gets or sets the size of the header.
Public property | ColumnHeaderTextAlignment | Gets or sets the column header text alignment.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Culture | Gets or sets the culture.
Public property | CurrentDate | Gets or sets the current date.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DayNameFormat | Gets or sets the day name format.
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DifferentMonthDaysTextColor | Gets or sets the color of the different month days text.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableKeyboardNavigation | Gets or sets a value indicating whether to enable keyboard navigation
Public property | EnableMultipleSelection | Gets or sets a value indicating whether to enable multiple selection.
Public property | EnableNavigation | Gets or sets a value indicating whether to enable navigation.
Public property | EnableQuickNavigation | Gets or sets a value indicating whether to enable navigation.
Public property | EnableSelection | Gets or sets a value indicating whether to enable selection.
Public property | EnableToggleSelection | Enables or disables toggle selection mode
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vCalendar (Overrides Control..::..Font.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavigationArrowColor | Gets or sets the color of the navigation arrow.
Public property | NavigationArrowHighlightColor | Gets or sets the color of the highlighted navigation arrow.
Public property | NavigationEndDate | Gets or sets the navigation end date.
Public property | NavigationFont | Gets or sets the navigation font.
Public property | NavigationStartDate | Gets or sets the navigation start date.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint border.
Public property | PaintCellAppointmentsStyle | Gets or sets a value whether to paint cell's appointment style.
Public property | PaintCellBorder | Gets or sets a value indicating whether to paint cell default border.
Public property | PaintCellDifferentMonthDatesStyle | Gets or sets a value indicating whether to paint cell different month dates style.
Public property | PaintCellFill | Gets or sets a value indicating whether to paint cell default fill.
Public property | PaintCellWeekendsStyle | Gets or sets a value indicating whether to paint cell's weeeknd style
Public property | PaintColumnHeaderHorizontalLine | Gets or sets a value indicating whether to paint column header horizontal line.
Public property | PaintFill | Gets or sets a value indicating whether to paint fill.
Public property | PaintRowHeaderVerticalLine | Gets or sets a value indicating whether to paint row header horizontal line.
Public property | PaintTitleBorder | Gets or sets a value indicating whether to paint border.
Public property | PaintTitleFill | Gets or sets a value indicating whether to paint fill.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RowHeaderFont | Gets or sets the row header font.
Public property | RowHeaderSize | Gets or sets the size of the header.
Public property | RowHeaderTextAlignment | Gets or sets the row header text alignment.
Public property | RowHeaderVerticalLineColor | Gets or sets the color of the row heared horizontal line.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedDate | Gets or sets the selected date.
Public property | SelectedDates | Gets or sets the selected dates.
Public property | ShowColumnHeader | Gets or sets a value indicating whether to show column header.
Public property | ShowDifferentMonthDates | Gets or sets a value indicating whether to show different month dates.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Gets or sets a value indicating whether to show focus rectangle.
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowNavigation | Gets or sets a value indicating whether to show navigation title.
Public property | ShowNavigationArrows | Gets or sets a value indicating whether to show navigation arrows.
Public property | ShowRowHeader | Gets or sets a value indicating whether to show row header.
Public property | ShowTodayDate | Gets or sets a value indicating whether to show today's date.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StartDayOfWeek | Gets or sets the start day of week.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control
Public property | TitleFormatDayString | Gets or sets the title format day string.
Public property | TitleFormatEndCenturyString | Gets or sets the title format century string.
Public property | TitleFormatEndYearString | Gets or sets the title format year string.
Public property | TitleFormatMonthString | Gets or sets the title format month string.
Public property | TitleFormatStartCenturyString | Gets or sets the title format century string.
Public property | TitleFormatStartYearString | Gets or sets the title format year string.
Public property | TitleHeight | Gets or sets the height of the title.
Public property | TodaysDate |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use theme's text color
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | VisibleDate |
Public property | WeekendsTextColor | Gets or sets the color of the weekends text.
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CalendarNavigated | Occurs when user has navigated
Public event | CalendarViewChanged | Occurs when calendar view is changed.
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | CellPaint | Occurs when cell is painted.
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectionChanged | Occurs when selection is changed.
Public event | SelectionChanging | Occurs when selection is changing
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vMonthCalendar Class


vMonthCalendar Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar Constructor
vMonthCalendar Class See Also Send Feedback
Initializes a new instance of the [!:vCalendar] class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vMonthCalendar()
Visual Basic
Public Sub New
Visual C++
public:
vMonthCalendar()

See Also

vMonthCalendar Class


vMonthCalendar Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar Fields
vMonthCalendar Class See Also Send Feedback

The vMonthCalendar type exposes the following members.

Fields

 | Name | Description
Protected field | backFill |
Protected field | theme |
Protected field | titleFill |

See Also

vMonthCalendar Class


backFill Field

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..backFill Field
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected BackgroundElement backFill
Visual Basic
Protected backFill As BackgroundElement
Visual C++
protected:
BackgroundElement^ backFill

See Also

vMonthCalendar Class


theme Field

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..theme Field
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected ControlTheme theme
Visual Basic
Protected theme As ControlTheme
Visual C++
protected:
ControlTheme^ theme

See Also

vMonthCalendar Class


titleFill Field

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..titleFill Field
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected BackgroundElement titleFill
Visual Basic
Protected titleFill As BackgroundElement
Visual C++
protected:
BackgroundElement^ titleFill

See Also

vMonthCalendar Class


vMonthCalendar Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar Methods
vMonthCalendar Class See Also Send Feedback

The vMonthCalendar type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Public method | GetAppointmentsInMonth |
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVisibleDate | Specifies the day to display as the first day of the week on the Calendar control.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NavigateTo | Navigates to.
Public method | NavigateToToday | Navigates to today.
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCalendarNavigated |
Protected method | OnCalendarViewChanged |
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnCellPaint |
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectionChanged |
Protected method | OnSelectionChanging |
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Overrides Control..::..ProcessCmdKey(Message%, Keys).)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RenderAppointments | Renders the appointments.
Protected method | RenderCenturiesView |
Protected method | RenderColumnHeader |
Protected method | RenderDaysView |
Protected method | RenderMonthsView |
Protected method | RenderNavigationTitle | Renders the navigation title.
Protected method | RenderRowHeader |
Protected method | RenderYearsView | Renders the years view.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Public method | SetCalendarView | Sets the calendar view.
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Overrides Component..::..ToString()()()().)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vMonthCalendar Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..AccessibilityNotifyClients Method
vMonthCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vMonthCalendar Class
vMonthCalendar Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..BeginInvoke Method
vMonthCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vMonthCalendar Class
vMonthCalendar Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..Dispose Method
vMonthCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)

See Also

vMonthCalendar Class
vMonthCalendar Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..Dispose Method (Boolean)
vMonthCalendar Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vMonthCalendar Class
Dispose Overload


GetAppointmentsInMonth Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..GetAppointmentsInMonth Method
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<vAppointment> GetAppointmentsInMonth()
Visual Basic
Public Function GetAppointmentsInMonth As List(Of vAppointment)
Visual C++
public:
List<vAppointment^>^ GetAppointmentsInMonth()

See Also

vMonthCalendar Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..GetChildAtPoint Method
vMonthCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vMonthCalendar Class
vMonthCalendar Members


GetVisibleDate Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..GetVisibleDate Method
vMonthCalendar Class See Also Send Feedback
Specifies the day to display as the first day of the week on the Calendar control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime GetVisibleDate()
Visual Basic
Public Function GetVisibleDate As DateTime
Visual C++
public:
DateTime GetVisibleDate()

See Also

vMonthCalendar Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..Invalidate Method
vMonthCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vMonthCalendar Class
vMonthCalendar Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..Invoke Method
vMonthCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vMonthCalendar Class
vMonthCalendar Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..MemberwiseClone Method
vMonthCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vMonthCalendar Class
vMonthCalendar Members


NavigateTo Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..NavigateTo Method
vMonthCalendar Class See Also Send Feedback
Navigates to.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void NavigateTo(
    DateTime date
)
Visual Basic
Public Sub NavigateTo ( _
    date As DateTime _
)
Visual C++
public:
void NavigateTo(
    DateTime date
)

Parameters

date
Type: System..::..DateTime
The date.

See Also

vMonthCalendar Class


NavigateToToday Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..NavigateToToday Method
vMonthCalendar Class See Also Send Feedback
Navigates to today.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void NavigateToToday()
Visual Basic
Public Sub NavigateToToday
Visual C++
public:
void NavigateToToday()

See Also

vMonthCalendar Class


OnCalendarNavigated Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..OnCalendarNavigated Method
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCalendarNavigated(
    EventArgs args
)
Visual Basic
Protected Overridable Sub OnCalendarNavigated ( _
    args As EventArgs _
)
Visual C++
protected:
virtual void OnCalendarNavigated(
    EventArgs^ args
)

Parameters

args
Type: System..::..EventArgs

See Also

vMonthCalendar Class


OnCalendarViewChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..OnCalendarViewChanged Method
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCalendarViewChanged(
    EventArgs args
)
Visual Basic
Protected Overridable Sub OnCalendarViewChanged ( _
    args As EventArgs _
)
Visual C++
protected:
virtual void OnCalendarViewChanged(
    EventArgs^ args
)

Parameters

args
Type: System..::..EventArgs

See Also

vMonthCalendar Class


OnCellPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..OnCellPaint Method
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCellPaint(
    CalendarPaintEventArgs args
)
Visual Basic
Protected Overridable Sub OnCellPaint ( _
    args As CalendarPaintEventArgs _
)
Visual C++
protected:
virtual void OnCellPaint(
    CalendarPaintEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.Controls..::..CalendarPaintEventArgs

See Also

vMonthCalendar Class


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..OnMouseDown Method
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vMonthCalendar Class


OnMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..OnMouseLeave Method
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vMonthCalendar Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..OnMouseMove Method
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vMonthCalendar Class


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..OnMouseUp Method
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vMonthCalendar Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..OnPaint Method
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vMonthCalendar Class


OnSelectionChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..OnSelectionChanged Method
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnSelectionChanged(
    SelectionEventArgs args
)
Visual Basic
Protected Overridable Sub OnSelectionChanged ( _
    args As SelectionEventArgs _
)
Visual C++
protected:
virtual void OnSelectionChanged(
    SelectionEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.Controls..::..SelectionEventArgs

See Also

vMonthCalendar Class


OnSelectionChanging Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..OnSelectionChanging Method
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnSelectionChanging(
    SelectionCancelEventArgs args
)
Visual Basic
Protected Overridable Sub OnSelectionChanging ( _
    args As SelectionCancelEventArgs _
)
Visual C++
protected:
virtual void OnSelectionChanging(
    SelectionCancelEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.Controls..::..SelectionCancelEventArgs

See Also

vMonthCalendar Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..PerformLayout Method
vMonthCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vMonthCalendar Class
vMonthCalendar Members


ProcessCmdKey Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..ProcessCmdKey Method
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override bool ProcessCmdKey(
    ref Message msg,
    Keys keyData
)
Visual Basic
Protected Overrides Function ProcessCmdKey ( _
    ByRef msg As Message, _
    keyData As Keys _
) As Boolean
Visual C++
protected:
virtual bool ProcessCmdKey(
    Message% msg,
    Keys keyData
) override

Parameters

msg
Type: System.Windows.Forms..::..Message %
keyData
Type: System.Windows.Forms..::..Keys

See Also

vMonthCalendar Class


RenderAppointments Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..RenderAppointments Method
vMonthCalendar Class See Also Send Feedback
Renders the appointments.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void RenderAppointments(
    Graphics g,
    ref DateTime time,
    ref Rectangle cellBounds,
    string str4,
    StringFormat format,
    Font cellFont
)
Visual Basic
Protected Overridable Sub RenderAppointments ( _
    g As Graphics, _
    ByRef time As DateTime, _
    ByRef cellBounds As Rectangle, _
    str4 As String, _
    format As StringFormat, _
    cellFont As Font _
)
Visual C++
protected:
virtual void RenderAppointments(
    Graphics^ g,
    DateTime% time,
    Rectangle% cellBounds,
    String^ str4,
    StringFormat^ format,
    Font^ cellFont
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
time
Type: System..::..DateTime %
The time.
cellBounds
Type: System.Drawing..::..Rectangle %
The cell bounds.
str4
Type: System..::..String
The STR4.
format
Type: System.Drawing..::..StringFormat
The format.
cellFont
Type: System.Drawing..::..Font
The cell font.

See Also

vMonthCalendar Class


RenderCenturiesView Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..RenderCenturiesView Method
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void RenderCenturiesView(
    Graphics g,
    Rectangle bounds
)
Visual Basic
Protected Overridable Sub RenderCenturiesView ( _
    g As Graphics, _
    bounds As Rectangle _
)
Visual C++
protected:
virtual void RenderCenturiesView(
    Graphics^ g,
    Rectangle bounds
)

Parameters

g
Type: System.Drawing..::..Graphics
bounds
Type: System.Drawing..::..Rectangle

See Also

vMonthCalendar Class


RenderColumnHeader Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..RenderColumnHeader Method
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void RenderColumnHeader(
    Graphics g,
    ref Rectangle bounds,
    ref Rectangle cellTable
)
Visual Basic
Protected Overridable Sub RenderColumnHeader ( _
    g As Graphics, _
    ByRef bounds As Rectangle, _
    ByRef cellTable As Rectangle _
)
Visual C++
protected:
virtual void RenderColumnHeader(
    Graphics^ g,
    Rectangle% bounds,
    Rectangle% cellTable
)

Parameters

g
Type: System.Drawing..::..Graphics
bounds
Type: System.Drawing..::..Rectangle %
cellTable
Type: System.Drawing..::..Rectangle %

See Also

vMonthCalendar Class


RenderDaysView Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..RenderDaysView Method
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void RenderDaysView(
    Graphics g,
    Rectangle bounds
)
Visual Basic
Protected Overridable Sub RenderDaysView ( _
    g As Graphics, _
    bounds As Rectangle _
)
Visual C++
protected:
virtual void RenderDaysView(
    Graphics^ g,
    Rectangle bounds
)

Parameters

g
Type: System.Drawing..::..Graphics
bounds
Type: System.Drawing..::..Rectangle

See Also

vMonthCalendar Class


RenderMonthsView Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..RenderMonthsView Method
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void RenderMonthsView(
    Graphics g,
    Rectangle bounds
)
Visual Basic
Protected Overridable Sub RenderMonthsView ( _
    g As Graphics, _
    bounds As Rectangle _
)
Visual C++
protected:
virtual void RenderMonthsView(
    Graphics^ g,
    Rectangle bounds
)

Parameters

g
Type: System.Drawing..::..Graphics
bounds
Type: System.Drawing..::..Rectangle

See Also

vMonthCalendar Class


RenderNavigationTitle Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..RenderNavigationTitle Method
vMonthCalendar Class See Also Send Feedback
Renders the navigation title.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void RenderNavigationTitle(
    Graphics g
)
Visual Basic
Protected Overridable Sub RenderNavigationTitle ( _
    g As Graphics _
)
Visual C++
protected:
virtual void RenderNavigationTitle(
    Graphics^ g
)

Parameters

g
Type: System.Drawing..::..Graphics
Graphics

See Also

vMonthCalendar Class


RenderRowHeader Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..RenderRowHeader Method
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void RenderRowHeader(
    Graphics g,
    ref Rectangle bounds,
    ref Rectangle cellTable
)
Visual Basic
Protected Overridable Sub RenderRowHeader ( _
    g As Graphics, _
    ByRef bounds As Rectangle, _
    ByRef cellTable As Rectangle _
)
Visual C++
protected:
virtual void RenderRowHeader(
    Graphics^ g,
    Rectangle% bounds,
    Rectangle% cellTable
)

Parameters

g
Type: System.Drawing..::..Graphics
bounds
Type: System.Drawing..::..Rectangle %
cellTable
Type: System.Drawing..::..Rectangle %

See Also

vMonthCalendar Class


RenderYearsView Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..RenderYearsView Method
vMonthCalendar Class See Also Send Feedback
Renders the years view.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void RenderYearsView(
    Graphics g,
    Rectangle bounds
)
Visual Basic
Protected Overridable Sub RenderYearsView ( _
    g As Graphics, _
    bounds As Rectangle _
)
Visual C++
protected:
virtual void RenderYearsView(
    Graphics^ g,
    Rectangle bounds
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
bounds
Type: System.Drawing..::..Rectangle
The bounds.

See Also

vMonthCalendar Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..ResumeLayout Method
vMonthCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vMonthCalendar Class
vMonthCalendar Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..RtlTranslateAlignment Method
vMonthCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vMonthCalendar Class
vMonthCalendar Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..Scale Method
vMonthCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vMonthCalendar Class
vMonthCalendar Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..Select Method
vMonthCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vMonthCalendar Class
vMonthCalendar Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..SetBounds Method
vMonthCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vMonthCalendar Class
vMonthCalendar Members


SetCalendarView Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..SetCalendarView Method
vMonthCalendar Class See Also Send Feedback
Sets the calendar view.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCalendarView(
    vCalendarView view
)
Visual Basic
Public Sub SetCalendarView ( _
    view As vCalendarView _
)
Visual C++
public:
void SetCalendarView(
    vCalendarView view
)

Parameters

view
Type: VIBlend.WinForms.Controls..::..vCalendarView
The view.

See Also

vMonthCalendar Class


ToString Method

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..ToString Method
vMonthCalendar Class See Also Send Feedback
Returns a String containing the name of the Component, if any. This method should not be overridden.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String containing the name of the Component, if any, or null if the Component is unnamed.

See Also

vMonthCalendar Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..UpdateBounds Method
vMonthCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vMonthCalendar Class
vMonthCalendar Members


vMonthCalendar Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar Properties
vMonthCalendar Class See Also Send Feedback

The vMonthCalendar type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Appointments | Gets the list of calendar events
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | Calendar | Gets the calendar.
Public property | CalendarView | Gets or sets the calendar view.
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CellAlignment | Gets or sets the cell alignment.
Public property | CellDefaultTextColor | Gets or sets the color of the default cells text.
Public property | CellFont | Gets or sets the cell font.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColumnHeaderFont | Gets or sets the column header font.
Public property | ColumnHeaderHorizontalLineColor | Gets or sets the color of the column header horizontal line.
Public property | ColumnHeaderSize | Gets or sets the size of the header.
Public property | ColumnHeaderTextAlignment | Gets or sets the column header text alignment.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Culture | Gets or sets the culture.
Public property | CurrentDate | Gets or sets the current date.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DayNameFormat | Gets or sets the day name format.
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DifferentMonthDaysTextColor | Gets or sets the color of the different month days text.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableKeyboardNavigation | Gets or sets a value indicating whether to enable keyboard navigation
Public property | EnableMultipleSelection | Gets or sets a value indicating whether to enable multiple selection.
Public property | EnableNavigation | Gets or sets a value indicating whether to enable navigation.
Public property | EnableQuickNavigation | Gets or sets a value indicating whether to enable navigation.
Public property | EnableSelection | Gets or sets a value indicating whether to enable selection.
Public property | EnableToggleSelection | Enables or disables toggle selection mode
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vCalendar (Overrides Control..::..Font.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavigationArrowColor | Gets or sets the color of the navigation arrow.
Public property | NavigationArrowHighlightColor | Gets or sets the color of the highlighted navigation arrow.
Public property | NavigationEndDate | Gets or sets the navigation end date.
Public property | NavigationFont | Gets or sets the navigation font.
Public property | NavigationStartDate | Gets or sets the navigation start date.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint border.
Public property | PaintCellAppointmentsStyle | Gets or sets a value whether to paint cell's appointment style.
Public property | PaintCellBorder | Gets or sets a value indicating whether to paint cell default border.
Public property | PaintCellDifferentMonthDatesStyle | Gets or sets a value indicating whether to paint cell different month dates style.
Public property | PaintCellFill | Gets or sets a value indicating whether to paint cell default fill.
Public property | PaintCellWeekendsStyle | Gets or sets a value indicating whether to paint cell's weeeknd style
Public property | PaintColumnHeaderHorizontalLine | Gets or sets a value indicating whether to paint column header horizontal line.
Public property | PaintFill | Gets or sets a value indicating whether to paint fill.
Public property | PaintRowHeaderVerticalLine | Gets or sets a value indicating whether to paint row header horizontal line.
Public property | PaintTitleBorder | Gets or sets a value indicating whether to paint border.
Public property | PaintTitleFill | Gets or sets a value indicating whether to paint fill.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RowHeaderFont | Gets or sets the row header font.
Public property | RowHeaderSize | Gets or sets the size of the header.
Public property | RowHeaderTextAlignment | Gets or sets the row header text alignment.
Public property | RowHeaderVerticalLineColor | Gets or sets the color of the row heared horizontal line.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedDate | Gets or sets the selected date.
Public property | SelectedDates | Gets or sets the selected dates.
Public property | ShowColumnHeader | Gets or sets a value indicating whether to show column header.
Public property | ShowDifferentMonthDates | Gets or sets a value indicating whether to show different month dates.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Gets or sets a value indicating whether to show focus rectangle.
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowNavigation | Gets or sets a value indicating whether to show navigation title.
Public property | ShowNavigationArrows | Gets or sets a value indicating whether to show navigation arrows.
Public property | ShowRowHeader | Gets or sets a value indicating whether to show row header.
Public property | ShowTodayDate | Gets or sets a value indicating whether to show today's date.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StartDayOfWeek | Gets or sets the start day of week.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control
Public property | TitleFormatDayString | Gets or sets the title format day string.
Public property | TitleFormatEndCenturyString | Gets or sets the title format century string.
Public property | TitleFormatEndYearString | Gets or sets the title format year string.
Public property | TitleFormatMonthString | Gets or sets the title format month string.
Public property | TitleFormatStartCenturyString | Gets or sets the title format century string.
Public property | TitleFormatStartYearString | Gets or sets the title format year string.
Public property | TitleHeight | Gets or sets the height of the title.
Public property | TodaysDate |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use theme's text color
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | VisibleDate |
Public property | WeekendsTextColor | Gets or sets the color of the weekends text.
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vMonthCalendar Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..AllowAnimations Property
vMonthCalendar Class See Also Send Feedback
Determines whether to use animations

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vMonthCalendar Class


Appointments Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..Appointments Property
vMonthCalendar Class See Also Send Feedback
Gets the list of calendar events

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<vAppointment> Appointments { get; set; }
Visual Basic
Public Property Appointments As List(Of vAppointment)
    Get
    Set
Visual C++
public:
property List<vAppointment^>^ Appointments {
    List<vAppointment^>^ get ();
    void set (List<vAppointment^>^ value);
}

See Also

vMonthCalendar Class


Calendar Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..Calendar Property
vMonthCalendar Class See Also Send Feedback
Gets the calendar.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Calendar Calendar { get; }
Visual Basic
Public ReadOnly Property Calendar As Calendar
    Get
Visual C++
public:
property Calendar^ Calendar {
    Calendar^ get ();
}

Field Value

The calendar.

See Also

vMonthCalendar Class


CalendarView Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..CalendarView Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the calendar view.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vCalendarView CalendarView { get; set; }
Visual Basic
Public Property CalendarView As vCalendarView
    Get
    Set
Visual C++
public:
property vCalendarView CalendarView {
    vCalendarView get ();
    void set (vCalendarView value);
}

Field Value

The calendar view.

See Also

vMonthCalendar Class


CellAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..CellAlignment Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the cell alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment CellAlignment { get; set; }
Visual Basic
Public Property CellAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment CellAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The cell alignment.

See Also

vMonthCalendar Class


CellDefaultTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..CellDefaultTextColor Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the color of the default cells text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Nullable<Color> CellDefaultTextColor { get; set; }
Visual Basic
Public Property CellDefaultTextColor As Nullable(Of Color)
    Get
    Set
Visual C++
public:
property Nullable<Color> CellDefaultTextColor {
    Nullable<Color> get ();
    void set (Nullable<Color> value);
}

See Also

vMonthCalendar Class


CellFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..CellFont Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the cell font.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font CellFont { get; set; }
Visual Basic
Public Property CellFont As Font
    Get
    Set
Visual C++
public:
property Font^ CellFont {
    Font^ get ();
    void set (Font^ value);
}

Field Value

The cell font.

See Also

vMonthCalendar Class


ColumnHeaderFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..ColumnHeaderFont Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the column header font.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font ColumnHeaderFont { get; set; }
Visual Basic
Public Property ColumnHeaderFont As Font
    Get
    Set
Visual C++
public:
property Font^ ColumnHeaderFont {
    Font^ get ();
    void set (Font^ value);
}

Field Value

The column header font.

See Also

vMonthCalendar Class


ColumnHeaderHorizontalLineColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..ColumnHeaderHorizontalLineColor Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the color of the column header horizontal line.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color ColumnHeaderHorizontalLineColor { get; set; }
Visual Basic
Public Property ColumnHeaderHorizontalLineColor As Color
    Get
    Set
Visual C++
public:
property Color ColumnHeaderHorizontalLineColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the column header horizontal line.

See Also

vMonthCalendar Class


ColumnHeaderSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..ColumnHeaderSize Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the size of the header.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ColumnHeaderSize { get; set; }
Visual Basic
Public Property ColumnHeaderSize As Integer
    Get
    Set
Visual C++
public:
property int ColumnHeaderSize {
    int get ();
    void set (int value);
}

See Also

vMonthCalendar Class


ColumnHeaderTextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..ColumnHeaderTextAlignment Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the column header text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment ColumnHeaderTextAlignment { get; set; }
Visual Basic
Public Property ColumnHeaderTextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment ColumnHeaderTextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The column header text alignment.

See Also

vMonthCalendar Class


Culture Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..Culture Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the culture.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CultureInfo Culture { get; set; }
Visual Basic
Public Property Culture As CultureInfo
    Get
    Set
Visual C++
public:
property CultureInfo^ Culture {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}

Field Value

The culture.

See Also

vMonthCalendar Class


CurrentDate Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..CurrentDate Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the current date.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime CurrentDate { get; set; }
Visual Basic
Public Property CurrentDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime CurrentDate {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The current date.

See Also

vMonthCalendar Class


DayNameFormat Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..DayNameFormat Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the day name format.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DayNameFormat DayNameFormat { get; set; }
Visual Basic
Public Property DayNameFormat As DayNameFormat
    Get
    Set
Visual C++
public:
property DayNameFormat DayNameFormat {
    DayNameFormat get ();
    void set (DayNameFormat value);
}

Field Value

The day name format.

See Also

vMonthCalendar Class


DifferentMonthDaysTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..DifferentMonthDaysTextColor Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the color of the different month days text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DifferentMonthDaysTextColor { get; set; }
Visual Basic
Public Property DifferentMonthDaysTextColor As Color
    Get
    Set
Visual C++
public:
property Color DifferentMonthDaysTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the different month days text.

See Also

vMonthCalendar Class


EnableKeyboardNavigation Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..EnableKeyboardNavigation Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to enable keyboard navigation

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableKeyboardNavigation { get; set; }
Visual Basic
Public Property EnableKeyboardNavigation As Boolean
    Get
    Set
Visual C++
public:
property bool EnableKeyboardNavigation {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


EnableMultipleSelection Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..EnableMultipleSelection Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to enable multiple selection.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableMultipleSelection { get; set; }
Visual Basic
Public Property EnableMultipleSelection As Boolean
    Get
    Set
Visual C++
public:
property bool EnableMultipleSelection {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


EnableNavigation Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..EnableNavigation Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to enable navigation.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableNavigation { get; set; }
Visual Basic
Public Property EnableNavigation As Boolean
    Get
    Set
Visual C++
public:
property bool EnableNavigation {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


EnableQuickNavigation Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..EnableQuickNavigation Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to enable navigation.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableQuickNavigation { get; set; }
Visual Basic
Public Property EnableQuickNavigation As Boolean
    Get
    Set
Visual C++
public:
property bool EnableQuickNavigation {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


EnableSelection Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..EnableSelection Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to enable selection.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableSelection { get; set; }
Visual Basic
Public Property EnableSelection As Boolean
    Get
    Set
Visual C++
public:
property bool EnableSelection {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


EnableToggleSelection Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..EnableToggleSelection Property
vMonthCalendar Class See Also Send Feedback
Enables or disables toggle selection mode

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableToggleSelection { get; set; }
Visual Basic
Public Property EnableToggleSelection As Boolean
    Get
    Set
Visual C++
public:
property bool EnableToggleSelection {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


Font Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..Font Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the font of the vCalendar

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Font Font { get; set; }
Visual Basic
Public Overrides Property Font As Font
    Get
    Set
Visual C++
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}

See Also

vMonthCalendar Class


NavigationArrowColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..NavigationArrowColor Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the color of the navigation arrow.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Nullable<Color> NavigationArrowColor { get; set; }
Visual Basic
Public Property NavigationArrowColor As Nullable(Of Color)
    Get
    Set
Visual C++
public:
property Nullable<Color> NavigationArrowColor {
    Nullable<Color> get ();
    void set (Nullable<Color> value);
}

See Also

vMonthCalendar Class


NavigationArrowHighlightColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..NavigationArrowHighlightColor Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the color of the highlighted navigation arrow.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Nullable<Color> NavigationArrowHighlightColor { get; set; }
Visual Basic
Public Property NavigationArrowHighlightColor As Nullable(Of Color)
    Get
    Set
Visual C++
public:
property Nullable<Color> NavigationArrowHighlightColor {
    Nullable<Color> get ();
    void set (Nullable<Color> value);
}

See Also

vMonthCalendar Class


NavigationEndDate Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..NavigationEndDate Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the navigation end date.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime NavigationEndDate { get; set; }
Visual Basic
Public Property NavigationEndDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime NavigationEndDate {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The navigation end date.

See Also

vMonthCalendar Class


NavigationFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..NavigationFont Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the navigation font.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font NavigationFont { get; set; }
Visual Basic
Public Property NavigationFont As Font
    Get
    Set
Visual C++
public:
property Font^ NavigationFont {
    Font^ get ();
    void set (Font^ value);
}

Field Value

The navigation font.

See Also

vMonthCalendar Class


NavigationStartDate Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..NavigationStartDate Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the navigation start date.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime NavigationStartDate { get; set; }
Visual Basic
Public Property NavigationStartDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime NavigationStartDate {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The navigation start date.

See Also

vMonthCalendar Class


PaintBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..PaintBorder Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to paint border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintBorder { get; set; }
Visual Basic
Public Property PaintBorder As Boolean
    Get
    Set
Visual C++
public:
property bool PaintBorder {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


PaintCellAppointmentsStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..PaintCellAppointmentsStyle Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value whether to paint cell's appointment style.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintCellAppointmentsStyle { get; set; }
Visual Basic
Public Property PaintCellAppointmentsStyle As Boolean
    Get
    Set
Visual C++
public:
property bool PaintCellAppointmentsStyle {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


PaintCellBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..PaintCellBorder Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to paint cell default border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintCellBorder { get; set; }
Visual Basic
Public Property PaintCellBorder As Boolean
    Get
    Set
Visual C++
public:
property bool PaintCellBorder {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


PaintCellDifferentMonthDatesStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..PaintCellDifferentMonthDatesStyle Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to paint cell different month dates style.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintCellDifferentMonthDatesStyle { get; set; }
Visual Basic
Public Property PaintCellDifferentMonthDatesStyle As Boolean
    Get
    Set
Visual C++
public:
property bool PaintCellDifferentMonthDatesStyle {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


PaintCellFill Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..PaintCellFill Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to paint cell default fill.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintCellFill { get; set; }
Visual Basic
Public Property PaintCellFill As Boolean
    Get
    Set
Visual C++
public:
property bool PaintCellFill {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


PaintCellWeekendsStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..PaintCellWeekendsStyle Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to paint cell's weeeknd style

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintCellWeekendsStyle { get; set; }
Visual Basic
Public Property PaintCellWeekendsStyle As Boolean
    Get
    Set
Visual C++
public:
property bool PaintCellWeekendsStyle {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


PaintColumnHeaderHorizontalLine Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..PaintColumnHeaderHorizontalLine Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to paint column header horizontal line.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintColumnHeaderHorizontalLine { get; set; }
Visual Basic
Public Property PaintColumnHeaderHorizontalLine As Boolean
    Get
    Set
Visual C++
public:
property bool PaintColumnHeaderHorizontalLine {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


PaintFill Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..PaintFill Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to paint fill.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintFill { get; set; }
Visual Basic
Public Property PaintFill As Boolean
    Get
    Set
Visual C++
public:
property bool PaintFill {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


PaintRowHeaderVerticalLine Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..PaintRowHeaderVerticalLine Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to paint row header horizontal line.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintRowHeaderVerticalLine { get; set; }
Visual Basic
Public Property PaintRowHeaderVerticalLine As Boolean
    Get
    Set
Visual C++
public:
property bool PaintRowHeaderVerticalLine {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


PaintTitleBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..PaintTitleBorder Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to paint border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintTitleBorder { get; set; }
Visual Basic
Public Property PaintTitleBorder As Boolean
    Get
    Set
Visual C++
public:
property bool PaintTitleBorder {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


PaintTitleFill Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..PaintTitleFill Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to paint fill.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintTitleFill { get; set; }
Visual Basic
Public Property PaintTitleFill As Boolean
    Get
    Set
Visual C++
public:
property bool PaintTitleFill {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


RowHeaderFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..RowHeaderFont Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the row header font.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font RowHeaderFont { get; set; }
Visual Basic
Public Property RowHeaderFont As Font
    Get
    Set
Visual C++
public:
property Font^ RowHeaderFont {
    Font^ get ();
    void set (Font^ value);
}

Field Value

The row header font.

See Also

vMonthCalendar Class


RowHeaderSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..RowHeaderSize Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the size of the header.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int RowHeaderSize { get; set; }
Visual Basic
Public Property RowHeaderSize As Integer
    Get
    Set
Visual C++
public:
property int RowHeaderSize {
    int get ();
    void set (int value);
}

See Also

vMonthCalendar Class


RowHeaderTextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..RowHeaderTextAlignment Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the row header text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment RowHeaderTextAlignment { get; set; }
Visual Basic
Public Property RowHeaderTextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment RowHeaderTextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The row header text alignment.

See Also

vMonthCalendar Class


RowHeaderVerticalLineColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..RowHeaderVerticalLineColor Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the color of the row heared horizontal line.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color RowHeaderVerticalLineColor { get; set; }
Visual Basic
Public Property RowHeaderVerticalLineColor As Color
    Get
    Set
Visual C++
public:
property Color RowHeaderVerticalLineColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the row heared horizontal line.

See Also

vMonthCalendar Class


SelectedDate Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..SelectedDate Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the selected date.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime SelectedDate { get; set; }
Visual Basic
Public Property SelectedDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime SelectedDate {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The selected date.

See Also

vMonthCalendar Class


SelectedDates Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..SelectedDates Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the selected dates.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<DateTime> SelectedDates { get; }
Visual Basic
Public ReadOnly Property SelectedDates As List(Of DateTime)
    Get
Visual C++
public:
property List<DateTime>^ SelectedDates {
    List<DateTime>^ get ();
}

Field Value

The selected dates.

See Also

vMonthCalendar Class


ShowColumnHeader Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..ShowColumnHeader Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to show column header.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowColumnHeader { get; set; }
Visual Basic
Public Property ShowColumnHeader As Boolean
    Get
    Set
Visual C++
public:
property bool ShowColumnHeader {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


ShowDifferentMonthDates Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..ShowDifferentMonthDates Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to show different month dates.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowDifferentMonthDates { get; set; }
Visual Basic
Public Property ShowDifferentMonthDates As Boolean
    Get
    Set
Visual C++
public:
property bool ShowDifferentMonthDates {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


ShowFocusRectangle Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..ShowFocusRectangle Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to show focus rectangle.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowFocusRectangle { get; set; }
Visual Basic
Public Property ShowFocusRectangle As Boolean
    Get
    Set
Visual C++
public:
property bool ShowFocusRectangle {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


ShowNavigation Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..ShowNavigation Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to show navigation title.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowNavigation { get; set; }
Visual Basic
Public Property ShowNavigation As Boolean
    Get
    Set
Visual C++
public:
property bool ShowNavigation {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


ShowNavigationArrows Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..ShowNavigationArrows Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to show navigation arrows.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowNavigationArrows { get; set; }
Visual Basic
Public Property ShowNavigationArrows As Boolean
    Get
    Set
Visual C++
public:
property bool ShowNavigationArrows {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


ShowRowHeader Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..ShowRowHeader Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to show row header.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowRowHeader { get; set; }
Visual Basic
Public Property ShowRowHeader As Boolean
    Get
    Set
Visual C++
public:
property bool ShowRowHeader {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


ShowTodayDate Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..ShowTodayDate Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to show today's date.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowTodayDate { get; set; }
Visual Basic
Public Property ShowTodayDate As Boolean
    Get
    Set
Visual C++
public:
property bool ShowTodayDate {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


StartDayOfWeek Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..StartDayOfWeek Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the start day of week.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DayOfWeek StartDayOfWeek { get; set; }
Visual Basic
Public Property StartDayOfWeek As DayOfWeek
    Get
    Set
Visual C++
public:
property DayOfWeek StartDayOfWeek {
    DayOfWeek get ();
    void set (DayOfWeek value);
}

Field Value

The start day of week.

See Also

vMonthCalendar Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..Theme Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the theme of the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ControlTheme Theme { get; set; }
Visual Basic
Public Overridable Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
virtual property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vMonthCalendar Class


TitleFormatDayString Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..TitleFormatDayString Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the title format day string.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string TitleFormatDayString { get; set; }
Visual Basic
Public Property TitleFormatDayString As String
    Get
    Set
Visual C++
public:
property String^ TitleFormatDayString {
    String^ get ();
    void set (String^ value);
}

Field Value

The title format day string.

See Also

vMonthCalendar Class


TitleFormatEndCenturyString Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..TitleFormatEndCenturyString Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the title format century string.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string TitleFormatEndCenturyString { get; set; }
Visual Basic
Public Property TitleFormatEndCenturyString As String
    Get
    Set
Visual C++
public:
property String^ TitleFormatEndCenturyString {
    String^ get ();
    void set (String^ value);
}

Field Value

The title format century string.

See Also

vMonthCalendar Class


TitleFormatEndYearString Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..TitleFormatEndYearString Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the title format year string.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string TitleFormatEndYearString { get; set; }
Visual Basic
Public Property TitleFormatEndYearString As String
    Get
    Set
Visual C++
public:
property String^ TitleFormatEndYearString {
    String^ get ();
    void set (String^ value);
}

Field Value

The title format year string.

See Also

vMonthCalendar Class


TitleFormatMonthString Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..TitleFormatMonthString Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the title format month string.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string TitleFormatMonthString { get; set; }
Visual Basic
Public Property TitleFormatMonthString As String
    Get
    Set
Visual C++
public:
property String^ TitleFormatMonthString {
    String^ get ();
    void set (String^ value);
}

Field Value

The title format month string.

See Also

vMonthCalendar Class


TitleFormatStartCenturyString Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..TitleFormatStartCenturyString Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the title format century string.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string TitleFormatStartCenturyString { get; set; }
Visual Basic
Public Property TitleFormatStartCenturyString As String
    Get
    Set
Visual C++
public:
property String^ TitleFormatStartCenturyString {
    String^ get ();
    void set (String^ value);
}

Field Value

The title format century string.

See Also

vMonthCalendar Class


TitleFormatStartYearString Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..TitleFormatStartYearString Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the title format year string.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string TitleFormatStartYearString { get; set; }
Visual Basic
Public Property TitleFormatStartYearString As String
    Get
    Set
Visual C++
public:
property String^ TitleFormatStartYearString {
    String^ get ();
    void set (String^ value);
}

Field Value

The title format year string.

See Also

vMonthCalendar Class


TitleHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..TitleHeight Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the height of the title.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int TitleHeight { get; set; }
Visual Basic
Public Property TitleHeight As Integer
    Get
    Set
Visual C++
public:
property int TitleHeight {
    int get ();
    void set (int value);
}

Field Value

The height of the title.

See Also

vMonthCalendar Class


TodaysDate Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..TodaysDate Property
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime TodaysDate { get; }
Visual Basic
Public ReadOnly Property TodaysDate As DateTime
    Get
Visual C++
public:
property DateTime TodaysDate {
    DateTime get ();
}

See Also

vMonthCalendar Class


UseThemeTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..UseThemeTextColor Property
vMonthCalendar Class See Also Send Feedback
Gets or sets a value indicating whether to use theme's text color

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeTextColor { get; set; }
Visual Basic
Public Property UseThemeTextColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeTextColor {
    bool get ();
    void set (bool value);
}

See Also

vMonthCalendar Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..VIBlendTheme Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vMonthCalendar Class


VisibleDate Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..VisibleDate Property
vMonthCalendar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTime VisibleDate { get; }
Visual Basic
Public ReadOnly Property VisibleDate As DateTime
    Get
Visual C++
public:
property DateTime VisibleDate {
    DateTime get ();
}

See Also

vMonthCalendar Class


WeekendsTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..WeekendsTextColor Property
vMonthCalendar Class See Also Send Feedback
Gets or sets the color of the weekends text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color WeekendsTextColor { get; set; }
Visual Basic
Public Property WeekendsTextColor As Color
    Get
    Set
Visual C++
public:
property Color WeekendsTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the weekends text.

See Also

vMonthCalendar Class


vMonthCalendar Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar Events
vMonthCalendar Class See Also Send Feedback

The vMonthCalendar type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CalendarNavigated | Occurs when user has navigated
Public event | CalendarViewChanged | Occurs when calendar view is changed.
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | CellPaint | Occurs when cell is painted.
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectionChanged | Occurs when selection is changed.
Public event | SelectionChanging | Occurs when selection is changing
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vMonthCalendar Class


CalendarNavigated Event

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..CalendarNavigated Event
vMonthCalendar Class See Also Send Feedback
Occurs when user has navigated

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler CalendarNavigated
Visual Basic
Public Event CalendarNavigated As EventHandler
Visual C++
public:
 event EventHandler^ CalendarNavigated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vMonthCalendar Class


CalendarViewChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..CalendarViewChanged Event
vMonthCalendar Class See Also Send Feedback
Occurs when calendar view is changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler CalendarViewChanged
Visual Basic
Public Event CalendarViewChanged As EventHandler
Visual C++
public:
 event EventHandler^ CalendarViewChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vMonthCalendar Class


CellPaint Event

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..CellPaint Event
vMonthCalendar Class See Also Send Feedback
Occurs when cell is painted.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event CalendarPaintHandler CellPaint
Visual Basic
Public Event CellPaint As CalendarPaintHandler
Visual C++
public:
 event CalendarPaintHandler^ CellPaint {
    void add (CalendarPaintHandler^ value);
    void remove (CalendarPaintHandler^ value);
}

See Also

vMonthCalendar Class


SelectionChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..SelectionChanged Event
vMonthCalendar Class See Also Send Feedback
Occurs when selection is changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<SelectionEventArgs> SelectionChanged
Visual Basic
Public Event SelectionChanged As EventHandler(Of SelectionEventArgs)
Visual C++
public:
 event EventHandler<SelectionEventArgs^>^ SelectionChanged {
    void add (EventHandler<SelectionEventArgs^>^ value);
    void remove (EventHandler<SelectionEventArgs^>^ value);
}

See Also

vMonthCalendar Class


SelectionChanging Event

[image]

VIBlend Controls for WinForms Help Documentation
vMonthCalendar..::..SelectionChanging Event
vMonthCalendar Class See Also Send Feedback
Occurs when selection is changing

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<SelectionCancelEventArgs> SelectionChanging
Visual Basic
Public Event SelectionChanging As EventHandler(Of SelectionCancelEventArgs)
Visual C++
public:
 event EventHandler<SelectionCancelEventArgs^>^ SelectionChanging {
    void add (EventHandler<SelectionCancelEventArgs^>^ value);
    void remove (EventHandler<SelectionCancelEventArgs^>^ value);
}

See Also

vMonthCalendar Class


vMultiLabel Class

[image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel Class
Members See Also Send Feedback
Represents a vMultiLabel control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vMultiLabel : ScrollableControlMiniBase
Visual Basic
Public Class vMultiLabel _
    Inherits ScrollableControlMiniBase
Visual C++
public ref class vMultiLabel : public ScrollableControlMiniBase

Remarks

A vMultiLabel control provides visual grouping of multiple label controls.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
ScrollableControlMiniBase
VIBlend.WinForms.Controls..::..vMultiLabel

See Also

vMultiLabel Members


vMultiLabel Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel Members
vMultiLabel Class Constructors Methods Properties Events See Also Send Feedback

The vMultiLabel type exposes the following members.

Constructors

 | Name | Description
Public method | vMultiLabel | Initializes a new instance of the vLabel class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Labels | Gets a reference to the Labels collection of the vMultiLabel control
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vMultiLabel Class


vMultiLabel Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel Constructor
vMultiLabel Class See Also Send Feedback
Initializes a new instance of the vLabel class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vMultiLabel()
Visual Basic
Public Sub New
Visual C++
public:
vMultiLabel()

See Also

vMultiLabel Class


vMultiLabel Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel Methods
vMultiLabel Class See Also Send Feedback

The vMultiLabel type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vMultiLabel Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel..::..AccessibilityNotifyClients Method
vMultiLabel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vMultiLabel Class
vMultiLabel Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel..::..BeginInvoke Method
vMultiLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vMultiLabel Class
vMultiLabel Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel..::..Dispose Method
vMultiLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vMultiLabel Class
vMultiLabel Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel..::..GetChildAtPoint Method
vMultiLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vMultiLabel Class
vMultiLabel Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel..::..Invalidate Method
vMultiLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vMultiLabel Class
vMultiLabel Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel..::..Invoke Method
vMultiLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vMultiLabel Class
vMultiLabel Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel..::..MemberwiseClone Method
vMultiLabel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vMultiLabel Class
vMultiLabel Members


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel..::..OnLayout Method
vMultiLabel Class See Also Send Feedback
Raises the Layout event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
A LayoutEventArgs that contains the event data.

See Also

vMultiLabel Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel..::..PerformLayout Method
vMultiLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vMultiLabel Class
vMultiLabel Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel..::..ResumeLayout Method
vMultiLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vMultiLabel Class
vMultiLabel Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel..::..RtlTranslateAlignment Method
vMultiLabel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vMultiLabel Class
vMultiLabel Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel..::..Scale Method
vMultiLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vMultiLabel Class
vMultiLabel Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel..::..Select Method
vMultiLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vMultiLabel Class
vMultiLabel Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel..::..SetBounds Method
vMultiLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vMultiLabel Class
vMultiLabel Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel..::..UpdateBounds Method
vMultiLabel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vMultiLabel Class
vMultiLabel Members


vMultiLabel Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel Properties
vMultiLabel Class See Also Send Feedback

The vMultiLabel type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Labels | Gets a reference to the Labels collection of the vMultiLabel control
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vMultiLabel Class


Labels Property

[image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel..::..Labels Property
vMultiLabel Class See Also Send Feedback
Gets a reference to the Labels collection of the vMultiLabel control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vLabelCollection Labels { get; }
Visual Basic
Public ReadOnly Property Labels As vLabelCollection
    Get
Visual C++
public:
property vLabelCollection^ Labels {
    vLabelCollection^ get ();
}

See Also

vMultiLabel Class


vMultiLabel Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vMultiLabel Events
vMultiLabel Class See Also Send Feedback

The vMultiLabel type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vMultiLabel Class


vNavItemCancelEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
vNavItemCancelEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vNavItemCancelEventArgs : vNavItemEventArgs
Visual Basic
Public Class vNavItemCancelEventArgs _
    Inherits vNavItemEventArgs
Visual C++
public ref class vNavItemCancelEventArgs : public vNavItemEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..vNavItemEventArgs
VIBlend.WinForms.Controls..::..vNavItemCancelEventArgs

See Also

vNavItemCancelEventArgs Members


vNavItemCancelEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavItemCancelEventArgs Members
vNavItemCancelEventArgs Class Constructors Methods Properties See Also Send Feedback

The vNavItemCancelEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | vNavItemCancelEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets the cancel property.
Public property | Item | NavigationPane item associated with the event. (Inherited from vNavItemEventArgs.)

See Also

vNavItemCancelEventArgs Class


vNavItemCancelEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vNavItemCancelEventArgs Constructor
vNavItemCancelEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vNavItemCancelEventArgs(
    vNavPaneItem item
)
Visual Basic
Public Sub New ( _
    item As vNavPaneItem _
)
Visual C++
public:
vNavItemCancelEventArgs(
    vNavPaneItem^ item
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..vNavPaneItem
NavigationPane item associated with the event.

See Also

vNavItemCancelEventArgs Class


vNavItemCancelEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavItemCancelEventArgs Methods
vNavItemCancelEventArgs Class See Also Send Feedback

The vNavItemCancelEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vNavItemCancelEventArgs Class


vNavItemCancelEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavItemCancelEventArgs Properties
vNavItemCancelEventArgs Class See Also Send Feedback

The vNavItemCancelEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets the cancel property.
Public property | Item | NavigationPane item associated with the event. (Inherited from vNavItemEventArgs.)

See Also

vNavItemCancelEventArgs Class


Cancel Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavItemCancelEventArgs..::..Cancel Property
vNavItemCancelEventArgs Class See Also Send Feedback
Gets or sets the cancel property.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic
Public Property Cancel As Boolean
    Get
    Set
Visual C++
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}

See Also

vNavItemCancelEventArgs Class


vNavItemEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
vNavItemEventArgs Class
Members See Also Send Feedback
Represents a vNavPane event arguments

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vNavItemEventArgs : EventArgs
Visual Basic
Public Class vNavItemEventArgs _
    Inherits EventArgs
Visual C++
public ref class vNavItemEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..vNavItemEventArgs
VIBlend.WinForms.Controls..::..vNavItemCancelEventArgs

See Also

vNavItemEventArgs Members


vNavItemEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavItemEventArgs Members
vNavItemEventArgs Class Constructors Methods Properties See Also Send Feedback

The vNavItemEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | vNavItemEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | NavigationPane item associated with the event.

See Also

vNavItemEventArgs Class


vNavItemEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vNavItemEventArgs Constructor
vNavItemEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vNavItemEventArgs(
    vNavPaneItem item
)
Visual Basic
Public Sub New ( _
    item As vNavPaneItem _
)
Visual C++
public:
vNavItemEventArgs(
    vNavPaneItem^ item
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..vNavPaneItem
NavigationPane item associated with the event.

See Also

vNavItemEventArgs Class


vNavItemEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavItemEventArgs Methods
vNavItemEventArgs Class See Also Send Feedback

The vNavItemEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vNavItemEventArgs Class


vNavItemEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavItemEventArgs Properties
vNavItemEventArgs Class See Also Send Feedback

The vNavItemEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Item | NavigationPane item associated with the event.

See Also

vNavItemEventArgs Class


Item Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavItemEventArgs..::..Item Property
vNavItemEventArgs Class See Also Send Feedback
NavigationPane item associated with the event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vNavPaneItem Item { get; }
Visual Basic
Public ReadOnly Property Item As vNavPaneItem
    Get
Visual C++
public:
property vNavPaneItem^ Item {
    vNavPaneItem^ get ();
}

See Also

vNavItemEventArgs Class


vNavPane Class

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane Class
Members See Also Send Feedback
Represents a NavigationPane control, which allows the user to select from a list of container controls that can host other controls.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vNavPane : Panel, IScrollableControlBase
Visual Basic
Public Class vNavPane _
    Inherits Panel _
    Implements IScrollableControlBase
Visual C++
public ref class vNavPane : public Panel,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..Panel
VIBlend.WinForms.Controls..::..vNavPane

See Also

vNavPane Members


vNavPane Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane Members
vNavPane Class Constructors Methods Properties Events See Also Send Feedback

The vNavPane type exposes the following members.

Constructors

 | Name | Description
Public method | vNavPane | Initializes a new instance of the vNavPane class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clears this instance.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest | HitTest to find whether on the point position there is nav pane item
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | LayoutControl | Layouts the control and its items.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawItemHeader | Raises the [E:DrawItemHeader] event.
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Public method | OnExpandedChanged | Called when expanded is changed.
Public method | OnExpandedChanging | Raises the [E:ExpandedChanging] event.
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides ScrollableControl..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnToolTipShown |
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectItem(Int32) | Expands an item.
Public method | SelectItem(vNavPaneItem) | Selects a specific navigation pane item
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowPressedItemState |
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AnimationDelay | Gets or sets the animation Delay.
Public property | AnimationPower | Gets or sets the animation power.
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets whether the control is enabled.
Public property | EnableToolTips | Gets or sets a value indicating whether tool tips are enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImageList | Gets or sets the list of images to display on the control's items.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsExpandCollapseAnimationEnabled | Gets or sets whether the expand/collapse animation is enabled.
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets the collection of panes in this navigationpane control.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Theme | Gets or sets the theme of the control.
Public property | ToolTipDuration | Gets or sets the duration of the tool tip.
Public property | ToolTipShowDelay | Gets or sets the tool tip show delay.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItemHeader | Occurs when the item's header is rendered.
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | ExpandedChanged | Occurs when a the expanded item changes inside the navigation pane
Public event | ExpandedChanging | Occurs when a the expanded item changes inside the navigation pane
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | TooltipShow | Occurs when tooltip shows.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vNavPane Class


vNavPane Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane Constructor
vNavPane Class See Also Send Feedback
Initializes a new instance of the vNavPane class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vNavPane()
Visual Basic
Public Sub New
Visual C++
public:
vNavPane()

See Also

vNavPane Class


vNavPane Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane Methods
vNavPane Class See Also Send Feedback

The vNavPane type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clears this instance.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest | HitTest to find whether on the point position there is nav pane item
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | LayoutControl | Layouts the control and its items.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawItemHeader | Raises the [E:DrawItemHeader] event.
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Public method | OnExpandedChanged | Called when expanded is changed.
Public method | OnExpandedChanging | Raises the [E:ExpandedChanging] event.
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides ScrollableControl..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnToolTipShown |
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectItem(Int32) | Expands an item.
Public method | SelectItem(vNavPaneItem) | Selects a specific navigation pane item
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

See Also

vNavPane Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..AccessibilityNotifyClients Method
vNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vNavPane Class
vNavPane Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..BeginInvoke Method
vNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vNavPane Class
vNavPane Members


Clear Method

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..Clear Method
vNavPane Class See Also Send Feedback
Clears this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

vNavPane Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..Dispose Method
vNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)

See Also

vNavPane Class
vNavPane Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..Dispose Method (Boolean)
vNavPane Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vNavPane Class
Dispose Overload


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..GetChildAtPoint Method
vNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vNavPane Class
vNavPane Members


HitTest Method

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..HitTest Method
vNavPane Class See Also Send Feedback
HitTest to find whether on the point position there is nav pane item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vNavPaneItem HitTest()
Visual Basic
Public Function HitTest As vNavPaneItem
Visual C++
public:
vNavPaneItem^ HitTest()

Return Value

See Also

vNavPane Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..Invalidate Method
vNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vNavPane Class
vNavPane Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..Invoke Method
vNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vNavPane Class
vNavPane Members


LayoutControl Method

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..LayoutControl Method
vNavPane Class See Also Send Feedback
Layouts the control and its items.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void LayoutControl(
    bool fromLayout
)
Visual Basic
Protected Overridable Sub LayoutControl ( _
    fromLayout As Boolean _
)
Visual C++
protected:
virtual void LayoutControl(
    bool fromLayout
)

Parameters

fromLayout
Type: System..::..Boolean

See Also

vNavPane Class


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..MemberwiseClone Method
vNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vNavPane Class
vNavPane Members


OnDrawItemHeader Method

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..OnDrawItemHeader Method
vNavPane Class See Also Send Feedback
Raises the [E:DrawItemHeader] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnDrawItemHeader(
    DrawNavPaneEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnDrawItemHeader ( _
    args As DrawNavPaneEventArgs _
)
Visual C++
protected public:
virtual void OnDrawItemHeader(
    DrawNavPaneEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.Controls..::..DrawNavPaneEventArgs
The DrawNavPaneEventArgs instance containing the event data.

See Also

vNavPane Class


OnExpandedChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..OnExpandedChanged Method
vNavPane Class See Also Send Feedback
Called when expanded is changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnExpandedChanged(
    vNavPaneItem item
)
Visual Basic
Public Sub OnExpandedChanged ( _
    item As vNavPaneItem _
)
Visual C++
public:
void OnExpandedChanged(
    vNavPaneItem^ item
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..vNavPaneItem
The item.

See Also

vNavPane Class


OnExpandedChanging Method

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..OnExpandedChanging Method
vNavPane Class See Also Send Feedback
Raises the [E:ExpandedChanging] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnExpandedChanging(
    vNavItemCancelEventArgs args
)
Visual Basic
Public Sub OnExpandedChanging ( _
    args As vNavItemCancelEventArgs _
)
Visual C++
public:
void OnExpandedChanging(
    vNavItemCancelEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.Controls..::..vNavItemCancelEventArgs
The vNavItemCancelEventArgs instance containing the event data.

See Also

vNavPane Class


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..OnLayout Method
vNavPane Class See Also Send Feedback
Raises the Layout event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
A LayoutEventArgs that contains the event data.

See Also

vNavPane Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..OnPaint Method
vNavPane Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vNavPane Class


OnToolTipShown Method

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..OnToolTipShown Method
vNavPane Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnToolTipShown(
    ToolTipEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnToolTipShown ( _
    args As ToolTipEventArgs _
)
Visual C++
protected public:
virtual void OnToolTipShown(
    ToolTipEventArgs^ args
)

Parameters

args
Type: ToolTipEventArgs

See Also

vNavPane Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..PerformLayout Method
vNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vNavPane Class
vNavPane Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..ResumeLayout Method
vNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vNavPane Class
vNavPane Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..RtlTranslateAlignment Method
vNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vNavPane Class
vNavPane Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..Scale Method
vNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vNavPane Class
vNavPane Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..Select Method
vNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vNavPane Class
vNavPane Members


SelectItem Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..SelectItem Method
vNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SelectItem(Int32) | Expands an item.
Public method | SelectItem(vNavPaneItem) | Selects a specific navigation pane item

See Also

vNavPane Class
vNavPane Members


SelectItem Method (Int32)

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..SelectItem Method (Int32)
vNavPane Class See Also Send Feedback
Expands an item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SelectItem(
    int index
)
Visual Basic
Public Sub SelectItem ( _
    index As Integer _
)
Visual C++
public:
void SelectItem(
    int index
)

Parameters

index
Type: System..::..Int32
The index.

See Also

vNavPane Class
SelectItem Overload


SelectItem Method (vNavPaneItem)

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..SelectItem Method (vNavPaneItem)
vNavPane Class See Also Send Feedback
Selects a specific navigation pane item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SelectItem(
    vNavPaneItem item
)
Visual Basic
Public Sub SelectItem ( _
    item As vNavPaneItem _
)
Visual C++
public:
void SelectItem(
    vNavPaneItem^ item
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..vNavPaneItem
The Item to select

See Also

vNavPane Class
SelectItem Overload


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..SetBounds Method
vNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vNavPane Class
vNavPane Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..UpdateBounds Method
vNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vNavPane Class
vNavPane Members


vNavPane Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane Properties
vNavPane Class See Also Send Feedback

The vNavPane type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowPressedItemState |
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AnimationDelay | Gets or sets the animation Delay.
Public property | AnimationPower | Gets or sets the animation power.
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets whether the control is enabled.
Public property | EnableToolTips | Gets or sets a value indicating whether tool tips are enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImageList | Gets or sets the list of images to display on the control's items.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsExpandCollapseAnimationEnabled | Gets or sets whether the expand/collapse animation is enabled.
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets the collection of panes in this navigationpane control.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Theme | Gets or sets the theme of the control.
Public property | ToolTipDuration | Gets or sets the duration of the tool tip.
Public property | ToolTipShowDelay | Gets or sets the tool tip show delay.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vNavPane Class


AllowPressedItemState Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..AllowPressedItemState Property
vNavPane Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowPressedItemState { get; set; }
Visual Basic
Public Property AllowPressedItemState As Boolean
    Get
    Set
Visual C++
public:
property bool AllowPressedItemState {
    bool get ();
    void set (bool value);
}

See Also

vNavPane Class


AnimationDelay Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..AnimationDelay Property
vNavPane Class See Also Send Feedback
Gets or sets the animation Delay.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int AnimationDelay { get; set; }
Visual Basic
Public Property AnimationDelay As Integer
    Get
    Set
Visual C++
public:
property int AnimationDelay {
    int get ();
    void set (int value);
}

Field Value

The animation Delay.

See Also

vNavPane Class


AnimationPower Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..AnimationPower Property
vNavPane Class See Also Send Feedback
Gets or sets the animation power.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int AnimationPower { get; set; }
Visual Basic
Public Property AnimationPower As Integer
    Get
    Set
Visual C++
public:
property int AnimationPower {
    int get ();
    void set (int value);
}

Field Value

The animation power.

See Also

vNavPane Class


Enabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..Enabled Property
vNavPane Class See Also Send Feedback
Gets or sets whether the control is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

vNavPane Class


EnableToolTips Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..EnableToolTips Property
vNavPane Class See Also Send Feedback
Gets or sets a value indicating whether tool tips are enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool EnableToolTips { get; set; }
Visual Basic
Public Overridable Property EnableToolTips As Boolean
    Get
    Set
Visual C++
public:
virtual property bool EnableToolTips {
    bool get ();
    void set (bool value);
}

See Also

vNavPane Class


ImageList Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..ImageList Property
vNavPane Class See Also Send Feedback
Gets or sets the list of images to display on the control's items.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ImageList ImageList { get; set; }
Visual Basic
Public Overridable Property ImageList As ImageList
    Get
    Set
Visual C++
public:
virtual property ImageList^ ImageList {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

vNavPane Class


IsExpandCollapseAnimationEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..IsExpandCollapseAnimationEnabled Property
vNavPane Class See Also Send Feedback
Gets or sets whether the expand/collapse animation is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsExpandCollapseAnimationEnabled { get; set; }
Visual Basic
Public Property IsExpandCollapseAnimationEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsExpandCollapseAnimationEnabled {
    bool get ();
    void set (bool value);
}

See Also

vNavPane Class


Items Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..Items Property
vNavPane Class See Also Send Feedback
Gets the collection of panes in this navigationpane control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public NavPaneItemsCollection Items { get; }
Visual Basic
Public ReadOnly Property Items As NavPaneItemsCollection
    Get
Visual C++
public:
property NavPaneItemsCollection^ Items {
    NavPaneItemsCollection^ get ();
}

See Also

vNavPane Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..Theme Property
vNavPane Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vNavPane Class


ToolTipDuration Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..ToolTipDuration Property
vNavPane Class See Also Send Feedback
Gets or sets the duration of the tool tip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ToolTipDuration { get; set; }
Visual Basic
Public Property ToolTipDuration As Integer
    Get
    Set
Visual C++
public:
property int ToolTipDuration {
    int get ();
    void set (int value);
}

Field Value

The duration of the tool tip.

See Also

vNavPane Class


ToolTipShowDelay Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..ToolTipShowDelay Property
vNavPane Class See Also Send Feedback
Gets or sets the tool tip show delay.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ToolTipShowDelay { get; set; }
Visual Basic
Public Property ToolTipShowDelay As Integer
    Get
    Set
Visual C++
public:
property int ToolTipShowDelay {
    int get ();
    void set (int value);
}

Field Value

The tool tip show delay.

See Also

vNavPane Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..VIBlendTheme Property
vNavPane Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vNavPane Class


vNavPane Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPane Events
vNavPane Class See Also Send Feedback

The vNavPane type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItemHeader | Occurs when the item's header is rendered.
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | ExpandedChanged | Occurs when a the expanded item changes inside the navigation pane
Public event | ExpandedChanging | Occurs when a the expanded item changes inside the navigation pane
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | TooltipShow | Occurs when tooltip shows.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vNavPane Class


DrawItemHeader Event

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..DrawItemHeader Event
vNavPane Class See Also Send Feedback
Occurs when the item's header is rendered.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<DrawNavPaneEventArgs> DrawItemHeader
Visual Basic
Public Event DrawItemHeader As EventHandler(Of DrawNavPaneEventArgs)
Visual C++
public:
 event EventHandler<DrawNavPaneEventArgs^>^ DrawItemHeader {
    void add (EventHandler<DrawNavPaneEventArgs^>^ value);
    void remove (EventHandler<DrawNavPaneEventArgs^>^ value);
}

See Also

vNavPane Class


ExpandedChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..ExpandedChanged Event
vNavPane Class See Also Send Feedback
Occurs when a the expanded item changes inside the navigation pane

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<vNavItemEventArgs> ExpandedChanged
Visual Basic
Public Event ExpandedChanged As EventHandler(Of vNavItemEventArgs)
Visual C++
public:
 event EventHandler<vNavItemEventArgs^>^ ExpandedChanged {
    void add (EventHandler<vNavItemEventArgs^>^ value);
    void remove (EventHandler<vNavItemEventArgs^>^ value);
}

See Also

vNavPane Class


ExpandedChanging Event

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..ExpandedChanging Event
vNavPane Class See Also Send Feedback
Occurs when a the expanded item changes inside the navigation pane

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<vNavItemCancelEventArgs> ExpandedChanging
Visual Basic
Public Event ExpandedChanging As EventHandler(Of vNavItemCancelEventArgs)
Visual C++
public:
 event EventHandler<vNavItemCancelEventArgs^>^ ExpandedChanging {
    void add (EventHandler<vNavItemCancelEventArgs^>^ value);
    void remove (EventHandler<vNavItemCancelEventArgs^>^ value);
}

See Also

vNavPane Class


TooltipShow Event

[image]

VIBlend Controls for WinForms Help Documentation
vNavPane..::..TooltipShow Event
vNavPane Class See Also Send Feedback
Occurs when tooltip shows.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event ToolTipShownHandler TooltipShow
Visual Basic
Public Event TooltipShow As ToolTipShownHandler
Visual C++
public:
 event ToolTipShownHandler^ TooltipShow {
    void add (ToolTipShownHandler^ value);
    void remove (ToolTipShownHandler^ value);
}

See Also

vNavPane Class


vNavPaneItem Class

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem Class
Members See Also Send Feedback
Represents a vNavPane item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vNavPaneItem : Control,
    INotifyPropertyChanged
Visual Basic
Public Class vNavPaneItem _
    Inherits Control _
    Implements INotifyPropertyChanged
Visual C++
public ref class vNavPaneItem : public Control,
    INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vNavPaneItem

See Also

vNavPaneItem Members


vNavPaneItem Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem Members
vNavPaneItem Class Constructors Methods Properties Events See Also Send Feedback

The vNavPaneItem type exposes the following members.

Constructors

 | Name | Description
Public method | vNavPaneItem | Initializes a new instance of the vNavPaneItem class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clears this instance.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when a property is changed.
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundBorder | Gets or sets the background border.
Public property | BackgroundBrush | Gets or sets the background brush.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisabledBackgroundBorder | Gets or sets the disabledBackgroundBorder border.
Public property | DisabledBackgroundBrush | Gets or sets the disabled background brush.
Public property | DisabledTextColor | Gets or sets the disabledTextColor TextColor.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | HeaderControl | Gets the header control.
Public property | HeaderFont | Gets or sets the font of the text to display in the item's header area
Public property | HeaderHeight | Gets or sets the height of the header area of the item
Public property | HeaderImageAlignment | Gets or sets the image alignment.
Public property | HeaderText | Gets or sets the text to display on the item's header area
Public property | HeaderTextAlignment | Gets or sets the text alignment.
Public property | HeaderTextImageRelation | Gets or sets the header text and image relation.
Public property | HeaderTheme | Gets or sets the theme of the item's header.
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightBackgroundBorder | Gets or sets the highlightBackground border.
Public property | HighlightBackgroundBrush | Gets or sets the HighlightBackground brush.
Public property | HighlightTextColor | Gets or sets the highlight TextColor.
Public property | Image | Gets or sets the image to display on the item's header
Public property | ImageIndex | Gets or sets the index of the image to display on the item's header
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsExpanded | Checks if the item is currently in expanded state
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemPanel | Gets a reference to the panel which hosts the controls within the navigation pane item
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavPane | Gets a reference to the NavigationPane control which hosts the item
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedBackgroundBorder | Gets or sets the selectedBackground border.
Public property | SelectedBackgroundBrush | Gets or sets the background brush.
Public property | SelectedTextColor | Gets or sets the selected TextColor.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | TextColor | Gets or sets the TextColor.
Public property | TooltipText | Gets or sets the tooltip text of the item.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use theme's text color
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property value is changed.
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vNavPaneItem Class


vNavPaneItem Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem Constructor
vNavPaneItem Class See Also Send Feedback
Initializes a new instance of the vNavPaneItem class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vNavPaneItem()
Visual Basic
Public Sub New
Visual C++
public:
vNavPaneItem()

See Also

vNavPaneItem Class


vNavPaneItem Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem Methods
vNavPaneItem Class See Also Send Feedback

The vNavPaneItem type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clears this instance.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when a property is changed.
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vNavPaneItem Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..AccessibilityNotifyClients Method
vNavPaneItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vNavPaneItem Class
vNavPaneItem Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..BeginInvoke Method
vNavPaneItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vNavPaneItem Class
vNavPaneItem Members


Clear Method

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..Clear Method
vNavPaneItem Class See Also Send Feedback
Clears this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

vNavPaneItem Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..Dispose Method
vNavPaneItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Overrides Control..::..Dispose(Boolean).)

See Also

vNavPaneItem Class
vNavPaneItem Members


Dispose Method

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..Dispose Method
vNavPaneItem Class See Also Send Feedback
Releases all resources used by the Component.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
void Dispose()

See Also

vNavPaneItem Class
Dispose Overload


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..Dispose Method (Boolean)
vNavPaneItem Class See Also Send Feedback
Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

vNavPaneItem Class
Dispose Overload


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..GetChildAtPoint Method
vNavPaneItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vNavPaneItem Class
vNavPaneItem Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..Invalidate Method
vNavPaneItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vNavPaneItem Class
vNavPaneItem Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..Invoke Method
vNavPaneItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vNavPaneItem Class
vNavPaneItem Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..MemberwiseClone Method
vNavPaneItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vNavPaneItem Class
vNavPaneItem Members


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..OnLayout Method
vNavPaneItem Class See Also Send Feedback
Raises the Layout event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
A LayoutEventArgs that contains the event data.

See Also

vNavPaneItem Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..OnMouseMove Method
vNavPaneItem Class See Also Send Feedback
Raises the MouseMove event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vNavPaneItem Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..OnPaint Method
vNavPaneItem Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vNavPaneItem Class


OnPropertyChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..OnPropertyChanged Method
vNavPaneItem Class See Also Send Feedback
Called when a property is changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String
Name of the property.

See Also

vNavPaneItem Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..PerformLayout Method
vNavPaneItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vNavPaneItem Class
vNavPaneItem Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..ResumeLayout Method
vNavPaneItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vNavPaneItem Class
vNavPaneItem Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..RtlTranslateAlignment Method
vNavPaneItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vNavPaneItem Class
vNavPaneItem Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..Scale Method
vNavPaneItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vNavPaneItem Class
vNavPaneItem Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..Select Method
vNavPaneItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vNavPaneItem Class
vNavPaneItem Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..SetBounds Method
vNavPaneItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vNavPaneItem Class
vNavPaneItem Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..UpdateBounds Method
vNavPaneItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vNavPaneItem Class
vNavPaneItem Members


vNavPaneItem Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem Properties
vNavPaneItem Class See Also Send Feedback

The vNavPaneItem type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundBorder | Gets or sets the background border.
Public property | BackgroundBrush | Gets or sets the background brush.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisabledBackgroundBorder | Gets or sets the disabledBackgroundBorder border.
Public property | DisabledBackgroundBrush | Gets or sets the disabled background brush.
Public property | DisabledTextColor | Gets or sets the disabledTextColor TextColor.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | HeaderControl | Gets the header control.
Public property | HeaderFont | Gets or sets the font of the text to display in the item's header area
Public property | HeaderHeight | Gets or sets the height of the header area of the item
Public property | HeaderImageAlignment | Gets or sets the image alignment.
Public property | HeaderText | Gets or sets the text to display on the item's header area
Public property | HeaderTextAlignment | Gets or sets the text alignment.
Public property | HeaderTextImageRelation | Gets or sets the header text and image relation.
Public property | HeaderTheme | Gets or sets the theme of the item's header.
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightBackgroundBorder | Gets or sets the highlightBackground border.
Public property | HighlightBackgroundBrush | Gets or sets the HighlightBackground brush.
Public property | HighlightTextColor | Gets or sets the highlight TextColor.
Public property | Image | Gets or sets the image to display on the item's header
Public property | ImageIndex | Gets or sets the index of the image to display on the item's header
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsExpanded | Checks if the item is currently in expanded state
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemPanel | Gets a reference to the panel which hosts the controls within the navigation pane item
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavPane | Gets a reference to the NavigationPane control which hosts the item
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedBackgroundBorder | Gets or sets the selectedBackground border.
Public property | SelectedBackgroundBrush | Gets or sets the background brush.
Public property | SelectedTextColor | Gets or sets the selected TextColor.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | TextColor | Gets or sets the TextColor.
Public property | TooltipText | Gets or sets the tooltip text of the item.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use theme's text color
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vNavPaneItem Class


BackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..BackgroundBorder Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the background border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BackgroundBorder { get; set; }
Visual Basic
Public Property BackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color BackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The background border.

See Also

vNavPaneItem Class


BackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..BackgroundBrush Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush BackgroundBrush { get; set; }
Visual Basic
Public Property BackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ BackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vNavPaneItem Class


DisabledBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..DisabledBackgroundBorder Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the disabledBackgroundBorder border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DisabledBackgroundBorder { get; set; }
Visual Basic
Public Property DisabledBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color DisabledBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The disabledBackgroundBorder border.

See Also

vNavPaneItem Class


DisabledBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..DisabledBackgroundBrush Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the disabled background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush DisabledBackgroundBrush { get; set; }
Visual Basic
Public Property DisabledBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ DisabledBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The disabled background brush.

See Also

vNavPaneItem Class


DisabledTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..DisabledTextColor Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the disabledTextColor TextColor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DisabledTextColor { get; set; }
Visual Basic
Public Property DisabledTextColor As Color
    Get
    Set
Visual C++
public:
property Color DisabledTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The disabledTextColor TextColor.

See Also

vNavPaneItem Class


HeaderControl Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..HeaderControl Property
vNavPaneItem Class See Also Send Feedback
Gets the header control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vNavPaneHeader HeaderControl { get; }
Visual Basic
Public ReadOnly Property HeaderControl As vNavPaneHeader
    Get
Visual C++
public:
property vNavPaneHeader^ HeaderControl {
    vNavPaneHeader^ get ();
}

Field Value

The header control.

See Also

vNavPaneItem Class


HeaderFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..HeaderFont Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the font of the text to display in the item's header area

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font HeaderFont { get; set; }
Visual Basic
Public Property HeaderFont As Font
    Get
    Set
Visual C++
public:
property Font^ HeaderFont {
    Font^ get ();
    void set (Font^ value);
}

See Also

vNavPaneItem Class


HeaderHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..HeaderHeight Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the height of the header area of the item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int HeaderHeight { get; set; }
Visual Basic
Public Property HeaderHeight As Integer
    Get
    Set
Visual C++
public:
property int HeaderHeight {
    int get ();
    void set (int value);
}

See Also

vNavPaneItem Class


HeaderImageAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..HeaderImageAlignment Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the image alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment HeaderImageAlignment { get; set; }
Visual Basic
Public Property HeaderImageAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment HeaderImageAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The image alignment.

See Also

vNavPaneItem Class


HeaderText Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..HeaderText Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the text to display on the item's header area

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string HeaderText { get; set; }
Visual Basic
Public Property HeaderText As String
    Get
    Set
Visual C++
public:
property String^ HeaderText {
    String^ get ();
    void set (String^ value);
}

See Also

vNavPaneItem Class


HeaderTextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..HeaderTextAlignment Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment HeaderTextAlignment { get; set; }
Visual Basic
Public Property HeaderTextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment HeaderTextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The text alignment.

See Also

vNavPaneItem Class


HeaderTextImageRelation Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..HeaderTextImageRelation Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the header text and image relation.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public TextImageRelation HeaderTextImageRelation { get; set; }
Visual Basic
Public Property HeaderTextImageRelation As TextImageRelation
    Get
    Set
Visual C++
public:
property TextImageRelation HeaderTextImageRelation {
    TextImageRelation get ();
    void set (TextImageRelation value);
}

Field Value

The header text and image relation.

See Also

vNavPaneItem Class


HeaderTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..HeaderTheme Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the theme of the item's header.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme HeaderTheme { get; set; }
Visual Basic
Public Property HeaderTheme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ HeaderTheme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vNavPaneItem Class


HighlightBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..HighlightBackgroundBorder Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the highlightBackground border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color HighlightBackgroundBorder { get; set; }
Visual Basic
Public Property HighlightBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color HighlightBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The highlightBackground border.

See Also

vNavPaneItem Class


HighlightBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..HighlightBackgroundBrush Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the HighlightBackground brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush HighlightBackgroundBrush { get; set; }
Visual Basic
Public Property HighlightBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ HighlightBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The HighlightBackground brush.

See Also

vNavPaneItem Class


HighlightTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..HighlightTextColor Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the highlight TextColor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color HighlightTextColor { get; set; }
Visual Basic
Public Property HighlightTextColor As Color
    Get
    Set
Visual C++
public:
property Color HighlightTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The highlight TextColor.

See Also

vNavPaneItem Class


Image Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..Image Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the image to display on the item's header

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Image Image { get; set; }
Visual Basic
Public Property Image As Image
    Get
    Set
Visual C++
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}

See Also

vNavPaneItem Class


ImageIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..ImageIndex Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the index of the image to display on the item's header

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ImageIndex { get; set; }
Visual Basic
Public Property ImageIndex As Integer
    Get
    Set
Visual C++
public:
property int ImageIndex {
    int get ();
    void set (int value);
}

See Also

vNavPaneItem Class


IsExpanded Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..IsExpanded Property
vNavPaneItem Class See Also Send Feedback
Checks if the item is currently in expanded state

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsExpanded { get; internal set; }
Visual Basic
Public Property IsExpanded As Boolean
    Get
    Friend Set
Visual C++
public:
property bool IsExpanded {
    bool get ();
    internal: void set (bool value);
}

See Also

vNavPaneItem Class


ItemPanel Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..ItemPanel Property
vNavPaneItem Class See Also Send Feedback
Gets a reference to the panel which hosts the controls within the navigation pane item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Panel ItemPanel { get; internal set; }
Visual Basic
Public Property ItemPanel As Panel
    Get
    Friend Set
Visual C++
public:
property Panel^ ItemPanel {
    Panel^ get ();
    internal: void set (Panel^ value);
}

See Also

vNavPaneItem Class


NavPane Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..NavPane Property
vNavPaneItem Class See Also Send Feedback
Gets a reference to the NavigationPane control which hosts the item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vNavPane NavPane { get; }
Visual Basic
Public ReadOnly Property NavPane As vNavPane
    Get
Visual C++
public:
property vNavPane^ NavPane {
    vNavPane^ get ();
}

See Also

vNavPaneItem Class


SelectedBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..SelectedBackgroundBorder Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the selectedBackground border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color SelectedBackgroundBorder { get; set; }
Visual Basic
Public Property SelectedBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color SelectedBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The selectedBackground border.

See Also

vNavPaneItem Class


SelectedBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..SelectedBackgroundBrush Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush SelectedBackgroundBrush { get; set; }
Visual Basic
Public Property SelectedBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ SelectedBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vNavPaneItem Class


SelectedTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..SelectedTextColor Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the selected TextColor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color SelectedTextColor { get; set; }
Visual Basic
Public Property SelectedTextColor As Color
    Get
    Set
Visual C++
public:
property Color SelectedTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The selected TextColor.

See Also

vNavPaneItem Class


TextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..TextColor Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the TextColor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color TextColor { get; set; }
Visual Basic
Public Property TextColor As Color
    Get
    Set
Visual C++
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}

Field Value

The TextColor.

See Also

vNavPaneItem Class


TooltipText Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..TooltipText Property
vNavPaneItem Class See Also Send Feedback
Gets or sets the tooltip text of the item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string TooltipText { get; set; }
Visual Basic
Public Property TooltipText As String
    Get
    Set
Visual C++
public:
property String^ TooltipText {
    String^ get ();
    void set (String^ value);
}

See Also

vNavPaneItem Class


UseThemeBackground Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..UseThemeBackground Property
vNavPaneItem Class See Also Send Feedback
Gets or sets a value indicating whether to use theme's background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBackground { get; set; }
Visual Basic
Public Property UseThemeBackground As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBackground {
    bool get ();
    void set (bool value);
}

See Also

vNavPaneItem Class


UseThemeTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..UseThemeTextColor Property
vNavPaneItem Class See Also Send Feedback
Gets or sets a value indicating whether to use theme's text color

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeTextColor { get; set; }
Visual Basic
Public Property UseThemeTextColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeTextColor {
    bool get ();
    void set (bool value);
}

See Also

vNavPaneItem Class


vNavPaneItem Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem Events
vNavPaneItem Class See Also Send Feedback

The vNavPaneItem type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property value is changed.
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vNavPaneItem Class


PropertyChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vNavPaneItem..::..PropertyChanged Event
vNavPaneItem Class See Also Send Feedback
Occurs when a property value is changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

vNavPaneItem Class


vNumberEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vNumberEditor : InputBase
Visual Basic
Public Class vNumberEditor _
    Inherits InputBase
Visual C++
public ref class vNumberEditor : public InputBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vTextBox
VIBlend.WinForms.Controls..::..InputBase
VIBlend.WinForms.Controls..::..vNumberEditor
VIBlend.WinForms.DataGridView..::..NumberEditor

See Also

vNumberEditor Members


vNumberEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor Members
vNumberEditor Class Constructors Methods Fields Properties Events See Also Send Feedback

The vNumberEditor type exposes the following members.

Constructors

 | Name | Description
Public method | vNumberEditor | Initializes a new instance of NumberEditor.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | (Overrides InputBase..::..Backspace()()()().)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from InputBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | (Overrides InputBase..::..CtrlC()()()().)
Protected method | CtrlV | (Overrides InputBase..::..CtrlV()()()().)
Protected method | CtrlX | (Overrides InputBase..::..CtrlX()()()().)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | (Overrides InputBase..::..Delete()()()().)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key. (Inherited from InputBase.)
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key. (Inherited from InputBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider. (Inherited from InputBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text. (Inherited from InputBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key. (Inherited from InputBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | (Overrides InputBase..::..Insert(String).)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown | (Inherited from InputBase.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed. (Inherited from InputBase.)
Public method | LeftKey | Moves the cursor one position left. (Inherited from InputBase.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from InputBase.)
Protected method | OnKeyPress | (Inherited from InputBase.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from InputBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | (Inherited from InputBase.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | (Inherited from InputBase.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from InputBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event. (Inherited from InputBase.)
Protected method | OnValueChanged | Calls the ValueChanged event. (Inherited from InputBase.)
Protected method | OnValueChanging | Calls the ValueChanging event. (Inherited from InputBase.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | Parses editor's value. (Overrides InputBase..::..ParseValue()()()().)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | (Overrides InputBase..::..Redo()()()().)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters. (Inherited from InputBase.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key. (Inherited from InputBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | (Overrides InputBase..::..SetFormattedText()()()().)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit | (Inherited from InputBase.)
Protected method | SpinDigitWithWrap | Spins the digit with wrap. (Inherited from InputBase.)
Public method | SpinValue | Increases or decreases the current value. (Inherited from InputBase.)
Protected method | SpinValueBeforeDigit | Spins the value before digit. (Inherited from InputBase.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | Makes undo of the current value. (Overrides InputBase..::..Undo()()()().)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key. (Inherited from InputBase.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | baseFormatString | (Inherited from InputBase.)
Protected field | cultureInfo | (Inherited from InputBase.)
Protected field | decimalPlaces | (Inherited from InputBase.)
Protected field | decimalPossibleChars | (Inherited from InputBase.)
Protected field | emptyValue | (Inherited from InputBase.)
Protected field | formatString | (Inherited from InputBase.)
Protected field | isLessThanZero | (Inherited from InputBase.)
Protected field | manager | (Inherited from InputBase.)
Protected field | maximum | (Inherited from InputBase.)
Protected field | minimum | (Inherited from InputBase.)
Protected field | undoValue | (Inherited from InputBase.)
Protected field | value | (Inherited from InputBase.)
Protected field | valueString | (Inherited from InputBase.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information. (Inherited from InputBase.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DecimalPlaces | Gets or sets editor's decimal places. (Inherited from InputBase.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator | (Inherited from InputBase.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value. (Inherited from InputBase.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value. (Inherited from InputBase.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | (Inherited from InputBase.)
Public property | Minimum | Gets or sets editor's Minimum value. (Inherited from InputBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | Gets the current separator character. (Overrides InputBase..::..SeparatorChar.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type. (Inherited from InputBase.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from InputBase.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from InputBase.)
Public property | Value | Gets or sets editor's value. (Inherited from InputBase.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed. (Inherited from InputBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event. (Inherited from InputBase.)
Public event | ValueChanged | Represents the ValueChanged event. (Inherited from InputBase.)
Public event | ValueChanging | Represents the ValueChanging event. (Inherited from InputBase.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vNumberEditor Class


vNumberEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor Constructor
vNumberEditor Class See Also Send Feedback
Initializes a new instance of NumberEditor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vNumberEditor()
Visual Basic
Public Sub New
Visual C++
public:
vNumberEditor()

See Also

vNumberEditor Class


vNumberEditor Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor Fields
vNumberEditor Class See Also Send Feedback

The vNumberEditor type exposes the following members.

Fields

 | Name | Description
Protected field | baseFormatString | (Inherited from InputBase.)
Protected field | cultureInfo | (Inherited from InputBase.)
Protected field | decimalPlaces | (Inherited from InputBase.)
Protected field | decimalPossibleChars | (Inherited from InputBase.)
Protected field | emptyValue | (Inherited from InputBase.)
Protected field | formatString | (Inherited from InputBase.)
Protected field | isLessThanZero | (Inherited from InputBase.)
Protected field | manager | (Inherited from InputBase.)
Protected field | maximum | (Inherited from InputBase.)
Protected field | minimum | (Inherited from InputBase.)
Protected field | undoValue | (Inherited from InputBase.)
Protected field | value | (Inherited from InputBase.)
Protected field | valueString | (Inherited from InputBase.)

See Also

vNumberEditor Class


vNumberEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor Methods
vNumberEditor Class See Also Send Feedback

The vNumberEditor type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | (Overrides InputBase..::..Backspace()()()().)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from InputBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | (Overrides InputBase..::..CtrlC()()()().)
Protected method | CtrlV | (Overrides InputBase..::..CtrlV()()()().)
Protected method | CtrlX | (Overrides InputBase..::..CtrlX()()()().)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | (Overrides InputBase..::..Delete()()()().)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key. (Inherited from InputBase.)
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key. (Inherited from InputBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider. (Inherited from InputBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text. (Inherited from InputBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key. (Inherited from InputBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | (Overrides InputBase..::..Insert(String).)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown | (Inherited from InputBase.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed. (Inherited from InputBase.)
Public method | LeftKey | Moves the cursor one position left. (Inherited from InputBase.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from InputBase.)
Protected method | OnKeyPress | (Inherited from InputBase.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from InputBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | (Inherited from InputBase.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | (Inherited from InputBase.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from InputBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event. (Inherited from InputBase.)
Protected method | OnValueChanged | Calls the ValueChanged event. (Inherited from InputBase.)
Protected method | OnValueChanging | Calls the ValueChanging event. (Inherited from InputBase.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | Parses editor's value. (Overrides InputBase..::..ParseValue()()()().)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | (Overrides InputBase..::..Redo()()()().)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters. (Inherited from InputBase.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key. (Inherited from InputBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | (Overrides InputBase..::..SetFormattedText()()()().)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit | (Inherited from InputBase.)
Protected method | SpinDigitWithWrap | Spins the digit with wrap. (Inherited from InputBase.)
Public method | SpinValue | Increases or decreases the current value. (Inherited from InputBase.)
Protected method | SpinValueBeforeDigit | Spins the value before digit. (Inherited from InputBase.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | Makes undo of the current value. (Overrides InputBase..::..Undo()()()().)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key. (Inherited from InputBase.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vNumberEditor Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..AccessibilityNotifyClients Method
vNumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vNumberEditor Class
vNumberEditor Members


Backspace Method

[image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..Backspace Method
vNumberEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Backspace()
Visual Basic
Public Overrides Sub Backspace
Visual C++
public:
virtual void Backspace() override

See Also

vNumberEditor Class


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..BeginInvoke Method
vNumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vNumberEditor Class
vNumberEditor Members


CtrlC Method

[image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..CtrlC Method
vNumberEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void CtrlC()
Visual Basic
Protected Overrides Sub CtrlC
Visual C++
protected:
virtual void CtrlC() override

See Also

vNumberEditor Class


CtrlV Method

[image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..CtrlV Method
vNumberEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void CtrlV()
Visual Basic
Protected Overrides Sub CtrlV
Visual C++
protected:
virtual void CtrlV() override

See Also

vNumberEditor Class


CtrlX Method

[image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..CtrlX Method
vNumberEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void CtrlX()
Visual Basic
Protected Overrides Sub CtrlX
Visual C++
protected:
virtual void CtrlX() override

See Also

vNumberEditor Class


Delete Method

[image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..Delete Method
vNumberEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Delete()
Visual Basic
Public Overrides Sub Delete
Visual C++
public:
virtual void Delete() override

See Also

vNumberEditor Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..Dispose Method
vNumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vNumberEditor Class
vNumberEditor Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..GetChildAtPoint Method
vNumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vNumberEditor Class
vNumberEditor Members


Insert Method

[image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..Insert Method
vNumberEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Insert(
    string insertion
)
Visual Basic
Public Overrides Sub Insert ( _
    insertion As String _
)
Visual C++
public:
virtual void Insert(
    String^ insertion
) override

Parameters

insertion
Type: System..::..String

See Also

vNumberEditor Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..Invalidate Method
vNumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vNumberEditor Class
vNumberEditor Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..Invoke Method
vNumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vNumberEditor Class
vNumberEditor Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..MemberwiseClone Method
vNumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vNumberEditor Class
vNumberEditor Members


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..OnMouseUp Method
vNumberEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs mevent
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    mevent As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ mevent
) override

Parameters

mevent
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vNumberEditor Class


ParseValue Method

[image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..ParseValue Method
vNumberEditor Class See Also Send Feedback
Parses editor's value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override bool ParseValue()
Visual Basic
Protected Overrides Function ParseValue As Boolean
Visual C++
protected:
virtual bool ParseValue() override

Return Value

See Also

vNumberEditor Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..PerformLayout Method
vNumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vNumberEditor Class
vNumberEditor Members


Redo Method

[image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..Redo Method
vNumberEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Redo()
Visual Basic
Public Overrides Sub Redo
Visual C++
public:
virtual void Redo() override

See Also

vNumberEditor Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..ResumeLayout Method
vNumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vNumberEditor Class
vNumberEditor Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..RtlTranslateAlignment Method
vNumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vNumberEditor Class
vNumberEditor Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..Scale Method
vNumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vNumberEditor Class
vNumberEditor Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..Select Method
vNumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vNumberEditor Class
vNumberEditor Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..SetBounds Method
vNumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vNumberEditor Class
vNumberEditor Members


SetFormattedText Method

[image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..SetFormattedText Method
vNumberEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override bool SetFormattedText()
Visual Basic
Protected Overrides Function SetFormattedText As Boolean
Visual C++
protected:
virtual bool SetFormattedText() override

See Also

vNumberEditor Class


Undo Method

[image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..Undo Method
vNumberEditor Class See Also Send Feedback
Makes undo of the current value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Undo()
Visual Basic
Public Overrides Sub Undo
Visual C++
public:
virtual void Undo() override

See Also

vNumberEditor Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..UpdateBounds Method
vNumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vNumberEditor Class
vNumberEditor Members


vNumberEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor Properties
vNumberEditor Class See Also Send Feedback

The vNumberEditor type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information. (Inherited from InputBase.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DecimalPlaces | Gets or sets editor's decimal places. (Inherited from InputBase.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator | (Inherited from InputBase.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value. (Inherited from InputBase.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value. (Inherited from InputBase.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | (Inherited from InputBase.)
Public property | Minimum | Gets or sets editor's Minimum value. (Inherited from InputBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | Gets the current separator character. (Overrides InputBase..::..SeparatorChar.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type. (Inherited from InputBase.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from InputBase.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from InputBase.)
Public property | Value | Gets or sets editor's value. (Inherited from InputBase.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vNumberEditor Class


SeparatorChar Property

[image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor..::..SeparatorChar Property
vNumberEditor Class See Also Send Feedback
Gets the current separator character.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string SeparatorChar { get; }
Visual Basic
Public Overrides ReadOnly Property SeparatorChar As String
    Get
Visual C++
public:
virtual property String^ SeparatorChar {
    String^ get () override;
}

Field Value

See Also

vNumberEditor Class


vNumberEditor Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumberEditor Events
vNumberEditor Class See Also Send Feedback

The vNumberEditor type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed. (Inherited from InputBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event. (Inherited from InputBase.)
Public event | ValueChanged | Represents the ValueChanged event. (Inherited from InputBase.)
Public event | ValueChanging | Represents the ValueChanging event. (Inherited from InputBase.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vNumberEditor Class


vNumericUpDown Class

[image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown Class
Members See Also Send Feedback
Represents a vNumericUpDown control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vNumericUpDown : vNumericUpDownBase,
    IScrollableControlBase
Visual Basic
Public Class vNumericUpDown _
    Inherits vNumericUpDownBase _
    Implements IScrollableControlBase
Visual C++
public ref class vNumericUpDown : public vNumericUpDownBase,
    IScrollableControlBase

Remarks

A vNumericUpDown displays a numeric value that the user can increment or decrement by clicking on the up/down arrows.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
vControlBase
vEditorControlBase
vButtonEditBase
vNumericUpDownBase
VIBlend.WinForms.Controls..::..vNumericUpDown
VIBlend.WinForms.DataGridView..::..NumericUpDownEditor

See Also

vNumericUpDown Members


vNumericUpDown Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown Members
vNumericUpDown Class Constructors Methods Properties Events See Also Send Feedback

The vNumericUpDown type exposes the following members.

Constructors

 | Name | Description
Public method | vNumericUpDown | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawSpin | Draws the spin.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetArrowColor | Gets the color of the arrow.
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDownClick | Overriden from vSpinControlBase (Overrides vNumericUpDownBaseHandleDownClick()()()().)
Protected method | HandleUpClick | Overriden from vSpinControlBase (Overrides vNumericUpDownBaseHandleUpClick()()()().)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event (Overrides vButtonEditBaseOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Raises the ValueChanged event.
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SpinValue | Spins the value.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether the control is animated
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | Increment | Gets or sets the increment step.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the maximum value.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the minimum value.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the edit field of the spin control. (Overrides Control..::..Text.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when the Value property changes.
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vNumericUpDown Class


vNumericUpDown Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown Constructor
vNumericUpDown Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vNumericUpDown()
Visual Basic
Public Sub New
Visual C++
public:
vNumericUpDown()

See Also

vNumericUpDown Class


vNumericUpDown Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown Methods
vNumericUpDown Class See Also Send Feedback

The vNumericUpDown type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawSpin | Draws the spin.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetArrowColor | Gets the color of the arrow.
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDownClick | Overriden from vSpinControlBase (Overrides vNumericUpDownBaseHandleDownClick()()()().)
Protected method | HandleUpClick | Overriden from vSpinControlBase (Overrides vNumericUpDownBaseHandleUpClick()()()().)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event (Overrides vButtonEditBaseOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Raises the ValueChanged event.
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SpinValue | Spins the value.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vNumericUpDown Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..AccessibilityNotifyClients Method
vNumericUpDown Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vNumericUpDown Class
vNumericUpDown Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..BeginInvoke Method
vNumericUpDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vNumericUpDown Class
vNumericUpDown Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..Dispose Method
vNumericUpDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vNumericUpDown Class
vNumericUpDown Members


DrawSpin Method

[image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..DrawSpin Method
vNumericUpDown Class See Also Send Feedback
Draws the spin.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DrawSpin(
    Graphics g,
    Rectangle rect,
    string text,
    Font font,
    Color foreColor,
    Color backColor,
    RightToLeft rightToLeft,
    bool isEnabled,
    bool readOnly,
    bool isMouseOver,
    bool isUpMouseOver,
    bool isDownMouseOver,
    bool isUpPressed,
    bool isDownPressed,
    bool isFocused
)
Visual Basic
Protected Overridable Sub DrawSpin ( _
    g As Graphics, _
    rect As Rectangle, _
    text As String, _
    font As Font, _
    foreColor As Color, _
    backColor As Color, _
    rightToLeft As RightToLeft, _
    isEnabled As Boolean, _
    readOnly As Boolean, _
    isMouseOver As Boolean, _
    isUpMouseOver As Boolean, _
    isDownMouseOver As Boolean, _
    isUpPressed As Boolean, _
    isDownPressed As Boolean, _
    isFocused As Boolean _
)
Visual C++
protected:
virtual void DrawSpin(
    Graphics^ g,
    Rectangle rect,
    String^ text,
    Font^ font,
    Color foreColor,
    Color backColor,
    RightToLeft rightToLeft,
    bool isEnabled,
    bool readOnly,
    bool isMouseOver,
    bool isUpMouseOver,
    bool isDownMouseOver,
    bool isUpPressed,
    bool isDownPressed,
    bool isFocused
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
rect
Type: System.Drawing..::..Rectangle
The rect.
text
Type: System..::..String
The text.
font
Type: System.Drawing..::..Font
The font.
foreColor
Type: System.Drawing..::..Color
Color of the fore.
backColor
Type: System.Drawing..::..Color
Color of the back.
rightToLeft
Type: System.Windows.Forms..::..RightToLeft
The right to left.
isEnabled
Type: System..::..Boolean
if set to true [is enabled].
readOnly
Type: System..::..Boolean
if set to true [read only].
isMouseOver
Type: System..::..Boolean
if set to true [is mouse over].
isUpMouseOver
Type: System..::..Boolean
if set to true [is up mouse over].
isDownMouseOver
Type: System..::..Boolean
if set to true [is down mouse over].
isUpPressed
Type: System..::..Boolean
if set to true [is up pressed].
isDownPressed
Type: System..::..Boolean
if set to true [is down pressed].
isFocused
Type: System..::..Boolean
if set to true [is focused].

See Also

vNumericUpDown Class


GetArrowColor Method

[image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..GetArrowColor Method
vNumericUpDown Class See Also Send Feedback
Gets the color of the arrow.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual Color GetArrowColor(
    ControlState controlState
)
Visual Basic
Protected Overridable Function GetArrowColor ( _
    controlState As ControlState _
) As Color
Visual C++
protected:
virtual Color GetArrowColor(
    ControlState controlState
)

Parameters

controlState
Type: ControlState
State of the control.

Return Value

See Also

vNumericUpDown Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..GetChildAtPoint Method
vNumericUpDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vNumericUpDown Class
vNumericUpDown Members


HandleDownClick Method

[image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..HandleDownClick Method
vNumericUpDown Class See Also Send Feedback
Overriden from vSpinControlBase

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void HandleDownClick()
Visual Basic
Protected Overrides Sub HandleDownClick
Visual C++
protected:
virtual void HandleDownClick() override

See Also

vNumericUpDown Class


HandleUpClick Method

[image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..HandleUpClick Method
vNumericUpDown Class See Also Send Feedback
Overriden from vSpinControlBase

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void HandleUpClick()
Visual Basic
Protected Overrides Sub HandleUpClick
Visual C++
protected:
virtual void HandleUpClick() override

See Also

vNumericUpDown Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..Invalidate Method
vNumericUpDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vNumericUpDown Class
vNumericUpDown Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..Invoke Method
vNumericUpDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vNumericUpDown Class
vNumericUpDown Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..MemberwiseClone Method
vNumericUpDown Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vNumericUpDown Class
vNumericUpDown Members


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..OnPaint Method
vNumericUpDown Class See Also Send Feedback
Raises the OnPaint event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vNumericUpDown Class


OnValueChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..OnValueChanged Method
vNumericUpDown Class See Also Send Feedback
Raises the ValueChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnValueChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnValueChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnValueChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vNumericUpDown Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..PerformLayout Method
vNumericUpDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vNumericUpDown Class
vNumericUpDown Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..ResumeLayout Method
vNumericUpDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vNumericUpDown Class
vNumericUpDown Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..RtlTranslateAlignment Method
vNumericUpDown Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vNumericUpDown Class
vNumericUpDown Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..Scale Method
vNumericUpDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vNumericUpDown Class
vNumericUpDown Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..Select Method
vNumericUpDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vNumericUpDown Class
vNumericUpDown Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..SetBounds Method
vNumericUpDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vNumericUpDown Class
vNumericUpDown Members


SpinValue Method

[image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..SpinValue Method
vNumericUpDown Class See Also Send Feedback
Spins the value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SpinValue(
    bool up
)
Visual Basic
Public Sub SpinValue ( _
    up As Boolean _
)
Visual C++
public:
void SpinValue(
    bool up
)

Parameters

up
Type: System..::..Boolean
if set to true [up].

See Also

vNumericUpDown Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..UpdateBounds Method
vNumericUpDown Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vNumericUpDown Class
vNumericUpDown Members


vNumericUpDown Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown Properties
vNumericUpDown Class See Also Send Feedback

The vNumericUpDown type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether the control is animated
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | Increment | Gets or sets the increment step.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the maximum value.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the minimum value.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the edit field of the spin control. (Overrides Control..::..Text.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vNumericUpDown Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..AllowAnimations Property
vNumericUpDown Class See Also Send Feedback
Determines whether the control is animated

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vNumericUpDown Class


Increment Property

[image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..Increment Property
vNumericUpDown Class See Also Send Feedback
Gets or sets the increment step.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Increment { get; set; }
Visual Basic
Public Property Increment As Integer
    Get
    Set
Visual C++
public:
property int Increment {
    int get ();
    void set (int value);
}

See Also

vNumericUpDown Class


Maximum Property

[image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..Maximum Property
vNumericUpDown Class See Also Send Feedback
Gets or sets the maximum value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Maximum { get; set; }
Visual Basic
Public Property Maximum As Integer
    Get
    Set
Visual C++
public:
property int Maximum {
    int get ();
    void set (int value);
}

See Also

vNumericUpDown Class


Minimum Property

[image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..Minimum Property
vNumericUpDown Class See Also Send Feedback
Gets or sets the minimum value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Minimum { get; set; }
Visual Basic
Public Property Minimum As Integer
    Get
    Set
Visual C++
public:
property int Minimum {
    int get ();
    void set (int value);
}

See Also

vNumericUpDown Class


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..Text Property
vNumericUpDown Class See Also Send Feedback
Gets or sets the text of the edit field of the spin control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string Text { get; set; }
Visual Basic
Public Overrides Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

See Also

vNumericUpDown Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..Theme Property
vNumericUpDown Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vNumericUpDown Class


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..Value Property
vNumericUpDown Class See Also Send Feedback
Gets or sets the value of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Value { get; set; }
Visual Basic
Public Property Value As Integer
    Get
    Set
Visual C++
public:
property int Value {
    int get ();
    void set (int value);
}

See Also

vNumericUpDown Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..VIBlendTheme Property
vNumericUpDown Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vNumericUpDown Class


vNumericUpDown Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown Events
vNumericUpDown Class See Also Send Feedback

The vNumericUpDown type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when the Value property changes.
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vNumericUpDown Class


ValueChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vNumericUpDown..::..ValueChanged Event
vNumericUpDown Class See Also Send Feedback
Occurs when the Value property changes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ValueChanged
Visual Basic
Public Event ValueChanged As EventHandler
Visual C++
public:
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vNumericUpDown Class


vOptionsFieldSet Class

[image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet Class
Members See Also Send Feedback
Represents an vOptionsFieldSet control that displays a drop-down list of single-choice items.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vOptionsFieldSet : vCheckBox
Visual Basic
Public Class vOptionsFieldSet _
    Inherits vCheckBox
Visual C++
public ref class vOptionsFieldSet : public vCheckBox

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ButtonBase
System.Windows.Forms..::..CheckBox
VIBlend.WinForms.Controls..::..vCheckBox
VIBlend.WinForms.Controls..::..vOptionsFieldSet

See Also

vOptionsFieldSet Members


vOptionsFieldSet Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet Members
vOptionsFieldSet Class Constructors Methods Properties Events See Also Send Feedback

The vOptionsFieldSet type exposes the following members.

Constructors

 | Name | Description
Public method | vOptionsFieldSet | Initializes a new instance of the vOptionsFieldSet class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the CheckBox control. (Inherited from CheckBox.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ButtonBase..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawCheck | (Overrides vCheckBox..::..DrawCheck(Graphics, Int32, Int32).)
Protected method | DrawCheckBox | (Overrides vCheckBox..::..DrawCheckBox(Graphics, Rectangle, ControlState).)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from CheckBox.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnCheckedChanged | Raises the CheckedChanged event. (Inherited from CheckBox.)
Protected method | OnCheckStateChanged | Raises the CheckStateChanged event. (Inherited from CheckBox.)
Protected method | OnClick | Raises the Click event. (Inherited from CheckBox.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from ButtonBase.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from ButtonBase.)
Protected method | OnHandleCreated | (Inherited from CheckBox.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from CheckBox.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus(EventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown(MouseEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseEnter | Raises the OnMouseEnter(EventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave(EventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Raises the OnMouseMove(MouseEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseUp | (Inherited from CheckBox.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint(PaintEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Public method | OnPropertyChanged | Called when a property is changed (Inherited from vCheckBox.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from ButtonBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from CheckBox.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
 | ShowWindow |
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the current CheckBox control. (Inherited from CheckBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ButtonBase.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Appearance | Gets or sets the value that determines the appearance of a CheckBox control. (Inherited from CheckBox.)
Public property | AutoCheck | Gets or set a value indicating whether the Checked or CheckState values and the CheckBox's appearance are automatically changed when the CheckBox is clicked. (Inherited from CheckBox.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckAlign | Gets or sets the horizontal and vertical alignment of the check mark on a CheckBox control. (Inherited from CheckBox.)
Public property | Checked | Gets or set a value indicating whether the CheckBox is in the checked state. (Inherited from CheckBox.)
Public property | CheckMarkColor | Gets or sets the color of the check mark (Inherited from vCheckBox.)
Public property | CheckMarkColorIntermidiate | Gets or sets the color of the check mark in intermediate state (Inherited from vCheckBox.)
Public property | CheckState | Gets or sets the state of the CheckBox. (Inherited from CheckBox.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from CheckBox.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from CheckBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets a reference to the DropDown window of the OptionsFieldSet control
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalSpacing | Gets or sets the horizontal spacing of the vOptionsFieldSet control.
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Panel | Gets or sets the container panel of the vOptionsFieldSet control
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RadioButtons | Gets a reference to the radio buttons list of the vOptionsFieldSet control
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAlign | Gets or sets the alignment of the text on the CheckBox control. (Inherited from CheckBox.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the checkbutton's text is wrappable (Inherited from vCheckBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vCheckBox.)
Public property | ThreeState | Gets or sets a value indicating whether the CheckBox will allow three check states rather than two. (Inherited from CheckBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeCheckMarkColors | Gets or sets whether the check mark will use the Theme colors or the colors defined through the control properties (Inherited from vCheckBox.)
Public property | UseThemeFont | Determines whether to use the Font from the Theme or a custom value (Inherited from vCheckBox.)
Public property | UseThemeTextColor | Determines whether to use the text color from the Theme or a custom value (Inherited from vCheckBox.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalSpacing | Gets or sets the vertical spacing of the vOptionsFieldSet control.
Public property | VIBlendTheme | Gets or sets the theme of the control to one of the built-in themes. (Inherited from vCheckBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AppearanceChanged | Occurs when the value of the Appearance property changes. (Inherited from CheckBox.)
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | CheckedChanged | Occurs when the value of the Checked property changes. (Inherited from CheckBox.)
Public event | CheckStateChanged | Occurs when the value of the CheckState property changes. (Inherited from CheckBox.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the CheckBox control. (Inherited from CheckBox.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the CheckBox control. (Inherited from CheckBox.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property is changed. (Inherited from vCheckBox.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vOptionsFieldSet Class


vOptionsFieldSet Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet Constructor
vOptionsFieldSet Class See Also Send Feedback
Initializes a new instance of the vOptionsFieldSet class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOptionsFieldSet()
Visual Basic
Public Sub New
Visual C++
public:
vOptionsFieldSet()

See Also

vOptionsFieldSet Class


vOptionsFieldSet Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet Methods
vOptionsFieldSet Class See Also Send Feedback

The vOptionsFieldSet type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the CheckBox control. (Inherited from CheckBox.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ButtonBase..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawCheck | (Overrides vCheckBox..::..DrawCheck(Graphics, Int32, Int32).)
Protected method | DrawCheckBox | (Overrides vCheckBox..::..DrawCheckBox(Graphics, Rectangle, ControlState).)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from CheckBox.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnCheckedChanged | Raises the CheckedChanged event. (Inherited from CheckBox.)
Protected method | OnCheckStateChanged | Raises the CheckStateChanged event. (Inherited from CheckBox.)
Protected method | OnClick | Raises the Click event. (Inherited from CheckBox.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from ButtonBase.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from ButtonBase.)
Protected method | OnHandleCreated | (Inherited from CheckBox.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from CheckBox.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus(EventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown(MouseEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseEnter | Raises the OnMouseEnter(EventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave(EventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Raises the OnMouseMove(MouseEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseUp | (Inherited from CheckBox.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint(PaintEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Public method | OnPropertyChanged | Called when a property is changed (Inherited from vCheckBox.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from ButtonBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from CheckBox.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
 | ShowWindow |
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the current CheckBox control. (Inherited from CheckBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ButtonBase.)

See Also

vOptionsFieldSet Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..AccessibilityNotifyClients Method
vOptionsFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vOptionsFieldSet Class
vOptionsFieldSet Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..BeginInvoke Method
vOptionsFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vOptionsFieldSet Class
vOptionsFieldSet Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..Dispose Method
vOptionsFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ButtonBase..::..Dispose(Boolean).)

See Also

vOptionsFieldSet Class
vOptionsFieldSet Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..Dispose Method (Boolean)
vOptionsFieldSet Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vOptionsFieldSet Class
Dispose Overload


DrawCheck Method

[image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..DrawCheck Method
vOptionsFieldSet Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal override void DrawCheck(
    Graphics graphics,
    int x,
    int y
)
Visual Basic
Protected Friend Overrides Sub DrawCheck ( _
    graphics As Graphics, _
    x As Integer, _
    y As Integer _
)
Visual C++
protected public:
virtual void DrawCheck(
    Graphics^ graphics,
    int x,
    int y
) override

Parameters

graphics
Type: System.Drawing..::..Graphics
x
Type: System..::..Int32
y
Type: System..::..Int32

See Also

vOptionsFieldSet Class


DrawCheckBox Method

[image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..DrawCheckBox Method
vOptionsFieldSet Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal override void DrawCheckBox(
    Graphics g,
    Rectangle rect,
    ControlState controlState
)
Visual Basic
Protected Friend Overrides Sub DrawCheckBox ( _
    g As Graphics, _
    rect As Rectangle, _
    controlState As ControlState _
)
Visual C++
protected public:
virtual void DrawCheckBox(
    Graphics^ g,
    Rectangle rect,
    ControlState controlState
) override

Parameters

g
Type: System.Drawing..::..Graphics
rect
Type: System.Drawing..::..Rectangle
controlState
Type: ControlState

See Also

vOptionsFieldSet Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..GetChildAtPoint Method
vOptionsFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vOptionsFieldSet Class
vOptionsFieldSet Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..Invalidate Method
vOptionsFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vOptionsFieldSet Class
vOptionsFieldSet Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..Invoke Method
vOptionsFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vOptionsFieldSet Class
vOptionsFieldSet Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..MemberwiseClone Method
vOptionsFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vOptionsFieldSet Class
vOptionsFieldSet Members


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..PerformLayout Method
vOptionsFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vOptionsFieldSet Class
vOptionsFieldSet Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..ResumeLayout Method
vOptionsFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vOptionsFieldSet Class
vOptionsFieldSet Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..RtlTranslateAlignment Method
vOptionsFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vOptionsFieldSet Class
vOptionsFieldSet Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..Scale Method
vOptionsFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vOptionsFieldSet Class
vOptionsFieldSet Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..Select Method
vOptionsFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vOptionsFieldSet Class
vOptionsFieldSet Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..SetBounds Method
vOptionsFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vOptionsFieldSet Class
vOptionsFieldSet Members


ShowWindow Method

[image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..ShowWindow Method
vOptionsFieldSet Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static bool ShowWindow(
    HandleRef hWnd,
    int nCmdShow
)
Visual Basic
Public Shared Function ShowWindow ( _
    hWnd As HandleRef, _
    nCmdShow As Integer _
) As Boolean
Visual C++
public:
static bool ShowWindow(
    HandleRef hWnd,
    int nCmdShow
)

Parameters

hWnd
Type: System.Runtime.InteropServices..::..HandleRef
nCmdShow
Type: System..::..Int32

See Also

vOptionsFieldSet Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..UpdateBounds Method
vOptionsFieldSet Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vOptionsFieldSet Class
vOptionsFieldSet Members


vOptionsFieldSet Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet Properties
vOptionsFieldSet Class See Also Send Feedback

The vOptionsFieldSet type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Appearance | Gets or sets the value that determines the appearance of a CheckBox control. (Inherited from CheckBox.)
Public property | AutoCheck | Gets or set a value indicating whether the Checked or CheckState values and the CheckBox's appearance are automatically changed when the CheckBox is clicked. (Inherited from CheckBox.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckAlign | Gets or sets the horizontal and vertical alignment of the check mark on a CheckBox control. (Inherited from CheckBox.)
Public property | Checked | Gets or set a value indicating whether the CheckBox is in the checked state. (Inherited from CheckBox.)
Public property | CheckMarkColor | Gets or sets the color of the check mark (Inherited from vCheckBox.)
Public property | CheckMarkColorIntermidiate | Gets or sets the color of the check mark in intermediate state (Inherited from vCheckBox.)
Public property | CheckState | Gets or sets the state of the CheckBox. (Inherited from CheckBox.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from CheckBox.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from CheckBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets a reference to the DropDown window of the OptionsFieldSet control
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalSpacing | Gets or sets the horizontal spacing of the vOptionsFieldSet control.
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Panel | Gets or sets the container panel of the vOptionsFieldSet control
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RadioButtons | Gets a reference to the radio buttons list of the vOptionsFieldSet control
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAlign | Gets or sets the alignment of the text on the CheckBox control. (Inherited from CheckBox.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the checkbutton's text is wrappable (Inherited from vCheckBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vCheckBox.)
Public property | ThreeState | Gets or sets a value indicating whether the CheckBox will allow three check states rather than two. (Inherited from CheckBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeCheckMarkColors | Gets or sets whether the check mark will use the Theme colors or the colors defined through the control properties (Inherited from vCheckBox.)
Public property | UseThemeFont | Determines whether to use the Font from the Theme or a custom value (Inherited from vCheckBox.)
Public property | UseThemeTextColor | Determines whether to use the text color from the Theme or a custom value (Inherited from vCheckBox.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalSpacing | Gets or sets the vertical spacing of the vOptionsFieldSet control.
Public property | VIBlendTheme | Gets or sets the theme of the control to one of the built-in themes. (Inherited from vCheckBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vOptionsFieldSet Class


DropDown Property

[image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..DropDown Property
vOptionsFieldSet Class See Also Send Feedback
Gets a reference to the DropDown window of the OptionsFieldSet control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDropDownBase DropDown { get; }
Visual Basic
Public ReadOnly Property DropDown As vDropDownBase
    Get
Visual C++
public:
property vDropDownBase^ DropDown {
    vDropDownBase^ get ();
}

See Also

vOptionsFieldSet Class


HorizontalSpacing Property

[image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..HorizontalSpacing Property
vOptionsFieldSet Class See Also Send Feedback
Gets or sets the horizontal spacing of the vOptionsFieldSet control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int HorizontalSpacing { get; set; }
Visual Basic
Public Property HorizontalSpacing As Integer
    Get
    Set
Visual C++
public:
property int HorizontalSpacing {
    int get ();
    void set (int value);
}

Field Value

The spacing.

See Also

vOptionsFieldSet Class


Panel Property

[image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..Panel Property
vOptionsFieldSet Class See Also Send Feedback
Gets or sets the container panel of the vOptionsFieldSet control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vPanel Panel { get; set; }
Visual Basic
Public Property Panel As vPanel
    Get
    Set
Visual C++
public:
property vPanel^ Panel {
    vPanel^ get ();
    void set (vPanel^ value);
}

Field Value

The container panel.

See Also

vOptionsFieldSet Class


RadioButtons Property

[image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..RadioButtons Property
vOptionsFieldSet Class See Also Send Feedback
Gets a reference to the radio buttons list of the vOptionsFieldSet control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<vRadioButton> RadioButtons { get; }
Visual Basic
Public ReadOnly Property RadioButtons As List(Of vRadioButton)
    Get
Visual C++
public:
property List<vRadioButton^>^ RadioButtons {
    List<vRadioButton^>^ get ();
}

See Also

vOptionsFieldSet Class


VerticalSpacing Property

[image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet..::..VerticalSpacing Property
vOptionsFieldSet Class See Also Send Feedback
Gets or sets the vertical spacing of the vOptionsFieldSet control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int VerticalSpacing { get; set; }
Visual Basic
Public Property VerticalSpacing As Integer
    Get
    Set
Visual C++
public:
property int VerticalSpacing {
    int get ();
    void set (int value);
}

Field Value

The spacing.

See Also

vOptionsFieldSet Class


vOptionsFieldSet Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOptionsFieldSet Events
vOptionsFieldSet Class See Also Send Feedback

The vOptionsFieldSet type exposes the following members.

Events

 | Name | Description
Public event | AppearanceChanged | Occurs when the value of the Appearance property changes. (Inherited from CheckBox.)
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | CheckedChanged | Occurs when the value of the Checked property changes. (Inherited from CheckBox.)
Public event | CheckStateChanged | Occurs when the value of the CheckState property changes. (Inherited from CheckBox.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the CheckBox control. (Inherited from CheckBox.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the CheckBox control. (Inherited from CheckBox.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property is changed. (Inherited from vCheckBox.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vOptionsFieldSet Class


vOutlookItem Class

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem Class
Members See Also Send Feedback
Represents a vOutlookNavPane item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vOutlookItem : Control,
    INotifyPropertyChanged
Visual Basic
Public Class vOutlookItem _
    Inherits Control _
    Implements INotifyPropertyChanged
Visual C++
public ref class vOutlookItem : public Control,
    INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vOutlookItem

See Also

vOutlookItem Members


vOutlookItem Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem Members
vOutlookItem Class Constructors Methods Properties Events See Also Send Feedback

The vOutlookItem type exposes the following members.

Constructors

 | Name | Description
Public method | vOutlookItem | Initializes a new instance of the vOutlookItem class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the property changed event
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Overrides Control..::..OnVisibleChanged(EventArgs).)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoHide | Gets or sets a value indicating whether the item can be hidden by resizing the resize splitter.
Public property | AutoScroll | Gets or sets a value indicating whether the auto-scroll is behavior.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundBorder | Gets or sets the background border.
Public property | BackgroundBrush | Gets or sets the background brush.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisabledBackgroundBorder | Gets or sets the disabledBackgroundBorder border.
Public property | DisabledBackgroundBrush | Gets or sets the disabled background brush.
Public property | DisabledTextColor | Gets or sets the disabledTextColor TextColor.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor |
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | HeaderControl | Gets the header control.
Public property | HeaderFont | Gets or sets the font of the text to display in the item's header area
Public property | HeaderHeight | Gets or sets the height of the item's header
Public property | HeaderImageAlignment | Gets or sets the image alignment.
Public property | HeaderText | Gets or sets the text to display on the item's header
Public property | HeaderTextAlignment | Gets or sets the text alignment.
Public property | HeaderTextImageRelation | Gets or sets the header text and image relation.
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightBackgroundBorder | Gets or sets the highlightBackground border.
Public property | HighlightBackgroundBrush | Gets or sets the HighlightBackground brush.
Public property | HighlightTextColor | Gets or sets the highlight TextColor.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsExpanded | Checks if the item is currently in expanded state
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LargeImage | Gets or sets the Large image to display on the item's header
Public property | LargeImageIndex | Gets or sets the index of the Large image to display on the item's header
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MenuItemVisible | Gets or sets a value indicating whether the menu item associated to the item can be displayed.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavPane | Gets a reference to the NavigationPane control which hosts the item
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Panel | Gets a reference to the panel which hosts the controls within the navigation pane item
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedBackgroundBorder | Gets or sets the selectedBackground border.
Public property | SelectedBackgroundBrush | Gets or sets the background brush.
Public property | SelectedTextColor | Gets or sets the selected TextColor.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmallImage | Gets or sets the Large image to display on the item's header.
Public property | SmallImageIndex | Gets or sets the index of the small image to display on the item's header
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | TextColor | Gets or sets the TextColor.
Public property | TooltipText | Gets or sets the tooltip text of the item
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use theme's text color
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property of the item changes
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vOutlookItem Class


vOutlookItem Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem Constructor
vOutlookItem Class See Also Send Feedback
Initializes a new instance of the vOutlookItem class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOutlookItem()
Visual Basic
Public Sub New
Visual C++
public:
vOutlookItem()

See Also

vOutlookItem Class


vOutlookItem Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem Methods
vOutlookItem Class See Also Send Feedback

The vOutlookItem type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the property changed event
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Overrides Control..::..OnVisibleChanged(EventArgs).)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vOutlookItem Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..AccessibilityNotifyClients Method
vOutlookItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vOutlookItem Class
vOutlookItem Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..BeginInvoke Method
vOutlookItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vOutlookItem Class
vOutlookItem Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..Dispose Method
vOutlookItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vOutlookItem Class
vOutlookItem Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..GetChildAtPoint Method
vOutlookItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vOutlookItem Class
vOutlookItem Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..Invalidate Method
vOutlookItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vOutlookItem Class
vOutlookItem Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..Invoke Method
vOutlookItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vOutlookItem Class
vOutlookItem Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..MemberwiseClone Method
vOutlookItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vOutlookItem Class
vOutlookItem Members


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..OnLayout Method
vOutlookItem Class See Also Send Feedback
Raises the Layout event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
A LayoutEventArgs that contains the event data.

See Also

vOutlookItem Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..OnMouseMove Method
vOutlookItem Class See Also Send Feedback
Raises the MouseMove event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vOutlookItem Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..OnPaint Method
vOutlookItem Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vOutlookItem Class


OnPropertyChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..OnPropertyChanged Method
vOutlookItem Class See Also Send Feedback
Raises the property changed event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnPropertyChanged(
    string name
)
Visual Basic
Protected Friend Overridable Sub OnPropertyChanged ( _
    name As String _
)
Visual C++
protected public:
virtual void OnPropertyChanged(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the item property

See Also

vOutlookItem Class


OnVisibleChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..OnVisibleChanged Method
vOutlookItem Class See Also Send Feedback
Raises the VisibleChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnVisibleChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnVisibleChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnVisibleChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vOutlookItem Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..PerformLayout Method
vOutlookItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vOutlookItem Class
vOutlookItem Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..ResumeLayout Method
vOutlookItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vOutlookItem Class
vOutlookItem Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..RtlTranslateAlignment Method
vOutlookItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vOutlookItem Class
vOutlookItem Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..Scale Method
vOutlookItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vOutlookItem Class
vOutlookItem Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..Select Method
vOutlookItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vOutlookItem Class
vOutlookItem Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..SetBounds Method
vOutlookItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vOutlookItem Class
vOutlookItem Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..UpdateBounds Method
vOutlookItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vOutlookItem Class
vOutlookItem Members


vOutlookItem Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem Properties
vOutlookItem Class See Also Send Feedback

The vOutlookItem type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoHide | Gets or sets a value indicating whether the item can be hidden by resizing the resize splitter.
Public property | AutoScroll | Gets or sets a value indicating whether the auto-scroll is behavior.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundBorder | Gets or sets the background border.
Public property | BackgroundBrush | Gets or sets the background brush.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisabledBackgroundBorder | Gets or sets the disabledBackgroundBorder border.
Public property | DisabledBackgroundBrush | Gets or sets the disabled background brush.
Public property | DisabledTextColor | Gets or sets the disabledTextColor TextColor.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor |
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | HeaderControl | Gets the header control.
Public property | HeaderFont | Gets or sets the font of the text to display in the item's header area
Public property | HeaderHeight | Gets or sets the height of the item's header
Public property | HeaderImageAlignment | Gets or sets the image alignment.
Public property | HeaderText | Gets or sets the text to display on the item's header
Public property | HeaderTextAlignment | Gets or sets the text alignment.
Public property | HeaderTextImageRelation | Gets or sets the header text and image relation.
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightBackgroundBorder | Gets or sets the highlightBackground border.
Public property | HighlightBackgroundBrush | Gets or sets the HighlightBackground brush.
Public property | HighlightTextColor | Gets or sets the highlight TextColor.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsExpanded | Checks if the item is currently in expanded state
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LargeImage | Gets or sets the Large image to display on the item's header
Public property | LargeImageIndex | Gets or sets the index of the Large image to display on the item's header
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MenuItemVisible | Gets or sets a value indicating whether the menu item associated to the item can be displayed.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavPane | Gets a reference to the NavigationPane control which hosts the item
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Panel | Gets a reference to the panel which hosts the controls within the navigation pane item
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedBackgroundBorder | Gets or sets the selectedBackground border.
Public property | SelectedBackgroundBrush | Gets or sets the background brush.
Public property | SelectedTextColor | Gets or sets the selected TextColor.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmallImage | Gets or sets the Large image to display on the item's header.
Public property | SmallImageIndex | Gets or sets the index of the small image to display on the item's header
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | TextColor | Gets or sets the TextColor.
Public property | TooltipText | Gets or sets the tooltip text of the item
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use theme's text color
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vOutlookItem Class


AutoHide Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..AutoHide Property
vOutlookItem Class See Also Send Feedback
Gets or sets a value indicating whether the item can be hidden by resizing the resize splitter.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AutoHide { get; set; }
Visual Basic
Public Property AutoHide As Boolean
    Get
    Set
Visual C++
public:
property bool AutoHide {
    bool get ();
    void set (bool value);
}

See Also

vOutlookItem Class


AutoScroll Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..AutoScroll Property
vOutlookItem Class See Also Send Feedback
Gets or sets a value indicating whether the auto-scroll is behavior.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AutoScroll { get; set; }
Visual Basic
Public Property AutoScroll As Boolean
    Get
    Set
Visual C++
public:
property bool AutoScroll {
    bool get ();
    void set (bool value);
}

See Also

vOutlookItem Class


BackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..BackgroundBorder Property
vOutlookItem Class See Also Send Feedback
Gets or sets the background border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BackgroundBorder { get; set; }
Visual Basic
Public Property BackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color BackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The background border.

See Also

vOutlookItem Class


BackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..BackgroundBrush Property
vOutlookItem Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush BackgroundBrush { get; set; }
Visual Basic
Public Property BackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ BackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vOutlookItem Class


DisabledBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..DisabledBackgroundBorder Property
vOutlookItem Class See Also Send Feedback
Gets or sets the disabledBackgroundBorder border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DisabledBackgroundBorder { get; set; }
Visual Basic
Public Property DisabledBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color DisabledBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The disabledBackgroundBorder border.

See Also

vOutlookItem Class


DisabledBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..DisabledBackgroundBrush Property
vOutlookItem Class See Also Send Feedback
Gets or sets the disabled background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush DisabledBackgroundBrush { get; set; }
Visual Basic
Public Property DisabledBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ DisabledBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The disabled background brush.

See Also

vOutlookItem Class


DisabledTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..DisabledTextColor Property
vOutlookItem Class See Also Send Feedback
Gets or sets the disabledTextColor TextColor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DisabledTextColor { get; set; }
Visual Basic
Public Property DisabledTextColor As Color
    Get
    Set
Visual C++
public:
property Color DisabledTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The disabledTextColor TextColor.

See Also

vOutlookItem Class


ForeColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..ForeColor Property
vOutlookItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color ForeColor { get; set; }
Visual Basic
Public Property ForeColor As Color
    Get
    Set
Visual C++
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}

See Also

vOutlookItem Class


HeaderControl Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..HeaderControl Property
vOutlookItem Class See Also Send Feedback
Gets the header control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOutlookHeader HeaderControl { get; }
Visual Basic
Public ReadOnly Property HeaderControl As vOutlookHeader
    Get
Visual C++
public:
property vOutlookHeader^ HeaderControl {
    vOutlookHeader^ get ();
}

Field Value

The header control.

See Also

vOutlookItem Class


HeaderFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..HeaderFont Property
vOutlookItem Class See Also Send Feedback
Gets or sets the font of the text to display in the item's header area

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font HeaderFont { get; set; }
Visual Basic
Public Property HeaderFont As Font
    Get
    Set
Visual C++
public:
property Font^ HeaderFont {
    Font^ get ();
    void set (Font^ value);
}

See Also

vOutlookItem Class


HeaderHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..HeaderHeight Property
vOutlookItem Class See Also Send Feedback
Gets or sets the height of the item's header

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int HeaderHeight { get; set; }
Visual Basic
Public Property HeaderHeight As Integer
    Get
    Set
Visual C++
public:
property int HeaderHeight {
    int get ();
    void set (int value);
}

See Also

vOutlookItem Class


HeaderImageAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..HeaderImageAlignment Property
vOutlookItem Class See Also Send Feedback
Gets or sets the image alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment HeaderImageAlignment { get; set; }
Visual Basic
Public Property HeaderImageAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment HeaderImageAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The image alignment.

See Also

vOutlookItem Class


HeaderText Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..HeaderText Property
vOutlookItem Class See Also Send Feedback
Gets or sets the text to display on the item's header

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string HeaderText { get; set; }
Visual Basic
Public Property HeaderText As String
    Get
    Set
Visual C++
public:
property String^ HeaderText {
    String^ get ();
    void set (String^ value);
}

See Also

vOutlookItem Class


HeaderTextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..HeaderTextAlignment Property
vOutlookItem Class See Also Send Feedback
Gets or sets the text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment HeaderTextAlignment { get; set; }
Visual Basic
Public Property HeaderTextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment HeaderTextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The text alignment.

See Also

vOutlookItem Class


HeaderTextImageRelation Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..HeaderTextImageRelation Property
vOutlookItem Class See Also Send Feedback
Gets or sets the header text and image relation.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public TextImageRelation HeaderTextImageRelation { get; set; }
Visual Basic
Public Property HeaderTextImageRelation As TextImageRelation
    Get
    Set
Visual C++
public:
property TextImageRelation HeaderTextImageRelation {
    TextImageRelation get ();
    void set (TextImageRelation value);
}

Field Value

The header text and image relation.

See Also

vOutlookItem Class


HighlightBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..HighlightBackgroundBorder Property
vOutlookItem Class See Also Send Feedback
Gets or sets the highlightBackground border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color HighlightBackgroundBorder { get; set; }
Visual Basic
Public Property HighlightBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color HighlightBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The highlightBackground border.

See Also

vOutlookItem Class


HighlightBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..HighlightBackgroundBrush Property
vOutlookItem Class See Also Send Feedback
Gets or sets the HighlightBackground brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush HighlightBackgroundBrush { get; set; }
Visual Basic
Public Property HighlightBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ HighlightBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The HighlightBackground brush.

See Also

vOutlookItem Class


HighlightTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..HighlightTextColor Property
vOutlookItem Class See Also Send Feedback
Gets or sets the highlight TextColor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color HighlightTextColor { get; set; }
Visual Basic
Public Property HighlightTextColor As Color
    Get
    Set
Visual C++
public:
property Color HighlightTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The highlight TextColor.

See Also

vOutlookItem Class


IsExpanded Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..IsExpanded Property
vOutlookItem Class See Also Send Feedback
Checks if the item is currently in expanded state

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsExpanded { get; internal set; }
Visual Basic
Public Property IsExpanded As Boolean
    Get
    Friend Set
Visual C++
public:
property bool IsExpanded {
    bool get ();
    internal: void set (bool value);
}

See Also

vOutlookItem Class


LargeImage Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..LargeImage Property
vOutlookItem Class See Also Send Feedback
Gets or sets the Large image to display on the item's header

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Image LargeImage { get; set; }
Visual Basic
Public Property LargeImage As Image
    Get
    Set
Visual C++
public:
property Image^ LargeImage {
    Image^ get ();
    void set (Image^ value);
}

See Also

vOutlookItem Class


LargeImageIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..LargeImageIndex Property
vOutlookItem Class See Also Send Feedback
Gets or sets the index of the Large image to display on the item's header

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual int LargeImageIndex { get; set; }
Visual Basic
Public Overridable Property LargeImageIndex As Integer
    Get
    Set
Visual C++
public:
virtual property int LargeImageIndex {
    int get ();
    void set (int value);
}

See Also

vOutlookItem Class


MenuItemVisible Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..MenuItemVisible Property
vOutlookItem Class See Also Send Feedback
Gets or sets a value indicating whether the menu item associated to the item can be displayed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool MenuItemVisible { get; set; }
Visual Basic
Public Property MenuItemVisible As Boolean
    Get
    Set
Visual C++
public:
property bool MenuItemVisible {
    bool get ();
    void set (bool value);
}

See Also

vOutlookItem Class


NavPane Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..NavPane Property
vOutlookItem Class See Also Send Feedback
Gets a reference to the NavigationPane control which hosts the item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOutlookNavPane NavPane { get; }
Visual Basic
Public ReadOnly Property NavPane As vOutlookNavPane
    Get
Visual C++
public:
property vOutlookNavPane^ NavPane {
    vOutlookNavPane^ get ();
}

See Also

vOutlookItem Class


Panel Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..Panel Property
vOutlookItem Class See Also Send Feedback
Gets a reference to the panel which hosts the controls within the navigation pane item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Panel Panel { get; internal set; }
Visual Basic
Public Property Panel As Panel
    Get
    Friend Set
Visual C++
public:
property Panel^ Panel {
    Panel^ get ();
    internal: void set (Panel^ value);
}

See Also

vOutlookItem Class


SelectedBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..SelectedBackgroundBorder Property
vOutlookItem Class See Also Send Feedback
Gets or sets the selectedBackground border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color SelectedBackgroundBorder { get; set; }
Visual Basic
Public Property SelectedBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color SelectedBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The selectedBackground border.

See Also

vOutlookItem Class


SelectedBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..SelectedBackgroundBrush Property
vOutlookItem Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush SelectedBackgroundBrush { get; set; }
Visual Basic
Public Property SelectedBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ SelectedBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vOutlookItem Class


SelectedTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..SelectedTextColor Property
vOutlookItem Class See Also Send Feedback
Gets or sets the selected TextColor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color SelectedTextColor { get; set; }
Visual Basic
Public Property SelectedTextColor As Color
    Get
    Set
Visual C++
public:
property Color SelectedTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The selected TextColor.

See Also

vOutlookItem Class


SmallImage Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..SmallImage Property
vOutlookItem Class See Also Send Feedback
Gets or sets the Large image to display on the item's header.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Image SmallImage { get; set; }
Visual Basic
Public Property SmallImage As Image
    Get
    Set
Visual C++
public:
property Image^ SmallImage {
    Image^ get ();
    void set (Image^ value);
}

See Also

vOutlookItem Class


SmallImageIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..SmallImageIndex Property
vOutlookItem Class See Also Send Feedback
Gets or sets the index of the small image to display on the item's header

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int SmallImageIndex { get; set; }
Visual Basic
Public Property SmallImageIndex As Integer
    Get
    Set
Visual C++
public:
property int SmallImageIndex {
    int get ();
    void set (int value);
}

See Also

vOutlookItem Class


TextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..TextColor Property
vOutlookItem Class See Also Send Feedback
Gets or sets the TextColor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color TextColor { get; set; }
Visual Basic
Public Property TextColor As Color
    Get
    Set
Visual C++
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}

Field Value

The TextColor.

See Also

vOutlookItem Class


TooltipText Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..TooltipText Property
vOutlookItem Class See Also Send Feedback
Gets or sets the tooltip text of the item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string TooltipText { get; set; }
Visual Basic
Public Property TooltipText As String
    Get
    Set
Visual C++
public:
property String^ TooltipText {
    String^ get ();
    void set (String^ value);
}

See Also

vOutlookItem Class


UseThemeBackground Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..UseThemeBackground Property
vOutlookItem Class See Also Send Feedback
Gets or sets a value indicating whether to use theme's background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBackground { get; set; }
Visual Basic
Public Property UseThemeBackground As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBackground {
    bool get ();
    void set (bool value);
}

See Also

vOutlookItem Class


UseThemeTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..UseThemeTextColor Property
vOutlookItem Class See Also Send Feedback
Gets or sets a value indicating whether to use theme's text color

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeTextColor { get; set; }
Visual Basic
Public Property UseThemeTextColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeTextColor {
    bool get ();
    void set (bool value);
}

See Also

vOutlookItem Class


vOutlookItem Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem Events
vOutlookItem Class See Also Send Feedback

The vOutlookItem type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property of the item changes
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vOutlookItem Class


PropertyChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookItem..::..PropertyChanged Event
vOutlookItem Class See Also Send Feedback
Occurs when a property of the item changes

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

vOutlookItem Class


vOutlookNavItemCancelEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavItemCancelEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vOutlookNavItemCancelEventArgs : vOutlookNavItemEventArgs
Visual Basic
Public Class vOutlookNavItemCancelEventArgs _
    Inherits vOutlookNavItemEventArgs
Visual C++
public ref class vOutlookNavItemCancelEventArgs : public vOutlookNavItemEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..vOutlookNavItemEventArgs
VIBlend.WinForms.Controls..::..vOutlookNavItemCancelEventArgs

See Also

vOutlookNavItemCancelEventArgs Members


vOutlookNavItemCancelEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavItemCancelEventArgs Members
vOutlookNavItemCancelEventArgs Class Constructors Methods Properties See Also Send Feedback

The vOutlookNavItemCancelEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | vOutlookNavItemCancelEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets the cancel property.
Public property | Item | NavigationPane item associated with the event. (Inherited from vOutlookNavItemEventArgs.)

See Also

vOutlookNavItemCancelEventArgs Class


vOutlookNavItemCancelEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavItemCancelEventArgs Constructor
vOutlookNavItemCancelEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOutlookNavItemCancelEventArgs(
    vOutlookItem item
)
Visual Basic
Public Sub New ( _
    item As vOutlookItem _
)
Visual C++
public:
vOutlookNavItemCancelEventArgs(
    vOutlookItem^ item
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..vOutlookItem
NavigationPane item associated with the event.

See Also

vOutlookNavItemCancelEventArgs Class


vOutlookNavItemCancelEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavItemCancelEventArgs Methods
vOutlookNavItemCancelEventArgs Class See Also Send Feedback

The vOutlookNavItemCancelEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vOutlookNavItemCancelEventArgs Class


vOutlookNavItemCancelEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavItemCancelEventArgs Properties
vOutlookNavItemCancelEventArgs Class See Also Send Feedback

The vOutlookNavItemCancelEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets the cancel property.
Public property | Item | NavigationPane item associated with the event. (Inherited from vOutlookNavItemEventArgs.)

See Also

vOutlookNavItemCancelEventArgs Class


Cancel Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavItemCancelEventArgs..::..Cancel Property
vOutlookNavItemCancelEventArgs Class See Also Send Feedback
Gets or sets the cancel property.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic
Public Property Cancel As Boolean
    Get
    Set
Visual C++
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}

See Also

vOutlookNavItemCancelEventArgs Class


vOutlookNavItemEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavItemEventArgs Class
Members See Also Send Feedback
Represents a vNavPane event arguments

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vOutlookNavItemEventArgs : EventArgs
Visual Basic
Public Class vOutlookNavItemEventArgs _
    Inherits EventArgs
Visual C++
public ref class vOutlookNavItemEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..vOutlookNavItemEventArgs
VIBlend.WinForms.Controls..::..vOutlookNavItemCancelEventArgs

See Also

vOutlookNavItemEventArgs Members


vOutlookNavItemEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavItemEventArgs Members
vOutlookNavItemEventArgs Class Constructors Methods Properties See Also Send Feedback

The vOutlookNavItemEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | vOutlookNavItemEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | NavigationPane item associated with the event.

See Also

vOutlookNavItemEventArgs Class


vOutlookNavItemEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavItemEventArgs Constructor
vOutlookNavItemEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOutlookNavItemEventArgs(
    vOutlookItem item
)
Visual Basic
Public Sub New ( _
    item As vOutlookItem _
)
Visual C++
public:
vOutlookNavItemEventArgs(
    vOutlookItem^ item
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..vOutlookItem
NavigationPane item associated with the event.

See Also

vOutlookNavItemEventArgs Class


vOutlookNavItemEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavItemEventArgs Methods
vOutlookNavItemEventArgs Class See Also Send Feedback

The vOutlookNavItemEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vOutlookNavItemEventArgs Class


vOutlookNavItemEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavItemEventArgs Properties
vOutlookNavItemEventArgs Class See Also Send Feedback

The vOutlookNavItemEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Item | NavigationPane item associated with the event.

See Also

vOutlookNavItemEventArgs Class


Item Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavItemEventArgs..::..Item Property
vOutlookNavItemEventArgs Class See Also Send Feedback
NavigationPane item associated with the event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOutlookItem Item { get; }
Visual Basic
Public ReadOnly Property Item As vOutlookItem
    Get
Visual C++
public:
property vOutlookItem^ Item {
    vOutlookItem^ get ();
}

See Also

vOutlookNavItemEventArgs Class


vOutlookNavPane Class

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane Class
Members See Also Send Feedback
Represents an Outlook style NavigationPane control, which allows the user to select from a list of container controls that can host other controls.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vOutlookNavPane : Control,
    IScrollableControlBase
Visual Basic
Public Class vOutlookNavPane _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class vOutlookNavPane : public Control,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vOutlookNavPane

See Also

vOutlookNavPane Members


vOutlookNavPane Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane Members
vOutlookNavPane Class Constructors Methods Properties Events See Also Send Feedback

The vOutlookNavPane type exposes the following members.

Constructors

 | Name | Description
Public method | vOutlookNavPane | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HideFirstGroup | Hides the first visible item group
Public method | HitTest | HitTest to find whether on the point position there is nav pane item
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawItemHeader | Raises the [E:DrawItemHeader] event.
Protected method | OnDrawItemResizePart | Raises the [E:DrawItemHeader] event.
Protected method | OnDrawItemStatusPart | Raises the [E:DrawItemHeader] event.
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectionChanged | Raises the SelectionChanged event
Protected method | OnSelectionChanging | Raises the SelectionChanging event
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnSplitterPositionChanged | Raises the SplitterPositionChanged event
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnToolTipShown |
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectItem | Selects a specific navigation pane item
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowFirstGroup | Shows the first hidden item group
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivePanel | Gets a reference to the content panel of the active item.
Public property | AddOrRemoveButtonsString | Gets or sets the add or remove buttons.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the Panel.
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DownArrowMenuImage | Gets or sets down arrow menu image.
Public property | Enabled | Gets or sets whether the control is enabled.
Public property | EnableToolTips | Gets or sets a value indicating whether tool tips are enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Header | Gets the header.
Public property | HeaderBackgroundBorder | Gets or sets the background border.
Public property | HeaderBackgroundBrush | Gets or sets the HighlightBackground brush.
Public property | HeaderFont | Gets or sets the header Font.
Public property | HeaderHeight | Gets or sets the header height
Public property | HeaderTextAlignment | Gets or sets the text alignment.
Public property | HeaderTextColor | Gets or sets the TextColor.
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets the collection of panes in this navigationpane control.
Public property | LargeImageList | Gets or sets the list of large images to display on the control's items.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Public property | ResizeItem | Gets or sets the resize control.
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedItem | Gets or sets the selected item
Public property | ShowFewerButtonsItemString | Gets or sets the show fewer buttons item.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowMoreButtonsItemString | Gets or sets the show more buttons item.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmallImageList | Gets or sets the list of small images to display on the control's items when the items are not expanded.
Public property | StatusItem | Gets or sets the status control.
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control.
Public property | ToolTipDuration | Gets or sets the duration of the tool tip.
Public property | ToolTipShowDelay | Gets or sets the tool tip show delay.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UpArrowMenuImage | Gets or sets up arrow menu image.
Public property | UseControlBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor
Public property | UseHeaderThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseHeaderThemeTextColor | Gets or sets a value indicating whether to use theme's text color
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets whether the control is visible.
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItemHeader |
Public event | DrawItemResizePart |
Public event | DrawItemStatusPart |
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selected item has changed.
Public event | SelectionChanging | Occurs when the selected item is changing.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SplitterPositionChanged | Occurs when the splitter position has changed
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | TooltipShow | Occurs when tooltip shows.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vOutlookNavPane Class


vOutlookNavPane Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane Constructor
vOutlookNavPane Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOutlookNavPane()
Visual Basic
Public Sub New
Visual C++
public:
vOutlookNavPane()

See Also

vOutlookNavPane Class


vOutlookNavPane Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane Methods
vOutlookNavPane Class See Also Send Feedback

The vOutlookNavPane type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HideFirstGroup | Hides the first visible item group
Public method | HitTest | HitTest to find whether on the point position there is nav pane item
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawItemHeader | Raises the [E:DrawItemHeader] event.
Protected method | OnDrawItemResizePart | Raises the [E:DrawItemHeader] event.
Protected method | OnDrawItemStatusPart | Raises the [E:DrawItemHeader] event.
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectionChanged | Raises the SelectionChanged event
Protected method | OnSelectionChanging | Raises the SelectionChanging event
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnSplitterPositionChanged | Raises the SplitterPositionChanged event
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnToolTipShown |
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectItem | Selects a specific navigation pane item
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowFirstGroup | Shows the first hidden item group
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vOutlookNavPane Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..AccessibilityNotifyClients Method
vOutlookNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vOutlookNavPane Class
vOutlookNavPane Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..BeginInvoke Method
vOutlookNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vOutlookNavPane Class
vOutlookNavPane Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..Dispose Method
vOutlookNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)

See Also

vOutlookNavPane Class
vOutlookNavPane Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..Dispose Method (Boolean)
vOutlookNavPane Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vOutlookNavPane Class
Dispose Overload


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..GetChildAtPoint Method
vOutlookNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vOutlookNavPane Class
vOutlookNavPane Members


HideFirstGroup Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..HideFirstGroup Method
vOutlookNavPane Class See Also Send Feedback
Hides the first visible item group

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void HideFirstGroup()
Visual Basic
Public Sub HideFirstGroup
Visual C++
public:
void HideFirstGroup()

See Also

vOutlookNavPane Class


HitTest Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..HitTest Method
vOutlookNavPane Class See Also Send Feedback
HitTest to find whether on the point position there is nav pane item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOutlookItem HitTest()
Visual Basic
Public Function HitTest As vOutlookItem
Visual C++
public:
vOutlookItem^ HitTest()

Return Value

See Also

vOutlookNavPane Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..Invalidate Method
vOutlookNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vOutlookNavPane Class
vOutlookNavPane Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..Invoke Method
vOutlookNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vOutlookNavPane Class
vOutlookNavPane Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..MemberwiseClone Method
vOutlookNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vOutlookNavPane Class
vOutlookNavPane Members


OnDrawItemHeader Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..OnDrawItemHeader Method
vOutlookNavPane Class See Also Send Feedback
Raises the [E:DrawItemHeader] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnDrawItemHeader(
    DrawOutlookNavPaneEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnDrawItemHeader ( _
    args As DrawOutlookNavPaneEventArgs _
)
Visual C++
protected public:
virtual void OnDrawItemHeader(
    DrawOutlookNavPaneEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.Controls..::..DrawOutlookNavPaneEventArgs
The DrawOutlookNavPaneEventArgs instance containing the event data.

See Also

vOutlookNavPane Class


OnDrawItemResizePart Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..OnDrawItemResizePart Method
vOutlookNavPane Class See Also Send Feedback
Raises the [E:DrawItemHeader] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnDrawItemResizePart(
    DrawOutlookNavPaneResizeItemEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnDrawItemResizePart ( _
    args As DrawOutlookNavPaneResizeItemEventArgs _
)
Visual C++
protected public:
virtual void OnDrawItemResizePart(
    DrawOutlookNavPaneResizeItemEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.Controls..::..DrawOutlookNavPaneResizeItemEventArgs
The DrawOutlookNavPaneEventArgs instance containing the event data.

See Also

vOutlookNavPane Class


OnDrawItemStatusPart Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..OnDrawItemStatusPart Method
vOutlookNavPane Class See Also Send Feedback
Raises the [E:DrawItemHeader] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnDrawItemStatusPart(
    DrawOutlookNavPaneStatusEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnDrawItemStatusPart ( _
    args As DrawOutlookNavPaneStatusEventArgs _
)
Visual C++
protected public:
virtual void OnDrawItemStatusPart(
    DrawOutlookNavPaneStatusEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.Controls..::..DrawOutlookNavPaneStatusEventArgs
The DrawOutlookNavPaneEventArgs instance containing the event data.

See Also

vOutlookNavPane Class


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..OnLayout Method
vOutlookNavPane Class See Also Send Feedback
Raises the Layout event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
A LayoutEventArgs that contains the event data.

See Also

vOutlookNavPane Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..OnPaint Method
vOutlookNavPane Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vOutlookNavPane Class


OnSelectionChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..OnSelectionChanged Method
vOutlookNavPane Class See Also Send Feedback
Raises the SelectionChanged event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnSelectionChanged(
    vOutlookNavItemEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnSelectionChanged ( _
    args As vOutlookNavItemEventArgs _
)
Visual C++
protected public:
virtual void OnSelectionChanged(
    vOutlookNavItemEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.Controls..::..vOutlookNavItemEventArgs

See Also

vOutlookNavPane Class


OnSelectionChanging Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..OnSelectionChanging Method
vOutlookNavPane Class See Also Send Feedback
Raises the SelectionChanging event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnSelectionChanging(
    vOutlookNavItemCancelEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnSelectionChanging ( _
    args As vOutlookNavItemCancelEventArgs _
)
Visual C++
protected public:
virtual void OnSelectionChanging(
    vOutlookNavItemCancelEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.Controls..::..vOutlookNavItemCancelEventArgs

See Also

vOutlookNavPane Class


OnSplitterPositionChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..OnSplitterPositionChanged Method
vOutlookNavPane Class See Also Send Feedback
Raises the SplitterPositionChanged event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnSplitterPositionChanged()
Visual Basic
Protected Friend Overridable Sub OnSplitterPositionChanged
Visual C++
protected public:
virtual void OnSplitterPositionChanged()

See Also

vOutlookNavPane Class


OnToolTipShown Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..OnToolTipShown Method
vOutlookNavPane Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnToolTipShown(
    ToolTipEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnToolTipShown ( _
    args As ToolTipEventArgs _
)
Visual C++
protected public:
virtual void OnToolTipShown(
    ToolTipEventArgs^ args
)

Parameters

args
Type: ToolTipEventArgs

See Also

vOutlookNavPane Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..PerformLayout Method
vOutlookNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vOutlookNavPane Class
vOutlookNavPane Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..ResumeLayout Method
vOutlookNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vOutlookNavPane Class
vOutlookNavPane Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..RtlTranslateAlignment Method
vOutlookNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vOutlookNavPane Class
vOutlookNavPane Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..Scale Method
vOutlookNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vOutlookNavPane Class
vOutlookNavPane Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..Select Method
vOutlookNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vOutlookNavPane Class
vOutlookNavPane Members


SelectItem Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..SelectItem Method
vOutlookNavPane Class See Also Send Feedback
Selects a specific navigation pane item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SelectItem(
    vOutlookItem item
)
Visual Basic
Public Sub SelectItem ( _
    item As vOutlookItem _
)
Visual C++
public:
void SelectItem(
    vOutlookItem^ item
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..vOutlookItem
The Item to select.

See Also

vOutlookNavPane Class


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..SetBounds Method
vOutlookNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vOutlookNavPane Class
vOutlookNavPane Members


ShowFirstGroup Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..ShowFirstGroup Method
vOutlookNavPane Class See Also Send Feedback
Shows the first hidden item group

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ShowFirstGroup()
Visual Basic
Public Sub ShowFirstGroup
Visual C++
public:
void ShowFirstGroup()

See Also

vOutlookNavPane Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..UpdateBounds Method
vOutlookNavPane Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vOutlookNavPane Class
vOutlookNavPane Members


vOutlookNavPane Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane Properties
vOutlookNavPane Class See Also Send Feedback

The vOutlookNavPane type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivePanel | Gets a reference to the content panel of the active item.
Public property | AddOrRemoveButtonsString | Gets or sets the add or remove buttons.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the Panel.
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DownArrowMenuImage | Gets or sets down arrow menu image.
Public property | Enabled | Gets or sets whether the control is enabled.
Public property | EnableToolTips | Gets or sets a value indicating whether tool tips are enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Header | Gets the header.
Public property | HeaderBackgroundBorder | Gets or sets the background border.
Public property | HeaderBackgroundBrush | Gets or sets the HighlightBackground brush.
Public property | HeaderFont | Gets or sets the header Font.
Public property | HeaderHeight | Gets or sets the header height
Public property | HeaderTextAlignment | Gets or sets the text alignment.
Public property | HeaderTextColor | Gets or sets the TextColor.
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets the collection of panes in this navigationpane control.
Public property | LargeImageList | Gets or sets the list of large images to display on the control's items.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Public property | ResizeItem | Gets or sets the resize control.
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedItem | Gets or sets the selected item
Public property | ShowFewerButtonsItemString | Gets or sets the show fewer buttons item.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowMoreButtonsItemString | Gets or sets the show more buttons item.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmallImageList | Gets or sets the list of small images to display on the control's items when the items are not expanded.
Public property | StatusItem | Gets or sets the status control.
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control.
Public property | ToolTipDuration | Gets or sets the duration of the tool tip.
Public property | ToolTipShowDelay | Gets or sets the tool tip show delay.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UpArrowMenuImage | Gets or sets up arrow menu image.
Public property | UseControlBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor
Public property | UseHeaderThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseHeaderThemeTextColor | Gets or sets a value indicating whether to use theme's text color
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets whether the control is visible.
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vOutlookNavPane Class


ActivePanel Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..ActivePanel Property
vOutlookNavPane Class See Also Send Feedback
Gets a reference to the content panel of the active item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Panel ActivePanel { get; internal set; }
Visual Basic
Public Property ActivePanel As Panel
    Get
    Friend Set
Visual C++
public:
property Panel^ ActivePanel {
    Panel^ get ();
    internal: void set (Panel^ value);
}

See Also

vOutlookNavPane Class


AddOrRemoveButtonsString Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..AddOrRemoveButtonsString Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the add or remove buttons.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string AddOrRemoveButtonsString { get; set; }
Visual Basic
Public Property AddOrRemoveButtonsString As String
    Get
    Set
Visual C++
public:
property String^ AddOrRemoveButtonsString {
    String^ get ();
    void set (String^ value);
}

Field Value

The add or remove buttons.

See Also

vOutlookNavPane Class


ControlBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..ControlBorderColor Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the BorderColor of the Panel.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Color ControlBorderColor { get; set; }
Visual Basic
Public Overridable Property ControlBorderColor As Color
    Get
    Set
Visual C++
public:
virtual property Color ControlBorderColor {
    Color get ();
    void set (Color value);
}

See Also

vOutlookNavPane Class


DownArrowMenuImage Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..DownArrowMenuImage Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets down arrow menu image.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Image DownArrowMenuImage { get; set; }
Visual Basic
Public Property DownArrowMenuImage As Image
    Get
    Set
Visual C++
public:
property Image^ DownArrowMenuImage {
    Image^ get ();
    void set (Image^ value);
}

Field Value

Down arrow menu image.

See Also

vOutlookNavPane Class


Enabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..Enabled Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets whether the control is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

vOutlookNavPane Class


EnableToolTips Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..EnableToolTips Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets a value indicating whether tool tips are enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool EnableToolTips { get; set; }
Visual Basic
Public Overridable Property EnableToolTips As Boolean
    Get
    Set
Visual C++
public:
virtual property bool EnableToolTips {
    bool get ();
    void set (bool value);
}

See Also

vOutlookNavPane Class


Header Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..Header Property
vOutlookNavPane Class See Also Send Feedback
Gets the header.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOutlookHeader Header { get; }
Visual Basic
Public ReadOnly Property Header As vOutlookHeader
    Get
Visual C++
public:
property vOutlookHeader^ Header {
    vOutlookHeader^ get ();
}

Field Value

The header.

See Also

vOutlookNavPane Class


HeaderBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..HeaderBackgroundBorder Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the background border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color HeaderBackgroundBorder { get; set; }
Visual Basic
Public Property HeaderBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color HeaderBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The background border.

See Also

vOutlookNavPane Class


HeaderBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..HeaderBackgroundBrush Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the HighlightBackground brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush HeaderBackgroundBrush { get; set; }
Visual Basic
Public Property HeaderBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ HeaderBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The HighlightBackground brush.

See Also

vOutlookNavPane Class


HeaderFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..HeaderFont Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the header Font.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font HeaderFont { get; set; }
Visual Basic
Public Property HeaderFont As Font
    Get
    Set
Visual C++
public:
property Font^ HeaderFont {
    Font^ get ();
    void set (Font^ value);
}

See Also

vOutlookNavPane Class


HeaderHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..HeaderHeight Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the header height

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int HeaderHeight { get; set; }
Visual Basic
Public Property HeaderHeight As Integer
    Get
    Set
Visual C++
public:
property int HeaderHeight {
    int get ();
    void set (int value);
}

See Also

vOutlookNavPane Class


HeaderTextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..HeaderTextAlignment Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment HeaderTextAlignment { get; set; }
Visual Basic
Public Property HeaderTextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment HeaderTextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The text alignment.

See Also

vOutlookNavPane Class


HeaderTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..HeaderTextColor Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the TextColor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color HeaderTextColor { get; set; }
Visual Basic
Public Property HeaderTextColor As Color
    Get
    Set
Visual C++
public:
property Color HeaderTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The TextColor.

See Also

vOutlookNavPane Class


Items Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..Items Property
vOutlookNavPane Class See Also Send Feedback
Gets the collection of panes in this navigationpane control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public OutlookItemsCollection Items { get; }
Visual Basic
Public ReadOnly Property Items As OutlookItemsCollection
    Get
Visual C++
public:
property OutlookItemsCollection^ Items {
    OutlookItemsCollection^ get ();
}

See Also

vOutlookNavPane Class


LargeImageList Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..LargeImageList Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the list of large images to display on the control's items.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ImageList LargeImageList { get; set; }
Visual Basic
Public Overridable Property LargeImageList As ImageList
    Get
    Set
Visual C++
public:
virtual property ImageList^ LargeImageList {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

vOutlookNavPane Class


PaintBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..PaintBorder Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets a value indicating whether to paint a border

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintBorder { get; set; }
Visual Basic
Public Property PaintBorder As Boolean
    Get
    Set
Visual C++
public:
property bool PaintBorder {
    bool get ();
    void set (bool value);
}

Field Value

true if [paint border]; otherwise, false.

See Also

vOutlookNavPane Class


ResizeItem Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..ResizeItem Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the resize control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOutlookResizeItem ResizeItem { get; }
Visual Basic
Public ReadOnly Property ResizeItem As vOutlookResizeItem
    Get
Visual C++
public:
property vOutlookResizeItem^ ResizeItem {
    vOutlookResizeItem^ get ();
}

See Also

vOutlookNavPane Class


SelectedItem Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..SelectedItem Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the selected item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOutlookItem SelectedItem { get; set; }
Visual Basic
Public Property SelectedItem As vOutlookItem
    Get
    Set
Visual C++
public:
property vOutlookItem^ SelectedItem {
    vOutlookItem^ get ();
    void set (vOutlookItem^ value);
}

See Also

vOutlookNavPane Class


ShowFewerButtonsItemString Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..ShowFewerButtonsItemString Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the show fewer buttons item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string ShowFewerButtonsItemString { get; set; }
Visual Basic
Public Property ShowFewerButtonsItemString As String
    Get
    Set
Visual C++
public:
property String^ ShowFewerButtonsItemString {
    String^ get ();
    void set (String^ value);
}

Field Value

The show fewer buttons item.

See Also

vOutlookNavPane Class


ShowMoreButtonsItemString Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..ShowMoreButtonsItemString Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the show more buttons item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string ShowMoreButtonsItemString { get; set; }
Visual Basic
Public Property ShowMoreButtonsItemString As String
    Get
    Set
Visual C++
public:
property String^ ShowMoreButtonsItemString {
    String^ get ();
    void set (String^ value);
}

Field Value

The show more buttons item.

See Also

vOutlookNavPane Class


SmallImageList Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..SmallImageList Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the list of small images to display on the control's items when the items are not expanded.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ImageList SmallImageList { get; set; }
Visual Basic
Public Overridable Property SmallImageList As ImageList
    Get
    Set
Visual C++
public:
virtual property ImageList^ SmallImageList {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

vOutlookNavPane Class


StatusItem Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..StatusItem Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the status control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOutlookStatusItem StatusItem { get; }
Visual Basic
Public ReadOnly Property StatusItem As vOutlookStatusItem
    Get
Visual C++
public:
property vOutlookStatusItem^ StatusItem {
    vOutlookStatusItem^ get ();
}

See Also

vOutlookNavPane Class


StyleKey Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..StyleKey Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the style key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual string StyleKey { get; set; }
Visual Basic
Protected Friend Overridable Property StyleKey As String
    Get
    Set
Visual C++
protected public:
virtual property String^ StyleKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The style key.

See Also

vOutlookNavPane Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..Theme Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vOutlookNavPane Class


ToolTipDuration Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..ToolTipDuration Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the duration of the tool tip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ToolTipDuration { get; set; }
Visual Basic
Public Property ToolTipDuration As Integer
    Get
    Set
Visual C++
public:
property int ToolTipDuration {
    int get ();
    void set (int value);
}

Field Value

The duration of the tool tip.

See Also

vOutlookNavPane Class


ToolTipShowDelay Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..ToolTipShowDelay Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the tool tip show delay.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ToolTipShowDelay { get; set; }
Visual Basic
Public Property ToolTipShowDelay As Integer
    Get
    Set
Visual C++
public:
property int ToolTipShowDelay {
    int get ();
    void set (int value);
}

Field Value

The tool tip show delay.

See Also

vOutlookNavPane Class


UpArrowMenuImage Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..UpArrowMenuImage Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets up arrow menu image.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Image UpArrowMenuImage { get; set; }
Visual Basic
Public Property UpArrowMenuImage As Image
    Get
    Set
Visual C++
public:
property Image^ UpArrowMenuImage {
    Image^ get ();
    void set (Image^ value);
}

Field Value

Up arrow menu image.

See Also

vOutlookNavPane Class


UseControlBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..UseControlBorderColor Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets a value indicating whether to use the ControlBorderColor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool UseControlBorderColor { get; set; }
Visual Basic
Public Overridable Property UseControlBorderColor As Boolean
    Get
    Set
Visual C++
public:
virtual property bool UseControlBorderColor {
    bool get ();
    void set (bool value);
}

See Also

vOutlookNavPane Class


UseHeaderThemeBackground Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..UseHeaderThemeBackground Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets a value indicating whether to use theme's background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseHeaderThemeBackground { get; set; }
Visual Basic
Public Property UseHeaderThemeBackground As Boolean
    Get
    Set
Visual C++
public:
property bool UseHeaderThemeBackground {
    bool get ();
    void set (bool value);
}

See Also

vOutlookNavPane Class


UseHeaderThemeTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..UseHeaderThemeTextColor Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets a value indicating whether to use theme's text color

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseHeaderThemeTextColor { get; set; }
Visual Basic
Public Property UseHeaderThemeTextColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseHeaderThemeTextColor {
    bool get ();
    void set (bool value);
}

See Also

vOutlookNavPane Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..VIBlendTheme Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vOutlookNavPane Class


Visible Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..Visible Property
vOutlookNavPane Class See Also Send Feedback
Gets or sets whether the control is visible.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Visible { get; set; }
Visual Basic
Public Property Visible As Boolean
    Get
    Set
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

vOutlookNavPane Class


vOutlookNavPane Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane Events
vOutlookNavPane Class See Also Send Feedback

The vOutlookNavPane type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItemHeader |
Public event | DrawItemResizePart |
Public event | DrawItemStatusPart |
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selected item has changed.
Public event | SelectionChanging | Occurs when the selected item is changing.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SplitterPositionChanged | Occurs when the splitter position has changed
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | TooltipShow | Occurs when tooltip shows.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vOutlookNavPane Class


DrawItemHeader Event

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..DrawItemHeader Event
vOutlookNavPane Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<DrawOutlookNavPaneEventArgs> DrawItemHeader
Visual Basic
Public Event DrawItemHeader As EventHandler(Of DrawOutlookNavPaneEventArgs)
Visual C++
public:
 event EventHandler<DrawOutlookNavPaneEventArgs^>^ DrawItemHeader {
    void add (EventHandler<DrawOutlookNavPaneEventArgs^>^ value);
    void remove (EventHandler<DrawOutlookNavPaneEventArgs^>^ value);
}

See Also

vOutlookNavPane Class


DrawItemResizePart Event

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..DrawItemResizePart Event
vOutlookNavPane Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<DrawOutlookNavPaneResizeItemEventArgs> DrawItemResizePart
Visual Basic
Public Event DrawItemResizePart As EventHandler(Of DrawOutlookNavPaneResizeItemEventArgs)
Visual C++
public:
 event EventHandler<DrawOutlookNavPaneResizeItemEventArgs^>^ DrawItemResizePart {
    void add (EventHandler<DrawOutlookNavPaneResizeItemEventArgs^>^ value);
    void remove (EventHandler<DrawOutlookNavPaneResizeItemEventArgs^>^ value);
}

See Also

vOutlookNavPane Class


DrawItemStatusPart Event

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..DrawItemStatusPart Event
vOutlookNavPane Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<DrawOutlookNavPaneStatusEventArgs> DrawItemStatusPart
Visual Basic
Public Event DrawItemStatusPart As EventHandler(Of DrawOutlookNavPaneStatusEventArgs)
Visual C++
public:
 event EventHandler<DrawOutlookNavPaneStatusEventArgs^>^ DrawItemStatusPart {
    void add (EventHandler<DrawOutlookNavPaneStatusEventArgs^>^ value);
    void remove (EventHandler<DrawOutlookNavPaneStatusEventArgs^>^ value);
}

See Also

vOutlookNavPane Class


SelectionChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..SelectionChanged Event
vOutlookNavPane Class See Also Send Feedback
Occurs when the selected item has changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<vOutlookNavItemEventArgs> SelectionChanged
Visual Basic
Public Event SelectionChanged As EventHandler(Of vOutlookNavItemEventArgs)
Visual C++
public:
 event EventHandler<vOutlookNavItemEventArgs^>^ SelectionChanged {
    void add (EventHandler<vOutlookNavItemEventArgs^>^ value);
    void remove (EventHandler<vOutlookNavItemEventArgs^>^ value);
}

See Also

vOutlookNavPane Class


SelectionChanging Event

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..SelectionChanging Event
vOutlookNavPane Class See Also Send Feedback
Occurs when the selected item is changing.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<vOutlookNavItemCancelEventArgs> SelectionChanging
Visual Basic
Public Event SelectionChanging As EventHandler(Of vOutlookNavItemCancelEventArgs)
Visual C++
public:
 event EventHandler<vOutlookNavItemCancelEventArgs^>^ SelectionChanging {
    void add (EventHandler<vOutlookNavItemCancelEventArgs^>^ value);
    void remove (EventHandler<vOutlookNavItemCancelEventArgs^>^ value);
}

See Also

vOutlookNavPane Class


SplitterPositionChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..SplitterPositionChanged Event
vOutlookNavPane Class See Also Send Feedback
Occurs when the splitter position has changed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler SplitterPositionChanged
Visual Basic
Public Event SplitterPositionChanged As EventHandler
Visual C++
public:
 event EventHandler^ SplitterPositionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vOutlookNavPane Class


TooltipShow Event

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookNavPane..::..TooltipShow Event
vOutlookNavPane Class See Also Send Feedback
Occurs when tooltip shows.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event ToolTipShownHandler TooltipShow
Visual Basic
Public Event TooltipShow As ToolTipShownHandler
Visual C++
public:
 event ToolTipShownHandler^ TooltipShow {
    void add (ToolTipShownHandler^ value);
    void remove (ToolTipShownHandler^ value);
}

See Also

vOutlookNavPane Class


vOutlookResizeItem Class

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vOutlookResizeItem : Control,
    IScrollableControlBase
Visual Basic
Public Class vOutlookResizeItem _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class vOutlookResizeItem : public Control,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vOutlookResizeItem

See Also

vOutlookResizeItem Members


vOutlookResizeItem Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem Members
vOutlookResizeItem Class Constructors Methods Properties Events See Also Send Feedback

The vOutlookResizeItem type exposes the following members.

Constructors

 | Name | Description
Public method | vOutlookResizeItem | Initializes a new instance of the vOutlookResizeItem class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the [E:MouseUp] event. (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RenderResizeItem | Renders the resize item.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets a value indicating whether to enable animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AnimationManager | Gets or sets the animation manager.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundBorder | Gets or sets the background border.
Public property | BackgroundBrush | Gets or sets the HighlightBackground brush.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HostedControl | Gets or sets the hosted control.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme |
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vOutlookResizeItem Class


vOutlookResizeItem Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem Constructor
vOutlookResizeItem Class See Also Send Feedback
Initializes a new instance of the vOutlookResizeItem class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOutlookResizeItem(
    vOutlookNavPane navpane
)
Visual Basic
Public Sub New ( _
    navpane As vOutlookNavPane _
)
Visual C++
public:
vOutlookResizeItem(
    vOutlookNavPane^ navpane
)

Parameters

navpane
Type: VIBlend.WinForms.Controls..::..vOutlookNavPane
The navpane.

See Also

vOutlookResizeItem Class


vOutlookResizeItem Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem Methods
vOutlookResizeItem Class See Also Send Feedback

The vOutlookResizeItem type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the [E:MouseUp] event. (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RenderResizeItem | Renders the resize item.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vOutlookResizeItem Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..AccessibilityNotifyClients Method
vOutlookResizeItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vOutlookResizeItem Class
vOutlookResizeItem Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..BeginInvoke Method
vOutlookResizeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vOutlookResizeItem Class
vOutlookResizeItem Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..Dispose Method
vOutlookResizeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vOutlookResizeItem Class
vOutlookResizeItem Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..GetChildAtPoint Method
vOutlookResizeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vOutlookResizeItem Class
vOutlookResizeItem Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..Invalidate Method
vOutlookResizeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vOutlookResizeItem Class
vOutlookResizeItem Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..Invoke Method
vOutlookResizeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vOutlookResizeItem Class
vOutlookResizeItem Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..MemberwiseClone Method
vOutlookResizeItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vOutlookResizeItem Class
vOutlookResizeItem Members


OnMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..OnMouseLeave Method
vOutlookResizeItem Class See Also Send Feedback
Raises the MouseLeave event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vOutlookResizeItem Class


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..OnMouseUp Method
vOutlookResizeItem Class See Also Send Feedback
Raises the [E:MouseUp] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs mevent
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    mevent As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ mevent
) override

Parameters

mevent
Type: System.Windows.Forms..::..MouseEventArgs
The MouseEventArgs instance containing the event data.

See Also

vOutlookResizeItem Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..OnPaint Method
vOutlookResizeItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vOutlookResizeItem Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..PerformLayout Method
vOutlookResizeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vOutlookResizeItem Class
vOutlookResizeItem Members


RenderResizeItem Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..RenderResizeItem Method
vOutlookResizeItem Class See Also Send Feedback
Renders the resize item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void RenderResizeItem(
    PaintEventArgs e
)
Visual Basic
Protected Overridable Sub RenderResizeItem ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void RenderResizeItem(
    PaintEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
The PaintEventArgs instance containing the event data.

See Also

vOutlookResizeItem Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..ResumeLayout Method
vOutlookResizeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vOutlookResizeItem Class
vOutlookResizeItem Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..RtlTranslateAlignment Method
vOutlookResizeItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vOutlookResizeItem Class
vOutlookResizeItem Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..Scale Method
vOutlookResizeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vOutlookResizeItem Class
vOutlookResizeItem Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..Select Method
vOutlookResizeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vOutlookResizeItem Class
vOutlookResizeItem Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..SetBounds Method
vOutlookResizeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vOutlookResizeItem Class
vOutlookResizeItem Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..UpdateBounds Method
vOutlookResizeItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vOutlookResizeItem Class
vOutlookResizeItem Members


vOutlookResizeItem Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem Properties
vOutlookResizeItem Class See Also Send Feedback

The vOutlookResizeItem type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets a value indicating whether to enable animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AnimationManager | Gets or sets the animation manager.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundBorder | Gets or sets the background border.
Public property | BackgroundBrush | Gets or sets the HighlightBackground brush.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HostedControl | Gets or sets the hosted control.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme |
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vOutlookResizeItem Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..AllowAnimations Property
vOutlookResizeItem Class See Also Send Feedback
Gets or sets a value indicating whether to enable animations

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vOutlookResizeItem Class


AnimationManager Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..AnimationManager Property
vOutlookResizeItem Class See Also Send Feedback
Gets or sets the animation manager.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public AnimationManager AnimationManager { get; set; }
Visual Basic
Public Property AnimationManager As AnimationManager
    Get
    Set
Visual C++
public:
virtual property AnimationManager^ AnimationManager {
    AnimationManager^ get () sealed;
    void set (AnimationManager^ value) sealed;
}

Field Value

The animation manager.

See Also

vOutlookResizeItem Class


BackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..BackgroundBorder Property
vOutlookResizeItem Class See Also Send Feedback
Gets or sets the background border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BackgroundBorder { get; set; }
Visual Basic
Public Property BackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color BackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The background border.

See Also

vOutlookResizeItem Class


BackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..BackgroundBrush Property
vOutlookResizeItem Class See Also Send Feedback
Gets or sets the HighlightBackground brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush BackgroundBrush { get; set; }
Visual Basic
Public Property BackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ BackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The HighlightBackground brush.

See Also

vOutlookResizeItem Class


HostedControl Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..HostedControl Property
vOutlookResizeItem Class See Also Send Feedback
Gets or sets the hosted control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control HostedControl { get; set; }
Visual Basic
Public Property HostedControl As Control
    Get
    Set
Visual C++
public:
property Control^ HostedControl {
    Control^ get ();
    void set (Control^ value);
}

Field Value

The hosted control.

See Also

vOutlookResizeItem Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..Theme Property
vOutlookResizeItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vOutlookResizeItem Class


UseThemeBackground Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..UseThemeBackground Property
vOutlookResizeItem Class See Also Send Feedback
Gets or sets a value indicating whether to use theme's background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBackground { get; set; }
Visual Basic
Public Property UseThemeBackground As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBackground {
    bool get ();
    void set (bool value);
}

See Also

vOutlookResizeItem Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem..::..VIBlendTheme Property
vOutlookResizeItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vOutlookResizeItem Class


vOutlookResizeItem Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookResizeItem Events
vOutlookResizeItem Class See Also Send Feedback

The vOutlookResizeItem type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vOutlookResizeItem Class


vOutlookStatusItem Class

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vOutlookStatusItem : Control,
    IScrollableControlBase
Visual Basic
Public Class vOutlookStatusItem _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class vOutlookStatusItem : public Control,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vOutlookStatusItem

See Also

vOutlookStatusItem Members


vOutlookStatusItem Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem Members
vOutlookStatusItem Class Constructors Methods Properties Events See Also Send Feedback

The vOutlookStatusItem type exposes the following members.

Constructors

 | Name | Description
Public method | vOutlookStatusItem | Initializes a new instance of the vOutlookStatusItem class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetDownImage | Gets down image.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUpImage | Gets up image.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitializeMenu | Initializes the menu.
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RefreshStatus | Refreshes the status.
Protected method | RenderStatusItem | Renders the status item.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations |
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AnimationManager |
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundBorder | Gets or sets the background border.
Public property | BackgroundBrush | Gets or sets the background brush.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisabledBackgroundBorder | Gets or sets the disabledBackgroundBorder border.
Public property | DisabledBackgroundBrush | Gets or sets the disabled background brush.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Menu | Gets or sets the associated menu.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavPane | Gets the nav pane.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SplitButton | Gets the split button instance.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme |
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vOutlookStatusItem Class


vOutlookStatusItem Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem Constructor
vOutlookStatusItem Class See Also Send Feedback
Initializes a new instance of the vOutlookStatusItem class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOutlookStatusItem(
    vOutlookNavPane pane
)
Visual Basic
Public Sub New ( _
    pane As vOutlookNavPane _
)
Visual C++
public:
vOutlookStatusItem(
    vOutlookNavPane^ pane
)

Parameters

pane
Type: VIBlend.WinForms.Controls..::..vOutlookNavPane
The pane.

See Also

vOutlookStatusItem Class


vOutlookStatusItem Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem Methods
vOutlookStatusItem Class See Also Send Feedback

The vOutlookStatusItem type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetDownImage | Gets down image.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUpImage | Gets up image.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitializeMenu | Initializes the menu.
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RefreshStatus | Refreshes the status.
Protected method | RenderStatusItem | Renders the status item.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vOutlookStatusItem Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..AccessibilityNotifyClients Method
vOutlookStatusItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vOutlookStatusItem Class
vOutlookStatusItem Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..BeginInvoke Method
vOutlookStatusItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vOutlookStatusItem Class
vOutlookStatusItem Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..Dispose Method
vOutlookStatusItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vOutlookStatusItem Class
vOutlookStatusItem Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..GetChildAtPoint Method
vOutlookStatusItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vOutlookStatusItem Class
vOutlookStatusItem Members


GetDownImage Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..GetDownImage Method
vOutlookStatusItem Class See Also Send Feedback
Gets down image.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual Bitmap GetDownImage()
Visual Basic
Protected Overridable Function GetDownImage As Bitmap
Visual C++
protected:
virtual Bitmap^ GetDownImage()

Return Value

See Also

vOutlookStatusItem Class


GetUpImage Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..GetUpImage Method
vOutlookStatusItem Class See Also Send Feedback
Gets up image.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual Bitmap GetUpImage()
Visual Basic
Protected Overridable Function GetUpImage As Bitmap
Visual C++
protected:
virtual Bitmap^ GetUpImage()

Return Value

See Also

vOutlookStatusItem Class


InitializeMenu Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..InitializeMenu Method
vOutlookStatusItem Class See Also Send Feedback
Initializes the menu.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void InitializeMenu()
Visual Basic
Protected Friend Overridable Sub InitializeMenu
Visual C++
protected public:
virtual void InitializeMenu()

See Also

vOutlookStatusItem Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..Invalidate Method
vOutlookStatusItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vOutlookStatusItem Class
vOutlookStatusItem Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..Invoke Method
vOutlookStatusItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vOutlookStatusItem Class
vOutlookStatusItem Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..MemberwiseClone Method
vOutlookStatusItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vOutlookStatusItem Class
vOutlookStatusItem Members


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..OnLayout Method
vOutlookStatusItem Class See Also Send Feedback
Raises the Layout event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
A LayoutEventArgs that contains the event data.

See Also

vOutlookStatusItem Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..OnPaint Method
vOutlookStatusItem Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vOutlookStatusItem Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..PerformLayout Method
vOutlookStatusItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vOutlookStatusItem Class
vOutlookStatusItem Members


RefreshStatus Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..RefreshStatus Method
vOutlookStatusItem Class See Also Send Feedback
Refreshes the status.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void RefreshStatus()
Visual Basic
Public Sub RefreshStatus
Visual C++
public:
void RefreshStatus()

See Also

vOutlookStatusItem Class


RenderStatusItem Method

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..RenderStatusItem Method
vOutlookStatusItem Class See Also Send Feedback
Renders the status item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void RenderStatusItem(
    PaintEventArgs e
)
Visual Basic
Protected Overridable Sub RenderStatusItem ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void RenderStatusItem(
    PaintEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
The PaintEventArgs instance containing the event data.

See Also

vOutlookStatusItem Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..ResumeLayout Method
vOutlookStatusItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vOutlookStatusItem Class
vOutlookStatusItem Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..RtlTranslateAlignment Method
vOutlookStatusItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vOutlookStatusItem Class
vOutlookStatusItem Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..Scale Method
vOutlookStatusItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vOutlookStatusItem Class
vOutlookStatusItem Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..Select Method
vOutlookStatusItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vOutlookStatusItem Class
vOutlookStatusItem Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..SetBounds Method
vOutlookStatusItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vOutlookStatusItem Class
vOutlookStatusItem Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..UpdateBounds Method
vOutlookStatusItem Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vOutlookStatusItem Class
vOutlookStatusItem Members


vOutlookStatusItem Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem Properties
vOutlookStatusItem Class See Also Send Feedback

The vOutlookStatusItem type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations |
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AnimationManager |
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundBorder | Gets or sets the background border.
Public property | BackgroundBrush | Gets or sets the background brush.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisabledBackgroundBorder | Gets or sets the disabledBackgroundBorder border.
Public property | DisabledBackgroundBrush | Gets or sets the disabled background brush.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Menu | Gets or sets the associated menu.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavPane | Gets the nav pane.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SplitButton | Gets the split button instance.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme |
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vOutlookStatusItem Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..AllowAnimations Property
vOutlookStatusItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vOutlookStatusItem Class


AnimationManager Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..AnimationManager Property
vOutlookStatusItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public AnimationManager AnimationManager { get; set; }
Visual Basic
Public Property AnimationManager As AnimationManager
    Get
    Set
Visual C++
public:
virtual property AnimationManager^ AnimationManager {
    AnimationManager^ get () sealed;
    void set (AnimationManager^ value) sealed;
}

See Also

vOutlookStatusItem Class


BackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..BackgroundBorder Property
vOutlookStatusItem Class See Also Send Feedback
Gets or sets the background border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BackgroundBorder { get; set; }
Visual Basic
Public Property BackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color BackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The background border.

See Also

vOutlookStatusItem Class


BackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..BackgroundBrush Property
vOutlookStatusItem Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush BackgroundBrush { get; set; }
Visual Basic
Public Property BackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ BackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vOutlookStatusItem Class


DisabledBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..DisabledBackgroundBorder Property
vOutlookStatusItem Class See Also Send Feedback
Gets or sets the disabledBackgroundBorder border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DisabledBackgroundBorder { get; set; }
Visual Basic
Public Property DisabledBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color DisabledBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The disabledBackgroundBorder border.

See Also

vOutlookStatusItem Class


DisabledBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..DisabledBackgroundBrush Property
vOutlookStatusItem Class See Also Send Feedback
Gets or sets the disabled background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush DisabledBackgroundBrush { get; set; }
Visual Basic
Public Property DisabledBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ DisabledBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The disabled background brush.

See Also

vOutlookStatusItem Class


Menu Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..Menu Property
vOutlookStatusItem Class See Also Send Feedback
Gets or sets the associated menu.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContextMenuStrip Menu { get; }
Visual Basic
Public ReadOnly Property Menu As ContextMenuStrip
    Get
Visual C++
public:
property ContextMenuStrip^ Menu {
    ContextMenuStrip^ get ();
}

See Also

vOutlookStatusItem Class


NavPane Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..NavPane Property
vOutlookStatusItem Class See Also Send Feedback
Gets the nav pane.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vOutlookNavPane NavPane { get; }
Visual Basic
Public ReadOnly Property NavPane As vOutlookNavPane
    Get
Visual C++
public:
property vOutlookNavPane^ NavPane {
    vOutlookNavPane^ get ();
}

Field Value

The nav pane.

See Also

vOutlookStatusItem Class


SplitButton Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..SplitButton Property
vOutlookStatusItem Class See Also Send Feedback
Gets the split button instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vSplitButton SplitButton { get; }
Visual Basic
Public ReadOnly Property SplitButton As vSplitButton
    Get
Visual C++
public:
property vSplitButton^ SplitButton {
    vSplitButton^ get ();
}

See Also

vOutlookStatusItem Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..Theme Property
vOutlookStatusItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vOutlookStatusItem Class


UseThemeBackground Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..UseThemeBackground Property
vOutlookStatusItem Class See Also Send Feedback
Gets or sets a value indicating whether to use theme's background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBackground { get; set; }
Visual Basic
Public Property UseThemeBackground As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBackground {
    bool get ();
    void set (bool value);
}

See Also

vOutlookStatusItem Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem..::..VIBlendTheme Property
vOutlookStatusItem Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vOutlookStatusItem Class


vOutlookStatusItem Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vOutlookStatusItem Events
vOutlookStatusItem Class See Also Send Feedback

The vOutlookStatusItem type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vOutlookStatusItem Class


vPanel Class

[image]

VIBlend Controls for WinForms Help Documentation
vPanel Class
Members See Also Send Feedback
Represents a vPanel control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vPanel : Control, IScrollableControlBase
Visual Basic
Public Class vPanel _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class vPanel : public Control,
    IScrollableControlBase

Remarks

A vPanel is a scrollable container control that can host a group of other controls.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vPanel
VIBlend.WinForms.Controls..::..vFlowLayoutPanel

See Also

vPanel Members


vPanel Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPanel Members
vPanel Class Constructors Methods Properties Events See Also Send Feedback

The vPanel type exposes the following members.

Constructors

 | Name | Description
Public method | vPanel | Initializes a new instance of the vPanel class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderRadius | Gets or sets the border radius.
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content | Gets the panel.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | CustomScrollersIntersectionColor | Gets or sets the color of the scrollers intersection.
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Determines the opacity of the Panel control's background
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border
Public property | PaintFill | Gets or sets a value indicating whether to paint a background
Public property | PanelBorderColor | Gets or sets the BorderColor of the Panel.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UsePanelBorderColor | Gets or sets a value indicating whether to use the PanelBorderColor
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme |
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vPanel Class


vPanel Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vPanel Constructor
vPanel Class See Also Send Feedback
Initializes a new instance of the vPanel class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vPanel()
Visual Basic
Public Sub New
Visual C++
public:
vPanel()

See Also

vPanel Class


vPanel Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPanel Methods
vPanel Class See Also Send Feedback

The vPanel type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vPanel Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..AccessibilityNotifyClients Method
vPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vPanel Class
vPanel Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..BeginInvoke Method
vPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vPanel Class
vPanel Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..Dispose Method
vPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vPanel Class
vPanel Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..GetChildAtPoint Method
vPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vPanel Class
vPanel Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..Invalidate Method
vPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vPanel Class
vPanel Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..Invoke Method
vPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vPanel Class
vPanel Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..MemberwiseClone Method
vPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vPanel Class
vPanel Members


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..OnLayout Method
vPanel Class See Also Send Feedback
Raises the Layout event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
A LayoutEventArgs that contains the event data.

See Also

vPanel Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..OnPaint Method
vPanel Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vPanel Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..PerformLayout Method
vPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vPanel Class
vPanel Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..ResumeLayout Method
vPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vPanel Class
vPanel Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..RtlTranslateAlignment Method
vPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vPanel Class
vPanel Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..Scale Method
vPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vPanel Class
vPanel Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..Select Method
vPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vPanel Class
vPanel Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..SetBounds Method
vPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vPanel Class
vPanel Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..UpdateBounds Method
vPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vPanel Class
vPanel Members


vPanel Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPanel Properties
vPanel Class See Also Send Feedback

The vPanel type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderRadius | Gets or sets the border radius.
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content | Gets the panel.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | CustomScrollersIntersectionColor | Gets or sets the color of the scrollers intersection.
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Determines the opacity of the Panel control's background
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border
Public property | PaintFill | Gets or sets a value indicating whether to paint a background
Public property | PanelBorderColor | Gets or sets the BorderColor of the Panel.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UsePanelBorderColor | Gets or sets a value indicating whether to use the PanelBorderColor
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme |
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vPanel Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..AllowAnimations Property
vPanel Class See Also Send Feedback
Determines whether to use animations

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vPanel Class


BorderRadius Property

[image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..BorderRadius Property
vPanel Class See Also Send Feedback
Gets or sets the border radius.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int BorderRadius { get; set; }
Visual Basic
Public Property BorderRadius As Integer
    Get
    Set
Visual C++
public:
property int BorderRadius {
    int get ();
    void set (int value);
}

Field Value

The border radius.

See Also

vPanel Class


Content Property

[image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..Content Property
vPanel Class See Also Send Feedback
Gets the panel.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vContentPanel Content { get; }
Visual Basic
Public ReadOnly Property Content As vContentPanel
    Get
Visual C++
public:
property vContentPanel^ Content {
    vContentPanel^ get ();
}

Field Value

The panel.

See Also

vPanel Class


CustomScrollersIntersectionColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..CustomScrollersIntersectionColor Property
vPanel Class See Also Send Feedback
Gets or sets the color of the scrollers intersection.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color CustomScrollersIntersectionColor { get; set; }
Visual Basic
Public Property CustomScrollersIntersectionColor As Color
    Get
    Set
Visual C++
public:
property Color CustomScrollersIntersectionColor {
    Color get ();
    void set (Color value);
}

See Also

vPanel Class


Opacity Property

[image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..Opacity Property
vPanel Class See Also Send Feedback
Determines the opacity of the Panel control's background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public float Opacity { get; set; }
Visual Basic
Public Property Opacity As Single
    Get
    Set
Visual C++
public:
property float Opacity {
    float get ();
    void set (float value);
}

See Also

vPanel Class


PaintBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..PaintBorder Property
vPanel Class See Also Send Feedback
Gets or sets a value indicating whether to paint a border

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintBorder { get; set; }
Visual Basic
Public Property PaintBorder As Boolean
    Get
    Set
Visual C++
public:
property bool PaintBorder {
    bool get ();
    void set (bool value);
}

See Also

vPanel Class


PaintFill Property

[image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..PaintFill Property
vPanel Class See Also Send Feedback
Gets or sets a value indicating whether to paint a background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintFill { get; set; }
Visual Basic
Public Property PaintFill As Boolean
    Get
    Set
Visual C++
public:
property bool PaintFill {
    bool get ();
    void set (bool value);
}

See Also

vPanel Class


PanelBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..PanelBorderColor Property
vPanel Class See Also Send Feedback
Gets or sets the BorderColor of the Panel.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Color PanelBorderColor { get; set; }
Visual Basic
Public Overridable Property PanelBorderColor As Color
    Get
    Set
Visual C++
public:
virtual property Color PanelBorderColor {
    Color get ();
    void set (Color value);
}

See Also

vPanel Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..Theme Property
vPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vPanel Class


UsePanelBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..UsePanelBorderColor Property
vPanel Class See Also Send Feedback
Gets or sets a value indicating whether to use the PanelBorderColor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool UsePanelBorderColor { get; set; }
Visual Basic
Public Overridable Property UsePanelBorderColor As Boolean
    Get
    Set
Visual C++
public:
virtual property bool UsePanelBorderColor {
    bool get ();
    void set (bool value);
}

See Also

vPanel Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vPanel..::..VIBlendTheme Property
vPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vPanel Class


vPanel Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPanel Events
vPanel Class See Also Send Feedback

The vPanel type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vPanel Class


vPercentageEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vPercentageEditor : InputBase
Visual Basic
Public Class vPercentageEditor _
    Inherits InputBase
Visual C++
public ref class vPercentageEditor : public InputBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vTextBox
VIBlend.WinForms.Controls..::..InputBase
VIBlend.WinForms.Controls..::..vPercentageEditor
VIBlend.WinForms.DataGridView..::..PercentageEditor

See Also

vPercentageEditor Members


vPercentageEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor Members
vPercentageEditor Class Constructors Methods Fields Properties Events See Also Send Feedback

The vPercentageEditor type exposes the following members.

Constructors

 | Name | Description
Public method | vPercentageEditor | Represents a new instance of PercentageEditor.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | Simulates BackSpace. (Overrides InputBase..::..Backspace()()()().)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from InputBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | Executes the Ctrl + C command. (Overrides InputBase..::..CtrlC()()()().)
Protected method | CtrlV | Executes the Ctrl + V command. (Overrides InputBase..::..CtrlV()()()().)
Protected method | CtrlX | Executes the Ctrl + X command. (Overrides InputBase..::..CtrlX()()()().)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | Deletes the selected value. (Overrides InputBase..::..Delete()()()().)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key. (Inherited from InputBase.)
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key. (Inherited from InputBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider. (Inherited from InputBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text. (Inherited from InputBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key. (Inherited from InputBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | Inserts a string into the editor. (Overrides InputBase..::..Insert(String).)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown | (Inherited from InputBase.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed. (Inherited from InputBase.)
Public method | LeftKey | Moves the cursor one position left. (Inherited from InputBase.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from InputBase.)
Protected method | OnKeyPress | (Inherited from InputBase.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from InputBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | (Inherited from InputBase.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | (Inherited from InputBase.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from InputBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event. (Inherited from InputBase.)
Protected method | OnValueChanged | Calls the ValueChanged event. (Inherited from InputBase.)
Protected method | OnValueChanging | Calls the ValueChanging event. (Inherited from InputBase.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | Parses editor's value. (Overrides InputBase..::..ParseValue()()()().)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | Redoes this instance. (Overrides InputBase..::..Redo()()()().)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters. (Inherited from InputBase.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key. (Inherited from InputBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | Formats editor's text. (Overrides InputBase..::..SetFormattedText()()()().)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit | (Inherited from InputBase.)
Protected method | SpinDigitWithWrap | Spins the digit with wrap. (Inherited from InputBase.)
Public method | SpinValue | Increases or decreases the current value. (Inherited from InputBase.)
Protected method | SpinValueBeforeDigit | Spins the value before digit. (Inherited from InputBase.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | Makes undo of the current value. (Overrides InputBase..::..Undo()()()().)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key. (Inherited from InputBase.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | baseFormatString | (Inherited from InputBase.)
Protected field | cultureInfo | (Inherited from InputBase.)
Protected field | decimalPlaces | (Inherited from InputBase.)
Protected field | decimalPossibleChars | (Inherited from InputBase.)
Protected field | emptyValue | (Inherited from InputBase.)
Protected field | formatString | (Inherited from InputBase.)
Protected field | isLessThanZero | (Inherited from InputBase.)
Protected field | manager | (Inherited from InputBase.)
Protected field | maximum | (Inherited from InputBase.)
Protected field | minimum | (Inherited from InputBase.)
Protected field | undoValue | (Inherited from InputBase.)
Protected field | value | (Inherited from InputBase.)
Protected field | valueString | (Inherited from InputBase.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information. (Inherited from InputBase.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DecimalPlaces | Gets or sets editor's decimal places. (Inherited from InputBase.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator | (Inherited from InputBase.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value. (Inherited from InputBase.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value. (Inherited from InputBase.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | (Inherited from InputBase.)
Public property | Minimum | Gets or sets editor's Minimum value. (Inherited from InputBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | Gets the current separator character. (Overrides InputBase..::..SeparatorChar.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type. (Inherited from InputBase.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from InputBase.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from InputBase.)
Public property | Value | Gets or sets editor's value. (Inherited from InputBase.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed. (Inherited from InputBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event. (Inherited from InputBase.)
Public event | ValueChanged | Represents the ValueChanged event. (Inherited from InputBase.)
Public event | ValueChanging | Represents the ValueChanging event. (Inherited from InputBase.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vPercentageEditor Class


vPercentageEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor Constructor
vPercentageEditor Class See Also Send Feedback
Represents a new instance of PercentageEditor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vPercentageEditor()
Visual Basic
Public Sub New
Visual C++
public:
vPercentageEditor()

See Also

vPercentageEditor Class


vPercentageEditor Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor Fields
vPercentageEditor Class See Also Send Feedback

The vPercentageEditor type exposes the following members.

Fields

 | Name | Description
Protected field | baseFormatString | (Inherited from InputBase.)
Protected field | cultureInfo | (Inherited from InputBase.)
Protected field | decimalPlaces | (Inherited from InputBase.)
Protected field | decimalPossibleChars | (Inherited from InputBase.)
Protected field | emptyValue | (Inherited from InputBase.)
Protected field | formatString | (Inherited from InputBase.)
Protected field | isLessThanZero | (Inherited from InputBase.)
Protected field | manager | (Inherited from InputBase.)
Protected field | maximum | (Inherited from InputBase.)
Protected field | minimum | (Inherited from InputBase.)
Protected field | undoValue | (Inherited from InputBase.)
Protected field | value | (Inherited from InputBase.)
Protected field | valueString | (Inherited from InputBase.)

See Also

vPercentageEditor Class


vPercentageEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor Methods
vPercentageEditor Class See Also Send Feedback

The vPercentageEditor type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | Simulates BackSpace. (Overrides InputBase..::..Backspace()()()().)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from InputBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | Executes the Ctrl + C command. (Overrides InputBase..::..CtrlC()()()().)
Protected method | CtrlV | Executes the Ctrl + V command. (Overrides InputBase..::..CtrlV()()()().)
Protected method | CtrlX | Executes the Ctrl + X command. (Overrides InputBase..::..CtrlX()()()().)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | Deletes the selected value. (Overrides InputBase..::..Delete()()()().)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key. (Inherited from InputBase.)
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key. (Inherited from InputBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider. (Inherited from InputBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text. (Inherited from InputBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key. (Inherited from InputBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | Inserts a string into the editor. (Overrides InputBase..::..Insert(String).)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown | (Inherited from InputBase.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed. (Inherited from InputBase.)
Public method | LeftKey | Moves the cursor one position left. (Inherited from InputBase.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from InputBase.)
Protected method | OnKeyPress | (Inherited from InputBase.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from InputBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | (Inherited from InputBase.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | (Inherited from InputBase.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from InputBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event. (Inherited from InputBase.)
Protected method | OnValueChanged | Calls the ValueChanged event. (Inherited from InputBase.)
Protected method | OnValueChanging | Calls the ValueChanging event. (Inherited from InputBase.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | Parses editor's value. (Overrides InputBase..::..ParseValue()()()().)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | Redoes this instance. (Overrides InputBase..::..Redo()()()().)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters. (Inherited from InputBase.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key. (Inherited from InputBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | Formats editor's text. (Overrides InputBase..::..SetFormattedText()()()().)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit | (Inherited from InputBase.)
Protected method | SpinDigitWithWrap | Spins the digit with wrap. (Inherited from InputBase.)
Public method | SpinValue | Increases or decreases the current value. (Inherited from InputBase.)
Protected method | SpinValueBeforeDigit | Spins the value before digit. (Inherited from InputBase.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | Makes undo of the current value. (Overrides InputBase..::..Undo()()()().)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key. (Inherited from InputBase.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vPercentageEditor Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..AccessibilityNotifyClients Method
vPercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vPercentageEditor Class
vPercentageEditor Members


Backspace Method

[image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..Backspace Method
vPercentageEditor Class See Also Send Feedback
Simulates BackSpace.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Backspace()
Visual Basic
Public Overrides Sub Backspace
Visual C++
public:
virtual void Backspace() override

See Also

vPercentageEditor Class


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..BeginInvoke Method
vPercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vPercentageEditor Class
vPercentageEditor Members


CtrlC Method

[image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..CtrlC Method
vPercentageEditor Class See Also Send Feedback
Executes the Ctrl + C command.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void CtrlC()
Visual Basic
Protected Overrides Sub CtrlC
Visual C++
protected:
virtual void CtrlC() override

See Also

vPercentageEditor Class


CtrlV Method

[image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..CtrlV Method
vPercentageEditor Class See Also Send Feedback
Executes the Ctrl + V command.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void CtrlV()
Visual Basic
Protected Overrides Sub CtrlV
Visual C++
protected:
virtual void CtrlV() override

See Also

vPercentageEditor Class


CtrlX Method

[image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..CtrlX Method
vPercentageEditor Class See Also Send Feedback
Executes the Ctrl + X command.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void CtrlX()
Visual Basic
Protected Overrides Sub CtrlX
Visual C++
protected:
virtual void CtrlX() override

See Also

vPercentageEditor Class


Delete Method

[image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..Delete Method
vPercentageEditor Class See Also Send Feedback
Deletes the selected value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Delete()
Visual Basic
Public Overrides Sub Delete
Visual C++
public:
virtual void Delete() override

See Also

vPercentageEditor Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..Dispose Method
vPercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vPercentageEditor Class
vPercentageEditor Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..GetChildAtPoint Method
vPercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vPercentageEditor Class
vPercentageEditor Members


Insert Method

[image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..Insert Method
vPercentageEditor Class See Also Send Feedback
Inserts a string into the editor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Insert(
    string insertion
)
Visual Basic
Public Overrides Sub Insert ( _
    insertion As String _
)
Visual C++
public:
virtual void Insert(
    String^ insertion
) override

Parameters

insertion
Type: System..::..String

See Also

vPercentageEditor Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..Invalidate Method
vPercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vPercentageEditor Class
vPercentageEditor Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..Invoke Method
vPercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vPercentageEditor Class
vPercentageEditor Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..MemberwiseClone Method
vPercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vPercentageEditor Class
vPercentageEditor Members


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..OnMouseUp Method
vPercentageEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vPercentageEditor Class


ParseValue Method

[image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..ParseValue Method
vPercentageEditor Class See Also Send Feedback
Parses editor's value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override bool ParseValue()
Visual Basic
Protected Overrides Function ParseValue As Boolean
Visual C++
protected:
virtual bool ParseValue() override

Return Value

See Also

vPercentageEditor Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..PerformLayout Method
vPercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vPercentageEditor Class
vPercentageEditor Members


Redo Method

[image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..Redo Method
vPercentageEditor Class See Also Send Feedback
Redoes this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Redo()
Visual Basic
Public Overrides Sub Redo
Visual C++
public:
virtual void Redo() override

See Also

vPercentageEditor Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..ResumeLayout Method
vPercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vPercentageEditor Class
vPercentageEditor Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..RtlTranslateAlignment Method
vPercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vPercentageEditor Class
vPercentageEditor Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..Scale Method
vPercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vPercentageEditor Class
vPercentageEditor Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..Select Method
vPercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vPercentageEditor Class
vPercentageEditor Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..SetBounds Method
vPercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vPercentageEditor Class
vPercentageEditor Members


SetFormattedText Method

[image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..SetFormattedText Method
vPercentageEditor Class See Also Send Feedback
Formats editor's text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override bool SetFormattedText()
Visual Basic
Protected Overrides Function SetFormattedText As Boolean
Visual C++
protected:
virtual bool SetFormattedText() override

Return Value

See Also

vPercentageEditor Class


Undo Method

[image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..Undo Method
vPercentageEditor Class See Also Send Feedback
Makes undo of the current value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void Undo()
Visual Basic
Public Overrides Sub Undo
Visual C++
public:
virtual void Undo() override

See Also

vPercentageEditor Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..UpdateBounds Method
vPercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vPercentageEditor Class
vPercentageEditor Members


vPercentageEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor Properties
vPercentageEditor Class See Also Send Feedback

The vPercentageEditor type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information. (Inherited from InputBase.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DecimalPlaces | Gets or sets editor's decimal places. (Inherited from InputBase.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator | (Inherited from InputBase.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value. (Inherited from InputBase.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value. (Inherited from InputBase.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | (Inherited from InputBase.)
Public property | Minimum | Gets or sets editor's Minimum value. (Inherited from InputBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | Gets the current separator character. (Overrides InputBase..::..SeparatorChar.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type. (Inherited from InputBase.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from InputBase.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from InputBase.)
Public property | Value | Gets or sets editor's value. (Inherited from InputBase.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vPercentageEditor Class


SeparatorChar Property

[image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor..::..SeparatorChar Property
vPercentageEditor Class See Also Send Feedback
Gets the current separator character.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string SeparatorChar { get; }
Visual Basic
Public Overrides ReadOnly Property SeparatorChar As String
    Get
Visual C++
public:
virtual property String^ SeparatorChar {
    String^ get () override;
}

Field Value

See Also

vPercentageEditor Class


vPercentageEditor Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vPercentageEditor Events
vPercentageEditor Class See Also Send Feedback

The vPercentageEditor type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed. (Inherited from InputBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event. (Inherited from InputBase.)
Public event | ValueChanged | Represents the ValueChanged event. (Inherited from InputBase.)
Public event | ValueChanging | Represents the ValueChanging event. (Inherited from InputBase.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vPercentageEditor Class


vProgressBar Class

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar Class
Members See Also Send Feedback
Represents a vProgressBar control. The control displays a bar that fills to indicate to the user the progress of an operation.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vProgressBar : Control,
    IScrollableControlBase
Visual Basic
Public Class vProgressBar _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class vProgressBar : public Control,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vProgressBar

See Also

vProgressBar Members


vProgressBar Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar Members
vProgressBar Class Constructors Methods Properties Events See Also Send Feedback

The vProgressBar type exposes the following members.

Constructors

 | Name | Description
Public method | vProgressBar | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Decrement | Decrements the current position of the vProgressBar bar by the specified amount.
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Increment | Advances the current position of the vProgressBar bar by the specified amount.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Called when the value is changed.
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformStep | Advances the current position of the vProgressBar by the amount of the Step property.
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RenderProgressBar(Graphics) | Renders the progress bar.
Public method | RenderProgressBar(Graphics, Rectangle) | Renders the progress bar.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundBorder | Gets or sets the background border.
Public property | BackgroundBrush | Gets or sets the background brush.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BackgroundSeparatorColor | Gets or sets the background separator color.
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the Maximum value of the vProgressBar control.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the Minimum value of the vProgressBar control.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | Gets or sets the orientation of the control.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ProgressBackgroundBrush | Gets or sets the background brush.
Public property | ProgressBarFillStyle | Gets or sets the progress fill style of the control.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the progress bar.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Step | Gets or sets the amount by which a call to the PerformStep method increases the current position of the vProgressBar.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the current position of the vProgressBar control.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when value is changed
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vProgressBar Class


vProgressBar Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar Constructor
vProgressBar Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vProgressBar()
Visual Basic
Public Sub New
Visual C++
public:
vProgressBar()

See Also

vProgressBar Class


vProgressBar Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar Methods
vProgressBar Class See Also Send Feedback

The vProgressBar type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Decrement | Decrements the current position of the vProgressBar bar by the specified amount.
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Increment | Advances the current position of the vProgressBar bar by the specified amount.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Called when the value is changed.
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformStep | Advances the current position of the vProgressBar by the amount of the Step property.
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RenderProgressBar(Graphics) | Renders the progress bar.
Public method | RenderProgressBar(Graphics, Rectangle) | Renders the progress bar.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vProgressBar Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..AccessibilityNotifyClients Method
vProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vProgressBar Class
vProgressBar Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..BeginInvoke Method
vProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vProgressBar Class
vProgressBar Members


Decrement Method

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..Decrement Method
vProgressBar Class See Also Send Feedback
Decrements the current position of the vProgressBar bar by the specified amount.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Decrement(
    int value
)
Visual Basic
Public Sub Decrement ( _
    value As Integer _
)
Visual C++
public:
void Decrement(
    int value
)

Parameters

value
Type: System..::..Int32
The amount by which to decrement the vProgressBar's current position.

See Also

vProgressBar Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..Dispose Method
vProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vProgressBar Class
vProgressBar Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..GetChildAtPoint Method
vProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vProgressBar Class
vProgressBar Members


Increment Method

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..Increment Method
vProgressBar Class See Also Send Feedback
Advances the current position of the vProgressBar bar by the specified amount.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Increment(
    int value
)
Visual Basic
Public Sub Increment ( _
    value As Integer _
)
Visual C++
public:
void Increment(
    int value
)

Parameters

value
Type: System..::..Int32
The amount by which to increment the vProgressBar's current position.

See Also

vProgressBar Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..Invalidate Method
vProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vProgressBar Class
vProgressBar Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..Invoke Method
vProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vProgressBar Class
vProgressBar Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..MemberwiseClone Method
vProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vProgressBar Class
vProgressBar Members


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..OnPaint Method
vProgressBar Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vProgressBar Class


OnValueChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..OnValueChanged Method
vProgressBar Class See Also Send Feedback
Called when the value is changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnValueChanged()
Visual Basic
Protected Overridable Sub OnValueChanged
Visual C++
protected:
virtual void OnValueChanged()

See Also

vProgressBar Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..PerformLayout Method
vProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vProgressBar Class
vProgressBar Members


PerformStep Method

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..PerformStep Method
vProgressBar Class See Also Send Feedback
Advances the current position of the vProgressBar by the amount of the Step property.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void PerformStep()
Visual Basic
Public Sub PerformStep
Visual C++
public:
void PerformStep()

See Also

vProgressBar Class


RenderProgressBar Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..RenderProgressBar Method
vProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderProgressBar(Graphics) | Renders the progress bar.
Public method | RenderProgressBar(Graphics, Rectangle) | Renders the progress bar.

See Also

vProgressBar Class
vProgressBar Members


RenderProgressBar Method (Graphics)

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..RenderProgressBar Method (Graphics)
vProgressBar Class See Also Send Feedback
Renders the progress bar.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void RenderProgressBar(
    Graphics g
)
Visual Basic
Public Overridable Sub RenderProgressBar ( _
    g As Graphics _
)
Visual C++
public:
virtual void RenderProgressBar(
    Graphics^ g
)

Parameters

g
Type: System.Drawing..::..Graphics

See Also

vProgressBar Class
RenderProgressBar Overload


RenderProgressBar Method (Graphics, Rectangle)

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..RenderProgressBar Method (Graphics, Rectangle)
vProgressBar Class See Also Send Feedback
Renders the progress bar.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void RenderProgressBar(
    Graphics g,
    Rectangle bounds
)
Visual Basic
Public Overridable Sub RenderProgressBar ( _
    g As Graphics, _
    bounds As Rectangle _
)
Visual C++
public:
virtual void RenderProgressBar(
    Graphics^ g,
    Rectangle bounds
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
bounds
Type: System.Drawing..::..Rectangle
The bounds.

See Also

vProgressBar Class
RenderProgressBar Overload


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..ResumeLayout Method
vProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vProgressBar Class
vProgressBar Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..RtlTranslateAlignment Method
vProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vProgressBar Class
vProgressBar Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..Scale Method
vProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vProgressBar Class
vProgressBar Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..Select Method
vProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vProgressBar Class
vProgressBar Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..SetBounds Method
vProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vProgressBar Class
vProgressBar Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..UpdateBounds Method
vProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vProgressBar Class
vProgressBar Members


vProgressBar Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar Properties
vProgressBar Class See Also Send Feedback

The vProgressBar type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundBorder | Gets or sets the background border.
Public property | BackgroundBrush | Gets or sets the background brush.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BackgroundSeparatorColor | Gets or sets the background separator color.
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the Maximum value of the vProgressBar control.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the Minimum value of the vProgressBar control.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | Gets or sets the orientation of the control.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ProgressBackgroundBrush | Gets or sets the background brush.
Public property | ProgressBarFillStyle | Gets or sets the progress fill style of the control.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the progress bar.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Step | Gets or sets the amount by which a call to the PerformStep method increases the current position of the vProgressBar.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the current position of the vProgressBar control.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vProgressBar Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..AllowAnimations Property
vProgressBar Class See Also Send Feedback
Gets or sets whether the control is animated

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vProgressBar Class


BackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..BackgroundBorder Property
vProgressBar Class See Also Send Feedback
Gets or sets the background border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BackgroundBorder { get; set; }
Visual Basic
Public Property BackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color BackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The background border.

See Also

vProgressBar Class


BackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..BackgroundBrush Property
vProgressBar Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush BackgroundBrush { get; set; }
Visual Basic
Public Property BackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ BackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vProgressBar Class


BackgroundSeparatorColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..BackgroundSeparatorColor Property
vProgressBar Class See Also Send Feedback
Gets or sets the background separator color.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BackgroundSeparatorColor { get; set; }
Visual Basic
Public Property BackgroundSeparatorColor As Color
    Get
    Set
Visual C++
public:
property Color BackgroundSeparatorColor {
    Color get ();
    void set (Color value);
}

Field Value

The background separator color.

See Also

vProgressBar Class


Maximum Property

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..Maximum Property
vProgressBar Class See Also Send Feedback
Gets or sets the Maximum value of the vProgressBar control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Maximum { get; set; }
Visual Basic
Public Property Maximum As Integer
    Get
    Set
Visual C++
public:
property int Maximum {
    int get ();
    void set (int value);
}

See Also

vProgressBar Class


Minimum Property

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..Minimum Property
vProgressBar Class See Also Send Feedback
Gets or sets the Minimum value of the vProgressBar control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Minimum { get; set; }
Visual Basic
Public Property Minimum As Integer
    Get
    Set
Visual C++
public:
property int Minimum {
    int get ();
    void set (int value);
}

See Also

vProgressBar Class


Orientation Property

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..Orientation Property
vProgressBar Class See Also Send Feedback
Gets or sets the orientation of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic
Public Property Orientation As Orientation
    Get
    Set
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

vProgressBar Class


ProgressBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..ProgressBackgroundBrush Property
vProgressBar Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush ProgressBackgroundBrush { get; set; }
Visual Basic
Public Property ProgressBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ ProgressBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vProgressBar Class


ProgressBarFillStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..ProgressBarFillStyle Property
vProgressBar Class See Also Send Feedback
Gets or sets the progress fill style of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vProgressBar..::..vProgressBarFillStyle ProgressBarFillStyle { get; set; }
Visual Basic
Public Property ProgressBarFillStyle As vProgressBar..::..vProgressBarFillStyle
    Get
    Set
Visual C++
public:
property vProgressBar..::..vProgressBarFillStyle ProgressBarFillStyle {
    vProgressBar..::..vProgressBarFillStyle get ();
    void set (vProgressBar..::..vProgressBarFillStyle value);
}

See Also

vProgressBar Class


RoundedCornersMask Property

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..RoundedCornersMask Property
vProgressBar Class See Also Send Feedback
Gets or sets the mask that determines which corners are rounded

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public byte RoundedCornersMask { get; set; }
Visual Basic
Public Property RoundedCornersMask As Byte
    Get
    Set
Visual C++
public:
property unsigned char RoundedCornersMask {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

vProgressBar Class


RoundedCornersRadius Property

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..RoundedCornersRadius Property
vProgressBar Class See Also Send Feedback
Gets or sets the rounded corners radius of the progress bar.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int RoundedCornersRadius { get; set; }
Visual Basic
Public Property RoundedCornersRadius As Integer
    Get
    Set
Visual C++
public:
property int RoundedCornersRadius {
    int get ();
    void set (int value);
}

See Also

vProgressBar Class


Step Property

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..Step Property
vProgressBar Class See Also Send Feedback
Gets or sets the amount by which a call to the PerformStep method increases the current position of the vProgressBar.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Step { get; set; }
Visual Basic
Public Property Step As Integer
    Get
    Set
Visual C++
public:
property int Step {
    int get ();
    void set (int value);
}

See Also

vProgressBar Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..Theme Property
vProgressBar Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vProgressBar Class


UseThemeBackground Property

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..UseThemeBackground Property
vProgressBar Class See Also Send Feedback
Gets or sets a value indicating whether to use theme's background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBackground { get; set; }
Visual Basic
Public Property UseThemeBackground As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBackground {
    bool get ();
    void set (bool value);
}

See Also

vProgressBar Class


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..Value Property
vProgressBar Class See Also Send Feedback
Gets or sets the current position of the vProgressBar control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Value { get; set; }
Visual Basic
Public Property Value As Integer
    Get
    Set
Visual C++
public:
property int Value {
    int get ();
    void set (int value);
}

Remarks

The minimum and maximum values of the Value property are specified by the Minimum and Maximum properties. This property enables you to increment or decrement the value of the vProgressBar.

See Also

vProgressBar Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..VIBlendTheme Property
vProgressBar Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vProgressBar Class


vProgressBar Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vProgressBar Events
vProgressBar Class See Also Send Feedback

The vProgressBar type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when value is changed
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vProgressBar Class


ValueChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..ValueChanged Event
vProgressBar Class See Also Send Feedback
Occurs when value is changed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ValueChanged
Visual Basic
Public Event ValueChanged As EventHandler
Visual C++
public:
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vProgressBar Class


vProgressBar.vProgressBarFillStyle Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
vProgressBar..::..vProgressBarFillStyle Enumeration
vProgressBar Class See Also Send Feedback
Enumeration of the vProgressBar fill styles

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum vProgressBarFillStyle
Visual Basic
Public Enumeration vProgressBarFillStyle
Visual C++
public enum class vProgressBarFillStyle

Members

Member name | Description
Solid |
Dashed |

See Also


vRadioButton Class

[image]

VIBlend Controls for WinForms Help Documentation
vRadioButton Class
Members See Also Send Feedback
Represents a vRadioButton control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vRadioButton : RadioButton,
    IScrollableControlBase
Visual Basic
Public Class vRadioButton _
    Inherits RadioButton _
    Implements IScrollableControlBase
Visual C++
public ref class vRadioButton : public RadioButton,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ButtonBase
System.Windows.Forms..::..RadioButton
VIBlend.WinForms.Controls..::..vRadioButton

See Also

vRadioButton Members


vRadioButton Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioButton Members
vRadioButton Class Constructors Methods Properties Events See Also Send Feedback

The vRadioButton type exposes the following members.

Constructors

 | Name | Description
Public method | vRadioButton | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the RadioButton control. (Inherited from RadioButton.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnCheckedChanged | Raises the CheckedChanged event. (Inherited from RadioButton.)
Protected method | OnClick | Raises the Click event. (Inherited from RadioButton.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from ButtonBase.)
Protected method | OnEnter | Raises the Enter event. (Inherited from RadioButton.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Overrides OnGotFocus (Overrides ButtonBase..::..OnGotFocus(EventArgs).)
Protected method | OnHandleCreated | Overrides the OnHandleCreated(EventArgs) method. (Inherited from RadioButton.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Overrides OnLostFocus (Overrides ButtonBase..::..OnLostFocus(EventArgs).)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Overrides OnMouseDown (Overrides ButtonBase..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Overrides OnMouseEnter (Overrides ButtonBase..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Overrides OnMouseLeave (Overrides ButtonBase..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the OnMouseMove(MouseEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseUp | Overrides OnMouseUp (Overrides RadioButton..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Overrides OnPaint (Overrides ButtonBase..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from ButtonBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for the control, simulating a click by a user. (Inherited from RadioButton.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Overrides the ProcessMnemonic(Char) method. (Inherited from RadioButton.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Overrides the ToString()()()() method. (Inherited from RadioButton.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ButtonBase.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Appearance | Gets or sets a value determining the appearance of the RadioButton. (Inherited from RadioButton.)
Public property | AutoCheck | Gets or sets a value indicating whether the Checked value and the appearance of the control automatically change when the control is clicked. (Inherited from RadioButton.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckAlign | Gets or sets the location of the check box portion of the RadioButton. (Inherited from RadioButton.)
Public property | Checked | Gets or sets a value indicating whether the control is checked. (Inherited from RadioButton.)
Public property | CheckMarkColor | Gets or sets the color of the check mark
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Overrides CreateParams. (Inherited from RadioButton.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from RadioButton.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from RadioButton.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAlign | Gets or sets the alignment of the text on the RadioButton control. (Inherited from RadioButton.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeCheckMarkColors | Gets or sets whether the check mark will use the Theme colors or the colors defined through the control properties
Public property | UseThemeFont | Determines whether to use the Font from the Theme or the Font property of the control.
Public property | UseThemeTextColor | Determines whether to use the text color from the Theme or ForeColor control property.
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AppearanceChanged | Occurs when the Appearance property value changes. (Inherited from RadioButton.)
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | CheckedChanged | Occurs when the value of the Checked property changes. (Inherited from RadioButton.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the RadioButton control. (Inherited from RadioButton.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the RadioButton control with the mouse. (Inherited from RadioButton.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRadioButton Class


vRadioButton Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vRadioButton Constructor
vRadioButton Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRadioButton()
Visual Basic
Public Sub New
Visual C++
public:
vRadioButton()

See Also

vRadioButton Class


vRadioButton Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioButton Methods
vRadioButton Class See Also Send Feedback

The vRadioButton type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the RadioButton control. (Inherited from RadioButton.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnCheckedChanged | Raises the CheckedChanged event. (Inherited from RadioButton.)
Protected method | OnClick | Raises the Click event. (Inherited from RadioButton.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from ButtonBase.)
Protected method | OnEnter | Raises the Enter event. (Inherited from RadioButton.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Overrides OnGotFocus (Overrides ButtonBase..::..OnGotFocus(EventArgs).)
Protected method | OnHandleCreated | Overrides the OnHandleCreated(EventArgs) method. (Inherited from RadioButton.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Overrides OnLostFocus (Overrides ButtonBase..::..OnLostFocus(EventArgs).)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Overrides OnMouseDown (Overrides ButtonBase..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Overrides OnMouseEnter (Overrides ButtonBase..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Overrides OnMouseLeave (Overrides ButtonBase..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the OnMouseMove(MouseEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnMouseUp | Overrides OnMouseUp (Overrides RadioButton..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Overrides OnPaint (Overrides ButtonBase..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from ButtonBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for the control, simulating a click by a user. (Inherited from RadioButton.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Overrides the ProcessMnemonic(Char) method. (Inherited from RadioButton.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Overrides the ToString()()()() method. (Inherited from RadioButton.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ButtonBase.)

See Also

vRadioButton Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..AccessibilityNotifyClients Method
vRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vRadioButton Class
vRadioButton Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..BeginInvoke Method
vRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vRadioButton Class
vRadioButton Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..Dispose Method
vRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)

See Also

vRadioButton Class
vRadioButton Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..GetChildAtPoint Method
vRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vRadioButton Class
vRadioButton Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..Invalidate Method
vRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vRadioButton Class
vRadioButton Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..Invoke Method
vRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vRadioButton Class
vRadioButton Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..MemberwiseClone Method
vRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vRadioButton Class
vRadioButton Members


OnGotFocus Method

[image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..OnGotFocus Method
vRadioButton Class See Also Send Feedback
Overrides OnGotFocus

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnGotFocus(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnGotFocus ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnGotFocus(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
A EventArgs that contains the event data.

See Also

vRadioButton Class


OnLostFocus Method

[image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..OnLostFocus Method
vRadioButton Class See Also Send Feedback
Overrides OnLostFocus

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLostFocus(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnLostFocus ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLostFocus(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
A EventArgs that contains the event data.

See Also

vRadioButton Class


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..OnMouseDown Method
vRadioButton Class See Also Send Feedback
Overrides OnMouseDown

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs mevent
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    mevent As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ mevent
) override

Parameters

mevent
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vRadioButton Class


OnMouseEnter Method

[image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..OnMouseEnter Method
vRadioButton Class See Also Send Feedback
Overrides OnMouseEnter

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseEnter(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseEnter ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseEnter(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
A EventArgs that contains the event data.

See Also

vRadioButton Class


OnMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..OnMouseLeave Method
vRadioButton Class See Also Send Feedback
Overrides OnMouseLeave

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
A EventArgs that contains the event data.

See Also

vRadioButton Class


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..OnMouseUp Method
vRadioButton Class See Also Send Feedback
Overrides OnMouseUp

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs mevent
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    mevent As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ mevent
) override

Parameters

mevent
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vRadioButton Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..OnPaint Method
vRadioButton Class See Also Send Feedback
Overrides OnPaint

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vRadioButton Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..PerformLayout Method
vRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vRadioButton Class
vRadioButton Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..ResumeLayout Method
vRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vRadioButton Class
vRadioButton Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..RtlTranslateAlignment Method
vRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vRadioButton Class
vRadioButton Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..Scale Method
vRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vRadioButton Class
vRadioButton Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..Select Method
vRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vRadioButton Class
vRadioButton Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..SetBounds Method
vRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vRadioButton Class
vRadioButton Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..UpdateBounds Method
vRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vRadioButton Class
vRadioButton Members


vRadioButton Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioButton Properties
vRadioButton Class See Also Send Feedback

The vRadioButton type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Appearance | Gets or sets a value determining the appearance of the RadioButton. (Inherited from RadioButton.)
Public property | AutoCheck | Gets or sets a value indicating whether the Checked value and the appearance of the control automatically change when the control is clicked. (Inherited from RadioButton.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckAlign | Gets or sets the location of the check box portion of the RadioButton. (Inherited from RadioButton.)
Public property | Checked | Gets or sets a value indicating whether the control is checked. (Inherited from RadioButton.)
Public property | CheckMarkColor | Gets or sets the color of the check mark
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Overrides CreateParams. (Inherited from RadioButton.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from RadioButton.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from RadioButton.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAlign | Gets or sets the alignment of the text on the RadioButton control. (Inherited from RadioButton.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeCheckMarkColors | Gets or sets whether the check mark will use the Theme colors or the colors defined through the control properties
Public property | UseThemeFont | Determines whether to use the Font from the Theme or the Font property of the control.
Public property | UseThemeTextColor | Determines whether to use the text color from the Theme or ForeColor control property.
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vRadioButton Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..AllowAnimations Property
vRadioButton Class See Also Send Feedback
Gets or sets whether the control is animated

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vRadioButton Class


CheckMarkColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..CheckMarkColor Property
vRadioButton Class See Also Send Feedback
Gets or sets the color of the check mark

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color CheckMarkColor { get; set; }
Visual Basic
Public Property CheckMarkColor As Color
    Get
    Set
Visual C++
public:
property Color CheckMarkColor {
    Color get ();
    void set (Color value);
}

See Also

vRadioButton Class
vRadioButton..::..UseThemeCheckMarkColors


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..Theme Property
vRadioButton Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vRadioButton Class


UseThemeCheckMarkColors Property

[image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..UseThemeCheckMarkColors Property
vRadioButton Class See Also Send Feedback
Gets or sets whether the check mark will use the Theme colors or the colors defined through the control properties

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeCheckMarkColors { get; set; }
Visual Basic
Public Property UseThemeCheckMarkColors As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeCheckMarkColors {
    bool get ();
    void set (bool value);
}

See Also

vRadioButton Class


UseThemeFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..UseThemeFont Property
vRadioButton Class See Also Send Feedback
Determines whether to use the Font from the Theme or the Font property of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeFont { get; set; }
Visual Basic
Public Property UseThemeFont As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeFont {
    bool get ();
    void set (bool value);
}

See Also

vRadioButton Class


UseThemeTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..UseThemeTextColor Property
vRadioButton Class See Also Send Feedback
Determines whether to use the text color from the Theme or ForeColor control property.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeTextColor { get; set; }
Visual Basic
Public Property UseThemeTextColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeTextColor {
    bool get ();
    void set (bool value);
}

See Also

vRadioButton Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vRadioButton..::..VIBlendTheme Property
vRadioButton Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vRadioButton Class


vRadioButton Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioButton Events
vRadioButton Class See Also Send Feedback

The vRadioButton type exposes the following members.

Events

 | Name | Description
Public event | AppearanceChanged | Occurs when the Appearance property value changes. (Inherited from RadioButton.)
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | CheckedChanged | Occurs when the value of the Checked property changes. (Inherited from RadioButton.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the RadioButton control. (Inherited from RadioButton.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the RadioButton control with the mouse. (Inherited from RadioButton.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRadioButton Class


vRadioListBox Class

[image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox Class
Members See Also Send Feedback
Represents a vCheckedListBox control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vRadioListBox : vListBox
Visual Basic
Public Class vRadioListBox _
    Inherits vListBox
Visual C++
public ref class vRadioListBox : public vListBox

Remarks

A vCheckedListBox displays a collection of items. The control allows you to use images, check boxes and detailed description for each item.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vListBox
VIBlend.WinForms.Controls..::..vRadioListBox

See Also

vRadioListBox Members


vRadioListBox Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox Members
vRadioListBox Class Constructors Methods Fields Properties Events See Also Send Feedback

The vRadioListBox type exposes the following members.

Constructors

 | Name | Description
Public method | vRadioListBox | Initializes a new instance of the vRadioListBox class

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | BeginDrag | Begins the drag. (Inherited from vListBox.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Begins a batch of changes on the items collection (Inherited from vListBox.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CanSelectMultipleItems | Determines whether this instance can select multiple items. (Inherited from vListBox.)
Public method | CheckItem | Checks the item.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawDragFeedback(Graphics) | (Inherited from vListBox.)
Public method | DrawItem | (Inherited from vListBox.)
Public method | DrawItemImage | Draws the item image. (Inherited from vListBox.)
Public method | DrawListItemBackGroundAndBorder | Draws the list item back ground and border. (Inherited from vListBox.)
Public method | DrawListItemTextAndDescription | Draws the list item text and description. (Inherited from vListBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Protected method | EndDrag | Ends the drag. (Inherited from vListBox.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Begins a batch of changes on the items collection previously started by BeginUpdate() (Inherited from vListBox.)
Public method | EnsureVisible | Ensures that a list view item is visible. (Inherited from vListBox.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FilterItemOnProperty | (Inherited from vListBox.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindItem(Point) | Get ListItem at specific point. (Inherited from vListBox.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Protected method | GetBackFillColor | Gets the color of the back fill. (Inherited from vListBox.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemFont | Gets the item font. (Inherited from vListBox.)
Public method | GetItemForeColor | Gets the color of the item fore. (Inherited from vListBox.)
Public method | GetItemImage | Gets the item image. (Inherited from vListBox.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest | Performs a HitTest at a specific point (Inherited from vListBox.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from vListBox.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDataSourceChanged | Raises the DataSourceChanged event (Inherited from vListBox.)
Protected method | OnDisplayMemberChanged | Raises the OnDisplayMemberChanged event (Inherited from vListBox.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawItem | Raises the DrawItem event. (Inherited from vListBox.)
Protected method | OnDrawListItem | (Inherited from vListBox.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemChecked | Raises the [E:ItemChecked] event.
Protected method | OnItemChecking | Raises the [E:ItemChecking] event.
Protected method | OnItemDragEnded | (Inherited from vListBox.)
Protected method | OnItemDragEnding | (Inherited from vListBox.)
Protected method | OnItemDragging | (Inherited from vListBox.)
Protected method | OnItemDragStarted | (Inherited from vListBox.)
Protected method | OnItemDragStarting | (Inherited from vListBox.)
Protected method | OnItemFormat | Raises the [E:ItemFormat] event. (Inherited from vListBox.)
Protected method | OnItemMouseDown | Raises the [E:ItemMouseDown] event. (Inherited from vListBox.)
Protected method | OnItemMouseUp | Raises the [E:ItemMouseUp] event. (Inherited from vListBox.)
Protected method | OnKeyDown | (Overrides vListBox..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from vListBox.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vListBox.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Overrides vListBox..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vListBox.)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Inherited from vListBox.)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vListBox.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from vListBox.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vListBox.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from vListBox.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectedIndexChanged | Raises the SelectedIndexChanged event (Inherited from vListBox.)
Protected method | OnSelectedItemChanged | (Inherited from vListBox.)
Protected method | OnSelectedItemChanging | (Inherited from vListBox.)
Protected method | OnSelectedValueChanged | Raises the SelectedValueChanged event. (Inherited from vListBox.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | This member overrides Control.ProcessCmdKey. (Inherited from vListBox.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Public method | ReBind | Rebinds the ListBox control. (Inherited from vListBox.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveSort | Removes the sort. (Inherited from vListBox.)
Protected method | RenderListBox | (Overrides vListBox..::..RenderListBox(PaintEventArgs).)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Reverse | Reverses this instance. (Inherited from vListBox.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetItemCore | Sets the object with the specified index in the derived class. (Inherited from vListBox.)
Protected method | SetItemsCore | Sets the object with the specified index in the derived class. (Inherited from vListBox.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort(Boolean) | Sorts the specified ascending. (Inherited from vListBox.)
Public method | Sort(IComparer<(Of <<'(ListItem>)>>)) | Sorts the specified comparer. (Inherited from vListBox.)
Public method | Sort(Comparison<(Of <<'(ListItem>)>>)) | Sorts the specified comparison. (Inherited from vListBox.)
Public method | StartDraggingTimer | Starts the dragging timer. (Inherited from vListBox.)
Public method | StopDraggingTimer | Stops the dragging timer. (Inherited from vListBox.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | backFill | (Inherited from vListBox.)
Protected field | displayBounds | (Inherited from vListBox.)
Protected field | isScrollBarUpdateRequired | (Inherited from vListBox.)
Protected field | theme | (Inherited from vListBox.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether animations are enabled for the control (Inherited from vListBox.)
Public property | AllowDragDrop | Gets or sets whether the Drag drop operation is enabled (Inherited from vListBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowMultipleSelection | Obsolete. Gets or sets a value indicating whether the multiple selection is enabled. (Inherited from vListBox.)
Public property | AllowSelection | Obsolete. Gets a value indicating whether the vListBox currently enables selection of list items. (Inherited from vListBox.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the BackColor property for the control (Inherited from vListBox.)
Public property | BackgroundImage | Gets or sets the BackgroundImage for the control (Inherited from vListBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the BorderColor of the ListBox. (Inherited from vListBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckOnClick | Gets or sets a value indicating whether the item is checked when it is clicked.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for the vListBox control (Inherited from vListBox.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayMember | Gets or sets the display member associated to the vListBox. (Inherited from vListBox.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropFeedbackColor | Gets or sets the color of the drop feedback. (Inherited from vListBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HotTrack | Gets or sets whether the items change in appearance when the mouse passes over them (Inherited from vListBox.)
Public property | ImageList | Gets or sets the images to display on the vListBox items. (Inherited from vListBox.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsUpdating | (Inherited from vListBox.)
Public property | ItemHeight | Gets or sets the height of the vListBox items. (Inherited from vListBox.)
Public property | Items | Gets the vListBox items collection. (Inherited from vListBox.)
Public property | ItemsSpacing | (Inherited from vListBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMaskListItem | Gets or sets the mask that determines which corners of a ListItem are rounded (Inherited from vListBox.)
Public property | RoundedCornersRadiusListItem | Gets or sets the rounded corners radius of the ListItems. (Inherited from vListBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the selected index. (Inherited from vListBox.)
Public property | SelectedIndices | Gets the collection of selected indices. (Inherited from vListBox.)
Public property | SelectedItem | Gets or sets the selected item. (Inherited from vListBox.)
Public property | SelectedItems | Gets the collection of selected items. (Inherited from vListBox.)
Public property | SelectedValue | (Inherited from vListBox.)
Public property | SelectionMode | Gets or sets the selection mode. (Overrides vListBox..::..SelectionMode.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmartScrollEnabled | Determines whether to use Smart scrolling (Inherited from vListBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the Theme of the control. (Inherited from vListBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property. (Inherited from vListBox.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the BorderColor (Inherited from vListBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets a string that specifies the property of the data source from which to draw the value. (Inherited from vListBox.)
Public property | VIBlendScrollBarsTheme | Gets or sets the theme of the treeview scrollbars using one of the built-in themes. (Inherited from vListBox.)
Public property | VIBlendTheme | Gets or sets the theme of the control to one of the built-in themes. (Inherited from vListBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs Data Source is changed. (Inherited from vListBox.)
Public event | DisplayMemberChanged | Occurs when the DisplayMember has been changed. (Inherited from vListBox.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawListItem | Occurs when an item is being painted. (Inherited from vListBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemChecked | Occurs when item is checked.
Public event | ItemChecking | Occurs when item's check state is changing.
Public event | ItemDragEnded | Occurs when item's drag operation has ended. (Inherited from vListBox.)
Public event | ItemDragEnding | Occurs when item's drag operation is ending. (Inherited from vListBox.)
Public event | ItemDragging | Occurs when the drag item changes its location. (Inherited from vListBox.)
Public event | ItemDragStarted | Occurs when item's drag operation has started. (Inherited from vListBox.)
Public event | ItemDragStarting | Occurs when item's drag operation is starting. (Inherited from vListBox.)
Public event | ItemFormat | Occurs when the control's DataSource property is set and before the item is added to the Items collection. You can use this event to format the item's string. (Inherited from vListBox.)
Public event | ItemMouseDown | Occurs when the mouse is clicked over a ListItem. (Inherited from vListBox.)
Public event | ItemMouseUp | Occurs when the mouse is clicked over a ListItem. (Inherited from vListBox.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the selected index changes (Inherited from vListBox.)
Public event | SelectedItemChanged | occurs when the selection is changed. (Inherited from vListBox.)
Public event | SelectedItemChanging | Occurs when the selection is changing. (Inherited from vListBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue has changed. (Inherited from vListBox.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRadioListBox Class


vRadioListBox Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox Constructor
vRadioListBox Class See Also Send Feedback
Initializes a new instance of the vRadioListBox class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRadioListBox()
Visual Basic
Public Sub New
Visual C++
public:
vRadioListBox()

See Also

vRadioListBox Class


vRadioListBox Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox Fields
vRadioListBox Class See Also Send Feedback

The vRadioListBox type exposes the following members.

Fields

 | Name | Description
Protected field | backFill | (Inherited from vListBox.)
Protected field | displayBounds | (Inherited from vListBox.)
Protected field | isScrollBarUpdateRequired | (Inherited from vListBox.)
Protected field | theme | (Inherited from vListBox.)

See Also

vRadioListBox Class


vRadioListBox Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox Methods
vRadioListBox Class See Also Send Feedback

The vRadioListBox type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | BeginDrag | Begins the drag. (Inherited from vListBox.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Begins a batch of changes on the items collection (Inherited from vListBox.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CanSelectMultipleItems | Determines whether this instance can select multiple items. (Inherited from vListBox.)
Public method | CheckItem | Checks the item.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawDragFeedback(Graphics) | (Inherited from vListBox.)
Public method | DrawItem | (Inherited from vListBox.)
Public method | DrawItemImage | Draws the item image. (Inherited from vListBox.)
Public method | DrawListItemBackGroundAndBorder | Draws the list item back ground and border. (Inherited from vListBox.)
Public method | DrawListItemTextAndDescription | Draws the list item text and description. (Inherited from vListBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Protected method | EndDrag | Ends the drag. (Inherited from vListBox.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Begins a batch of changes on the items collection previously started by BeginUpdate() (Inherited from vListBox.)
Public method | EnsureVisible | Ensures that a list view item is visible. (Inherited from vListBox.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FilterItemOnProperty | (Inherited from vListBox.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindItem(Point) | Get ListItem at specific point. (Inherited from vListBox.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Protected method | GetBackFillColor | Gets the color of the back fill. (Inherited from vListBox.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemFont | Gets the item font. (Inherited from vListBox.)
Public method | GetItemForeColor | Gets the color of the item fore. (Inherited from vListBox.)
Public method | GetItemImage | Gets the item image. (Inherited from vListBox.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest | Performs a HitTest at a specific point (Inherited from vListBox.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from vListBox.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDataSourceChanged | Raises the DataSourceChanged event (Inherited from vListBox.)
Protected method | OnDisplayMemberChanged | Raises the OnDisplayMemberChanged event (Inherited from vListBox.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawItem | Raises the DrawItem event. (Inherited from vListBox.)
Protected method | OnDrawListItem | (Inherited from vListBox.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemChecked | Raises the [E:ItemChecked] event.
Protected method | OnItemChecking | Raises the [E:ItemChecking] event.
Protected method | OnItemDragEnded | (Inherited from vListBox.)
Protected method | OnItemDragEnding | (Inherited from vListBox.)
Protected method | OnItemDragging | (Inherited from vListBox.)
Protected method | OnItemDragStarted | (Inherited from vListBox.)
Protected method | OnItemDragStarting | (Inherited from vListBox.)
Protected method | OnItemFormat | Raises the [E:ItemFormat] event. (Inherited from vListBox.)
Protected method | OnItemMouseDown | Raises the [E:ItemMouseDown] event. (Inherited from vListBox.)
Protected method | OnItemMouseUp | Raises the [E:ItemMouseUp] event. (Inherited from vListBox.)
Protected method | OnKeyDown | (Overrides vListBox..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from vListBox.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vListBox.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Overrides vListBox..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vListBox.)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Inherited from vListBox.)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vListBox.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from vListBox.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vListBox.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from vListBox.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectedIndexChanged | Raises the SelectedIndexChanged event (Inherited from vListBox.)
Protected method | OnSelectedItemChanged | (Inherited from vListBox.)
Protected method | OnSelectedItemChanging | (Inherited from vListBox.)
Protected method | OnSelectedValueChanged | Raises the SelectedValueChanged event. (Inherited from vListBox.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | This member overrides Control.ProcessCmdKey. (Inherited from vListBox.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Public method | ReBind | Rebinds the ListBox control. (Inherited from vListBox.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveSort | Removes the sort. (Inherited from vListBox.)
Protected method | RenderListBox | (Overrides vListBox..::..RenderListBox(PaintEventArgs).)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Reverse | Reverses this instance. (Inherited from vListBox.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetItemCore | Sets the object with the specified index in the derived class. (Inherited from vListBox.)
Protected method | SetItemsCore | Sets the object with the specified index in the derived class. (Inherited from vListBox.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort(Boolean) | Sorts the specified ascending. (Inherited from vListBox.)
Public method | Sort(IComparer<(Of <<'(ListItem>)>>)) | Sorts the specified comparer. (Inherited from vListBox.)
Public method | Sort(Comparison<(Of <<'(ListItem>)>>)) | Sorts the specified comparison. (Inherited from vListBox.)
Public method | StartDraggingTimer | Starts the dragging timer. (Inherited from vListBox.)
Public method | StopDraggingTimer | Stops the dragging timer. (Inherited from vListBox.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vRadioListBox Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..AccessibilityNotifyClients Method
vRadioListBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vRadioListBox Class
vRadioListBox Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..BeginInvoke Method
vRadioListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vRadioListBox Class
vRadioListBox Members


CheckItem Method

[image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..CheckItem Method
vRadioListBox Class See Also Send Feedback
Checks the item.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void CheckItem(
    ListItem item
)
Visual Basic
Public Overridable Sub CheckItem ( _
    item As ListItem _
)
Visual C++
public:
virtual void CheckItem(
    ListItem^ item
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..ListItem
The item.

See Also

vRadioListBox Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..Dispose Method
vRadioListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vRadioListBox Class
vRadioListBox Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..GetChildAtPoint Method
vRadioListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vRadioListBox Class
vRadioListBox Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..Invalidate Method
vRadioListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vRadioListBox Class
vRadioListBox Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..Invoke Method
vRadioListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vRadioListBox Class
vRadioListBox Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..MemberwiseClone Method
vRadioListBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vRadioListBox Class
vRadioListBox Members


OnItemChecked Method

[image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..OnItemChecked Method
vRadioListBox Class See Also Send Feedback
Raises the [E:ItemChecked] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnItemChecked(
    ItemCheckChangedEventArgs args
)
Visual Basic
Protected Overridable Sub OnItemChecked ( _
    args As ItemCheckChangedEventArgs _
)
Visual C++
protected:
virtual void OnItemChecked(
    ItemCheckChangedEventArgs^ args
)

Parameters

args
Type: ItemCheckChangedEventArgs
The ItemCheckChangedEventArgs instance containing the event data.

See Also

vRadioListBox Class


OnItemChecking Method

[image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..OnItemChecking Method
vRadioListBox Class See Also Send Feedback
Raises the [E:ItemChecking] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnItemChecking(
    ItemCheckChangingEventArgs args
)
Visual Basic
Protected Overridable Sub OnItemChecking ( _
    args As ItemCheckChangingEventArgs _
)
Visual C++
protected:
virtual void OnItemChecking(
    ItemCheckChangingEventArgs^ args
)

Parameters

args
Type: ItemCheckChangingEventArgs
The ItemCheckChangingEventArgs instance containing the event data.

See Also

vRadioListBox Class


OnKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..OnKeyDown Method
vRadioListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs

See Also

vRadioListBox Class


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..OnMouseDown Method
vRadioListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs mevent
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    mevent As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ mevent
) override

Parameters

mevent
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vRadioListBox Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..PerformLayout Method
vRadioListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vRadioListBox Class
vRadioListBox Members


RenderListBox Method

[image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..RenderListBox Method
vRadioListBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void RenderListBox(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub RenderListBox ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void RenderListBox(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vRadioListBox Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..ResumeLayout Method
vRadioListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vRadioListBox Class
vRadioListBox Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..RtlTranslateAlignment Method
vRadioListBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vRadioListBox Class
vRadioListBox Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..Scale Method
vRadioListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vRadioListBox Class
vRadioListBox Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..Select Method
vRadioListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vRadioListBox Class
vRadioListBox Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..SetBounds Method
vRadioListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vRadioListBox Class
vRadioListBox Members


Sort Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..Sort Method
vRadioListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort(Boolean) | Sorts the specified ascending. (Inherited from vListBox.)
Public method | Sort(IComparer<(Of <<'(ListItem>)>>)) | Sorts the specified comparer. (Inherited from vListBox.)
Public method | Sort(Comparison<(Of <<'(ListItem>)>>)) | Sorts the specified comparison. (Inherited from vListBox.)

See Also

vRadioListBox Class
vRadioListBox Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..UpdateBounds Method
vRadioListBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vRadioListBox Class
vRadioListBox Members


vRadioListBox Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox Properties
vRadioListBox Class See Also Send Feedback

The vRadioListBox type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether animations are enabled for the control (Inherited from vListBox.)
Public property | AllowDragDrop | Gets or sets whether the Drag drop operation is enabled (Inherited from vListBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowMultipleSelection | Obsolete. Gets or sets a value indicating whether the multiple selection is enabled. (Inherited from vListBox.)
Public property | AllowSelection | Obsolete. Gets a value indicating whether the vListBox currently enables selection of list items. (Inherited from vListBox.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the BackColor property for the control (Inherited from vListBox.)
Public property | BackgroundImage | Gets or sets the BackgroundImage for the control (Inherited from vListBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the BorderColor of the ListBox. (Inherited from vListBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckOnClick | Gets or sets a value indicating whether the item is checked when it is clicked.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for the vListBox control (Inherited from vListBox.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayMember | Gets or sets the display member associated to the vListBox. (Inherited from vListBox.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropFeedbackColor | Gets or sets the color of the drop feedback. (Inherited from vListBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HotTrack | Gets or sets whether the items change in appearance when the mouse passes over them (Inherited from vListBox.)
Public property | ImageList | Gets or sets the images to display on the vListBox items. (Inherited from vListBox.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsUpdating | (Inherited from vListBox.)
Public property | ItemHeight | Gets or sets the height of the vListBox items. (Inherited from vListBox.)
Public property | Items | Gets the vListBox items collection. (Inherited from vListBox.)
Public property | ItemsSpacing | (Inherited from vListBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMaskListItem | Gets or sets the mask that determines which corners of a ListItem are rounded (Inherited from vListBox.)
Public property | RoundedCornersRadiusListItem | Gets or sets the rounded corners radius of the ListItems. (Inherited from vListBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the selected index. (Inherited from vListBox.)
Public property | SelectedIndices | Gets the collection of selected indices. (Inherited from vListBox.)
Public property | SelectedItem | Gets or sets the selected item. (Inherited from vListBox.)
Public property | SelectedItems | Gets the collection of selected items. (Inherited from vListBox.)
Public property | SelectedValue | (Inherited from vListBox.)
Public property | SelectionMode | Gets or sets the selection mode. (Overrides vListBox..::..SelectionMode.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmartScrollEnabled | Determines whether to use Smart scrolling (Inherited from vListBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the Theme of the control. (Inherited from vListBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property. (Inherited from vListBox.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the BorderColor (Inherited from vListBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets a string that specifies the property of the data source from which to draw the value. (Inherited from vListBox.)
Public property | VIBlendScrollBarsTheme | Gets or sets the theme of the treeview scrollbars using one of the built-in themes. (Inherited from vListBox.)
Public property | VIBlendTheme | Gets or sets the theme of the control to one of the built-in themes. (Inherited from vListBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vRadioListBox Class


CheckOnClick Property

[image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..CheckOnClick Property
vRadioListBox Class See Also Send Feedback
Gets or sets a value indicating whether the item is checked when it is clicked.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool CheckOnClick { get; set; }
Visual Basic
Public Property CheckOnClick As Boolean
    Get
    Set
Visual C++
public:
property bool CheckOnClick {
    bool get ();
    void set (bool value);
}

See Also

vRadioListBox Class


SelectionMode Property

[image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..SelectionMode Property
vRadioListBox Class See Also Send Feedback
Gets or sets the selection mode.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override SelectionMode SelectionMode { get; set; }
Visual Basic
Public Overrides Property SelectionMode As SelectionMode
    Get
    Set
Visual C++
public:
virtual property SelectionMode SelectionMode {
    SelectionMode get () override;
    void set (SelectionMode value) override;
}

Field Value

The selection mode.

See Also

vRadioListBox Class


vRadioListBox Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox Events
vRadioListBox Class See Also Send Feedback

The vRadioListBox type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs Data Source is changed. (Inherited from vListBox.)
Public event | DisplayMemberChanged | Occurs when the DisplayMember has been changed. (Inherited from vListBox.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawListItem | Occurs when an item is being painted. (Inherited from vListBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemChecked | Occurs when item is checked.
Public event | ItemChecking | Occurs when item's check state is changing.
Public event | ItemDragEnded | Occurs when item's drag operation has ended. (Inherited from vListBox.)
Public event | ItemDragEnding | Occurs when item's drag operation is ending. (Inherited from vListBox.)
Public event | ItemDragging | Occurs when the drag item changes its location. (Inherited from vListBox.)
Public event | ItemDragStarted | Occurs when item's drag operation has started. (Inherited from vListBox.)
Public event | ItemDragStarting | Occurs when item's drag operation is starting. (Inherited from vListBox.)
Public event | ItemFormat | Occurs when the control's DataSource property is set and before the item is added to the Items collection. You can use this event to format the item's string. (Inherited from vListBox.)
Public event | ItemMouseDown | Occurs when the mouse is clicked over a ListItem. (Inherited from vListBox.)
Public event | ItemMouseUp | Occurs when the mouse is clicked over a ListItem. (Inherited from vListBox.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the selected index changes (Inherited from vListBox.)
Public event | SelectedItemChanged | occurs when the selection is changed. (Inherited from vListBox.)
Public event | SelectedItemChanging | Occurs when the selection is changing. (Inherited from vListBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue has changed. (Inherited from vListBox.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRadioListBox Class


ItemChecked Event

[image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..ItemChecked Event
vRadioListBox Class See Also Send Feedback
Occurs when item is checked.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event ItemCheckChangedEventHandler ItemChecked
Visual Basic
Public Event ItemChecked As ItemCheckChangedEventHandler
Visual C++
public:
 event ItemCheckChangedEventHandler^ ItemChecked {
    void add (ItemCheckChangedEventHandler^ value);
    void remove (ItemCheckChangedEventHandler^ value);
}

See Also

vRadioListBox Class


ItemChecking Event

[image]

VIBlend Controls for WinForms Help Documentation
vRadioListBox..::..ItemChecking Event
vRadioListBox Class See Also Send Feedback
Occurs when item's check state is changing.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event ItemCheckChangingEventHandler ItemChecking
Visual Basic
Public Event ItemChecking As ItemCheckChangingEventHandler
Visual C++
public:
 event ItemCheckChangingEventHandler^ ItemChecking {
    void add (ItemCheckChangingEventHandler^ value);
    void remove (ItemCheckChangingEventHandler^ value);
}

See Also

vRadioListBox Class


vRatingControl Class

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl Class
Members See Also Send Feedback
Represents a vRatingControl

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vRatingControl : ScrollableControlMiniBase
Visual Basic
Public Class vRatingControl _
    Inherits ScrollableControlMiniBase
Visual C++
public ref class vRatingControl : public ScrollableControlMiniBase

Remarks

A vRatingControl displays a rating bar, and allows the user to select a rating level.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
ScrollableControlMiniBase
VIBlend.WinForms.Controls..::..vRatingControl

See Also

vRatingControl Members


vRatingControl Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl Members
vRatingControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The vRatingControl type exposes the following members.

Constructors

 | Name | Description
Public method | vRatingControl | Initializes a new instance of the [!:RatingControl] class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Public method | OnValueChanged | Called when value has changed
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | backFill |

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxValue | Gets or sets the rating positions number.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RatingColor | Gets or sets the color of the rating.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | Shape | Gets or sets the shape.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Spacing | Gets or sets the rating positions number.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseRatingColor | Gets or sets a value indicating whether to use the rating color.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the rating.
Public property | ValueIndicatorSize | Gets or sets the width of the rating indicator.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when value has changed
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRatingControl Class


vRatingControl Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl Constructor
vRatingControl Class See Also Send Feedback
Initializes a new instance of the [!:RatingControl] class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRatingControl()
Visual Basic
Public Sub New
Visual C++
public:
vRatingControl()

See Also

vRatingControl Class


vRatingControl Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl Fields
vRatingControl Class See Also Send Feedback

The vRatingControl type exposes the following members.

Fields

 | Name | Description
Protected field | backFill |

See Also

vRatingControl Class


backFill Field

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..backFill Field
vRatingControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected BackgroundElement backFill
Visual Basic
Protected backFill As BackgroundElement
Visual C++
protected:
BackgroundElement^ backFill

See Also

vRatingControl Class


vRatingControl Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl Methods
vRatingControl Class See Also Send Feedback

The vRatingControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Public method | OnValueChanged | Called when value has changed
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vRatingControl Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..AccessibilityNotifyClients Method
vRatingControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vRatingControl Class
vRatingControl Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..BeginInvoke Method
vRatingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vRatingControl Class
vRatingControl Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..Dispose Method
vRatingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vRatingControl Class
vRatingControl Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..GetChildAtPoint Method
vRatingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vRatingControl Class
vRatingControl Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..Invalidate Method
vRatingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vRatingControl Class
vRatingControl Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..Invoke Method
vRatingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vRatingControl Class
vRatingControl Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..MemberwiseClone Method
vRatingControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vRatingControl Class
vRatingControl Members


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..OnMouseDown Method
vRatingControl Class See Also Send Feedback
Raises the MouseDown event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vRatingControl Class


OnMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..OnMouseLeave Method
vRatingControl Class See Also Send Feedback
Raises the MouseLeave event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vRatingControl Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..OnMouseMove Method
vRatingControl Class See Also Send Feedback
Raises the MouseMove event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vRatingControl Class


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..OnMouseUp Method
vRatingControl Class See Also Send Feedback
Raises the MouseUp event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vRatingControl Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..OnPaint Method
vRatingControl Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vRatingControl Class


OnValueChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..OnValueChanged Method
vRatingControl Class See Also Send Feedback
Called when value has changed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnValueChanged()
Visual Basic
Public Sub OnValueChanged
Visual C++
public:
void OnValueChanged()

See Also

vRatingControl Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..PerformLayout Method
vRatingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vRatingControl Class
vRatingControl Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..ResumeLayout Method
vRatingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vRatingControl Class
vRatingControl Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..RtlTranslateAlignment Method
vRatingControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vRatingControl Class
vRatingControl Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..Scale Method
vRatingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vRatingControl Class
vRatingControl Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..Select Method
vRatingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vRatingControl Class
vRatingControl Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..SetBounds Method
vRatingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vRatingControl Class
vRatingControl Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..UpdateBounds Method
vRatingControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vRatingControl Class
vRatingControl Members


vRatingControl Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl Properties
vRatingControl Class See Also Send Feedback

The vRatingControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxValue | Gets or sets the rating positions number.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RatingColor | Gets or sets the color of the rating.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | Shape | Gets or sets the shape.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Spacing | Gets or sets the rating positions number.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseRatingColor | Gets or sets a value indicating whether to use the rating color.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the rating.
Public property | ValueIndicatorSize | Gets or sets the width of the rating indicator.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vRatingControl Class


MaxValue Property

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..MaxValue Property
vRatingControl Class See Also Send Feedback
Gets or sets the rating positions number.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int MaxValue { get; set; }
Visual Basic
Public Property MaxValue As Integer
    Get
    Set
Visual C++
public:
property int MaxValue {
    int get ();
    void set (int value);
}

Field Value

The rating positions number.

See Also

vRatingControl Class


RatingColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..RatingColor Property
vRatingControl Class See Also Send Feedback
Gets or sets the color of the rating.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color RatingColor { get; set; }
Visual Basic
Public Property RatingColor As Color
    Get
    Set
Visual C++
public:
property Color RatingColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the rating.

See Also

vRatingControl Class


Shape Property

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..Shape Property
vRatingControl Class See Also Send Feedback
Gets or sets the shape.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRatingControlShapes Shape { get; set; }
Visual Basic
Public Property Shape As vRatingControlShapes
    Get
    Set
Visual C++
public:
property vRatingControlShapes Shape {
    vRatingControlShapes get ();
    void set (vRatingControlShapes value);
}

Field Value

The shape.

See Also

vRatingControl Class


Spacing Property

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..Spacing Property
vRatingControl Class See Also Send Feedback
Gets or sets the rating positions number.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Spacing { get; set; }
Visual Basic
Public Property Spacing As Integer
    Get
    Set
Visual C++
public:
property int Spacing {
    int get ();
    void set (int value);
}

Field Value

The rating positions number.

See Also

vRatingControl Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..Theme Property
vRatingControl Class See Also Send Feedback
Gets or sets the theme of the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vRatingControl Class


UseRatingColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..UseRatingColor Property
vRatingControl Class See Also Send Feedback
Gets or sets a value indicating whether to use the rating color.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseRatingColor { get; set; }
Visual Basic
Public Property UseRatingColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseRatingColor {
    bool get ();
    void set (bool value);
}

See Also

vRatingControl Class


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..Value Property
vRatingControl Class See Also Send Feedback
Gets or sets the rating.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public float Value { get; set; }
Visual Basic
Public Property Value As Single
    Get
    Set
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}

Field Value

The rating.

See Also

vRatingControl Class


ValueIndicatorSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..ValueIndicatorSize Property
vRatingControl Class See Also Send Feedback
Gets or sets the width of the rating indicator.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ValueIndicatorSize { get; set; }
Visual Basic
Public Property ValueIndicatorSize As Integer
    Get
    Set
Visual C++
public:
property int ValueIndicatorSize {
    int get ();
    void set (int value);
}

Field Value

The width of the rating indicator.

See Also

vRatingControl Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..VIBlendTheme Property
vRatingControl Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vRatingControl Class


vRatingControl Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRatingControl Events
vRatingControl Class See Also Send Feedback

The vRatingControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when value has changed
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRatingControl Class


ValueChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControl..::..ValueChanged Event
vRatingControl Class See Also Send Feedback
Occurs when value has changed

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ValueChanged
Visual Basic
Public Event ValueChanged As EventHandler
Visual C++
public:
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vRatingControl Class


vRatingControlShapes Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
vRatingControlShapes Enumeration
See Also Send Feedback
Enumaration of the rating control shape types

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum vRatingControlShapes
Visual Basic
Public Enumeration vRatingControlShapes
Visual C++
public enum class vRatingControlShapes

Members

Member name | Description
Standard |
Star |

See Also


vRepeatButton Class

[image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton Class
Members See Also Send Feedback
Represents a vRepeatButton control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vRepeatButton : vButton
Visual Basic
Public Class vRepeatButton _
    Inherits vButton
Visual C++
public ref class vRepeatButton : public vButton

Remarks

A vRepeatButton is a button with a built-in timer that raises events when the user holds the button pressed.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ButtonBase
System.Windows.Forms..::..Button
VIBlend.WinForms.Controls..::..vButton
VIBlend.WinForms.Controls..::..vRepeatButton

See Also

vRepeatButton Members


vRepeatButton Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton Members
vRepeatButton Class Constructors Methods Fields Properties Events See Also Send Feedback

The vRepeatButton type exposes the following members.

Constructors

 | Name | Description
Public method | vRepeatButton | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ButtonBase..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder | (Inherited from vButton.)
Protected method | DrawControl | Draws the control. (Inherited from vButton.)
Protected method | DrawFocusRectangle | (Inherited from vButton.)
Protected method | DrawImageAndText | (Inherited from vButton.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect | (Inherited from vButton.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from vButton.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from vButton.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vButton.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Inherited from vButton.)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vButton.)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Inherited from vButton.)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vButton.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vButton.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

Fields

 | Name | Description
Protected field | buttonBorderStyle | (Inherited from vButton.)
Protected field | opacity | (Inherited from vButton.)
Protected field | paintHelper | (Inherited from vButton.)
Protected field | theme | (Inherited from vButton.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vButton.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button (Inherited from vButton.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Public property | DelayInterval | Gets or sets the repeat delay interval
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Inherited from vButton.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled. (Inherited from vButton.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control. (Inherited from vButton.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity. (Inherited from vButton.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vButton.)
Public property | PaintDefaultBorder | Gets or sets a value indicating whether to paint a border when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultFill | Gets or sets a value indicating whether to paint a background when the control state is default. (Inherited from vButton.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vButton.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded (Inherited from vButton.)
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control. (Inherited from vButton.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused (Inherited from vButton.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image (Inherited from vButton.)
Public property | StyleKey | Gets or sets the style key. (Inherited from vButton.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control. (Inherited from vButton.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable (Inherited from vButton.)
Public property | Theme | Gets or sets the theme of the control (Inherited from vButton.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control. (Inherited from vButton.)
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control. (Inherited from vButton.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color. (Inherited from vButton.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vButton.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | RepeatButtonClick | Occurs when the vRepeatButton delay elapses
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRepeatButton Class


vRepeatButton Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton Constructor
vRepeatButton Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRepeatButton()
Visual Basic
Public Sub New
Visual C++
public:
vRepeatButton()

See Also

vRepeatButton Class


vRepeatButton Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton Fields
vRepeatButton Class See Also Send Feedback

The vRepeatButton type exposes the following members.

Fields

 | Name | Description
Protected field | buttonBorderStyle | (Inherited from vButton.)
Protected field | opacity | (Inherited from vButton.)
Protected field | paintHelper | (Inherited from vButton.)
Protected field | theme | (Inherited from vButton.)

See Also

vRepeatButton Class


vRepeatButton Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton Methods
vRepeatButton Class See Also Send Feedback

The vRepeatButton type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ButtonBase..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder | (Inherited from vButton.)
Protected method | DrawControl | Draws the control. (Inherited from vButton.)
Protected method | DrawFocusRectangle | (Inherited from vButton.)
Protected method | DrawImageAndText | (Inherited from vButton.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect | (Inherited from vButton.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from vButton.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from vButton.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vButton.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Inherited from vButton.)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vButton.)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Inherited from vButton.)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vButton.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vButton.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

See Also

vRepeatButton Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton..::..AccessibilityNotifyClients Method
vRepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vRepeatButton Class
vRepeatButton Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton..::..BeginInvoke Method
vRepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vRepeatButton Class
vRepeatButton Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton..::..Dispose Method
vRepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ButtonBase..::..Dispose(Boolean).)

See Also

vRepeatButton Class
vRepeatButton Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton..::..Dispose Method (Boolean)
vRepeatButton Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vRepeatButton Class
Dispose Overload


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton..::..GetChildAtPoint Method
vRepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vRepeatButton Class
vRepeatButton Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton..::..Invalidate Method
vRepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vRepeatButton Class
vRepeatButton Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton..::..Invoke Method
vRepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vRepeatButton Class
vRepeatButton Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton..::..MemberwiseClone Method
vRepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vRepeatButton Class
vRepeatButton Members


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton..::..PerformLayout Method
vRepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vRepeatButton Class
vRepeatButton Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton..::..ResumeLayout Method
vRepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vRepeatButton Class
vRepeatButton Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton..::..RtlTranslateAlignment Method
vRepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vRepeatButton Class
vRepeatButton Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton..::..Scale Method
vRepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vRepeatButton Class
vRepeatButton Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton..::..Select Method
vRepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vRepeatButton Class
vRepeatButton Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton..::..SetBounds Method
vRepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vRepeatButton Class
vRepeatButton Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton..::..UpdateBounds Method
vRepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vRepeatButton Class
vRepeatButton Members


vRepeatButton Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton Properties
vRepeatButton Class See Also Send Feedback

The vRepeatButton type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vButton.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button (Inherited from vButton.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Public property | DelayInterval | Gets or sets the repeat delay interval
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Inherited from vButton.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled. (Inherited from vButton.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control. (Inherited from vButton.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity. (Inherited from vButton.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vButton.)
Public property | PaintDefaultBorder | Gets or sets a value indicating whether to paint a border when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultFill | Gets or sets a value indicating whether to paint a background when the control state is default. (Inherited from vButton.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vButton.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded (Inherited from vButton.)
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control. (Inherited from vButton.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused (Inherited from vButton.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image (Inherited from vButton.)
Public property | StyleKey | Gets or sets the style key. (Inherited from vButton.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control. (Inherited from vButton.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable (Inherited from vButton.)
Public property | Theme | Gets or sets the theme of the control (Inherited from vButton.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control. (Inherited from vButton.)
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control. (Inherited from vButton.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color. (Inherited from vButton.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vButton.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vRepeatButton Class


DelayInterval Property

[image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton..::..DelayInterval Property
vRepeatButton Class See Also Send Feedback
Gets or sets the repeat delay interval

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int DelayInterval { get; set; }
Visual Basic
Public Property DelayInterval As Integer
    Get
    Set
Visual C++
public:
property int DelayInterval {
    int get ();
    void set (int value);
}

See Also

vRepeatButton Class


vRepeatButton Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton Events
vRepeatButton Class See Also Send Feedback

The vRepeatButton type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | RepeatButtonClick | Occurs when the vRepeatButton delay elapses
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRepeatButton Class


RepeatButtonClick Event

[image]

VIBlend Controls for WinForms Help Documentation
vRepeatButton..::..RepeatButtonClick Event
vRepeatButton Class See Also Send Feedback
Occurs when the vRepeatButton delay elapses

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler RepeatButtonClick
Visual Basic
Public Event RepeatButtonClick As EventHandler
Visual C++
public:
 event EventHandler^ RepeatButtonClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vRepeatButton Class


vRibbonApplicationButton Class

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton Class
Members See Also Send Feedback
Represents a vRibbonApplicationButton control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vRibbonApplicationButton : Control,
    IScrollableControlBase
Visual Basic
Public Class vRibbonApplicationButton _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class vRibbonApplicationButton : public Control,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vRibbonApplicationButton

See Also

vRibbonApplicationButton Members


vRibbonApplicationButton Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton Members
vRibbonApplicationButton Class Constructors Methods Properties Events See Also Send Feedback

The vRibbonApplicationButton type exposes the following members.

Constructors

 | Name | Description
Public method | vRibbonApplicationButton | Initializes a new instance of the vRibbonApplicationButton class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the Popup.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | Open | Opens the Popup.
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content | Gets the content.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDownHeight | Gets or sets the height of the drop down.
Public property | DropDownWidth | Gets or sets the width of the drop down.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedButton | Gets the rounded button.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRibbonApplicationButton Class


vRibbonApplicationButton Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton Constructor
vRibbonApplicationButton Class See Also Send Feedback
Initializes a new instance of the vRibbonApplicationButton class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonApplicationButton()
Visual Basic
Public Sub New
Visual C++
public:
vRibbonApplicationButton()

See Also

vRibbonApplicationButton Class


vRibbonApplicationButton Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton Methods
vRibbonApplicationButton Class See Also Send Feedback

The vRibbonApplicationButton type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the Popup.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | Open | Opens the Popup.
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vRibbonApplicationButton Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..AccessibilityNotifyClients Method
vRibbonApplicationButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vRibbonApplicationButton Class
vRibbonApplicationButton Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..BeginInvoke Method
vRibbonApplicationButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vRibbonApplicationButton Class
vRibbonApplicationButton Members


Close Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..Close Method
vRibbonApplicationButton Class See Also Send Feedback
Closes the Popup.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

vRibbonApplicationButton Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..Dispose Method
vRibbonApplicationButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vRibbonApplicationButton Class
vRibbonApplicationButton Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..GetChildAtPoint Method
vRibbonApplicationButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vRibbonApplicationButton Class
vRibbonApplicationButton Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..Invalidate Method
vRibbonApplicationButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vRibbonApplicationButton Class
vRibbonApplicationButton Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..Invoke Method
vRibbonApplicationButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vRibbonApplicationButton Class
vRibbonApplicationButton Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..MemberwiseClone Method
vRibbonApplicationButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vRibbonApplicationButton Class
vRibbonApplicationButton Members


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..OnLayout Method
vRibbonApplicationButton Class See Also Send Feedback
Raises the Layout event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
A LayoutEventArgs that contains the event data.

See Also

vRibbonApplicationButton Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..OnPaint Method
vRibbonApplicationButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vRibbonApplicationButton Class


Open Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..Open Method
vRibbonApplicationButton Class See Also Send Feedback
Opens the Popup.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Open()
Visual Basic
Public Sub Open
Visual C++
public:
void Open()

See Also

vRibbonApplicationButton Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..PerformLayout Method
vRibbonApplicationButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vRibbonApplicationButton Class
vRibbonApplicationButton Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..ResumeLayout Method
vRibbonApplicationButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vRibbonApplicationButton Class
vRibbonApplicationButton Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..RtlTranslateAlignment Method
vRibbonApplicationButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vRibbonApplicationButton Class
vRibbonApplicationButton Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..Scale Method
vRibbonApplicationButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vRibbonApplicationButton Class
vRibbonApplicationButton Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..Select Method
vRibbonApplicationButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vRibbonApplicationButton Class
vRibbonApplicationButton Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..SetBounds Method
vRibbonApplicationButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vRibbonApplicationButton Class
vRibbonApplicationButton Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..UpdateBounds Method
vRibbonApplicationButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vRibbonApplicationButton Class
vRibbonApplicationButton Members


vRibbonApplicationButton Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton Properties
vRibbonApplicationButton Class See Also Send Feedback

The vRibbonApplicationButton type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content | Gets the content.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDownHeight | Gets or sets the height of the drop down.
Public property | DropDownWidth | Gets or sets the width of the drop down.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedButton | Gets the rounded button.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vRibbonApplicationButton Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..AllowAnimations Property
vRibbonApplicationButton Class See Also Send Feedback
Determines whether to use animations

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vRibbonApplicationButton Class


Content Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..Content Property
vRibbonApplicationButton Class See Also Send Feedback
Gets the content.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Panel Content { get; }
Visual Basic
Public ReadOnly Property Content As Panel
    Get
Visual C++
public:
property Panel^ Content {
    Panel^ get ();
}

Field Value

The content.

See Also

vRibbonApplicationButton Class


DropDownHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..DropDownHeight Property
vRibbonApplicationButton Class See Also Send Feedback
Gets or sets the height of the drop down.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int DropDownHeight { get; set; }
Visual Basic
Public Property DropDownHeight As Integer
    Get
    Set
Visual C++
public:
property int DropDownHeight {
    int get ();
    void set (int value);
}

Field Value

The height of the drop down.

See Also

vRibbonApplicationButton Class


DropDownWidth Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..DropDownWidth Property
vRibbonApplicationButton Class See Also Send Feedback
Gets or sets the width of the drop down.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int DropDownWidth { get; set; }
Visual Basic
Public Property DropDownWidth As Integer
    Get
    Set
Visual C++
public:
property int DropDownWidth {
    int get ();
    void set (int value);
}

Field Value

The width of the drop down.

See Also

vRibbonApplicationButton Class


RoundedButton Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..RoundedButton Property
vRibbonApplicationButton Class See Also Send Feedback
Gets the rounded button.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vToggleCircularButton RoundedButton { get; }
Visual Basic
Public ReadOnly Property RoundedButton As vToggleCircularButton
    Get
Visual C++
public:
property vToggleCircularButton^ RoundedButton {
    vToggleCircularButton^ get ();
}

Field Value

The rounded button.

See Also

vRibbonApplicationButton Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..Theme Property
vRibbonApplicationButton Class See Also Send Feedback
Gets or sets the theme of the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vRibbonApplicationButton Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton..::..VIBlendTheme Property
vRibbonApplicationButton Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vRibbonApplicationButton Class


vRibbonApplicationButton Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonApplicationButton Events
vRibbonApplicationButton Class See Also Send Feedback

The vRibbonApplicationButton type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRibbonApplicationButton Class


vRibbonBar Class

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar Class
Members See Also Send Feedback
Represents a vRibbonBar control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vRibbonBar : vTabControl
Visual Basic
Public Class vRibbonBar _
    Inherits vTabControl
Visual C++
public ref class vRibbonBar : public vTabControl

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..Panel
VIBlend.WinForms.Controls..::..vTabControl
VIBlend.WinForms.Controls..::..vRibbonBar

See Also

vRibbonBar Members


vRibbonBar Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar Members
vRibbonBar Class Constructors Methods Fields Properties Events See Also Send Feedback

The vRibbonBar type exposes the following members.

Constructors

 | Name | Description
Public method | vRibbonBar | Initializes a new instance of the vRibbonBar class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the TabControl's DropDown. (Inherited from vTabControl.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | DeleteTabPage | Deletes the tab page. (Inherited from vTabControl.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawCloseButton | Draws the close button. (Inherited from vTabControl.)
Protected method | DrawContexts | (Inherited from vTabControl.)
Public method | DrawDefaultTab | (Inherited from vTabControl.)
Public method | DrawHighlightedTab | (Inherited from vTabControl.)
Public method | DrawSelectedAndHighlightedTab | (Inherited from vTabControl.)
Public method | DrawSelectedTab | (Inherited from vTabControl.)
Protected method | DrawTab | Draws the tab. (Inherited from vTabControl.)
Protected method | DrawTabImage | (Inherited from vTabControl.)
Public method | DrawTabText(Graphics, vTabPage, Color, Rectangle) | (Inherited from vTabControl.)
Public method | DrawTabText(Graphics, vTabPage, ControlState, Rectangle) | (Inherited from vTabControl.)
Protected method | DrawTextLeftRotated | Draws the text left rotated. (Inherited from vTabControl.)
Protected method | DrawTitleBackGround | (Overrides vTabControl..::..DrawTitleBackGround(Graphics).)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureTabVisible | Call this function to ensure that a specific tab page is visible. (Inherited from vTabControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Protected method | GetPageRectangle | (Inherited from vTabControl.)
Protected method | GetPagesByContext | (Inherited from vTabControl.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest | Performs a hit test and returns the tab page at a specific point. (Inherited from vTabControl.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawTabControlTitle | Raises the [E:DrawTabControlTitle] event. (Inherited from vTabControl.)
Protected method | OnDrawTabPage | Raises the [E:DrawTabPage] event. (Inherited from vTabControl.)
Protected method | OnDrawTabPageBackground | Raises the [E:DrawTabPageBackground] event. (Inherited from vTabControl.)
Protected method | OnDropDownStyleChanged | Raises the DropDownStyleChanged event. (Inherited from vTabControl.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ScrollableControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | (Inherited from vTabControl.)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides vTabControl..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides vTabControlOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides vTabControlOnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | (Inherited from vTabControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Overrides vTabControlOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Overrides Control..::..OnParentChanged(EventArgs).)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPopupPaint | (Inherited from vTabControl.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabMouseDown | Raises the [E:TabMouseDown] event. (Inherited from vTabControl.)
Protected method | OnTabMouseUp | Raises the [E:TabMouseUp] event. (Inherited from vTabControl.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnToolTipShown | (Inherited from vTabControl.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | (Inherited from vTabControl.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | OpenDropDown | Opens the TabControl's popup. (Inherited from vTabControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Overrides Control..::..ResetFont()()()().)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Public method | UpdateScrollbars | Updates the scrollbars. (Inherited from vTabControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Overrides ScrollableControl..::..WndProc(Message%).)

Fields

 | Name | Description
Protected field | allowAnimations | (Inherited from vTabControl.)
Protected field | backGround | (Inherited from vTabControl.)
Protected field | dropDown | (Inherited from vTabControl.)
Protected field | dropDownPosition | (Inherited from vTabControl.)
Protected field | dropDownSize | (Inherited from vTabControl.)
Protected field | otherControls | (Inherited from vTabControl.)
Protected field | paintHelper | (Inherited from vTabControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTabControl.)
Public property | AllowDeleteOnMiddleMouseButton | Gets or sets whether the tab is closed on mouse wheel button click (Inherited from vTabControl.)
Public property | AllowDragDrop | Gets or sets whether drag and drop is enabled. (Inherited from vTabControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowMinimizedState | Gets or sets a value indicating whether the control can be minimized.
Public property | AllowParentFormDrag | Gets or sets a value indicating whether parent form could be moved and resized using ribbon's caption
Public property | AllowRibbonRendering | Gets or sets whether the default rendering is enabled.
Public property | AllowScrollingAnimation | Gets or sets a value indicating whether scrolling animation is enabled (Inherited from vTabControl.)
Public property | AllPagesHeight | Gets or sets the height of all pages. (Overrides vTabControl..::..AllPagesHeight.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | ApplicationButton | Gets or sets the application button.
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | (Inherited from vTabControl.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ContextTabsOffset | Gets or sets the context tabs offset. (Inherited from vTabControl.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | CornerRadius | Get or sets the rounding radius when the TabsShape property is set to RoundedCorners. (Inherited from vTabControl.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Public property | DescriptionText | Gets or sets the description text.
Public property | DescriptionTextColor | Gets or sets the color of the description text.
Public property | DescriptionTextFont | Gets or sets the description text font.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DrawQuickAccessToolbarBackground | Gets or sets a value indicating whether should draw qat background
Public property | DrawTitleFill |
Public property | EnableCloseButtons | Gets or sets whether the close buttons are enabled. (Inherited from vTabControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableDropDownStyle | Gets or sets a value indicating whether drop down style is enabled. (Overrides vTabControl..::..EnableDropDownStyle.)
Public property | EnableToolTips | Gets or sets a value indicating whether tool tips are enabled. (Inherited from vTabControl.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FitTabsToBounds | (Overrides vTabControl..::..FitTabsToBounds.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control.
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImageList | Gets or sets the image list associated to the tab control. (Inherited from vTabControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | QuickAccessToolbar | Gets or sets the QuickAccessToolbar associated to the RibbonBar control.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RibbonStyle | Gets or sets the ribbon style.
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the selected tab in the tab control. (Inherited from vTabControl.)
Public property | SelectedTab | Gets or sets the selected tab in the tab control. (Inherited from vTabControl.)
Public property | ShowCloseButtonOnSelectedTabOnly | Gets or sets a value indicating whether to display the close button only when the TabPage is selected. (Inherited from vTabControl.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when a tab is focused. (Inherited from vTabControl.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key. (Inherited from vTabControl.)
Public property | TabAlignment | (Overrides vTabControl..::..TabAlignment.)
Public property | TabContexts | Gets or sets the tab contexts. (Overrides vTabControl..::..TabContexts.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabPages | Gets the tab pages collection of the vTabControl. (Inherited from vTabControl.)
Public property | TabsAreaBackColor | (Overrides vTabControl..::..TabsAreaBackColor.)
Public property | TabsAreaBorderColor | Gets or sets the BackColor of vTabControl Tabs area. (Inherited from vTabControl.)
Public property | TabsInitialOffset | Gets or sets the initial offset for the tab pages. (Overrides vTabControl..::..TabsInitialOffset.)
Public property | TabsShape | Gets or sets the tabs shape. (Inherited from vTabControl.)
Public property | TabsSpacing | Gets or sets the spacing between the tab pages. (Inherited from vTabControl.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text.
Public property | TextAlignment | Gets or sets the text alignment.
Public property | TextOrientation | (Overrides vTabControl..::..TextOrientation.)
Public property | Theme | (Overrides vTabControl..::..Theme.)
Public property | TitleHeight | Determines the height of the title area which holds the tab pages (Inherited from vTabControl.)
Public property | ToolTipDuration | Gets or sets the duration of the tool tip. (Inherited from vTabControl.)
Public property | ToolTipShowDelay | Gets or sets the tool tip show delay. (Inherited from vTabControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseTabsAreaBackColor | (Overrides vTabControl..::..UseTabsAreaBackColor.)
Public property | UseTabsAreaBorderColor | Gets or sets a value indicating whether to use the TabsAreaBorderColor (Inherited from vTabControl.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Overrides vTabControl..::..VIBlendTheme.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawTabPage | Occurs when a TabPage is rendered. (Inherited from vTabControl.)
Public event | DrawTabPageBackground | Occurs when a TabPage is rendered. (Inherited from vTabControl.)
Public event | DrawTitleBackground | Occurs when the Title is rendered. (Inherited from vTabControl.)
Public event | DropDownStyleChanged | Occurs when the EnableDropDownStyle property is changed. (Inherited from vTabControl.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HoveredTabChanged | Occurs when the HoveredTab has changed. (Inherited from vTabControl.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PopupPaint | Occurs when popup panel is painted. (Inherited from vTabControl.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property has changed. (Inherited from vTabControl.)
Public event | SelectedIndexChanging | Occurs when the selected index is about to change (Inherited from vTabControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabMouseDown | Occurs when the mouse button is clicked over a tab. (Inherited from vTabControl.)
Public event | TabMouseUp | Occurs when the mouse button is clicked over a tab. (Inherited from vTabControl.)
Public event | TabPageDragEnded | Occurs when a tab page drag has ended (Inherited from vTabControl.)
Public event | TabPageDragEnding | Occurs when a tab page drag is about to end (Inherited from vTabControl.)
Public event | TabPageDragStarted | Occurs when a tab page drag has started (Inherited from vTabControl.)
Public event | TabPageDragStarting | Occurs when a tab page drag is about to start (Inherited from vTabControl.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | TitleClick | Occurs when the users clicks in the Title area (Inherited from vTabControl.)
Public event | TooltipShow | Occurs when tooltip shows. (Inherited from vTabControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRibbonBar Class


vRibbonBar Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar Constructor
vRibbonBar Class See Also Send Feedback
Initializes a new instance of the vRibbonBar class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonBar()
Visual Basic
Public Sub New
Visual C++
public:
vRibbonBar()

See Also

vRibbonBar Class


vRibbonBar Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar Fields
vRibbonBar Class See Also Send Feedback

The vRibbonBar type exposes the following members.

Fields

 | Name | Description
Protected field | allowAnimations | (Inherited from vTabControl.)
Protected field | backGround | (Inherited from vTabControl.)
Protected field | dropDown | (Inherited from vTabControl.)
Protected field | dropDownPosition | (Inherited from vTabControl.)
Protected field | dropDownSize | (Inherited from vTabControl.)
Protected field | otherControls | (Inherited from vTabControl.)
Protected field | paintHelper | (Inherited from vTabControl.)

See Also

vRibbonBar Class


vRibbonBar Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar Methods
vRibbonBar Class See Also Send Feedback

The vRibbonBar type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the TabControl's DropDown. (Inherited from vTabControl.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | DeleteTabPage | Deletes the tab page. (Inherited from vTabControl.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawCloseButton | Draws the close button. (Inherited from vTabControl.)
Protected method | DrawContexts | (Inherited from vTabControl.)
Public method | DrawDefaultTab | (Inherited from vTabControl.)
Public method | DrawHighlightedTab | (Inherited from vTabControl.)
Public method | DrawSelectedAndHighlightedTab | (Inherited from vTabControl.)
Public method | DrawSelectedTab | (Inherited from vTabControl.)
Protected method | DrawTab | Draws the tab. (Inherited from vTabControl.)
Protected method | DrawTabImage | (Inherited from vTabControl.)
Public method | DrawTabText(Graphics, vTabPage, Color, Rectangle) | (Inherited from vTabControl.)
Public method | DrawTabText(Graphics, vTabPage, ControlState, Rectangle) | (Inherited from vTabControl.)
Protected method | DrawTextLeftRotated | Draws the text left rotated. (Inherited from vTabControl.)
Protected method | DrawTitleBackGround | (Overrides vTabControl..::..DrawTitleBackGround(Graphics).)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureTabVisible | Call this function to ensure that a specific tab page is visible. (Inherited from vTabControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Protected method | GetPageRectangle | (Inherited from vTabControl.)
Protected method | GetPagesByContext | (Inherited from vTabControl.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest | Performs a hit test and returns the tab page at a specific point. (Inherited from vTabControl.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawTabControlTitle | Raises the [E:DrawTabControlTitle] event. (Inherited from vTabControl.)
Protected method | OnDrawTabPage | Raises the [E:DrawTabPage] event. (Inherited from vTabControl.)
Protected method | OnDrawTabPageBackground | Raises the [E:DrawTabPageBackground] event. (Inherited from vTabControl.)
Protected method | OnDropDownStyleChanged | Raises the DropDownStyleChanged event. (Inherited from vTabControl.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ScrollableControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | (Inherited from vTabControl.)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides vTabControl..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides vTabControlOnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides vTabControlOnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | (Inherited from vTabControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Overrides vTabControlOnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Overrides Control..::..OnParentChanged(EventArgs).)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPopupPaint | (Inherited from vTabControl.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabMouseDown | Raises the [E:TabMouseDown] event. (Inherited from vTabControl.)
Protected method | OnTabMouseUp | Raises the [E:TabMouseUp] event. (Inherited from vTabControl.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnToolTipShown | (Inherited from vTabControl.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | (Inherited from vTabControl.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | OpenDropDown | Opens the TabControl's popup. (Inherited from vTabControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Overrides Control..::..ResetFont()()()().)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Public method | UpdateScrollbars | Updates the scrollbars. (Inherited from vTabControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Overrides ScrollableControl..::..WndProc(Message%).)

See Also

vRibbonBar Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..AccessibilityNotifyClients Method
vRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vRibbonBar Class
vRibbonBar Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..BeginInvoke Method
vRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vRibbonBar Class
vRibbonBar Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..Dispose Method
vRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vRibbonBar Class
vRibbonBar Members


DrawTabText Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..DrawTabText Method
vRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawTabText(Graphics, vTabPage, Color, Rectangle) | (Inherited from vTabControl.)
Public method | DrawTabText(Graphics, vTabPage, ControlState, Rectangle) | (Inherited from vTabControl.)

See Also

vRibbonBar Class
vRibbonBar Members


DrawTitleBackGround Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..DrawTitleBackGround Method
vRibbonBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void DrawTitleBackGround(
    Graphics g
)
Visual Basic
Protected Overrides Sub DrawTitleBackGround ( _
    g As Graphics _
)
Visual C++
protected:
virtual void DrawTitleBackGround(
    Graphics^ g
) override

Parameters

g
Type: System.Drawing..::..Graphics

See Also

vRibbonBar Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..GetChildAtPoint Method
vRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vRibbonBar Class
vRibbonBar Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..Invalidate Method
vRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vRibbonBar Class
vRibbonBar Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..Invoke Method
vRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vRibbonBar Class
vRibbonBar Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..MemberwiseClone Method
vRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vRibbonBar Class
vRibbonBar Members


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..OnMouseDown Method
vRibbonBar Class See Also Send Feedback
Raises the MouseDown event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vRibbonBar Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..OnMouseMove Method
vRibbonBar Class See Also Send Feedback
Raises the MouseMove event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vRibbonBar Class


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..OnMouseUp Method
vRibbonBar Class See Also Send Feedback
Raises the MouseUp event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vRibbonBar Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..OnPaint Method
vRibbonBar Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs p
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    p As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ p
) override

Parameters

p
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vRibbonBar Class


OnParentChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..OnParentChanged Method
vRibbonBar Class See Also Send Feedback
Raises the ParentChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnParentChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnParentChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnParentChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vRibbonBar Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..PerformLayout Method
vRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vRibbonBar Class
vRibbonBar Members


ResetFont Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..ResetFont Method
vRibbonBar Class See Also Send Feedback
Resets the Font property to its default value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void ResetFont()
Visual Basic
Public Overrides Sub ResetFont
Visual C++
public:
virtual void ResetFont() override

See Also

vRibbonBar Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..ResumeLayout Method
vRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vRibbonBar Class
vRibbonBar Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..RtlTranslateAlignment Method
vRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vRibbonBar Class
vRibbonBar Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..Scale Method
vRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vRibbonBar Class
vRibbonBar Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..Select Method
vRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vRibbonBar Class
vRibbonBar Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..SetBounds Method
vRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vRibbonBar Class
vRibbonBar Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..UpdateBounds Method
vRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vRibbonBar Class
vRibbonBar Members


WndProc Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..WndProc Method
vRibbonBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void WndProc(
    ref Message m
)
Visual Basic
Protected Overrides Sub WndProc ( _
    ByRef m As Message _
)
Visual C++
protected:
virtual void WndProc(
    Message% m
) override

Parameters

m
Type: System.Windows.Forms..::..Message %
The Windows Message to process.

See Also

vRibbonBar Class


vRibbonBar Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar Properties
vRibbonBar Class See Also Send Feedback

The vRibbonBar type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTabControl.)
Public property | AllowDeleteOnMiddleMouseButton | Gets or sets whether the tab is closed on mouse wheel button click (Inherited from vTabControl.)
Public property | AllowDragDrop | Gets or sets whether drag and drop is enabled. (Inherited from vTabControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowMinimizedState | Gets or sets a value indicating whether the control can be minimized.
Public property | AllowParentFormDrag | Gets or sets a value indicating whether parent form could be moved and resized using ribbon's caption
Public property | AllowRibbonRendering | Gets or sets whether the default rendering is enabled.
Public property | AllowScrollingAnimation | Gets or sets a value indicating whether scrolling animation is enabled (Inherited from vTabControl.)
Public property | AllPagesHeight | Gets or sets the height of all pages. (Overrides vTabControl..::..AllPagesHeight.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | ApplicationButton | Gets or sets the application button.
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | (Inherited from vTabControl.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ContextTabsOffset | Gets or sets the context tabs offset. (Inherited from vTabControl.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | CornerRadius | Get or sets the rounding radius when the TabsShape property is set to RoundedCorners. (Inherited from vTabControl.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Public property | DescriptionText | Gets or sets the description text.
Public property | DescriptionTextColor | Gets or sets the color of the description text.
Public property | DescriptionTextFont | Gets or sets the description text font.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DrawQuickAccessToolbarBackground | Gets or sets a value indicating whether should draw qat background
Public property | DrawTitleFill |
Public property | EnableCloseButtons | Gets or sets whether the close buttons are enabled. (Inherited from vTabControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableDropDownStyle | Gets or sets a value indicating whether drop down style is enabled. (Overrides vTabControl..::..EnableDropDownStyle.)
Public property | EnableToolTips | Gets or sets a value indicating whether tool tips are enabled. (Inherited from vTabControl.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FitTabsToBounds | (Overrides vTabControl..::..FitTabsToBounds.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control.
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImageList | Gets or sets the image list associated to the tab control. (Inherited from vTabControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | QuickAccessToolbar | Gets or sets the QuickAccessToolbar associated to the RibbonBar control.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RibbonStyle | Gets or sets the ribbon style.
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the selected tab in the tab control. (Inherited from vTabControl.)
Public property | SelectedTab | Gets or sets the selected tab in the tab control. (Inherited from vTabControl.)
Public property | ShowCloseButtonOnSelectedTabOnly | Gets or sets a value indicating whether to display the close button only when the TabPage is selected. (Inherited from vTabControl.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when a tab is focused. (Inherited from vTabControl.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key. (Inherited from vTabControl.)
Public property | TabAlignment | (Overrides vTabControl..::..TabAlignment.)
Public property | TabContexts | Gets or sets the tab contexts. (Overrides vTabControl..::..TabContexts.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabPages | Gets the tab pages collection of the vTabControl. (Inherited from vTabControl.)
Public property | TabsAreaBackColor | (Overrides vTabControl..::..TabsAreaBackColor.)
Public property | TabsAreaBorderColor | Gets or sets the BackColor of vTabControl Tabs area. (Inherited from vTabControl.)
Public property | TabsInitialOffset | Gets or sets the initial offset for the tab pages. (Overrides vTabControl..::..TabsInitialOffset.)
Public property | TabsShape | Gets or sets the tabs shape. (Inherited from vTabControl.)
Public property | TabsSpacing | Gets or sets the spacing between the tab pages. (Inherited from vTabControl.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text.
Public property | TextAlignment | Gets or sets the text alignment.
Public property | TextOrientation | (Overrides vTabControl..::..TextOrientation.)
Public property | Theme | (Overrides vTabControl..::..Theme.)
Public property | TitleHeight | Determines the height of the title area which holds the tab pages (Inherited from vTabControl.)
Public property | ToolTipDuration | Gets or sets the duration of the tool tip. (Inherited from vTabControl.)
Public property | ToolTipShowDelay | Gets or sets the tool tip show delay. (Inherited from vTabControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseTabsAreaBackColor | (Overrides vTabControl..::..UseTabsAreaBackColor.)
Public property | UseTabsAreaBorderColor | Gets or sets a value indicating whether to use the TabsAreaBorderColor (Inherited from vTabControl.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Overrides vTabControl..::..VIBlendTheme.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vRibbonBar Class


AllowMinimizedState Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..AllowMinimizedState Property
vRibbonBar Class See Also Send Feedback
Gets or sets a value indicating whether the control can be minimized.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowMinimizedState { get; set; }
Visual Basic
Public Property AllowMinimizedState As Boolean
    Get
    Set
Visual C++
public:
property bool AllowMinimizedState {
    bool get ();
    void set (bool value);
}

See Also

vRibbonBar Class


AllowParentFormDrag Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..AllowParentFormDrag Property
vRibbonBar Class See Also Send Feedback
Gets or sets a value indicating whether parent form could be moved and resized using ribbon's caption

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowParentFormDrag { get; set; }
Visual Basic
Public Property AllowParentFormDrag As Boolean
    Get
    Set
Visual C++
public:
property bool AllowParentFormDrag {
    bool get ();
    void set (bool value);
}

See Also

vRibbonBar Class


AllowRibbonRendering Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..AllowRibbonRendering Property
vRibbonBar Class See Also Send Feedback
Gets or sets whether the default rendering is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowRibbonRendering { get; set; }
Visual Basic
Public Property AllowRibbonRendering As Boolean
    Get
    Set
Visual C++
public:
property bool AllowRibbonRendering {
    bool get ();
    void set (bool value);
}

See Also

vRibbonBar Class


AllPagesHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..AllPagesHeight Property
vRibbonBar Class See Also Send Feedback
Gets or sets the height of all pages.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override int AllPagesHeight { get; set; }
Visual Basic
Public Overrides Property AllPagesHeight As Integer
    Get
    Set
Visual C++
public:
virtual property int AllPagesHeight {
    int get () override;
    void set (int value) override;
}

Field Value

The height of all pages.

See Also

vRibbonBar Class


ApplicationButton Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..ApplicationButton Property
vRibbonBar Class See Also Send Feedback
Gets or sets the application button.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonApplicationButton ApplicationButton { get; set; }
Visual Basic
Public Property ApplicationButton As vRibbonApplicationButton
    Get
    Set
Visual C++
public:
property vRibbonApplicationButton^ ApplicationButton {
    vRibbonApplicationButton^ get ();
    void set (vRibbonApplicationButton^ value);
}

Field Value

The application button.

See Also

vRibbonBar Class


DescriptionText Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..DescriptionText Property
vRibbonBar Class See Also Send Feedback
Gets or sets the description text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string DescriptionText { get; set; }
Visual Basic
Public Property DescriptionText As String
    Get
    Set
Visual C++
public:
property String^ DescriptionText {
    String^ get ();
    void set (String^ value);
}

Field Value

The description text.

See Also

vRibbonBar Class


DescriptionTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..DescriptionTextColor Property
vRibbonBar Class See Also Send Feedback
Gets or sets the color of the description text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DescriptionTextColor { get; set; }
Visual Basic
Public Property DescriptionTextColor As Color
    Get
    Set
Visual C++
public:
property Color DescriptionTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the description text.

See Also

vRibbonBar Class


DescriptionTextFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..DescriptionTextFont Property
vRibbonBar Class See Also Send Feedback
Gets or sets the description text font.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font DescriptionTextFont { get; set; }
Visual Basic
Public Property DescriptionTextFont As Font
    Get
    Set
Visual C++
public:
property Font^ DescriptionTextFont {
    Font^ get ();
    void set (Font^ value);
}

Field Value

The description text font.

See Also

vRibbonBar Class


DrawQuickAccessToolbarBackground Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..DrawQuickAccessToolbarBackground Property
vRibbonBar Class See Also Send Feedback
Gets or sets a value indicating whether should draw qat background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool DrawQuickAccessToolbarBackground { get; set; }
Visual Basic
Public Property DrawQuickAccessToolbarBackground As Boolean
    Get
    Set
Visual C++
public:
property bool DrawQuickAccessToolbarBackground {
    bool get ();
    void set (bool value);
}

See Also

vRibbonBar Class


DrawTitleFill Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..DrawTitleFill Property
vRibbonBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool DrawTitleFill { get; set; }
Visual Basic
Public Property DrawTitleFill As Boolean
    Get
    Set
Visual C++
public:
property bool DrawTitleFill {
    bool get ();
    void set (bool value);
}

See Also

vRibbonBar Class


EnableDropDownStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..EnableDropDownStyle Property
vRibbonBar Class See Also Send Feedback
Gets or sets a value indicating whether drop down style is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override bool EnableDropDownStyle { get; set; }
Visual Basic
Public Overrides Property EnableDropDownStyle As Boolean
    Get
    Set
Visual C++
public:
virtual property bool EnableDropDownStyle {
    bool get () override;
    void set (bool value) override;
}

Field Value

See Also

vRibbonBar Class


FitTabsToBounds Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..FitTabsToBounds Property
vRibbonBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override bool FitTabsToBounds { get; set; }
Visual Basic
Public Overrides Property FitTabsToBounds As Boolean
    Get
    Set
Visual C++
public:
virtual property bool FitTabsToBounds {
    bool get () override;
    void set (bool value) override;
}

See Also

vRibbonBar Class


Font Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..Font Property
vRibbonBar Class See Also Send Feedback
Gets or sets the font of the text displayed by the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font Font { get; set; }
Visual Basic
Public Property Font As Font
    Get
    Set
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

Field Value

Return Value

The Font to apply to the text displayed by the control. The default is the value of the DefaultFont property.

See Also

vRibbonBar Class


QuickAccessToolbar Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..QuickAccessToolbar Property
vRibbonBar Class See Also Send Feedback
Gets or sets the QuickAccessToolbar associated to the RibbonBar control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public QuickAccessToolbar QuickAccessToolbar { get; set; }
Visual Basic
Public Property QuickAccessToolbar As QuickAccessToolbar
    Get
    Set
Visual C++
public:
property QuickAccessToolbar^ QuickAccessToolbar {
    QuickAccessToolbar^ get ();
    void set (QuickAccessToolbar^ value);
}

Field Value

The QuickAccessToolbar.

See Also

vRibbonBar Class


RibbonStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..RibbonStyle Property
vRibbonBar Class See Also Send Feedback
Gets or sets the ribbon style.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RibbonStyle RibbonStyle { get; set; }
Visual Basic
Public Property RibbonStyle As RibbonStyle
    Get
    Set
Visual C++
public:
property RibbonStyle RibbonStyle {
    RibbonStyle get ();
    void set (RibbonStyle value);
}

Field Value

The ribbon style.

See Also

vRibbonBar Class


TabAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..TabAlignment Property
vRibbonBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override vTabPageAlignment TabAlignment { get; set; }
Visual Basic
Public Overrides Property TabAlignment As vTabPageAlignment
    Get
    Set
Visual C++
public:
virtual property vTabPageAlignment TabAlignment {
    vTabPageAlignment get () override;
    void set (vTabPageAlignment value) override;
}

See Also

vRibbonBar Class


TabContexts Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..TabContexts Property
vRibbonBar Class See Also Send Feedback
Gets or sets the tab contexts.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override List<TabContext> TabContexts { get; set; }
Visual Basic
Public Overrides Property TabContexts As List(Of TabContext)
    Get
    Set
Visual C++
public:
virtual property List<TabContext^>^ TabContexts {
    List<TabContext^>^ get () override;
    void set (List<TabContext^>^ value) override;
}

Field Value

The tab context.

See Also

vRibbonBar Class


TabsAreaBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..TabsAreaBackColor Property
vRibbonBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Color TabsAreaBackColor { get; set; }
Visual Basic
Public Overrides Property TabsAreaBackColor As Color
    Get
    Set
Visual C++
public:
virtual property Color TabsAreaBackColor {
    Color get () override;
    void set (Color value) override;
}

See Also

vRibbonBar Class


TabsInitialOffset Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..TabsInitialOffset Property
vRibbonBar Class See Also Send Feedback
Gets or sets the initial offset for the tab pages.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override int TabsInitialOffset { get; set; }
Visual Basic
Public Overrides Property TabsInitialOffset As Integer
    Get
    Set
Visual C++
public:
virtual property int TabsInitialOffset {
    int get () override;
    void set (int value) override;
}

Field Value

See Also

vRibbonBar Class


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..Text Property
vRibbonBar Class See Also Send Feedback
Gets or sets the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Field Value

The text.

See Also

vRibbonBar Class


TextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..TextAlignment Property
vRibbonBar Class See Also Send Feedback
Gets or sets the text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment TextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The text alignment.

See Also

vRibbonBar Class


TextOrientation Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..TextOrientation Property
vRibbonBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override vTabPageTextOrientation TextOrientation { get; set; }
Visual Basic
Public Overrides Property TextOrientation As vTabPageTextOrientation
    Get
    Set
Visual C++
public:
virtual property vTabPageTextOrientation TextOrientation {
    vTabPageTextOrientation get () override;
    void set (vTabPageTextOrientation value) override;
}

See Also

vRibbonBar Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..Theme Property
vRibbonBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override ControlTheme Theme { get; set; }
Visual Basic
Public Overrides Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
virtual property ControlTheme^ Theme {
    ControlTheme^ get () override;
    void set (ControlTheme^ value) override;
}

See Also

vRibbonBar Class


UseTabsAreaBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..UseTabsAreaBackColor Property
vRibbonBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override bool UseTabsAreaBackColor { get; set; }
Visual Basic
Public Overrides Property UseTabsAreaBackColor As Boolean
    Get
    Set
Visual C++
public:
virtual property bool UseTabsAreaBackColor {
    bool get () override;
    void set (bool value) override;
}

See Also

vRibbonBar Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar..::..VIBlendTheme Property
vRibbonBar Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Overrides Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
virtual property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get () override;
    void set (VIBLEND_THEME value) override;
}

Field Value

See Also

vRibbonBar Class


vRibbonBar Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBar Events
vRibbonBar Class See Also Send Feedback

The vRibbonBar type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawTabPage | Occurs when a TabPage is rendered. (Inherited from vTabControl.)
Public event | DrawTabPageBackground | Occurs when a TabPage is rendered. (Inherited from vTabControl.)
Public event | DrawTitleBackground | Occurs when the Title is rendered. (Inherited from vTabControl.)
Public event | DropDownStyleChanged | Occurs when the EnableDropDownStyle property is changed. (Inherited from vTabControl.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HoveredTabChanged | Occurs when the HoveredTab has changed. (Inherited from vTabControl.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PopupPaint | Occurs when popup panel is painted. (Inherited from vTabControl.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property has changed. (Inherited from vTabControl.)
Public event | SelectedIndexChanging | Occurs when the selected index is about to change (Inherited from vTabControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabMouseDown | Occurs when the mouse button is clicked over a tab. (Inherited from vTabControl.)
Public event | TabMouseUp | Occurs when the mouse button is clicked over a tab. (Inherited from vTabControl.)
Public event | TabPageDragEnded | Occurs when a tab page drag has ended (Inherited from vTabControl.)
Public event | TabPageDragEnding | Occurs when a tab page drag is about to end (Inherited from vTabControl.)
Public event | TabPageDragStarted | Occurs when a tab page drag has started (Inherited from vTabControl.)
Public event | TabPageDragStarting | Occurs when a tab page drag is about to start (Inherited from vTabControl.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | TitleClick | Occurs when the users clicks in the Title area (Inherited from vTabControl.)
Public event | TooltipShow | Occurs when tooltip shows. (Inherited from vTabControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRibbonBar Class


vRibbonBarGallery Class

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery Class
Members See Also Send Feedback
Represents a vRibbonBarGallery control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vRibbonBarGallery : ScrollableControlMiniBase
Visual Basic
Public Class vRibbonBarGallery _
    Inherits ScrollableControlMiniBase
Visual C++
public ref class vRibbonBarGallery : public ScrollableControlMiniBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
ScrollableControlMiniBase
VIBlend.WinForms.Controls..::..vRibbonBarGallery

See Also

vRibbonBarGallery Members


vRibbonBarGallery Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery Members
vRibbonBarGallery Class Constructors Methods Properties Events See Also Send Feedback

The vRibbonBarGallery type exposes the following members.

Constructors

 | Name | Description
Public method | vRibbonBarGallery | Initializes a new instance of the vRibbonBarGallery class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HideDropDown | Hides the drop down.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | (Overrides Control..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content | Gets the content.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Overrides Control..::..DefaultSize.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DownScrollButton | Gets down scroll button.
Public property | DropDownButton | Gets the drop down button.
Public property | DropDownSize | Gets or sets the size of the pop up.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GalleryButtons | Gets the gallery buttons collection. Use this collection to add or remove buttons to the gallery.
Public property | Groups | Gets the groups.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MenuItems | Gets the menu items.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PopupBackColor | Gets or sets the color of the pop up.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UpScrollButton | Gets up scroll button.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme |
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRibbonBarGallery Class


vRibbonBarGallery Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery Constructor
vRibbonBarGallery Class See Also Send Feedback
Initializes a new instance of the vRibbonBarGallery class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonBarGallery()
Visual Basic
Public Sub New
Visual C++
public:
vRibbonBarGallery()

See Also

vRibbonBarGallery Class


vRibbonBarGallery Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery Methods
vRibbonBarGallery Class See Also Send Feedback

The vRibbonBarGallery type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HideDropDown | Hides the drop down.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | (Overrides Control..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vRibbonBarGallery Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..AccessibilityNotifyClients Method
vRibbonBarGallery Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vRibbonBarGallery Class
vRibbonBarGallery Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..BeginInvoke Method
vRibbonBarGallery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vRibbonBarGallery Class
vRibbonBarGallery Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..Dispose Method
vRibbonBarGallery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)

See Also

vRibbonBarGallery Class
vRibbonBarGallery Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..Dispose Method (Boolean)
vRibbonBarGallery Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vRibbonBarGallery Class
Dispose Overload


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..GetChildAtPoint Method
vRibbonBarGallery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vRibbonBarGallery Class
vRibbonBarGallery Members


HideDropDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..HideDropDown Method
vRibbonBarGallery Class See Also Send Feedback
Hides the drop down.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void HideDropDown()
Visual Basic
Public Sub HideDropDown
Visual C++
public:
void HideDropDown()

See Also

vRibbonBarGallery Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..Invalidate Method
vRibbonBarGallery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vRibbonBarGallery Class
vRibbonBarGallery Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..Invoke Method
vRibbonBarGallery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vRibbonBarGallery Class
vRibbonBarGallery Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..MemberwiseClone Method
vRibbonBarGallery Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vRibbonBarGallery Class
vRibbonBarGallery Members


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..OnLayout Method
vRibbonBarGallery Class See Also Send Feedback
Raises the Layout event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
A LayoutEventArgs that contains the event data.

See Also

vRibbonBarGallery Class


OnMouseEnter Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..OnMouseEnter Method
vRibbonBarGallery Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseEnter(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseEnter ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseEnter(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vRibbonBarGallery Class


OnMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..OnMouseLeave Method
vRibbonBarGallery Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vRibbonBarGallery Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..OnPaint Method
vRibbonBarGallery Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vRibbonBarGallery Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..PerformLayout Method
vRibbonBarGallery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vRibbonBarGallery Class
vRibbonBarGallery Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..ResumeLayout Method
vRibbonBarGallery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vRibbonBarGallery Class
vRibbonBarGallery Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..RtlTranslateAlignment Method
vRibbonBarGallery Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vRibbonBarGallery Class
vRibbonBarGallery Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..Scale Method
vRibbonBarGallery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vRibbonBarGallery Class
vRibbonBarGallery Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..Select Method
vRibbonBarGallery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vRibbonBarGallery Class
vRibbonBarGallery Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..SetBounds Method
vRibbonBarGallery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vRibbonBarGallery Class
vRibbonBarGallery Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..UpdateBounds Method
vRibbonBarGallery Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vRibbonBarGallery Class
vRibbonBarGallery Members


vRibbonBarGallery Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery Properties
vRibbonBarGallery Class See Also Send Feedback

The vRibbonBarGallery type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content | Gets the content.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Overrides Control..::..DefaultSize.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DownScrollButton | Gets down scroll button.
Public property | DropDownButton | Gets the drop down button.
Public property | DropDownSize | Gets or sets the size of the pop up.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GalleryButtons | Gets the gallery buttons collection. Use this collection to add or remove buttons to the gallery.
Public property | Groups | Gets the groups.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MenuItems | Gets the menu items.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PopupBackColor | Gets or sets the color of the pop up.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UpScrollButton | Gets up scroll button.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme |
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vRibbonBarGallery Class


Content Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..Content Property
vRibbonBarGallery Class See Also Send Feedback
Gets the content.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vFlowLayoutPanel Content { get; }
Visual Basic
Public ReadOnly Property Content As vFlowLayoutPanel
    Get
Visual C++
public:
property vFlowLayoutPanel^ Content {
    vFlowLayoutPanel^ get ();
}

Field Value

The content.

See Also

vRibbonBarGallery Class


DefaultSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..DefaultSize Property
vRibbonBarGallery Class See Also Send Feedback
Gets the default size of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override Size DefaultSize { get; }
Visual Basic
Protected Overrides ReadOnly Property DefaultSize As Size
    Get
Visual C++
protected:
virtual property Size DefaultSize {
    Size get () override;
}

Field Value

Return Value

The default Size of the control.

See Also

vRibbonBarGallery Class


DownScrollButton Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..DownScrollButton Property
vRibbonBarGallery Class See Also Send Feedback
Gets down scroll button.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vArrowButton DownScrollButton { get; }
Visual Basic
Public ReadOnly Property DownScrollButton As vArrowButton
    Get
Visual C++
public:
property vArrowButton^ DownScrollButton {
    vArrowButton^ get ();
}

Field Value

Down scroll button.

See Also

vRibbonBarGallery Class


DropDownButton Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..DropDownButton Property
vRibbonBarGallery Class See Also Send Feedback
Gets the drop down button.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonDropDownButton DropDownButton { get; }
Visual Basic
Public ReadOnly Property DropDownButton As vRibbonDropDownButton
    Get
Visual C++
public:
property vRibbonDropDownButton^ DropDownButton {
    vRibbonDropDownButton^ get ();
}

Field Value

The drop down button.

See Also

vRibbonBarGallery Class


DropDownSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..DropDownSize Property
vRibbonBarGallery Class See Also Send Feedback
Gets or sets the size of the pop up.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Size DropDownSize { get; set; }
Visual Basic
Public Property DropDownSize As Size
    Get
    Set
Visual C++
public:
property Size DropDownSize {
    Size get ();
    void set (Size value);
}

Field Value

The size of the pop up.

See Also

vRibbonBarGallery Class


GalleryButtons Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..GalleryButtons Property
vRibbonBarGallery Class See Also Send Feedback
Gets the gallery buttons collection. Use this collection to add or remove buttons to the gallery.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GalleryButtonCollection GalleryButtons { get; }
Visual Basic
Public ReadOnly Property GalleryButtons As GalleryButtonCollection
    Get
Visual C++
public:
property GalleryButtonCollection^ GalleryButtons {
    GalleryButtonCollection^ get ();
}

Field Value

The gallery buttons.

See Also

vRibbonBarGallery Class


Groups Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..Groups Property
vRibbonBarGallery Class See Also Send Feedback
Gets the groups.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<RibbonBarGalleryGroup> Groups { get; }
Visual Basic
Public ReadOnly Property Groups As List(Of RibbonBarGalleryGroup)
    Get
Visual C++
public:
property List<RibbonBarGalleryGroup^>^ Groups {
    List<RibbonBarGalleryGroup^>^ get ();
}

Field Value

The groups.

See Also

vRibbonBarGallery Class


MenuItems Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..MenuItems Property
vRibbonBarGallery Class See Also Send Feedback
Gets the menu items.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<vApplicationMenuItem> MenuItems { get; }
Visual Basic
Public ReadOnly Property MenuItems As List(Of vApplicationMenuItem)
    Get
Visual C++
public:
property List<vApplicationMenuItem^>^ MenuItems {
    List<vApplicationMenuItem^>^ get ();
}

Field Value

The menu items.

See Also

vRibbonBarGallery Class


PopupBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..PopupBackColor Property
vRibbonBarGallery Class See Also Send Feedback
Gets or sets the color of the pop up.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color PopupBackColor { get; set; }
Visual Basic
Public Property PopupBackColor As Color
    Get
    Set
Visual C++
public:
property Color PopupBackColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the pop up.

See Also

vRibbonBarGallery Class


StyleKey Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..StyleKey Property
vRibbonBarGallery Class See Also Send Feedback
Gets or sets the style key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual string StyleKey { get; set; }
Visual Basic
Protected Overridable Property StyleKey As String
    Get
    Set
Visual C++
protected:
virtual property String^ StyleKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The style key.

See Also

vRibbonBarGallery Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..Theme Property
vRibbonBarGallery Class See Also Send Feedback
Gets or sets the theme.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

Field Value

The theme.

See Also

vRibbonBarGallery Class


UpScrollButton Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..UpScrollButton Property
vRibbonBarGallery Class See Also Send Feedback
Gets up scroll button.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vArrowButton UpScrollButton { get; }
Visual Basic
Public ReadOnly Property UpScrollButton As vArrowButton
    Get
Visual C++
public:
property vArrowButton^ UpScrollButton {
    vArrowButton^ get ();
}

Field Value

Up scroll button.

See Also

vRibbonBarGallery Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery..::..VIBlendTheme Property
vRibbonBarGallery Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vRibbonBarGallery Class


vRibbonBarGallery Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonBarGallery Events
vRibbonBarGallery Class See Also Send Feedback

The vRibbonBarGallery type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRibbonBarGallery Class


vRibbonButton Class

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton Class
Members See Also Send Feedback
Represents a vRibbonButton control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vRibbonButton : vButton
Visual Basic
Public Class vRibbonButton _
    Inherits vButton
Visual C++
public ref class vRibbonButton : public vButton

Remarks

A ribbon button control raises an event when the user clicks it, and provides customizable visual appearance, and themes.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ButtonBase
System.Windows.Forms..::..Button
VIBlend.WinForms.Controls..::..vButton
VIBlend.WinForms.Controls..::..vRibbonButton
VIBlend.WinForms.Controls..::..GalleryButton

See Also

vRibbonButton Members


vRibbonButton Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton Members
vRibbonButton Class Constructors Methods Fields Properties Events See Also Send Feedback

The vRibbonButton type exposes the following members.

Constructors

 | Name | Description
Public method | vRibbonButton | Initializes a new instance of the vRibbonButton class

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder | (Overrides vButton..::..DrawBorder(Graphics, ControlState, Rectangle).)
Protected method | DrawControl | (Overrides vButton..::..DrawControl(Graphics, Rectangle, ControlState, Boolean, Byte).)
Protected method | DrawFocusRectangle | (Inherited from vButton.)
Protected method | DrawImageAndText | (Inherited from vButton.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect | (Inherited from vButton.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from vButton.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from vButton.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vButton.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Inherited from vButton.)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vButton.)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Inherited from vButton.)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vButton.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vButton.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

Fields

 | Name | Description
Protected field | buttonBorderStyle | (Inherited from vButton.)
Protected field | opacity | (Inherited from vButton.)
Protected field | paintHelper | (Inherited from vButton.)
Protected field | theme | (Inherited from vButton.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vButton.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button (Inherited from vButton.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Inherited from vButton.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled. (Inherited from vButton.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control. (Inherited from vButton.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity. (Inherited from vButton.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vButton.)
Public property | PaintDefaultBorder | Gets or sets a value indicating whether to paint a border when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultFill | Gets or sets a value indicating whether to paint a background when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultStateBorder | Gets or sets a value indicating whether to paint a border
Public property | PaintDefaultStateFill | Gets or sets a value indicating whether to paint a background
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vButton.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded (Inherited from vButton.)
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control. (Inherited from vButton.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused (Inherited from vButton.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image (Inherited from vButton.)
Public property | StyleKey | Gets or sets the style key. (Inherited from vButton.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control. (Inherited from vButton.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable (Inherited from vButton.)
Public property | Theme | Gets or sets the theme of the control (Inherited from vButton.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control. (Inherited from vButton.)
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control. (Inherited from vButton.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color. (Inherited from vButton.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vButton.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRibbonButton Class


vRibbonButton Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton Constructor
vRibbonButton Class See Also Send Feedback
Initializes a new instance of the vRibbonButton class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonButton()
Visual Basic
Public Sub New
Visual C++
public:
vRibbonButton()

See Also

vRibbonButton Class


vRibbonButton Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton Fields
vRibbonButton Class See Also Send Feedback

The vRibbonButton type exposes the following members.

Fields

 | Name | Description
Protected field | buttonBorderStyle | (Inherited from vButton.)
Protected field | opacity | (Inherited from vButton.)
Protected field | paintHelper | (Inherited from vButton.)
Protected field | theme | (Inherited from vButton.)

See Also

vRibbonButton Class


vRibbonButton Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton Methods
vRibbonButton Class See Also Send Feedback

The vRibbonButton type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder | (Overrides vButton..::..DrawBorder(Graphics, ControlState, Rectangle).)
Protected method | DrawControl | (Overrides vButton..::..DrawControl(Graphics, Rectangle, ControlState, Boolean, Byte).)
Protected method | DrawFocusRectangle | (Inherited from vButton.)
Protected method | DrawImageAndText | (Inherited from vButton.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect | (Inherited from vButton.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from vButton.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from vButton.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vButton.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Inherited from vButton.)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vButton.)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Inherited from vButton.)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vButton.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vButton.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

See Also

vRibbonButton Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton..::..AccessibilityNotifyClients Method
vRibbonButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vRibbonButton Class
vRibbonButton Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton..::..BeginInvoke Method
vRibbonButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vRibbonButton Class
vRibbonButton Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton..::..Dispose Method
vRibbonButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)

See Also

vRibbonButton Class
vRibbonButton Members


DrawBorder Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton..::..DrawBorder Method
vRibbonButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override Rectangle DrawBorder(
    Graphics graphics,
    ControlState controlState,
    Rectangle drawRect
)
Visual Basic
Protected Overrides Function DrawBorder ( _
    graphics As Graphics, _
    controlState As ControlState, _
    drawRect As Rectangle _
) As Rectangle
Visual C++
protected:
virtual Rectangle DrawBorder(
    Graphics^ graphics,
    ControlState controlState,
    Rectangle drawRect
) override

Parameters

graphics
Type: System.Drawing..::..Graphics
controlState
Type: ControlState
drawRect
Type: System.Drawing..::..Rectangle

See Also

vRibbonButton Class


DrawControl Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton..::..DrawControl Method
vRibbonButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void DrawControl(
    Graphics graphics,
    Rectangle bounds,
    ControlState controlState,
    bool isFocused,
    byte roundedCornersMask
)
Visual Basic
Protected Overrides Sub DrawControl ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    controlState As ControlState, _
    isFocused As Boolean, _
    roundedCornersMask As Byte _
)
Visual C++
protected:
virtual void DrawControl(
    Graphics^ graphics,
    Rectangle bounds,
    ControlState controlState,
    bool isFocused,
    unsigned char roundedCornersMask
) override

Parameters

graphics
Type: System.Drawing..::..Graphics
bounds
Type: System.Drawing..::..Rectangle
controlState
Type: ControlState
isFocused
Type: System..::..Boolean
roundedCornersMask
Type: System..::..Byte

See Also

vRibbonButton Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton..::..GetChildAtPoint Method
vRibbonButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vRibbonButton Class
vRibbonButton Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton..::..Invalidate Method
vRibbonButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vRibbonButton Class
vRibbonButton Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton..::..Invoke Method
vRibbonButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vRibbonButton Class
vRibbonButton Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton..::..MemberwiseClone Method
vRibbonButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vRibbonButton Class
vRibbonButton Members


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton..::..PerformLayout Method
vRibbonButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vRibbonButton Class
vRibbonButton Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton..::..ResumeLayout Method
vRibbonButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vRibbonButton Class
vRibbonButton Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton..::..RtlTranslateAlignment Method
vRibbonButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vRibbonButton Class
vRibbonButton Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton..::..Scale Method
vRibbonButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vRibbonButton Class
vRibbonButton Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton..::..Select Method
vRibbonButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vRibbonButton Class
vRibbonButton Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton..::..SetBounds Method
vRibbonButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vRibbonButton Class
vRibbonButton Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton..::..UpdateBounds Method
vRibbonButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vRibbonButton Class
vRibbonButton Members


vRibbonButton Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton Properties
vRibbonButton Class See Also Send Feedback

The vRibbonButton type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vButton.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button (Inherited from vButton.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Inherited from vButton.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled. (Inherited from vButton.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control. (Inherited from vButton.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity. (Inherited from vButton.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vButton.)
Public property | PaintDefaultBorder | Gets or sets a value indicating whether to paint a border when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultFill | Gets or sets a value indicating whether to paint a background when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultStateBorder | Gets or sets a value indicating whether to paint a border
Public property | PaintDefaultStateFill | Gets or sets a value indicating whether to paint a background
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vButton.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded (Inherited from vButton.)
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control. (Inherited from vButton.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused (Inherited from vButton.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image (Inherited from vButton.)
Public property | StyleKey | Gets or sets the style key. (Inherited from vButton.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control. (Inherited from vButton.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable (Inherited from vButton.)
Public property | Theme | Gets or sets the theme of the control (Inherited from vButton.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control. (Inherited from vButton.)
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control. (Inherited from vButton.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color. (Inherited from vButton.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vButton.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vRibbonButton Class


PaintDefaultStateBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton..::..PaintDefaultStateBorder Property
vRibbonButton Class See Also Send Feedback
Gets or sets a value indicating whether to paint a border

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintDefaultStateBorder { get; set; }
Visual Basic
Public Property PaintDefaultStateBorder As Boolean
    Get
    Set
Visual C++
public:
property bool PaintDefaultStateBorder {
    bool get ();
    void set (bool value);
}

Field Value

true if [paint border]; otherwise, false.

See Also

vRibbonButton Class


PaintDefaultStateFill Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton..::..PaintDefaultStateFill Property
vRibbonButton Class See Also Send Feedback
Gets or sets a value indicating whether to paint a background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintDefaultStateFill { get; set; }
Visual Basic
Public Property PaintDefaultStateFill As Boolean
    Get
    Set
Visual C++
public:
property bool PaintDefaultStateFill {
    bool get ();
    void set (bool value);
}

Field Value

true if [paint fill]; otherwise, false.

See Also

vRibbonButton Class


vRibbonButton Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonButton Events
vRibbonButton Class See Also Send Feedback

The vRibbonButton type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRibbonButton Class


vRibbonFooterButton Class

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vRibbonFooterButton : vButton
Visual Basic
Public Class vRibbonFooterButton _
    Inherits vButton
Visual C++
public ref class vRibbonFooterButton : public vButton

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ButtonBase
System.Windows.Forms..::..Button
VIBlend.WinForms.Controls..::..vButton
VIBlend.WinForms.Controls..::..vRibbonFooterButton

See Also

vRibbonFooterButton Members


vRibbonFooterButton Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton Members
vRibbonFooterButton Class Constructors Methods Fields Properties Events See Also Send Feedback

The vRibbonFooterButton type exposes the following members.

Constructors

 | Name | Description
Public method | vRibbonFooterButton | Initializes a new instance of the vRibbonFooterButton class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder | (Inherited from vButton.)
Protected method | DrawControl | (Overrides vButton..::..DrawControl(Graphics, Rectangle, ControlState, Boolean, Byte).)
Protected method | DrawFocusRectangle | (Inherited from vButton.)
Protected method | DrawImageAndText | (Inherited from vButton.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect | (Inherited from vButton.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from vButton.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from vButton.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vButton.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Inherited from vButton.)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vButton.)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Inherited from vButton.)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vButton.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vButton.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

Fields

 | Name | Description
Protected field | buttonBorderStyle | (Inherited from vButton.)
Protected field | opacity | (Inherited from vButton.)
Protected field | paintHelper | (Inherited from vButton.)
Protected field | theme | (Inherited from vButton.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vButton.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button (Inherited from vButton.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Inherited from vButton.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled. (Inherited from vButton.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control. (Inherited from vButton.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity. (Inherited from vButton.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vButton.)
Public property | PaintDefaultBorder | Gets or sets a value indicating whether to paint a border when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultFill | Gets or sets a value indicating whether to paint a background when the control state is default. (Inherited from vButton.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vButton.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded (Inherited from vButton.)
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control. (Inherited from vButton.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused (Inherited from vButton.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image (Inherited from vButton.)
Public property | StyleKey | Gets or sets the style key. (Inherited from vButton.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control. (Inherited from vButton.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable (Inherited from vButton.)
Public property | Theme | Gets or sets the theme of the control (Inherited from vButton.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control. (Inherited from vButton.)
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control. (Inherited from vButton.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color. (Inherited from vButton.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vButton.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRibbonFooterButton Class


vRibbonFooterButton Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton Constructor
vRibbonFooterButton Class See Also Send Feedback
Initializes a new instance of the vRibbonFooterButton class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonFooterButton()
Visual Basic
Public Sub New
Visual C++
public:
vRibbonFooterButton()

See Also

vRibbonFooterButton Class


vRibbonFooterButton Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton Fields
vRibbonFooterButton Class See Also Send Feedback

The vRibbonFooterButton type exposes the following members.

Fields

 | Name | Description
Protected field | buttonBorderStyle | (Inherited from vButton.)
Protected field | opacity | (Inherited from vButton.)
Protected field | paintHelper | (Inherited from vButton.)
Protected field | theme | (Inherited from vButton.)

See Also

vRibbonFooterButton Class


vRibbonFooterButton Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton Methods
vRibbonFooterButton Class See Also Send Feedback

The vRibbonFooterButton type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder | (Inherited from vButton.)
Protected method | DrawControl | (Overrides vButton..::..DrawControl(Graphics, Rectangle, ControlState, Boolean, Byte).)
Protected method | DrawFocusRectangle | (Inherited from vButton.)
Protected method | DrawImageAndText | (Inherited from vButton.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect | (Inherited from vButton.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from vButton.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from vButton.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vButton.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Inherited from vButton.)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vButton.)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Inherited from vButton.)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vButton.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vButton.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

See Also

vRibbonFooterButton Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton..::..AccessibilityNotifyClients Method
vRibbonFooterButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vRibbonFooterButton Class
vRibbonFooterButton Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton..::..BeginInvoke Method
vRibbonFooterButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vRibbonFooterButton Class
vRibbonFooterButton Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton..::..Dispose Method
vRibbonFooterButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)

See Also

vRibbonFooterButton Class
vRibbonFooterButton Members


DrawControl Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton..::..DrawControl Method
vRibbonFooterButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void DrawControl(
    Graphics graphics,
    Rectangle bounds,
    ControlState controlState,
    bool isFocused,
    byte roundedCornersMask
)
Visual Basic
Protected Overrides Sub DrawControl ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    controlState As ControlState, _
    isFocused As Boolean, _
    roundedCornersMask As Byte _
)
Visual C++
protected:
virtual void DrawControl(
    Graphics^ graphics,
    Rectangle bounds,
    ControlState controlState,
    bool isFocused,
    unsigned char roundedCornersMask
) override

Parameters

graphics
Type: System.Drawing..::..Graphics
bounds
Type: System.Drawing..::..Rectangle
controlState
Type: ControlState
isFocused
Type: System..::..Boolean
roundedCornersMask
Type: System..::..Byte

See Also

vRibbonFooterButton Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton..::..GetChildAtPoint Method
vRibbonFooterButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vRibbonFooterButton Class
vRibbonFooterButton Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton..::..Invalidate Method
vRibbonFooterButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vRibbonFooterButton Class
vRibbonFooterButton Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton..::..Invoke Method
vRibbonFooterButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vRibbonFooterButton Class
vRibbonFooterButton Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton..::..MemberwiseClone Method
vRibbonFooterButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vRibbonFooterButton Class
vRibbonFooterButton Members


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton..::..PerformLayout Method
vRibbonFooterButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vRibbonFooterButton Class
vRibbonFooterButton Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton..::..ResumeLayout Method
vRibbonFooterButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vRibbonFooterButton Class
vRibbonFooterButton Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton..::..RtlTranslateAlignment Method
vRibbonFooterButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vRibbonFooterButton Class
vRibbonFooterButton Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton..::..Scale Method
vRibbonFooterButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vRibbonFooterButton Class
vRibbonFooterButton Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton..::..Select Method
vRibbonFooterButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vRibbonFooterButton Class
vRibbonFooterButton Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton..::..SetBounds Method
vRibbonFooterButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vRibbonFooterButton Class
vRibbonFooterButton Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton..::..UpdateBounds Method
vRibbonFooterButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vRibbonFooterButton Class
vRibbonFooterButton Members


vRibbonFooterButton Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton Properties
vRibbonFooterButton Class See Also Send Feedback

The vRibbonFooterButton type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vButton.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button (Inherited from vButton.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Inherited from vButton.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled. (Inherited from vButton.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control. (Inherited from vButton.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity. (Inherited from vButton.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vButton.)
Public property | PaintDefaultBorder | Gets or sets a value indicating whether to paint a border when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultFill | Gets or sets a value indicating whether to paint a background when the control state is default. (Inherited from vButton.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vButton.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded (Inherited from vButton.)
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control. (Inherited from vButton.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused (Inherited from vButton.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image (Inherited from vButton.)
Public property | StyleKey | Gets or sets the style key. (Inherited from vButton.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control. (Inherited from vButton.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable (Inherited from vButton.)
Public property | Theme | Gets or sets the theme of the control (Inherited from vButton.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control. (Inherited from vButton.)
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control. (Inherited from vButton.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color. (Inherited from vButton.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vButton.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vRibbonFooterButton Class


vRibbonFooterButton Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonFooterButton Events
vRibbonFooterButton Class See Also Send Feedback

The vRibbonFooterButton type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRibbonFooterButton Class


vRibbonGroup Class

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup Class
Members See Also Send Feedback
Represents a vRibbonGroup control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vRibbonGroup : Control,
    IScrollableControlBase
Visual Basic
Public Class vRibbonGroup _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class vRibbonGroup : public Control,
    IScrollableControlBase

Remarks

A ribbon group control is used to group and host multiple other controls within a ribbon bar.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vRibbonGroup

See Also

vRibbonGroup Members


vRibbonGroup Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup Members
vRibbonGroup Class Constructors Methods Properties Events See Also Send Feedback

The vRibbonGroup type exposes the following members.

Constructors

 | Name | Description
Public method | vRibbonGroup | Initializes a new instance of the vRibbonGroup class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | (Overrides Control..::..OnMouseClick(MouseEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Overrides Control..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations |
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AnimationManager |
Public property | AutoCloseInterval | Gets or sets the auto close interval.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content | Gets the content.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets the drop down.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableFooterButton | Gets or sets a value indicating whether the footer button is enabled
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | FooterHeight | Gets or sets the height of the header area of the item
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GroupStyle | Gets or sets the group style.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | Image | Gets or sets the image of the Ribbon Group control
Public property | ImageIndex | Gets or sets the index of the image.
Public property | ImageList | Gets or sets the image list.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Radius | Gets or sets the radius.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFooterButton | Gets or sets a value indicating whether to show the footer button.
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control.
Public property | TextAlignment | Gets or sets the text alignment.
Public property | Theme |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use theme text color.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme |
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRibbonGroup Class


vRibbonGroup Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup Constructor
vRibbonGroup Class See Also Send Feedback
Initializes a new instance of the vRibbonGroup class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonGroup()
Visual Basic
Public Sub New
Visual C++
public:
vRibbonGroup()

See Also

vRibbonGroup Class


vRibbonGroup Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup Methods
vRibbonGroup Class See Also Send Feedback

The vRibbonGroup type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | (Overrides Control..::..OnMouseClick(MouseEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Overrides Control..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vRibbonGroup Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..AccessibilityNotifyClients Method
vRibbonGroup Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vRibbonGroup Class
vRibbonGroup Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..BeginInvoke Method
vRibbonGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vRibbonGroup Class
vRibbonGroup Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..Dispose Method
vRibbonGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)

See Also

vRibbonGroup Class
vRibbonGroup Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..Dispose Method (Boolean)
vRibbonGroup Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vRibbonGroup Class
Dispose Overload


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..GetChildAtPoint Method
vRibbonGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vRibbonGroup Class
vRibbonGroup Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..Invalidate Method
vRibbonGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vRibbonGroup Class
vRibbonGroup Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..Invoke Method
vRibbonGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vRibbonGroup Class
vRibbonGroup Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..MemberwiseClone Method
vRibbonGroup Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vRibbonGroup Class
vRibbonGroup Members


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..OnLayout Method
vRibbonGroup Class See Also Send Feedback
Raises the Layout event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
A LayoutEventArgs that contains the event data.

See Also

vRibbonGroup Class


OnMouseClick Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..OnMouseClick Method
vRibbonGroup Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseClick(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseClick ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseClick(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vRibbonGroup Class


OnMouseEnter Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..OnMouseEnter Method
vRibbonGroup Class See Also Send Feedback
Raises the MouseEnter event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseEnter(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseEnter ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseEnter(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vRibbonGroup Class


OnMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..OnMouseLeave Method
vRibbonGroup Class See Also Send Feedback
Raises the MouseLeave event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vRibbonGroup Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..OnPaint Method
vRibbonGroup Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vRibbonGroup Class


OnSizeChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..OnSizeChanged Method
vRibbonGroup Class See Also Send Feedback
Raises the SizeChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnSizeChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnSizeChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSizeChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vRibbonGroup Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..PerformLayout Method
vRibbonGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vRibbonGroup Class
vRibbonGroup Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..ResumeLayout Method
vRibbonGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vRibbonGroup Class
vRibbonGroup Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..RtlTranslateAlignment Method
vRibbonGroup Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vRibbonGroup Class
vRibbonGroup Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..Scale Method
vRibbonGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vRibbonGroup Class
vRibbonGroup Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..Select Method
vRibbonGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vRibbonGroup Class
vRibbonGroup Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..SetBounds Method
vRibbonGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vRibbonGroup Class
vRibbonGroup Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..UpdateBounds Method
vRibbonGroup Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vRibbonGroup Class
vRibbonGroup Members


vRibbonGroup Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup Properties
vRibbonGroup Class See Also Send Feedback

The vRibbonGroup type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations |
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AnimationManager |
Public property | AutoCloseInterval | Gets or sets the auto close interval.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content | Gets the content.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets the drop down.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableFooterButton | Gets or sets a value indicating whether the footer button is enabled
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | FooterHeight | Gets or sets the height of the header area of the item
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GroupStyle | Gets or sets the group style.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | Image | Gets or sets the image of the Ribbon Group control
Public property | ImageIndex | Gets or sets the index of the image.
Public property | ImageList | Gets or sets the image list.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Radius | Gets or sets the radius.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFooterButton | Gets or sets a value indicating whether to show the footer button.
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control.
Public property | TextAlignment | Gets or sets the text alignment.
Public property | Theme |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use theme text color.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme |
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vRibbonGroup Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..AllowAnimations Property
vRibbonGroup Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vRibbonGroup Class


AnimationManager Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..AnimationManager Property
vRibbonGroup Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public AnimationManager AnimationManager { get; set; }
Visual Basic
Public Property AnimationManager As AnimationManager
    Get
    Set
Visual C++
public:
virtual property AnimationManager^ AnimationManager {
    AnimationManager^ get () sealed;
    void set (AnimationManager^ value) sealed;
}

See Also

vRibbonGroup Class


AutoCloseInterval Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..AutoCloseInterval Property
vRibbonGroup Class See Also Send Feedback
Gets or sets the auto close interval.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int AutoCloseInterval { get; set; }
Visual Basic
Public Property AutoCloseInterval As Integer
    Get
    Set
Visual C++
public:
property int AutoCloseInterval {
    int get ();
    void set (int value);
}

Field Value

The auto close interval.

See Also

vRibbonGroup Class


Content Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..Content Property
vRibbonGroup Class See Also Send Feedback
Gets the content.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonGroupContent Content { get; }
Visual Basic
Public ReadOnly Property Content As vRibbonGroupContent
    Get
Visual C++
public:
property vRibbonGroupContent^ Content {
    vRibbonGroupContent^ get ();
}

Field Value

The content.

See Also

vRibbonGroup Class


DropDown Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..DropDown Property
vRibbonGroup Class See Also Send Feedback
Gets the drop down.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ToolStripDropDown DropDown { get; }
Visual Basic
Public ReadOnly Property DropDown As ToolStripDropDown
    Get
Visual C++
public:
property ToolStripDropDown^ DropDown {
    ToolStripDropDown^ get ();
}

Field Value

The drop down.

See Also

vRibbonGroup Class


EnableFooterButton Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..EnableFooterButton Property
vRibbonGroup Class See Also Send Feedback
Gets or sets a value indicating whether the footer button is enabled

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableFooterButton { get; set; }
Visual Basic
Public Property EnableFooterButton As Boolean
    Get
    Set
Visual C++
public:
property bool EnableFooterButton {
    bool get ();
    void set (bool value);
}

See Also

vRibbonGroup Class


FooterHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..FooterHeight Property
vRibbonGroup Class See Also Send Feedback
Gets or sets the height of the header area of the item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int FooterHeight { get; set; }
Visual Basic
Public Property FooterHeight As Integer
    Get
    Set
Visual C++
public:
property int FooterHeight {
    int get ();
    void set (int value);
}

See Also

vRibbonGroup Class


GroupStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..GroupStyle Property
vRibbonGroup Class See Also Send Feedback
Gets or sets the group style.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RibbonStyle GroupStyle { get; set; }
Visual Basic
Public Property GroupStyle As RibbonStyle
    Get
    Set
Visual C++
public:
property RibbonStyle GroupStyle {
    RibbonStyle get ();
    void set (RibbonStyle value);
}

Field Value

The group style.

See Also

vRibbonGroup Class


Image Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..Image Property
vRibbonGroup Class See Also Send Feedback
Gets or sets the image of the Ribbon Group control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Image Image { get; set; }
Visual Basic
Public Property Image As Image
    Get
    Set
Visual C++
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}

See Also

vRibbonGroup Class


ImageIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..ImageIndex Property
vRibbonGroup Class See Also Send Feedback
Gets or sets the index of the image.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ImageIndex { get; set; }
Visual Basic
Public Property ImageIndex As Integer
    Get
    Set
Visual C++
public:
property int ImageIndex {
    int get ();
    void set (int value);
}

Field Value

The index of the image.

See Also

vRibbonGroup Class


ImageList Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..ImageList Property
vRibbonGroup Class See Also Send Feedback
Gets or sets the image list.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ImageList ImageList { get; set; }
Visual Basic
Public Property ImageList As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ ImageList {
    ImageList^ get ();
    void set (ImageList^ value);
}

Field Value

The image list.

See Also

vRibbonGroup Class


Radius Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..Radius Property
vRibbonGroup Class See Also Send Feedback
Gets or sets the radius.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Radius { get; set; }
Visual Basic
Public Property Radius As Integer
    Get
    Set
Visual C++
public:
property int Radius {
    int get ();
    void set (int value);
}

Field Value

The radius.

See Also

vRibbonGroup Class


ShowFooterButton Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..ShowFooterButton Property
vRibbonGroup Class See Also Send Feedback
Gets or sets a value indicating whether to show the footer button.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowFooterButton { get; set; }
Visual Basic
Public Property ShowFooterButton As Boolean
    Get
    Set
Visual C++
public:
property bool ShowFooterButton {
    bool get ();
    void set (bool value);
}

See Also

vRibbonGroup Class


StyleKey Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..StyleKey Property
vRibbonGroup Class See Also Send Feedback
Gets or sets the style key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual string StyleKey { get; set; }
Visual Basic
Protected Overridable Property StyleKey As String
    Get
    Set
Visual C++
protected:
virtual property String^ StyleKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The style key.

See Also

vRibbonGroup Class


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..Text Property
vRibbonGroup Class See Also Send Feedback
Gets or sets the text associated with this control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Field Value

Return Value

The text associated with this control.

See Also

vRibbonGroup Class


TextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..TextAlignment Property
vRibbonGroup Class See Also Send Feedback
Gets or sets the text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment TextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The text alignment.

See Also

vRibbonGroup Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..Theme Property
vRibbonGroup Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vRibbonGroup Class


UseThemeTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..UseThemeTextColor Property
vRibbonGroup Class See Also Send Feedback
Gets or sets a value indicating whether to use theme text color.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeTextColor { get; set; }
Visual Basic
Public Property UseThemeTextColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeTextColor {
    bool get ();
    void set (bool value);
}

See Also

vRibbonGroup Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup..::..VIBlendTheme Property
vRibbonGroup Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vRibbonGroup Class


vRibbonGroup Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroup Events
vRibbonGroup Class See Also Send Feedback

The vRibbonGroup type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRibbonGroup Class


vRibbonGroupContent Class

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vRibbonGroupContent : Control,
    IScrollableControlBase
Visual Basic
Public Class vRibbonGroupContent _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class vRibbonGroupContent : public Control,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vRibbonGroupContent

See Also

vRibbonGroupContent Members


vRibbonGroupContent Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent Members
vRibbonGroupContent Class Constructors Methods Properties Events See Also Send Feedback

The vRibbonGroupContent type exposes the following members.

Constructors

 | Name | Description
Public method | vRibbonGroupContent | Initializes a new instance of the vRibbonGroupContent class

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations |
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AnimationManager |
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentPanel | Gets a reference to the panel which hosts the controls within the navigation pane item
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableFooterButton | Gets or sets a value indicating whether the footer button is enabled
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | Footer | Gets a reference to the panel which hosts the controls within the navigation pane item
Public property | FooterHeight | Gets or sets the height of the header area of the item
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Radius | Gets or sets the radius.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RibbonGroup |
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFooterButton | Gets or sets a value indicating whether to show the footer button.
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control.
Public property | TextAlignment | Gets or sets the text alignment.
Public property | Theme |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme |
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRibbonGroupContent Class


vRibbonGroupContent Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent Constructor
vRibbonGroupContent Class See Also Send Feedback
Initializes a new instance of the vRibbonGroupContent class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonGroupContent(
    vRibbonGroup group
)
Visual Basic
Public Sub New ( _
    group As vRibbonGroup _
)
Visual C++
public:
vRibbonGroupContent(
    vRibbonGroup^ group
)

Parameters

group
Type: VIBlend.WinForms.Controls..::..vRibbonGroup

See Also

vRibbonGroupContent Class


vRibbonGroupContent Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent Methods
vRibbonGroupContent Class See Also Send Feedback

The vRibbonGroupContent type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vRibbonGroupContent Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..AccessibilityNotifyClients Method
vRibbonGroupContent Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vRibbonGroupContent Class
vRibbonGroupContent Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..BeginInvoke Method
vRibbonGroupContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vRibbonGroupContent Class
vRibbonGroupContent Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..Dispose Method
vRibbonGroupContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vRibbonGroupContent Class
vRibbonGroupContent Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..GetChildAtPoint Method
vRibbonGroupContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vRibbonGroupContent Class
vRibbonGroupContent Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..Invalidate Method
vRibbonGroupContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vRibbonGroupContent Class
vRibbonGroupContent Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..Invoke Method
vRibbonGroupContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vRibbonGroupContent Class
vRibbonGroupContent Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..MemberwiseClone Method
vRibbonGroupContent Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vRibbonGroupContent Class
vRibbonGroupContent Members


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..OnLayout Method
vRibbonGroupContent Class See Also Send Feedback
Raises the Layout event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
A LayoutEventArgs that contains the event data.

See Also

vRibbonGroupContent Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..OnPaint Method
vRibbonGroupContent Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vRibbonGroupContent Class


OnSizeChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..OnSizeChanged Method
vRibbonGroupContent Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnSizeChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnSizeChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSizeChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vRibbonGroupContent Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..PerformLayout Method
vRibbonGroupContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vRibbonGroupContent Class
vRibbonGroupContent Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..ResumeLayout Method
vRibbonGroupContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vRibbonGroupContent Class
vRibbonGroupContent Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..RtlTranslateAlignment Method
vRibbonGroupContent Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vRibbonGroupContent Class
vRibbonGroupContent Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..Scale Method
vRibbonGroupContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vRibbonGroupContent Class
vRibbonGroupContent Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..Select Method
vRibbonGroupContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vRibbonGroupContent Class
vRibbonGroupContent Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..SetBounds Method
vRibbonGroupContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vRibbonGroupContent Class
vRibbonGroupContent Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..UpdateBounds Method
vRibbonGroupContent Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vRibbonGroupContent Class
vRibbonGroupContent Members


vRibbonGroupContent Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent Properties
vRibbonGroupContent Class See Also Send Feedback

The vRibbonGroupContent type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations |
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AnimationManager |
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentPanel | Gets a reference to the panel which hosts the controls within the navigation pane item
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableFooterButton | Gets or sets a value indicating whether the footer button is enabled
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | Footer | Gets a reference to the panel which hosts the controls within the navigation pane item
Public property | FooterHeight | Gets or sets the height of the header area of the item
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Radius | Gets or sets the radius.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RibbonGroup |
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFooterButton | Gets or sets a value indicating whether to show the footer button.
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control.
Public property | TextAlignment | Gets or sets the text alignment.
Public property | Theme |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme |
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vRibbonGroupContent Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..AllowAnimations Property
vRibbonGroupContent Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vRibbonGroupContent Class


AnimationManager Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..AnimationManager Property
vRibbonGroupContent Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public AnimationManager AnimationManager { get; set; }
Visual Basic
Public Property AnimationManager As AnimationManager
    Get
    Set
Visual C++
public:
virtual property AnimationManager^ AnimationManager {
    AnimationManager^ get () sealed;
    void set (AnimationManager^ value) sealed;
}

See Also

vRibbonGroupContent Class


ContentPanel Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..ContentPanel Property
vRibbonGroupContent Class See Also Send Feedback
Gets a reference to the panel which hosts the controls within the navigation pane item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RibbonGroupPanel ContentPanel { get; internal set; }
Visual Basic
Public Property ContentPanel As RibbonGroupPanel
    Get
    Friend Set
Visual C++
public:
property RibbonGroupPanel^ ContentPanel {
    RibbonGroupPanel^ get ();
    internal: void set (RibbonGroupPanel^ value);
}

See Also

vRibbonGroupContent Class


EnableFooterButton Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..EnableFooterButton Property
vRibbonGroupContent Class See Also Send Feedback
Gets or sets a value indicating whether the footer button is enabled

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableFooterButton { get; set; }
Visual Basic
Public Property EnableFooterButton As Boolean
    Get
    Set
Visual C++
public:
property bool EnableFooterButton {
    bool get ();
    void set (bool value);
}

See Also

vRibbonGroupContent Class


Footer Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..Footer Property
vRibbonGroupContent Class See Also Send Feedback
Gets a reference to the panel which hosts the controls within the navigation pane item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonGroupFooter Footer { get; internal set; }
Visual Basic
Public Property Footer As vRibbonGroupFooter
    Get
    Friend Set
Visual C++
public:
property vRibbonGroupFooter^ Footer {
    vRibbonGroupFooter^ get ();
    internal: void set (vRibbonGroupFooter^ value);
}

See Also

vRibbonGroupContent Class


FooterHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..FooterHeight Property
vRibbonGroupContent Class See Also Send Feedback
Gets or sets the height of the header area of the item

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int FooterHeight { get; set; }
Visual Basic
Public Property FooterHeight As Integer
    Get
    Set
Visual C++
public:
property int FooterHeight {
    int get ();
    void set (int value);
}

See Also

vRibbonGroupContent Class


Radius Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..Radius Property
vRibbonGroupContent Class See Also Send Feedback
Gets or sets the radius.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Radius { get; set; }
Visual Basic
Public Property Radius As Integer
    Get
    Set
Visual C++
public:
property int Radius {
    int get ();
    void set (int value);
}

Field Value

The radius.

See Also

vRibbonGroupContent Class


RibbonGroup Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..RibbonGroup Property
vRibbonGroupContent Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonGroup RibbonGroup { get; }
Visual Basic
Public ReadOnly Property RibbonGroup As vRibbonGroup
    Get
Visual C++
public:
property vRibbonGroup^ RibbonGroup {
    vRibbonGroup^ get ();
}

See Also

vRibbonGroupContent Class


ShowFooterButton Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..ShowFooterButton Property
vRibbonGroupContent Class See Also Send Feedback
Gets or sets a value indicating whether to show the footer button.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowFooterButton { get; set; }
Visual Basic
Public Property ShowFooterButton As Boolean
    Get
    Set
Visual C++
public:
property bool ShowFooterButton {
    bool get ();
    void set (bool value);
}

See Also

vRibbonGroupContent Class


StyleKey Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..StyleKey Property
vRibbonGroupContent Class See Also Send Feedback
Gets or sets the style key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual string StyleKey { get; set; }
Visual Basic
Protected Overridable Property StyleKey As String
    Get
    Set
Visual C++
protected:
virtual property String^ StyleKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The style key.

See Also

vRibbonGroupContent Class


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..Text Property
vRibbonGroupContent Class See Also Send Feedback
Gets or sets the text associated with this control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Field Value

Return Value

The text associated with this control.

See Also

vRibbonGroupContent Class


TextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..TextAlignment Property
vRibbonGroupContent Class See Also Send Feedback
Gets or sets the text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment TextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The text alignment.

See Also

vRibbonGroupContent Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..Theme Property
vRibbonGroupContent Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vRibbonGroupContent Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent..::..VIBlendTheme Property
vRibbonGroupContent Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vRibbonGroupContent Class


vRibbonGroupContent Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupContent Events
vRibbonGroupContent Class See Also Send Feedback

The vRibbonGroupContent type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRibbonGroupContent Class


vRibbonGroupFooter Class

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vRibbonGroupFooter : Control,
    IScrollableControlBase
Visual Basic
Public Class vRibbonGroupFooter _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class vRibbonGroupFooter : public Control,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vRibbonGroupFooter

See Also

vRibbonGroupFooter Members


vRibbonGroupFooter Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter Members
vRibbonGroupFooter Class Constructors Methods Properties Events See Also Send Feedback

The vRibbonGroupFooter type exposes the following members.

Constructors

 | Name | Description
Public method | vRibbonGroupFooter | Initializes a new instance of the vRibbonGroupFooter class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the [E:MouseDown] event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the [E:MouseMove] event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the [E:MouseUp] event. (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations |
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AnimationManager |
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Overrides Control..::..Font.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | FooterButton | Gets the footer button.
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RibbonGroup | Gets the ribbon group.
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFooterButton | Gets or sets a value indicating whether to show the footer button.
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment.
Public property | Theme |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use theme text color.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme |
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRibbonGroupFooter Class


vRibbonGroupFooter Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter Constructor
vRibbonGroupFooter Class See Also Send Feedback
Initializes a new instance of the vRibbonGroupFooter class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonGroupFooter(
    vRibbonGroupContent item
)
Visual Basic
Public Sub New ( _
    item As vRibbonGroupContent _
)
Visual C++
public:
vRibbonGroupFooter(
    vRibbonGroupContent^ item
)

Parameters

item
Type: VIBlend.WinForms.Controls..::..vRibbonGroupContent
The item.

See Also

vRibbonGroupFooter Class


vRibbonGroupFooter Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter Methods
vRibbonGroupFooter Class See Also Send Feedback

The vRibbonGroupFooter type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the [E:MouseDown] event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the [E:MouseMove] event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the [E:MouseUp] event. (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vRibbonGroupFooter Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..AccessibilityNotifyClients Method
vRibbonGroupFooter Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vRibbonGroupFooter Class
vRibbonGroupFooter Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..BeginInvoke Method
vRibbonGroupFooter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vRibbonGroupFooter Class
vRibbonGroupFooter Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..Dispose Method
vRibbonGroupFooter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vRibbonGroupFooter Class
vRibbonGroupFooter Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..GetChildAtPoint Method
vRibbonGroupFooter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vRibbonGroupFooter Class
vRibbonGroupFooter Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..Invalidate Method
vRibbonGroupFooter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vRibbonGroupFooter Class
vRibbonGroupFooter Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..Invoke Method
vRibbonGroupFooter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vRibbonGroupFooter Class
vRibbonGroupFooter Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..MemberwiseClone Method
vRibbonGroupFooter Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vRibbonGroupFooter Class
vRibbonGroupFooter Members


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..OnLayout Method
vRibbonGroupFooter Class See Also Send Feedback
Raises the Layout event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
A LayoutEventArgs that contains the event data.

See Also

vRibbonGroupFooter Class


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..OnMouseDown Method
vRibbonGroupFooter Class See Also Send Feedback
Raises the [E:MouseDown] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs mevent
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    mevent As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ mevent
) override

Parameters

mevent
Type: System.Windows.Forms..::..MouseEventArgs
The MouseEventArgs instance containing the event data.

See Also

vRibbonGroupFooter Class


OnMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..OnMouseLeave Method
vRibbonGroupFooter Class See Also Send Feedback
Raises the MouseLeave event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vRibbonGroupFooter Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..OnMouseMove Method
vRibbonGroupFooter Class See Also Send Feedback
Raises the [E:MouseMove] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs mevent
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    mevent As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ mevent
) override

Parameters

mevent
Type: System.Windows.Forms..::..MouseEventArgs
The MouseEventArgs instance containing the event data.

See Also

vRibbonGroupFooter Class


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..OnMouseUp Method
vRibbonGroupFooter Class See Also Send Feedback
Raises the [E:MouseUp] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs mevent
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    mevent As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ mevent
) override

Parameters

mevent
Type: System.Windows.Forms..::..MouseEventArgs
The MouseEventArgs instance containing the event data.

See Also

vRibbonGroupFooter Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..OnPaint Method
vRibbonGroupFooter Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vRibbonGroupFooter Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..PerformLayout Method
vRibbonGroupFooter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vRibbonGroupFooter Class
vRibbonGroupFooter Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..ResumeLayout Method
vRibbonGroupFooter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vRibbonGroupFooter Class
vRibbonGroupFooter Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..RtlTranslateAlignment Method
vRibbonGroupFooter Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vRibbonGroupFooter Class
vRibbonGroupFooter Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..Scale Method
vRibbonGroupFooter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vRibbonGroupFooter Class
vRibbonGroupFooter Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..Select Method
vRibbonGroupFooter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vRibbonGroupFooter Class
vRibbonGroupFooter Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..SetBounds Method
vRibbonGroupFooter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vRibbonGroupFooter Class
vRibbonGroupFooter Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..UpdateBounds Method
vRibbonGroupFooter Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vRibbonGroupFooter Class
vRibbonGroupFooter Members


vRibbonGroupFooter Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter Properties
vRibbonGroupFooter Class See Also Send Feedback

The vRibbonGroupFooter type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations |
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AnimationManager |
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Overrides Control..::..Font.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | FooterButton | Gets the footer button.
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RibbonGroup | Gets the ribbon group.
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFooterButton | Gets or sets a value indicating whether to show the footer button.
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | TextAlignment | Gets or sets the text alignment.
Public property | Theme |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use theme text color.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme |
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vRibbonGroupFooter Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..AllowAnimations Property
vRibbonGroupFooter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vRibbonGroupFooter Class


AnimationManager Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..AnimationManager Property
vRibbonGroupFooter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public AnimationManager AnimationManager { get; set; }
Visual Basic
Public Property AnimationManager As AnimationManager
    Get
    Set
Visual C++
public:
virtual property AnimationManager^ AnimationManager {
    AnimationManager^ get () sealed;
    void set (AnimationManager^ value) sealed;
}

See Also

vRibbonGroupFooter Class


Font Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..Font Property
vRibbonGroupFooter Class See Also Send Feedback
Gets or sets the font of the text displayed by the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Font Font { get; set; }
Visual Basic
Public Overrides Property Font As Font
    Get
    Set
Visual C++
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}

Field Value

Return Value

The Font to apply to the text displayed by the control. The default is the value of the DefaultFont property.

See Also

vRibbonGroupFooter Class


FooterButton Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..FooterButton Property
vRibbonGroupFooter Class See Also Send Feedback
Gets the footer button.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonFooterButton FooterButton { get; }
Visual Basic
Public ReadOnly Property FooterButton As vRibbonFooterButton
    Get
Visual C++
public:
property vRibbonFooterButton^ FooterButton {
    vRibbonFooterButton^ get ();
}

Field Value

The footer button.

See Also

vRibbonGroupFooter Class


RibbonGroup Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..RibbonGroup Property
vRibbonGroupFooter Class See Also Send Feedback
Gets the ribbon group.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonGroupContent RibbonGroup { get; }
Visual Basic
Public ReadOnly Property RibbonGroup As vRibbonGroupContent
    Get
Visual C++
public:
property vRibbonGroupContent^ RibbonGroup {
    vRibbonGroupContent^ get ();
}

Field Value

The ribbon group.

See Also

vRibbonGroupFooter Class


ShowFooterButton Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..ShowFooterButton Property
vRibbonGroupFooter Class See Also Send Feedback
Gets or sets a value indicating whether to show the footer button.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowFooterButton { get; set; }
Visual Basic
Public Property ShowFooterButton As Boolean
    Get
    Set
Visual C++
public:
property bool ShowFooterButton {
    bool get ();
    void set (bool value);
}

See Also

vRibbonGroupFooter Class


StyleKey Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..StyleKey Property
vRibbonGroupFooter Class See Also Send Feedback
Gets or sets the style key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual string StyleKey { get; set; }
Visual Basic
Protected Overridable Property StyleKey As String
    Get
    Set
Visual C++
protected:
virtual property String^ StyleKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The style key.

See Also

vRibbonGroupFooter Class


TextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..TextAlignment Property
vRibbonGroupFooter Class See Also Send Feedback
Gets or sets the text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment TextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The text alignment.

See Also

vRibbonGroupFooter Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..Theme Property
vRibbonGroupFooter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vRibbonGroupFooter Class


UseThemeTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..UseThemeTextColor Property
vRibbonGroupFooter Class See Also Send Feedback
Gets or sets a value indicating whether to use theme text color.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeTextColor { get; set; }
Visual Basic
Public Property UseThemeTextColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeTextColor {
    bool get ();
    void set (bool value);
}

See Also

vRibbonGroupFooter Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter..::..VIBlendTheme Property
vRibbonGroupFooter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vRibbonGroupFooter Class


vRibbonGroupFooter Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonGroupFooter Events
vRibbonGroupFooter Class See Also Send Feedback

The vRibbonGroupFooter type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRibbonGroupFooter Class


vRibbonHorizontalLayoutPanel Class

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vRibbonHorizontalLayoutPanel : vHorizontalLayoutPanel
Visual Basic
Public Class vRibbonHorizontalLayoutPanel _
    Inherits vHorizontalLayoutPanel
Visual C++
public ref class vRibbonHorizontalLayoutPanel : public vHorizontalLayoutPanel

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..Panel
VIBlend.WinForms.Controls..::..vHorizontalLayoutPanel
VIBlend.WinForms.Controls..::..vRibbonHorizontalLayoutPanel

See Also

vRibbonHorizontalLayoutPanel Members


vRibbonHorizontalLayoutPanel Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel Members
vRibbonHorizontalLayoutPanel Class Constructors Methods Properties Events See Also Send Feedback

The vRibbonHorizontalLayoutPanel type exposes the following members.

Constructors

 | Name | Description
Public method | vRibbonHorizontalLayoutPanel | Initializes a new instance of the vRibbonHorizontalLayoutPanel class

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vHorizontalLayoutPanel.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from vHorizontalLayoutPanel.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from vHorizontalLayoutPanel.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from vHorizontalLayoutPanel.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from vHorizontalLayoutPanel.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollLeft | (Inherited from vHorizontalLayoutPanel.)
Protected method | ScrollRight | (Inherited from vHorizontalLayoutPanel.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vHorizontalLayoutPanel.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from vHorizontalLayoutPanel.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from vHorizontalLayoutPanel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vHorizontalLayoutPanel.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vHorizontalLayoutPanel.)
Public property | PanelBackColor | Gets or sets the BackColor of the Panel. (Inherited from vHorizontalLayoutPanel.)
Public property | PanelBorderColor | Gets or sets the BorderColor of the Panel. (Inherited from vHorizontalLayoutPanel.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StartOffset | Gets or sets the start offset. (Inherited from vHorizontalLayoutPanel.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vHorizontalLayoutPanel.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UsePanelBackColor | Gets or sets a value indicating whether to use the PanelBackColor (Inherited from vHorizontalLayoutPanel.)
Public property | UsePanelBorderColor | Gets or sets a value indicating whether to use the PanelBorderColor (Inherited from vHorizontalLayoutPanel.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vHorizontalLayoutPanel.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRibbonHorizontalLayoutPanel Class


vRibbonHorizontalLayoutPanel Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel Constructor
vRibbonHorizontalLayoutPanel Class See Also Send Feedback
Initializes a new instance of the vRibbonHorizontalLayoutPanel class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonHorizontalLayoutPanel()
Visual Basic
Public Sub New
Visual C++
public:
vRibbonHorizontalLayoutPanel()

See Also

vRibbonHorizontalLayoutPanel Class


vRibbonHorizontalLayoutPanel Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel Methods
vRibbonHorizontalLayoutPanel Class See Also Send Feedback

The vRibbonHorizontalLayoutPanel type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vHorizontalLayoutPanel.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from vHorizontalLayoutPanel.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from vHorizontalLayoutPanel.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from vHorizontalLayoutPanel.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from vHorizontalLayoutPanel.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollLeft | (Inherited from vHorizontalLayoutPanel.)
Protected method | ScrollRight | (Inherited from vHorizontalLayoutPanel.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

See Also

vRibbonHorizontalLayoutPanel Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel..::..AccessibilityNotifyClients Method
vRibbonHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vRibbonHorizontalLayoutPanel Class
vRibbonHorizontalLayoutPanel Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel..::..BeginInvoke Method
vRibbonHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vRibbonHorizontalLayoutPanel Class
vRibbonHorizontalLayoutPanel Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel..::..Dispose Method
vRibbonHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vHorizontalLayoutPanel.)

See Also

vRibbonHorizontalLayoutPanel Class
vRibbonHorizontalLayoutPanel Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel..::..GetChildAtPoint Method
vRibbonHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vRibbonHorizontalLayoutPanel Class
vRibbonHorizontalLayoutPanel Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel..::..Invalidate Method
vRibbonHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vRibbonHorizontalLayoutPanel Class
vRibbonHorizontalLayoutPanel Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel..::..Invoke Method
vRibbonHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vRibbonHorizontalLayoutPanel Class
vRibbonHorizontalLayoutPanel Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel..::..MemberwiseClone Method
vRibbonHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vRibbonHorizontalLayoutPanel Class
vRibbonHorizontalLayoutPanel Members


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel..::..PerformLayout Method
vRibbonHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vRibbonHorizontalLayoutPanel Class
vRibbonHorizontalLayoutPanel Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel..::..ResumeLayout Method
vRibbonHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vRibbonHorizontalLayoutPanel Class
vRibbonHorizontalLayoutPanel Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel..::..RtlTranslateAlignment Method
vRibbonHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vRibbonHorizontalLayoutPanel Class
vRibbonHorizontalLayoutPanel Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel..::..Scale Method
vRibbonHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vRibbonHorizontalLayoutPanel Class
vRibbonHorizontalLayoutPanel Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel..::..Select Method
vRibbonHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vRibbonHorizontalLayoutPanel Class
vRibbonHorizontalLayoutPanel Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel..::..SetBounds Method
vRibbonHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vRibbonHorizontalLayoutPanel Class
vRibbonHorizontalLayoutPanel Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel..::..UpdateBounds Method
vRibbonHorizontalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vRibbonHorizontalLayoutPanel Class
vRibbonHorizontalLayoutPanel Members


vRibbonHorizontalLayoutPanel Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel Properties
vRibbonHorizontalLayoutPanel Class See Also Send Feedback

The vRibbonHorizontalLayoutPanel type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vHorizontalLayoutPanel.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from vHorizontalLayoutPanel.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from vHorizontalLayoutPanel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vHorizontalLayoutPanel.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vHorizontalLayoutPanel.)
Public property | PanelBackColor | Gets or sets the BackColor of the Panel. (Inherited from vHorizontalLayoutPanel.)
Public property | PanelBorderColor | Gets or sets the BorderColor of the Panel. (Inherited from vHorizontalLayoutPanel.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StartOffset | Gets or sets the start offset. (Inherited from vHorizontalLayoutPanel.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vHorizontalLayoutPanel.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UsePanelBackColor | Gets or sets a value indicating whether to use the PanelBackColor (Inherited from vHorizontalLayoutPanel.)
Public property | UsePanelBorderColor | Gets or sets a value indicating whether to use the PanelBorderColor (Inherited from vHorizontalLayoutPanel.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vHorizontalLayoutPanel.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vRibbonHorizontalLayoutPanel Class


vRibbonHorizontalLayoutPanel Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRibbonHorizontalLayoutPanel Events
vRibbonHorizontalLayoutPanel Class See Also Send Feedback

The vRibbonHorizontalLayoutPanel type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRibbonHorizontalLayoutPanel Class


vRichTextBox Class

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox Class
Members See Also Send Feedback
Represents a vRichTextBox control, that provides advanced text editing and formatting capabilities.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vRichTextBox : Control,
    IScrollableControlBase
Visual Basic
Public Class vRichTextBox _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class vRichTextBox : public Control,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vRichTextBox

See Also

vRichTextBox Members


vRichTextBox Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox Members
vRichTextBox Class Constructors Methods Properties Events See Also Send Feedback

The vRichTextBox type exposes the following members.

Constructors

 | Name | Description
Public method | vRichTextBox | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawText | Draws the text.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Overrides Control..::..OnTextChanged(EventArgs).)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowFocused | Gets or sets a value indicating whether [allow focused].
Public property | AllowHighlight | Gets or sets a value indicating whether [allow highlight].
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox.
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox.
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum length of the text in the textbox.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Overrides Control..::..RightToLeft.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Overrides Control..::..Text.)
Public property | TextBox | Gets the text box.
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRichTextBox Class


vRichTextBox Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox Constructor
vRichTextBox Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRichTextBox()
Visual Basic
Public Sub New
Visual C++
public:
vRichTextBox()

See Also

vRichTextBox Class


vRichTextBox Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox Methods
vRichTextBox Class See Also Send Feedback

The vRichTextBox type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawText | Draws the text.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Overrides Control..::..OnTextChanged(EventArgs).)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vRichTextBox Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..AccessibilityNotifyClients Method
vRichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vRichTextBox Class
vRichTextBox Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..BeginInvoke Method
vRichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vRichTextBox Class
vRichTextBox Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..Dispose Method
vRichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vRichTextBox Class
vRichTextBox Members


DrawText Method

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..DrawText Method
vRichTextBox Class See Also Send Feedback
Draws the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DrawText(
    Graphics g
)
Visual Basic
Protected Overridable Sub DrawText ( _
    g As Graphics _
)
Visual C++
protected:
virtual void DrawText(
    Graphics^ g
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.

See Also

vRichTextBox Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..GetChildAtPoint Method
vRichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vRichTextBox Class
vRichTextBox Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..Invalidate Method
vRichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vRichTextBox Class
vRichTextBox Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..Invoke Method
vRichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vRichTextBox Class
vRichTextBox Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..MemberwiseClone Method
vRichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vRichTextBox Class
vRichTextBox Members


OnTextChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..OnTextChanged Method
vRichTextBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnTextChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnTextChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnTextChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vRichTextBox Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..PerformLayout Method
vRichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vRichTextBox Class
vRichTextBox Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..ResumeLayout Method
vRichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vRichTextBox Class
vRichTextBox Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..RtlTranslateAlignment Method
vRichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vRichTextBox Class
vRichTextBox Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..Scale Method
vRichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vRichTextBox Class
vRichTextBox Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..Select Method
vRichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vRichTextBox Class
vRichTextBox Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..SetBounds Method
vRichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vRichTextBox Class
vRichTextBox Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..UpdateBounds Method
vRichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vRichTextBox Class
vRichTextBox Members


vRichTextBox Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox Properties
vRichTextBox Class See Also Send Feedback

The vRichTextBox type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowFocused | Gets or sets a value indicating whether [allow focused].
Public property | AllowHighlight | Gets or sets a value indicating whether [allow highlight].
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox.
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox.
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum length of the text in the textbox.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Overrides Control..::..RightToLeft.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Overrides Control..::..Text.)
Public property | TextBox | Gets the text box.
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vRichTextBox Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..AllowAnimations Property
vRichTextBox Class See Also Send Feedback
Gets or sets whether the control is animated

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vRichTextBox Class


AllowFocused Property

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..AllowFocused Property
vRichTextBox Class See Also Send Feedback
Gets or sets a value indicating whether [allow focused].

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowFocused { get; set; }
Visual Basic
Public Property AllowFocused As Boolean
    Get
    Set
Visual C++
public:
property bool AllowFocused {
    bool get ();
    void set (bool value);
}

Field Value

true if [allow focused]; otherwise, false.

See Also

vRichTextBox Class


AllowHighlight Property

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..AllowHighlight Property
vRichTextBox Class See Also Send Feedback
Gets or sets a value indicating whether [allow highlight].

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowHighlight { get; set; }
Visual Basic
Public Property AllowHighlight As Boolean
    Get
    Set
Visual C++
public:
property bool AllowHighlight {
    bool get ();
    void set (bool value);
}

Field Value

true if [allow highlight]; otherwise, false.

See Also

vRichTextBox Class


ControlBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..ControlBorderColor Property
vRichTextBox Class See Also Send Feedback
Gets or sets the BorderColor of the TextBox.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Color ControlBorderColor { get; set; }
Visual Basic
Public Overridable Property ControlBorderColor As Color
    Get
    Set
Visual C++
public:
virtual property Color ControlBorderColor {
    Color get ();
    void set (Color value);
}

See Also

vRichTextBox Class


ControlHighlightBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..ControlHighlightBorderColor Property
vRichTextBox Class See Also Send Feedback
Gets or sets the Highlight BorderColor of the TextBox.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Color ControlHighlightBorderColor { get; set; }
Visual Basic
Public Overridable Property ControlHighlightBorderColor As Color
    Get
    Set
Visual C++
public:
virtual property Color ControlHighlightBorderColor {
    Color get ();
    void set (Color value);
}

See Also

vRichTextBox Class


EnableBorderHighlight Property

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..EnableBorderHighlight Property
vRichTextBox Class See Also Send Feedback
Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableBorderHighlight { get; set; }
Visual Basic
Public Property EnableBorderHighlight As Boolean
    Get
    Set
Visual C++
public:
property bool EnableBorderHighlight {
    bool get ();
    void set (bool value);
}

See Also

vRichTextBox Class


GleamWidth Property

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..GleamWidth Property
vRichTextBox Class See Also Send Feedback
Gets or sets the width of the gleam.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int GleamWidth { get; set; }
Visual Basic
Public Property GleamWidth As Integer
    Get
    Set
Visual C++
public:
property int GleamWidth {
    int get ();
    void set (int value);
}

Field Value

The width of the gleam.

See Also

vRichTextBox Class


MaxLength Property

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..MaxLength Property
vRichTextBox Class See Also Send Feedback
Gets or sets the maximum length of the text in the textbox.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int MaxLength { get; set; }
Visual Basic
Public Property MaxLength As Integer
    Get
    Set
Visual C++
public:
property int MaxLength {
    int get ();
    void set (int value);
}

See Also

vRichTextBox Class


Multiline Property

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..Multiline Property
vRichTextBox Class See Also Send Feedback
Gets or sets whether the vTextBox has multiple lines.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Multiline { get; set; }
Visual Basic
Public Property Multiline As Boolean
    Get
    Set
Visual C++
public:
property bool Multiline {
    bool get ();
    void set (bool value);
}

See Also

vRichTextBox Class


Readonly Property

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..Readonly Property
vRichTextBox Class See Also Send Feedback
Gets or sets whether the vTextBox is in read only mode.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Readonly { get; set; }
Visual Basic
Public Property Readonly As Boolean
    Get
    Set
Visual C++
public:
property bool Readonly {
    bool get ();
    void set (bool value);
}

See Also

vRichTextBox Class


RightToLeft Property

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..RightToLeft Property
vRichTextBox Class See Also Send Feedback
Gets or sets whether the vTextBox is in right-to-left mode.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override RightToLeft RightToLeft { get; set; }
Visual Basic
Public Overrides Property RightToLeft As RightToLeft
    Get
    Set
Visual C++
public:
virtual property RightToLeft RightToLeft {
    RightToLeft get () override;
    void set (RightToLeft value) override;
}

See Also

vRichTextBox Class


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..Text Property
vRichTextBox Class See Also Send Feedback
Gets or sets the text of the vTextBox control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string Text { get; set; }
Visual Basic
Public Overrides Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

See Also

vRichTextBox Class


TextBox Property

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..TextBox Property
vRichTextBox Class See Also Send Feedback
Gets the text box.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRichTextBoxBase TextBox { get; }
Visual Basic
Public ReadOnly Property TextBox As vRichTextBoxBase
    Get
Visual C++
public:
property vRichTextBoxBase^ TextBox {
    vRichTextBoxBase^ get ();
}

Field Value

The text box.

See Also

vRichTextBox Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..Theme Property
vRichTextBox Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vRichTextBox Class


UseThemeBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..UseThemeBorderColor Property
vRichTextBox Class See Also Send Feedback
Gets or sets a value indicating whether to use the ControlBorderColor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool UseThemeBorderColor { get; set; }
Visual Basic
Public Overridable Property UseThemeBorderColor As Boolean
    Get
    Set
Visual C++
public:
virtual property bool UseThemeBorderColor {
    bool get ();
    void set (bool value);
}

See Also

vRichTextBox Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox..::..VIBlendTheme Property
vRichTextBox Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vRichTextBox Class


vRichTextBox Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBox Events
vRichTextBox Class See Also Send Feedback

The vRichTextBox type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vRichTextBox Class


vRichTextBoxBase Class

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vRichTextBoxBase : RichTextBox
Visual Basic
Public Class vRichTextBoxBase _
    Inherits RichTextBox
Visual C++
public ref class vRichTextBoxBase : public RichTextBox

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..TextBoxBase
System.Windows.Forms..::..RichTextBox
VIBlend.WinForms.Controls..::..vRichTextBoxBase

See Also

vRichTextBoxBase Members


vRichTextBoxBase Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase Members
vRichTextBoxBase Class Constructors Methods Properties Events See Also Send Feedback

The vRichTextBoxBase type exposes the following members.

Constructors

 | Name | Description
Public method | vRichTextBoxBase | Initializes a new instance of the [!:vTextBoxBase] class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CanPaste | Determines whether you can paste information from the Clipboard in the specified data format. (Inherited from RichTextBox.)
Public method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase.)
Public method | ClearUndo | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from TextBoxBase.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | (Inherited from TextBoxBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateRichEditOleCallback | Creates an IRichEditOleCallback-compatible object for handling rich-edit callback operations. (Inherited from RichTextBox.)
Public method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | DeselectAll | Specifies that the value of the SelectionLength property is zero so that no characters are selected in the control. (Inherited from TextBoxBase.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | This method is not relevant for this class. (Inherited from RichTextBox.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | Find(String) | Searches the text in a RichTextBox control for a string. (Inherited from RichTextBox.)
Public method | Find(array<Char>[]()[][]) | Searches the text of a RichTextBox control for the first instance of a character from a list of characters. (Inherited from RichTextBox.)
Public method | Find(String, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string with specific options applied to the search. (Inherited from RichTextBox.)
Public method | Find(array<Char>[]()[][], Int32) | Searches the text of a RichTextBox control, at a specific starting point, for the first instance of a character from a list of characters. (Inherited from RichTextBox.)
Public method | Find(String, Int32, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string at a specific location within the control and with specific options applied to the search. (Inherited from RichTextBox.)
Public method | Find(array<Char>[]()[][], Int32, Int32) | Searches a range of text in a RichTextBox control for the first instance of a character from a list of characters. (Inherited from RichTextBox.)
Public method | Find(String, Int32, Int32, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string within a range of text within the control and with specific options applied to the search. (Inherited from RichTextBox.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetCharFromPosition | Retrieves the character that is closest to the specified location within the control. (Inherited from TextBoxBase.)
Public method | GetCharIndexFromPosition | Retrieves the index of the character nearest to the specified location. (Inherited from RichTextBox.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetFirstCharIndexFromLine | Retrieves the index of the first character of a given line. (Inherited from TextBoxBase.)
Public method | GetFirstCharIndexOfCurrentLine | Retrieves the index of the first character of the current line. (Inherited from TextBoxBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetLineFromCharIndex | Retrieves the line number from the specified character position within the text of the RichTextBox control. (Inherited from RichTextBox.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPositionFromCharIndex | Retrieves the location within the control at the specified character index. (Inherited from RichTextBox.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is an input key or a special key that requires preprocessing. (Inherited from TextBoxBase.)
Public method | LoadFile(String) | Loads a rich text format (RTF) or standard ASCII text file into the RichTextBox control. (Inherited from RichTextBox.)
Public method | LoadFile(String, RichTextBoxStreamType) | Loads a specific type of file into the RichTextBox control. (Inherited from RichTextBox.)
Public method | LoadFile(Stream, RichTextBoxStreamType) | Loads the contents of an existing data stream into the RichTextBox control. (Inherited from RichTextBox.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAcceptsTabChanged | Raises the AcceptsTabChanged event. (Inherited from TextBoxBase.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | (Inherited from RichTextBox.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnBorderStyleChanged | Raises the BorderStyleChanged event. (Inherited from TextBoxBase.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContentsResized | Raises the ContentsResized event. (Inherited from RichTextBox.)
Protected method | OnContextMenuChanged | (Inherited from RichTextBox.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | (Inherited from TextBoxBase.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from RichTextBox.)
Protected method | OnHandleDestroyed | (Inherited from RichTextBox.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnHideSelectionChanged | Raise the HideSelectionChanged event. (Inherited from TextBoxBase.)
Protected method | OnHScroll | Raises the HScroll event. (Inherited from RichTextBox.)
Protected method | OnImeChange | Raises the ImeChange event. (Inherited from RichTextBox.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLinkClicked | Raises the LinkClicked event. (Inherited from RichTextBox.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnModifiedChanged | Raises the ModifiedChanged event. (Inherited from TextBoxBase.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnMultilineChanged | Raises the MultilineChanged event. (Inherited from TextBoxBase.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | This method is not relevant for this class. (Inherited from TextBoxBase.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnProtected | Raises the Protected event. (Inherited from RichTextBox.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnReadOnlyChanged | Raises the ReadOnlyChanged event. (Inherited from TextBoxBase.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | (Inherited from RichTextBox.)
Protected method | OnSelectionChanged | Raises the SelectionChanged event. (Inherited from RichTextBox.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from TextBoxBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Protected method | OnVScroll | Raises the VScroll event. (Inherited from RichTextBox.)
Public method | Paste()()()() | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase.)
Public method | Paste(DataFormats..::..Format) | Pastes the contents of the Clipboard in the specified Clipboard format. (Inherited from RichTextBox.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from RichTextBox.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | (Inherited from TextBoxBase.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | Reapplies the last operation that was undone in the control. (Inherited from RichTextBox.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | SaveFile(String) | Saves the contents of the RichTextBox to a rich text format (RTF) file. (Inherited from RichTextBox.)
Public method | SaveFile(String, RichTextBoxStreamType) | Saves the contents of the RichTextBox to a specific type of file. (Inherited from RichTextBox.)
Public method | SaveFile(Stream, RichTextBoxStreamType) | Saves the contents of a RichTextBox control to an open data stream. (Inherited from RichTextBox.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Public method | Select(Int32, Int32) | Selects a range of text in the text box. (Inherited from TextBoxBase.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Sets the specified bounds of the TextBoxBase control. (Inherited from TextBoxBase.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the TextBoxBase control. (Inherited from TextBoxBase.)
Public method | Undo | Undoes the last edit operation in the text box. (Inherited from TextBoxBase.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from RichTextBox.)

Properties

 | Name | Description
Public property | AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from TextBoxBase.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control will enable drag-and-drop operations. (Inherited from RichTextBox.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant to this class. (Inherited from RichTextBox.)
Public property | AutoWordSelection | Gets or sets a value indicating whether automatic word selection is enabled. (Inherited from RichTextBox.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from TextBoxBase.)
Public property | BackgroundImage | This property is not relevant to this class. (Inherited from RichTextBox.)
Public property | BackgroundImageLayout | This property is not relevant to this class. (Inherited from RichTextBox.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border type of the text box control. (Inherited from TextBoxBase.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BulletIndent | Gets or sets the indentation used in the RichTextBox control when the bullet style is applied to the text. (Inherited from RichTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from TextBoxBase.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanRedo | Gets a value indicating whether there are actions that have occurred within the RichTextBox that can be reapplied. (Inherited from RichTextBox.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBoxBase.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from RichTextBox.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from TextBoxBase.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from RichTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DetectUrls | Gets or sets a value indicating whether or not the RichTextBox will automatically format a Uniform Resource Locator (URL) when it is typed into the control. (Inherited from RichTextBox.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether control drawing is done in a buffer before the control is displayed. This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | EnableAutoDragDrop | Gets or sets a value that enables drag-and-drop operations on text, pictures, and other data. (Inherited from RichTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font used when displaying text in the control. (Inherited from RichTextBox.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the font used when displaying text in the control. (Inherited from RichTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from TextBoxBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from TextBoxBase.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LanguageOption | Gets or sets a value that indicates RichTextBox settings for Input Method Editor (IME) and Asian language support. (Inherited from RichTextBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Lines | Gets or sets the lines of text in a text box control. (Inherited from TextBoxBase.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum number of characters the user can type or paste into the rich text box control. (Inherited from RichTextBox.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from TextBoxBase.)
Public property | Multiline | Gets or sets a value indicating whether this is a multiline RichTextBox control. (Inherited from RichTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredHeight | Gets the preferred height for a text box. (Inherited from TextBoxBase.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from TextBoxBase.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | RedoActionName | Gets the name of the action that can be reapplied to the control when the Redo()()()() method is called. (Inherited from RichTextBox.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RichTextShortcutsEnabled | This property is not relevant for this class. (Inherited from RichTextBox.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightMargin | Gets or sets the size of a single line of text within the RichTextBox control. (Inherited from RichTextBox.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Rtf | Gets or sets the text of the RichTextBox control, including all rich text format (RTF) codes. (Inherited from RichTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets the type of scroll bars to display in the RichTextBox control. (Inherited from RichTextBox.)
Public property | SelectedRtf | Gets or sets the currently selected rich text format (RTF) formatted text in the control. (Inherited from RichTextBox.)
Public property | SelectedText | Gets or sets the selected text within the RichTextBox. (Inherited from RichTextBox.)
Public property | SelectionAlignment | Gets or sets the alignment to apply to the current selection or insertion point. (Inherited from RichTextBox.)
Public property | SelectionBackColor | Gets or sets the color of text when the text is selected in a RichTextBox control. (Inherited from RichTextBox.)
Public property | SelectionBullet | Gets or sets a value indicating whether the bullet style is applied to the current selection or insertion point. (Inherited from RichTextBox.)
Public property | SelectionCharOffset | Gets or sets whether text in the control appears on the baseline, as a superscript, or as a subscript below the baseline. (Inherited from RichTextBox.)
Public property | SelectionColor | Gets or sets the text color of the current text selection or insertion point. (Inherited from RichTextBox.)
Public property | SelectionFont | Gets or sets the font of the current text selection or insertion point. (Inherited from RichTextBox.)
Public property | SelectionHangingIndent | Gets or sets the distance between the left edge of the first line of text in the selected paragraph and the left edge of subsequent lines in the same paragraph. (Inherited from RichTextBox.)
Public property | SelectionIndent | Gets or sets the length, in pixels, of the indentation of the line where the selection starts. (Inherited from RichTextBox.)
Public property | SelectionLength | Gets or sets the number of characters selected in control. (Inherited from RichTextBox.)
Public property | SelectionProtected | Gets or sets a value indicating whether the current text selection is protected. (Inherited from RichTextBox.)
Public property | SelectionRightIndent | The distance (in pixels) between the right edge of the RichTextBox control and the right edge of the text that is selected or added at the current insertion point. (Inherited from RichTextBox.)
Public property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase.)
Public property | SelectionTabs | Gets or sets the absolute tab stop positions in a RichTextBox control. (Inherited from RichTextBox.)
Public property | SelectionType | Gets the selection type within the control. (Inherited from RichTextBox.)
Public property | ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from TextBoxBase.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowSelectionMargin | Gets or sets a value indicating whether a selection margin is displayed in the RichTextBox. (Inherited from RichTextBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the current text in the rich text box. (Inherited from RichTextBox.)
Public property | TextLength | (Inherited from RichTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UndoActionName | Gets the name of the action that can be undone in the control when the Undo()()()() method is called. (Inherited from RichTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from TextBoxBase.)
Public property | ZoomFactor | Gets or sets the current zoom level of the RichTextBox. (Inherited from RichTextBox.)

Events

 | Name | Description
Public event | AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed. (Inherited from TextBoxBase.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from RichTextBox.)
Public event | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. (Inherited from RichTextBox.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | BorderStyleChanged | Occurs when the value of the BorderStyle property has changed. (Inherited from TextBoxBase.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the text box is clicked. (Inherited from TextBoxBase.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContentsResized | Occurs when contents within the control are resized. (Inherited from RichTextBox.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when the user completes a drag-and-drop (Inherited from RichTextBox.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from RichTextBox.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from RichTextBox.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from RichTextBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from RichTextBox.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HideSelectionChanged | Occurs when the value of the HideSelection property has changed. (Inherited from TextBoxBase.)
Public event | HScroll | Occurs when the user clicks the horizontal scroll bar of the control. (Inherited from RichTextBox.)
Public event | ImeChange | Occurs when the user switches input methods on an Asian version of the Windows operating system. (Inherited from RichTextBox.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LinkClicked | Occurs when the user clicks on a link within the text of the control. (Inherited from RichTextBox.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | ModifiedChanged | Occurs when the value of the Modified property has changed. (Inherited from TextBoxBase.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from TextBoxBase.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | MultilineChanged | Occurs when the value of the Multiline property has changed. (Inherited from TextBoxBase.)
Public event | PaddingChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | Paint | Occurs when the control is redrawn. This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | Protected | Occurs when the user attempts to modify protected text in the control. (Inherited from RichTextBox.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | This event is not relevant to this class. (Inherited from RichTextBox.)
Public event | ReadOnlyChanged | Occurs when the value of the ReadOnly property has changed. (Inherited from TextBoxBase.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of text within the control has changed. (Inherited from RichTextBox.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | VScroll | Occurs when the user clicks the vertical scroll bars of the control. (Inherited from RichTextBox.)

See Also

vRichTextBoxBase Class


vRichTextBoxBase Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase Constructor
vRichTextBoxBase Class See Also Send Feedback
Initializes a new instance of the [!:vTextBoxBase] class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRichTextBoxBase()
Visual Basic
Public Sub New
Visual C++
public:
vRichTextBoxBase()

See Also

vRichTextBoxBase Class


vRichTextBoxBase Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase Methods
vRichTextBoxBase Class See Also Send Feedback

The vRichTextBoxBase type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CanPaste | Determines whether you can paste information from the Clipboard in the specified data format. (Inherited from RichTextBox.)
Public method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase.)
Public method | ClearUndo | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from TextBoxBase.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | (Inherited from TextBoxBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateRichEditOleCallback | Creates an IRichEditOleCallback-compatible object for handling rich-edit callback operations. (Inherited from RichTextBox.)
Public method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | DeselectAll | Specifies that the value of the SelectionLength property is zero so that no characters are selected in the control. (Inherited from TextBoxBase.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | This method is not relevant for this class. (Inherited from RichTextBox.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | Find(String) | Searches the text in a RichTextBox control for a string. (Inherited from RichTextBox.)
Public method | Find(array<Char>[]()[][]) | Searches the text of a RichTextBox control for the first instance of a character from a list of characters. (Inherited from RichTextBox.)
Public method | Find(String, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string with specific options applied to the search. (Inherited from RichTextBox.)
Public method | Find(array<Char>[]()[][], Int32) | Searches the text of a RichTextBox control, at a specific starting point, for the first instance of a character from a list of characters. (Inherited from RichTextBox.)
Public method | Find(String, Int32, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string at a specific location within the control and with specific options applied to the search. (Inherited from RichTextBox.)
Public method | Find(array<Char>[]()[][], Int32, Int32) | Searches a range of text in a RichTextBox control for the first instance of a character from a list of characters. (Inherited from RichTextBox.)
Public method | Find(String, Int32, Int32, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string within a range of text within the control and with specific options applied to the search. (Inherited from RichTextBox.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetCharFromPosition | Retrieves the character that is closest to the specified location within the control. (Inherited from TextBoxBase.)
Public method | GetCharIndexFromPosition | Retrieves the index of the character nearest to the specified location. (Inherited from RichTextBox.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetFirstCharIndexFromLine | Retrieves the index of the first character of a given line. (Inherited from TextBoxBase.)
Public method | GetFirstCharIndexOfCurrentLine | Retrieves the index of the first character of the current line. (Inherited from TextBoxBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetLineFromCharIndex | Retrieves the line number from the specified character position within the text of the RichTextBox control. (Inherited from RichTextBox.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPositionFromCharIndex | Retrieves the location within the control at the specified character index. (Inherited from RichTextBox.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is an input key or a special key that requires preprocessing. (Inherited from TextBoxBase.)
Public method | LoadFile(String) | Loads a rich text format (RTF) or standard ASCII text file into the RichTextBox control. (Inherited from RichTextBox.)
Public method | LoadFile(String, RichTextBoxStreamType) | Loads a specific type of file into the RichTextBox control. (Inherited from RichTextBox.)
Public method | LoadFile(Stream, RichTextBoxStreamType) | Loads the contents of an existing data stream into the RichTextBox control. (Inherited from RichTextBox.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAcceptsTabChanged | Raises the AcceptsTabChanged event. (Inherited from TextBoxBase.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | (Inherited from RichTextBox.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnBorderStyleChanged | Raises the BorderStyleChanged event. (Inherited from TextBoxBase.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContentsResized | Raises the ContentsResized event. (Inherited from RichTextBox.)
Protected method | OnContextMenuChanged | (Inherited from RichTextBox.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | (Inherited from TextBoxBase.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from RichTextBox.)
Protected method | OnHandleDestroyed | (Inherited from RichTextBox.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnHideSelectionChanged | Raise the HideSelectionChanged event. (Inherited from TextBoxBase.)
Protected method | OnHScroll | Raises the HScroll event. (Inherited from RichTextBox.)
Protected method | OnImeChange | Raises the ImeChange event. (Inherited from RichTextBox.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLinkClicked | Raises the LinkClicked event. (Inherited from RichTextBox.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnModifiedChanged | Raises the ModifiedChanged event. (Inherited from TextBoxBase.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnMultilineChanged | Raises the MultilineChanged event. (Inherited from TextBoxBase.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | This method is not relevant for this class. (Inherited from TextBoxBase.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnProtected | Raises the Protected event. (Inherited from RichTextBox.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnReadOnlyChanged | Raises the ReadOnlyChanged event. (Inherited from TextBoxBase.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | (Inherited from RichTextBox.)
Protected method | OnSelectionChanged | Raises the SelectionChanged event. (Inherited from RichTextBox.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from TextBoxBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Protected method | OnVScroll | Raises the VScroll event. (Inherited from RichTextBox.)
Public method | Paste()()()() | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase.)
Public method | Paste(DataFormats..::..Format) | Pastes the contents of the Clipboard in the specified Clipboard format. (Inherited from RichTextBox.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from RichTextBox.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | (Inherited from TextBoxBase.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | Reapplies the last operation that was undone in the control. (Inherited from RichTextBox.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | SaveFile(String) | Saves the contents of the RichTextBox to a rich text format (RTF) file. (Inherited from RichTextBox.)
Public method | SaveFile(String, RichTextBoxStreamType) | Saves the contents of the RichTextBox to a specific type of file. (Inherited from RichTextBox.)
Public method | SaveFile(Stream, RichTextBoxStreamType) | Saves the contents of a RichTextBox control to an open data stream. (Inherited from RichTextBox.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Public method | Select(Int32, Int32) | Selects a range of text in the text box. (Inherited from TextBoxBase.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Sets the specified bounds of the TextBoxBase control. (Inherited from TextBoxBase.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the TextBoxBase control. (Inherited from TextBoxBase.)
Public method | Undo | Undoes the last edit operation in the text box. (Inherited from TextBoxBase.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from RichTextBox.)

See Also

vRichTextBoxBase Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..AccessibilityNotifyClients Method
vRichTextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vRichTextBoxBase Class
vRichTextBoxBase Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..BeginInvoke Method
vRichTextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vRichTextBoxBase Class
vRichTextBoxBase Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..Dispose Method
vRichTextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vRichTextBoxBase Class
vRichTextBoxBase Members


Find Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..Find Method
vRichTextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Find(String) | Searches the text in a RichTextBox control for a string. (Inherited from RichTextBox.)
Public method | Find(array<Char>[]()[][]) | Searches the text of a RichTextBox control for the first instance of a character from a list of characters. (Inherited from RichTextBox.)
Public method | Find(String, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string with specific options applied to the search. (Inherited from RichTextBox.)
Public method | Find(array<Char>[]()[][], Int32) | Searches the text of a RichTextBox control, at a specific starting point, for the first instance of a character from a list of characters. (Inherited from RichTextBox.)
Public method | Find(String, Int32, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string at a specific location within the control and with specific options applied to the search. (Inherited from RichTextBox.)
Public method | Find(array<Char>[]()[][], Int32, Int32) | Searches a range of text in a RichTextBox control for the first instance of a character from a list of characters. (Inherited from RichTextBox.)
Public method | Find(String, Int32, Int32, RichTextBoxFinds) | Searches the text in a RichTextBox control for a string within a range of text within the control and with specific options applied to the search. (Inherited from RichTextBox.)

See Also

vRichTextBoxBase Class
vRichTextBoxBase Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..GetChildAtPoint Method
vRichTextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vRichTextBoxBase Class
vRichTextBoxBase Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..Invalidate Method
vRichTextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vRichTextBoxBase Class
vRichTextBoxBase Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..Invoke Method
vRichTextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vRichTextBoxBase Class
vRichTextBoxBase Members


LoadFile Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..LoadFile Method
vRichTextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadFile(String) | Loads a rich text format (RTF) or standard ASCII text file into the RichTextBox control. (Inherited from RichTextBox.)
Public method | LoadFile(String, RichTextBoxStreamType) | Loads a specific type of file into the RichTextBox control. (Inherited from RichTextBox.)
Public method | LoadFile(Stream, RichTextBoxStreamType) | Loads the contents of an existing data stream into the RichTextBox control. (Inherited from RichTextBox.)

See Also

vRichTextBoxBase Class
vRichTextBoxBase Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..MemberwiseClone Method
vRichTextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vRichTextBoxBase Class
vRichTextBoxBase Members


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..OnPaint Method
vRichTextBoxBase Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vRichTextBoxBase Class


Paste Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..Paste Method
vRichTextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Paste()()()() | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase.)
Public method | Paste(DataFormats..::..Format) | Pastes the contents of the Clipboard in the specified Clipboard format. (Inherited from RichTextBox.)

See Also

vRichTextBoxBase Class
vRichTextBoxBase Members


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..PerformLayout Method
vRichTextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vRichTextBoxBase Class
vRichTextBoxBase Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..ResumeLayout Method
vRichTextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vRichTextBoxBase Class
vRichTextBoxBase Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..RtlTranslateAlignment Method
vRichTextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vRichTextBoxBase Class
vRichTextBoxBase Members


SaveFile Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..SaveFile Method
vRichTextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SaveFile(String) | Saves the contents of the RichTextBox to a rich text format (RTF) file. (Inherited from RichTextBox.)
Public method | SaveFile(String, RichTextBoxStreamType) | Saves the contents of the RichTextBox to a specific type of file. (Inherited from RichTextBox.)
Public method | SaveFile(Stream, RichTextBoxStreamType) | Saves the contents of a RichTextBox control to an open data stream. (Inherited from RichTextBox.)

See Also

vRichTextBoxBase Class
vRichTextBoxBase Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..Scale Method
vRichTextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vRichTextBoxBase Class
vRichTextBoxBase Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..Select Method
vRichTextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Public method | Select(Int32, Int32) | Selects a range of text in the text box. (Inherited from TextBoxBase.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vRichTextBoxBase Class
vRichTextBoxBase Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..SetBounds Method
vRichTextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vRichTextBoxBase Class
vRichTextBoxBase Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase..::..UpdateBounds Method
vRichTextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vRichTextBoxBase Class
vRichTextBoxBase Members


vRichTextBoxBase Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase Properties
vRichTextBoxBase Class See Also Send Feedback

The vRichTextBoxBase type exposes the following members.

Properties

 | Name | Description
Public property | AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from TextBoxBase.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control will enable drag-and-drop operations. (Inherited from RichTextBox.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant to this class. (Inherited from RichTextBox.)
Public property | AutoWordSelection | Gets or sets a value indicating whether automatic word selection is enabled. (Inherited from RichTextBox.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from TextBoxBase.)
Public property | BackgroundImage | This property is not relevant to this class. (Inherited from RichTextBox.)
Public property | BackgroundImageLayout | This property is not relevant to this class. (Inherited from RichTextBox.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border type of the text box control. (Inherited from TextBoxBase.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BulletIndent | Gets or sets the indentation used in the RichTextBox control when the bullet style is applied to the text. (Inherited from RichTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from TextBoxBase.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanRedo | Gets a value indicating whether there are actions that have occurred within the RichTextBox that can be reapplied. (Inherited from RichTextBox.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBoxBase.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from RichTextBox.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from TextBoxBase.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from RichTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DetectUrls | Gets or sets a value indicating whether or not the RichTextBox will automatically format a Uniform Resource Locator (URL) when it is typed into the control. (Inherited from RichTextBox.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether control drawing is done in a buffer before the control is displayed. This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | EnableAutoDragDrop | Gets or sets a value that enables drag-and-drop operations on text, pictures, and other data. (Inherited from RichTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font used when displaying text in the control. (Inherited from RichTextBox.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the font used when displaying text in the control. (Inherited from RichTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from TextBoxBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from TextBoxBase.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LanguageOption | Gets or sets a value that indicates RichTextBox settings for Input Method Editor (IME) and Asian language support. (Inherited from RichTextBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Lines | Gets or sets the lines of text in a text box control. (Inherited from TextBoxBase.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum number of characters the user can type or paste into the rich text box control. (Inherited from RichTextBox.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from TextBoxBase.)
Public property | Multiline | Gets or sets a value indicating whether this is a multiline RichTextBox control. (Inherited from RichTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredHeight | Gets the preferred height for a text box. (Inherited from TextBoxBase.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from TextBoxBase.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | RedoActionName | Gets the name of the action that can be reapplied to the control when the Redo()()()() method is called. (Inherited from RichTextBox.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RichTextShortcutsEnabled | This property is not relevant for this class. (Inherited from RichTextBox.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightMargin | Gets or sets the size of a single line of text within the RichTextBox control. (Inherited from RichTextBox.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Rtf | Gets or sets the text of the RichTextBox control, including all rich text format (RTF) codes. (Inherited from RichTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets the type of scroll bars to display in the RichTextBox control. (Inherited from RichTextBox.)
Public property | SelectedRtf | Gets or sets the currently selected rich text format (RTF) formatted text in the control. (Inherited from RichTextBox.)
Public property | SelectedText | Gets or sets the selected text within the RichTextBox. (Inherited from RichTextBox.)
Public property | SelectionAlignment | Gets or sets the alignment to apply to the current selection or insertion point. (Inherited from RichTextBox.)
Public property | SelectionBackColor | Gets or sets the color of text when the text is selected in a RichTextBox control. (Inherited from RichTextBox.)
Public property | SelectionBullet | Gets or sets a value indicating whether the bullet style is applied to the current selection or insertion point. (Inherited from RichTextBox.)
Public property | SelectionCharOffset | Gets or sets whether text in the control appears on the baseline, as a superscript, or as a subscript below the baseline. (Inherited from RichTextBox.)
Public property | SelectionColor | Gets or sets the text color of the current text selection or insertion point. (Inherited from RichTextBox.)
Public property | SelectionFont | Gets or sets the font of the current text selection or insertion point. (Inherited from RichTextBox.)
Public property | SelectionHangingIndent | Gets or sets the distance between the left edge of the first line of text in the selected paragraph and the left edge of subsequent lines in the same paragraph. (Inherited from RichTextBox.)
Public property | SelectionIndent | Gets or sets the length, in pixels, of the indentation of the line where the selection starts. (Inherited from RichTextBox.)
Public property | SelectionLength | Gets or sets the number of characters selected in control. (Inherited from RichTextBox.)
Public property | SelectionProtected | Gets or sets a value indicating whether the current text selection is protected. (Inherited from RichTextBox.)
Public property | SelectionRightIndent | The distance (in pixels) between the right edge of the RichTextBox control and the right edge of the text that is selected or added at the current insertion point. (Inherited from RichTextBox.)
Public property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase.)
Public property | SelectionTabs | Gets or sets the absolute tab stop positions in a RichTextBox control. (Inherited from RichTextBox.)
Public property | SelectionType | Gets the selection type within the control. (Inherited from RichTextBox.)
Public property | ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from TextBoxBase.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowSelectionMargin | Gets or sets a value indicating whether a selection margin is displayed in the RichTextBox. (Inherited from RichTextBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the current text in the rich text box. (Inherited from RichTextBox.)
Public property | TextLength | (Inherited from RichTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UndoActionName | Gets the name of the action that can be undone in the control when the Undo()()()() method is called. (Inherited from RichTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from TextBoxBase.)
Public property | ZoomFactor | Gets or sets the current zoom level of the RichTextBox. (Inherited from RichTextBox.)

See Also

vRichTextBoxBase Class


vRichTextBoxBase Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vRichTextBoxBase Events
vRichTextBoxBase Class See Also Send Feedback

The vRichTextBoxBase type exposes the following members.

Events

 | Name | Description
Public event | AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed. (Inherited from TextBoxBase.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from RichTextBox.)
Public event | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. (Inherited from RichTextBox.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | BorderStyleChanged | Occurs when the value of the BorderStyle property has changed. (Inherited from TextBoxBase.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the text box is clicked. (Inherited from TextBoxBase.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContentsResized | Occurs when contents within the control are resized. (Inherited from RichTextBox.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when the user completes a drag-and-drop (Inherited from RichTextBox.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from RichTextBox.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from RichTextBox.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from RichTextBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from RichTextBox.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HideSelectionChanged | Occurs when the value of the HideSelection property has changed. (Inherited from TextBoxBase.)
Public event | HScroll | Occurs when the user clicks the horizontal scroll bar of the control. (Inherited from RichTextBox.)
Public event | ImeChange | Occurs when the user switches input methods on an Asian version of the Windows operating system. (Inherited from RichTextBox.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LinkClicked | Occurs when the user clicks on a link within the text of the control. (Inherited from RichTextBox.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | ModifiedChanged | Occurs when the value of the Modified property has changed. (Inherited from TextBoxBase.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from TextBoxBase.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | MultilineChanged | Occurs when the value of the Multiline property has changed. (Inherited from TextBoxBase.)
Public event | PaddingChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | Paint | Occurs when the control is redrawn. This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | Protected | Occurs when the user attempts to modify protected text in the control. (Inherited from RichTextBox.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | This event is not relevant to this class. (Inherited from RichTextBox.)
Public event | ReadOnlyChanged | Occurs when the value of the ReadOnly property has changed. (Inherited from TextBoxBase.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectionChanged | Occurs when the selection of text within the control has changed. (Inherited from RichTextBox.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | VScroll | Occurs when the user clicks the vertical scroll bars of the control. (Inherited from RichTextBox.)

See Also

vRichTextBoxBase Class


vScrollBar Class

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar Class
Members See Also Send Feedback
Represents a base class for the vHScrollBar and vVScrollBar controls

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public abstract class vScrollBar : ScrollableControlMiniBase
Visual Basic
Public MustInherit Class vScrollBar _
    Inherits ScrollableControlMiniBase
Visual C++
public ref class vScrollBar abstract : public ScrollableControlMiniBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
ScrollableControlMiniBase
VIBlend.WinForms.Controls..::..vScrollBar
VIBlend.WinForms.Controls..::..vHScrollBar
VIBlend.WinForms.Controls..::..vVScrollBar

See Also

vScrollBar Members


vScrollBar Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vScrollBar Members
vScrollBar Class Constructors Methods Properties Events See Also Send Feedback

The vScrollBar type exposes the following members.

Constructors

 | Name | Description
Public method | vScrollBar | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDiffFactor |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnScroll | Raises the Scroll event
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Raises the ValueChanged event.
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Public method | SetDiffFactor |
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LargeChange | Gets or sets the large change value of the scroll bar.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the maximum change value of the scroll bar.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the minimum change value of the scroll bar.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollButtonsRoundedCornersRadius | Gets or sets the rounded corners radius of the scroll bar buttons.
Public property | ScrollButtonsSemiRounded | Gets or sets whether the scrollbar buttons appear semirounded.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmallChange | Gets or sets the small change value of the scroll bar.
Public property | SmartScrollEnabled | Gets or sets whether smart scrolling is enabled
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the current value of the scroll bar.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the thumb of the scroll bar has been moved by either a mouse or keyboard action.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when the Value property is changed, either by a Scroll event or programmatically.
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vScrollBar Class


vScrollBar Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar Constructor
vScrollBar Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vScrollBar()
Visual Basic
Public Sub New
Visual C++
public:
vScrollBar()

See Also

vScrollBar Class


vScrollBar Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vScrollBar Methods
vScrollBar Class See Also Send Feedback

The vScrollBar type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDiffFactor |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnScroll | Raises the Scroll event
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Raises the ValueChanged event.
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Public method | SetDiffFactor |
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vScrollBar Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..AccessibilityNotifyClients Method
vScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vScrollBar Class
vScrollBar Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..BeginInvoke Method
vScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vScrollBar Class
vScrollBar Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..Dispose Method
vScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)

See Also

vScrollBar Class
vScrollBar Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..Dispose Method (Boolean)
vScrollBar Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vScrollBar Class
Dispose Overload


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..GetChildAtPoint Method
vScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vScrollBar Class
vScrollBar Members


GetDiffFactor Method

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..GetDiffFactor Method
vScrollBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int GetDiffFactor()
Visual Basic
Public Function GetDiffFactor As Integer
Visual C++
public:
int GetDiffFactor()

See Also

vScrollBar Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..Invalidate Method
vScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vScrollBar Class
vScrollBar Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..Invoke Method
vScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vScrollBar Class
vScrollBar Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..MemberwiseClone Method
vScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vScrollBar Class
vScrollBar Members


OnScroll Method

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..OnScroll Method
vScrollBar Class See Also Send Feedback
Raises the Scroll event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnScroll(
    ScrollEventArgs e
)
Visual Basic
Protected Overridable Sub OnScroll ( _
    e As ScrollEventArgs _
)
Visual C++
protected:
virtual void OnScroll(
    ScrollEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..ScrollEventArgs
A ScrollEventArgs that contains the event data.

See Also

vScrollBar Class


OnValueChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..OnValueChanged Method
vScrollBar Class See Also Send Feedback
Raises the ValueChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnValueChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnValueChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnValueChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::..EventArgs
A EventArgs that contains the event data.

See Also

vScrollBar Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..PerformLayout Method
vScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vScrollBar Class
vScrollBar Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..ResumeLayout Method
vScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vScrollBar Class
vScrollBar Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..RtlTranslateAlignment Method
vScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vScrollBar Class
vScrollBar Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..Scale Method
vScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vScrollBar Class
vScrollBar Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..Select Method
vScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vScrollBar Class
vScrollBar Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..SetBounds Method
vScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vScrollBar Class
vScrollBar Members


SetDiffFactor Method

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..SetDiffFactor Method
vScrollBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetDiffFactor(
    int value
)
Visual Basic
Public Sub SetDiffFactor ( _
    value As Integer _
)
Visual C++
public:
void SetDiffFactor(
    int value
)

Parameters

value
Type: System..::..Int32

See Also

vScrollBar Class


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..UpdateBounds Method
vScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vScrollBar Class
vScrollBar Members


vScrollBar Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vScrollBar Properties
vScrollBar Class See Also Send Feedback

The vScrollBar type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LargeChange | Gets or sets the large change value of the scroll bar.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the maximum change value of the scroll bar.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the minimum change value of the scroll bar.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollButtonsRoundedCornersRadius | Gets or sets the rounded corners radius of the scroll bar buttons.
Public property | ScrollButtonsSemiRounded | Gets or sets whether the scrollbar buttons appear semirounded.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmallChange | Gets or sets the small change value of the scroll bar.
Public property | SmartScrollEnabled | Gets or sets whether smart scrolling is enabled
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the current value of the scroll bar.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vScrollBar Class


LargeChange Property

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..LargeChange Property
vScrollBar Class See Also Send Feedback
Gets or sets the large change value of the scroll bar.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int LargeChange { get; set; }
Visual Basic
Public Property LargeChange As Integer
    Get
    Set
Visual C++
public:
property int LargeChange {
    int get ();
    void set (int value);
}

See Also

vScrollBar Class


Maximum Property

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..Maximum Property
vScrollBar Class See Also Send Feedback
Gets or sets the maximum change value of the scroll bar.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Maximum { get; set; }
Visual Basic
Public Property Maximum As Integer
    Get
    Set
Visual C++
public:
property int Maximum {
    int get ();
    void set (int value);
}

See Also

vScrollBar Class


Minimum Property

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..Minimum Property
vScrollBar Class See Also Send Feedback
Gets or sets the minimum change value of the scroll bar.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Minimum { get; set; }
Visual Basic
Public Property Minimum As Integer
    Get
    Set
Visual C++
public:
property int Minimum {
    int get ();
    void set (int value);
}

See Also

vScrollBar Class


ScrollButtonsRoundedCornersRadius Property

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..ScrollButtonsRoundedCornersRadius Property
vScrollBar Class See Also Send Feedback
Gets or sets the rounded corners radius of the scroll bar buttons.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ScrollButtonsRoundedCornersRadius { get; set; }
Visual Basic
Public Property ScrollButtonsRoundedCornersRadius As Integer
    Get
    Set
Visual C++
public:
property int ScrollButtonsRoundedCornersRadius {
    int get ();
    void set (int value);
}

See Also

vScrollBar Class


ScrollButtonsSemiRounded Property

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..ScrollButtonsSemiRounded Property
vScrollBar Class See Also Send Feedback
Gets or sets whether the scrollbar buttons appear semirounded.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ScrollButtonsSemiRounded { get; set; }
Visual Basic
Public Property ScrollButtonsSemiRounded As Boolean
    Get
    Set
Visual C++
public:
property bool ScrollButtonsSemiRounded {
    bool get ();
    void set (bool value);
}

See Also

vScrollBar Class


SmallChange Property

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..SmallChange Property
vScrollBar Class See Also Send Feedback
Gets or sets the small change value of the scroll bar.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int SmallChange { get; set; }
Visual Basic
Public Property SmallChange As Integer
    Get
    Set
Visual C++
public:
property int SmallChange {
    int get ();
    void set (int value);
}

See Also

vScrollBar Class


SmartScrollEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..SmartScrollEnabled Property
vScrollBar Class See Also Send Feedback
Gets or sets whether smart scrolling is enabled

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool SmartScrollEnabled { get; set; }
Visual Basic
Public Property SmartScrollEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool SmartScrollEnabled {
    bool get ();
    void set (bool value);
}

See Also

vScrollBar Class


StyleKey Property

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..StyleKey Property
vScrollBar Class See Also Send Feedback
Gets or sets the style key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual string StyleKey { get; set; }
Visual Basic
Protected Friend Overridable Property StyleKey As String
    Get
    Set
Visual C++
protected public:
virtual property String^ StyleKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The style key.

See Also

vScrollBar Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..Theme Property
vScrollBar Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vScrollBar Class


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..Value Property
vScrollBar Class See Also Send Feedback
Gets or sets the current value of the scroll bar.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Value { get; set; }
Visual Basic
Public Property Value As Integer
    Get
    Set
Visual C++
public:
property int Value {
    int get ();
    void set (int value);
}

See Also

vScrollBar Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..VIBlendTheme Property
vScrollBar Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vScrollBar Class


vScrollBar Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vScrollBar Events
vScrollBar Class See Also Send Feedback

The vScrollBar type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the thumb of the scroll bar has been moved by either a mouse or keyboard action.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when the Value property is changed, either by a Scroll event or programmatically.
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vScrollBar Class


Scroll Event

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..Scroll Event
vScrollBar Class See Also Send Feedback
Occurs when the thumb of the scroll bar has been moved by either a mouse or keyboard action.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event ScrollEventHandler Scroll
Visual Basic
Public Event Scroll As ScrollEventHandler
Visual C++
public:
 event ScrollEventHandler^ Scroll {
    void add (ScrollEventHandler^ value);
    void remove (ScrollEventHandler^ value);
}

See Also

vScrollBar Class


ValueChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vScrollBar..::..ValueChanged Event
vScrollBar Class See Also Send Feedback
Occurs when the Value property is changed, either by a Scroll event or programmatically.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ValueChanged
Visual Basic
Public Event ValueChanged As EventHandler
Visual C++
public:
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vScrollBar Class


vSeparator Class

[image]

VIBlend Controls for WinForms Help Documentation
vSeparator Class
Members See Also Send Feedback
Represents a vSeparator control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vSeparator : ScrollableControlMiniBase
Visual Basic
Public Class vSeparator _
    Inherits ScrollableControlMiniBase
Visual C++
public ref class vSeparator : public ScrollableControlMiniBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
ScrollableControlMiniBase
VIBlend.WinForms.Controls..::..vSeparator

See Also

vSeparator Members


vSeparator Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSeparator Members
vSeparator Class Constructors Methods Properties Events See Also Send Feedback

The vSeparator type exposes the following members.

Constructors

 | Name | Description
Public method | vSeparator | Initializes a new instance of the vSeparator class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder |
Public property | PaintFill |
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the VI blend theme.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vSeparator Class


vSeparator Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vSeparator Constructor
vSeparator Class See Also Send Feedback
Initializes a new instance of the vSeparator class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vSeparator()
Visual Basic
Public Sub New
Visual C++
public:
vSeparator()

See Also

vSeparator Class


vSeparator Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSeparator Methods
vSeparator Class See Also Send Feedback

The vSeparator type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vSeparator Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..AccessibilityNotifyClients Method
vSeparator Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vSeparator Class
vSeparator Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..BeginInvoke Method
vSeparator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vSeparator Class
vSeparator Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..Dispose Method
vSeparator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vSeparator Class
vSeparator Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..GetChildAtPoint Method
vSeparator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vSeparator Class
vSeparator Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..Invalidate Method
vSeparator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vSeparator Class
vSeparator Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..Invoke Method
vSeparator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vSeparator Class
vSeparator Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..MemberwiseClone Method
vSeparator Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vSeparator Class
vSeparator Members


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..OnPaint Method
vSeparator Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vSeparator Class


OnSizeChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..OnSizeChanged Method
vSeparator Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnSizeChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnSizeChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSizeChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vSeparator Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..PerformLayout Method
vSeparator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vSeparator Class
vSeparator Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..ResumeLayout Method
vSeparator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vSeparator Class
vSeparator Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..RtlTranslateAlignment Method
vSeparator Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vSeparator Class
vSeparator Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..Scale Method
vSeparator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vSeparator Class
vSeparator Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..Select Method
vSeparator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vSeparator Class
vSeparator Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..SetBounds Method
vSeparator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vSeparator Class
vSeparator Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..UpdateBounds Method
vSeparator Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vSeparator Class
vSeparator Members


vSeparator Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSeparator Properties
vSeparator Class See Also Send Feedback

The vSeparator type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder |
Public property | PaintFill |
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the VI blend theme.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vSeparator Class


PaintBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..PaintBorder Property
vSeparator Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintBorder { get; set; }
Visual Basic
Public Property PaintBorder As Boolean
    Get
    Set
Visual C++
public:
property bool PaintBorder {
    bool get ();
    void set (bool value);
}

See Also

vSeparator Class


PaintFill Property

[image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..PaintFill Property
vSeparator Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintFill { get; set; }
Visual Basic
Public Property PaintFill As Boolean
    Get
    Set
Visual C++
public:
property bool PaintFill {
    bool get ();
    void set (bool value);
}

See Also

vSeparator Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..Theme Property
vSeparator Class See Also Send Feedback
Gets or sets the theme.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

Field Value

The theme.

See Also

vSeparator Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vSeparator..::..VIBlendTheme Property
vSeparator Class See Also Send Feedback
Gets or sets the VI blend theme.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

Field Value

The VI blend theme.

See Also

vSeparator Class


vSeparator Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSeparator Events
vSeparator Class See Also Send Feedback

The vSeparator type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vSeparator Class


vSizeType Class

[image]

VIBlend Controls for WinForms Help Documentation
vSizeType Class
Members See Also Send Feedback
Represents an extension of the standard Size class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vSizeType
Visual Basic
Public Class vSizeType
Visual C++
public ref class vSizeType

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..vSizeType

See Also

vSizeType Members


vSizeType Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizeType Members
vSizeType Class Constructors Methods Properties See Also Send Feedback

The vSizeType type exposes the following members.

Constructors

 | Name | Description
Public method | vSizeType()()()() | Initializes a new instance of the [!:SizeType] class.
Public method | vSizeType(Size, SizeUnitType) | Initializes a new instance of the [!:SizeType] class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Size | Gets or sets the size.
Public property | UnitType | Gets or sets the type of the size.

See Also

vSizeType Class


vSizeType Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizeType Constructor
vSizeType Class See Also Send Feedback

Overload List

 | Name | Description
Public method | vSizeType()()()() | Initializes a new instance of the [!:SizeType] class.
Public method | vSizeType(Size, SizeUnitType) | Initializes a new instance of the [!:SizeType] class.

See Also

vSizeType Class
vSizeType Members


vSizeType Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vSizeType Constructor
vSizeType Class See Also Send Feedback
Initializes a new instance of the [!:SizeType] class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vSizeType()
Visual Basic
Public Sub New
Visual C++
public:
vSizeType()

See Also

vSizeType Class
vSizeType Overload


vSizeType Constructor (Size, SizeUnitType)

[image]

VIBlend Controls for WinForms Help Documentation
vSizeType Constructor (Size, SizeUnitType)
vSizeType Class See Also Send Feedback
Initializes a new instance of the [!:SizeType] class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vSizeType(
    Size size,
    SizeUnitType sizeType
)
Visual Basic
Public Sub New ( _
    size As Size, _
    sizeType As SizeUnitType _
)
Visual C++
public:
vSizeType(
    Size size,
    SizeUnitType sizeType
)

Parameters

size
Type: System.Drawing..::..Size
The size.
sizeType
Type: VIBlend.WinForms.Controls..::..SizeUnitType
Type of the size.

See Also

vSizeType Class
vSizeType Overload


vSizeType Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizeType Methods
vSizeType Class See Also Send Feedback

The vSizeType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vSizeType Class


vSizeType Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizeType Properties
vSizeType Class See Also Send Feedback

The vSizeType type exposes the following members.

Properties

 | Name | Description
Public property | Size | Gets or sets the size.
Public property | UnitType | Gets or sets the type of the size.

See Also

vSizeType Class


Size Property

[image]

VIBlend Controls for WinForms Help Documentation
vSizeType..::..Size Property
vSizeType Class See Also Send Feedback
Gets or sets the size.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Size Size { get; set; }
Visual Basic
Public Property Size As Size
    Get
    Set
Visual C++
public:
property Size Size {
    Size get ();
    void set (Size value);
}

Field Value

The size.

See Also

vSizeType Class


UnitType Property

[image]

VIBlend Controls for WinForms Help Documentation
vSizeType..::..UnitType Property
vSizeType Class See Also Send Feedback
Gets or sets the type of the size.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public SizeUnitType UnitType { get; set; }
Visual Basic
Public Property UnitType As SizeUnitType
    Get
    Set
Visual C++
public:
property SizeUnitType UnitType {
    SizeUnitType get ();
    void set (SizeUnitType value);
}

Field Value

The type of the size.

See Also

vSizeType Class


vSizingControl Class

[image]

VIBlend Controls for WinForms Help Documentation
vSizingControl Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vSizingControl : Control
Visual Basic
Public Class vSizingControl _
    Inherits Control
Visual C++
public ref class vSizingControl : public Control

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vSizingControl

See Also

vSizingControl Members


vSizingControl Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl Members
vSizingControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The vSizingControl type exposes the following members.

Constructors

 | Name | Description
Public method | vSizingControl()()()() | Initializes a new instance of the vSizingControl class.
Public method | vSizingControl(Control) | Initializes a new instance of the vSizingControl class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Overrides Control..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Public field | PreferredBounds |
Public field | resizeLocation |
Public field | resizeSize |

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackGroundFill | Gets the back ground fill.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SizingDirection | Gets or sets the sizing direction.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vSizingControl Class


vSizingControl Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl Constructor
vSizingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | vSizingControl()()()() | Initializes a new instance of the vSizingControl class.
Public method | vSizingControl(Control) | Initializes a new instance of the vSizingControl class.

See Also

vSizingControl Class
vSizingControl Members


vSizingControl Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vSizingControl Constructor
vSizingControl Class See Also Send Feedback
Initializes a new instance of the vSizingControl class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vSizingControl()
Visual Basic
Public Sub New
Visual C++
public:
vSizingControl()

See Also

vSizingControl Class
vSizingControl Overload


vSizingControl Constructor (Control)

[image]

VIBlend Controls for WinForms Help Documentation
vSizingControl Constructor (Control)
vSizingControl Class See Also Send Feedback
Initializes a new instance of the vSizingControl class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vSizingControl(
    Control control
)
Visual Basic
Public Sub New ( _
    control As Control _
)
Visual C++
public:
vSizingControl(
    Control^ control
)

Parameters

control
Type: System.Windows.Forms..::..Control
The control.

See Also

vSizingControl Class
vSizingControl Overload


vSizingControl Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl Fields
vSizingControl Class See Also Send Feedback

The vSizingControl type exposes the following members.

Fields

 | Name | Description
Public field | PreferredBounds |
Public field | resizeLocation |
Public field | resizeSize |

See Also

vSizingControl Class


PreferredBounds Field

[image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..PreferredBounds Field
vSizingControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle PreferredBounds
Visual Basic
Public PreferredBounds As Rectangle
Visual C++
public:
Rectangle PreferredBounds

See Also

vSizingControl Class


resizeLocation Field

[image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..resizeLocation Field
vSizingControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool resizeLocation
Visual Basic
Public resizeLocation As Boolean
Visual C++
public:
bool resizeLocation

See Also

vSizingControl Class


resizeSize Field

[image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..resizeSize Field
vSizingControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool resizeSize
Visual Basic
Public resizeSize As Boolean
Visual C++
public:
bool resizeSize

See Also

vSizingControl Class


vSizingControl Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl Methods
vSizingControl Class See Also Send Feedback

The vSizingControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Overrides Control..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vSizingControl Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..AccessibilityNotifyClients Method
vSizingControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vSizingControl Class
vSizingControl Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..BeginInvoke Method
vSizingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vSizingControl Class
vSizingControl Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..Dispose Method
vSizingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vSizingControl Class
vSizingControl Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..GetChildAtPoint Method
vSizingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vSizingControl Class
vSizingControl Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..Invalidate Method
vSizingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vSizingControl Class
vSizingControl Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..Invoke Method
vSizingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vSizingControl Class
vSizingControl Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..MemberwiseClone Method
vSizingControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vSizingControl Class
vSizingControl Members


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..OnMouseDown Method
vSizingControl Class See Also Send Feedback
Raises the MouseDown event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vSizingControl Class


OnMouseEnter Method

[image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..OnMouseEnter Method
vSizingControl Class See Also Send Feedback
Raises the MouseEnter event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseEnter(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseEnter ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseEnter(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vSizingControl Class


OnMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..OnMouseLeave Method
vSizingControl Class See Also Send Feedback
Raises the MouseLeave event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vSizingControl Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..OnMouseMove Method
vSizingControl Class See Also Send Feedback
Raises the MouseMove event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vSizingControl Class


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..OnMouseUp Method
vSizingControl Class See Also Send Feedback
Raises the MouseUp event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vSizingControl Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..OnPaint Method
vSizingControl Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vSizingControl Class


OnSizeChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..OnSizeChanged Method
vSizingControl Class See Also Send Feedback
Raises the SizeChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnSizeChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnSizeChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSizeChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vSizingControl Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..PerformLayout Method
vSizingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vSizingControl Class
vSizingControl Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..ResumeLayout Method
vSizingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vSizingControl Class
vSizingControl Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..RtlTranslateAlignment Method
vSizingControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vSizingControl Class
vSizingControl Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..Scale Method
vSizingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vSizingControl Class
vSizingControl Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..Select Method
vSizingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vSizingControl Class
vSizingControl Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..SetBounds Method
vSizingControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vSizingControl Class
vSizingControl Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..UpdateBounds Method
vSizingControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vSizingControl Class
vSizingControl Members


vSizingControl Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl Properties
vSizingControl Class See Also Send Feedback

The vSizingControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackGroundFill | Gets the back ground fill.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SizingDirection | Gets or sets the sizing direction.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vSizingControl Class


BackGroundFill Property

[image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..BackGroundFill Property
vSizingControl Class See Also Send Feedback
Gets the back ground fill.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BackgroundElement BackGroundFill { get; }
Visual Basic
Public ReadOnly Property BackGroundFill As BackgroundElement
    Get
Visual C++
public:
property BackgroundElement^ BackGroundFill {
    BackgroundElement^ get ();
}

Field Value

The back ground fill.

See Also

vSizingControl Class


SizingDirection Property

[image]

VIBlend Controls for WinForms Help Documentation
vSizingControl..::..SizingDirection Property
vSizingControl Class See Also Send Feedback
Gets or sets the sizing direction.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public SizingDirection SizingDirection { get; set; }
Visual Basic
Public Property SizingDirection As SizingDirection
    Get
    Set
Visual C++
public:
property SizingDirection SizingDirection {
    SizingDirection get ();
    void set (SizingDirection value);
}

Field Value

The sizing direction.

See Also

vSizingControl Class


vSizingControl Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSizingControl Events
vSizingControl Class See Also Send Feedback

The vSizingControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vSizingControl Class


vSplitButton Class

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton Class
Members See Also Send Feedback
Represents a vSplitButton control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vSplitButton : vButton,
    IScrollableControlBase
Visual Basic
Public Class vSplitButton _
    Inherits vButton _
    Implements IScrollableControlBase
Visual C++
public ref class vSplitButton : public vButton,
    IScrollableControlBase

Remarks

A vSplitButton is similar to a normal button, and in addition it contains a built-in drop-down menu.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ButtonBase
System.Windows.Forms..::..Button
VIBlend.WinForms.Controls..::..vButton
VIBlend.WinForms.Controls..::..vSplitButton

See Also

vSplitButton Members


vSplitButton Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton Members
vSplitButton Class Constructors Methods Fields Properties Events See Also Send Feedback

The vSplitButton type exposes the following members.

Constructors

 | Name | Description
Public method | vSplitButton | Initializes a new instance of the vSplitButton class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder | Draws the border. (Overrides vButton..::..DrawBorder(Graphics, ControlState, Rectangle).)
Protected method | DrawControl | Draws the control. (Overrides vButton..::..DrawControl(Graphics, Rectangle, ControlState, Boolean, Byte).)
Protected method | DrawFocusRectangle | (Inherited from vButton.)
Protected method | DrawImageAndText | (Inherited from vButton.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetContentRect | Gets the content rect.
 | GetContentRectangle | Gets the content rectangle.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect | (Inherited from vButton.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActionButtonClick | Called when the button is clicked.
Protected method | OnArrowButtonClick | Called when the arrow button is clicked.
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from vButton.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from vButton.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vButton.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides vButton..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides vButton..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event (Overrides vButton..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides vButton..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Override (Overrides vButton..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

Fields

 | Name | Description
Protected field | buttonBorderStyle | (Inherited from vButton.)
Protected field | opacity | (Inherited from vButton.)
Protected field | paintHelper | (Inherited from vButton.)
Protected field | theme | (Inherited from vButton.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vButton.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | ArrowUnderContent | Gets or sets the arrow position.
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | AutoSyncDropDownMenu | Gets or sets a value indicating whether to auto-sync the DropDownMenu. When the property is set to true, the clicked item's text is in sync with the button's text.
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button (Inherited from vButton.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu |
Public property | ContextMenuStrip |
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DrawArrowOnly | Gets or sets button's text alignment
Public property | DropDownButtonWidth | Gets or sets the width of the drop down button.
Public property | DropDownMenu | Gets or sets the drop down menu associated with the control
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Inherited from vButton.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled. (Inherited from vButton.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control. (Inherited from vButton.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity. (Inherited from vButton.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vButton.)
Public property | PaintDefaultBorder | (Overrides vButton..::..PaintDefaultBorder.)
Public property | PaintDefaultFill | (Overrides vButton..::..PaintDefaultFill.)
Public property | PaintDefaultStateBorder | Gets or sets a value indicating whether to paint a border
Public property | PaintDefaultStateFill | Gets or sets a value indicating whether to paint a background
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vButton.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded (Inherited from vButton.)
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control. (Inherited from vButton.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused (Inherited from vButton.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image (Inherited from vButton.)
Public property | StyleKey | Gets or sets the style key. (Inherited from vButton.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control. (Inherited from vButton.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable (Inherited from vButton.)
Public property | Theme | Gets or sets the theme of the control (Overrides vButton..::..Theme.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control. (Inherited from vButton.)
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control. (Inherited from vButton.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color. (Inherited from vButton.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vButton.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | ActionButtonClick | Occurs when the action button is clicked.
Public event | ArrowButtonClick | Occurs when the arrow button is clicked.
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vSplitButton Class


vSplitButton Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton Constructor
vSplitButton Class See Also Send Feedback
Initializes a new instance of the vSplitButton class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vSplitButton()
Visual Basic
Public Sub New
Visual C++
public:
vSplitButton()

See Also

vSplitButton Class


vSplitButton Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton Fields
vSplitButton Class See Also Send Feedback

The vSplitButton type exposes the following members.

Fields

 | Name | Description
Protected field | buttonBorderStyle | (Inherited from vButton.)
Protected field | opacity | (Inherited from vButton.)
Protected field | paintHelper | (Inherited from vButton.)
Protected field | theme | (Inherited from vButton.)

See Also

vSplitButton Class


vSplitButton Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton Methods
vSplitButton Class See Also Send Feedback

The vSplitButton type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder | Draws the border. (Overrides vButton..::..DrawBorder(Graphics, ControlState, Rectangle).)
Protected method | DrawControl | Draws the control. (Overrides vButton..::..DrawControl(Graphics, Rectangle, ControlState, Boolean, Byte).)
Protected method | DrawFocusRectangle | (Inherited from vButton.)
Protected method | DrawImageAndText | (Inherited from vButton.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetContentRect | Gets the content rect.
 | GetContentRectangle | Gets the content rectangle.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect | (Inherited from vButton.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActionButtonClick | Called when the button is clicked.
Protected method | OnArrowButtonClick | Called when the arrow button is clicked.
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from vButton.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from vButton.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vButton.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides vButton..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides vButton..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event (Overrides vButton..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides vButton..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Override (Overrides vButton..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

See Also

vSplitButton Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..AccessibilityNotifyClients Method
vSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vSplitButton Class
vSplitButton Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..BeginInvoke Method
vSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vSplitButton Class
vSplitButton Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..Dispose Method
vSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)

See Also

vSplitButton Class
vSplitButton Members


DrawBorder Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..DrawBorder Method
vSplitButton Class See Also Send Feedback
Draws the border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override Rectangle DrawBorder(
    Graphics graphics,
    ControlState controlState,
    Rectangle drawRect
)
Visual Basic
Protected Overrides Function DrawBorder ( _
    graphics As Graphics, _
    controlState As ControlState, _
    drawRect As Rectangle _
) As Rectangle
Visual C++
protected:
virtual Rectangle DrawBorder(
    Graphics^ graphics,
    ControlState controlState,
    Rectangle drawRect
) override

Parameters

graphics
Type: System.Drawing..::..Graphics
The graphics.
controlState
Type: ControlState
State of the control.
drawRect
Type: System.Drawing..::..Rectangle
The draw rect.

Return Value

See Also

vSplitButton Class


DrawControl Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..DrawControl Method
vSplitButton Class See Also Send Feedback
Draws the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void DrawControl(
    Graphics graphics,
    Rectangle bounds,
    ControlState controlState,
    bool isFocused,
    byte roundedCornersMask
)
Visual Basic
Protected Overrides Sub DrawControl ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    controlState As ControlState, _
    isFocused As Boolean, _
    roundedCornersMask As Byte _
)
Visual C++
protected:
virtual void DrawControl(
    Graphics^ graphics,
    Rectangle bounds,
    ControlState controlState,
    bool isFocused,
    unsigned char roundedCornersMask
) override

Parameters

graphics
Type: System.Drawing..::..Graphics
The graphics.
bounds
Type: System.Drawing..::..Rectangle
The bounds.
controlState
Type: ControlState
State of the control.
isFocused
Type: System..::..Boolean
if set to true [is focused].
roundedCornersMask
Type: System..::..Byte
The rounded corners mask.

See Also

vSplitButton Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..GetChildAtPoint Method
vSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vSplitButton Class
vSplitButton Members


GetContentRect Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..GetContentRect Method
vSplitButton Class See Also Send Feedback
Gets the content rect.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle GetContentRect()
Visual Basic
Public Function GetContentRect As Rectangle
Visual C++
public:
Rectangle GetContentRect()

Return Value

See Also

vSplitButton Class


GetContentRectangle Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..GetContentRectangle Method
vSplitButton Class See Also Send Feedback
Gets the content rectangle.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static Rectangle GetContentRectangle(
    vSplitButton button
)
Visual Basic
Public Shared Function GetContentRectangle ( _
    button As vSplitButton _
) As Rectangle
Visual C++
public:
static Rectangle GetContentRectangle(
    vSplitButton^ button
)

Parameters

button
Type: VIBlend.WinForms.Controls..::..vSplitButton
The button.

Return Value

See Also

vSplitButton Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..Invalidate Method
vSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vSplitButton Class
vSplitButton Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..Invoke Method
vSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vSplitButton Class
vSplitButton Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..MemberwiseClone Method
vSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vSplitButton Class
vSplitButton Members


OnActionButtonClick Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..OnActionButtonClick Method
vSplitButton Class See Also Send Feedback
Called when the button is clicked.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnActionButtonClick()
Visual Basic
Protected Overridable Sub OnActionButtonClick
Visual C++
protected:
virtual void OnActionButtonClick()

See Also

vSplitButton Class


OnArrowButtonClick Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..OnArrowButtonClick Method
vSplitButton Class See Also Send Feedback
Called when the arrow button is clicked.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnArrowButtonClick()
Visual Basic
Protected Overridable Sub OnArrowButtonClick
Visual C++
protected:
virtual void OnArrowButtonClick()

See Also

vSplitButton Class


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..OnMouseDown Method
vSplitButton Class See Also Send Feedback
Raises the MouseDown event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs args
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    args As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vSplitButton Class


OnMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..OnMouseLeave Method
vSplitButton Class See Also Send Feedback
Raises the MouseLeave event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
A EventArgs that contains the event data.

See Also

vSplitButton Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..OnMouseMove Method
vSplitButton Class See Also Send Feedback
Raises the MouseMove event

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs args
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    args As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vSplitButton Class


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..OnMouseUp Method
vSplitButton Class See Also Send Feedback
Raises the MouseUp event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vSplitButton Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..OnPaint Method
vSplitButton Class See Also Send Feedback
Override

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
PaintEventArgs

See Also

vSplitButton Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..PerformLayout Method
vSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vSplitButton Class
vSplitButton Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..ResumeLayout Method
vSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vSplitButton Class
vSplitButton Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..RtlTranslateAlignment Method
vSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vSplitButton Class
vSplitButton Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..Scale Method
vSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vSplitButton Class
vSplitButton Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..Select Method
vSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vSplitButton Class
vSplitButton Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..SetBounds Method
vSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vSplitButton Class
vSplitButton Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..UpdateBounds Method
vSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vSplitButton Class
vSplitButton Members


vSplitButton Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton Properties
vSplitButton Class See Also Send Feedback

The vSplitButton type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vButton.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | ArrowUnderContent | Gets or sets the arrow position.
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | AutoSyncDropDownMenu | Gets or sets a value indicating whether to auto-sync the DropDownMenu. When the property is set to true, the clicked item's text is in sync with the button's text.
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button (Inherited from vButton.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu |
Public property | ContextMenuStrip |
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DrawArrowOnly | Gets or sets button's text alignment
Public property | DropDownButtonWidth | Gets or sets the width of the drop down button.
Public property | DropDownMenu | Gets or sets the drop down menu associated with the control
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Inherited from vButton.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled. (Inherited from vButton.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control. (Inherited from vButton.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity. (Inherited from vButton.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vButton.)
Public property | PaintDefaultBorder | (Overrides vButton..::..PaintDefaultBorder.)
Public property | PaintDefaultFill | (Overrides vButton..::..PaintDefaultFill.)
Public property | PaintDefaultStateBorder | Gets or sets a value indicating whether to paint a border
Public property | PaintDefaultStateFill | Gets or sets a value indicating whether to paint a background
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vButton.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded (Inherited from vButton.)
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control. (Inherited from vButton.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused (Inherited from vButton.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image (Inherited from vButton.)
Public property | StyleKey | Gets or sets the style key. (Inherited from vButton.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control. (Inherited from vButton.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable (Inherited from vButton.)
Public property | Theme | Gets or sets the theme of the control (Overrides vButton..::..Theme.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control. (Inherited from vButton.)
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control. (Inherited from vButton.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color. (Inherited from vButton.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vButton.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vSplitButton Class


ArrowUnderContent Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..ArrowUnderContent Property
vSplitButton Class See Also Send Feedback
Gets or sets the arrow position.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ArrowUnderContent { get; set; }
Visual Basic
Public Property ArrowUnderContent As Boolean
    Get
    Set
Visual C++
public:
property bool ArrowUnderContent {
    bool get ();
    void set (bool value);
}

Field Value

The arrow position.

See Also

vSplitButton Class


AutoSyncDropDownMenu Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..AutoSyncDropDownMenu Property
vSplitButton Class See Also Send Feedback
Gets or sets a value indicating whether to auto-sync the DropDownMenu. When the property is set to true, the clicked item's text is in sync with the button's text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AutoSyncDropDownMenu { get; set; }
Visual Basic
Public Property AutoSyncDropDownMenu As Boolean
    Get
    Set
Visual C++
public:
property bool AutoSyncDropDownMenu {
    bool get ();
    void set (bool value);
}

See Also

vSplitButton Class


ContextMenu Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..ContextMenu Property
vSplitButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContextMenu ContextMenu { get; set; }
Visual Basic
Public Property ContextMenu As ContextMenu
    Get
    Set
Visual C++
public:
property ContextMenu^ ContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}

See Also

vSplitButton Class


ContextMenuStrip Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..ContextMenuStrip Property
vSplitButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContextMenuStrip ContextMenuStrip { get; set; }
Visual Basic
Public Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
Visual C++
public:
property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get ();
    void set (ContextMenuStrip^ value);
}

See Also

vSplitButton Class


DrawArrowOnly Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..DrawArrowOnly Property
vSplitButton Class See Also Send Feedback
Gets or sets button's text alignment

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool DrawArrowOnly { get; set; }
Visual Basic
Public Property DrawArrowOnly As Boolean
    Get
    Set
Visual C++
public:
property bool DrawArrowOnly {
    bool get ();
    void set (bool value);
}

See Also

vSplitButton Class


DropDownButtonWidth Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..DropDownButtonWidth Property
vSplitButton Class See Also Send Feedback
Gets or sets the width of the drop down button.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual int DropDownButtonWidth { get; set; }
Visual Basic
Public Overridable Property DropDownButtonWidth As Integer
    Get
    Set
Visual C++
public:
virtual property int DropDownButtonWidth {
    int get ();
    void set (int value);
}

Field Value

The width of the drop down button.

See Also

vSplitButton Class


DropDownMenu Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..DropDownMenu Property
vSplitButton Class See Also Send Feedback
Gets or sets the drop down menu associated with the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContextMenuStrip DropDownMenu { get; set; }
Visual Basic
Public Property DropDownMenu As ContextMenuStrip
    Get
    Set
Visual C++
public:
property ContextMenuStrip^ DropDownMenu {
    ContextMenuStrip^ get ();
    void set (ContextMenuStrip^ value);
}

See Also

vSplitButton Class


PaintDefaultBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..PaintDefaultBorder Property
vSplitButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override bool PaintDefaultBorder { get; set; }
Visual Basic
Public Overrides Property PaintDefaultBorder As Boolean
    Get
    Set
Visual C++
public:
virtual property bool PaintDefaultBorder {
    bool get () override;
    void set (bool value) override;
}

See Also

vSplitButton Class


PaintDefaultFill Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..PaintDefaultFill Property
vSplitButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override bool PaintDefaultFill { get; set; }
Visual Basic
Public Overrides Property PaintDefaultFill As Boolean
    Get
    Set
Visual C++
public:
virtual property bool PaintDefaultFill {
    bool get () override;
    void set (bool value) override;
}

See Also

vSplitButton Class


PaintDefaultStateBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..PaintDefaultStateBorder Property
vSplitButton Class See Also Send Feedback
Gets or sets a value indicating whether to paint a border

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintDefaultStateBorder { get; set; }
Visual Basic
Public Property PaintDefaultStateBorder As Boolean
    Get
    Set
Visual C++
public:
property bool PaintDefaultStateBorder {
    bool get ();
    void set (bool value);
}

Field Value

true if [paint border]; otherwise, false.

See Also

vSplitButton Class


PaintDefaultStateFill Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..PaintDefaultStateFill Property
vSplitButton Class See Also Send Feedback
Gets or sets a value indicating whether to paint a background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintDefaultStateFill { get; set; }
Visual Basic
Public Property PaintDefaultStateFill As Boolean
    Get
    Set
Visual C++
public:
property bool PaintDefaultStateFill {
    bool get ();
    void set (bool value);
}

Field Value

true if [paint fill]; otherwise, false.

See Also

vSplitButton Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..Theme Property
vSplitButton Class See Also Send Feedback
Gets or sets the theme of the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override ControlTheme Theme { get; set; }
Visual Basic
Public Overrides Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
virtual property ControlTheme^ Theme {
    ControlTheme^ get () override;
    void set (ControlTheme^ value) override;
}

Field Value

See Also

vSplitButton Class


vSplitButton Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitButton Events
vSplitButton Class See Also Send Feedback

The vSplitButton type exposes the following members.

Events

 | Name | Description
Public event | ActionButtonClick | Occurs when the action button is clicked.
Public event | ArrowButtonClick | Occurs when the arrow button is clicked.
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vSplitButton Class


ActionButtonClick Event

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..ActionButtonClick Event
vSplitButton Class See Also Send Feedback
Occurs when the action button is clicked.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ActionButtonClick
Visual Basic
Public Event ActionButtonClick As EventHandler
Visual C++
public:
 event EventHandler^ ActionButtonClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vSplitButton Class


ArrowButtonClick Event

[image]

VIBlend Controls for WinForms Help Documentation
vSplitButton..::..ArrowButtonClick Event
vSplitButton Class See Also Send Feedback
Occurs when the arrow button is clicked.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ArrowButtonClick
Visual Basic
Public Event ArrowButtonClick As EventHandler
Visual C++
public:
 event EventHandler^ ArrowButtonClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vSplitButton Class


vSplitContainer Class

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer Class
Members See Also Send Feedback
Represents a control consisting of a movable bar that divides a container's display area into two resizable panels.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vSplitContainer : SplitContainerBase,
    IScrollableControlBase
Visual Basic
Public Class vSplitContainer _
    Inherits SplitContainerBase _
    Implements IScrollableControlBase
Visual C++
public ref class vSplitContainer : public SplitContainerBase,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
VIBlend.WinForms.Controls..::..SplitContainerBase
VIBlend.WinForms.Controls..::..vSplitContainer

See Also

vSplitContainer Members


vSplitContainer Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer Members
vSplitContainer Class Constructors Methods Fields Properties Events See Also Send Feedback

The vSplitContainer type exposes the following members.

Constructors

 | Name | Description
Public method | vSplitContainer | Initializes a new instance of the vSplitContainer class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AddControl | Adds the control. (Overrides SplitContainerBase..::..AddControl(Control, vSizeType).)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | (Inherited from ContainerControl.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetControlSize | Gets the size of the control. (Overrides SplitContainerBase..::..GetControlSize(Control).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Protected method | InsertControl | Inserts the control. (Overrides SplitContainerBase..::..InsertControl(Int32, Control, vSizeType).)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | Maximize | Maximizes the specified control.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Overrides Control..::..OnControlAdded(ControlEventArgs).)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Overrides Control..::..OnControlRemoved(ControlEventArgs).)
Protected method | OnCreateControl | (Inherited from ContainerControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides ContainerControl..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RefreshSplitters | Refreshes the splitters. (Overrides SplitContainerBase..::..RefreshSplitters()()()().)
Protected method | RemoveControl | Removes the control. (Overrides SplitContainerBase..::..RemoveControl(Control).)
Protected method | RemoveControlAt | Removes the control at. (Overrides SplitContainerBase..::..RemoveControlAt(Int32).)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | Restore | Restores this instance.
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | ResumeSuspendedLayout | Resumes the suspended layout. (Overrides SplitContainerBase..::..ResumeSuspendedLayout(Boolean).)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Public method | SetControlSize | Sets the size of the control. (Overrides SplitContainerBase..::..SetControlSize(Control, vSizeType).)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | SuspendLayout(Boolean) | Suspends the layout. (Overrides SplitContainerBase..::..SuspendLayout(Boolean).)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | Causes all of the child controls within a control that support validation to validate their data. (Inherited from ContainerControl.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from ContainerControl.)
Protected method | WndProc | (Inherited from ContainerControl.)

Fields

 | Name | Description
Protected field | controlSize | (Inherited from SplitContainerBase.)
Protected field | orientation | (Inherited from SplitContainerBase.)
Protected field | theme |

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from ContainerControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from ContainerControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | Gets or sets the orientation. (Inherited from SplitContainerBase.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Panel1 | Gets the panel1.
Public property | Panel1MinSize | Gets or sets the minimum size of the first panel.
Public property | Panel2 | Gets the panel2.
Public property | Panel2MinSize | Gets or sets the minimum size of the second panel.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowSplitters | Gets or sets a value indicating whether to show splitters. (Inherited from SplitContainerBase.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SplitterDistance | Gets or sets the splitter distance.
Public property | SplitterSize | Gets or sets the size of the splitter. (Inherited from SplitContainerBase.)
Public property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from ContainerControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vSplitContainer Class


vSplitContainer Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer Constructor
vSplitContainer Class See Also Send Feedback
Initializes a new instance of the vSplitContainer class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vSplitContainer()
Visual Basic
Public Sub New
Visual C++
public:
vSplitContainer()

See Also

vSplitContainer Class


vSplitContainer Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer Fields
vSplitContainer Class See Also Send Feedback

The vSplitContainer type exposes the following members.

Fields

 | Name | Description
Protected field | controlSize | (Inherited from SplitContainerBase.)
Protected field | orientation | (Inherited from SplitContainerBase.)
Protected field | theme |

See Also

vSplitContainer Class


theme Field

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..theme Field
vSplitContainer Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected ControlTheme theme
Visual Basic
Protected theme As ControlTheme
Visual C++
protected:
ControlTheme^ theme

See Also

vSplitContainer Class


vSplitContainer Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer Methods
vSplitContainer Class See Also Send Feedback

The vSplitContainer type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AddControl | Adds the control. (Overrides SplitContainerBase..::..AddControl(Control, vSizeType).)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | (Inherited from ContainerControl.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetControlSize | Gets the size of the control. (Overrides SplitContainerBase..::..GetControlSize(Control).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Protected method | InsertControl | Inserts the control. (Overrides SplitContainerBase..::..InsertControl(Int32, Control, vSizeType).)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | Maximize | Maximizes the specified control.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Overrides Control..::..OnControlAdded(ControlEventArgs).)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Overrides Control..::..OnControlRemoved(ControlEventArgs).)
Protected method | OnCreateControl | (Inherited from ContainerControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides ContainerControl..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RefreshSplitters | Refreshes the splitters. (Overrides SplitContainerBase..::..RefreshSplitters()()()().)
Protected method | RemoveControl | Removes the control. (Overrides SplitContainerBase..::..RemoveControl(Control).)
Protected method | RemoveControlAt | Removes the control at. (Overrides SplitContainerBase..::..RemoveControlAt(Int32).)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | Restore | Restores this instance.
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | ResumeSuspendedLayout | Resumes the suspended layout. (Overrides SplitContainerBase..::..ResumeSuspendedLayout(Boolean).)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Public method | SetControlSize | Sets the size of the control. (Overrides SplitContainerBase..::..SetControlSize(Control, vSizeType).)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | SuspendLayout(Boolean) | Suspends the layout. (Overrides SplitContainerBase..::..SuspendLayout(Boolean).)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | Causes all of the child controls within a control that support validation to validate their data. (Inherited from ContainerControl.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from ContainerControl.)
Protected method | WndProc | (Inherited from ContainerControl.)

See Also

vSplitContainer Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..AccessibilityNotifyClients Method
vSplitContainer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vSplitContainer Class
vSplitContainer Members


AddControl Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..AddControl Method
vSplitContainer Class See Also Send Feedback
Adds the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void AddControl(
    Control control,
    vSizeType sizeType
)
Visual Basic
Protected Overrides Sub AddControl ( _
    control As Control, _
    sizeType As vSizeType _
)
Visual C++
protected:
virtual void AddControl(
    Control^ control,
    vSizeType^ sizeType
) override

Parameters

control
Type: System.Windows.Forms..::..Control
The control.
sizeType
Type: VIBlend.WinForms.Controls..::..vSizeType
Type of the size.

See Also

vSplitContainer Class


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..BeginInvoke Method
vSplitContainer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vSplitContainer Class
vSplitContainer Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..Dispose Method
vSplitContainer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

vSplitContainer Class
vSplitContainer Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..GetChildAtPoint Method
vSplitContainer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vSplitContainer Class
vSplitContainer Members


GetControlSize Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..GetControlSize Method
vSplitContainer Class See Also Send Feedback
Gets the size of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override vSizeType GetControlSize(
    Control control
)
Visual Basic
Public Overrides Function GetControlSize ( _
    control As Control _
) As vSizeType
Visual C++
public:
virtual vSizeType^ GetControlSize(
    Control^ control
) override

Parameters

control
Type: System.Windows.Forms..::..Control
The control.

Return Value

See Also

vSplitContainer Class


InsertControl Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..InsertControl Method
vSplitContainer Class See Also Send Feedback
Inserts the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void InsertControl(
    int index,
    Control control,
    vSizeType sizeType
)
Visual Basic
Protected Overrides Sub InsertControl ( _
    index As Integer, _
    control As Control, _
    sizeType As vSizeType _
)
Visual C++
protected:
virtual void InsertControl(
    int index,
    Control^ control,
    vSizeType^ sizeType
) override

Parameters

index
Type: System..::..Int32
The index.
control
Type: System.Windows.Forms..::..Control
The control.
sizeType
Type: VIBlend.WinForms.Controls..::..vSizeType
Type of the size.

See Also

vSplitContainer Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..Invalidate Method
vSplitContainer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vSplitContainer Class
vSplitContainer Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..Invoke Method
vSplitContainer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vSplitContainer Class
vSplitContainer Members


Maximize Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..Maximize Method
vSplitContainer Class See Also Send Feedback
Maximizes the specified control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Maximize(
    Control control
)
Visual Basic
Public Sub Maximize ( _
    control As Control _
)
Visual C++
public:
void Maximize(
    Control^ control
)

Parameters

control
Type: System.Windows.Forms..::..Control
The control.

See Also

vSplitContainer Class


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..MemberwiseClone Method
vSplitContainer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vSplitContainer Class
vSplitContainer Members


OnControlAdded Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..OnControlAdded Method
vSplitContainer Class See Also Send Feedback
Raises the ControlAdded event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnControlAdded(
    ControlEventArgs e
)
Visual Basic
Protected Overrides Sub OnControlAdded ( _
    e As ControlEventArgs _
)
Visual C++
protected:
virtual void OnControlAdded(
    ControlEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..ControlEventArgs
A ControlEventArgs that contains the event data.

See Also

vSplitContainer Class


OnControlRemoved Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..OnControlRemoved Method
vSplitContainer Class See Also Send Feedback
Raises the ControlRemoved event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnControlRemoved(
    ControlEventArgs e
)
Visual Basic
Protected Overrides Sub OnControlRemoved ( _
    e As ControlEventArgs _
)
Visual C++
protected:
virtual void OnControlRemoved(
    ControlEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..ControlEventArgs
A ControlEventArgs that contains the event data.

See Also

vSplitContainer Class


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..OnLayout Method
vSplitContainer Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs
A LayoutEventArgs that contains the event data.

See Also

vSplitContainer Class


OnSizeChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..OnSizeChanged Method
vSplitContainer Class See Also Send Feedback
Raises the SizeChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnSizeChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnSizeChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSizeChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vSplitContainer Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..PerformLayout Method
vSplitContainer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vSplitContainer Class
vSplitContainer Members


RefreshSplitters Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..RefreshSplitters Method
vSplitContainer Class See Also Send Feedback
Refreshes the splitters.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void RefreshSplitters()
Visual Basic
Protected Overrides Sub RefreshSplitters
Visual C++
protected:
virtual void RefreshSplitters() override

See Also

vSplitContainer Class


RemoveControl Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..RemoveControl Method
vSplitContainer Class See Also Send Feedback
Removes the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void RemoveControl(
    Control control
)
Visual Basic
Protected Overrides Sub RemoveControl ( _
    control As Control _
)
Visual C++
protected:
virtual void RemoveControl(
    Control^ control
) override

Parameters

control
Type: System.Windows.Forms..::..Control
The control.

See Also

vSplitContainer Class


RemoveControlAt Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..RemoveControlAt Method
vSplitContainer Class See Also Send Feedback
Removes the control at.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void RemoveControlAt(
    int index
)
Visual Basic
Protected Overrides Sub RemoveControlAt ( _
    index As Integer _
)
Visual C++
protected:
virtual void RemoveControlAt(
    int index
) override

Parameters

index
Type: System..::..Int32
The index.

See Also

vSplitContainer Class


Restore Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..Restore Method
vSplitContainer Class See Also Send Feedback
Restores this instance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Restore()
Visual Basic
Public Sub Restore
Visual C++
public:
void Restore()

See Also

vSplitContainer Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..ResumeLayout Method
vSplitContainer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vSplitContainer Class
vSplitContainer Members


ResumeSuspendedLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..ResumeSuspendedLayout Method
vSplitContainer Class See Also Send Feedback
Resumes the suspended layout.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void ResumeSuspendedLayout(
    bool resumeChildren
)
Visual Basic
Public Overrides Sub ResumeSuspendedLayout ( _
    resumeChildren As Boolean _
)
Visual C++
public:
virtual void ResumeSuspendedLayout(
    bool resumeChildren
) override

Parameters

resumeChildren
Type: System..::..Boolean
if set to true [resume children].

See Also

vSplitContainer Class


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..RtlTranslateAlignment Method
vSplitContainer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vSplitContainer Class
vSplitContainer Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..Scale Method
vSplitContainer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vSplitContainer Class
vSplitContainer Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..Select Method
vSplitContainer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

vSplitContainer Class
vSplitContainer Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..SetBounds Method
vSplitContainer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vSplitContainer Class
vSplitContainer Members


SetControlSize Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..SetControlSize Method
vSplitContainer Class See Also Send Feedback
Sets the size of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void SetControlSize(
    Control control,
    vSizeType sizeType
)
Visual Basic
Public Overrides Sub SetControlSize ( _
    control As Control, _
    sizeType As vSizeType _
)
Visual C++
public:
virtual void SetControlSize(
    Control^ control,
    vSizeType^ sizeType
) override

Parameters

control
Type: System.Windows.Forms..::..Control
The control.
sizeType
Type: VIBlend.WinForms.Controls..::..vSizeType
Type of the size.

See Also

vSplitContainer Class


SuspendLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..SuspendLayout Method
vSplitContainer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | SuspendLayout(Boolean) | Suspends the layout. (Overrides SplitContainerBase..::..SuspendLayout(Boolean).)

See Also

vSplitContainer Class
vSplitContainer Members


SuspendLayout Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..SuspendLayout Method (Boolean)
vSplitContainer Class See Also Send Feedback
Suspends the layout.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void SuspendLayout(
    bool suspendChildren
)
Visual Basic
Public Overrides Sub SuspendLayout ( _
    suspendChildren As Boolean _
)
Visual C++
public:
virtual void SuspendLayout(
    bool suspendChildren
) override

Parameters

suspendChildren
Type: System..::..Boolean
if set to true [suspend children].

See Also

vSplitContainer Class
SuspendLayout Overload


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..UpdateBounds Method
vSplitContainer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vSplitContainer Class
vSplitContainer Members


Validate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..Validate Method
vSplitContainer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

vSplitContainer Class
vSplitContainer Members


ValidateChildren Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..ValidateChildren Method
vSplitContainer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateChildren()()()() | Causes all of the child controls within a control that support validation to validate their data. (Inherited from ContainerControl.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from ContainerControl.)

See Also

vSplitContainer Class
vSplitContainer Members


vSplitContainer Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer Properties
vSplitContainer Class See Also Send Feedback

The vSplitContainer type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from ContainerControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from ContainerControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | Gets or sets the orientation. (Inherited from SplitContainerBase.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Panel1 | Gets the panel1.
Public property | Panel1MinSize | Gets or sets the minimum size of the first panel.
Public property | Panel2 | Gets the panel2.
Public property | Panel2MinSize | Gets or sets the minimum size of the second panel.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowSplitters | Gets or sets a value indicating whether to show splitters. (Inherited from SplitContainerBase.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SplitterDistance | Gets or sets the splitter distance.
Public property | SplitterSize | Gets or sets the size of the splitter. (Inherited from SplitContainerBase.)
Public property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vSplitContainer Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..AllowAnimations Property
vSplitContainer Class See Also Send Feedback
Determines whether to use animations

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vSplitContainer Class


Panel1 Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..Panel1 Property
vSplitContainer Class See Also Send Feedback
Gets the panel1.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vSplitterPanel Panel1 { get; }
Visual Basic
Public ReadOnly Property Panel1 As vSplitterPanel
    Get
Visual C++
public:
property vSplitterPanel^ Panel1 {
    vSplitterPanel^ get ();
}

Field Value

The panel1.

See Also

vSplitContainer Class


Panel1MinSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..Panel1MinSize Property
vSplitContainer Class See Also Send Feedback
Gets or sets the minimum size of the first panel.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Size Panel1MinSize { get; set; }
Visual Basic
Public Property Panel1MinSize As Size
    Get
    Set
Visual C++
public:
property Size Panel1MinSize {
    Size get ();
    void set (Size value);
}

See Also

vSplitContainer Class


Panel2 Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..Panel2 Property
vSplitContainer Class See Also Send Feedback
Gets the panel2.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vSplitterPanel Panel2 { get; }
Visual Basic
Public ReadOnly Property Panel2 As vSplitterPanel
    Get
Visual C++
public:
property vSplitterPanel^ Panel2 {
    vSplitterPanel^ get ();
}

Field Value

The panel2.

See Also

vSplitContainer Class


Panel2MinSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..Panel2MinSize Property
vSplitContainer Class See Also Send Feedback
Gets or sets the minimum size of the second panel.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Size Panel2MinSize { get; set; }
Visual Basic
Public Property Panel2MinSize As Size
    Get
    Set
Visual C++
public:
property Size Panel2MinSize {
    Size get ();
    void set (Size value);
}

Field Value

The size of the panel2 min.

See Also

vSplitContainer Class


SplitterDistance Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..SplitterDistance Property
vSplitContainer Class See Also Send Feedback
Gets or sets the splitter distance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int SplitterDistance { get; set; }
Visual Basic
Public Property SplitterDistance As Integer
    Get
    Set
Visual C++
public:
property int SplitterDistance {
    int get ();
    void set (int value);
}

Field Value

The splitter distance.

See Also

vSplitContainer Class


StyleKey Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..StyleKey Property
vSplitContainer Class See Also Send Feedback
Gets or sets the style key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual string StyleKey { get; set; }
Visual Basic
Public Overridable Property StyleKey As String
    Get
    Set
Visual C++
public:
virtual property String^ StyleKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The style key.

See Also

vSplitContainer Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..Theme Property
vSplitContainer Class See Also Send Feedback
Gets or sets the theme of the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ControlTheme Theme { get; set; }
Visual Basic
Public Overridable Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
virtual property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vSplitContainer Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer..::..VIBlendTheme Property
vSplitContainer Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vSplitContainer Class


vSplitContainer Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitContainer Events
vSplitContainer Class See Also Send Feedback

The vSplitContainer type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from ContainerControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vSplitContainer Class


vSplitterPanel Class

[image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vSplitterPanel : Panel
Visual Basic
Public Class vSplitterPanel _
    Inherits Panel
Visual C++
public ref class vSplitterPanel : public Panel

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..Panel
VIBlend.WinForms.Controls..::..vSplitterPanel

See Also

vSplitterPanel Members


vSplitterPanel Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel Members
vSplitterPanel Class Constructors Methods Properties Events See Also Send Feedback

The vSplitterPanel type exposes the following members.

Constructors

 | Name | Description
Public method | vSplitterPanel | Initializes a new instance of the vSplitterPanel class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ScrollableControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the color of the border.
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vSplitterPanel Class


vSplitterPanel Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel Constructor
vSplitterPanel Class See Also Send Feedback
Initializes a new instance of the vSplitterPanel class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vSplitterPanel()
Visual Basic
Public Sub New
Visual C++
public:
vSplitterPanel()

See Also

vSplitterPanel Class


vSplitterPanel Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel Methods
vSplitterPanel Class See Also Send Feedback

The vSplitterPanel type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ScrollableControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

See Also

vSplitterPanel Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel..::..AccessibilityNotifyClients Method
vSplitterPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vSplitterPanel Class
vSplitterPanel Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel..::..BeginInvoke Method
vSplitterPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vSplitterPanel Class
vSplitterPanel Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel..::..Dispose Method
vSplitterPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vSplitterPanel Class
vSplitterPanel Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel..::..GetChildAtPoint Method
vSplitterPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vSplitterPanel Class
vSplitterPanel Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel..::..Invalidate Method
vSplitterPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vSplitterPanel Class
vSplitterPanel Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel..::..Invoke Method
vSplitterPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vSplitterPanel Class
vSplitterPanel Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel..::..MemberwiseClone Method
vSplitterPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vSplitterPanel Class
vSplitterPanel Members


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel..::..OnPaint Method
vSplitterPanel Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vSplitterPanel Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel..::..PerformLayout Method
vSplitterPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vSplitterPanel Class
vSplitterPanel Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel..::..ResumeLayout Method
vSplitterPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vSplitterPanel Class
vSplitterPanel Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel..::..RtlTranslateAlignment Method
vSplitterPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vSplitterPanel Class
vSplitterPanel Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel..::..Scale Method
vSplitterPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vSplitterPanel Class
vSplitterPanel Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel..::..Select Method
vSplitterPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vSplitterPanel Class
vSplitterPanel Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel..::..SetBounds Method
vSplitterPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vSplitterPanel Class
vSplitterPanel Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel..::..UpdateBounds Method
vSplitterPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vSplitterPanel Class
vSplitterPanel Members


vSplitterPanel Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel Properties
vSplitterPanel Class See Also Send Feedback

The vSplitterPanel type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the color of the border.
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vSplitterPanel Class


BorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel..::..BorderColor Property
vSplitterPanel Class See Also Send Feedback
Gets or sets the color of the border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BorderColor { get; set; }
Visual Basic
Public Property BorderColor As Color
    Get
    Set
Visual C++
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the border.

See Also

vSplitterPanel Class


vSplitterPanel Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vSplitterPanel Events
vSplitterPanel Class See Also Send Feedback

The vSplitterPanel type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vSplitterPanel Class


vStripsRenderer Class

[image]

VIBlend Controls for WinForms Help Documentation
vStripsRenderer Class
Members See Also Send Feedback
Represents a vStripsRenderer component

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vStripsRenderer : Component
Visual Basic
Public Class vStripsRenderer _
    Inherits Component
Visual C++
public ref class vStripsRenderer : public Component

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
VIBlend.WinForms.Controls..::..vStripsRenderer

See Also

vStripsRenderer Members


vStripsRenderer Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vStripsRenderer Members
vStripsRenderer Class Constructors Methods Properties Events See Also Send Feedback

The vStripsRenderer type exposes the following members.

Constructors

 | Name | Description
Public method | vStripsRenderer()()()() | Initializes a new instance of the [!:vRendererComponent] class.
Public method | vStripsRenderer(IContainer) |

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | RenderedContextMenuStrip | Gets or sets the rendered context menu strip.
Public property | RenderedMenuStrip | Gets or sets the rendered menu strip.
Public property | RenderedStatusStrip | Gets or sets the rendered status strip.
Public property | RenderedToolStrip | Gets or sets the rendered tool strip.
Public property | Renderer | Gets or sets the renderer.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Theme | Gets or sets the theme.
Public property | VIBlendTheme | Gets or sets the VIblend theme.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

vStripsRenderer Class


vStripsRenderer Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
vStripsRenderer Constructor
vStripsRenderer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | vStripsRenderer()()()() | Initializes a new instance of the [!:vRendererComponent] class.
Public method | vStripsRenderer(IContainer) | Initializes a new instance of the vStripsRenderer class

See Also

vStripsRenderer Class
vStripsRenderer Members


vStripsRenderer Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vStripsRenderer Constructor
vStripsRenderer Class See Also Send Feedback
Initializes a new instance of the [!:vRendererComponent] class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vStripsRenderer()
Visual Basic
Public Sub New
Visual C++
public:
vStripsRenderer()

See Also

vStripsRenderer Class
vStripsRenderer Overload


vStripsRenderer Constructor (IContainer)

[image]

VIBlend Controls for WinForms Help Documentation
vStripsRenderer Constructor (IContainer)
vStripsRenderer Class See Also Send Feedback
Initializes a new instance of the vStripsRenderer class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vStripsRenderer(
    IContainer container
)
Visual Basic
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
vStripsRenderer(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::..IContainer

See Also

vStripsRenderer Class
vStripsRenderer Overload


vStripsRenderer Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vStripsRenderer Methods
vStripsRenderer Class See Also Send Feedback

The vStripsRenderer type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

vStripsRenderer Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vStripsRenderer..::..Dispose Method
vStripsRenderer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

vStripsRenderer Class
vStripsRenderer Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vStripsRenderer..::..MemberwiseClone Method
vStripsRenderer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vStripsRenderer Class
vStripsRenderer Members


vStripsRenderer Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vStripsRenderer Properties
vStripsRenderer Class See Also Send Feedback

The vStripsRenderer type exposes the following members.

Properties

 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | RenderedContextMenuStrip | Gets or sets the rendered context menu strip.
Public property | RenderedMenuStrip | Gets or sets the rendered menu strip.
Public property | RenderedStatusStrip | Gets or sets the rendered status strip.
Public property | RenderedToolStrip | Gets or sets the rendered tool strip.
Public property | Renderer | Gets or sets the renderer.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Theme | Gets or sets the theme.
Public property | VIBlendTheme | Gets or sets the VIblend theme.

See Also

vStripsRenderer Class


RenderedContextMenuStrip Property

[image]

VIBlend Controls for WinForms Help Documentation
vStripsRenderer..::..RenderedContextMenuStrip Property
vStripsRenderer Class See Also Send Feedback
Gets or sets the rendered context menu strip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContextMenuStrip RenderedContextMenuStrip { get; set; }
Visual Basic
Public Property RenderedContextMenuStrip As ContextMenuStrip
    Get
    Set
Visual C++
public:
property ContextMenuStrip^ RenderedContextMenuStrip {
    ContextMenuStrip^ get ();
    void set (ContextMenuStrip^ value);
}

See Also

vStripsRenderer Class


RenderedMenuStrip Property

[image]

VIBlend Controls for WinForms Help Documentation
vStripsRenderer..::..RenderedMenuStrip Property
vStripsRenderer Class See Also Send Feedback
Gets or sets the rendered menu strip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public MenuStrip RenderedMenuStrip { get; set; }
Visual Basic
Public Property RenderedMenuStrip As MenuStrip
    Get
    Set
Visual C++
public:
property MenuStrip^ RenderedMenuStrip {
    MenuStrip^ get ();
    void set (MenuStrip^ value);
}

See Also

vStripsRenderer Class


RenderedStatusStrip Property

[image]

VIBlend Controls for WinForms Help Documentation
vStripsRenderer..::..RenderedStatusStrip Property
vStripsRenderer Class See Also Send Feedback
Gets or sets the rendered status strip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public StatusStrip RenderedStatusStrip { get; set; }
Visual Basic
Public Property RenderedStatusStrip As StatusStrip
    Get
    Set
Visual C++
public:
property StatusStrip^ RenderedStatusStrip {
    StatusStrip^ get ();
    void set (StatusStrip^ value);
}

See Also

vStripsRenderer Class


RenderedToolStrip Property

[image]

VIBlend Controls for WinForms Help Documentation
vStripsRenderer..::..RenderedToolStrip Property
vStripsRenderer Class See Also Send Feedback
Gets or sets the rendered tool strip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ToolStrip RenderedToolStrip { get; set; }
Visual Basic
Public Property RenderedToolStrip As ToolStrip
    Get
    Set
Visual C++
public:
property ToolStrip^ RenderedToolStrip {
    ToolStrip^ get ();
    void set (ToolStrip^ value);
}

See Also

vStripsRenderer Class


Renderer Property

[image]

VIBlend Controls for WinForms Help Documentation
vStripsRenderer..::..Renderer Property
vStripsRenderer Class See Also Send Feedback
Gets or sets the renderer.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vToolStripProfessionalRenderer Renderer { get; set; }
Visual Basic
Public Property Renderer As vToolStripProfessionalRenderer
    Get
    Set
Visual C++
public:
property vToolStripProfessionalRenderer^ Renderer {
    vToolStripProfessionalRenderer^ get ();
    void set (vToolStripProfessionalRenderer^ value);
}

See Also

vStripsRenderer Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vStripsRenderer..::..Theme Property
vStripsRenderer Class See Also Send Feedback
Gets or sets the theme.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

Field Value

The theme.

See Also

vStripsRenderer Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vStripsRenderer..::..VIBlendTheme Property
vStripsRenderer Class See Also Send Feedback
Gets or sets the VIblend theme.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

Field Value

The VIblend theme.

See Also

vStripsRenderer Class


vStripsRenderer Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vStripsRenderer Events
vStripsRenderer Class See Also Send Feedback

The vStripsRenderer type exposes the following members.

Events

 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)

See Also

vStripsRenderer Class


vTabCancelEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
vTabCancelEventArgs Class
Members See Also Send Feedback
Represents a tab control cancel event arguments

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vTabCancelEventArgs : vTabEventArgs
Visual Basic
Public Class vTabCancelEventArgs _
    Inherits vTabEventArgs
Visual C++
public ref class vTabCancelEventArgs : public vTabEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..vTabEventArgs
VIBlend.WinForms.Controls..::..vTabCancelEventArgs

See Also

vTabCancelEventArgs Members


vTabCancelEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabCancelEventArgs Members
vTabCancelEventArgs Class Constructors Methods Properties See Also Send Feedback

The vTabCancelEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | vTabCancelEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets whether to cancel the event.
Public property | TabPage | Gets the drag source tab page. (Inherited from vTabEventArgs.)

See Also

vTabCancelEventArgs Class


vTabCancelEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vTabCancelEventArgs Constructor
vTabCancelEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTabCancelEventArgs(
    vTabPage page
)
Visual Basic
Public Sub New ( _
    page As vTabPage _
)
Visual C++
public:
vTabCancelEventArgs(
    vTabPage^ page
)

Parameters

page
Type: VIBlend.WinForms.Controls..::..vTabPage
Tab page associated with the event.

See Also

vTabCancelEventArgs Class


vTabCancelEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabCancelEventArgs Methods
vTabCancelEventArgs Class See Also Send Feedback

The vTabCancelEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vTabCancelEventArgs Class


vTabCancelEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabCancelEventArgs Properties
vTabCancelEventArgs Class See Also Send Feedback

The vTabCancelEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets whether to cancel the event.
Public property | TabPage | Gets the drag source tab page. (Inherited from vTabEventArgs.)

See Also

vTabCancelEventArgs Class


Cancel Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabCancelEventArgs..::..Cancel Property
vTabCancelEventArgs Class See Also Send Feedback
Gets or sets whether to cancel the event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic
Public Property Cancel As Boolean
    Get
    Set
Visual C++
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}

See Also

vTabCancelEventArgs Class


vTabControl Class

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vTabControl : Panel,
    IScrollableControlBase
Visual Basic
Public Class vTabControl _
    Inherits Panel _
    Implements IScrollableControlBase
Visual C++
public ref class vTabControl : public Panel,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..Panel
VIBlend.WinForms.Controls..::..vTabControl
VIBlend.WinForms.Controls..::..vRibbonBar

See Also

vTabControl Members


vTabControl Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl Members
vTabControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The vTabControl type exposes the following members.

Constructors

 | Name | Description
Public method | vTabControl | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the TabControl's DropDown.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | DeleteTabPage | Deletes the tab page.
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawCloseButton | Draws the close button.
Protected method | DrawContexts |
Public method | DrawDefaultTab |
Public method | DrawHighlightedTab |
Public method | DrawSelectedAndHighlightedTab |
Public method | DrawSelectedTab |
Protected method | DrawTab | Draws the tab.
Protected method | DrawTabImage |
Public method | DrawTabText(Graphics, vTabPage, Color, Rectangle) |
Public method | DrawTabText(Graphics, vTabPage, ControlState, Rectangle) |
Protected method | DrawTextLeftRotated | Draws the text left rotated.
Protected method | DrawTitleBackGround |
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureTabVisible | Call this function to ensure that a specific tab page is visible.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Protected method | GetPageRectangle |
Protected method | GetPagesByContext |
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest | Performs a hit test and returns the tab page at a specific point.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawTabControlTitle | Raises the [E:DrawTabControlTitle] event.
Protected method | OnDrawTabPage | Raises the [E:DrawTabPage] event.
Protected method | OnDrawTabPageBackground | Raises the [E:DrawTabPageBackground] event.
Protected method | OnDropDownStyleChanged | Raises the DropDownStyleChanged event.
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ScrollableControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | (Overrides Control..::..OnMouseDoubleClick(MouseEventArgs).)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | (Overrides ScrollableControl..::..OnMouseWheel(MouseEventArgs).)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPopupPaint |
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabMouseDown | Raises the [E:TabMouseDown] event.
Protected method | OnTabMouseUp | Raises the [E:TabMouseUp] event.
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnToolTipShown |
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | (Overrides Control..::..OnValidating(CancelEventArgs).)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | OpenDropDown | Opens the TabControl's popup.
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Public method | UpdateScrollbars | Updates the scrollbars.
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

Fields

 | Name | Description
Protected field | allowAnimations |
Protected field | backGround |
Protected field | dropDown |
Protected field | dropDownPosition |
Protected field | dropDownSize |
Protected field | otherControls |
Protected field | paintHelper |

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDeleteOnMiddleMouseButton | Gets or sets whether the tab is closed on mouse wheel button click
Public property | AllowDragDrop | Gets or sets whether drag and drop is enabled.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowScrollingAnimation | Gets or sets a value indicating whether scrolling animation is enabled
Public property | AllPagesHeight | Gets or sets the height of all pages.
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor |
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ContextTabsOffset | Gets or sets the context tabs offset.
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | CornerRadius | Get or sets the rounding radius when the TabsShape property is set to RoundedCorners.
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableCloseButtons | Gets or sets whether the close buttons are enabled.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableDropDownStyle | Gets or sets a value indicating whether drop down style is enabled.
Public property | EnableToolTips | Gets or sets a value indicating whether tool tips are enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FitTabsToBounds | Gets or sets whether tab pages should fit to control's bounds
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImageList | Gets or sets the image list associated to the tab control.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the selected tab in the tab control.
Public property | SelectedTab | Gets or sets the selected tab in the tab control.
Public property | ShowCloseButtonOnSelectedTabOnly | Gets or sets a value indicating whether to display the close button only when the TabPage is selected.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when a tab is focused.
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabAlignment | Gets or sets the tab pages alignment.
Public property | TabContexts | Gets or sets the tab contexts.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabPages | Gets the tab pages collection of the vTabControl.
Public property | TabsAreaBackColor | Gets or sets the BackColor of vTabControl Tabs area.
Public property | TabsAreaBorderColor | Gets or sets the BackColor of vTabControl Tabs area.
Public property | TabsInitialOffset | Gets or sets the initial offset for the tab pages.
Public property | TabsShape | Gets or sets the tabs shape.
Public property | TabsSpacing | Gets or sets the spacing between the tab pages.
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | TextOrientation | Gets or sets text orientation of the tab pages.
Public property | Theme | Gets or sets the theme of the control.
Public property | TitleHeight | Determines the height of the title area which holds the tab pages
Public property | ToolTipDuration | Gets or sets the duration of the tool tip.
Public property | ToolTipShowDelay | Gets or sets the tool tip show delay.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseTabsAreaBackColor | Gets or sets a value indicating whether to use the TabsAreaBackColor
Public property | UseTabsAreaBorderColor | Gets or sets a value indicating whether to use the TabsAreaBorderColor
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawTabPage | Occurs when a TabPage is rendered.
Public event | DrawTabPageBackground | Occurs when a TabPage is rendered.
Public event | DrawTitleBackground | Occurs when the Title is rendered.
Public event | DropDownStyleChanged | Occurs when the EnableDropDownStyle property is changed.
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HoveredTabChanged | Occurs when the HoveredTab has changed.
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PopupPaint | Occurs when popup panel is painted.
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property has changed.
Public event | SelectedIndexChanging | Occurs when the selected index is about to change
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabMouseDown | Occurs when the mouse button is clicked over a tab.
Public event | TabMouseUp | Occurs when the mouse button is clicked over a tab.
Public event | TabPageDragEnded | Occurs when a tab page drag has ended
Public event | TabPageDragEnding | Occurs when a tab page drag is about to end
Public event | TabPageDragStarted | Occurs when a tab page drag has started
Public event | TabPageDragStarting | Occurs when a tab page drag is about to start
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | TitleClick | Occurs when the users clicks in the Title area
Public event | TooltipShow | Occurs when tooltip shows.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vTabControl Class


vTabControl Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl Constructor
vTabControl Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTabControl()
Visual Basic
Public Sub New
Visual C++
public:
vTabControl()

See Also

vTabControl Class


vTabControl Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl Fields
vTabControl Class See Also Send Feedback

The vTabControl type exposes the following members.

Fields

 | Name | Description
Protected field | allowAnimations |
Protected field | backGround |
Protected field | dropDown |
Protected field | dropDownPosition |
Protected field | dropDownSize |
Protected field | otherControls |
Protected field | paintHelper |

See Also

vTabControl Class


allowAnimations Field

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..allowAnimations Field
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected bool allowAnimations
Visual Basic
Protected allowAnimations As Boolean
Visual C++
protected:
bool allowAnimations

See Also

vTabControl Class


backGround Field

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..backGround Field
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected BackgroundElement backGround
Visual Basic
Protected backGround As BackgroundElement
Visual C++
protected:
BackgroundElement^ backGround

See Also

vTabControl Class


dropDown Field

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..dropDown Field
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected ToolStripDropDown dropDown
Visual Basic
Protected dropDown As ToolStripDropDown
Visual C++
protected:
ToolStripDropDown^ dropDown

See Also

vTabControl Class


dropDownPosition Field

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..dropDownPosition Field
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected Point dropDownPosition
Visual Basic
Protected dropDownPosition As Point
Visual C++
protected:
Point dropDownPosition

See Also

vTabControl Class


dropDownSize Field

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..dropDownSize Field
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected Size dropDownSize
Visual Basic
Protected dropDownSize As Size
Visual C++
protected:
Size dropDownSize

See Also

vTabControl Class


otherControls Field

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..otherControls Field
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected int otherControls
Visual Basic
Protected otherControls As Integer
Visual C++
protected:
int otherControls

See Also

vTabControl Class


paintHelper Field

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..paintHelper Field
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected PaintHelper paintHelper
Visual Basic
Protected paintHelper As PaintHelper
Visual C++
protected:
PaintHelper^ paintHelper

See Also

vTabControl Class


vTabControl Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl Methods
vTabControl Class See Also Send Feedback

The vTabControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the TabControl's DropDown.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | DeleteTabPage | Deletes the tab page.
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawCloseButton | Draws the close button.
Protected method | DrawContexts |
Public method | DrawDefaultTab |
Public method | DrawHighlightedTab |
Public method | DrawSelectedAndHighlightedTab |
Public method | DrawSelectedTab |
Protected method | DrawTab | Draws the tab.
Protected method | DrawTabImage |
Public method | DrawTabText(Graphics, vTabPage, Color, Rectangle) |
Public method | DrawTabText(Graphics, vTabPage, ControlState, Rectangle) |
Protected method | DrawTextLeftRotated | Draws the text left rotated.
Protected method | DrawTitleBackGround |
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureTabVisible | Call this function to ensure that a specific tab page is visible.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Protected method | GetPageRectangle |
Protected method | GetPagesByContext |
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest | Performs a hit test and returns the tab page at a specific point.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawTabControlTitle | Raises the [E:DrawTabControlTitle] event.
Protected method | OnDrawTabPage | Raises the [E:DrawTabPage] event.
Protected method | OnDrawTabPageBackground | Raises the [E:DrawTabPageBackground] event.
Protected method | OnDropDownStyleChanged | Raises the DropDownStyleChanged event.
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ScrollableControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | (Overrides Control..::..OnMouseDoubleClick(MouseEventArgs).)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | (Overrides ScrollableControl..::..OnMouseWheel(MouseEventArgs).)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPopupPaint |
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabMouseDown | Raises the [E:TabMouseDown] event.
Protected method | OnTabMouseUp | Raises the [E:TabMouseUp] event.
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnToolTipShown |
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | (Overrides Control..::..OnValidating(CancelEventArgs).)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | OpenDropDown | Opens the TabControl's popup.
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Public method | UpdateScrollbars | Updates the scrollbars.
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

See Also

vTabControl Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..AccessibilityNotifyClients Method
vTabControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vTabControl Class
vTabControl Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..BeginInvoke Method
vTabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vTabControl Class
vTabControl Members


CloseDropDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..CloseDropDown Method
vTabControl Class See Also Send Feedback
Closes the TabControl's DropDown.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void CloseDropDown()
Visual Basic
Public Sub CloseDropDown
Visual C++
public:
void CloseDropDown()

See Also

vTabControl Class


DeleteTabPage Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DeleteTabPage Method
vTabControl Class See Also Send Feedback
Deletes the tab page.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DeleteTabPage(
    vTabPage page
)
Visual Basic
Public Sub DeleteTabPage ( _
    page As vTabPage _
)
Visual C++
public:
void DeleteTabPage(
    vTabPage^ page
)

Parameters

page
Type: VIBlend.WinForms.Controls..::..vTabPage
The page.

See Also

vTabControl Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..Dispose Method
vTabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vTabControl Class
vTabControl Members


DrawCloseButton Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DrawCloseButton Method
vTabControl Class See Also Send Feedback
Draws the close button.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DrawCloseButton(
    Graphics graphics,
    Rectangle bounds,
    Color color1,
    Color color2
)
Visual Basic
Protected Overridable Sub DrawCloseButton ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    color1 As Color, _
    color2 As Color _
)
Visual C++
protected:
virtual void DrawCloseButton(
    Graphics^ graphics,
    Rectangle bounds,
    Color color1,
    Color color2
)

Parameters

graphics
Type: System.Drawing..::..Graphics
The graphics.
bounds
Type: System.Drawing..::..Rectangle
The bounds.
color1
Type: System.Drawing..::..Color
The color1.
color2
Type: System.Drawing..::..Color
The color2.

See Also

vTabControl Class


DrawContexts Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DrawContexts Method
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DrawContexts(
    Graphics g
)
Visual Basic
Protected Overridable Sub DrawContexts ( _
    g As Graphics _
)
Visual C++
protected:
virtual void DrawContexts(
    Graphics^ g
)

Parameters

g
Type: System.Drawing..::..Graphics

See Also

vTabControl Class


DrawDefaultTab Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DrawDefaultTab Method
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void DrawDefaultTab(
    Graphics g,
    vTabPage page
)
Visual Basic
Public Overridable Sub DrawDefaultTab ( _
    g As Graphics, _
    page As vTabPage _
)
Visual C++
public:
virtual void DrawDefaultTab(
    Graphics^ g,
    vTabPage^ page
)

Parameters

g
Type: System.Drawing..::..Graphics
page
Type: VIBlend.WinForms.Controls..::..vTabPage

See Also

vTabControl Class


DrawHighlightedTab Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DrawHighlightedTab Method
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void DrawHighlightedTab(
    Graphics g,
    vTabPage page,
    byte roundedCornersBitmaskPage,
    ControlState tabState
)
Visual Basic
Public Overridable Sub DrawHighlightedTab ( _
    g As Graphics, _
    page As vTabPage, _
    roundedCornersBitmaskPage As Byte, _
    tabState As ControlState _
)
Visual C++
public:
virtual void DrawHighlightedTab(
    Graphics^ g,
    vTabPage^ page,
    unsigned char roundedCornersBitmaskPage,
    ControlState tabState
)

Parameters

g
Type: System.Drawing..::..Graphics
page
Type: VIBlend.WinForms.Controls..::..vTabPage
roundedCornersBitmaskPage
Type: System..::..Byte
tabState
Type: ControlState

See Also

vTabControl Class


DrawSelectedAndHighlightedTab Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DrawSelectedAndHighlightedTab Method
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void DrawSelectedAndHighlightedTab(
    Graphics g,
    vTabPage page,
    ref Rectangle pageRectangle,
    ref int pageRadius
)
Visual Basic
Public Overridable Sub DrawSelectedAndHighlightedTab ( _
    g As Graphics, _
    page As vTabPage, _
    ByRef pageRectangle As Rectangle, _
    ByRef pageRadius As Integer _
)
Visual C++
public:
virtual void DrawSelectedAndHighlightedTab(
    Graphics^ g,
    vTabPage^ page,
    Rectangle% pageRectangle,
    int% pageRadius
)

Parameters

g
Type: System.Drawing..::..Graphics
page
Type: VIBlend.WinForms.Controls..::..vTabPage
pageRectangle
Type: System.Drawing..::..Rectangle %
pageRadius
Type: System..::..Int32 %

See Also

vTabControl Class


DrawSelectedTab Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DrawSelectedTab Method
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void DrawSelectedTab(
    Graphics g,
    vTabPage page,
    ref Rectangle pageRectangle
)
Visual Basic
Public Overridable Sub DrawSelectedTab ( _
    g As Graphics, _
    page As vTabPage, _
    ByRef pageRectangle As Rectangle _
)
Visual C++
public:
virtual void DrawSelectedTab(
    Graphics^ g,
    vTabPage^ page,
    Rectangle% pageRectangle
)

Parameters

g
Type: System.Drawing..::..Graphics
page
Type: VIBlend.WinForms.Controls..::..vTabPage
pageRectangle
Type: System.Drawing..::..Rectangle %

See Also

vTabControl Class


DrawTab Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DrawTab Method
vTabControl Class See Also Send Feedback
Draws the tab.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DrawTab(
    Graphics g,
    vTabPage page
)
Visual Basic
Protected Overridable Sub DrawTab ( _
    g As Graphics, _
    page As vTabPage _
)
Visual C++
protected:
virtual void DrawTab(
    Graphics^ g,
    vTabPage^ page
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
page
Type: VIBlend.WinForms.Controls..::..vTabPage
The page.

See Also

vTabControl Class


DrawTabImage Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DrawTabImage Method
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DrawTabImage(
    Graphics g,
    vTabPage page,
    ref SizeF empty,
    int index,
    ref Rectangle rectangle2
)
Visual Basic
Protected Overridable Sub DrawTabImage ( _
    g As Graphics, _
    page As vTabPage, _
    ByRef empty As SizeF, _
    index As Integer, _
    ByRef rectangle2 As Rectangle _
)
Visual C++
protected:
virtual void DrawTabImage(
    Graphics^ g,
    vTabPage^ page,
    SizeF% empty,
    int index,
    Rectangle% rectangle2
)

Parameters

g
Type: System.Drawing..::..Graphics
page
Type: VIBlend.WinForms.Controls..::..vTabPage
empty
Type: System.Drawing..::..SizeF %
index
Type: System..::..Int32
rectangle2
Type: System.Drawing..::..Rectangle %

See Also

vTabControl Class


DrawTabText Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DrawTabText Method
vTabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawTabText(Graphics, vTabPage, Color, Rectangle) |
Public method | DrawTabText(Graphics, vTabPage, ControlState, Rectangle) |

See Also

vTabControl Class
vTabControl Members


DrawTabText Method (Graphics, vTabPage, Color, Rectangle)

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DrawTabText Method (Graphics, vTabPage, Color, Rectangle)
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Rectangle DrawTabText(
    Graphics g,
    vTabPage page,
    Color textColor,
    Rectangle layoutRectangle
)
Visual Basic
Public Overridable Function DrawTabText ( _
    g As Graphics, _
    page As vTabPage, _
    textColor As Color, _
    layoutRectangle As Rectangle _
) As Rectangle
Visual C++
public:
virtual Rectangle DrawTabText(
    Graphics^ g,
    vTabPage^ page,
    Color textColor,
    Rectangle layoutRectangle
)

Parameters

g
Type: System.Drawing..::..Graphics
page
Type: VIBlend.WinForms.Controls..::..vTabPage
textColor
Type: System.Drawing..::..Color
layoutRectangle
Type: System.Drawing..::..Rectangle

See Also

vTabControl Class
DrawTabText Overload


DrawTabText Method (Graphics, vTabPage, , Rectangle)

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DrawTabText Method (Graphics, vTabPage, , Rectangle)
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Rectangle DrawTabText(
    Graphics g,
    vTabPage page,
    ControlState tabState,
    Rectangle layoutRectangle
)
Visual Basic
Public Overridable Function DrawTabText ( _
    g As Graphics, _
    page As vTabPage, _
    tabState As ControlState, _
    layoutRectangle As Rectangle _
) As Rectangle
Visual C++
public:
virtual Rectangle DrawTabText(
    Graphics^ g,
    vTabPage^ page,
    ControlState tabState,
    Rectangle layoutRectangle
)

Parameters

g
Type: System.Drawing..::..Graphics
page
Type: VIBlend.WinForms.Controls..::..vTabPage
tabState
Type: ControlState
layoutRectangle
Type: System.Drawing..::..Rectangle

See Also

vTabControl Class
DrawTabText Overload


DrawTextLeftRotated Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DrawTextLeftRotated Method
vTabControl Class See Also Send Feedback
Draws the text left rotated.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DrawTextLeftRotated(
    Graphics g,
    Font f,
    Rectangle r,
    string text,
    SolidBrush brush,
    StringFormat format
)
Visual Basic
Protected Overridable Sub DrawTextLeftRotated ( _
    g As Graphics, _
    f As Font, _
    r As Rectangle, _
    text As String, _
    brush As SolidBrush, _
    format As StringFormat _
)
Visual C++
protected:
virtual void DrawTextLeftRotated(
    Graphics^ g,
    Font^ f,
    Rectangle r,
    String^ text,
    SolidBrush^ brush,
    StringFormat^ format
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
f
Type: System.Drawing..::..Font
The f.
r
Type: System.Drawing..::..Rectangle
The r.
text
Type: System..::..String
The text.
brush
Type: System.Drawing..::..SolidBrush
The brush.
format
Type: System.Drawing..::..StringFormat
The format.

See Also

vTabControl Class


DrawTitleBackGround Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DrawTitleBackGround Method
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DrawTitleBackGround(
    Graphics g
)
Visual Basic
Protected Overridable Sub DrawTitleBackGround ( _
    g As Graphics _
)
Visual C++
protected:
virtual void DrawTitleBackGround(
    Graphics^ g
)

Parameters

g
Type: System.Drawing..::..Graphics

See Also

vTabControl Class


EnsureTabVisible Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..EnsureTabVisible Method
vTabControl Class See Also Send Feedback
Call this function to ensure that a specific tab page is visible.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void EnsureTabVisible(
    vTabPage tabPage
)
Visual Basic
Public Sub EnsureTabVisible ( _
    tabPage As vTabPage _
)
Visual C++
public:
void EnsureTabVisible(
    vTabPage^ tabPage
)

Parameters

tabPage
Type: VIBlend.WinForms.Controls..::..vTabPage
vTabPage to make visible.

See Also

vTabControl Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..GetChildAtPoint Method
vTabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vTabControl Class
vTabControl Members


GetPageRectangle Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..GetPageRectangle Method
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal Rectangle GetPageRectangle(
    Graphics g,
    vTabPage page
)
Visual Basic
Protected Friend Function GetPageRectangle ( _
    g As Graphics, _
    page As vTabPage _
) As Rectangle
Visual C++
protected public:
Rectangle GetPageRectangle(
    Graphics^ g,
    vTabPage^ page
)

Parameters

g
Type: System.Drawing..::..Graphics
page
Type: VIBlend.WinForms.Controls..::..vTabPage

See Also

vTabControl Class


GetPagesByContext Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..GetPagesByContext Method
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected List<vTabPage> GetPagesByContext(
    TabContext context
)
Visual Basic
Protected Function GetPagesByContext ( _
    context As TabContext _
) As List(Of vTabPage)
Visual C++
protected:
List<vTabPage^>^ GetPagesByContext(
    TabContext^ context
)

Parameters

context
Type: VIBlend.WinForms.Controls..::..TabContext

See Also

vTabControl Class


HitTest Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..HitTest Method
vTabControl Class See Also Send Feedback
Performs a hit test and returns the tab page at a specific point.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTabPage HitTest(
    Point point
)
Visual Basic
Public Function HitTest ( _
    point As Point _
) As vTabPage
Visual C++
public:
vTabPage^ HitTest(
    Point point
)

Parameters

point
Type: System.Drawing..::..Point
Point where to perform the hit test.

Return Value

A vTabPage located at the hit test point. If there is no tab page at this location the method returns a null.

See Also

vTabControl Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..Invalidate Method
vTabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vTabControl Class
vTabControl Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..Invoke Method
vTabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vTabControl Class
vTabControl Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..MemberwiseClone Method
vTabControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vTabControl Class
vTabControl Members


OnDrawTabControlTitle Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..OnDrawTabControlTitle Method
vTabControl Class See Also Send Feedback
Raises the [E:DrawTabControlTitle] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnDrawTabControlTitle(
    DrawTabControlTitleEventArgs e
)
Visual Basic
Protected Overridable Sub OnDrawTabControlTitle ( _
    e As DrawTabControlTitleEventArgs _
)
Visual C++
protected:
virtual void OnDrawTabControlTitle(
    DrawTabControlTitleEventArgs^ e
)

Parameters

e
Type: DrawTabControlTitleEventArgs
The DrawTabControlTitleEventArgs instance containing the event data.

See Also

vTabControl Class


OnDrawTabPage Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..OnDrawTabPage Method
vTabControl Class See Also Send Feedback
Raises the [E:DrawTabPage] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnDrawTabPage(
    DrawTabPageEventArgs e
)
Visual Basic
Protected Overridable Sub OnDrawTabPage ( _
    e As DrawTabPageEventArgs _
)
Visual C++
protected:
virtual void OnDrawTabPage(
    DrawTabPageEventArgs^ e
)

Parameters

e
Type: DrawTabPageEventArgs
The DrawTabPageEventArgs instance containing the event data.

See Also

vTabControl Class


OnDrawTabPageBackground Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..OnDrawTabPageBackground Method
vTabControl Class See Also Send Feedback
Raises the [E:DrawTabPageBackground] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnDrawTabPageBackground(
    DrawTabPageEventArgs e
)
Visual Basic
Protected Friend Overridable Sub OnDrawTabPageBackground ( _
    e As DrawTabPageEventArgs _
)
Visual C++
protected public:
virtual void OnDrawTabPageBackground(
    DrawTabPageEventArgs^ e
)

Parameters

e
Type: DrawTabPageEventArgs
The DrawTabPageEventArgs instance containing the event data.

See Also

vTabControl Class


OnDropDownStyleChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..OnDropDownStyleChanged Method
vTabControl Class See Also Send Feedback
Raises the DropDownStyleChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnDropDownStyleChanged()
Visual Basic
Protected Overridable Sub OnDropDownStyleChanged
Visual C++
protected:
virtual void OnDropDownStyleChanged()

See Also

vTabControl Class


OnMouseDoubleClick Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..OnMouseDoubleClick Method
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDoubleClick(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDoubleClick ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDoubleClick(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vTabControl Class


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..OnMouseDown Method
vTabControl Class See Also Send Feedback
Raises the MouseDown event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vTabControl Class


OnMouseWheel Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..OnMouseWheel Method
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseWheel(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseWheel ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseWheel(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vTabControl Class


OnPopupPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..OnPopupPaint Method
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnPopupPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overridable Sub OnPopupPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPopupPaint(
    PaintEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vTabControl Class


OnTabMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..OnTabMouseDown Method
vTabControl Class See Also Send Feedback
Raises the [E:TabMouseDown] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnTabMouseDown(
    vTabMouseEventArgs args
)
Visual Basic
Protected Overridable Sub OnTabMouseDown ( _
    args As vTabMouseEventArgs _
)
Visual C++
protected:
virtual void OnTabMouseDown(
    vTabMouseEventArgs^ args
)

Parameters

args
Type: vTabMouseEventArgs
The vTabMouseEventArgs instance containing the event data.

See Also

vTabControl Class


OnTabMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..OnTabMouseUp Method
vTabControl Class See Also Send Feedback
Raises the [E:TabMouseUp] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnTabMouseUp(
    vTabMouseEventArgs args
)
Visual Basic
Protected Overridable Sub OnTabMouseUp ( _
    args As vTabMouseEventArgs _
)
Visual C++
protected:
virtual void OnTabMouseUp(
    vTabMouseEventArgs^ args
)

Parameters

args
Type: vTabMouseEventArgs
The vTabMouseEventArgs instance containing the event data.

See Also

vTabControl Class


OnToolTipShown Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..OnToolTipShown Method
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnToolTipShown(
    ToolTipEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnToolTipShown ( _
    args As ToolTipEventArgs _
)
Visual C++
protected public:
virtual void OnToolTipShown(
    ToolTipEventArgs^ args
)

Parameters

args
Type: ToolTipEventArgs

See Also

vTabControl Class


OnValidating Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..OnValidating Method
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnValidating(
    CancelEventArgs e
)
Visual Basic
Protected Overrides Sub OnValidating ( _
    e As CancelEventArgs _
)
Visual C++
protected:
virtual void OnValidating(
    CancelEventArgs^ e
) override

Parameters

e
Type: System.ComponentModel..::..CancelEventArgs

See Also

vTabControl Class


OpenDropDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..OpenDropDown Method
vTabControl Class See Also Send Feedback
Opens the TabControl's popup.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OpenDropDown()
Visual Basic
Public Sub OpenDropDown
Visual C++
public:
void OpenDropDown()

See Also

vTabControl Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..PerformLayout Method
vTabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vTabControl Class
vTabControl Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..ResumeLayout Method
vTabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vTabControl Class
vTabControl Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..RtlTranslateAlignment Method
vTabControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vTabControl Class
vTabControl Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..Scale Method
vTabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vTabControl Class
vTabControl Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..Select Method
vTabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vTabControl Class
vTabControl Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..SetBounds Method
vTabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vTabControl Class
vTabControl Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..UpdateBounds Method
vTabControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vTabControl Class
vTabControl Members


UpdateScrollbars Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..UpdateScrollbars Method
vTabControl Class See Also Send Feedback
Updates the scrollbars.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void UpdateScrollbars()
Visual Basic
Public Sub UpdateScrollbars
Visual C++
public:
void UpdateScrollbars()

See Also

vTabControl Class


vTabControl Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl Properties
vTabControl Class See Also Send Feedback

The vTabControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDeleteOnMiddleMouseButton | Gets or sets whether the tab is closed on mouse wheel button click
Public property | AllowDragDrop | Gets or sets whether drag and drop is enabled.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowScrollingAnimation | Gets or sets a value indicating whether scrolling animation is enabled
Public property | AllPagesHeight | Gets or sets the height of all pages.
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor |
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ContextTabsOffset | Gets or sets the context tabs offset.
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | CornerRadius | Get or sets the rounding radius when the TabsShape property is set to RoundedCorners.
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableCloseButtons | Gets or sets whether the close buttons are enabled.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableDropDownStyle | Gets or sets a value indicating whether drop down style is enabled.
Public property | EnableToolTips | Gets or sets a value indicating whether tool tips are enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FitTabsToBounds | Gets or sets whether tab pages should fit to control's bounds
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImageList | Gets or sets the image list associated to the tab control.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the selected tab in the tab control.
Public property | SelectedTab | Gets or sets the selected tab in the tab control.
Public property | ShowCloseButtonOnSelectedTabOnly | Gets or sets a value indicating whether to display the close button only when the TabPage is selected.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when a tab is focused.
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabAlignment | Gets or sets the tab pages alignment.
Public property | TabContexts | Gets or sets the tab contexts.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabPages | Gets the tab pages collection of the vTabControl.
Public property | TabsAreaBackColor | Gets or sets the BackColor of vTabControl Tabs area.
Public property | TabsAreaBorderColor | Gets or sets the BackColor of vTabControl Tabs area.
Public property | TabsInitialOffset | Gets or sets the initial offset for the tab pages.
Public property | TabsShape | Gets or sets the tabs shape.
Public property | TabsSpacing | Gets or sets the spacing between the tab pages.
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | TextOrientation | Gets or sets text orientation of the tab pages.
Public property | Theme | Gets or sets the theme of the control.
Public property | TitleHeight | Determines the height of the title area which holds the tab pages
Public property | ToolTipDuration | Gets or sets the duration of the tool tip.
Public property | ToolTipShowDelay | Gets or sets the tool tip show delay.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseTabsAreaBackColor | Gets or sets a value indicating whether to use the TabsAreaBackColor
Public property | UseTabsAreaBorderColor | Gets or sets a value indicating whether to use the TabsAreaBorderColor
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vTabControl Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..AllowAnimations Property
vTabControl Class See Also Send Feedback
Gets or sets whether the control is animated

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool AllowAnimations { get; set; }
Visual Basic
Public Overridable Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get ();
    void set (bool value);
}

See Also

vTabControl Class


AllowDeleteOnMiddleMouseButton Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..AllowDeleteOnMiddleMouseButton Property
vTabControl Class See Also Send Feedback
Gets or sets whether the tab is closed on mouse wheel button click

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowDeleteOnMiddleMouseButton { get; set; }
Visual Basic
Public Property AllowDeleteOnMiddleMouseButton As Boolean
    Get
    Set
Visual C++
public:
property bool AllowDeleteOnMiddleMouseButton {
    bool get ();
    void set (bool value);
}

See Also

vTabControl Class


AllowDragDrop Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..AllowDragDrop Property
vTabControl Class See Also Send Feedback
Gets or sets whether drag and drop is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool AllowDragDrop { get; set; }
Visual Basic
Public Overridable Property AllowDragDrop As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowDragDrop {
    bool get ();
    void set (bool value);
}

See Also

vTabControl Class


AllowScrollingAnimation Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..AllowScrollingAnimation Property
vTabControl Class See Also Send Feedback
Gets or sets a value indicating whether scrolling animation is enabled

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowScrollingAnimation { get; set; }
Visual Basic
Public Property AllowScrollingAnimation As Boolean
    Get
    Set
Visual C++
public:
property bool AllowScrollingAnimation {
    bool get ();
    void set (bool value);
}

See Also

vTabControl Class


AllPagesHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..AllPagesHeight Property
vTabControl Class See Also Send Feedback
Gets or sets the height of all pages.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual int AllPagesHeight { get; set; }
Visual Basic
Public Overridable Property AllPagesHeight As Integer
    Get
    Set
Visual C++
public:
virtual property int AllPagesHeight {
    int get ();
    void set (int value);
}

Field Value

The height of all pages.

See Also

vTabControl Class


BackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..BackColor Property
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BackColor { get; set; }
Visual Basic
Public Property BackColor As Color
    Get
    Set
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}

See Also

vTabControl Class


ContextTabsOffset Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..ContextTabsOffset Property
vTabControl Class See Also Send Feedback
Gets or sets the context tabs offset.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ContextTabsOffset { get; set; }
Visual Basic
Public Property ContextTabsOffset As Integer
    Get
    Set
Visual C++
public:
property int ContextTabsOffset {
    int get ();
    void set (int value);
}

Field Value

The context tabs offset.

See Also

vTabControl Class


CornerRadius Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..CornerRadius Property
vTabControl Class See Also Send Feedback
Get or sets the rounding radius when the TabsShape property is set to RoundedCorners.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int CornerRadius { get; set; }
Visual Basic
Public Property CornerRadius As Integer
    Get
    Set
Visual C++
public:
property int CornerRadius {
    int get ();
    void set (int value);
}

See Also

vTabControl Class


EnableCloseButtons Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..EnableCloseButtons Property
vTabControl Class See Also Send Feedback
Gets or sets whether the close buttons are enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableCloseButtons { get; set; }
Visual Basic
Public Property EnableCloseButtons As Boolean
    Get
    Set
Visual C++
public:
property bool EnableCloseButtons {
    bool get ();
    void set (bool value);
}

See Also

vTabControl Class


EnableDropDownStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..EnableDropDownStyle Property
vTabControl Class See Also Send Feedback
Gets or sets a value indicating whether drop down style is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool EnableDropDownStyle { get; set; }
Visual Basic
Public Overridable Property EnableDropDownStyle As Boolean
    Get
    Set
Visual C++
public:
virtual property bool EnableDropDownStyle {
    bool get ();
    void set (bool value);
}

See Also

vTabControl Class


EnableToolTips Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..EnableToolTips Property
vTabControl Class See Also Send Feedback
Gets or sets a value indicating whether tool tips are enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool EnableToolTips { get; set; }
Visual Basic
Public Overridable Property EnableToolTips As Boolean
    Get
    Set
Visual C++
public:
virtual property bool EnableToolTips {
    bool get ();
    void set (bool value);
}

See Also

vTabControl Class


FitTabsToBounds Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..FitTabsToBounds Property
vTabControl Class See Also Send Feedback
Gets or sets whether tab pages should fit to control's bounds

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool FitTabsToBounds { get; set; }
Visual Basic
Public Overridable Property FitTabsToBounds As Boolean
    Get
    Set
Visual C++
public:
virtual property bool FitTabsToBounds {
    bool get ();
    void set (bool value);
}

See Also

vTabControl Class


ImageList Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..ImageList Property
vTabControl Class See Also Send Feedback
Gets or sets the image list associated to the tab control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ImageList ImageList { get; set; }
Visual Basic
Public Overridable Property ImageList As ImageList
    Get
    Set
Visual C++
public:
virtual property ImageList^ ImageList {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

vTabControl Class


SelectedIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..SelectedIndex Property
vTabControl Class See Also Send Feedback
Gets or sets the index of the selected tab in the tab control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic
Public Property SelectedIndex As Integer
    Get
    Set
Visual C++
public:
property int SelectedIndex {
    int get ();
    void set (int value);
}

See Also

vTabControl Class


SelectedTab Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..SelectedTab Property
vTabControl Class See Also Send Feedback
Gets or sets the selected tab in the tab control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTabPage SelectedTab { get; set; }
Visual Basic
Public Property SelectedTab As vTabPage
    Get
    Set
Visual C++
public:
property vTabPage^ SelectedTab {
    vTabPage^ get ();
    void set (vTabPage^ value);
}

See Also

vTabControl Class


ShowCloseButtonOnSelectedTabOnly Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..ShowCloseButtonOnSelectedTabOnly Property
vTabControl Class See Also Send Feedback
Gets or sets a value indicating whether to display the close button only when the TabPage is selected.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowCloseButtonOnSelectedTabOnly { get; set; }
Visual Basic
Public Property ShowCloseButtonOnSelectedTabOnly As Boolean
    Get
    Set
Visual C++
public:
property bool ShowCloseButtonOnSelectedTabOnly {
    bool get ();
    void set (bool value);
}

See Also

vTabControl Class


ShowFocusRectangle Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..ShowFocusRectangle Property
vTabControl Class See Also Send Feedback
Determines whether to show the focus rectangle when a tab is focused.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowFocusRectangle { get; set; }
Visual Basic
Public Property ShowFocusRectangle As Boolean
    Get
    Set
Visual C++
public:
property bool ShowFocusRectangle {
    bool get ();
    void set (bool value);
}

See Also

vTabControl Class


StyleKey Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..StyleKey Property
vTabControl Class See Also Send Feedback
Gets or sets the style key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual string StyleKey { get; set; }
Visual Basic
Protected Friend Overridable Property StyleKey As String
    Get
    Set
Visual C++
protected public:
virtual property String^ StyleKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The style key.

See Also

vTabControl Class


TabAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..TabAlignment Property
vTabControl Class See Also Send Feedback
Gets or sets the tab pages alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual vTabPageAlignment TabAlignment { get; set; }
Visual Basic
Public Overridable Property TabAlignment As vTabPageAlignment
    Get
    Set
Visual C++
public:
virtual property vTabPageAlignment TabAlignment {
    vTabPageAlignment get ();
    void set (vTabPageAlignment value);
}

See Also

vTabControl Class


TabContexts Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..TabContexts Property
vTabControl Class See Also Send Feedback
Gets or sets the tab contexts.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual List<TabContext> TabContexts { get; set; }
Visual Basic
Public Overridable Property TabContexts As List(Of TabContext)
    Get
    Set
Visual C++
public:
virtual property List<TabContext^>^ TabContexts {
    List<TabContext^>^ get ();
    void set (List<TabContext^>^ value);
}

Field Value

The tab context.

See Also

vTabControl Class


TabPages Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..TabPages Property
vTabControl Class See Also Send Feedback
Gets the tab pages collection of the vTabControl.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTabCollection TabPages { get; }
Visual Basic
Public ReadOnly Property TabPages As vTabCollection
    Get
Visual C++
public:
property vTabCollection^ TabPages {
    vTabCollection^ get ();
}

See Also

vTabControl Class


TabsAreaBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..TabsAreaBackColor Property
vTabControl Class See Also Send Feedback
Gets or sets the BackColor of vTabControl Tabs area.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Color TabsAreaBackColor { get; set; }
Visual Basic
Public Overridable Property TabsAreaBackColor As Color
    Get
    Set
Visual C++
public:
virtual property Color TabsAreaBackColor {
    Color get ();
    void set (Color value);
}

See Also

vTabControl Class


TabsAreaBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..TabsAreaBorderColor Property
vTabControl Class See Also Send Feedback
Gets or sets the BackColor of vTabControl Tabs area.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Color TabsAreaBorderColor { get; set; }
Visual Basic
Public Overridable Property TabsAreaBorderColor As Color
    Get
    Set
Visual C++
public:
virtual property Color TabsAreaBorderColor {
    Color get ();
    void set (Color value);
}

See Also

vTabControl Class


TabsInitialOffset Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..TabsInitialOffset Property
vTabControl Class See Also Send Feedback
Gets or sets the initial offset for the tab pages.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual int TabsInitialOffset { get; set; }
Visual Basic
Public Overridable Property TabsInitialOffset As Integer
    Get
    Set
Visual C++
public:
virtual property int TabsInitialOffset {
    int get ();
    void set (int value);
}

See Also

vTabControl Class


TabsShape Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..TabsShape Property
vTabControl Class See Also Send Feedback
Gets or sets the tabs shape.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public TabsShape TabsShape { get; set; }
Visual Basic
Public Property TabsShape As TabsShape
    Get
    Set
Visual C++
public:
property TabsShape TabsShape {
    TabsShape get ();
    void set (TabsShape value);
}

Field Value

The tabs shape.

See Also

vTabControl Class


TabsSpacing Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..TabsSpacing Property
vTabControl Class See Also Send Feedback
Gets or sets the spacing between the tab pages.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int TabsSpacing { get; set; }
Visual Basic
Public Property TabsSpacing As Integer
    Get
    Set
Visual C++
public:
property int TabsSpacing {
    int get ();
    void set (int value);
}

See Also

vTabControl Class


TextOrientation Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..TextOrientation Property
vTabControl Class See Also Send Feedback
Gets or sets text orientation of the tab pages.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual vTabPageTextOrientation TextOrientation { get; set; }
Visual Basic
Public Overridable Property TextOrientation As vTabPageTextOrientation
    Get
    Set
Visual C++
public:
virtual property vTabPageTextOrientation TextOrientation {
    vTabPageTextOrientation get ();
    void set (vTabPageTextOrientation value);
}

See Also

vTabControl Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..Theme Property
vTabControl Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ControlTheme Theme { get; set; }
Visual Basic
Public Overridable Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
virtual property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vTabControl Class


TitleHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..TitleHeight Property
vTabControl Class See Also Send Feedback
Determines the height of the title area which holds the tab pages

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual int TitleHeight { get; set; }
Visual Basic
Public Overridable Property TitleHeight As Integer
    Get
    Set
Visual C++
public:
virtual property int TitleHeight {
    int get ();
    void set (int value);
}

See Also

vTabControl Class


ToolTipDuration Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..ToolTipDuration Property
vTabControl Class See Also Send Feedback
Gets or sets the duration of the tool tip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ToolTipDuration { get; set; }
Visual Basic
Public Property ToolTipDuration As Integer
    Get
    Set
Visual C++
public:
property int ToolTipDuration {
    int get ();
    void set (int value);
}

Field Value

The duration of the tool tip.

See Also

vTabControl Class


ToolTipShowDelay Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..ToolTipShowDelay Property
vTabControl Class See Also Send Feedback
Gets or sets the tool tip show delay.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ToolTipShowDelay { get; set; }
Visual Basic
Public Property ToolTipShowDelay As Integer
    Get
    Set
Visual C++
public:
property int ToolTipShowDelay {
    int get ();
    void set (int value);
}

Field Value

The tool tip show delay.

See Also

vTabControl Class


UseTabsAreaBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..UseTabsAreaBackColor Property
vTabControl Class See Also Send Feedback
Gets or sets a value indicating whether to use the TabsAreaBackColor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool UseTabsAreaBackColor { get; set; }
Visual Basic
Public Overridable Property UseTabsAreaBackColor As Boolean
    Get
    Set
Visual C++
public:
virtual property bool UseTabsAreaBackColor {
    bool get ();
    void set (bool value);
}

See Also

vTabControl Class


UseTabsAreaBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..UseTabsAreaBorderColor Property
vTabControl Class See Also Send Feedback
Gets or sets a value indicating whether to use the TabsAreaBorderColor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool UseTabsAreaBorderColor { get; set; }
Visual Basic
Public Overridable Property UseTabsAreaBorderColor As Boolean
    Get
    Set
Visual C++
public:
virtual property bool UseTabsAreaBorderColor {
    bool get ();
    void set (bool value);
}

See Also

vTabControl Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..VIBlendTheme Property
vTabControl Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Overridable Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
virtual property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vTabControl Class


vTabControl Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabControl Events
vTabControl Class See Also Send Feedback

The vTabControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawTabPage | Occurs when a TabPage is rendered.
Public event | DrawTabPageBackground | Occurs when a TabPage is rendered.
Public event | DrawTitleBackground | Occurs when the Title is rendered.
Public event | DropDownStyleChanged | Occurs when the EnableDropDownStyle property is changed.
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HoveredTabChanged | Occurs when the HoveredTab has changed.
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PopupPaint | Occurs when popup panel is painted.
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property has changed.
Public event | SelectedIndexChanging | Occurs when the selected index is about to change
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabMouseDown | Occurs when the mouse button is clicked over a tab.
Public event | TabMouseUp | Occurs when the mouse button is clicked over a tab.
Public event | TabPageDragEnded | Occurs when a tab page drag has ended
Public event | TabPageDragEnding | Occurs when a tab page drag is about to end
Public event | TabPageDragStarted | Occurs when a tab page drag has started
Public event | TabPageDragStarting | Occurs when a tab page drag is about to start
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | TitleClick | Occurs when the users clicks in the Title area
Public event | TooltipShow | Occurs when tooltip shows.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vTabControl Class


DrawTabPage Event

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DrawTabPage Event
vTabControl Class See Also Send Feedback
Occurs when a TabPage is rendered.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<DrawTabPageEventArgs> DrawTabPage
Visual Basic
Public Event DrawTabPage As EventHandler(Of DrawTabPageEventArgs)
Visual C++
public:
 event EventHandler<DrawTabPageEventArgs^>^ DrawTabPage {
    void add (EventHandler<DrawTabPageEventArgs^>^ value);
    void remove (EventHandler<DrawTabPageEventArgs^>^ value);
}

See Also

vTabControl Class


DrawTabPageBackground Event

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DrawTabPageBackground Event
vTabControl Class See Also Send Feedback
Occurs when a TabPage is rendered.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<DrawTabPageEventArgs> DrawTabPageBackground
Visual Basic
Public Event DrawTabPageBackground As EventHandler(Of DrawTabPageEventArgs)
Visual C++
public:
 event EventHandler<DrawTabPageEventArgs^>^ DrawTabPageBackground {
    void add (EventHandler<DrawTabPageEventArgs^>^ value);
    void remove (EventHandler<DrawTabPageEventArgs^>^ value);
}

See Also

vTabControl Class


DrawTitleBackground Event

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DrawTitleBackground Event
vTabControl Class See Also Send Feedback
Occurs when the Title is rendered.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<DrawTabControlTitleEventArgs> DrawTitleBackground
Visual Basic
Public Event DrawTitleBackground As EventHandler(Of DrawTabControlTitleEventArgs)
Visual C++
public:
 event EventHandler<DrawTabControlTitleEventArgs^>^ DrawTitleBackground {
    void add (EventHandler<DrawTabControlTitleEventArgs^>^ value);
    void remove (EventHandler<DrawTabControlTitleEventArgs^>^ value);
}

See Also

vTabControl Class


DropDownStyleChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DropDownStyleChanged Event
vTabControl Class See Also Send Feedback
Occurs when the EnableDropDownStyle property is changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler DropDownStyleChanged
Visual Basic
Public Event DropDownStyleChanged As EventHandler
Visual C++
public:
 event EventHandler^ DropDownStyleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vTabControl Class


HoveredTabChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..HoveredTabChanged Event
vTabControl Class See Also Send Feedback
Occurs when the HoveredTab has changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTabControl..::..DragEventHandler HoveredTabChanged
Visual Basic
Public Event HoveredTabChanged As vTabControl..::..DragEventHandler
Visual C++
public:
 event vTabControl..::..DragEventHandler^ HoveredTabChanged {
    void add (vTabControl..::..DragEventHandler^ value);
    void remove (vTabControl..::..DragEventHandler^ value);
}

See Also

vTabControl Class


PopupPaint Event

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..PopupPaint Event
vTabControl Class See Also Send Feedback
Occurs when popup panel is painted.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event PaintEventHandler PopupPaint
Visual Basic
Public Event PopupPaint As PaintEventHandler
Visual C++
public:
 event PaintEventHandler^ PopupPaint {
    void add (PaintEventHandler^ value);
    void remove (PaintEventHandler^ value);
}

See Also

vTabControl Class


SelectedIndexChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..SelectedIndexChanged Event
vTabControl Class See Also Send Feedback
Occurs when the SelectedIndex property has changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler SelectedIndexChanged
Visual Basic
Public Event SelectedIndexChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectedIndexChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vTabControl Class


SelectedIndexChanging Event

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..SelectedIndexChanging Event
vTabControl Class See Also Send Feedback
Occurs when the selected index is about to change

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTabControl..::..vTabCancelEventHandler SelectedIndexChanging
Visual Basic
Public Event SelectedIndexChanging As vTabControl..::..vTabCancelEventHandler
Visual C++
public:
 event vTabControl..::..vTabCancelEventHandler^ SelectedIndexChanging {
    void add (vTabControl..::..vTabCancelEventHandler^ value);
    void remove (vTabControl..::..vTabCancelEventHandler^ value);
}

See Also

vTabControl Class


TabMouseDown Event

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..TabMouseDown Event
vTabControl Class See Also Send Feedback
Occurs when the mouse button is clicked over a tab.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<vTabMouseEventArgs> TabMouseDown
Visual Basic
Public Event TabMouseDown As EventHandler(Of vTabMouseEventArgs)
Visual C++
public:
 event EventHandler<vTabMouseEventArgs^>^ TabMouseDown {
    void add (EventHandler<vTabMouseEventArgs^>^ value);
    void remove (EventHandler<vTabMouseEventArgs^>^ value);
}

See Also

vTabControl Class


TabMouseUp Event

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..TabMouseUp Event
vTabControl Class See Also Send Feedback
Occurs when the mouse button is clicked over a tab.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<vTabMouseEventArgs> TabMouseUp
Visual Basic
Public Event TabMouseUp As EventHandler(Of vTabMouseEventArgs)
Visual C++
public:
 event EventHandler<vTabMouseEventArgs^>^ TabMouseUp {
    void add (EventHandler<vTabMouseEventArgs^>^ value);
    void remove (EventHandler<vTabMouseEventArgs^>^ value);
}

See Also

vTabControl Class


TabPageDragEnded Event

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..TabPageDragEnded Event
vTabControl Class See Also Send Feedback
Occurs when a tab page drag has ended

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTabControl..::..DragEventHandler TabPageDragEnded
Visual Basic
Public Event TabPageDragEnded As vTabControl..::..DragEventHandler
Visual C++
public:
 event vTabControl..::..DragEventHandler^ TabPageDragEnded {
    void add (vTabControl..::..DragEventHandler^ value);
    void remove (vTabControl..::..DragEventHandler^ value);
}

See Also

vTabControl Class


TabPageDragEnding Event

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..TabPageDragEnding Event
vTabControl Class See Also Send Feedback
Occurs when a tab page drag is about to end

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTabControl..::..DragCancelEventHandler TabPageDragEnding
Visual Basic
Public Event TabPageDragEnding As vTabControl..::..DragCancelEventHandler
Visual C++
public:
 event vTabControl..::..DragCancelEventHandler^ TabPageDragEnding {
    void add (vTabControl..::..DragCancelEventHandler^ value);
    void remove (vTabControl..::..DragCancelEventHandler^ value);
}

See Also

vTabControl Class


TabPageDragStarted Event

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..TabPageDragStarted Event
vTabControl Class See Also Send Feedback
Occurs when a tab page drag has started

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTabControl..::..DragEventHandler TabPageDragStarted
Visual Basic
Public Event TabPageDragStarted As vTabControl..::..DragEventHandler
Visual C++
public:
 event vTabControl..::..DragEventHandler^ TabPageDragStarted {
    void add (vTabControl..::..DragEventHandler^ value);
    void remove (vTabControl..::..DragEventHandler^ value);
}

See Also

vTabControl Class


TabPageDragStarting Event

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..TabPageDragStarting Event
vTabControl Class See Also Send Feedback
Occurs when a tab page drag is about to start

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTabControl..::..DragCancelEventHandler TabPageDragStarting
Visual Basic
Public Event TabPageDragStarting As vTabControl..::..DragCancelEventHandler
Visual C++
public:
 event vTabControl..::..DragCancelEventHandler^ TabPageDragStarting {
    void add (vTabControl..::..DragCancelEventHandler^ value);
    void remove (vTabControl..::..DragCancelEventHandler^ value);
}

See Also

vTabControl Class


TitleClick Event

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..TitleClick Event
vTabControl Class See Also Send Feedback
Occurs when the users clicks in the Title area

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler TitleClick
Visual Basic
Public Event TitleClick As EventHandler
Visual C++
public:
 event EventHandler^ TitleClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vTabControl Class


TooltipShow Event

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..TooltipShow Event
vTabControl Class See Also Send Feedback
Occurs when tooltip shows.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event ToolTipShownHandler TooltipShow
Visual Basic
Public Event TooltipShow As ToolTipShownHandler
Visual C++
public:
 event ToolTipShownHandler^ TooltipShow {
    void add (ToolTipShownHandler^ value);
    void remove (ToolTipShownHandler^ value);
}

See Also

vTabControl Class


vTabControl.DragCancelEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DragCancelEventHandler Delegate
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void DragCancelEventHandler(
    Object sender,
    DragCancelEventArgs e
)
Visual Basic
Public Delegate Sub DragCancelEventHandler ( _
    sender As Object, _
    e As DragCancelEventArgs _
)
Visual C++
public delegate void DragCancelEventHandler(
    Object^ sender,
    DragCancelEventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: VIBlend.WinForms.Controls..::..DragCancelEventArgs

See Also


vTabControl.DragEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..DragEventHandler Delegate
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void DragEventHandler(
    Object sender,
    vTabEventArgs e
)
Visual Basic
Public Delegate Sub DragEventHandler ( _
    sender As Object, _
    e As vTabEventArgs _
)
Visual C++
public delegate void DragEventHandler(
    Object^ sender,
    vTabEventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: VIBlend.WinForms.Controls..::..vTabEventArgs

See Also


vTabControl.vTabCancelEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vTabControl..::..vTabCancelEventHandler Delegate
vTabControl Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void vTabCancelEventHandler(
    Object sender,
    vTabCancelEventArgs e
)
Visual Basic
Public Delegate Sub vTabCancelEventHandler ( _
    sender As Object, _
    e As vTabCancelEventArgs _
)
Visual C++
public delegate void vTabCancelEventHandler(
    Object^ sender,
    vTabCancelEventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: VIBlend.WinForms.Controls..::..vTabCancelEventArgs

See Also


vTabEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
vTabEventArgs Class
Members See Also Send Feedback
Represent a vTabControl event arguments for drag and drop operations.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vTabEventArgs : EventArgs
Visual Basic
Public Class vTabEventArgs _
    Inherits EventArgs
Visual C++
public ref class vTabEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..vTabEventArgs
VIBlend.WinForms.Controls..::..DragCancelEventArgs
VIBlend.WinForms.Controls..::..vTabCancelEventArgs

See Also

vTabEventArgs Members


vTabEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabEventArgs Members
vTabEventArgs Class Constructors Methods Properties See Also Send Feedback

The vTabEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | vTabEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TabPage | Gets the drag source tab page.

See Also

vTabEventArgs Class


vTabEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vTabEventArgs Constructor
vTabEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTabEventArgs(
    vTabPage sourcePage
)
Visual Basic
Public Sub New ( _
    sourcePage As vTabPage _
)
Visual C++
public:
vTabEventArgs(
    vTabPage^ sourcePage
)

Parameters

sourcePage
Type: VIBlend.WinForms.Controls..::..vTabPage
Drag source tab page.

See Also

vTabEventArgs Class


vTabEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabEventArgs Methods
vTabEventArgs Class See Also Send Feedback

The vTabEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vTabEventArgs Class


vTabEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabEventArgs Properties
vTabEventArgs Class See Also Send Feedback

The vTabEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | TabPage | Gets the drag source tab page.

See Also

vTabEventArgs Class


TabPage Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabEventArgs..::..TabPage Property
vTabEventArgs Class See Also Send Feedback
Gets the drag source tab page.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTabPage TabPage { get; }
Visual Basic
Public ReadOnly Property TabPage As vTabPage
    Get
Visual C++
public:
property vTabPage^ TabPage {
    vTabPage^ get ();
}

See Also

vTabEventArgs Class


vTabPage Class

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage Class
Members See Also Send Feedback
Represents a tab page in the vTabControl

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vTabPage : Panel, IScrollableControlBase,
    INotifyPropertyChanged
Visual Basic
Public Class vTabPage _
    Inherits Panel _
    Implements IScrollableControlBase, INotifyPropertyChanged
Visual C++
public ref class vTabPage : public Panel,
    IScrollableControlBase, INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..Panel
VIBlend.WinForms.Controls..::..vTabPage

See Also

vTabPage Members


vTabPage Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage Members
vTabPage Class Constructors Methods Properties Events See Also Send Feedback

The vTabPage type exposes the following members.

Constructors

 | Name | Description
Public method | vTabPage()()()() | Constructor
Public method | vTabPage(String) | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPageRectange | Gets the page rectange.
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ScrollableControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged |
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | (Overrides Control..::..OnValidating(CancelEventArgs).)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Overrides Control..::..ResetFont()()()().)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Public method | UpdateTabControlLayout | Updates the tab control layout.
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentBackColor | Gets or sets a value of the ContentBackColor.
Public property | ContentBorderColor | Gets or sets a value of the ContentBorderColor.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets the page's dock style
Public property | DockPadding | Gets the DockPadding of the tab page
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableCloseButton | Gets or sets whether the close buttons is enabled.
Public property | Enabled | Gets or sets the Enabled property.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control.
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | HeaderBounds | Gets the header bounds.
Public property | HeaderHeight | Gets or sets the height of the header.
Public property | HeaderWidth | Gets or sets the width of the header.
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the color of the text.
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImageIndex | Gets or sets the index of the image displayed on the tab page.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | Invisible | Determines whether the tab page is visible.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsSelected | Gets a value indicating whether this instance is selected.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | LayoutPanel | Gets or sets the layout panel.
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultilineText | Gets or sets a value indicating whether this vTabControl is multiline.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets the Padding of the tab page.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the color of the text.
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedTextFont | Gets or sets the font of the text.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabContext | Gets or sets the tab context.
Public property | TabControl | Gets the tab control.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the tab page. (Overrides Panel..::..Text.)
Public property | TextAlignment | Gets or sets the text alignment.
Public property | TextColor | Gets or sets the color of the text.
Public property | TextFont | Gets or sets the font of the text.
Public property | TextImageRelation | Gets or sets the text image relation.
Public property | Theme | Gets or sets the theme of the tab page.
Public property | TooltipText | Gets or sets the tooltip text of the tab page.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseContentBackColor | Gets or sets a value indicating whether to use the ContentBackColor property.
Public property | UseContentBorderColor | Gets or sets a value indicating whether to use the content border color.
Public property | UseDefaultTextFont | Gets or sets a value indicating whether to use the theme text font.
Public property | UseTabControlTheme | Determines whether the TabPage will use the TabControl's theme or the value from its own Theme properties
Public property | UseTabPageSpecificThemeSetters | Gets or sets a value whether to use the tab page specific styles defined in the theme.
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets whether the content of the tab page is visible.
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property value changes.
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vTabPage Class


vTabPage Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage Constructor
vTabPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | vTabPage()()()() | Constructor
Public method | vTabPage(String) | Constructor

See Also

vTabPage Class
vTabPage Members


vTabPage Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage Constructor
vTabPage Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTabPage()
Visual Basic
Public Sub New
Visual C++
public:
vTabPage()

See Also

vTabPage Class
vTabPage Overload


vTabPage Constructor (String)

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage Constructor (String)
vTabPage Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTabPage(
    string text
)
Visual Basic
Public Sub New ( _
    text As String _
)
Visual C++
public:
vTabPage(
    String^ text
)

Parameters

text
Type: System..::..String
The text of the tab page

See Also

vTabPage Class
vTabPage Overload


vTabPage Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage Methods
vTabPage Class See Also Send Feedback

The vTabPage type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPageRectange | Gets the page rectange.
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ScrollableControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged |
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | (Overrides Control..::..OnValidating(CancelEventArgs).)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Overrides Control..::..ResetFont()()()().)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Public method | UpdateTabControlLayout | Updates the tab control layout.
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

See Also

vTabPage Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..AccessibilityNotifyClients Method
vTabPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vTabPage Class
vTabPage Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..BeginInvoke Method
vTabPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vTabPage Class
vTabPage Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..Dispose Method
vTabPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vTabPage Class
vTabPage Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..GetChildAtPoint Method
vTabPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vTabPage Class
vTabPage Members


GetPageRectange Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..GetPageRectange Method
vTabPage Class See Also Send Feedback
Gets the page rectange.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle GetPageRectange()
Visual Basic
Public Function GetPageRectange As Rectangle
Visual C++
public:
Rectangle GetPageRectange()

Return Value

See Also

vTabPage Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..Invalidate Method
vTabPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vTabPage Class
vTabPage Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..Invoke Method
vTabPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vTabPage Class
vTabPage Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..MemberwiseClone Method
vTabPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vTabPage Class
vTabPage Members


OnPropertyChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..OnPropertyChanged Method
vTabPage Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String

See Also

vTabPage Class


OnValidating Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..OnValidating Method
vTabPage Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnValidating(
    CancelEventArgs e
)
Visual Basic
Protected Overrides Sub OnValidating ( _
    e As CancelEventArgs _
)
Visual C++
protected:
virtual void OnValidating(
    CancelEventArgs^ e
) override

Parameters

e
Type: System.ComponentModel..::..CancelEventArgs

See Also

vTabPage Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..PerformLayout Method
vTabPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vTabPage Class
vTabPage Members


ResetFont Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..ResetFont Method
vTabPage Class See Also Send Feedback
Resets the Font property to its default value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void ResetFont()
Visual Basic
Public Overrides Sub ResetFont
Visual C++
public:
virtual void ResetFont() override

See Also

vTabPage Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..ResumeLayout Method
vTabPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vTabPage Class
vTabPage Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..RtlTranslateAlignment Method
vTabPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vTabPage Class
vTabPage Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..Scale Method
vTabPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vTabPage Class
vTabPage Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..Select Method
vTabPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vTabPage Class
vTabPage Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..SetBounds Method
vTabPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vTabPage Class
vTabPage Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..UpdateBounds Method
vTabPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vTabPage Class
vTabPage Members


UpdateTabControlLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..UpdateTabControlLayout Method
vTabPage Class See Also Send Feedback
Updates the tab control layout.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void UpdateTabControlLayout()
Visual Basic
Public Overridable Sub UpdateTabControlLayout
Visual C++
public:
virtual void UpdateTabControlLayout()

See Also

vTabPage Class


vTabPage Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage Properties
vTabPage Class See Also Send Feedback

The vTabPage type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentBackColor | Gets or sets a value of the ContentBackColor.
Public property | ContentBorderColor | Gets or sets a value of the ContentBorderColor.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets the page's dock style
Public property | DockPadding | Gets the DockPadding of the tab page
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableCloseButton | Gets or sets whether the close buttons is enabled.
Public property | Enabled | Gets or sets the Enabled property.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control.
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | HeaderBounds | Gets the header bounds.
Public property | HeaderHeight | Gets or sets the height of the header.
Public property | HeaderWidth | Gets or sets the width of the header.
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the color of the text.
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImageIndex | Gets or sets the index of the image displayed on the tab page.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | Invisible | Determines whether the tab page is visible.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsSelected | Gets a value indicating whether this instance is selected.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | LayoutPanel | Gets or sets the layout panel.
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultilineText | Gets or sets a value indicating whether this vTabControl is multiline.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets the Padding of the tab page.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the color of the text.
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedTextFont | Gets or sets the font of the text.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabContext | Gets or sets the tab context.
Public property | TabControl | Gets the tab control.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the tab page. (Overrides Panel..::..Text.)
Public property | TextAlignment | Gets or sets the text alignment.
Public property | TextColor | Gets or sets the color of the text.
Public property | TextFont | Gets or sets the font of the text.
Public property | TextImageRelation | Gets or sets the text image relation.
Public property | Theme | Gets or sets the theme of the tab page.
Public property | TooltipText | Gets or sets the tooltip text of the tab page.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseContentBackColor | Gets or sets a value indicating whether to use the ContentBackColor property.
Public property | UseContentBorderColor | Gets or sets a value indicating whether to use the content border color.
Public property | UseDefaultTextFont | Gets or sets a value indicating whether to use the theme text font.
Public property | UseTabControlTheme | Determines whether the TabPage will use the TabControl's theme or the value from its own Theme properties
Public property | UseTabPageSpecificThemeSetters | Gets or sets a value whether to use the tab page specific styles defined in the theme.
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets whether the content of the tab page is visible.
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vTabPage Class


ContentBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..ContentBackColor Property
vTabPage Class See Also Send Feedback
Gets or sets a value of the ContentBackColor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color ContentBackColor { get; set; }
Visual Basic
Public Property ContentBackColor As Color
    Get
    Set
Visual C++
public:
property Color ContentBackColor {
    Color get ();
    void set (Color value);
}

See Also

vTabPage Class


ContentBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..ContentBorderColor Property
vTabPage Class See Also Send Feedback
Gets or sets a value of the ContentBorderColor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color ContentBorderColor { get; set; }
Visual Basic
Public Property ContentBorderColor As Color
    Get
    Set
Visual C++
public:
property Color ContentBorderColor {
    Color get ();
    void set (Color value);
}

See Also

vTabPage Class


Dock Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..Dock Property
vTabPage Class See Also Send Feedback
Gets or sets the page's dock style

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DockStyle Dock { get; set; }
Visual Basic
Public Property Dock As DockStyle
    Get
    Set
Visual C++
public:
property DockStyle Dock {
    DockStyle get ();
    void set (DockStyle value);
}

See Also

vTabPage Class


DockPadding Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..DockPadding Property
vTabPage Class See Also Send Feedback
Gets the DockPadding of the tab page

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ScrollableControl..::..DockPaddingEdges DockPadding { get; }
Visual Basic
Public ReadOnly Property DockPadding As ScrollableControl..::..DockPaddingEdges
    Get
Visual C++
public:
property ScrollableControl..::..DockPaddingEdges^ DockPadding {
    ScrollableControl..::..DockPaddingEdges^ get ();
}

See Also

vTabPage Class


EnableCloseButton Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..EnableCloseButton Property
vTabPage Class See Also Send Feedback
Gets or sets whether the close buttons is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableCloseButton { get; set; }
Visual Basic
Public Property EnableCloseButton As Boolean
    Get
    Set
Visual C++
public:
property bool EnableCloseButton {
    bool get ();
    void set (bool value);
}

See Also

vTabPage Class


Enabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..Enabled Property
vTabPage Class See Also Send Feedback
Gets or sets the Enabled property.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

vTabPage Class


Font Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..Font Property
vTabPage Class See Also Send Feedback
Gets or sets the font of the text displayed by the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font Font { get; set; }
Visual Basic
Public Property Font As Font
    Get
    Set
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

Field Value

Return Value

The Font to apply to the text displayed by the control. The default is the value of the DefaultFont property.

See Also

vTabPage Class


HeaderBounds Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..HeaderBounds Property
vTabPage Class See Also Send Feedback
Gets the header bounds.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle HeaderBounds { get; }
Visual Basic
Public ReadOnly Property HeaderBounds As Rectangle
    Get
Visual C++
public:
property Rectangle HeaderBounds {
    Rectangle get ();
}

Field Value

The header bounds.

See Also

vTabPage Class


HeaderHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..HeaderHeight Property
vTabPage Class See Also Send Feedback
Gets or sets the height of the header.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Nullable<int> HeaderHeight { get; set; }
Visual Basic
Public Property HeaderHeight As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> HeaderHeight {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Field Value

The width of the header.

See Also

vTabPage Class


HeaderWidth Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..HeaderWidth Property
vTabPage Class See Also Send Feedback
Gets or sets the width of the header.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Nullable<int> HeaderWidth { get; set; }
Visual Basic
Public Property HeaderWidth As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> HeaderWidth {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Field Value

The width of the header.

See Also

vTabPage Class


HighlightTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..HighlightTextColor Property
vTabPage Class See Also Send Feedback
Gets or sets the color of the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color HighlightTextColor { get; set; }
Visual Basic
Public Property HighlightTextColor As Color
    Get
    Set
Visual C++
public:
property Color HighlightTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the text.

See Also

vTabPage Class


ImageIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..ImageIndex Property
vTabPage Class See Also Send Feedback
Gets or sets the index of the image displayed on the tab page.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual int ImageIndex { get; set; }
Visual Basic
Public Overridable Property ImageIndex As Integer
    Get
    Set
Visual C++
public:
virtual property int ImageIndex {
    int get ();
    void set (int value);
}

See Also

vTabPage Class


Invisible Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..Invisible Property
vTabPage Class See Also Send Feedback
Determines whether the tab page is visible.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Invisible { get; set; }
Visual Basic
Public Property Invisible As Boolean
    Get
    Set
Visual C++
public:
property bool Invisible {
    bool get ();
    void set (bool value);
}

See Also

vTabPage Class


IsSelected Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..IsSelected Property
vTabPage Class See Also Send Feedback
Gets a value indicating whether this instance is selected.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsSelected { get; }
Visual Basic
Public ReadOnly Property IsSelected As Boolean
    Get
Visual C++
public:
property bool IsSelected {
    bool get ();
}

Field Value

true if this instance is selected; otherwise, false.

See Also

vTabPage Class


LayoutPanel Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..LayoutPanel Property
vTabPage Class See Also Send Feedback
Gets or sets the layout panel.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vRibbonHorizontalLayoutPanel LayoutPanel { get; }
Visual Basic
Public ReadOnly Property LayoutPanel As vRibbonHorizontalLayoutPanel
    Get
Visual C++
public:
property vRibbonHorizontalLayoutPanel^ LayoutPanel {
    vRibbonHorizontalLayoutPanel^ get ();
}

Field Value

The layout panel.

See Also

vTabPage Class


MultilineText Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..MultilineText Property
vTabPage Class See Also Send Feedback
Gets or sets a value indicating whether this vTabControl is multiline.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool MultilineText { get; set; }
Visual Basic
Public Property MultilineText As Boolean
    Get
    Set
Visual C++
public:
property bool MultilineText {
    bool get ();
    void set (bool value);
}

Field Value

true if multiline; otherwise, false.

See Also

vTabPage Class


Padding Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..Padding Property
vTabPage Class See Also Send Feedback
Gets or sets the Padding of the tab page.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Padding Padding { get; set; }
Visual Basic
Public Property Padding As Padding
    Get
    Set
Visual C++
public:
property Padding Padding {
    Padding get ();
    void set (Padding value);
}

See Also

vTabPage Class


PressedTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..PressedTextColor Property
vTabPage Class See Also Send Feedback
Gets or sets the color of the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color PressedTextColor { get; set; }
Visual Basic
Public Property PressedTextColor As Color
    Get
    Set
Visual C++
public:
property Color PressedTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the text.

See Also

vTabPage Class


SelectedTextFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..SelectedTextFont Property
vTabPage Class See Also Send Feedback
Gets or sets the font of the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font SelectedTextFont { get; set; }
Visual Basic
Public Property SelectedTextFont As Font
    Get
    Set
Visual C++
public:
property Font^ SelectedTextFont {
    Font^ get ();
    void set (Font^ value);
}

Field Value

The color of the text.

See Also

vTabPage Class


StyleKey Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..StyleKey Property
vTabPage Class See Also Send Feedback
Gets or sets the style key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual string StyleKey { get; set; }
Visual Basic
Protected Friend Overridable Property StyleKey As String
    Get
    Set
Visual C++
protected public:
virtual property String^ StyleKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The style key.

See Also

vTabPage Class


TabContext Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..TabContext Property
vTabPage Class See Also Send Feedback
Gets or sets the tab context.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public TabContext TabContext { get; set; }
Visual Basic
Public Property TabContext As TabContext
    Get
    Set
Visual C++
public:
property TabContext^ TabContext {
    TabContext^ get ();
    void set (TabContext^ value);
}

Field Value

The tab context.

See Also

vTabPage Class


TabControl Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..TabControl Property
vTabPage Class See Also Send Feedback
Gets the tab control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTabControl TabControl { get; }
Visual Basic
Public ReadOnly Property TabControl As vTabControl
    Get
Visual C++
public:
property vTabControl^ TabControl {
    vTabControl^ get ();
}

Field Value

The tab control.

See Also

vTabPage Class


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..Text Property
vTabPage Class See Also Send Feedback
Gets or sets the text of the tab page.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string Text { get; set; }
Visual Basic
Public Overrides Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

See Also

vTabPage Class


TextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..TextAlignment Property
vTabPage Class See Also Send Feedback
Gets or sets the text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment TextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The text alignment.

See Also

vTabPage Class


TextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..TextColor Property
vTabPage Class See Also Send Feedback
Gets or sets the color of the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color TextColor { get; set; }
Visual Basic
Public Property TextColor As Color
    Get
    Set
Visual C++
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the text.

See Also

vTabPage Class


TextFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..TextFont Property
vTabPage Class See Also Send Feedback
Gets or sets the font of the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font TextFont { get; set; }
Visual Basic
Public Property TextFont As Font
    Get
    Set
Visual C++
public:
property Font^ TextFont {
    Font^ get ();
    void set (Font^ value);
}

Field Value

The color of the text.

See Also

vTabPage Class


TextImageRelation Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..TextImageRelation Property
vTabPage Class See Also Send Feedback
Gets or sets the text image relation.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public TextImageRelation TextImageRelation { get; set; }
Visual Basic
Public Property TextImageRelation As TextImageRelation
    Get
    Set
Visual C++
public:
property TextImageRelation TextImageRelation {
    TextImageRelation get ();
    void set (TextImageRelation value);
}

Field Value

The text image relation.

See Also

vTabPage Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..Theme Property
vTabPage Class See Also Send Feedback
Gets or sets the theme of the tab page.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vTabPage Class


TooltipText Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..TooltipText Property
vTabPage Class See Also Send Feedback
Gets or sets the tooltip text of the tab page.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string TooltipText { get; set; }
Visual Basic
Public Property TooltipText As String
    Get
    Set
Visual C++
public:
property String^ TooltipText {
    String^ get ();
    void set (String^ value);
}

See Also

vTabPage Class


UseContentBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..UseContentBackColor Property
vTabPage Class See Also Send Feedback
Gets or sets a value indicating whether to use the ContentBackColor property.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseContentBackColor { get; set; }
Visual Basic
Public Property UseContentBackColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseContentBackColor {
    bool get ();
    void set (bool value);
}

See Also

vTabPage Class


UseContentBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..UseContentBorderColor Property
vTabPage Class See Also Send Feedback
Gets or sets a value indicating whether to use the content border color.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseContentBorderColor { get; set; }
Visual Basic
Public Property UseContentBorderColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseContentBorderColor {
    bool get ();
    void set (bool value);
}

See Also

vTabPage Class


UseDefaultTextFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..UseDefaultTextFont Property
vTabPage Class See Also Send Feedback
Gets or sets a value indicating whether to use the theme text font.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseDefaultTextFont { get; set; }
Visual Basic
Public Property UseDefaultTextFont As Boolean
    Get
    Set
Visual C++
public:
property bool UseDefaultTextFont {
    bool get ();
    void set (bool value);
}

See Also

vTabPage Class


UseTabControlTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..UseTabControlTheme Property
vTabPage Class See Also Send Feedback
Determines whether the TabPage will use the TabControl's theme or the value from its own Theme properties

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseTabControlTheme { get; set; }
Visual Basic
Public Property UseTabControlTheme As Boolean
    Get
    Set
Visual C++
public:
property bool UseTabControlTheme {
    bool get ();
    void set (bool value);
}

See Also

vTabPage Class


UseTabPageSpecificThemeSetters Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..UseTabPageSpecificThemeSetters Property
vTabPage Class See Also Send Feedback
Gets or sets a value whether to use the tab page specific styles defined in the theme.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseTabPageSpecificThemeSetters { get; set; }
Visual Basic
Public Property UseTabPageSpecificThemeSetters As Boolean
    Get
    Set
Visual C++
public:
property bool UseTabPageSpecificThemeSetters {
    bool get ();
    void set (bool value);
}

See Also

vTabPage Class


UseThemeTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..UseThemeTextColor Property
vTabPage Class See Also Send Feedback
Gets or sets a value indicating whether to use the theme text color.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeTextColor { get; set; }
Visual Basic
Public Property UseThemeTextColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeTextColor {
    bool get ();
    void set (bool value);
}

See Also

vTabPage Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..VIBlendTheme Property
vTabPage Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vTabPage Class


Visible Property

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..Visible Property
vTabPage Class See Also Send Feedback
Gets or sets whether the content of the tab page is visible.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Visible { get; set; }
Visual Basic
Public Property Visible As Boolean
    Get
    Set
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

vTabPage Class


vTabPage Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTabPage Events
vTabPage Class See Also Send Feedback

The vTabPage type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property value changes.
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vTabPage Class


PropertyChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vTabPage..::..PropertyChanged Event
vTabPage Class See Also Send Feedback
Occurs when a property value changes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

vTabPage Class


vTabPageAlignment Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
vTabPageAlignment Enumeration
See Also Send Feedback
Enumerates the tab pages' alignment

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum vTabPageAlignment
Visual Basic
Public Enumeration vTabPageAlignment
Visual C++
public enum class vTabPageAlignment

Members

Member name | Description
Top |
Bottom |
Left |
Right |

See Also


vTabPageTextOrientation Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
vTabPageTextOrientation Enumeration
See Also Send Feedback
Enumerates the tab pages' text orientation

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum vTabPageTextOrientation
Visual Basic
Public Enumeration vTabPageTextOrientation
Visual C++
public enum class vTabPageTextOrientation

Members

Member name | Description
Vertical |
Horizontal |

See Also


vTextBox Class

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox Class
Members See Also Send Feedback
Represents a vTextBox control which

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vTextBox : Control, IScrollableControlBase
Visual Basic
Public Class vTextBox _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class vTextBox : public Control,
    IScrollableControlBase

Remarks

Provides an editable text field with cutomizable features.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vTextBox
VIBlend.WinForms.Controls..::..InputBase
VIBlend.WinForms.Controls..::..vDateTimeEditor
VIBlend.WinForms.DataGridView..::..TextBoxEditor

See Also

vTextBox Members


vTextBox Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTextBox Members
vTextBox Class Constructors Methods Properties Events See Also Send Feedback

The vTextBox type exposes the following members.

Constructors

 | Name | Description
Public method | vTextBox | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawText | Draws the text.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Overrides Control..::..OnTextChanged(EventArgs).)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Overrides Control..::..OnVisibleChanged(EventArgs).)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text.
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset.
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox.
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox.
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text.
Public property | DefaultTextColor | Gets or sets the default color of the text.
Public property | DefaultTextFont | Gets or sets the default text font.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum length of the text in the textbox.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Overrides Control..::..RightToLeft.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars.
Public property | SelectionLength |
Public property | SelectionStart |
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex |
Public property | TabStop |
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Overrides Control..::..Text.)
Public property | TextAlign | Gets or sets the text alignment.
Public property | TextBox | Gets the text box.
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vTextBox Class


vTextBox Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox Constructor
vTextBox Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTextBox()
Visual Basic
Public Sub New
Visual C++
public:
vTextBox()

See Also

vTextBox Class


vTextBox Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTextBox Methods
vTextBox Class See Also Send Feedback

The vTextBox type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawText | Draws the text.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Overrides Control..::..OnTextChanged(EventArgs).)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Overrides Control..::..OnVisibleChanged(EventArgs).)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text.
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vTextBox Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..AccessibilityNotifyClients Method
vTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vTextBox Class
vTextBox Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..BeginInvoke Method
vTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vTextBox Class
vTextBox Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..Dispose Method
vTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vTextBox Class
vTextBox Members


DrawText Method

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..DrawText Method
vTextBox Class See Also Send Feedback
Draws the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DrawText(
    Graphics g
)
Visual Basic
Protected Overridable Sub DrawText ( _
    g As Graphics _
)
Visual C++
protected:
virtual void DrawText(
    Graphics^ g
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.

See Also

vTextBox Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..GetChildAtPoint Method
vTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vTextBox Class
vTextBox Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..Invalidate Method
vTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vTextBox Class
vTextBox Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..Invoke Method
vTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vTextBox Class
vTextBox Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..MemberwiseClone Method
vTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vTextBox Class
vTextBox Members


OnTextChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..OnTextChanged Method
vTextBox Class See Also Send Feedback
Raises the TextChanged event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnTextChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnTextChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnTextChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vTextBox Class


OnVisibleChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..OnVisibleChanged Method
vTextBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnVisibleChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnVisibleChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnVisibleChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vTextBox Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..PerformLayout Method
vTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vTextBox Class
vTextBox Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..ResumeLayout Method
vTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vTextBox Class
vTextBox Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..RtlTranslateAlignment Method
vTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vTextBox Class
vTextBox Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..Scale Method
vTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vTextBox Class
vTextBox Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..Select Method
vTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vTextBox Class
vTextBox Members


SelectAll Method

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..SelectAll Method
vTextBox Class See Also Send Feedback
selects the whole text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SelectAll()
Visual Basic
Public Sub SelectAll
Visual C++
public:
void SelectAll()

See Also

vTextBox Class


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..SetBounds Method
vTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vTextBox Class
vTextBox Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..UpdateBounds Method
vTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vTextBox Class
vTextBox Members


vTextBox Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTextBox Properties
vTextBox Class See Also Send Feedback

The vTextBox type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset.
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox.
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox.
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text.
Public property | DefaultTextColor | Gets or sets the default color of the text.
Public property | DefaultTextFont | Gets or sets the default text font.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum length of the text in the textbox.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Overrides Control..::..RightToLeft.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars.
Public property | SelectionLength |
Public property | SelectionStart |
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex |
Public property | TabStop |
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Overrides Control..::..Text.)
Public property | TextAlign | Gets or sets the text alignment.
Public property | TextBox | Gets the text box.
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vTextBox Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..AllowAnimations Property
vTextBox Class See Also Send Feedback
Gets or sets whether the control is animated

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vTextBox Class


BoundsOffset Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..BoundsOffset Property
vTextBox Class See Also Send Feedback
Gets or sets the bounds offset.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Size BoundsOffset { get; set; }
Visual Basic
Public Property BoundsOffset As Size
    Get
    Set
Visual C++
public:
property Size BoundsOffset {
    Size get ();
    void set (Size value);
}

See Also

vTextBox Class


ControlBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..ControlBorderColor Property
vTextBox Class See Also Send Feedback
Gets or sets the BorderColor of the TextBox.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Color ControlBorderColor { get; set; }
Visual Basic
Public Overridable Property ControlBorderColor As Color
    Get
    Set
Visual C++
public:
virtual property Color ControlBorderColor {
    Color get ();
    void set (Color value);
}

See Also

vTextBox Class


ControlHighlightBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..ControlHighlightBorderColor Property
vTextBox Class See Also Send Feedback
Gets or sets the Highlight BorderColor of the TextBox.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Color ControlHighlightBorderColor { get; set; }
Visual Basic
Public Overridable Property ControlHighlightBorderColor As Color
    Get
    Set
Visual C++
public:
virtual property Color ControlHighlightBorderColor {
    Color get ();
    void set (Color value);
}

See Also

vTextBox Class


DefaultText Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..DefaultText Property
vTextBox Class See Also Send Feedback
Gets or sets the default text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string DefaultText { get; set; }
Visual Basic
Public Property DefaultText As String
    Get
    Set
Visual C++
public:
property String^ DefaultText {
    String^ get ();
    void set (String^ value);
}

Field Value

The default text.

See Also

vTextBox Class


DefaultTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..DefaultTextColor Property
vTextBox Class See Also Send Feedback
Gets or sets the default color of the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DefaultTextColor { get; set; }
Visual Basic
Public Property DefaultTextColor As Color
    Get
    Set
Visual C++
public:
property Color DefaultTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The default color of the text.

See Also

vTextBox Class


DefaultTextFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..DefaultTextFont Property
vTextBox Class See Also Send Feedback
Gets or sets the default text font.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font DefaultTextFont { get; set; }
Visual Basic
Public Property DefaultTextFont As Font
    Get
    Set
Visual C++
public:
property Font^ DefaultTextFont {
    Font^ get ();
    void set (Font^ value);
}

Field Value

The default text font.

See Also

vTextBox Class


EnableBorderHighlight Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..EnableBorderHighlight Property
vTextBox Class See Also Send Feedback
Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableBorderHighlight { get; set; }
Visual Basic
Public Property EnableBorderHighlight As Boolean
    Get
    Set
Visual C++
public:
property bool EnableBorderHighlight {
    bool get ();
    void set (bool value);
}

See Also

vTextBox Class


GleamWidth Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..GleamWidth Property
vTextBox Class See Also Send Feedback
Gets or sets the width of the gleam.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int GleamWidth { get; set; }
Visual Basic
Public Property GleamWidth As Integer
    Get
    Set
Visual C++
public:
property int GleamWidth {
    int get ();
    void set (int value);
}

Field Value

The width of the gleam.

See Also

vTextBox Class


MaxLength Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..MaxLength Property
vTextBox Class See Also Send Feedback
Gets or sets the maximum length of the text in the textbox.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int MaxLength { get; set; }
Visual Basic
Public Property MaxLength As Integer
    Get
    Set
Visual C++
public:
property int MaxLength {
    int get ();
    void set (int value);
}

See Also

vTextBox Class


Multiline Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..Multiline Property
vTextBox Class See Also Send Feedback
Gets or sets whether the vTextBox has multiple lines.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Multiline { get; set; }
Visual Basic
Public Property Multiline As Boolean
    Get
    Set
Visual C++
public:
property bool Multiline {
    bool get ();
    void set (bool value);
}

See Also

vTextBox Class


PasswordChar Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..PasswordChar Property
vTextBox Class See Also Send Feedback
Gets or sets textbox's password character.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public char PasswordChar { get; set; }
Visual Basic
Public Property PasswordChar As Char
    Get
    Set
Visual C++
public:
property wchar_t PasswordChar {
    wchar_t get ();
    void set (wchar_t value);
}

See Also

vTextBox Class


Readonly Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..Readonly Property
vTextBox Class See Also Send Feedback
Gets or sets whether the vTextBox is in read only mode.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Readonly { get; set; }
Visual Basic
Public Property Readonly As Boolean
    Get
    Set
Visual C++
public:
property bool Readonly {
    bool get ();
    void set (bool value);
}

See Also

vTextBox Class


RightToLeft Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..RightToLeft Property
vTextBox Class See Also Send Feedback
Gets or sets whether the vTextBox is in right-to-left mode.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override RightToLeft RightToLeft { get; set; }
Visual Basic
Public Overrides Property RightToLeft As RightToLeft
    Get
    Set
Visual C++
public:
virtual property RightToLeft RightToLeft {
    RightToLeft get () override;
    void set (RightToLeft value) override;
}

See Also

vTextBox Class


ScrollBars Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..ScrollBars Property
vTextBox Class See Also Send Feedback
Gets or sets whether the textbox has scrollbars.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ScrollBars ScrollBars { get; set; }
Visual Basic
Public Property ScrollBars As ScrollBars
    Get
    Set
Visual C++
public:
property ScrollBars ScrollBars {
    ScrollBars get ();
    void set (ScrollBars value);
}

See Also

vTextBox Class


SelectionLength Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..SelectionLength Property
vTextBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int SelectionLength { get; set; }
Visual Basic
Public Property SelectionLength As Integer
    Get
    Set
Visual C++
public:
property int SelectionLength {
    int get ();
    void set (int value);
}

See Also

vTextBox Class


SelectionStart Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..SelectionStart Property
vTextBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int SelectionStart { get; set; }
Visual Basic
Public Property SelectionStart As Integer
    Get
    Set
Visual C++
public:
property int SelectionStart {
    int get ();
    void set (int value);
}

See Also

vTextBox Class


ShowDefaultText Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..ShowDefaultText Property
vTextBox Class See Also Send Feedback
Gets or sets a value indicating whether to draw default text

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowDefaultText { get; set; }
Visual Basic
Public Property ShowDefaultText As Boolean
    Get
    Set
Visual C++
public:
property bool ShowDefaultText {
    bool get ();
    void set (bool value);
}

See Also

vTextBox Class


TabIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..TabIndex Property
vTextBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int TabIndex { get; set; }
Visual Basic
Public Property TabIndex As Integer
    Get
    Set
Visual C++
public:
property int TabIndex {
    int get ();
    void set (int value);
}

See Also

vTextBox Class


TabStop Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..TabStop Property
vTextBox Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool TabStop { get; set; }
Visual Basic
Public Property TabStop As Boolean
    Get
    Set
Visual C++
public:
property bool TabStop {
    bool get ();
    void set (bool value);
}

See Also

vTextBox Class


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..Text Property
vTextBox Class See Also Send Feedback
Gets or sets the text of the vTextBox control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string Text { get; set; }
Visual Basic
Public Overrides Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

See Also

vTextBox Class


TextAlign Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..TextAlign Property
vTextBox Class See Also Send Feedback
Gets or sets the text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HorizontalAlignment TextAlign { get; set; }
Visual Basic
Public Property TextAlign As HorizontalAlignment
    Get
    Set
Visual C++
public:
property HorizontalAlignment TextAlign {
    HorizontalAlignment get ();
    void set (HorizontalAlignment value);
}

See Also

vTextBox Class


TextBox Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..TextBox Property
vTextBox Class See Also Send Feedback
Gets the text box.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTextBoxBase TextBox { get; }
Visual Basic
Public ReadOnly Property TextBox As vTextBoxBase
    Get
Visual C++
public:
property vTextBoxBase^ TextBox {
    vTextBoxBase^ get ();
}

Field Value

The text box.

See Also

vTextBox Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..Theme Property
vTextBox Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vTextBox Class


UseThemeBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..UseThemeBorderColor Property
vTextBox Class See Also Send Feedback
Gets or sets a value indicating whether to use the ControlBorderColor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool UseThemeBorderColor { get; set; }
Visual Basic
Public Overridable Property UseThemeBorderColor As Boolean
    Get
    Set
Visual C++
public:
virtual property bool UseThemeBorderColor {
    bool get ();
    void set (bool value);
}

See Also

vTextBox Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vTextBox..::..VIBlendTheme Property
vTextBox Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vTextBox Class


vTextBox Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTextBox Events
vTextBox Class See Also Send Feedback

The vTextBox type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vTextBox Class


vToggleButton Class

[image]

VIBlend Controls for WinForms Help Documentation
vToggleButton Class
Members See Also Send Feedback
Represents a vToggleButton control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vToggleButton : vButton
Visual Basic
Public Class vToggleButton _
    Inherits vButton
Visual C++
public ref class vToggleButton : public vButton

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ButtonBase
System.Windows.Forms..::..Button
VIBlend.WinForms.Controls..::..vButton
VIBlend.WinForms.Controls..::..vToggleButton
VIBlend.WinForms.Controls..::..vToggleCircularButton

See Also

vToggleButton Members


vToggleButton Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton Members
vToggleButton Class Constructors Methods Fields Properties Events See Also Send Feedback

The vToggleButton type exposes the following members.

Constructors

 | Name | Description
Public method | vToggleButton | Initializes a new instance of the vToggleButton class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder | (Inherited from vButton.)
Protected method | DrawControl | Draws the control. (Inherited from vButton.)
Protected method | DrawFocusRectangle | (Inherited from vButton.)
Protected method | DrawImageAndText | (Inherited from vButton.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect | (Inherited from vButton.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from vButton.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from vButton.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vButton.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Inherited from vButton.)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vButton.)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Inherited from vButton.)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vButton.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vButton.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

Fields

 | Name | Description
Protected field | buttonBorderStyle | (Inherited from vButton.)
Protected field | opacity | (Inherited from vButton.)
Protected field | paintHelper | (Inherited from vButton.)
Protected field | theme | (Inherited from vButton.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vButton.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button (Inherited from vButton.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Inherited from vButton.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled. (Inherited from vButton.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control. (Inherited from vButton.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsThreeState | Gets or sets a value indicating whether the toggle button is in 3-State mode
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity. (Inherited from vButton.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vButton.)
Public property | PaintDefaultBorder | Gets or sets a value indicating whether to paint a border when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultFill | Gets or sets a value indicating whether to paint a background when the control state is default. (Inherited from vButton.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vButton.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded (Inherited from vButton.)
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control. (Inherited from vButton.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused (Inherited from vButton.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image (Inherited from vButton.)
Public property | StyleKey | Gets or sets the style key. (Inherited from vButton.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control. (Inherited from vButton.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable (Inherited from vButton.)
Public property | Theme | Gets or sets the theme of the control (Inherited from vButton.)
Public property | Toggle | Gets or sets the toggle state of the control
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control. (Inherited from vButton.)
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control. (Inherited from vButton.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color. (Inherited from vButton.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vButton.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | ToggleStateChanged | Occurs when the toggle state of the button changes
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vToggleButton Class


vToggleButton Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vToggleButton Constructor
vToggleButton Class See Also Send Feedback
Initializes a new instance of the vToggleButton class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vToggleButton()
Visual Basic
Public Sub New
Visual C++
public:
vToggleButton()

See Also

vToggleButton Class


vToggleButton Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton Fields
vToggleButton Class See Also Send Feedback

The vToggleButton type exposes the following members.

Fields

 | Name | Description
Protected field | buttonBorderStyle | (Inherited from vButton.)
Protected field | opacity | (Inherited from vButton.)
Protected field | paintHelper | (Inherited from vButton.)
Protected field | theme | (Inherited from vButton.)

See Also

vToggleButton Class


vToggleButton Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton Methods
vToggleButton Class See Also Send Feedback

The vToggleButton type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder | (Inherited from vButton.)
Protected method | DrawControl | Draws the control. (Inherited from vButton.)
Protected method | DrawFocusRectangle | (Inherited from vButton.)
Protected method | DrawImageAndText | (Inherited from vButton.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect | (Inherited from vButton.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from vButton.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from vButton.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vButton.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Inherited from vButton.)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vButton.)
Protected method | OnMouseMove | Raises the OnMouseMove event. (Inherited from vButton.)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vButton.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vButton.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

See Also

vToggleButton Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton..::..AccessibilityNotifyClients Method
vToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vToggleButton Class
vToggleButton Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton..::..BeginInvoke Method
vToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vToggleButton Class
vToggleButton Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton..::..Dispose Method
vToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)

See Also

vToggleButton Class
vToggleButton Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton..::..GetChildAtPoint Method
vToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vToggleButton Class
vToggleButton Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton..::..Invalidate Method
vToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vToggleButton Class
vToggleButton Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton..::..Invoke Method
vToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vToggleButton Class
vToggleButton Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton..::..MemberwiseClone Method
vToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vToggleButton Class
vToggleButton Members


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton..::..PerformLayout Method
vToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vToggleButton Class
vToggleButton Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton..::..ResumeLayout Method
vToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vToggleButton Class
vToggleButton Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton..::..RtlTranslateAlignment Method
vToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vToggleButton Class
vToggleButton Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton..::..Scale Method
vToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vToggleButton Class
vToggleButton Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton..::..Select Method
vToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vToggleButton Class
vToggleButton Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton..::..SetBounds Method
vToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vToggleButton Class
vToggleButton Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton..::..UpdateBounds Method
vToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vToggleButton Class
vToggleButton Members


vToggleButton Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton Properties
vToggleButton Class See Also Send Feedback

The vToggleButton type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vButton.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button (Inherited from vButton.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Inherited from vButton.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled. (Inherited from vButton.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control. (Inherited from vButton.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsThreeState | Gets or sets a value indicating whether the toggle button is in 3-State mode
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity. (Inherited from vButton.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vButton.)
Public property | PaintDefaultBorder | Gets or sets a value indicating whether to paint a border when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultFill | Gets or sets a value indicating whether to paint a background when the control state is default. (Inherited from vButton.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vButton.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded (Inherited from vButton.)
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control. (Inherited from vButton.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused (Inherited from vButton.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image (Inherited from vButton.)
Public property | StyleKey | Gets or sets the style key. (Inherited from vButton.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control. (Inherited from vButton.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable (Inherited from vButton.)
Public property | Theme | Gets or sets the theme of the control (Inherited from vButton.)
Public property | Toggle | Gets or sets the toggle state of the control
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control. (Inherited from vButton.)
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control. (Inherited from vButton.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color. (Inherited from vButton.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vButton.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vToggleButton Class


IsThreeState Property

[image]

VIBlend Controls for WinForms Help Documentation
vToggleButton..::..IsThreeState Property
vToggleButton Class See Also Send Feedback
Gets or sets a value indicating whether the toggle button is in 3-State mode

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsThreeState { get; set; }
Visual Basic
Public Property IsThreeState As Boolean
    Get
    Set
Visual C++
public:
property bool IsThreeState {
    bool get ();
    void set (bool value);
}

See Also

vToggleButton Class


Toggle Property

[image]

VIBlend Controls for WinForms Help Documentation
vToggleButton..::..Toggle Property
vToggleButton Class See Also Send Feedback
Gets or sets the toggle state of the control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CheckState Toggle { get; set; }
Visual Basic
Public Property Toggle As CheckState
    Get
    Set
Visual C++
public:
property CheckState Toggle {
    CheckState get ();
    void set (CheckState value);
}

See Also

vToggleButton Class


vToggleButton Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleButton Events
vToggleButton Class See Also Send Feedback

The vToggleButton type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | ToggleStateChanged | Occurs when the toggle state of the button changes
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vToggleButton Class


ToggleStateChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vToggleButton..::..ToggleStateChanged Event
vToggleButton Class See Also Send Feedback
Occurs when the toggle state of the button changes

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ToggleStateChanged
Visual Basic
Public Event ToggleStateChanged As EventHandler
Visual C++
public:
 event EventHandler^ ToggleStateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vToggleButton Class


vToggleCircularButton Class

[image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vToggleCircularButton : vToggleButton
Visual Basic
Public Class vToggleCircularButton _
    Inherits vToggleButton
Visual C++
public ref class vToggleCircularButton : public vToggleButton

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ButtonBase
System.Windows.Forms..::..Button
VIBlend.WinForms.Controls..::..vButton
VIBlend.WinForms.Controls..::..vToggleButton
VIBlend.WinForms.Controls..::..vToggleCircularButton

See Also

vToggleCircularButton Members


vToggleCircularButton Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton Members
vToggleCircularButton Class Constructors Methods Fields Properties Events See Also Send Feedback

The vToggleCircularButton type exposes the following members.

Constructors

 | Name | Description
Public method | vToggleCircularButton | Initializes a new instance of the vToggleCircularButton class

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder | (Inherited from vButton.)
Protected method | DrawControl | (Overrides vButton..::..DrawControl(Graphics, Rectangle, ControlState, Boolean, Byte).)
Protected method | DrawFocusRectangle | (Inherited from vButton.)
Protected method | DrawImageAndText | (Inherited from vButton.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect | (Inherited from vButton.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from vButton.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from vButton.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vButton.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Inherited from vButton.)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vButton.)
Protected method | OnMouseMove | (Overrides vButton..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vButton.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vButton.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

Fields

 | Name | Description
Protected field | buttonBorderStyle | (Inherited from vButton.)
Protected field | opacity | (Inherited from vButton.)
Protected field | paintHelper | (Inherited from vButton.)
Protected field | theme | (Inherited from vButton.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vButton.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button (Inherited from vButton.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | ButtonColorScheme | Gets or sets the button's color sheme.
Public property | ButtonStyle | Gets or sets the button style.
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Inherited from vButton.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled. (Inherited from vButton.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control. (Inherited from vButton.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsThreeState | Gets or sets a value indicating whether the toggle button is in 3-State mode (Inherited from vToggleButton.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity. (Inherited from vButton.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vButton.)
Public property | PaintDefaultBorder | Gets or sets a value indicating whether to paint a border when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultFill | Gets or sets a value indicating whether to paint a background when the control state is default. (Inherited from vButton.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vButton.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded (Inherited from vButton.)
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control. (Inherited from vButton.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused (Inherited from vButton.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image (Inherited from vButton.)
Public property | StyleKey | Gets or sets the style key. (Inherited from vButton.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control. (Inherited from vButton.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable (Inherited from vButton.)
Public property | Theme | (Overrides vButton..::..Theme.)
Public property | Toggle |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control. (Inherited from vButton.)
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control. (Inherited from vButton.)
Public property | UseButtonScheme | Gets or sets whether the button should use the built-in color schemes.
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color. (Inherited from vButton.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vButton.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | ToggleStateChanged | Occurs when the toggle state of the button changes (Inherited from vToggleButton.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vToggleCircularButton Class


vToggleCircularButton Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton Constructor
vToggleCircularButton Class See Also Send Feedback
Initializes a new instance of the vToggleCircularButton class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vToggleCircularButton()
Visual Basic
Public Sub New
Visual C++
public:
vToggleCircularButton()

See Also

vToggleCircularButton Class


vToggleCircularButton Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton Fields
vToggleCircularButton Class See Also Send Feedback

The vToggleCircularButton type exposes the following members.

Fields

 | Name | Description
Protected field | buttonBorderStyle | (Inherited from vButton.)
Protected field | opacity | (Inherited from vButton.)
Protected field | paintHelper | (Inherited from vButton.)
Protected field | theme | (Inherited from vButton.)

See Also

vToggleCircularButton Class


vToggleCircularButton Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton Methods
vToggleCircularButton Class See Also Send Feedback

The vToggleCircularButton type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from ButtonBase.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBorder | (Inherited from vButton.)
Protected method | DrawControl | (Overrides vButton..::..DrawControl(Graphics, Rectangle, ControlState, Boolean, Byte).)
Protected method | DrawFocusRectangle | (Inherited from vButton.)
Protected method | DrawImageAndText | (Inherited from vButton.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageAndTextRect | (Inherited from vButton.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | (Inherited from Button.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from vButton.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Button.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from vButton.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the OnKeyUp(KeyEventArgs) event. (Inherited from ButtonBase.)
Protected method | OnLayout | (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the OnLostFocus event. (Inherited from vButton.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the OnMouseDown event. (Inherited from vButton.)
Protected method | OnMouseEnter | (Inherited from Button.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the OnMouseLeave event. (Inherited from vButton.)
Protected method | OnMouseMove | (Overrides vButton..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the OnMouseUp event. (Inherited from vButton.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event. (Inherited from vButton.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ButtonBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Button.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ButtonBase.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Button.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Protected method | ResetFlagsandPaint | Resets the Button control to the state before it is pressed and redraws it. (Inherited from ButtonBase.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Button.)

See Also

vToggleCircularButton Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..AccessibilityNotifyClients Method
vToggleCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vToggleCircularButton Class
vToggleCircularButton Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..BeginInvoke Method
vToggleCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vToggleCircularButton Class
vToggleCircularButton Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..Dispose Method
vToggleCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ButtonBase and optionally releases the managed resources. (Inherited from ButtonBase.)

See Also

vToggleCircularButton Class
vToggleCircularButton Members


DrawControl Method

[image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..DrawControl Method
vToggleCircularButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void DrawControl(
    Graphics graphics,
    Rectangle bounds,
    ControlState controlState,
    bool isFocused,
    byte roundedCornersMask
)
Visual Basic
Protected Overrides Sub DrawControl ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    controlState As ControlState, _
    isFocused As Boolean, _
    roundedCornersMask As Byte _
)
Visual C++
protected:
virtual void DrawControl(
    Graphics^ graphics,
    Rectangle bounds,
    ControlState controlState,
    bool isFocused,
    unsigned char roundedCornersMask
) override

Parameters

graphics
Type: System.Drawing..::..Graphics
bounds
Type: System.Drawing..::..Rectangle
controlState
Type: ControlState
isFocused
Type: System..::..Boolean
roundedCornersMask
Type: System..::..Byte

See Also

vToggleCircularButton Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..GetChildAtPoint Method
vToggleCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vToggleCircularButton Class
vToggleCircularButton Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..Invalidate Method
vToggleCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vToggleCircularButton Class
vToggleCircularButton Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..Invoke Method
vToggleCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vToggleCircularButton Class
vToggleCircularButton Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..MemberwiseClone Method
vToggleCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vToggleCircularButton Class
vToggleCircularButton Members


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..OnLayout Method
vToggleCircularButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs

See Also

vToggleCircularButton Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..OnMouseMove Method
vToggleCircularButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs mevent
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    mevent As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ mevent
) override

Parameters

mevent
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vToggleCircularButton Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..PerformLayout Method
vToggleCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vToggleCircularButton Class
vToggleCircularButton Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..ResumeLayout Method
vToggleCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vToggleCircularButton Class
vToggleCircularButton Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..RtlTranslateAlignment Method
vToggleCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vToggleCircularButton Class
vToggleCircularButton Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..Scale Method
vToggleCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vToggleCircularButton Class
vToggleCircularButton Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..Select Method
vToggleCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vToggleCircularButton Class
vToggleCircularButton Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..SetBounds Method
vToggleCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vToggleCircularButton Class
vToggleCircularButton Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..UpdateBounds Method
vToggleCircularButton Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vToggleCircularButton Class
vToggleCircularButton Members


vToggleCircularButton Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton Properties
vToggleCircularButton Class See Also Send Feedback

The vToggleCircularButton type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations (Inherited from vButton.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the button (Inherited from vButton.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | ButtonColorScheme | Gets or sets the button's color sheme.
Public property | ButtonStyle | Gets or sets the button style.
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets a CreateParams on the base class when creating a window. (Inherited from Button.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from ButtonBase.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from ButtonBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the vButton (Inherited from vButton.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightTextColor | Gets or sets the highlight state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | HoverEffectsEnabled | Gets or sets a value indicating whether mouse hover effects are enabled. (Inherited from vButton.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAbsolutePosition | Gets or sets the position of the image on the button control. (Inherited from vButton.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Protected property | IsDefault | Gets or sets a value indicating whether the button control is the default button. (Inherited from ButtonBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsThreeState | Gets or sets a value indicating whether the toggle button is in 3-State mode (Inherited from vToggleButton.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets a value indicating whether this [!:BackGroundElement] has opacity. (Inherited from vButton.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border (Inherited from vButton.)
Public property | PaintDefaultBorder | Gets or sets a value indicating whether to paint a border when the control state is default. (Inherited from vButton.)
Public property | PaintDefaultFill | Gets or sets a value indicating whether to paint a background when the control state is default. (Inherited from vButton.)
Public property | PaintFill | Gets or sets a value indicating whether to paint a background (Inherited from vButton.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PressedTextColor | Gets or sets the pressed state text color. The property is used when the UseThemeTextColor is true (Inherited from vButton.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded (Inherited from vButton.)
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vButton control. (Inherited from vButton.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the button is Focused (Inherited from vButton.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StretchImage | Gets or sets a value indicating whether to stretch the associated Image (Inherited from vButton.)
Public property | StyleKey | Gets or sets the style key. (Inherited from vButton.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAbsolutePosition | Gets or sets the position of the text on the button control. (Inherited from vButton.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | TextWrap | Gets or sets whether the button's text is wrappable (Inherited from vButton.)
Public property | Theme | (Overrides vButton..::..Theme.)
Public property | Toggle |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseAbsoluteImagePositioning | Gets or sets the positioning mode of the image on the button control. (Inherited from vButton.)
Public property | UseAbsoluteTextPositioning | Gets or sets the positioning mode of the text on the button control. (Inherited from vButton.)
Public property | UseButtonScheme | Gets or sets whether the button should use the built-in color schemes.
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use the theme text color. (Inherited from vButton.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes (Inherited from vButton.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vToggleCircularButton Class


ButtonColorScheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..ButtonColorScheme Property
vToggleCircularButton Class See Also Send Feedback
Gets or sets the button's color sheme.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ButtonDefaultColorSchemes ButtonColorScheme { get; set; }
Visual Basic
Public Property ButtonColorScheme As ButtonDefaultColorSchemes
    Get
    Set
Visual C++
public:
property ButtonDefaultColorSchemes ButtonColorScheme {
    ButtonDefaultColorSchemes get ();
    void set (ButtonDefaultColorSchemes value);
}

See Also

vToggleCircularButton Class


ButtonStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..ButtonStyle Property
vToggleCircularButton Class See Also Send Feedback
Gets or sets the button style.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RibbonStyle ButtonStyle { get; set; }
Visual Basic
Public Property ButtonStyle As RibbonStyle
    Get
    Set
Visual C++
public:
property RibbonStyle ButtonStyle {
    RibbonStyle get ();
    void set (RibbonStyle value);
}

Field Value

The button style.

See Also

vToggleCircularButton Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..Theme Property
vToggleCircularButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override ControlTheme Theme { get; set; }
Visual Basic
Public Overrides Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
virtual property ControlTheme^ Theme {
    ControlTheme^ get () override;
    void set (ControlTheme^ value) override;
}

See Also

vToggleCircularButton Class


Toggle Property

[image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..Toggle Property
vToggleCircularButton Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CheckState Toggle { get; set; }
Visual Basic
Public Property Toggle As CheckState
    Get
    Set
Visual C++
public:
property CheckState Toggle {
    CheckState get ();
    void set (CheckState value);
}

See Also

vToggleCircularButton Class


UseButtonScheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton..::..UseButtonScheme Property
vToggleCircularButton Class See Also Send Feedback
Gets or sets whether the button should use the built-in color schemes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseButtonScheme { get; set; }
Visual Basic
Public Property UseButtonScheme As Boolean
    Get
    Set
Visual C++
public:
property bool UseButtonScheme {
    bool get ();
    void set (bool value);
}

See Also

vToggleCircularButton Class


vToggleCircularButton Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToggleCircularButton Events
vToggleCircularButton Class See Also Send Feedback

The vToggleCircularButton type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | ToggleStateChanged | Occurs when the toggle state of the button changes (Inherited from vToggleButton.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vToggleCircularButton Class


vToolStripDropDown Class

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vToolStripDropDown : ToolStripDropDown
Visual Basic
Public Class vToolStripDropDown _
    Inherits ToolStripDropDown
Visual C++
public ref class vToolStripDropDown : public ToolStripDropDown

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ToolStrip
System.Windows.Forms..::..ToolStripDropDown
VIBlend.WinForms.Controls..::..vToolStripDropDown

See Also

vToolStripDropDown Members


vToolStripDropDown Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown Members
vToolStripDropDown Class Constructors Methods Properties Events See Also Send Feedback

The vToolStripDropDown type exposes the following members.

Constructors

 | Name | Description
Public method | vToolStripDropDown()()()() |
Public method | vToolStripDropDown(Control) |

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close()()()() | Closes the ToolStripDropDown control. (Inherited from ToolStripDropDown.)
Public method | Close(ToolStripDropDownCloseReason) | Closes the ToolStripDropDown control for the specified reason. (Inherited from ToolStripDropDown.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from ToolStrip.)
Protected method | CreateDefaultItem | Creates a default ToolStripItem with the specified text, image, and event handler on a new ToolStrip instance. (Inherited from ToolStrip.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | (Inherited from ToolStripDropDown.)
Protected method | CreateLayoutSettings | Applies various layout options to the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ToolStripDropDown..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemAt(Point) | Returns the item located at the specified point in the client area of the ToolStrip. (Inherited from ToolStrip.)
Public method | GetItemAt(Int32, Int32) | Returns the item located at the specified x- and y-coordinates of the ToolStrip client area. (Inherited from ToolStrip.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetNextItem | Retrieves the next ToolStripItem from the specified reference point and moving in the specified direction. (Inherited from ToolStrip.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Protected method | InvalidateRegion |
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines whether a character is an input character that the item recognizes. (Inherited from ToolStrip.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from ToolStrip.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBeginDrag | Raises the BeginDrag event. (Inherited from ToolStrip.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | (Overrides ToolStripDropDown..::..OnClosed(ToolStripDropDownClosedEventArgs).)
Protected method | OnClosing | (Overrides ToolStripDropDown..::..OnClosing(ToolStripDropDownClosingEventArgs).)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from ToolStrip.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the Enabled event. (Inherited from ToolStrip.)
Protected method | OnEndDrag | Raises the EndDrag event. (Inherited from ToolStrip.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | (Inherited from ToolStrip.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from ToolStripDropDown.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from ToolStrip.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnHideAnimationFinished |
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | (Inherited from ToolStrip.)
Protected method | OnItemAdded | Raises the ItemAdded event. (Inherited from ToolStrip.)
Protected method | OnItemClicked | Raises the ItemClicked event. (Inherited from ToolStripDropDown.)
Protected method | OnItemRemoved | Raises the ItemRemoved event. (Inherited from ToolStrip.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides ToolStripDropDown..::..OnLayout(LayoutEventArgs).)
Protected method | OnLayoutCompleted | Raises the LayoutCompleted event. (Inherited from ToolStrip.)
Protected method | OnLayoutStyleChanged | Raises the LayoutStyleChanged event. (Inherited from ToolStrip.)
Protected method | OnLeave | Raises the Leave event. (Inherited from ToolStrip.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from ToolStrip.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | (Inherited from ToolStrip.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from ToolStrip.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from ToolStrip.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from ToolStrip.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from ToolStripDropDown.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnOpened | (Overrides ToolStripDropDown..::..OnOpened(EventArgs).)
Protected method | OnOpening | (Overrides ToolStripDropDown..::..OnOpening(CancelEventArgs).)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from ToolStrip.)
Protected method | OnPaintBackground | Raises the Paint event for the ToolStrip background. (Inherited from ToolStrip.)
Protected method | OnPaintGrip | Raises the PaintGrip event. (Inherited from ToolStrip.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ToolStripDropDown.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnRendererChanged | Raises the RendererChanged event. (Inherited from ToolStrip.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ToolStrip.)
Protected method | OnScroll | (Inherited from ToolStrip.)
Protected method | OnSizeChanged | (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from ToolStrip.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from ToolStripDropDown.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ToolStrip.)
Protected method | ProcessDialogChar | Processes a dialog box character. (Inherited from ToolStripDropDown.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from ToolStripDropDown.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from ToolStripDropDown.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetMinimumSize | This method is not relevant for this class. (Inherited from ToolStrip.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Protected method | RestoreFocus | Controls the return location of the focus. (Inherited from ToolStrip.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ToolStripDropDown.)
Protected method | ScaleCore | This method is not relevant to this class. (Inherited from ToolStripDropDown.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from ToolStrip.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | This method is not relevant for this class. (Inherited from ToolStrip.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from ToolStripDropDown.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayedItems | Resets the collection of displayed and overflow items after a layout is done. (Inherited from ToolStrip.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetItemLocation | Anchors a ToolStripItem to a particular place on a ToolStrip. (Inherited from ToolStrip.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Adjusts the size of the owner ToolStrip to accommodate the ToolStripDropDown if the owner ToolStrip is currently displayed, or clears and resets active ToolStripDropDown child controls of the ToolStrip if the ToolStrip is not currently displayed. (Inherited from ToolStripDropDown.)
Public method | Show()()()() | Displays the ToolStripDropDown control in its default position. (Inherited from ToolStripDropDown.)
Public method | Show(Point) | Positions the ToolStripDropDown relative to the specified screen location. (Inherited from ToolStripDropDown.)
Public method | Show(Control) |
Public method | Show(Control, Point) | Positions the ToolStripDropDown relative to the specified control location. (Inherited from ToolStripDropDown.)
Public method | Show(Point, ToolStripDropDownDirection) | Positions the ToolStripDropDown relative to the specified control location and with the specified direction relative to the parent control. (Inherited from ToolStripDropDown.)
Public method | Show(Int32, Int32) | Positions the ToolStripDropDown relative to the specified screen coordinates. (Inherited from ToolStripDropDown.)
Public method | Show(Control, Rectangle) |
Public method | Show(Control, Point, ToolStripDropDownDirection) | Positions the ToolStripDropDown relative to the specified control at the specified location and with the specified direction relative to the parent control. (Inherited from ToolStripDropDown.)
Public method | Show(Control, Int32, Int32) | Positions the ToolStripDropDown relative to the specified control's horizontal and vertical screen coordinates. (Inherited from ToolStripDropDown.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from ToolStrip.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ToolStripDropDown.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether drag-and-drop and item reordering are handled through events that you implement. (Inherited from ToolStrip.)
Public property | AllowItemReorder | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | AllowMerge | Gets or sets a value indicating whether multiple MenuStrip, ToolStripDropDownMenu, ToolStripMenuItem, and other types can be combined. (Inherited from ToolStrip.)
Public property | AllowTransparency | Gets or sets a value indicating whether the Opacity of the form can be adjusted. (Inherited from ToolStripDropDown.)
Public property | Anchor | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | AutoClose | Gets or sets a value indicating whether the ToolStripDropDown control should automatically close when it has lost activation. (Inherited from ToolStripDropDown.)
Public property | AutoScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollMargin | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollMinSize | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoSize | Gets or sets a value indicating whether the ToolStripDropDown automatically adjusts its size when the form is resized. (Inherited from ToolStripDropDown.)
Public property | BackColor | Gets or sets the background color for the ToolStrip. (Inherited from ToolStrip.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the binding context for the ToolStrip. (Inherited from ToolStrip.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanOverflow | Gets or sets a value indicating whether the items in a ToolStripDropDown can be sent to an overflow menu. (Inherited from ToolStripDropDown.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanResize |
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the ToolStrip causes validation to be performed on any controls that require validation when it receives focus. (Inherited from ToolStrip.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content |
Public property | ContextMenu | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | ContextMenuStrip | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | Controls | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Overrides ToolStripDropDown..::..CreateParams.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the ToolStrip. (Inherited from ToolStrip.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultDock | (Inherited from ToolStripDropDown.)
Public property | DefaultDropDownDirection | Gets or sets the direction in which the ToolStripDropDown is displayed relative to the ToolStrip. (Inherited from ToolStripDropDown.)
Protected property | DefaultGripMargin | Gets the default spacing, in pixels, between the sizing grip and the edges of the ToolStrip. (Inherited from ToolStrip.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the spacing, in pixels, between the ToolStrip and the ToolStripContainer. (Inherited from ToolStrip.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from ToolStripDropDown.)
Protected property | DefaultShowItemToolTips | (Inherited from ToolStripDropDown.)
Protected property | DefaultSize | Gets the default size of the ToolStrip. (Inherited from ToolStrip.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | DisplayedItems | Gets the subset of items that are currently displayed on the ToolStrip, including items that are automatically added into the ToolStrip. (Inherited from ToolStrip.)
Public property | DisplayRectangle | Retrieves the current display rectangle. (Inherited from ToolStrip.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropShadowEnabled | Gets or sets a value indicating whether a three-dimensional shadow effect appears when the ToolStripDropDown is displayed. (Inherited from ToolStripDropDown.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | FocusOnPopUp |
Public property | Font | Gets or sets the font of the text displayed on the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the ToolStrip. (Inherited from ToolStrip.)
Public property | GripDisplayStyle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | GripMargin | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | GripRectangle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | GripStyle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImageList | Gets or sets the image list that contains the image displayed on a ToolStrip item. (Inherited from ToolStrip.)
Public property | ImageScalingSize | Gets or sets the size, in pixels, of an image used on a ToolStrip. (Inherited from ToolStrip.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsAutoGenerated | Gets a value indicating whether this ToolStripDropDown was automatically generated. (Inherited from ToolStripDropDown.)
Public property | IsCurrentlyDragging | Gets a value indicating whether the user is currently moving the ToolStrip from one ToolStripContainer to another. (Inherited from ToolStrip.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsDropDown | Gets a value indicating whether a ToolStrip is a ToolStripDropDown control. (Inherited from ToolStrip.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets all the items that belong to a ToolStrip. (Inherited from ToolStrip.)
Public property | LayoutEngine | Passes a reference to the cached LayoutEngine returned by the layout engine interface. (Inherited from ToolStrip.)
Public property | LayoutSettings | Gets or sets layout scheme characteristics. (Inherited from ToolStrip.)
Public property | LayoutStyle | Gets or sets a value indicating how the ToolStrip lays out the items collection. (Inherited from ToolStrip.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Protected property | MaxItemSize | Gets the maximum height and width, in pixels, of the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Determines the opacity of the form. (Inherited from ToolStripDropDown.)
Public property | Orientation | Gets the orientation of the ToolStripPanel. (Inherited from ToolStrip.)
Public property | OverflowButton | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | OwnerItem | Gets or sets the ToolStripItem that is the owner of this ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Panel |
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public property | Renderer | Gets or sets a ToolStripRenderer used to customize the look and feel of a ToolStrip. (Inherited from ToolStrip.)
Public property | RenderMode | Gets or sets the painting styles to be applied to the ToolStrip. (Inherited from ToolStrip.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | (Inherited from ToolStripDropDown.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowItemToolTips | Gets or sets a value indicating whether ToolTips are to be displayed on ToolStrip items. (Inherited from ToolStrip.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Stretch | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | TabIndex | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to an item in the ToolStrip using the TAB key. (Inherited from ToolStrip.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | TextDirection | Specifies the direction in which to draw the text on the item. (Inherited from ToolStripDropDown.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether the ToolStripDropDown is a top-level control. (Inherited from ToolStripDropDown.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Protected property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from ToolStripDropDown.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Visible | Gets or sets a value indicating whether the ToolStripDropDown is visible or hidden. (Inherited from ToolStripDropDown.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property has changed. (Inherited from ToolStrip.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ToolStripDropDown.)
Public event | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ToolStripDropDown.)
Public event | BeginDrag | Occurs when the user begins to drag the ToolStrip control. (Inherited from ToolStrip.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from ToolStripDropDown.)
Public event | CausesValidationChanged | Occurs when the CausesValidation property changes. (Inherited from ToolStrip.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from ToolStripDropDown.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the ToolStripDropDown is closed. (Inherited from ToolStripDropDown.)
Public event | Closing | Occurs when the ToolStripDropDown control is about to close. (Inherited from ToolStripDropDown.)
Public event | ContextMenuChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | ContextMenuStripChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | ControlAdded | This event is not relevant for this class. (Inherited from ToolStrip.)
Public event | ControlRemoved | This event is not relevant for this class. (Inherited from ToolStrip.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from ToolStrip.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | EndDrag | Occurs when the user stops dragging the ToolStrip control. (Inherited from ToolStrip.)
Public event | Enter | Occurs when the focus enters the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public event | FontChanged | Occurs when the value of the Font property changes. (Inherited from ToolStripDropDown.)
Public event | ForeColorChanged | Occurs when the value of the ForeColor property changes. (Inherited from ToolStripDropDown.)
Public event | GiveFeedback | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from ToolStripDropDown.)
Public event | HideAnimationFinished | Occurs when hide animation has finished
Public event | ImeModeChanged | Occurs when the ImeModeChanged property has changed. (Inherited from ToolStripDropDown.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemAdded | Occurs when a new ToolStripItem is added to the ToolStripItemCollection. (Inherited from ToolStrip.)
Public event | ItemClicked | Occurs when the ToolStripItem is clicked. (Inherited from ToolStrip.)
Public event | ItemRemoved | Occurs when a ToolStripItem is removed from the ToolStripItemCollection. (Inherited from ToolStrip.)
Public event | KeyDown | Occurs when a key is pressed and held down while the ToolStripDropDown has focus. (Inherited from ToolStripDropDown.)
Public event | KeyPress | Occurs when a key is pressed while the ToolStripDropDown has focus. (Inherited from ToolStripDropDown.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from ToolStripDropDown.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | LayoutCompleted | Occurs when the layout of the ToolStrip is complete. (Inherited from ToolStrip.)
Public event | LayoutStyleChanged | Occurs when the value of the LayoutStyle property changes. (Inherited from ToolStrip.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from ToolStripDropDown.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | Opened | Occurs when the ToolStripDropDown is opened. (Inherited from ToolStripDropDown.)
Public event | Opening | Occurs when the ToolStripDropDown control is opening. (Inherited from ToolStripDropDown.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintGrip | Occurs when the ToolStrip move handle is painted. (Inherited from ToolStrip.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from ToolStripDropDown.)
Public event | RendererChanged | Occurs when the value of the Renderer property changes. (Inherited from ToolStrip.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the ToolStripLayoutStyle style changes. (Inherited from ToolStripDropDown.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | TabStopChanged | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | TextChanged | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | Validated | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | Validating | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vToolStripDropDown Class


vToolStripDropDown Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown Constructor
vToolStripDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | vToolStripDropDown()()()() | Initializes a new instance of the vToolStripDropDown class
Public method | vToolStripDropDown(Control) | Initializes a new instance of the vToolStripDropDown class

See Also

vToolStripDropDown Class
vToolStripDropDown Members


vToolStripDropDown Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown Constructor
vToolStripDropDown Class See Also Send Feedback
Initializes a new instance of the vToolStripDropDown class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vToolStripDropDown()
Visual Basic
Public Sub New
Visual C++
public:
vToolStripDropDown()

See Also

vToolStripDropDown Class
vToolStripDropDown Overload


vToolStripDropDown Constructor (Control)

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown Constructor (Control)
vToolStripDropDown Class See Also Send Feedback
Initializes a new instance of the vToolStripDropDown class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vToolStripDropDown(
    Control content
)
Visual Basic
Public Sub New ( _
    content As Control _
)
Visual C++
public:
vToolStripDropDown(
    Control^ content
)

Parameters

content
Type: System.Windows.Forms..::..Control

See Also

vToolStripDropDown Class
vToolStripDropDown Overload


vToolStripDropDown Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown Methods
vToolStripDropDown Class See Also Send Feedback

The vToolStripDropDown type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close()()()() | Closes the ToolStripDropDown control. (Inherited from ToolStripDropDown.)
Public method | Close(ToolStripDropDownCloseReason) | Closes the ToolStripDropDown control for the specified reason. (Inherited from ToolStripDropDown.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from ToolStrip.)
Protected method | CreateDefaultItem | Creates a default ToolStripItem with the specified text, image, and event handler on a new ToolStrip instance. (Inherited from ToolStrip.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | (Inherited from ToolStripDropDown.)
Protected method | CreateLayoutSettings | Applies various layout options to the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ToolStripDropDown..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemAt(Point) | Returns the item located at the specified point in the client area of the ToolStrip. (Inherited from ToolStrip.)
Public method | GetItemAt(Int32, Int32) | Returns the item located at the specified x- and y-coordinates of the ToolStrip client area. (Inherited from ToolStrip.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetNextItem | Retrieves the next ToolStripItem from the specified reference point and moving in the specified direction. (Inherited from ToolStrip.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Protected method | InvalidateRegion |
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines whether a character is an input character that the item recognizes. (Inherited from ToolStrip.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from ToolStrip.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBeginDrag | Raises the BeginDrag event. (Inherited from ToolStrip.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | (Overrides ToolStripDropDown..::..OnClosed(ToolStripDropDownClosedEventArgs).)
Protected method | OnClosing | (Overrides ToolStripDropDown..::..OnClosing(ToolStripDropDownClosingEventArgs).)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from ToolStrip.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the Enabled event. (Inherited from ToolStrip.)
Protected method | OnEndDrag | Raises the EndDrag event. (Inherited from ToolStrip.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | (Inherited from ToolStrip.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from ToolStripDropDown.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from ToolStrip.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnHideAnimationFinished |
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | (Inherited from ToolStrip.)
Protected method | OnItemAdded | Raises the ItemAdded event. (Inherited from ToolStrip.)
Protected method | OnItemClicked | Raises the ItemClicked event. (Inherited from ToolStripDropDown.)
Protected method | OnItemRemoved | Raises the ItemRemoved event. (Inherited from ToolStrip.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides ToolStripDropDown..::..OnLayout(LayoutEventArgs).)
Protected method | OnLayoutCompleted | Raises the LayoutCompleted event. (Inherited from ToolStrip.)
Protected method | OnLayoutStyleChanged | Raises the LayoutStyleChanged event. (Inherited from ToolStrip.)
Protected method | OnLeave | Raises the Leave event. (Inherited from ToolStrip.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from ToolStrip.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | (Inherited from ToolStrip.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from ToolStrip.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from ToolStrip.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from ToolStrip.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from ToolStripDropDown.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnOpened | (Overrides ToolStripDropDown..::..OnOpened(EventArgs).)
Protected method | OnOpening | (Overrides ToolStripDropDown..::..OnOpening(CancelEventArgs).)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from ToolStrip.)
Protected method | OnPaintBackground | Raises the Paint event for the ToolStrip background. (Inherited from ToolStrip.)
Protected method | OnPaintGrip | Raises the PaintGrip event. (Inherited from ToolStrip.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ToolStripDropDown.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnRendererChanged | Raises the RendererChanged event. (Inherited from ToolStrip.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ToolStrip.)
Protected method | OnScroll | (Inherited from ToolStrip.)
Protected method | OnSizeChanged | (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from ToolStrip.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from ToolStripDropDown.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ToolStrip.)
Protected method | ProcessDialogChar | Processes a dialog box character. (Inherited from ToolStripDropDown.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from ToolStripDropDown.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from ToolStripDropDown.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetMinimumSize | This method is not relevant for this class. (Inherited from ToolStrip.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Protected method | RestoreFocus | Controls the return location of the focus. (Inherited from ToolStrip.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ToolStripDropDown.)
Protected method | ScaleCore | This method is not relevant to this class. (Inherited from ToolStripDropDown.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from ToolStrip.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | This method is not relevant for this class. (Inherited from ToolStrip.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from ToolStripDropDown.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayedItems | Resets the collection of displayed and overflow items after a layout is done. (Inherited from ToolStrip.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetItemLocation | Anchors a ToolStripItem to a particular place on a ToolStrip. (Inherited from ToolStrip.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Adjusts the size of the owner ToolStrip to accommodate the ToolStripDropDown if the owner ToolStrip is currently displayed, or clears and resets active ToolStripDropDown child controls of the ToolStrip if the ToolStrip is not currently displayed. (Inherited from ToolStripDropDown.)
Public method | Show()()()() | Displays the ToolStripDropDown control in its default position. (Inherited from ToolStripDropDown.)
Public method | Show(Point) | Positions the ToolStripDropDown relative to the specified screen location. (Inherited from ToolStripDropDown.)
Public method | Show(Control) |
Public method | Show(Control, Point) | Positions the ToolStripDropDown relative to the specified control location. (Inherited from ToolStripDropDown.)
Public method | Show(Point, ToolStripDropDownDirection) | Positions the ToolStripDropDown relative to the specified control location and with the specified direction relative to the parent control. (Inherited from ToolStripDropDown.)
Public method | Show(Int32, Int32) | Positions the ToolStripDropDown relative to the specified screen coordinates. (Inherited from ToolStripDropDown.)
Public method | Show(Control, Rectangle) |
Public method | Show(Control, Point, ToolStripDropDownDirection) | Positions the ToolStripDropDown relative to the specified control at the specified location and with the specified direction relative to the parent control. (Inherited from ToolStripDropDown.)
Public method | Show(Control, Int32, Int32) | Positions the ToolStripDropDown relative to the specified control's horizontal and vertical screen coordinates. (Inherited from ToolStripDropDown.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from ToolStrip.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ToolStripDropDown.)

See Also

vToolStripDropDown Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..AccessibilityNotifyClients Method
vToolStripDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vToolStripDropDown Class
vToolStripDropDown Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..BeginInvoke Method
vToolStripDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vToolStripDropDown Class
vToolStripDropDown Members


Close Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..Close Method
vToolStripDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Close()()()() | Closes the ToolStripDropDown control. (Inherited from ToolStripDropDown.)
Public method | Close(ToolStripDropDownCloseReason) | Closes the ToolStripDropDown control for the specified reason. (Inherited from ToolStripDropDown.)

See Also

vToolStripDropDown Class
vToolStripDropDown Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..Dispose Method
vToolStripDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ToolStripDropDown..::..Dispose(Boolean).)

See Also

vToolStripDropDown Class
vToolStripDropDown Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..Dispose Method (Boolean)
vToolStripDropDown Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vToolStripDropDown Class
Dispose Overload


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..GetChildAtPoint Method
vToolStripDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | This method is not relevant for this class. (Inherited from ToolStrip.)

See Also

vToolStripDropDown Class
vToolStripDropDown Members


GetItemAt Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..GetItemAt Method
vToolStripDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetItemAt(Point) | Returns the item located at the specified point in the client area of the ToolStrip. (Inherited from ToolStrip.)
Public method | GetItemAt(Int32, Int32) | Returns the item located at the specified x- and y-coordinates of the ToolStrip client area. (Inherited from ToolStrip.)

See Also

vToolStripDropDown Class
vToolStripDropDown Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..Invalidate Method
vToolStripDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vToolStripDropDown Class
vToolStripDropDown Members


InvalidateRegion Method

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..InvalidateRegion Method
vToolStripDropDown Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected void InvalidateRegion()
Visual Basic
Protected Sub InvalidateRegion
Visual C++
protected:
void InvalidateRegion()

See Also

vToolStripDropDown Class


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..Invoke Method
vToolStripDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vToolStripDropDown Class
vToolStripDropDown Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..MemberwiseClone Method
vToolStripDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vToolStripDropDown Class
vToolStripDropDown Members


OnClosed Method

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..OnClosed Method
vToolStripDropDown Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnClosed(
    ToolStripDropDownClosedEventArgs e
)
Visual Basic
Protected Overrides Sub OnClosed ( _
    e As ToolStripDropDownClosedEventArgs _
)
Visual C++
protected:
virtual void OnClosed(
    ToolStripDropDownClosedEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..ToolStripDropDownClosedEventArgs

See Also

vToolStripDropDown Class


OnClosing Method

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..OnClosing Method
vToolStripDropDown Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnClosing(
    ToolStripDropDownClosingEventArgs e
)
Visual Basic
Protected Overrides Sub OnClosing ( _
    e As ToolStripDropDownClosingEventArgs _
)
Visual C++
protected:
virtual void OnClosing(
    ToolStripDropDownClosingEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..ToolStripDropDownClosingEventArgs

See Also

vToolStripDropDown Class


OnHideAnimationFinished Method

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..OnHideAnimationFinished Method
vToolStripDropDown Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnHideAnimationFinished()
Visual Basic
Protected Overridable Sub OnHideAnimationFinished
Visual C++
protected:
virtual void OnHideAnimationFinished()

See Also

vToolStripDropDown Class


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..OnLayout Method
vToolStripDropDown Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs e
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    e As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..LayoutEventArgs

See Also

vToolStripDropDown Class


OnOpened Method

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..OnOpened Method
vToolStripDropDown Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnOpened(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnOpened ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnOpened(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vToolStripDropDown Class


OnOpening Method

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..OnOpening Method
vToolStripDropDown Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnOpening(
    CancelEventArgs e
)
Visual Basic
Protected Overrides Sub OnOpening ( _
    e As CancelEventArgs _
)
Visual C++
protected:
virtual void OnOpening(
    CancelEventArgs^ e
) override

Parameters

e
Type: System.ComponentModel..::..CancelEventArgs

See Also

vToolStripDropDown Class


OnSizeChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..OnSizeChanged Method
vToolStripDropDown Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnSizeChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnSizeChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSizeChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vToolStripDropDown Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..PerformLayout Method
vToolStripDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vToolStripDropDown Class
vToolStripDropDown Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..ResumeLayout Method
vToolStripDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vToolStripDropDown Class
vToolStripDropDown Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..RtlTranslateAlignment Method
vToolStripDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vToolStripDropDown Class
vToolStripDropDown Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..Scale Method
vToolStripDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vToolStripDropDown Class
vToolStripDropDown Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..Select Method
vToolStripDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from ToolStrip.)

See Also

vToolStripDropDown Class
vToolStripDropDown Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..SetBounds Method
vToolStripDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vToolStripDropDown Class
vToolStripDropDown Members


Show Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..Show Method
vToolStripDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Show()()()() | Displays the ToolStripDropDown control in its default position. (Inherited from ToolStripDropDown.)
Public method | Show(Point) | Positions the ToolStripDropDown relative to the specified screen location. (Inherited from ToolStripDropDown.)
Public method | Show(Control) |
Public method | Show(Control, Point) | Positions the ToolStripDropDown relative to the specified control location. (Inherited from ToolStripDropDown.)
Public method | Show(Point, ToolStripDropDownDirection) | Positions the ToolStripDropDown relative to the specified control location and with the specified direction relative to the parent control. (Inherited from ToolStripDropDown.)
Public method | Show(Int32, Int32) | Positions the ToolStripDropDown relative to the specified screen coordinates. (Inherited from ToolStripDropDown.)
Public method | Show(Control, Rectangle) |
Public method | Show(Control, Point, ToolStripDropDownDirection) | Positions the ToolStripDropDown relative to the specified control at the specified location and with the specified direction relative to the parent control. (Inherited from ToolStripDropDown.)
Public method | Show(Control, Int32, Int32) | Positions the ToolStripDropDown relative to the specified control's horizontal and vertical screen coordinates. (Inherited from ToolStripDropDown.)

See Also

vToolStripDropDown Class
vToolStripDropDown Members


Show Method (Control)

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..Show Method (Control)
vToolStripDropDown Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Show(
    Control control
)
Visual Basic
Public Sub Show ( _
    control As Control _
)
Visual C++
public:
void Show(
    Control^ control
)

Parameters

control
Type: System.Windows.Forms..::..Control

See Also

vToolStripDropDown Class
Show Overload


Show Method (Control, Rectangle)

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..Show Method (Control, Rectangle)
vToolStripDropDown Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Show(
    Control control,
    Rectangle area
)
Visual Basic
Public Sub Show ( _
    control As Control, _
    area As Rectangle _
)
Visual C++
public:
void Show(
    Control^ control,
    Rectangle area
)

Parameters

control
Type: System.Windows.Forms..::..Control
area
Type: System.Drawing..::..Rectangle

See Also

vToolStripDropDown Class
Show Overload


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..UpdateBounds Method
vToolStripDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vToolStripDropDown Class
vToolStripDropDown Members


vToolStripDropDown Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown Properties
vToolStripDropDown Class See Also Send Feedback

The vToolStripDropDown type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether drag-and-drop and item reordering are handled through events that you implement. (Inherited from ToolStrip.)
Public property | AllowItemReorder | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | AllowMerge | Gets or sets a value indicating whether multiple MenuStrip, ToolStripDropDownMenu, ToolStripMenuItem, and other types can be combined. (Inherited from ToolStrip.)
Public property | AllowTransparency | Gets or sets a value indicating whether the Opacity of the form can be adjusted. (Inherited from ToolStripDropDown.)
Public property | Anchor | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | AutoClose | Gets or sets a value indicating whether the ToolStripDropDown control should automatically close when it has lost activation. (Inherited from ToolStripDropDown.)
Public property | AutoScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollMargin | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollMinSize | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoSize | Gets or sets a value indicating whether the ToolStripDropDown automatically adjusts its size when the form is resized. (Inherited from ToolStripDropDown.)
Public property | BackColor | Gets or sets the background color for the ToolStrip. (Inherited from ToolStrip.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the binding context for the ToolStrip. (Inherited from ToolStrip.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanOverflow | Gets or sets a value indicating whether the items in a ToolStripDropDown can be sent to an overflow menu. (Inherited from ToolStripDropDown.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanResize |
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the ToolStrip causes validation to be performed on any controls that require validation when it receives focus. (Inherited from ToolStrip.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content |
Public property | ContextMenu | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | ContextMenuStrip | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | Controls | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Overrides ToolStripDropDown..::..CreateParams.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the ToolStrip. (Inherited from ToolStrip.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultDock | (Inherited from ToolStripDropDown.)
Public property | DefaultDropDownDirection | Gets or sets the direction in which the ToolStripDropDown is displayed relative to the ToolStrip. (Inherited from ToolStripDropDown.)
Protected property | DefaultGripMargin | Gets the default spacing, in pixels, between the sizing grip and the edges of the ToolStrip. (Inherited from ToolStrip.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the spacing, in pixels, between the ToolStrip and the ToolStripContainer. (Inherited from ToolStrip.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from ToolStripDropDown.)
Protected property | DefaultShowItemToolTips | (Inherited from ToolStripDropDown.)
Protected property | DefaultSize | Gets the default size of the ToolStrip. (Inherited from ToolStrip.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | DisplayedItems | Gets the subset of items that are currently displayed on the ToolStrip, including items that are automatically added into the ToolStrip. (Inherited from ToolStrip.)
Public property | DisplayRectangle | Retrieves the current display rectangle. (Inherited from ToolStrip.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropShadowEnabled | Gets or sets a value indicating whether a three-dimensional shadow effect appears when the ToolStripDropDown is displayed. (Inherited from ToolStripDropDown.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | FocusOnPopUp |
Public property | Font | Gets or sets the font of the text displayed on the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the ToolStrip. (Inherited from ToolStrip.)
Public property | GripDisplayStyle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | GripMargin | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | GripRectangle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | GripStyle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImageList | Gets or sets the image list that contains the image displayed on a ToolStrip item. (Inherited from ToolStrip.)
Public property | ImageScalingSize | Gets or sets the size, in pixels, of an image used on a ToolStrip. (Inherited from ToolStrip.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsAutoGenerated | Gets a value indicating whether this ToolStripDropDown was automatically generated. (Inherited from ToolStripDropDown.)
Public property | IsCurrentlyDragging | Gets a value indicating whether the user is currently moving the ToolStrip from one ToolStripContainer to another. (Inherited from ToolStrip.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsDropDown | Gets a value indicating whether a ToolStrip is a ToolStripDropDown control. (Inherited from ToolStrip.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets all the items that belong to a ToolStrip. (Inherited from ToolStrip.)
Public property | LayoutEngine | Passes a reference to the cached LayoutEngine returned by the layout engine interface. (Inherited from ToolStrip.)
Public property | LayoutSettings | Gets or sets layout scheme characteristics. (Inherited from ToolStrip.)
Public property | LayoutStyle | Gets or sets a value indicating how the ToolStrip lays out the items collection. (Inherited from ToolStrip.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Protected property | MaxItemSize | Gets the maximum height and width, in pixels, of the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Determines the opacity of the form. (Inherited from ToolStripDropDown.)
Public property | Orientation | Gets the orientation of the ToolStripPanel. (Inherited from ToolStrip.)
Public property | OverflowButton | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | OwnerItem | Gets or sets the ToolStripItem that is the owner of this ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Panel |
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public property | Renderer | Gets or sets a ToolStripRenderer used to customize the look and feel of a ToolStrip. (Inherited from ToolStrip.)
Public property | RenderMode | Gets or sets the painting styles to be applied to the ToolStrip. (Inherited from ToolStrip.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | (Inherited from ToolStripDropDown.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowItemToolTips | Gets or sets a value indicating whether ToolTips are to be displayed on ToolStrip items. (Inherited from ToolStrip.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Stretch | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | TabIndex | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to an item in the ToolStrip using the TAB key. (Inherited from ToolStrip.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | TextDirection | Specifies the direction in which to draw the text on the item. (Inherited from ToolStripDropDown.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether the ToolStripDropDown is a top-level control. (Inherited from ToolStripDropDown.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Protected property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from ToolStripDropDown.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Visible | Gets or sets a value indicating whether the ToolStripDropDown is visible or hidden. (Inherited from ToolStripDropDown.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vToolStripDropDown Class


CanResize Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..CanResize Property
vToolStripDropDown Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool CanResize { get; set; }
Visual Basic
Public Property CanResize As Boolean
    Get
    Set
Visual C++
public:
property bool CanResize {
    bool get ();
    void set (bool value);
}

See Also

vToolStripDropDown Class


Content Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..Content Property
vToolStripDropDown Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control Content { get; }
Visual Basic
Public ReadOnly Property Content As Control
    Get
Visual C++
public:
property Control^ Content {
    Control^ get ();
}

See Also

vToolStripDropDown Class


CreateParams Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..CreateParams Property
vToolStripDropDown Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override CreateParams CreateParams { get; }
Visual Basic
Protected Overrides ReadOnly Property CreateParams As CreateParams
    Get
Visual C++
protected:
virtual property CreateParams^ CreateParams {
    CreateParams^ get () override;
}

See Also

vToolStripDropDown Class


FocusOnPopUp Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..FocusOnPopUp Property
vToolStripDropDown Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool FocusOnPopUp { get; set; }
Visual Basic
Public Property FocusOnPopUp As Boolean
    Get
    Set
Visual C++
public:
property bool FocusOnPopUp {
    bool get ();
    void set (bool value);
}

See Also

vToolStripDropDown Class


Panel Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..Panel Property
vToolStripDropDown Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Panel Panel { get; }
Visual Basic
Public ReadOnly Property Panel As Panel
    Get
Visual C++
public:
property Panel^ Panel {
    Panel^ get ();
}

See Also

vToolStripDropDown Class


vToolStripDropDown Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown Events
vToolStripDropDown Class See Also Send Feedback

The vToolStripDropDown type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property has changed. (Inherited from ToolStrip.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ToolStripDropDown.)
Public event | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ToolStripDropDown.)
Public event | BeginDrag | Occurs when the user begins to drag the ToolStrip control. (Inherited from ToolStrip.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from ToolStripDropDown.)
Public event | CausesValidationChanged | Occurs when the CausesValidation property changes. (Inherited from ToolStrip.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from ToolStripDropDown.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the ToolStripDropDown is closed. (Inherited from ToolStripDropDown.)
Public event | Closing | Occurs when the ToolStripDropDown control is about to close. (Inherited from ToolStripDropDown.)
Public event | ContextMenuChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | ContextMenuStripChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | ControlAdded | This event is not relevant for this class. (Inherited from ToolStrip.)
Public event | ControlRemoved | This event is not relevant for this class. (Inherited from ToolStrip.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from ToolStrip.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | EndDrag | Occurs when the user stops dragging the ToolStrip control. (Inherited from ToolStrip.)
Public event | Enter | Occurs when the focus enters the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public event | FontChanged | Occurs when the value of the Font property changes. (Inherited from ToolStripDropDown.)
Public event | ForeColorChanged | Occurs when the value of the ForeColor property changes. (Inherited from ToolStripDropDown.)
Public event | GiveFeedback | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from ToolStripDropDown.)
Public event | HideAnimationFinished | Occurs when hide animation has finished
Public event | ImeModeChanged | Occurs when the ImeModeChanged property has changed. (Inherited from ToolStripDropDown.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemAdded | Occurs when a new ToolStripItem is added to the ToolStripItemCollection. (Inherited from ToolStrip.)
Public event | ItemClicked | Occurs when the ToolStripItem is clicked. (Inherited from ToolStrip.)
Public event | ItemRemoved | Occurs when a ToolStripItem is removed from the ToolStripItemCollection. (Inherited from ToolStrip.)
Public event | KeyDown | Occurs when a key is pressed and held down while the ToolStripDropDown has focus. (Inherited from ToolStripDropDown.)
Public event | KeyPress | Occurs when a key is pressed while the ToolStripDropDown has focus. (Inherited from ToolStripDropDown.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from ToolStripDropDown.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | LayoutCompleted | Occurs when the layout of the ToolStrip is complete. (Inherited from ToolStrip.)
Public event | LayoutStyleChanged | Occurs when the value of the LayoutStyle property changes. (Inherited from ToolStrip.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from ToolStripDropDown.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | Opened | Occurs when the ToolStripDropDown is opened. (Inherited from ToolStripDropDown.)
Public event | Opening | Occurs when the ToolStripDropDown control is opening. (Inherited from ToolStripDropDown.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintGrip | Occurs when the ToolStrip move handle is painted. (Inherited from ToolStrip.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from ToolStripDropDown.)
Public event | RendererChanged | Occurs when the value of the Renderer property changes. (Inherited from ToolStrip.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the ToolStripLayoutStyle style changes. (Inherited from ToolStripDropDown.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | TabStopChanged | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | TextChanged | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | Validated | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | Validating | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vToolStripDropDown Class


HideAnimationFinished Event

[image]

VIBlend Controls for WinForms Help Documentation
vToolStripDropDown..::..HideAnimationFinished Event
vToolStripDropDown Class See Also Send Feedback
Occurs when hide animation has finished

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler HideAnimationFinished
Visual Basic
Public Event HideAnimationFinished As EventHandler
Visual C++
public:
 event EventHandler^ HideAnimationFinished {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vToolStripDropDown Class


vToolTip Class

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip Class
Members See Also Send Feedback
Represents a vTooltip control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vToolTip : ScrollableControlMiniBase
Visual Basic
Public Class vToolTip _
    Inherits ScrollableControlMiniBase
Visual C++
public ref class vToolTip : public ScrollableControlMiniBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
ScrollableControlMiniBase
VIBlend.WinForms.Controls..::..vToolTip

See Also

vToolTip Members


vToolTip Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip Members
vToolTip Class Constructors Methods Properties Events See Also Send Feedback

The vToolTip type exposes the following members.

Constructors

 | Name | Description
Public method | vToolTip | Initializes a new instance of the vToolTip class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawImage |
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HideTooltip | Hides the tooltip.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowTooltip()()()() | Shows the tooltip.
Public method | ShowTooltip(Point) |
Public method | ShowTooltip(Point, Control) |
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AbsoluteShowPosition | Gets or sets the absolute show position.
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoPopDelay | Gets or sets the auto pop delay.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentMargin | Gets or sets the content margin.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DescriptionRelativeSizeProportion | Gets or sets the decription relative size proportion.
Public property | DescriptionText | Gets or sets the description text.
Public property | DescriptionTextAlignment | Gets or sets the description text alignment.
Public property | DescriptionTextColor | Gets or sets the color of the description text.
Public property | DescriptionTextFont | Gets or sets the description text font.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DrawFooterLine | Gets or sets a value indicating whether to draw a footer line.
Public property | DrawHeaderLine | Gets or sets a value indicating whether to draw a Header line.
Public property | DrawImageBeforeText | Gets or sets a value indicating whether to draw the image before the text
Public property | DropDownShowDirection | Gets or sets the drop down direction.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control.
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | FooterIcon | Gets or sets the footer icon.
Public property | FooterRelativeSizeProportion | Gets or sets the footer relative size proportion.
Public property | FooterText | Gets or sets the footer text.
Public property | FooterTextAlignment | Gets or sets the footer text alignment.
Public property | FooterTextColor | Gets or sets the color of the footer text.
Public property | FooterTextFont | Gets or sets the footer text font.
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GradientStyle | Gets or sets the gradient style.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | HeaderRelativeSizeProportion | Gets or sets the header relative size proportion.
Public property | HeaderText | Gets or sets the header text.
Public property | HeaderTextAlignment | Gets or sets the header text alignment.
Public property | HeaderTextColor | Gets or sets the color of the header text.
Public property | HeaderTextFont | Gets or sets the header text font.
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | Image | Gets or sets the image.
Public property | ImageAlignment | Gets or sets the image alignment.
Public property | ImageRelativeSizeProportion | Gets or sets the Image relative size proportion.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InitialDelay | Gets or sets the initial delay.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsShown | Gets a value indicating whether this instance is shown.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | OwnerControl | Gets or sets the owner control.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ShowBelowOwner | Gets or sets whether to show the drop down below the owner control.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackColor | Gets or sets a value indicating whether to use the backcolor from the theme
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vToolTip Class


vToolTip Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip Constructor
vToolTip Class See Also Send Feedback
Initializes a new instance of the vToolTip class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vToolTip()
Visual Basic
Public Sub New
Visual C++
public:
vToolTip()

See Also

vToolTip Class


vToolTip Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip Methods
vToolTip Class See Also Send Feedback

The vToolTip type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawImage |
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HideTooltip | Hides the tooltip.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides Control..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowTooltip()()()() | Shows the tooltip.
Public method | ShowTooltip(Point) |
Public method | ShowTooltip(Point, Control) |
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vToolTip Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..AccessibilityNotifyClients Method
vToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vToolTip Class
vToolTip Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..BeginInvoke Method
vToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vToolTip Class
vToolTip Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..Dispose Method
vToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)

See Also

vToolTip Class
vToolTip Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..Dispose Method (Boolean)
vToolTip Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vToolTip Class
Dispose Overload


DrawImage Method

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..DrawImage Method
vToolTip Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected void DrawImage(
    Graphics g,
    Image image,
    Rectangle r,
    ContentAlignment align
)
Visual Basic
Protected Sub DrawImage ( _
    g As Graphics, _
    image As Image, _
    r As Rectangle, _
    align As ContentAlignment _
)
Visual C++
protected:
void DrawImage(
    Graphics^ g,
    Image^ image,
    Rectangle r,
    ContentAlignment align
)

Parameters

g
Type: System.Drawing..::..Graphics
image
Type: System.Drawing..::..Image
r
Type: System.Drawing..::..Rectangle
align
Type: System.Drawing..::..ContentAlignment

See Also

vToolTip Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..GetChildAtPoint Method
vToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vToolTip Class
vToolTip Members


HideTooltip Method

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..HideTooltip Method
vToolTip Class See Also Send Feedback
Hides the tooltip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void HideTooltip()
Visual Basic
Public Sub HideTooltip
Visual C++
public:
void HideTooltip()

See Also

vToolTip Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..Invalidate Method
vToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vToolTip Class
vToolTip Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..Invoke Method
vToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vToolTip Class
vToolTip Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..MemberwiseClone Method
vToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vToolTip Class
vToolTip Members


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..OnLayout Method
vToolTip Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs

See Also

vToolTip Class


OnMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..OnMouseLeave Method
vToolTip Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vToolTip Class


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..OnMouseMove Method
vToolTip Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vToolTip Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..OnPaint Method
vToolTip Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vToolTip Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..PerformLayout Method
vToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vToolTip Class
vToolTip Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..ResumeLayout Method
vToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vToolTip Class
vToolTip Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..RtlTranslateAlignment Method
vToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vToolTip Class
vToolTip Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..Scale Method
vToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vToolTip Class
vToolTip Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..Select Method
vToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vToolTip Class
vToolTip Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..SetBounds Method
vToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vToolTip Class
vToolTip Members


ShowTooltip Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..ShowTooltip Method
vToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowTooltip()()()() | Shows the tooltip.
Public method | ShowTooltip(Point) |
Public method | ShowTooltip(Point, Control) |

See Also

vToolTip Class
vToolTip Members


ShowTooltip Method

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..ShowTooltip Method
vToolTip Class See Also Send Feedback
Shows the tooltip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ShowTooltip()
Visual Basic
Public Sub ShowTooltip
Visual C++
public:
void ShowTooltip()

See Also

vToolTip Class
ShowTooltip Overload


ShowTooltip Method (Point)

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..ShowTooltip Method (Point)
vToolTip Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ShowTooltip(
    Point point
)
Visual Basic
Public Sub ShowTooltip ( _
    point As Point _
)
Visual C++
public:
void ShowTooltip(
    Point point
)

Parameters

point
Type: System.Drawing..::..Point

See Also

vToolTip Class
ShowTooltip Overload


ShowTooltip Method (Point, Control)

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..ShowTooltip Method (Point, Control)
vToolTip Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ShowTooltip(
    Point point,
    Control owner
)
Visual Basic
Public Sub ShowTooltip ( _
    point As Point, _
    owner As Control _
)
Visual C++
public:
void ShowTooltip(
    Point point,
    Control^ owner
)

Parameters

point
Type: System.Drawing..::..Point
owner
Type: System.Windows.Forms..::..Control

See Also

vToolTip Class
ShowTooltip Overload


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..UpdateBounds Method
vToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vToolTip Class
vToolTip Members


vToolTip Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip Properties
vToolTip Class See Also Send Feedback

The vToolTip type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteShowPosition | Gets or sets the absolute show position.
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoPopDelay | Gets or sets the auto pop delay.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentMargin | Gets or sets the content margin.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DescriptionRelativeSizeProportion | Gets or sets the decription relative size proportion.
Public property | DescriptionText | Gets or sets the description text.
Public property | DescriptionTextAlignment | Gets or sets the description text alignment.
Public property | DescriptionTextColor | Gets or sets the color of the description text.
Public property | DescriptionTextFont | Gets or sets the description text font.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DrawFooterLine | Gets or sets a value indicating whether to draw a footer line.
Public property | DrawHeaderLine | Gets or sets a value indicating whether to draw a Header line.
Public property | DrawImageBeforeText | Gets or sets a value indicating whether to draw the image before the text
Public property | DropDownShowDirection | Gets or sets the drop down direction.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control.
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | FooterIcon | Gets or sets the footer icon.
Public property | FooterRelativeSizeProportion | Gets or sets the footer relative size proportion.
Public property | FooterText | Gets or sets the footer text.
Public property | FooterTextAlignment | Gets or sets the footer text alignment.
Public property | FooterTextColor | Gets or sets the color of the footer text.
Public property | FooterTextFont | Gets or sets the footer text font.
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GradientStyle | Gets or sets the gradient style.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | HeaderRelativeSizeProportion | Gets or sets the header relative size proportion.
Public property | HeaderText | Gets or sets the header text.
Public property | HeaderTextAlignment | Gets or sets the header text alignment.
Public property | HeaderTextColor | Gets or sets the color of the header text.
Public property | HeaderTextFont | Gets or sets the header text font.
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | Image | Gets or sets the image.
Public property | ImageAlignment | Gets or sets the image alignment.
Public property | ImageRelativeSizeProportion | Gets or sets the Image relative size proportion.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InitialDelay | Gets or sets the initial delay.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsShown | Gets a value indicating whether this instance is shown.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | OwnerControl | Gets or sets the owner control.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ShowBelowOwner | Gets or sets whether to show the drop down below the owner control.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Protected property | StyleKey | Gets or sets the style key.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackColor | Gets or sets a value indicating whether to use the backcolor from the theme
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vToolTip Class


AbsoluteShowPosition Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..AbsoluteShowPosition Property
vToolTip Class See Also Send Feedback
Gets or sets the absolute show position.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Point AbsoluteShowPosition { get; set; }
Visual Basic
Public Property AbsoluteShowPosition As Point
    Get
    Set
Visual C++
public:
property Point AbsoluteShowPosition {
    Point get ();
    void set (Point value);
}

Field Value

The absolute show position.

See Also

vToolTip Class


AutoPopDelay Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..AutoPopDelay Property
vToolTip Class See Also Send Feedback
Gets or sets the auto pop delay.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int AutoPopDelay { get; set; }
Visual Basic
Public Property AutoPopDelay As Integer
    Get
    Set
Visual C++
public:
property int AutoPopDelay {
    int get ();
    void set (int value);
}

Field Value

The auto pop delay.

See Also

vToolTip Class


ContentMargin Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..ContentMargin Property
vToolTip Class See Also Send Feedback
Gets or sets the content margin.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Padding ContentMargin { get; set; }
Visual Basic
Public Property ContentMargin As Padding
    Get
    Set
Visual C++
public:
property Padding ContentMargin {
    Padding get ();
    void set (Padding value);
}

Field Value

The content margin.

See Also

vToolTip Class


DescriptionRelativeSizeProportion Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..DescriptionRelativeSizeProportion Property
vToolTip Class See Also Send Feedback
Gets or sets the decription relative size proportion.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public SizeF DescriptionRelativeSizeProportion { get; set; }
Visual Basic
Public Property DescriptionRelativeSizeProportion As SizeF
    Get
    Set
Visual C++
public:
property SizeF DescriptionRelativeSizeProportion {
    SizeF get ();
    void set (SizeF value);
}

Field Value

The decription relative size proportion.

See Also

vToolTip Class


DescriptionText Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..DescriptionText Property
vToolTip Class See Also Send Feedback
Gets or sets the description text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string DescriptionText { get; set; }
Visual Basic
Public Property DescriptionText As String
    Get
    Set
Visual C++
public:
property String^ DescriptionText {
    String^ get ();
    void set (String^ value);
}

Field Value

The description text.

See Also

vToolTip Class


DescriptionTextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..DescriptionTextAlignment Property
vToolTip Class See Also Send Feedback
Gets or sets the description text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment DescriptionTextAlignment { get; set; }
Visual Basic
Public Property DescriptionTextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment DescriptionTextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The description text alignment.

See Also

vToolTip Class


DescriptionTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..DescriptionTextColor Property
vToolTip Class See Also Send Feedback
Gets or sets the color of the description text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DescriptionTextColor { get; set; }
Visual Basic
Public Property DescriptionTextColor As Color
    Get
    Set
Visual C++
public:
property Color DescriptionTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the description text.

See Also

vToolTip Class


DescriptionTextFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..DescriptionTextFont Property
vToolTip Class See Also Send Feedback
Gets or sets the description text font.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font DescriptionTextFont { get; set; }
Visual Basic
Public Property DescriptionTextFont As Font
    Get
    Set
Visual C++
public:
property Font^ DescriptionTextFont {
    Font^ get ();
    void set (Font^ value);
}

Field Value

The description text font.

See Also

vToolTip Class


DrawFooterLine Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..DrawFooterLine Property
vToolTip Class See Also Send Feedback
Gets or sets a value indicating whether to draw a footer line.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool DrawFooterLine { get; set; }
Visual Basic
Public Property DrawFooterLine As Boolean
    Get
    Set
Visual C++
public:
property bool DrawFooterLine {
    bool get ();
    void set (bool value);
}

See Also

vToolTip Class


DrawHeaderLine Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..DrawHeaderLine Property
vToolTip Class See Also Send Feedback
Gets or sets a value indicating whether to draw a Header line.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool DrawHeaderLine { get; set; }
Visual Basic
Public Property DrawHeaderLine As Boolean
    Get
    Set
Visual C++
public:
property bool DrawHeaderLine {
    bool get ();
    void set (bool value);
}

See Also

vToolTip Class


DrawImageBeforeText Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..DrawImageBeforeText Property
vToolTip Class See Also Send Feedback
Gets or sets a value indicating whether to draw the image before the text

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool DrawImageBeforeText { get; set; }
Visual Basic
Public Property DrawImageBeforeText As Boolean
    Get
    Set
Visual C++
public:
property bool DrawImageBeforeText {
    bool get ();
    void set (bool value);
}

See Also

vToolTip Class


DropDownShowDirection Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..DropDownShowDirection Property
vToolTip Class See Also Send Feedback
Gets or sets the drop down direction.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ToolStripDropDownDirection DropDownShowDirection { get; set; }
Visual Basic
Public Property DropDownShowDirection As ToolStripDropDownDirection
    Get
    Set
Visual C++
public:
property ToolStripDropDownDirection DropDownShowDirection {
    ToolStripDropDownDirection get ();
    void set (ToolStripDropDownDirection value);
}

Field Value

The drop down show direction.

See Also

vToolTip Class


Font Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..Font Property
vToolTip Class See Also Send Feedback
Gets or sets the font of the text displayed by the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font Font { get; set; }
Visual Basic
Public Property Font As Font
    Get
    Set
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

Field Value

Return Value

The Font to apply to the text displayed by the control. The default is the value of the DefaultFont property.

See Also

vToolTip Class


FooterIcon Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..FooterIcon Property
vToolTip Class See Also Send Feedback
Gets or sets the footer icon.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Icon FooterIcon { get; set; }
Visual Basic
Public Property FooterIcon As Icon
    Get
    Set
Visual C++
public:
property Icon^ FooterIcon {
    Icon^ get ();
    void set (Icon^ value);
}

Field Value

The footer icon.

See Also

vToolTip Class


FooterRelativeSizeProportion Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..FooterRelativeSizeProportion Property
vToolTip Class See Also Send Feedback
Gets or sets the footer relative size proportion.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public SizeF FooterRelativeSizeProportion { get; set; }
Visual Basic
Public Property FooterRelativeSizeProportion As SizeF
    Get
    Set
Visual C++
public:
property SizeF FooterRelativeSizeProportion {
    SizeF get ();
    void set (SizeF value);
}

Field Value

The footer relative size proportion.

See Also

vToolTip Class


FooterText Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..FooterText Property
vToolTip Class See Also Send Feedback
Gets or sets the footer text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string FooterText { get; set; }
Visual Basic
Public Property FooterText As String
    Get
    Set
Visual C++
public:
property String^ FooterText {
    String^ get ();
    void set (String^ value);
}

Field Value

The footer text.

See Also

vToolTip Class


FooterTextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..FooterTextAlignment Property
vToolTip Class See Also Send Feedback
Gets or sets the footer text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment FooterTextAlignment { get; set; }
Visual Basic
Public Property FooterTextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment FooterTextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The footer text alignment.

See Also

vToolTip Class


FooterTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..FooterTextColor Property
vToolTip Class See Also Send Feedback
Gets or sets the color of the footer text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color FooterTextColor { get; set; }
Visual Basic
Public Property FooterTextColor As Color
    Get
    Set
Visual C++
public:
property Color FooterTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the footer text.

See Also

vToolTip Class


FooterTextFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..FooterTextFont Property
vToolTip Class See Also Send Feedback
Gets or sets the footer text font.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font FooterTextFont { get; set; }
Visual Basic
Public Property FooterTextFont As Font
    Get
    Set
Visual C++
public:
property Font^ FooterTextFont {
    Font^ get ();
    void set (Font^ value);
}

Field Value

The footer text font.

See Also

vToolTip Class


GradientStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..GradientStyle Property
vToolTip Class See Also Send Feedback
Gets or sets the gradient style.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GradientStyles GradientStyle { get; set; }
Visual Basic
Public Property GradientStyle As GradientStyles
    Get
    Set
Visual C++
public:
property GradientStyles GradientStyle {
    GradientStyles get ();
    void set (GradientStyles value);
}

Field Value

The gradient style.

See Also

vToolTip Class


HeaderRelativeSizeProportion Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..HeaderRelativeSizeProportion Property
vToolTip Class See Also Send Feedback
Gets or sets the header relative size proportion.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public SizeF HeaderRelativeSizeProportion { get; set; }
Visual Basic
Public Property HeaderRelativeSizeProportion As SizeF
    Get
    Set
Visual C++
public:
property SizeF HeaderRelativeSizeProportion {
    SizeF get ();
    void set (SizeF value);
}

Field Value

The header relative size proportion.

See Also

vToolTip Class


HeaderText Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..HeaderText Property
vToolTip Class See Also Send Feedback
Gets or sets the header text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string HeaderText { get; set; }
Visual Basic
Public Property HeaderText As String
    Get
    Set
Visual C++
public:
property String^ HeaderText {
    String^ get ();
    void set (String^ value);
}

Field Value

The header text.

See Also

vToolTip Class


HeaderTextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..HeaderTextAlignment Property
vToolTip Class See Also Send Feedback
Gets or sets the header text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment HeaderTextAlignment { get; set; }
Visual Basic
Public Property HeaderTextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment HeaderTextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The header text alignment.

See Also

vToolTip Class


HeaderTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..HeaderTextColor Property
vToolTip Class See Also Send Feedback
Gets or sets the color of the header text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color HeaderTextColor { get; set; }
Visual Basic
Public Property HeaderTextColor As Color
    Get
    Set
Visual C++
public:
property Color HeaderTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the header text.

See Also

vToolTip Class


HeaderTextFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..HeaderTextFont Property
vToolTip Class See Also Send Feedback
Gets or sets the header text font.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font HeaderTextFont { get; set; }
Visual Basic
Public Property HeaderTextFont As Font
    Get
    Set
Visual C++
public:
property Font^ HeaderTextFont {
    Font^ get ();
    void set (Font^ value);
}

Field Value

The header text font.

See Also

vToolTip Class


Image Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..Image Property
vToolTip Class See Also Send Feedback
Gets or sets the image.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Image Image { get; set; }
Visual Basic
Public Property Image As Image
    Get
    Set
Visual C++
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}

Field Value

The image.

See Also

vToolTip Class


ImageAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..ImageAlignment Property
vToolTip Class See Also Send Feedback
Gets or sets the image alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment ImageAlignment { get; set; }
Visual Basic
Public Property ImageAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment ImageAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The image alignment.

See Also

vToolTip Class


ImageRelativeSizeProportion Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..ImageRelativeSizeProportion Property
vToolTip Class See Also Send Feedback
Gets or sets the Image relative size proportion.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public SizeF ImageRelativeSizeProportion { get; set; }
Visual Basic
Public Property ImageRelativeSizeProportion As SizeF
    Get
    Set
Visual C++
public:
property SizeF ImageRelativeSizeProportion {
    SizeF get ();
    void set (SizeF value);
}

Field Value

The Image relative size proportion.

See Also

vToolTip Class


InitialDelay Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..InitialDelay Property
vToolTip Class See Also Send Feedback
Gets or sets the initial delay.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int InitialDelay { get; set; }
Visual Basic
Public Property InitialDelay As Integer
    Get
    Set
Visual C++
public:
property int InitialDelay {
    int get ();
    void set (int value);
}

Field Value

The initial delay.

See Also

vToolTip Class


IsShown Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..IsShown Property
vToolTip Class See Also Send Feedback
Gets a value indicating whether this instance is shown.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsShown { get; }
Visual Basic
Public ReadOnly Property IsShown As Boolean
    Get
Visual C++
public:
property bool IsShown {
    bool get ();
}

Field Value

true if this instance is shown; otherwise, false.

See Also

vToolTip Class


OwnerControl Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..OwnerControl Property
vToolTip Class See Also Send Feedback
Gets or sets the owner control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control OwnerControl { get; set; }
Visual Basic
Public Property OwnerControl As Control
    Get
    Set
Visual C++
public:
property Control^ OwnerControl {
    Control^ get ();
    void set (Control^ value);
}

Field Value

The owner control.

See Also

vToolTip Class


ShowBelowOwner Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..ShowBelowOwner Property
vToolTip Class See Also Send Feedback
Gets or sets whether to show the drop down below the owner control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowBelowOwner { get; set; }
Visual Basic
Public Property ShowBelowOwner As Boolean
    Get
    Set
Visual C++
public:
property bool ShowBelowOwner {
    bool get ();
    void set (bool value);
}

See Also

vToolTip Class


StyleKey Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..StyleKey Property
vToolTip Class See Also Send Feedback
Gets or sets the style key.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual string StyleKey { get; set; }
Visual Basic
Protected Overridable Property StyleKey As String
    Get
    Set
Visual C++
protected:
virtual property String^ StyleKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The style key.

See Also

vToolTip Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..Theme Property
vToolTip Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vToolTip Class


UseThemeBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..UseThemeBackColor Property
vToolTip Class See Also Send Feedback
Gets or sets a value indicating whether to use the backcolor from the theme

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBackColor { get; set; }
Visual Basic
Public Property UseThemeBackColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBackColor {
    bool get ();
    void set (bool value);
}

See Also

vToolTip Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vToolTip..::..VIBlendTheme Property
vToolTip Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vToolTip Class


vToolTip Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vToolTip Events
vToolTip Class See Also Send Feedback

The vToolTip type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vToolTip Class


vTrackBar Class

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar Class
Members See Also Send Feedback
Represents a vTrackBar control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vTrackBar : Control, IScrollableControlBase
Visual Basic
Public Class vTrackBar _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class vTrackBar : public Control,
    IScrollableControlBase

Remarks

vTrackBar displays a slider which allows the user to indicate the progress of an operation. TrackBar controls are often called sliders.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vTrackBar

See Also

vTrackBar Members


vTrackBar Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTrackBar Members
vTrackBar Class Constructors Methods Properties Events See Also Send Feedback

The vTrackBar type exposes the following members.

Constructors

 | Name | Description
Public method | vTrackBar | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBackFillAndProgress | Draws the back fill and progress.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Protected method | DrawTrackBar | Draws the track bar.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundBorder | Gets or sets the background border.
Public property | BackgroundBrush | Gets or sets the background brush.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value property when the thumb is moved a large distance.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the Maximum value for the track bar's position.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the Minimum value for the track bar's position.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | Gets or sets the orientation of the track bar.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ProgressBackgroundBorder | Gets or sets the selectedBackground border.
Public property | ProgressBackgroundBrush | Gets or sets the background brush.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded
Public property | RoundedCornersMaskThumb | Gets or sets the mask that determines which corners for the TrackBar's Thumb are rounded
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius.
Public property | RoundedCornersRadiusThumb | Gets or sets the rounded corners radius of the TrackBar's Thumb.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmallChange | Gets or sets the value added to or subtracted from the Value property when the thumb is moved a small distance.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control.
Public property | ThumbBackgroundBorder | Gets or sets the background thumb border.
Public property | ThumbBackgroundBrush | Gets or sets the thumb background brush.
Public property | ThumbHighlightBackgroundBorder | Gets or sets the background thumb border.
Public property | ThumbHighlightBackgroundBrush | Gets or sets the thumb Highlight background brush.
Public property | ThumbPressedBackgroundBorder | Gets or sets the background thumb border.
Public property | ThumbPressedBackgroundBrush | Gets or sets the thumb Pressed background brush.
Public property | ThumbSize | Gets or sets the size of the track bar's thumb.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the value of the track bar control.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when either a mouse or keyboard action moves the scroll box.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when the Value property of a track bar changes, either by movement of the scroll box or programmatically.
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vTrackBar Class


vTrackBar Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar Constructor
vTrackBar Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTrackBar()
Visual Basic
Public Sub New
Visual C++
public:
vTrackBar()

See Also

vTrackBar Class


vTrackBar Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTrackBar Methods
vTrackBar Class See Also Send Feedback

The vTrackBar type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawBackFillAndProgress | Draws the back fill and progress.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Protected method | DrawTrackBar | Draws the track bar.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vTrackBar Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..AccessibilityNotifyClients Method
vTrackBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vTrackBar Class
vTrackBar Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..BeginInvoke Method
vTrackBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vTrackBar Class
vTrackBar Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..Dispose Method
vTrackBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vTrackBar Class
vTrackBar Members


DrawBackFillAndProgress Method

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..DrawBackFillAndProgress Method
vTrackBar Class See Also Send Feedback
Draws the back fill and progress.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DrawBackFillAndProgress(
    Graphics g,
    Rectangle rect
)
Visual Basic
Protected Overridable Sub DrawBackFillAndProgress ( _
    g As Graphics, _
    rect As Rectangle _
)
Visual C++
protected:
virtual void DrawBackFillAndProgress(
    Graphics^ g,
    Rectangle rect
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
rect
Type: System.Drawing..::..Rectangle
The rect.

See Also

vTrackBar Class


DrawTrackBar Method

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..DrawTrackBar Method
vTrackBar Class See Also Send Feedback
Draws the track bar.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DrawTrackBar(
    PaintEventArgs e
)
Visual Basic
Protected Overridable Sub DrawTrackBar ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void DrawTrackBar(
    PaintEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
The PaintEventArgs instance containing the event data.

See Also

vTrackBar Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..GetChildAtPoint Method
vTrackBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vTrackBar Class
vTrackBar Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..Invalidate Method
vTrackBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vTrackBar Class
vTrackBar Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..Invoke Method
vTrackBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vTrackBar Class
vTrackBar Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..MemberwiseClone Method
vTrackBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vTrackBar Class
vTrackBar Members


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..PerformLayout Method
vTrackBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vTrackBar Class
vTrackBar Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..ResumeLayout Method
vTrackBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vTrackBar Class
vTrackBar Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..RtlTranslateAlignment Method
vTrackBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vTrackBar Class
vTrackBar Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..Scale Method
vTrackBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vTrackBar Class
vTrackBar Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..Select Method
vTrackBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vTrackBar Class
vTrackBar Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..SetBounds Method
vTrackBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vTrackBar Class
vTrackBar Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..UpdateBounds Method
vTrackBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vTrackBar Class
vTrackBar Members


vTrackBar Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTrackBar Properties
vTrackBar Class See Also Send Feedback

The vTrackBar type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundBorder | Gets or sets the background border.
Public property | BackgroundBrush | Gets or sets the background brush.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value property when the thumb is moved a large distance.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the Maximum value for the track bar's position.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the Minimum value for the track bar's position.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | Gets or sets the orientation of the track bar.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ProgressBackgroundBorder | Gets or sets the selectedBackground border.
Public property | ProgressBackgroundBrush | Gets or sets the background brush.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded
Public property | RoundedCornersMaskThumb | Gets or sets the mask that determines which corners for the TrackBar's Thumb are rounded
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius.
Public property | RoundedCornersRadiusThumb | Gets or sets the rounded corners radius of the TrackBar's Thumb.
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmallChange | Gets or sets the value added to or subtracted from the Value property when the thumb is moved a small distance.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control.
Public property | ThumbBackgroundBorder | Gets or sets the background thumb border.
Public property | ThumbBackgroundBrush | Gets or sets the thumb background brush.
Public property | ThumbHighlightBackgroundBorder | Gets or sets the background thumb border.
Public property | ThumbHighlightBackgroundBrush | Gets or sets the thumb Highlight background brush.
Public property | ThumbPressedBackgroundBorder | Gets or sets the background thumb border.
Public property | ThumbPressedBackgroundBrush | Gets or sets the thumb Pressed background brush.
Public property | ThumbSize | Gets or sets the size of the track bar's thumb.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the value of the track bar control.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vTrackBar Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..AllowAnimations Property
vTrackBar Class See Also Send Feedback
Gets or sets whether the control is animated

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vTrackBar Class


BackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..BackgroundBorder Property
vTrackBar Class See Also Send Feedback
Gets or sets the background border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BackgroundBorder { get; set; }
Visual Basic
Public Property BackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color BackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The background border.

See Also

vTrackBar Class


BackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..BackgroundBrush Property
vTrackBar Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush BackgroundBrush { get; set; }
Visual Basic
Public Property BackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ BackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vTrackBar Class


LargeChange Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..LargeChange Property
vTrackBar Class See Also Send Feedback
Gets or sets a value to be added to or subtracted from the Value property when the thumb is moved a large distance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int LargeChange { get; set; }
Visual Basic
Public Property LargeChange As Integer
    Get
    Set
Visual C++
public:
property int LargeChange {
    int get ();
    void set (int value);
}

See Also

vTrackBar Class


Maximum Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..Maximum Property
vTrackBar Class See Also Send Feedback
Gets or sets the Maximum value for the track bar's position.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Maximum { get; set; }
Visual Basic
Public Property Maximum As Integer
    Get
    Set
Visual C++
public:
property int Maximum {
    int get ();
    void set (int value);
}

See Also

vTrackBar Class


Minimum Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..Minimum Property
vTrackBar Class See Also Send Feedback
Gets or sets the Minimum value for the track bar's position.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Minimum { get; set; }
Visual Basic
Public Property Minimum As Integer
    Get
    Set
Visual C++
public:
property int Minimum {
    int get ();
    void set (int value);
}

See Also

vTrackBar Class


Orientation Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..Orientation Property
vTrackBar Class See Also Send Feedback
Gets or sets the orientation of the track bar.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic
Public Property Orientation As Orientation
    Get
    Set
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

vTrackBar Class


ProgressBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..ProgressBackgroundBorder Property
vTrackBar Class See Also Send Feedback
Gets or sets the selectedBackground border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color ProgressBackgroundBorder { get; set; }
Visual Basic
Public Property ProgressBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color ProgressBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The selectedBackground border.

See Also

vTrackBar Class


ProgressBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..ProgressBackgroundBrush Property
vTrackBar Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush ProgressBackgroundBrush { get; set; }
Visual Basic
Public Property ProgressBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ ProgressBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vTrackBar Class


RoundedCornersMask Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..RoundedCornersMask Property
vTrackBar Class See Also Send Feedback
Gets or sets the mask that determines which corners are rounded

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public byte RoundedCornersMask { get; set; }
Visual Basic
Public Property RoundedCornersMask As Byte
    Get
    Set
Visual C++
public:
property unsigned char RoundedCornersMask {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

vTrackBar Class


RoundedCornersMaskThumb Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..RoundedCornersMaskThumb Property
vTrackBar Class See Also Send Feedback
Gets or sets the mask that determines which corners for the TrackBar's Thumb are rounded

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public byte RoundedCornersMaskThumb { get; set; }
Visual Basic
Public Property RoundedCornersMaskThumb As Byte
    Get
    Set
Visual C++
public:
property unsigned char RoundedCornersMaskThumb {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

vTrackBar Class


RoundedCornersRadius Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..RoundedCornersRadius Property
vTrackBar Class See Also Send Feedback
Gets or sets the rounded corners radius.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int RoundedCornersRadius { get; set; }
Visual Basic
Public Property RoundedCornersRadius As Integer
    Get
    Set
Visual C++
public:
property int RoundedCornersRadius {
    int get ();
    void set (int value);
}

See Also

vTrackBar Class


RoundedCornersRadiusThumb Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..RoundedCornersRadiusThumb Property
vTrackBar Class See Also Send Feedback
Gets or sets the rounded corners radius of the TrackBar's Thumb.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int RoundedCornersRadiusThumb { get; set; }
Visual Basic
Public Property RoundedCornersRadiusThumb As Integer
    Get
    Set
Visual C++
public:
property int RoundedCornersRadiusThumb {
    int get ();
    void set (int value);
}

See Also

vTrackBar Class


SmallChange Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..SmallChange Property
vTrackBar Class See Also Send Feedback
Gets or sets the value added to or subtracted from the Value property when the thumb is moved a small distance.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int SmallChange { get; set; }
Visual Basic
Public Property SmallChange As Integer
    Get
    Set
Visual C++
public:
property int SmallChange {
    int get ();
    void set (int value);
}

See Also

vTrackBar Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..Theme Property
vTrackBar Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vTrackBar Class


ThumbBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..ThumbBackgroundBorder Property
vTrackBar Class See Also Send Feedback
Gets or sets the background thumb border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color ThumbBackgroundBorder { get; set; }
Visual Basic
Public Property ThumbBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color ThumbBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The thumb background border.

See Also

vTrackBar Class


ThumbBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..ThumbBackgroundBrush Property
vTrackBar Class See Also Send Feedback
Gets or sets the thumb background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush ThumbBackgroundBrush { get; set; }
Visual Basic
Public Property ThumbBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ ThumbBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vTrackBar Class


ThumbHighlightBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..ThumbHighlightBackgroundBorder Property
vTrackBar Class See Also Send Feedback
Gets or sets the background thumb border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color ThumbHighlightBackgroundBorder { get; set; }
Visual Basic
Public Property ThumbHighlightBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color ThumbHighlightBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The thumb background border.

See Also

vTrackBar Class


ThumbHighlightBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..ThumbHighlightBackgroundBrush Property
vTrackBar Class See Also Send Feedback
Gets or sets the thumb Highlight background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush ThumbHighlightBackgroundBrush { get; set; }
Visual Basic
Public Property ThumbHighlightBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ ThumbHighlightBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vTrackBar Class


ThumbPressedBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..ThumbPressedBackgroundBorder Property
vTrackBar Class See Also Send Feedback
Gets or sets the background thumb border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color ThumbPressedBackgroundBorder { get; set; }
Visual Basic
Public Property ThumbPressedBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color ThumbPressedBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The thumb background border.

See Also

vTrackBar Class


ThumbPressedBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..ThumbPressedBackgroundBrush Property
vTrackBar Class See Also Send Feedback
Gets or sets the thumb Pressed background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush ThumbPressedBackgroundBrush { get; set; }
Visual Basic
Public Property ThumbPressedBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ ThumbPressedBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vTrackBar Class


ThumbSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..ThumbSize Property
vTrackBar Class See Also Send Feedback
Gets or sets the size of the track bar's thumb.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Size ThumbSize { get; set; }
Visual Basic
Public Property ThumbSize As Size
    Get
    Set
Visual C++
public:
property Size ThumbSize {
    Size get ();
    void set (Size value);
}

See Also

vTrackBar Class


UseThemeBackground Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..UseThemeBackground Property
vTrackBar Class See Also Send Feedback
Gets or sets a value indicating whether to use theme's background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBackground { get; set; }
Visual Basic
Public Property UseThemeBackground As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBackground {
    bool get ();
    void set (bool value);
}

See Also

vTrackBar Class


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..Value Property
vTrackBar Class See Also Send Feedback
Gets or sets the value of the track bar control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Value { get; set; }
Visual Basic
Public Property Value As Integer
    Get
    Set
Visual C++
public:
property int Value {
    int get ();
    void set (int value);
}

See Also

vTrackBar Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..VIBlendTheme Property
vTrackBar Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vTrackBar Class


vTrackBar Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTrackBar Events
vTrackBar Class See Also Send Feedback

The vTrackBar type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when either a mouse or keyboard action moves the scroll box.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when the Value property of a track bar changes, either by movement of the scroll box or programmatically.
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vTrackBar Class


Scroll Event

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..Scroll Event
vTrackBar Class See Also Send Feedback
Occurs when either a mouse or keyboard action moves the scroll box.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event ScrollEventHandler Scroll
Visual Basic
Public Event Scroll As ScrollEventHandler
Visual C++
public:
 event ScrollEventHandler^ Scroll {
    void add (ScrollEventHandler^ value);
    void remove (ScrollEventHandler^ value);
}

See Also

vTrackBar Class


ValueChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vTrackBar..::..ValueChanged Event
vTrackBar Class See Also Send Feedback
Occurs when the Value property of a track bar changes, either by movement of the scroll box or programmatically.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ValueChanged
Visual Basic
Public Event ValueChanged As EventHandler
Visual C++
public:
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vTrackBar Class


vTreeNode Class

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode Class
Members See Also Send Feedback
Represents a tree node in a vTreeView control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vTreeNode : IComponent, IDisposable,
    INotifyPropertyChanged
Visual Basic
Public Class vTreeNode _
    Implements IComponent, IDisposable, INotifyPropertyChanged
Visual C++
public ref class vTreeNode : IComponent,
    IDisposable, INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..vTreeNode

See Also

vTreeNode Members


vTreeNode Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeNode Members
vTreeNode Class Constructors Methods Properties Events See Also Send Feedback

The vTreeNode type exposes the following members.

Constructors

 | Name | Description
Public method | vTreeNode()()()() | Constructor
Public method | vTreeNode(String) | Constructor
Public method | vTreeNode(vTreeNode) | Constructor

Methods

 | Name | Description
Public method | BeginEdit | Opens a textbox editor to edit the node.
Protected method | CalculateBounds | Calculates the bounds.
Public method | Collapse()()()() | Collapses the TreeNode.
Public method | Collapse(Boolean) |
Public method | Contains | Checks if the node contains a specific child node under it.
Public method | Dispose()()()() |
Protected method | Dispose(Boolean) |
Protected method | Draw | Draws the specified g.
Public method | DrawCheckBox(Graphics, Rectangle, Boolean, Boolean, Boolean, CheckState, ControlState) | Draws the check box.
Public method | DrawCheckBox(Graphics, Rectangle, Boolean, Boolean, Boolean, CheckState, ControlState, VIBLEND_THEME) | Draws the check box.
Public method | DrawImage |
Public method | DrawNodeTextAndDescription | Draws the node text and description.
Public method | DrawText | Draws the text.
Public method | EndEdit | Ends the node edit
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expands the node.
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnLayoutUpdated | Raises the [E:LayoutUpdated] event.
Protected method | OnPropertyChanged | Called when a property is changed.
Public method | Remove | Removes the node from the collection.
Public method | RemoveChildren | Removes all child nodes of the node.
Public method | Toggle | Toggles the expanded/collapsed state of the node.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BackgroundBorder | Gets or sets the background border.
Public property | BackgroundBrush | Gets or sets the background brush.
Public property | Checked | Gets or sets whether the node is checked
Public property | CheckMarkColor | Gets or sets the CheckMarkColor
Public property | Depth | Gets the depth of the node within the vTreeView control.
Public property | DescriptionText | Gets or sets the description text.
Public property | DescriptionTextAlignment | Gets or sets the description text alignment.
Public property | DescriptionTextColor | Gets or sets the color of the description text.
Public property | DescriptionTextFont | Gets or sets the description text font.
Public property | DisabledBackgroundBorder | Gets or sets the disabledBackgroundBorder border.
Public property | DisabledBackgroundBrush | Gets or sets the disabled background brush.
Public property | DisabledForeColor | Gets or sets the DisabledForeColor
Public property | Enabled | Gets or sets a value indicating whether this vTreeNode is enabled.
Public property | ExtraWidth | Gets or sets node's extra width
Public property | Font | Gets or sets the font.
Public property | ForeColor | Gets or sets the ForeColor
Public property | HighlightBackgroundBorder | Gets or sets the highlightBackground border.
Public property | HighlightBackgroundBrush | Gets or sets the HighlightBackground brush.
Public property | HighlightForeColor | Gets or sets the HighlightForeColor
Public property | ImageIndex | Gets or sets the image index of the image associated with the tree node.
Public property | IsExpanded | Checks if the node is expanded
Public property | IsLabelEditable | Gets or sets whether the node is editable.
Public property | IsVisible | Gets or sets whether the node is currently visible.
Public property | ItemHeight | Gets or sets the height of the tree node.
Public property | LabelBounds | Gets or sets the label bounds.
Public property | NextNode | Gets the next node. Returns null if there is no next node.
Public property | NextSiblingNode | Gets the next sibling node. Returns null if no such node exists.
Public property | NextVisibleNode | Gets the next visible node. Returns null if no such node exists.
Public property | Nodes | Gets the child nodes of the vTreeNode.
Public property | Parent | Gets the parent node of the vTreeNode.
Public property | PrevNode | Get the previous node. Returns null if no such node exists.
Public property | PrevSiblingNode | Gets the prev sibling node. Returns null if no such node exists.
Public property | PrevVisibleNode | Get the previous visible node. Returns null if no such node exists.
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vTreeNode control.
Public property | Selected | Gets or sets whether the node is selected.
Public property | SelectedBackgroundBorder | Gets or sets the selectedBackground border.
Public property | SelectedBackgroundBrush | Gets or sets the background brush.
Public property | SelectedForeColor | Gets or sets the SelectedForeColor
Public property | SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when the tree node is in the selected state.
Public property | ShowCheckBox | Gets or sets whether to show checkboxes
Public property | Site |
Public property | StateImageIndex | Gets or sets the index of the image used to indicate the state of the TreeNode when the parent TreeView has its CheckBoxes property set to false.
Public property | Tag | Gets or sets the Tag
Public property | Text | Gets or sets the text of the node.
Public property | TextAlignment | Gets or sets the text alignment
Public property | TooltipText | Gets or sets the tooltip text of the tree node
Public property | TreeView | Gets the tree view which hosts the tree node.
Public property | UseThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use theme's textcolor
Public property | Value | Gets or sets the Value

Events

 | Name | Description
Public event | Disposed |
Public event | LayoutUpdated | Occurs when the LabelBounds property is calculated.
Public event | PropertyChanged | Occurs when a property is changed.

See Also

vTreeNode Class


vTreeNode Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeNode Constructor
vTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | vTreeNode()()()() | Constructor
Public method | vTreeNode(String) | Constructor
Public method | vTreeNode(vTreeNode) | Constructor

See Also

vTreeNode Class
vTreeNode Members


vTreeNode Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode Constructor
vTreeNode Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode()
Visual Basic
Public Sub New
Visual C++
public:
vTreeNode()

See Also

vTreeNode Class
vTreeNode Overload


vTreeNode Constructor (String)

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode Constructor (String)
vTreeNode Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode(
    string text
)
Visual Basic
Public Sub New ( _
    text As String _
)
Visual C++
public:
vTreeNode(
    String^ text
)

Parameters

text
Type: System..::..String
The text of the node.

See Also

vTreeNode Class
vTreeNode Overload


vTreeNode Constructor (vTreeNode)

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode Constructor (vTreeNode)
vTreeNode Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode(
    vTreeNode parent
)
Visual Basic
Public Sub New ( _
    parent As vTreeNode _
)
Visual C++
public:
vTreeNode(
    vTreeNode^ parent
)

Parameters

parent
Type: VIBlend.WinForms.Controls..::..vTreeNode
The parent node under which this node will be added.

See Also

vTreeNode Class
vTreeNode Overload


vTreeNode Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeNode Methods
vTreeNode Class See Also Send Feedback

The vTreeNode type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Opens a textbox editor to edit the node.
Protected method | CalculateBounds | Calculates the bounds.
Public method | Collapse()()()() | Collapses the TreeNode.
Public method | Collapse(Boolean) |
Public method | Contains | Checks if the node contains a specific child node under it.
Public method | Dispose()()()() |
Protected method | Dispose(Boolean) |
Protected method | Draw | Draws the specified g.
Public method | DrawCheckBox(Graphics, Rectangle, Boolean, Boolean, Boolean, CheckState, ControlState) | Draws the check box.
Public method | DrawCheckBox(Graphics, Rectangle, Boolean, Boolean, Boolean, CheckState, ControlState, VIBLEND_THEME) | Draws the check box.
Public method | DrawImage |
Public method | DrawNodeTextAndDescription | Draws the node text and description.
Public method | DrawText | Draws the text.
Public method | EndEdit | Ends the node edit
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expands the node.
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnLayoutUpdated | Raises the [E:LayoutUpdated] event.
Protected method | OnPropertyChanged | Called when a property is changed.
Public method | Remove | Removes the node from the collection.
Public method | RemoveChildren | Removes all child nodes of the node.
Public method | Toggle | Toggles the expanded/collapsed state of the node.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vTreeNode Class


BeginEdit Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..BeginEdit Method
vTreeNode Class See Also Send Feedback
Opens a textbox editor to edit the node.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void BeginEdit()
Visual Basic
Public Sub BeginEdit
Visual C++
public:
void BeginEdit()

See Also

vTreeNode Class


CalculateBounds Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..CalculateBounds Method
vTreeNode Class See Also Send Feedback
Calculates the bounds.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void CalculateBounds(
    Graphics g,
    Font f,
    int lineHeight,
    int x,
    int indent,
    int depth,
    int y,
    Size imgSize
)
Visual Basic
Protected Friend Overridable Sub CalculateBounds ( _
    g As Graphics, _
    f As Font, _
    lineHeight As Integer, _
    x As Integer, _
    indent As Integer, _
    depth As Integer, _
    y As Integer, _
    imgSize As Size _
)
Visual C++
protected public:
virtual void CalculateBounds(
    Graphics^ g,
    Font^ f,
    int lineHeight,
    int x,
    int indent,
    int depth,
    int y,
    Size imgSize
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
f
Type: System.Drawing..::..Font
The f.
lineHeight
Type: System..::..Int32
Height of the line.
x
Type: System..::..Int32
The x.
indent
Type: System..::..Int32
The indent.
depth
Type: System..::..Int32
The depth.
y
Type: System..::..Int32
The y.
imgSize
Type: System.Drawing..::..Size
Size of the img.

See Also

vTreeNode Class


Collapse Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Collapse Method
vTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Collapse()()()() | Collapses the TreeNode.
Public method | Collapse(Boolean) |

See Also

vTreeNode Class
vTreeNode Members


Collapse Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Collapse Method
vTreeNode Class See Also Send Feedback
Collapses the TreeNode.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void Collapse()
Visual Basic
Public Overridable Sub Collapse
Visual C++
public:
virtual void Collapse()

See Also

vTreeNode Class
Collapse Overload


Collapse Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Collapse Method (Boolean)
vTreeNode Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void Collapse(
    bool withoutAnimations
)
Visual Basic
Public Overridable Sub Collapse ( _
    withoutAnimations As Boolean _
)
Visual C++
public:
virtual void Collapse(
    bool withoutAnimations
)

Parameters

withoutAnimations
Type: System..::..Boolean

See Also

vTreeNode Class
Collapse Overload


Contains Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Contains Method
vTreeNode Class See Also Send Feedback
Checks if the node contains a specific child node under it.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Contains(
    vTreeNode node
)
Visual Basic
Public Function Contains ( _
    node As vTreeNode _
) As Boolean
Visual C++
public:
bool Contains(
    vTreeNode^ node
)

Parameters

node
Type: VIBlend.WinForms.Controls..::..vTreeNode
The child node to look for.

Return Value

true if the node contains the child node; otherwise false;

See Also

vTreeNode Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Dispose Method
vTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the vTreeNode
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the vTreeNode and optionally releases the managed resources

See Also

vTreeNode Class
vTreeNode Members


Dispose Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Dispose Method
vTreeNode Class See Also Send Feedback
Releases all resources used by the vTreeNode

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

vTreeNode Class
Dispose Overload


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Dispose Method (Boolean)
vTreeNode Class See Also Send Feedback
Releases the unmanaged resources used by the vTreeNode and optionally releases the managed resources

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vTreeNode Class
Dispose Overload


Draw Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Draw Method
vTreeNode Class See Also Send Feedback
Draws the specified g.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void Draw(
    Graphics g,
    TreeBackGroundElement backGround,
    Font f,
    Pen pen,
    LineStates state,
    int lineHeight,
    int indent,
    int x,
    int y,
    ref Size imgSize,
    Image img,
    bool selected
)
Visual Basic
Protected Friend Overridable Sub Draw ( _
    g As Graphics, _
    backGround As TreeBackGroundElement, _
    f As Font, _
    pen As Pen, _
    state As LineStates, _
    lineHeight As Integer, _
    indent As Integer, _
    x As Integer, _
    y As Integer, _
    ByRef imgSize As Size, _
    img As Image, _
    selected As Boolean _
)
Visual C++
protected public:
virtual void Draw(
    Graphics^ g,
    TreeBackGroundElement^ backGround,
    Font^ f,
    Pen^ pen,
    LineStates^ state,
    int lineHeight,
    int indent,
    int x,
    int y,
    Size% imgSize,
    Image^ img,
    bool selected
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
backGround
Type: TreeBackGroundElement
The background.
f
Type: System.Drawing..::..Font
The f.
pen
Type: System.Drawing..::..Pen
The pen.
state
Type: VIBlend.WinForms.Controls..::..LineStates
The state.
lineHeight
Type: System..::..Int32
Height of the line.
indent
Type: System..::..Int32
The indent.
x
Type: System..::..Int32
The x.
y
Type: System..::..Int32
The y.
imgSize
Type: System.Drawing..::..Size %
Size of the img.
img
Type: System.Drawing..::..Image
The img.
selected
Type: System..::..Boolean
if set to true [selected].

See Also

vTreeNode Class


DrawCheckBox Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..DrawCheckBox Method
vTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawCheckBox(Graphics, Rectangle, Boolean, Boolean, Boolean, CheckState, ControlState) | Draws the check box.
Public method | DrawCheckBox(Graphics, Rectangle, Boolean, Boolean, Boolean, CheckState, ControlState, VIBLEND_THEME) | Draws the check box.

See Also

vTreeNode Class
vTreeNode Members


DrawCheckBox Method (Graphics, Rectangle, Boolean, Boolean, Boolean, CheckState, )

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..DrawCheckBox Method (Graphics, Rectangle, Boolean, Boolean, Boolean, CheckState, )
vTreeNode Class See Also Send Feedback
Draws the check box.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawCheckBox(
    Graphics g,
    Rectangle rect,
    bool isEnabled,
    bool isMouseOver,
    bool isFocused,
    CheckState checkState,
    ControlState state
)
Visual Basic
Public Sub DrawCheckBox ( _
    g As Graphics, _
    rect As Rectangle, _
    isEnabled As Boolean, _
    isMouseOver As Boolean, _
    isFocused As Boolean, _
    checkState As CheckState, _
    state As ControlState _
)
Visual C++
public:
void DrawCheckBox(
    Graphics^ g,
    Rectangle rect,
    bool isEnabled,
    bool isMouseOver,
    bool isFocused,
    CheckState checkState,
    ControlState state
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
rect
Type: System.Drawing..::..Rectangle
The rect.
isEnabled
Type: System..::..Boolean
if set to true [is enabled].
isMouseOver
Type: System..::..Boolean
if set to true [is mouse over].
isFocused
Type: System..::..Boolean
if set to true [is focused].
checkState
Type: System.Windows.Forms..::..CheckState
State of the check.
state
Type: ControlState
The state.

See Also

vTreeNode Class
DrawCheckBox Overload


DrawCheckBox Method (Graphics, Rectangle, Boolean, Boolean, Boolean, CheckState, , VIBLEND_THEME)

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..DrawCheckBox Method (Graphics, Rectangle, Boolean, Boolean, Boolean, CheckState, , VIBLEND_THEME)
vTreeNode Class See Also Send Feedback
Draws the check box.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawCheckBox(
    Graphics g,
    Rectangle rect,
    bool isEnabled,
    bool isMouseOver,
    bool isFocused,
    CheckState checkState,
    ControlState state,
    VIBLEND_THEME theme
)
Visual Basic
Public Sub DrawCheckBox ( _
    g As Graphics, _
    rect As Rectangle, _
    isEnabled As Boolean, _
    isMouseOver As Boolean, _
    isFocused As Boolean, _
    checkState As CheckState, _
    state As ControlState, _
    theme As VIBLEND_THEME _
)
Visual C++
public:
void DrawCheckBox(
    Graphics^ g,
    Rectangle rect,
    bool isEnabled,
    bool isMouseOver,
    bool isFocused,
    CheckState checkState,
    ControlState state,
    VIBLEND_THEME theme
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
rect
Type: System.Drawing..::..Rectangle
The rect.
isEnabled
Type: System..::..Boolean
if set to true [is enabled].
isMouseOver
Type: System..::..Boolean
if set to true [is mouse over].
isFocused
Type: System..::..Boolean
if set to true [is focused].
checkState
Type: System.Windows.Forms..::..CheckState
State of the check.
state
Type: ControlState
The state.
theme
Type: VIBlend.Utilities..::..VIBLEND_THEME
The theme.

See Also

vTreeNode Class
DrawCheckBox Overload


DrawImage Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..DrawImage Method
vTreeNode Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawImage(
    Graphics g,
    int lineHeight,
    int x,
    int y,
    Size imgSize,
    Image img,
    float opacity
)
Visual Basic
Public Sub DrawImage ( _
    g As Graphics, _
    lineHeight As Integer, _
    x As Integer, _
    y As Integer, _
    imgSize As Size, _
    img As Image, _
    opacity As Single _
)
Visual C++
public:
void DrawImage(
    Graphics^ g,
    int lineHeight,
    int x,
    int y,
    Size imgSize,
    Image^ img,
    float opacity
)

Parameters

g
Type: System.Drawing..::..Graphics
lineHeight
Type: System..::..Int32
x
Type: System..::..Int32
y
Type: System..::..Int32
imgSize
Type: System.Drawing..::..Size
img
Type: System.Drawing..::..Image
opacity
Type: System..::..Single

See Also

vTreeNode Class


DrawNodeTextAndDescription Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..DrawNodeTextAndDescription Method
vTreeNode Class See Also Send Feedback
Draws the node text and description.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void DrawNodeTextAndDescription(
    Graphics graphics,
    Rectangle bounds,
    vTreeNode node,
    Brush brush,
    Brush descriptionBrush,
    Font font
)
Visual Basic
Public Overridable Sub DrawNodeTextAndDescription ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    node As vTreeNode, _
    brush As Brush, _
    descriptionBrush As Brush, _
    font As Font _
)
Visual C++
public:
virtual void DrawNodeTextAndDescription(
    Graphics^ graphics,
    Rectangle bounds,
    vTreeNode^ node,
    Brush^ brush,
    Brush^ descriptionBrush,
    Font^ font
)

Parameters

graphics
Type: System.Drawing..::..Graphics
The graphics.
bounds
Type: System.Drawing..::..Rectangle
The bounds.
node
Type: VIBlend.WinForms.Controls..::..vTreeNode
The node.
brush
Type: System.Drawing..::..Brush
The brush.
descriptionBrush
Type: System.Drawing..::..Brush
The description brush.
font
Type: System.Drawing..::..Font

See Also

vTreeNode Class


DrawText Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..DrawText Method
vTreeNode Class See Also Send Feedback
Draws the text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void DrawText(
    Graphics g,
    TreeBackGroundElement backGround,
    Font f,
    string label,
    SolidBrush brush
)
Visual Basic
Public Overridable Sub DrawText ( _
    g As Graphics, _
    backGround As TreeBackGroundElement, _
    f As Font, _
    label As String, _
    brush As SolidBrush _
)
Visual C++
public:
virtual void DrawText(
    Graphics^ g,
    TreeBackGroundElement^ backGround,
    Font^ f,
    String^ label,
    SolidBrush^ brush
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
backGround
Type: TreeBackGroundElement
The back ground.
f
Type: System.Drawing..::..Font
The f.
label
Type: System..::..String
The label.
brush
Type: System.Drawing..::..SolidBrush
The brush.

See Also

vTreeNode Class


EndEdit Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..EndEdit Method
vTreeNode Class See Also Send Feedback
Ends the node edit

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void EndEdit(
    bool cancel
)
Visual Basic
Public Sub EndEdit ( _
    cancel As Boolean _
)
Visual C++
public:
void EndEdit(
    bool cancel
)

Parameters

cancel
Type: System..::..Boolean
Determines whether to apply the changes or not

See Also

vTreeNode Class


Expand Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Expand Method
vTreeNode Class See Also Send Feedback
Expands the node.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void Expand()
Visual Basic
Public Overridable Sub Expand
Visual C++
public:
virtual void Expand()

See Also

vTreeNode Class


Finalize Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Finalize Method
vTreeNode Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

vTreeNode Class


OnLayoutUpdated Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..OnLayoutUpdated Method
vTreeNode Class See Also Send Feedback
Raises the [E:LayoutUpdated] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnLayoutUpdated(
    vTreeViewLayoutEventArgs args
)
Visual Basic
Protected Overridable Sub OnLayoutUpdated ( _
    args As vTreeViewLayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayoutUpdated(
    vTreeViewLayoutEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.Controls..::..vTreeViewLayoutEventArgs
The vTreeViewLayoutEventArgs instance containing the event data.

See Also

vTreeNode Class


OnPropertyChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..OnPropertyChanged Method
vTreeNode Class See Also Send Feedback
Called when a property is changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String
Name of the property.

See Also

vTreeNode Class


Remove Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Remove Method
vTreeNode Class See Also Send Feedback
Removes the node from the collection.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void Remove()
Visual Basic
Public Overridable Sub Remove
Visual C++
public:
virtual void Remove()

See Also

vTreeNode Class


RemoveChildren Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..RemoveChildren Method
vTreeNode Class See Also Send Feedback
Removes all child nodes of the node.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void RemoveChildren()
Visual Basic
Public Overridable Sub RemoveChildren
Visual C++
public:
virtual void RemoveChildren()

See Also

vTreeNode Class


Toggle Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Toggle Method
vTreeNode Class See Also Send Feedback
Toggles the expanded/collapsed state of the node.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Toggle()
Visual Basic
Public Sub Toggle
Visual C++
public:
void Toggle()

See Also

vTreeNode Class


vTreeNode Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeNode Properties
vTreeNode Class See Also Send Feedback

The vTreeNode type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundBorder | Gets or sets the background border.
Public property | BackgroundBrush | Gets or sets the background brush.
Public property | Checked | Gets or sets whether the node is checked
Public property | CheckMarkColor | Gets or sets the CheckMarkColor
Public property | Depth | Gets the depth of the node within the vTreeView control.
Public property | DescriptionText | Gets or sets the description text.
Public property | DescriptionTextAlignment | Gets or sets the description text alignment.
Public property | DescriptionTextColor | Gets or sets the color of the description text.
Public property | DescriptionTextFont | Gets or sets the description text font.
Public property | DisabledBackgroundBorder | Gets or sets the disabledBackgroundBorder border.
Public property | DisabledBackgroundBrush | Gets or sets the disabled background brush.
Public property | DisabledForeColor | Gets or sets the DisabledForeColor
Public property | Enabled | Gets or sets a value indicating whether this vTreeNode is enabled.
Public property | ExtraWidth | Gets or sets node's extra width
Public property | Font | Gets or sets the font.
Public property | ForeColor | Gets or sets the ForeColor
Public property | HighlightBackgroundBorder | Gets or sets the highlightBackground border.
Public property | HighlightBackgroundBrush | Gets or sets the HighlightBackground brush.
Public property | HighlightForeColor | Gets or sets the HighlightForeColor
Public property | ImageIndex | Gets or sets the image index of the image associated with the tree node.
Public property | IsExpanded | Checks if the node is expanded
Public property | IsLabelEditable | Gets or sets whether the node is editable.
Public property | IsVisible | Gets or sets whether the node is currently visible.
Public property | ItemHeight | Gets or sets the height of the tree node.
Public property | LabelBounds | Gets or sets the label bounds.
Public property | NextNode | Gets the next node. Returns null if there is no next node.
Public property | NextSiblingNode | Gets the next sibling node. Returns null if no such node exists.
Public property | NextVisibleNode | Gets the next visible node. Returns null if no such node exists.
Public property | Nodes | Gets the child nodes of the vTreeNode.
Public property | Parent | Gets the parent node of the vTreeNode.
Public property | PrevNode | Get the previous node. Returns null if no such node exists.
Public property | PrevSiblingNode | Gets the prev sibling node. Returns null if no such node exists.
Public property | PrevVisibleNode | Get the previous visible node. Returns null if no such node exists.
Public property | RoundedCornersMask | Gets or sets the mask that determines which corners are rounded
Public property | RoundedCornersRadius | Gets or sets the rounded corners radius of the vTreeNode control.
Public property | Selected | Gets or sets whether the node is selected.
Public property | SelectedBackgroundBorder | Gets or sets the selectedBackground border.
Public property | SelectedBackgroundBrush | Gets or sets the background brush.
Public property | SelectedForeColor | Gets or sets the SelectedForeColor
Public property | SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when the tree node is in the selected state.
Public property | ShowCheckBox | Gets or sets whether to show checkboxes
Public property | Site |
Public property | StateImageIndex | Gets or sets the index of the image used to indicate the state of the TreeNode when the parent TreeView has its CheckBoxes property set to false.
Public property | Tag | Gets or sets the Tag
Public property | Text | Gets or sets the text of the node.
Public property | TextAlignment | Gets or sets the text alignment
Public property | TooltipText | Gets or sets the tooltip text of the tree node
Public property | TreeView | Gets the tree view which hosts the tree node.
Public property | UseThemeBackground | Gets or sets a value indicating whether to use theme's background
Public property | UseThemeTextColor | Gets or sets a value indicating whether to use theme's textcolor
Public property | Value | Gets or sets the Value

See Also

vTreeNode Class


BackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..BackgroundBorder Property
vTreeNode Class See Also Send Feedback
Gets or sets the background border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BackgroundBorder { get; set; }
Visual Basic
Public Property BackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color BackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The background border.

See Also

vTreeNode Class


BackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..BackgroundBrush Property
vTreeNode Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush BackgroundBrush { get; set; }
Visual Basic
Public Property BackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ BackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vTreeNode Class


Checked Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Checked Property
vTreeNode Class See Also Send Feedback
Gets or sets whether the node is checked

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CheckState Checked { get; set; }
Visual Basic
Public Property Checked As CheckState
    Get
    Set
Visual C++
public:
property CheckState Checked {
    CheckState get ();
    void set (CheckState value);
}

See Also

vTreeNode Class


CheckMarkColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..CheckMarkColor Property
vTreeNode Class See Also Send Feedback
Gets or sets the CheckMarkColor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color CheckMarkColor { get; set; }
Visual Basic
Public Property CheckMarkColor As Color
    Get
    Set
Visual C++
public:
property Color CheckMarkColor {
    Color get ();
    void set (Color value);
}

See Also

vTreeNode Class


Depth Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Depth Property
vTreeNode Class See Also Send Feedback
Gets the depth of the node within the vTreeView control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Depth { get; }
Visual Basic
Public ReadOnly Property Depth As Integer
    Get
Visual C++
public:
property int Depth {
    int get ();
}

See Also

vTreeNode Class


DescriptionText Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..DescriptionText Property
vTreeNode Class See Also Send Feedback
Gets or sets the description text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string DescriptionText { get; set; }
Visual Basic
Public Property DescriptionText As String
    Get
    Set
Visual C++
public:
property String^ DescriptionText {
    String^ get ();
    void set (String^ value);
}

Field Value

The description text.

See Also

vTreeNode Class


DescriptionTextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..DescriptionTextAlignment Property
vTreeNode Class See Also Send Feedback
Gets or sets the description text alignment.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment DescriptionTextAlignment { get; set; }
Visual Basic
Public Property DescriptionTextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment DescriptionTextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

Field Value

The description text alignment.

See Also

vTreeNode Class


DescriptionTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..DescriptionTextColor Property
vTreeNode Class See Also Send Feedback
Gets or sets the color of the description text.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DescriptionTextColor { get; set; }
Visual Basic
Public Property DescriptionTextColor As Color
    Get
    Set
Visual C++
public:
property Color DescriptionTextColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the description text.

See Also

vTreeNode Class


DescriptionTextFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..DescriptionTextFont Property
vTreeNode Class See Also Send Feedback
Gets or sets the description text font.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font DescriptionTextFont { get; set; }
Visual Basic
Public Property DescriptionTextFont As Font
    Get
    Set
Visual C++
public:
property Font^ DescriptionTextFont {
    Font^ get ();
    void set (Font^ value);
}

Field Value

The description text font.

See Also

vTreeNode Class


DisabledBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..DisabledBackgroundBorder Property
vTreeNode Class See Also Send Feedback
Gets or sets the disabledBackgroundBorder border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color DisabledBackgroundBorder { get; set; }
Visual Basic
Public Property DisabledBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color DisabledBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The disabledBackgroundBorder border.

See Also

vTreeNode Class


DisabledBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..DisabledBackgroundBrush Property
vTreeNode Class See Also Send Feedback
Gets or sets the disabled background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush DisabledBackgroundBrush { get; set; }
Visual Basic
Public Property DisabledBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ DisabledBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The disabled background brush.

See Also

vTreeNode Class


DisabledForeColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..DisabledForeColor Property
vTreeNode Class See Also Send Feedback
Gets or sets the DisabledForeColor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Nullable<Color> DisabledForeColor { get; set; }
Visual Basic
Public Property DisabledForeColor As Nullable(Of Color)
    Get
    Set
Visual C++
public:
property Nullable<Color> DisabledForeColor {
    Nullable<Color> get ();
    void set (Nullable<Color> value);
}

See Also

vTreeNode Class


Enabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Enabled Property
vTreeNode Class See Also Send Feedback
Gets or sets a value indicating whether this vTreeNode is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Field Value

true if enabled; otherwise, false.

See Also

vTreeNode Class


ExtraWidth Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..ExtraWidth Property
vTreeNode Class See Also Send Feedback
Gets or sets node's extra width

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ExtraWidth { get; set; }
Visual Basic
Public Property ExtraWidth As Integer
    Get
    Set
Visual C++
public:
property int ExtraWidth {
    int get ();
    void set (int value);
}

See Also

vTreeNode Class


Font Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Font Property
vTreeNode Class See Also Send Feedback
Gets or sets the font.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font Font { get; set; }
Visual Basic
Public Property Font As Font
    Get
    Set
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

Field Value

The font.

See Also

vTreeNode Class


ForeColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..ForeColor Property
vTreeNode Class See Also Send Feedback
Gets or sets the ForeColor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color ForeColor { get; set; }
Visual Basic
Public Property ForeColor As Color
    Get
    Set
Visual C++
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}

See Also

vTreeNode Class


HighlightBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..HighlightBackgroundBorder Property
vTreeNode Class See Also Send Feedback
Gets or sets the highlightBackground border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color HighlightBackgroundBorder { get; set; }
Visual Basic
Public Property HighlightBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color HighlightBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The highlightBackground border.

See Also

vTreeNode Class


HighlightBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..HighlightBackgroundBrush Property
vTreeNode Class See Also Send Feedback
Gets or sets the HighlightBackground brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush HighlightBackgroundBrush { get; set; }
Visual Basic
Public Property HighlightBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ HighlightBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The HighlightBackground brush.

See Also

vTreeNode Class


HighlightForeColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..HighlightForeColor Property
vTreeNode Class See Also Send Feedback
Gets or sets the HighlightForeColor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color HighlightForeColor { get; set; }
Visual Basic
Public Property HighlightForeColor As Color
    Get
    Set
Visual C++
public:
property Color HighlightForeColor {
    Color get ();
    void set (Color value);
}

See Also

vTreeNode Class


ImageIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..ImageIndex Property
vTreeNode Class See Also Send Feedback
Gets or sets the image index of the image associated with the tree node.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ImageIndex { get; set; }
Visual Basic
Public Property ImageIndex As Integer
    Get
    Set
Visual C++
public:
property int ImageIndex {
    int get ();
    void set (int value);
}

See Also

vTreeNode Class


IsExpanded Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..IsExpanded Property
vTreeNode Class See Also Send Feedback
Checks if the node is expanded

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsExpanded { get; }
Visual Basic
Public ReadOnly Property IsExpanded As Boolean
    Get
Visual C++
public:
property bool IsExpanded {
    bool get ();
}

See Also

vTreeNode Class


IsLabelEditable Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..IsLabelEditable Property
vTreeNode Class See Also Send Feedback
Gets or sets whether the node is editable.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsLabelEditable { get; set; }
Visual Basic
Public Property IsLabelEditable As Boolean
    Get
    Set
Visual C++
public:
property bool IsLabelEditable {
    bool get ();
    void set (bool value);
}

See Also

vTreeNode Class


IsVisible Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..IsVisible Property
vTreeNode Class See Also Send Feedback
Gets or sets whether the node is currently visible.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsVisible { get; set; }
Visual Basic
Public Property IsVisible As Boolean
    Get
    Set
Visual C++
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}

See Also

vTreeNode Class


ItemHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..ItemHeight Property
vTreeNode Class See Also Send Feedback
Gets or sets the height of the tree node.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Nullable<int> ItemHeight { get; set; }
Visual Basic
Public Property ItemHeight As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> ItemHeight {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

vTreeNode Class


LabelBounds Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..LabelBounds Property
vTreeNode Class See Also Send Feedback
Gets or sets the label bounds.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle LabelBounds { get; internal set; }
Visual Basic
Public Property LabelBounds As Rectangle
    Get
    Friend Set
Visual C++
public:
property Rectangle LabelBounds {
    Rectangle get ();
    internal: void set (Rectangle value);
}

Field Value

The label bounds.

See Also

vTreeNode Class


NextNode Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..NextNode Property
vTreeNode Class See Also Send Feedback
Gets the next node. Returns null if there is no next node.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode NextNode { get; }
Visual Basic
Public ReadOnly Property NextNode As vTreeNode
    Get
Visual C++
public:
property vTreeNode^ NextNode {
    vTreeNode^ get ();
}

See Also

vTreeNode Class


NextSiblingNode Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..NextSiblingNode Property
vTreeNode Class See Also Send Feedback
Gets the next sibling node. Returns null if no such node exists.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode NextSiblingNode { get; }
Visual Basic
Public ReadOnly Property NextSiblingNode As vTreeNode
    Get
Visual C++
public:
property vTreeNode^ NextSiblingNode {
    vTreeNode^ get ();
}

See Also

vTreeNode Class


NextVisibleNode Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..NextVisibleNode Property
vTreeNode Class See Also Send Feedback
Gets the next visible node. Returns null if no such node exists.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode NextVisibleNode { get; }
Visual Basic
Public ReadOnly Property NextVisibleNode As vTreeNode
    Get
Visual C++
public:
property vTreeNode^ NextVisibleNode {
    vTreeNode^ get ();
}

See Also

vTreeNode Class


Nodes Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Nodes Property
vTreeNode Class See Also Send Feedback
Gets the child nodes of the vTreeNode.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNodeCollection Nodes { get; }
Visual Basic
Public ReadOnly Property Nodes As vTreeNodeCollection
    Get
Visual C++
public:
property vTreeNodeCollection^ Nodes {
    vTreeNodeCollection^ get ();
}

See Also

vTreeNode Class


Parent Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Parent Property
vTreeNode Class See Also Send Feedback
Gets the parent node of the vTreeNode.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual vTreeNode Parent { get; set; }
Visual Basic
Public Overridable Property Parent As vTreeNode
    Get
    Set
Visual C++
public:
virtual property vTreeNode^ Parent {
    vTreeNode^ get ();
    void set (vTreeNode^ value);
}

See Also

vTreeNode Class


PrevNode Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..PrevNode Property
vTreeNode Class See Also Send Feedback
Get the previous node. Returns null if no such node exists.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode PrevNode { get; }
Visual Basic
Public ReadOnly Property PrevNode As vTreeNode
    Get
Visual C++
public:
property vTreeNode^ PrevNode {
    vTreeNode^ get ();
}

See Also

vTreeNode Class


PrevSiblingNode Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..PrevSiblingNode Property
vTreeNode Class See Also Send Feedback
Gets the prev sibling node. Returns null if no such node exists.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode PrevSiblingNode { get; }
Visual Basic
Public ReadOnly Property PrevSiblingNode As vTreeNode
    Get
Visual C++
public:
property vTreeNode^ PrevSiblingNode {
    vTreeNode^ get ();
}

See Also

vTreeNode Class


PrevVisibleNode Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..PrevVisibleNode Property
vTreeNode Class See Also Send Feedback
Get the previous visible node. Returns null if no such node exists.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode PrevVisibleNode { get; }
Visual Basic
Public ReadOnly Property PrevVisibleNode As vTreeNode
    Get
Visual C++
public:
property vTreeNode^ PrevVisibleNode {
    vTreeNode^ get ();
}

See Also

vTreeNode Class


RoundedCornersMask Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..RoundedCornersMask Property
vTreeNode Class See Also Send Feedback
Gets or sets the mask that determines which corners are rounded

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public byte RoundedCornersMask { get; set; }
Visual Basic
Public Property RoundedCornersMask As Byte
    Get
    Set
Visual C++
public:
property unsigned char RoundedCornersMask {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

vTreeNode Class


RoundedCornersRadius Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..RoundedCornersRadius Property
vTreeNode Class See Also Send Feedback
Gets or sets the rounded corners radius of the vTreeNode control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int RoundedCornersRadius { get; set; }
Visual Basic
Public Property RoundedCornersRadius As Integer
    Get
    Set
Visual C++
public:
property int RoundedCornersRadius {
    int get ();
    void set (int value);
}

See Also

vTreeNode Class


Selected Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Selected Property
vTreeNode Class See Also Send Feedback
Gets or sets whether the node is selected.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Selected { get; set; }
Visual Basic
Public Property Selected As Boolean
    Get
    Set
Visual C++
public:
property bool Selected {
    bool get ();
    void set (bool value);
}

See Also

vTreeNode Class


SelectedBackgroundBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..SelectedBackgroundBorder Property
vTreeNode Class See Also Send Feedback
Gets or sets the selectedBackground border.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color SelectedBackgroundBorder { get; set; }
Visual Basic
Public Property SelectedBackgroundBorder As Color
    Get
    Set
Visual C++
public:
property Color SelectedBackgroundBorder {
    Color get ();
    void set (Color value);
}

Field Value

The selectedBackground border.

See Also

vTreeNode Class


SelectedBackgroundBrush Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..SelectedBackgroundBrush Property
vTreeNode Class See Also Send Feedback
Gets or sets the background brush.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Brush SelectedBackgroundBrush { get; set; }
Visual Basic
Public Property SelectedBackgroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ SelectedBackgroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The background brush.

See Also

vTreeNode Class


SelectedForeColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..SelectedForeColor Property
vTreeNode Class See Also Send Feedback
Gets or sets the SelectedForeColor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color SelectedForeColor { get; set; }
Visual Basic
Public Property SelectedForeColor As Color
    Get
    Set
Visual C++
public:
property Color SelectedForeColor {
    Color get ();
    void set (Color value);
}

See Also

vTreeNode Class


SelectedImageIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..SelectedImageIndex Property
vTreeNode Class See Also Send Feedback
Gets or sets the image list index value of the image that is displayed when the tree node is in the selected state.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int SelectedImageIndex { get; set; }
Visual Basic
Public Property SelectedImageIndex As Integer
    Get
    Set
Visual C++
public:
property int SelectedImageIndex {
    int get ();
    void set (int value);
}

See Also

vTreeNode Class


ShowCheckBox Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..ShowCheckBox Property
vTreeNode Class See Also Send Feedback
Gets or sets whether to show checkboxes

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowCheckBox { get; set; }
Visual Basic
Public Property ShowCheckBox As Boolean
    Get
    Set
Visual C++
public:
property bool ShowCheckBox {
    bool get ();
    void set (bool value);
}

See Also

vTreeNode Class


Site Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Site Property
vTreeNode Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ISite Site { get; set; }
Visual Basic
Public Property Site As ISite
    Get
    Set
Visual C++
public:
virtual property ISite^ Site {
    ISite^ get () sealed;
    void set (ISite^ value) sealed;
}

Implements

IComponent..::..Site

See Also

vTreeNode Class


StateImageIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..StateImageIndex Property
vTreeNode Class See Also Send Feedback
Gets or sets the index of the image used to indicate the state of the TreeNode when the parent TreeView has its CheckBoxes property set to false.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int StateImageIndex { get; set; }
Visual Basic
Public Property StateImageIndex As Integer
    Get
    Set
Visual C++
public:
property int StateImageIndex {
    int get ();
    void set (int value);
}

See Also

vTreeNode Class


Tag Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Tag Property
vTreeNode Class See Also Send Feedback
Gets or sets the Tag

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object Tag { get; set; }
Visual Basic
Public Property Tag As Object
    Get
    Set
Visual C++
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

See Also

vTreeNode Class


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Text Property
vTreeNode Class See Also Send Feedback
Gets or sets the text of the node.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

vTreeNode Class


TextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..TextAlignment Property
vTreeNode Class See Also Send Feedback
Gets or sets the text alignment

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment TextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

vTreeNode Class


TooltipText Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..TooltipText Property
vTreeNode Class See Also Send Feedback
Gets or sets the tooltip text of the tree node

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string TooltipText { get; set; }
Visual Basic
Public Property TooltipText As String
    Get
    Set
Visual C++
public:
property String^ TooltipText {
    String^ get ();
    void set (String^ value);
}

See Also

vTreeNode Class


TreeView Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..TreeView Property
vTreeNode Class See Also Send Feedback
Gets the tree view which hosts the tree node.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeView TreeView { get; internal set; }
Visual Basic
Public Property TreeView As vTreeView
    Get
    Friend Set
Visual C++
public:
property vTreeView^ TreeView {
    vTreeView^ get ();
    internal: void set (vTreeView^ value);
}

See Also

vTreeNode Class


UseThemeBackground Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..UseThemeBackground Property
vTreeNode Class See Also Send Feedback
Gets or sets a value indicating whether to use theme's background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBackground { get; set; }
Visual Basic
Public Property UseThemeBackground As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBackground {
    bool get ();
    void set (bool value);
}

See Also

vTreeNode Class


UseThemeTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..UseThemeTextColor Property
vTreeNode Class See Also Send Feedback
Gets or sets a value indicating whether to use theme's textcolor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeTextColor { get; set; }
Visual Basic
Public Property UseThemeTextColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeTextColor {
    bool get ();
    void set (bool value);
}

See Also

vTreeNode Class


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Value Property
vTreeNode Class See Also Send Feedback
Gets or sets the Value

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object Value { get; set; }
Visual Basic
Public Property Value As Object
    Get
    Set
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

vTreeNode Class


vTreeNode Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeNode Events
vTreeNode Class See Also Send Feedback

The vTreeNode type exposes the following members.

Events

 | Name | Description
Public event | Disposed |
Public event | LayoutUpdated | Occurs when the LabelBounds property is calculated.
Public event | PropertyChanged | Occurs when a property is changed.

See Also

vTreeNode Class


Disposed Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..Disposed Event
vTreeNode Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler Disposed
Visual Basic
Public Event Disposed As EventHandler
Visual C++
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Implements

IComponent..::..Disposed

See Also

vTreeNode Class


LayoutUpdated Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..LayoutUpdated Event
vTreeNode Class See Also Send Feedback
Occurs when the LabelBounds property is calculated.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<vTreeViewLayoutEventArgs> LayoutUpdated
Visual Basic
Public Event LayoutUpdated As EventHandler(Of vTreeViewLayoutEventArgs)
Visual C++
public:
 event EventHandler<vTreeViewLayoutEventArgs^>^ LayoutUpdated {
    void add (EventHandler<vTreeViewLayoutEventArgs^>^ value);
    void remove (EventHandler<vTreeViewLayoutEventArgs^>^ value);
}

See Also

vTreeNode Class


PropertyChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNode..::..PropertyChanged Event
vTreeNode Class See Also Send Feedback
Occurs when a property is changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

vTreeNode Class


vTreeNodeCollection Class

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection Class
Members See Also Send Feedback
Represents a collection of tree nodes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vTreeNodeCollection : IList,
    ICollection, IEnumerable<vTreeNode>, IEnumerable
Visual Basic
Public Class vTreeNodeCollection _
    Implements IList, ICollection, IEnumerable(Of vTreeNode),  _
    IEnumerable
Visual C++
public ref class vTreeNodeCollection : IList,
    ICollection, IEnumerable<vTreeNode^>, IEnumerable

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..vTreeNodeCollection

See Also

vTreeNodeCollection Members


vTreeNodeCollection Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection Members
vTreeNodeCollection Class Constructors Methods Properties See Also Send Feedback

The vTreeNodeCollection type exposes the following members.

Constructors

 | Name | Description
Protected method | vTreeNodeCollection()()()() | Initializes a new instance of the vTreeNodeCollection class.
Public method | vTreeNodeCollection(vTreeView, vTreeNode) | Initializes a new instance of the vTreeNodeCollection class.

Methods

 | Name | Description
Public method | Add(Object) | Adds an item to the IList.
Public method | Add(vTreeNode) | Adds the specified node.
Public method | Add(Object, Boolean) | Adds the specified value.
Public method | Add(vTreeNode, Boolean) | Adds the specified node.
Public method | Clear | Removes all items from the IList.
Public method | Contains | Determines whether the IList contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | Gets the index.
Public method | GetOwnerNode | Gets the owner node.
Public method | GetOwnerTree | Gets the owner tree.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IList.
Public method | Insert(Int32, Object) | Inserts an item to the IList at the specified index.
Public method | Insert(Int32, vTreeNode) | Inserts the specified i.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(Object) | Removes the first occurrence of a specific object from the IList.
Public method | Remove(vTreeNode) | Removes the specified child.
Public method | RemoveAt | Removes the IList item at the specified index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsFixedSize | Gets a value indicating whether the IList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the IList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Public property | Item | Gets the vTreeNode with the specified i.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.

See Also

vTreeNodeCollection Class


vTreeNodeCollection Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection Constructor
vTreeNodeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | vTreeNodeCollection()()()() | Initializes a new instance of the vTreeNodeCollection class.
Public method | vTreeNodeCollection(vTreeView, vTreeNode) | Initializes a new instance of the vTreeNodeCollection class.

See Also

vTreeNodeCollection Class
vTreeNodeCollection Members


vTreeNodeCollection Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection Constructor
vTreeNodeCollection Class See Also Send Feedback
Initializes a new instance of the vTreeNodeCollection class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected vTreeNodeCollection()
Visual Basic
Protected Sub New
Visual C++
protected:
vTreeNodeCollection()

See Also

vTreeNodeCollection Class
vTreeNodeCollection Overload


vTreeNodeCollection Constructor (vTreeView, vTreeNode)

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection Constructor (vTreeView, vTreeNode)
vTreeNodeCollection Class See Also Send Feedback
Initializes a new instance of the vTreeNodeCollection class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNodeCollection(
    vTreeView owner,
    vTreeNode parentNode
)
Visual Basic
Public Sub New ( _
    owner As vTreeView, _
    parentNode As vTreeNode _
)
Visual C++
public:
vTreeNodeCollection(
    vTreeView^ owner,
    vTreeNode^ parentNode
)

Parameters

owner
Type: VIBlend.WinForms.Controls..::..vTreeView
The owner.
parentNode
Type: VIBlend.WinForms.Controls..::..vTreeNode
The parent node.

See Also

vTreeNodeCollection Class
vTreeNodeCollection Overload


vTreeNodeCollection Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection Methods
vTreeNodeCollection Class See Also Send Feedback

The vTreeNodeCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add(Object) | Adds an item to the IList.
Public method | Add(vTreeNode) | Adds the specified node.
Public method | Add(Object, Boolean) | Adds the specified value.
Public method | Add(vTreeNode, Boolean) | Adds the specified node.
Public method | Clear | Removes all items from the IList.
Public method | Contains | Determines whether the IList contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | Gets the index.
Public method | GetOwnerNode | Gets the owner node.
Public method | GetOwnerTree | Gets the owner tree.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IList.
Public method | Insert(Int32, Object) | Inserts an item to the IList at the specified index.
Public method | Insert(Int32, vTreeNode) | Inserts the specified i.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(Object) | Removes the first occurrence of a specific object from the IList.
Public method | Remove(vTreeNode) | Removes the specified child.
Public method | RemoveAt | Removes the IList item at the specified index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vTreeNodeCollection Class


Add Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..Add Method
vTreeNodeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(Object) | Adds an item to the IList.
Public method | Add(vTreeNode) | Adds the specified node.
Public method | Add(Object, Boolean) | Adds the specified value.
Public method | Add(vTreeNode, Boolean) | Adds the specified node.

See Also

vTreeNodeCollection Class
vTreeNodeCollection Members


Add Method (Object)

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..Add Method (Object)
vTreeNodeCollection Class See Also Send Feedback
Adds an item to the IList.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Add(
    Object value
)
Visual Basic
Public Function Add ( _
    value As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ value
) sealed

Parameters

value
Type: System..::..Object
The Object to add to the IList.

Return Value

The position into which the new element was inserted.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | The IList is read-only. -or- The IList has a fixed size.

See Also

vTreeNodeCollection Class
Add Overload


Add Method (vTreeNode)

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..Add Method (vTreeNode)
vTreeNodeCollection Class See Also Send Feedback
Adds the specified node.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Add(
    vTreeNode node
)
Visual Basic
Public Sub Add ( _
    node As vTreeNode _
)
Visual C++
public:
void Add(
    vTreeNode^ node
)

Parameters

node
Type: VIBlend.WinForms.Controls..::..vTreeNode
The node.

See Also

vTreeNodeCollection Class
Add Overload


Add Method (Object, Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..Add Method (Object, Boolean)
vTreeNodeCollection Class See Also Send Feedback
Adds the specified value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Add(
    Object value,
    bool expand
)
Visual Basic
Public Function Add ( _
    value As Object, _
    expand As Boolean _
) As Integer
Visual C++
public:
int Add(
    Object^ value,
    bool expand
)

Parameters

value
Type: System..::..Object
The value.
expand
Type: System..::..Boolean
if set to true [expand].

Return Value

See Also

vTreeNodeCollection Class
Add Overload


Add Method (vTreeNode, Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..Add Method (vTreeNode, Boolean)
vTreeNodeCollection Class See Also Send Feedback
Adds the specified node.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Add(
    vTreeNode node,
    bool expand
)
Visual Basic
Public Sub Add ( _
    node As vTreeNode, _
    expand As Boolean _
)
Visual C++
public:
void Add(
    vTreeNode^ node,
    bool expand
)

Parameters

node
Type: VIBlend.WinForms.Controls..::..vTreeNode
The node.
expand
Type: System..::..Boolean
if set to true [expand].

See Also

vTreeNodeCollection Class
Add Overload


Clear Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..Clear Method
vTreeNodeCollection Class See Also Send Feedback
Removes all items from the IList.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | The IList is read-only.

See Also

vTreeNodeCollection Class


Contains Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..Contains Method
vTreeNodeCollection Class See Also Send Feedback
Determines whether the IList contains a specific value.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Contains(
    Object value
)
Visual Basic
Public Function Contains ( _
    value As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ value
) sealed

Parameters

value
Type: System..::..Object
The Object to locate in the IList.

Return Value

true if the Object is found in the IList; otherwise, false.

Implements

IList..::..Contains(Object)

See Also

vTreeNodeCollection Class


CopyTo Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..CopyTo Method
vTreeNodeCollection Class See Also Send Feedback
Copies the elements of the ICollection to an Array, starting at a particular Array index.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from ICollection. The Array must have zero-based indexing.
index
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is null.
System..::..ArgumentOutOfRangeException | index is less than zero.
System..::..ArgumentException | array is multidimensional. -or- index is equal to or greater than the length of array. -or- The number of elements in the source ICollection is greater than the available space from index to the end of the destination array.
System..::..ArgumentException | The type of the source ICollection cannot be cast automatically to the type of the destination array.

See Also

vTreeNodeCollection Class


GetEnumerator Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..GetEnumerator Method
vTreeNodeCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public IEnumerator<vTreeNode> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of vTreeNode)
Visual C++
public:
virtual IEnumerator<vTreeNode^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

vTreeNodeCollection Class


GetIndex Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..GetIndex Method
vTreeNodeCollection Class See Also Send Feedback
Gets the index.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int GetIndex(
    vTreeNode node
)
Visual Basic
Public Function GetIndex ( _
    node As vTreeNode _
) As Integer
Visual C++
public:
int GetIndex(
    vTreeNode^ node
)

Parameters

node
Type: VIBlend.WinForms.Controls..::..vTreeNode
The node.

Return Value

See Also

vTreeNodeCollection Class


GetOwnerNode Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..GetOwnerNode Method
vTreeNodeCollection Class See Also Send Feedback
Gets the owner node.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode GetOwnerNode()
Visual Basic
Public Function GetOwnerNode As vTreeNode
Visual C++
public:
vTreeNode^ GetOwnerNode()

Return Value

See Also

vTreeNodeCollection Class


GetOwnerTree Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..GetOwnerTree Method
vTreeNodeCollection Class See Also Send Feedback
Gets the owner tree.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeView GetOwnerTree()
Visual Basic
Public Function GetOwnerTree As vTreeView
Visual C++
public:
vTreeView^ GetOwnerTree()

Return Value

See Also

vTreeNodeCollection Class


IndexOf Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..IndexOf Method
vTreeNodeCollection Class See Also Send Feedback
Determines the index of a specific item in the IList.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int IndexOf(
    Object value
)
Visual Basic
Public Function IndexOf ( _
    value As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ value
) sealed

Parameters

value
Type: System..::..Object
The Object to locate in the IList.

Return Value

The index of value if found in the list; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

vTreeNodeCollection Class


Insert Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..Insert Method
vTreeNodeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Insert(Int32, Object) | Inserts an item to the IList at the specified index.
Public method | Insert(Int32, vTreeNode) | Inserts the specified i.

See Also

vTreeNodeCollection Class
vTreeNodeCollection Members


Insert Method (Int32, Object)

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..Insert Method (Int32, Object)
vTreeNodeCollection Class See Also Send Feedback
Inserts an item to the IList at the specified index.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Insert(
    int index,
    Object value
)
Visual Basic
Public Sub Insert ( _
    index As Integer, _
    value As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ value
) sealed

Parameters

index
Type: System..::..Int32
The zero-based index at which value should be inserted.
value
Type: System..::..Object
The Object to insert into the IList.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is not a valid index in the IList.
System..::..NotSupportedException | The IList is read-only. -or- The IList has a fixed size.
System..::..NullReferenceException | value is null reference in the IList.

See Also

vTreeNodeCollection Class
Insert Overload


Insert Method (Int32, vTreeNode)

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..Insert Method (Int32, vTreeNode)
vTreeNodeCollection Class See Also Send Feedback
Inserts the specified i.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Insert(
    int i,
    vTreeNode node
)
Visual Basic
Public Sub Insert ( _
    i As Integer, _
    node As vTreeNode _
)
Visual C++
public:
void Insert(
    int i,
    vTreeNode^ node
)

Parameters

i
Type: System..::..Int32
The i.
node
Type: VIBlend.WinForms.Controls..::..vTreeNode
The node.

See Also

vTreeNodeCollection Class
Insert Overload


Remove Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..Remove Method
vTreeNodeCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(Object) | Removes the first occurrence of a specific object from the IList.
Public method | Remove(vTreeNode) | Removes the specified child.

See Also

vTreeNodeCollection Class
vTreeNodeCollection Members


Remove Method (Object)

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..Remove Method (Object)
vTreeNodeCollection Class See Also Send Feedback
Removes the first occurrence of a specific object from the IList.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Remove(
    Object value
)
Visual Basic
Public Sub Remove ( _
    value As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ value
) sealed

Parameters

value
Type: System..::..Object
The Object to remove from the IList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | The IList is read-only. -or- The IList has a fixed size.

See Also

vTreeNodeCollection Class
Remove Overload


Remove Method (vTreeNode)

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..Remove Method (vTreeNode)
vTreeNodeCollection Class See Also Send Feedback
Removes the specified child.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Remove(
    vTreeNode child
)
Visual Basic
Public Sub Remove ( _
    child As vTreeNode _
)
Visual C++
public:
void Remove(
    vTreeNode^ child
)

Parameters

child
Type: VIBlend.WinForms.Controls..::..vTreeNode
The child.

See Also

vTreeNodeCollection Class
Remove Overload


RemoveAt Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..RemoveAt Method
vTreeNodeCollection Class See Also Send Feedback
Removes the IList item at the specified index.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
) sealed

Parameters

index
Type: System..::..Int32
The zero-based index of the item to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is not a valid index in the IList.
System..::..NotSupportedException | The IList is read-only. -or- The IList has a fixed size.

See Also

vTreeNodeCollection Class


vTreeNodeCollection Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection Properties
vTreeNodeCollection Class See Also Send Feedback

The vTreeNodeCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsFixedSize | Gets a value indicating whether the IList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the IList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Public property | Item | Gets the vTreeNode with the specified i.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.

See Also

vTreeNodeCollection Class


Count Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..Count Property
vTreeNodeCollection Class See Also Send Feedback
Gets the number of elements contained in the ICollection.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Field Value

Return Value

The number of elements contained in the ICollection.

Implements

ICollection..::..Count

See Also

vTreeNodeCollection Class


IsFixedSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..IsFixedSize Property
vTreeNodeCollection Class See Also Send Feedback
Gets a value indicating whether the IList has a fixed size.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsFixedSize { get; }
Visual Basic
Public ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get () sealed;
}

Field Value

Return Value

true if the IList has a fixed size; otherwise, false.

Implements

IList..::..IsFixedSize

See Also

vTreeNodeCollection Class


IsReadOnly Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..IsReadOnly Property
vTreeNodeCollection Class See Also Send Feedback
Gets a value indicating whether the IList is read-only.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic
Public ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Field Value

Return Value

true if the IList is read-only; otherwise, false.

Implements

IList..::..IsReadOnly

See Also

vTreeNodeCollection Class


IsSynchronized Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..IsSynchronized Property
vTreeNodeCollection Class See Also Send Feedback
Gets a value indicating whether access to the ICollection is synchronized (thread safe).

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic
Public ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Field Value

Return Value

true if access to the ICollection is synchronized (thread safe); otherwise, false.

Implements

ICollection..::..IsSynchronized

See Also

vTreeNodeCollection Class


Item Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..Item Property
vTreeNodeCollection Class See Also Send Feedback
Gets the vTreeNode with the specified i.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode this[
    int i
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    i As Integer _
) As vTreeNode
    Get
Visual C++
public:
property vTreeNode^ default[int i] {
    vTreeNode^ get (int i);
}

Parameters

i
Type: System..::..Int32

Field Value

See Also

vTreeNodeCollection Class


SyncRoot Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeCollection..::..SyncRoot Property
vTreeNodeCollection Class See Also Send Feedback
Gets an object that can be used to synchronize access to the ICollection.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic
Public ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}

Field Value

Return Value

An object that can be used to synchronize access to the ICollection.

Implements

ICollection..::..SyncRoot

See Also

vTreeNodeCollection Class


vTreeNodeLabelEditEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeLabelEditEventArgs Class
Members See Also Send Feedback
Represents a vTreeNode label edit event arguments

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vTreeNodeLabelEditEventArgs : EventArgs
Visual Basic
Public Class vTreeNodeLabelEditEventArgs _
    Inherits EventArgs
Visual C++
public ref class vTreeNodeLabelEditEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..vTreeNodeLabelEditEventArgs

See Also

vTreeNodeLabelEditEventArgs Members


vTreeNodeLabelEditEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeLabelEditEventArgs Members
vTreeNodeLabelEditEventArgs Class Constructors Methods Properties See Also Send Feedback

The vTreeNodeLabelEditEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | vTreeNodeLabelEditEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CancelEdit | Determines whether to cancel the edit or not
Public property | Label | Gets the label for the vTreeNode being edited
Public property | Node | Gets the vTreeNode being edited

See Also

vTreeNodeLabelEditEventArgs Class


vTreeNodeLabelEditEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeLabelEditEventArgs Constructor
vTreeNodeLabelEditEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNodeLabelEditEventArgs(
    vTreeNode node,
    string label
)
Visual Basic
Public Sub New ( _
    node As vTreeNode, _
    label As String _
)
Visual C++
public:
vTreeNodeLabelEditEventArgs(
    vTreeNode^ node,
    String^ label
)

Parameters

node
Type: VIBlend.WinForms.Controls..::..vTreeNode
vTreeNode to edit
label
Type: System..::..String
The vTreeNode's label

See Also

vTreeNodeLabelEditEventArgs Class


vTreeNodeLabelEditEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeLabelEditEventArgs Methods
vTreeNodeLabelEditEventArgs Class See Also Send Feedback

The vTreeNodeLabelEditEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vTreeNodeLabelEditEventArgs Class


vTreeNodeLabelEditEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeLabelEditEventArgs Properties
vTreeNodeLabelEditEventArgs Class See Also Send Feedback

The vTreeNodeLabelEditEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | CancelEdit | Determines whether to cancel the edit or not
Public property | Label | Gets the label for the vTreeNode being edited
Public property | Node | Gets the vTreeNode being edited

See Also

vTreeNodeLabelEditEventArgs Class


CancelEdit Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeLabelEditEventArgs..::..CancelEdit Property
vTreeNodeLabelEditEventArgs Class See Also Send Feedback
Determines whether to cancel the edit or not

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool CancelEdit { get; set; }
Visual Basic
Public Property CancelEdit As Boolean
    Get
    Set
Visual C++
public:
property bool CancelEdit {
    bool get ();
    void set (bool value);
}

See Also

vTreeNodeLabelEditEventArgs Class


Label Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeLabelEditEventArgs..::..Label Property
vTreeNodeLabelEditEventArgs Class See Also Send Feedback
Gets the label for the vTreeNode being edited

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Label { get; }
Visual Basic
Public ReadOnly Property Label As String
    Get
Visual C++
public:
property String^ Label {
    String^ get ();
}

See Also

vTreeNodeLabelEditEventArgs Class


Node Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeNodeLabelEditEventArgs..::..Node Property
vTreeNodeLabelEditEventArgs Class See Also Send Feedback
Gets the vTreeNode being edited

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode Node { get; }
Visual Basic
Public ReadOnly Property Node As vTreeNode
    Get
Visual C++
public:
property vTreeNode^ Node {
    vTreeNode^ get ();
}

See Also

vTreeNodeLabelEditEventArgs Class


vTreeView Class

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView Class
Members See Also Send Feedback
Represents a vTreeView control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vTreeView : Control, IScrollableControlBase
Visual Basic
Public Class vTreeView _
    Inherits Control _
    Implements IScrollableControlBase
Visual C++
public ref class vTreeView : public Control,
    IScrollableControlBase

Remarks

A vTreeView displays a hierarchical collection of items with rich customization of the functionality, and the visual appearance."

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vTreeView

See Also

vTreeView Members


vTreeView Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeView Members
vTreeView Class Constructors Methods Properties Events See Also Send Feedback

The vTreeView type exposes the following members.

Constructors

 | Name | Description
Public method | vTreeView | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginEdit | Opens a textbox editor to edit the currently selected node.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate |
Public method | BringIntoView | Scrolls to a given tree node, if needeed.
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CollapseAll | Collapses all tree nodes.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrowIndicator | Draws the arrow indicator.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndEdit | Ends the editing of a tree node.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Ends the update.
 | EnsureVisible | Ensures that a specific tree node is visible
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandAll | Expands all nodes
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindNodeAt | Gets an instance of a node from collection in a given position.
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetNodes | Gets all vTreeNodes recursively as list.
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest | Performs a HitTest at a specific point and returns the tree node located at this point
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | InvalidateNodes | Fires the MouseMove.
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawTreeNode |
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnToolTipShown |
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Overrides Control..::..ProcessCmdKey(Message%, Keys).)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Public method | UpdateLayout | Updates the layout.
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDragAndDrop | Gets or sets whether drag and drop is enabled.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the vTreeView control
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckBoxes | Gets or sets whether the tree view should display checkboxes next to the nodes.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Public property | DefaultExpandCollapseIndicators | Gets or sets whether to use default expand/collapse indicators
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableIndicatorsAnimation | Gets or sets a value indicating whether indigators animation is enabled
Public property | EnableMultipleSelection | Gets or sets a value indicating whether multiple selection is enabled.
Public property | EnableToggleAnimation | Gets or sets a value indicating whether toggle animation is enabled
Public property | EnableToolTips | Gets or sets a value indicating whether tool tips are enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FirstVisibleNode | Gets the first visible node.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control.
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FullRowSelect | Gets or sets a value indicating whether fullRowSelect is enabled.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImageList | Gets or sets the ImageList that contains the Image objects used by the tree nodes.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | IndicatorsColor | Gets or sets the color of the indicators.
Public property | IndicatorsHighlightColor | Gets or sets the highlight color of the indicators.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsEditing | Checks if the vTreeView is currently in a node text editing mode.
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsUpdating | Gets a value indicating whether this instance is updating.
Public property | ItemHeight | Gets the height of the tree nodes
Public property | LabelEdit | Gets or sets a value indicating whether the label text of the tree nodes can be edited.
Public property | LastVisibleNode | Gets the last visible node.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | LineColor | Gets or sets the color of tree lines.
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Nodes | Gets the collection of the tree view nodes.
Public property | NodesSpacing | Gets or sets the spacing between the tree nodes.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintNodesDefaultBorder | Gets or sets a value indicating whether to paint a border
Public property | PaintNodesDefaultFill | Gets or sets a value indicating whether to paint a background
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollPosition | Gets the current scroll position of the vTreeView control
Public property | SelectedNode | Gets the first selected node in the vTreeView.
Public property | SelectedNodes | Gets the currently selected nodes
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the tab is Focused
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowRootLines | Gets or sets whether to show root lines.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control.
Public property | ToolTipDuration | Gets or sets the duration of the tool tip.
Public property | ToolTipShowDelay | Gets or sets the tool tip show delay.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TreeIndent | Gets or sets the indent of the tree nodes.
Public property | TriStateMode | Gets or sets whether the tree view should display checkboxes next to the nodes and have the tri state mode enabled.
Public property | UseThemeBackColor | Gets or sets a value indicating whether to use the Theme BackColor
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the Theme border color
Public property | UseThemeIndicatorsColor | Gets or sets a value indicating whether to use the default indicators color.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendScrollBarsTheme | Gets or sets the theme of the treeview scrollbars using one of the built-in themes.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AfterCollapse | Occurs after the tree node is collapsed.
Public event | AfterDragEnd | Occurs after a drag and drop ends
Public event | AfterDragStart | Occurs after a drag and drop starts
Public event | AfterExpand | Occurs after the tree node is expanded.
Public event | AfterLabelEdit | Occurs after a node label is edited.
Public event | AfterSelect | Occurs after a node is selected
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BeforeCollapse | Occurs before a node collapses
Public event | BeforeDragEnd | Occurs before a drag and drop ends
Public event | BeforeDragStart | Occurs before a drag and drop starts
Public event | BeforeExpand | Occurs before a node expands.
Public event | BeforeLabelEdit | Occurs before a node label edit.
Public event | BeforeSelect | Occurs before a node is selected
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawTreeNode | Occurs when a node is rendered.
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | NodeChecked | Occurs after the tree node is checked
Public event | NodeMouseDown | Occurs when the user clicks the mouse button over a node
Public event | NodeMouseUp | Occurs when the user clicks the mouse button over a node
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | TooltipShow | Occurs when tooltip shows.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vTreeView Class


vTreeView Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView Constructor
vTreeView Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeView()
Visual Basic
Public Sub New
Visual C++
public:
vTreeView()

See Also

vTreeView Class


vTreeView Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeView Methods
vTreeView Class See Also Send Feedback

The vTreeView type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginEdit | Opens a textbox editor to edit the currently selected node.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate |
Public method | BringIntoView | Scrolls to a given tree node, if needeed.
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CollapseAll | Collapses all tree nodes.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrowIndicator | Draws the arrow indicator.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndEdit | Ends the editing of a tree node.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Ends the update.
 | EnsureVisible | Ensures that a specific tree node is visible
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandAll | Expands all nodes
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindNodeAt | Gets an instance of a node from collection in a given position.
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetNodes | Gets all vTreeNodes recursively as list.
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest | Performs a HitTest at a specific point and returns the tree node located at this point
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | InvalidateNodes | Fires the MouseMove.
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawTreeNode |
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnToolTipShown |
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Overrides Control..::..ProcessCmdKey(Message%, Keys).)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Public method | UpdateLayout | Updates the layout.
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vTreeView Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..AccessibilityNotifyClients Method
vTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vTreeView Class
vTreeView Members


BeginEdit Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..BeginEdit Method
vTreeView Class See Also Send Feedback
Opens a textbox editor to edit the currently selected node.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool BeginEdit(
    string value
)
Visual Basic
Public Function BeginEdit ( _
    value As String _
) As Boolean
Visual C++
public:
bool BeginEdit(
    String^ value
)

Parameters

value
Type: System..::..String
Text to insert in the text box. If you pass a null (VB Nothing), the node's text will be used.

Return Value

See Also

vTreeView Class


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..BeginInvoke Method
vTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vTreeView Class
vTreeView Members


BeginUpdate Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..BeginUpdate Method
vTreeView Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void BeginUpdate()
Visual Basic
Public Sub BeginUpdate
Visual C++
public:
void BeginUpdate()

See Also

vTreeView Class


BringIntoView Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..BringIntoView Method
vTreeView Class See Also Send Feedback
Scrolls to a given tree node, if needeed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void BringIntoView(
    vTreeNode treeNode
)
Visual Basic
Public Sub BringIntoView ( _
    treeNode As vTreeNode _
)
Visual C++
public:
void BringIntoView(
    vTreeNode^ treeNode
)

Parameters

treeNode
Type: VIBlend.WinForms.Controls..::..vTreeNode

See Also

vTreeView Class


CollapseAll Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..CollapseAll Method
vTreeView Class See Also Send Feedback
Collapses all tree nodes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void CollapseAll()
Visual Basic
Public Sub CollapseAll
Visual C++
public:
void CollapseAll()

See Also

vTreeView Class


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..Dispose Method
vTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

vTreeView Class
vTreeView Members


DrawArrowIndicator Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..DrawArrowIndicator Method
vTreeView Class See Also Send Feedback
Draws the arrow indicator.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DrawArrowIndicator(
    Graphics g,
    int x,
    int y,
    bool isExpanded,
    bool isHover
)
Visual Basic
Protected Overridable Sub DrawArrowIndicator ( _
    g As Graphics, _
    x As Integer, _
    y As Integer, _
    isExpanded As Boolean, _
    isHover As Boolean _
)
Visual C++
protected:
virtual void DrawArrowIndicator(
    Graphics^ g,
    int x,
    int y,
    bool isExpanded,
    bool isHover
)

Parameters

g
Type: System.Drawing..::..Graphics
The g.
x
Type: System..::..Int32
The x.
y
Type: System..::..Int32
The y.
isExpanded
Type: System..::..Boolean
if set to true [is expanded].
isHover
Type: System..::..Boolean
if set to true [is hover].

See Also

vTreeView Class


EndEdit Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..EndEdit Method
vTreeView Class See Also Send Feedback
Ends the editing of a tree node.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void EndEdit(
    bool cancel
)
Visual Basic
Public Sub EndEdit ( _
    cancel As Boolean _
)
Visual C++
public:
void EndEdit(
    bool cancel
)

Parameters

cancel
Type: System..::..Boolean
Determines whether the changes should be applied or not.

See Also

vTreeView Class


EndUpdate Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..EndUpdate Method
vTreeView Class See Also Send Feedback
Ends the update.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void EndUpdate()
Visual Basic
Public Sub EndUpdate
Visual C++
public:
void EndUpdate()

See Also

vTreeView Class


EnsureVisible Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..EnsureVisible Method
vTreeView Class See Also Send Feedback
Ensures that a specific tree node is visible

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static void EnsureVisible(
    vTreeNode node
)
Visual Basic
Public Shared Sub EnsureVisible ( _
    node As vTreeNode _
)
Visual C++
public:
static void EnsureVisible(
    vTreeNode^ node
)

Parameters

node
Type: VIBlend.WinForms.Controls..::..vTreeNode

See Also

vTreeView Class


ExpandAll Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..ExpandAll Method
vTreeView Class See Also Send Feedback
Expands all nodes

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ExpandAll()
Visual Basic
Public Sub ExpandAll
Visual C++
public:
void ExpandAll()

See Also

vTreeView Class


FindNodeAt Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..FindNodeAt Method
vTreeView Class See Also Send Feedback
Gets an instance of a node from collection in a given position.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode FindNodeAt(
    vTreeNodeCollection nodes,
    int x,
    int y
)
Visual Basic
Public Function FindNodeAt ( _
    nodes As vTreeNodeCollection, _
    x As Integer, _
    y As Integer _
) As vTreeNode
Visual C++
public:
vTreeNode^ FindNodeAt(
    vTreeNodeCollection^ nodes,
    int x,
    int y
)

Parameters

nodes
Type: VIBlend.WinForms.Controls..::..vTreeNodeCollection
x
Type: System..::..Int32
y
Type: System..::..Int32

Return Value

See Also

vTreeView Class


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..GetChildAtPoint Method
vTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vTreeView Class
vTreeView Members


GetNodes Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..GetNodes Method
vTreeView Class See Also Send Feedback
Gets all vTreeNodes recursively as list.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<vTreeNode> GetNodes()
Visual Basic
Public Function GetNodes As List(Of vTreeNode)
Visual C++
public:
List<vTreeNode^>^ GetNodes()

Return Value

See Also

vTreeView Class


HitTest Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..HitTest Method
vTreeView Class See Also Send Feedback
Performs a HitTest at a specific point and returns the tree node located at this point

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode HitTest(
    Point point
)
Visual Basic
Public Function HitTest ( _
    point As Point _
) As vTreeNode
Visual C++
public:
vTreeNode^ HitTest(
    Point point
)

Parameters

point
Type: System.Drawing..::..Point
Point to test

Return Value

A vTreeNode located at the hit test point. If there is no node at this location, the method returns null (VB Nothing).

See Also

vTreeView Class


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..Invalidate Method
vTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vTreeView Class
vTreeView Members


InvalidateNodes Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..InvalidateNodes Method
vTreeView Class See Also Send Feedback
Fires the MouseMove.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void InvalidateNodes(
    vTreeNodeCollection nodes
)
Visual Basic
Public Sub InvalidateNodes ( _
    nodes As vTreeNodeCollection _
)
Visual C++
public:
void InvalidateNodes(
    vTreeNodeCollection^ nodes
)

Parameters

nodes
Type: VIBlend.WinForms.Controls..::..vTreeNodeCollection

See Also

vTreeView Class


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..Invoke Method
vTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vTreeView Class
vTreeView Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..MemberwiseClone Method
vTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vTreeView Class
vTreeView Members


OnDrawTreeNode Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..OnDrawTreeNode Method
vTreeView Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnDrawTreeNode(
    DrawNodeEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnDrawTreeNode ( _
    args As DrawNodeEventArgs _
)
Visual C++
protected public:
virtual void OnDrawTreeNode(
    DrawNodeEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.Controls..::..DrawNodeEventArgs

See Also

vTreeView Class


OnToolTipShown Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..OnToolTipShown Method
vTreeView Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal virtual void OnToolTipShown(
    ToolTipEventArgs args
)
Visual Basic
Protected Friend Overridable Sub OnToolTipShown ( _
    args As ToolTipEventArgs _
)
Visual C++
protected public:
virtual void OnToolTipShown(
    ToolTipEventArgs^ args
)

Parameters

args
Type: ToolTipEventArgs

See Also

vTreeView Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..PerformLayout Method
vTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vTreeView Class
vTreeView Members


ProcessCmdKey Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..ProcessCmdKey Method
vTreeView Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override bool ProcessCmdKey(
    ref Message msg,
    Keys keyData
)
Visual Basic
Protected Overrides Function ProcessCmdKey ( _
    ByRef msg As Message, _
    keyData As Keys _
) As Boolean
Visual C++
protected:
virtual bool ProcessCmdKey(
    Message% msg,
    Keys keyData
) override

Parameters

msg
Type: System.Windows.Forms..::..Message %
keyData
Type: System.Windows.Forms..::..Keys

See Also

vTreeView Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..ResumeLayout Method
vTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vTreeView Class
vTreeView Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..RtlTranslateAlignment Method
vTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vTreeView Class
vTreeView Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..Scale Method
vTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vTreeView Class
vTreeView Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..Select Method
vTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vTreeView Class
vTreeView Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..SetBounds Method
vTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vTreeView Class
vTreeView Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..UpdateBounds Method
vTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vTreeView Class
vTreeView Members


UpdateLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..UpdateLayout Method
vTreeView Class See Also Send Feedback
Updates the layout.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void UpdateLayout()
Visual Basic
Public Sub UpdateLayout
Visual C++
public:
void UpdateLayout()

See Also

vTreeView Class


vTreeView Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeView Properties
vTreeView Class See Also Send Feedback

The vTreeView type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether the control is animated
Public property | AllowDragAndDrop | Gets or sets whether drag and drop is enabled.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the vTreeView control
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckBoxes | Gets or sets whether the tree view should display checkboxes next to the nodes.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Public property | DefaultExpandCollapseIndicators | Gets or sets whether to use default expand/collapse indicators
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableIndicatorsAnimation | Gets or sets a value indicating whether indigators animation is enabled
Public property | EnableMultipleSelection | Gets or sets a value indicating whether multiple selection is enabled.
Public property | EnableToggleAnimation | Gets or sets a value indicating whether toggle animation is enabled
Public property | EnableToolTips | Gets or sets a value indicating whether tool tips are enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FirstVisibleNode | Gets the first visible node.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control.
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FullRowSelect | Gets or sets a value indicating whether fullRowSelect is enabled.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImageList | Gets or sets the ImageList that contains the Image objects used by the tree nodes.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | IndicatorsColor | Gets or sets the color of the indicators.
Public property | IndicatorsHighlightColor | Gets or sets the highlight color of the indicators.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsEditing | Checks if the vTreeView is currently in a node text editing mode.
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsUpdating | Gets a value indicating whether this instance is updating.
Public property | ItemHeight | Gets the height of the tree nodes
Public property | LabelEdit | Gets or sets a value indicating whether the label text of the tree nodes can be edited.
Public property | LastVisibleNode | Gets the last visible node.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | LineColor | Gets or sets the color of tree lines.
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Nodes | Gets the collection of the tree view nodes.
Public property | NodesSpacing | Gets or sets the spacing between the tree nodes.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintNodesDefaultBorder | Gets or sets a value indicating whether to paint a border
Public property | PaintNodesDefaultFill | Gets or sets a value indicating whether to paint a background
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollPosition | Gets the current scroll position of the vTreeView control
Public property | SelectedNode | Gets the first selected node in the vTreeView.
Public property | SelectedNodes | Gets the currently selected nodes
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowFocusRectangle | Determines whether to show the focus rectangle when the tab is Focused
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowRootLines | Gets or sets whether to show root lines.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control.
Public property | ToolTipDuration | Gets or sets the duration of the tool tip.
Public property | ToolTipShowDelay | Gets or sets the tool tip show delay.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TreeIndent | Gets or sets the indent of the tree nodes.
Public property | TriStateMode | Gets or sets whether the tree view should display checkboxes next to the nodes and have the tri state mode enabled.
Public property | UseThemeBackColor | Gets or sets a value indicating whether to use the Theme BackColor
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the Theme border color
Public property | UseThemeIndicatorsColor | Gets or sets a value indicating whether to use the default indicators color.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendScrollBarsTheme | Gets or sets the theme of the treeview scrollbars using one of the built-in themes.
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vTreeView Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..AllowAnimations Property
vTreeView Class See Also Send Feedback
Gets or sets whether the control is animated

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vTreeView Class


AllowDragAndDrop Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..AllowDragAndDrop Property
vTreeView Class See Also Send Feedback
Gets or sets whether drag and drop is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowDragAndDrop { get; set; }
Visual Basic
Public Property AllowDragAndDrop As Boolean
    Get
    Set
Visual C++
public:
property bool AllowDragAndDrop {
    bool get ();
    void set (bool value);
}

See Also

vTreeView Class


BorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..BorderColor Property
vTreeView Class See Also Send Feedback
Gets or sets the border color of the vTreeView control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color BorderColor { get; set; }
Visual Basic
Public Property BorderColor As Color
    Get
    Set
Visual C++
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}

See Also

vTreeView Class


CheckBoxes Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..CheckBoxes Property
vTreeView Class See Also Send Feedback
Gets or sets whether the tree view should display checkboxes next to the nodes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool CheckBoxes { get; set; }
Visual Basic
Public Property CheckBoxes As Boolean
    Get
    Set
Visual C++
public:
property bool CheckBoxes {
    bool get ();
    void set (bool value);
}

See Also

vTreeView Class


DefaultExpandCollapseIndicators Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..DefaultExpandCollapseIndicators Property
vTreeView Class See Also Send Feedback
Gets or sets whether to use default expand/collapse indicators

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool DefaultExpandCollapseIndicators { get; set; }
Visual Basic
Public Property DefaultExpandCollapseIndicators As Boolean
    Get
    Set
Visual C++
public:
property bool DefaultExpandCollapseIndicators {
    bool get ();
    void set (bool value);
}

See Also

vTreeView Class


EnableIndicatorsAnimation Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..EnableIndicatorsAnimation Property
vTreeView Class See Also Send Feedback
Gets or sets a value indicating whether indigators animation is enabled

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableIndicatorsAnimation { get; set; }
Visual Basic
Public Property EnableIndicatorsAnimation As Boolean
    Get
    Set
Visual C++
public:
property bool EnableIndicatorsAnimation {
    bool get ();
    void set (bool value);
}

Field Value

true if true the animation is enabled; otherwise, false.

See Also

vTreeView Class


EnableMultipleSelection Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..EnableMultipleSelection Property
vTreeView Class See Also Send Feedback
Gets or sets a value indicating whether multiple selection is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableMultipleSelection { get; set; }
Visual Basic
Public Property EnableMultipleSelection As Boolean
    Get
    Set
Visual C++
public:
property bool EnableMultipleSelection {
    bool get ();
    void set (bool value);
}

See Also

vTreeView Class


EnableToggleAnimation Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..EnableToggleAnimation Property
vTreeView Class See Also Send Feedback
Gets or sets a value indicating whether toggle animation is enabled

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableToggleAnimation { get; set; }
Visual Basic
Public Property EnableToggleAnimation As Boolean
    Get
    Set
Visual C++
public:
property bool EnableToggleAnimation {
    bool get ();
    void set (bool value);
}

Field Value

true if true the animation is enabled; otherwise, false.

See Also

vTreeView Class


EnableToolTips Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..EnableToolTips Property
vTreeView Class See Also Send Feedback
Gets or sets a value indicating whether tool tips are enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool EnableToolTips { get; set; }
Visual Basic
Public Overridable Property EnableToolTips As Boolean
    Get
    Set
Visual C++
public:
virtual property bool EnableToolTips {
    bool get ();
    void set (bool value);
}

See Also

vTreeView Class


FirstVisibleNode Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..FirstVisibleNode Property
vTreeView Class See Also Send Feedback
Gets the first visible node.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode FirstVisibleNode { get; }
Visual Basic
Public ReadOnly Property FirstVisibleNode As vTreeNode
    Get
Visual C++
public:
property vTreeNode^ FirstVisibleNode {
    vTreeNode^ get ();
}

See Also

vTreeView Class


Font Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..Font Property
vTreeView Class See Also Send Feedback
Gets or sets the font of the text displayed by the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font Font { get; set; }
Visual Basic
Public Property Font As Font
    Get
    Set
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

Field Value

Return Value

The Font to apply to the text displayed by the control. The default is the value of the DefaultFont property.

See Also

vTreeView Class


FullRowSelect Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..FullRowSelect Property
vTreeView Class See Also Send Feedback
Gets or sets a value indicating whether fullRowSelect is enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool FullRowSelect { get; set; }
Visual Basic
Public Property FullRowSelect As Boolean
    Get
    Set
Visual C++
public:
property bool FullRowSelect {
    bool get ();
    void set (bool value);
}

See Also

vTreeView Class


ImageList Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..ImageList Property
vTreeView Class See Also Send Feedback
Gets or sets the ImageList that contains the Image objects used by the tree nodes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ImageList ImageList { get; set; }
Visual Basic
Public Property ImageList As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ ImageList {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

vTreeView Class


IndicatorsColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..IndicatorsColor Property
vTreeView Class See Also Send Feedback
Gets or sets the color of the indicators.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color IndicatorsColor { get; set; }
Visual Basic
Public Property IndicatorsColor As Color
    Get
    Set
Visual C++
public:
property Color IndicatorsColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the indicators.

See Also

vTreeView Class


IndicatorsHighlightColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..IndicatorsHighlightColor Property
vTreeView Class See Also Send Feedback
Gets or sets the highlight color of the indicators.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color IndicatorsHighlightColor { get; set; }
Visual Basic
Public Property IndicatorsHighlightColor As Color
    Get
    Set
Visual C++
public:
property Color IndicatorsHighlightColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the indicators.

See Also

vTreeView Class


IsEditing Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..IsEditing Property
vTreeView Class See Also Send Feedback
Checks if the vTreeView is currently in a node text editing mode.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsEditing { get; }
Visual Basic
Public ReadOnly Property IsEditing As Boolean
    Get
Visual C++
public:
property bool IsEditing {
    bool get ();
}

See Also

vTreeView Class


IsUpdating Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..IsUpdating Property
vTreeView Class See Also Send Feedback
Gets a value indicating whether this instance is updating.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsUpdating { get; }
Visual Basic
Public ReadOnly Property IsUpdating As Boolean
    Get
Visual C++
public:
property bool IsUpdating {
    bool get ();
}

Field Value

true if this instance is updating; otherwise, false.

See Also

vTreeView Class


ItemHeight Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..ItemHeight Property
vTreeView Class See Also Send Feedback
Gets the height of the tree nodes

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ItemHeight { get; set; }
Visual Basic
Public Property ItemHeight As Integer
    Get
    Set
Visual C++
public:
property int ItemHeight {
    int get ();
    void set (int value);
}

See Also

vTreeView Class


LabelEdit Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..LabelEdit Property
vTreeView Class See Also Send Feedback
Gets or sets a value indicating whether the label text of the tree nodes can be edited.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool LabelEdit { get; set; }
Visual Basic
Public Property LabelEdit As Boolean
    Get
    Set
Visual C++
public:
property bool LabelEdit {
    bool get ();
    void set (bool value);
}

See Also

vTreeView Class


LastVisibleNode Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..LastVisibleNode Property
vTreeView Class See Also Send Feedback
Gets the last visible node.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode LastVisibleNode { get; }
Visual Basic
Public ReadOnly Property LastVisibleNode As vTreeNode
    Get
Visual C++
public:
property vTreeNode^ LastVisibleNode {
    vTreeNode^ get ();
}

See Also

vTreeView Class


LineColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..LineColor Property
vTreeView Class See Also Send Feedback
Gets or sets the color of tree lines.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color LineColor { get; set; }
Visual Basic
Public Property LineColor As Color
    Get
    Set
Visual C++
public:
property Color LineColor {
    Color get ();
    void set (Color value);
}

See Also

vTreeView Class


Nodes Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..Nodes Property
vTreeView Class See Also Send Feedback
Gets the collection of the tree view nodes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNodeCollection Nodes { get; }
Visual Basic
Public ReadOnly Property Nodes As vTreeNodeCollection
    Get
Visual C++
public:
property vTreeNodeCollection^ Nodes {
    vTreeNodeCollection^ get ();
}

See Also

vTreeView Class


NodesSpacing Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..NodesSpacing Property
vTreeView Class See Also Send Feedback
Gets or sets the spacing between the tree nodes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int NodesSpacing { get; set; }
Visual Basic
Public Property NodesSpacing As Integer
    Get
    Set
Visual C++
public:
property int NodesSpacing {
    int get ();
    void set (int value);
}

See Also

vTreeView Class


PaintNodesDefaultBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..PaintNodesDefaultBorder Property
vTreeView Class See Also Send Feedback
Gets or sets a value indicating whether to paint a border

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintNodesDefaultBorder { get; set; }
Visual Basic
Public Property PaintNodesDefaultBorder As Boolean
    Get
    Set
Visual C++
public:
property bool PaintNodesDefaultBorder {
    bool get ();
    void set (bool value);
}

Field Value

true if [paint border]; otherwise, false.

See Also

vTreeView Class


PaintNodesDefaultFill Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..PaintNodesDefaultFill Property
vTreeView Class See Also Send Feedback
Gets or sets a value indicating whether to paint a background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintNodesDefaultFill { get; set; }
Visual Basic
Public Property PaintNodesDefaultFill As Boolean
    Get
    Set
Visual C++
public:
property bool PaintNodesDefaultFill {
    bool get ();
    void set (bool value);
}

Field Value

true if [paint fill]; otherwise, false.

See Also

vTreeView Class


ScrollPosition Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..ScrollPosition Property
vTreeView Class See Also Send Feedback
Gets the current scroll position of the vTreeView control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Point ScrollPosition { get; set; }
Visual Basic
Public Property ScrollPosition As Point
    Get
    Set
Visual C++
public:
property Point ScrollPosition {
    Point get ();
    void set (Point value);
}

See Also

vTreeView Class


SelectedNode Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..SelectedNode Property
vTreeView Class See Also Send Feedback
Gets the first selected node in the vTreeView.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode SelectedNode { get; set; }
Visual Basic
Public Property SelectedNode As vTreeNode
    Get
    Set
Visual C++
public:
property vTreeNode^ SelectedNode {
    vTreeNode^ get ();
    void set (vTreeNode^ value);
}

See Also

vTreeView Class


SelectedNodes Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..SelectedNodes Property
vTreeView Class See Also Send Feedback
Gets the currently selected nodes

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode[] SelectedNodes { get; }
Visual Basic
Public ReadOnly Property SelectedNodes As vTreeNode()
    Get
Visual C++
public:
property array<vTreeNode^>^ SelectedNodes {
    array<vTreeNode^>^ get ();
}

See Also

vTreeView Class


ShowFocusRectangle Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..ShowFocusRectangle Property
vTreeView Class See Also Send Feedback
Determines whether to show the focus rectangle when the tab is Focused

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowFocusRectangle { get; set; }
Visual Basic
Public Property ShowFocusRectangle As Boolean
    Get
    Set
Visual C++
public:
property bool ShowFocusRectangle {
    bool get ();
    void set (bool value);
}

See Also

vTreeView Class


ShowRootLines Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..ShowRootLines Property
vTreeView Class See Also Send Feedback
Gets or sets whether to show root lines.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowRootLines { get; set; }
Visual Basic
Public Property ShowRootLines As Boolean
    Get
    Set
Visual C++
public:
property bool ShowRootLines {
    bool get ();
    void set (bool value);
}

See Also

vTreeView Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..Theme Property
vTreeView Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vTreeView Class


ToolTipDuration Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..ToolTipDuration Property
vTreeView Class See Also Send Feedback
Gets or sets the duration of the tool tip.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ToolTipDuration { get; set; }
Visual Basic
Public Property ToolTipDuration As Integer
    Get
    Set
Visual C++
public:
property int ToolTipDuration {
    int get ();
    void set (int value);
}

Field Value

The duration of the tool tip.

See Also

vTreeView Class


ToolTipShowDelay Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..ToolTipShowDelay Property
vTreeView Class See Also Send Feedback
Gets or sets the tool tip show delay.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ToolTipShowDelay { get; set; }
Visual Basic
Public Property ToolTipShowDelay As Integer
    Get
    Set
Visual C++
public:
property int ToolTipShowDelay {
    int get ();
    void set (int value);
}

Field Value

The tool tip show delay.

See Also

vTreeView Class


TreeIndent Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..TreeIndent Property
vTreeView Class See Also Send Feedback
Gets or sets the indent of the tree nodes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int TreeIndent { get; set; }
Visual Basic
Public Property TreeIndent As Integer
    Get
    Set
Visual C++
public:
property int TreeIndent {
    int get ();
    void set (int value);
}

See Also

vTreeView Class


TriStateMode Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..TriStateMode Property
vTreeView Class See Also Send Feedback
Gets or sets whether the tree view should display checkboxes next to the nodes and have the tri state mode enabled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool TriStateMode { get; set; }
Visual Basic
Public Property TriStateMode As Boolean
    Get
    Set
Visual C++
public:
property bool TriStateMode {
    bool get ();
    void set (bool value);
}

See Also

vTreeView Class


UseThemeBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..UseThemeBackColor Property
vTreeView Class See Also Send Feedback
Gets or sets a value indicating whether to use the Theme BackColor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBackColor { get; set; }
Visual Basic
Public Property UseThemeBackColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBackColor {
    bool get ();
    void set (bool value);
}

See Also

vTreeView Class


UseThemeBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..UseThemeBorderColor Property
vTreeView Class See Also Send Feedback
Gets or sets a value indicating whether to use the Theme border color

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeBorderColor { get; set; }
Visual Basic
Public Property UseThemeBorderColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeBorderColor {
    bool get ();
    void set (bool value);
}

See Also

vTreeView Class


UseThemeIndicatorsColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..UseThemeIndicatorsColor Property
vTreeView Class See Also Send Feedback
Gets or sets a value indicating whether to use the default indicators color.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool UseThemeIndicatorsColor { get; set; }
Visual Basic
Public Property UseThemeIndicatorsColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseThemeIndicatorsColor {
    bool get ();
    void set (bool value);
}

See Also

vTreeView Class


VIBlendScrollBarsTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..VIBlendScrollBarsTheme Property
vTreeView Class See Also Send Feedback
Gets or sets the theme of the treeview scrollbars using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendScrollBarsTheme { get; set; }
Visual Basic
Public Property VIBlendScrollBarsTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendScrollBarsTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vTreeView Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..VIBlendTheme Property
vTreeView Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vTreeView Class


vTreeView Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeView Events
vTreeView Class See Also Send Feedback

The vTreeView type exposes the following members.

Events

 | Name | Description
Public event | AfterCollapse | Occurs after the tree node is collapsed.
Public event | AfterDragEnd | Occurs after a drag and drop ends
Public event | AfterDragStart | Occurs after a drag and drop starts
Public event | AfterExpand | Occurs after the tree node is expanded.
Public event | AfterLabelEdit | Occurs after a node label is edited.
Public event | AfterSelect | Occurs after a node is selected
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BeforeCollapse | Occurs before a node collapses
Public event | BeforeDragEnd | Occurs before a drag and drop ends
Public event | BeforeDragStart | Occurs before a drag and drop starts
Public event | BeforeExpand | Occurs before a node expands.
Public event | BeforeLabelEdit | Occurs before a node label edit.
Public event | BeforeSelect | Occurs before a node is selected
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawTreeNode | Occurs when a node is rendered.
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | NodeChecked | Occurs after the tree node is checked
Public event | NodeMouseDown | Occurs when the user clicks the mouse button over a node
Public event | NodeMouseUp | Occurs when the user clicks the mouse button over a node
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | TooltipShow | Occurs when tooltip shows.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vTreeView Class


AfterCollapse Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..AfterCollapse Event
vTreeView Class See Also Send Feedback
Occurs after the tree node is collapsed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTreeViewEventHandler AfterCollapse
Visual Basic
Public Event AfterCollapse As vTreeViewEventHandler
Visual C++
public:
 event vTreeViewEventHandler^ AfterCollapse {
    void add (vTreeViewEventHandler^ value);
    void remove (vTreeViewEventHandler^ value);
}

See Also

vTreeView Class


AfterDragEnd Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..AfterDragEnd Event
vTreeView Class See Also Send Feedback
Occurs after a drag and drop ends

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTreeViewDragEventHandler AfterDragEnd
Visual Basic
Public Event AfterDragEnd As vTreeViewDragEventHandler
Visual C++
public:
 event vTreeViewDragEventHandler^ AfterDragEnd {
    void add (vTreeViewDragEventHandler^ value);
    void remove (vTreeViewDragEventHandler^ value);
}

See Also

vTreeView Class


AfterDragStart Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..AfterDragStart Event
vTreeView Class See Also Send Feedback
Occurs after a drag and drop starts

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTreeViewDragEventHandler AfterDragStart
Visual Basic
Public Event AfterDragStart As vTreeViewDragEventHandler
Visual C++
public:
 event vTreeViewDragEventHandler^ AfterDragStart {
    void add (vTreeViewDragEventHandler^ value);
    void remove (vTreeViewDragEventHandler^ value);
}

See Also

vTreeView Class


AfterExpand Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..AfterExpand Event
vTreeView Class See Also Send Feedback
Occurs after the tree node is expanded.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTreeViewEventHandler AfterExpand
Visual Basic
Public Event AfterExpand As vTreeViewEventHandler
Visual C++
public:
 event vTreeViewEventHandler^ AfterExpand {
    void add (vTreeViewEventHandler^ value);
    void remove (vTreeViewEventHandler^ value);
}

See Also

vTreeView Class


AfterLabelEdit Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..AfterLabelEdit Event
vTreeView Class See Also Send Feedback
Occurs after a node label is edited.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTreeViewLabelEditEventHandler AfterLabelEdit
Visual Basic
Public Event AfterLabelEdit As vTreeViewLabelEditEventHandler
Visual C++
public:
 event vTreeViewLabelEditEventHandler^ AfterLabelEdit {
    void add (vTreeViewLabelEditEventHandler^ value);
    void remove (vTreeViewLabelEditEventHandler^ value);
}

See Also

vTreeView Class


AfterSelect Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..AfterSelect Event
vTreeView Class See Also Send Feedback
Occurs after a node is selected

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTreeViewEventHandler AfterSelect
Visual Basic
Public Event AfterSelect As vTreeViewEventHandler
Visual C++
public:
 event vTreeViewEventHandler^ AfterSelect {
    void add (vTreeViewEventHandler^ value);
    void remove (vTreeViewEventHandler^ value);
}

See Also

vTreeView Class


BeforeCollapse Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..BeforeCollapse Event
vTreeView Class See Also Send Feedback
Occurs before a node collapses

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTreeViewCancelEventHandler BeforeCollapse
Visual Basic
Public Event BeforeCollapse As vTreeViewCancelEventHandler
Visual C++
public:
 event vTreeViewCancelEventHandler^ BeforeCollapse {
    void add (vTreeViewCancelEventHandler^ value);
    void remove (vTreeViewCancelEventHandler^ value);
}

See Also

vTreeView Class


BeforeDragEnd Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..BeforeDragEnd Event
vTreeView Class See Also Send Feedback
Occurs before a drag and drop ends

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTreeViewDragCancelEventHandler BeforeDragEnd
Visual Basic
Public Event BeforeDragEnd As vTreeViewDragCancelEventHandler
Visual C++
public:
 event vTreeViewDragCancelEventHandler^ BeforeDragEnd {
    void add (vTreeViewDragCancelEventHandler^ value);
    void remove (vTreeViewDragCancelEventHandler^ value);
}

See Also

vTreeView Class


BeforeDragStart Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..BeforeDragStart Event
vTreeView Class See Also Send Feedback
Occurs before a drag and drop starts

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTreeViewDragCancelEventHandler BeforeDragStart
Visual Basic
Public Event BeforeDragStart As vTreeViewDragCancelEventHandler
Visual C++
public:
 event vTreeViewDragCancelEventHandler^ BeforeDragStart {
    void add (vTreeViewDragCancelEventHandler^ value);
    void remove (vTreeViewDragCancelEventHandler^ value);
}

See Also

vTreeView Class


BeforeExpand Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..BeforeExpand Event
vTreeView Class See Also Send Feedback
Occurs before a node expands.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTreeViewCancelEventHandler BeforeExpand
Visual Basic
Public Event BeforeExpand As vTreeViewCancelEventHandler
Visual C++
public:
 event vTreeViewCancelEventHandler^ BeforeExpand {
    void add (vTreeViewCancelEventHandler^ value);
    void remove (vTreeViewCancelEventHandler^ value);
}

See Also

vTreeView Class


BeforeLabelEdit Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..BeforeLabelEdit Event
vTreeView Class See Also Send Feedback
Occurs before a node label edit.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTreeViewLabelEditEventHandler BeforeLabelEdit
Visual Basic
Public Event BeforeLabelEdit As vTreeViewLabelEditEventHandler
Visual C++
public:
 event vTreeViewLabelEditEventHandler^ BeforeLabelEdit {
    void add (vTreeViewLabelEditEventHandler^ value);
    void remove (vTreeViewLabelEditEventHandler^ value);
}

See Also

vTreeView Class


BeforeSelect Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..BeforeSelect Event
vTreeView Class See Also Send Feedback
Occurs before a node is selected

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTreeViewCancelEventHandler BeforeSelect
Visual Basic
Public Event BeforeSelect As vTreeViewCancelEventHandler
Visual C++
public:
 event vTreeViewCancelEventHandler^ BeforeSelect {
    void add (vTreeViewCancelEventHandler^ value);
    void remove (vTreeViewCancelEventHandler^ value);
}

See Also

vTreeView Class


DrawTreeNode Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..DrawTreeNode Event
vTreeView Class See Also Send Feedback
Occurs when a node is rendered.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<DrawNodeEventArgs> DrawTreeNode
Visual Basic
Public Event DrawTreeNode As EventHandler(Of DrawNodeEventArgs)
Visual C++
public:
 event EventHandler<DrawNodeEventArgs^>^ DrawTreeNode {
    void add (EventHandler<DrawNodeEventArgs^>^ value);
    void remove (EventHandler<DrawNodeEventArgs^>^ value);
}

See Also

vTreeView Class


NodeChecked Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..NodeChecked Event
vTreeView Class See Also Send Feedback
Occurs after the tree node is checked

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTreeViewEventHandler NodeChecked
Visual Basic
Public Event NodeChecked As vTreeViewEventHandler
Visual C++
public:
 event vTreeViewEventHandler^ NodeChecked {
    void add (vTreeViewEventHandler^ value);
    void remove (vTreeViewEventHandler^ value);
}

See Also

vTreeView Class


NodeMouseDown Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..NodeMouseDown Event
vTreeView Class See Also Send Feedback
Occurs when the user clicks the mouse button over a node

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTreeViewMouseEventHandler NodeMouseDown
Visual Basic
Public Event NodeMouseDown As vTreeViewMouseEventHandler
Visual C++
public:
 event vTreeViewMouseEventHandler^ NodeMouseDown {
    void add (vTreeViewMouseEventHandler^ value);
    void remove (vTreeViewMouseEventHandler^ value);
}

See Also

vTreeView Class


NodeMouseUp Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..NodeMouseUp Event
vTreeView Class See Also Send Feedback
Occurs when the user clicks the mouse button over a node

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vTreeViewMouseEventHandler NodeMouseUp
Visual Basic
Public Event NodeMouseUp As vTreeViewMouseEventHandler
Visual C++
public:
 event vTreeViewMouseEventHandler^ NodeMouseUp {
    void add (vTreeViewMouseEventHandler^ value);
    void remove (vTreeViewMouseEventHandler^ value);
}

See Also

vTreeView Class


TooltipShow Event

[image]

VIBlend Controls for WinForms Help Documentation
vTreeView..::..TooltipShow Event
vTreeView Class See Also Send Feedback
Occurs when tooltip shows.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event ToolTipShownHandler TooltipShow
Visual Basic
Public Event TooltipShow As ToolTipShownHandler
Visual C++
public:
 event ToolTipShownHandler^ TooltipShow {
    void add (ToolTipShownHandler^ value);
    void remove (ToolTipShownHandler^ value);
}

See Also

vTreeView Class


vTreeViewAction Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewAction Enumeration
See Also Send Feedback
Enumerates the vTreeView actions

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum vTreeViewAction
Visual Basic
Public Enumeration vTreeViewAction
Visual C++
public enum class vTreeViewAction

Members

Member name | Description
Unknown |
Expand |
Collapse |

See Also


vTreeViewBox Class

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox Class
Members See Also Send Feedback
Represents a vTreeViewBox control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vTreeViewBox : vControlBox
Visual Basic
Public Class vTreeViewBox _
    Inherits vControlBox
Visual C++
public ref class vTreeViewBox : public vControlBox

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vControlBox
VIBlend.WinForms.Controls..::..vTreeViewBox

See Also

vTreeViewBox Members


vTreeViewBox Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox Members
vTreeViewBox Class Constructors Methods Properties Events See Also Send Feedback

The vTreeViewBox type exposes the following members.

Constructors

 | Name | Description
Public method | vTreeViewBox | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down. (Inherited from vControlBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vControlBox.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrow | Draws the arrow. (Inherited from vControlBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the [E:Paint] event. (Overrides vControlBox..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when property is changed. (Inherited from vControlBox.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown | (Inherited from vControlBox.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from vControlBox.)
Public property | BackColorDropDown | Gets or sets the background color for the dropdown control. (Inherited from vControlBox.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color which is used when the UseThemeBorderColor property is false. (Inherited from vControlBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentControl | Gets or sets the content control which is displayed when the dropdown is opened (Inherited from vControlBox.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets a reference to the DropDown of the ControlBox (Inherited from vControlBox.)
Public property | DropDownArrowBackgroundEnabled | Determines whether to the drop-down arrow's background is painted (Inherited from vControlBox.)
Public property | DropDownArrowColor | Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false. (Inherited from vControlBox.)
Public property | DropDownButtonBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownButtonDisabledBackgroundBrush | Gets or sets the disabled background brush. (Inherited from vControlBox.)
Public property | DropDownButtonHighlightBackgroundBrush | Gets or sets the HighlightBackground brush. (Inherited from vControlBox.)
Public property | DropDownButtonPressedBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMaximumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMinimumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownResizeDirection | Gets or sets a value indicating the possible drop-down resize directions (Inherited from vControlBox.)
Public property | DropDownWidth | Gets or sets the width in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | EditBase | Gets a reference to the EditBox of the vControlBox control (Inherited from vControlBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font that is used to display the text in the editbox of the control (Inherited from vControlBox.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color which is used to display the text (Inherited from vControlBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowGrip | Gets or sets a value indicating whether grip is shown (Inherited from vControlBox.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text displayed in the editbox of the control (Inherited from vControlBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vControlBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TreeView | Gets a reference to the underlying vTreeView control
Public property | UseDropDownButtonThemeBackground | Gets or sets a value indicating whether to use theme's background (Inherited from vControlBox.)
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeBorderColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeDropDownArrowColor | Gets or sets whether to use the Theme default arrow color. (Inherited from vControlBox.)
Public property | UseThemeFont | Gets or sets whether to use the Theme Font or the control's Font property. (Inherited from vControlBox.)
Public property | UseThemeForeColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vControlBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from vControlBox.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vTreeViewBox Class


vTreeViewBox Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox Constructor
vTreeViewBox Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeViewBox()
Visual Basic
Public Sub New
Visual C++
public:
vTreeViewBox()

See Also

vTreeViewBox Class


vTreeViewBox Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox Methods
vTreeViewBox Class See Also Send Feedback

The vTreeViewBox type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down. (Inherited from vControlBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vControlBox.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrow | Draws the arrow. (Inherited from vControlBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the [E:Paint] event. (Overrides vControlBox..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when property is changed. (Inherited from vControlBox.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown | (Inherited from vControlBox.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vTreeViewBox Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox..::..AccessibilityNotifyClients Method
vTreeViewBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vTreeViewBox Class
vTreeViewBox Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox..::..BeginInvoke Method
vTreeViewBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vTreeViewBox Class
vTreeViewBox Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox..::..Dispose Method
vTreeViewBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vControlBox.)

See Also

vTreeViewBox Class
vTreeViewBox Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox..::..GetChildAtPoint Method
vTreeViewBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vTreeViewBox Class
vTreeViewBox Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox..::..Invalidate Method
vTreeViewBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vTreeViewBox Class
vTreeViewBox Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox..::..Invoke Method
vTreeViewBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vTreeViewBox Class
vTreeViewBox Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox..::..MemberwiseClone Method
vTreeViewBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vTreeViewBox Class
vTreeViewBox Members


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox..::..OnPaint Method
vTreeViewBox Class See Also Send Feedback
Raises the [E:Paint] event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs p
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    p As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ p
) override

Parameters

p
Type: System.Windows.Forms..::..PaintEventArgs
The PaintEventArgs instance containing the event data.

See Also

vTreeViewBox Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox..::..PerformLayout Method
vTreeViewBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vTreeViewBox Class
vTreeViewBox Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox..::..ResumeLayout Method
vTreeViewBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vTreeViewBox Class
vTreeViewBox Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox..::..RtlTranslateAlignment Method
vTreeViewBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vTreeViewBox Class
vTreeViewBox Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox..::..Scale Method
vTreeViewBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vTreeViewBox Class
vTreeViewBox Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox..::..Select Method
vTreeViewBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vTreeViewBox Class
vTreeViewBox Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox..::..SetBounds Method
vTreeViewBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vTreeViewBox Class
vTreeViewBox Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox..::..UpdateBounds Method
vTreeViewBox Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vTreeViewBox Class
vTreeViewBox Members


vTreeViewBox Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox Properties
vTreeViewBox Class See Also Send Feedback

The vTreeViewBox type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from vControlBox.)
Public property | BackColorDropDown | Gets or sets the background color for the dropdown control. (Inherited from vControlBox.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color which is used when the UseThemeBorderColor property is false. (Inherited from vControlBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentControl | Gets or sets the content control which is displayed when the dropdown is opened (Inherited from vControlBox.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets a reference to the DropDown of the ControlBox (Inherited from vControlBox.)
Public property | DropDownArrowBackgroundEnabled | Determines whether to the drop-down arrow's background is painted (Inherited from vControlBox.)
Public property | DropDownArrowColor | Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false. (Inherited from vControlBox.)
Public property | DropDownButtonBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownButtonDisabledBackgroundBrush | Gets or sets the disabled background brush. (Inherited from vControlBox.)
Public property | DropDownButtonHighlightBackgroundBrush | Gets or sets the HighlightBackground brush. (Inherited from vControlBox.)
Public property | DropDownButtonPressedBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMaximumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMinimumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownResizeDirection | Gets or sets a value indicating the possible drop-down resize directions (Inherited from vControlBox.)
Public property | DropDownWidth | Gets or sets the width in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | EditBase | Gets a reference to the EditBox of the vControlBox control (Inherited from vControlBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font that is used to display the text in the editbox of the control (Inherited from vControlBox.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color which is used to display the text (Inherited from vControlBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowGrip | Gets or sets a value indicating whether grip is shown (Inherited from vControlBox.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text displayed in the editbox of the control (Inherited from vControlBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vControlBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TreeView | Gets a reference to the underlying vTreeView control
Public property | UseDropDownButtonThemeBackground | Gets or sets a value indicating whether to use theme's background (Inherited from vControlBox.)
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeBorderColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeDropDownArrowColor | Gets or sets whether to use the Theme default arrow color. (Inherited from vControlBox.)
Public property | UseThemeFont | Gets or sets whether to use the Theme Font or the control's Font property. (Inherited from vControlBox.)
Public property | UseThemeForeColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vControlBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vTreeViewBox Class


TreeView Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox..::..TreeView Property
vTreeViewBox Class See Also Send Feedback
Gets a reference to the underlying vTreeView control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeView TreeView { get; }
Visual Basic
Public ReadOnly Property TreeView As vTreeView
    Get
Visual C++
public:
property vTreeView^ TreeView {
    vTreeView^ get ();
}

See Also

vTreeViewBox Class


vTreeViewBox Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewBox Events
vTreeViewBox Class See Also Send Feedback

The vTreeViewBox type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from vControlBox.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vTreeViewBox Class


vTreeViewCancelEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewCancelEventArgs Class
Members See Also Send Feedback
Represents a vTreeView cancel event arguments

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vTreeViewCancelEventArgs : CancelEventArgs
Visual Basic
Public Class vTreeViewCancelEventArgs _
    Inherits CancelEventArgs
Visual C++
public ref class vTreeViewCancelEventArgs : public CancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
VIBlend.WinForms.Controls..::..vTreeViewCancelEventArgs

See Also

vTreeViewCancelEventArgs Members


vTreeViewCancelEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewCancelEventArgs Members
vTreeViewCancelEventArgs Class Constructors Methods Properties See Also Send Feedback

The vTreeViewCancelEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | vTreeViewCancelEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action | Event's TreeViewAction
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Node | Event's vTreeNode.

See Also

vTreeViewCancelEventArgs Class


vTreeViewCancelEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewCancelEventArgs Constructor
vTreeViewCancelEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeViewCancelEventArgs(
    vTreeNode node,
    bool cancel,
    vTreeViewAction action
)
Visual Basic
Public Sub New ( _
    node As vTreeNode, _
    cancel As Boolean, _
    action As vTreeViewAction _
)
Visual C++
public:
vTreeViewCancelEventArgs(
    vTreeNode^ node,
    bool cancel,
    vTreeViewAction action
)

Parameters

node
Type: VIBlend.WinForms.Controls..::..vTreeNode
vTreeView node.
cancel
Type: System..::..Boolean
Event's cancel state.
action
Type: VIBlend.WinForms.Controls..::..vTreeViewAction
TreeViewAction for the event.

See Also

vTreeViewCancelEventArgs Class


vTreeViewCancelEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewCancelEventArgs Methods
vTreeViewCancelEventArgs Class See Also Send Feedback

The vTreeViewCancelEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vTreeViewCancelEventArgs Class


vTreeViewCancelEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewCancelEventArgs Properties
vTreeViewCancelEventArgs Class See Also Send Feedback

The vTreeViewCancelEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Action | Event's TreeViewAction
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Node | Event's vTreeNode.

See Also

vTreeViewCancelEventArgs Class


Action Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewCancelEventArgs..::..Action Property
vTreeViewCancelEventArgs Class See Also Send Feedback
Event's TreeViewAction

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeViewAction Action { get; }
Visual Basic
Public ReadOnly Property Action As vTreeViewAction
    Get
Visual C++
public:
property vTreeViewAction Action {
    vTreeViewAction get ();
}

See Also

vTreeViewCancelEventArgs Class


Node Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewCancelEventArgs..::..Node Property
vTreeViewCancelEventArgs Class See Also Send Feedback
Event's vTreeNode.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode Node { get; }
Visual Basic
Public ReadOnly Property Node As vTreeNode
    Get
Visual C++
public:
property vTreeNode^ Node {
    vTreeNode^ get ();
}

See Also

vTreeViewCancelEventArgs Class


vTreeViewCancelEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewCancelEventHandler Delegate
See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void vTreeViewCancelEventHandler(
    Object sender,
    vTreeViewCancelEventArgs e
)
Visual Basic
Public Delegate Sub vTreeViewCancelEventHandler ( _
    sender As Object, _
    e As vTreeViewCancelEventArgs _
)
Visual C++
public delegate void vTreeViewCancelEventHandler(
    Object^ sender,
    vTreeViewCancelEventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: VIBlend.WinForms.Controls..::..vTreeViewCancelEventArgs

See Also


vTreeViewDragCancelEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewDragCancelEventArgs Class
Members See Also Send Feedback
Represents vTreeView drag and drop cancel event arguments

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vTreeViewDragCancelEventArgs : vTreeViewDragEventArgs
Visual Basic
Public Class vTreeViewDragCancelEventArgs _
    Inherits vTreeViewDragEventArgs
Visual C++
public ref class vTreeViewDragCancelEventArgs : public vTreeViewDragEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..vTreeViewDragEventArgs
VIBlend.WinForms.Controls..::..vTreeViewDragCancelEventArgs

See Also

vTreeViewDragCancelEventArgs Members


vTreeViewDragCancelEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewDragCancelEventArgs Members
vTreeViewDragCancelEventArgs Class Constructors Methods Properties See Also Send Feedback

The vTreeViewDragCancelEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | vTreeViewDragCancelEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Determines whether the event is canceled.
Public property | DragNode | The drag vTreeNode. (Inherited from vTreeViewDragEventArgs.)
Public property | TargetNode | The target vTreeNode. (Inherited from vTreeViewDragEventArgs.)

See Also

vTreeViewDragCancelEventArgs Class


vTreeViewDragCancelEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewDragCancelEventArgs Constructor
vTreeViewDragCancelEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeViewDragCancelEventArgs(
    vTreeNode dragNode,
    vTreeNode targetNode
)
Visual Basic
Public Sub New ( _
    dragNode As vTreeNode, _
    targetNode As vTreeNode _
)
Visual C++
public:
vTreeViewDragCancelEventArgs(
    vTreeNode^ dragNode,
    vTreeNode^ targetNode
)

Parameters

dragNode
Type: VIBlend.WinForms.Controls..::..vTreeNode
The drag vTreeNode.
targetNode
Type: VIBlend.WinForms.Controls..::..vTreeNode
The target vTreeNode.

See Also

vTreeViewDragCancelEventArgs Class


vTreeViewDragCancelEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewDragCancelEventArgs Methods
vTreeViewDragCancelEventArgs Class See Also Send Feedback

The vTreeViewDragCancelEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vTreeViewDragCancelEventArgs Class


vTreeViewDragCancelEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewDragCancelEventArgs Properties
vTreeViewDragCancelEventArgs Class See Also Send Feedback

The vTreeViewDragCancelEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Determines whether the event is canceled.
Public property | DragNode | The drag vTreeNode. (Inherited from vTreeViewDragEventArgs.)
Public property | TargetNode | The target vTreeNode. (Inherited from vTreeViewDragEventArgs.)

See Also

vTreeViewDragCancelEventArgs Class


Cancel Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewDragCancelEventArgs..::..Cancel Property
vTreeViewDragCancelEventArgs Class See Also Send Feedback
Determines whether the event is canceled.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic
Public Property Cancel As Boolean
    Get
    Set
Visual C++
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}

See Also

vTreeViewDragCancelEventArgs Class


vTreeViewDragCancelEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewDragCancelEventHandler Delegate
See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void vTreeViewDragCancelEventHandler(
    Object sender,
    vTreeViewDragCancelEventArgs e
)
Visual Basic
Public Delegate Sub vTreeViewDragCancelEventHandler ( _
    sender As Object, _
    e As vTreeViewDragCancelEventArgs _
)
Visual C++
public delegate void vTreeViewDragCancelEventHandler(
    Object^ sender,
    vTreeViewDragCancelEventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: VIBlend.WinForms.Controls..::..vTreeViewDragCancelEventArgs

See Also


vTreeViewDragEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewDragEventArgs Class
Members See Also Send Feedback
Represents vTreeView drag and drop event arguments

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vTreeViewDragEventArgs : EventArgs
Visual Basic
Public Class vTreeViewDragEventArgs _
    Inherits EventArgs
Visual C++
public ref class vTreeViewDragEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..vTreeViewDragEventArgs
VIBlend.WinForms.Controls..::..vTreeViewDragCancelEventArgs

See Also

vTreeViewDragEventArgs Members


vTreeViewDragEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewDragEventArgs Members
vTreeViewDragEventArgs Class Constructors Methods Properties See Also Send Feedback

The vTreeViewDragEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | vTreeViewDragEventArgs | Constructors

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DragNode | The drag vTreeNode.
Public property | TargetNode | The target vTreeNode.

See Also

vTreeViewDragEventArgs Class


vTreeViewDragEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewDragEventArgs Constructor
vTreeViewDragEventArgs Class See Also Send Feedback
Constructors

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeViewDragEventArgs(
    vTreeNode dragNode,
    vTreeNode targetNode
)
Visual Basic
Public Sub New ( _
    dragNode As vTreeNode, _
    targetNode As vTreeNode _
)
Visual C++
public:
vTreeViewDragEventArgs(
    vTreeNode^ dragNode,
    vTreeNode^ targetNode
)

Parameters

dragNode
Type: VIBlend.WinForms.Controls..::..vTreeNode
The drag vTreeNode
targetNode
Type: VIBlend.WinForms.Controls..::..vTreeNode
The target vTreeNode

See Also

vTreeViewDragEventArgs Class


vTreeViewDragEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewDragEventArgs Methods
vTreeViewDragEventArgs Class See Also Send Feedback

The vTreeViewDragEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vTreeViewDragEventArgs Class


vTreeViewDragEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewDragEventArgs Properties
vTreeViewDragEventArgs Class See Also Send Feedback

The vTreeViewDragEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | DragNode | The drag vTreeNode.
Public property | TargetNode | The target vTreeNode.

See Also

vTreeViewDragEventArgs Class


DragNode Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewDragEventArgs..::..DragNode Property
vTreeViewDragEventArgs Class See Also Send Feedback
The drag vTreeNode.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode DragNode { get; }
Visual Basic
Public ReadOnly Property DragNode As vTreeNode
    Get
Visual C++
public:
property vTreeNode^ DragNode {
    vTreeNode^ get ();
}

See Also

vTreeViewDragEventArgs Class


TargetNode Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewDragEventArgs..::..TargetNode Property
vTreeViewDragEventArgs Class See Also Send Feedback
The target vTreeNode.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode TargetNode { get; }
Visual Basic
Public ReadOnly Property TargetNode As vTreeNode
    Get
Visual C++
public:
property vTreeNode^ TargetNode {
    vTreeNode^ get ();
}

See Also

vTreeViewDragEventArgs Class


vTreeViewDragEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewDragEventHandler Delegate
See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void vTreeViewDragEventHandler(
    Object sender,
    vTreeViewDragEventArgs e
)
Visual Basic
Public Delegate Sub vTreeViewDragEventHandler ( _
    sender As Object, _
    e As vTreeViewDragEventArgs _
)
Visual C++
public delegate void vTreeViewDragEventHandler(
    Object^ sender,
    vTreeViewDragEventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: VIBlend.WinForms.Controls..::..vTreeViewDragEventArgs

See Also


vTreeViewEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewEventArgs Class
Members See Also Send Feedback
Represents vTreeView event arguments

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vTreeViewEventArgs : EventArgs
Visual Basic
Public Class vTreeViewEventArgs _
    Inherits EventArgs
Visual C++
public ref class vTreeViewEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..vTreeViewEventArgs

See Also

vTreeViewEventArgs Members


vTreeViewEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewEventArgs Members
vTreeViewEventArgs Class Constructors Methods Properties See Also Send Feedback

The vTreeViewEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | vTreeViewEventArgs | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action | Gets the action associated with the event.
Public property | Node | Gets the tree node associated with the event.

See Also

vTreeViewEventArgs Class


vTreeViewEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewEventArgs Constructor
vTreeViewEventArgs Class See Also Send Feedback
Constructor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeViewEventArgs(
    vTreeNode node,
    vTreeViewAction action
)
Visual Basic
Public Sub New ( _
    node As vTreeNode, _
    action As vTreeViewAction _
)
Visual C++
public:
vTreeViewEventArgs(
    vTreeNode^ node,
    vTreeViewAction action
)

Parameters

node
Type: VIBlend.WinForms.Controls..::..vTreeNode
vTreeNode associated with the event.
action
Type: VIBlend.WinForms.Controls..::..vTreeViewAction
Action associated with the event.

See Also

vTreeViewEventArgs Class


vTreeViewEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewEventArgs Methods
vTreeViewEventArgs Class See Also Send Feedback

The vTreeViewEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vTreeViewEventArgs Class


vTreeViewEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewEventArgs Properties
vTreeViewEventArgs Class See Also Send Feedback

The vTreeViewEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the action associated with the event.
Public property | Node | Gets the tree node associated with the event.

See Also

vTreeViewEventArgs Class


Action Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewEventArgs..::..Action Property
vTreeViewEventArgs Class See Also Send Feedback
Gets the action associated with the event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeViewAction Action { get; }
Visual Basic
Public ReadOnly Property Action As vTreeViewAction
    Get
Visual C++
public:
property vTreeViewAction Action {
    vTreeViewAction get ();
}

See Also

vTreeViewEventArgs Class


Node Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewEventArgs..::..Node Property
vTreeViewEventArgs Class See Also Send Feedback
Gets the tree node associated with the event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode Node { get; }
Visual Basic
Public ReadOnly Property Node As vTreeNode
    Get
Visual C++
public:
property vTreeNode^ Node {
    vTreeNode^ get ();
}

See Also

vTreeViewEventArgs Class


vTreeViewEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewEventHandler Delegate
See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void vTreeViewEventHandler(
    Object sender,
    vTreeViewEventArgs e
)
Visual Basic
Public Delegate Sub vTreeViewEventHandler ( _
    sender As Object, _
    e As vTreeViewEventArgs _
)
Visual C++
public delegate void vTreeViewEventHandler(
    Object^ sender,
    vTreeViewEventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: VIBlend.WinForms.Controls..::..vTreeViewEventArgs

See Also


vTreeViewLabelEditEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewLabelEditEventHandler Delegate
See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void vTreeViewLabelEditEventHandler(
    Object sender,
    vTreeNodeLabelEditEventArgs e
)
Visual Basic
Public Delegate Sub vTreeViewLabelEditEventHandler ( _
    sender As Object, _
    e As vTreeNodeLabelEditEventArgs _
)
Visual C++
public delegate void vTreeViewLabelEditEventHandler(
    Object^ sender,
    vTreeNodeLabelEditEventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: VIBlend.WinForms.Controls..::..vTreeNodeLabelEditEventArgs

See Also


vTreeViewLayoutEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewLayoutEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vTreeViewLayoutEventArgs : EventArgs
Visual Basic
Public Class vTreeViewLayoutEventArgs _
    Inherits EventArgs
Visual C++
public ref class vTreeViewLayoutEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..vTreeViewLayoutEventArgs

See Also

vTreeViewLayoutEventArgs Members


vTreeViewLayoutEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewLayoutEventArgs Members
vTreeViewLayoutEventArgs Class Constructors Methods Properties See Also Send Feedback

The vTreeViewLayoutEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | vTreeViewLayoutEventArgs | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bounds | Gets the action associated with the event.
Public property | Node | Gets the tree node associated with the event.

See Also

vTreeViewLayoutEventArgs Class


vTreeViewLayoutEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewLayoutEventArgs Constructor
vTreeViewLayoutEventArgs Class See Also Send Feedback
Constructor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeViewLayoutEventArgs(
    vTreeNode node,
    Rectangle bounds
)
Visual Basic
Public Sub New ( _
    node As vTreeNode, _
    bounds As Rectangle _
)
Visual C++
public:
vTreeViewLayoutEventArgs(
    vTreeNode^ node,
    Rectangle bounds
)

Parameters

node
Type: VIBlend.WinForms.Controls..::..vTreeNode
vTreeNode associated with the event.
bounds
Type: System.Drawing..::..Rectangle

See Also

vTreeViewLayoutEventArgs Class


vTreeViewLayoutEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewLayoutEventArgs Methods
vTreeViewLayoutEventArgs Class See Also Send Feedback

The vTreeViewLayoutEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vTreeViewLayoutEventArgs Class


vTreeViewLayoutEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewLayoutEventArgs Properties
vTreeViewLayoutEventArgs Class See Also Send Feedback

The vTreeViewLayoutEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Bounds | Gets the action associated with the event.
Public property | Node | Gets the tree node associated with the event.

See Also

vTreeViewLayoutEventArgs Class


Bounds Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewLayoutEventArgs..::..Bounds Property
vTreeViewLayoutEventArgs Class See Also Send Feedback
Gets the action associated with the event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle Bounds { get; set; }
Visual Basic
Public Property Bounds As Rectangle
    Get
    Set
Visual C++
public:
property Rectangle Bounds {
    Rectangle get ();
    void set (Rectangle value);
}

See Also

vTreeViewLayoutEventArgs Class


Node Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewLayoutEventArgs..::..Node Property
vTreeViewLayoutEventArgs Class See Also Send Feedback
Gets the tree node associated with the event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode Node { get; }
Visual Basic
Public ReadOnly Property Node As vTreeNode
    Get
Visual C++
public:
property vTreeNode^ Node {
    vTreeNode^ get ();
}

See Also

vTreeViewLayoutEventArgs Class


vTreeViewMouseEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewMouseEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vTreeViewMouseEventArgs : EventArgs
Visual Basic
Public Class vTreeViewMouseEventArgs _
    Inherits EventArgs
Visual C++
public ref class vTreeViewMouseEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.Controls..::..vTreeViewMouseEventArgs

See Also

vTreeViewMouseEventArgs Members


vTreeViewMouseEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewMouseEventArgs Members
vTreeViewMouseEventArgs Class Constructors Methods Properties See Also Send Feedback

The vTreeViewMouseEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | vTreeViewMouseEventArgs | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action | Gets the action associated with the event.
Public property | MouseEventArgs | Gets the mouse event args.
Public property | Node | Gets the tree node associated with the event.

See Also

vTreeViewMouseEventArgs Class


vTreeViewMouseEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewMouseEventArgs Constructor
vTreeViewMouseEventArgs Class See Also Send Feedback
Constructor.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeViewMouseEventArgs(
    vTreeNode node,
    MouseEventArgs args,
    vTreeViewAction action
)
Visual Basic
Public Sub New ( _
    node As vTreeNode, _
    args As MouseEventArgs, _
    action As vTreeViewAction _
)
Visual C++
public:
vTreeViewMouseEventArgs(
    vTreeNode^ node,
    MouseEventArgs^ args,
    vTreeViewAction action
)

Parameters

node
Type: VIBlend.WinForms.Controls..::..vTreeNode
vTreeNode associated with the event.
args
Type: System.Windows.Forms..::..MouseEventArgs
action
Type: VIBlend.WinForms.Controls..::..vTreeViewAction
Action associated with the event.

See Also

vTreeViewMouseEventArgs Class


vTreeViewMouseEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewMouseEventArgs Methods
vTreeViewMouseEventArgs Class See Also Send Feedback

The vTreeViewMouseEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vTreeViewMouseEventArgs Class


vTreeViewMouseEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vTreeViewMouseEventArgs Properties
vTreeViewMouseEventArgs Class See Also Send Feedback

The vTreeViewMouseEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the action associated with the event.
Public property | MouseEventArgs | Gets the mouse event args.
Public property | Node | Gets the tree node associated with the event.

See Also

vTreeViewMouseEventArgs Class


Action Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewMouseEventArgs..::..Action Property
vTreeViewMouseEventArgs Class See Also Send Feedback
Gets the action associated with the event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeViewAction Action { get; }
Visual Basic
Public ReadOnly Property Action As vTreeViewAction
    Get
Visual C++
public:
property vTreeViewAction Action {
    vTreeViewAction get ();
}

See Also

vTreeViewMouseEventArgs Class


MouseEventArgs Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewMouseEventArgs..::..MouseEventArgs Property
vTreeViewMouseEventArgs Class See Also Send Feedback
Gets the mouse event args.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public MouseEventArgs MouseEventArgs { get; }
Visual Basic
Public ReadOnly Property MouseEventArgs As MouseEventArgs
    Get
Visual C++
public:
property MouseEventArgs^ MouseEventArgs {
    MouseEventArgs^ get ();
}

Field Value

The mouse event args.

See Also

vTreeViewMouseEventArgs Class


Node Property

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewMouseEventArgs..::..Node Property
vTreeViewMouseEventArgs Class See Also Send Feedback
Gets the tree node associated with the event.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vTreeNode Node { get; }
Visual Basic
Public ReadOnly Property Node As vTreeNode
    Get
Visual C++
public:
property vTreeNode^ Node {
    vTreeNode^ get ();
}

See Also

vTreeViewMouseEventArgs Class


vTreeViewMouseEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vTreeViewMouseEventHandler Delegate
See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void vTreeViewMouseEventHandler(
    Object sender,
    vTreeViewMouseEventArgs e
)
Visual Basic
Public Delegate Sub vTreeViewMouseEventHandler ( _
    sender As Object, _
    e As vTreeViewMouseEventArgs _
)
Visual C++
public delegate void vTreeViewMouseEventHandler(
    Object^ sender,
    vTreeViewMouseEventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: VIBlend.WinForms.Controls..::..vTreeViewMouseEventArgs

See Also


vVerticalLayoutPanel Class

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel Class
Members See Also Send Feedback
Represents a vVerticalLayoutPanel control where the user can arrange multiple controls.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vVerticalLayoutPanel : Panel,
    IScrollableControlBase
Visual Basic
Public Class vVerticalLayoutPanel _
    Inherits Panel _
    Implements IScrollableControlBase
Visual C++
public ref class vVerticalLayoutPanel : public Panel,
    IScrollableControlBase

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..Panel
VIBlend.WinForms.Controls..::..vVerticalLayoutPanel
VIBlend.WinForms.Controls..::..vExplorerBar

See Also

vVerticalLayoutPanel Members


vVerticalLayoutPanel Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel Members
vVerticalLayoutPanel Class Constructors Methods Properties Events See Also Send Feedback

The vVerticalLayoutPanel type exposes the following members.

Constructors

 | Name | Description
Public method | vVerticalLayoutPanel | vVerticalLayoutPanel constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides ScrollableControl..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Overrides Control..::..ProcessCmdKey(Message%, Keys).)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollDown |
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Protected method | ScrollUp |
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | (Overrides ScrollableControl..::..AutoScroll.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Overrides Panel..::..AutoSize.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border
Public property | PaintFill | Gets or sets a value indicating whether to paint a background
Public property | PanelBackColor | Gets or sets the BackColor of the Panel.
Public property | PanelBorderColor | Gets or sets the BorderColor of the Panel.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UsePanelBackColor | Gets or sets a value indicating whether to use the PanelBackColor
Public property | UsePanelBorderColor | Gets or sets a value indicating whether to use the PanelBorderColor
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vVerticalLayoutPanel Class


vVerticalLayoutPanel Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel Constructor
vVerticalLayoutPanel Class See Also Send Feedback
vVerticalLayoutPanel constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vVerticalLayoutPanel()
Visual Basic
Public Sub New
Visual C++
public:
vVerticalLayoutPanel()

See Also

vVerticalLayoutPanel Class


vVerticalLayoutPanel Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel Methods
vVerticalLayoutPanel Class See Also Send Feedback

The vVerticalLayoutPanel type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Overrides ScrollableControl..::..OnLayout(LayoutEventArgs).)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Overrides Control..::..ProcessCmdKey(Message%, Keys).)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollDown |
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Protected method | ScrollUp |
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)

See Also

vVerticalLayoutPanel Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..AccessibilityNotifyClients Method
vVerticalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vVerticalLayoutPanel Class
vVerticalLayoutPanel Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..BeginInvoke Method
vVerticalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vVerticalLayoutPanel Class
vVerticalLayoutPanel Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..Dispose Method
vVerticalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)

See Also

vVerticalLayoutPanel Class
vVerticalLayoutPanel Members


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..Dispose Method (Boolean)
vVerticalLayoutPanel Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vVerticalLayoutPanel Class
Dispose Overload


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..GetChildAtPoint Method
vVerticalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vVerticalLayoutPanel Class
vVerticalLayoutPanel Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..Invalidate Method
vVerticalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vVerticalLayoutPanel Class
vVerticalLayoutPanel Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..Invoke Method
vVerticalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vVerticalLayoutPanel Class
vVerticalLayoutPanel Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..MemberwiseClone Method
vVerticalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vVerticalLayoutPanel Class
vVerticalLayoutPanel Members


OnKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..OnKeyDown Method
vVerticalLayoutPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs

See Also

vVerticalLayoutPanel Class


OnLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..OnLayout Method
vVerticalLayoutPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)
Visual Basic
Protected Overrides Sub OnLayout ( _
    levent As LayoutEventArgs _
)
Visual C++
protected:
virtual void OnLayout(
    LayoutEventArgs^ levent
) override

Parameters

levent
Type: System.Windows.Forms..::..LayoutEventArgs

See Also

vVerticalLayoutPanel Class


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..OnPaint Method
vVerticalLayoutPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

vVerticalLayoutPanel Class


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..PerformLayout Method
vVerticalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vVerticalLayoutPanel Class
vVerticalLayoutPanel Members


ProcessCmdKey Method

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..ProcessCmdKey Method
vVerticalLayoutPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override bool ProcessCmdKey(
    ref Message msg,
    Keys keyData
)
Visual Basic
Protected Overrides Function ProcessCmdKey ( _
    ByRef msg As Message, _
    keyData As Keys _
) As Boolean
Visual C++
protected:
virtual bool ProcessCmdKey(
    Message% msg,
    Keys keyData
) override

Parameters

msg
Type: System.Windows.Forms..::..Message %
keyData
Type: System.Windows.Forms..::..Keys

See Also

vVerticalLayoutPanel Class


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..ResumeLayout Method
vVerticalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vVerticalLayoutPanel Class
vVerticalLayoutPanel Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..RtlTranslateAlignment Method
vVerticalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vVerticalLayoutPanel Class
vVerticalLayoutPanel Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..Scale Method
vVerticalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vVerticalLayoutPanel Class
vVerticalLayoutPanel Members


ScrollDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..ScrollDown Method
vVerticalLayoutPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void ScrollDown()
Visual Basic
Protected Overridable Sub ScrollDown
Visual C++
protected:
virtual void ScrollDown()

See Also

vVerticalLayoutPanel Class


ScrollUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..ScrollUp Method
vVerticalLayoutPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void ScrollUp()
Visual Basic
Protected Overridable Sub ScrollUp
Visual C++
protected:
virtual void ScrollUp()

See Also

vVerticalLayoutPanel Class


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..Select Method
vVerticalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vVerticalLayoutPanel Class
vVerticalLayoutPanel Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..SetBounds Method
vVerticalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vVerticalLayoutPanel Class
vVerticalLayoutPanel Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..UpdateBounds Method
vVerticalLayoutPanel Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vVerticalLayoutPanel Class
vVerticalLayoutPanel Members


vVerticalLayoutPanel Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel Properties
vVerticalLayoutPanel Class See Also Send Feedback

The vVerticalLayoutPanel type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Determines whether to use animations
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | (Overrides ScrollableControl..::..AutoScroll.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Overrides Panel..::..AutoSize.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PaintBorder | Gets or sets a value indicating whether to paint a border
Public property | PaintFill | Gets or sets a value indicating whether to paint a background
Public property | PanelBackColor | Gets or sets the BackColor of the Panel.
Public property | PanelBorderColor | Gets or sets the BorderColor of the Panel.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Theme | Gets or sets the theme of the control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UsePanelBackColor | Gets or sets a value indicating whether to use the PanelBackColor
Public property | UsePanelBorderColor | Gets or sets a value indicating whether to use the PanelBorderColor
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vVerticalLayoutPanel Class


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..AllowAnimations Property
vVerticalLayoutPanel Class See Also Send Feedback
Determines whether to use animations

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vVerticalLayoutPanel Class


AutoScroll Property

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..AutoScroll Property
vVerticalLayoutPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override bool AutoScroll { get; set; }
Visual Basic
Public Overrides Property AutoScroll As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AutoScroll {
    bool get () override;
    void set (bool value) override;
}

See Also

vVerticalLayoutPanel Class


AutoSize Property

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..AutoSize Property
vVerticalLayoutPanel Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override bool AutoSize { get; set; }
Visual Basic
Public Overrides Property AutoSize As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AutoSize {
    bool get () override;
    void set (bool value) override;
}

See Also

vVerticalLayoutPanel Class


PaintBorder Property

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..PaintBorder Property
vVerticalLayoutPanel Class See Also Send Feedback
Gets or sets a value indicating whether to paint a border

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintBorder { get; set; }
Visual Basic
Public Property PaintBorder As Boolean
    Get
    Set
Visual C++
public:
property bool PaintBorder {
    bool get ();
    void set (bool value);
}

Field Value

true if [paint border]; otherwise, false.

See Also

vVerticalLayoutPanel Class


PaintFill Property

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..PaintFill Property
vVerticalLayoutPanel Class See Also Send Feedback
Gets or sets a value indicating whether to paint a background

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PaintFill { get; set; }
Visual Basic
Public Property PaintFill As Boolean
    Get
    Set
Visual C++
public:
property bool PaintFill {
    bool get ();
    void set (bool value);
}

Field Value

true if [paint fill]; otherwise, false.

See Also

vVerticalLayoutPanel Class


PanelBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..PanelBackColor Property
vVerticalLayoutPanel Class See Also Send Feedback
Gets or sets the BackColor of the Panel.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Color PanelBackColor { get; set; }
Visual Basic
Public Overridable Property PanelBackColor As Color
    Get
    Set
Visual C++
public:
virtual property Color PanelBackColor {
    Color get ();
    void set (Color value);
}

See Also

vVerticalLayoutPanel Class


PanelBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..PanelBorderColor Property
vVerticalLayoutPanel Class See Also Send Feedback
Gets or sets the BorderColor of the Panel.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Color PanelBorderColor { get; set; }
Visual Basic
Public Overridable Property PanelBorderColor As Color
    Get
    Set
Visual C++
public:
virtual property Color PanelBorderColor {
    Color get ();
    void set (Color value);
}

See Also

vVerticalLayoutPanel Class


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..Theme Property
vVerticalLayoutPanel Class See Also Send Feedback
Gets or sets the theme of the control.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ControlTheme Theme { get; set; }
Visual Basic
Public Property Theme As ControlTheme
    Get
    Set
Visual C++
public:
property ControlTheme^ Theme {
    ControlTheme^ get ();
    void set (ControlTheme^ value);
}

See Also

vVerticalLayoutPanel Class


UsePanelBackColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..UsePanelBackColor Property
vVerticalLayoutPanel Class See Also Send Feedback
Gets or sets a value indicating whether to use the PanelBackColor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool UsePanelBackColor { get; set; }
Visual Basic
Public Overridable Property UsePanelBackColor As Boolean
    Get
    Set
Visual C++
public:
virtual property bool UsePanelBackColor {
    bool get ();
    void set (bool value);
}

See Also

vVerticalLayoutPanel Class


UsePanelBorderColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..UsePanelBorderColor Property
vVerticalLayoutPanel Class See Also Send Feedback
Gets or sets a value indicating whether to use the PanelBorderColor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool UsePanelBorderColor { get; set; }
Visual Basic
Public Overridable Property UsePanelBorderColor As Boolean
    Get
    Set
Visual C++
public:
virtual property bool UsePanelBorderColor {
    bool get ();
    void set (bool value);
}

See Also

vVerticalLayoutPanel Class


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel..::..VIBlendTheme Property
vVerticalLayoutPanel Class See Also Send Feedback
Gets or sets the theme of the control using one of the built-in themes.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vVerticalLayoutPanel Class


vVerticalLayoutPanel Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVerticalLayoutPanel Events
vVerticalLayoutPanel Class See Also Send Feedback

The vVerticalLayoutPanel type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vVerticalLayoutPanel Class


vVScrollBar Class

[image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar Class
Members See Also Send Feedback
Represents a vertical scroll bar control

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vVScrollBar : vScrollBar
Visual Basic
Public Class vVScrollBar _
    Inherits vScrollBar
Visual C++
public ref class vVScrollBar : public vScrollBar

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
ScrollableControlMiniBase
VIBlend.WinForms.Controls..::..vScrollBar
VIBlend.WinForms.Controls..::..vVScrollBar

See Also

vVScrollBar Members


vVScrollBar Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar Members
vVScrollBar Class Constructors Methods Properties Events See Also Send Feedback

The vVScrollBar type exposes the following members.

Constructors

 | Name | Description
Public method | vVScrollBar | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vScrollBar.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDiffFactor | (Inherited from vScrollBar.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnScroll | Raises the Scroll event (Inherited from vScrollBar.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Raises the ValueChanged event. (Inherited from vScrollBar.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Public method | SetDiffFactor | (Inherited from vScrollBar.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LargeChange | Gets or sets the large change value of the scroll bar. (Inherited from vScrollBar.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the maximum change value of the scroll bar. (Inherited from vScrollBar.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the minimum change value of the scroll bar. (Inherited from vScrollBar.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollButtonsRoundedCornersRadius | Gets or sets the rounded corners radius of the scroll bar buttons. (Inherited from vScrollBar.)
Public property | ScrollButtonsSemiRounded | Gets or sets whether the scrollbar buttons appear semirounded. (Inherited from vScrollBar.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmallChange | Gets or sets the small change value of the scroll bar. (Inherited from vScrollBar.)
Public property | SmartScrollEnabled | Gets or sets whether smart scrolling is enabled (Inherited from vScrollBar.)
Protected property | StyleKey | (Overrides vScrollBar..::..StyleKey.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vScrollBar.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the current value of the scroll bar. (Inherited from vScrollBar.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vScrollBar.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the thumb of the scroll bar has been moved by either a mouse or keyboard action. (Inherited from vScrollBar.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when the Value property is changed, either by a Scroll event or programmatically. (Inherited from vScrollBar.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vVScrollBar Class


vVScrollBar Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar Constructor
vVScrollBar Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vVScrollBar()
Visual Basic
Public Sub New
Visual C++
public:
vVScrollBar()

See Also

vVScrollBar Class


vVScrollBar Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar Methods
vVScrollBar Class See Also Send Feedback

The vVScrollBar type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vScrollBar.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDiffFactor | (Inherited from vScrollBar.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnScroll | Raises the Scroll event (Inherited from vScrollBar.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Raises the ValueChanged event. (Inherited from vScrollBar.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Public method | SetDiffFactor | (Inherited from vScrollBar.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vVScrollBar Class


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar..::..AccessibilityNotifyClients Method
vVScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vVScrollBar Class
vVScrollBar Members


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar..::..BeginInvoke Method
vVScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vVScrollBar Class
vVScrollBar Members


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar..::..Dispose Method
vVScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vScrollBar.)

See Also

vVScrollBar Class
vVScrollBar Members


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar..::..GetChildAtPoint Method
vVScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vVScrollBar Class
vVScrollBar Members


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar..::..Invalidate Method
vVScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vVScrollBar Class
vVScrollBar Members


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar..::..Invoke Method
vVScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vVScrollBar Class
vVScrollBar Members


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar..::..MemberwiseClone Method
vVScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vVScrollBar Class
vVScrollBar Members


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar..::..PerformLayout Method
vVScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vVScrollBar Class
vVScrollBar Members


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar..::..ResumeLayout Method
vVScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vVScrollBar Class
vVScrollBar Members


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar..::..RtlTranslateAlignment Method
vVScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vVScrollBar Class
vVScrollBar Members


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar..::..Scale Method
vVScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vVScrollBar Class
vVScrollBar Members


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar..::..Select Method
vVScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vVScrollBar Class
vVScrollBar Members


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar..::..SetBounds Method
vVScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vVScrollBar Class
vVScrollBar Members


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar..::..UpdateBounds Method
vVScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vVScrollBar Class
vVScrollBar Members


vVScrollBar Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar Properties
vVScrollBar Class See Also Send Feedback

The vVScrollBar type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LargeChange | Gets or sets the large change value of the scroll bar. (Inherited from vScrollBar.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the maximum change value of the scroll bar. (Inherited from vScrollBar.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the minimum change value of the scroll bar. (Inherited from vScrollBar.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollButtonsRoundedCornersRadius | Gets or sets the rounded corners radius of the scroll bar buttons. (Inherited from vScrollBar.)
Public property | ScrollButtonsSemiRounded | Gets or sets whether the scrollbar buttons appear semirounded. (Inherited from vScrollBar.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmallChange | Gets or sets the small change value of the scroll bar. (Inherited from vScrollBar.)
Public property | SmartScrollEnabled | Gets or sets whether smart scrolling is enabled (Inherited from vScrollBar.)
Protected property | StyleKey | (Overrides vScrollBar..::..StyleKey.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vScrollBar.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the current value of the scroll bar. (Inherited from vScrollBar.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vScrollBar.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vVScrollBar Class


StyleKey Property

[image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar..::..StyleKey Property
vVScrollBar Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal override string StyleKey { get; set; }
Visual Basic
Protected Friend Overrides Property StyleKey As String
    Get
    Set
Visual C++
protected public:
virtual property String^ StyleKey {
    String^ get () override;
    void set (String^ value) override;
}

See Also

vVScrollBar Class


vVScrollBar Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vVScrollBar Events
vVScrollBar Class See Also Send Feedback

The vVScrollBar type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the thumb of the scroll bar has been moved by either a mouse or keyboard action. (Inherited from vScrollBar.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when the Value property is changed, either by a Scroll event or programmatically. (Inherited from vScrollBar.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vVScrollBar Class


WeekPattern Class

[image]

VIBlend Controls for WinForms Help Documentation
WeekPattern Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class WeekPattern
Visual Basic
Public Class WeekPattern
Visual C++
public ref class WeekPattern

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..WeekPattern

See Also

WeekPattern Members


WeekPattern Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
WeekPattern Members
WeekPattern Class Constructors Methods Properties See Also Send Feedback

The WeekPattern type exposes the following members.

Constructors

 | Name | Description
Public method | WeekPattern | Initializes a new instance of the WeekPattern class.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | OccurOnFriday | Gets or sets a value indicating whether the day occurs on Friday
Public property | OccurOnMonday | Gets or sets a value indicating whether the day occurs on monday
Public property | OccurOnSaturday | Gets or sets a value indicating whether the day occurs on Saturday
Public property | OccurOnSunday | Gets or sets a value indicating whether the day occurs on Sunday
Public property | OccurOnThursday | Gets or sets a value indicating whether the day occurs on Thursday
Public property | OccurOnTuesday | Gets or sets a value indicating whether the day occurs on Tuesday
Public property | OccurOnWednesday | Gets or sets a value indicating whether the day occurs on Wednesday
Public property | WeeksToNextOccurences | Gets or sets the number of weeks to next occurence.

See Also

WeekPattern Class


WeekPattern Constructor

[image]

VIBlend Controls for WinForms Help Documentation
WeekPattern Constructor
WeekPattern Class See Also Send Feedback
Initializes a new instance of the WeekPattern class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public WeekPattern(
    int numberOfWeeksToNextOccurence
)
Visual Basic
Public Sub New ( _
    numberOfWeeksToNextOccurence As Integer _
)
Visual C++
public:
WeekPattern(
    int numberOfWeeksToNextOccurence
)

Parameters

numberOfWeeksToNextOccurence
Type: System..::..Int32
The number of weeks to next occurence.

See Also

WeekPattern Class


WeekPattern Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
WeekPattern Methods
WeekPattern Class See Also Send Feedback

The WeekPattern type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

WeekPattern Class


Clone Method

[image]

VIBlend Controls for WinForms Help Documentation
WeekPattern..::..Clone Method
WeekPattern Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public WeekPattern Clone()
Visual Basic
Public Function Clone As WeekPattern
Visual C++
public:
WeekPattern^ Clone()

See Also

WeekPattern Class


ToString Method

[image]

VIBlend Controls for WinForms Help Documentation
WeekPattern..::..ToString Method
WeekPattern Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

WeekPattern Class


WeekPattern Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
WeekPattern Properties
WeekPattern Class See Also Send Feedback

The WeekPattern type exposes the following members.

Properties

 | Name | Description
Public property | OccurOnFriday | Gets or sets a value indicating whether the day occurs on Friday
Public property | OccurOnMonday | Gets or sets a value indicating whether the day occurs on monday
Public property | OccurOnSaturday | Gets or sets a value indicating whether the day occurs on Saturday
Public property | OccurOnSunday | Gets or sets a value indicating whether the day occurs on Sunday
Public property | OccurOnThursday | Gets or sets a value indicating whether the day occurs on Thursday
Public property | OccurOnTuesday | Gets or sets a value indicating whether the day occurs on Tuesday
Public property | OccurOnWednesday | Gets or sets a value indicating whether the day occurs on Wednesday
Public property | WeeksToNextOccurences | Gets or sets the number of weeks to next occurence.

See Also

WeekPattern Class


OccurOnFriday Property

[image]

VIBlend Controls for WinForms Help Documentation
WeekPattern..::..OccurOnFriday Property
WeekPattern Class See Also Send Feedback
Gets or sets a value indicating whether the day occurs on Friday

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool OccurOnFriday { get; set; }
Visual Basic
Public Property OccurOnFriday As Boolean
    Get
    Set
Visual C++
public:
property bool OccurOnFriday {
    bool get ();
    void set (bool value);
}

See Also

WeekPattern Class


OccurOnMonday Property

[image]

VIBlend Controls for WinForms Help Documentation
WeekPattern..::..OccurOnMonday Property
WeekPattern Class See Also Send Feedback
Gets or sets a value indicating whether the day occurs on monday

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool OccurOnMonday { get; set; }
Visual Basic
Public Property OccurOnMonday As Boolean
    Get
    Set
Visual C++
public:
property bool OccurOnMonday {
    bool get ();
    void set (bool value);
}

See Also

WeekPattern Class


OccurOnSaturday Property

[image]

VIBlend Controls for WinForms Help Documentation
WeekPattern..::..OccurOnSaturday Property
WeekPattern Class See Also Send Feedback
Gets or sets a value indicating whether the day occurs on Saturday

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool OccurOnSaturday { get; set; }
Visual Basic
Public Property OccurOnSaturday As Boolean
    Get
    Set
Visual C++
public:
property bool OccurOnSaturday {
    bool get ();
    void set (bool value);
}

See Also

WeekPattern Class


OccurOnSunday Property

[image]

VIBlend Controls for WinForms Help Documentation
WeekPattern..::..OccurOnSunday Property
WeekPattern Class See Also Send Feedback
Gets or sets a value indicating whether the day occurs on Sunday

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool OccurOnSunday { get; set; }
Visual Basic
Public Property OccurOnSunday As Boolean
    Get
    Set
Visual C++
public:
property bool OccurOnSunday {
    bool get ();
    void set (bool value);
}

See Also

WeekPattern Class


OccurOnThursday Property

[image]

VIBlend Controls for WinForms Help Documentation
WeekPattern..::..OccurOnThursday Property
WeekPattern Class See Also Send Feedback
Gets or sets a value indicating whether the day occurs on Thursday

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool OccurOnThursday { get; set; }
Visual Basic
Public Property OccurOnThursday As Boolean
    Get
    Set
Visual C++
public:
property bool OccurOnThursday {
    bool get ();
    void set (bool value);
}

See Also

WeekPattern Class


OccurOnTuesday Property

[image]

VIBlend Controls for WinForms Help Documentation
WeekPattern..::..OccurOnTuesday Property
WeekPattern Class See Also Send Feedback
Gets or sets a value indicating whether the day occurs on Tuesday

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool OccurOnTuesday { get; set; }
Visual Basic
Public Property OccurOnTuesday As Boolean
    Get
    Set
Visual C++
public:
property bool OccurOnTuesday {
    bool get ();
    void set (bool value);
}

See Also

WeekPattern Class


OccurOnWednesday Property

[image]

VIBlend Controls for WinForms Help Documentation
WeekPattern..::..OccurOnWednesday Property
WeekPattern Class See Also Send Feedback
Gets or sets a value indicating whether the day occurs on Wednesday

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool OccurOnWednesday { get; set; }
Visual Basic
Public Property OccurOnWednesday As Boolean
    Get
    Set
Visual C++
public:
property bool OccurOnWednesday {
    bool get ();
    void set (bool value);
}

See Also

WeekPattern Class


WeeksToNextOccurences Property

[image]

VIBlend Controls for WinForms Help Documentation
WeekPattern..::..WeeksToNextOccurences Property
WeekPattern Class See Also Send Feedback
Gets or sets the number of weeks to next occurence.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int WeeksToNextOccurences { get; set; }
Visual Basic
Public Property WeeksToNextOccurences As Integer
    Get
    Set
Visual C++
public:
property int WeeksToNextOccurences {
    int get ();
    void set (int value);
}

Field Value

The number of weeks to next occurence.

See Also

WeekPattern Class


WindowsAPI Class

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static class WindowsAPI
Visual Basic
Public NotInheritable Class WindowsAPI
Visual C++
public ref class WindowsAPI abstract sealed

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..WindowsAPI

See Also

WindowsAPI Members


WindowsAPI Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI Members
WindowsAPI Class Methods Fields Properties See Also Send Feedback

The WindowsAPI type exposes the following members.

Methods

Name | Description
DrawTextOnGlass | Draws theme text on glass.
FillForGlass | Fills an area for glass rendering
HiWord | Equivalent to the HiWord C Macro
LoWord | Equivalent to the LoWord C Macro
MakeLParam | Equivalent to the MakeLParam C Macro

Fields

Name | Description
BI_RGB | An uncompressed format.
CS_DROPSHADOW | Enables the drop shadow effect on a window
DIB_RGB_COLORS | The BITMAPINFO structure contains an array of literal RGB values.
SRCCOPY | Copies the source rectangle directly to the destination rectangle.
VK_CAPITAL |
VK_NUMLOCK |
VK_SHIFT |
WH_KEYBOARD | Installs a hook procedure that monitors keystroke messages.
WH_KEYBOARD_LL | Windows NT/2000/XP: Installs a hook procedure that monitors low-level keyboard input events.
WH_MOUSE | Installs a hook procedure that monitors mouse messages.
WH_MOUSE_LL | Windows NT/2000/XP: Installs a hook procedure that monitors low-level mouse input events.
WM_ERASEBKGND | The WM_ERASEBKGND message is sent when the window background must be erased (for example, when a window is resized).
WM_KEYDOWN |
WM_KEYUP |
WM_LBUTTONDBLCLK |
WM_LBUTTONDOWN |
WM_LBUTTONUP |
WM_MBUTTONDBLCLK |
WM_MBUTTONDOWN |
WM_MBUTTONUP |
WM_MOUSEFIRST |
WM_MOUSELAST |
WM_MOUSEMOVE |
WM_MOUSEWHEEL |
WM_NCCALCSIZE | The WM_NCCALCSIZE message is sent when the size and position of a window's client area must be calculated.
WM_NCHITTEST | The WM_NCHITTEST message is sent to a window when the cursor moves, or when a mouse button is pressed or released.
WM_NCLBUTTONUP | The WM_NCLBUTTONUP message is posted when the user releases the left mouse button while the cursor is within the nonclient area of a window.
WM_NCMOUSELEAVE | The WM_NCMOUSELEAVE message is posted to a window when the cursor leaves the nonclient area of the window specified in a prior call to TrackMouseEvent.
WM_NCMOUSEMOVE | The WM_NCMOUSEMOVE message is posted to a window when the cursor is moved within the nonclient area of the window.
WM_RBUTTONDBLCLK |
WM_RBUTTONDOWN |
WM_RBUTTONUP |
WM_SIZE | The WM_SIZE message is sent to a window after its size has changed.
WM_SYSKEYDOWN |
WM_SYSKEYUP |
WM_XBUTTONDBLCLK |
WM_XBUTTONDOWN |
WM_XBUTTONUP |

Properties

Name | Description
AllowGlass | If set to true and the OS Glass effect is enabled, the form resembles the standard glass Form. However, if the property value is false, the Form renders the Form without the glass effect.
IsGlassEnabled | Gets if computer is glass capable and enabled
IsVista | Gets a value indicating if operating system is vista or higher
IsWindows | Gets if the current OS is Windows NT or later
IsXP | Gets a value indicating if operating system is xp or higher

See Also

WindowsAPI Class


WindowsAPI Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI Fields
WindowsAPI Class See Also Send Feedback

The WindowsAPI type exposes the following members.

Fields

Name | Description
BI_RGB | An uncompressed format.
CS_DROPSHADOW | Enables the drop shadow effect on a window
DIB_RGB_COLORS | The BITMAPINFO structure contains an array of literal RGB values.
SRCCOPY | Copies the source rectangle directly to the destination rectangle.
VK_CAPITAL |
VK_NUMLOCK |
VK_SHIFT |
WH_KEYBOARD | Installs a hook procedure that monitors keystroke messages.
WH_KEYBOARD_LL | Windows NT/2000/XP: Installs a hook procedure that monitors low-level keyboard input events.
WH_MOUSE | Installs a hook procedure that monitors mouse messages.
WH_MOUSE_LL | Windows NT/2000/XP: Installs a hook procedure that monitors low-level mouse input events.
WM_ERASEBKGND | The WM_ERASEBKGND message is sent when the window background must be erased (for example, when a window is resized).
WM_KEYDOWN |
WM_KEYUP |
WM_LBUTTONDBLCLK |
WM_LBUTTONDOWN |
WM_LBUTTONUP |
WM_MBUTTONDBLCLK |
WM_MBUTTONDOWN |
WM_MBUTTONUP |
WM_MOUSEFIRST |
WM_MOUSELAST |
WM_MOUSEMOVE |
WM_MOUSEWHEEL |
WM_NCCALCSIZE | The WM_NCCALCSIZE message is sent when the size and position of a window's client area must be calculated.
WM_NCHITTEST | The WM_NCHITTEST message is sent to a window when the cursor moves, or when a mouse button is pressed or released.
WM_NCLBUTTONUP | The WM_NCLBUTTONUP message is posted when the user releases the left mouse button while the cursor is within the nonclient area of a window.
WM_NCMOUSELEAVE | The WM_NCMOUSELEAVE message is posted to a window when the cursor leaves the nonclient area of the window specified in a prior call to TrackMouseEvent.
WM_NCMOUSEMOVE | The WM_NCMOUSEMOVE message is posted to a window when the cursor is moved within the nonclient area of the window.
WM_RBUTTONDBLCLK |
WM_RBUTTONDOWN |
WM_RBUTTONUP |
WM_SIZE | The WM_SIZE message is sent to a window after its size has changed.
WM_SYSKEYDOWN |
WM_SYSKEYUP |
WM_XBUTTONDBLCLK |
WM_XBUTTONDOWN |
WM_XBUTTONUP |

See Also

WindowsAPI Class


BI_RGB Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..BI_RGB Field
WindowsAPI Class See Also Send Feedback
An uncompressed format.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int BI_RGB
Visual Basic
Public Const BI_RGB As Integer
Visual C++
public:
literal int BI_RGB

See Also

WindowsAPI Class


CS_DROPSHADOW Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..CS_DROPSHADOW Field
WindowsAPI Class See Also Send Feedback
Enables the drop shadow effect on a window

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int CS_DROPSHADOW
Visual Basic
Public Const CS_DROPSHADOW As Integer
Visual C++
public:
literal int CS_DROPSHADOW

See Also

WindowsAPI Class


DIB_RGB_COLORS Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..DIB_RGB_COLORS Field
WindowsAPI Class See Also Send Feedback
The BITMAPINFO structure contains an array of literal RGB values.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int DIB_RGB_COLORS
Visual Basic
Public Const DIB_RGB_COLORS As Integer
Visual C++
public:
literal int DIB_RGB_COLORS

See Also

WindowsAPI Class


SRCCOPY Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..SRCCOPY Field
WindowsAPI Class See Also Send Feedback
Copies the source rectangle directly to the destination rectangle.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int SRCCOPY
Visual Basic
Public Const SRCCOPY As Integer
Visual C++
public:
literal int SRCCOPY

See Also

WindowsAPI Class


VK_CAPITAL Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..VK_CAPITAL Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const byte VK_CAPITAL
Visual Basic
Public Const VK_CAPITAL As Byte
Visual C++
public:
literal unsigned char VK_CAPITAL

See Also

WindowsAPI Class


VK_NUMLOCK Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..VK_NUMLOCK Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const byte VK_NUMLOCK
Visual Basic
Public Const VK_NUMLOCK As Byte
Visual C++
public:
literal unsigned char VK_NUMLOCK

See Also

WindowsAPI Class


VK_SHIFT Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..VK_SHIFT Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const byte VK_SHIFT
Visual Basic
Public Const VK_SHIFT As Byte
Visual C++
public:
literal unsigned char VK_SHIFT

See Also

WindowsAPI Class


WH_KEYBOARD Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WH_KEYBOARD Field
WindowsAPI Class See Also Send Feedback
Installs a hook procedure that monitors keystroke messages.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WH_KEYBOARD
Visual Basic
Public Const WH_KEYBOARD As Integer
Visual C++
public:
literal int WH_KEYBOARD

See Also

WindowsAPI Class


WH_KEYBOARD_LL Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WH_KEYBOARD_LL Field
WindowsAPI Class See Also Send Feedback
Windows NT/2000/XP: Installs a hook procedure that monitors low-level keyboard input events.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WH_KEYBOARD_LL
Visual Basic
Public Const WH_KEYBOARD_LL As Integer
Visual C++
public:
literal int WH_KEYBOARD_LL

See Also

WindowsAPI Class


WH_MOUSE Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WH_MOUSE Field
WindowsAPI Class See Also Send Feedback
Installs a hook procedure that monitors mouse messages.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WH_MOUSE
Visual Basic
Public Const WH_MOUSE As Integer
Visual C++
public:
literal int WH_MOUSE

See Also

WindowsAPI Class


WH_MOUSE_LL Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WH_MOUSE_LL Field
WindowsAPI Class See Also Send Feedback
Windows NT/2000/XP: Installs a hook procedure that monitors low-level mouse input events.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WH_MOUSE_LL
Visual Basic
Public Const WH_MOUSE_LL As Integer
Visual C++
public:
literal int WH_MOUSE_LL

See Also

WindowsAPI Class


WM_ERASEBKGND Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_ERASEBKGND Field
WindowsAPI Class See Also Send Feedback
The WM_ERASEBKGND message is sent when the window background must be erased (for example, when a window is resized).

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_ERASEBKGND
Visual Basic
Public Const WM_ERASEBKGND As Integer
Visual C++
public:
literal int WM_ERASEBKGND

See Also

WindowsAPI Class


WM_KEYDOWN Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_KEYDOWN Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_KEYDOWN
Visual Basic
Public Const WM_KEYDOWN As Integer
Visual C++
public:
literal int WM_KEYDOWN

See Also

WindowsAPI Class


WM_KEYUP Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_KEYUP Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_KEYUP
Visual Basic
Public Const WM_KEYUP As Integer
Visual C++
public:
literal int WM_KEYUP

See Also

WindowsAPI Class


WM_LBUTTONDBLCLK Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_LBUTTONDBLCLK Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_LBUTTONDBLCLK
Visual Basic
Public Const WM_LBUTTONDBLCLK As Integer
Visual C++
public:
literal int WM_LBUTTONDBLCLK

See Also

WindowsAPI Class


WM_LBUTTONDOWN Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_LBUTTONDOWN Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_LBUTTONDOWN
Visual Basic
Public Const WM_LBUTTONDOWN As Integer
Visual C++
public:
literal int WM_LBUTTONDOWN

See Also

WindowsAPI Class


WM_LBUTTONUP Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_LBUTTONUP Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_LBUTTONUP
Visual Basic
Public Const WM_LBUTTONUP As Integer
Visual C++
public:
literal int WM_LBUTTONUP

See Also

WindowsAPI Class


WM_MBUTTONDBLCLK Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_MBUTTONDBLCLK Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_MBUTTONDBLCLK
Visual Basic
Public Const WM_MBUTTONDBLCLK As Integer
Visual C++
public:
literal int WM_MBUTTONDBLCLK

See Also

WindowsAPI Class


WM_MBUTTONDOWN Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_MBUTTONDOWN Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_MBUTTONDOWN
Visual Basic
Public Const WM_MBUTTONDOWN As Integer
Visual C++
public:
literal int WM_MBUTTONDOWN

See Also

WindowsAPI Class


WM_MBUTTONUP Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_MBUTTONUP Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_MBUTTONUP
Visual Basic
Public Const WM_MBUTTONUP As Integer
Visual C++
public:
literal int WM_MBUTTONUP

See Also

WindowsAPI Class


WM_MOUSEFIRST Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_MOUSEFIRST Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_MOUSEFIRST
Visual Basic
Public Const WM_MOUSEFIRST As Integer
Visual C++
public:
literal int WM_MOUSEFIRST

See Also

WindowsAPI Class


WM_MOUSELAST Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_MOUSELAST Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_MOUSELAST
Visual Basic
Public Const WM_MOUSELAST As Integer
Visual C++
public:
literal int WM_MOUSELAST

See Also

WindowsAPI Class


WM_MOUSEMOVE Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_MOUSEMOVE Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_MOUSEMOVE
Visual Basic
Public Const WM_MOUSEMOVE As Integer
Visual C++
public:
literal int WM_MOUSEMOVE

See Also

WindowsAPI Class


WM_MOUSEWHEEL Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_MOUSEWHEEL Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_MOUSEWHEEL
Visual Basic
Public Const WM_MOUSEWHEEL As Integer
Visual C++
public:
literal int WM_MOUSEWHEEL

See Also

WindowsAPI Class


WM_NCCALCSIZE Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_NCCALCSIZE Field
WindowsAPI Class See Also Send Feedback
The WM_NCCALCSIZE message is sent when the size and position of a window's client area must be calculated.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_NCCALCSIZE
Visual Basic
Public Const WM_NCCALCSIZE As Integer
Visual C++
public:
literal int WM_NCCALCSIZE

See Also

WindowsAPI Class


WM_NCHITTEST Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_NCHITTEST Field
WindowsAPI Class See Also Send Feedback
The WM_NCHITTEST message is sent to a window when the cursor moves, or when a mouse button is pressed or released.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_NCHITTEST
Visual Basic
Public Const WM_NCHITTEST As Integer
Visual C++
public:
literal int WM_NCHITTEST

See Also

WindowsAPI Class


WM_NCLBUTTONUP Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_NCLBUTTONUP Field
WindowsAPI Class See Also Send Feedback
The WM_NCLBUTTONUP message is posted when the user releases the left mouse button while the cursor is within the nonclient area of a window.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_NCLBUTTONUP
Visual Basic
Public Const WM_NCLBUTTONUP As Integer
Visual C++
public:
literal int WM_NCLBUTTONUP

See Also

WindowsAPI Class


WM_NCMOUSELEAVE Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_NCMOUSELEAVE Field
WindowsAPI Class See Also Send Feedback
The WM_NCMOUSELEAVE message is posted to a window when the cursor leaves the nonclient area of the window specified in a prior call to TrackMouseEvent.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_NCMOUSELEAVE
Visual Basic
Public Const WM_NCMOUSELEAVE As Integer
Visual C++
public:
literal int WM_NCMOUSELEAVE

See Also

WindowsAPI Class


WM_NCMOUSEMOVE Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_NCMOUSEMOVE Field
WindowsAPI Class See Also Send Feedback
The WM_NCMOUSEMOVE message is posted to a window when the cursor is moved within the nonclient area of the window.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_NCMOUSEMOVE
Visual Basic
Public Const WM_NCMOUSEMOVE As Integer
Visual C++
public:
literal int WM_NCMOUSEMOVE

See Also

WindowsAPI Class


WM_RBUTTONDBLCLK Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_RBUTTONDBLCLK Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_RBUTTONDBLCLK
Visual Basic
Public Const WM_RBUTTONDBLCLK As Integer
Visual C++
public:
literal int WM_RBUTTONDBLCLK

See Also

WindowsAPI Class


WM_RBUTTONDOWN Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_RBUTTONDOWN Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_RBUTTONDOWN
Visual Basic
Public Const WM_RBUTTONDOWN As Integer
Visual C++
public:
literal int WM_RBUTTONDOWN

See Also

WindowsAPI Class


WM_RBUTTONUP Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_RBUTTONUP Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_RBUTTONUP
Visual Basic
Public Const WM_RBUTTONUP As Integer
Visual C++
public:
literal int WM_RBUTTONUP

See Also

WindowsAPI Class


WM_SIZE Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_SIZE Field
WindowsAPI Class See Also Send Feedback
The WM_SIZE message is sent to a window after its size has changed.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_SIZE
Visual Basic
Public Const WM_SIZE As Integer
Visual C++
public:
literal int WM_SIZE

See Also

WindowsAPI Class


WM_SYSKEYDOWN Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_SYSKEYDOWN Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_SYSKEYDOWN
Visual Basic
Public Const WM_SYSKEYDOWN As Integer
Visual C++
public:
literal int WM_SYSKEYDOWN

See Also

WindowsAPI Class


WM_SYSKEYUP Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_SYSKEYUP Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_SYSKEYUP
Visual Basic
Public Const WM_SYSKEYUP As Integer
Visual C++
public:
literal int WM_SYSKEYUP

See Also

WindowsAPI Class


WM_XBUTTONDBLCLK Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_XBUTTONDBLCLK Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_XBUTTONDBLCLK
Visual Basic
Public Const WM_XBUTTONDBLCLK As Integer
Visual C++
public:
literal int WM_XBUTTONDBLCLK

See Also

WindowsAPI Class


WM_XBUTTONDOWN Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_XBUTTONDOWN Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_XBUTTONDOWN
Visual Basic
Public Const WM_XBUTTONDOWN As Integer
Visual C++
public:
literal int WM_XBUTTONDOWN

See Also

WindowsAPI Class


WM_XBUTTONUP Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..WM_XBUTTONUP Field
WindowsAPI Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public const int WM_XBUTTONUP
Visual Basic
Public Const WM_XBUTTONUP As Integer
Visual C++
public:
literal int WM_XBUTTONUP

See Also

WindowsAPI Class


WindowsAPI Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI Methods
WindowsAPI Class See Also Send Feedback

The WindowsAPI type exposes the following members.

Methods

Name | Description
DrawTextOnGlass | Draws theme text on glass.
FillForGlass | Fills an area for glass rendering
HiWord | Equivalent to the HiWord C Macro
LoWord | Equivalent to the LoWord C Macro
MakeLParam | Equivalent to the MakeLParam C Macro

See Also

WindowsAPI Class


DrawTextOnGlass Method

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..DrawTextOnGlass Method
WindowsAPI Class See Also Send Feedback
Draws theme text on glass.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static void DrawTextOnGlass(
    IntPtr hwnd,
    string text,
    Font font,
    Rectangle ctlrct,
    int iglowSize
)
Visual Basic
Public Shared Sub DrawTextOnGlass ( _
    hwnd As IntPtr, _
    text As String, _
    font As Font, _
    ctlrct As Rectangle, _
    iglowSize As Integer _
)
Visual C++
public:
static void DrawTextOnGlass(
    IntPtr hwnd,
    String^ text,
    Font^ font,
    Rectangle ctlrct,
    int iglowSize
)

Parameters

hwnd
Type: System..::..IntPtr
text
Type: System..::..String
font
Type: System.Drawing..::..Font
ctlrct
Type: System.Drawing..::..Rectangle
iglowSize
Type: System..::..Int32

Remarks

This method is courtesy of 版权所有 (I hope the name's right)

See Also

WindowsAPI Class


FillForGlass Method

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..FillForGlass Method
WindowsAPI Class See Also Send Feedback
Fills an area for glass rendering

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static void FillForGlass(
    Graphics g,
    Rectangle r
)
Visual Basic
Public Shared Sub FillForGlass ( _
    g As Graphics, _
    r As Rectangle _
)
Visual C++
public:
static void FillForGlass(
    Graphics^ g,
    Rectangle r
)

Parameters

g
Type: System.Drawing..::..Graphics
r
Type: System.Drawing..::..Rectangle

See Also

WindowsAPI Class


HiWord Method

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..HiWord Method
WindowsAPI Class See Also Send Feedback
Equivalent to the HiWord C Macro

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int HiWord(
    int dwValue
)
Visual Basic
Public Shared Function HiWord ( _
    dwValue As Integer _
) As Integer
Visual C++
public:
static int HiWord(
    int dwValue
)

Parameters

dwValue
Type: System..::..Int32

Return Value

See Also

WindowsAPI Class


LoWord Method

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..LoWord Method
WindowsAPI Class See Also Send Feedback
Equivalent to the LoWord C Macro

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static int LoWord(
    int dwValue
)
Visual Basic
Public Shared Function LoWord ( _
    dwValue As Integer _
) As Integer
Visual C++
public:
static int LoWord(
    int dwValue
)

Parameters

dwValue
Type: System..::..Int32

Return Value

See Also

WindowsAPI Class


MakeLParam Method

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..MakeLParam Method
WindowsAPI Class See Also Send Feedback
Equivalent to the MakeLParam C Macro

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static IntPtr MakeLParam(
    int LoWord,
    int HiWord
)
Visual Basic
Public Shared Function MakeLParam ( _
    LoWord As Integer, _
    HiWord As Integer _
) As IntPtr
Visual C++
public:
static IntPtr MakeLParam(
    int LoWord,
    int HiWord
)

Parameters

LoWord
Type: System..::..Int32
HiWord
Type: System..::..Int32

Return Value

See Also

WindowsAPI Class


WindowsAPI Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI Properties
WindowsAPI Class See Also Send Feedback

The WindowsAPI type exposes the following members.

Properties

Name | Description
AllowGlass | If set to true and the OS Glass effect is enabled, the form resembles the standard glass Form. However, if the property value is false, the Form renders the Form without the glass effect.
IsGlassEnabled | Gets if computer is glass capable and enabled
IsVista | Gets a value indicating if operating system is vista or higher
IsWindows | Gets if the current OS is Windows NT or later
IsXP | Gets a value indicating if operating system is xp or higher

See Also

WindowsAPI Class


AllowGlass Property

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..AllowGlass Property
WindowsAPI Class See Also Send Feedback
If set to true and the OS Glass effect is enabled, the form resembles the standard glass Form. However, if the property value is false, the Form renders the Form without the glass effect.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static bool AllowGlass { get; set; }
Visual Basic
Public Shared Property AllowGlass As Boolean
    Get
    Set
Visual C++
public:
static property bool AllowGlass {
    bool get ();
    void set (bool value);
}

See Also

WindowsAPI Class


IsGlassEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..IsGlassEnabled Property
WindowsAPI Class See Also Send Feedback
Gets if computer is glass capable and enabled

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static bool IsGlassEnabled { get; }
Visual Basic
Public Shared ReadOnly Property IsGlassEnabled As Boolean
    Get
Visual C++
public:
static property bool IsGlassEnabled {
    bool get ();
}

See Also

WindowsAPI Class


IsVista Property

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..IsVista Property
WindowsAPI Class See Also Send Feedback
Gets a value indicating if operating system is vista or higher

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static bool IsVista { get; }
Visual Basic
Public Shared ReadOnly Property IsVista As Boolean
    Get
Visual C++
public:
static property bool IsVista {
    bool get ();
}

See Also

WindowsAPI Class


IsWindows Property

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..IsWindows Property
WindowsAPI Class See Also Send Feedback
Gets if the current OS is Windows NT or later

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static bool IsWindows { get; }
Visual Basic
Public Shared ReadOnly Property IsWindows As Boolean
    Get
Visual C++
public:
static property bool IsWindows {
    bool get ();
}

See Also

WindowsAPI Class


IsXP Property

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..IsXP Property
WindowsAPI Class See Also Send Feedback
Gets a value indicating if operating system is xp or higher

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public static bool IsXP { get; }
Visual Basic
Public Shared ReadOnly Property IsXP As Boolean
    Get
Visual C++
public:
static property bool IsXP {
    bool get ();
}

See Also

WindowsAPI Class


WindowsAPI.NCCALCSIZE_PARAMS Structure

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..NCCALCSIZE_PARAMS Structure
WindowsAPI Class Members See Also Send Feedback
The NCCALCSIZE_PARAMS structure contains information that an application can use while processing the WM_NCCALCSIZE message to calculate the size, position, and valid contents of the client area of a window.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public struct NCCALCSIZE_PARAMS
Visual Basic
Public Structure NCCALCSIZE_PARAMS
Visual C++
public value class NCCALCSIZE_PARAMS

See Also

WindowsAPI..::..NCCALCSIZE_PARAMS Members


WindowsAPI.NCCALCSIZE_PARAMS Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..NCCALCSIZE_PARAMS Members
WindowsAPI..::..NCCALCSIZE_PARAMS Structure Methods Fields See Also Send Feedback

The WindowsAPI..::..NCCALCSIZE_PARAMS type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | lppos |
Public field | rect0 |
Public field | rect1 |
Public field | rect2 |

See Also

WindowsAPI..::..NCCALCSIZE_PARAMS Structure


WindowsAPI.NCCALCSIZE_PARAMS Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..NCCALCSIZE_PARAMS Fields
WindowsAPI..::..NCCALCSIZE_PARAMS Structure See Also Send Feedback

The WindowsAPI..::..NCCALCSIZE_PARAMS type exposes the following members.

Fields

 | Name | Description
Public field | lppos |
Public field | rect0 |
Public field | rect1 |
Public field | rect2 |

See Also

WindowsAPI..::..NCCALCSIZE_PARAMS Structure


lppos Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..NCCALCSIZE_PARAMS..::..lppos Field
WindowsAPI..::..NCCALCSIZE_PARAMS Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public IntPtr lppos
Visual Basic
Public lppos As IntPtr
Visual C++
public:
IntPtr lppos

See Also

WindowsAPI..::..NCCALCSIZE_PARAMS Structure


rect0 Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..NCCALCSIZE_PARAMS..::..rect0 Field
WindowsAPI..::..NCCALCSIZE_PARAMS Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public WindowsAPI..::..RECT rect0
Visual Basic
Public rect0 As WindowsAPI..::..RECT
Visual C++
public:
WindowsAPI..::..RECT rect0

See Also

WindowsAPI..::..NCCALCSIZE_PARAMS Structure


rect1 Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..NCCALCSIZE_PARAMS..::..rect1 Field
WindowsAPI..::..NCCALCSIZE_PARAMS Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public WindowsAPI..::..RECT rect1
Visual Basic
Public rect1 As WindowsAPI..::..RECT
Visual C++
public:
WindowsAPI..::..RECT rect1

See Also

WindowsAPI..::..NCCALCSIZE_PARAMS Structure


rect2 Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..NCCALCSIZE_PARAMS..::..rect2 Field
WindowsAPI..::..NCCALCSIZE_PARAMS Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public WindowsAPI..::..RECT rect2
Visual Basic
Public rect2 As WindowsAPI..::..RECT
Visual C++
public:
WindowsAPI..::..RECT rect2

See Also

WindowsAPI..::..NCCALCSIZE_PARAMS Structure


WindowsAPI.NCCALCSIZE_PARAMS Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..NCCALCSIZE_PARAMS Methods
WindowsAPI..::..NCCALCSIZE_PARAMS Structure See Also Send Feedback

The WindowsAPI..::..NCCALCSIZE_PARAMS type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

WindowsAPI..::..NCCALCSIZE_PARAMS Structure


WindowsAPI.RECT Structure

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..RECT Structure
WindowsAPI Class Members See Also Send Feedback
Describes the width, height, and location of a rectangle.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public struct RECT
Visual Basic
Public Structure RECT
Visual C++
public value class RECT

See Also

WindowsAPI..::..RECT Members


WindowsAPI.RECT Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..RECT Members
WindowsAPI..::..RECT Structure Methods Fields See Also Send Feedback

The WindowsAPI..::..RECT type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | Bottom |
Public field | Left |
Public field | Right |
Public field | Top |

See Also

WindowsAPI..::..RECT Structure


WindowsAPI.RECT Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..RECT Fields
WindowsAPI..::..RECT Structure See Also Send Feedback

The WindowsAPI..::..RECT type exposes the following members.

Fields

 | Name | Description
Public field | Bottom |
Public field | Left |
Public field | Right |
Public field | Top |

See Also

WindowsAPI..::..RECT Structure


Bottom Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..RECT..::..Bottom Field
WindowsAPI..::..RECT Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Bottom
Visual Basic
Public Bottom As Integer
Visual C++
public:
int Bottom

See Also

WindowsAPI..::..RECT Structure


Left Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..RECT..::..Left Field
WindowsAPI..::..RECT Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Left
Visual Basic
Public Left As Integer
Visual C++
public:
int Left

See Also

WindowsAPI..::..RECT Structure


Right Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..RECT..::..Right Field
WindowsAPI..::..RECT Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Right
Visual Basic
Public Right As Integer
Visual C++
public:
int Right

See Also

WindowsAPI..::..RECT Structure


Top Field

[image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..RECT..::..Top Field
WindowsAPI..::..RECT Structure See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Top
Visual Basic
Public Top As Integer
Visual C++
public:
int Top

See Also

WindowsAPI..::..RECT Structure


WindowsAPI.RECT Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
WindowsAPI..::..RECT Methods
WindowsAPI..::..RECT Structure See Also Send Feedback

The WindowsAPI..::..RECT type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

WindowsAPI..::..RECT Structure


YearPattern Class

[image]

VIBlend Controls for WinForms Help Documentation
YearPattern Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class YearPattern
Visual Basic
Public Class YearPattern
Visual C++
public ref class YearPattern

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.Controls..::..YearPattern

See Also

YearPattern Members


YearPattern Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPattern Members
YearPattern Class Constructors Methods Properties See Also Send Feedback

The YearPattern type exposes the following members.

Constructors

 | Name | Description
Public method | YearPattern | Initializes a new instance of the YearPattern class.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Day | Gets or sets the day.
Public property | Month | Gets or sets the month.

See Also

YearPattern Class


YearPattern Constructor

[image]

VIBlend Controls for WinForms Help Documentation
YearPattern Constructor
YearPattern Class See Also Send Feedback
Initializes a new instance of the YearPattern class.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public YearPattern(
    int month,
    int day
)
Visual Basic
Public Sub New ( _
    month As Integer, _
    day As Integer _
)
Visual C++
public:
YearPattern(
    int month,
    int day
)

Parameters

month
Type: System..::..Int32
The month.
day
Type: System..::..Int32
The day.

See Also

YearPattern Class


YearPattern Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPattern Methods
YearPattern Class See Also Send Feedback

The YearPattern type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

YearPattern Class


Clone Method

[image]

VIBlend Controls for WinForms Help Documentation
YearPattern..::..Clone Method
YearPattern Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public YearPattern Clone()
Visual Basic
Public Function Clone As YearPattern
Visual C++
public:
YearPattern^ Clone()

See Also

YearPattern Class


YearPattern Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPattern Properties
YearPattern Class See Also Send Feedback

The YearPattern type exposes the following members.

Properties

 | Name | Description
Public property | Day | Gets or sets the day.
Public property | Month | Gets or sets the month.

See Also

YearPattern Class


Day Property

[image]

VIBlend Controls for WinForms Help Documentation
YearPattern..::..Day Property
YearPattern Class See Also Send Feedback
Gets or sets the day.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Day { get; set; }
Visual Basic
Public Property Day As Integer
    Get
    Set
Visual C++
public:
property int Day {
    int get ();
    void set (int value);
}

Field Value

The day.

See Also

YearPattern Class


Month Property

[image]

VIBlend Controls for WinForms Help Documentation
YearPattern..::..Month Property
YearPattern Class See Also Send Feedback
Gets or sets the month.

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Month { get; set; }
Visual Basic
Public Property Month As Integer
    Get
    Set
Visual C++
public:
property int Month {
    int get ();
    void set (int value);
}

Field Value

The month.

See Also

YearPattern Class


YearPatternConverter Class

[image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class YearPatternConverter : ExpandableObjectConverter
Visual Basic
Public Class YearPatternConverter _
    Inherits ExpandableObjectConverter
Visual C++
public ref class YearPatternConverter : public ExpandableObjectConverter

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..TypeConverter
System.ComponentModel..::..ExpandableObjectConverter
VIBlend.WinForms.Controls..::..YearPatternConverter

See Also

YearPatternConverter Members


YearPatternConverter Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter Members
YearPatternConverter Class Constructors Methods See Also Send Feedback

The YearPatternConverter type exposes the following members.

Constructors

 | Name | Description
Public method | YearPatternConverter | Initializes a new instance of the YearPatternConverter class

Methods

 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | (Overrides TypeConverter..::..CreateInstance(ITypeDescriptorContext, IDictionary).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported()()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | (Overrides TypeConverter..::..GetCreateInstanceSupported(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) | (Overrides ExpandableObjectConverter..::..GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]).)
Public method | GetPropertiesSupported()()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | (Overrides ExpandableObjectConverter..::..GetPropertiesSupported(ITypeDescriptorContext).)
Public method | GetStandardValues()()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive()()()() | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported()()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

YearPatternConverter Class


YearPatternConverter Constructor

[image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter Constructor
YearPatternConverter Class See Also Send Feedback
Initializes a new instance of the YearPatternConverter class

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public YearPatternConverter()
Visual Basic
Public Sub New
Visual C++
public:
YearPatternConverter()

See Also

YearPatternConverter Class


YearPatternConverter Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter Methods
YearPatternConverter Class See Also Send Feedback

The YearPatternConverter type exposes the following members.

Methods

 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | (Overrides TypeConverter..::..CreateInstance(ITypeDescriptorContext, IDictionary).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported()()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | (Overrides TypeConverter..::..GetCreateInstanceSupported(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) | (Overrides ExpandableObjectConverter..::..GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]).)
Public method | GetPropertiesSupported()()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | (Overrides ExpandableObjectConverter..::..GetPropertiesSupported(ITypeDescriptorContext).)
Public method | GetStandardValues()()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive()()()() | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported()()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

YearPatternConverter Class


CanConvertFrom Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..CanConvertFrom Method
YearPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

YearPatternConverter Class
YearPatternConverter Members


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..CanConvertFrom Method (ITypeDescriptorContext, Type)
YearPatternConverter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
sourceType
Type: System..::..Type

See Also

YearPatternConverter Class
CanConvertFrom Overload


CanConvertTo Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..CanConvertTo Method
YearPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)

See Also

YearPatternConverter Class
YearPatternConverter Members


ConvertFrom Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..ConvertFrom Method
YearPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

YearPatternConverter Class
YearPatternConverter Members


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
YearPatternConverter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
culture
Type: System.Globalization..::..CultureInfo
value
Type: System..::..Object

See Also

YearPatternConverter Class
ConvertFrom Overload


ConvertFromInvariantString Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..ConvertFromInvariantString Method
YearPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)

See Also

YearPatternConverter Class
YearPatternConverter Members


ConvertFromString Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..ConvertFromString Method
YearPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

YearPatternConverter Class
YearPatternConverter Members


ConvertTo Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..ConvertTo Method
YearPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

YearPatternConverter Class
YearPatternConverter Members


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
YearPatternConverter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
Visual C++
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
culture
Type: System.Globalization..::..CultureInfo
value
Type: System..::..Object
destinationType
Type: System..::..Type

See Also

YearPatternConverter Class
ConvertTo Overload


ConvertToInvariantString Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..ConvertToInvariantString Method
YearPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

YearPatternConverter Class
YearPatternConverter Members


ConvertToString Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..ConvertToString Method
YearPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

YearPatternConverter Class
YearPatternConverter Members


CreateInstance Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..CreateInstance Method
YearPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | (Overrides TypeConverter..::..CreateInstance(ITypeDescriptorContext, IDictionary).)

See Also

YearPatternConverter Class
YearPatternConverter Members


CreateInstance Method (ITypeDescriptorContext, IDictionary)

[image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..CreateInstance Method (ITypeDescriptorContext, IDictionary)
YearPatternConverter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override Object CreateInstance(
    ITypeDescriptorContext context,
    IDictionary propertyValues
)
Visual Basic
Public Overrides Function CreateInstance ( _
    context As ITypeDescriptorContext, _
    propertyValues As IDictionary _
) As Object
Visual C++
public:
virtual Object^ CreateInstance(
    ITypeDescriptorContext^ context,
    IDictionary^ propertyValues
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
propertyValues
Type: System.Collections..::..IDictionary

See Also

YearPatternConverter Class
CreateInstance Overload


GetCreateInstanceSupported Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..GetCreateInstanceSupported Method
YearPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCreateInstanceSupported()()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | (Overrides TypeConverter..::..GetCreateInstanceSupported(ITypeDescriptorContext).)

See Also

YearPatternConverter Class
YearPatternConverter Members


GetCreateInstanceSupported Method (ITypeDescriptorContext)

[image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..GetCreateInstanceSupported Method (ITypeDescriptorContext)
YearPatternConverter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override bool GetCreateInstanceSupported(
    ITypeDescriptorContext context
)
Visual Basic
Public Overrides Function GetCreateInstanceSupported ( _
    context As ITypeDescriptorContext _
) As Boolean
Visual C++
public:
virtual bool GetCreateInstanceSupported(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext

See Also

YearPatternConverter Class
GetCreateInstanceSupported Overload


GetProperties Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..GetProperties Method
YearPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) | (Overrides ExpandableObjectConverter..::..GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]).)

See Also

YearPatternConverter Class
YearPatternConverter Members


GetProperties Method (ITypeDescriptorContext, Object, Attribute[])

[image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..GetProperties Method (ITypeDescriptorContext, Object, array<Attribute>[]()[][])
YearPatternConverter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override PropertyDescriptorCollection GetProperties(
    ITypeDescriptorContext context,
    Object value,
    Attribute[] attributes
)
Visual Basic
Public Overrides Function GetProperties ( _
    context As ITypeDescriptorContext, _
    value As Object, _
    attributes As Attribute() _
) As PropertyDescriptorCollection
Visual C++
public:
virtual PropertyDescriptorCollection^ GetProperties(
    ITypeDescriptorContext^ context,
    Object^ value,
    array<Attribute^>^ attributes
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
value
Type: System..::..Object
attributes
Type: array< System..::..Attribute >[]()[][]

See Also

YearPatternConverter Class
GetProperties Overload


GetPropertiesSupported Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..GetPropertiesSupported Method
YearPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPropertiesSupported()()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | (Overrides ExpandableObjectConverter..::..GetPropertiesSupported(ITypeDescriptorContext).)

See Also

YearPatternConverter Class
YearPatternConverter Members


GetPropertiesSupported Method (ITypeDescriptorContext)

[image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..GetPropertiesSupported Method (ITypeDescriptorContext)
YearPatternConverter Class See Also Send Feedback

Namespace: VIBlend.WinForms.Controls
Assembly: VIBlend.WinForms.Controls (in VIBlend.WinForms.Controls.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override bool GetPropertiesSupported(
    ITypeDescriptorContext context
)
Visual Basic
Public Overrides Function GetPropertiesSupported ( _
    context As ITypeDescriptorContext _
) As Boolean
Visual C++
public:
virtual bool GetPropertiesSupported(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext

See Also

YearPatternConverter Class
GetPropertiesSupported Overload


GetStandardValues Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..GetStandardValues Method
YearPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetStandardValues()()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)

See Also

YearPatternConverter Class
YearPatternConverter Members


GetStandardValuesExclusive Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..GetStandardValuesExclusive Method
YearPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetStandardValuesExclusive()()()() | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)

See Also

YearPatternConverter Class
YearPatternConverter Members


GetStandardValuesSupported Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..GetStandardValuesSupported Method
YearPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetStandardValuesSupported()()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)

See Also

YearPatternConverter Class
YearPatternConverter Members


IsValid Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
YearPatternConverter..::..IsValid Method
YearPatternConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

YearPatternConverter Class
YearPatternConverter Members


VIBlend.WinForms.DataGridView Namespace

[image]

VIBlend Controls for WinForms Help Documentation
VIBlend.WinForms.DataGridView Namespace
Send Feedback

Classes

 | Class | Description
Public class | BindingProgressEventArgs | Represents a data binding progress event arguments
Public class | BoundField | Represents a data binding relationship between a column in the data source, and a HierarchyItem
Public class | BoundFieldEventArgs | Represents an event argument for HierarchyItem data binding event.
Public class | BoundFieldFilter | Represents a data field filter used during the data binding process
Public class | BoundItemsCollection<(Of <(<'T>)>)> | Represents a list of BoundField or BoundValueField items which represent data binding assiciations between columns in the data source and HierarchyItems in the data grid
Public class | BoundValueField | Represents a data binding relationship between a column in the data source, and a Summary HierarchyItem which specifies a Pivot table value item
Public class | ButtonEditor | Represents a ButtonEditor used in the GridView control
Public class | CellCancelEventArgs | Represents a GridView grid cell cancel event argument
Public class | CellEventArgs | Represents a GridView grid cell event argument
Public class | CellMouseEventArgs | Represents a GridView grid cell mouse event argument
Public class | CellPaintEventArgs | Represents a GridView grid cell paint event argument
Public class | CellParsingEventArgs | Represents a grid cell parsing event argument
Public class | CellsArea | Represents the data grid's cell area
Public class | CellsArea..::..ConditionalFormattingGroup | Represents a conditional formatting group
Public class | CellValueChangingEventArgs | Represents a DataGridView grid cell value change event arguments.
Public class | CellValueNeededEventArgs | Represents a data grid value need event arguments
Public class | CheckBoxEditor | Represents a CheckBoxEditor used in the GridView control
Public class | CollectionChangedEventArgs |
Public class | ColumnChooser |
Public class | ColumnsHierarchy | Represents a ColumnsHierarchy
Public class | ComboBoxEditor | Represents a ComboBoxEditor used in the GridView control
Public class | CurrencyEditor |
Public class | DataGridGroupHeaderItem |
Public class | DataGridLocalization |
Public class | DataGridLocalizationBase | Represents a base class for the DataGrid localization providers.
Public class | DateTimePickerEditor | Represents a DateTimePickerEditor used in the GridView control
Public class | EditorActivationCancelEventArgs | Represents Grid cell editor activation event arguments that supports event canceling.
Public class | FixedPointEditor |
Public class | GridCell | Defines an grid cell inside the CellsArea
Public class | GridToolTipEventArgs | Represents a GridView ToolTip event argument
Public class | GroupHeaderDragCancelEventArgs |
Public class | GroupHeaderDragEventArgs |
Public class | Hierarchy | Represents a base class for a Hierarchy which hosts one or more row, or column items
Public class | HierarchyItem | Represents a item in the rows or columns header area of the data grid
Public class | HierarchyItemCancelEventArgs | Represents a HierarchyItem cancel event argument
Public class | HierarchyItemDragCancelEventArgs | Represents a HierarchyItem drag cancel event argument
Public class | HierarchyItemDragEventArgs | Represents a grid HierarchyItem drag event argument
Public class | HierarchyItemEventArgs | Represents a HierarchyItem event argument
Public class | HierarchyItemMouseEventArgs | Represents a HierarchyItem mouse event argument.
Public class | HierarchyItemPaintEventArgs | Represents a HierarchyItem paint event argument
Public class | HierarchyItemsCollection | Represents a collection of HierarchyItems
Public class | MaskEditor | Represents a Mask Editor.
Public class | NumberEditor |
Public class | NumericUpDownEditor | Represents a NumericUpDownEditor used in the GridView control
Public class | PercentageEditor |
Public class | PivotDesignPanelLocalization |
Public class | PivotDesignPanelLocalizationBase | Represents a base class for the DataGrid localization providers.
Public class | PivotValueFieldTextNeededEventArgs | Represents PivotValueFieldNameNeeded event arguments.
Public class | ProgressBarEditor | Represents a ProgressBarEditor used in the GridView control
Public class | RowsHierarchy | Represents a Rows Hierarchy
Public class | TextBoxEditor | Represents a TextBoxEditor used in the GridView control
Public class | TrackBarEditor | Represents a vTrackBarEditor used in the GridView control
Public class | vDataGridView | Represents a GridView control
Public class | vDataGridView..::..CellKeyEventArgs |
Public class | vDataGridView..::..GroupHeaderCustomTextNeededEventArgs | Represents a group header custom text needed event arguments.
Public class | vDataGridViewGroupsHeader |
Public class | vDataGridViewPivotDesign |

Structures

 | Structure | Description
Public structure | CellSpan | Defines a Cell span / cell merge inside the data grid's cells area (CellsArea)
Public structure | HierarchyItemFilter |

Interfaces

 | Interface | Description
Public interface | IEditor | Grid cell editor interface definition

Delegates

 | Delegate | Description
Public delegate | PivotValueFieldTextNeededEventHandler |
Public delegate | vDataGridView..::..BindingProgressFormatEventHandler |
Public delegate | vDataGridView..::..CellCancelEventHandler |
Public delegate | vDataGridView..::..CellEditorActivateEventHandler |
Public delegate | vDataGridView..::..CellEventHandler |
Public delegate | vDataGridView..::..CellMouseEventHandler |
Public delegate | vDataGridView..::..CellPaintEventHandler |
Public delegate | vDataGridView..::..CellParsingEventHandler |
Public delegate | vDataGridView..::..CellValueChangingEventHandler |
Public delegate | vDataGridView..::..CellValueNeededEventHandler |
Public delegate | vDataGridView..::..DataBindingCompleteEventHandler |
Public delegate | vDataGridView..::..DataBindingStartEventHandler |
Public delegate | vDataGridView..::..GridBindField |
Public delegate | vDataGridView..::..GridGroupHeaderCustomTextNeededEventHandler |
Public delegate | vDataGridView..::..GridTooltipEventHandler |
Public delegate | vDataGridView..::..HierarchyItemCancelEventHandler |
Public delegate | vDataGridView..::..HierarchyItemDragCancelEventHandler |
Public delegate | vDataGridView..::..HierarchyItemDragEventHandler |
Public delegate | vDataGridView..::..HierarchyItemEventHandler |
Public delegate | vDataGridView..::..HierarchyItemMouseEventHandler |
Public delegate | vDataGridView..::..HierarchyItemPaintEventHandler |

Enumerations

 | Enumeration | Description
Public enumeration | AutoResizeMode | Enumeration of the Auto resize modes
Public enumeration | CellEditorType | Specifies a grid cell editor type
Public enumeration | CollectionChangedReason |
Public enumeration | DisplaySettings | Grid Cell Image display settings
Public enumeration | EditorActivationFlags | Enumaration of the grid editor activation flags
Public enumeration | FilterDisplayMode | Represents the FilterDisplayMode enum.
Public enumeration | GridBindingState | Enumaration of the grid's binding states
Public enumeration | GridCellCFColorScale | Default GridCell color scales
Public enumeration | GridCellDataSource | Grid Cell data source enumeration
Public enumeration | GridItemSortMode | Enumeration of the grid item sort modes
Public enumeration | GridLinesDisplayMode | Enumeration of the grid lines display modes
Public enumeration | HeaderGroupsAlignment |
Public enumeration | ImagePositions | Image positioning options
Public enumeration | LocalizationNames | Represents the LocalizationNames enumeration.
Public enumeration | PivotDesignLocalizationNames | Represents the LocalizationNames enumeration.
Public enumeration | PivotFieldFunction | Represents an aggregation function which will be used to calculate the value of a grid cell when the grid is bound to a data source in a pivot table mode
Public enumeration | PivotTotalsMode | Enumeration of the Pivot Table totals display modes.
Public enumeration | SortingDirection | Enumeration of the sorting directions.
Protected enumeration | vDataGridView..::..CURSOR_TYPE |
Public enumeration | vDataGridView..::..SELECTION_MODE | Enumeration of the grid cells selection mode


AutoResizeMode Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
AutoResizeMode Enumeration
See Also Send Feedback
Enumeration of the Auto resize modes

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum AutoResizeMode
Visual Basic
Public Enumeration AutoResizeMode
Visual C++
public enum class AutoResizeMode

Members

Member name | Description
FIT_ITEM_CONTENT |
FIT_CELL_CONTENT |
FIT_ALL |

See Also

VIBlend.WinForms.DataGridView Namespace


BindingProgressEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
BindingProgressEventArgs Class
Members See Also Send Feedback
Represents a data binding progress event arguments

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class BindingProgressEventArgs
Visual Basic
Public Class BindingProgressEventArgs
Visual C++
public ref class BindingProgressEventArgs

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..BindingProgressEventArgs

See Also

BindingProgressEventArgs Members
VIBlend.WinForms.DataGridView Namespace


BindingProgressEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
BindingProgressEventArgs Members
BindingProgressEventArgs Class Constructors Methods Properties See Also Send Feedback

The BindingProgressEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | BindingProgressEventArgs | BindingProgressEventArgs constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ProgressPercentage |
Public property | RecordsCount |
Public property | RecordsProcessed |

See Also

BindingProgressEventArgs Class
VIBlend.WinForms.DataGridView Namespace


BindingProgressEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
BindingProgressEventArgs Constructor
BindingProgressEventArgs Class See Also Send Feedback
BindingProgressEventArgs constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BindingProgressEventArgs(
    int recordsProcessed,
    int recordsCount
)
Visual Basic
Public Sub New ( _
    recordsProcessed As Integer, _
    recordsCount As Integer _
)
Visual C++
public:
BindingProgressEventArgs(
    int recordsProcessed,
    int recordsCount
)

Parameters

recordsProcessed
Type: System..::..Int32
recordsCount
Type: System..::..Int32

See Also

BindingProgressEventArgs Class
VIBlend.WinForms.DataGridView Namespace


BindingProgressEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
BindingProgressEventArgs Methods
BindingProgressEventArgs Class See Also Send Feedback

The BindingProgressEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BindingProgressEventArgs Class
VIBlend.WinForms.DataGridView Namespace


BindingProgressEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
BindingProgressEventArgs Properties
BindingProgressEventArgs Class See Also Send Feedback

The BindingProgressEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ProgressPercentage |
Public property | RecordsCount |
Public property | RecordsProcessed |

See Also

BindingProgressEventArgs Class
VIBlend.WinForms.DataGridView Namespace


ProgressPercentage Property

[image]

VIBlend Controls for WinForms Help Documentation
BindingProgressEventArgs..::..ProgressPercentage Property
BindingProgressEventArgs Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public double ProgressPercentage { get; }
Visual Basic
Public ReadOnly Property ProgressPercentage As Double
    Get
Visual C++
public:
property double ProgressPercentage {
    double get ();
}

See Also

BindingProgressEventArgs Class
VIBlend.WinForms.DataGridView Namespace


RecordsCount Property

[image]

VIBlend Controls for WinForms Help Documentation
BindingProgressEventArgs..::..RecordsCount Property
BindingProgressEventArgs Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int RecordsCount { get; set; }
Visual Basic
Public Property RecordsCount As Integer
    Get
    Set
Visual C++
public:
property int RecordsCount {
    int get ();
    void set (int value);
}

See Also

BindingProgressEventArgs Class
VIBlend.WinForms.DataGridView Namespace


RecordsProcessed Property

[image]

VIBlend Controls for WinForms Help Documentation
BindingProgressEventArgs..::..RecordsProcessed Property
BindingProgressEventArgs Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int RecordsProcessed { get; set; }
Visual Basic
Public Property RecordsProcessed As Integer
    Get
    Set
Visual C++
public:
property int RecordsProcessed {
    int get ();
    void set (int value);
}

See Also

BindingProgressEventArgs Class
VIBlend.WinForms.DataGridView Namespace


BoundField Class

[image]

VIBlend Controls for WinForms Help Documentation
BoundField Class
Members See Also Send Feedback
Represents a data binding relationship between a column in the data source, and a HierarchyItem

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class BoundField
Visual Basic
Public Class BoundField
Visual C++
public ref class BoundField

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..BoundField
VIBlend.WinForms.DataGridView..::..BoundValueField

See Also

BoundField Members
VIBlend.WinForms.DataGridView Namespace


BoundField Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
BoundField Members
BoundField Class Constructors Methods Properties See Also Send Feedback

The BoundField type exposes the following members.

Constructors

 | Name | Description
Public method | BoundField()()()() | BoundField constructor.
Public method | BoundField(String, String) | BoundField constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowFiltering | Gets or sets if the HierarchyItems bound to this field are filterable.
Public property | CellsDisplaySettings | Gets or sets the grid cells display settings of the HierarchyItems bound to this field.
Public property | CellsEditor | Gets or sets the grid cells in-place editor of the HierarchyItems bound to this field
Public property | CellsFormatProvider | Gets or sets the grid cells FormatProvider of the HierarchyItems bound to this field.
Public property | CellsFormatString | Gets or sets the grid cells Format string of the HierarchyItems bound to this field.
Public property | CellsImageAlignment | Gets or sets the grid cells image alignment of the HierarchyItems bound to this field.
Public property | CellsStyle | Gets or sets the grid cells style of the HierarchyItems bound to this field
Public property | CellsTextAlignment | Gets or sets the grid cells text alignment property of the HierarchyItems bound to this field.
Public property | CellsTextImageRelation | Gets or sets the grid cells text and image relation property of the HierarchyItems bound to this field.
Public property | CellsTextWrap | Gets or sets the grid cells text wrap property of the HierarchyItems bound to this field.
Public property | DataField | The name of the column from the data source
Public property | Resizable | Gets or sets whether HierarchyItems bound to this field are resizable.
Public property | SortMode | Gets or sets if the HierarchyItems bound to this field are sortable.
Public property | Text | The text (caption) of the HierarchyItem
Public property | TextWrap | Gets or sets the TextWrap property of HierarchyItems bound to this field.
Public property | Width | Gets or sets the Width of the HierarchyItems bound to this field

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


BoundField Constructor

[image] [image]

VIBlend Controls for WinForms Help Documentation
BoundField Constructor
BoundField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BoundField()()()() | BoundField constructor.
Public method | BoundField(String, String) | BoundField constructor.

See Also

BoundField Class
BoundField Members
VIBlend.WinForms.DataGridView Namespace


BoundField Constructor

[image]

VIBlend Controls for WinForms Help Documentation
BoundField Constructor
BoundField Class See Also Send Feedback
BoundField constructor.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BoundField()
Visual Basic
Public Sub New
Visual C++
public:
BoundField()

See Also

BoundField Class
BoundField Overload
VIBlend.WinForms.DataGridView Namespace


BoundField Constructor (String, String)

[image]

VIBlend Controls for WinForms Help Documentation
BoundField Constructor (String, String)
BoundField Class See Also Send Feedback
BoundField constructor.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BoundField(
    string text,
    string dataField
)
Visual Basic
Public Sub New ( _
    text As String, _
    dataField As String _
)
Visual C++
public:
BoundField(
    String^ text,
    String^ dataField
)

Parameters

text
Type: System..::..String
The test to display in the HierarchyItem.
dataField
Type: System..::..String
DataField to bind to.

See Also

BoundField Class
BoundField Overload
VIBlend.WinForms.DataGridView Namespace


BoundField Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
BoundField Methods
BoundField Class See Also Send Feedback

The BoundField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


BoundField Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
BoundField Properties
BoundField Class See Also Send Feedback

The BoundField type exposes the following members.

Properties

 | Name | Description
Public property | AllowFiltering | Gets or sets if the HierarchyItems bound to this field are filterable.
Public property | CellsDisplaySettings | Gets or sets the grid cells display settings of the HierarchyItems bound to this field.
Public property | CellsEditor | Gets or sets the grid cells in-place editor of the HierarchyItems bound to this field
Public property | CellsFormatProvider | Gets or sets the grid cells FormatProvider of the HierarchyItems bound to this field.
Public property | CellsFormatString | Gets or sets the grid cells Format string of the HierarchyItems bound to this field.
Public property | CellsImageAlignment | Gets or sets the grid cells image alignment of the HierarchyItems bound to this field.
Public property | CellsStyle | Gets or sets the grid cells style of the HierarchyItems bound to this field
Public property | CellsTextAlignment | Gets or sets the grid cells text alignment property of the HierarchyItems bound to this field.
Public property | CellsTextImageRelation | Gets or sets the grid cells text and image relation property of the HierarchyItems bound to this field.
Public property | CellsTextWrap | Gets or sets the grid cells text wrap property of the HierarchyItems bound to this field.
Public property | DataField | The name of the column from the data source
Public property | Resizable | Gets or sets whether HierarchyItems bound to this field are resizable.
Public property | SortMode | Gets or sets if the HierarchyItems bound to this field are sortable.
Public property | Text | The text (caption) of the HierarchyItem
Public property | TextWrap | Gets or sets the TextWrap property of HierarchyItems bound to this field.
Public property | Width | Gets or sets the Width of the HierarchyItems bound to this field

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


AllowFiltering Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundField..::..AllowFiltering Property
BoundField Class See Also Send Feedback
Gets or sets if the HierarchyItems bound to this field are filterable.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowFiltering { get; set; }
Visual Basic
Public Property AllowFiltering As Boolean
    Get
    Set
Visual C++
public:
property bool AllowFiltering {
    bool get ();
    void set (bool value);
}

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


CellsDisplaySettings Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundField..::..CellsDisplaySettings Property
BoundField Class See Also Send Feedback
Gets or sets the grid cells display settings of the HierarchyItems bound to this field.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DisplaySettings CellsDisplaySettings { get; set; }
Visual Basic
Public Property CellsDisplaySettings As DisplaySettings
    Get
    Set
Visual C++
public:
property DisplaySettings CellsDisplaySettings {
    DisplaySettings get ();
    void set (DisplaySettings value);
}

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


CellsEditor Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundField..::..CellsEditor Property
BoundField Class See Also Send Feedback
Gets or sets the grid cells in-place editor of the HierarchyItems bound to this field

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public IEditor CellsEditor { get; set; }
Visual Basic
Public Property CellsEditor As IEditor
    Get
    Set
Visual C++
public:
property IEditor^ CellsEditor {
    IEditor^ get ();
    void set (IEditor^ value);
}

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


CellsFormatProvider Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundField..::..CellsFormatProvider Property
BoundField Class See Also Send Feedback
Gets or sets the grid cells FormatProvider of the HierarchyItems bound to this field.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public IFormatProvider CellsFormatProvider { get; set; }
Visual Basic
Public Property CellsFormatProvider As IFormatProvider
    Get
    Set
Visual C++
public:
property IFormatProvider^ CellsFormatProvider {
    IFormatProvider^ get ();
    void set (IFormatProvider^ value);
}

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


CellsFormatString Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundField..::..CellsFormatString Property
BoundField Class See Also Send Feedback
Gets or sets the grid cells Format string of the HierarchyItems bound to this field.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string CellsFormatString { get; set; }
Visual Basic
Public Property CellsFormatString As String
    Get
    Set
Visual C++
public:
property String^ CellsFormatString {
    String^ get ();
    void set (String^ value);
}

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


CellsImageAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundField..::..CellsImageAlignment Property
BoundField Class See Also Send Feedback
Gets or sets the grid cells image alignment of the HierarchyItems bound to this field.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment CellsImageAlignment { get; set; }
Visual Basic
Public Property CellsImageAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment CellsImageAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


CellsStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundField..::..CellsStyle Property
BoundField Class See Also Send Feedback
Gets or sets the grid cells style of the HierarchyItems bound to this field

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCellStyle CellsStyle { get; set; }
Visual Basic
Public Property CellsStyle As GridCellStyle
    Get
    Set
Visual C++
public:
property GridCellStyle^ CellsStyle {
    GridCellStyle^ get ();
    void set (GridCellStyle^ value);
}

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


CellsTextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundField..::..CellsTextAlignment Property
BoundField Class See Also Send Feedback
Gets or sets the grid cells text alignment property of the HierarchyItems bound to this field.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment CellsTextAlignment { get; set; }
Visual Basic
Public Property CellsTextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment CellsTextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


CellsTextImageRelation Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundField..::..CellsTextImageRelation Property
BoundField Class See Also Send Feedback
Gets or sets the grid cells text and image relation property of the HierarchyItems bound to this field.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public TextImageRelation CellsTextImageRelation { get; set; }
Visual Basic
Public Property CellsTextImageRelation As TextImageRelation
    Get
    Set
Visual C++
public:
property TextImageRelation CellsTextImageRelation {
    TextImageRelation get ();
    void set (TextImageRelation value);
}

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


CellsTextWrap Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundField..::..CellsTextWrap Property
BoundField Class See Also Send Feedback
Gets or sets the grid cells text wrap property of the HierarchyItems bound to this field.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool CellsTextWrap { get; set; }
Visual Basic
Public Property CellsTextWrap As Boolean
    Get
    Set
Visual C++
public:
property bool CellsTextWrap {
    bool get ();
    void set (bool value);
}

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


DataField Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundField..::..DataField Property
BoundField Class See Also Send Feedback
The name of the column from the data source

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string DataField { get; set; }
Visual Basic
Public Property DataField As String
    Get
    Set
Visual C++
public:
property String^ DataField {
    String^ get ();
    void set (String^ value);
}

Remarks

When you bind to a database table, this property should be set to the name of the column that you want to bind. If you want to bind to a list of objects, the value of this property should match the name of an object's public property which you want to bind. Note that the value of this property is case sensitive

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


Resizable Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundField..::..Resizable Property
BoundField Class See Also Send Feedback
Gets or sets whether HierarchyItems bound to this field are resizable.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Resizable { get; set; }
Visual Basic
Public Property Resizable As Boolean
    Get
    Set
Visual C++
public:
property bool Resizable {
    bool get ();
    void set (bool value);
}

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


SortMode Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundField..::..SortMode Property
BoundField Class See Also Send Feedback
Gets or sets if the HierarchyItems bound to this field are sortable.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridItemSortMode SortMode { get; set; }
Visual Basic
Public Property SortMode As GridItemSortMode
    Get
    Set
Visual C++
public:
property GridItemSortMode SortMode {
    GridItemSortMode get ();
    void set (GridItemSortMode value);
}

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundField..::..Text Property
BoundField Class See Also Send Feedback
The text (caption) of the HierarchyItem

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


TextWrap Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundField..::..TextWrap Property
BoundField Class See Also Send Feedback
Gets or sets the TextWrap property of HierarchyItems bound to this field.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool TextWrap { get; set; }
Visual Basic
Public Property TextWrap As Boolean
    Get
    Set
Visual C++
public:
property bool TextWrap {
    bool get ();
    void set (bool value);
}

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


Width Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundField..::..Width Property
BoundField Class See Also Send Feedback
Gets or sets the Width of the HierarchyItems bound to this field

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Width { get; set; }
Visual Basic
Public Property Width As Integer
    Get
    Set
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

See Also

BoundField Class
VIBlend.WinForms.DataGridView Namespace


BoundFieldEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
BoundFieldEventArgs Class
Members See Also Send Feedback
Represents an event argument for HierarchyItem data binding event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class BoundFieldEventArgs : EventArgs
Visual Basic
Public Class BoundFieldEventArgs _
    Inherits EventArgs
Visual C++
public ref class BoundFieldEventArgs : public EventArgs

Remarks

GridView triggers HierarchyItem data binding events when a column from the data source is being bound. These events are useful when the user wants to intercept the data binding process for perticular fields and configure the properties of the respective HierarchyItem. For example, you can use this event to associate the data bound HierarchyItem with a grid cell editor, specify data formatting rules, text alignment properties and more.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.DataGridView..::..BoundFieldEventArgs

See Also

BoundFieldEventArgs Members
VIBlend.WinForms.DataGridView Namespace


BoundFieldEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
BoundFieldEventArgs Members
BoundFieldEventArgs Class Constructors Methods Properties See Also Send Feedback

The BoundFieldEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | BoundFieldEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BoundField | Reference to the BoundField
Public property | BoundFieldIndex | Gets the index of corresponding row or column in the data source.
Public property | GridControl | Reference to the grid control
Public property | HierarchyItem | Reference to the HierarchyItem

See Also

BoundFieldEventArgs Class
VIBlend.WinForms.DataGridView Namespace


BoundFieldEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
BoundFieldEventArgs Constructor
BoundFieldEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BoundFieldEventArgs(
    HierarchyItem hierarchyItem,
    BoundField boundField,
    vDataGridView gridControl
)
Visual Basic
Public Sub New ( _
    hierarchyItem As HierarchyItem, _
    boundField As BoundField, _
    gridControl As vDataGridView _
)
Visual C++
public:
BoundFieldEventArgs(
    HierarchyItem^ hierarchyItem,
    BoundField^ boundField,
    vDataGridView^ gridControl
)

Parameters

hierarchyItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The BoundField HierarchyItem
boundField
Type: VIBlend.WinForms.DataGridView..::..BoundField
The BoundField
gridControl
Type: VIBlend.WinForms.DataGridView..::..vDataGridView
The GridControl

See Also

BoundFieldEventArgs Class
VIBlend.WinForms.DataGridView Namespace


BoundFieldEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
BoundFieldEventArgs Methods
BoundFieldEventArgs Class See Also Send Feedback

The BoundFieldEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundFieldEventArgs Class
VIBlend.WinForms.DataGridView Namespace


BoundFieldEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
BoundFieldEventArgs Properties
BoundFieldEventArgs Class See Also Send Feedback

The BoundFieldEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | BoundField | Reference to the BoundField
Public property | BoundFieldIndex | Gets the index of corresponding row or column in the data source.
Public property | GridControl | Reference to the grid control
Public property | HierarchyItem | Reference to the HierarchyItem

See Also

BoundFieldEventArgs Class
VIBlend.WinForms.DataGridView Namespace


BoundField Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundFieldEventArgs..::..BoundField Property
BoundFieldEventArgs Class See Also Send Feedback
Reference to the BoundField

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BoundField BoundField { get; }
Visual Basic
Public ReadOnly Property BoundField As BoundField
    Get
Visual C++
public:
property BoundField^ BoundField {
    BoundField^ get ();
}

See Also

BoundFieldEventArgs Class
VIBlend.WinForms.DataGridView Namespace


BoundFieldIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundFieldEventArgs..::..BoundFieldIndex Property
BoundFieldEventArgs Class See Also Send Feedback
Gets the index of corresponding row or column in the data source.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int BoundFieldIndex { get; }
Visual Basic
Public ReadOnly Property BoundFieldIndex As Integer
    Get
Visual C++
public:
property int BoundFieldIndex {
    int get ();
}

See Also

BoundFieldEventArgs Class
VIBlend.WinForms.DataGridView Namespace


GridControl Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundFieldEventArgs..::..GridControl Property
BoundFieldEventArgs Class See Also Send Feedback
Reference to the grid control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDataGridView GridControl { get; }
Visual Basic
Public ReadOnly Property GridControl As vDataGridView
    Get
Visual C++
public:
property vDataGridView^ GridControl {
    vDataGridView^ get ();
}

See Also

BoundFieldEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItem Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundFieldEventArgs..::..HierarchyItem Property
BoundFieldEventArgs Class See Also Send Feedback
Reference to the HierarchyItem

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem HierarchyItem { get; }
Visual Basic
Public ReadOnly Property HierarchyItem As HierarchyItem
    Get
Visual C++
public:
property HierarchyItem^ HierarchyItem {
    HierarchyItem^ get ();
}

See Also

BoundFieldEventArgs Class
VIBlend.WinForms.DataGridView Namespace


BoundFieldFilter Class

[image]

VIBlend Controls for WinForms Help Documentation
BoundFieldFilter Class
Members See Also Send Feedback
Represents a data field filter used during the data binding process

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class BoundFieldFilter
Visual Basic
Public Class BoundFieldFilter
Visual C++
public ref class BoundFieldFilter

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..BoundFieldFilter

See Also

BoundFieldFilter Members
VIBlend.WinForms.DataGridView Namespace


BoundFieldFilter Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
BoundFieldFilter Members
BoundFieldFilter Class Constructors Methods Properties See Also Send Feedback

The BoundFieldFilter type exposes the following members.

Constructors

 | Name | Description
Public method | BoundFieldFilter | BoundFieldFilter constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataField | The name of the column from the data source
Public property | Filters | Collection of filters applied to the DataField

See Also

BoundFieldFilter Class
VIBlend.WinForms.DataGridView Namespace


BoundFieldFilter Constructor

[image]

VIBlend Controls for WinForms Help Documentation
BoundFieldFilter Constructor
BoundFieldFilter Class See Also Send Feedback
BoundFieldFilter constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BoundFieldFilter()
Visual Basic
Public Sub New
Visual C++
public:
BoundFieldFilter()

See Also

BoundFieldFilter Class
VIBlend.WinForms.DataGridView Namespace


BoundFieldFilter Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
BoundFieldFilter Methods
BoundFieldFilter Class See Also Send Feedback

The BoundFieldFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundFieldFilter Class
VIBlend.WinForms.DataGridView Namespace


BoundFieldFilter Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
BoundFieldFilter Properties
BoundFieldFilter Class See Also Send Feedback

The BoundFieldFilter type exposes the following members.

Properties

 | Name | Description
Public property | DataField | The name of the column from the data source
Public property | Filters | Collection of filters applied to the DataField

See Also

BoundFieldFilter Class
VIBlend.WinForms.DataGridView Namespace


DataField Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundFieldFilter..::..DataField Property
BoundFieldFilter Class See Also Send Feedback
The name of the column from the data source

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string DataField { get; set; }
Visual Basic
Public Property DataField As String
    Get
    Set
Visual C++
public:
property String^ DataField {
    String^ get ();
    void set (String^ value);
}

Remarks

When you bind to a database table, this property should be set to the name of the column that you want to bind. If you want to bind to a list of objects, the value of this property should match the name of an object's public property which you want to bind. Note that the value of this property is case sensitive

See Also

BoundFieldFilter Class
VIBlend.WinForms.DataGridView Namespace


Filters Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundFieldFilter..::..Filters Property
BoundFieldFilter Class See Also Send Feedback
Collection of filters applied to the DataField

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<IFilterBase> Filters { get; private set; }
Visual Basic
Public Property Filters As List(Of IFilterBase)
    Get
    Private Set
Visual C++
public:
property List<IFilterBase^>^ Filters {
    List<IFilterBase^>^ get ();
    private: void set (List<IFilterBase^>^ value);
}

See Also

BoundFieldFilter Class
VIBlend.WinForms.DataGridView Namespace


BoundItemsCollection(T) Class

[image]

VIBlend Controls for WinForms Help Documentation
BoundItemsCollection<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Represents a list of BoundField or BoundValueField items which represent data binding assiciations between columns in the data source and HierarchyItems in the data grid

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[SerializableAttribute]
public class BoundItemsCollection<T> : IEnumerable<T>,
    IList, ICollection, IEnumerable
Visual Basic
<SerializableAttribute> _
Public Class BoundItemsCollection(Of T) _
    Implements IEnumerable(Of T), IList, ICollection,  _
    IEnumerable
Visual C++
[SerializableAttribute]
generic<typename T>
public ref class BoundItemsCollection : IEnumerable<T>,
    IList, ICollection, IEnumerable

Type Parameters

T

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..BoundItemsCollection<(Of <(<'T>)>)>

See Also

BoundItemsCollection<(Of <(<'T>)>)> Members
VIBlend.WinForms.DataGridView Namespace


BoundItemsCollection(T) Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
BoundItemsCollection<(Of <(<'T>)>)> Members
BoundItemsCollection<(Of <(<'T>)>)> Class Constructors Methods Properties Events See Also Send Feedback

The BoundItemsCollection<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | BoundItemsCollection<(Of <(<'T>)>)> | Initializes a new instance of the BoundItemsCollection<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | Add | Adds an item to the collection
Public method | Clear | Removes all items form the collection
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator to support iterating through the collection
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of an item
Public method | Insert | Inserts an item at a specific position
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes an item from the collection
Public method | RemoveAt | Removes an item located at a specific index
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Returns the number of items in the collection
Public property | Item | Returns a reference to a item located at a specific index

Events

 | Name | Description
Public event | CollectionChanged | Occurs when the collection has changed

See Also

BoundItemsCollection<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView Namespace


BoundItemsCollection(T) Constructor

[image]

VIBlend Controls for WinForms Help Documentation
BoundItemsCollection<(Of <(<'T>)>)> Constructor
BoundItemsCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the BoundItemsCollection<(Of <(<'T>)>)> class

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BoundItemsCollection()
Visual Basic
Public Sub New
Visual C++
public:
BoundItemsCollection()

See Also

BoundItemsCollection<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView Namespace


BoundItemsCollection(T) Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
BoundItemsCollection<(Of <(<'T>)>)> Methods
BoundItemsCollection<(Of <(<'T>)>)> Class See Also Send Feedback

The BoundItemsCollection<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the collection
Public method | Clear | Removes all items form the collection
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator to support iterating through the collection
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of an item
Public method | Insert | Inserts an item at a specific position
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes an item from the collection
Public method | RemoveAt | Removes an item located at a specific index
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundItemsCollection<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView Namespace


Add Method

[image]

VIBlend Controls for WinForms Help Documentation
BoundItemsCollection<(Of <(<'T>)>)>..::..Add Method
BoundItemsCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Adds an item to the collection

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual T Add(
    T item
)
Visual Basic
Public Overridable Function Add ( _
    item As T _
) As T
Visual C++
public:
virtual T Add(
    T item
)

Parameters

item
Type: T

See Also

BoundItemsCollection<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView Namespace


Clear Method

[image]

VIBlend Controls for WinForms Help Documentation
BoundItemsCollection<(Of <(<'T>)>)>..::..Clear Method
BoundItemsCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Removes all items form the collection

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

BoundItemsCollection<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView Namespace


Contains Method

[image]

VIBlend Controls for WinForms Help Documentation
BoundItemsCollection<(Of <(<'T>)>)>..::..Contains Method
BoundItemsCollection<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool Contains(
    T item
)
Visual Basic
Public Overridable Function Contains ( _
    item As T _
) As Boolean
Visual C++
public:
virtual bool Contains(
    T item
)

Parameters

item
Type: T

See Also

BoundItemsCollection<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView Namespace


GetEnumerator Method

[image]

VIBlend Controls for WinForms Help Documentation
BoundItemsCollection<(Of <(<'T>)>)>..::..GetEnumerator Method
BoundItemsCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Returns an enumerator to support iterating through the collection

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual IEnumerator<T> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of T)
Visual C++
public:
virtual IEnumerator<T>^ GetEnumerator()

See Also

BoundItemsCollection<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView Namespace


IndexOf Method

[image]

VIBlend Controls for WinForms Help Documentation
BoundItemsCollection<(Of <(<'T>)>)>..::..IndexOf Method
BoundItemsCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Returns the index of an item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual int IndexOf(
    T item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As T _
) As Integer
Visual C++
public:
virtual int IndexOf(
    T item
)

Parameters

item
Type: T

See Also

BoundItemsCollection<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView Namespace


Insert Method

[image]

VIBlend Controls for WinForms Help Documentation
BoundItemsCollection<(Of <(<'T>)>)>..::..Insert Method
BoundItemsCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Inserts an item at a specific position

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void Insert(
    T item,
    int i
)
Visual Basic
Public Overridable Sub Insert ( _
    item As T, _
    i As Integer _
)
Visual C++
public:
virtual void Insert(
    T item,
    int i
)

Parameters

item
Type: T
i
Type: System..::..Int32

See Also

BoundItemsCollection<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView Namespace


Remove Method

[image]

VIBlend Controls for WinForms Help Documentation
BoundItemsCollection<(Of <(<'T>)>)>..::..Remove Method
BoundItemsCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Removes an item from the collection

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void Remove(
    T item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As T _
)
Visual C++
public:
virtual void Remove(
    T item
)

Parameters

item
Type: T

See Also

BoundItemsCollection<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView Namespace


RemoveAt Method

[image]

VIBlend Controls for WinForms Help Documentation
BoundItemsCollection<(Of <(<'T>)>)>..::..RemoveAt Method
BoundItemsCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Removes an item located at a specific index

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32

See Also

BoundItemsCollection<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView Namespace


BoundItemsCollection(T) Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
BoundItemsCollection<(Of <(<'T>)>)> Properties
BoundItemsCollection<(Of <(<'T>)>)> Class See Also Send Feedback

The BoundItemsCollection<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Count | Returns the number of items in the collection
Public property | Item | Returns a reference to a item located at a specific index

See Also

BoundItemsCollection<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView Namespace


Count Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundItemsCollection<(Of <(<'T>)>)>..::..Count Property
BoundItemsCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Returns the number of items in the collection

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Implements

ICollection..::..Count

See Also

BoundItemsCollection<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView Namespace


Item Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundItemsCollection<(Of <(<'T>)>)>..::..Item Property
BoundItemsCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Returns a reference to a item located at a specific index

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual T this[
    int i
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    i As Integer _
) As T
    Get
    Set
Visual C++
public:
virtual property T default[int i] {
    T get (int i);
    void set (int i, T value);
}

Parameters

i
Type: System..::..Int32

See Also

BoundItemsCollection<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView Namespace


BoundItemsCollection(T) Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
BoundItemsCollection<(Of <(<'T>)>)> Events
BoundItemsCollection<(Of <(<'T>)>)> Class See Also Send Feedback

The BoundItemsCollection<(Of <(<'T>)>)> type exposes the following members.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when the collection has changed

See Also

BoundItemsCollection<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView Namespace


CollectionChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
BoundItemsCollection<(Of <(<'T>)>)>..::..CollectionChanged Event
BoundItemsCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Occurs when the collection has changed

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<CollectionChangedEventArgs> CollectionChanged
Visual Basic
Public Event CollectionChanged As EventHandler(Of CollectionChangedEventArgs)
Visual C++
public:
 event EventHandler<CollectionChangedEventArgs^>^ CollectionChanged {
    void add (EventHandler<CollectionChangedEventArgs^>^ value);
    void remove (EventHandler<CollectionChangedEventArgs^>^ value);
}

See Also

BoundItemsCollection<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView Namespace


BoundValueField Class

[image]

VIBlend Controls for WinForms Help Documentation
BoundValueField Class
Members See Also Send Feedback
Represents a data binding relationship between a column in the data source, and a Summary HierarchyItem which specifies a Pivot table value item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class BoundValueField : BoundField
Visual Basic
Public Class BoundValueField _
    Inherits BoundField
Visual C++
public ref class BoundValueField : public BoundField

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..BoundField
VIBlend.WinForms.DataGridView..::..BoundValueField

See Also

BoundValueField Members
VIBlend.WinForms.DataGridView Namespace


BoundValueField Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
BoundValueField Members
BoundValueField Class Constructors Methods Properties See Also Send Feedback

The BoundValueField type exposes the following members.

Constructors

 | Name | Description
Public method | BoundValueField | BoundValueField constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowFiltering | Gets or sets if the HierarchyItems bound to this field are filterable. (Inherited from BoundField.)
Public property | CellsDisplaySettings | Gets or sets the grid cells display settings of the HierarchyItems bound to this field. (Inherited from BoundField.)
Public property | CellsEditor | Gets or sets the grid cells in-place editor of the HierarchyItems bound to this field (Inherited from BoundField.)
Public property | CellsFormatProvider | Gets or sets the grid cells FormatProvider of the HierarchyItems bound to this field. (Inherited from BoundField.)
Public property | CellsFormatString | Gets or sets the grid cells Format string of the HierarchyItems bound to this field. (Inherited from BoundField.)
Public property | CellsImageAlignment | Gets or sets the grid cells image alignment of the HierarchyItems bound to this field. (Inherited from BoundField.)
Public property | CellsStyle | Gets or sets the grid cells style of the HierarchyItems bound to this field (Inherited from BoundField.)
Public property | CellsTextAlignment | Gets or sets the grid cells text alignment property of the HierarchyItems bound to this field. (Inherited from BoundField.)
Public property | CellsTextImageRelation | Gets or sets the grid cells text and image relation property of the HierarchyItems bound to this field. (Inherited from BoundField.)
Public property | CellsTextWrap | Gets or sets the grid cells text wrap property of the HierarchyItems bound to this field. (Inherited from BoundField.)
Public property | DataField | The name of the column from the data source (Inherited from BoundField.)
Public property | Function | Specifies the pivot table data aggregation function. This function will be used to calculate the values of the data grid cells
Public property | Resizable | Gets or sets whether HierarchyItems bound to this field are resizable. (Inherited from BoundField.)
Public property | SortMode | Gets or sets if the HierarchyItems bound to this field are sortable. (Inherited from BoundField.)
Public property | Text | The text (caption) of the HierarchyItem (Inherited from BoundField.)
Public property | TextWrap | Gets or sets the TextWrap property of HierarchyItems bound to this field. (Inherited from BoundField.)
Public property | Width | Gets or sets the Width of the HierarchyItems bound to this field (Inherited from BoundField.)

See Also

BoundValueField Class
VIBlend.WinForms.DataGridView Namespace


BoundValueField Constructor

[image]

VIBlend Controls for WinForms Help Documentation
BoundValueField Constructor
BoundValueField Class See Also Send Feedback
BoundValueField constructor.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BoundValueField(
    string text,
    string dataField,
    PivotFieldFunction function
)
Visual Basic
Public Sub New ( _
    text As String, _
    dataField As String, _
    function As PivotFieldFunction _
)
Visual C++
public:
BoundValueField(
    String^ text,
    String^ dataField,
    PivotFieldFunction function
)

Parameters

text
Type: System..::..String
Text to display in the HierarchyItem.
dataField
Type: System..::..String
DataField to bind to.
function
Type: VIBlend.WinForms.DataGridView..::..PivotFieldFunction
Data aggregation function.

See Also

BoundValueField Class
VIBlend.WinForms.DataGridView Namespace


BoundValueField Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
BoundValueField Methods
BoundValueField Class See Also Send Feedback

The BoundValueField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundValueField Class
VIBlend.WinForms.DataGridView Namespace


BoundValueField Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
BoundValueField Properties
BoundValueField Class See Also Send Feedback

The BoundValueField type exposes the following members.

Properties

 | Name | Description
Public property | AllowFiltering | Gets or sets if the HierarchyItems bound to this field are filterable. (Inherited from BoundField.)
Public property | CellsDisplaySettings | Gets or sets the grid cells display settings of the HierarchyItems bound to this field. (Inherited from BoundField.)
Public property | CellsEditor | Gets or sets the grid cells in-place editor of the HierarchyItems bound to this field (Inherited from BoundField.)
Public property | CellsFormatProvider | Gets or sets the grid cells FormatProvider of the HierarchyItems bound to this field. (Inherited from BoundField.)
Public property | CellsFormatString | Gets or sets the grid cells Format string of the HierarchyItems bound to this field. (Inherited from BoundField.)
Public property | CellsImageAlignment | Gets or sets the grid cells image alignment of the HierarchyItems bound to this field. (Inherited from BoundField.)
Public property | CellsStyle | Gets or sets the grid cells style of the HierarchyItems bound to this field (Inherited from BoundField.)
Public property | CellsTextAlignment | Gets or sets the grid cells text alignment property of the HierarchyItems bound to this field. (Inherited from BoundField.)
Public property | CellsTextImageRelation | Gets or sets the grid cells text and image relation property of the HierarchyItems bound to this field. (Inherited from BoundField.)
Public property | CellsTextWrap | Gets or sets the grid cells text wrap property of the HierarchyItems bound to this field. (Inherited from BoundField.)
Public property | DataField | The name of the column from the data source (Inherited from BoundField.)
Public property | Function | Specifies the pivot table data aggregation function. This function will be used to calculate the values of the data grid cells
Public property | Resizable | Gets or sets whether HierarchyItems bound to this field are resizable. (Inherited from BoundField.)
Public property | SortMode | Gets or sets if the HierarchyItems bound to this field are sortable. (Inherited from BoundField.)
Public property | Text | The text (caption) of the HierarchyItem (Inherited from BoundField.)
Public property | TextWrap | Gets or sets the TextWrap property of HierarchyItems bound to this field. (Inherited from BoundField.)
Public property | Width | Gets or sets the Width of the HierarchyItems bound to this field (Inherited from BoundField.)

See Also

BoundValueField Class
VIBlend.WinForms.DataGridView Namespace


Function Property

[image]

VIBlend Controls for WinForms Help Documentation
BoundValueField..::..Function Property
BoundValueField Class See Also Send Feedback
Specifies the pivot table data aggregation function. This function will be used to calculate the values of the data grid cells

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public PivotFieldFunction Function { get; set; }
Visual Basic
Public Property Function As PivotFieldFunction
    Get
    Set
Visual C++
public:
property PivotFieldFunction Function {
    PivotFieldFunction get ();
    void set (PivotFieldFunction value);
}

See Also

BoundValueField Class
VIBlend.WinForms.DataGridView Namespace


ButtonEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
ButtonEditor Class
Members See Also Send Feedback
Represents a ButtonEditor used in the GridView control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class ButtonEditor : IEditor
Visual Basic
Public Class ButtonEditor _
    Implements IEditor
Visual C++
public ref class ButtonEditor : IEditor

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..ButtonEditor

See Also

ButtonEditor Members
VIBlend.WinForms.DataGridView Namespace


ButtonEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
ButtonEditor Members
ButtonEditor Class Constructors Methods Properties See Also Send Feedback

The ButtonEditor type exposes the following members.

Constructors

 | Name | Description
Public method | ButtonEditor | Constructor

Methods

 | Name | Description
Public method | DrawEditorControl | Handles the painting of the editor control
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Public method | OnGridKeyDown | Handles grid KeyDown events
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | Control | Gets a reference to the underlying control of the editor
Public property | DeActivationFlags | Gets or sets the editor activation flags
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor

See Also

ButtonEditor Class
VIBlend.WinForms.DataGridView Namespace


ButtonEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
ButtonEditor Constructor
ButtonEditor Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ButtonEditor()
Visual Basic
Public Sub New
Visual C++
public:
ButtonEditor()

See Also

ButtonEditor Class
VIBlend.WinForms.DataGridView Namespace


ButtonEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
ButtonEditor Methods
ButtonEditor Class See Also Send Feedback

The ButtonEditor type exposes the following members.

Methods

 | Name | Description
Public method | DrawEditorControl | Handles the painting of the editor control
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Public method | OnGridKeyDown | Handles grid KeyDown events
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ButtonEditor Class
VIBlend.WinForms.DataGridView Namespace


DrawEditorControl Method

[image]

VIBlend Controls for WinForms Help Documentation
ButtonEditor..::..DrawEditorControl Method
ButtonEditor Class See Also Send Feedback
Handles the painting of the editor control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawEditorControl(
    Graphics graphics,
    GridCell gridCell,
    out bool isDrawHandled
)
Visual Basic
Public Sub DrawEditorControl ( _
    graphics As Graphics, _
    gridCell As GridCell, _
    <OutAttribute> ByRef isDrawHandled As Boolean _
)
Visual C++
public:
virtual void DrawEditorControl(
    Graphics^ graphics,
    GridCell^ gridCell,
    [OutAttribute] bool% isDrawHandled
) sealed

Parameters

graphics
Type: System.Drawing..::..Graphics
Reference to the GDI+ surface
gridCell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the grid cell being rendered
isDrawHandled
Type: System..::..Boolean %
Output flag indicating whether the method handled the drawing or not

Implements

IEditor..::..DrawEditorControl(Graphics, GridCell, Boolean%)

See Also

ButtonEditor Class
VIBlend.WinForms.DataGridView Namespace


LayoutEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
ButtonEditor..::..LayoutEditor Method
ButtonEditor Class See Also Send Feedback
This methods is called by the grid control when the editor must update its layout

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void LayoutEditor(
    GridCell cell
)
Visual Basic
Public Overridable Sub LayoutEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void LayoutEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the GridCell being edited

Implements

IEditor..::..LayoutEditor(GridCell)

See Also

ButtonEditor Class
VIBlend.WinForms.DataGridView Namespace


OnCloseEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
ButtonEditor..::..OnCloseEditor Method
ButtonEditor Class See Also Send Feedback
This method is called by the grid control when at the end of a cell edit operation

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void OnCloseEditor()
Visual Basic
Public Overridable Sub OnCloseEditor
Visual C++
public:
virtual void OnCloseEditor()

Implements

IEditor..::..OnCloseEditor()()()()

See Also

ButtonEditor Class
VIBlend.WinForms.DataGridView Namespace


OnGridKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
ButtonEditor..::..OnGridKeyDown Method
ButtonEditor Class See Also Send Feedback
Handles grid KeyDown events

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnGridKeyDown(
    KeyEventArgs args,
    GridCell cell,
    out bool closeEditor,
    out bool closeEditorAndSaveChanges
)
Visual Basic
Public Sub OnGridKeyDown ( _
    args As KeyEventArgs, _
    cell As GridCell, _
    <OutAttribute> ByRef closeEditor As Boolean, _
    <OutAttribute> ByRef closeEditorAndSaveChanges As Boolean _
)
Visual C++
public:
virtual void OnGridKeyDown(
    KeyEventArgs^ args,
    GridCell^ cell,
    [OutAttribute] bool% closeEditor,
    [OutAttribute] bool% closeEditorAndSaveChanges
) sealed

Parameters

args
Type: System.Windows.Forms..::..KeyEventArgs
KeyDown event arguments
cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
The grid cell where the event occured. This may be null if the event did not occur within a grid cell.
closeEditor
Type: System..::..Boolean %
Output flag indicating whether to keep the editor open or close it instantly
closeEditorAndSaveChanges
Type: System..::..Boolean %

Implements

IEditor..::..OnGridKeyDown(KeyEventArgs, GridCell, Boolean%, Boolean%)

See Also

ButtonEditor Class
VIBlend.WinForms.DataGridView Namespace


OnOpenEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
ButtonEditor..::..OnOpenEditor Method
ButtonEditor Class See Also Send Feedback
This method is called by the grid control when the editor is being activated

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void OnOpenEditor(
    GridCell cell
)
Visual Basic
Public Overridable Sub OnOpenEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void OnOpenEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell

Implements

IEditor..::..OnOpenEditor(GridCell)

See Also

ButtonEditor Class
VIBlend.WinForms.DataGridView Namespace


ButtonEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
ButtonEditor Properties
ButtonEditor Class See Also Send Feedback

The ButtonEditor type exposes the following members.

Properties

 | Name | Description
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | Control | Gets a reference to the underlying control of the editor
Public property | DeActivationFlags | Gets or sets the editor activation flags
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor

See Also

ButtonEditor Class
VIBlend.WinForms.DataGridView Namespace


ActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
ButtonEditor..::..ActivationFlags Property
ButtonEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags ActivationFlags { get; set; }
Visual Basic
Public Property ActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags ActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..ActivationFlags

See Also

ButtonEditor Class
VIBlend.WinForms.DataGridView Namespace


Control Property

[image]

VIBlend Controls for WinForms Help Documentation
ButtonEditor..::..Control Property
ButtonEditor Class See Also Send Feedback
Gets a reference to the underlying control of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control Control { get; }
Visual Basic
Public ReadOnly Property Control As Control
    Get
Visual C++
public:
virtual property Control^ Control {
    Control^ get () sealed;
}

Implements

IEditor..::..Control

See Also

ButtonEditor Class
VIBlend.WinForms.DataGridView Namespace


DeActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
ButtonEditor..::..DeActivationFlags Property
ButtonEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags DeActivationFlags { get; set; }
Visual Basic
Public Property DeActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags DeActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..DeActivationFlags

See Also

ButtonEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorType Property

[image]

VIBlend Controls for WinForms Help Documentation
ButtonEditor..::..EditorType Property
ButtonEditor Class See Also Send Feedback
Gets the type of the grid cell editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellEditorType EditorType { get; }
Visual Basic
Public ReadOnly Property EditorType As CellEditorType
    Get
Visual C++
public:
virtual property CellEditorType EditorType {
    CellEditorType get () sealed;
}

Implements

IEditor..::..EditorType

See Also

ButtonEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorValue Property

[image]

VIBlend Controls for WinForms Help Documentation
ButtonEditor..::..EditorValue Property
ButtonEditor Class See Also Send Feedback
Get's or sets the current value of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object EditorValue { get; set; }
Visual Basic
Public Property EditorValue As Object
    Get
    Set
Visual C++
public:
virtual property Object^ EditorValue {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Implements

IEditor..::..EditorValue

See Also

ButtonEditor Class
VIBlend.WinForms.DataGridView Namespace


CellCancelEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
CellCancelEventArgs Class
Members See Also Send Feedback
Represents a GridView grid cell cancel event argument

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class CellCancelEventArgs : CellEventArgs
Visual Basic
Public Class CellCancelEventArgs _
    Inherits CellEventArgs
Visual C++
public ref class CellCancelEventArgs : public CellEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.DataGridView..::..CellEventArgs
VIBlend.WinForms.DataGridView..::..CellCancelEventArgs
VIBlend.WinForms.DataGridView..::..CellValueChangingEventArgs
VIBlend.WinForms.DataGridView..::..EditorActivationCancelEventArgs

See Also

CellCancelEventArgs Members
VIBlend.WinForms.DataGridView Namespace


CellCancelEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellCancelEventArgs Members
CellCancelEventArgs Class Constructors Methods Properties See Also Send Feedback

The CellCancelEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CellCancelEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Determines if the event is canceled.
Public property | Cell | GridCell associated with the event (Inherited from CellEventArgs.)

See Also

CellCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellCancelEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
CellCancelEventArgs Constructor
CellCancelEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellCancelEventArgs(
    GridCell cell
)
Visual Basic
Public Sub New ( _
    cell As GridCell _
)
Visual C++
public:
CellCancelEventArgs(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
GridCell associated with the event

See Also

CellCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellCancelEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellCancelEventArgs Methods
CellCancelEventArgs Class See Also Send Feedback

The CellCancelEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CellCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellCancelEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellCancelEventArgs Properties
CellCancelEventArgs Class See Also Send Feedback

The CellCancelEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Determines if the event is canceled.
Public property | Cell | GridCell associated with the event (Inherited from CellEventArgs.)

See Also

CellCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Cancel Property

[image]

VIBlend Controls for WinForms Help Documentation
CellCancelEventArgs..::..Cancel Property
CellCancelEventArgs Class See Also Send Feedback
Determines if the event is canceled.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic
Public Property Cancel As Boolean
    Get
    Set
Visual C++
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}

See Also

CellCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellEditorType Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
CellEditorType Enumeration
See Also Send Feedback
Specifies a grid cell editor type

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum CellEditorType
Visual Basic
Public Enumeration CellEditorType
Visual C++
public enum class CellEditorType

Members

Member name | Description
TextBox |
ComboBox |
Button |
CheckBox |
TrackBar |
NumericUpDown |
ProgressBar |
TimePicker |
Currency |
Percentage |
FixedPoint |
Number |
Custom |

See Also

VIBlend.WinForms.DataGridView Namespace


CellEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
CellEventArgs Class
Members See Also Send Feedback
Represents a GridView grid cell event argument

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class CellEventArgs : EventArgs,
    ICell
Visual Basic
Public Class CellEventArgs _
    Inherits EventArgs _
    Implements ICell
Visual C++
public ref class CellEventArgs : public EventArgs,
    ICell

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.DataGridView..::..CellEventArgs
VIBlend.WinForms.DataGridView..::..CellCancelEventArgs
VIBlend.WinForms.DataGridView..::..CellParsingEventArgs

See Also

CellEventArgs Members
VIBlend.WinForms.DataGridView Namespace


CellEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellEventArgs Members
CellEventArgs Class Constructors Methods Properties See Also Send Feedback

The CellEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CellEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cell | GridCell associated with the event

See Also

CellEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
CellEventArgs Constructor
CellEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellEventArgs(
    GridCell cell
)
Visual Basic
Public Sub New ( _
    cell As GridCell _
)
Visual C++
public:
CellEventArgs(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
GridCell associated with the event

See Also

CellEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellEventArgs Methods
CellEventArgs Class See Also Send Feedback

The CellEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CellEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellEventArgs Properties
CellEventArgs Class See Also Send Feedback

The CellEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cell | GridCell associated with the event

See Also

CellEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Cell Property

[image]

VIBlend Controls for WinForms Help Documentation
CellEventArgs..::..Cell Property
CellEventArgs Class See Also Send Feedback
GridCell associated with the event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell Cell { get; }
Visual Basic
Public ReadOnly Property Cell As GridCell
    Get
Visual C++
public:
virtual property GridCell^ Cell {
    GridCell^ get () sealed;
}

See Also

CellEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellMouseEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
CellMouseEventArgs Class
Members See Also Send Feedback
Represents a GridView grid cell mouse event argument

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class CellMouseEventArgs : MouseEventArgs,
    ICell
Visual Basic
Public Class CellMouseEventArgs _
    Inherits MouseEventArgs _
    Implements ICell
Visual C++
public ref class CellMouseEventArgs : public MouseEventArgs,
    ICell

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.Windows.Forms..::..MouseEventArgs
VIBlend.WinForms.DataGridView..::..CellMouseEventArgs

See Also

CellMouseEventArgs Members
VIBlend.WinForms.DataGridView Namespace


CellMouseEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellMouseEventArgs Members
CellMouseEventArgs Class Constructors Methods Properties See Also Send Feedback

The CellMouseEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CellMouseEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Button | Gets which mouse button was pressed. (Inherited from MouseEventArgs.)
Public property | Cell | The grid cell associated with the event
Public property | Clicks | Gets the number of times the mouse button was pressed and released. (Inherited from MouseEventArgs.)
Public property | Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel. (Inherited from MouseEventArgs.)
Public property | Location | Gets the location of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)
Public property | X | Gets the x-coordinate of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)
Public property | Y | Gets the y-coordinate of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)

See Also

CellMouseEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellMouseEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
CellMouseEventArgs Constructor
CellMouseEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellMouseEventArgs(
    GridCell cell,
    MouseButtons button,
    int clicks,
    int x,
    int y,
    int delta
)
Visual Basic
Public Sub New ( _
    cell As GridCell, _
    button As MouseButtons, _
    clicks As Integer, _
    x As Integer, _
    y As Integer, _
    delta As Integer _
)
Visual C++
public:
CellMouseEventArgs(
    GridCell^ cell,
    MouseButtons button,
    int clicks,
    int x,
    int y,
    int delta
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
GridCell
button
Type: System.Windows.Forms..::..MouseButtons
MouseButons
clicks
Type: System..::..Int32
MouseEventArgs Clicks
x
Type: System..::..Int32
MouseEventArgs X
y
Type: System..::..Int32
MouseEventArgs Y
delta
Type: System..::..Int32
MouseEventArgs Delta

See Also

CellMouseEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellMouseEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellMouseEventArgs Methods
CellMouseEventArgs Class See Also Send Feedback

The CellMouseEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CellMouseEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellMouseEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellMouseEventArgs Properties
CellMouseEventArgs Class See Also Send Feedback

The CellMouseEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Button | Gets which mouse button was pressed. (Inherited from MouseEventArgs.)
Public property | Cell | The grid cell associated with the event
Public property | Clicks | Gets the number of times the mouse button was pressed and released. (Inherited from MouseEventArgs.)
Public property | Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel. (Inherited from MouseEventArgs.)
Public property | Location | Gets the location of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)
Public property | X | Gets the x-coordinate of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)
Public property | Y | Gets the y-coordinate of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)

See Also

CellMouseEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Cell Property

[image]

VIBlend Controls for WinForms Help Documentation
CellMouseEventArgs..::..Cell Property
CellMouseEventArgs Class See Also Send Feedback
The grid cell associated with the event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell Cell { get; }
Visual Basic
Public ReadOnly Property Cell As GridCell
    Get
Visual C++
public:
virtual property GridCell^ Cell {
    GridCell^ get () sealed;
}

See Also

CellMouseEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellPaintEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
CellPaintEventArgs Class
Members See Also Send Feedback
Represents a GridView grid cell paint event argument

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class CellPaintEventArgs : EventArgs,
    ICell
Visual Basic
Public Class CellPaintEventArgs _
    Inherits EventArgs _
    Implements ICell
Visual C++
public ref class CellPaintEventArgs : public EventArgs,
    ICell

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.DataGridView..::..CellPaintEventArgs

See Also

CellPaintEventArgs Members
VIBlend.WinForms.DataGridView Namespace


CellPaintEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellPaintEventArgs Members
CellPaintEventArgs Class Constructors Methods Properties See Also Send Feedback

The CellPaintEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CellPaintEventArgs | Initializes a new instance of the CellPaintEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bounds | Gets the bounds of the grid cell paint area
Public property | Cell | GridCell associated with the event
Public property | Graphics | Gets a refrence to the GDI+ drawing surface
Public property | Handled | Flag indicating whether the painting was performed and handled by the even handler

See Also

CellPaintEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellPaintEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
CellPaintEventArgs Constructor
CellPaintEventArgs Class See Also Send Feedback
Initializes a new instance of the CellPaintEventArgs class

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellPaintEventArgs(
    GridCell cell,
    Rectangle bounds,
    Graphics g
)
Visual Basic
Public Sub New ( _
    cell As GridCell, _
    bounds As Rectangle, _
    g As Graphics _
)
Visual C++
public:
CellPaintEventArgs(
    GridCell^ cell,
    Rectangle bounds,
    Graphics^ g
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
bounds
Type: System.Drawing..::..Rectangle
g
Type: System.Drawing..::..Graphics

See Also

CellPaintEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellPaintEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellPaintEventArgs Methods
CellPaintEventArgs Class See Also Send Feedback

The CellPaintEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CellPaintEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellPaintEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellPaintEventArgs Properties
CellPaintEventArgs Class See Also Send Feedback

The CellPaintEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Bounds | Gets the bounds of the grid cell paint area
Public property | Cell | GridCell associated with the event
Public property | Graphics | Gets a refrence to the GDI+ drawing surface
Public property | Handled | Flag indicating whether the painting was performed and handled by the even handler

See Also

CellPaintEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Bounds Property

[image]

VIBlend Controls for WinForms Help Documentation
CellPaintEventArgs..::..Bounds Property
CellPaintEventArgs Class See Also Send Feedback
Gets the bounds of the grid cell paint area

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle Bounds { get; }
Visual Basic
Public ReadOnly Property Bounds As Rectangle
    Get
Visual C++
public:
property Rectangle Bounds {
    Rectangle get ();
}

See Also

CellPaintEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Cell Property

[image]

VIBlend Controls for WinForms Help Documentation
CellPaintEventArgs..::..Cell Property
CellPaintEventArgs Class See Also Send Feedback
GridCell associated with the event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell Cell { get; }
Visual Basic
Public ReadOnly Property Cell As GridCell
    Get
Visual C++
public:
virtual property GridCell^ Cell {
    GridCell^ get () sealed;
}

See Also

CellPaintEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Graphics Property

[image]

VIBlend Controls for WinForms Help Documentation
CellPaintEventArgs..::..Graphics Property
CellPaintEventArgs Class See Also Send Feedback
Gets a refrence to the GDI+ drawing surface

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Graphics Graphics { get; }
Visual Basic
Public ReadOnly Property Graphics As Graphics
    Get
Visual C++
public:
property Graphics^ Graphics {
    Graphics^ get ();
}

See Also

CellPaintEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Handled Property

[image]

VIBlend Controls for WinForms Help Documentation
CellPaintEventArgs..::..Handled Property
CellPaintEventArgs Class See Also Send Feedback
Flag indicating whether the painting was performed and handled by the even handler

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Handled { get; set; }
Visual Basic
Public Property Handled As Boolean
    Get
    Set
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

See Also

CellPaintEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellParsingEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
CellParsingEventArgs Class
Members See Also Send Feedback
Represents a grid cell parsing event argument

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class CellParsingEventArgs : CellEventArgs
Visual Basic
Public Class CellParsingEventArgs _
    Inherits CellEventArgs
Visual C++
public ref class CellParsingEventArgs : public CellEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.DataGridView..::..CellEventArgs
VIBlend.WinForms.DataGridView..::..CellParsingEventArgs

See Also

CellParsingEventArgs Members
VIBlend.WinForms.DataGridView Namespace


CellParsingEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellParsingEventArgs Members
CellParsingEventArgs Class Constructors Methods Properties See Also Send Feedback

The CellParsingEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CellParsingEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Determines whether the event is canceled
Public property | Cell | GridCell associated with the event (Inherited from CellEventArgs.)
Public property | ParsingApplied | Determines whether parsing was applied

See Also

CellParsingEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellParsingEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
CellParsingEventArgs Constructor
CellParsingEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellParsingEventArgs(
    GridCell cell
)
Visual Basic
Public Sub New ( _
    cell As GridCell _
)
Visual C++
public:
CellParsingEventArgs(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Grid cell associated with the event

See Also

CellParsingEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellParsingEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellParsingEventArgs Methods
CellParsingEventArgs Class See Also Send Feedback

The CellParsingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CellParsingEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellParsingEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellParsingEventArgs Properties
CellParsingEventArgs Class See Also Send Feedback

The CellParsingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Determines whether the event is canceled
Public property | Cell | GridCell associated with the event (Inherited from CellEventArgs.)
Public property | ParsingApplied | Determines whether parsing was applied

See Also

CellParsingEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Cancel Property

[image]

VIBlend Controls for WinForms Help Documentation
CellParsingEventArgs..::..Cancel Property
CellParsingEventArgs Class See Also Send Feedback
Determines whether the event is canceled

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic
Public Property Cancel As Boolean
    Get
    Set
Visual C++
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}

See Also

CellParsingEventArgs Class
VIBlend.WinForms.DataGridView Namespace


ParsingApplied Property

[image]

VIBlend Controls for WinForms Help Documentation
CellParsingEventArgs..::..ParsingApplied Property
CellParsingEventArgs Class See Also Send Feedback
Determines whether parsing was applied

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ParsingApplied { get; set; }
Visual Basic
Public Property ParsingApplied As Boolean
    Get
    Set
Visual C++
public:
property bool ParsingApplied {
    bool get ();
    void set (bool value);
}

See Also

CellParsingEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellsArea Class

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea Class
Members See Also Send Feedback
Represents the data grid's cell area
Represents the data grid's cell area

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class CellsArea : INotifyPropertyChanged
Visual Basic
Public Class CellsArea _
    Implements INotifyPropertyChanged
Visual C++
public ref class CellsArea : INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..CellsArea

See Also

CellsArea Members
VIBlend.WinForms.DataGridView Namespace


CellsArea Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellsArea Members
CellsArea Class Constructors Methods Properties See Also Send Feedback

The CellsArea type exposes the following members.

Constructors

 | Name | Description
Public method | CellsArea | Constructor

Methods

 | Name | Description
Public method | Clear | Clears all stored cell values and settings.
Public method | ClearCellFormatSettings | Clears all format settings for the grid cells.
Public method | ClearCellsSpan | Clears the merged cells.
Public method | ClearSelection | Clears the grid cells selection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCellAbove | Returns the cell displayed above a specific cell
Public method | GetCellBelow | Returns the cell displayed below a specific cell
Public method | GetCellDataSource | Gets the data source type of a grid cell
Public method | GetCellDisplaySettings | Gets the display settings for a specific grid cell
Public method | GetCellDrawStyle | Gets the custom draw style of a specific grid cell
Public method | GetCellEditor(HierarchyItem) | Obsolete.
Public method | GetCellEditor(HierarchyItem, HierarchyItem) | Gets the cell editor of a specific grid cell
Public method | GetCellFormatProvider | Gets the format provider for a grid cell.
Public method | GetCellFormatString | Gets the formatting for a grid cell.
Public method | GetCellFormattedText | Gets the cell's value as formatted text using the respective format provider and format expression
Public method | GetCellImageAlignment | Gets the image alignment for a specific grid cell
Public method | GetCellImageIndex | Gets the image index of a cell's image
Public method | GetCellImagePosition | Gets the image positioning mode of a grid cell
Public method | GetCellLeft | Returns the cell displayed on the left of a specific cell
Public method | GetCellRight | Returns the cell displayed on the right of a specific cell
Public method | GetCellSpan | Returns the cell span properties of a grid cell
Public method | GetCellSpansList | Gets the List of cell span groups.
Public method | GetCellTextAlignment | Gets the text alignment for a specific grid cell
Public method | GetCellTextImageRelation | Gets the text and image display relation of a grid cell
Public method | GetCellTextWrap | Gets the text wrap mode of a grid cell
Public method | GetCellValue | Gets the Value of a grid cell
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HitTest | Returns the grid cell at a specific position
Public method | IsCellMerged | Determines whether the specific cell is merged.
Public method | IsCellSelected | Determines whether a grid cell is selected
Public method | IsLockedCell | Determines if a grid cell is locked or not
Public method | LockCell | Locks a specific grid cell
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveCellSpan | Removes the cell merge.
Public method | SelectCell(GridCell) | Selects a specific grid cell.
Public method | SelectCell(HierarchyItem, HierarchyItem) | Selects a specific grid cell.
Public method | SetCellAutoSize | Sets the size of the cell to auto.
Public method | SetCellConditionalFormattingGroup(GridCell, String) | Specifies the conditional formatting group name for a specific grid cell
Public method | SetCellConditionalFormattingGroup(HierarchyItem, String) | Specifies the conditional formatting group name for a specific row or column item
Public method | SetCellConditionalFormattingGroup(HierarchyItem, HierarchyItem, String) | Specifies the conditional formatting group name for a specific grid cell
Public method | SetCellDataSource(HierarchyItem, GridCellDataSource) | Obsolete.
Public method | SetCellDataSource(HierarchyItem, HierarchyItem, GridCellDataSource) | Sets the data source property of a grid cell
Public method | SetCellDisplaySettings(HierarchyItem, DisplaySettings) | Obsolete.
Public method | SetCellDisplaySettings(HierarchyItem, HierarchyItem, DisplaySettings) | Sets the display settings for a specific cell.
Public method | SetCellDrawStyle(HierarchyItem, GridCellStyle) | Obsolete.
Public method | SetCellDrawStyle(HierarchyItem, HierarchyItem, GridCellStyle) | Sets a custom draw style for a specific grid cell
Public method | SetCellEditor(HierarchyItem, IEditor) | Obsolete.
Public method | SetCellEditor(HierarchyItem, HierarchyItem, IEditor) | Sets the data editor control for a specific grid cell
Public method | SetCellFormatProvider | Sets the format provider for a grid cell.
Public method | SetCellFormatString | Sets the formatting for a grid cell.
Public method | SetCellImage | Sets the image index of a grid cell
Public method | SetCellImageAlignment(HierarchyItem, ContentAlignment) | Obsolete.
Public method | SetCellImageAlignment(HierarchyItem, HierarchyItem, ContentAlignment) | Sets the image alignment for a specific grid cell
Public method | SetCellImagePosition | Sets the image positioning mode of a grid cell
Public method | SetCellSpan | Sets the span of a data grid cell
Public method | SetCellTextAlignment(HierarchyItem, ContentAlignment) | Obsolete.
Public method | SetCellTextAlignment(HierarchyItem, HierarchyItem, ContentAlignment) | Sets the text alignment for a specific grid cell
Public method | SetCellTextImageRelation | Sets the text and image display relation of a grid cell
Public method | SetCellTextWrap(HierarchyItem, Boolean) | Obsolete.
Public method | SetCellTextWrap(HierarchyItem, HierarchyItem, Boolean) | Sets the text wrap mode for a specific grid cell
Public method | SetCellValue | Sets the Value of a cell
Public method | SetItemConditionalFormattingGroup | Obsolete. Specifies the conditional formatting group name for a specific row or column item
Public method | SetItemEditor | Obsolete. Sets the grid cell editor for all cell in a row or column.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnlockAllCells |
Public method | UnlockCell | Unlocks a specific grid cell
Public method | UnSelectCell(GridCell) | Removes the selection for a specific grid cell
Public method | UnSelectCell(HierarchyItem, HierarchyItem) | Removes the selection for a specific grid cell

Properties

Name Description
Public property AllowCellMerge
Specifies whether cell merge operations are allowed or not
Public property Cells
Retrieves all non-empty grid cells
Public property CellSpanGroupsCount
Returns the number of cell span groups

Remarks

Use this property to determine the number of cell merges in the data grid
Public property ConditionalFormattingEnabled
Determines whether the conditional formatting is on or off
Public property ConditionalFormattingGroups
Conditional formatting groups collection
Public property EditCell
Gets a reference to the grid cell that is currently being edited
Public property GridControl
Returns a reference to the Grid control hosting the CellsArea.
Public property NonEmptyCells
Retrieves all non-empty grid cells
Public property SelectedCells
Returns a list of all selected cells
Public property SelectedCellsCount
Returns the number of selected cells

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


CellsArea Constructor

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea Constructor
CellsArea Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellsArea(
    vDataGridView gridView
)
Visual Basic
Public Sub New ( _
    gridView As vDataGridView _
)
Visual C++
public:
CellsArea(
    vDataGridView^ gridView
)

Parameters

gridView
Type: VIBlend.WinForms.DataGridView..::..vDataGridView

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


CellsArea Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellsArea Methods
CellsArea Class See Also Send Feedback

The CellsArea type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears all stored cell values and settings.
Public method | ClearCellFormatSettings | Clears all format settings for the grid cells.
Public method | ClearCellsSpan | Clears the merged cells.
Public method | ClearSelection | Clears the grid cells selection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCellAbove | Returns the cell displayed above a specific cell
Public method | GetCellBelow | Returns the cell displayed below a specific cell
Public method | GetCellDataSource | Gets the data source type of a grid cell
Public method | GetCellDisplaySettings | Gets the display settings for a specific grid cell
Public method | GetCellDrawStyle | Gets the custom draw style of a specific grid cell
Public method | GetCellEditor(HierarchyItem) | Obsolete.
Public method | GetCellEditor(HierarchyItem, HierarchyItem) | Gets the cell editor of a specific grid cell
Public method | GetCellFormatProvider | Gets the format provider for a grid cell.
Public method | GetCellFormatString | Gets the formatting for a grid cell.
Public method | GetCellFormattedText | Gets the cell's value as formatted text using the respective format provider and format expression
Public method | GetCellImageAlignment | Gets the image alignment for a specific grid cell
Public method | GetCellImageIndex | Gets the image index of a cell's image
Public method | GetCellImagePosition | Gets the image positioning mode of a grid cell
Public method | GetCellLeft | Returns the cell displayed on the left of a specific cell
Public method | GetCellRight | Returns the cell displayed on the right of a specific cell
Public method | GetCellSpan | Returns the cell span properties of a grid cell
Public method | GetCellSpansList | Gets the List of cell span groups.
Public method | GetCellTextAlignment | Gets the text alignment for a specific grid cell
Public method | GetCellTextImageRelation | Gets the text and image display relation of a grid cell
Public method | GetCellTextWrap | Gets the text wrap mode of a grid cell
Public method | GetCellValue | Gets the Value of a grid cell
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HitTest | Returns the grid cell at a specific position
Public method | IsCellMerged | Determines whether the specific cell is merged.
Public method | IsCellSelected | Determines whether a grid cell is selected
Public method | IsLockedCell | Determines if a grid cell is locked or not
Public method | LockCell | Locks a specific grid cell
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveCellSpan | Removes the cell merge.
Public method | SelectCell(GridCell) | Selects a specific grid cell.
Public method | SelectCell(HierarchyItem, HierarchyItem) | Selects a specific grid cell.
Public method | SetCellAutoSize | Sets the size of the cell to auto.
Public method | SetCellConditionalFormattingGroup(GridCell, String) | Specifies the conditional formatting group name for a specific grid cell
Public method | SetCellConditionalFormattingGroup(HierarchyItem, String) | Specifies the conditional formatting group name for a specific row or column item
Public method | SetCellConditionalFormattingGroup(HierarchyItem, HierarchyItem, String) | Specifies the conditional formatting group name for a specific grid cell
Public method | SetCellDataSource(HierarchyItem, GridCellDataSource) | Obsolete.
Public method | SetCellDataSource(HierarchyItem, HierarchyItem, GridCellDataSource) | Sets the data source property of a grid cell
Public method | SetCellDisplaySettings(HierarchyItem, DisplaySettings) | Obsolete.
Public method | SetCellDisplaySettings(HierarchyItem, HierarchyItem, DisplaySettings) | Sets the display settings for a specific cell.
Public method | SetCellDrawStyle(HierarchyItem, GridCellStyle) | Obsolete.
Public method | SetCellDrawStyle(HierarchyItem, HierarchyItem, GridCellStyle) | Sets a custom draw style for a specific grid cell
Public method | SetCellEditor(HierarchyItem, IEditor) | Obsolete.
Public method | SetCellEditor(HierarchyItem, HierarchyItem, IEditor) | Sets the data editor control for a specific grid cell
Public method | SetCellFormatProvider | Sets the format provider for a grid cell.
Public method | SetCellFormatString | Sets the formatting for a grid cell.
Public method | SetCellImage | Sets the image index of a grid cell
Public method | SetCellImageAlignment(HierarchyItem, ContentAlignment) | Obsolete.
Public method | SetCellImageAlignment(HierarchyItem, HierarchyItem, ContentAlignment) | Sets the image alignment for a specific grid cell
Public method | SetCellImagePosition | Sets the image positioning mode of a grid cell
Public method | SetCellSpan | Sets the span of a data grid cell
Public method | SetCellTextAlignment(HierarchyItem, ContentAlignment) | Obsolete.
Public method | SetCellTextAlignment(HierarchyItem, HierarchyItem, ContentAlignment) | Sets the text alignment for a specific grid cell
Public method | SetCellTextImageRelation | Sets the text and image display relation of a grid cell
Public method | SetCellTextWrap(HierarchyItem, Boolean) | Obsolete.
Public method | SetCellTextWrap(HierarchyItem, HierarchyItem, Boolean) | Sets the text wrap mode for a specific grid cell
Public method | SetCellValue | Sets the Value of a cell
Public method | SetItemConditionalFormattingGroup | Obsolete. Specifies the conditional formatting group name for a specific row or column item
Public method | SetItemEditor | Obsolete. Sets the grid cell editor for all cell in a row or column.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnlockAllCells |
Public method | UnlockCell | Unlocks a specific grid cell
Public method | UnSelectCell(GridCell) | Removes the selection for a specific grid cell
Public method | UnSelectCell(HierarchyItem, HierarchyItem) | Removes the selection for a specific grid cell

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


Clear Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..Clear Method
CellsArea Class See Also Send Feedback
Clears all stored cell values and settings.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


ClearCellFormatSettings Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..ClearCellFormatSettings Method
CellsArea Class See Also Send Feedback
Clears all format settings for the grid cells.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ClearCellFormatSettings()
Visual Basic
Public Sub ClearCellFormatSettings
Visual C++
public:
void ClearCellFormatSettings()

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


ClearCellsSpan Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..ClearCellsSpan Method
CellsArea Class See Also Send Feedback
Clears the merged cells.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ClearCellsSpan()
Visual Basic
Public Sub ClearCellsSpan
Visual C++
public:
void ClearCellsSpan()

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


ClearSelection Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..ClearSelection Method
CellsArea Class See Also Send Feedback
Clears the grid cells selection.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ClearSelection()
Visual Basic
Public Sub ClearSelection
Visual C++
public:
void ClearSelection()

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellAbove Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellAbove Method
CellsArea Class See Also Send Feedback
Returns the cell displayed above a specific cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell GetCellAbove(
    GridCell cell
)
Visual Basic
Public Function GetCellAbove ( _
    cell As GridCell _
) As GridCell
Visual C++
public:
GridCell^ GetCellAbove(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
The grid cell used as a starting point.

Return Value

The grid cell that appears above the specified cell. If such cell does not exist the method return null.

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellBelow Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellBelow Method
CellsArea Class See Also Send Feedback
Returns the cell displayed below a specific cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell GetCellBelow(
    GridCell cell
)
Visual Basic
Public Function GetCellBelow ( _
    cell As GridCell _
) As GridCell
Visual C++
public:
GridCell^ GetCellBelow(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
The grid cell used as a starting point.

Return Value

The grid cell that appears below the specified cell. If such cell does not exist the method return null.

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellDataSource Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellDataSource Method
CellsArea Class See Also Send Feedback
Gets the data source type of a grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCellDataSource GetCellDataSource(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Function GetCellDataSource ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
) As GridCellDataSource
Visual C++
public:
GridCellDataSource GetCellDataSource(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column

Return Value

The data source type of the grid cell. The default value is NotSet which means that the cell is unbound

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellDisplaySettings Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellDisplaySettings Method
CellsArea Class See Also Send Feedback
Gets the display settings for a specific grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DisplaySettings GetCellDisplaySettings(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Function GetCellDisplaySettings ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
) As DisplaySettings
Visual C++
public:
DisplaySettings GetCellDisplaySettings(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column

Return Value

Cell's display settings

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellDrawStyle Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellDrawStyle Method
CellsArea Class See Also Send Feedback
Gets the custom draw style of a specific grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCellStyle GetCellDrawStyle(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Function GetCellDrawStyle ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
) As GridCellStyle
Visual C++
public:
GridCellStyle^ GetCellDrawStyle(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column

Return Value

The custom draw style of the grid cell or null if a custom style is not set

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellEditor Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellEditor Method
CellsArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCellEditor(HierarchyItem) | Obsolete.
Public method | GetCellEditor(HierarchyItem, HierarchyItem) | Gets the cell editor of a specific grid cell

See Also

CellsArea Class
CellsArea Members
VIBlend.WinForms.DataGridView Namespace


GetCellEditor Method (HierarchyItem)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellEditor Method (HierarchyItem)
CellsArea Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[ObsoleteAttribute("Use HierarchyItem.CellsEditor")]
public IEditor GetCellEditor(
    HierarchyItem item
)
Visual Basic
<ObsoleteAttribute("Use HierarchyItem.CellsEditor")> _
Public Function GetCellEditor ( _
    item As HierarchyItem _
) As IEditor
Visual C++
[ObsoleteAttribute(L"Use HierarchyItem.CellsEditor")]
public:
IEditor^ GetCellEditor(
    HierarchyItem^ item
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem

See Also

CellsArea Class
GetCellEditor Overload
VIBlend.WinForms.DataGridView Namespace


GetCellEditor Method (HierarchyItem, HierarchyItem)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellEditor Method (HierarchyItem, HierarchyItem)
CellsArea Class See Also Send Feedback
Gets the cell editor of a specific grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public IEditor GetCellEditor(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Function GetCellEditor ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
) As IEditor
Visual C++
public:
IEditor^ GetCellEditor(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column

Return Value

The function returns a reference to the cell's editor control or null if there is no editor assiciated with the grid cell

See Also

CellsArea Class
GetCellEditor Overload
VIBlend.WinForms.DataGridView Namespace


GetCellFormatProvider Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellFormatProvider Method
CellsArea Class See Also Send Feedback
Gets the format provider for a grid cell.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public IFormatProvider GetCellFormatProvider(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Function GetCellFormatProvider ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
) As IFormatProvider
Visual C++
public:
IFormatProvider^ GetCellFormatProvider(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellFormatString Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellFormatString Method
CellsArea Class See Also Send Feedback
Gets the formatting for a grid cell.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string GetCellFormatString(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Function GetCellFormatString ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
) As String
Visual C++
public:
String^ GetCellFormatString(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellFormattedText Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellFormattedText Method
CellsArea Class See Also Send Feedback
Gets the cell's value as formatted text using the respective format provider and format expression

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string GetCellFormattedText(
    GridCell cell
)
Visual Basic
Public Function GetCellFormattedText ( _
    cell As GridCell _
) As String
Visual C++
public:
String^ GetCellFormattedText(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellImageAlignment Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellImageAlignment Method
CellsArea Class See Also Send Feedback
Gets the image alignment for a specific grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment GetCellImageAlignment(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Function GetCellImageAlignment ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
) As ContentAlignment
Visual C++
public:
ContentAlignment GetCellImageAlignment(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column

Return Value

The image alignment of the grid cell. The default value is MiddleCenter

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellImageIndex Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellImageIndex Method
CellsArea Class See Also Send Feedback
Gets the image index of a cell's image

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int GetCellImageIndex(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Function GetCellImageIndex ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
) As Integer
Visual C++
public:
int GetCellImageIndex(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem

Return Value

The image index of the image associated with the grid cell. If there's no image associated with the cell the function returns -1.

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellImagePosition Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellImagePosition Method
CellsArea Class See Also Send Feedback
Gets the image positioning mode of a grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ImagePositions GetCellImagePosition(
    HierarchyItem rowItem,
    HierarchyItem colItem
)
Visual Basic
Public Function GetCellImagePosition ( _
    rowItem As HierarchyItem, _
    colItem As HierarchyItem _
) As ImagePositions
Visual C++
public:
ImagePositions GetCellImagePosition(
    HierarchyItem^ rowItem,
    HierarchyItem^ colItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
colItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellLeft Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellLeft Method
CellsArea Class See Also Send Feedback
Returns the cell displayed on the left of a specific cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell GetCellLeft(
    GridCell cell
)
Visual Basic
Public Function GetCellLeft ( _
    cell As GridCell _
) As GridCell
Visual C++
public:
GridCell^ GetCellLeft(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
The grid cell used as a starting point.

Return Value

The grid cell that appears on the left side of the specified cell. If such cell does not exist the method return null.

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellRight Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellRight Method
CellsArea Class See Also Send Feedback
Returns the cell displayed on the right of a specific cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell GetCellRight(
    GridCell cell
)
Visual Basic
Public Function GetCellRight ( _
    cell As GridCell _
) As GridCell
Visual C++
public:
GridCell^ GetCellRight(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
The grid cell used as a starting point.

Return Value

The grid cell that appears on the right side of the specified cell. If such cell does not exist the method return null.

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellSpan Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellSpan Method
CellsArea Class See Also Send Feedback
Returns the cell span properties of a grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellSpan GetCellSpan(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Function GetCellSpan ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
) As CellSpan
Visual C++
public:
CellSpan GetCellSpan(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column

Return Value

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellSpansList Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellSpansList Method
CellsArea Class See Also Send Feedback
Gets the List of cell span groups.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<CellSpan> GetCellSpansList()
Visual Basic
Public Function GetCellSpansList As List(Of CellSpan)
Visual C++
public:
List<CellSpan>^ GetCellSpansList()

Return Value

List of CellSpan objects containing information about cell merges

Remarks

Use this method to retrieve information about the cell merges in the data grid

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellTextAlignment Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellTextAlignment Method
CellsArea Class See Also Send Feedback
Gets the text alignment for a specific grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment GetCellTextAlignment(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Function GetCellTextAlignment ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
) As ContentAlignment
Visual C++
public:
ContentAlignment GetCellTextAlignment(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column

Return Value

Cell's text alignment. The default value is MiddleCenter

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellTextImageRelation Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellTextImageRelation Method
CellsArea Class See Also Send Feedback
Gets the text and image display relation of a grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public TextImageRelation GetCellTextImageRelation(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Function GetCellTextImageRelation ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
) As TextImageRelation
Visual C++
public:
TextImageRelation GetCellTextImageRelation(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellTextWrap Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellTextWrap Method
CellsArea Class See Also Send Feedback
Gets the text wrap mode of a grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool GetCellTextWrap(
    HierarchyItem rowItem,
    HierarchyItem colItem
)
Visual Basic
Public Function GetCellTextWrap ( _
    rowItem As HierarchyItem, _
    colItem As HierarchyItem _
) As Boolean
Visual C++
public:
bool GetCellTextWrap(
    HierarchyItem^ rowItem,
    HierarchyItem^ colItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
colItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GetCellValue Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GetCellValue Method
CellsArea Class See Also Send Feedback
Gets the Value of a grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object GetCellValue(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Function GetCellValue ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
) As Object
Visual C++
public:
Object^ GetCellValue(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


HitTest Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..HitTest Method
CellsArea Class See Also Send Feedback
Returns the grid cell at a specific position

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell HitTest(
    Point point
)
Visual Basic
Public Function HitTest ( _
    point As Point _
) As GridCell
Visual C++
public:
GridCell^ HitTest(
    Point point
)

Parameters

point
Type: System.Drawing..::..Point

Return Value

A reference to a grid cell or null if the position is outside of the cells area

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


IsCellMerged Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..IsCellMerged Method
CellsArea Class See Also Send Feedback
Determines whether the specific cell is merged.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsCellMerged(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Function IsCellMerged ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
) As Boolean
Visual C++
public:
bool IsCellMerged(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The row item.
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The column item.

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


IsCellSelected Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..IsCellSelected Method
CellsArea Class See Also Send Feedback
Determines whether a grid cell is selected

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsCellSelected(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Function IsCellSelected ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
) As Boolean
Visual C++
public:
bool IsCellSelected(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column

Return Value

The method returns true when the cell is selected.

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


IsLockedCell Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..IsLockedCell Method
CellsArea Class See Also Send Feedback
Determines if a grid cell is locked or not

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsLockedCell(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Function IsLockedCell ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
) As Boolean
Visual C++
public:
bool IsLockedCell(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column

Return Value

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


LockCell Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..LockCell Method
CellsArea Class See Also Send Feedback
Locks a specific grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void LockCell(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Sub LockCell ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
)
Visual C++
public:
void LockCell(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


RemoveCellSpan Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..RemoveCellSpan Method
CellsArea Class See Also Send Feedback
Removes the cell merge.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void RemoveCellSpan(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Sub RemoveCellSpan ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
)
Visual C++
public:
void RemoveCellSpan(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The row item.
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The column item.

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


SelectCell Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SelectCell Method
CellsArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SelectCell(GridCell) | Selects a specific grid cell.
Public method | SelectCell(HierarchyItem, HierarchyItem) | Selects a specific grid cell.

See Also

CellsArea Class
CellsArea Members
VIBlend.WinForms.DataGridView Namespace


SelectCell Method (GridCell)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SelectCell Method (GridCell)
CellsArea Class See Also Send Feedback
Selects a specific grid cell.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SelectCell(
    GridCell cell
)
Visual Basic
Public Sub SelectCell ( _
    cell As GridCell _
)
Visual C++
public:
void SelectCell(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell

See Also

CellsArea Class
SelectCell Overload
VIBlend.WinForms.DataGridView Namespace


SelectCell Method (HierarchyItem, HierarchyItem)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SelectCell Method (HierarchyItem, HierarchyItem)
CellsArea Class See Also Send Feedback
Selects a specific grid cell.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SelectCell(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Sub SelectCell ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
)
Visual C++
public:
void SelectCell(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column

See Also

CellsArea Class
SelectCell Overload
VIBlend.WinForms.DataGridView Namespace


SetCellAutoSize Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellAutoSize Method
CellsArea Class See Also Send Feedback
Sets the size of the cell to auto.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCellAutoSize(
    HierarchyItem rowItem,
    HierarchyItem colItem,
    bool autoSize
)
Visual Basic
Public Sub SetCellAutoSize ( _
    rowItem As HierarchyItem, _
    colItem As HierarchyItem, _
    autoSize As Boolean _
)
Visual C++
public:
void SetCellAutoSize(
    HierarchyItem^ rowItem,
    HierarchyItem^ colItem,
    bool autoSize
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The row item.
colItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The col item.
autoSize
Type: System..::..Boolean
if set to true [auto size].

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


SetCellConditionalFormattingGroup Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellConditionalFormattingGroup Method
CellsArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCellConditionalFormattingGroup(GridCell, String) | Specifies the conditional formatting group name for a specific grid cell
Public method | SetCellConditionalFormattingGroup(HierarchyItem, String) | Specifies the conditional formatting group name for a specific row or column item
Public method | SetCellConditionalFormattingGroup(HierarchyItem, HierarchyItem, String) | Specifies the conditional formatting group name for a specific grid cell

See Also

CellsArea Class
CellsArea Members
VIBlend.WinForms.DataGridView Namespace


SetCellConditionalFormattingGroup Method (GridCell, String)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellConditionalFormattingGroup Method (GridCell, String)
CellsArea Class See Also Send Feedback
Specifies the conditional formatting group name for a specific grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCellConditionalFormattingGroup(
    GridCell cell,
    string groupName
)
Visual Basic
Public Sub SetCellConditionalFormattingGroup ( _
    cell As GridCell, _
    groupName As String _
)
Visual C++
public:
void SetCellConditionalFormattingGroup(
    GridCell^ cell,
    String^ groupName
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
A reference to the grid cell
groupName
Type: System..::..String
The name of the conditional formatting group

See Also

CellsArea Class
SetCellConditionalFormattingGroup Overload
VIBlend.WinForms.DataGridView Namespace


SetCellConditionalFormattingGroup Method (HierarchyItem, String)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellConditionalFormattingGroup Method (HierarchyItem, String)
CellsArea Class See Also Send Feedback
Specifies the conditional formatting group name for a specific row or column item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCellConditionalFormattingGroup(
    HierarchyItem item,
    string groupName
)
Visual Basic
Public Sub SetCellConditionalFormattingGroup ( _
    item As HierarchyItem, _
    groupName As String _
)
Visual C++
public:
void SetCellConditionalFormattingGroup(
    HierarchyItem^ item,
    String^ groupName
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Row or column item to include in the group
groupName
Type: System..::..String
The name of the conditional formatting group

See Also

CellsArea Class
SetCellConditionalFormattingGroup Overload
VIBlend.WinForms.DataGridView Namespace


SetCellConditionalFormattingGroup Method (HierarchyItem, HierarchyItem, String)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellConditionalFormattingGroup Method (HierarchyItem, HierarchyItem, String)
CellsArea Class See Also Send Feedback
Specifies the conditional formatting group name for a specific grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCellConditionalFormattingGroup(
    HierarchyItem rowItem,
    HierarchyItem columnItem,
    string groupName
)
Visual Basic
Public Sub SetCellConditionalFormattingGroup ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem, _
    groupName As String _
)
Visual C++
public:
void SetCellConditionalFormattingGroup(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem,
    String^ groupName
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column
groupName
Type: System..::..String
The name of the conditional formatting group

See Also

CellsArea Class
SetCellConditionalFormattingGroup Overload
VIBlend.WinForms.DataGridView Namespace


SetCellDataSource Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellDataSource Method
CellsArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCellDataSource(HierarchyItem, GridCellDataSource) | Obsolete.
Public method | SetCellDataSource(HierarchyItem, HierarchyItem, GridCellDataSource) | Sets the data source property of a grid cell

See Also

CellsArea Class
CellsArea Members
VIBlend.WinForms.DataGridView Namespace


SetCellDataSource Method (HierarchyItem, GridCellDataSource)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellDataSource Method (HierarchyItem, GridCellDataSource)
CellsArea Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[ObsoleteAttribute("Use HierarchyItem.CellsDataSource property")]
public void SetCellDataSource(
    HierarchyItem Item,
    GridCellDataSource cellDataSource
)
Visual Basic
<ObsoleteAttribute("Use HierarchyItem.CellsDataSource property")> _
Public Sub SetCellDataSource ( _
    Item As HierarchyItem, _
    cellDataSource As GridCellDataSource _
)
Visual C++
[ObsoleteAttribute(L"Use HierarchyItem.CellsDataSource property")]
public:
void SetCellDataSource(
    HierarchyItem^ Item,
    GridCellDataSource cellDataSource
)

Parameters

Item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
cellDataSource
Type: VIBlend.WinForms.DataGridView..::..GridCellDataSource

See Also

CellsArea Class
SetCellDataSource Overload
VIBlend.WinForms.DataGridView Namespace


SetCellDataSource Method (HierarchyItem, HierarchyItem, GridCellDataSource)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellDataSource Method (HierarchyItem, HierarchyItem, GridCellDataSource)
CellsArea Class See Also Send Feedback
Sets the data source property of a grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCellDataSource(
    HierarchyItem rowItem,
    HierarchyItem columnItem,
    GridCellDataSource cellDataSource
)
Visual Basic
Public Sub SetCellDataSource ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem, _
    cellDataSource As GridCellDataSource _
)
Visual C++
public:
void SetCellDataSource(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem,
    GridCellDataSource cellDataSource
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column
cellDataSource
Type: VIBlend.WinForms.DataGridView..::..GridCellDataSource
Cell's data source type

See Also

CellsArea Class
SetCellDataSource Overload
VIBlend.WinForms.DataGridView Namespace


SetCellDisplaySettings Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellDisplaySettings Method
CellsArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCellDisplaySettings(HierarchyItem, DisplaySettings) | Obsolete.
Public method | SetCellDisplaySettings(HierarchyItem, HierarchyItem, DisplaySettings) | Sets the display settings for a specific cell.

See Also

CellsArea Class
CellsArea Members
VIBlend.WinForms.DataGridView Namespace


SetCellDisplaySettings Method (HierarchyItem, DisplaySettings)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellDisplaySettings Method (HierarchyItem, DisplaySettings)
CellsArea Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[ObsoleteAttribute("Use HierarchyItem.CellsDisplaySettings")]
public void SetCellDisplaySettings(
    HierarchyItem Item,
    DisplaySettings displaySettings
)
Visual Basic
<ObsoleteAttribute("Use HierarchyItem.CellsDisplaySettings")> _
Public Sub SetCellDisplaySettings ( _
    Item As HierarchyItem, _
    displaySettings As DisplaySettings _
)
Visual C++
[ObsoleteAttribute(L"Use HierarchyItem.CellsDisplaySettings")]
public:
void SetCellDisplaySettings(
    HierarchyItem^ Item,
    DisplaySettings displaySettings
)

Parameters

Item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
displaySettings
Type: VIBlend.WinForms.DataGridView..::..DisplaySettings

See Also

CellsArea Class
SetCellDisplaySettings Overload
VIBlend.WinForms.DataGridView Namespace


SetCellDisplaySettings Method (HierarchyItem, HierarchyItem, DisplaySettings)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellDisplaySettings Method (HierarchyItem, HierarchyItem, DisplaySettings)
CellsArea Class See Also Send Feedback
Sets the display settings for a specific cell.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCellDisplaySettings(
    HierarchyItem rowItem,
    HierarchyItem columnItem,
    DisplaySettings displaySettings
)
Visual Basic
Public Sub SetCellDisplaySettings ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem, _
    displaySettings As DisplaySettings _
)
Visual C++
public:
void SetCellDisplaySettings(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem,
    DisplaySettings displaySettings
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column
displaySettings
Type: VIBlend.WinForms.DataGridView..::..DisplaySettings
Cell's displaySettings

Remarks

Use this method to specify whether you want the grid cell to be displayed as text, image or both

See Also

CellsArea Class
SetCellDisplaySettings Overload
VIBlend.WinForms.DataGridView Namespace


SetCellDrawStyle Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellDrawStyle Method
CellsArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCellDrawStyle(HierarchyItem, GridCellStyle) | Obsolete.
Public method | SetCellDrawStyle(HierarchyItem, HierarchyItem, GridCellStyle) | Sets a custom draw style for a specific grid cell

See Also

CellsArea Class
CellsArea Members
VIBlend.WinForms.DataGridView Namespace


SetCellDrawStyle Method (HierarchyItem, GridCellStyle)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellDrawStyle Method (HierarchyItem, GridCellStyle)
CellsArea Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[ObsoleteAttribute("Use HierarchyItem.CellsStyle")]
public void SetCellDrawStyle(
    HierarchyItem item,
    GridCellStyle cellStyle
)
Visual Basic
<ObsoleteAttribute("Use HierarchyItem.CellsStyle")> _
Public Sub SetCellDrawStyle ( _
    item As HierarchyItem, _
    cellStyle As GridCellStyle _
)
Visual C++
[ObsoleteAttribute(L"Use HierarchyItem.CellsStyle")]
public:
void SetCellDrawStyle(
    HierarchyItem^ item,
    GridCellStyle^ cellStyle
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
cellStyle
Type: VIBlend.Utilities..::..GridCellStyle

See Also

CellsArea Class
SetCellDrawStyle Overload
VIBlend.WinForms.DataGridView Namespace


SetCellDrawStyle Method (HierarchyItem, HierarchyItem, GridCellStyle)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellDrawStyle Method (HierarchyItem, HierarchyItem, GridCellStyle)
CellsArea Class See Also Send Feedback
Sets a custom draw style for a specific grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCellDrawStyle(
    HierarchyItem rowItem,
    HierarchyItem colItem,
    GridCellStyle cellStyle
)
Visual Basic
Public Sub SetCellDrawStyle ( _
    rowItem As HierarchyItem, _
    colItem As HierarchyItem, _
    cellStyle As GridCellStyle _
)
Visual C++
public:
void SetCellDrawStyle(
    HierarchyItem^ rowItem,
    HierarchyItem^ colItem,
    GridCellStyle^ cellStyle
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
colItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
cellStyle
Type: VIBlend.Utilities..::..GridCellStyle

See Also

CellsArea Class
SetCellDrawStyle Overload
VIBlend.WinForms.DataGridView Namespace


SetCellEditor Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellEditor Method
CellsArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCellEditor(HierarchyItem, IEditor) | Obsolete.
Public method | SetCellEditor(HierarchyItem, HierarchyItem, IEditor) | Sets the data editor control for a specific grid cell

See Also

CellsArea Class
CellsArea Members
VIBlend.WinForms.DataGridView Namespace


SetCellEditor Method (HierarchyItem, IEditor)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellEditor Method (HierarchyItem, IEditor)
CellsArea Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[ObsoleteAttribute("Use HierarchyItem.CellsEditor")]
public void SetCellEditor(
    HierarchyItem item,
    IEditor editor
)
Visual Basic
<ObsoleteAttribute("Use HierarchyItem.CellsEditor")> _
Public Sub SetCellEditor ( _
    item As HierarchyItem, _
    editor As IEditor _
)
Visual C++
[ObsoleteAttribute(L"Use HierarchyItem.CellsEditor")]
public:
void SetCellEditor(
    HierarchyItem^ item,
    IEditor^ editor
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
editor
Type: VIBlend.WinForms.DataGridView..::..IEditor

See Also

CellsArea Class
SetCellEditor Overload
VIBlend.WinForms.DataGridView Namespace


SetCellEditor Method (HierarchyItem, HierarchyItem, IEditor)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellEditor Method (HierarchyItem, HierarchyItem, IEditor)
CellsArea Class See Also Send Feedback
Sets the data editor control for a specific grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCellEditor(
    HierarchyItem rowItem,
    HierarchyItem columnItem,
    IEditor cellEditor
)
Visual Basic
Public Sub SetCellEditor ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem, _
    cellEditor As IEditor _
)
Visual C++
public:
void SetCellEditor(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem,
    IEditor^ cellEditor
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column
cellEditor
Type: VIBlend.WinForms.DataGridView..::..IEditor
Cell's editor control

See Also

CellsArea Class
SetCellEditor Overload
VIBlend.WinForms.DataGridView Namespace


SetCellFormatProvider Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellFormatProvider Method
CellsArea Class See Also Send Feedback
Sets the format provider for a grid cell.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCellFormatProvider(
    HierarchyItem rowItem,
    HierarchyItem columnItem,
    IFormatProvider formatProvider
)
Visual Basic
Public Sub SetCellFormatProvider ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem, _
    formatProvider As IFormatProvider _
)
Visual C++
public:
void SetCellFormatProvider(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem,
    IFormatProvider^ formatProvider
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column
formatProvider
Type: System..::..IFormatProvider
Format provider to use for the grid cell.

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


SetCellFormatString Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellFormatString Method
CellsArea Class See Also Send Feedback
Sets the formatting for a grid cell.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCellFormatString(
    HierarchyItem rowItem,
    HierarchyItem columnItem,
    string formatString
)
Visual Basic
Public Sub SetCellFormatString ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem, _
    formatString As String _
)
Visual C++
public:
void SetCellFormatString(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem,
    String^ formatString
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column
formatString
Type: System..::..String
Format string for the grid cell's text.

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


SetCellImage Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellImage Method
CellsArea Class See Also Send Feedback
Sets the image index of a grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCellImage(
    HierarchyItem rowItem,
    HierarchyItem columnItem,
    int imageIndex
)
Visual Basic
Public Sub SetCellImage ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem, _
    imageIndex As Integer _
)
Visual C++
public:
void SetCellImage(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem,
    int imageIndex
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
imageIndex
Type: System..::..Int32
Image index

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


SetCellImageAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellImageAlignment Method
CellsArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCellImageAlignment(HierarchyItem, ContentAlignment) | Obsolete.
Public method | SetCellImageAlignment(HierarchyItem, HierarchyItem, ContentAlignment) | Sets the image alignment for a specific grid cell

See Also

CellsArea Class
CellsArea Members
VIBlend.WinForms.DataGridView Namespace


SetCellImageAlignment Method (HierarchyItem, ContentAlignment)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellImageAlignment Method (HierarchyItem, ContentAlignment)
CellsArea Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[ObsoleteAttribute("Use HierarchyItem.ImageAlignment")]
public void SetCellImageAlignment(
    HierarchyItem Item,
    ContentAlignment imageAlignment
)
Visual Basic
<ObsoleteAttribute("Use HierarchyItem.ImageAlignment")> _
Public Sub SetCellImageAlignment ( _
    Item As HierarchyItem, _
    imageAlignment As ContentAlignment _
)
Visual C++
[ObsoleteAttribute(L"Use HierarchyItem.ImageAlignment")]
public:
void SetCellImageAlignment(
    HierarchyItem^ Item,
    ContentAlignment imageAlignment
)

Parameters

Item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
imageAlignment
Type: System.Drawing..::..ContentAlignment

See Also

CellsArea Class
SetCellImageAlignment Overload
VIBlend.WinForms.DataGridView Namespace


SetCellImageAlignment Method (HierarchyItem, HierarchyItem, ContentAlignment)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellImageAlignment Method (HierarchyItem, HierarchyItem, ContentAlignment)
CellsArea Class See Also Send Feedback
Sets the image alignment for a specific grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCellImageAlignment(
    HierarchyItem rowItem,
    HierarchyItem columnItem,
    ContentAlignment imageAlignment
)
Visual Basic
Public Sub SetCellImageAlignment ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem, _
    imageAlignment As ContentAlignment _
)
Visual C++
public:
void SetCellImageAlignment(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem,
    ContentAlignment imageAlignment
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column
imageAlignment
Type: System.Drawing..::..ContentAlignment
Cell's image alignment

See Also

CellsArea Class
SetCellImageAlignment Overload
VIBlend.WinForms.DataGridView Namespace


SetCellImagePosition Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellImagePosition Method
CellsArea Class See Also Send Feedback
Sets the image positioning mode of a grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCellImagePosition(
    HierarchyItem rowItem,
    HierarchyItem colItem,
    ImagePositions position
)
Visual Basic
Public Sub SetCellImagePosition ( _
    rowItem As HierarchyItem, _
    colItem As HierarchyItem, _
    position As ImagePositions _
)
Visual C++
public:
void SetCellImagePosition(
    HierarchyItem^ rowItem,
    HierarchyItem^ colItem,
    ImagePositions position
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
colItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
position
Type: VIBlend.WinForms.DataGridView..::..ImagePositions

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


SetCellSpan Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellSpan Method
CellsArea Class See Also Send Feedback
Sets the span of a data grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCellSpan(
    HierarchyItem rowItem,
    HierarchyItem columnItem,
    int rowsCount,
    int columnsCount
)
Visual Basic
Public Sub SetCellSpan ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem, _
    rowsCount As Integer, _
    columnsCount As Integer _
)
Visual C++
public:
void SetCellSpan(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem,
    int rowsCount,
    int columnsCount
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The row of the grid cell.
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The column of the grid cell.
rowsCount
Type: System..::..Int32
Number of rows to merge/span
columnsCount
Type: System..::..Int32
Number of columns to merge/span

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


SetCellTextAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellTextAlignment Method
CellsArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCellTextAlignment(HierarchyItem, ContentAlignment) | Obsolete.
Public method | SetCellTextAlignment(HierarchyItem, HierarchyItem, ContentAlignment) | Sets the text alignment for a specific grid cell

See Also

CellsArea Class
CellsArea Members
VIBlend.WinForms.DataGridView Namespace


SetCellTextAlignment Method (HierarchyItem, ContentAlignment)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellTextAlignment Method (HierarchyItem, ContentAlignment)
CellsArea Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[ObsoleteAttribute("Use HierarchyItem.CellsTextAlignment")]
public void SetCellTextAlignment(
    HierarchyItem Item,
    ContentAlignment textAlignment
)
Visual Basic
<ObsoleteAttribute("Use HierarchyItem.CellsTextAlignment")> _
Public Sub SetCellTextAlignment ( _
    Item As HierarchyItem, _
    textAlignment As ContentAlignment _
)
Visual C++
[ObsoleteAttribute(L"Use HierarchyItem.CellsTextAlignment")]
public:
void SetCellTextAlignment(
    HierarchyItem^ Item,
    ContentAlignment textAlignment
)

Parameters

Item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
textAlignment
Type: System.Drawing..::..ContentAlignment

See Also

CellsArea Class
SetCellTextAlignment Overload
VIBlend.WinForms.DataGridView Namespace


SetCellTextAlignment Method (HierarchyItem, HierarchyItem, ContentAlignment)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellTextAlignment Method (HierarchyItem, HierarchyItem, ContentAlignment)
CellsArea Class See Also Send Feedback
Sets the text alignment for a specific grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCellTextAlignment(
    HierarchyItem rowItem,
    HierarchyItem columnItem,
    ContentAlignment textAlignment
)
Visual Basic
Public Sub SetCellTextAlignment ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem, _
    textAlignment As ContentAlignment _
)
Visual C++
public:
void SetCellTextAlignment(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem,
    ContentAlignment textAlignment
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column
textAlignment
Type: System.Drawing..::..ContentAlignment
Cell's new text alignment

See Also

CellsArea Class
SetCellTextAlignment Overload
VIBlend.WinForms.DataGridView Namespace


SetCellTextImageRelation Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellTextImageRelation Method
CellsArea Class See Also Send Feedback
Sets the text and image display relation of a grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCellTextImageRelation(
    HierarchyItem rowItem,
    HierarchyItem columnItem,
    TextImageRelation relation
)
Visual Basic
Public Sub SetCellTextImageRelation ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem, _
    relation As TextImageRelation _
)
Visual C++
public:
void SetCellTextImageRelation(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem,
    TextImageRelation relation
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column
relation
Type: System.Windows.Forms..::..TextImageRelation
Cell's text and image relation

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


SetCellTextWrap Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellTextWrap Method
CellsArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCellTextWrap(HierarchyItem, Boolean) | Obsolete.
Public method | SetCellTextWrap(HierarchyItem, HierarchyItem, Boolean) | Sets the text wrap mode for a specific grid cell

See Also

CellsArea Class
CellsArea Members
VIBlend.WinForms.DataGridView Namespace


SetCellTextWrap Method (HierarchyItem, Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellTextWrap Method (HierarchyItem, Boolean)
CellsArea Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[ObsoleteAttribute("Use HierarchyItem.CellsTextWrap")]
public void SetCellTextWrap(
    HierarchyItem item,
    bool textWrap
)
Visual Basic
<ObsoleteAttribute("Use HierarchyItem.CellsTextWrap")> _
Public Sub SetCellTextWrap ( _
    item As HierarchyItem, _
    textWrap As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use HierarchyItem.CellsTextWrap")]
public:
void SetCellTextWrap(
    HierarchyItem^ item,
    bool textWrap
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
textWrap
Type: System..::..Boolean

See Also

CellsArea Class
SetCellTextWrap Overload
VIBlend.WinForms.DataGridView Namespace


SetCellTextWrap Method (HierarchyItem, HierarchyItem, Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellTextWrap Method (HierarchyItem, HierarchyItem, Boolean)
CellsArea Class See Also Send Feedback
Sets the text wrap mode for a specific grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCellTextWrap(
    HierarchyItem rowItem,
    HierarchyItem columnItem,
    bool textWrap
)
Visual Basic
Public Sub SetCellTextWrap ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem, _
    textWrap As Boolean _
)
Visual C++
public:
void SetCellTextWrap(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem,
    bool textWrap
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
textWrap
Type: System..::..Boolean

See Also

CellsArea Class
SetCellTextWrap Overload
VIBlend.WinForms.DataGridView Namespace


SetCellValue Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetCellValue Method
CellsArea Class See Also Send Feedback
Sets the Value of a cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCellValue(
    HierarchyItem rowItem,
    HierarchyItem columnItem,
    Object value
)
Visual Basic
Public Sub SetCellValue ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem, _
    value As Object _
)
Visual C++
public:
void SetCellValue(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem,
    Object^ value
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
value
Type: System..::..Object

Remarks

The Value of a grid cell can be of any type. The default bahavior of the grid is to format and display the object as a String. If you want to override this behaviour, you need to specify a formatter for the cell or its corresponding row, or column.

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


SetItemConditionalFormattingGroup Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetItemConditionalFormattingGroup Method
CellsArea Class See Also Send Feedback
Specifies the conditional formatting group name for a specific row or column item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[ObsoleteAttribute("Please, use SetCellConditionalFormattingGroup")]
public void SetItemConditionalFormattingGroup(
    HierarchyItem item,
    string groupName
)
Visual Basic
<ObsoleteAttribute("Please, use SetCellConditionalFormattingGroup")> _
Public Sub SetItemConditionalFormattingGroup ( _
    item As HierarchyItem, _
    groupName As String _
)
Visual C++
[ObsoleteAttribute(L"Please, use SetCellConditionalFormattingGroup")]
public:
void SetItemConditionalFormattingGroup(
    HierarchyItem^ item,
    String^ groupName
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Row or column item to include in the group
groupName
Type: System..::..String
The name of the conditional formatting group

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


SetItemEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SetItemEditor Method
CellsArea Class See Also Send Feedback
Sets the grid cell editor for all cell in a row or column.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[ObsoleteAttribute("Please, use SetCellEditor")]
public void SetItemEditor(
    HierarchyItem item,
    IEditor editor
)
Visual Basic
<ObsoleteAttribute("Please, use SetCellEditor")> _
Public Sub SetItemEditor ( _
    item As HierarchyItem, _
    editor As IEditor _
)
Visual C++
[ObsoleteAttribute(L"Please, use SetCellEditor")]
public:
void SetItemEditor(
    HierarchyItem^ item,
    IEditor^ editor
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Row or a column item
editor
Type: VIBlend.WinForms.DataGridView..::..IEditor
The editor for the entire row or column

Remarks

Use this method to specify a cell editor for all cell in row or column.

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


UnlockAllCells Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..UnlockAllCells Method
CellsArea Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void UnlockAllCells()
Visual Basic
Public Sub UnlockAllCells
Visual C++
public:
void UnlockAllCells()

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


UnlockCell Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..UnlockCell Method
CellsArea Class See Also Send Feedback
Unlocks a specific grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void UnlockCell(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Sub UnlockCell ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
)
Visual C++
public:
void UnlockCell(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


UnSelectCell Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..UnSelectCell Method
CellsArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnSelectCell(GridCell) | Removes the selection for a specific grid cell
Public method | UnSelectCell(HierarchyItem, HierarchyItem) | Removes the selection for a specific grid cell

See Also

CellsArea Class
CellsArea Members
VIBlend.WinForms.DataGridView Namespace


UnSelectCell Method (GridCell)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..UnSelectCell Method (GridCell)
CellsArea Class See Also Send Feedback
Removes the selection for a specific grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void UnSelectCell(
    GridCell cell
)
Visual Basic
Public Sub UnSelectCell ( _
    cell As GridCell _
)
Visual C++
public:
void UnSelectCell(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell

See Also

CellsArea Class
UnSelectCell Overload
VIBlend.WinForms.DataGridView Namespace


UnSelectCell Method (HierarchyItem, HierarchyItem)

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..UnSelectCell Method (HierarchyItem, HierarchyItem)
CellsArea Class See Also Send Feedback
Removes the selection for a specific grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void UnSelectCell(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Sub UnSelectCell ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
)
Visual C++
public:
void UnSelectCell(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's row
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Cell's column

See Also

CellsArea Class
UnSelectCell Overload
VIBlend.WinForms.DataGridView Namespace


CellsArea Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellsArea Properties
CellsArea Class See Also Send Feedback

The CellsArea type exposes the following members.

Properties

Name Description
Public property AllowCellMerge
Specifies whether cell merge operations are allowed or not
Public property Cells
Retrieves all non-empty grid cells
Public property CellSpanGroupsCount
Returns the number of cell span groups

Remarks

Use this property to determine the number of cell merges in the data grid
Public property ConditionalFormattingEnabled
Determines whether the conditional formatting is on or off
Public property ConditionalFormattingGroups
Conditional formatting groups collection
Public property EditCell
Gets a reference to the grid cell that is currently being edited
Public property GridControl
Returns a reference to the Grid control hosting the CellsArea.
Public property NonEmptyCells
Retrieves all non-empty grid cells
Public property SelectedCells
Returns a list of all selected cells
Public property SelectedCellsCount
Returns the number of selected cells

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


AllowCellMerge Property

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..AllowCellMerge Property
CellsArea Class See Also Send Feedback
Specifies whether cell merge operations are allowed or not

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowCellMerge { get; set; }
Visual Basic
Public Property AllowCellMerge As Boolean
    Get
    Set
Visual C++
public:
property bool AllowCellMerge {
    bool get ();
    void set (bool value);
}

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


Cells Property

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..Cells Property
CellsArea Class See Also Send Feedback
Retrieves all non-empty grid cells

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell[] Cells { get; }
Visual Basic
Public ReadOnly Property Cells As GridCell()
    Get
Visual C++
public:
property array<GridCell^>^ Cells {
    array<GridCell^>^ get ();
}

Return Value

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


CellSpanGroupsCount Property

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..CellSpanGroupsCount Property
CellsArea Class See Also Send Feedback
Returns the number of cell span groups

Remarks

Use this property to determine the number of cell merges in the data grid

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int CellSpanGroupsCount { get; }
Visual Basic
Public ReadOnly Property CellSpanGroupsCount As Integer
    Get
Visual C++
public:
property int CellSpanGroupsCount {
    int get ();
}

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


ConditionalFormattingEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..ConditionalFormattingEnabled Property
CellsArea Class See Also Send Feedback
Determines whether the conditional formatting is on or off

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ConditionalFormattingEnabled { get; set; }
Visual Basic
Public Property ConditionalFormattingEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool ConditionalFormattingEnabled {
    bool get ();
    void set (bool value);
}

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


ConditionalFormattingGroups Property

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..ConditionalFormattingGroups Property
CellsArea Class See Also Send Feedback
Conditional formatting groups collection

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Dictionary<string, CellsArea..::..ConditionalFormattingGroup> ConditionalFormattingGroups { get; }
Visual Basic
Public ReadOnly Property ConditionalFormattingGroups As Dictionary(Of String, CellsArea..::..ConditionalFormattingGroup)
    Get
Visual C++
public:
property Dictionary<String^, CellsArea..::..ConditionalFormattingGroup^>^ ConditionalFormattingGroups {
    Dictionary<String^, CellsArea..::..ConditionalFormattingGroup^>^ get ();
}

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


EditCell Property

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..EditCell Property
CellsArea Class See Also Send Feedback
Gets a reference to the grid cell that is currently being edited

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell EditCell { get; }
Visual Basic
Public ReadOnly Property EditCell As GridCell
    Get
Visual C++
public:
property GridCell^ EditCell {
    GridCell^ get ();
}

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


GridControl Property

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..GridControl Property
CellsArea Class See Also Send Feedback
Returns a reference to the Grid control hosting the CellsArea.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDataGridView GridControl { get; }
Visual Basic
Public ReadOnly Property GridControl As vDataGridView
    Get
Visual C++
public:
property vDataGridView^ GridControl {
    vDataGridView^ get ();
}

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


NonEmptyCells Property

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..NonEmptyCells Property
CellsArea Class See Also Send Feedback
Retrieves all non-empty grid cells

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell[] NonEmptyCells { get; }
Visual Basic
Public ReadOnly Property NonEmptyCells As GridCell()
    Get
Visual C++
public:
property array<GridCell^>^ NonEmptyCells {
    array<GridCell^>^ get ();
}

Return Value

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


SelectedCells Property

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SelectedCells Property
CellsArea Class See Also Send Feedback
Returns a list of all selected cells

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell[] SelectedCells { get; }
Visual Basic
Public ReadOnly Property SelectedCells As GridCell()
    Get
Visual C++
public:
property array<GridCell^>^ SelectedCells {
    array<GridCell^>^ get ();
}

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


SelectedCellsCount Property

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..SelectedCellsCount Property
CellsArea Class See Also Send Feedback
Returns the number of selected cells

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int SelectedCellsCount { get; }
Visual Basic
Public ReadOnly Property SelectedCellsCount As Integer
    Get
Visual C++
public:
property int SelectedCellsCount {
    int get ();
}

See Also

CellsArea Class
VIBlend.WinForms.DataGridView Namespace


CellsArea.ConditionalFormattingGroup Class

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..ConditionalFormattingGroup Class
CellsArea Class Members See Also Send Feedback
Represents a conditional formatting group

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class ConditionalFormattingGroup
Visual Basic
Public Class ConditionalFormattingGroup
Visual C++
public ref class ConditionalFormattingGroup

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..CellsArea..::..ConditionalFormattingGroup

See Also

CellsArea..::..ConditionalFormattingGroup Members
VIBlend.WinForms.DataGridView Namespace


CellsArea.ConditionalFormattingGroup Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..ConditionalFormattingGroup Members
CellsArea..::..ConditionalFormattingGroup Class Constructors Methods See Also Send Feedback

Represents the data grid's cell area
Represents the data grid's cell area

The CellsArea..::..ConditionalFormattingGroup type exposes the following members.

Constructors

 | Name | Description
Public method | CellsArea..::..ConditionalFormattingGroup | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCFColor | Calculates the Color corresponding to a specific value
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetConditionalFormattingColorScale | Sets the Color scale for the group
Public method | SetCustomConditionalFormattingColorScale | Specifies a custom conditional formatting color scale
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CellsArea..::..ConditionalFormattingGroup Class
VIBlend.WinForms.DataGridView Namespace


CellsArea.ConditionalFormattingGroup Constructor

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..ConditionalFormattingGroup Constructor
CellsArea..::..ConditionalFormattingGroup Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ConditionalFormattingGroup()
Visual Basic
Public Sub New
Visual C++
public:
ConditionalFormattingGroup()

See Also

CellsArea..::..ConditionalFormattingGroup Class
VIBlend.WinForms.DataGridView Namespace


CellsArea.ConditionalFormattingGroup Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..ConditionalFormattingGroup Methods
CellsArea..::..ConditionalFormattingGroup Class See Also Send Feedback

The CellsArea..::..ConditionalFormattingGroup type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCFColor | Calculates the Color corresponding to a specific value
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetConditionalFormattingColorScale | Sets the Color scale for the group
Public method | SetCustomConditionalFormattingColorScale | Specifies a custom conditional formatting color scale
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CellsArea..::..ConditionalFormattingGroup Class
VIBlend.WinForms.DataGridView Namespace


GetCFColor Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..ConditionalFormattingGroup..::..GetCFColor Method
CellsArea..::..ConditionalFormattingGroup Class See Also Send Feedback
Calculates the Color corresponding to a specific value

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color GetCFColor(
    double value
)
Visual Basic
Public Function GetCFColor ( _
    value As Double _
) As Color
Visual C++
public:
Color GetCFColor(
    double value
)

Parameters

value
Type: System..::..Double
The value for which the color has to be calculated

Return Value

A Color corresponding to the value specified

See Also

CellsArea..::..ConditionalFormattingGroup Class
VIBlend.WinForms.DataGridView Namespace


SetConditionalFormattingColorScale Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..ConditionalFormattingGroup..::..SetConditionalFormattingColorScale Method
CellsArea..::..ConditionalFormattingGroup Class See Also Send Feedback
Sets the Color scale for the group

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetConditionalFormattingColorScale(
    GridCellCFColorScale colorScale
)
Visual Basic
Public Sub SetConditionalFormattingColorScale ( _
    colorScale As GridCellCFColorScale _
)
Visual C++
public:
void SetConditionalFormattingColorScale(
    GridCellCFColorScale colorScale
)

Parameters

colorScale
Type: VIBlend.WinForms.DataGridView..::..GridCellCFColorScale
The color scale for the group

See Also

CellsArea..::..ConditionalFormattingGroup Class
VIBlend.WinForms.DataGridView Namespace


SetCustomConditionalFormattingColorScale Method

[image]

VIBlend Controls for WinForms Help Documentation
CellsArea..::..ConditionalFormattingGroup..::..SetCustomConditionalFormattingColorScale Method
CellsArea..::..ConditionalFormattingGroup Class See Also Send Feedback
Specifies a custom conditional formatting color scale

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetCustomConditionalFormattingColorScale(
    Color[] colors
)
Visual Basic
Public Sub SetCustomConditionalFormattingColorScale ( _
    colors As Color() _
)
Visual C++
public:
void SetCustomConditionalFormattingColorScale(
    array<Color>^ colors
)

Parameters

colors
Type: array< System.Drawing..::..Color >[]()[][]
You must pass an array of exactly 100 items of type Color

See Also

CellsArea..::..ConditionalFormattingGroup Class
VIBlend.WinForms.DataGridView Namespace


CellSpan Structure

[image]

VIBlend Controls for WinForms Help Documentation
CellSpan Structure
Members See Also Send Feedback
Defines a Cell span / cell merge inside the data grid's cells area (CellsArea)

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public struct CellSpan
Visual Basic
Public Structure CellSpan
Visual C++
public value class CellSpan

See Also

CellSpan Members
VIBlend.WinForms.DataGridView Namespace


CellSpan Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellSpan Members
CellSpan Structure Constructors Methods Fields See Also Send Feedback

The CellSpan type exposes the following members.

Constructors

 | Name | Description
Public method | CellSpan | Initializes a new instance of the CellSpan class

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | ColumnItem | Column HierarchyItem corresponding to the grid cell
Public field | ColumnsCount | Number of Columns to span / merge
Public field | RowItem | Row HierarchyItem corresponding to the grid cell
Public field | RowsCount | Number of Rows to span / marge

See Also

CellSpan Structure
VIBlend.WinForms.DataGridView Namespace


CellSpan Constructor

[image]

VIBlend Controls for WinForms Help Documentation
CellSpan Constructor
CellSpan Structure See Also Send Feedback
Initializes a new instance of the CellSpan class

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellSpan(
    HierarchyItem rowItem,
    HierarchyItem columnItem,
    int rowsCount,
    int columnsCount
)
Visual Basic
Public Sub New ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem, _
    rowsCount As Integer, _
    columnsCount As Integer _
)
Visual C++
public:
CellSpan(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem,
    int rowsCount,
    int columnsCount
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
rowsCount
Type: System..::..Int32
columnsCount
Type: System..::..Int32

See Also

CellSpan Structure
VIBlend.WinForms.DataGridView Namespace


CellSpan Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellSpan Fields
CellSpan Structure See Also Send Feedback

The CellSpan type exposes the following members.

Fields

 | Name | Description
Public field | ColumnItem | Column HierarchyItem corresponding to the grid cell
Public field | ColumnsCount | Number of Columns to span / merge
Public field | RowItem | Row HierarchyItem corresponding to the grid cell
Public field | RowsCount | Number of Rows to span / marge

See Also

CellSpan Structure
VIBlend.WinForms.DataGridView Namespace


ColumnItem Field

[image]

VIBlend Controls for WinForms Help Documentation
CellSpan..::..ColumnItem Field
CellSpan Structure See Also Send Feedback
Column HierarchyItem corresponding to the grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem ColumnItem
Visual Basic
Public ColumnItem As HierarchyItem
Visual C++
public:
HierarchyItem^ ColumnItem

See Also

CellSpan Structure
VIBlend.WinForms.DataGridView Namespace


ColumnsCount Field

[image]

VIBlend Controls for WinForms Help Documentation
CellSpan..::..ColumnsCount Field
CellSpan Structure See Also Send Feedback
Number of Columns to span / merge

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ColumnsCount
Visual Basic
Public ColumnsCount As Integer
Visual C++
public:
int ColumnsCount

See Also

CellSpan Structure
VIBlend.WinForms.DataGridView Namespace


RowItem Field

[image]

VIBlend Controls for WinForms Help Documentation
CellSpan..::..RowItem Field
CellSpan Structure See Also Send Feedback
Row HierarchyItem corresponding to the grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem RowItem
Visual Basic
Public RowItem As HierarchyItem
Visual C++
public:
HierarchyItem^ RowItem

See Also

CellSpan Structure
VIBlend.WinForms.DataGridView Namespace


RowsCount Field

[image]

VIBlend Controls for WinForms Help Documentation
CellSpan..::..RowsCount Field
CellSpan Structure See Also Send Feedback
Number of Rows to span / marge

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int RowsCount
Visual Basic
Public RowsCount As Integer
Visual C++
public:
int RowsCount

See Also

CellSpan Structure
VIBlend.WinForms.DataGridView Namespace


CellSpan Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellSpan Methods
CellSpan Structure See Also Send Feedback

The CellSpan type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

CellSpan Structure
VIBlend.WinForms.DataGridView Namespace


CellValueChangingEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
CellValueChangingEventArgs Class
Members See Also Send Feedback
Represents a DataGridView grid cell value change event arguments.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class CellValueChangingEventArgs : CellCancelEventArgs
Visual Basic
Public Class CellValueChangingEventArgs _
    Inherits CellCancelEventArgs
Visual C++
public ref class CellValueChangingEventArgs : public CellCancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.DataGridView..::..CellEventArgs
VIBlend.WinForms.DataGridView..::..CellCancelEventArgs
VIBlend.WinForms.DataGridView..::..CellValueChangingEventArgs

See Also

CellValueChangingEventArgs Members
VIBlend.WinForms.DataGridView Namespace


CellValueChangingEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellValueChangingEventArgs Members
CellValueChangingEventArgs Class Constructors Methods Properties See Also Send Feedback

The CellValueChangingEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CellValueChangingEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Determines if the event is canceled. (Inherited from CellCancelEventArgs.)
Public property | Cell | GridCell associated with the event (Inherited from CellEventArgs.)
Public property | NewValue | The new value of the grid cell.

See Also

CellValueChangingEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellValueChangingEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
CellValueChangingEventArgs Constructor
CellValueChangingEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellValueChangingEventArgs(
    GridCell cell,
    Object newValue
)
Visual Basic
Public Sub New ( _
    cell As GridCell, _
    newValue As Object _
)
Visual C++
public:
CellValueChangingEventArgs(
    GridCell^ cell,
    Object^ newValue
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
newValue
Type: System..::..Object

See Also

CellValueChangingEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellValueChangingEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellValueChangingEventArgs Methods
CellValueChangingEventArgs Class See Also Send Feedback

The CellValueChangingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CellValueChangingEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellValueChangingEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellValueChangingEventArgs Properties
CellValueChangingEventArgs Class See Also Send Feedback

The CellValueChangingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Determines if the event is canceled. (Inherited from CellCancelEventArgs.)
Public property | Cell | GridCell associated with the event (Inherited from CellEventArgs.)
Public property | NewValue | The new value of the grid cell.

See Also

CellValueChangingEventArgs Class
VIBlend.WinForms.DataGridView Namespace


NewValue Property

[image]

VIBlend Controls for WinForms Help Documentation
CellValueChangingEventArgs..::..NewValue Property
CellValueChangingEventArgs Class See Also Send Feedback
The new value of the grid cell.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object NewValue { get; set; }
Visual Basic
Public Property NewValue As Object
    Get
    Set
Visual C++
public:
property Object^ NewValue {
    Object^ get ();
    void set (Object^ value);
}

See Also

CellValueChangingEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellValueNeededEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
CellValueNeededEventArgs Class
Members See Also Send Feedback
Represents a data grid value need event arguments

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class CellValueNeededEventArgs
Visual Basic
Public Class CellValueNeededEventArgs
Visual C++
public ref class CellValueNeededEventArgs

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..CellValueNeededEventArgs

See Also

CellValueNeededEventArgs Members
VIBlend.WinForms.DataGridView Namespace


CellValueNeededEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellValueNeededEventArgs Members
CellValueNeededEventArgs Class Constructors Methods Fields See Also Send Feedback

The CellValueNeededEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CellValueNeededEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | CellImageIndex | The image index of the cell's image
Public field | CellValue | The value of the cell
Public field | ColumnItem | Cell's Column
Public field | RowItem | Cell's Row

See Also

CellValueNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellValueNeededEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
CellValueNeededEventArgs Constructor
CellValueNeededEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellValueNeededEventArgs(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Sub New ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
)
Visual C++
public:
CellValueNeededEventArgs(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem

See Also

CellValueNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellValueNeededEventArgs Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellValueNeededEventArgs Fields
CellValueNeededEventArgs Class See Also Send Feedback

The CellValueNeededEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | CellImageIndex | The image index of the cell's image
Public field | CellValue | The value of the cell
Public field | ColumnItem | Cell's Column
Public field | RowItem | Cell's Row

See Also

CellValueNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellImageIndex Field

[image]

VIBlend Controls for WinForms Help Documentation
CellValueNeededEventArgs..::..CellImageIndex Field
CellValueNeededEventArgs Class See Also Send Feedback
The image index of the cell's image

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int CellImageIndex
Visual Basic
Public CellImageIndex As Integer
Visual C++
public:
int CellImageIndex

See Also

CellValueNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellValue Field

[image]

VIBlend Controls for WinForms Help Documentation
CellValueNeededEventArgs..::..CellValue Field
CellValueNeededEventArgs Class See Also Send Feedback
The value of the cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object CellValue
Visual Basic
Public CellValue As Object
Visual C++
public:
Object^ CellValue

See Also

CellValueNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


ColumnItem Field

[image]

VIBlend Controls for WinForms Help Documentation
CellValueNeededEventArgs..::..ColumnItem Field
CellValueNeededEventArgs Class See Also Send Feedback
Cell's Column

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem ColumnItem
Visual Basic
Public ColumnItem As HierarchyItem
Visual C++
public:
HierarchyItem^ ColumnItem

See Also

CellValueNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


RowItem Field

[image]

VIBlend Controls for WinForms Help Documentation
CellValueNeededEventArgs..::..RowItem Field
CellValueNeededEventArgs Class See Also Send Feedback
Cell's Row

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem RowItem
Visual Basic
Public RowItem As HierarchyItem
Visual C++
public:
HierarchyItem^ RowItem

See Also

CellValueNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CellValueNeededEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
CellValueNeededEventArgs Methods
CellValueNeededEventArgs Class See Also Send Feedback

The CellValueNeededEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CellValueNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CheckBoxEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor Class
Members See Also Send Feedback
Represents a CheckBoxEditor used in the GridView control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class CheckBoxEditor : IEditor
Visual Basic
Public Class CheckBoxEditor _
    Implements IEditor
Visual C++
public ref class CheckBoxEditor : IEditor

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..CheckBoxEditor

See Also

CheckBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


CheckBoxEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor Members
CheckBoxEditor Class Constructors Methods Properties Events See Also Send Feedback

The CheckBoxEditor type exposes the following members.

Constructors

 | Name | Description
Public method | CheckBoxEditor | Constructor

Methods

 | Name | Description
Public method | DrawEditorControl | Handles the painting of the editor control
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCheckedChanged | Called when the check-state is changed.
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Public method | OnGridKeyDown | Handles grid KeyDown events
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | Control | Gets a reference to the underlying control of the editor
Public property | DeActivationFlags | Gets or sets the editor activation flags
Public property | EditCell | Gets the edit cell.
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | HandleGridSpaceKey | Gets or sets a value indicating whether to handle the space key.
Public property | ThreeState | Gets or sets a value indicating whether the checkBox supports indeterminate state.
Public property | VIBlendTheme | Gets or sets the VIblend theme.

Events

 | Name | Description
Public event | CheckedChanged | Occurs when the editor's value is changed.

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


CheckBoxEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor Constructor
CheckBoxEditor Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CheckBoxEditor()
Visual Basic
Public Sub New
Visual C++
public:
CheckBoxEditor()

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


CheckBoxEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor Methods
CheckBoxEditor Class See Also Send Feedback

The CheckBoxEditor type exposes the following members.

Methods

 | Name | Description
Public method | DrawEditorControl | Handles the painting of the editor control
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCheckedChanged | Called when the check-state is changed.
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Public method | OnGridKeyDown | Handles grid KeyDown events
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


DrawEditorControl Method

[image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor..::..DrawEditorControl Method
CheckBoxEditor Class See Also Send Feedback
Handles the painting of the editor control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawEditorControl(
    Graphics graphics,
    GridCell gridCell,
    out bool isDrawHandled
)
Visual Basic
Public Sub DrawEditorControl ( _
    graphics As Graphics, _
    gridCell As GridCell, _
    <OutAttribute> ByRef isDrawHandled As Boolean _
)
Visual C++
public:
virtual void DrawEditorControl(
    Graphics^ graphics,
    GridCell^ gridCell,
    [OutAttribute] bool% isDrawHandled
) sealed

Parameters

graphics
Type: System.Drawing..::..Graphics
Reference to the GDI+ surface
gridCell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the grid cell being rendered
isDrawHandled
Type: System..::..Boolean %
Output flag indicating whether the method handled the drawing or not

Implements

IEditor..::..DrawEditorControl(Graphics, GridCell, Boolean%)

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


LayoutEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor..::..LayoutEditor Method
CheckBoxEditor Class See Also Send Feedback
This methods is called by the grid control when the editor must update its layout

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void LayoutEditor(
    GridCell cell
)
Visual Basic
Public Overridable Sub LayoutEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void LayoutEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the GridCell being edited

Implements

IEditor..::..LayoutEditor(GridCell)

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


OnCheckedChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor..::..OnCheckedChanged Method
CheckBoxEditor Class See Also Send Feedback
Called when the check-state is changed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCheckedChanged()
Visual Basic
Protected Overridable Sub OnCheckedChanged
Visual C++
protected:
virtual void OnCheckedChanged()

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


OnCloseEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor..::..OnCloseEditor Method
CheckBoxEditor Class See Also Send Feedback
This method is called by the grid control when at the end of a cell edit operation

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnCloseEditor()
Visual Basic
Public Sub OnCloseEditor
Visual C++
public:
virtual void OnCloseEditor() sealed

Implements

IEditor..::..OnCloseEditor()()()()

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


OnGridKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor..::..OnGridKeyDown Method
CheckBoxEditor Class See Also Send Feedback
Handles grid KeyDown events

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnGridKeyDown(
    KeyEventArgs args,
    GridCell cell,
    out bool closeEditor,
    out bool closeEditorAndSaveChanges
)
Visual Basic
Public Sub OnGridKeyDown ( _
    args As KeyEventArgs, _
    cell As GridCell, _
    <OutAttribute> ByRef closeEditor As Boolean, _
    <OutAttribute> ByRef closeEditorAndSaveChanges As Boolean _
)
Visual C++
public:
virtual void OnGridKeyDown(
    KeyEventArgs^ args,
    GridCell^ cell,
    [OutAttribute] bool% closeEditor,
    [OutAttribute] bool% closeEditorAndSaveChanges
) sealed

Parameters

args
Type: System.Windows.Forms..::..KeyEventArgs
KeyDown event arguments
cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
closeEditor
Type: System..::..Boolean %
The grid cell where the event occured. This may be null if the event did not occur within a grid cell.Output flag indicating whether to keep the editor open or close it instantly
closeEditorAndSaveChanges
Type: System..::..Boolean %

Implements

IEditor..::..OnGridKeyDown(KeyEventArgs, GridCell, Boolean%, Boolean%)

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


OnOpenEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor..::..OnOpenEditor Method
CheckBoxEditor Class See Also Send Feedback
This method is called by the grid control when the editor is being activated

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnOpenEditor(
    GridCell cell
)
Visual Basic
Public Sub OnOpenEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void OnOpenEditor(
    GridCell^ cell
) sealed

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell

Implements

IEditor..::..OnOpenEditor(GridCell)

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


CheckBoxEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor Properties
CheckBoxEditor Class See Also Send Feedback

The CheckBoxEditor type exposes the following members.

Properties

 | Name | Description
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | Control | Gets a reference to the underlying control of the editor
Public property | DeActivationFlags | Gets or sets the editor activation flags
Public property | EditCell | Gets the edit cell.
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | HandleGridSpaceKey | Gets or sets a value indicating whether to handle the space key.
Public property | ThreeState | Gets or sets a value indicating whether the checkBox supports indeterminate state.
Public property | VIBlendTheme | Gets or sets the VIblend theme.

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


ActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor..::..ActivationFlags Property
CheckBoxEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags ActivationFlags { get; set; }
Visual Basic
Public Property ActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags ActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..ActivationFlags

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


Control Property

[image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor..::..Control Property
CheckBoxEditor Class See Also Send Feedback
Gets a reference to the underlying control of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control Control { get; }
Visual Basic
Public ReadOnly Property Control As Control
    Get
Visual C++
public:
virtual property Control^ Control {
    Control^ get () sealed;
}

Implements

IEditor..::..Control

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


DeActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor..::..DeActivationFlags Property
CheckBoxEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags DeActivationFlags { get; set; }
Visual Basic
Public Property DeActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags DeActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..DeActivationFlags

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


EditCell Property

[image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor..::..EditCell Property
CheckBoxEditor Class See Also Send Feedback
Gets the edit cell.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell EditCell { get; }
Visual Basic
Public ReadOnly Property EditCell As GridCell
    Get
Visual C++
public:
property GridCell^ EditCell {
    GridCell^ get ();
}

Field Value

The edit cell.

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorType Property

[image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor..::..EditorType Property
CheckBoxEditor Class See Also Send Feedback
Gets the type of the grid cell editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellEditorType EditorType { get; }
Visual Basic
Public ReadOnly Property EditorType As CellEditorType
    Get
Visual C++
public:
virtual property CellEditorType EditorType {
    CellEditorType get () sealed;
}

Implements

IEditor..::..EditorType

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorValue Property

[image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor..::..EditorValue Property
CheckBoxEditor Class See Also Send Feedback
Get's or sets the current value of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object EditorValue { get; set; }
Visual Basic
Public Property EditorValue As Object
    Get
    Set
Visual C++
public:
virtual property Object^ EditorValue {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Implements

IEditor..::..EditorValue

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


HandleGridSpaceKey Property

[image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor..::..HandleGridSpaceKey Property
CheckBoxEditor Class See Also Send Feedback
Gets or sets a value indicating whether to handle the space key.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool HandleGridSpaceKey { get; set; }
Visual Basic
Public Property HandleGridSpaceKey As Boolean
    Get
    Set
Visual C++
public:
property bool HandleGridSpaceKey {
    bool get ();
    void set (bool value);
}

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


ThreeState Property

[image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor..::..ThreeState Property
CheckBoxEditor Class See Also Send Feedback
Gets or sets a value indicating whether the checkBox supports indeterminate state.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ThreeState { get; set; }
Visual Basic
Public Property ThreeState As Boolean
    Get
    Set
Visual C++
public:
property bool ThreeState {
    bool get ();
    void set (bool value);
}

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor..::..VIBlendTheme Property
CheckBoxEditor Class See Also Send Feedback
Gets or sets the VIblend theme.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Nullable<VIBLEND_THEME> VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As Nullable(Of VIBLEND_THEME)
    Get
    Set
Visual C++
public:
property Nullable<VIBLEND_THEME> VIBlendTheme {
    Nullable<VIBLEND_THEME> get ();
    void set (Nullable<VIBLEND_THEME> value);
}

Field Value

The VIblend theme.

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


CheckBoxEditor Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor Events
CheckBoxEditor Class See Also Send Feedback

The CheckBoxEditor type exposes the following members.

Events

 | Name | Description
Public event | CheckedChanged | Occurs when the editor's value is changed.

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


CheckedChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
CheckBoxEditor..::..CheckedChanged Event
CheckBoxEditor Class See Also Send Feedback
Occurs when the editor's value is changed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler CheckedChanged
Visual Basic
Public Event CheckedChanged As EventHandler
Visual C++
public:
 event EventHandler^ CheckedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

CheckBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


CollectionChangedEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
CollectionChangedEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class CollectionChangedEventArgs : EventArgs
Visual Basic
Public Class CollectionChangedEventArgs _
    Inherits EventArgs
Visual C++
public ref class CollectionChangedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.DataGridView..::..CollectionChangedEventArgs

See Also

CollectionChangedEventArgs Members
VIBlend.WinForms.DataGridView Namespace


CollectionChangedEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
CollectionChangedEventArgs Members
CollectionChangedEventArgs Class Constructors Methods Properties See Also Send Feedback

The CollectionChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CollectionChangedEventArgs | Initializes a new instance of the CollectionChangedEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Reason | Gets the reason.

See Also

CollectionChangedEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CollectionChangedEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
CollectionChangedEventArgs Constructor
CollectionChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the CollectionChangedEventArgs class

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CollectionChangedEventArgs(
    CollectionChangedReason reason
)
Visual Basic
Public Sub New ( _
    reason As CollectionChangedReason _
)
Visual C++
public:
CollectionChangedEventArgs(
    CollectionChangedReason reason
)

Parameters

reason
Type: VIBlend.WinForms.DataGridView..::..CollectionChangedReason

See Also

CollectionChangedEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CollectionChangedEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
CollectionChangedEventArgs Methods
CollectionChangedEventArgs Class See Also Send Feedback

The CollectionChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CollectionChangedEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CollectionChangedEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
CollectionChangedEventArgs Properties
CollectionChangedEventArgs Class See Also Send Feedback

The CollectionChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Reason | Gets the reason.

See Also

CollectionChangedEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Reason Property

[image]

VIBlend Controls for WinForms Help Documentation
CollectionChangedEventArgs..::..Reason Property
CollectionChangedEventArgs Class See Also Send Feedback
Gets the reason.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CollectionChangedReason Reason { get; }
Visual Basic
Public ReadOnly Property Reason As CollectionChangedReason
    Get
Visual C++
public:
property CollectionChangedReason Reason {
    CollectionChangedReason get ();
}

Field Value

The reason.

See Also

CollectionChangedEventArgs Class
VIBlend.WinForms.DataGridView Namespace


CollectionChangedReason Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
CollectionChangedReason Enumeration
See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum CollectionChangedReason
Visual Basic
Public Enumeration CollectionChangedReason
Visual C++
public enum class CollectionChangedReason

Members

Member name | Description
Add |
Remove |
Reset |
ItemChange |

See Also

VIBlend.WinForms.DataGridView Namespace


ColumnChooser Class

[image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class ColumnChooser : RibbonForm
Visual Basic
Public Class ColumnChooser _
    Inherits RibbonForm
Visual C++
public ref class ColumnChooser : public RibbonForm

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
VIBlend.WinForms.Controls..::..vForm
VIBlend.WinForms.Controls..::..RibbonForm
VIBlend.WinForms.DataGridView..::..ColumnChooser

See Also

ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


ColumnChooser Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser Members
ColumnChooser Class Constructors Methods Fields Properties Events See Also Send Feedback

The ColumnChooser type exposes the following members.

Constructors

 | Name | Description
Public method | ColumnChooser | Initializes a new instance of the ColumnChooser class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vForm.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawText | (Inherited from vForm.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetFocusControl | (Inherited from vForm.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPointFromPtr | (Inherited from vForm.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleMaximize | Handles the maximize. (Inherited from vForm.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Protected method | InvalidateFrame | (Inherited from RibbonForm.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NCHitTest | (Inherited from vForm.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from vForm.)
Protected method | OnActivating | (Inherited from vForm.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from vForm.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the [E:Layout] event. (Inherited from RibbonForm.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from vForm.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from vForm.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from vForm.)
Protected method | OnMouseEnter | (Overrides vForm..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from vForm.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from RibbonForm.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | (Inherited from vForm.)
Protected method | OnResizeEnd | (Inherited from vForm.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from vForm.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | Populate | Popuplates this instance.
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetPadding | Sets the padding. (Inherited from vForm.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show()()()() | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Public method | WMNCHitTest | (Inherited from vForm.)
Protected method | WndProc | (Inherited from vForm.)

Fields

 | Name | Description
Protected field | boundsHelper | (Inherited from vForm.)
Protected field | closeButton | (Inherited from vForm.)
Protected field | helper | (Inherited from vForm.)
Protected field | maximizeButton | (Inherited from vForm.)
Protected field | minimizeButton | (Inherited from vForm.)
Protected field | titleFill | (Inherited from vForm.)

Properties

 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vForm.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowMaximize | Gets or sets a value indicating whether form is maximized on double click (Inherited from vForm.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderWidth | Gets or sets the width of the border. (Inherited from vForm.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsHelper | (Inherited from vForm.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CloseBox | Gets or sets a value indicating whether to show the close box. (Inherited from vForm.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataGrid | Gets or sets the data grid.
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from vForm.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | HasRibbon | Gets or sets a value indicating whether this instance has ribbon. (Inherited from RibbonForm.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsActiveWindow | Gets a value indicating whether this instance is active window. (Inherited from vForm.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from vForm.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from vForm.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | RoundRadius | Gets or sets the round radius. (Inherited from vForm.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ShadowColor | Gets or sets the color of the shadow. (Inherited from vForm.)
Public property | ShadowWidth | Gets or sets the width of the shadow. (Inherited from vForm.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Protected property | StyleKey | Gets or sets the style key. (Inherited from RibbonForm.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | TextAlignment | Gets or sets the text alignment. (Inherited from vForm.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from RibbonForm.)
Public property | TitleHeight | Gets or sets the height of the title. (Inherited from vForm.)
Public property | TitleOpacity | Gets or sets the title opacity. (Inherited from vForm.)
Public property | TitleRectangle | Gets the title rectangle. (Inherited from vForm.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vForm.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets the form's window state. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | Activating | Occurs when form is activating. (Inherited from vForm.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ColumnChooser Class
VIBlend.WinForms.DataGridView Namespace


ColumnChooser Constructor

[image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser Constructor
ColumnChooser Class See Also Send Feedback
Initializes a new instance of the ColumnChooser class.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ColumnChooser()
Visual Basic
Public Sub New
Visual C++
public:
ColumnChooser()

See Also

ColumnChooser Class
VIBlend.WinForms.DataGridView Namespace


ColumnChooser Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser Fields
ColumnChooser Class See Also Send Feedback

The ColumnChooser type exposes the following members.

Fields

 | Name | Description
Protected field | boundsHelper | (Inherited from vForm.)
Protected field | closeButton | (Inherited from vForm.)
Protected field | helper | (Inherited from vForm.)
Protected field | maximizeButton | (Inherited from vForm.)
Protected field | minimizeButton | (Inherited from vForm.)
Protected field | titleFill | (Inherited from vForm.)

See Also

ColumnChooser Class
VIBlend.WinForms.DataGridView Namespace


ColumnChooser Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser Methods
ColumnChooser Class See Also Send Feedback

The ColumnChooser type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vForm.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawText | (Inherited from vForm.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetFocusControl | (Inherited from vForm.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPointFromPtr | (Inherited from vForm.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleMaximize | Handles the maximize. (Inherited from vForm.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Protected method | InvalidateFrame | (Inherited from RibbonForm.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NCHitTest | (Inherited from vForm.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from vForm.)
Protected method | OnActivating | (Inherited from vForm.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from vForm.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the [E:Layout] event. (Inherited from RibbonForm.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from vForm.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from vForm.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from vForm.)
Protected method | OnMouseEnter | (Overrides vForm..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from vForm.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from RibbonForm.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | (Inherited from vForm.)
Protected method | OnResizeEnd | (Inherited from vForm.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from vForm.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | Populate | Popuplates this instance.
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetPadding | Sets the padding. (Inherited from vForm.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show()()()() | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Public method | WMNCHitTest | (Inherited from vForm.)
Protected method | WndProc | (Inherited from vForm.)

See Also

ColumnChooser Class
VIBlend.WinForms.DataGridView Namespace


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..AccessibilityNotifyClients Method
ColumnChooser Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ColumnChooser Class
ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..BeginInvoke Method
ColumnChooser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ColumnChooser Class
ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..Dispose Method
ColumnChooser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vForm.)

See Also

ColumnChooser Class
ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..GetChildAtPoint Method
ColumnChooser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ColumnChooser Class
ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..Invalidate Method
ColumnChooser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ColumnChooser Class
ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..Invoke Method
ColumnChooser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ColumnChooser Class
ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..MemberwiseClone Method
ColumnChooser Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ColumnChooser Class
ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


OnMouseEnter Method

[image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..OnMouseEnter Method
ColumnChooser Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseEnter(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseEnter ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseEnter(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

ColumnChooser Class
VIBlend.WinForms.DataGridView Namespace


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..PerformLayout Method
ColumnChooser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ColumnChooser Class
ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


Populate Method

[image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..Populate Method
ColumnChooser Class See Also Send Feedback
Popuplates this instance.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Populate()
Visual Basic
Public Sub Populate
Visual C++
public:
void Populate()

See Also

ColumnChooser Class
VIBlend.WinForms.DataGridView Namespace


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..ResumeLayout Method
ColumnChooser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ColumnChooser Class
ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..RtlTranslateAlignment Method
ColumnChooser Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ColumnChooser Class
ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..Scale Method
ColumnChooser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ColumnChooser Class
ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..Select Method
ColumnChooser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

ColumnChooser Class
ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..SetBounds Method
ColumnChooser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ColumnChooser Class
ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


Show Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..Show Method
ColumnChooser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Show()()()() | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

ColumnChooser Class
ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


ShowDialog Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..ShowDialog Method
ColumnChooser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

ColumnChooser Class
ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..UpdateBounds Method
ColumnChooser Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ColumnChooser Class
ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


Validate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..Validate Method
ColumnChooser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ColumnChooser Class
ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


ValidateChildren Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..ValidateChildren Method
ColumnChooser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ColumnChooser Class
ColumnChooser Members
VIBlend.WinForms.DataGridView Namespace


ColumnChooser Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser Properties
ColumnChooser Class See Also Send Feedback

The ColumnChooser type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vForm.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowMaximize | Gets or sets a value indicating whether form is maximized on double click (Inherited from vForm.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderWidth | Gets or sets the width of the border. (Inherited from vForm.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsHelper | (Inherited from vForm.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CloseBox | Gets or sets a value indicating whether to show the close box. (Inherited from vForm.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataGrid | Gets or sets the data grid.
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from vForm.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | HasRibbon | Gets or sets a value indicating whether this instance has ribbon. (Inherited from RibbonForm.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsActiveWindow | Gets a value indicating whether this instance is active window. (Inherited from vForm.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from vForm.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from vForm.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | RoundRadius | Gets or sets the round radius. (Inherited from vForm.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ShadowColor | Gets or sets the color of the shadow. (Inherited from vForm.)
Public property | ShadowWidth | Gets or sets the width of the shadow. (Inherited from vForm.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Protected property | StyleKey | Gets or sets the style key. (Inherited from RibbonForm.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | TextAlignment | Gets or sets the text alignment. (Inherited from vForm.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from RibbonForm.)
Public property | TitleHeight | Gets or sets the height of the title. (Inherited from vForm.)
Public property | TitleOpacity | Gets or sets the title opacity. (Inherited from vForm.)
Public property | TitleRectangle | Gets the title rectangle. (Inherited from vForm.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vForm.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets the form's window state. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

ColumnChooser Class
VIBlend.WinForms.DataGridView Namespace


DataGrid Property

[image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser..::..DataGrid Property
ColumnChooser Class See Also Send Feedback
Gets or sets the data grid.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDataGridView DataGrid { get; internal set; }
Visual Basic
Public Property DataGrid As vDataGridView
    Get
    Friend Set
Visual C++
public:
property vDataGridView^ DataGrid {
    vDataGridView^ get ();
    internal: void set (vDataGridView^ value);
}

Field Value

The data grid.

See Also

ColumnChooser Class
VIBlend.WinForms.DataGridView Namespace


ColumnChooser Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnChooser Events
ColumnChooser Class See Also Send Feedback

The ColumnChooser type exposes the following members.

Events

 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | Activating | Occurs when form is activating. (Inherited from vForm.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ColumnChooser Class
VIBlend.WinForms.DataGridView Namespace


ColumnsHierarchy Class

[image]

VIBlend Controls for WinForms Help Documentation
ColumnsHierarchy Class
Members See Also Send Feedback
Represents a ColumnsHierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class ColumnsHierarchy : Hierarchy
Visual Basic
Public Class ColumnsHierarchy _
    Inherits Hierarchy
Visual C++
public ref class ColumnsHierarchy : public Hierarchy

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..Hierarchy
VIBlend.WinForms.DataGridView..::..ColumnsHierarchy

See Also

ColumnsHierarchy Members
VIBlend.WinForms.DataGridView Namespace


ColumnsHierarchy Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnsHierarchy Members
ColumnsHierarchy Class Constructors Methods Properties Events See Also Send Feedback

The ColumnsHierarchy type exposes the following members.

Constructors

 | Name | Description
Public method | ColumnsHierarchy | Constructor

Methods

 | Name | Description
Protected method | ApplyFilters | (Inherited from Hierarchy.)
Public method | AutoResize()()()() | Resizes the items in the hierarchy for optimal visual appearance (Overrides Hierarchy..::..AutoResize()()()().)
Public method | AutoResize(AutoResizeMode) | Resizes the items in the hierarchy for optimal visual appearance (Overrides Hierarchy..::..AutoResize(AutoResizeMode).)
Public method | Clear | Removes all HierarchyItems and their settings. (Inherited from Hierarchy.)
Public method | ClearSelection | Unselects all selected items. (Inherited from Hierarchy.)
Public method | CollapseAllItems | Collapses all items in the Hierarchy (Inherited from Hierarchy.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandAllItems | Expands all items in the Hierarchy (Inherited from Hierarchy.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildItemsRecursive | Retrieves all child HierarchyItems at all levels (Inherited from Hierarchy.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemByUniqueID | Gets a HierarchyItem by its unique ID (Inherited from Hierarchy.)
Public method | GetNextItem | Returns the item displayed immediatelly after a specified item (Inherited from Hierarchy.)
Public method | GetPreviousItem | Returns the item displayed immediatelly before a specified item (Inherited from Hierarchy.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HitTest | Performs a HitTest at a specific point within the Hierarchy (Inherited from Hierarchy.)
Public method | IsItemSelected | Checks if an item is selected (Inherited from Hierarchy.)
Public method | IsSummaryItem | Checks if a specific item is a Summary Item (Inherited from Hierarchy.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnFilterChanged | (Inherited from Hierarchy.)
Protected method | OnSortingChanged | (Inherited from Hierarchy.)
Public method | RemoveSort | Removes the sorting order previously applied through the SortBy method (Inherited from Hierarchy.)
Public method | ResizeColumnsToFitGridWidth | Resizes the width of the columns to fit to the grid's width.
Public method | SelectItem | Selects an item in the Hierarchy (Inherited from Hierarchy.)
Public method | SetColumnWidth | Sets the width of a column within the hierarchy (Inherited from Hierarchy.)
Public method | SetRowHeight | Sets the height of the row. (Inherited from Hierarchy.)
Public method | ShowHiddenItems | Sets the status of all hidden items to visible. (Inherited from Hierarchy.)
Public method | SortBy(HierarchyItem, SortingDirection) | Sorts the Hierarchy by a specefic HierarchyItem (Inherited from Hierarchy.)
Public method | SortBy(HierarchyItem, SortingDirection, IComparer<(Of <<'(HierarchyItem>)>>)) | Sorts the Items in the Hierarchy. (Inherited from Hierarchy.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnSelectItem | UnSelects an item in the Hierarchy (Inherited from Hierarchy.)

Properties

 | Name | Description
Public property | AllowDragDrop | Gets or sets whether drag and drop is enabled for this Hierarchy (Inherited from Hierarchy.)
Public property | AllowResize | Gets or sets whether the HierarchyItems resizing is allowed (Inherited from Hierarchy.)
Public property | AutoStretchColumns | Gets or sets whether to automatically resize the columns when the total width is less than the width of the grid control.
Public property | ColumnWidths | Gets the columns' widths for the hierarchy (Inherited from Hierarchy.)
Public property | Filters | (Inherited from Hierarchy.)
Public property | Fixed | Determines if the Hierarchy is fixed or not. Fixed Hierarchies are not affected by the scrolling of the data grid's content (Inherited from Hierarchy.)
Public property | GridControl | Retruns a reference to the Grid control hosting the hierarchy (Inherited from Hierarchy.)
Public property | Height | Gets the Height of the Hierarchy in pixels
Public property | HiddenItems | Gets the hidden items (Inherited from Hierarchy.)
Public property | HierarchyDepth | Gets the depth of the hierarchy. (Inherited from Hierarchy.)
Public property | IsFiltered | Checks if the Hierarchy contains HierarchyItems which are filtered. (Inherited from Hierarchy.)
Public property | IsSorted | Checks if the Hierarchy is Sorted (Inherited from Hierarchy.)
Public property | Items | Gets the items of the Hierarchy (Inherited from Hierarchy.)
Public property | SelectedItems | Gets the selected items (Inherited from Hierarchy.)
Public property | ShowExpandCollapseButtons | Determines whether to show the expand/collapse buttons on the items hosted by the hierarchy (Inherited from Hierarchy.)
Public property | SortingDirection | Gets the sort order direction if the Hierarchy is sorted. (Inherited from Hierarchy.)
Public property | SortItem | Gets the Item the Hierarchy is sorted by. (Inherited from Hierarchy.)
Public property | SummaryItems | Gets the summary items of the Hierarchy (Inherited from Hierarchy.)
Public property | TotalItemsCount | Gets the total number of HierarchyItems hosted by the Hierarchy. This includes both Hierarchy items and Summary items. Hidden items are also counted. (Inherited from Hierarchy.)
Public property | Visible | Determines whether the hierarchy is visible (Inherited from Hierarchy.)
Public property | Width | Gets the Width of the Hierarchy in pixels
Public property | X | Returns the horizontal position of Hierarchy relative to the top-left corner of the grid control (Inherited from Hierarchy.)
Public property | Y | Returns the horizontal position of Hierarchy relative to the top-left corner of the grid control (Inherited from Hierarchy.)

Events

 | Name | Description
Public event | FiltersChanged | Occurs when the Hierarchy filters have changed. (Inherited from Hierarchy.)
Public event | SortingChanged | Occurs when the Hierarchy sorting have changed. (Inherited from Hierarchy.)

See Also

ColumnsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


ColumnsHierarchy Constructor

[image]

VIBlend Controls for WinForms Help Documentation
ColumnsHierarchy Constructor
ColumnsHierarchy Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ColumnsHierarchy(
    vDataGridView gridControl
)
Visual Basic
Public Sub New ( _
    gridControl As vDataGridView _
)
Visual C++
public:
ColumnsHierarchy(
    vDataGridView^ gridControl
)

Parameters

gridControl
Type: VIBlend.WinForms.DataGridView..::..vDataGridView
Reference to the grid control hosting the hierarchy

See Also

ColumnsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


ColumnsHierarchy Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnsHierarchy Methods
ColumnsHierarchy Class See Also Send Feedback

The ColumnsHierarchy type exposes the following members.

Methods

 | Name | Description
Protected method | ApplyFilters | (Inherited from Hierarchy.)
Public method | AutoResize()()()() | Resizes the items in the hierarchy for optimal visual appearance (Overrides Hierarchy..::..AutoResize()()()().)
Public method | AutoResize(AutoResizeMode) | Resizes the items in the hierarchy for optimal visual appearance (Overrides Hierarchy..::..AutoResize(AutoResizeMode).)
Public method | Clear | Removes all HierarchyItems and their settings. (Inherited from Hierarchy.)
Public method | ClearSelection | Unselects all selected items. (Inherited from Hierarchy.)
Public method | CollapseAllItems | Collapses all items in the Hierarchy (Inherited from Hierarchy.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandAllItems | Expands all items in the Hierarchy (Inherited from Hierarchy.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildItemsRecursive | Retrieves all child HierarchyItems at all levels (Inherited from Hierarchy.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemByUniqueID | Gets a HierarchyItem by its unique ID (Inherited from Hierarchy.)
Public method | GetNextItem | Returns the item displayed immediatelly after a specified item (Inherited from Hierarchy.)
Public method | GetPreviousItem | Returns the item displayed immediatelly before a specified item (Inherited from Hierarchy.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HitTest | Performs a HitTest at a specific point within the Hierarchy (Inherited from Hierarchy.)
Public method | IsItemSelected | Checks if an item is selected (Inherited from Hierarchy.)
Public method | IsSummaryItem | Checks if a specific item is a Summary Item (Inherited from Hierarchy.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnFilterChanged | (Inherited from Hierarchy.)
Protected method | OnSortingChanged | (Inherited from Hierarchy.)
Public method | RemoveSort | Removes the sorting order previously applied through the SortBy method (Inherited from Hierarchy.)
Public method | ResizeColumnsToFitGridWidth | Resizes the width of the columns to fit to the grid's width.
Public method | SelectItem | Selects an item in the Hierarchy (Inherited from Hierarchy.)
Public method | SetColumnWidth | Sets the width of a column within the hierarchy (Inherited from Hierarchy.)
Public method | SetRowHeight | Sets the height of the row. (Inherited from Hierarchy.)
Public method | ShowHiddenItems | Sets the status of all hidden items to visible. (Inherited from Hierarchy.)
Public method | SortBy(HierarchyItem, SortingDirection) | Sorts the Hierarchy by a specefic HierarchyItem (Inherited from Hierarchy.)
Public method | SortBy(HierarchyItem, SortingDirection, IComparer<(Of <<'(HierarchyItem>)>>)) | Sorts the Items in the Hierarchy. (Inherited from Hierarchy.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnSelectItem | UnSelects an item in the Hierarchy (Inherited from Hierarchy.)

See Also

ColumnsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


AutoResize Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnsHierarchy..::..AutoResize Method
ColumnsHierarchy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AutoResize()()()() | Resizes the items in the hierarchy for optimal visual appearance (Overrides Hierarchy..::..AutoResize()()()().)
Public method | AutoResize(AutoResizeMode) | Resizes the items in the hierarchy for optimal visual appearance (Overrides Hierarchy..::..AutoResize(AutoResizeMode).)

See Also

ColumnsHierarchy Class
ColumnsHierarchy Members
VIBlend.WinForms.DataGridView Namespace


AutoResize Method

[image]

VIBlend Controls for WinForms Help Documentation
ColumnsHierarchy..::..AutoResize Method
ColumnsHierarchy Class See Also Send Feedback
Resizes the items in the hierarchy for optimal visual appearance

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void AutoResize()
Visual Basic
Public Overrides Sub AutoResize
Visual C++
public:
virtual void AutoResize() override

See Also

ColumnsHierarchy Class
AutoResize Overload
VIBlend.WinForms.DataGridView Namespace


AutoResize Method (AutoResizeMode)

[image]

VIBlend Controls for WinForms Help Documentation
ColumnsHierarchy..::..AutoResize Method (AutoResizeMode)
ColumnsHierarchy Class See Also Send Feedback
Resizes the items in the hierarchy for optimal visual appearance

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void AutoResize(
    AutoResizeMode autoResizeMode
)
Visual Basic
Public Overrides Sub AutoResize ( _
    autoResizeMode As AutoResizeMode _
)
Visual C++
public:
virtual void AutoResize(
    AutoResizeMode autoResizeMode
) override

Parameters

autoResizeMode
Type: VIBlend.WinForms.DataGridView..::..AutoResizeMode

See Also

ColumnsHierarchy Class
AutoResize Overload
VIBlend.WinForms.DataGridView Namespace


ResizeColumnsToFitGridWidth Method

[image]

VIBlend Controls for WinForms Help Documentation
ColumnsHierarchy..::..ResizeColumnsToFitGridWidth Method
ColumnsHierarchy Class See Also Send Feedback
Resizes the width of the columns to fit to the grid's width.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ResizeColumnsToFitGridWidth()
Visual Basic
Public Sub ResizeColumnsToFitGridWidth
Visual C++
public:
void ResizeColumnsToFitGridWidth()

See Also

ColumnsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


SortBy Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnsHierarchy..::..SortBy Method
ColumnsHierarchy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SortBy(HierarchyItem, SortingDirection) | Sorts the Hierarchy by a specefic HierarchyItem (Inherited from Hierarchy.)
Public method | SortBy(HierarchyItem, SortingDirection, IComparer<(Of <<'(HierarchyItem>)>>)) | Sorts the Items in the Hierarchy. (Inherited from Hierarchy.)

See Also

ColumnsHierarchy Class
ColumnsHierarchy Members
VIBlend.WinForms.DataGridView Namespace


ColumnsHierarchy Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnsHierarchy Properties
ColumnsHierarchy Class See Also Send Feedback

The ColumnsHierarchy type exposes the following members.

Properties

 | Name | Description
Public property | AllowDragDrop | Gets or sets whether drag and drop is enabled for this Hierarchy (Inherited from Hierarchy.)
Public property | AllowResize | Gets or sets whether the HierarchyItems resizing is allowed (Inherited from Hierarchy.)
Public property | AutoStretchColumns | Gets or sets whether to automatically resize the columns when the total width is less than the width of the grid control.
Public property | ColumnWidths | Gets the columns' widths for the hierarchy (Inherited from Hierarchy.)
Public property | Filters | (Inherited from Hierarchy.)
Public property | Fixed | Determines if the Hierarchy is fixed or not. Fixed Hierarchies are not affected by the scrolling of the data grid's content (Inherited from Hierarchy.)
Public property | GridControl | Retruns a reference to the Grid control hosting the hierarchy (Inherited from Hierarchy.)
Public property | Height | Gets the Height of the Hierarchy in pixels
Public property | HiddenItems | Gets the hidden items (Inherited from Hierarchy.)
Public property | HierarchyDepth | Gets the depth of the hierarchy. (Inherited from Hierarchy.)
Public property | IsFiltered | Checks if the Hierarchy contains HierarchyItems which are filtered. (Inherited from Hierarchy.)
Public property | IsSorted | Checks if the Hierarchy is Sorted (Inherited from Hierarchy.)
Public property | Items | Gets the items of the Hierarchy (Inherited from Hierarchy.)
Public property | SelectedItems | Gets the selected items (Inherited from Hierarchy.)
Public property | ShowExpandCollapseButtons | Determines whether to show the expand/collapse buttons on the items hosted by the hierarchy (Inherited from Hierarchy.)
Public property | SortingDirection | Gets the sort order direction if the Hierarchy is sorted. (Inherited from Hierarchy.)
Public property | SortItem | Gets the Item the Hierarchy is sorted by. (Inherited from Hierarchy.)
Public property | SummaryItems | Gets the summary items of the Hierarchy (Inherited from Hierarchy.)
Public property | TotalItemsCount | Gets the total number of HierarchyItems hosted by the Hierarchy. This includes both Hierarchy items and Summary items. Hidden items are also counted. (Inherited from Hierarchy.)
Public property | Visible | Determines whether the hierarchy is visible (Inherited from Hierarchy.)
Public property | Width | Gets the Width of the Hierarchy in pixels
Public property | X | Returns the horizontal position of Hierarchy relative to the top-left corner of the grid control (Inherited from Hierarchy.)
Public property | Y | Returns the horizontal position of Hierarchy relative to the top-left corner of the grid control (Inherited from Hierarchy.)

See Also

ColumnsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


AutoStretchColumns Property

[image]

VIBlend Controls for WinForms Help Documentation
ColumnsHierarchy..::..AutoStretchColumns Property
ColumnsHierarchy Class See Also Send Feedback
Gets or sets whether to automatically resize the columns when the total width is less than the width of the grid control.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AutoStretchColumns { get; set; }
Visual Basic
Public Property AutoStretchColumns As Boolean
    Get
    Set
Visual C++
public:
property bool AutoStretchColumns {
    bool get ();
    void set (bool value);
}

See Also

ColumnsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


Height Property

[image]

VIBlend Controls for WinForms Help Documentation
ColumnsHierarchy..::..Height Property
ColumnsHierarchy Class See Also Send Feedback
Gets the Height of the Hierarchy in pixels

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Height { get; }
Visual Basic
Public ReadOnly Property Height As Integer
    Get
Visual C++
public:
property int Height {
    int get ();
}

See Also

ColumnsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


Width Property

[image]

VIBlend Controls for WinForms Help Documentation
ColumnsHierarchy..::..Width Property
ColumnsHierarchy Class See Also Send Feedback
Gets the Width of the Hierarchy in pixels

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Width { get; }
Visual Basic
Public ReadOnly Property Width As Integer
    Get
Visual C++
public:
property int Width {
    int get ();
}

See Also

ColumnsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


ColumnsHierarchy Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
ColumnsHierarchy Events
ColumnsHierarchy Class See Also Send Feedback

The ColumnsHierarchy type exposes the following members.

Events

 | Name | Description
Public event | FiltersChanged | Occurs when the Hierarchy filters have changed. (Inherited from Hierarchy.)
Public event | SortingChanged | Occurs when the Hierarchy sorting have changed. (Inherited from Hierarchy.)

See Also

ColumnsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


ComboBoxEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor Class
Members See Also Send Feedback
Represents a ComboBoxEditor used in the GridView control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class ComboBoxEditor : vComboBox,
    IEditor
Visual Basic
Public Class ComboBoxEditor _
    Inherits vComboBox _
    Implements IEditor
Visual C++
public ref class ComboBoxEditor : public vComboBox,
    IEditor

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vComboBox
VIBlend.WinForms.DataGridView..::..ComboBoxEditor

See Also

ComboBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


ComboBoxEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor Members
ComboBoxEditor Class Constructors Methods Properties Events See Also Send Feedback

The ComboBoxEditor type exposes the following members.

Constructors

 | Name | Description
Public method | ComboBoxEditor | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down. (Inherited from vComboBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrow | Draws the arrow. (Inherited from vComboBox.)
Public method | DrawEditorControl | Handles the painting of the editor control
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Protected method | LoadComboBoxWithEditorValue | Loads the combo box with editor value.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDropDownClosed | Called when the drop down is closed. (Inherited from vComboBox.)
Protected method | OnDropDownOpened | Called when the drop down is opened. (Overrides vComboBox..::..OnDropDownOpened()()()().)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Overrides Control..::..OnGotFocus(EventArgs).)
Public method | OnGridKeyDown | Handles grid KeyDown events
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemMouseDown | Raises the [E:ItemMouseDown] event. (Inherited from vComboBox.)
Protected method | OnItemMouseUp | Raises the [E:ItemMouseUp] event. (Inherited from vComboBox.)
Protected method | OnKeyDown | Raises the [E:KeyDown] event. (Overrides vComboBox..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from vComboBox.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoaded | Called when the editor is loaded.
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Inherited from vComboBox.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectedIndexChanged | (Overrides vComboBox..::..OnSelectedIndexChanged(EventArgs).)
Protected method | OnSelectedItemChanged | (Inherited from vComboBox.)
Protected method | OnSelectedItemChanging | (Inherited from vComboBox.)
Protected method | OnSelectedValueChanged | Raises the SelectedValueChanged event. (Inherited from vComboBox.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | This member overrides Control.ProcessCmdKey. (Inherited from vComboBox.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveSort | Removes the sort. (Inherited from vComboBox.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Reverse | Reverses this instance. (Inherited from vComboBox.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown | Shows the drop down. (Inherited from vComboBox.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort(Boolean) | Sorts the specified ascending. (Inherited from vComboBox.)
Public method | Sort(IComparer<(Of <<'(ListItem>)>>)) | Sorts the specified comparer. (Inherited from vComboBox.)
Public method | Sort(Comparison<(Of <<'(ListItem>)>>)) | Sorts the specified comparison. (Inherited from vComboBox.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | AllowAnimations | Determines whether to use animations (Inherited from vComboBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoCompleteEnabled | Gets or sets a value indicating whether auto complete is enabled. (Inherited from vComboBox.)
Public property | AutoOpenEditorOnActivation | Gets or sets a value indicating whether to open the editor when activated.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from vComboBox.)
Public property | BackgroundImage | Gets or sets the background image of the control (Inherited from vComboBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color which is used when the UseThemeBorderColor property is false. (Inherited from vComboBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets a reference to the underlying control of the editor
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the DataSource of the vComboBox (Inherited from vComboBox.)
Public property | DeActivationFlags | Gets or sets the editor activation flags
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vComboBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vComboBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayMember | Gets or sets the display member associated to the vComboBox. (Inherited from vComboBox.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets the drop down. (Inherited from vComboBox.)
Public property | DropDownArrowBackgroundEnabled | Determines whether to the drop-down arrow's background is painted (Inherited from vComboBox.)
Public property | DropDownArrowColor | Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false. (Inherited from vComboBox.)
Public property | DropDownButtonBackgroundBrush | Gets or sets the background brush. (Inherited from vComboBox.)
Public property | DropDownButtonDisabledBackgroundBrush | Gets or sets the disabled background brush. (Inherited from vComboBox.)
Public property | DropDownButtonHighlightBackgroundBrush | Gets or sets the HighlightBackground brush. (Inherited from vComboBox.)
Public property | DropDownButtonPressedBackgroundBrush | Gets or sets the background brush. (Inherited from vComboBox.)
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ComboBox (Inherited from vComboBox.)
Public property | DropDownList | Gets or sets whether the combo box is a drop down list. (Inherited from vComboBox.)
Public property | DropDownMaximumSize | Gets or sets the maximum size of the drop-down portion of the ComboBox (Inherited from vComboBox.)
Public property | DropDownMinimumSize | Gets or sets the maximum size of the drop-down portion of the ComboBox (Inherited from vComboBox.)
Public property | DropDownResizeDirection | Gets or sets a value indicating the possible drop-down resize directions (Inherited from vComboBox.)
Public property | DropDownWidth | Gets or sets the width in pixels of the drop-down portion of the ComboBox (Inherited from vComboBox.)
Public property | EditBase | Gets the edit base. (Inherited from vComboBox.)
Public property | EditCell | Gets the edit cell.
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | EnableCloseOnSelectionChanged | Gets or sets a value indicating whether to close the editor when the selection is changed.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font that is used to display the text in the editbox of the control (Inherited from vComboBox.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color which is used to display the text (Inherited from vComboBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImageList | Gets or sets the images list of the vComboBox (Inherited from vComboBox.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of the items inside the dropdown list of the vComboBox (Inherited from vComboBox.)
Public property | Items | Gets the ComboBox Items collection. (Inherited from vComboBox.)
Public property | ItemsSpacing | (Inherited from vComboBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | ListBox | Gets the vListBox inside the vComboBox. (Inherited from vComboBox.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Indicates whether the control should draw right-to-left for RTL langauges (Inherited from vComboBox.)
Public property | RoundedCornersMaskListItem | Gets or sets the mask that determines which corners of a ListItem are rounded (Inherited from vComboBox.)
Public property | RoundedCornersRadiusListItem | Gets or sets the rounded corners radius of the ListItems. (Inherited from vComboBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the currently selected item. Returns -1 if there is no item selected (Inherited from vComboBox.)
Public property | SelectedItem | Gets or sets the currently selected item of the drop down list of the combo box control. (Inherited from vComboBox.)
Public property | SelectedValue | Gets or sets the selected value. (Inherited from vComboBox.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vComboBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowGrip | Gets or sets a value indicating whether grip is shown (Inherited from vComboBox.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text displayed in the editbox of the control (Inherited from vComboBox.)
Public property | Theme | Gets or sets the Theme of the control. (Inherited from vComboBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultDropDownWidth | Gets or sets a value indicating whether to use the default drop down width. (Inherited from vComboBox.)
Public property | UseDropDownButtonThemeBackground | Gets or sets a value indicating whether to use theme's background (Inherited from vComboBox.)
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property. (Inherited from vComboBox.)
Public property | UseThemeBorderColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vComboBox.)
Public property | UseThemeDropDownArrowColor | Gets or sets whether to use the Theme default arrow color. (Inherited from vComboBox.)
Public property | UseThemeFont | Gets or sets whether to use the Theme Font or the control's Font property. (Inherited from vComboBox.)
Public property | UseThemeForeColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vComboBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets a string that specifies the property of the data source from which to draw the value. (Inherited from vComboBox.)
Public property | VIBlendScrollBarsTheme | Gets or sets the theme of the treeview scrollbars using one of the built-in themes. (Inherited from vComboBox.)
Public property | VIBlendTheme | Gets or sets the theme of the control to one of the built-in themes. (Inherited from vComboBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DropDownClose | (Inherited from vComboBox.)
Public event | DropDownOpen | Occurs when the DropDown is opened. (Inherited from vComboBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemMouseDown | Occurs when the mouse is clicked over a ListItem. (Inherited from vComboBox.)
Public event | ItemMouseUp | Occurs when the mouse is clicked over a ListItem. (Inherited from vComboBox.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Loaded | Occurs when the editor is loaded.
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the selected index has changed (Inherited from vComboBox.)
Public event | SelectedItemChanged | occurs when the selection is changed. (Inherited from vComboBox.)
Public event | SelectedItemChanging | Occurs when the selection is changing. (Inherited from vComboBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue has changed. (Inherited from vComboBox.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


ComboBoxEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor Constructor
ComboBoxEditor Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ComboBoxEditor()
Visual Basic
Public Sub New
Visual C++
public:
ComboBoxEditor()

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


ComboBoxEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor Methods
ComboBoxEditor Class See Also Send Feedback

The ComboBoxEditor type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down. (Inherited from vComboBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrow | Draws the arrow. (Inherited from vComboBox.)
Public method | DrawEditorControl | Handles the painting of the editor control
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Protected method | LoadComboBoxWithEditorValue | Loads the combo box with editor value.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDropDownClosed | Called when the drop down is closed. (Inherited from vComboBox.)
Protected method | OnDropDownOpened | Called when the drop down is opened. (Overrides vComboBox..::..OnDropDownOpened()()()().)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Overrides Control..::..OnGotFocus(EventArgs).)
Public method | OnGridKeyDown | Handles grid KeyDown events
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemMouseDown | Raises the [E:ItemMouseDown] event. (Inherited from vComboBox.)
Protected method | OnItemMouseUp | Raises the [E:ItemMouseUp] event. (Inherited from vComboBox.)
Protected method | OnKeyDown | Raises the [E:KeyDown] event. (Overrides vComboBox..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from vComboBox.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoaded | Called when the editor is loaded.
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | (Inherited from vComboBox.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSelectedIndexChanged | (Overrides vComboBox..::..OnSelectedIndexChanged(EventArgs).)
Protected method | OnSelectedItemChanged | (Inherited from vComboBox.)
Protected method | OnSelectedItemChanging | (Inherited from vComboBox.)
Protected method | OnSelectedValueChanged | Raises the SelectedValueChanged event. (Inherited from vComboBox.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | This member overrides Control.ProcessCmdKey. (Inherited from vComboBox.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveSort | Removes the sort. (Inherited from vComboBox.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Reverse | Reverses this instance. (Inherited from vComboBox.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown | Shows the drop down. (Inherited from vComboBox.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort(Boolean) | Sorts the specified ascending. (Inherited from vComboBox.)
Public method | Sort(IComparer<(Of <<'(ListItem>)>>)) | Sorts the specified comparer. (Inherited from vComboBox.)
Public method | Sort(Comparison<(Of <<'(ListItem>)>>)) | Sorts the specified comparison. (Inherited from vComboBox.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..AccessibilityNotifyClients Method
ComboBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ComboBoxEditor Class
ComboBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..BeginInvoke Method
ComboBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ComboBoxEditor Class
ComboBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..Dispose Method
ComboBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

ComboBoxEditor Class
ComboBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


DrawEditorControl Method

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..DrawEditorControl Method
ComboBoxEditor Class See Also Send Feedback
Handles the painting of the editor control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawEditorControl(
    Graphics graphics,
    GridCell gridCell,
    out bool isDrawHandled
)
Visual Basic
Public Sub DrawEditorControl ( _
    graphics As Graphics, _
    gridCell As GridCell, _
    <OutAttribute> ByRef isDrawHandled As Boolean _
)
Visual C++
public:
virtual void DrawEditorControl(
    Graphics^ graphics,
    GridCell^ gridCell,
    [OutAttribute] bool% isDrawHandled
) sealed

Parameters

graphics
Type: System.Drawing..::..Graphics
Reference to the GDI+ surface
gridCell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the grid cell being rendered
isDrawHandled
Type: System..::..Boolean %
Output flag indicating whether the method handled the drawing or not

Implements

IEditor..::..DrawEditorControl(Graphics, GridCell, Boolean%)

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..GetChildAtPoint Method
ComboBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ComboBoxEditor Class
ComboBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..Invalidate Method
ComboBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ComboBoxEditor Class
ComboBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..Invoke Method
ComboBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ComboBoxEditor Class
ComboBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


LayoutEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..LayoutEditor Method
ComboBoxEditor Class See Also Send Feedback
This methods is called by the grid control when the editor must update its layout

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void LayoutEditor(
    GridCell cell
)
Visual Basic
Public Overridable Sub LayoutEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void LayoutEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the GridCell being edited

Implements

IEditor..::..LayoutEditor(GridCell)

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


LoadComboBoxWithEditorValue Method

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..LoadComboBoxWithEditorValue Method
ComboBoxEditor Class See Also Send Feedback
Loads the combo box with editor value.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void LoadComboBoxWithEditorValue()
Visual Basic
Protected Overridable Sub LoadComboBoxWithEditorValue
Visual C++
protected:
virtual void LoadComboBoxWithEditorValue()

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..MemberwiseClone Method
ComboBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ComboBoxEditor Class
ComboBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


OnCloseEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..OnCloseEditor Method
ComboBoxEditor Class See Also Send Feedback
This method is called by the grid control when at the end of a cell edit operation

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void OnCloseEditor()
Visual Basic
Public Overridable Sub OnCloseEditor
Visual C++
public:
virtual void OnCloseEditor()

Implements

IEditor..::..OnCloseEditor()()()()

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


OnDropDownOpened Method

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..OnDropDownOpened Method
ComboBoxEditor Class See Also Send Feedback
Called when the drop down is opened.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnDropDownOpened()
Visual Basic
Protected Overrides Sub OnDropDownOpened
Visual C++
protected:
virtual void OnDropDownOpened() override

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


OnGotFocus Method

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..OnGotFocus Method
ComboBoxEditor Class See Also Send Feedback
Raises the GotFocus event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnGotFocus(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnGotFocus ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnGotFocus(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


OnGridKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..OnGridKeyDown Method
ComboBoxEditor Class See Also Send Feedback
Handles grid KeyDown events

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnGridKeyDown(
    KeyEventArgs args,
    GridCell cell,
    out bool closeEditor,
    out bool closeEditorAndSaveChanges
)
Visual Basic
Public Sub OnGridKeyDown ( _
    args As KeyEventArgs, _
    cell As GridCell, _
    <OutAttribute> ByRef closeEditor As Boolean, _
    <OutAttribute> ByRef closeEditorAndSaveChanges As Boolean _
)
Visual C++
public:
virtual void OnGridKeyDown(
    KeyEventArgs^ args,
    GridCell^ cell,
    [OutAttribute] bool% closeEditor,
    [OutAttribute] bool% closeEditorAndSaveChanges
) sealed

Parameters

args
Type: System.Windows.Forms..::..KeyEventArgs
KeyDown event arguments
cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
closeEditor
Type: System..::..Boolean %
The grid cell where the event occured. This may be null if the event did not occur within a grid cell.Output flag indicating whether to keep the editor open or close it instantly
closeEditorAndSaveChanges
Type: System..::..Boolean %

Implements

IEditor..::..OnGridKeyDown(KeyEventArgs, GridCell, Boolean%, Boolean%)

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


OnKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..OnKeyDown Method
ComboBoxEditor Class See Also Send Feedback
Raises the [E:KeyDown] event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
The KeyEventArgs instance containing the event data.

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


OnLoaded Method

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..OnLoaded Method
ComboBoxEditor Class See Also Send Feedback
Called when the editor is loaded.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnLoaded()
Visual Basic
Protected Overridable Sub OnLoaded
Visual C++
protected:
virtual void OnLoaded()

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


OnOpenEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..OnOpenEditor Method
ComboBoxEditor Class See Also Send Feedback
This method is called by the grid control when the editor is being activated

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void OnOpenEditor(
    GridCell cell
)
Visual Basic
Public Overridable Sub OnOpenEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void OnOpenEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell

Implements

IEditor..::..OnOpenEditor(GridCell)

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


OnSelectedIndexChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..OnSelectedIndexChanged Method
ComboBoxEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnSelectedIndexChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnSelectedIndexChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSelectedIndexChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..PerformLayout Method
ComboBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ComboBoxEditor Class
ComboBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..ResumeLayout Method
ComboBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ComboBoxEditor Class
ComboBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..RtlTranslateAlignment Method
ComboBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ComboBoxEditor Class
ComboBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..Scale Method
ComboBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ComboBoxEditor Class
ComboBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..Select Method
ComboBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

ComboBoxEditor Class
ComboBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..SetBounds Method
ComboBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ComboBoxEditor Class
ComboBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


Sort Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..Sort Method
ComboBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort(Boolean) | Sorts the specified ascending. (Inherited from vComboBox.)
Public method | Sort(IComparer<(Of <<'(ListItem>)>>)) | Sorts the specified comparer. (Inherited from vComboBox.)
Public method | Sort(Comparison<(Of <<'(ListItem>)>>)) | Sorts the specified comparison. (Inherited from vComboBox.)

See Also

ComboBoxEditor Class
ComboBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..UpdateBounds Method
ComboBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ComboBoxEditor Class
ComboBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


ComboBoxEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor Properties
ComboBoxEditor Class See Also Send Feedback

The ComboBoxEditor type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | AllowAnimations | Determines whether to use animations (Inherited from vComboBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoCompleteEnabled | Gets or sets a value indicating whether auto complete is enabled. (Inherited from vComboBox.)
Public property | AutoOpenEditorOnActivation | Gets or sets a value indicating whether to open the editor when activated.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from vComboBox.)
Public property | BackgroundImage | Gets or sets the background image of the control (Inherited from vComboBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color which is used when the UseThemeBorderColor property is false. (Inherited from vComboBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets a reference to the underlying control of the editor
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the DataSource of the vComboBox (Inherited from vComboBox.)
Public property | DeActivationFlags | Gets or sets the editor activation flags
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vComboBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vComboBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayMember | Gets or sets the display member associated to the vComboBox. (Inherited from vComboBox.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets the drop down. (Inherited from vComboBox.)
Public property | DropDownArrowBackgroundEnabled | Determines whether to the drop-down arrow's background is painted (Inherited from vComboBox.)
Public property | DropDownArrowColor | Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false. (Inherited from vComboBox.)
Public property | DropDownButtonBackgroundBrush | Gets or sets the background brush. (Inherited from vComboBox.)
Public property | DropDownButtonDisabledBackgroundBrush | Gets or sets the disabled background brush. (Inherited from vComboBox.)
Public property | DropDownButtonHighlightBackgroundBrush | Gets or sets the HighlightBackground brush. (Inherited from vComboBox.)
Public property | DropDownButtonPressedBackgroundBrush | Gets or sets the background brush. (Inherited from vComboBox.)
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ComboBox (Inherited from vComboBox.)
Public property | DropDownList | Gets or sets whether the combo box is a drop down list. (Inherited from vComboBox.)
Public property | DropDownMaximumSize | Gets or sets the maximum size of the drop-down portion of the ComboBox (Inherited from vComboBox.)
Public property | DropDownMinimumSize | Gets or sets the maximum size of the drop-down portion of the ComboBox (Inherited from vComboBox.)
Public property | DropDownResizeDirection | Gets or sets a value indicating the possible drop-down resize directions (Inherited from vComboBox.)
Public property | DropDownWidth | Gets or sets the width in pixels of the drop-down portion of the ComboBox (Inherited from vComboBox.)
Public property | EditBase | Gets the edit base. (Inherited from vComboBox.)
Public property | EditCell | Gets the edit cell.
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | EnableCloseOnSelectionChanged | Gets or sets a value indicating whether to close the editor when the selection is changed.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font that is used to display the text in the editbox of the control (Inherited from vComboBox.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color which is used to display the text (Inherited from vComboBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImageList | Gets or sets the images list of the vComboBox (Inherited from vComboBox.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of the items inside the dropdown list of the vComboBox (Inherited from vComboBox.)
Public property | Items | Gets the ComboBox Items collection. (Inherited from vComboBox.)
Public property | ItemsSpacing | (Inherited from vComboBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | ListBox | Gets the vListBox inside the vComboBox. (Inherited from vComboBox.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Indicates whether the control should draw right-to-left for RTL langauges (Inherited from vComboBox.)
Public property | RoundedCornersMaskListItem | Gets or sets the mask that determines which corners of a ListItem are rounded (Inherited from vComboBox.)
Public property | RoundedCornersRadiusListItem | Gets or sets the rounded corners radius of the ListItems. (Inherited from vComboBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index of the currently selected item. Returns -1 if there is no item selected (Inherited from vComboBox.)
Public property | SelectedItem | Gets or sets the currently selected item of the drop down list of the combo box control. (Inherited from vComboBox.)
Public property | SelectedValue | Gets or sets the selected value. (Inherited from vComboBox.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vComboBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowGrip | Gets or sets a value indicating whether grip is shown (Inherited from vComboBox.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text displayed in the editbox of the control (Inherited from vComboBox.)
Public property | Theme | Gets or sets the Theme of the control. (Inherited from vComboBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultDropDownWidth | Gets or sets a value indicating whether to use the default drop down width. (Inherited from vComboBox.)
Public property | UseDropDownButtonThemeBackground | Gets or sets a value indicating whether to use theme's background (Inherited from vComboBox.)
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property. (Inherited from vComboBox.)
Public property | UseThemeBorderColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vComboBox.)
Public property | UseThemeDropDownArrowColor | Gets or sets whether to use the Theme default arrow color. (Inherited from vComboBox.)
Public property | UseThemeFont | Gets or sets whether to use the Theme Font or the control's Font property. (Inherited from vComboBox.)
Public property | UseThemeForeColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vComboBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets a string that specifies the property of the data source from which to draw the value. (Inherited from vComboBox.)
Public property | VIBlendScrollBarsTheme | Gets or sets the theme of the treeview scrollbars using one of the built-in themes. (Inherited from vComboBox.)
Public property | VIBlendTheme | Gets or sets the theme of the control to one of the built-in themes. (Inherited from vComboBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


ActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..ActivationFlags Property
ComboBoxEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags ActivationFlags { get; set; }
Visual Basic
Public Property ActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags ActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..ActivationFlags

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


AutoOpenEditorOnActivation Property

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..AutoOpenEditorOnActivation Property
ComboBoxEditor Class See Also Send Feedback
Gets or sets a value indicating whether to open the editor when activated.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AutoOpenEditorOnActivation { get; set; }
Visual Basic
Public Property AutoOpenEditorOnActivation As Boolean
    Get
    Set
Visual C++
public:
property bool AutoOpenEditorOnActivation {
    bool get ();
    void set (bool value);
}

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


Control Property

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..Control Property
ComboBoxEditor Class See Also Send Feedback
Gets a reference to the underlying control of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control Control { get; }
Visual Basic
Public ReadOnly Property Control As Control
    Get
Visual C++
public:
virtual property Control^ Control {
    Control^ get () sealed;
}

Implements

IEditor..::..Control

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


DeActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..DeActivationFlags Property
ComboBoxEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags DeActivationFlags { get; set; }
Visual Basic
Public Property DeActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags DeActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..DeActivationFlags

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


EditCell Property

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..EditCell Property
ComboBoxEditor Class See Also Send Feedback
Gets the edit cell.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell EditCell { get; }
Visual Basic
Public ReadOnly Property EditCell As GridCell
    Get
Visual C++
public:
property GridCell^ EditCell {
    GridCell^ get ();
}

Field Value

The edit cell.

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorType Property

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..EditorType Property
ComboBoxEditor Class See Also Send Feedback
Gets the type of the grid cell editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellEditorType EditorType { get; }
Visual Basic
Public ReadOnly Property EditorType As CellEditorType
    Get
Visual C++
public:
virtual property CellEditorType EditorType {
    CellEditorType get () sealed;
}

Implements

IEditor..::..EditorType

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorValue Property

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..EditorValue Property
ComboBoxEditor Class See Also Send Feedback
Get's or sets the current value of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object EditorValue { get; set; }
Visual Basic
Public Property EditorValue As Object
    Get
    Set
Visual C++
public:
virtual property Object^ EditorValue {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Implements

IEditor..::..EditorValue

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


EnableCloseOnSelectionChanged Property

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..EnableCloseOnSelectionChanged Property
ComboBoxEditor Class See Also Send Feedback
Gets or sets a value indicating whether to close the editor when the selection is changed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableCloseOnSelectionChanged { get; set; }
Visual Basic
Public Property EnableCloseOnSelectionChanged As Boolean
    Get
    Set
Visual C++
public:
property bool EnableCloseOnSelectionChanged {
    bool get ();
    void set (bool value);
}

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


ComboBoxEditor Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor Events
ComboBoxEditor Class See Also Send Feedback

The ComboBoxEditor type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DropDownClose | (Inherited from vComboBox.)
Public event | DropDownOpen | Occurs when the DropDown is opened. (Inherited from vComboBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemMouseDown | Occurs when the mouse is clicked over a ListItem. (Inherited from vComboBox.)
Public event | ItemMouseUp | Occurs when the mouse is clicked over a ListItem. (Inherited from vComboBox.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Loaded | Occurs when the editor is loaded.
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the selected index has changed (Inherited from vComboBox.)
Public event | SelectedItemChanged | occurs when the selection is changed. (Inherited from vComboBox.)
Public event | SelectedItemChanging | Occurs when the selection is changing. (Inherited from vComboBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue has changed. (Inherited from vComboBox.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


Loaded Event

[image]

VIBlend Controls for WinForms Help Documentation
ComboBoxEditor..::..Loaded Event
ComboBoxEditor Class See Also Send Feedback
Occurs when the editor is loaded.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler Loaded
Visual Basic
Public Event Loaded As EventHandler
Visual C++
public:
 event EventHandler^ Loaded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ComboBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


CurrencyEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class CurrencyEditor : vCurrencyEditor,
    IEditor
Visual Basic
Public Class CurrencyEditor _
    Inherits vCurrencyEditor _
    Implements IEditor
Visual C++
public ref class CurrencyEditor : public vCurrencyEditor,
    IEditor

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vTextBox
VIBlend.WinForms.Controls..::..InputBase
VIBlend.WinForms.Controls..::..vCurrencyEditor
VIBlend.WinForms.DataGridView..::..CurrencyEditor

See Also

CurrencyEditor Members
VIBlend.WinForms.DataGridView Namespace


CurrencyEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor Members
CurrencyEditor Class Constructors Methods Fields Properties Events See Also Send Feedback

The CurrencyEditor type exposes the following members.

Constructors

 | Name | Description
Public method | CurrencyEditor | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | Simulates BackSpace. (Inherited from vCurrencyEditor.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from InputBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | Executes the Ctrl + C command. (Inherited from vCurrencyEditor.)
Protected method | CtrlV | Executes the Ctrl + V command. (Inherited from vCurrencyEditor.)
Protected method | CtrlX | Executes the Ctrl + X command. (Inherited from vCurrencyEditor.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | Deletes the selected value. (Inherited from vCurrencyEditor.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key. (Inherited from InputBase.)
Public method | DrawEditorControl | Handles the painting of the editor control
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key. (Inherited from InputBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider. (Inherited from InputBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text. (Inherited from vCurrencyEditor.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDefaultKeys | Handles the default keys.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key. (Inherited from InputBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | Inserts a string into the editor. (Inherited from vCurrencyEditor.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown | (Inherited from InputBase.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed. (Inherited from InputBase.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Public method | LeftKey | Moves the cursor one position left. (Inherited from InputBase.)
Protected method | LoadEditorValue | Loads the editor value.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Public method | OnGridKeyDown | Handles grid KeyDown events
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the [E:KeyDown] event. (Overrides InputBase..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | (Inherited from InputBase.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from InputBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from vCurrencyEditor.)
Protected method | OnMouseWheel | (Inherited from InputBase.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | (Inherited from InputBase.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from InputBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event. (Inherited from InputBase.)
Protected method | OnValueChanged | Calls the ValueChanged event. (Inherited from InputBase.)
Protected method | OnValueChanging | Calls the ValueChanging event. (Inherited from InputBase.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | Parses editor's value. (Inherited from vCurrencyEditor.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | Redoes this instance. (Inherited from vCurrencyEditor.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters. (Inherited from InputBase.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key. (Inherited from InputBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | Formats editor's text. (Inherited from vCurrencyEditor.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit | (Inherited from InputBase.)
Protected method | SpinDigitWithWrap | Spins the digit with wrap. (Inherited from InputBase.)
Public method | SpinValue | Increases or decreases the current value. (Inherited from InputBase.)
Protected method | SpinValueBeforeDigit | Spins the value before digit. (Inherited from InputBase.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | Makes undo of the current value. (Inherited from vCurrencyEditor.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key. (Inherited from InputBase.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | baseFormatString | (Inherited from InputBase.)
Protected field | cultureInfo | (Inherited from InputBase.)
Protected field | decimalPlaces | (Inherited from InputBase.)
Protected field | decimalPossibleChars | (Inherited from InputBase.)
Protected field | emptyValue | (Inherited from InputBase.)
Protected field | formatString | (Inherited from InputBase.)
Protected field | isLessThanZero | (Inherited from InputBase.)
Protected field | manager | (Inherited from InputBase.)
Protected field | maximum | (Inherited from InputBase.)
Protected field | minimum | (Inherited from InputBase.)
Protected field | undoValue | (Inherited from InputBase.)
Protected field | value | (Inherited from InputBase.)
Protected field | valueString | (Inherited from InputBase.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets a reference to the underlying control of the editor
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information. (Inherited from InputBase.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DeActivationFlags | Gets or sets the editor activation flags
Public property | DecimalPlaces | Gets or sets editor's decimal places. (Inherited from InputBase.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EditCell | Gets the edit cell.
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HandleEnterKey | Gets or sets a value indicating whether to handle the enter and esc keys.
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator | (Inherited from InputBase.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value. (Inherited from InputBase.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value. (Inherited from InputBase.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | (Inherited from InputBase.)
Public property | Minimum | Gets or sets editor's Minimum value. (Inherited from InputBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | Gets the current separator character. (Inherited from vCurrencyEditor.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type. (Inherited from InputBase.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from InputBase.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from InputBase.)
Public property | Value | Gets or sets editor's value. (Inherited from InputBase.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed. (Inherited from InputBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event. (Inherited from InputBase.)
Public event | ValueChanged | Represents the ValueChanged event. (Inherited from InputBase.)
Public event | ValueChanging | Represents the ValueChanging event. (Inherited from InputBase.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


CurrencyEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor Constructor
CurrencyEditor Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CurrencyEditor()
Visual Basic
Public Sub New
Visual C++
public:
CurrencyEditor()

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


CurrencyEditor Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor Fields
CurrencyEditor Class See Also Send Feedback

The CurrencyEditor type exposes the following members.

Fields

 | Name | Description
Protected field | baseFormatString | (Inherited from InputBase.)
Protected field | cultureInfo | (Inherited from InputBase.)
Protected field | decimalPlaces | (Inherited from InputBase.)
Protected field | decimalPossibleChars | (Inherited from InputBase.)
Protected field | emptyValue | (Inherited from InputBase.)
Protected field | formatString | (Inherited from InputBase.)
Protected field | isLessThanZero | (Inherited from InputBase.)
Protected field | manager | (Inherited from InputBase.)
Protected field | maximum | (Inherited from InputBase.)
Protected field | minimum | (Inherited from InputBase.)
Protected field | undoValue | (Inherited from InputBase.)
Protected field | value | (Inherited from InputBase.)
Protected field | valueString | (Inherited from InputBase.)

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


CurrencyEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor Methods
CurrencyEditor Class See Also Send Feedback

The CurrencyEditor type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | Simulates BackSpace. (Inherited from vCurrencyEditor.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from InputBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | Executes the Ctrl + C command. (Inherited from vCurrencyEditor.)
Protected method | CtrlV | Executes the Ctrl + V command. (Inherited from vCurrencyEditor.)
Protected method | CtrlX | Executes the Ctrl + X command. (Inherited from vCurrencyEditor.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | Deletes the selected value. (Inherited from vCurrencyEditor.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key. (Inherited from InputBase.)
Public method | DrawEditorControl | Handles the painting of the editor control
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key. (Inherited from InputBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider. (Inherited from InputBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text. (Inherited from vCurrencyEditor.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDefaultKeys | Handles the default keys.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key. (Inherited from InputBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | Inserts a string into the editor. (Inherited from vCurrencyEditor.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown | (Inherited from InputBase.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed. (Inherited from InputBase.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Public method | LeftKey | Moves the cursor one position left. (Inherited from InputBase.)
Protected method | LoadEditorValue | Loads the editor value.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Public method | OnGridKeyDown | Handles grid KeyDown events
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the [E:KeyDown] event. (Overrides InputBase..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | (Inherited from InputBase.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from InputBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from vCurrencyEditor.)
Protected method | OnMouseWheel | (Inherited from InputBase.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | (Inherited from InputBase.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from InputBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event. (Inherited from InputBase.)
Protected method | OnValueChanged | Calls the ValueChanged event. (Inherited from InputBase.)
Protected method | OnValueChanging | Calls the ValueChanging event. (Inherited from InputBase.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | Parses editor's value. (Inherited from vCurrencyEditor.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | Redoes this instance. (Inherited from vCurrencyEditor.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters. (Inherited from InputBase.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key. (Inherited from InputBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | Formats editor's text. (Inherited from vCurrencyEditor.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit | (Inherited from InputBase.)
Protected method | SpinDigitWithWrap | Spins the digit with wrap. (Inherited from InputBase.)
Public method | SpinValue | Increases or decreases the current value. (Inherited from InputBase.)
Protected method | SpinValueBeforeDigit | Spins the value before digit. (Inherited from InputBase.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | Makes undo of the current value. (Inherited from vCurrencyEditor.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key. (Inherited from InputBase.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..AccessibilityNotifyClients Method
CurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

CurrencyEditor Class
CurrencyEditor Members
VIBlend.WinForms.DataGridView Namespace


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..BeginInvoke Method
CurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

CurrencyEditor Class
CurrencyEditor Members
VIBlend.WinForms.DataGridView Namespace


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..Dispose Method
CurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

CurrencyEditor Class
CurrencyEditor Members
VIBlend.WinForms.DataGridView Namespace


DrawEditorControl Method

[image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..DrawEditorControl Method
CurrencyEditor Class See Also Send Feedback
Handles the painting of the editor control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawEditorControl(
    Graphics graphics,
    GridCell gridCell,
    out bool isDrawHandled
)
Visual Basic
Public Sub DrawEditorControl ( _
    graphics As Graphics, _
    gridCell As GridCell, _
    <OutAttribute> ByRef isDrawHandled As Boolean _
)
Visual C++
public:
virtual void DrawEditorControl(
    Graphics^ graphics,
    GridCell^ gridCell,
    [OutAttribute] bool% isDrawHandled
) sealed

Parameters

graphics
Type: System.Drawing..::..Graphics
Reference to the GDI+ surface
gridCell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the grid cell being rendered
isDrawHandled
Type: System..::..Boolean %
Output flag indicating whether the method handled the drawing or not

Implements

IEditor..::..DrawEditorControl(Graphics, GridCell, Boolean%)

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..GetChildAtPoint Method
CurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

CurrencyEditor Class
CurrencyEditor Members
VIBlend.WinForms.DataGridView Namespace


HandleDefaultKeys Method

[image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..HandleDefaultKeys Method
CurrencyEditor Class See Also Send Feedback
Handles the default keys.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void HandleDefaultKeys(
    KeyEventArgs e
)
Visual Basic
Protected Overridable Sub HandleDefaultKeys ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void HandleDefaultKeys(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
The KeyEventArgs instance containing the event data.

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..Invalidate Method
CurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

CurrencyEditor Class
CurrencyEditor Members
VIBlend.WinForms.DataGridView Namespace


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..Invoke Method
CurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

CurrencyEditor Class
CurrencyEditor Members
VIBlend.WinForms.DataGridView Namespace


LayoutEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..LayoutEditor Method
CurrencyEditor Class See Also Send Feedback
This methods is called by the grid control when the editor must update its layout

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void LayoutEditor(
    GridCell cell
)
Visual Basic
Public Overridable Sub LayoutEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void LayoutEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the GridCell being edited

Implements

IEditor..::..LayoutEditor(GridCell)

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


LoadEditorValue Method

[image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..LoadEditorValue Method
CurrencyEditor Class See Also Send Feedback
Loads the editor value.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void LoadEditorValue()
Visual Basic
Protected Overridable Sub LoadEditorValue
Visual C++
protected:
virtual void LoadEditorValue()

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..MemberwiseClone Method
CurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

CurrencyEditor Class
CurrencyEditor Members
VIBlend.WinForms.DataGridView Namespace


OnCloseEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..OnCloseEditor Method
CurrencyEditor Class See Also Send Feedback
This method is called by the grid control when at the end of a cell edit operation

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnCloseEditor()
Visual Basic
Public Sub OnCloseEditor
Visual C++
public:
virtual void OnCloseEditor() sealed

Implements

IEditor..::..OnCloseEditor()()()()

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


OnGridKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..OnGridKeyDown Method
CurrencyEditor Class See Also Send Feedback
Handles grid KeyDown events

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnGridKeyDown(
    KeyEventArgs args,
    GridCell cell,
    out bool closeEditor,
    out bool closeEditorAndSaveChanges
)
Visual Basic
Public Sub OnGridKeyDown ( _
    args As KeyEventArgs, _
    cell As GridCell, _
    <OutAttribute> ByRef closeEditor As Boolean, _
    <OutAttribute> ByRef closeEditorAndSaveChanges As Boolean _
)
Visual C++
public:
virtual void OnGridKeyDown(
    KeyEventArgs^ args,
    GridCell^ cell,
    [OutAttribute] bool% closeEditor,
    [OutAttribute] bool% closeEditorAndSaveChanges
) sealed

Parameters

args
Type: System.Windows.Forms..::..KeyEventArgs
KeyDown event arguments
cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
closeEditor
Type: System..::..Boolean %
The grid cell where the event occured. This may be null if the event did not occur within a grid cell.Output flag indicating whether to keep the editor open or close it instantly
closeEditorAndSaveChanges
Type: System..::..Boolean %

Implements

IEditor..::..OnGridKeyDown(KeyEventArgs, GridCell, Boolean%, Boolean%)

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


OnKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..OnKeyDown Method
CurrencyEditor Class See Also Send Feedback
Raises the [E:KeyDown] event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
The KeyEventArgs instance containing the event data.

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


OnOpenEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..OnOpenEditor Method
CurrencyEditor Class See Also Send Feedback
This method is called by the grid control when the editor is being activated

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnOpenEditor(
    GridCell cell
)
Visual Basic
Public Sub OnOpenEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void OnOpenEditor(
    GridCell^ cell
) sealed

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell

Implements

IEditor..::..OnOpenEditor(GridCell)

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..PerformLayout Method
CurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

CurrencyEditor Class
CurrencyEditor Members
VIBlend.WinForms.DataGridView Namespace


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..ResumeLayout Method
CurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

CurrencyEditor Class
CurrencyEditor Members
VIBlend.WinForms.DataGridView Namespace


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..RtlTranslateAlignment Method
CurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

CurrencyEditor Class
CurrencyEditor Members
VIBlend.WinForms.DataGridView Namespace


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..Scale Method
CurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

CurrencyEditor Class
CurrencyEditor Members
VIBlend.WinForms.DataGridView Namespace


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..Select Method
CurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

CurrencyEditor Class
CurrencyEditor Members
VIBlend.WinForms.DataGridView Namespace


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..SetBounds Method
CurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

CurrencyEditor Class
CurrencyEditor Members
VIBlend.WinForms.DataGridView Namespace


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..UpdateBounds Method
CurrencyEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

CurrencyEditor Class
CurrencyEditor Members
VIBlend.WinForms.DataGridView Namespace


CurrencyEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor Properties
CurrencyEditor Class See Also Send Feedback

The CurrencyEditor type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets a reference to the underlying control of the editor
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information. (Inherited from InputBase.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DeActivationFlags | Gets or sets the editor activation flags
Public property | DecimalPlaces | Gets or sets editor's decimal places. (Inherited from InputBase.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EditCell | Gets the edit cell.
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HandleEnterKey | Gets or sets a value indicating whether to handle the enter and esc keys.
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator | (Inherited from InputBase.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value. (Inherited from InputBase.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value. (Inherited from InputBase.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | (Inherited from InputBase.)
Public property | Minimum | Gets or sets editor's Minimum value. (Inherited from InputBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | Gets the current separator character. (Inherited from vCurrencyEditor.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type. (Inherited from InputBase.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from InputBase.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from InputBase.)
Public property | Value | Gets or sets editor's value. (Inherited from InputBase.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


ActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..ActivationFlags Property
CurrencyEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags ActivationFlags { get; set; }
Visual Basic
Public Property ActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags ActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..ActivationFlags

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


Control Property

[image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..Control Property
CurrencyEditor Class See Also Send Feedback
Gets a reference to the underlying control of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control Control { get; }
Visual Basic
Public ReadOnly Property Control As Control
    Get
Visual C++
public:
virtual property Control^ Control {
    Control^ get () sealed;
}

Implements

IEditor..::..Control

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


DeActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..DeActivationFlags Property
CurrencyEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags DeActivationFlags { get; set; }
Visual Basic
Public Property DeActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags DeActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..DeActivationFlags

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


EditCell Property

[image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..EditCell Property
CurrencyEditor Class See Also Send Feedback
Gets the edit cell.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell EditCell { get; }
Visual Basic
Public ReadOnly Property EditCell As GridCell
    Get
Visual C++
public:
property GridCell^ EditCell {
    GridCell^ get ();
}

Field Value

The edit cell.

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorType Property

[image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..EditorType Property
CurrencyEditor Class See Also Send Feedback
Gets the type of the grid cell editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellEditorType EditorType { get; }
Visual Basic
Public ReadOnly Property EditorType As CellEditorType
    Get
Visual C++
public:
virtual property CellEditorType EditorType {
    CellEditorType get () sealed;
}

Implements

IEditor..::..EditorType

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorValue Property

[image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..EditorValue Property
CurrencyEditor Class See Also Send Feedback
Get's or sets the current value of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object EditorValue { get; set; }
Visual Basic
Public Property EditorValue As Object
    Get
    Set
Visual C++
public:
virtual property Object^ EditorValue {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Implements

IEditor..::..EditorValue

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


HandleEnterKey Property

[image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor..::..HandleEnterKey Property
CurrencyEditor Class See Also Send Feedback
Gets or sets a value indicating whether to handle the enter and esc keys.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool HandleEnterKey { get; set; }
Visual Basic
Public Property HandleEnterKey As Boolean
    Get
    Set
Visual C++
public:
property bool HandleEnterKey {
    bool get ();
    void set (bool value);
}

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


CurrencyEditor Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
CurrencyEditor Events
CurrencyEditor Class See Also Send Feedback

The CurrencyEditor type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed. (Inherited from InputBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event. (Inherited from InputBase.)
Public event | ValueChanged | Represents the ValueChanged event. (Inherited from InputBase.)
Public event | ValueChanging | Represents the ValueChanging event. (Inherited from InputBase.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

CurrencyEditor Class
VIBlend.WinForms.DataGridView Namespace


DataGridGroupHeaderItem Class

[image]

VIBlend Controls for WinForms Help Documentation
DataGridGroupHeaderItem Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class DataGridGroupHeaderItem
Visual Basic
Public Class DataGridGroupHeaderItem
Visual C++
public ref class DataGridGroupHeaderItem

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..DataGridGroupHeaderItem

See Also

DataGridGroupHeaderItem Members
VIBlend.WinForms.DataGridView Namespace


DataGridGroupHeaderItem Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DataGridGroupHeaderItem Members
DataGridGroupHeaderItem Class Constructors Methods Properties See Also Send Feedback

The DataGridGroupHeaderItem type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridGroupHeaderItem | Initializes a new instance of the DataGridGroupHeaderItem class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bounds | Gets or sets the bounds.
Public property | CloseButtonColor | Gets or sets the color of the close button.
Public property | CloseButtonHighlightColor | Gets or sets the color of the close button highlight.
Public property | CloseButtonRenderBounds | Gets or sets the bounds.
Public property | Column | Gets the column.
Public property | ParentHeader | Gets the parent header.
Public property | RenderBounds | Gets or sets the bounds.
Public property | ShowCloseButton | Gets or sets a value indicating whether to show a close button.
Public property | Text | Gets or sets the text.

See Also

DataGridGroupHeaderItem Class
VIBlend.WinForms.DataGridView Namespace


DataGridGroupHeaderItem Constructor

[image]

VIBlend Controls for WinForms Help Documentation
DataGridGroupHeaderItem Constructor
DataGridGroupHeaderItem Class See Also Send Feedback
Initializes a new instance of the DataGridGroupHeaderItem class.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DataGridGroupHeaderItem(
    BoundField boundField,
    vDataGridViewGroupsHeader parent
)
Visual Basic
Public Sub New ( _
    boundField As BoundField, _
    parent As vDataGridViewGroupsHeader _
)
Visual C++
public:
DataGridGroupHeaderItem(
    BoundField^ boundField,
    vDataGridViewGroupsHeader^ parent
)

Parameters

boundField
Type: VIBlend.WinForms.DataGridView..::..BoundField
parent
Type: VIBlend.WinForms.DataGridView..::..vDataGridViewGroupsHeader

See Also

DataGridGroupHeaderItem Class
VIBlend.WinForms.DataGridView Namespace


DataGridGroupHeaderItem Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DataGridGroupHeaderItem Methods
DataGridGroupHeaderItem Class See Also Send Feedback

The DataGridGroupHeaderItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridGroupHeaderItem Class
VIBlend.WinForms.DataGridView Namespace


DataGridGroupHeaderItem Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
DataGridGroupHeaderItem Properties
DataGridGroupHeaderItem Class See Also Send Feedback

The DataGridGroupHeaderItem type exposes the following members.

Properties

 | Name | Description
Public property | Bounds | Gets or sets the bounds.
Public property | CloseButtonColor | Gets or sets the color of the close button.
Public property | CloseButtonHighlightColor | Gets or sets the color of the close button highlight.
Public property | CloseButtonRenderBounds | Gets or sets the bounds.
Public property | Column | Gets the column.
Public property | ParentHeader | Gets the parent header.
Public property | RenderBounds | Gets or sets the bounds.
Public property | ShowCloseButton | Gets or sets a value indicating whether to show a close button.
Public property | Text | Gets or sets the text.

See Also

DataGridGroupHeaderItem Class
VIBlend.WinForms.DataGridView Namespace


Bounds Property

[image]

VIBlend Controls for WinForms Help Documentation
DataGridGroupHeaderItem..::..Bounds Property
DataGridGroupHeaderItem Class See Also Send Feedback
Gets or sets the bounds.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle Bounds { get; internal set; }
Visual Basic
Public Property Bounds As Rectangle
    Get
    Friend Set
Visual C++
public:
property Rectangle Bounds {
    Rectangle get ();
    internal: void set (Rectangle value);
}

Field Value

The bounds.

See Also

DataGridGroupHeaderItem Class
VIBlend.WinForms.DataGridView Namespace


CloseButtonColor Property

[image]

VIBlend Controls for WinForms Help Documentation
DataGridGroupHeaderItem..::..CloseButtonColor Property
DataGridGroupHeaderItem Class See Also Send Feedback
Gets or sets the color of the close button.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color CloseButtonColor { get; set; }
Visual Basic
Public Property CloseButtonColor As Color
    Get
    Set
Visual C++
public:
property Color CloseButtonColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the close button.

See Also

DataGridGroupHeaderItem Class
VIBlend.WinForms.DataGridView Namespace


CloseButtonHighlightColor Property

[image]

VIBlend Controls for WinForms Help Documentation
DataGridGroupHeaderItem..::..CloseButtonHighlightColor Property
DataGridGroupHeaderItem Class See Also Send Feedback
Gets or sets the color of the close button highlight.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color CloseButtonHighlightColor { get; set; }
Visual Basic
Public Property CloseButtonHighlightColor As Color
    Get
    Set
Visual C++
public:
property Color CloseButtonHighlightColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the close button highlight.

See Also

DataGridGroupHeaderItem Class
VIBlend.WinForms.DataGridView Namespace


CloseButtonRenderBounds Property

[image]

VIBlend Controls for WinForms Help Documentation
DataGridGroupHeaderItem..::..CloseButtonRenderBounds Property
DataGridGroupHeaderItem Class See Also Send Feedback
Gets or sets the bounds.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle CloseButtonRenderBounds { get; internal set; }
Visual Basic
Public Property CloseButtonRenderBounds As Rectangle
    Get
    Friend Set
Visual C++
public:
property Rectangle CloseButtonRenderBounds {
    Rectangle get ();
    internal: void set (Rectangle value);
}

Field Value

The bounds.

See Also

DataGridGroupHeaderItem Class
VIBlend.WinForms.DataGridView Namespace


Column Property

[image]

VIBlend Controls for WinForms Help Documentation
DataGridGroupHeaderItem..::..Column Property
DataGridGroupHeaderItem Class See Also Send Feedback
Gets the column.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BoundField Column { get; }
Visual Basic
Public ReadOnly Property Column As BoundField
    Get
Visual C++
public:
property BoundField^ Column {
    BoundField^ get ();
}

Field Value

The column.

See Also

DataGridGroupHeaderItem Class
VIBlend.WinForms.DataGridView Namespace


ParentHeader Property

[image]

VIBlend Controls for WinForms Help Documentation
DataGridGroupHeaderItem..::..ParentHeader Property
DataGridGroupHeaderItem Class See Also Send Feedback
Gets the parent header.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDataGridViewGroupsHeader ParentHeader { get; }
Visual Basic
Public ReadOnly Property ParentHeader As vDataGridViewGroupsHeader
    Get
Visual C++
public:
property vDataGridViewGroupsHeader^ ParentHeader {
    vDataGridViewGroupsHeader^ get ();
}

Field Value

The parent header.

See Also

DataGridGroupHeaderItem Class
VIBlend.WinForms.DataGridView Namespace


RenderBounds Property

[image]

VIBlend Controls for WinForms Help Documentation
DataGridGroupHeaderItem..::..RenderBounds Property
DataGridGroupHeaderItem Class See Also Send Feedback
Gets or sets the bounds.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle RenderBounds { get; internal set; }
Visual Basic
Public Property RenderBounds As Rectangle
    Get
    Friend Set
Visual C++
public:
property Rectangle RenderBounds {
    Rectangle get ();
    internal: void set (Rectangle value);
}

Field Value

The bounds.

See Also

DataGridGroupHeaderItem Class
VIBlend.WinForms.DataGridView Namespace


ShowCloseButton Property

[image]

VIBlend Controls for WinForms Help Documentation
DataGridGroupHeaderItem..::..ShowCloseButton Property
DataGridGroupHeaderItem Class See Also Send Feedback
Gets or sets a value indicating whether to show a close button.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowCloseButton { get; set; }
Visual Basic
Public Property ShowCloseButton As Boolean
    Get
    Set
Visual C++
public:
property bool ShowCloseButton {
    bool get ();
    void set (bool value);
}

See Also

DataGridGroupHeaderItem Class
VIBlend.WinForms.DataGridView Namespace


Text Property

[image]

VIBlend Controls for WinForms Help Documentation
DataGridGroupHeaderItem..::..Text Property
DataGridGroupHeaderItem Class See Also Send Feedback
Gets or sets the text.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Field Value

The text.

See Also

DataGridGroupHeaderItem Class
VIBlend.WinForms.DataGridView Namespace


DataGridLocalization Class

[image]

VIBlend Controls for WinForms Help Documentation
DataGridLocalization Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class DataGridLocalization : DataGridLocalizationBase
Visual Basic
Public Class DataGridLocalization _
    Inherits DataGridLocalizationBase
Visual C++
public ref class DataGridLocalization : public DataGridLocalizationBase

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..DataGridLocalizationBase
VIBlend.WinForms.DataGridView..::..DataGridLocalization

See Also

DataGridLocalization Members
VIBlend.WinForms.DataGridView Namespace


DataGridLocalization Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DataGridLocalization Members
DataGridLocalization Class Constructors Methods See Also Send Feedback

The DataGridLocalization type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridLocalization | Initializes a new instance of the DataGridLocalization class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString | (Overrides DataGridLocalizationBase..::..GetString(LocalizationNames).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridLocalization Class
VIBlend.WinForms.DataGridView Namespace


DataGridLocalization Constructor

[image]

VIBlend Controls for WinForms Help Documentation
DataGridLocalization Constructor
DataGridLocalization Class See Also Send Feedback
Initializes a new instance of the DataGridLocalization class

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DataGridLocalization()
Visual Basic
Public Sub New
Visual C++
public:
DataGridLocalization()

See Also

DataGridLocalization Class
VIBlend.WinForms.DataGridView Namespace


DataGridLocalization Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DataGridLocalization Methods
DataGridLocalization Class See Also Send Feedback

The DataGridLocalization type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString | (Overrides DataGridLocalizationBase..::..GetString(LocalizationNames).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridLocalization Class
VIBlend.WinForms.DataGridView Namespace


GetString Method

[image]

VIBlend Controls for WinForms Help Documentation
DataGridLocalization..::..GetString Method
DataGridLocalization Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string GetString(
    LocalizationNames name
)
Visual Basic
Public Overrides Function GetString ( _
    name As LocalizationNames _
) As String
Visual C++
public:
virtual String^ GetString(
    LocalizationNames name
) override

Parameters

name
Type: VIBlend.WinForms.DataGridView..::..LocalizationNames

See Also

DataGridLocalization Class
VIBlend.WinForms.DataGridView Namespace


DataGridLocalizationBase Class

[image]

VIBlend Controls for WinForms Help Documentation
DataGridLocalizationBase Class
Members See Also Send Feedback
Represents a base class for the DataGrid localization providers.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public abstract class DataGridLocalizationBase
Visual Basic
Public MustInherit Class DataGridLocalizationBase
Visual C++
public ref class DataGridLocalizationBase abstract

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..DataGridLocalizationBase
VIBlend.WinForms.DataGridView..::..DataGridLocalization

See Also

DataGridLocalizationBase Members
VIBlend.WinForms.DataGridView Namespace


DataGridLocalizationBase Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DataGridLocalizationBase Members
DataGridLocalizationBase Class Constructors Methods See Also Send Feedback

The DataGridLocalizationBase type exposes the following members.

Constructors

 | Name | Description
Protected method | DataGridLocalizationBase | Initializes a new instance of the DataGridLocalizationBase class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridLocalizationBase Class
VIBlend.WinForms.DataGridView Namespace


DataGridLocalizationBase Constructor

[image]

VIBlend Controls for WinForms Help Documentation
DataGridLocalizationBase Constructor
DataGridLocalizationBase Class See Also Send Feedback
Initializes a new instance of the DataGridLocalizationBase class

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected DataGridLocalizationBase()
Visual Basic
Protected Sub New
Visual C++
protected:
DataGridLocalizationBase()

See Also

DataGridLocalizationBase Class
VIBlend.WinForms.DataGridView Namespace


DataGridLocalizationBase Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DataGridLocalizationBase Methods
DataGridLocalizationBase Class See Also Send Feedback

The DataGridLocalizationBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridLocalizationBase Class
VIBlend.WinForms.DataGridView Namespace


GetString Method

[image]

VIBlend Controls for WinForms Help Documentation
DataGridLocalizationBase..::..GetString Method
DataGridLocalizationBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public abstract string GetString(
    LocalizationNames name
)
Visual Basic
Public MustOverride Function GetString ( _
    name As LocalizationNames _
) As String
Visual C++
public:
virtual String^ GetString(
    LocalizationNames name
) abstract

Parameters

name
Type: VIBlend.WinForms.DataGridView..::..LocalizationNames

See Also

DataGridLocalizationBase Class
VIBlend.WinForms.DataGridView Namespace


DateTimePickerEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor Class
Members See Also Send Feedback
Represents a DateTimePickerEditor used in the GridView control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class DateTimePickerEditor : vDateTimePicker,
    IEditor
Visual Basic
Public Class DateTimePickerEditor _
    Inherits vDateTimePicker _
    Implements IEditor
Visual C++
public ref class DateTimePickerEditor : public vDateTimePicker,
    IEditor

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vControlBox
VIBlend.WinForms.Controls..::..vDatePicker
VIBlend.WinForms.Controls..::..vDateTimePicker
VIBlend.WinForms.DataGridView..::..DateTimePickerEditor

See Also

DateTimePickerEditor Members
VIBlend.WinForms.DataGridView Namespace


DateTimePickerEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor Members
DateTimePickerEditor Class Constructors Methods Fields Properties Events See Also Send Feedback

The DateTimePickerEditor type exposes the following members.

Constructors

 | Name | Description
Public method | DateTimePickerEditor | Initializes a new instance of the DateTimePickerEditor class

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down. (Inherited from vControlBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vDateTimePicker.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrow | Draws the arrow. (Inherited from vControlBox.)
Public method | DrawEditorControl | Handles the painting of the editor control
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Public method | OnGridKeyDown | Handles grid KeyDown events
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Overrides vDateTimePicker..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from vControlBox.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when property is changed. (Inherited from vControlBox.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Called when the value has been changed (Overrides vDatePicker..::..OnValueChanged()()()().)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown | (Inherited from vControlBox.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | dateTimeEditor | (Inherited from vDatePicker.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoOpenEditorOnActivation | Gets or sets a value indicating whether to open the editor when activated.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from vControlBox.)
Public property | BackColorDropDown | Gets or sets the background color for the dropdown control. (Inherited from vControlBox.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color which is used when the UseThemeBorderColor property is false. (Inherited from vControlBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | Calendar | Returns the calendar control hosted by the vDataTimePicker control (Inherited from vDatePicker.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentControl | Gets or sets the content control which is displayed when the dropdown is opened (Inherited from vControlBox.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets a reference to the underlying control of the editor
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Culture | Gets or sets the current culture settings of the control. (Inherited from vDatePicker.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DateTimeEditor | (Inherited from vDatePicker.)
Public property | DeActivationFlags | Gets or sets the editor activation flags
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Public property | DefaultDateTimeFormat | Gets or sets the default date time format. (Inherited from vDateTimePicker.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets a reference to the DropDown of the ControlBox (Inherited from vControlBox.)
Public property | DropDownArrowBackgroundEnabled | Determines whether to the drop-down arrow's background is painted (Inherited from vControlBox.)
Public property | DropDownArrowColor | Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false. (Inherited from vControlBox.)
Public property | DropDownButtonBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownButtonDisabledBackgroundBrush | Gets or sets the disabled background brush. (Inherited from vControlBox.)
Public property | DropDownButtonHighlightBackgroundBrush | Gets or sets the HighlightBackground brush. (Inherited from vControlBox.)
Public property | DropDownButtonPressedBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMaximumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMinimumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownResizeDirection | Gets or sets a value indicating the possible drop-down resize directions (Inherited from vControlBox.)
Public property | DropDownWidth | Gets or sets the width in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | EditBase | Gets a reference to the EditBox of the vControlBox control (Inherited from vControlBox.)
Public property | EditCell | Gets the edit cell.
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | EnableCloseOnSelectionChanged | Gets or sets a value indicating whether to close the editor when the selection is changed.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font that is used to display the text in the editbox of the control (Inherited from vDatePicker.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color which is used to display the text (Inherited from vControlBox.)
Public property | FormatValue | Gets or sets the text formatting applied to the text box of the DatePicker control (Inherited from vDatePicker.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaxDate | Gets or sets the maximum DateTime. (Inherited from vDatePicker.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinDate | Gets or sets the minimum DateTime (Inherited from vDatePicker.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowGrip | Gets or sets a value indicating whether grip is shown (Inherited from vControlBox.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text displayed in the editbox of the control (Inherited from vControlBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vControlBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UpdateTimer | Gets the update timer. (Inherited from vDateTimePicker.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from vDatePicker.)
Public property | UseDropDownButtonThemeBackground | Gets or sets a value indicating whether to use theme's background (Inherited from vControlBox.)
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeBorderColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeDropDownArrowColor | Gets or sets whether to use the Theme default arrow color. (Inherited from vControlBox.)
Public property | UseThemeFont | Gets or sets whether to use the Theme Font or the control's Font property. (Inherited from vControlBox.)
Public property | UseThemeForeColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from vDatePicker.)
Public property | Value | Gets or sets the current DateTime for the control. (Inherited from vDatePicker.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vControlBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from vControlBox.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when the value has been changed (Inherited from vDatePicker.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


DateTimePickerEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor Constructor
DateTimePickerEditor Class See Also Send Feedback
Initializes a new instance of the DateTimePickerEditor class

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTimePickerEditor()
Visual Basic
Public Sub New
Visual C++
public:
DateTimePickerEditor()

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


DateTimePickerEditor Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor Fields
DateTimePickerEditor Class See Also Send Feedback

The DateTimePickerEditor type exposes the following members.

Fields

 | Name | Description
Protected field | dateTimeEditor | (Inherited from vDatePicker.)

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


DateTimePickerEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor Methods
DateTimePickerEditor Class See Also Send Feedback

The DateTimePickerEditor type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CloseDropDown | Closes the drop down. (Inherited from vControlBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vDateTimePicker.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Protected method | DrawArrow | Draws the arrow. (Inherited from vControlBox.)
Public method | DrawEditorControl | Handles the painting of the editor control
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Public method | OnGridKeyDown | Handles grid KeyDown events
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | (Overrides vDateTimePicker..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from vControlBox.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when property is changed. (Inherited from vControlBox.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Called when the value has been changed (Overrides vDatePicker..::..OnValueChanged()()()().)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowDropDown | (Inherited from vControlBox.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..AccessibilityNotifyClients Method
DateTimePickerEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DateTimePickerEditor Class
DateTimePickerEditor Members
VIBlend.WinForms.DataGridView Namespace


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..BeginInvoke Method
DateTimePickerEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DateTimePickerEditor Class
DateTimePickerEditor Members
VIBlend.WinForms.DataGridView Namespace


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..Dispose Method
DateTimePickerEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Inherited from vDateTimePicker.)

See Also

DateTimePickerEditor Class
DateTimePickerEditor Members
VIBlend.WinForms.DataGridView Namespace


DrawEditorControl Method

[image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..DrawEditorControl Method
DateTimePickerEditor Class See Also Send Feedback
Handles the painting of the editor control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawEditorControl(
    Graphics graphics,
    GridCell gridCell,
    out bool isDrawHandled
)
Visual Basic
Public Sub DrawEditorControl ( _
    graphics As Graphics, _
    gridCell As GridCell, _
    <OutAttribute> ByRef isDrawHandled As Boolean _
)
Visual C++
public:
virtual void DrawEditorControl(
    Graphics^ graphics,
    GridCell^ gridCell,
    [OutAttribute] bool% isDrawHandled
) sealed

Parameters

graphics
Type: System.Drawing..::..Graphics
Reference to the GDI+ surface
gridCell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the grid cell being rendered
isDrawHandled
Type: System..::..Boolean %
Output flag indicating whether the method handled the drawing or not

Implements

IEditor..::..DrawEditorControl(Graphics, GridCell, Boolean%)

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..GetChildAtPoint Method
DateTimePickerEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DateTimePickerEditor Class
DateTimePickerEditor Members
VIBlend.WinForms.DataGridView Namespace


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..Invalidate Method
DateTimePickerEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DateTimePickerEditor Class
DateTimePickerEditor Members
VIBlend.WinForms.DataGridView Namespace


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..Invoke Method
DateTimePickerEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DateTimePickerEditor Class
DateTimePickerEditor Members
VIBlend.WinForms.DataGridView Namespace


LayoutEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..LayoutEditor Method
DateTimePickerEditor Class See Also Send Feedback
This methods is called by the grid control when the editor must update its layout

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void LayoutEditor(
    GridCell cell
)
Visual Basic
Public Overridable Sub LayoutEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void LayoutEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the GridCell being edited

Implements

IEditor..::..LayoutEditor(GridCell)

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..MemberwiseClone Method
DateTimePickerEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DateTimePickerEditor Class
DateTimePickerEditor Members
VIBlend.WinForms.DataGridView Namespace


OnCloseEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..OnCloseEditor Method
DateTimePickerEditor Class See Also Send Feedback
This method is called by the grid control when at the end of a cell edit operation

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void OnCloseEditor()
Visual Basic
Public Overridable Sub OnCloseEditor
Visual C++
public:
virtual void OnCloseEditor()

Implements

IEditor..::..OnCloseEditor()()()()

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


OnGridKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..OnGridKeyDown Method
DateTimePickerEditor Class See Also Send Feedback
Handles grid KeyDown events

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnGridKeyDown(
    KeyEventArgs args,
    GridCell cell,
    out bool closeEditor,
    out bool closeEditorAndSaveChanges
)
Visual Basic
Public Sub OnGridKeyDown ( _
    args As KeyEventArgs, _
    cell As GridCell, _
    <OutAttribute> ByRef closeEditor As Boolean, _
    <OutAttribute> ByRef closeEditorAndSaveChanges As Boolean _
)
Visual C++
public:
virtual void OnGridKeyDown(
    KeyEventArgs^ args,
    GridCell^ cell,
    [OutAttribute] bool% closeEditor,
    [OutAttribute] bool% closeEditorAndSaveChanges
) sealed

Parameters

args
Type: System.Windows.Forms..::..KeyEventArgs
KeyDown event arguments
cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
The grid cell where the event occured. This may be null if the event did not occur within a grid cell.
closeEditor
Type: System..::..Boolean %
Output flag indicating whether to keep the editor open or close it instantly
closeEditorAndSaveChanges
Type: System..::..Boolean %

Implements

IEditor..::..OnGridKeyDown(KeyEventArgs, GridCell, Boolean%, Boolean%)

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


OnKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..OnKeyDown Method
DateTimePickerEditor Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


OnOpenEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..OnOpenEditor Method
DateTimePickerEditor Class See Also Send Feedback
This method is called by the grid control when the editor is being activated

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void OnOpenEditor(
    GridCell cell
)
Visual Basic
Public Overridable Sub OnOpenEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void OnOpenEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell

Implements

IEditor..::..OnOpenEditor(GridCell)

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


OnValueChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..OnValueChanged Method
DateTimePickerEditor Class See Also Send Feedback
Called when the value has been changed

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnValueChanged()
Visual Basic
Protected Overrides Sub OnValueChanged
Visual C++
protected:
virtual void OnValueChanged() override

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..PerformLayout Method
DateTimePickerEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DateTimePickerEditor Class
DateTimePickerEditor Members
VIBlend.WinForms.DataGridView Namespace


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..ResumeLayout Method
DateTimePickerEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DateTimePickerEditor Class
DateTimePickerEditor Members
VIBlend.WinForms.DataGridView Namespace


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..RtlTranslateAlignment Method
DateTimePickerEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DateTimePickerEditor Class
DateTimePickerEditor Members
VIBlend.WinForms.DataGridView Namespace


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..Scale Method
DateTimePickerEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DateTimePickerEditor Class
DateTimePickerEditor Members
VIBlend.WinForms.DataGridView Namespace


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..Select Method
DateTimePickerEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

DateTimePickerEditor Class
DateTimePickerEditor Members
VIBlend.WinForms.DataGridView Namespace


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..SetBounds Method
DateTimePickerEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DateTimePickerEditor Class
DateTimePickerEditor Members
VIBlend.WinForms.DataGridView Namespace


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..UpdateBounds Method
DateTimePickerEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DateTimePickerEditor Class
DateTimePickerEditor Members
VIBlend.WinForms.DataGridView Namespace


DateTimePickerEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor Properties
DateTimePickerEditor Class See Also Send Feedback

The DateTimePickerEditor type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoOpenEditorOnActivation | Gets or sets a value indicating whether to open the editor when activated.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from vControlBox.)
Public property | BackColorDropDown | Gets or sets the background color for the dropdown control. (Inherited from vControlBox.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color which is used when the UseThemeBorderColor property is false. (Inherited from vControlBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | Calendar | Returns the calendar control hosted by the vDataTimePicker control (Inherited from vDatePicker.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentControl | Gets or sets the content control which is displayed when the dropdown is opened (Inherited from vControlBox.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets a reference to the underlying control of the editor
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Culture | Gets or sets the current culture settings of the control. (Inherited from vDatePicker.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DateTimeEditor | (Inherited from vDatePicker.)
Public property | DeActivationFlags | Gets or sets the editor activation flags
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Public property | DefaultDateTimeFormat | Gets or sets the default date time format. (Inherited from vDateTimePicker.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | DropDown | Gets a reference to the DropDown of the ControlBox (Inherited from vControlBox.)
Public property | DropDownArrowBackgroundEnabled | Determines whether to the drop-down arrow's background is painted (Inherited from vControlBox.)
Public property | DropDownArrowColor | Gets or sets the border color which is used when the UseThemeDropDownArrowColor property is false. (Inherited from vControlBox.)
Public property | DropDownButtonBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownButtonDisabledBackgroundBrush | Gets or sets the disabled background brush. (Inherited from vControlBox.)
Public property | DropDownButtonHighlightBackgroundBrush | Gets or sets the HighlightBackground brush. (Inherited from vControlBox.)
Public property | DropDownButtonPressedBackgroundBrush | Gets or sets the background brush. (Inherited from vControlBox.)
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMaximumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownMinimumSize | Gets or sets the maximum size of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | DropDownResizeDirection | Gets or sets a value indicating the possible drop-down resize directions (Inherited from vControlBox.)
Public property | DropDownWidth | Gets or sets the width in pixels of the drop-down portion of the ControlBox (Inherited from vControlBox.)
Public property | EditBase | Gets a reference to the EditBox of the vControlBox control (Inherited from vControlBox.)
Public property | EditCell | Gets the edit cell.
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | EnableCloseOnSelectionChanged | Gets or sets a value indicating whether to close the editor when the selection is changed.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font that is used to display the text in the editbox of the control (Inherited from vDatePicker.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color which is used to display the text (Inherited from vControlBox.)
Public property | FormatValue | Gets or sets the text formatting applied to the text box of the DatePicker control (Inherited from vDatePicker.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaxDate | Gets or sets the maximum DateTime. (Inherited from vDatePicker.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinDate | Gets or sets the minimum DateTime (Inherited from vDatePicker.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowGrip | Gets or sets a value indicating whether grip is shown (Inherited from vControlBox.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text displayed in the editbox of the control (Inherited from vControlBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vControlBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UpdateTimer | Gets the update timer. (Inherited from vDateTimePicker.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from vDatePicker.)
Public property | UseDropDownButtonThemeBackground | Gets or sets a value indicating whether to use theme's background (Inherited from vControlBox.)
Public property | UseThemeBackColor | Gets or sets whether to use the Theme BackColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeBorderColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseThemeDropDownArrowColor | Gets or sets whether to use the Theme default arrow color. (Inherited from vControlBox.)
Public property | UseThemeFont | Gets or sets whether to use the Theme Font or the control's Font property. (Inherited from vControlBox.)
Public property | UseThemeForeColor | Gets or sets whether to use the Theme BorderColor or the control's BackColor property. (Inherited from vControlBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from vDatePicker.)
Public property | Value | Gets or sets the current DateTime for the control. (Inherited from vDatePicker.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vControlBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


ActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..ActivationFlags Property
DateTimePickerEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags ActivationFlags { get; set; }
Visual Basic
Public Property ActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags ActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..ActivationFlags

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


AutoOpenEditorOnActivation Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..AutoOpenEditorOnActivation Property
DateTimePickerEditor Class See Also Send Feedback
Gets or sets a value indicating whether to open the editor when activated.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AutoOpenEditorOnActivation { get; set; }
Visual Basic
Public Property AutoOpenEditorOnActivation As Boolean
    Get
    Set
Visual C++
public:
property bool AutoOpenEditorOnActivation {
    bool get ();
    void set (bool value);
}

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


Control Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..Control Property
DateTimePickerEditor Class See Also Send Feedback
Gets a reference to the underlying control of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control Control { get; }
Visual Basic
Public ReadOnly Property Control As Control
    Get
Visual C++
public:
virtual property Control^ Control {
    Control^ get () sealed;
}

Implements

IEditor..::..Control

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


DeActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..DeActivationFlags Property
DateTimePickerEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags DeActivationFlags { get; set; }
Visual Basic
Public Property DeActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags DeActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..DeActivationFlags

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


EditCell Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..EditCell Property
DateTimePickerEditor Class See Also Send Feedback
Gets the edit cell.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell EditCell { get; }
Visual Basic
Public ReadOnly Property EditCell As GridCell
    Get
Visual C++
public:
property GridCell^ EditCell {
    GridCell^ get ();
}

Field Value

The edit cell.

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorType Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..EditorType Property
DateTimePickerEditor Class See Also Send Feedback
Gets the type of the grid cell editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellEditorType EditorType { get; }
Visual Basic
Public ReadOnly Property EditorType As CellEditorType
    Get
Visual C++
public:
virtual property CellEditorType EditorType {
    CellEditorType get () sealed;
}

Implements

IEditor..::..EditorType

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorValue Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..EditorValue Property
DateTimePickerEditor Class See Also Send Feedback
Get's or sets the current value of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object EditorValue { get; set; }
Visual Basic
Public Property EditorValue As Object
    Get
    Set
Visual C++
public:
virtual property Object^ EditorValue {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Implements

IEditor..::..EditorValue

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


EnableCloseOnSelectionChanged Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor..::..EnableCloseOnSelectionChanged Property
DateTimePickerEditor Class See Also Send Feedback
Gets or sets a value indicating whether to close the editor when the selection is changed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableCloseOnSelectionChanged { get; set; }
Visual Basic
Public Property EnableCloseOnSelectionChanged As Boolean
    Get
    Set
Visual C++
public:
property bool EnableCloseOnSelectionChanged {
    bool get ();
    void set (bool value);
}

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


DateTimePickerEditor Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimePickerEditor Events
DateTimePickerEditor Class See Also Send Feedback

The DateTimePickerEditor type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from vControlBox.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when the value has been changed (Inherited from vDatePicker.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DateTimePickerEditor Class
VIBlend.WinForms.DataGridView Namespace


DisplaySettings Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
DisplaySettings Enumeration
See Also Send Feedback
Grid Cell Image display settings

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum DisplaySettings
Visual Basic
Public Enumeration DisplaySettings
Visual C++
public enum class DisplaySettings

Members

Member name | Description
TextOnly |
ImageOnly |
TextAndImage |

See Also

VIBlend.WinForms.DataGridView Namespace


EditorActivationCancelEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
EditorActivationCancelEventArgs Class
Members See Also Send Feedback
Represents Grid cell editor activation event arguments that supports event canceling.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class EditorActivationCancelEventArgs : CellCancelEventArgs
Visual Basic
Public Class EditorActivationCancelEventArgs _
    Inherits CellCancelEventArgs
Visual C++
public ref class EditorActivationCancelEventArgs : public CellCancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.DataGridView..::..CellEventArgs
VIBlend.WinForms.DataGridView..::..CellCancelEventArgs
VIBlend.WinForms.DataGridView..::..EditorActivationCancelEventArgs

See Also

EditorActivationCancelEventArgs Members
VIBlend.WinForms.DataGridView Namespace


EditorActivationCancelEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
EditorActivationCancelEventArgs Members
EditorActivationCancelEventArgs Class Constructors Methods Properties See Also Send Feedback

The EditorActivationCancelEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | EditorActivationCancelEventArgs | EditorActivationCancelEventArgs constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivationFlags | Gets the bitmaks that represents the cell editor's activation flags.
Public property | Cancel | Determines if the event is canceled. (Inherited from CellCancelEventArgs.)
Public property | Cell | GridCell associated with the event (Inherited from CellEventArgs.)
Public property | KeyEventArgs | Gets the KeyEventArgs.

See Also

EditorActivationCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


EditorActivationCancelEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
EditorActivationCancelEventArgs Constructor
EditorActivationCancelEventArgs Class See Also Send Feedback
EditorActivationCancelEventArgs constructor.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationCancelEventArgs(
    GridCell cell,
    EditorActivationFlags editorActivationFlag,
    KeyEventArgs keyArgs
)
Visual Basic
Public Sub New ( _
    cell As GridCell, _
    editorActivationFlag As EditorActivationFlags, _
    keyArgs As KeyEventArgs _
)
Visual C++
public:
EditorActivationCancelEventArgs(
    GridCell^ cell,
    EditorActivationFlags editorActivationFlag,
    KeyEventArgs^ keyArgs
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
A refrence to the grid cell.
editorActivationFlag
Type: VIBlend.WinForms.DataGridView..::..EditorActivationFlags
Bitmask that represents the editor activation flags.
keyArgs
Type: System.Windows.Forms..::..KeyEventArgs
Reference to the key event arguments.

See Also

EditorActivationCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


EditorActivationCancelEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
EditorActivationCancelEventArgs Methods
EditorActivationCancelEventArgs Class See Also Send Feedback

The EditorActivationCancelEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EditorActivationCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


EditorActivationCancelEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
EditorActivationCancelEventArgs Properties
EditorActivationCancelEventArgs Class See Also Send Feedback

The EditorActivationCancelEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ActivationFlags | Gets the bitmaks that represents the cell editor's activation flags.
Public property | Cancel | Determines if the event is canceled. (Inherited from CellCancelEventArgs.)
Public property | Cell | GridCell associated with the event (Inherited from CellEventArgs.)
Public property | KeyEventArgs | Gets the KeyEventArgs.

See Also

EditorActivationCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


ActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
EditorActivationCancelEventArgs..::..ActivationFlags Property
EditorActivationCancelEventArgs Class See Also Send Feedback
Gets the bitmaks that represents the cell editor's activation flags.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags ActivationFlags { get; }
Visual Basic
Public ReadOnly Property ActivationFlags As EditorActivationFlags
    Get
Visual C++
public:
property EditorActivationFlags ActivationFlags {
    EditorActivationFlags get ();
}

See Also

EditorActivationCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


KeyEventArgs Property

[image]

VIBlend Controls for WinForms Help Documentation
EditorActivationCancelEventArgs..::..KeyEventArgs Property
EditorActivationCancelEventArgs Class See Also Send Feedback
Gets the KeyEventArgs.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public KeyEventArgs KeyEventArgs { get; }
Visual Basic
Public ReadOnly Property KeyEventArgs As KeyEventArgs
    Get
Visual C++
public:
property KeyEventArgs^ KeyEventArgs {
    KeyEventArgs^ get ();
}

See Also

EditorActivationCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


EditorActivationFlags Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
EditorActivationFlags Enumeration
See Also Send Feedback
Enumaration of the grid editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[FlagsAttribute]
public enum EditorActivationFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration EditorActivationFlags
Visual C++
[FlagsAttribute]
public enum class EditorActivationFlags

Members

Member name | Description
MOUSE_MOVE |
MOUSE_CLICK |
MOUSE_DBLCLICK |
KEY_PRESS |
PROGRAMMATIC |
MOUSE_CLICK_SELECTED_CELL |
KEY_PRESS_ENTER |
KEY_PRESS_ESC |

See Also

VIBlend.WinForms.DataGridView Namespace


FilterDisplayMode Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
FilterDisplayMode Enumeration
See Also Send Feedback
Represents the FilterDisplayMode enum.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum FilterDisplayMode
Visual Basic
Public Enumeration FilterDisplayMode
Visual C++
public enum class FilterDisplayMode

Members

Member name | Description
Default |
Basic |
Custom |

See Also

VIBlend.WinForms.DataGridView Namespace


FixedPointEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class FixedPointEditor : vFixedPointEditor,
    IEditor
Visual Basic
Public Class FixedPointEditor _
    Inherits vFixedPointEditor _
    Implements IEditor
Visual C++
public ref class FixedPointEditor : public vFixedPointEditor,
    IEditor

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vTextBox
VIBlend.WinForms.Controls..::..InputBase
VIBlend.WinForms.Controls..::..vFixedPointEditor
VIBlend.WinForms.DataGridView..::..FixedPointEditor

See Also

FixedPointEditor Members
VIBlend.WinForms.DataGridView Namespace


FixedPointEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor Members
FixedPointEditor Class Constructors Methods Fields Properties Events See Also Send Feedback

The FixedPointEditor type exposes the following members.

Constructors

 | Name | Description
Public method | FixedPointEditor | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | (Inherited from vFixedPointEditor.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from InputBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | (Inherited from vFixedPointEditor.)
Protected method | CtrlV | (Inherited from vFixedPointEditor.)
Protected method | CtrlX | (Inherited from vFixedPointEditor.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | (Inherited from vFixedPointEditor.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key. (Inherited from InputBase.)
Public method | DrawEditorControl | Handles the painting of the editor control
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key. (Inherited from InputBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider. (Inherited from InputBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text. (Inherited from InputBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDefaultKeys | Handles the default keys.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key. (Inherited from InputBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | (Inherited from vFixedPointEditor.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown | (Inherited from InputBase.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed. (Inherited from InputBase.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Public method | LeftKey | Moves the cursor one position left. (Inherited from InputBase.)
Protected method | LoadEditorValue | Loads the editor value.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Public method | OnGridKeyDown | Handles grid KeyDown events
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the [E:KeyDown] event. (Overrides InputBase..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | (Inherited from InputBase.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from InputBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from vFixedPointEditor.)
Protected method | OnMouseWheel | (Inherited from InputBase.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | (Inherited from InputBase.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from InputBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event. (Inherited from InputBase.)
Protected method | OnValueChanged | Calls the ValueChanged event. (Inherited from InputBase.)
Protected method | OnValueChanging | Calls the ValueChanging event. (Inherited from InputBase.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | (Inherited from vFixedPointEditor.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | (Inherited from vFixedPointEditor.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters. (Inherited from InputBase.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key. (Inherited from InputBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | (Inherited from vFixedPointEditor.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit | (Inherited from InputBase.)
Protected method | SpinDigitWithWrap | Spins the digit with wrap. (Inherited from InputBase.)
Public method | SpinValue | Increases or decreases the current value. (Inherited from InputBase.)
Protected method | SpinValueBeforeDigit | Spins the value before digit. (Inherited from InputBase.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | (Inherited from vFixedPointEditor.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key. (Inherited from InputBase.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | baseFormatString | (Inherited from InputBase.)
Protected field | cultureInfo | (Inherited from InputBase.)
Protected field | decimalPlaces | (Inherited from InputBase.)
Protected field | decimalPossibleChars | (Inherited from InputBase.)
Protected field | emptyValue | (Inherited from InputBase.)
Protected field | formatString | (Inherited from InputBase.)
Protected field | isLessThanZero | (Inherited from InputBase.)
Protected field | manager | (Inherited from InputBase.)
Protected field | maximum | (Inherited from InputBase.)
Protected field | minimum | (Inherited from InputBase.)
Protected field | undoValue | (Inherited from InputBase.)
Protected field | value | (Inherited from InputBase.)
Protected field | valueString | (Inherited from InputBase.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets a reference to the underlying control of the editor
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information. (Inherited from InputBase.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DeActivationFlags | Gets or sets the editor activation flags
Public property | DecimalPlaces | Gets or sets editor's decimal places. (Inherited from InputBase.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EditCell | Gets the edit cell.
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HandleEnterKey | Gets or sets a value indicating whether to handle the enter and esc keys.
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator | (Inherited from InputBase.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value. (Inherited from InputBase.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value. (Inherited from InputBase.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | (Inherited from InputBase.)
Public property | Minimum | Gets or sets editor's Minimum value. (Inherited from InputBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | (Inherited from vFixedPointEditor.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type. (Inherited from InputBase.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from InputBase.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from InputBase.)
Public property | Value | Gets or sets editor's value. (Inherited from InputBase.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed. (Inherited from InputBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event. (Inherited from InputBase.)
Public event | ValueChanged | Represents the ValueChanged event. (Inherited from InputBase.)
Public event | ValueChanging | Represents the ValueChanging event. (Inherited from InputBase.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


FixedPointEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor Constructor
FixedPointEditor Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public FixedPointEditor()
Visual Basic
Public Sub New
Visual C++
public:
FixedPointEditor()

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


FixedPointEditor Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor Fields
FixedPointEditor Class See Also Send Feedback

The FixedPointEditor type exposes the following members.

Fields

 | Name | Description
Protected field | baseFormatString | (Inherited from InputBase.)
Protected field | cultureInfo | (Inherited from InputBase.)
Protected field | decimalPlaces | (Inherited from InputBase.)
Protected field | decimalPossibleChars | (Inherited from InputBase.)
Protected field | emptyValue | (Inherited from InputBase.)
Protected field | formatString | (Inherited from InputBase.)
Protected field | isLessThanZero | (Inherited from InputBase.)
Protected field | manager | (Inherited from InputBase.)
Protected field | maximum | (Inherited from InputBase.)
Protected field | minimum | (Inherited from InputBase.)
Protected field | undoValue | (Inherited from InputBase.)
Protected field | value | (Inherited from InputBase.)
Protected field | valueString | (Inherited from InputBase.)

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


FixedPointEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor Methods
FixedPointEditor Class See Also Send Feedback

The FixedPointEditor type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | (Inherited from vFixedPointEditor.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from InputBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | (Inherited from vFixedPointEditor.)
Protected method | CtrlV | (Inherited from vFixedPointEditor.)
Protected method | CtrlX | (Inherited from vFixedPointEditor.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | (Inherited from vFixedPointEditor.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key. (Inherited from InputBase.)
Public method | DrawEditorControl | Handles the painting of the editor control
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key. (Inherited from InputBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider. (Inherited from InputBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text. (Inherited from InputBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDefaultKeys | Handles the default keys.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key. (Inherited from InputBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | (Inherited from vFixedPointEditor.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown | (Inherited from InputBase.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed. (Inherited from InputBase.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Public method | LeftKey | Moves the cursor one position left. (Inherited from InputBase.)
Protected method | LoadEditorValue | Loads the editor value.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Public method | OnGridKeyDown | Handles grid KeyDown events
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the [E:KeyDown] event. (Overrides InputBase..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | (Inherited from InputBase.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from InputBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from vFixedPointEditor.)
Protected method | OnMouseWheel | (Inherited from InputBase.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | (Inherited from InputBase.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from InputBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event. (Inherited from InputBase.)
Protected method | OnValueChanged | Calls the ValueChanged event. (Inherited from InputBase.)
Protected method | OnValueChanging | Calls the ValueChanging event. (Inherited from InputBase.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | (Inherited from vFixedPointEditor.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | (Inherited from vFixedPointEditor.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters. (Inherited from InputBase.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key. (Inherited from InputBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | (Inherited from vFixedPointEditor.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit | (Inherited from InputBase.)
Protected method | SpinDigitWithWrap | Spins the digit with wrap. (Inherited from InputBase.)
Public method | SpinValue | Increases or decreases the current value. (Inherited from InputBase.)
Protected method | SpinValueBeforeDigit | Spins the value before digit. (Inherited from InputBase.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | (Inherited from vFixedPointEditor.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key. (Inherited from InputBase.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..AccessibilityNotifyClients Method
FixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

FixedPointEditor Class
FixedPointEditor Members
VIBlend.WinForms.DataGridView Namespace


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..BeginInvoke Method
FixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

FixedPointEditor Class
FixedPointEditor Members
VIBlend.WinForms.DataGridView Namespace


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..Dispose Method
FixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

FixedPointEditor Class
FixedPointEditor Members
VIBlend.WinForms.DataGridView Namespace


DrawEditorControl Method

[image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..DrawEditorControl Method
FixedPointEditor Class See Also Send Feedback
Handles the painting of the editor control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawEditorControl(
    Graphics graphics,
    GridCell gridCell,
    out bool isDrawHandled
)
Visual Basic
Public Sub DrawEditorControl ( _
    graphics As Graphics, _
    gridCell As GridCell, _
    <OutAttribute> ByRef isDrawHandled As Boolean _
)
Visual C++
public:
virtual void DrawEditorControl(
    Graphics^ graphics,
    GridCell^ gridCell,
    [OutAttribute] bool% isDrawHandled
) sealed

Parameters

graphics
Type: System.Drawing..::..Graphics
Reference to the GDI+ surface
gridCell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the grid cell being rendered
isDrawHandled
Type: System..::..Boolean %
Output flag indicating whether the method handled the drawing or not

Implements

IEditor..::..DrawEditorControl(Graphics, GridCell, Boolean%)

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..GetChildAtPoint Method
FixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

FixedPointEditor Class
FixedPointEditor Members
VIBlend.WinForms.DataGridView Namespace


HandleDefaultKeys Method

[image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..HandleDefaultKeys Method
FixedPointEditor Class See Also Send Feedback
Handles the default keys.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void HandleDefaultKeys(
    KeyEventArgs e
)
Visual Basic
Protected Overridable Sub HandleDefaultKeys ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void HandleDefaultKeys(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
The KeyEventArgs instance containing the event data.

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..Invalidate Method
FixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

FixedPointEditor Class
FixedPointEditor Members
VIBlend.WinForms.DataGridView Namespace


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..Invoke Method
FixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

FixedPointEditor Class
FixedPointEditor Members
VIBlend.WinForms.DataGridView Namespace


LayoutEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..LayoutEditor Method
FixedPointEditor Class See Also Send Feedback
This methods is called by the grid control when the editor must update its layout

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void LayoutEditor(
    GridCell cell
)
Visual Basic
Public Overridable Sub LayoutEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void LayoutEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the GridCell being edited

Implements

IEditor..::..LayoutEditor(GridCell)

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


LoadEditorValue Method

[image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..LoadEditorValue Method
FixedPointEditor Class See Also Send Feedback
Loads the editor value.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void LoadEditorValue()
Visual Basic
Protected Overridable Sub LoadEditorValue
Visual C++
protected:
virtual void LoadEditorValue()

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..MemberwiseClone Method
FixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

FixedPointEditor Class
FixedPointEditor Members
VIBlend.WinForms.DataGridView Namespace


OnCloseEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..OnCloseEditor Method
FixedPointEditor Class See Also Send Feedback
This method is called by the grid control when at the end of a cell edit operation

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnCloseEditor()
Visual Basic
Public Sub OnCloseEditor
Visual C++
public:
virtual void OnCloseEditor() sealed

Implements

IEditor..::..OnCloseEditor()()()()

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


OnGridKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..OnGridKeyDown Method
FixedPointEditor Class See Also Send Feedback
Handles grid KeyDown events

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnGridKeyDown(
    KeyEventArgs args,
    GridCell cell,
    out bool closeEditor,
    out bool closeEditorAndSaveChanges
)
Visual Basic
Public Sub OnGridKeyDown ( _
    args As KeyEventArgs, _
    cell As GridCell, _
    <OutAttribute> ByRef closeEditor As Boolean, _
    <OutAttribute> ByRef closeEditorAndSaveChanges As Boolean _
)
Visual C++
public:
virtual void OnGridKeyDown(
    KeyEventArgs^ args,
    GridCell^ cell,
    [OutAttribute] bool% closeEditor,
    [OutAttribute] bool% closeEditorAndSaveChanges
) sealed

Parameters

args
Type: System.Windows.Forms..::..KeyEventArgs
KeyDown event arguments
cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
closeEditor
Type: System..::..Boolean %
The grid cell where the event occured. This may be null if the event did not occur within a grid cell.Output flag indicating whether to keep the editor open or close it instantly
closeEditorAndSaveChanges
Type: System..::..Boolean %

Implements

IEditor..::..OnGridKeyDown(KeyEventArgs, GridCell, Boolean%, Boolean%)

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


OnKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..OnKeyDown Method
FixedPointEditor Class See Also Send Feedback
Raises the [E:KeyDown] event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
The KeyEventArgs instance containing the event data.

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


OnOpenEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..OnOpenEditor Method
FixedPointEditor Class See Also Send Feedback
This method is called by the grid control when the editor is being activated

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnOpenEditor(
    GridCell cell
)
Visual Basic
Public Sub OnOpenEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void OnOpenEditor(
    GridCell^ cell
) sealed

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell

Implements

IEditor..::..OnOpenEditor(GridCell)

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..PerformLayout Method
FixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

FixedPointEditor Class
FixedPointEditor Members
VIBlend.WinForms.DataGridView Namespace


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..ResumeLayout Method
FixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

FixedPointEditor Class
FixedPointEditor Members
VIBlend.WinForms.DataGridView Namespace


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..RtlTranslateAlignment Method
FixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

FixedPointEditor Class
FixedPointEditor Members
VIBlend.WinForms.DataGridView Namespace


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..Scale Method
FixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

FixedPointEditor Class
FixedPointEditor Members
VIBlend.WinForms.DataGridView Namespace


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..Select Method
FixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

FixedPointEditor Class
FixedPointEditor Members
VIBlend.WinForms.DataGridView Namespace


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..SetBounds Method
FixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

FixedPointEditor Class
FixedPointEditor Members
VIBlend.WinForms.DataGridView Namespace


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..UpdateBounds Method
FixedPointEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

FixedPointEditor Class
FixedPointEditor Members
VIBlend.WinForms.DataGridView Namespace


FixedPointEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor Properties
FixedPointEditor Class See Also Send Feedback

The FixedPointEditor type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets a reference to the underlying control of the editor
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information. (Inherited from InputBase.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DeActivationFlags | Gets or sets the editor activation flags
Public property | DecimalPlaces | Gets or sets editor's decimal places. (Inherited from InputBase.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EditCell | Gets the edit cell.
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HandleEnterKey | Gets or sets a value indicating whether to handle the enter and esc keys.
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator | (Inherited from InputBase.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value. (Inherited from InputBase.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value. (Inherited from InputBase.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | (Inherited from InputBase.)
Public property | Minimum | Gets or sets editor's Minimum value. (Inherited from InputBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | (Inherited from vFixedPointEditor.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type. (Inherited from InputBase.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from InputBase.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from InputBase.)
Public property | Value | Gets or sets editor's value. (Inherited from InputBase.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


ActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..ActivationFlags Property
FixedPointEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags ActivationFlags { get; set; }
Visual Basic
Public Property ActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags ActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..ActivationFlags

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


Control Property

[image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..Control Property
FixedPointEditor Class See Also Send Feedback
Gets a reference to the underlying control of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control Control { get; }
Visual Basic
Public ReadOnly Property Control As Control
    Get
Visual C++
public:
virtual property Control^ Control {
    Control^ get () sealed;
}

Implements

IEditor..::..Control

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


DeActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..DeActivationFlags Property
FixedPointEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags DeActivationFlags { get; set; }
Visual Basic
Public Property DeActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags DeActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..DeActivationFlags

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


EditCell Property

[image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..EditCell Property
FixedPointEditor Class See Also Send Feedback
Gets the edit cell.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell EditCell { get; }
Visual Basic
Public ReadOnly Property EditCell As GridCell
    Get
Visual C++
public:
property GridCell^ EditCell {
    GridCell^ get ();
}

Field Value

The edit cell.

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorType Property

[image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..EditorType Property
FixedPointEditor Class See Also Send Feedback
Gets the type of the grid cell editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellEditorType EditorType { get; }
Visual Basic
Public ReadOnly Property EditorType As CellEditorType
    Get
Visual C++
public:
virtual property CellEditorType EditorType {
    CellEditorType get () sealed;
}

Implements

IEditor..::..EditorType

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorValue Property

[image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..EditorValue Property
FixedPointEditor Class See Also Send Feedback
Get's or sets the current value of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object EditorValue { get; set; }
Visual Basic
Public Property EditorValue As Object
    Get
    Set
Visual C++
public:
virtual property Object^ EditorValue {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Implements

IEditor..::..EditorValue

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


HandleEnterKey Property

[image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor..::..HandleEnterKey Property
FixedPointEditor Class See Also Send Feedback
Gets or sets a value indicating whether to handle the enter and esc keys.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool HandleEnterKey { get; set; }
Visual Basic
Public Property HandleEnterKey As Boolean
    Get
    Set
Visual C++
public:
property bool HandleEnterKey {
    bool get ();
    void set (bool value);
}

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


FixedPointEditor Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
FixedPointEditor Events
FixedPointEditor Class See Also Send Feedback

The FixedPointEditor type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed. (Inherited from InputBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event. (Inherited from InputBase.)
Public event | ValueChanged | Represents the ValueChanged event. (Inherited from InputBase.)
Public event | ValueChanging | Represents the ValueChanging event. (Inherited from InputBase.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

FixedPointEditor Class
VIBlend.WinForms.DataGridView Namespace


GridBindingState Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
GridBindingState Enumeration
See Also Send Feedback
Enumaration of the grid's binding states

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum GridBindingState
Visual Basic
Public Enumeration GridBindingState
Visual C++
public enum class GridBindingState

Members

Member name | Description
Unbound |
Bound |
BoundPivot |

See Also

VIBlend.WinForms.DataGridView Namespace


GridCell Class

[image]

VIBlend Controls for WinForms Help Documentation
GridCell Class
Members See Also Send Feedback
Defines an grid cell inside the CellsArea

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class GridCell
Visual Basic
Public Class GridCell
Visual C++
public ref class GridCell

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..GridCell

See Also

GridCell Members
VIBlend.WinForms.DataGridView Namespace


GridCell Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
GridCell Members
GridCell Class Constructors Methods Properties See Also Send Feedback

The GridCell type exposes the following members.

Constructors

 | Name | Description
Public method | GridCell | Initializes a new instance of the GridCell class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bounds | Cell's bounds
Public property | CellsArea | The CellsArea where cell is located
Public property | CellSpan | The CellSpan of the GridCell.
Public property | ColumnItem | The Column HierarchyItem corresponding to the grid cell
Public property | DisplaySettings | Gets or sets cell's display settings
Public property | DrawStyle | The custom draw style of the grid cell
Public property | Editor | The editor control associated with the cell.
Public property | EditValue | Gets the uncommited value of the grid cell before the editor closes.
Public property | FormattedText | Gets the cell's Value as a Formatted text
Public property | ImageAlignment | Gets or sets cell's image alignment
Public property | ImageIndex | Gets or sets cell's image index
Public property | ImagePosition | Gets or sets the position of cell's image
Public property | Locked | The locked state of the grid cell
Public property | RowItem | The Row HierarchyItem corresponding to the grid cell
Public property | Selected | The selection state of the grid cell
Public property | TextAlignment | Gets or sets the alignment of cell's text
Public property | TextImageRelation | Gets or sets the relation between the text and image applied to this cell
Public property | TextWrap | Gets or sets the wrap mode of cell's text
Public property | Value | Gets or sets the value of the text

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


GridCell Constructor

[image]

VIBlend Controls for WinForms Help Documentation
GridCell Constructor
GridCell Class See Also Send Feedback
Initializes a new instance of the GridCell class.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell(
    HierarchyItem rowItem,
    HierarchyItem columnItem,
    CellsArea cellsArea
)
Visual Basic
Public Sub New ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem, _
    cellsArea As CellsArea _
)
Visual C++
public:
GridCell(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem,
    CellsArea^ cellsArea
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The row item.
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The column item.
cellsArea
Type: VIBlend.WinForms.DataGridView..::..CellsArea
The cells area.

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


GridCell Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
GridCell Methods
GridCell Class See Also Send Feedback

The GridCell type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


GridCell Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
GridCell Properties
GridCell Class See Also Send Feedback

The GridCell type exposes the following members.

Properties

 | Name | Description
Public property | Bounds | Cell's bounds
Public property | CellsArea | The CellsArea where cell is located
Public property | CellSpan | The CellSpan of the GridCell.
Public property | ColumnItem | The Column HierarchyItem corresponding to the grid cell
Public property | DisplaySettings | Gets or sets cell's display settings
Public property | DrawStyle | The custom draw style of the grid cell
Public property | Editor | The editor control associated with the cell.
Public property | EditValue | Gets the uncommited value of the grid cell before the editor closes.
Public property | FormattedText | Gets the cell's Value as a Formatted text
Public property | ImageAlignment | Gets or sets cell's image alignment
Public property | ImageIndex | Gets or sets cell's image index
Public property | ImagePosition | Gets or sets the position of cell's image
Public property | Locked | The locked state of the grid cell
Public property | RowItem | The Row HierarchyItem corresponding to the grid cell
Public property | Selected | The selection state of the grid cell
Public property | TextAlignment | Gets or sets the alignment of cell's text
Public property | TextImageRelation | Gets or sets the relation between the text and image applied to this cell
Public property | TextWrap | Gets or sets the wrap mode of cell's text
Public property | Value | Gets or sets the value of the text

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


Bounds Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..Bounds Property
GridCell Class See Also Send Feedback
Cell's bounds

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle Bounds { get; }
Visual Basic
Public ReadOnly Property Bounds As Rectangle
    Get
Visual C++
public:
property Rectangle Bounds {
    Rectangle get ();
}

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


CellsArea Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..CellsArea Property
GridCell Class See Also Send Feedback
The CellsArea where cell is located

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellsArea CellsArea { get; set; }
Visual Basic
Public Property CellsArea As CellsArea
    Get
    Set
Visual C++
public:
property CellsArea^ CellsArea {
    CellsArea^ get ();
    void set (CellsArea^ value);
}

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


CellSpan Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..CellSpan Property
GridCell Class See Also Send Feedback
The CellSpan of the GridCell.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual CellSpan CellSpan { get; set; }
Visual Basic
Public Overridable Property CellSpan As CellSpan
    Get
    Set
Visual C++
public:
virtual property CellSpan CellSpan {
    CellSpan get ();
    void set (CellSpan value);
}

Remarks

The CellSpan for a grid cell which does not participate in a cell merge contains exactly one row and one column

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


ColumnItem Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..ColumnItem Property
GridCell Class See Also Send Feedback
The Column HierarchyItem corresponding to the grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem ColumnItem { get; internal set; }
Visual Basic
Public Property ColumnItem As HierarchyItem
    Get
    Friend Set
Visual C++
public:
property HierarchyItem^ ColumnItem {
    HierarchyItem^ get ();
    internal: void set (HierarchyItem^ value);
}

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


DisplaySettings Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..DisplaySettings Property
GridCell Class See Also Send Feedback
Gets or sets cell's display settings

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual DisplaySettings DisplaySettings { get; set; }
Visual Basic
Public Overridable Property DisplaySettings As DisplaySettings
    Get
    Set
Visual C++
public:
virtual property DisplaySettings DisplaySettings {
    DisplaySettings get ();
    void set (DisplaySettings value);
}

Remarks

The DisplaySettings of a cell determine whether the the grid should render the cell's text, image or both

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


DrawStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..DrawStyle Property
GridCell Class See Also Send Feedback
The custom draw style of the grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual GridCellStyle DrawStyle { get; set; }
Visual Basic
Public Overridable Property DrawStyle As GridCellStyle
    Get
    Set
Visual C++
public:
virtual property GridCellStyle^ DrawStyle {
    GridCellStyle^ get ();
    void set (GridCellStyle^ value);
}

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


Editor Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..Editor Property
GridCell Class See Also Send Feedback
The editor control associated with the cell.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual IEditor Editor { get; set; }
Visual Basic
Public Overridable Property Editor As IEditor
    Get
    Set
Visual C++
public:
virtual property IEditor^ Editor {
    IEditor^ get ();
    void set (IEditor^ value);
}

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


EditValue Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..EditValue Property
GridCell Class See Also Send Feedback
Gets the uncommited value of the grid cell before the editor closes.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object EditValue { get; internal set; }
Visual Basic
Public Property EditValue As Object
    Get
    Friend Set
Visual C++
public:
property Object^ EditValue {
    Object^ get ();
    internal: void set (Object^ value);
}

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


FormattedText Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..FormattedText Property
GridCell Class See Also Send Feedback
Gets the cell's Value as a Formatted text

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual string FormattedText { get; }
Visual Basic
Public Overridable ReadOnly Property FormattedText As String
    Get
Visual C++
public:
virtual property String^ FormattedText {
    String^ get ();
}

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace
[!:GridCellFormatting]


ImageAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..ImageAlignment Property
GridCell Class See Also Send Feedback
Gets or sets cell's image alignment

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ContentAlignment ImageAlignment { get; set; }
Visual Basic
Public Overridable Property ImageAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
virtual property ContentAlignment ImageAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


ImageIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..ImageIndex Property
GridCell Class See Also Send Feedback
Gets or sets cell's image index

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual int ImageIndex { get; set; }
Visual Basic
Public Overridable Property ImageIndex As Integer
    Get
    Set
Visual C++
public:
virtual property int ImageIndex {
    int get ();
    void set (int value);
}

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


ImagePosition Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..ImagePosition Property
GridCell Class See Also Send Feedback
Gets or sets the position of cell's image

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ImagePositions ImagePosition { get; set; }
Visual Basic
Public Overridable Property ImagePosition As ImagePositions
    Get
    Set
Visual C++
public:
virtual property ImagePositions ImagePosition {
    ImagePositions get ();
    void set (ImagePositions value);
}

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


Locked Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..Locked Property
GridCell Class See Also Send Feedback
The locked state of the grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool Locked { get; set; }
Visual Basic
Public Overridable Property Locked As Boolean
    Get
    Set
Visual C++
public:
virtual property bool Locked {
    bool get ();
    void set (bool value);
}

Remarks

Locked cells cannot be modified by the user via an editor

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


RowItem Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..RowItem Property
GridCell Class See Also Send Feedback
The Row HierarchyItem corresponding to the grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem RowItem { get; internal set; }
Visual Basic
Public Property RowItem As HierarchyItem
    Get
    Friend Set
Visual C++
public:
property HierarchyItem^ RowItem {
    HierarchyItem^ get ();
    internal: void set (HierarchyItem^ value);
}

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


Selected Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..Selected Property
GridCell Class See Also Send Feedback
The selection state of the grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool Selected { get; set; }
Visual Basic
Public Overridable Property Selected As Boolean
    Get
    Set
Visual C++
public:
virtual property bool Selected {
    bool get ();
    void set (bool value);
}

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


TextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..TextAlignment Property
GridCell Class See Also Send Feedback
Gets or sets the alignment of cell's text

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual ContentAlignment TextAlignment { get; set; }
Visual Basic
Public Overridable Property TextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
virtual property ContentAlignment TextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


TextImageRelation Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..TextImageRelation Property
GridCell Class See Also Send Feedback
Gets or sets the relation between the text and image applied to this cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual TextImageRelation TextImageRelation { get; set; }
Visual Basic
Public Overridable Property TextImageRelation As TextImageRelation
    Get
    Set
Visual C++
public:
virtual property TextImageRelation TextImageRelation {
    TextImageRelation get ();
    void set (TextImageRelation value);
}

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


TextWrap Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..TextWrap Property
GridCell Class See Also Send Feedback
Gets or sets the wrap mode of cell's text

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool TextWrap { get; set; }
Visual Basic
Public Overridable Property TextWrap As Boolean
    Get
    Set
Visual C++
public:
virtual property bool TextWrap {
    bool get ();
    void set (bool value);
}

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
GridCell..::..Value Property
GridCell Class See Also Send Feedback
Gets or sets the value of the text

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual Object Value { get; set; }
Visual Basic
Public Overridable Property Value As Object
    Get
    Set
Visual C++
public:
virtual property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

GridCell Class
VIBlend.WinForms.DataGridView Namespace
[!:GridCellFormatting]


GridCellCFColorScale Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
GridCellCFColorScale Enumeration
See Also Send Feedback
Default GridCell color scales

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum GridCellCFColorScale
Visual Basic
Public Enumeration GridCellCFColorScale
Visual C++
public enum class GridCellCFColorScale

Members

Member name | Description
RED_TO_GREEN |
GREEN_TO_RED |
RED_TO_BLUE |
BLUE_TO_RED |
ORANGE_TO_YELLOW |
YELLOW_TO_ORANGE |
YELLOW_TO_GREEN |
GREEN_TO_YELLOW |

See Also

VIBlend.WinForms.DataGridView Namespace


GridCellDataSource Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
GridCellDataSource Enumeration
See Also Send Feedback
Grid Cell data source enumeration

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum GridCellDataSource
Visual Basic
Public Enumeration GridCellDataSource
Visual C++
public enum class GridCellDataSource

Members

Member name | Description
NotSet |
Static |
Virtual |
DataBound |
DataBoundPivot |

See Also

VIBlend.WinForms.DataGridView Namespace


GridItemSortMode Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
GridItemSortMode Enumeration
See Also Send Feedback
Enumeration of the grid item sort modes

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum GridItemSortMode
Visual Basic
Public Enumeration GridItemSortMode
Visual C++
public enum class GridItemSortMode

Members

Member name | Description
Default |
Automatic |
NotSortable |

See Also

VIBlend.WinForms.DataGridView Namespace


GridLinesDisplayMode Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
GridLinesDisplayMode Enumeration
See Also Send Feedback
Enumeration of the grid lines display modes

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum GridLinesDisplayMode
Visual Basic
Public Enumeration GridLinesDisplayMode
Visual C++
public enum class GridLinesDisplayMode

Members

Member name | Description
DISPLAY_ALL |
DISPLAY_ROW_LINES |
DISPLAY_COLUMN_LINES |
DISPLAY_NONE |

See Also

VIBlend.WinForms.DataGridView Namespace


GridToolTipEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
GridToolTipEventArgs Class
Members See Also Send Feedback
Represents a GridView ToolTip event argument

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class GridToolTipEventArgs : EventArgs
Visual Basic
Public Class GridToolTipEventArgs _
    Inherits EventArgs
Visual C++
public ref class GridToolTipEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.DataGridView..::..GridToolTipEventArgs

See Also

GridToolTipEventArgs Members
VIBlend.WinForms.DataGridView Namespace


GridToolTipEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
GridToolTipEventArgs Members
GridToolTipEventArgs Class Constructors Methods Properties See Also Send Feedback

The GridToolTipEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GridToolTipEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColumnItem | HierarchyItem representing the column where the tooltip will be displayed.
Public property | Handled | Determines whether the event was handled
Public property | RowItem | HierarchyItem representing the row where the tooltip will be displayed.
Public property | ToolTipText | Gets or sets the tooltip text

See Also

GridToolTipEventArgs Class
VIBlend.WinForms.DataGridView Namespace


GridToolTipEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
GridToolTipEventArgs Constructor
GridToolTipEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridToolTipEventArgs(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Sub New ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
)
Visual C++
public:
GridToolTipEventArgs(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
HierarchyItem representing the row where the tooltip will be displayed.
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
HierarchyItem representing the column where the tooltip will be displayed.

See Also

GridToolTipEventArgs Class
VIBlend.WinForms.DataGridView Namespace


GridToolTipEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
GridToolTipEventArgs Methods
GridToolTipEventArgs Class See Also Send Feedback

The GridToolTipEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridToolTipEventArgs Class
VIBlend.WinForms.DataGridView Namespace


GridToolTipEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
GridToolTipEventArgs Properties
GridToolTipEventArgs Class See Also Send Feedback

The GridToolTipEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ColumnItem | HierarchyItem representing the column where the tooltip will be displayed.
Public property | Handled | Determines whether the event was handled
Public property | RowItem | HierarchyItem representing the row where the tooltip will be displayed.
Public property | ToolTipText | Gets or sets the tooltip text

See Also

GridToolTipEventArgs Class
VIBlend.WinForms.DataGridView Namespace


ColumnItem Property

[image]

VIBlend Controls for WinForms Help Documentation
GridToolTipEventArgs..::..ColumnItem Property
GridToolTipEventArgs Class See Also Send Feedback
HierarchyItem representing the column where the tooltip will be displayed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem ColumnItem { get; }
Visual Basic
Public ReadOnly Property ColumnItem As HierarchyItem
    Get
Visual C++
public:
property HierarchyItem^ ColumnItem {
    HierarchyItem^ get ();
}

See Also

GridToolTipEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Handled Property

[image]

VIBlend Controls for WinForms Help Documentation
GridToolTipEventArgs..::..Handled Property
GridToolTipEventArgs Class See Also Send Feedback
Determines whether the event was handled

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Handled { get; set; }
Visual Basic
Public Property Handled As Boolean
    Get
    Set
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

See Also

GridToolTipEventArgs Class
VIBlend.WinForms.DataGridView Namespace


RowItem Property

[image]

VIBlend Controls for WinForms Help Documentation
GridToolTipEventArgs..::..RowItem Property
GridToolTipEventArgs Class See Also Send Feedback
HierarchyItem representing the row where the tooltip will be displayed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem RowItem { get; }
Visual Basic
Public ReadOnly Property RowItem As HierarchyItem
    Get
Visual C++
public:
property HierarchyItem^ RowItem {
    HierarchyItem^ get ();
}

See Also

GridToolTipEventArgs Class
VIBlend.WinForms.DataGridView Namespace


ToolTipText Property

[image]

VIBlend Controls for WinForms Help Documentation
GridToolTipEventArgs..::..ToolTipText Property
GridToolTipEventArgs Class See Also Send Feedback
Gets or sets the tooltip text

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string ToolTipText { get; set; }
Visual Basic
Public Property ToolTipText As String
    Get
    Set
Visual C++
public:
property String^ ToolTipText {
    String^ get ();
    void set (String^ value);
}

See Also

GridToolTipEventArgs Class
VIBlend.WinForms.DataGridView Namespace


GroupHeaderDragCancelEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
GroupHeaderDragCancelEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class GroupHeaderDragCancelEventArgs : CancelEventArgs
Visual Basic
Public Class GroupHeaderDragCancelEventArgs _
    Inherits CancelEventArgs
Visual C++
public ref class GroupHeaderDragCancelEventArgs : public CancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
VIBlend.WinForms.DataGridView..::..GroupHeaderDragCancelEventArgs

See Also

GroupHeaderDragCancelEventArgs Members
VIBlend.WinForms.DataGridView Namespace


GroupHeaderDragCancelEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
GroupHeaderDragCancelEventArgs Members
GroupHeaderDragCancelEventArgs Class Constructors Methods Properties See Also Send Feedback

The GroupHeaderDragCancelEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GroupHeaderDragCancelEventArgs | Initializes a new instance of the GroupHeaderDragEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | HeaderItem | Gets the header item.

See Also

GroupHeaderDragCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


GroupHeaderDragCancelEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
GroupHeaderDragCancelEventArgs Constructor
GroupHeaderDragCancelEventArgs Class See Also Send Feedback
Initializes a new instance of the GroupHeaderDragEventArgs class.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GroupHeaderDragCancelEventArgs(
    DataGridGroupHeaderItem headerItem
)
Visual Basic
Public Sub New ( _
    headerItem As DataGridGroupHeaderItem _
)
Visual C++
public:
GroupHeaderDragCancelEventArgs(
    DataGridGroupHeaderItem^ headerItem
)

Parameters

headerItem
Type: VIBlend.WinForms.DataGridView..::..DataGridGroupHeaderItem
The header item.

See Also

GroupHeaderDragCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


GroupHeaderDragCancelEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
GroupHeaderDragCancelEventArgs Methods
GroupHeaderDragCancelEventArgs Class See Also Send Feedback

The GroupHeaderDragCancelEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupHeaderDragCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


GroupHeaderDragCancelEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
GroupHeaderDragCancelEventArgs Properties
GroupHeaderDragCancelEventArgs Class See Also Send Feedback

The GroupHeaderDragCancelEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | HeaderItem | Gets the header item.

See Also

GroupHeaderDragCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HeaderItem Property

[image]

VIBlend Controls for WinForms Help Documentation
GroupHeaderDragCancelEventArgs..::..HeaderItem Property
GroupHeaderDragCancelEventArgs Class See Also Send Feedback
Gets the header item.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DataGridGroupHeaderItem HeaderItem { get; }
Visual Basic
Public ReadOnly Property HeaderItem As DataGridGroupHeaderItem
    Get
Visual C++
public:
property DataGridGroupHeaderItem^ HeaderItem {
    DataGridGroupHeaderItem^ get ();
}

Field Value

The header item.

See Also

GroupHeaderDragCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


GroupHeaderDragEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
GroupHeaderDragEventArgs Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class GroupHeaderDragEventArgs : EventArgs
Visual Basic
Public Class GroupHeaderDragEventArgs _
    Inherits EventArgs
Visual C++
public ref class GroupHeaderDragEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.DataGridView..::..GroupHeaderDragEventArgs

See Also

GroupHeaderDragEventArgs Members
VIBlend.WinForms.DataGridView Namespace


GroupHeaderDragEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
GroupHeaderDragEventArgs Members
GroupHeaderDragEventArgs Class Constructors Methods Properties See Also Send Feedback

The GroupHeaderDragEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GroupHeaderDragEventArgs | Initializes a new instance of the GroupHeaderDragEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HeaderItem | Gets the header item.

See Also

GroupHeaderDragEventArgs Class
VIBlend.WinForms.DataGridView Namespace


GroupHeaderDragEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
GroupHeaderDragEventArgs Constructor
GroupHeaderDragEventArgs Class See Also Send Feedback
Initializes a new instance of the GroupHeaderDragEventArgs class.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GroupHeaderDragEventArgs(
    DataGridGroupHeaderItem headerItem
)
Visual Basic
Public Sub New ( _
    headerItem As DataGridGroupHeaderItem _
)
Visual C++
public:
GroupHeaderDragEventArgs(
    DataGridGroupHeaderItem^ headerItem
)

Parameters

headerItem
Type: VIBlend.WinForms.DataGridView..::..DataGridGroupHeaderItem
The header item.

See Also

GroupHeaderDragEventArgs Class
VIBlend.WinForms.DataGridView Namespace


GroupHeaderDragEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
GroupHeaderDragEventArgs Methods
GroupHeaderDragEventArgs Class See Also Send Feedback

The GroupHeaderDragEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupHeaderDragEventArgs Class
VIBlend.WinForms.DataGridView Namespace


GroupHeaderDragEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
GroupHeaderDragEventArgs Properties
GroupHeaderDragEventArgs Class See Also Send Feedback

The GroupHeaderDragEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | HeaderItem | Gets the header item.

See Also

GroupHeaderDragEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HeaderItem Property

[image]

VIBlend Controls for WinForms Help Documentation
GroupHeaderDragEventArgs..::..HeaderItem Property
GroupHeaderDragEventArgs Class See Also Send Feedback
Gets the header item.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DataGridGroupHeaderItem HeaderItem { get; }
Visual Basic
Public ReadOnly Property HeaderItem As DataGridGroupHeaderItem
    Get
Visual C++
public:
property DataGridGroupHeaderItem^ HeaderItem {
    DataGridGroupHeaderItem^ get ();
}

Field Value

The header item.

See Also

GroupHeaderDragEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HeaderGroupsAlignment Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
HeaderGroupsAlignment Enumeration
See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum HeaderGroupsAlignment
Visual Basic
Public Enumeration HeaderGroupsAlignment
Visual C++
public enum class HeaderGroupsAlignment

Members

Member name | Description
Near |
Center |
Far |

See Also

VIBlend.WinForms.DataGridView Namespace


Hierarchy Class

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy Class
Members See Also Send Feedback
Represents a base class for a Hierarchy which hosts one or more row, or column items
Represents a base class for a Hierarchy which hosts one or more row, or column items

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public abstract class Hierarchy
Visual Basic
Public MustInherit Class Hierarchy
Visual C++
public ref class Hierarchy abstract

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..Hierarchy
VIBlend.WinForms.DataGridView..::..ColumnsHierarchy
VIBlend.WinForms.DataGridView..::..RowsHierarchy

See Also

Hierarchy Members
VIBlend.WinForms.DataGridView Namespace


Hierarchy Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
Hierarchy Members
Hierarchy Class Constructors Methods Properties Events See Also Send Feedback

The Hierarchy type exposes the following members.

Constructors

 | Name | Description
Public method | Hierarchy | Constructor

Methods

 | Name | Description
Protected method | ApplyFilters |
Public method | AutoResize()()()() | Automatically resizes the items in the Hierarchy for best visual appearance
Public method | AutoResize(AutoResizeMode) | Automatically resizes the items in the Hierarchy for best visual appearance
Public method | Clear | Removes all HierarchyItems and their settings.
Public method | ClearSelection | Unselects all selected items.
Public method | CollapseAllItems | Collapses all items in the Hierarchy
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandAllItems | Expands all items in the Hierarchy
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildItemsRecursive | Retrieves all child HierarchyItems at all levels
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemByUniqueID | Gets a HierarchyItem by its unique ID
Public method | GetNextItem | Returns the item displayed immediatelly after a specified item
Public method | GetPreviousItem | Returns the item displayed immediatelly before a specified item
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HitTest | Performs a HitTest at a specific point within the Hierarchy
Public method | IsItemSelected | Checks if an item is selected
Public method | IsSummaryItem | Checks if a specific item is a Summary Item
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnFilterChanged |
Protected method | OnSortingChanged |
Public method | RemoveSort | Removes the sorting order previously applied through the SortBy method
Public method | SelectItem | Selects an item in the Hierarchy
Public method | SetColumnWidth | Sets the width of a column within the hierarchy
Public method | SetRowHeight | Sets the height of the row.
Public method | ShowHiddenItems | Sets the status of all hidden items to visible.
Public method | SortBy(HierarchyItem, SortingDirection) | Sorts the Hierarchy by a specefic HierarchyItem
Public method | SortBy(HierarchyItem, SortingDirection, IComparer<(Of <<'(HierarchyItem>)>>)) | Sorts the Items in the Hierarchy.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnSelectItem | UnSelects an item in the Hierarchy

Properties

 | Name | Description
Public property | AllowDragDrop | Gets or sets whether drag and drop is enabled for this Hierarchy
Public property | AllowResize | Gets or sets whether the HierarchyItems resizing is allowed
Public property | ColumnWidths | Gets the columns' widths for the hierarchy
Public property | Filters |
Public property | Fixed | Determines if the Hierarchy is fixed or not. Fixed Hierarchies are not affected by the scrolling of the data grid's content
Public property | GridControl | Retruns a reference to the Grid control hosting the hierarchy
Public property | HiddenItems | Gets the hidden items
Public property | HierarchyDepth | Gets the depth of the hierarchy.
Public property | IsFiltered | Checks if the Hierarchy contains HierarchyItems which are filtered.
Public property | IsSorted | Checks if the Hierarchy is Sorted
Public property | Items | Gets the items of the Hierarchy
Public property | SelectedItems | Gets the selected items
Public property | ShowExpandCollapseButtons | Determines whether to show the expand/collapse buttons on the items hosted by the hierarchy
Public property | SortingDirection | Gets the sort order direction if the Hierarchy is sorted.
Public property | SortItem | Gets the Item the Hierarchy is sorted by.
Public property | SummaryItems | Gets the summary items of the Hierarchy
Public property | TotalItemsCount | Gets the total number of HierarchyItems hosted by the Hierarchy. This includes both Hierarchy items and Summary items. Hidden items are also counted.
Public property | Visible | Determines whether the hierarchy is visible
Public property | X | Returns the horizontal position of Hierarchy relative to the top-left corner of the grid control
Public property | Y | Returns the horizontal position of Hierarchy relative to the top-left corner of the grid control

Events

 | Name | Description
Public event | FiltersChanged | Occurs when the Hierarchy filters have changed.
Public event | SortingChanged | Occurs when the Hierarchy sorting have changed.

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


Hierarchy Constructor

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy Constructor
Hierarchy Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Hierarchy()
Visual Basic
Public Sub New
Visual C++
public:
Hierarchy()

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


Hierarchy Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
Hierarchy Methods
Hierarchy Class See Also Send Feedback

The Hierarchy type exposes the following members.

Methods

 | Name | Description
Protected method | ApplyFilters |
Public method | AutoResize()()()() | Automatically resizes the items in the Hierarchy for best visual appearance
Public method | AutoResize(AutoResizeMode) | Automatically resizes the items in the Hierarchy for best visual appearance
Public method | Clear | Removes all HierarchyItems and their settings.
Public method | ClearSelection | Unselects all selected items.
Public method | CollapseAllItems | Collapses all items in the Hierarchy
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandAllItems | Expands all items in the Hierarchy
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildItemsRecursive | Retrieves all child HierarchyItems at all levels
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemByUniqueID | Gets a HierarchyItem by its unique ID
Public method | GetNextItem | Returns the item displayed immediatelly after a specified item
Public method | GetPreviousItem | Returns the item displayed immediatelly before a specified item
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HitTest | Performs a HitTest at a specific point within the Hierarchy
Public method | IsItemSelected | Checks if an item is selected
Public method | IsSummaryItem | Checks if a specific item is a Summary Item
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnFilterChanged |
Protected method | OnSortingChanged |
Public method | RemoveSort | Removes the sorting order previously applied through the SortBy method
Public method | SelectItem | Selects an item in the Hierarchy
Public method | SetColumnWidth | Sets the width of a column within the hierarchy
Public method | SetRowHeight | Sets the height of the row.
Public method | ShowHiddenItems | Sets the status of all hidden items to visible.
Public method | SortBy(HierarchyItem, SortingDirection) | Sorts the Hierarchy by a specefic HierarchyItem
Public method | SortBy(HierarchyItem, SortingDirection, IComparer<(Of <<'(HierarchyItem>)>>)) | Sorts the Items in the Hierarchy.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnSelectItem | UnSelects an item in the Hierarchy

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


ApplyFilters Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..ApplyFilters Method
Hierarchy Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected void ApplyFilters()
Visual Basic
Protected Sub ApplyFilters
Visual C++
protected:
void ApplyFilters()

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


AutoResize Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..AutoResize Method
Hierarchy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AutoResize()()()() | Automatically resizes the items in the Hierarchy for best visual appearance
Public method | AutoResize(AutoResizeMode) | Automatically resizes the items in the Hierarchy for best visual appearance

See Also

Hierarchy Class
Hierarchy Members
VIBlend.WinForms.DataGridView Namespace


AutoResize Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..AutoResize Method
Hierarchy Class See Also Send Feedback
Automatically resizes the items in the Hierarchy for best visual appearance

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public abstract void AutoResize()
Visual Basic
Public MustOverride Sub AutoResize
Visual C++
public:
virtual void AutoResize() abstract

See Also

Hierarchy Class
AutoResize Overload
VIBlend.WinForms.DataGridView Namespace


AutoResize Method (AutoResizeMode)

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..AutoResize Method (AutoResizeMode)
Hierarchy Class See Also Send Feedback
Automatically resizes the items in the Hierarchy for best visual appearance

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public abstract void AutoResize(
    AutoResizeMode autoResizeMode
)
Visual Basic
Public MustOverride Sub AutoResize ( _
    autoResizeMode As AutoResizeMode _
)
Visual C++
public:
virtual void AutoResize(
    AutoResizeMode autoResizeMode
) abstract

Parameters

autoResizeMode
Type: VIBlend.WinForms.DataGridView..::..AutoResizeMode

See Also

Hierarchy Class
AutoResize Overload
VIBlend.WinForms.DataGridView Namespace


Clear Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..Clear Method
Hierarchy Class See Also Send Feedback
Removes all HierarchyItems and their settings.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


ClearSelection Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..ClearSelection Method
Hierarchy Class See Also Send Feedback
Unselects all selected items.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ClearSelection()
Visual Basic
Public Sub ClearSelection
Visual C++
public:
void ClearSelection()

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


CollapseAllItems Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..CollapseAllItems Method
Hierarchy Class See Also Send Feedback
Collapses all items in the Hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void CollapseAllItems()
Visual Basic
Public Sub CollapseAllItems
Visual C++
public:
void CollapseAllItems()

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


ExpandAllItems Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..ExpandAllItems Method
Hierarchy Class See Also Send Feedback
Expands all items in the Hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ExpandAllItems()
Visual Basic
Public Sub ExpandAllItems
Visual C++
public:
void ExpandAllItems()

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


GetChildItemsRecursive Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..GetChildItemsRecursive Method
Hierarchy Class See Also Send Feedback
Retrieves all child HierarchyItems at all levels

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<HierarchyItem> GetChildItemsRecursive()
Visual Basic
Public Function GetChildItemsRecursive As List(Of HierarchyItem)
Visual C++
public:
List<HierarchyItem^>^ GetChildItemsRecursive()

Return Value

List of HierarchyItems

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


GetItemByUniqueID Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..GetItemByUniqueID Method
Hierarchy Class See Also Send Feedback
Gets a HierarchyItem by its unique ID

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem GetItemByUniqueID(
    string id
)
Visual Basic
Public Function GetItemByUniqueID ( _
    id As String _
) As HierarchyItem
Visual C++
public:
HierarchyItem^ GetItemByUniqueID(
    String^ id
)

Parameters

id
Type: System..::..String
String which uniquely identifies the item within the hierarchy

Return Value

The method returns the hierarchy item with the respective unique Id. If no such item exists the method returns NULL.

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


GetNextItem Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..GetNextItem Method
Hierarchy Class See Also Send Feedback
Returns the item displayed immediatelly after a specified item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem GetNextItem(
    HierarchyItem item
)
Visual Basic
Public Function GetNextItem ( _
    item As HierarchyItem _
) As HierarchyItem
Visual C++
public:
HierarchyItem^ GetNextItem(
    HierarchyItem^ item
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
HierarchyItem to retrive the next item for.

Return Value

The item after the specified item, or null if a next item does not exist.

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


GetPreviousItem Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..GetPreviousItem Method
Hierarchy Class See Also Send Feedback
Returns the item displayed immediatelly before a specified item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem GetPreviousItem(
    HierarchyItem item
)
Visual Basic
Public Function GetPreviousItem ( _
    item As HierarchyItem _
) As HierarchyItem
Visual C++
public:
HierarchyItem^ GetPreviousItem(
    HierarchyItem^ item
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
HierarchyItem to retrive the previous item for.

Return Value

The item displayed before the specified item, or null if a previous item does not exist.

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


HitTest Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..HitTest Method
Hierarchy Class See Also Send Feedback
Performs a HitTest at a specific point within the Hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem HitTest(
    Point point
)
Visual Basic
Public Function HitTest ( _
    point As Point _
) As HierarchyItem
Visual C++
public:
HierarchyItem^ HitTest(
    Point point
)

Parameters

point
Type: System.Drawing..::..Point
Point representing the X, Y coordinate to test. The point must be relative to the top-left corner of the grid control

Return Value

The method returns the HierarchyItem located at the position pointed by the point parameter. If there is no HierarchyItem at this position the method returns NULL.

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


IsItemSelected Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..IsItemSelected Method
Hierarchy Class See Also Send Feedback
Checks if an item is selected

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsItemSelected(
    HierarchyItem item
)
Visual Basic
Public Function IsItemSelected ( _
    item As HierarchyItem _
) As Boolean
Visual C++
public:
bool IsItemSelected(
    HierarchyItem^ item
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Item to check

Return Value

The method returns true if the respective item is selected. If the item is not selected, or cannot be found within the hierarchy, the method returns false.

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


IsSummaryItem Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..IsSummaryItem Method
Hierarchy Class See Also Send Feedback
Checks if a specific item is a Summary Item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsSummaryItem(
    HierarchyItem item
)
Visual Basic
Public Function IsSummaryItem ( _
    item As HierarchyItem _
) As Boolean
Visual C++
public:
bool IsSummaryItem(
    HierarchyItem^ item
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The item to check

Return Value

The method returns true if the item is a summary item

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


OnFilterChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..OnFilterChanged Method
Hierarchy Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnFilterChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnFilterChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnFilterChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::..EventArgs

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


OnSortingChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..OnSortingChanged Method
Hierarchy Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnSortingChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnSortingChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSortingChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::..EventArgs

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


RemoveSort Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..RemoveSort Method
Hierarchy Class See Also Send Feedback
Removes the sorting order previously applied through the SortBy method

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void RemoveSort()
Visual Basic
Public Sub RemoveSort
Visual C++
public:
void RemoveSort()

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


SelectItem Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..SelectItem Method
Hierarchy Class See Also Send Feedback
Selects an item in the Hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SelectItem(
    HierarchyItem item
)
Visual Basic
Public Sub SelectItem ( _
    item As HierarchyItem _
)
Visual C++
public:
void SelectItem(
    HierarchyItem^ item
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Item to select

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


SetColumnWidth Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..SetColumnWidth Method
Hierarchy Class See Also Send Feedback
Sets the width of a column within the hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool SetColumnWidth(
    int columnIndex,
    int width
)
Visual Basic
Public Overridable Function SetColumnWidth ( _
    columnIndex As Integer, _
    width As Integer _
) As Boolean
Visual C++
public:
virtual bool SetColumnWidth(
    int columnIndex,
    int width
)

Parameters

columnIndex
Type: System..::..Int32
The zero-based index of the column
width
Type: System..::..Int32
The new width of the column

Return Value

The method returns if the new width is applied

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


SetRowHeight Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..SetRowHeight Method
Hierarchy Class See Also Send Feedback
Sets the height of the row.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool SetRowHeight(
    HierarchyItem hierarchyItem,
    int hieght
)
Visual Basic
Public Function SetRowHeight ( _
    hierarchyItem As HierarchyItem, _
    hieght As Integer _
) As Boolean
Visual C++
public:
bool SetRowHeight(
    HierarchyItem^ hierarchyItem,
    int hieght
)

Parameters

hierarchyItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The hierarchy item.
hieght
Type: System..::..Int32
The hieght.

Return Value

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


ShowHiddenItems Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..ShowHiddenItems Method
Hierarchy Class See Also Send Feedback
Sets the status of all hidden items to visible.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ShowHiddenItems()
Visual Basic
Public Sub ShowHiddenItems
Visual C++
public:
void ShowHiddenItems()

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


SortBy Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..SortBy Method
Hierarchy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SortBy(HierarchyItem, SortingDirection) | Sorts the Hierarchy by a specefic HierarchyItem
Public method | SortBy(HierarchyItem, SortingDirection, IComparer<(Of <<'(HierarchyItem>)>>)) | Sorts the Items in the Hierarchy.

See Also

Hierarchy Class
Hierarchy Members
VIBlend.WinForms.DataGridView Namespace


SortBy Method (HierarchyItem, SortingDirection)

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..SortBy Method (HierarchyItem, SortingDirection)
Hierarchy Class See Also Send Feedback
Sorts the Hierarchy by a specefic HierarchyItem

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SortBy(
    HierarchyItem item,
    SortingDirection sortingDirection
)
Visual Basic
Public Sub SortBy ( _
    item As HierarchyItem, _
    sortingDirection As SortingDirection _
)
Visual C++
public:
void SortBy(
    HierarchyItem^ item,
    SortingDirection sortingDirection
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
HierarchyItem to Sort by. This must be a HierarchyItem from the other Hierarchy. For example, the ColumnsHierarchy can be sorted by HierarchyItems from the RowsHierarchy.
sortingDirection
Type: VIBlend.WinForms.DataGridView..::..SortingDirection
Sorting direction.

See Also

Hierarchy Class
SortBy Overload
VIBlend.WinForms.DataGridView Namespace


SortBy Method (HierarchyItem, SortingDirection, IComparer(HierarchyItem))

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..SortBy Method (HierarchyItem, SortingDirection, IComparer<(Of <(<'HierarchyItem>)>)>)
Hierarchy Class See Also Send Feedback
Sorts the Items in the Hierarchy.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SortBy(
    HierarchyItem item,
    SortingDirection sortingDirection,
    IComparer<HierarchyItem> comparer
)
Visual Basic
Public Sub SortBy ( _
    item As HierarchyItem, _
    sortingDirection As SortingDirection, _
    comparer As IComparer(Of HierarchyItem) _
)
Visual C++
public:
void SortBy(
    HierarchyItem^ item,
    SortingDirection sortingDirection,
    IComparer<HierarchyItem^>^ comparer
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
HierarchyItem to Sort by. This must be a HierarchyItem from the other Hierarchy. For example, the ColumnsHierarchy can be sorted by HierarchyItems from the RowsHierarchy.
sortingDirection
Type: VIBlend.WinForms.DataGridView..::..SortingDirection
Sorting direction.
comparer
Type: System.Collections.Generic..::..IComparer <(Of <(<' HierarchyItem >)>)>
HierarchyItem comparer.

See Also

Hierarchy Class
SortBy Overload
VIBlend.WinForms.DataGridView Namespace


UnSelectItem Method

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..UnSelectItem Method
Hierarchy Class See Also Send Feedback
UnSelects an item in the Hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void UnSelectItem(
    HierarchyItem item
)
Visual Basic
Public Sub UnSelectItem ( _
    item As HierarchyItem _
)
Visual C++
public:
void UnSelectItem(
    HierarchyItem^ item
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Item to UnSelect

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


Hierarchy Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
Hierarchy Properties
Hierarchy Class See Also Send Feedback

The Hierarchy type exposes the following members.

Properties

 | Name | Description
Public property | AllowDragDrop | Gets or sets whether drag and drop is enabled for this Hierarchy
Public property | AllowResize | Gets or sets whether the HierarchyItems resizing is allowed
Public property | ColumnWidths | Gets the columns' widths for the hierarchy
Public property | Filters |
Public property | Fixed | Determines if the Hierarchy is fixed or not. Fixed Hierarchies are not affected by the scrolling of the data grid's content
Public property | GridControl | Retruns a reference to the Grid control hosting the hierarchy
Public property | HiddenItems | Gets the hidden items
Public property | HierarchyDepth | Gets the depth of the hierarchy.
Public property | IsFiltered | Checks if the Hierarchy contains HierarchyItems which are filtered.
Public property | IsSorted | Checks if the Hierarchy is Sorted
Public property | Items | Gets the items of the Hierarchy
Public property | SelectedItems | Gets the selected items
Public property | ShowExpandCollapseButtons | Determines whether to show the expand/collapse buttons on the items hosted by the hierarchy
Public property | SortingDirection | Gets the sort order direction if the Hierarchy is sorted.
Public property | SortItem | Gets the Item the Hierarchy is sorted by.
Public property | SummaryItems | Gets the summary items of the Hierarchy
Public property | TotalItemsCount | Gets the total number of HierarchyItems hosted by the Hierarchy. This includes both Hierarchy items and Summary items. Hidden items are also counted.
Public property | Visible | Determines whether the hierarchy is visible
Public property | X | Returns the horizontal position of Hierarchy relative to the top-left corner of the grid control
Public property | Y | Returns the horizontal position of Hierarchy relative to the top-left corner of the grid control

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


AllowDragDrop Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..AllowDragDrop Property
Hierarchy Class See Also Send Feedback
Gets or sets whether drag and drop is enabled for this Hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowDragDrop { get; set; }
Visual Basic
Public Property AllowDragDrop As Boolean
    Get
    Set
Visual C++
public:
property bool AllowDragDrop {
    bool get ();
    void set (bool value);
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


AllowResize Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..AllowResize Property
Hierarchy Class See Also Send Feedback
Gets or sets whether the HierarchyItems resizing is allowed

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool AllowResize { get; set; }
Visual Basic
Public Overridable Property AllowResize As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowResize {
    bool get ();
    void set (bool value);
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


ColumnWidths Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..ColumnWidths Property
Hierarchy Class See Also Send Feedback
Gets the columns' widths for the hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public nsCollection<int> ColumnWidths { get; }
Visual Basic
Public ReadOnly Property ColumnWidths As nsCollection(Of Integer)
    Get
Visual C++
public:
property nsCollection<int>^ ColumnWidths {
    nsCollection<int>^ get ();
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


Filters Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..Filters Property
Hierarchy Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public nsCollection<HierarchyItemFilter> Filters { get; }
Visual Basic
Public ReadOnly Property Filters As nsCollection(Of HierarchyItemFilter)
    Get
Visual C++
public:
property nsCollection<HierarchyItemFilter>^ Filters {
    nsCollection<HierarchyItemFilter>^ get ();
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


Fixed Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..Fixed Property
Hierarchy Class See Also Send Feedback
Determines if the Hierarchy is fixed or not. Fixed Hierarchies are not affected by the scrolling of the data grid's content

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Fixed { get; set; }
Visual Basic
Public Property Fixed As Boolean
    Get
    Set
Visual C++
public:
property bool Fixed {
    bool get ();
    void set (bool value);
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


GridControl Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..GridControl Property
Hierarchy Class See Also Send Feedback
Retruns a reference to the Grid control hosting the hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDataGridView GridControl { get; }
Visual Basic
Public ReadOnly Property GridControl As vDataGridView
    Get
Visual C++
public:
property vDataGridView^ GridControl {
    vDataGridView^ get ();
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


HiddenItems Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..HiddenItems Property
Hierarchy Class See Also Send Feedback
Gets the hidden items

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem[] HiddenItems { get; }
Visual Basic
Public ReadOnly Property HiddenItems As HierarchyItem()
    Get
Visual C++
public:
property array<HierarchyItem^>^ HiddenItems {
    array<HierarchyItem^>^ get ();
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


HierarchyDepth Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..HierarchyDepth Property
Hierarchy Class See Also Send Feedback
Gets the depth of the hierarchy.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int HierarchyDepth { get; }
Visual Basic
Public ReadOnly Property HierarchyDepth As Integer
    Get
Visual C++
public:
property int HierarchyDepth {
    int get ();
}

Remarks

Use this method do termine how many levels of nesting exist in the hierarchy. For example if you have only a item with one or child items the depth is 2. If these child items have their own child items, the depth increases.

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


IsFiltered Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..IsFiltered Property
Hierarchy Class See Also Send Feedback
Checks if the Hierarchy contains HierarchyItems which are filtered.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsFiltered { get; }
Visual Basic
Public ReadOnly Property IsFiltered As Boolean
    Get
Visual C++
public:
property bool IsFiltered {
    bool get ();
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


IsSorted Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..IsSorted Property
Hierarchy Class See Also Send Feedback
Checks if the Hierarchy is Sorted

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsSorted { get; }
Visual Basic
Public ReadOnly Property IsSorted As Boolean
    Get
Visual C++
public:
property bool IsSorted {
    bool get ();
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


Items Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..Items Property
Hierarchy Class See Also Send Feedback
Gets the items of the Hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemsCollection Items { get; }
Visual Basic
Public ReadOnly Property Items As HierarchyItemsCollection
    Get
Visual C++
public:
property HierarchyItemsCollection^ Items {
    HierarchyItemsCollection^ get ();
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


SelectedItems Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..SelectedItems Property
Hierarchy Class See Also Send Feedback
Gets the selected items

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem[] SelectedItems { get; }
Visual Basic
Public ReadOnly Property SelectedItems As HierarchyItem()
    Get
Visual C++
public:
property array<HierarchyItem^>^ SelectedItems {
    array<HierarchyItem^>^ get ();
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


ShowExpandCollapseButtons Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..ShowExpandCollapseButtons Property
Hierarchy Class See Also Send Feedback
Determines whether to show the expand/collapse buttons on the items hosted by the hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowExpandCollapseButtons { get; set; }
Visual Basic
Public Property ShowExpandCollapseButtons As Boolean
    Get
    Set
Visual C++
public:
property bool ShowExpandCollapseButtons {
    bool get ();
    void set (bool value);
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


SortingDirection Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..SortingDirection Property
Hierarchy Class See Also Send Feedback
Gets the sort order direction if the Hierarchy is sorted.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public SortingDirection SortingDirection { get; internal set; }
Visual Basic
Public Property SortingDirection As SortingDirection
    Get
    Friend Set
Visual C++
public:
property SortingDirection SortingDirection {
    SortingDirection get ();
    internal: void set (SortingDirection value);
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


SortItem Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..SortItem Property
Hierarchy Class See Also Send Feedback
Gets the Item the Hierarchy is sorted by.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem SortItem { get; internal set; }
Visual Basic
Public Property SortItem As HierarchyItem
    Get
    Friend Set
Visual C++
public:
property HierarchyItem^ SortItem {
    HierarchyItem^ get ();
    internal: void set (HierarchyItem^ value);
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


SummaryItems Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..SummaryItems Property
Hierarchy Class See Also Send Feedback
Gets the summary items of the Hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemsCollection SummaryItems { get; }
Visual Basic
Public ReadOnly Property SummaryItems As HierarchyItemsCollection
    Get
Visual C++
public:
property HierarchyItemsCollection^ SummaryItems {
    HierarchyItemsCollection^ get ();
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


TotalItemsCount Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..TotalItemsCount Property
Hierarchy Class See Also Send Feedback
Gets the total number of HierarchyItems hosted by the Hierarchy. This includes both Hierarchy items and Summary items. Hidden items are also counted.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int TotalItemsCount { get; }
Visual Basic
Public ReadOnly Property TotalItemsCount As Integer
    Get
Visual C++
public:
property int TotalItemsCount {
    int get ();
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


Visible Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..Visible Property
Hierarchy Class See Also Send Feedback
Determines whether the hierarchy is visible

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Visible { get; set; }
Visual Basic
Public Property Visible As Boolean
    Get
    Set
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


X Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..X Property
Hierarchy Class See Also Send Feedback
Returns the horizontal position of Hierarchy relative to the top-left corner of the grid control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int X { get; internal set; }
Visual Basic
Public Property X As Integer
    Get
    Friend Set
Visual C++
public:
property int X {
    int get ();
    internal: void set (int value);
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


Y Property

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..Y Property
Hierarchy Class See Also Send Feedback
Returns the horizontal position of Hierarchy relative to the top-left corner of the grid control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Y { get; internal set; }
Visual Basic
Public Property Y As Integer
    Get
    Friend Set
Visual C++
public:
property int Y {
    int get ();
    internal: void set (int value);
}

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


Hierarchy Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
Hierarchy Events
Hierarchy Class See Also Send Feedback

The Hierarchy type exposes the following members.

Events

 | Name | Description
Public event | FiltersChanged | Occurs when the Hierarchy filters have changed.
Public event | SortingChanged | Occurs when the Hierarchy sorting have changed.

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace


FiltersChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..FiltersChanged Event
Hierarchy Class See Also Send Feedback
Occurs when the Hierarchy filters have changed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler FiltersChanged
Visual Basic
Public Event FiltersChanged As EventHandler
Visual C++
public:
 event EventHandler^ FiltersChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Remarks

Use this event to capture filtering changes that affect the the HierarchyItems in the Hierarchy.

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace
Hierarchy..::..IsFiltered


SortingChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
Hierarchy..::..SortingChanged Event
Hierarchy Class See Also Send Feedback
Occurs when the Hierarchy sorting have changed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler SortingChanged
Visual Basic
Public Event SortingChanged As EventHandler
Visual C++
public:
 event EventHandler^ SortingChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Remarks

Use this event to capture sorting changes that affect the the HierarchyItems in the Hierarchy.

See Also

Hierarchy Class
VIBlend.WinForms.DataGridView Namespace
Hierarchy..::..IsSorted


HierarchyItem Class

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem Class
Members See Also Send Feedback
Represents a item in the rows or columns header area of the data grid

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class HierarchyItem : INotifyPropertyChanged
Visual Basic
Public Class HierarchyItem _
    Implements INotifyPropertyChanged
Visual C++
public ref class HierarchyItem : INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..HierarchyItem

See Also

HierarchyItem Members
VIBlend.WinForms.DataGridView Namespace


HierarchyItem Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem Members
HierarchyItem Class Constructors Methods Properties Events See Also Send Feedback

The HierarchyItem type exposes the following members.

Constructors

 | Name | Description
Public method | HierarchyItem | Default constructor

Methods

 | Name | Description
Public method | AutoResize | Automatically resizes the HierarchyItem for best fit.
Public method | Collapse | Collapses the item
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expands the item
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildItemsRecursive | Retrieves all child HierarchyItems at all levels
Public method | GetHashCode | Returns a hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueID | Returns a string which uniquely identifies the item
Public method | HitTest | Performs a HitTest at a specific point within the HierarchyItem
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnNotifyPropertyChanged | Raises the PropertyChanged event
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowFiltering | Gets or sets whether the grid's data can be filtered by this column
Public property | BoundField | Gets the bound field which establishes a data binding relationship between the items and a data column in the data source
Public property | BoundFieldIndex | Gets the index of corresponding row or column in the data source.
Public property | Caption | Gets or sets the text of this item
Public property | Cells | Gets all grid cells for this hierarchy item
Public property | CellsDataSource | Sets the data source property for all grid cells under this HierarchyItem (Row or Column).
Public property | CellsDisplaySettings | Gets or sets the grid cells display settings.
Public property | CellsEditor | Gets or sets the cells in-place editor.
Public property | CellsFormatProvider | Gets or sets the grid cells FormatProvider for this item.
Public property | CellsFormatString | Gets or sets the grid cells Format string for this item.
Public property | CellsImageAlignment | Gets or sets the grid cells image alignment.
Public property | CellsStyle | Gets or sets the grid cells style.
Public property | CellsTextAlignment | Gets or sets the grid cells text alignment property.
Public property | CellsTextImageRelation | Gets or sets the grid cells text and image relation property.
Public property | CellsTextWrap | Gets or sets the grid cells text wrap property.
Public property | ChildItemsDepth | Returns the depth of the child items hierarchy under this item
Public property | ContentType | Gets or sets the cells content type for this item
Public property | DataGridView | Gets the parent DataGridView control.
Public property | Depth | Gets the depth of the item in the hierarchy
Public property | DrawBounds | Gets the draw bounds.
Public property | Enabled | Determines whether the items is enabled or disabled
Public property | ExpandCollapseEnabled | Determines whether expand / collapse is enabled
Public property | Expanded | Checks if the item is currently expanded
Public property | Filtered | Checks if the item is filtered
Public property | FilteredChildItems | Gets the filtered child items.
Public property | FilteredChildItemsCount | Gets the filtered child items count.
Public property | Fixed | Gets or sets whether the item is Fixed (Frozen)
Public property | Height | Gets or sets the height of item
Public property | HeightWithChildren | Returns the height of the Item as it is rendered. This height includes the child items if the item is expanded
Public property | Hidden | Determines whether the item is visible
Public property | Hierarchy | Gets a reference to the Hierarchy which hosts the items
Public property | HierarchyItemStyleDisabled | Gets or sets a custom item style for disabled state.
Public property | HierarchyItemStyleNormal | Gets or sets a custom item style for normal state.
Public property | HierarchyItemStyleSelected | Gets or sets a custom item style for selected state.
Public property | ImageAlignment | Gets or sets the alignment of the image
Public property | ImageIndex | Gets or sets the item's image index
Public property | IsColumnsHierarchyItem | Checks if the HierarchyItem is part of the columns hierarchy
Public property | IsItemCellSelected | Returns true when the item has at least on corresponding grid cell which is selected
Public property | IsRowsHierarchyItem | Checks if the HierarchyItem is part of the rows hierarchy
Public property | IsSummaryItem | Checks if this item is a summary item
Public property | IsTotal | Checks if the HierarchyItem is a Total of other items in the same collection.
Public property | ItemAbove | Returns the Item displayed above this item
Public property | ItemBelow | Returns the Item displayed below this item
Public property | ItemData | Gets or sets the data object of the item
Public property | ItemIndex | Gets the index of the item within the items collection of the parent item or hierarchy
Public property | ItemLeft | Returns the Item displayed on the left of the this item
Public property | ItemRight | Returns the Item displayed on the right of the this item
Public property | Items | Collection representing the child items of this item
Public property | ItemsCount | Gets the count of the child items
Public property | ItemValue | Gets or sets a user defined value associated with the HierarchyItem
Public property | NonEmptyCells | Gets all non-empty grid cells for this hierarchy item
Public property | ParentItem | Gets the parent item if exist
Public property | Resizable | Gets or sets whether the item is resizable
Public property | Selected | Determines whether the item is selected
Public property | SortMode | Gets or sets the sort mode for the item
Public property | SummaryItems | Collection represeting the child summary items of this item
Public property | Tag | Gets or sets the tag associated to the HierarchyItem instance.
Public property | TextAlignment | Gets or sets the text alignment
Public property | TextImageIndicatorOffset | Gets or sets the offset between the expand/collapse indicator and the text and image
Public property | TextImageOffset | Gets or sets the offset between the text and the image
Public property | TextImageRelation | Gets or sets the relation between the text and the image
Public property | TextWrap | Gets or sets the text wrap mode
Public property | TooltipText | Gets or sets the tooltip text of this item
Public property | TotalItemsCount | Returns the number of child items and child summary items of the item
Public property | Visible | Gets whether the item is visible based on the current scroll position
Public property | VisibleChildItemsCount | Gets the visible child items count.
Public property | VisibleItemsCount | Returns the number child items and summary items which are currently visible
Public property | Width | Gets or sets the Width of the item
Public property | WidthWithChildren | Returns the width of the Item as it is rendered This width includes the child items if the item is expanded
Public property | X | Gets the Item's horizontal offset relative to the parent hierarchy
Public property | Y | Gets the Item's vertical offset relative to the parent hierarchy

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a HierarchyItem property changed.

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItem Constructor

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem Constructor
HierarchyItem Class See Also Send Feedback
Default constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem()
Visual Basic
Public Sub New
Visual C++
public:
HierarchyItem()

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItem Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem Methods
HierarchyItem Class See Also Send Feedback

The HierarchyItem type exposes the following members.

Methods

 | Name | Description
Public method | AutoResize | Automatically resizes the HierarchyItem for best fit.
Public method | Collapse | Collapses the item
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expands the item
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildItemsRecursive | Retrieves all child HierarchyItems at all levels
Public method | GetHashCode | Returns a hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueID | Returns a string which uniquely identifies the item
Public method | HitTest | Performs a HitTest at a specific point within the HierarchyItem
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnNotifyPropertyChanged | Raises the PropertyChanged event
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


AutoResize Method

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..AutoResize Method
HierarchyItem Class See Also Send Feedback
Automatically resizes the HierarchyItem for best fit.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void AutoResize(
    AutoResizeMode autoResizeMode
)
Visual Basic
Public Sub AutoResize ( _
    autoResizeMode As AutoResizeMode _
)
Visual C++
public:
void AutoResize(
    AutoResizeMode autoResizeMode
)

Parameters

autoResizeMode
Type: VIBlend.WinForms.DataGridView..::..AutoResizeMode
AutoResize mode

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Collapse Method

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Collapse Method
HierarchyItem Class See Also Send Feedback
Collapses the item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Collapse()
Visual Basic
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Expand Method

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Expand Method
HierarchyItem Class See Also Send Feedback
Expands the item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Expand()
Visual Basic
Public Sub Expand
Visual C++
public:
void Expand()

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


GetChildItemsRecursive Method

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..GetChildItemsRecursive Method
HierarchyItem Class See Also Send Feedback
Retrieves all child HierarchyItems at all levels

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<HierarchyItem> GetChildItemsRecursive()
Visual Basic
Public Function GetChildItemsRecursive As List(Of HierarchyItem)
Visual C++
public:
List<HierarchyItem^>^ GetChildItemsRecursive()

Return Value

List of HierarchyItems

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


GetHashCode Method

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..GetHashCode Method
HierarchyItem Class See Also Send Feedback
Returns a hash code for this instance.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


GetUniqueID Method

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..GetUniqueID Method
HierarchyItem Class See Also Send Feedback
Returns a string which uniquely identifies the item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string GetUniqueID()
Visual Basic
Public Function GetUniqueID As String
Visual C++
public:
String^ GetUniqueID()

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


HitTest Method

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..HitTest Method
HierarchyItem Class See Also Send Feedback
Performs a HitTest at a specific point within the HierarchyItem

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem HitTest(
    Point point
)
Visual Basic
Public Function HitTest ( _
    point As Point _
) As HierarchyItem
Visual C++
public:
HierarchyItem^ HitTest(
    Point point
)

Parameters

point
Type: System.Drawing..::..Point
Point representing the X, Y coordinate to test. The point must be relative to the top-left corner of the grid control

Return Value

The method returns the HierarchyItem located at the position pointed by the point parameter. If there is no HierarchyItem at this position the method returns NULL.

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


OnNotifyPropertyChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..OnNotifyPropertyChanged Method
HierarchyItem Class See Also Send Feedback
Raises the PropertyChanged event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnNotifyPropertyChanged(
    PropertyChangedEventArgs e
)
Visual Basic
Protected Overridable Sub OnNotifyPropertyChanged ( _
    e As PropertyChangedEventArgs _
)
Visual C++
protected:
virtual void OnNotifyPropertyChanged(
    PropertyChangedEventArgs^ e
)

Parameters

e
Type: System.ComponentModel..::..PropertyChangedEventArgs
PropertyChangedEventArgs that contains the event information.

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItem Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem Properties
HierarchyItem Class See Also Send Feedback

The HierarchyItem type exposes the following members.

Properties

 | Name | Description
Public property | AllowFiltering | Gets or sets whether the grid's data can be filtered by this column
Public property | BoundField | Gets the bound field which establishes a data binding relationship between the items and a data column in the data source
Public property | BoundFieldIndex | Gets the index of corresponding row or column in the data source.
Public property | Caption | Gets or sets the text of this item
Public property | Cells | Gets all grid cells for this hierarchy item
Public property | CellsDataSource | Sets the data source property for all grid cells under this HierarchyItem (Row or Column).
Public property | CellsDisplaySettings | Gets or sets the grid cells display settings.
Public property | CellsEditor | Gets or sets the cells in-place editor.
Public property | CellsFormatProvider | Gets or sets the grid cells FormatProvider for this item.
Public property | CellsFormatString | Gets or sets the grid cells Format string for this item.
Public property | CellsImageAlignment | Gets or sets the grid cells image alignment.
Public property | CellsStyle | Gets or sets the grid cells style.
Public property | CellsTextAlignment | Gets or sets the grid cells text alignment property.
Public property | CellsTextImageRelation | Gets or sets the grid cells text and image relation property.
Public property | CellsTextWrap | Gets or sets the grid cells text wrap property.
Public property | ChildItemsDepth | Returns the depth of the child items hierarchy under this item
Public property | ContentType | Gets or sets the cells content type for this item
Public property | DataGridView | Gets the parent DataGridView control.
Public property | Depth | Gets the depth of the item in the hierarchy
Public property | DrawBounds | Gets the draw bounds.
Public property | Enabled | Determines whether the items is enabled or disabled
Public property | ExpandCollapseEnabled | Determines whether expand / collapse is enabled
Public property | Expanded | Checks if the item is currently expanded
Public property | Filtered | Checks if the item is filtered
Public property | FilteredChildItems | Gets the filtered child items.
Public property | FilteredChildItemsCount | Gets the filtered child items count.
Public property | Fixed | Gets or sets whether the item is Fixed (Frozen)
Public property | Height | Gets or sets the height of item
Public property | HeightWithChildren | Returns the height of the Item as it is rendered. This height includes the child items if the item is expanded
Public property | Hidden | Determines whether the item is visible
Public property | Hierarchy | Gets a reference to the Hierarchy which hosts the items
Public property | HierarchyItemStyleDisabled | Gets or sets a custom item style for disabled state.
Public property | HierarchyItemStyleNormal | Gets or sets a custom item style for normal state.
Public property | HierarchyItemStyleSelected | Gets or sets a custom item style for selected state.
Public property | ImageAlignment | Gets or sets the alignment of the image
Public property | ImageIndex | Gets or sets the item's image index
Public property | IsColumnsHierarchyItem | Checks if the HierarchyItem is part of the columns hierarchy
Public property | IsItemCellSelected | Returns true when the item has at least on corresponding grid cell which is selected
Public property | IsRowsHierarchyItem | Checks if the HierarchyItem is part of the rows hierarchy
Public property | IsSummaryItem | Checks if this item is a summary item
Public property | IsTotal | Checks if the HierarchyItem is a Total of other items in the same collection.
Public property | ItemAbove | Returns the Item displayed above this item
Public property | ItemBelow | Returns the Item displayed below this item
Public property | ItemData | Gets or sets the data object of the item
Public property | ItemIndex | Gets the index of the item within the items collection of the parent item or hierarchy
Public property | ItemLeft | Returns the Item displayed on the left of the this item
Public property | ItemRight | Returns the Item displayed on the right of the this item
Public property | Items | Collection representing the child items of this item
Public property | ItemsCount | Gets the count of the child items
Public property | ItemValue | Gets or sets a user defined value associated with the HierarchyItem
Public property | NonEmptyCells | Gets all non-empty grid cells for this hierarchy item
Public property | ParentItem | Gets the parent item if exist
Public property | Resizable | Gets or sets whether the item is resizable
Public property | Selected | Determines whether the item is selected
Public property | SortMode | Gets or sets the sort mode for the item
Public property | SummaryItems | Collection represeting the child summary items of this item
Public property | Tag | Gets or sets the tag associated to the HierarchyItem instance.
Public property | TextAlignment | Gets or sets the text alignment
Public property | TextImageIndicatorOffset | Gets or sets the offset between the expand/collapse indicator and the text and image
Public property | TextImageOffset | Gets or sets the offset between the text and the image
Public property | TextImageRelation | Gets or sets the relation between the text and the image
Public property | TextWrap | Gets or sets the text wrap mode
Public property | TooltipText | Gets or sets the tooltip text of this item
Public property | TotalItemsCount | Returns the number of child items and child summary items of the item
Public property | Visible | Gets whether the item is visible based on the current scroll position
Public property | VisibleChildItemsCount | Gets the visible child items count.
Public property | VisibleItemsCount | Returns the number child items and summary items which are currently visible
Public property | Width | Gets or sets the Width of the item
Public property | WidthWithChildren | Returns the width of the Item as it is rendered This width includes the child items if the item is expanded
Public property | X | Gets the Item's horizontal offset relative to the parent hierarchy
Public property | Y | Gets the Item's vertical offset relative to the parent hierarchy

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


AllowFiltering Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..AllowFiltering Property
HierarchyItem Class See Also Send Feedback
Gets or sets whether the grid's data can be filtered by this column

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowFiltering { get; set; }
Visual Basic
Public Property AllowFiltering As Boolean
    Get
    Set
Visual C++
public:
property bool AllowFiltering {
    bool get ();
    void set (bool value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


BoundField Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..BoundField Property
HierarchyItem Class See Also Send Feedback
Gets the bound field which establishes a data binding relationship between the items and a data column in the data source

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BoundField BoundField { get; internal set; }
Visual Basic
Public Property BoundField As BoundField
    Get
    Friend Set
Visual C++
public:
property BoundField^ BoundField {
    BoundField^ get ();
    internal: void set (BoundField^ value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


BoundFieldIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..BoundFieldIndex Property
HierarchyItem Class See Also Send Feedback
Gets the index of corresponding row or column in the data source.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int BoundFieldIndex { get; internal set; }
Visual Basic
Public Property BoundFieldIndex As Integer
    Get
    Friend Set
Visual C++
public:
property int BoundFieldIndex {
    int get ();
    internal: void set (int value);
}

Remarks

This property is valid only when the data grid is working in databound mode. If the item is one of the RowsHierarchy items you can use this propery to determine the row number in the data source. If the item is one of the ColumnsHierarchy items, you can use the property to retrieve the column index in the data source. Please note, that this propery is not applicable in Pivot bound mode because in these cases the data is aggregated.

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Caption Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Caption Property
HierarchyItem Class See Also Send Feedback
Gets or sets the text of this item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Caption { get; set; }
Visual Basic
Public Property Caption As String
    Get
    Set
Visual C++
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Cells Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Cells Property
HierarchyItem Class See Also Send Feedback
Gets all grid cells for this hierarchy item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell[] Cells { get; }
Visual Basic
Public ReadOnly Property Cells As GridCell()
    Get
Visual C++
public:
property array<GridCell^>^ Cells {
    array<GridCell^>^ get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


CellsDataSource Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..CellsDataSource Property
HierarchyItem Class See Also Send Feedback
Sets the data source property for all grid cells under this HierarchyItem (Row or Column).

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCellDataSource CellsDataSource { get; set; }
Visual Basic
Public Property CellsDataSource As GridCellDataSource
    Get
    Set
Visual C++
public:
property GridCellDataSource CellsDataSource {
    GridCellDataSource get ();
    void set (GridCellDataSource value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


CellsDisplaySettings Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..CellsDisplaySettings Property
HierarchyItem Class See Also Send Feedback
Gets or sets the grid cells display settings.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DisplaySettings CellsDisplaySettings { get; set; }
Visual Basic
Public Property CellsDisplaySettings As DisplaySettings
    Get
    Set
Visual C++
public:
property DisplaySettings CellsDisplaySettings {
    DisplaySettings get ();
    void set (DisplaySettings value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


CellsEditor Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..CellsEditor Property
HierarchyItem Class See Also Send Feedback
Gets or sets the cells in-place editor.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public IEditor CellsEditor { get; set; }
Visual Basic
Public Property CellsEditor As IEditor
    Get
    Set
Visual C++
public:
property IEditor^ CellsEditor {
    IEditor^ get ();
    void set (IEditor^ value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


CellsFormatProvider Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..CellsFormatProvider Property
HierarchyItem Class See Also Send Feedback
Gets or sets the grid cells FormatProvider for this item.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public IFormatProvider CellsFormatProvider { get; set; }
Visual Basic
Public Property CellsFormatProvider As IFormatProvider
    Get
    Set
Visual C++
public:
property IFormatProvider^ CellsFormatProvider {
    IFormatProvider^ get ();
    void set (IFormatProvider^ value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


CellsFormatString Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..CellsFormatString Property
HierarchyItem Class See Also Send Feedback
Gets or sets the grid cells Format string for this item.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string CellsFormatString { get; set; }
Visual Basic
Public Property CellsFormatString As String
    Get
    Set
Visual C++
public:
property String^ CellsFormatString {
    String^ get ();
    void set (String^ value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


CellsImageAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..CellsImageAlignment Property
HierarchyItem Class See Also Send Feedback
Gets or sets the grid cells image alignment.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment CellsImageAlignment { get; set; }
Visual Basic
Public Property CellsImageAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment CellsImageAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


CellsStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..CellsStyle Property
HierarchyItem Class See Also Send Feedback
Gets or sets the grid cells style.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCellStyle CellsStyle { get; set; }
Visual Basic
Public Property CellsStyle As GridCellStyle
    Get
    Set
Visual C++
public:
property GridCellStyle^ CellsStyle {
    GridCellStyle^ get ();
    void set (GridCellStyle^ value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


CellsTextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..CellsTextAlignment Property
HierarchyItem Class See Also Send Feedback
Gets or sets the grid cells text alignment property.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment CellsTextAlignment { get; set; }
Visual Basic
Public Property CellsTextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment CellsTextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


CellsTextImageRelation Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..CellsTextImageRelation Property
HierarchyItem Class See Also Send Feedback
Gets or sets the grid cells text and image relation property.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public TextImageRelation CellsTextImageRelation { get; set; }
Visual Basic
Public Property CellsTextImageRelation As TextImageRelation
    Get
    Set
Visual C++
public:
property TextImageRelation CellsTextImageRelation {
    TextImageRelation get ();
    void set (TextImageRelation value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


CellsTextWrap Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..CellsTextWrap Property
HierarchyItem Class See Also Send Feedback
Gets or sets the grid cells text wrap property.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool CellsTextWrap { get; set; }
Visual Basic
Public Property CellsTextWrap As Boolean
    Get
    Set
Visual C++
public:
property bool CellsTextWrap {
    bool get ();
    void set (bool value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


ChildItemsDepth Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..ChildItemsDepth Property
HierarchyItem Class See Also Send Feedback
Returns the depth of the child items hierarchy under this item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ChildItemsDepth { get; }
Visual Basic
Public ReadOnly Property ChildItemsDepth As Integer
    Get
Visual C++
public:
property int ChildItemsDepth {
    int get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


ContentType Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..ContentType Property
HierarchyItem Class See Also Send Feedback
Gets or sets the cells content type for this item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Type ContentType { get; set; }
Visual Basic
Public Property ContentType As Type
    Get
    Set
Visual C++
public:
property Type^ ContentType {
    Type^ get ();
    void set (Type^ value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


DataGridView Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..DataGridView Property
HierarchyItem Class See Also Send Feedback
Gets the parent DataGridView control.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDataGridView DataGridView { get; }
Visual Basic
Public ReadOnly Property DataGridView As vDataGridView
    Get
Visual C++
public:
property vDataGridView^ DataGridView {
    vDataGridView^ get ();
}

Field Value

The DataGridView that hosts this HierarchyItem.

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Depth Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Depth Property
HierarchyItem Class See Also Send Feedback
Gets the depth of the item in the hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Depth { get; }
Visual Basic
Public ReadOnly Property Depth As Integer
    Get
Visual C++
public:
property int Depth {
    int get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


DrawBounds Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..DrawBounds Property
HierarchyItem Class See Also Send Feedback
Gets the draw bounds.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle DrawBounds { get; }
Visual Basic
Public ReadOnly Property DrawBounds As Rectangle
    Get
Visual C++
public:
property Rectangle DrawBounds {
    Rectangle get ();
}

Field Value

The draw bounds.

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Enabled Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Enabled Property
HierarchyItem Class See Also Send Feedback
Determines whether the items is enabled or disabled

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


ExpandCollapseEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..ExpandCollapseEnabled Property
HierarchyItem Class See Also Send Feedback
Determines whether expand / collapse is enabled

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ExpandCollapseEnabled { get; set; }
Visual Basic
Public Property ExpandCollapseEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool ExpandCollapseEnabled {
    bool get ();
    void set (bool value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Expanded Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Expanded Property
HierarchyItem Class See Also Send Feedback
Checks if the item is currently expanded

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Expanded { get; set; }
Visual Basic
Public Property Expanded As Boolean
    Get
    Set
Visual C++
public:
property bool Expanded {
    bool get ();
    void set (bool value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Filtered Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Filtered Property
HierarchyItem Class See Also Send Feedback
Checks if the item is filtered

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Filtered { get; internal set; }
Visual Basic
Public Property Filtered As Boolean
    Get
    Friend Set
Visual C++
public:
property bool Filtered {
    bool get ();
    internal: void set (bool value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


FilteredChildItems Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..FilteredChildItems Property
HierarchyItem Class See Also Send Feedback
Gets the filtered child items.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<HierarchyItem> FilteredChildItems { get; }
Visual Basic
Public ReadOnly Property FilteredChildItems As List(Of HierarchyItem)
    Get
Visual C++
public:
property List<HierarchyItem^>^ FilteredChildItems {
    List<HierarchyItem^>^ get ();
}

Field Value

The filtered child items.

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


FilteredChildItemsCount Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..FilteredChildItemsCount Property
HierarchyItem Class See Also Send Feedback
Gets the filtered child items count.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int FilteredChildItemsCount { get; }
Visual Basic
Public ReadOnly Property FilteredChildItemsCount As Integer
    Get
Visual C++
public:
property int FilteredChildItemsCount {
    int get ();
}

Field Value

The filtered child items count.

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Fixed Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Fixed Property
HierarchyItem Class See Also Send Feedback
Gets or sets whether the item is Fixed (Frozen)

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Fixed { get; set; }
Visual Basic
Public Property Fixed As Boolean
    Get
    Set
Visual C++
public:
property bool Fixed {
    bool get ();
    void set (bool value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Height Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Height Property
HierarchyItem Class See Also Send Feedback
Gets or sets the height of item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Height { get; set; }
Visual Basic
Public Property Height As Integer
    Get
    Set
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


HeightWithChildren Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..HeightWithChildren Property
HierarchyItem Class See Also Send Feedback
Returns the height of the Item as it is rendered. This height includes the child items if the item is expanded

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int HeightWithChildren { get; }
Visual Basic
Public ReadOnly Property HeightWithChildren As Integer
    Get
Visual C++
public:
property int HeightWithChildren {
    int get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Hidden Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Hidden Property
HierarchyItem Class See Also Send Feedback
Determines whether the item is visible

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Hidden { get; set; }
Visual Basic
Public Property Hidden As Boolean
    Get
    Set
Visual C++
public:
property bool Hidden {
    bool get ();
    void set (bool value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Hierarchy Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Hierarchy Property
HierarchyItem Class See Also Send Feedback
Gets a reference to the Hierarchy which hosts the items

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Hierarchy Hierarchy { get; internal set; }
Visual Basic
Public Property Hierarchy As Hierarchy
    Get
    Friend Set
Visual C++
public:
property Hierarchy^ Hierarchy {
    Hierarchy^ get ();
    internal: void set (Hierarchy^ value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemStyleDisabled Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..HierarchyItemStyleDisabled Property
HierarchyItem Class See Also Send Feedback
Gets or sets a custom item style for disabled state.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemStyle HierarchyItemStyleDisabled { get; set; }
Visual Basic
Public Property HierarchyItemStyleDisabled As HierarchyItemStyle
    Get
    Set
Visual C++
public:
property HierarchyItemStyle^ HierarchyItemStyleDisabled {
    HierarchyItemStyle^ get ();
    void set (HierarchyItemStyle^ value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemStyleNormal Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..HierarchyItemStyleNormal Property
HierarchyItem Class See Also Send Feedback
Gets or sets a custom item style for normal state.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemStyle HierarchyItemStyleNormal { get; set; }
Visual Basic
Public Property HierarchyItemStyleNormal As HierarchyItemStyle
    Get
    Set
Visual C++
public:
property HierarchyItemStyle^ HierarchyItemStyleNormal {
    HierarchyItemStyle^ get ();
    void set (HierarchyItemStyle^ value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemStyleSelected Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..HierarchyItemStyleSelected Property
HierarchyItem Class See Also Send Feedback
Gets or sets a custom item style for selected state.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemStyle HierarchyItemStyleSelected { get; set; }
Visual Basic
Public Property HierarchyItemStyleSelected As HierarchyItemStyle
    Get
    Set
Visual C++
public:
property HierarchyItemStyle^ HierarchyItemStyleSelected {
    HierarchyItemStyle^ get ();
    void set (HierarchyItemStyle^ value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


ImageAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..ImageAlignment Property
HierarchyItem Class See Also Send Feedback
Gets or sets the alignment of the image

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment ImageAlignment { get; set; }
Visual Basic
Public Property ImageAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment ImageAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


ImageIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..ImageIndex Property
HierarchyItem Class See Also Send Feedback
Gets or sets the item's image index

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ImageIndex { get; set; }
Visual Basic
Public Property ImageIndex As Integer
    Get
    Set
Visual C++
public:
property int ImageIndex {
    int get ();
    void set (int value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


IsColumnsHierarchyItem Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..IsColumnsHierarchyItem Property
HierarchyItem Class See Also Send Feedback
Checks if the HierarchyItem is part of the columns hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsColumnsHierarchyItem { get; internal set; }
Visual Basic
Public Property IsColumnsHierarchyItem As Boolean
    Get
    Friend Set
Visual C++
public:
property bool IsColumnsHierarchyItem {
    bool get ();
    internal: void set (bool value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


IsItemCellSelected Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..IsItemCellSelected Property
HierarchyItem Class See Also Send Feedback
Returns true when the item has at least on corresponding grid cell which is selected

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsItemCellSelected { get; }
Visual Basic
Public ReadOnly Property IsItemCellSelected As Boolean
    Get
Visual C++
public:
property bool IsItemCellSelected {
    bool get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


IsRowsHierarchyItem Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..IsRowsHierarchyItem Property
HierarchyItem Class See Also Send Feedback
Checks if the HierarchyItem is part of the rows hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsRowsHierarchyItem { get; }
Visual Basic
Public ReadOnly Property IsRowsHierarchyItem As Boolean
    Get
Visual C++
public:
property bool IsRowsHierarchyItem {
    bool get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


IsSummaryItem Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..IsSummaryItem Property
HierarchyItem Class See Also Send Feedback
Checks if this item is a summary item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsSummaryItem { get; }
Visual Basic
Public ReadOnly Property IsSummaryItem As Boolean
    Get
Visual C++
public:
property bool IsSummaryItem {
    bool get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


IsTotal Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..IsTotal Property
HierarchyItem Class See Also Send Feedback
Checks if the HierarchyItem is a Total of other items in the same collection.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsTotal { get; internal set; }
Visual Basic
Public Property IsTotal As Boolean
    Get
    Friend Set
Visual C++
public:
property bool IsTotal {
    bool get ();
    internal: void set (bool value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


ItemAbove Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..ItemAbove Property
HierarchyItem Class See Also Send Feedback
Returns the Item displayed above this item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem ItemAbove { get; }
Visual Basic
Public ReadOnly Property ItemAbove As HierarchyItem
    Get
Visual C++
public:
property HierarchyItem^ ItemAbove {
    HierarchyItem^ get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


ItemBelow Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..ItemBelow Property
HierarchyItem Class See Also Send Feedback
Returns the Item displayed below this item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem ItemBelow { get; }
Visual Basic
Public ReadOnly Property ItemBelow As HierarchyItem
    Get
Visual C++
public:
property HierarchyItem^ ItemBelow {
    HierarchyItem^ get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


ItemData Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..ItemData Property
HierarchyItem Class See Also Send Feedback
Gets or sets the data object of the item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object ItemData { get; set; }
Visual Basic
Public Property ItemData As Object
    Get
    Set
Visual C++
public:
property Object^ ItemData {
    Object^ get ();
    void set (Object^ value);
}

Remarks

Use this property to associate the item with a custom object

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


ItemIndex Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..ItemIndex Property
HierarchyItem Class See Also Send Feedback
Gets the index of the item within the items collection of the parent item or hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ItemIndex { get; }
Visual Basic
Public ReadOnly Property ItemIndex As Integer
    Get
Visual C++
public:
property int ItemIndex {
    int get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


ItemLeft Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..ItemLeft Property
HierarchyItem Class See Also Send Feedback
Returns the Item displayed on the left of the this item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem ItemLeft { get; }
Visual Basic
Public ReadOnly Property ItemLeft As HierarchyItem
    Get
Visual C++
public:
property HierarchyItem^ ItemLeft {
    HierarchyItem^ get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


ItemRight Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..ItemRight Property
HierarchyItem Class See Also Send Feedback
Returns the Item displayed on the right of the this item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem ItemRight { get; }
Visual Basic
Public ReadOnly Property ItemRight As HierarchyItem
    Get
Visual C++
public:
property HierarchyItem^ ItemRight {
    HierarchyItem^ get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Items Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Items Property
HierarchyItem Class See Also Send Feedback
Collection representing the child items of this item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemsCollection Items { get; }
Visual Basic
Public ReadOnly Property Items As HierarchyItemsCollection
    Get
Visual C++
public:
property HierarchyItemsCollection^ Items {
    HierarchyItemsCollection^ get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


ItemsCount Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..ItemsCount Property
HierarchyItem Class See Also Send Feedback
Gets the count of the child items

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ItemsCount { get; }
Visual Basic
Public ReadOnly Property ItemsCount As Integer
    Get
Visual C++
public:
property int ItemsCount {
    int get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


ItemValue Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..ItemValue Property
HierarchyItem Class See Also Send Feedback
Gets or sets a user defined value associated with the HierarchyItem

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object ItemValue { get; set; }
Visual Basic
Public Property ItemValue As Object
    Get
    Set
Visual C++
public:
property Object^ ItemValue {
    Object^ get ();
    void set (Object^ value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


NonEmptyCells Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..NonEmptyCells Property
HierarchyItem Class See Also Send Feedback
Gets all non-empty grid cells for this hierarchy item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell[] NonEmptyCells { get; }
Visual Basic
Public ReadOnly Property NonEmptyCells As GridCell()
    Get
Visual C++
public:
property array<GridCell^>^ NonEmptyCells {
    array<GridCell^>^ get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


ParentItem Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..ParentItem Property
HierarchyItem Class See Also Send Feedback
Gets the parent item if exist

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem ParentItem { get; }
Visual Basic
Public ReadOnly Property ParentItem As HierarchyItem
    Get
Visual C++
public:
property HierarchyItem^ ParentItem {
    HierarchyItem^ get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Resizable Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Resizable Property
HierarchyItem Class See Also Send Feedback
Gets or sets whether the item is resizable

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Resizable { get; set; }
Visual Basic
Public Property Resizable As Boolean
    Get
    Set
Visual C++
public:
property bool Resizable {
    bool get ();
    void set (bool value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Selected Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Selected Property
HierarchyItem Class See Also Send Feedback
Determines whether the item is selected

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Selected { get; set; }
Visual Basic
Public Property Selected As Boolean
    Get
    Set
Visual C++
public:
property bool Selected {
    bool get ();
    void set (bool value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


SortMode Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..SortMode Property
HierarchyItem Class See Also Send Feedback
Gets or sets the sort mode for the item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridItemSortMode SortMode { get; set; }
Visual Basic
Public Property SortMode As GridItemSortMode
    Get
    Set
Visual C++
public:
property GridItemSortMode SortMode {
    GridItemSortMode get ();
    void set (GridItemSortMode value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


SummaryItems Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..SummaryItems Property
HierarchyItem Class See Also Send Feedback
Collection represeting the child summary items of this item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemsCollection SummaryItems { get; }
Visual Basic
Public ReadOnly Property SummaryItems As HierarchyItemsCollection
    Get
Visual C++
public:
property HierarchyItemsCollection^ SummaryItems {
    HierarchyItemsCollection^ get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Tag Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Tag Property
HierarchyItem Class See Also Send Feedback
Gets or sets the tag associated to the HierarchyItem instance.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object Tag { get; set; }
Visual Basic
Public Property Tag As Object
    Get
    Set
Visual C++
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Field Value

The tag.

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


TextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..TextAlignment Property
HierarchyItem Class See Also Send Feedback
Gets or sets the text alignment

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment TextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


TextImageIndicatorOffset Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..TextImageIndicatorOffset Property
HierarchyItem Class See Also Send Feedback
Gets or sets the offset between the expand/collapse indicator and the text and image

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int TextImageIndicatorOffset { get; set; }
Visual Basic
Public Property TextImageIndicatorOffset As Integer
    Get
    Set
Visual C++
public:
property int TextImageIndicatorOffset {
    int get ();
    void set (int value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


TextImageOffset Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..TextImageOffset Property
HierarchyItem Class See Also Send Feedback
Gets or sets the offset between the text and the image

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int TextImageOffset { get; set; }
Visual Basic
Public Property TextImageOffset As Integer
    Get
    Set
Visual C++
public:
property int TextImageOffset {
    int get ();
    void set (int value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


TextImageRelation Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..TextImageRelation Property
HierarchyItem Class See Also Send Feedback
Gets or sets the relation between the text and the image

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public TextImageRelation TextImageRelation { get; set; }
Visual Basic
Public Property TextImageRelation As TextImageRelation
    Get
    Set
Visual C++
public:
property TextImageRelation TextImageRelation {
    TextImageRelation get ();
    void set (TextImageRelation value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


TextWrap Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..TextWrap Property
HierarchyItem Class See Also Send Feedback
Gets or sets the text wrap mode

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool TextWrap { get; set; }
Visual Basic
Public Property TextWrap As Boolean
    Get
    Set
Visual C++
public:
property bool TextWrap {
    bool get ();
    void set (bool value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


TooltipText Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..TooltipText Property
HierarchyItem Class See Also Send Feedback
Gets or sets the tooltip text of this item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string TooltipText { get; set; }
Visual Basic
Public Property TooltipText As String
    Get
    Set
Visual C++
public:
property String^ TooltipText {
    String^ get ();
    void set (String^ value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


TotalItemsCount Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..TotalItemsCount Property
HierarchyItem Class See Also Send Feedback
Returns the number of child items and child summary items of the item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int TotalItemsCount { get; }
Visual Basic
Public ReadOnly Property TotalItemsCount As Integer
    Get
Visual C++
public:
property int TotalItemsCount {
    int get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Visible Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Visible Property
HierarchyItem Class See Also Send Feedback
Gets whether the item is visible based on the current scroll position

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Visible { get; }
Visual Basic
Public ReadOnly Property Visible As Boolean
    Get
Visual C++
public:
property bool Visible {
    bool get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


VisibleChildItemsCount Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..VisibleChildItemsCount Property
HierarchyItem Class See Also Send Feedback
Gets the visible child items count.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int VisibleChildItemsCount { get; }
Visual Basic
Public ReadOnly Property VisibleChildItemsCount As Integer
    Get
Visual C++
public:
property int VisibleChildItemsCount {
    int get ();
}

Field Value

The visible child items count.

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


VisibleItemsCount Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..VisibleItemsCount Property
HierarchyItem Class See Also Send Feedback
Returns the number child items and summary items which are currently visible

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int VisibleItemsCount { get; }
Visual Basic
Public ReadOnly Property VisibleItemsCount As Integer
    Get
Visual C++
public:
property int VisibleItemsCount {
    int get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Width Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Width Property
HierarchyItem Class See Also Send Feedback
Gets or sets the Width of the item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Width { get; set; }
Visual Basic
Public Property Width As Integer
    Get
    Set
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


WidthWithChildren Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..WidthWithChildren Property
HierarchyItem Class See Also Send Feedback
Returns the width of the Item as it is rendered This width includes the child items if the item is expanded

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int WidthWithChildren { get; }
Visual Basic
Public ReadOnly Property WidthWithChildren As Integer
    Get
Visual C++
public:
property int WidthWithChildren {
    int get ();
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


X Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..X Property
HierarchyItem Class See Also Send Feedback
Gets the Item's horizontal offset relative to the parent hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int X { get; internal set; }
Visual Basic
Public Property X As Integer
    Get
    Friend Set
Visual C++
public:
property int X {
    int get ();
    internal: void set (int value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


Y Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..Y Property
HierarchyItem Class See Also Send Feedback
Gets the Item's vertical offset relative to the parent hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Y { get; internal set; }
Visual Basic
Public Property Y As Integer
    Get
    Friend Set
Visual C++
public:
property int Y {
    int get ();
    internal: void set (int value);
}

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItem Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem Events
HierarchyItem Class See Also Send Feedback

The HierarchyItem type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a HierarchyItem property changed.

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


PropertyChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItem..::..PropertyChanged Event
HierarchyItem Class See Also Send Feedback
Occurs when a HierarchyItem property changed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

HierarchyItem Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemCancelEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemCancelEventArgs Class
Members See Also Send Feedback
Represents a HierarchyItem cancel event argument

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class HierarchyItemCancelEventArgs : HierarchyItemEventArgs
Visual Basic
Public Class HierarchyItemCancelEventArgs _
    Inherits HierarchyItemEventArgs
Visual C++
public ref class HierarchyItemCancelEventArgs : public HierarchyItemEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.DataGridView..::..HierarchyItemEventArgs
VIBlend.WinForms.DataGridView..::..HierarchyItemCancelEventArgs

See Also

HierarchyItemCancelEventArgs Members
VIBlend.WinForms.DataGridView Namespace


HierarchyItemCancelEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemCancelEventArgs Members
HierarchyItemCancelEventArgs Class Constructors Methods Properties See Also Send Feedback

The HierarchyItemCancelEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | HierarchyItemCancelEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Determines whether the event is canceled
Public property | HierarchyItem | The HierarchyItem associated with the event. (Inherited from HierarchyItemEventArgs.)

See Also

HierarchyItemCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemCancelEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemCancelEventArgs Constructor
HierarchyItemCancelEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemCancelEventArgs(
    HierarchyItem item
)
Visual Basic
Public Sub New ( _
    item As HierarchyItem _
)
Visual C++
public:
HierarchyItemCancelEventArgs(
    HierarchyItem^ item
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
A HierarchyItem associated with the event.

See Also

HierarchyItemCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemCancelEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemCancelEventArgs Methods
HierarchyItemCancelEventArgs Class See Also Send Feedback

The HierarchyItemCancelEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HierarchyItemCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemCancelEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemCancelEventArgs Properties
HierarchyItemCancelEventArgs Class See Also Send Feedback

The HierarchyItemCancelEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Determines whether the event is canceled
Public property | HierarchyItem | The HierarchyItem associated with the event. (Inherited from HierarchyItemEventArgs.)

See Also

HierarchyItemCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Cancel Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemCancelEventArgs..::..Cancel Property
HierarchyItemCancelEventArgs Class See Also Send Feedback
Determines whether the event is canceled

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic
Public Property Cancel As Boolean
    Get
    Set
Visual C++
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}

See Also

HierarchyItemCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemDragCancelEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemDragCancelEventArgs Class
Members See Also Send Feedback
Represents a HierarchyItem drag cancel event argument

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class HierarchyItemDragCancelEventArgs : HierarchyItemDragEventArgs
Visual Basic
Public Class HierarchyItemDragCancelEventArgs _
    Inherits HierarchyItemDragEventArgs
Visual C++
public ref class HierarchyItemDragCancelEventArgs : public HierarchyItemDragEventArgs

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..HierarchyItemDragEventArgs
VIBlend.WinForms.DataGridView..::..HierarchyItemDragCancelEventArgs

See Also

HierarchyItemDragCancelEventArgs Members
VIBlend.WinForms.DataGridView Namespace


HierarchyItemDragCancelEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemDragCancelEventArgs Members
HierarchyItemDragCancelEventArgs Class Constructors Methods Properties See Also Send Feedback

The HierarchyItemDragCancelEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | HierarchyItemDragCancelEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Determines whether the event is canceled
Public property | DragSourceHierarchyItem | Gets the DragSource HierarchyItem (Inherited from HierarchyItemDragEventArgs.)
Public property | DropTargetHierarchyItem | Gets the DropTarget HierarchyItem (Inherited from HierarchyItemDragEventArgs.)

See Also

HierarchyItemDragCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemDragCancelEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemDragCancelEventArgs Constructor
HierarchyItemDragCancelEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemDragCancelEventArgs(
    HierarchyItem sourceItem,
    HierarchyItem targetItem
)
Visual Basic
Public Sub New ( _
    sourceItem As HierarchyItem, _
    targetItem As HierarchyItem _
)
Visual C++
public:
HierarchyItemDragCancelEventArgs(
    HierarchyItem^ sourceItem,
    HierarchyItem^ targetItem
)

Parameters

sourceItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Drag source HierarhcyItem
targetItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Drop target HierarchyItem

See Also

HierarchyItemDragCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemDragCancelEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemDragCancelEventArgs Methods
HierarchyItemDragCancelEventArgs Class See Also Send Feedback

The HierarchyItemDragCancelEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HierarchyItemDragCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemDragCancelEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemDragCancelEventArgs Properties
HierarchyItemDragCancelEventArgs Class See Also Send Feedback

The HierarchyItemDragCancelEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Determines whether the event is canceled
Public property | DragSourceHierarchyItem | Gets the DragSource HierarchyItem (Inherited from HierarchyItemDragEventArgs.)
Public property | DropTargetHierarchyItem | Gets the DropTarget HierarchyItem (Inherited from HierarchyItemDragEventArgs.)

See Also

HierarchyItemDragCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Cancel Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemDragCancelEventArgs..::..Cancel Property
HierarchyItemDragCancelEventArgs Class See Also Send Feedback
Determines whether the event is canceled

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic
Public Property Cancel As Boolean
    Get
    Set
Visual C++
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}

See Also

HierarchyItemDragCancelEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemDragEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemDragEventArgs Class
Members See Also Send Feedback
Represents a grid HierarchyItem drag event argument

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class HierarchyItemDragEventArgs
Visual Basic
Public Class HierarchyItemDragEventArgs
Visual C++
public ref class HierarchyItemDragEventArgs

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..HierarchyItemDragEventArgs
VIBlend.WinForms.DataGridView..::..HierarchyItemDragCancelEventArgs

See Also

HierarchyItemDragEventArgs Members
VIBlend.WinForms.DataGridView Namespace


HierarchyItemDragEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemDragEventArgs Members
HierarchyItemDragEventArgs Class Constructors Methods Properties See Also Send Feedback

The HierarchyItemDragEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | HierarchyItemDragEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DragSourceHierarchyItem | Gets the DragSource HierarchyItem
Public property | DropTargetHierarchyItem | Gets the DropTarget HierarchyItem

See Also

HierarchyItemDragEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemDragEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemDragEventArgs Constructor
HierarchyItemDragEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemDragEventArgs(
    HierarchyItem sourceItem,
    HierarchyItem targetItem
)
Visual Basic
Public Sub New ( _
    sourceItem As HierarchyItem, _
    targetItem As HierarchyItem _
)
Visual C++
public:
HierarchyItemDragEventArgs(
    HierarchyItem^ sourceItem,
    HierarchyItem^ targetItem
)

Parameters

sourceItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Drag source HierarchyItem.
targetItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Drop target HierarchyItem.

See Also

HierarchyItemDragEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemDragEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemDragEventArgs Methods
HierarchyItemDragEventArgs Class See Also Send Feedback

The HierarchyItemDragEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HierarchyItemDragEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemDragEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemDragEventArgs Properties
HierarchyItemDragEventArgs Class See Also Send Feedback

The HierarchyItemDragEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | DragSourceHierarchyItem | Gets the DragSource HierarchyItem
Public property | DropTargetHierarchyItem | Gets the DropTarget HierarchyItem

See Also

HierarchyItemDragEventArgs Class
VIBlend.WinForms.DataGridView Namespace


DragSourceHierarchyItem Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemDragEventArgs..::..DragSourceHierarchyItem Property
HierarchyItemDragEventArgs Class See Also Send Feedback
Gets the DragSource HierarchyItem

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem DragSourceHierarchyItem { get; }
Visual Basic
Public ReadOnly Property DragSourceHierarchyItem As HierarchyItem
    Get
Visual C++
public:
property HierarchyItem^ DragSourceHierarchyItem {
    HierarchyItem^ get ();
}

See Also

HierarchyItemDragEventArgs Class
VIBlend.WinForms.DataGridView Namespace


DropTargetHierarchyItem Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemDragEventArgs..::..DropTargetHierarchyItem Property
HierarchyItemDragEventArgs Class See Also Send Feedback
Gets the DropTarget HierarchyItem

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem DropTargetHierarchyItem { get; }
Visual Basic
Public ReadOnly Property DropTargetHierarchyItem As HierarchyItem
    Get
Visual C++
public:
property HierarchyItem^ DropTargetHierarchyItem {
    HierarchyItem^ get ();
}

See Also

HierarchyItemDragEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemEventArgs Class
Members See Also Send Feedback
Represents a HierarchyItem event argument

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class HierarchyItemEventArgs : EventArgs
Visual Basic
Public Class HierarchyItemEventArgs _
    Inherits EventArgs
Visual C++
public ref class HierarchyItemEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.DataGridView..::..HierarchyItemEventArgs
VIBlend.WinForms.DataGridView..::..HierarchyItemCancelEventArgs

See Also

HierarchyItemEventArgs Members
VIBlend.WinForms.DataGridView Namespace


HierarchyItemEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemEventArgs Members
HierarchyItemEventArgs Class Constructors Methods Properties See Also Send Feedback

The HierarchyItemEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | HierarchyItemEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HierarchyItem | The HierarchyItem associated with the event.

See Also

HierarchyItemEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemEventArgs Constructor
HierarchyItemEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemEventArgs(
    HierarchyItem item
)
Visual Basic
Public Sub New ( _
    item As HierarchyItem _
)
Visual C++
public:
HierarchyItemEventArgs(
    HierarchyItem^ item
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
A HierarchyItem associated with the event.

See Also

HierarchyItemEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemEventArgs Methods
HierarchyItemEventArgs Class See Also Send Feedback

The HierarchyItemEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HierarchyItemEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemEventArgs Properties
HierarchyItemEventArgs Class See Also Send Feedback

The HierarchyItemEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | HierarchyItem | The HierarchyItem associated with the event.

See Also

HierarchyItemEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItem Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemEventArgs..::..HierarchyItem Property
HierarchyItemEventArgs Class See Also Send Feedback
The HierarchyItem associated with the event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem HierarchyItem { get; }
Visual Basic
Public ReadOnly Property HierarchyItem As HierarchyItem
    Get
Visual C++
public:
property HierarchyItem^ HierarchyItem {
    HierarchyItem^ get ();
}

See Also

HierarchyItemEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemFilter Structure

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemFilter Structure
Members See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public struct HierarchyItemFilter
Visual Basic
Public Structure HierarchyItemFilter
Visual C++
public value class HierarchyItemFilter

See Also

HierarchyItemFilter Members
VIBlend.WinForms.DataGridView Namespace


HierarchyItemFilter Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemFilter Members
HierarchyItemFilter Structure Methods Fields See Also Send Feedback

The HierarchyItemFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | Filter |
Public field | Item |

See Also

HierarchyItemFilter Structure
VIBlend.WinForms.DataGridView Namespace


HierarchyItemFilter Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemFilter Fields
HierarchyItemFilter Structure See Also Send Feedback

The HierarchyItemFilter type exposes the following members.

Fields

 | Name | Description
Public field | Filter |
Public field | Item |

See Also

HierarchyItemFilter Structure
VIBlend.WinForms.DataGridView Namespace


Filter Field

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemFilter..::..Filter Field
HierarchyItemFilter Structure See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public IFilterBase Filter
Visual Basic
Public Filter As IFilterBase
Visual C++
public:
IFilterBase^ Filter

See Also

HierarchyItemFilter Structure
VIBlend.WinForms.DataGridView Namespace


Item Field

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemFilter..::..Item Field
HierarchyItemFilter Structure See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem Item
Visual Basic
Public Item As HierarchyItem
Visual C++
public:
HierarchyItem^ Item

See Also

HierarchyItemFilter Structure
VIBlend.WinForms.DataGridView Namespace


HierarchyItemFilter Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemFilter Methods
HierarchyItemFilter Structure See Also Send Feedback

The HierarchyItemFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

HierarchyItemFilter Structure
VIBlend.WinForms.DataGridView Namespace


HierarchyItemMouseEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemMouseEventArgs Class
Members See Also Send Feedback
Represents a HierarchyItem mouse event argument.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class HierarchyItemMouseEventArgs : MouseEventArgs
Visual Basic
Public Class HierarchyItemMouseEventArgs _
    Inherits MouseEventArgs
Visual C++
public ref class HierarchyItemMouseEventArgs : public MouseEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.Windows.Forms..::..MouseEventArgs
VIBlend.WinForms.DataGridView..::..HierarchyItemMouseEventArgs

See Also

HierarchyItemMouseEventArgs Members
VIBlend.WinForms.DataGridView Namespace


HierarchyItemMouseEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemMouseEventArgs Members
HierarchyItemMouseEventArgs Class Constructors Methods Properties See Also Send Feedback

The HierarchyItemMouseEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | HierarchyItemMouseEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Button | Gets which mouse button was pressed. (Inherited from MouseEventArgs.)
Public property | Clicks | Gets the number of times the mouse button was pressed and released. (Inherited from MouseEventArgs.)
Public property | Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel. (Inherited from MouseEventArgs.)
Public property | HierarchyItem | The HierarchyItem associated with the event.
Public property | Location | Gets the location of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)
Public property | X | Gets the x-coordinate of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)
Public property | Y | Gets the y-coordinate of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)

See Also

HierarchyItemMouseEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemMouseEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemMouseEventArgs Constructor
HierarchyItemMouseEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemMouseEventArgs(
    HierarchyItem hierarchyItem,
    MouseEventArgs args
)
Visual Basic
Public Sub New ( _
    hierarchyItem As HierarchyItem, _
    args As MouseEventArgs _
)
Visual C++
public:
HierarchyItemMouseEventArgs(
    HierarchyItem^ hierarchyItem,
    MouseEventArgs^ args
)

Parameters

hierarchyItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
HierarchyItem associated with the event.
args
Type: System.Windows.Forms..::..MouseEventArgs

See Also

HierarchyItemMouseEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemMouseEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemMouseEventArgs Methods
HierarchyItemMouseEventArgs Class See Also Send Feedback

The HierarchyItemMouseEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HierarchyItemMouseEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemMouseEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemMouseEventArgs Properties
HierarchyItemMouseEventArgs Class See Also Send Feedback

The HierarchyItemMouseEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Button | Gets which mouse button was pressed. (Inherited from MouseEventArgs.)
Public property | Clicks | Gets the number of times the mouse button was pressed and released. (Inherited from MouseEventArgs.)
Public property | Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel. (Inherited from MouseEventArgs.)
Public property | HierarchyItem | The HierarchyItem associated with the event.
Public property | Location | Gets the location of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)
Public property | X | Gets the x-coordinate of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)
Public property | Y | Gets the y-coordinate of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)

See Also

HierarchyItemMouseEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItem Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemMouseEventArgs..::..HierarchyItem Property
HierarchyItemMouseEventArgs Class See Also Send Feedback
The HierarchyItem associated with the event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem HierarchyItem { get; protected set; }
Visual Basic
Public Property HierarchyItem As HierarchyItem
    Get
    Protected Set
Visual C++
public:
property HierarchyItem^ HierarchyItem {
    HierarchyItem^ get ();
    protected: void set (HierarchyItem^ value);
}

See Also

HierarchyItemMouseEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemPaintEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemPaintEventArgs Class
Members See Also Send Feedback
Represents a HierarchyItem paint event argument

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class HierarchyItemPaintEventArgs : EventArgs
Visual Basic
Public Class HierarchyItemPaintEventArgs _
    Inherits EventArgs
Visual C++
public ref class HierarchyItemPaintEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.DataGridView..::..HierarchyItemPaintEventArgs

See Also

HierarchyItemPaintEventArgs Members
VIBlend.WinForms.DataGridView Namespace


HierarchyItemPaintEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemPaintEventArgs Members
HierarchyItemPaintEventArgs Class Constructors Methods Properties See Also Send Feedback

The HierarchyItemPaintEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | HierarchyItemPaintEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bounds | The bounds of the paint area
Public property | Graphics | Refrence to GDI+ surface
Public property | Handled | Determines whether the painting was performed by the event handler and the grid should not perform further painting for the item
Public property | HierarchyItem | The HierarachyItem associated with the paint event.

See Also

HierarchyItemPaintEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemPaintEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemPaintEventArgs Constructor
HierarchyItemPaintEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemPaintEventArgs(
    HierarchyItem item,
    Rectangle bounds,
    Graphics graphics
)
Visual Basic
Public Sub New ( _
    item As HierarchyItem, _
    bounds As Rectangle, _
    graphics As Graphics _
)
Visual C++
public:
HierarchyItemPaintEventArgs(
    HierarchyItem^ item,
    Rectangle bounds,
    Graphics^ graphics
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
A HierarchyItem associated with the event.
bounds
Type: System.Drawing..::..Rectangle
The bounds of the the item's paint area.
graphics
Type: System.Drawing..::..Graphics
GDI+ surface

See Also

HierarchyItemPaintEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemPaintEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemPaintEventArgs Methods
HierarchyItemPaintEventArgs Class See Also Send Feedback

The HierarchyItemPaintEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HierarchyItemPaintEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemPaintEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemPaintEventArgs Properties
HierarchyItemPaintEventArgs Class See Also Send Feedback

The HierarchyItemPaintEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Bounds | The bounds of the paint area
Public property | Graphics | Refrence to GDI+ surface
Public property | Handled | Determines whether the painting was performed by the event handler and the grid should not perform further painting for the item
Public property | HierarchyItem | The HierarachyItem associated with the paint event.

See Also

HierarchyItemPaintEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Bounds Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemPaintEventArgs..::..Bounds Property
HierarchyItemPaintEventArgs Class See Also Send Feedback
The bounds of the paint area

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Rectangle Bounds { get; }
Visual Basic
Public ReadOnly Property Bounds As Rectangle
    Get
Visual C++
public:
property Rectangle Bounds {
    Rectangle get ();
}

See Also

HierarchyItemPaintEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Graphics Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemPaintEventArgs..::..Graphics Property
HierarchyItemPaintEventArgs Class See Also Send Feedback
Refrence to GDI+ surface

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Graphics Graphics { get; }
Visual Basic
Public ReadOnly Property Graphics As Graphics
    Get
Visual C++
public:
property Graphics^ Graphics {
    Graphics^ get ();
}

See Also

HierarchyItemPaintEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Handled Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemPaintEventArgs..::..Handled Property
HierarchyItemPaintEventArgs Class See Also Send Feedback
Determines whether the painting was performed by the event handler and the grid should not perform further painting for the item

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Handled { get; set; }
Visual Basic
Public Property Handled As Boolean
    Get
    Set
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

See Also

HierarchyItemPaintEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItem Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemPaintEventArgs..::..HierarchyItem Property
HierarchyItemPaintEventArgs Class See Also Send Feedback
The HierarachyItem associated with the paint event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem HierarchyItem { get; set; }
Visual Basic
Public Property HierarchyItem As HierarchyItem
    Get
    Set
Visual C++
public:
property HierarchyItem^ HierarchyItem {
    HierarchyItem^ get ();
    void set (HierarchyItem^ value);
}

See Also

HierarchyItemPaintEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemsCollection Class

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection Class
Members See Also Send Feedback
Represents a collection of HierarchyItems

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[SerializableAttribute]
public class HierarchyItemsCollection : IEnumerable<HierarchyItem>,
    IList, ICollection, IEnumerable
Visual Basic
<SerializableAttribute> _
Public Class HierarchyItemsCollection _
    Implements IEnumerable(Of HierarchyItem), IList,  _
    ICollection, IEnumerable
Visual C++
[SerializableAttribute]
public ref class HierarchyItemsCollection : IEnumerable<HierarchyItem^>,
    IList, ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..HierarchyItemsCollection

See Also

HierarchyItemsCollection Members
VIBlend.WinForms.DataGridView Namespace


HierarchyItemsCollection Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection Members
HierarchyItemsCollection Class Constructors Methods Fields Properties Events See Also Send Feedback

The HierarchyItemsCollection type exposes the following members.

Constructors

 | Name | Description
Public method | HierarchyItemsCollection | Constructor

Methods

 | Name | Description
Public method | Add(String) | Adds a new item to the collection
Public method | Add(HierarchyItem) | Adds a new item to the collection
Public method | Clear | Removes all items from the collection
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified Item and returns the zero-based index of the first occurrence within the entire collection
Public method | Insert | Inserts a HierarchyItem into the collection at the specified index
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event
Public method | Remove | Removes the first occurrence of a specific HierarchyItem from the collection
Public method | RemoveAt | Removes the HierarchyItem at the specified index of the collection
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ownerItem |
Public field | parentHierarchy |

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the collection
Public property | Item | Gets or sets the element at the specified index.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when the collection has changed

See Also

HierarchyItemsCollection Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemsCollection Constructor

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection Constructor
HierarchyItemsCollection Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemsCollection(
    HierarchyItem parentItem,
    Hierarchy parentHierarchy
)
Visual Basic
Public Sub New ( _
    parentItem As HierarchyItem, _
    parentHierarchy As Hierarchy _
)
Visual C++
public:
HierarchyItemsCollection(
    HierarchyItem^ parentItem,
    Hierarchy^ parentHierarchy
)

Parameters

parentItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
HierarchyItem which hosts the collection
parentHierarchy
Type: VIBlend.WinForms.DataGridView..::..Hierarchy
Hierarchy which hosts the collection

See Also

HierarchyItemsCollection Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemsCollection Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection Fields
HierarchyItemsCollection Class See Also Send Feedback

The HierarchyItemsCollection type exposes the following members.

Fields

 | Name | Description
Public field | ownerItem |
Public field | parentHierarchy |

See Also

HierarchyItemsCollection Class
VIBlend.WinForms.DataGridView Namespace


ownerItem Field

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection..::..ownerItem Field
HierarchyItemsCollection Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem ownerItem
Visual Basic
Public ownerItem As HierarchyItem
Visual C++
public:
HierarchyItem^ ownerItem

See Also

HierarchyItemsCollection Class
VIBlend.WinForms.DataGridView Namespace


parentHierarchy Field

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection..::..parentHierarchy Field
HierarchyItemsCollection Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Hierarchy parentHierarchy
Visual Basic
Public parentHierarchy As Hierarchy
Visual C++
public:
Hierarchy^ parentHierarchy

See Also

HierarchyItemsCollection Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemsCollection Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection Methods
HierarchyItemsCollection Class See Also Send Feedback

The HierarchyItemsCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add(String) | Adds a new item to the collection
Public method | Add(HierarchyItem) | Adds a new item to the collection
Public method | Clear | Removes all items from the collection
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified Item and returns the zero-based index of the first occurrence within the entire collection
Public method | Insert | Inserts a HierarchyItem into the collection at the specified index
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event
Public method | Remove | Removes the first occurrence of a specific HierarchyItem from the collection
Public method | RemoveAt | Removes the HierarchyItem at the specified index of the collection
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HierarchyItemsCollection Class
VIBlend.WinForms.DataGridView Namespace


Add Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection..::..Add Method
HierarchyItemsCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(String) | Adds a new item to the collection
Public method | Add(HierarchyItem) | Adds a new item to the collection

See Also

HierarchyItemsCollection Class
HierarchyItemsCollection Members
VIBlend.WinForms.DataGridView Namespace


Add Method (String)

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection..::..Add Method (String)
HierarchyItemsCollection Class See Also Send Feedback
Adds a new item to the collection

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual HierarchyItem Add(
    string ItemText
)
Visual Basic
Public Overridable Function Add ( _
    ItemText As String _
) As HierarchyItem
Visual C++
public:
virtual HierarchyItem^ Add(
    String^ ItemText
)

Parameters

ItemText
Type: System..::..String
Item text

Return Value

The method returns a reference to the HierarchyItem object which is added

See Also

HierarchyItemsCollection Class
Add Overload
VIBlend.WinForms.DataGridView Namespace


Add Method (HierarchyItem)

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection..::..Add Method (HierarchyItem)
HierarchyItemsCollection Class See Also Send Feedback
Adds a new item to the collection

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual HierarchyItem Add(
    HierarchyItem item
)
Visual Basic
Public Overridable Function Add ( _
    item As HierarchyItem _
) As HierarchyItem
Visual C++
public:
virtual HierarchyItem^ Add(
    HierarchyItem^ item
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Reference to the HierarchyItem object to add

Return Value

The method returns a reference to the HierarchyItem object which is added

See Also

HierarchyItemsCollection Class
Add Overload
VIBlend.WinForms.DataGridView Namespace


Clear Method

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection..::..Clear Method
HierarchyItemsCollection Class See Also Send Feedback
Removes all items from the collection

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

HierarchyItemsCollection Class
VIBlend.WinForms.DataGridView Namespace


GetEnumerator Method

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection..::..GetEnumerator Method
HierarchyItemsCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual IEnumerator<HierarchyItem> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of HierarchyItem)
Visual C++
public:
virtual IEnumerator<HierarchyItem^>^ GetEnumerator()

Return Value

An IEnumerator for the entire collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

HierarchyItemsCollection Class
VIBlend.WinForms.DataGridView Namespace


IndexOf Method

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection..::..IndexOf Method
HierarchyItemsCollection Class See Also Send Feedback
Searches for the specified Item and returns the zero-based index of the first occurrence within the entire collection

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual int IndexOf(
    HierarchyItem item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As HierarchyItem _
) As Integer
Visual C++
public:
virtual int IndexOf(
    HierarchyItem^ item
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The item to location in the collection

Return Value

The zero-based index of the first occurrence of item within the entire collection, if found; otherwise, -1.

See Also

HierarchyItemsCollection Class
VIBlend.WinForms.DataGridView Namespace


Insert Method

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection..::..Insert Method
HierarchyItemsCollection Class See Also Send Feedback
Inserts a HierarchyItem into the collection at the specified index

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void Insert(
    HierarchyItem item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As HierarchyItem, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    HierarchyItem^ item,
    int index
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
HierarchyItem to insert
index
Type: System..::..Int32
The zero-based index at which item should be inserted

See Also

HierarchyItemsCollection Class
VIBlend.WinForms.DataGridView Namespace


OnCollectionChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection..::..OnCollectionChanged Method
HierarchyItemsCollection Class See Also Send Feedback
Raises the CollectionChanged event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected void OnCollectionChanged()
Visual Basic
Protected Sub OnCollectionChanged
Visual C++
protected:
void OnCollectionChanged()

See Also

HierarchyItemsCollection Class
VIBlend.WinForms.DataGridView Namespace


Remove Method

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection..::..Remove Method
HierarchyItemsCollection Class See Also Send Feedback
Removes the first occurrence of a specific HierarchyItem from the collection

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void Remove(
    HierarchyItem item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As HierarchyItem _
)
Visual C++
public:
virtual void Remove(
    HierarchyItem^ item
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The HierarchyItem to remove from the collection

See Also

HierarchyItemsCollection Class
VIBlend.WinForms.DataGridView Namespace


RemoveAt Method

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection..::..RemoveAt Method
HierarchyItemsCollection Class See Also Send Feedback
Removes the HierarchyItem at the specified index of the collection

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the HierarchyItem to remove

See Also

HierarchyItemsCollection Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemsCollection Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection Properties
HierarchyItemsCollection Class See Also Send Feedback

The HierarchyItemsCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the collection
Public property | Item | Gets or sets the element at the specified index.

See Also

HierarchyItemsCollection Class
VIBlend.WinForms.DataGridView Namespace


Count Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection..::..Count Property
HierarchyItemsCollection Class See Also Send Feedback
Gets the number of elements actually contained in the collection

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Implements

ICollection..::..Count

See Also

HierarchyItemsCollection Class
VIBlend.WinForms.DataGridView Namespace


Item Property

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection..::..Item Property
HierarchyItemsCollection Class See Also Send Feedback
Gets or sets the element at the specified index.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual HierarchyItem this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As HierarchyItem
    Get
    Set
Visual C++
public:
virtual property HierarchyItem^ default[int index] {
    HierarchyItem^ get (int index);
    void set (int index, HierarchyItem^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get or set.

Return Value

The element at the specified index.

See Also

HierarchyItemsCollection Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemsCollection Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection Events
HierarchyItemsCollection Class See Also Send Feedback

The HierarchyItemsCollection type exposes the following members.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when the collection has changed

See Also

HierarchyItemsCollection Class
VIBlend.WinForms.DataGridView Namespace


CollectionChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
HierarchyItemsCollection..::..CollectionChanged Event
HierarchyItemsCollection Class See Also Send Feedback
Occurs when the collection has changed

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler CollectionChanged
Visual Basic
Public Event CollectionChanged As EventHandler
Visual C++
public:
 event EventHandler^ CollectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

HierarchyItemsCollection Class
VIBlend.WinForms.DataGridView Namespace


IEditor Interface

[image]

VIBlend Controls for WinForms Help Documentation
IEditor Interface
Members See Also Send Feedback
Grid cell editor interface definition

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public interface IEditor
Visual Basic
Public Interface IEditor
Visual C++
public interface class IEditor

See Also

IEditor Members
VIBlend.WinForms.DataGridView Namespace


IEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
IEditor Members
IEditor Interface Methods Properties See Also Send Feedback

The IEditor type exposes the following members.

Methods

 | Name | Description
Public method | DrawEditorControl | Handles the painting of the editor control
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Public method | OnGridKeyDown | Handles grid KeyDown events
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated

Properties

 | Name | Description
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | Control | Gets a reference to the underlying control of the editor
Public property | DeActivationFlags | Gets or sets the editor deactivation flags
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Gets or sets the current value of the editor.

See Also

IEditor Interface
VIBlend.WinForms.DataGridView Namespace


IEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
IEditor Methods
IEditor Interface See Also Send Feedback

The IEditor type exposes the following members.

Methods

 | Name | Description
Public method | DrawEditorControl | Handles the painting of the editor control
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Public method | OnGridKeyDown | Handles grid KeyDown events
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated

See Also

IEditor Interface
VIBlend.WinForms.DataGridView Namespace


DrawEditorControl Method

[image]

VIBlend Controls for WinForms Help Documentation
IEditor..::..DrawEditorControl Method
IEditor Interface See Also Send Feedback
Handles the painting of the editor control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
void DrawEditorControl(
    Graphics graphics,
    GridCell gridCell,
    out bool isDrawHandled
)
Visual Basic
Sub DrawEditorControl ( _
    graphics As Graphics, _
    gridCell As GridCell, _
    <OutAttribute> ByRef isDrawHandled As Boolean _
)
Visual C++
void DrawEditorControl(
    Graphics^ graphics,
    GridCell^ gridCell,
    [OutAttribute] bool% isDrawHandled
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Reference to the GDI+ surface
gridCell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the grid cell being rendered
isDrawHandled
Type: System..::..Boolean %
Output flag indicating whether the method handled the drawing or not

Remarks

This method is called everytime the grid has to render a cell associated with the editor and the editor is not activated. Use the method to customize the visual appearance of grid cell which are currently not being edited. If you want to skip the custom painting set the isDrawHandled flag to false. This will instruct the grid to format the cell's value using the respective format provider and format expression and render it as text, image or both.

See Also

IEditor Interface
VIBlend.WinForms.DataGridView Namespace


LayoutEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
IEditor..::..LayoutEditor Method
IEditor Interface See Also Send Feedback
This methods is called by the grid control when the editor must update its layout

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
void LayoutEditor(
    GridCell cell
)
Visual Basic
Sub LayoutEditor ( _
    cell As GridCell _
)
Visual C++
void LayoutEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the GridCell being edited

See Also

IEditor Interface
VIBlend.WinForms.DataGridView Namespace


OnCloseEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
IEditor..::..OnCloseEditor Method
IEditor Interface See Also Send Feedback
This method is called by the grid control when at the end of a cell edit operation

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
void OnCloseEditor()
Visual Basic
Sub OnCloseEditor
Visual C++
void OnCloseEditor()

Remarks

Use this method to implement your own cleanup or post edit operation

See Also

IEditor Interface
VIBlend.WinForms.DataGridView Namespace


OnGridKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
IEditor..::..OnGridKeyDown Method
IEditor Interface See Also Send Feedback
Handles grid KeyDown events

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
void OnGridKeyDown(
    KeyEventArgs args,
    GridCell cell,
    out bool closeEditor,
    out bool closeEditorAndSaveChanges
)
Visual Basic
Sub OnGridKeyDown ( _
    args As KeyEventArgs, _
    cell As GridCell, _
    <OutAttribute> ByRef closeEditor As Boolean, _
    <OutAttribute> ByRef closeEditorAndSaveChanges As Boolean _
)
Visual C++
void OnGridKeyDown(
    KeyEventArgs^ args,
    GridCell^ cell,
    [OutAttribute] bool% closeEditor,
    [OutAttribute] bool% closeEditorAndSaveChanges
)

Parameters

args
Type: System.Windows.Forms..::..KeyEventArgs
KeyDown event arguments
cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
The grid cell where the event occured. This may be null if the event did not occur within a grid cell.
closeEditor
Type: System..::..Boolean %
Output flag indicating whether to keep the editor open or close it instantly
closeEditorAndSaveChanges
Type: System..::..Boolean %

Remarks

This method is called by the grid to pass KeyDown events if the editor is currently open. Use this method to handle the KeyDown events and instruct the grid whether to keep the editor open

See Also

IEditor Interface
VIBlend.WinForms.DataGridView Namespace


OnOpenEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
IEditor..::..OnOpenEditor Method
IEditor Interface See Also Send Feedback
This method is called by the grid control when the editor is being activated

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
void OnOpenEditor(
    GridCell cell
)
Visual Basic
Sub OnOpenEditor ( _
    cell As GridCell _
)
Visual C++
void OnOpenEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the GridCell being edited

Remarks

Use this method to perform your own initialization

See Also

IEditor Interface
VIBlend.WinForms.DataGridView Namespace


IEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
IEditor Properties
IEditor Interface See Also Send Feedback

The IEditor type exposes the following members.

Properties

 | Name | Description
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | Control | Gets a reference to the underlying control of the editor
Public property | DeActivationFlags | Gets or sets the editor deactivation flags
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Gets or sets the current value of the editor.

See Also

IEditor Interface
VIBlend.WinForms.DataGridView Namespace


ActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
IEditor..::..ActivationFlags Property
IEditor Interface See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
EditorActivationFlags ActivationFlags { get; set; }
Visual Basic
Property ActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
property EditorActivationFlags ActivationFlags {
    EditorActivationFlags get ();
    void set (EditorActivationFlags value);
}

Remarks

A editor in GridView can be activated by mouse or keyboard events. For example a checkbox editor can be activated when the users moves the mouse over it. Use this property to specify the activation preferences for the editor.

See Also

IEditor Interface
VIBlend.WinForms.DataGridView Namespace


Control Property

[image]

VIBlend Controls for WinForms Help Documentation
IEditor..::..Control Property
IEditor Interface See Also Send Feedback
Gets a reference to the underlying control of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
Control Control { get; }
Visual Basic
ReadOnly Property Control As Control
    Get
Visual C++
property Control^ Control {
    Control^ get ();
}

See Also

IEditor Interface
VIBlend.WinForms.DataGridView Namespace


DeActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
IEditor..::..DeActivationFlags Property
IEditor Interface See Also Send Feedback
Gets or sets the editor deactivation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
EditorActivationFlags DeActivationFlags { get; set; }
Visual Basic
Property DeActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
property EditorActivationFlags DeActivationFlags {
    EditorActivationFlags get ();
    void set (EditorActivationFlags value);
}

Remarks

A editor in GridView can be deactivated by mouse or keyboard events. For example a checkbox editor can be deactivated when the users moves the mouse out of the cell where the checkbox is located. Use this property to specify the deactivation preferences for the editor.

See Also

IEditor Interface
VIBlend.WinForms.DataGridView Namespace


EditorType Property

[image]

VIBlend Controls for WinForms Help Documentation
IEditor..::..EditorType Property
IEditor Interface See Also Send Feedback
Gets the type of the grid cell editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
CellEditorType EditorType { get; }
Visual Basic
ReadOnly Property EditorType As CellEditorType
    Get
Visual C++
property CellEditorType EditorType {
    CellEditorType get ();
}

See Also

IEditor Interface
VIBlend.WinForms.DataGridView Namespace


EditorValue Property

[image]

VIBlend Controls for WinForms Help Documentation
IEditor..::..EditorValue Property
IEditor Interface See Also Send Feedback
Gets or sets the current value of the editor.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
Object EditorValue { get; set; }
Visual Basic
Property EditorValue As Object
    Get
    Set
Visual C++
property Object^ EditorValue {
    Object^ get ();
    void set (Object^ value);
}

Remarks

When the grid opens an editor it will set the EditorValue property with the value of the grid cell being edited. Once the edtior closes, the editor will use the EditorValue property to get the new value for the grid cell

See Also

IEditor Interface
VIBlend.WinForms.DataGridView Namespace


ImagePositions Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
ImagePositions Enumeration
See Also Send Feedback
Image positioning options

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum ImagePositions
Visual Basic
Public Enumeration ImagePositions
Visual C++
public enum class ImagePositions

Members

Member name | Description
Center |
Tile |
Stretch |

See Also

VIBlend.WinForms.DataGridView Namespace


LocalizationNames Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
LocalizationNames Enumeration
See Also Send Feedback
Represents the LocalizationNames enumeration.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum LocalizationNames
Visual Basic
Public Enumeration LocalizationNames
Visual C++
public enum class LocalizationNames

Members

Member name | Description
ContextMenuSortSmallestToLargest |
ContextMenuSortLargestToSmallest |
ContextMenuColumnChooser |
ContextMenuGroupByThisColumn |
ContextMenuRemoveSort |
ContextMenuFilter |
ContextMenuClearFilter |
FilterWindowOrRadioButton |
FilterWindowAndRadioButton |
FilterWindowOkButton |
FilterWindowCancelButton |
FilterWindowFilterBy |
FilterOperatorSelect |
FilterOperatorEqual |
FilterOperatorEqualCaseSensitive |
FilterOperatorNotEqual |
FilterOperatorLessThan |
FilterOperatorLessThanOrEqual |
FilterOperatorGreaterThan |
FilterOperatorGreaterThanOrEqual |
FilterOperatorIsNull |
FilterOperatorIsNotNull |
FilterOperatorIsEmpty |
FilterOperatorIsNotEmpty |
FilterOperatorContains |
FilterOperatorContainsCaseSensitive |
FilterOperatorDoesNotContain |
FilterOperatorDoesNotContainCaseSensitive |
FilterOperatorStartsWith |
FilterOperatorStartsWithCaseSensitive |
FilterOperatorEndsWith |
FilterOperatorEndsWithCaseSensitive |
FilterOperatorRegularExpression |
FilterValueText |
FilterShowRowsWhereText |
FilterCriteriaDefinition |
FilterButtonCustomFilter |
FilterButtonBasicFilter |
FilterItemsAllText |
FilterItemsBlanksText |
FilterItemsNullsText |
PivotTableSubTotalText |
PivotTableGrandTotalText |

See Also

VIBlend.WinForms.DataGridView Namespace


MaskEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
MaskEditor Class
Members See Also Send Feedback
Represents a Mask Editor.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class MaskEditor : vMaskedTextBox, IEditor
Visual Basic
Public Class MaskEditor _
    Inherits vMaskedTextBox _
    Implements IEditor
Visual C++
public ref class MaskEditor : public vMaskedTextBox,
    IEditor

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vMaskedTextBox
VIBlend.WinForms.DataGridView..::..MaskEditor

See Also

MaskEditor Members
VIBlend.WinForms.DataGridView Namespace


MaskEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
MaskEditor Members
MaskEditor Class Constructors Methods Properties Events See Also Send Feedback

The MaskEditor type exposes the following members.

Constructors

 | Name | Description
Public method | MaskEditor | Initializes a new instance of the MaskEditor class

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawEditorControl | Handles the painting of the editor control
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Public method | OnGridKeyDown | Handles grid KeyDown events
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vMaskedTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets a reference to the underlying control of the editor
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DeActivationFlags | Gets or sets the editor activation flags
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Public property | DefaultMask | Gets or sets the default mask of the vMaskedTextBox control. (Inherited from vMaskedTextBox.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamRadius | Gets or sets the radius of the gleam. (Inherited from vMaskedTextBox.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vMaskedTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Mask | Gets or sets the mask. (Inherited from vMaskedTextBox.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum length of the text in the textbox. (Inherited from vMaskedTextBox.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vMaskedTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vMaskedTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | PromptChar | Gets or sets the prompt char. (Inherited from vMaskedTextBox.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vMaskedTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vMaskedTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SyncBackColorWithParentBackColor | Gets or sets a value indicating whether to sync the back color with parent's back color. (Inherited from vMaskedTextBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vMaskedTextBox.)
Public property | TextBox | Gets a reference to the TextBox of the vMaskBox control (Inherited from vMaskedTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vMaskedTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vMaskedTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

MaskEditor Class
VIBlend.WinForms.DataGridView Namespace


MaskEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
MaskEditor Constructor
MaskEditor Class See Also Send Feedback
Initializes a new instance of the MaskEditor class

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public MaskEditor()
Visual Basic
Public Sub New
Visual C++
public:
MaskEditor()

See Also

MaskEditor Class
VIBlend.WinForms.DataGridView Namespace


MaskEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
MaskEditor Methods
MaskEditor Class See Also Send Feedback

The MaskEditor type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawEditorControl | Handles the painting of the editor control
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Public method | OnGridKeyDown | Handles grid KeyDown events
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

MaskEditor Class
VIBlend.WinForms.DataGridView Namespace


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..AccessibilityNotifyClients Method
MaskEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

MaskEditor Class
MaskEditor Members
VIBlend.WinForms.DataGridView Namespace


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..BeginInvoke Method
MaskEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

MaskEditor Class
MaskEditor Members
VIBlend.WinForms.DataGridView Namespace


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..Dispose Method
MaskEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

MaskEditor Class
MaskEditor Members
VIBlend.WinForms.DataGridView Namespace


DrawEditorControl Method

[image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..DrawEditorControl Method
MaskEditor Class See Also Send Feedback
Handles the painting of the editor control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawEditorControl(
    Graphics graphics,
    GridCell gridCell,
    out bool isDrawHandled
)
Visual Basic
Public Sub DrawEditorControl ( _
    graphics As Graphics, _
    gridCell As GridCell, _
    <OutAttribute> ByRef isDrawHandled As Boolean _
)
Visual C++
public:
virtual void DrawEditorControl(
    Graphics^ graphics,
    GridCell^ gridCell,
    [OutAttribute] bool% isDrawHandled
) sealed

Parameters

graphics
Type: System.Drawing..::..Graphics
Reference to the GDI+ surface
gridCell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the grid cell being rendered
isDrawHandled
Type: System..::..Boolean %
Output flag indicating whether the method handled the drawing or not

Implements

IEditor..::..DrawEditorControl(Graphics, GridCell, Boolean%)

See Also

MaskEditor Class
VIBlend.WinForms.DataGridView Namespace


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..GetChildAtPoint Method
MaskEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

MaskEditor Class
MaskEditor Members
VIBlend.WinForms.DataGridView Namespace


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..Invalidate Method
MaskEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

MaskEditor Class
MaskEditor Members
VIBlend.WinForms.DataGridView Namespace


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..Invoke Method
MaskEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

MaskEditor Class
MaskEditor Members
VIBlend.WinForms.DataGridView Namespace


LayoutEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..LayoutEditor Method
MaskEditor Class See Also Send Feedback
This methods is called by the grid control when the editor must update its layout

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void LayoutEditor(
    GridCell cell
)
Visual Basic
Public Overridable Sub LayoutEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void LayoutEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the GridCell being edited

Implements

IEditor..::..LayoutEditor(GridCell)

See Also

MaskEditor Class
VIBlend.WinForms.DataGridView Namespace


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..MemberwiseClone Method
MaskEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MaskEditor Class
MaskEditor Members
VIBlend.WinForms.DataGridView Namespace


OnCloseEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..OnCloseEditor Method
MaskEditor Class See Also Send Feedback
This method is called by the grid control when at the end of a cell edit operation

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnCloseEditor()
Visual Basic
Public Sub OnCloseEditor
Visual C++
public:
virtual void OnCloseEditor() sealed

Implements

IEditor..::..OnCloseEditor()()()()

See Also

MaskEditor Class
VIBlend.WinForms.DataGridView Namespace


OnGridKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..OnGridKeyDown Method
MaskEditor Class See Also Send Feedback
Handles grid KeyDown events

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnGridKeyDown(
    KeyEventArgs args,
    GridCell cell,
    out bool closeEditor,
    out bool closeEditorAndSaveChanges
)
Visual Basic
Public Sub OnGridKeyDown ( _
    args As KeyEventArgs, _
    cell As GridCell, _
    <OutAttribute> ByRef closeEditor As Boolean, _
    <OutAttribute> ByRef closeEditorAndSaveChanges As Boolean _
)
Visual C++
public:
virtual void OnGridKeyDown(
    KeyEventArgs^ args,
    GridCell^ cell,
    [OutAttribute] bool% closeEditor,
    [OutAttribute] bool% closeEditorAndSaveChanges
) sealed

Parameters

args
Type: System.Windows.Forms..::..KeyEventArgs
KeyDown event arguments
cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
closeEditor
Type: System..::..Boolean %
The grid cell where the event occured. This may be null if the event did not occur within a grid cell.Output flag indicating whether to keep the editor open or close it instantly
closeEditorAndSaveChanges
Type: System..::..Boolean %

Implements

IEditor..::..OnGridKeyDown(KeyEventArgs, GridCell, Boolean%, Boolean%)

See Also

MaskEditor Class
VIBlend.WinForms.DataGridView Namespace


OnOpenEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..OnOpenEditor Method
MaskEditor Class See Also Send Feedback
This method is called by the grid control when the editor is being activated

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnOpenEditor(
    GridCell cell
)
Visual Basic
Public Sub OnOpenEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void OnOpenEditor(
    GridCell^ cell
) sealed

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell

Implements

IEditor..::..OnOpenEditor(GridCell)

See Also

MaskEditor Class
VIBlend.WinForms.DataGridView Namespace


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..PerformLayout Method
MaskEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

MaskEditor Class
MaskEditor Members
VIBlend.WinForms.DataGridView Namespace


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..ResumeLayout Method
MaskEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

MaskEditor Class
MaskEditor Members
VIBlend.WinForms.DataGridView Namespace


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..RtlTranslateAlignment Method
MaskEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

MaskEditor Class
MaskEditor Members
VIBlend.WinForms.DataGridView Namespace


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..Scale Method
MaskEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

MaskEditor Class
MaskEditor Members
VIBlend.WinForms.DataGridView Namespace


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..Select Method
MaskEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

MaskEditor Class
MaskEditor Members
VIBlend.WinForms.DataGridView Namespace


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..SetBounds Method
MaskEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

MaskEditor Class
MaskEditor Members
VIBlend.WinForms.DataGridView Namespace


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..UpdateBounds Method
MaskEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

MaskEditor Class
MaskEditor Members
VIBlend.WinForms.DataGridView Namespace


MaskEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
MaskEditor Properties
MaskEditor Class See Also Send Feedback

The MaskEditor type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vMaskedTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets a reference to the underlying control of the editor
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DeActivationFlags | Gets or sets the editor activation flags
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Public property | DefaultMask | Gets or sets the default mask of the vMaskedTextBox control. (Inherited from vMaskedTextBox.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamRadius | Gets or sets the radius of the gleam. (Inherited from vMaskedTextBox.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vMaskedTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Mask | Gets or sets the mask. (Inherited from vMaskedTextBox.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum length of the text in the textbox. (Inherited from vMaskedTextBox.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vMaskedTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vMaskedTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | PromptChar | Gets or sets the prompt char. (Inherited from vMaskedTextBox.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vMaskedTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vMaskedTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SyncBackColorWithParentBackColor | Gets or sets a value indicating whether to sync the back color with parent's back color. (Inherited from vMaskedTextBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vMaskedTextBox.)
Public property | TextBox | Gets a reference to the TextBox of the vMaskBox control (Inherited from vMaskedTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vMaskedTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vMaskedTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

MaskEditor Class
VIBlend.WinForms.DataGridView Namespace


ActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..ActivationFlags Property
MaskEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags ActivationFlags { get; set; }
Visual Basic
Public Property ActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags ActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..ActivationFlags

See Also

MaskEditor Class
VIBlend.WinForms.DataGridView Namespace


Control Property

[image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..Control Property
MaskEditor Class See Also Send Feedback
Gets a reference to the underlying control of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control Control { get; }
Visual Basic
Public ReadOnly Property Control As Control
    Get
Visual C++
public:
virtual property Control^ Control {
    Control^ get () sealed;
}

Implements

IEditor..::..Control

See Also

MaskEditor Class
VIBlend.WinForms.DataGridView Namespace


DeActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..DeActivationFlags Property
MaskEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags DeActivationFlags { get; set; }
Visual Basic
Public Property DeActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags DeActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..DeActivationFlags

See Also

MaskEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorType Property

[image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..EditorType Property
MaskEditor Class See Also Send Feedback
Gets the type of the grid cell editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellEditorType EditorType { get; }
Visual Basic
Public ReadOnly Property EditorType As CellEditorType
    Get
Visual C++
public:
virtual property CellEditorType EditorType {
    CellEditorType get () sealed;
}

Implements

IEditor..::..EditorType

See Also

MaskEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorValue Property

[image]

VIBlend Controls for WinForms Help Documentation
MaskEditor..::..EditorValue Property
MaskEditor Class See Also Send Feedback
Get's or sets the current value of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object EditorValue { get; set; }
Visual Basic
Public Property EditorValue As Object
    Get
    Set
Visual C++
public:
virtual property Object^ EditorValue {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Implements

IEditor..::..EditorValue

See Also

MaskEditor Class
VIBlend.WinForms.DataGridView Namespace


MaskEditor Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
MaskEditor Events
MaskEditor Class See Also Send Feedback

The MaskEditor type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

MaskEditor Class
VIBlend.WinForms.DataGridView Namespace


NumberEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
NumberEditor Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class NumberEditor : vNumberEditor,
    IEditor
Visual Basic
Public Class NumberEditor _
    Inherits vNumberEditor _
    Implements IEditor
Visual C++
public ref class NumberEditor : public vNumberEditor,
    IEditor

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vTextBox
VIBlend.WinForms.Controls..::..InputBase
VIBlend.WinForms.Controls..::..vNumberEditor
VIBlend.WinForms.DataGridView..::..NumberEditor

See Also

NumberEditor Members
VIBlend.WinForms.DataGridView Namespace


NumberEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor Members
NumberEditor Class Constructors Methods Fields Properties Events See Also Send Feedback

The NumberEditor type exposes the following members.

Constructors

 | Name | Description
Public method | NumberEditor | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | (Inherited from vNumberEditor.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from InputBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | (Inherited from vNumberEditor.)
Protected method | CtrlV | (Inherited from vNumberEditor.)
Protected method | CtrlX | (Inherited from vNumberEditor.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | (Inherited from vNumberEditor.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key. (Inherited from InputBase.)
Public method | DrawEditorControl | Handles the painting of the editor control
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key. (Inherited from InputBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider. (Inherited from InputBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text. (Inherited from InputBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDefaultKeys | Handles the default keys.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key. (Inherited from InputBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | (Inherited from vNumberEditor.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown | (Inherited from InputBase.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed. (Inherited from InputBase.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Public method | LeftKey | Moves the cursor one position left. (Inherited from InputBase.)
Protected method | LoadEditorValue | Loads the editor value.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Public method | OnGridKeyDown | Handles grid KeyDown events
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the [E:KeyDown] event. (Overrides InputBase..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | (Inherited from InputBase.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from InputBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from vNumberEditor.)
Protected method | OnMouseWheel | (Inherited from InputBase.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | (Inherited from InputBase.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from InputBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event. (Inherited from InputBase.)
Protected method | OnValueChanged | Calls the ValueChanged event. (Inherited from InputBase.)
Protected method | OnValueChanging | Calls the ValueChanging event. (Inherited from InputBase.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | Parses editor's value. (Inherited from vNumberEditor.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | (Inherited from vNumberEditor.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters. (Inherited from InputBase.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key. (Inherited from InputBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | (Inherited from vNumberEditor.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit | (Inherited from InputBase.)
Protected method | SpinDigitWithWrap | Spins the digit with wrap. (Inherited from InputBase.)
Public method | SpinValue | Increases or decreases the current value. (Inherited from InputBase.)
Protected method | SpinValueBeforeDigit | Spins the value before digit. (Inherited from InputBase.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | Makes undo of the current value. (Inherited from vNumberEditor.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key. (Inherited from InputBase.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | baseFormatString | (Inherited from InputBase.)
Protected field | cultureInfo | (Inherited from InputBase.)
Protected field | decimalPlaces | (Inherited from InputBase.)
Protected field | decimalPossibleChars | (Inherited from InputBase.)
Protected field | emptyValue | (Inherited from InputBase.)
Protected field | formatString | (Inherited from InputBase.)
Protected field | isLessThanZero | (Inherited from InputBase.)
Protected field | manager | (Inherited from InputBase.)
Protected field | maximum | (Inherited from InputBase.)
Protected field | minimum | (Inherited from InputBase.)
Protected field | undoValue | (Inherited from InputBase.)
Protected field | value | (Inherited from InputBase.)
Protected field | valueString | (Inherited from InputBase.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets a reference to the underlying control of the editor
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information. (Inherited from InputBase.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DeActivationFlags | Gets or sets the editor activation flags
Public property | DecimalPlaces | Gets or sets editor's decimal places. (Inherited from InputBase.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EditCell | Gets the edit cell.
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HandleEnterKey | Gets or sets a value indicating whether to handle the enter and esc keys.
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator | (Inherited from InputBase.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value. (Inherited from InputBase.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value. (Inherited from InputBase.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | (Inherited from InputBase.)
Public property | Minimum | Gets or sets editor's Minimum value. (Inherited from InputBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | Gets the current separator character. (Inherited from vNumberEditor.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type. (Inherited from InputBase.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from InputBase.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from InputBase.)
Public property | Value | Gets or sets editor's value. (Inherited from InputBase.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed. (Inherited from InputBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event. (Inherited from InputBase.)
Public event | ValueChanged | Represents the ValueChanged event. (Inherited from InputBase.)
Public event | ValueChanging | Represents the ValueChanging event. (Inherited from InputBase.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


NumberEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
NumberEditor Constructor
NumberEditor Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public NumberEditor()
Visual Basic
Public Sub New
Visual C++
public:
NumberEditor()

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


NumberEditor Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor Fields
NumberEditor Class See Also Send Feedback

The NumberEditor type exposes the following members.

Fields

 | Name | Description
Protected field | baseFormatString | (Inherited from InputBase.)
Protected field | cultureInfo | (Inherited from InputBase.)
Protected field | decimalPlaces | (Inherited from InputBase.)
Protected field | decimalPossibleChars | (Inherited from InputBase.)
Protected field | emptyValue | (Inherited from InputBase.)
Protected field | formatString | (Inherited from InputBase.)
Protected field | isLessThanZero | (Inherited from InputBase.)
Protected field | manager | (Inherited from InputBase.)
Protected field | maximum | (Inherited from InputBase.)
Protected field | minimum | (Inherited from InputBase.)
Protected field | undoValue | (Inherited from InputBase.)
Protected field | value | (Inherited from InputBase.)
Protected field | valueString | (Inherited from InputBase.)

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


NumberEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor Methods
NumberEditor Class See Also Send Feedback

The NumberEditor type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | (Inherited from vNumberEditor.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from InputBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | (Inherited from vNumberEditor.)
Protected method | CtrlV | (Inherited from vNumberEditor.)
Protected method | CtrlX | (Inherited from vNumberEditor.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | (Inherited from vNumberEditor.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key. (Inherited from InputBase.)
Public method | DrawEditorControl | Handles the painting of the editor control
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key. (Inherited from InputBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider. (Inherited from InputBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text. (Inherited from InputBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDefaultKeys | Handles the default keys.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key. (Inherited from InputBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | (Inherited from vNumberEditor.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown | (Inherited from InputBase.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed. (Inherited from InputBase.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Public method | LeftKey | Moves the cursor one position left. (Inherited from InputBase.)
Protected method | LoadEditorValue | Loads the editor value.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Public method | OnGridKeyDown | Handles grid KeyDown events
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the [E:KeyDown] event. (Overrides InputBase..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | (Inherited from InputBase.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from InputBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from vNumberEditor.)
Protected method | OnMouseWheel | (Inherited from InputBase.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | (Inherited from InputBase.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from InputBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event. (Inherited from InputBase.)
Protected method | OnValueChanged | Calls the ValueChanged event. (Inherited from InputBase.)
Protected method | OnValueChanging | Calls the ValueChanging event. (Inherited from InputBase.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | Parses editor's value. (Inherited from vNumberEditor.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | (Inherited from vNumberEditor.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters. (Inherited from InputBase.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key. (Inherited from InputBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | (Inherited from vNumberEditor.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit | (Inherited from InputBase.)
Protected method | SpinDigitWithWrap | Spins the digit with wrap. (Inherited from InputBase.)
Public method | SpinValue | Increases or decreases the current value. (Inherited from InputBase.)
Protected method | SpinValueBeforeDigit | Spins the value before digit. (Inherited from InputBase.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | Makes undo of the current value. (Inherited from vNumberEditor.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key. (Inherited from InputBase.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..AccessibilityNotifyClients Method
NumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

NumberEditor Class
NumberEditor Members
VIBlend.WinForms.DataGridView Namespace


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..BeginInvoke Method
NumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

NumberEditor Class
NumberEditor Members
VIBlend.WinForms.DataGridView Namespace


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..Dispose Method
NumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

NumberEditor Class
NumberEditor Members
VIBlend.WinForms.DataGridView Namespace


DrawEditorControl Method

[image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..DrawEditorControl Method
NumberEditor Class See Also Send Feedback
Handles the painting of the editor control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawEditorControl(
    Graphics graphics,
    GridCell gridCell,
    out bool isDrawHandled
)
Visual Basic
Public Sub DrawEditorControl ( _
    graphics As Graphics, _
    gridCell As GridCell, _
    <OutAttribute> ByRef isDrawHandled As Boolean _
)
Visual C++
public:
virtual void DrawEditorControl(
    Graphics^ graphics,
    GridCell^ gridCell,
    [OutAttribute] bool% isDrawHandled
) sealed

Parameters

graphics
Type: System.Drawing..::..Graphics
Reference to the GDI+ surface
gridCell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the grid cell being rendered
isDrawHandled
Type: System..::..Boolean %
Output flag indicating whether the method handled the drawing or not

Implements

IEditor..::..DrawEditorControl(Graphics, GridCell, Boolean%)

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..GetChildAtPoint Method
NumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

NumberEditor Class
NumberEditor Members
VIBlend.WinForms.DataGridView Namespace


HandleDefaultKeys Method

[image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..HandleDefaultKeys Method
NumberEditor Class See Also Send Feedback
Handles the default keys.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void HandleDefaultKeys(
    KeyEventArgs e
)
Visual Basic
Protected Overridable Sub HandleDefaultKeys ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void HandleDefaultKeys(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
The KeyEventArgs instance containing the event data.

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..Invalidate Method
NumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

NumberEditor Class
NumberEditor Members
VIBlend.WinForms.DataGridView Namespace


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..Invoke Method
NumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

NumberEditor Class
NumberEditor Members
VIBlend.WinForms.DataGridView Namespace


LayoutEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..LayoutEditor Method
NumberEditor Class See Also Send Feedback
This methods is called by the grid control when the editor must update its layout

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void LayoutEditor(
    GridCell cell
)
Visual Basic
Public Overridable Sub LayoutEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void LayoutEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the GridCell being edited

Implements

IEditor..::..LayoutEditor(GridCell)

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


LoadEditorValue Method

[image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..LoadEditorValue Method
NumberEditor Class See Also Send Feedback
Loads the editor value.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void LoadEditorValue()
Visual Basic
Protected Overridable Sub LoadEditorValue
Visual C++
protected:
virtual void LoadEditorValue()

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..MemberwiseClone Method
NumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

NumberEditor Class
NumberEditor Members
VIBlend.WinForms.DataGridView Namespace


OnCloseEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..OnCloseEditor Method
NumberEditor Class See Also Send Feedback
This method is called by the grid control when at the end of a cell edit operation

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnCloseEditor()
Visual Basic
Public Sub OnCloseEditor
Visual C++
public:
virtual void OnCloseEditor() sealed

Implements

IEditor..::..OnCloseEditor()()()()

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


OnGridKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..OnGridKeyDown Method
NumberEditor Class See Also Send Feedback
Handles grid KeyDown events

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnGridKeyDown(
    KeyEventArgs args,
    GridCell cell,
    out bool closeEditor,
    out bool closeEditorAndSaveChanges
)
Visual Basic
Public Sub OnGridKeyDown ( _
    args As KeyEventArgs, _
    cell As GridCell, _
    <OutAttribute> ByRef closeEditor As Boolean, _
    <OutAttribute> ByRef closeEditorAndSaveChanges As Boolean _
)
Visual C++
public:
virtual void OnGridKeyDown(
    KeyEventArgs^ args,
    GridCell^ cell,
    [OutAttribute] bool% closeEditor,
    [OutAttribute] bool% closeEditorAndSaveChanges
) sealed

Parameters

args
Type: System.Windows.Forms..::..KeyEventArgs
KeyDown event arguments
cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
closeEditor
Type: System..::..Boolean %
The grid cell where the event occured. This may be null if the event did not occur within a grid cell.Output flag indicating whether to keep the editor open or close it instantly
closeEditorAndSaveChanges
Type: System..::..Boolean %

Implements

IEditor..::..OnGridKeyDown(KeyEventArgs, GridCell, Boolean%, Boolean%)

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


OnKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..OnKeyDown Method
NumberEditor Class See Also Send Feedback
Raises the [E:KeyDown] event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
The KeyEventArgs instance containing the event data.

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


OnOpenEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..OnOpenEditor Method
NumberEditor Class See Also Send Feedback
This method is called by the grid control when the editor is being activated

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnOpenEditor(
    GridCell cell
)
Visual Basic
Public Sub OnOpenEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void OnOpenEditor(
    GridCell^ cell
) sealed

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell

Implements

IEditor..::..OnOpenEditor(GridCell)

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..PerformLayout Method
NumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

NumberEditor Class
NumberEditor Members
VIBlend.WinForms.DataGridView Namespace


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..ResumeLayout Method
NumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

NumberEditor Class
NumberEditor Members
VIBlend.WinForms.DataGridView Namespace


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..RtlTranslateAlignment Method
NumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

NumberEditor Class
NumberEditor Members
VIBlend.WinForms.DataGridView Namespace


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..Scale Method
NumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

NumberEditor Class
NumberEditor Members
VIBlend.WinForms.DataGridView Namespace


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..Select Method
NumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

NumberEditor Class
NumberEditor Members
VIBlend.WinForms.DataGridView Namespace


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..SetBounds Method
NumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

NumberEditor Class
NumberEditor Members
VIBlend.WinForms.DataGridView Namespace


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..UpdateBounds Method
NumberEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

NumberEditor Class
NumberEditor Members
VIBlend.WinForms.DataGridView Namespace


NumberEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor Properties
NumberEditor Class See Also Send Feedback

The NumberEditor type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets a reference to the underlying control of the editor
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information. (Inherited from InputBase.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DeActivationFlags | Gets or sets the editor activation flags
Public property | DecimalPlaces | Gets or sets editor's decimal places. (Inherited from InputBase.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EditCell | Gets the edit cell.
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HandleEnterKey | Gets or sets a value indicating whether to handle the enter and esc keys.
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator | (Inherited from InputBase.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value. (Inherited from InputBase.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value. (Inherited from InputBase.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | (Inherited from InputBase.)
Public property | Minimum | Gets or sets editor's Minimum value. (Inherited from InputBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | Gets the current separator character. (Inherited from vNumberEditor.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type. (Inherited from InputBase.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from InputBase.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from InputBase.)
Public property | Value | Gets or sets editor's value. (Inherited from InputBase.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


ActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..ActivationFlags Property
NumberEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags ActivationFlags { get; set; }
Visual Basic
Public Property ActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags ActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..ActivationFlags

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


Control Property

[image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..Control Property
NumberEditor Class See Also Send Feedback
Gets a reference to the underlying control of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control Control { get; }
Visual Basic
Public ReadOnly Property Control As Control
    Get
Visual C++
public:
virtual property Control^ Control {
    Control^ get () sealed;
}

Implements

IEditor..::..Control

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


DeActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..DeActivationFlags Property
NumberEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags DeActivationFlags { get; set; }
Visual Basic
Public Property DeActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags DeActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..DeActivationFlags

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


EditCell Property

[image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..EditCell Property
NumberEditor Class See Also Send Feedback
Gets the edit cell.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell EditCell { get; }
Visual Basic
Public ReadOnly Property EditCell As GridCell
    Get
Visual C++
public:
property GridCell^ EditCell {
    GridCell^ get ();
}

Field Value

The edit cell.

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorType Property

[image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..EditorType Property
NumberEditor Class See Also Send Feedback
Gets the type of the grid cell editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellEditorType EditorType { get; }
Visual Basic
Public ReadOnly Property EditorType As CellEditorType
    Get
Visual C++
public:
virtual property CellEditorType EditorType {
    CellEditorType get () sealed;
}

Implements

IEditor..::..EditorType

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorValue Property

[image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..EditorValue Property
NumberEditor Class See Also Send Feedback
Get's or sets the current value of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object EditorValue { get; set; }
Visual Basic
Public Property EditorValue As Object
    Get
    Set
Visual C++
public:
virtual property Object^ EditorValue {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Implements

IEditor..::..EditorValue

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


HandleEnterKey Property

[image]

VIBlend Controls for WinForms Help Documentation
NumberEditor..::..HandleEnterKey Property
NumberEditor Class See Also Send Feedback
Gets or sets a value indicating whether to handle the enter and esc keys.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool HandleEnterKey { get; set; }
Visual Basic
Public Property HandleEnterKey As Boolean
    Get
    Set
Visual C++
public:
property bool HandleEnterKey {
    bool get ();
    void set (bool value);
}

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


NumberEditor Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumberEditor Events
NumberEditor Class See Also Send Feedback

The NumberEditor type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed. (Inherited from InputBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event. (Inherited from InputBase.)
Public event | ValueChanged | Represents the ValueChanged event. (Inherited from InputBase.)
Public event | ValueChanging | Represents the ValueChanging event. (Inherited from InputBase.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

NumberEditor Class
VIBlend.WinForms.DataGridView Namespace


NumericUpDownEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor Class
Members See Also Send Feedback
Represents a NumericUpDownEditor used in the GridView control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class NumericUpDownEditor : vNumericUpDown,
    IEditor
Visual Basic
Public Class NumericUpDownEditor _
    Inherits vNumericUpDown _
    Implements IEditor
Visual C++
public ref class NumericUpDownEditor : public vNumericUpDown,
    IEditor

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
vControlBase
vEditorControlBase
vButtonEditBase
vNumericUpDownBase
VIBlend.WinForms.Controls..::..vNumericUpDown
VIBlend.WinForms.DataGridView..::..NumericUpDownEditor

See Also

NumericUpDownEditor Members
VIBlend.WinForms.DataGridView Namespace


NumericUpDownEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor Members
NumericUpDownEditor Class Constructors Methods Properties Events See Also Send Feedback

The NumericUpDownEditor type exposes the following members.

Constructors

 | Name | Description
Public method | NumericUpDownEditor | Initializes a new instance of the NumericUpDownEditor class

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawEditorControl | Handles the painting of the editor control
Protected method | DrawSpin | Draws the spin. (Inherited from vNumericUpDown.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetArrowColor | Gets the color of the arrow. (Inherited from vNumericUpDown.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDownClick | Overriden from vSpinControlBase (Inherited from vNumericUpDown.)
Protected method | HandleUpClick | Overriden from vSpinControlBase (Inherited from vNumericUpDown.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Public method | OnGridKeyDown | Handles grid KeyDown events
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event (Inherited from vNumericUpDown.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Raises the ValueChanged event. (Inherited from vNumericUpDown.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SpinValue | Spins the value. (Inherited from vNumericUpDown.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | AllowAnimations | Determines whether the control is animated (Inherited from vNumericUpDown.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets a reference to the underlying control of the editor
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DeActivationFlags | Gets or sets the editor activation flags
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | Increment | Gets or sets the increment step. (Inherited from vNumericUpDown.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the maximum value. (Inherited from vNumericUpDown.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the minimum value. (Inherited from vNumericUpDown.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the edit field of the spin control. (Inherited from vNumericUpDown.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vNumericUpDown.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control. (Inherited from vNumericUpDown.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vNumericUpDown.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when the Value property changes. (Inherited from vNumericUpDown.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

NumericUpDownEditor Class
VIBlend.WinForms.DataGridView Namespace


NumericUpDownEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor Constructor
NumericUpDownEditor Class See Also Send Feedback
Initializes a new instance of the NumericUpDownEditor class

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public NumericUpDownEditor()
Visual Basic
Public Sub New
Visual C++
public:
NumericUpDownEditor()

See Also

NumericUpDownEditor Class
VIBlend.WinForms.DataGridView Namespace


NumericUpDownEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor Methods
NumericUpDownEditor Class See Also Send Feedback

The NumericUpDownEditor type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawEditorControl | Handles the painting of the editor control
Protected method | DrawSpin | Draws the spin. (Inherited from vNumericUpDown.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetArrowColor | Gets the color of the arrow. (Inherited from vNumericUpDown.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDownClick | Overriden from vSpinControlBase (Inherited from vNumericUpDown.)
Protected method | HandleUpClick | Overriden from vSpinControlBase (Inherited from vNumericUpDown.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Public method | OnGridKeyDown | Handles grid KeyDown events
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the OnPaint event (Inherited from vNumericUpDown.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValueChanged | Raises the ValueChanged event. (Inherited from vNumericUpDown.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SpinValue | Spins the value. (Inherited from vNumericUpDown.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

NumericUpDownEditor Class
VIBlend.WinForms.DataGridView Namespace


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..AccessibilityNotifyClients Method
NumericUpDownEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

NumericUpDownEditor Class
NumericUpDownEditor Members
VIBlend.WinForms.DataGridView Namespace


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..BeginInvoke Method
NumericUpDownEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

NumericUpDownEditor Class
NumericUpDownEditor Members
VIBlend.WinForms.DataGridView Namespace


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..Dispose Method
NumericUpDownEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

NumericUpDownEditor Class
NumericUpDownEditor Members
VIBlend.WinForms.DataGridView Namespace


DrawEditorControl Method

[image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..DrawEditorControl Method
NumericUpDownEditor Class See Also Send Feedback
Handles the painting of the editor control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawEditorControl(
    Graphics graphics,
    GridCell gridCell,
    out bool isDrawHandled
)
Visual Basic
Public Sub DrawEditorControl ( _
    graphics As Graphics, _
    gridCell As GridCell, _
    <OutAttribute> ByRef isDrawHandled As Boolean _
)
Visual C++
public:
virtual void DrawEditorControl(
    Graphics^ graphics,
    GridCell^ gridCell,
    [OutAttribute] bool% isDrawHandled
) sealed

Parameters

graphics
Type: System.Drawing..::..Graphics
Reference to the GDI+ surface
gridCell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the grid cell being rendered
isDrawHandled
Type: System..::..Boolean %
Output flag indicating whether the method handled the drawing or not

Implements

IEditor..::..DrawEditorControl(Graphics, GridCell, Boolean%)

See Also

NumericUpDownEditor Class
VIBlend.WinForms.DataGridView Namespace


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..GetChildAtPoint Method
NumericUpDownEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

NumericUpDownEditor Class
NumericUpDownEditor Members
VIBlend.WinForms.DataGridView Namespace


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..Invalidate Method
NumericUpDownEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

NumericUpDownEditor Class
NumericUpDownEditor Members
VIBlend.WinForms.DataGridView Namespace


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..Invoke Method
NumericUpDownEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

NumericUpDownEditor Class
NumericUpDownEditor Members
VIBlend.WinForms.DataGridView Namespace


LayoutEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..LayoutEditor Method
NumericUpDownEditor Class See Also Send Feedback
This methods is called by the grid control when the editor must update its layout

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void LayoutEditor(
    GridCell cell
)
Visual Basic
Public Overridable Sub LayoutEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void LayoutEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the GridCell being edited

Implements

IEditor..::..LayoutEditor(GridCell)

See Also

NumericUpDownEditor Class
VIBlend.WinForms.DataGridView Namespace


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..MemberwiseClone Method
NumericUpDownEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

NumericUpDownEditor Class
NumericUpDownEditor Members
VIBlend.WinForms.DataGridView Namespace


OnCloseEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..OnCloseEditor Method
NumericUpDownEditor Class See Also Send Feedback
This method is called by the grid control when at the end of a cell edit operation

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnCloseEditor()
Visual Basic
Public Sub OnCloseEditor
Visual C++
public:
virtual void OnCloseEditor() sealed

Implements

IEditor..::..OnCloseEditor()()()()

See Also

NumericUpDownEditor Class
VIBlend.WinForms.DataGridView Namespace


OnGridKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..OnGridKeyDown Method
NumericUpDownEditor Class See Also Send Feedback
Handles grid KeyDown events

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnGridKeyDown(
    KeyEventArgs args,
    GridCell cell,
    out bool closeEditor,
    out bool closeEditorAndSaveChanges
)
Visual Basic
Public Sub OnGridKeyDown ( _
    args As KeyEventArgs, _
    cell As GridCell, _
    <OutAttribute> ByRef closeEditor As Boolean, _
    <OutAttribute> ByRef closeEditorAndSaveChanges As Boolean _
)
Visual C++
public:
virtual void OnGridKeyDown(
    KeyEventArgs^ args,
    GridCell^ cell,
    [OutAttribute] bool% closeEditor,
    [OutAttribute] bool% closeEditorAndSaveChanges
) sealed

Parameters

args
Type: System.Windows.Forms..::..KeyEventArgs
KeyDown event arguments
cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
closeEditor
Type: System..::..Boolean %
The grid cell where the event occured. This may be null if the event did not occur within a grid cell.Output flag indicating whether to keep the editor open or close it instantly
closeEditorAndSaveChanges
Type: System..::..Boolean %

Implements

IEditor..::..OnGridKeyDown(KeyEventArgs, GridCell, Boolean%, Boolean%)

See Also

NumericUpDownEditor Class
VIBlend.WinForms.DataGridView Namespace


OnOpenEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..OnOpenEditor Method
NumericUpDownEditor Class See Also Send Feedback
This method is called by the grid control when the editor is being activated

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnOpenEditor(
    GridCell cell
)
Visual Basic
Public Sub OnOpenEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void OnOpenEditor(
    GridCell^ cell
) sealed

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell

Implements

IEditor..::..OnOpenEditor(GridCell)

See Also

NumericUpDownEditor Class
VIBlend.WinForms.DataGridView Namespace


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..PerformLayout Method
NumericUpDownEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

NumericUpDownEditor Class
NumericUpDownEditor Members
VIBlend.WinForms.DataGridView Namespace


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..ResumeLayout Method
NumericUpDownEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

NumericUpDownEditor Class
NumericUpDownEditor Members
VIBlend.WinForms.DataGridView Namespace


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..RtlTranslateAlignment Method
NumericUpDownEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

NumericUpDownEditor Class
NumericUpDownEditor Members
VIBlend.WinForms.DataGridView Namespace


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..Scale Method
NumericUpDownEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

NumericUpDownEditor Class
NumericUpDownEditor Members
VIBlend.WinForms.DataGridView Namespace


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..Select Method
NumericUpDownEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

NumericUpDownEditor Class
NumericUpDownEditor Members
VIBlend.WinForms.DataGridView Namespace


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..SetBounds Method
NumericUpDownEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

NumericUpDownEditor Class
NumericUpDownEditor Members
VIBlend.WinForms.DataGridView Namespace


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..UpdateBounds Method
NumericUpDownEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

NumericUpDownEditor Class
NumericUpDownEditor Members
VIBlend.WinForms.DataGridView Namespace


NumericUpDownEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor Properties
NumericUpDownEditor Class See Also Send Feedback

The NumericUpDownEditor type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | AllowAnimations | Determines whether the control is animated (Inherited from vNumericUpDown.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets a reference to the underlying control of the editor
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DeActivationFlags | Gets or sets the editor activation flags
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | Increment | Gets or sets the increment step. (Inherited from vNumericUpDown.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the maximum value. (Inherited from vNumericUpDown.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the minimum value. (Inherited from vNumericUpDown.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the edit field of the spin control. (Inherited from vNumericUpDown.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vNumericUpDown.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the value of the control. (Inherited from vNumericUpDown.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vNumericUpDown.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

NumericUpDownEditor Class
VIBlend.WinForms.DataGridView Namespace


ActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..ActivationFlags Property
NumericUpDownEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags ActivationFlags { get; set; }
Visual Basic
Public Property ActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags ActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..ActivationFlags

See Also

NumericUpDownEditor Class
VIBlend.WinForms.DataGridView Namespace


Control Property

[image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..Control Property
NumericUpDownEditor Class See Also Send Feedback
Gets a reference to the underlying control of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control Control { get; }
Visual Basic
Public ReadOnly Property Control As Control
    Get
Visual C++
public:
virtual property Control^ Control {
    Control^ get () sealed;
}

Implements

IEditor..::..Control

See Also

NumericUpDownEditor Class
VIBlend.WinForms.DataGridView Namespace


DeActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..DeActivationFlags Property
NumericUpDownEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags DeActivationFlags { get; set; }
Visual Basic
Public Property DeActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags DeActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..DeActivationFlags

See Also

NumericUpDownEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorType Property

[image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..EditorType Property
NumericUpDownEditor Class See Also Send Feedback
Gets the type of the grid cell editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellEditorType EditorType { get; }
Visual Basic
Public ReadOnly Property EditorType As CellEditorType
    Get
Visual C++
public:
virtual property CellEditorType EditorType {
    CellEditorType get () sealed;
}

Implements

IEditor..::..EditorType

See Also

NumericUpDownEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorValue Property

[image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor..::..EditorValue Property
NumericUpDownEditor Class See Also Send Feedback
Get's or sets the current value of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object EditorValue { get; set; }
Visual Basic
Public Property EditorValue As Object
    Get
    Set
Visual C++
public:
virtual property Object^ EditorValue {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Implements

IEditor..::..EditorValue

See Also

NumericUpDownEditor Class
VIBlend.WinForms.DataGridView Namespace


NumericUpDownEditor Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericUpDownEditor Events
NumericUpDownEditor Class See Also Send Feedback

The NumericUpDownEditor type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueChanged | Occurs when the Value property changes. (Inherited from vNumericUpDown.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

NumericUpDownEditor Class
VIBlend.WinForms.DataGridView Namespace


PercentageEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class PercentageEditor : vPercentageEditor,
    IEditor
Visual Basic
Public Class PercentageEditor _
    Inherits vPercentageEditor _
    Implements IEditor
Visual C++
public ref class PercentageEditor : public vPercentageEditor,
    IEditor

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vTextBox
VIBlend.WinForms.Controls..::..InputBase
VIBlend.WinForms.Controls..::..vPercentageEditor
VIBlend.WinForms.DataGridView..::..PercentageEditor

See Also

PercentageEditor Members
VIBlend.WinForms.DataGridView Namespace


PercentageEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor Members
PercentageEditor Class Constructors Methods Fields Properties Events See Also Send Feedback

The PercentageEditor type exposes the following members.

Constructors

 | Name | Description
Public method | PercentageEditor | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | Simulates BackSpace. (Inherited from vPercentageEditor.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from InputBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | Executes the Ctrl + C command. (Inherited from vPercentageEditor.)
Protected method | CtrlV | Executes the Ctrl + V command. (Inherited from vPercentageEditor.)
Protected method | CtrlX | Executes the Ctrl + X command. (Inherited from vPercentageEditor.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | Deletes the selected value. (Inherited from vPercentageEditor.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key. (Inherited from InputBase.)
Public method | DrawEditorControl | Handles the painting of the editor control
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key. (Inherited from InputBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider. (Inherited from InputBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text. (Inherited from InputBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDefaultKeys | Handles the default keys.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key. (Inherited from InputBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | Inserts a string into the editor. (Inherited from vPercentageEditor.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown | (Inherited from InputBase.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed. (Inherited from InputBase.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Public method | LeftKey | Moves the cursor one position left. (Inherited from InputBase.)
Protected method | LoadEditorValue | Loads the editor value.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Public method | OnGridKeyDown | Handles grid KeyDown events
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the [E:KeyDown] event. (Overrides InputBase..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | (Inherited from InputBase.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from InputBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from vPercentageEditor.)
Protected method | OnMouseWheel | (Inherited from InputBase.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | (Inherited from InputBase.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from InputBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event. (Inherited from InputBase.)
Protected method | OnValueChanged | Calls the ValueChanged event. (Inherited from InputBase.)
Protected method | OnValueChanging | Calls the ValueChanging event. (Inherited from InputBase.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | Parses editor's value. (Inherited from vPercentageEditor.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | Redoes this instance. (Inherited from vPercentageEditor.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters. (Inherited from InputBase.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key. (Inherited from InputBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | Formats editor's text. (Inherited from vPercentageEditor.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit | (Inherited from InputBase.)
Protected method | SpinDigitWithWrap | Spins the digit with wrap. (Inherited from InputBase.)
Public method | SpinValue | Increases or decreases the current value. (Inherited from InputBase.)
Protected method | SpinValueBeforeDigit | Spins the value before digit. (Inherited from InputBase.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | Makes undo of the current value. (Inherited from vPercentageEditor.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key. (Inherited from InputBase.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

 | Name | Description
Protected field | baseFormatString | (Inherited from InputBase.)
Protected field | cultureInfo | (Inherited from InputBase.)
Protected field | decimalPlaces | (Inherited from InputBase.)
Protected field | decimalPossibleChars | (Inherited from InputBase.)
Protected field | emptyValue | (Inherited from InputBase.)
Protected field | formatString | (Inherited from InputBase.)
Protected field | isLessThanZero | (Inherited from InputBase.)
Protected field | manager | (Inherited from InputBase.)
Protected field | maximum | (Inherited from InputBase.)
Protected field | minimum | (Inherited from InputBase.)
Protected field | undoValue | (Inherited from InputBase.)
Protected field | value | (Inherited from InputBase.)
Protected field | valueString | (Inherited from InputBase.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets a reference to the underlying control of the editor
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information. (Inherited from InputBase.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DeActivationFlags | Gets or sets the editor activation flags
Public property | DecimalPlaces | Gets or sets editor's decimal places. (Inherited from InputBase.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EditCell | Gets the edit cell.
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HandleEnterKey | Gets or sets a value indicating whether to handle the enter and esc keys.
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator | (Inherited from InputBase.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value. (Inherited from InputBase.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value. (Inherited from InputBase.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | (Inherited from InputBase.)
Public property | Minimum | Gets or sets editor's Minimum value. (Inherited from InputBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | Gets the current separator character. (Inherited from vPercentageEditor.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type. (Inherited from InputBase.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from InputBase.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from InputBase.)
Public property | Value | Gets or sets editor's value. (Inherited from InputBase.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed. (Inherited from InputBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event. (Inherited from InputBase.)
Public event | ValueChanged | Represents the ValueChanged event. (Inherited from InputBase.)
Public event | ValueChanging | Represents the ValueChanging event. (Inherited from InputBase.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


PercentageEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor Constructor
PercentageEditor Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public PercentageEditor()
Visual Basic
Public Sub New
Visual C++
public:
PercentageEditor()

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


PercentageEditor Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor Fields
PercentageEditor Class See Also Send Feedback

The PercentageEditor type exposes the following members.

Fields

 | Name | Description
Protected field | baseFormatString | (Inherited from InputBase.)
Protected field | cultureInfo | (Inherited from InputBase.)
Protected field | decimalPlaces | (Inherited from InputBase.)
Protected field | decimalPossibleChars | (Inherited from InputBase.)
Protected field | emptyValue | (Inherited from InputBase.)
Protected field | formatString | (Inherited from InputBase.)
Protected field | isLessThanZero | (Inherited from InputBase.)
Protected field | manager | (Inherited from InputBase.)
Protected field | maximum | (Inherited from InputBase.)
Protected field | minimum | (Inherited from InputBase.)
Protected field | undoValue | (Inherited from InputBase.)
Protected field | value | (Inherited from InputBase.)
Protected field | valueString | (Inherited from InputBase.)

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


PercentageEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor Methods
PercentageEditor Class See Also Send Feedback

The PercentageEditor type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Backspace | Simulates BackSpace. (Inherited from vPercentageEditor.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from InputBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CtrlC | Executes the Ctrl + C command. (Inherited from vPercentageEditor.)
Protected method | CtrlV | Executes the Ctrl + V command. (Inherited from vPercentageEditor.)
Protected method | CtrlX | Executes the Ctrl + X command. (Inherited from vPercentageEditor.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Public method | Delete | Deletes the selected value. (Inherited from vPercentageEditor.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DownKey | Simulates pressing of down arrow key. (Inherited from InputBase.)
Public method | DrawEditorControl | Handles the painting of the editor control
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndKey | Simulates pressing of End key. (Inherited from InputBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetDefaultValidationErrorProvider | Gets the default validation error provider. (Inherited from InputBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetPureText | Gets editor's text. (Inherited from InputBase.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleDefaultKeys | Handles the default keys.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HomeKey | Simulates pressing of Home key. (Inherited from InputBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Insert | Inserts a string into the editor. (Inherited from vPercentageEditor.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Public method | IsCtrlDown | (Inherited from InputBase.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | IsShiftDown | Determines whether the shift key is pressed. (Inherited from InputBase.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Public method | LeftKey | Moves the cursor one position left. (Inherited from InputBase.)
Protected method | LoadEditorValue | Loads the editor value.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Public method | OnGridKeyDown | Handles grid KeyDown events
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the [E:KeyDown] event. (Overrides InputBase..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | (Inherited from InputBase.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from InputBase.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from vPercentageEditor.)
Protected method | OnMouseWheel | (Inherited from InputBase.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | (Inherited from InputBase.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from InputBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnValidationFailed | Calls the ValidationFailed event. (Inherited from InputBase.)
Protected method | OnValueChanged | Calls the ValueChanged event. (Inherited from InputBase.)
Protected method | OnValueChanging | Calls the ValueChanging event. (Inherited from InputBase.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Protected method | ParseValue | Parses editor's value. (Inherited from vPercentageEditor.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Redo | Redoes this instance. (Inherited from vPercentageEditor.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RemoveRange | Removes a range of characters. (Inherited from InputBase.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | RightKey | Simulates pressing of down key. (Inherited from InputBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetFormattedText | Formats editor's text. (Inherited from vPercentageEditor.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Protected method | SpinDigit | (Inherited from InputBase.)
Protected method | SpinDigitWithWrap | Spins the digit with wrap. (Inherited from InputBase.)
Public method | SpinValue | Increases or decreases the current value. (Inherited from InputBase.)
Protected method | SpinValueBeforeDigit | Spins the value before digit. (Inherited from InputBase.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Undo | Makes undo of the current value. (Inherited from vPercentageEditor.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | UpKey | Simulates pressing of up arrow key. (Inherited from InputBase.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..AccessibilityNotifyClients Method
PercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

PercentageEditor Class
PercentageEditor Members
VIBlend.WinForms.DataGridView Namespace


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..BeginInvoke Method
PercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

PercentageEditor Class
PercentageEditor Members
VIBlend.WinForms.DataGridView Namespace


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..Dispose Method
PercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

PercentageEditor Class
PercentageEditor Members
VIBlend.WinForms.DataGridView Namespace


DrawEditorControl Method

[image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..DrawEditorControl Method
PercentageEditor Class See Also Send Feedback
Handles the painting of the editor control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawEditorControl(
    Graphics graphics,
    GridCell gridCell,
    out bool isDrawHandled
)
Visual Basic
Public Sub DrawEditorControl ( _
    graphics As Graphics, _
    gridCell As GridCell, _
    <OutAttribute> ByRef isDrawHandled As Boolean _
)
Visual C++
public:
virtual void DrawEditorControl(
    Graphics^ graphics,
    GridCell^ gridCell,
    [OutAttribute] bool% isDrawHandled
) sealed

Parameters

graphics
Type: System.Drawing..::..Graphics
Reference to the GDI+ surface
gridCell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the grid cell being rendered
isDrawHandled
Type: System..::..Boolean %
Output flag indicating whether the method handled the drawing or not

Implements

IEditor..::..DrawEditorControl(Graphics, GridCell, Boolean%)

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..GetChildAtPoint Method
PercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

PercentageEditor Class
PercentageEditor Members
VIBlend.WinForms.DataGridView Namespace


HandleDefaultKeys Method

[image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..HandleDefaultKeys Method
PercentageEditor Class See Also Send Feedback
Handles the default keys.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void HandleDefaultKeys(
    KeyEventArgs e
)
Visual Basic
Protected Overridable Sub HandleDefaultKeys ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void HandleDefaultKeys(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
The KeyEventArgs instance containing the event data.

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..Invalidate Method
PercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

PercentageEditor Class
PercentageEditor Members
VIBlend.WinForms.DataGridView Namespace


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..Invoke Method
PercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

PercentageEditor Class
PercentageEditor Members
VIBlend.WinForms.DataGridView Namespace


LayoutEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..LayoutEditor Method
PercentageEditor Class See Also Send Feedback
This methods is called by the grid control when the editor must update its layout

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void LayoutEditor(
    GridCell cell
)
Visual Basic
Public Overridable Sub LayoutEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void LayoutEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the GridCell being edited

Implements

IEditor..::..LayoutEditor(GridCell)

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


LoadEditorValue Method

[image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..LoadEditorValue Method
PercentageEditor Class See Also Send Feedback
Loads the editor value.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void LoadEditorValue()
Visual Basic
Protected Overridable Sub LoadEditorValue
Visual C++
protected:
virtual void LoadEditorValue()

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..MemberwiseClone Method
PercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PercentageEditor Class
PercentageEditor Members
VIBlend.WinForms.DataGridView Namespace


OnCloseEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..OnCloseEditor Method
PercentageEditor Class See Also Send Feedback
This method is called by the grid control when at the end of a cell edit operation

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnCloseEditor()
Visual Basic
Public Sub OnCloseEditor
Visual C++
public:
virtual void OnCloseEditor() sealed

Implements

IEditor..::..OnCloseEditor()()()()

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


OnGridKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..OnGridKeyDown Method
PercentageEditor Class See Also Send Feedback
Handles grid KeyDown events

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnGridKeyDown(
    KeyEventArgs args,
    GridCell cell,
    out bool closeEditor,
    out bool closeEditorAndSaveChanges
)
Visual Basic
Public Sub OnGridKeyDown ( _
    args As KeyEventArgs, _
    cell As GridCell, _
    <OutAttribute> ByRef closeEditor As Boolean, _
    <OutAttribute> ByRef closeEditorAndSaveChanges As Boolean _
)
Visual C++
public:
virtual void OnGridKeyDown(
    KeyEventArgs^ args,
    GridCell^ cell,
    [OutAttribute] bool% closeEditor,
    [OutAttribute] bool% closeEditorAndSaveChanges
) sealed

Parameters

args
Type: System.Windows.Forms..::..KeyEventArgs
KeyDown event arguments
cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
closeEditor
Type: System..::..Boolean %
The grid cell where the event occured. This may be null if the event did not occur within a grid cell.Output flag indicating whether to keep the editor open or close it instantly
closeEditorAndSaveChanges
Type: System..::..Boolean %

Implements

IEditor..::..OnGridKeyDown(KeyEventArgs, GridCell, Boolean%, Boolean%)

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


OnKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..OnKeyDown Method
PercentageEditor Class See Also Send Feedback
Raises the [E:KeyDown] event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
The KeyEventArgs instance containing the event data.

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


OnOpenEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..OnOpenEditor Method
PercentageEditor Class See Also Send Feedback
This method is called by the grid control when the editor is being activated

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnOpenEditor(
    GridCell cell
)
Visual Basic
Public Sub OnOpenEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void OnOpenEditor(
    GridCell^ cell
) sealed

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell

Implements

IEditor..::..OnOpenEditor(GridCell)

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..PerformLayout Method
PercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

PercentageEditor Class
PercentageEditor Members
VIBlend.WinForms.DataGridView Namespace


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..ResumeLayout Method
PercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

PercentageEditor Class
PercentageEditor Members
VIBlend.WinForms.DataGridView Namespace


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..RtlTranslateAlignment Method
PercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

PercentageEditor Class
PercentageEditor Members
VIBlend.WinForms.DataGridView Namespace


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..Scale Method
PercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

PercentageEditor Class
PercentageEditor Members
VIBlend.WinForms.DataGridView Namespace


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..Select Method
PercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

PercentageEditor Class
PercentageEditor Members
VIBlend.WinForms.DataGridView Namespace


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..SetBounds Method
PercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

PercentageEditor Class
PercentageEditor Members
VIBlend.WinForms.DataGridView Namespace


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..UpdateBounds Method
PercentageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

PercentageEditor Class
PercentageEditor Members
VIBlend.WinForms.DataGridView Namespace


PercentageEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor Properties
PercentageEditor Class See Also Send Feedback

The PercentageEditor type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets a reference to the underlying control of the editor
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | CultureInfo | Gets or sets editor's culture information. (Inherited from InputBase.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DeActivationFlags | Gets or sets the editor activation flags
Public property | DecimalPlaces | Gets or sets editor's decimal places. (Inherited from InputBase.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EditCell | Gets the edit cell.
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HandleEnterKey | Gets or sets a value indicating whether to handle the enter and esc keys.
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Protected property | HasSeparator | (Inherited from InputBase.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LastValue | Gets editor's last value. (Inherited from InputBase.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets editor's Maximum value. (Inherited from InputBase.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | (Inherited from InputBase.)
Public property | Minimum | Gets or sets editor's Minimum value. (Inherited from InputBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | SeparatorChar | Gets the current separator character. (Inherited from vPercentageEditor.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SpinType | Gets or sets editor's spin type. (Inherited from InputBase.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseDefaultValidation | Gets or sets a value indicating whether to use the built-in validation. (Inherited from InputBase.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValidationString | Gets or sets the validation string. (Inherited from InputBase.)
Public property | Value | Gets or sets editor's value. (Inherited from InputBase.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


ActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..ActivationFlags Property
PercentageEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags ActivationFlags { get; set; }
Visual Basic
Public Property ActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags ActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..ActivationFlags

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


Control Property

[image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..Control Property
PercentageEditor Class See Also Send Feedback
Gets a reference to the underlying control of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control Control { get; }
Visual Basic
Public ReadOnly Property Control As Control
    Get
Visual C++
public:
virtual property Control^ Control {
    Control^ get () sealed;
}

Implements

IEditor..::..Control

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


DeActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..DeActivationFlags Property
PercentageEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags DeActivationFlags { get; set; }
Visual Basic
Public Property DeActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags DeActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..DeActivationFlags

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


EditCell Property

[image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..EditCell Property
PercentageEditor Class See Also Send Feedback
Gets the edit cell.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell EditCell { get; }
Visual Basic
Public ReadOnly Property EditCell As GridCell
    Get
Visual C++
public:
property GridCell^ EditCell {
    GridCell^ get ();
}

Field Value

The edit cell.

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorType Property

[image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..EditorType Property
PercentageEditor Class See Also Send Feedback
Gets the type of the grid cell editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellEditorType EditorType { get; }
Visual Basic
Public ReadOnly Property EditorType As CellEditorType
    Get
Visual C++
public:
virtual property CellEditorType EditorType {
    CellEditorType get () sealed;
}

Implements

IEditor..::..EditorType

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorValue Property

[image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..EditorValue Property
PercentageEditor Class See Also Send Feedback
Get's or sets the current value of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object EditorValue { get; set; }
Visual Basic
Public Property EditorValue As Object
    Get
    Set
Visual C++
public:
virtual property Object^ EditorValue {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Implements

IEditor..::..EditorValue

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


HandleEnterKey Property

[image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor..::..HandleEnterKey Property
PercentageEditor Class See Also Send Feedback
Gets or sets a value indicating whether to handle the enter and esc keys.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool HandleEnterKey { get; set; }
Visual Basic
Public Property HandleEnterKey As Boolean
    Get
    Set
Visual C++
public:
property bool HandleEnterKey {
    bool get ();
    void set (bool value);
}

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


PercentageEditor Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
PercentageEditor Events
PercentageEditor Class See Also Send Feedback

The PercentageEditor type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property has changed. (Inherited from InputBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValidationFailed | Represents the ValidationFailed event. (Inherited from InputBase.)
Public event | ValueChanged | Represents the ValueChanged event. (Inherited from InputBase.)
Public event | ValueChanging | Represents the ValueChanging event. (Inherited from InputBase.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PercentageEditor Class
VIBlend.WinForms.DataGridView Namespace


PivotDesignLocalizationNames Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
PivotDesignLocalizationNames Enumeration
See Also Send Feedback
Represents the LocalizationNames enumeration.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum PivotDesignLocalizationNames
Visual Basic
Public Enumeration PivotDesignLocalizationNames
Visual C++
public enum class PivotDesignLocalizationNames

Members

Member name | Description
MoveUpItem |
MoveDownItem |
MoveToRowAreaItem |
MoveToColumnAreaItem |
MoveToDataAreaItem |
RemoveFieldItem |
SelectItem |
FunctionItem |
AverageItem |
CountItem |
MaxItem |
MinItem |
ProductItem |
SumItem |

See Also

VIBlend.WinForms.DataGridView Namespace


PivotDesignPanelLocalization Class

[image]

VIBlend Controls for WinForms Help Documentation
PivotDesignPanelLocalization Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class PivotDesignPanelLocalization : PivotDesignPanelLocalizationBase
Visual Basic
Public Class PivotDesignPanelLocalization _
    Inherits PivotDesignPanelLocalizationBase
Visual C++
public ref class PivotDesignPanelLocalization : public PivotDesignPanelLocalizationBase

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..PivotDesignPanelLocalizationBase
VIBlend.WinForms.DataGridView..::..PivotDesignPanelLocalization

See Also

PivotDesignPanelLocalization Members
VIBlend.WinForms.DataGridView Namespace


PivotDesignPanelLocalization Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
PivotDesignPanelLocalization Members
PivotDesignPanelLocalization Class Constructors Methods See Also Send Feedback

The PivotDesignPanelLocalization type exposes the following members.

Constructors

 | Name | Description
Public method | PivotDesignPanelLocalization | Initializes a new instance of the PivotDesignPanelLocalization class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString | Gets the string. (Overrides PivotDesignPanelLocalizationBase..::..GetString(PivotDesignLocalizationNames).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PivotDesignPanelLocalization Class
VIBlend.WinForms.DataGridView Namespace


PivotDesignPanelLocalization Constructor

[image]

VIBlend Controls for WinForms Help Documentation
PivotDesignPanelLocalization Constructor
PivotDesignPanelLocalization Class See Also Send Feedback
Initializes a new instance of the PivotDesignPanelLocalization class

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public PivotDesignPanelLocalization()
Visual Basic
Public Sub New
Visual C++
public:
PivotDesignPanelLocalization()

See Also

PivotDesignPanelLocalization Class
VIBlend.WinForms.DataGridView Namespace


PivotDesignPanelLocalization Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
PivotDesignPanelLocalization Methods
PivotDesignPanelLocalization Class See Also Send Feedback

The PivotDesignPanelLocalization type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString | Gets the string. (Overrides PivotDesignPanelLocalizationBase..::..GetString(PivotDesignLocalizationNames).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PivotDesignPanelLocalization Class
VIBlend.WinForms.DataGridView Namespace


GetString Method

[image]

VIBlend Controls for WinForms Help Documentation
PivotDesignPanelLocalization..::..GetString Method
PivotDesignPanelLocalization Class See Also Send Feedback
Gets the string.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override string GetString(
    PivotDesignLocalizationNames name
)
Visual Basic
Public Overrides Function GetString ( _
    name As PivotDesignLocalizationNames _
) As String
Visual C++
public:
virtual String^ GetString(
    PivotDesignLocalizationNames name
) override

Parameters

name
Type: VIBlend.WinForms.DataGridView..::..PivotDesignLocalizationNames
The name.

Return Value

See Also

PivotDesignPanelLocalization Class
VIBlend.WinForms.DataGridView Namespace


PivotDesignPanelLocalizationBase Class

[image]

VIBlend Controls for WinForms Help Documentation
PivotDesignPanelLocalizationBase Class
Members See Also Send Feedback
Represents a base class for the DataGrid localization providers.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public abstract class PivotDesignPanelLocalizationBase
Visual Basic
Public MustInherit Class PivotDesignPanelLocalizationBase
Visual C++
public ref class PivotDesignPanelLocalizationBase abstract

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..PivotDesignPanelLocalizationBase
VIBlend.WinForms.DataGridView..::..PivotDesignPanelLocalization

See Also

PivotDesignPanelLocalizationBase Members
VIBlend.WinForms.DataGridView Namespace


PivotDesignPanelLocalizationBase Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
PivotDesignPanelLocalizationBase Members
PivotDesignPanelLocalizationBase Class Constructors Methods See Also Send Feedback

The PivotDesignPanelLocalizationBase type exposes the following members.

Constructors

 | Name | Description
Protected method | PivotDesignPanelLocalizationBase | Initializes a new instance of the PivotDesignPanelLocalizationBase class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PivotDesignPanelLocalizationBase Class
VIBlend.WinForms.DataGridView Namespace


PivotDesignPanelLocalizationBase Constructor

[image]

VIBlend Controls for WinForms Help Documentation
PivotDesignPanelLocalizationBase Constructor
PivotDesignPanelLocalizationBase Class See Also Send Feedback
Initializes a new instance of the PivotDesignPanelLocalizationBase class

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected PivotDesignPanelLocalizationBase()
Visual Basic
Protected Sub New
Visual C++
protected:
PivotDesignPanelLocalizationBase()

See Also

PivotDesignPanelLocalizationBase Class
VIBlend.WinForms.DataGridView Namespace


PivotDesignPanelLocalizationBase Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
PivotDesignPanelLocalizationBase Methods
PivotDesignPanelLocalizationBase Class See Also Send Feedback

The PivotDesignPanelLocalizationBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PivotDesignPanelLocalizationBase Class
VIBlend.WinForms.DataGridView Namespace


GetString Method

[image]

VIBlend Controls for WinForms Help Documentation
PivotDesignPanelLocalizationBase..::..GetString Method
PivotDesignPanelLocalizationBase Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public abstract string GetString(
    PivotDesignLocalizationNames name
)
Visual Basic
Public MustOverride Function GetString ( _
    name As PivotDesignLocalizationNames _
) As String
Visual C++
public:
virtual String^ GetString(
    PivotDesignLocalizationNames name
) abstract

Parameters

name
Type: VIBlend.WinForms.DataGridView..::..PivotDesignLocalizationNames

See Also

PivotDesignPanelLocalizationBase Class
VIBlend.WinForms.DataGridView Namespace


PivotFieldFunction Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
PivotFieldFunction Enumeration
See Also Send Feedback
Represents an aggregation function which will be used to calculate the value of a grid cell when the grid is bound to a data source in a pivot table mode

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum PivotFieldFunction
Visual Basic
Public Enumeration PivotFieldFunction
Visual C++
public enum class PivotFieldFunction

Members

Member name | Description
Sum |
Count |
Average |
Max |
Min |
Product |

See Also

VIBlend.WinForms.DataGridView Namespace


PivotTotalsMode Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
PivotTotalsMode Enumeration
See Also Send Feedback
Enumeration of the Pivot Table totals display modes.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum PivotTotalsMode
Visual Basic
Public Enumeration PivotTotalsMode
Visual C++
public enum class PivotTotalsMode

Members

Member name | Description
DISPLAY_SUBTOTALS |
DISPLAY_GRANDTOTALS |
DISPLAY_BOTH |

See Also

VIBlend.WinForms.DataGridView Namespace


PivotValueFieldTextNeededEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
PivotValueFieldTextNeededEventArgs Class
Members See Also Send Feedback
Represents PivotValueFieldNameNeeded event arguments.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class PivotValueFieldTextNeededEventArgs
Visual Basic
Public Class PivotValueFieldTextNeededEventArgs
Visual C++
public ref class PivotValueFieldTextNeededEventArgs

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..PivotValueFieldTextNeededEventArgs

See Also

PivotValueFieldTextNeededEventArgs Members
VIBlend.WinForms.DataGridView Namespace


PivotValueFieldTextNeededEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
PivotValueFieldTextNeededEventArgs Members
PivotValueFieldTextNeededEventArgs Class Constructors Methods Fields Properties See Also Send Feedback

The PivotValueFieldTextNeededEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | PivotValueFieldTextNeededEventArgs | Initializes a new instance of the PivotValueFieldTextNeededEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Field |

Properties

 | Name | Description
Public property | Handled |

See Also

PivotValueFieldTextNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


PivotValueFieldTextNeededEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
PivotValueFieldTextNeededEventArgs Constructor
PivotValueFieldTextNeededEventArgs Class See Also Send Feedback
Initializes a new instance of the PivotValueFieldTextNeededEventArgs class

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public PivotValueFieldTextNeededEventArgs()
Visual Basic
Public Sub New
Visual C++
public:
PivotValueFieldTextNeededEventArgs()

See Also

PivotValueFieldTextNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


PivotValueFieldTextNeededEventArgs Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
PivotValueFieldTextNeededEventArgs Fields
PivotValueFieldTextNeededEventArgs Class See Also Send Feedback

The PivotValueFieldTextNeededEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | Field |

See Also

PivotValueFieldTextNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Field Field

[image]

VIBlend Controls for WinForms Help Documentation
PivotValueFieldTextNeededEventArgs..::..Field Field
PivotValueFieldTextNeededEventArgs Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BoundValueField Field
Visual Basic
Public Field As BoundValueField
Visual C++
public:
BoundValueField^ Field

See Also

PivotValueFieldTextNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


PivotValueFieldTextNeededEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
PivotValueFieldTextNeededEventArgs Methods
PivotValueFieldTextNeededEventArgs Class See Also Send Feedback

The PivotValueFieldTextNeededEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PivotValueFieldTextNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


PivotValueFieldTextNeededEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
PivotValueFieldTextNeededEventArgs Properties
PivotValueFieldTextNeededEventArgs Class See Also Send Feedback

The PivotValueFieldTextNeededEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Handled |

See Also

PivotValueFieldTextNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Handled Property

[image]

VIBlend Controls for WinForms Help Documentation
PivotValueFieldTextNeededEventArgs..::..Handled Property
PivotValueFieldTextNeededEventArgs Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Handled { get; set; }
Visual Basic
Public Property Handled As Boolean
    Get
    Set
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

See Also

PivotValueFieldTextNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


PivotValueFieldTextNeededEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
PivotValueFieldTextNeededEventHandler Delegate
See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void PivotValueFieldTextNeededEventHandler(
    Object sender,
    PivotValueFieldTextNeededEventArgs e
)
Visual Basic
Public Delegate Sub PivotValueFieldTextNeededEventHandler ( _
    sender As Object, _
    e As PivotValueFieldTextNeededEventArgs _
)
Visual C++
public delegate void PivotValueFieldTextNeededEventHandler(
    Object^ sender,
    PivotValueFieldTextNeededEventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: VIBlend.WinForms.DataGridView..::..PivotValueFieldTextNeededEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


ProgressBarEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor Class
Members See Also Send Feedback
Represents a ProgressBarEditor used in the GridView control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class ProgressBarEditor : IEditor
Visual Basic
Public Class ProgressBarEditor _
    Implements IEditor
Visual C++
public ref class ProgressBarEditor : IEditor

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..ProgressBarEditor

See Also

ProgressBarEditor Members
VIBlend.WinForms.DataGridView Namespace


ProgressBarEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor Members
ProgressBarEditor Class Constructors Methods Properties See Also Send Feedback

The ProgressBarEditor type exposes the following members.

Constructors

 | Name | Description
Public method | ProgressBarEditor | Constructor

Methods

 | Name | Description
Public method | DrawEditorControl | Handles the painting of the editor control
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Public method | OnGridKeyDown | Handles grid KeyDown events
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | Control | Gets a reference to the underlying control of the editor
Public property | DeActivationFlags | Gets or sets the editor activation flags
Public property | EditCell | Gets the edit cell.
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | Maximum | Gets or sets the maximum.
Public property | Minimum | Gets or sets the minimum.
Public property | VIBlendTheme | Gets or sets the VIblend theme.

See Also

ProgressBarEditor Class
VIBlend.WinForms.DataGridView Namespace


ProgressBarEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor Constructor
ProgressBarEditor Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ProgressBarEditor()
Visual Basic
Public Sub New
Visual C++
public:
ProgressBarEditor()

See Also

ProgressBarEditor Class
VIBlend.WinForms.DataGridView Namespace


ProgressBarEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor Methods
ProgressBarEditor Class See Also Send Feedback

The ProgressBarEditor type exposes the following members.

Methods

 | Name | Description
Public method | DrawEditorControl | Handles the painting of the editor control
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Public method | OnGridKeyDown | Handles grid KeyDown events
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProgressBarEditor Class
VIBlend.WinForms.DataGridView Namespace


DrawEditorControl Method

[image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor..::..DrawEditorControl Method
ProgressBarEditor Class See Also Send Feedback
Handles the painting of the editor control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawEditorControl(
    Graphics graphics,
    GridCell gridCell,
    out bool isDrawHandled
)
Visual Basic
Public Sub DrawEditorControl ( _
    graphics As Graphics, _
    gridCell As GridCell, _
    <OutAttribute> ByRef isDrawHandled As Boolean _
)
Visual C++
public:
virtual void DrawEditorControl(
    Graphics^ graphics,
    GridCell^ gridCell,
    [OutAttribute] bool% isDrawHandled
) sealed

Parameters

graphics
Type: System.Drawing..::..Graphics
Reference to the GDI+ surface
gridCell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the grid cell being rendered
isDrawHandled
Type: System..::..Boolean %
Output flag indicating whether the method handled the drawing or not

Implements

IEditor..::..DrawEditorControl(Graphics, GridCell, Boolean%)

See Also

ProgressBarEditor Class
VIBlend.WinForms.DataGridView Namespace


LayoutEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor..::..LayoutEditor Method
ProgressBarEditor Class See Also Send Feedback
This methods is called by the grid control when the editor must update its layout

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void LayoutEditor(
    GridCell cell
)
Visual Basic
Public Overridable Sub LayoutEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void LayoutEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the GridCell being edited

Implements

IEditor..::..LayoutEditor(GridCell)

See Also

ProgressBarEditor Class
VIBlend.WinForms.DataGridView Namespace


OnCloseEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor..::..OnCloseEditor Method
ProgressBarEditor Class See Also Send Feedback
This method is called by the grid control when at the end of a cell edit operation

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnCloseEditor()
Visual Basic
Public Sub OnCloseEditor
Visual C++
public:
virtual void OnCloseEditor() sealed

Implements

IEditor..::..OnCloseEditor()()()()

See Also

ProgressBarEditor Class
VIBlend.WinForms.DataGridView Namespace


OnGridKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor..::..OnGridKeyDown Method
ProgressBarEditor Class See Also Send Feedback
Handles grid KeyDown events

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnGridKeyDown(
    KeyEventArgs args,
    GridCell cell,
    out bool closeEditor,
    out bool closeEditorAndSaveChanges
)
Visual Basic
Public Sub OnGridKeyDown ( _
    args As KeyEventArgs, _
    cell As GridCell, _
    <OutAttribute> ByRef closeEditor As Boolean, _
    <OutAttribute> ByRef closeEditorAndSaveChanges As Boolean _
)
Visual C++
public:
virtual void OnGridKeyDown(
    KeyEventArgs^ args,
    GridCell^ cell,
    [OutAttribute] bool% closeEditor,
    [OutAttribute] bool% closeEditorAndSaveChanges
) sealed

Parameters

args
Type: System.Windows.Forms..::..KeyEventArgs
KeyDown event arguments
cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
closeEditor
Type: System..::..Boolean %
The grid cell where the event occured. This may be null if the event did not occur within a grid cell.Output flag indicating whether to keep the editor open or close it instantly
closeEditorAndSaveChanges
Type: System..::..Boolean %

Implements

IEditor..::..OnGridKeyDown(KeyEventArgs, GridCell, Boolean%, Boolean%)

See Also

ProgressBarEditor Class
VIBlend.WinForms.DataGridView Namespace


OnOpenEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor..::..OnOpenEditor Method
ProgressBarEditor Class See Also Send Feedback
This method is called by the grid control when the editor is being activated

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnOpenEditor(
    GridCell cell
)
Visual Basic
Public Sub OnOpenEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void OnOpenEditor(
    GridCell^ cell
) sealed

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell

Implements

IEditor..::..OnOpenEditor(GridCell)

See Also

ProgressBarEditor Class
VIBlend.WinForms.DataGridView Namespace


ProgressBarEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor Properties
ProgressBarEditor Class See Also Send Feedback

The ProgressBarEditor type exposes the following members.

Properties

 | Name | Description
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | Control | Gets a reference to the underlying control of the editor
Public property | DeActivationFlags | Gets or sets the editor activation flags
Public property | EditCell | Gets the edit cell.
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | Maximum | Gets or sets the maximum.
Public property | Minimum | Gets or sets the minimum.
Public property | VIBlendTheme | Gets or sets the VIblend theme.

See Also

ProgressBarEditor Class
VIBlend.WinForms.DataGridView Namespace


ActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor..::..ActivationFlags Property
ProgressBarEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags ActivationFlags { get; set; }
Visual Basic
Public Property ActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags ActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..ActivationFlags

See Also

ProgressBarEditor Class
VIBlend.WinForms.DataGridView Namespace


Control Property

[image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor..::..Control Property
ProgressBarEditor Class See Also Send Feedback
Gets a reference to the underlying control of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control Control { get; }
Visual Basic
Public ReadOnly Property Control As Control
    Get
Visual C++
public:
virtual property Control^ Control {
    Control^ get () sealed;
}

Implements

IEditor..::..Control

See Also

ProgressBarEditor Class
VIBlend.WinForms.DataGridView Namespace


DeActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor..::..DeActivationFlags Property
ProgressBarEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags DeActivationFlags { get; set; }
Visual Basic
Public Property DeActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags DeActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..DeActivationFlags

See Also

ProgressBarEditor Class
VIBlend.WinForms.DataGridView Namespace


EditCell Property

[image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor..::..EditCell Property
ProgressBarEditor Class See Also Send Feedback
Gets the edit cell.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell EditCell { get; }
Visual Basic
Public ReadOnly Property EditCell As GridCell
    Get
Visual C++
public:
property GridCell^ EditCell {
    GridCell^ get ();
}

Field Value

The edit cell.

See Also

ProgressBarEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorType Property

[image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor..::..EditorType Property
ProgressBarEditor Class See Also Send Feedback
Gets the type of the grid cell editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellEditorType EditorType { get; }
Visual Basic
Public ReadOnly Property EditorType As CellEditorType
    Get
Visual C++
public:
virtual property CellEditorType EditorType {
    CellEditorType get () sealed;
}

Implements

IEditor..::..EditorType

See Also

ProgressBarEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorValue Property

[image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor..::..EditorValue Property
ProgressBarEditor Class See Also Send Feedback
Get's or sets the current value of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object EditorValue { get; set; }
Visual Basic
Public Property EditorValue As Object
    Get
    Set
Visual C++
public:
virtual property Object^ EditorValue {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Implements

IEditor..::..EditorValue

See Also

ProgressBarEditor Class
VIBlend.WinForms.DataGridView Namespace


Maximum Property

[image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor..::..Maximum Property
ProgressBarEditor Class See Also Send Feedback
Gets or sets the maximum.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Maximum { get; set; }
Visual Basic
Public Property Maximum As Integer
    Get
    Set
Visual C++
public:
property int Maximum {
    int get ();
    void set (int value);
}

Field Value

The maximum.

See Also

ProgressBarEditor Class
VIBlend.WinForms.DataGridView Namespace


Minimum Property

[image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor..::..Minimum Property
ProgressBarEditor Class See Also Send Feedback
Gets or sets the minimum.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Minimum { get; set; }
Visual Basic
Public Property Minimum As Integer
    Get
    Set
Visual C++
public:
property int Minimum {
    int get ();
    void set (int value);
}

Field Value

The minimum.

See Also

ProgressBarEditor Class
VIBlend.WinForms.DataGridView Namespace


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
ProgressBarEditor..::..VIBlendTheme Property
ProgressBarEditor Class See Also Send Feedback
Gets or sets the VIblend theme.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Nullable<VIBLEND_THEME> VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As Nullable(Of VIBLEND_THEME)
    Get
    Set
Visual C++
public:
property Nullable<VIBLEND_THEME> VIBlendTheme {
    Nullable<VIBLEND_THEME> get ();
    void set (Nullable<VIBLEND_THEME> value);
}

Field Value

The VIblend theme.

See Also

ProgressBarEditor Class
VIBlend.WinForms.DataGridView Namespace


RowsHierarchy Class

[image]

VIBlend Controls for WinForms Help Documentation
RowsHierarchy Class
Members See Also Send Feedback
Represents a Rows Hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class RowsHierarchy : Hierarchy
Visual Basic
Public Class RowsHierarchy _
    Inherits Hierarchy
Visual C++
public ref class RowsHierarchy : public Hierarchy

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..Hierarchy
VIBlend.WinForms.DataGridView..::..RowsHierarchy

See Also

RowsHierarchy Members
VIBlend.WinForms.DataGridView Namespace


RowsHierarchy Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
RowsHierarchy Members
RowsHierarchy Class Constructors Methods Properties Events See Also Send Feedback

The RowsHierarchy type exposes the following members.

Constructors

 | Name | Description
Public method | RowsHierarchy | Constructor

Methods

 | Name | Description
Protected method | ApplyFilters | (Inherited from Hierarchy.)
Public method | AutoResize()()()() | Resizes the items in the hierarchy for optimal visual appearance (Overrides Hierarchy..::..AutoResize()()()().)
Public method | AutoResize(AutoResizeMode) | Resizes the items in the hierarchy for optimal visual appearance (Overrides Hierarchy..::..AutoResize(AutoResizeMode).)
Public method | Clear | Removes all HierarchyItems and their settings. (Inherited from Hierarchy.)
Public method | ClearSelection | Unselects all selected items. (Inherited from Hierarchy.)
Public method | CollapseAllItems | Collapses all items in the Hierarchy (Inherited from Hierarchy.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandAllItems | Expands all items in the Hierarchy (Inherited from Hierarchy.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildItemsRecursive | Retrieves all child HierarchyItems at all levels (Inherited from Hierarchy.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemByUniqueID | Gets a HierarchyItem by its unique ID (Inherited from Hierarchy.)
Public method | GetNextItem | Returns the item displayed immediatelly after a specified item (Inherited from Hierarchy.)
Public method | GetPreviousItem | Returns the item displayed immediatelly before a specified item (Inherited from Hierarchy.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HitTest | Performs a HitTest at a specific point within the Hierarchy (Inherited from Hierarchy.)
Public method | IsItemSelected | Checks if an item is selected (Inherited from Hierarchy.)
Public method | IsSummaryItem | Checks if a specific item is a Summary Item (Inherited from Hierarchy.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnFilterChanged | (Inherited from Hierarchy.)
Protected method | OnSortingChanged | (Inherited from Hierarchy.)
Public method | RemoveSort | Removes the sorting order previously applied through the SortBy method (Inherited from Hierarchy.)
Public method | SelectItem | Selects an item in the Hierarchy (Inherited from Hierarchy.)
Public method | SetColumnWidth | Sets the width of a column within the hierarchy (Overrides Hierarchy..::..SetColumnWidth(Int32, Int32).)
Public method | SetRowHeight | Sets the height of the row. (Inherited from Hierarchy.)
Public method | ShowHiddenItems | Sets the status of all hidden items to visible. (Inherited from Hierarchy.)
Public method | SortBy(HierarchyItem, SortingDirection) | Sorts the Hierarchy by a specefic HierarchyItem (Inherited from Hierarchy.)
Public method | SortBy(HierarchyItem, SortingDirection, IComparer<(Of <<'(HierarchyItem>)>>)) | Sorts the Items in the Hierarchy. (Inherited from Hierarchy.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnSelectItem | UnSelects an item in the Hierarchy (Inherited from Hierarchy.)

Properties

 | Name | Description
Public property | AllowDragDrop | Gets or sets whether drag and drop is enabled for this Hierarchy (Inherited from Hierarchy.)
Public property | AllowResize | Gets or sets whether the HierarchyItems resizing is allowed (Inherited from Hierarchy.)
Public property | ColumnWidths | Gets the columns' widths for the hierarchy (Inherited from Hierarchy.)
Public property | CompactStyleRenderingEnabled | Gets or sets whether the Rows hierarchy is rendered in compact style where each child item appears under the parent item instead of on its right side
Public property | CompactStyleRenderingItemsIndent | Gets or sets the child items indent in the Rows hierarchy when the hierarchy is rendered in compact style.
Public property | Filters | (Inherited from Hierarchy.)
Public property | Fixed | Determines if the Hierarchy is fixed or not. Fixed Hierarchies are not affected by the scrolling of the data grid's content (Inherited from Hierarchy.)
Public property | GridControl | Retruns a reference to the Grid control hosting the hierarchy (Inherited from Hierarchy.)
Public property | Height | Gets the Height of the Hierarchy
Public property | HiddenItems | Gets the hidden items (Inherited from Hierarchy.)
Public property | HierarchyDepth | Gets the depth of the hierarchy. (Inherited from Hierarchy.)
Public property | IsFiltered | Checks if the Hierarchy contains HierarchyItems which are filtered. (Inherited from Hierarchy.)
Public property | IsSorted | Checks if the Hierarchy is Sorted (Inherited from Hierarchy.)
Public property | Items | Gets the items of the Hierarchy (Inherited from Hierarchy.)
Public property | SelectedItems | Gets the selected items (Inherited from Hierarchy.)
Public property | ShowExpandCollapseButtons | Determines whether to show the expand/collapse buttons on the items hosted by the hierarchy (Inherited from Hierarchy.)
Public property | SortingDirection | Gets the sort order direction if the Hierarchy is sorted. (Inherited from Hierarchy.)
Public property | SortItem | Gets the Item the Hierarchy is sorted by. (Inherited from Hierarchy.)
Public property | SummaryItems | Gets the summary items of the Hierarchy (Inherited from Hierarchy.)
Public property | TotalItemsCount | Gets the total number of HierarchyItems hosted by the Hierarchy. This includes both Hierarchy items and Summary items. Hidden items are also counted. (Inherited from Hierarchy.)
Public property | Visible | Determines whether the hierarchy is visible (Inherited from Hierarchy.)
Public property | Width | Gets the Width of the Hierarchy
Public property | X | Returns the horizontal position of Hierarchy relative to the top-left corner of the grid control (Inherited from Hierarchy.)
Public property | Y | Returns the horizontal position of Hierarchy relative to the top-left corner of the grid control (Inherited from Hierarchy.)

Events

 | Name | Description
Public event | FiltersChanged | Occurs when the Hierarchy filters have changed. (Inherited from Hierarchy.)
Public event | SortingChanged | Occurs when the Hierarchy sorting have changed. (Inherited from Hierarchy.)

See Also

RowsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


RowsHierarchy Constructor

[image]

VIBlend Controls for WinForms Help Documentation
RowsHierarchy Constructor
RowsHierarchy Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RowsHierarchy(
    vDataGridView gridControl
)
Visual Basic
Public Sub New ( _
    gridControl As vDataGridView _
)
Visual C++
public:
RowsHierarchy(
    vDataGridView^ gridControl
)

Parameters

gridControl
Type: VIBlend.WinForms.DataGridView..::..vDataGridView
Reference to the grid control hosting the hierarchy

See Also

RowsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


RowsHierarchy Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
RowsHierarchy Methods
RowsHierarchy Class See Also Send Feedback

The RowsHierarchy type exposes the following members.

Methods

 | Name | Description
Protected method | ApplyFilters | (Inherited from Hierarchy.)
Public method | AutoResize()()()() | Resizes the items in the hierarchy for optimal visual appearance (Overrides Hierarchy..::..AutoResize()()()().)
Public method | AutoResize(AutoResizeMode) | Resizes the items in the hierarchy for optimal visual appearance (Overrides Hierarchy..::..AutoResize(AutoResizeMode).)
Public method | Clear | Removes all HierarchyItems and their settings. (Inherited from Hierarchy.)
Public method | ClearSelection | Unselects all selected items. (Inherited from Hierarchy.)
Public method | CollapseAllItems | Collapses all items in the Hierarchy (Inherited from Hierarchy.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandAllItems | Expands all items in the Hierarchy (Inherited from Hierarchy.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildItemsRecursive | Retrieves all child HierarchyItems at all levels (Inherited from Hierarchy.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemByUniqueID | Gets a HierarchyItem by its unique ID (Inherited from Hierarchy.)
Public method | GetNextItem | Returns the item displayed immediatelly after a specified item (Inherited from Hierarchy.)
Public method | GetPreviousItem | Returns the item displayed immediatelly before a specified item (Inherited from Hierarchy.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HitTest | Performs a HitTest at a specific point within the Hierarchy (Inherited from Hierarchy.)
Public method | IsItemSelected | Checks if an item is selected (Inherited from Hierarchy.)
Public method | IsSummaryItem | Checks if a specific item is a Summary Item (Inherited from Hierarchy.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnFilterChanged | (Inherited from Hierarchy.)
Protected method | OnSortingChanged | (Inherited from Hierarchy.)
Public method | RemoveSort | Removes the sorting order previously applied through the SortBy method (Inherited from Hierarchy.)
Public method | SelectItem | Selects an item in the Hierarchy (Inherited from Hierarchy.)
Public method | SetColumnWidth | Sets the width of a column within the hierarchy (Overrides Hierarchy..::..SetColumnWidth(Int32, Int32).)
Public method | SetRowHeight | Sets the height of the row. (Inherited from Hierarchy.)
Public method | ShowHiddenItems | Sets the status of all hidden items to visible. (Inherited from Hierarchy.)
Public method | SortBy(HierarchyItem, SortingDirection) | Sorts the Hierarchy by a specefic HierarchyItem (Inherited from Hierarchy.)
Public method | SortBy(HierarchyItem, SortingDirection, IComparer<(Of <<'(HierarchyItem>)>>)) | Sorts the Items in the Hierarchy. (Inherited from Hierarchy.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnSelectItem | UnSelects an item in the Hierarchy (Inherited from Hierarchy.)

See Also

RowsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


AutoResize Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RowsHierarchy..::..AutoResize Method
RowsHierarchy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AutoResize()()()() | Resizes the items in the hierarchy for optimal visual appearance (Overrides Hierarchy..::..AutoResize()()()().)
Public method | AutoResize(AutoResizeMode) | Resizes the items in the hierarchy for optimal visual appearance (Overrides Hierarchy..::..AutoResize(AutoResizeMode).)

See Also

RowsHierarchy Class
RowsHierarchy Members
VIBlend.WinForms.DataGridView Namespace


AutoResize Method

[image]

VIBlend Controls for WinForms Help Documentation
RowsHierarchy..::..AutoResize Method
RowsHierarchy Class See Also Send Feedback
Resizes the items in the hierarchy for optimal visual appearance

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void AutoResize()
Visual Basic
Public Overrides Sub AutoResize
Visual C++
public:
virtual void AutoResize() override

See Also

RowsHierarchy Class
AutoResize Overload
VIBlend.WinForms.DataGridView Namespace


AutoResize Method (AutoResizeMode)

[image]

VIBlend Controls for WinForms Help Documentation
RowsHierarchy..::..AutoResize Method (AutoResizeMode)
RowsHierarchy Class See Also Send Feedback
Resizes the items in the hierarchy for optimal visual appearance

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override void AutoResize(
    AutoResizeMode autoResizeMode
)
Visual Basic
Public Overrides Sub AutoResize ( _
    autoResizeMode As AutoResizeMode _
)
Visual C++
public:
virtual void AutoResize(
    AutoResizeMode autoResizeMode
) override

Parameters

autoResizeMode
Type: VIBlend.WinForms.DataGridView..::..AutoResizeMode

See Also

RowsHierarchy Class
AutoResize Overload
VIBlend.WinForms.DataGridView Namespace


SetColumnWidth Method

[image]

VIBlend Controls for WinForms Help Documentation
RowsHierarchy..::..SetColumnWidth Method
RowsHierarchy Class See Also Send Feedback
Sets the width of a column within the hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override bool SetColumnWidth(
    int columnIndex,
    int width
)
Visual Basic
Public Overrides Function SetColumnWidth ( _
    columnIndex As Integer, _
    width As Integer _
) As Boolean
Visual C++
public:
virtual bool SetColumnWidth(
    int columnIndex,
    int width
) override

Parameters

columnIndex
Type: System..::..Int32
Zero-based index of the column
width
Type: System..::..Int32
New width in pixels

Return Value

The method returns true if the new width is applied

See Also

RowsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


SortBy Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
RowsHierarchy..::..SortBy Method
RowsHierarchy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SortBy(HierarchyItem, SortingDirection) | Sorts the Hierarchy by a specefic HierarchyItem (Inherited from Hierarchy.)
Public method | SortBy(HierarchyItem, SortingDirection, IComparer<(Of <<'(HierarchyItem>)>>)) | Sorts the Items in the Hierarchy. (Inherited from Hierarchy.)

See Also

RowsHierarchy Class
RowsHierarchy Members
VIBlend.WinForms.DataGridView Namespace


RowsHierarchy Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
RowsHierarchy Properties
RowsHierarchy Class See Also Send Feedback

The RowsHierarchy type exposes the following members.

Properties

 | Name | Description
Public property | AllowDragDrop | Gets or sets whether drag and drop is enabled for this Hierarchy (Inherited from Hierarchy.)
Public property | AllowResize | Gets or sets whether the HierarchyItems resizing is allowed (Inherited from Hierarchy.)
Public property | ColumnWidths | Gets the columns' widths for the hierarchy (Inherited from Hierarchy.)
Public property | CompactStyleRenderingEnabled | Gets or sets whether the Rows hierarchy is rendered in compact style where each child item appears under the parent item instead of on its right side
Public property | CompactStyleRenderingItemsIndent | Gets or sets the child items indent in the Rows hierarchy when the hierarchy is rendered in compact style.
Public property | Filters | (Inherited from Hierarchy.)
Public property | Fixed | Determines if the Hierarchy is fixed or not. Fixed Hierarchies are not affected by the scrolling of the data grid's content (Inherited from Hierarchy.)
Public property | GridControl | Retruns a reference to the Grid control hosting the hierarchy (Inherited from Hierarchy.)
Public property | Height | Gets the Height of the Hierarchy
Public property | HiddenItems | Gets the hidden items (Inherited from Hierarchy.)
Public property | HierarchyDepth | Gets the depth of the hierarchy. (Inherited from Hierarchy.)
Public property | IsFiltered | Checks if the Hierarchy contains HierarchyItems which are filtered. (Inherited from Hierarchy.)
Public property | IsSorted | Checks if the Hierarchy is Sorted (Inherited from Hierarchy.)
Public property | Items | Gets the items of the Hierarchy (Inherited from Hierarchy.)
Public property | SelectedItems | Gets the selected items (Inherited from Hierarchy.)
Public property | ShowExpandCollapseButtons | Determines whether to show the expand/collapse buttons on the items hosted by the hierarchy (Inherited from Hierarchy.)
Public property | SortingDirection | Gets the sort order direction if the Hierarchy is sorted. (Inherited from Hierarchy.)
Public property | SortItem | Gets the Item the Hierarchy is sorted by. (Inherited from Hierarchy.)
Public property | SummaryItems | Gets the summary items of the Hierarchy (Inherited from Hierarchy.)
Public property | TotalItemsCount | Gets the total number of HierarchyItems hosted by the Hierarchy. This includes both Hierarchy items and Summary items. Hidden items are also counted. (Inherited from Hierarchy.)
Public property | Visible | Determines whether the hierarchy is visible (Inherited from Hierarchy.)
Public property | Width | Gets the Width of the Hierarchy
Public property | X | Returns the horizontal position of Hierarchy relative to the top-left corner of the grid control (Inherited from Hierarchy.)
Public property | Y | Returns the horizontal position of Hierarchy relative to the top-left corner of the grid control (Inherited from Hierarchy.)

See Also

RowsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


CompactStyleRenderingEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
RowsHierarchy..::..CompactStyleRenderingEnabled Property
RowsHierarchy Class See Also Send Feedback
Gets or sets whether the Rows hierarchy is rendered in compact style where each child item appears under the parent item instead of on its right side

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool CompactStyleRenderingEnabled { get; set; }
Visual Basic
Public Property CompactStyleRenderingEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool CompactStyleRenderingEnabled {
    bool get ();
    void set (bool value);
}

See Also

RowsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


CompactStyleRenderingItemsIndent Property

[image]

VIBlend Controls for WinForms Help Documentation
RowsHierarchy..::..CompactStyleRenderingItemsIndent Property
RowsHierarchy Class See Also Send Feedback
Gets or sets the child items indent in the Rows hierarchy when the hierarchy is rendered in compact style.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int CompactStyleRenderingItemsIndent { get; set; }
Visual Basic
Public Property CompactStyleRenderingItemsIndent As Integer
    Get
    Set
Visual C++
public:
property int CompactStyleRenderingItemsIndent {
    int get ();
    void set (int value);
}

See Also

RowsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


Height Property

[image]

VIBlend Controls for WinForms Help Documentation
RowsHierarchy..::..Height Property
RowsHierarchy Class See Also Send Feedback
Gets the Height of the Hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Height { get; }
Visual Basic
Public ReadOnly Property Height As Integer
    Get
Visual C++
public:
property int Height {
    int get ();
}

See Also

RowsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


Width Property

[image]

VIBlend Controls for WinForms Help Documentation
RowsHierarchy..::..Width Property
RowsHierarchy Class See Also Send Feedback
Gets the Width of the Hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int Width { get; }
Visual Basic
Public ReadOnly Property Width As Integer
    Get
Visual C++
public:
property int Width {
    int get ();
}

See Also

RowsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


RowsHierarchy Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
RowsHierarchy Events
RowsHierarchy Class See Also Send Feedback

The RowsHierarchy type exposes the following members.

Events

 | Name | Description
Public event | FiltersChanged | Occurs when the Hierarchy filters have changed. (Inherited from Hierarchy.)
Public event | SortingChanged | Occurs when the Hierarchy sorting have changed. (Inherited from Hierarchy.)

See Also

RowsHierarchy Class
VIBlend.WinForms.DataGridView Namespace


SortingDirection Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
SortingDirection Enumeration
See Also Send Feedback
Enumeration of the sorting directions.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum SortingDirection
Visual Basic
Public Enumeration SortingDirection
Visual C++
public enum class SortingDirection

Members

Member name | Description
Ascending |
Descending |

See Also

VIBlend.WinForms.DataGridView Namespace


TextBoxEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor Class
Members See Also Send Feedback
Represents a TextBoxEditor used in the GridView control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class TextBoxEditor : vTextBox,
    IEditor
Visual Basic
Public Class TextBoxEditor _
    Inherits vTextBox _
    Implements IEditor
Visual C++
public ref class TextBoxEditor : public vTextBox,
    IEditor

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.Controls..::..vTextBox
VIBlend.WinForms.DataGridView..::..TextBoxEditor

See Also

TextBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


TextBoxEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor Members
TextBoxEditor Class Constructors Methods Properties Events See Also Send Feedback

The TextBoxEditor type exposes the following members.

Constructors

 | Name | Description
Public method | TextBoxEditor | Constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawEditorControl | Handles the painting of the editor control
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Public method | OnGridKeyDown | Handles grid KeyDown events
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from vTextBox.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets a reference to the underlying control of the editor
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DeActivationFlags | Gets or sets the editor activation flags
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum length of the text in the textbox. (Inherited from vTextBox.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TextBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


TextBoxEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor Constructor
TextBoxEditor Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public TextBoxEditor()
Visual Basic
Public Sub New
Visual C++
public:
TextBoxEditor()

See Also

TextBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


TextBoxEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor Methods
TextBoxEditor Class See Also Send Feedback

The TextBoxEditor type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawEditorControl | Handles the painting of the editor control
Protected method | DrawText | Draws the text. (Inherited from vTextBox.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Public method | OnGridKeyDown | Handles grid KeyDown events
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from vTextBox.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from vTextBox.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectAll | selects the whole text. (Inherited from vTextBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

TextBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..AccessibilityNotifyClients Method
TextBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

TextBoxEditor Class
TextBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..BeginInvoke Method
TextBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

TextBoxEditor Class
TextBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..Dispose Method
TextBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

TextBoxEditor Class
TextBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


DrawEditorControl Method

[image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..DrawEditorControl Method
TextBoxEditor Class See Also Send Feedback
Handles the painting of the editor control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawEditorControl(
    Graphics graphics,
    GridCell gridCell,
    out bool isDrawHandled
)
Visual Basic
Public Sub DrawEditorControl ( _
    graphics As Graphics, _
    gridCell As GridCell, _
    <OutAttribute> ByRef isDrawHandled As Boolean _
)
Visual C++
public:
virtual void DrawEditorControl(
    Graphics^ graphics,
    GridCell^ gridCell,
    [OutAttribute] bool% isDrawHandled
) sealed

Parameters

graphics
Type: System.Drawing..::..Graphics
Reference to the GDI+ surface
gridCell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the grid cell being rendered
isDrawHandled
Type: System..::..Boolean %
Output flag indicating whether the method handled the drawing or not

Implements

IEditor..::..DrawEditorControl(Graphics, GridCell, Boolean%)

See Also

TextBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..GetChildAtPoint Method
TextBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

TextBoxEditor Class
TextBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..Invalidate Method
TextBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

TextBoxEditor Class
TextBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..Invoke Method
TextBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

TextBoxEditor Class
TextBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


LayoutEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..LayoutEditor Method
TextBoxEditor Class See Also Send Feedback
This methods is called by the grid control when the editor must update its layout

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void LayoutEditor(
    GridCell cell
)
Visual Basic
Public Overridable Sub LayoutEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void LayoutEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the GridCell being edited

Implements

IEditor..::..LayoutEditor(GridCell)

See Also

TextBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..MemberwiseClone Method
TextBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TextBoxEditor Class
TextBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


OnCloseEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..OnCloseEditor Method
TextBoxEditor Class See Also Send Feedback
This method is called by the grid control when at the end of a cell edit operation

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnCloseEditor()
Visual Basic
Public Sub OnCloseEditor
Visual C++
public:
virtual void OnCloseEditor() sealed

Implements

IEditor..::..OnCloseEditor()()()()

See Also

TextBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


OnGridKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..OnGridKeyDown Method
TextBoxEditor Class See Also Send Feedback
Handles grid KeyDown events

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnGridKeyDown(
    KeyEventArgs args,
    GridCell cell,
    out bool closeEditor,
    out bool closeEditorAndSaveChanges
)
Visual Basic
Public Sub OnGridKeyDown ( _
    args As KeyEventArgs, _
    cell As GridCell, _
    <OutAttribute> ByRef closeEditor As Boolean, _
    <OutAttribute> ByRef closeEditorAndSaveChanges As Boolean _
)
Visual C++
public:
virtual void OnGridKeyDown(
    KeyEventArgs^ args,
    GridCell^ cell,
    [OutAttribute] bool% closeEditor,
    [OutAttribute] bool% closeEditorAndSaveChanges
) sealed

Parameters

args
Type: System.Windows.Forms..::..KeyEventArgs
KeyDown event arguments
cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
closeEditor
Type: System..::..Boolean %
The grid cell where the event occured. This may be null if the event did not occur within a grid cell.Output flag indicating whether to keep the editor open or close it instantly
closeEditorAndSaveChanges
Type: System..::..Boolean %

Implements

IEditor..::..OnGridKeyDown(KeyEventArgs, GridCell, Boolean%, Boolean%)

See Also

TextBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


OnOpenEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..OnOpenEditor Method
TextBoxEditor Class See Also Send Feedback
This method is called by the grid control when the editor is being activated

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnOpenEditor(
    GridCell cell
)
Visual Basic
Public Sub OnOpenEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void OnOpenEditor(
    GridCell^ cell
) sealed

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell

Implements

IEditor..::..OnOpenEditor(GridCell)

See Also

TextBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..PerformLayout Method
TextBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

TextBoxEditor Class
TextBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..ResumeLayout Method
TextBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

TextBoxEditor Class
TextBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..RtlTranslateAlignment Method
TextBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

TextBoxEditor Class
TextBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..Scale Method
TextBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

TextBoxEditor Class
TextBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..Select Method
TextBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

TextBoxEditor Class
TextBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..SetBounds Method
TextBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

TextBoxEditor Class
TextBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..UpdateBounds Method
TextBoxEditor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

TextBoxEditor Class
TextBoxEditor Members
VIBlend.WinForms.DataGridView Namespace


TextBoxEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor Properties
TextBoxEditor Class See Also Send Feedback

The TextBoxEditor type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | AllowAnimations | Gets or sets whether the control is animated (Inherited from vTextBox.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BoundsOffset | Gets or sets the bounds offset. (Inherited from vTextBox.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Control | Gets a reference to the underlying control of the editor
Public property | ControlBorderColor | Gets or sets the BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | ControlHighlightBorderColor | Gets or sets the Highlight BorderColor of the TextBox. (Inherited from vTextBox.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DeActivationFlags | Gets or sets the editor activation flags
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Public property | DefaultText | Gets or sets the default text. (Inherited from vTextBox.)
Public property | DefaultTextColor | Gets or sets the default color of the text. (Inherited from vTextBox.)
Public property | DefaultTextFont | Gets or sets the default text font. (Inherited from vTextBox.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor
Public property | EnableBorderHighlight | Gets or sets whether the border will be highlighted when the user moves the mouse over the control and when the control has focus (Inherited from vTextBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GleamWidth | Gets or sets the width of the gleam. (Inherited from vTextBox.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum length of the text in the textbox. (Inherited from vTextBox.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets whether the vTextBox has multiple lines. (Inherited from vTextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets textbox's password character. (Inherited from vTextBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Readonly | Gets or sets whether the vTextBox is in read only mode. (Inherited from vTextBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets whether the vTextBox is in right-to-left mode. (Inherited from vTextBox.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBars | Gets or sets whether the textbox has scrollbars. (Inherited from vTextBox.)
Public property | SelectionLength | (Inherited from vTextBox.)
Public property | SelectionStart | (Inherited from vTextBox.)
Public property | ShowDefaultText | Gets or sets a value indicating whether to draw default text (Inherited from vTextBox.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | (Inherited from vTextBox.)
Public property | TabStop | (Inherited from vTextBox.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the vTextBox control. (Inherited from vTextBox.)
Public property | TextAlign | Gets or sets the text alignment. (Inherited from vTextBox.)
Public property | TextBox | Gets the text box. (Inherited from vTextBox.)
Public property | Theme | Gets or sets the theme of the control. (Inherited from vTextBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseThemeBorderColor | Gets or sets a value indicating whether to use the ControlBorderColor (Inherited from vTextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme | Gets or sets the theme of the control using one of the built-in themes. (Inherited from vTextBox.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

TextBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


ActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..ActivationFlags Property
TextBoxEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags ActivationFlags { get; set; }
Visual Basic
Public Property ActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags ActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..ActivationFlags

See Also

TextBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


Control Property

[image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..Control Property
TextBoxEditor Class See Also Send Feedback
Gets a reference to the underlying control of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control Control { get; }
Visual Basic
Public ReadOnly Property Control As Control
    Get
Visual C++
public:
virtual property Control^ Control {
    Control^ get () sealed;
}

Implements

IEditor..::..Control

See Also

TextBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


DeActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..DeActivationFlags Property
TextBoxEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags DeActivationFlags { get; set; }
Visual Basic
Public Property DeActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags DeActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..DeActivationFlags

See Also

TextBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorType Property

[image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..EditorType Property
TextBoxEditor Class See Also Send Feedback
Gets the type of the grid cell editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellEditorType EditorType { get; }
Visual Basic
Public ReadOnly Property EditorType As CellEditorType
    Get
Visual C++
public:
virtual property CellEditorType EditorType {
    CellEditorType get () sealed;
}

Implements

IEditor..::..EditorType

See Also

TextBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorValue Property

[image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor..::..EditorValue Property
TextBoxEditor Class See Also Send Feedback
Get's or sets the current value of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object EditorValue { get; set; }
Visual Basic
Public Property EditorValue As Object
    Get
    Set
Visual C++
public:
virtual property Object^ EditorValue {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Implements

IEditor..::..EditorValue

See Also

TextBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


TextBoxEditor Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
TextBoxEditor Events
TextBoxEditor Class See Also Send Feedback

The TextBoxEditor type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TextBoxEditor Class
VIBlend.WinForms.DataGridView Namespace


TrackBarEditor Class

[image]

VIBlend Controls for WinForms Help Documentation
TrackBarEditor Class
Members See Also Send Feedback
Represents a vTrackBarEditor used in the GridView control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class TrackBarEditor : IEditor
Visual Basic
Public Class TrackBarEditor _
    Implements IEditor
Visual C++
public ref class TrackBarEditor : IEditor

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView..::..TrackBarEditor

See Also

TrackBarEditor Members
VIBlend.WinForms.DataGridView Namespace


TrackBarEditor Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
TrackBarEditor Members
TrackBarEditor Class Constructors Methods Properties See Also Send Feedback

The TrackBarEditor type exposes the following members.

Constructors

 | Name | Description
Public method | TrackBarEditor | Initializes a new instance of the TrackBarEditor class

Methods

 | Name | Description
Public method | DrawEditorControl | Handles the painting of the editor control
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Public method | OnGridKeyDown | Handles grid KeyDown events
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | Control | Gets a reference to the underlying control of the editor
Public property | DeActivationFlags | Gets or sets the editor activation flags
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor

See Also

TrackBarEditor Class
VIBlend.WinForms.DataGridView Namespace


TrackBarEditor Constructor

[image]

VIBlend Controls for WinForms Help Documentation
TrackBarEditor Constructor
TrackBarEditor Class See Also Send Feedback
Initializes a new instance of the TrackBarEditor class

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public TrackBarEditor()
Visual Basic
Public Sub New
Visual C++
public:
TrackBarEditor()

See Also

TrackBarEditor Class
VIBlend.WinForms.DataGridView Namespace


TrackBarEditor Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
TrackBarEditor Methods
TrackBarEditor Class See Also Send Feedback

The TrackBarEditor type exposes the following members.

Methods

 | Name | Description
Public method | DrawEditorControl | Handles the painting of the editor control
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LayoutEditor | This methods is called by the grid control when the editor must update its layout
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnCloseEditor | This method is called by the grid control when at the end of a cell edit operation
Public method | OnGridKeyDown | Handles grid KeyDown events
Public method | OnOpenEditor | This method is called by the grid control when the editor is being activated
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackBarEditor Class
VIBlend.WinForms.DataGridView Namespace


DrawEditorControl Method

[image]

VIBlend Controls for WinForms Help Documentation
TrackBarEditor..::..DrawEditorControl Method
TrackBarEditor Class See Also Send Feedback
Handles the painting of the editor control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DrawEditorControl(
    Graphics graphics,
    GridCell gridCell,
    out bool isDrawHandled
)
Visual Basic
Public Sub DrawEditorControl ( _
    graphics As Graphics, _
    gridCell As GridCell, _
    <OutAttribute> ByRef isDrawHandled As Boolean _
)
Visual C++
public:
virtual void DrawEditorControl(
    Graphics^ graphics,
    GridCell^ gridCell,
    [OutAttribute] bool% isDrawHandled
) sealed

Parameters

graphics
Type: System.Drawing..::..Graphics
Reference to the GDI+ surface
gridCell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the grid cell being rendered
isDrawHandled
Type: System..::..Boolean %
Output flag indicating whether the method handled the drawing or not

Implements

IEditor..::..DrawEditorControl(Graphics, GridCell, Boolean%)

See Also

TrackBarEditor Class
VIBlend.WinForms.DataGridView Namespace


LayoutEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
TrackBarEditor..::..LayoutEditor Method
TrackBarEditor Class See Also Send Feedback
This methods is called by the grid control when the editor must update its layout

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void LayoutEditor(
    GridCell cell
)
Visual Basic
Public Overridable Sub LayoutEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void LayoutEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
Reference to the GridCell being edited

Implements

IEditor..::..LayoutEditor(GridCell)

See Also

TrackBarEditor Class
VIBlend.WinForms.DataGridView Namespace


OnCloseEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
TrackBarEditor..::..OnCloseEditor Method
TrackBarEditor Class See Also Send Feedback
This method is called by the grid control when at the end of a cell edit operation

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void OnCloseEditor()
Visual Basic
Public Overridable Sub OnCloseEditor
Visual C++
public:
virtual void OnCloseEditor()

Implements

IEditor..::..OnCloseEditor()()()()

See Also

TrackBarEditor Class
VIBlend.WinForms.DataGridView Namespace


OnGridKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
TrackBarEditor..::..OnGridKeyDown Method
TrackBarEditor Class See Also Send Feedback
Handles grid KeyDown events

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void OnGridKeyDown(
    KeyEventArgs args,
    GridCell cell,
    out bool closeEditor,
    out bool closeEditorAndSaveChanges
)
Visual Basic
Public Sub OnGridKeyDown ( _
    args As KeyEventArgs, _
    cell As GridCell, _
    <OutAttribute> ByRef closeEditor As Boolean, _
    <OutAttribute> ByRef closeEditorAndSaveChanges As Boolean _
)
Visual C++
public:
virtual void OnGridKeyDown(
    KeyEventArgs^ args,
    GridCell^ cell,
    [OutAttribute] bool% closeEditor,
    [OutAttribute] bool% closeEditorAndSaveChanges
) sealed

Parameters

args
Type: System.Windows.Forms..::..KeyEventArgs
KeyDown event arguments
cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
The grid cell where the event occured. This may be null if the event did not occur within a grid cell.
closeEditor
Type: System..::..Boolean %
Output flag indicating whether to keep the editor open or close it instantly
closeEditorAndSaveChanges
Type: System..::..Boolean %

Implements

IEditor..::..OnGridKeyDown(KeyEventArgs, GridCell, Boolean%, Boolean%)

See Also

TrackBarEditor Class
VIBlend.WinForms.DataGridView Namespace


OnOpenEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
TrackBarEditor..::..OnOpenEditor Method
TrackBarEditor Class See Also Send Feedback
This method is called by the grid control when the editor is being activated

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void OnOpenEditor(
    GridCell cell
)
Visual Basic
Public Overridable Sub OnOpenEditor ( _
    cell As GridCell _
)
Visual C++
public:
virtual void OnOpenEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell

Implements

IEditor..::..OnOpenEditor(GridCell)

See Also

TrackBarEditor Class
VIBlend.WinForms.DataGridView Namespace


TrackBarEditor Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
TrackBarEditor Properties
TrackBarEditor Class See Also Send Feedback

The TrackBarEditor type exposes the following members.

Properties

 | Name | Description
Public property | ActivationFlags | Gets or sets the editor activation flags
Public property | Control | Gets a reference to the underlying control of the editor
Public property | DeActivationFlags | Gets or sets the editor activation flags
Public property | EditorType | Gets the type of the grid cell editor
Public property | EditorValue | Get's or sets the current value of the editor

See Also

TrackBarEditor Class
VIBlend.WinForms.DataGridView Namespace


ActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
TrackBarEditor..::..ActivationFlags Property
TrackBarEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags ActivationFlags { get; set; }
Visual Basic
Public Property ActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags ActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..ActivationFlags

See Also

TrackBarEditor Class
VIBlend.WinForms.DataGridView Namespace


Control Property

[image]

VIBlend Controls for WinForms Help Documentation
TrackBarEditor..::..Control Property
TrackBarEditor Class See Also Send Feedback
Gets a reference to the underlying control of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Control Control { get; }
Visual Basic
Public ReadOnly Property Control As Control
    Get
Visual C++
public:
virtual property Control^ Control {
    Control^ get () sealed;
}

Implements

IEditor..::..Control

See Also

TrackBarEditor Class
VIBlend.WinForms.DataGridView Namespace


DeActivationFlags Property

[image]

VIBlend Controls for WinForms Help Documentation
TrackBarEditor..::..DeActivationFlags Property
TrackBarEditor Class See Also Send Feedback
Gets or sets the editor activation flags

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public EditorActivationFlags DeActivationFlags { get; set; }
Visual Basic
Public Property DeActivationFlags As EditorActivationFlags
    Get
    Set
Visual C++
public:
virtual property EditorActivationFlags DeActivationFlags {
    EditorActivationFlags get () sealed;
    void set (EditorActivationFlags value) sealed;
}

Implements

IEditor..::..DeActivationFlags

See Also

TrackBarEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorType Property

[image]

VIBlend Controls for WinForms Help Documentation
TrackBarEditor..::..EditorType Property
TrackBarEditor Class See Also Send Feedback
Gets the type of the grid cell editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellEditorType EditorType { get; }
Visual Basic
Public ReadOnly Property EditorType As CellEditorType
    Get
Visual C++
public:
virtual property CellEditorType EditorType {
    CellEditorType get () sealed;
}

Implements

IEditor..::..EditorType

See Also

TrackBarEditor Class
VIBlend.WinForms.DataGridView Namespace


EditorValue Property

[image]

VIBlend Controls for WinForms Help Documentation
TrackBarEditor..::..EditorValue Property
TrackBarEditor Class See Also Send Feedback
Get's or sets the current value of the editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object EditorValue { get; set; }
Visual Basic
Public Property EditorValue As Object
    Get
    Set
Visual C++
public:
virtual property Object^ EditorValue {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Implements

IEditor..::..EditorValue

See Also

TrackBarEditor Class
VIBlend.WinForms.DataGridView Namespace


vDataGridView Class

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView Class
Members See Also Send Feedback
Represents a GridView control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vDataGridView : Control,
    IScrollableControlBase, INotifyPropertyChanged
Visual Basic
Public Class vDataGridView _
    Inherits Control _
    Implements IScrollableControlBase, INotifyPropertyChanged
Visual C++
public ref class vDataGridView : public Control,
    IScrollableControlBase, INotifyPropertyChanged

Remarks

vDataGridView is highly customizable data grid control that allows the user to visualize hierarchical data on rows, and on columns. vDataGridView can work in both databound, and unbound modes. The data can be displayed in standard tabular format, or transformed to a pivot table view.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.DataGridView..::..vDataGridView

See Also

vDataGridView Members
VIBlend.WinForms.DataGridView Namespace


vDataGridView Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView Members
vDataGridView Class Constructors Methods Fields Properties Events See Also Send Feedback

The vDataGridView type exposes the following members.

Constructors

 | Name | Description
Public method | vDataGridView | GridView constructor

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdateTotals | Begins the update totals.
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clears the DataGrid data.
Public method | CloseEditor | Submits a deactivation request to the currently opened editor
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DataBind | Binds data from the data source to the control.
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Protected method | DisplayContextMenu | Displays the context menu.
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | DrillThroughPivotCell | Gets the indexes of the rows set that is used to calculate the value of the grid cell in the pivot table view.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdateTotals | Ends the update totals.
Public method | EnsureVisible(GridCell) | Ensures that the specified grid cell is visible within the control, scrolling the contents of the control if necessary.
Public method | EnsureVisible(HierarchyItem) | Ensures that the specified item is visible within the control, scrolling the contents of the control if necessary.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHeight | Gets the height of the gridview control
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWidth | Gets the width of the gridview control
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HideColumnChooser | Hides the column chooser.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LoadColumnsLayout | Loads the columns layout.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoScrollPositionChanged |
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | (Overrides Control..::..OnBindingContextChanged(EventArgs).)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnCellBeginEdit | Raises the CellBedingEdit event
Protected method | OnCellEndEdit | Raises the CellEndEdit event
Protected method | OnCellKeyDown | Raises the [E:CellKeyDown] event.
Protected method | OnCellKeyUp | Raises the [E:CellKeyUp] event.
Protected method | OnCellMouseClick | Raises the CellMouseClick event
Protected method | OnCellMousedoubleClick | Raises the CellMousedoubleClick event
Protected method | OnCellMouseDown | Raises the CellMouseDown event
Protected method | OnCellMouseEnter | Raises the CellMouseEnter event
Protected method | OnCellMouseLeave | Raises the CellMouseLeave event
Protected method | OnCellMouseMove | Raises the CellMouseMove event
Protected method | OnCellMouseUp | Raises the CellMouseUp event
Protected method | OnCellParsing | Raises the CellParsing event
Protected method | OnCellSelectionChanged | Raises the CellSelectionChanged event.
Protected method | OnCellValidated | Raises the CellValidated event
Protected method | OnCellValidating | Raises the CellValidating event
Protected method | OnCellValueChanged | Raises the CellValueChanged event.
Protected method | OnCellValueChanging | Raises the CellValueChanging event.
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuClosed | Called when the context menu is closed.
Protected method | OnContextMenuShowing | Called when the context menu is showing.
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Overrides Control..::..OnControlRemoved(ControlEventArgs).)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | (Overrides Control..::..OnDoubleClick(EventArgs).)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | (Overrides Control..::..OnGotFocus(EventArgs).)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnHierarchyItemMouseClick | Raises the HierarchyItemMouseClick event.
Protected method | OnHierarchyItemMouseDoubleClick | Raises the HierarchyItemMouseDoubleClick event
Protected method | OnHierarchyItemMouseDown | Raises the HierarchyItemMouseDown event.
Protected method | OnHierarchyItemMouseUp | Raises the HierarchyItemMouseUp event.
Protected method | OnHorizontalScrollBarValueChanged | Raises the [E:HorizontalScrollBarValueChanged] event.
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemCollapsed | Raises the ItemCollapsed event
Protected method | OnItemExpanded | Raises the ItemExpanded event
Protected method | OnKeyDown | Raises the KeyDown event. (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Overrides Control..::..OnKeyUp(KeyEventArgs).)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnListChanged |
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Overrides Control..::..OnLostFocus(EventArgs).)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Overrides Control..::..OnMouseClick(MouseEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Overrides Control..::..OnMouseDoubleClick(MouseEventArgs).)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Overrides Control..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | (Overrides Control..::..OnMouseWheel(MouseEventArgs).)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when a property is changed.
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVerticalScrollBarValueChanged | Raises the [E:VerticalScrollBarValueChanged] event.
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveSort | Obsolete.
Public method | Render | Renders the content of the Data Grid Control
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | SaveColumnsLayout | Saves the layout.
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowColumnChooser()()()() | Shows the column chooser.
Public method | ShowColumnChooser(Point) | Shows the column chooser at a specific location.
Public method | ShowEditor(GridCell) | Submits an activation request to a grid cell's editor
Public method | ShowEditor(HierarchyItem, HierarchyItem) | Submits an activation request to a grid cell's editor
Public method | ShowFilterForm | Shows the filter form.
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SortBy | Obsolete.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Fields

Name Description
Public field BoundFields
Collection of Bound fields representing data binding relationships between data columns from the data source, and grid columns or rows
Public field BoundFieldsFilters
Collection of Bound filter fields that filter the grid data which will be displayed in a pivot table scenario
Public field BoundPivotColumns
Collection of Bound fields for which the grid data will be displayed on columns in a pivot table scenario
Public field BoundPivotRows
Collection of Bound fields for which the grid data will be displayed on rows in a pivot table scenario
Public field BoundPivotValues
Collection of BoundValue fields which will form the Pivot table values. In a pivot table the values can be attached either next to the rows or to the columns.
Public field GridCellSortComparer
Represents a custom grid cell comparer

Remarks

Use this property to override the default sorting behaviour of the grid
Public field GroupingColumns
Collection of Bound fields (columns) that the datagrid will be using to group rows
Public field PivotValuesOnRows
Determines whether the pivot table values are displayed next to the pivot rows or next to pivot columns

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether to use animations when visualizing the content of the grid
Public property | AllowCellMerge | Gets or sets whether the cells could be merged
Public property | AllowClipDrawing | Gets or sets whether the clip drawing is allowed
Public property | AllowContextMenuColumnChooser | Gets or sets a value indicating whether the 'Column Chooser' menu item is enabled.
Public property | AllowContextMenuFiltering | Determines whether to display the sorting options in the grid's context menu
Public property | AllowContextMenuGrouping | Gets or sets a value indicating whether the 'Group by this column' menu item is enabled.
Public property | AllowContextMenuSorting | Determines whether to display the sorting options in the grid's context menu
Public property | AllowCopyPaste | Gets or sets whether to enable copy/paste operations within the grid cells
Public property | AllowDefaultContextMenu | Gets or sets a value indicating whether the built-in context menu can be displayed.
Public property | AllowDragDropIndication | Gets or sets whether the dragging indicator is displayed
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowHeaderItemHighlightOnCellSelection | Gets or sets whether the header item is highlighted on cell selection
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoGenerateColumns | Gets or sets whether the DataGrid will automatically bind to all columns available in the data source.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | AutoUpdateOnListChanged | Gets or sets a value indicating whether the grid's cells are updated when a list changed event occurs.
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BindingProgressEnabled | Gets or sets whether the data binding progress indicator is visible
Public property | BindingProgressSampleRate | Gets or sets the data binding progress sample rate. The value must be between 1,000 and 100,000.
Public property | BindingState | Gets the current data binding state of the grid control
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CellsArea | Gets the cells area
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColumnChooser | Gets the column chooser.
Public property | ColumnsHierarchy | Gets the Columns hierarchy
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Overrides Control..::..ContextMenuStrip.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DataManager |
Public property | DataMember | Gets or sets the DataMember for the grid DataSource
Public property | DataSource | Gets or sets the DataSource of the grid control
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableColumnChooser | "Enables/disables the column chooser which allows you to easily show/hide columns.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableResizeToolTip | Enables/disables the tooltips which are shown when you resize a column/row.
Public property | EnableToolTips | Gets or sets a value indicating whether the tooltips are enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FilterDisplayMode | Gets or sets a value indicating the filtering window display mode.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GridLinesDashStyle | Gets or sets the grid lines dash style.
Public property | GridLinesDisplayMode | Determines how the grid lines will be displayed.
Public property | GroupingDefaultHeaderTextVisible | Gets or sets whether the rows group name and rows count is visible in the rows grouping headers.
Public property | GroupingEnabled | Determines if grouping is enabled or not.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets or sets the horizontal scroll position
Public property | HorizontalScrollBarLargeChange | Gets or sets the LargeChange of the Horizontal ScrollBar.
Public property | HorizontalScrollBarSmallChange | Gets or sets the SmallChange of the Horizontal ScrollBar.
Public property | ImageList | Gets or sets the image list associated to the grid control
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Localization | Gets the localization.
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultipleSelectionEnabled | Gets or sets whether multiple selection is enabled.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PivotColumnsTotalsEnabled | Gets or sets if the Pivot Table Columns Totals are enabled.
Public property | PivotColumnsTotalsMode | Gets or sets the Pivot Table Columns totals display mode.
Public property | PivotRowsTotalsEnabled | Gets or sets if the Pivot Table Rows Totals are enabled.
Public property | PivotRowsTotalsMode | Gets or sets the Pivot Table Rows totals display mode.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | ResizeToolTip | Gets the resize tool tip.
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RowsHierarchy | Gets the Rows hierarchy
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBarsEnabled | Determines whether the Horizontal and Vertical ScrollBars will be displayed
Public property | SelectionBorderDashStyle | Gets or sets the line dash style of the selection border
Public property | SelectionBorderEnabled | Determines whether the grid should draw a border around the selected grid cells
Public property | SelectionBorderWidth | Gets or sets the width in pixel of the selection border
Public property | SelectionMode | Gets or sets the grid cells selection mode
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the grid theme.
Public property | ToolTipDuration | Gets or sets the duration of the tool tip.
Public property | ToolTipShowDelay | Gets or sets the tool tip show delay.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets or sets the vertical scroll position
Public property | VerticalScrollBarLargeChange | Gets or sets the LargeChange of the Vertical ScrollBar.
Public property | VerticalScrollBarSmallChange | Gets or sets the SmallChange of the Vertical ScrollBar.
Public property | VIBlendTheme | Gets or sets the DataGrid's theme.
Public property | VirtualModeCellDefault | Gets or sets whether the grid cells are in virtual mode by default
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoScrollPositionChanged | Occurs when the scroll position has changed
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindField | Occurs when a the grid binds to data column from the data source
Public event | BindingComplete | Occurs when a data binding operation is complete.
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | BindingProgressChanged | Occurs when the data binding progress changes
Public event | BindingStart | Occurs when a data binding operation is complete.
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | CellBeginEdit | Occurs when a cell edit is begining
Public event | CellCustomPaint | Occurs when a cell is painted
Public event | CellEditorActivate | Occurs when a cell editor is being activated
Public event | CellEditorDeActivate | Occurs when a cell editor is being activated
Public event | CellEndEdit | Occurs when a cell edit is ending
Public event | CellKeyDown | Occurs when a key is down.
Public event | CellKeyUp | Occurs when a key is up.
Public event | CellMouseClick | Occurs when the mouse button is clicked in cell bounds
Public event | CellMouseDoubleClick | Occurs when the mouse button is double clicked inside the cell bounds.
Public event | CellMouseDown | Occurs when the mouse button is down in a cell bounds
Public event | CellMouseEnter | Occurs when the mouse pointer has entered cell bounds
Public event | CellMouseLeave | Occurs when the mouse pointer has left cell bounds
Public event | CellMouseMove | Occurs when a cell edit is ending
Public event | CellMouseUp | Occurs when the mouse button is released
Public event | CellPaintBegin | Occurs when a cell is painted.
Public event | CellParsing | Occurs when a cell date is parsed
Public event | CellSelectionChanged | Occurs when the grid cells selection has changed
Public event | CellValidated | Occurs when a cell is validated
Public event | CellValidating | Occurs when a cell is validating
Public event | CellValueChanged | Occurs after the value of a grid cell changed.
Public event | CellValueChanging | Occurs before a grid cell value changes.
Public event | CellValueNeeded | Occurs before a grid cell painting. Use this event in virtual mode to specify the content of the grid cell
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuClosed | Occurs when the built-in context menu is being closed
Public event | ContextMenuShowing | Occurs when the built-in context menu is being displayed.
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | GroupHeaderCustomTextNeeded | Occurs when a the rows group header is rendered. Use this event customize the text of the rows group headers.
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HierarchyItemCollapsed | Occurs when a HierarchyItem is collapsed
Public event | HierarchyItemCollapsing | Occurs when a HierarchyItem is collapsing
Public event | HierarchyItemCustomPaint | Occurs when a HierarchyItem is painted
Public event | HierarchyItemDrag | Occurs when a header item is dragged.
Public event | HierarchyItemDragEnded | Occurs when a drag operation with header item is ended
Public event | HierarchyItemDragEnding | Occurs when a drag operation with header item is ending
Public event | HierarchyItemDragStarted | Occurs when a drag operation with header item is started
Public event | HierarchyItemDragStarting | Occurs when a drag operation with header item is starting
Public event | HierarchyItemExpanded | Occurs when a HierarchyItem is expanded
Public event | HierarchyItemExpanding | Occurs when a HierarchyItem is expanding
Public event | HierarchyItemMouseClick | Occurs when a HierarchyItem is clicked
Public event | HierarchyItemMouseDoubleClick | Occurs when a HierarchyItem is double clicked.
Public event | HierarchyItemMouseDown | Occurs when the user presses a mouse button over HierarchyItem.
Public event | HierarchyItemMouseUp | Occurs when the user releases a mouse button over HierarchyItem.
Public event | HierarchyItemSelectionChanged | Occurs when the selection of a HierarchyItem has changed.
Public event | HorizontalScrollBarValueChanged | Occurs when the horizontal scrollbar value is changed.
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | ListChanged | Occurs when the CurrencyManager ListChanged event is raised.
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property is changed.
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | TooltipShow | Occurs before a tooltip is shown and provides a way to customize the tooltip text
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VerticalScrollBarValueChanged | Occurs when the vertical scrollbar value is changed.
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


vDataGridView Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView Constructor
vDataGridView Class See Also Send Feedback
GridView constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDataGridView()
Visual Basic
Public Sub New
Visual C++
public:
vDataGridView()

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


vDataGridView Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView Fields
vDataGridView Class See Also Send Feedback

The vDataGridView type exposes the following members.

Fields

Name Description
Public field BoundFields
Collection of Bound fields representing data binding relationships between data columns from the data source, and grid columns or rows
Public field BoundFieldsFilters
Collection of Bound filter fields that filter the grid data which will be displayed in a pivot table scenario
Public field BoundPivotColumns
Collection of Bound fields for which the grid data will be displayed on columns in a pivot table scenario
Public field BoundPivotRows
Collection of Bound fields for which the grid data will be displayed on rows in a pivot table scenario
Public field BoundPivotValues
Collection of BoundValue fields which will form the Pivot table values. In a pivot table the values can be attached either next to the rows or to the columns.
Public field GridCellSortComparer
Represents a custom grid cell comparer

Remarks

Use this property to override the default sorting behaviour of the grid
Public field GroupingColumns
Collection of Bound fields (columns) that the datagrid will be using to group rows
Public field PivotValuesOnRows
Determines whether the pivot table values are displayed next to the pivot rows or next to pivot columns

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


BoundFields Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..BoundFields Field
vDataGridView Class See Also Send Feedback
Collection of Bound fields representing data binding relationships between data columns from the data source, and grid columns or rows

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BoundItemsCollection<BoundField> BoundFields
Visual Basic
Public BoundFields As BoundItemsCollection(Of BoundField)
Visual C++
public:
BoundItemsCollection<BoundField^>^ BoundFields

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


BoundFieldsFilters Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..BoundFieldsFilters Field
vDataGridView Class See Also Send Feedback
Collection of Bound filter fields that filter the grid data which will be displayed in a pivot table scenario

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BoundItemsCollection<BoundFieldFilter> BoundFieldsFilters
Visual Basic
Public BoundFieldsFilters As BoundItemsCollection(Of BoundFieldFilter)
Visual C++
public:
BoundItemsCollection<BoundFieldFilter^>^ BoundFieldsFilters

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


BoundPivotColumns Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..BoundPivotColumns Field
vDataGridView Class See Also Send Feedback
Collection of Bound fields for which the grid data will be displayed on columns in a pivot table scenario

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BoundItemsCollection<BoundField> BoundPivotColumns
Visual Basic
Public BoundPivotColumns As BoundItemsCollection(Of BoundField)
Visual C++
public:
BoundItemsCollection<BoundField^>^ BoundPivotColumns

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace
vDataGridView..::..BoundPivotRows
vDataGridView..::..BoundPivotValues


BoundPivotRows Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..BoundPivotRows Field
vDataGridView Class See Also Send Feedback
Collection of Bound fields for which the grid data will be displayed on rows in a pivot table scenario

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BoundItemsCollection<BoundField> BoundPivotRows
Visual Basic
Public BoundPivotRows As BoundItemsCollection(Of BoundField)
Visual C++
public:
BoundItemsCollection<BoundField^>^ BoundPivotRows

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace
vDataGridView..::..BoundPivotColumns
vDataGridView..::..BoundPivotValues


BoundPivotValues Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..BoundPivotValues Field
vDataGridView Class See Also Send Feedback
Collection of BoundValue fields which will form the Pivot table values. In a pivot table the values can be attached either next to the rows or to the columns.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BoundItemsCollection<BoundValueField> BoundPivotValues
Visual Basic
Public BoundPivotValues As BoundItemsCollection(Of BoundValueField)
Visual C++
public:
BoundItemsCollection<BoundValueField^>^ BoundPivotValues

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace
vDataGridView..::..PivotValuesOnRows
vDataGridView..::..BoundPivotRows
vDataGridView..::..BoundPivotColumns


GridCellSortComparer Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GridCellSortComparer Field
vDataGridView Class See Also Send Feedback
Represents a custom grid cell comparer

Remarks

Use this property to override the default sorting behaviour of the grid

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public IComparer<GridCell> GridCellSortComparer
Visual Basic
Public GridCellSortComparer As IComparer(Of GridCell)
Visual C++
public:
IComparer<GridCell^>^ GridCellSortComparer

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


GroupingColumns Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GroupingColumns Field
vDataGridView Class See Also Send Feedback
Collection of Bound fields (columns) that the datagrid will be using to group rows

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public BoundItemsCollection<BoundField> GroupingColumns
Visual Basic
Public GroupingColumns As BoundItemsCollection(Of BoundField)
Visual C++
public:
BoundItemsCollection<BoundField^>^ GroupingColumns

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace
vDataGridView..::..BoundPivotColumns
vDataGridView..::..BoundPivotRows


PivotValuesOnRows Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..PivotValuesOnRows Field
vDataGridView Class See Also Send Feedback
Determines whether the pivot table values are displayed next to the pivot rows or next to pivot columns

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PivotValuesOnRows
Visual Basic
Public PivotValuesOnRows As Boolean
Visual C++
public:
bool PivotValuesOnRows

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


vDataGridView Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView Methods
vDataGridView Class See Also Send Feedback

The vDataGridView type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdateTotals | Begins the update totals.
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clears the DataGrid data.
Public method | CloseEditor | Submits a deactivation request to the currently opened editor
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DataBind | Binds data from the data source to the control.
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Protected method | DisplayContextMenu | Displays the context menu.
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | DrillThroughPivotCell | Gets the indexes of the rows set that is used to calculate the value of the grid cell in the pivot table view.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdateTotals | Ends the update totals.
Public method | EnsureVisible(GridCell) | Ensures that the specified grid cell is visible within the control, scrolling the contents of the control if necessary.
Public method | EnsureVisible(HierarchyItem) | Ensures that the specified item is visible within the control, scrolling the contents of the control if necessary.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHeight | Gets the height of the gridview control
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWidth | Gets the width of the gridview control
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HideColumnChooser | Hides the column chooser.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LoadColumnsLayout | Loads the columns layout.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoScrollPositionChanged |
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | (Overrides Control..::..OnBindingContextChanged(EventArgs).)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnCellBeginEdit | Raises the CellBedingEdit event
Protected method | OnCellEndEdit | Raises the CellEndEdit event
Protected method | OnCellKeyDown | Raises the [E:CellKeyDown] event.
Protected method | OnCellKeyUp | Raises the [E:CellKeyUp] event.
Protected method | OnCellMouseClick | Raises the CellMouseClick event
Protected method | OnCellMousedoubleClick | Raises the CellMousedoubleClick event
Protected method | OnCellMouseDown | Raises the CellMouseDown event
Protected method | OnCellMouseEnter | Raises the CellMouseEnter event
Protected method | OnCellMouseLeave | Raises the CellMouseLeave event
Protected method | OnCellMouseMove | Raises the CellMouseMove event
Protected method | OnCellMouseUp | Raises the CellMouseUp event
Protected method | OnCellParsing | Raises the CellParsing event
Protected method | OnCellSelectionChanged | Raises the CellSelectionChanged event.
Protected method | OnCellValidated | Raises the CellValidated event
Protected method | OnCellValidating | Raises the CellValidating event
Protected method | OnCellValueChanged | Raises the CellValueChanged event.
Protected method | OnCellValueChanging | Raises the CellValueChanging event.
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuClosed | Called when the context menu is closed.
Protected method | OnContextMenuShowing | Called when the context menu is showing.
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Overrides Control..::..OnControlRemoved(ControlEventArgs).)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | (Overrides Control..::..OnDoubleClick(EventArgs).)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | (Overrides Control..::..OnGotFocus(EventArgs).)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnHierarchyItemMouseClick | Raises the HierarchyItemMouseClick event.
Protected method | OnHierarchyItemMouseDoubleClick | Raises the HierarchyItemMouseDoubleClick event
Protected method | OnHierarchyItemMouseDown | Raises the HierarchyItemMouseDown event.
Protected method | OnHierarchyItemMouseUp | Raises the HierarchyItemMouseUp event.
Protected method | OnHorizontalScrollBarValueChanged | Raises the [E:HorizontalScrollBarValueChanged] event.
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemCollapsed | Raises the ItemCollapsed event
Protected method | OnItemExpanded | Raises the ItemExpanded event
Protected method | OnKeyDown | Raises the KeyDown event. (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Overrides Control..::..OnKeyUp(KeyEventArgs).)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnListChanged |
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Overrides Control..::..OnLostFocus(EventArgs).)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Overrides Control..::..OnMouseClick(MouseEventArgs).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Overrides Control..::..OnMouseDoubleClick(MouseEventArgs).)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Overrides Control..::..OnMouseEnter(EventArgs).)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | (Overrides Control..::..OnMouseWheel(MouseEventArgs).)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPropertyChanged | Called when a property is changed.
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVerticalScrollBarValueChanged | Raises the [E:VerticalScrollBarValueChanged] event.
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveSort | Obsolete.
Public method | Render | Renders the content of the Data Grid Control
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | SaveColumnsLayout | Saves the layout.
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowColumnChooser()()()() | Shows the column chooser.
Public method | ShowColumnChooser(Point) | Shows the column chooser at a specific location.
Public method | ShowEditor(GridCell) | Submits an activation request to a grid cell's editor
Public method | ShowEditor(HierarchyItem, HierarchyItem) | Submits an activation request to a grid cell's editor
Public method | ShowFilterForm | Shows the filter form.
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SortBy | Obsolete.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..AccessibilityNotifyClients Method
vDataGridView Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vDataGridView Class
vDataGridView Members
VIBlend.WinForms.DataGridView Namespace


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..BeginInvoke Method
vDataGridView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vDataGridView Class
vDataGridView Members
VIBlend.WinForms.DataGridView Namespace


BeginUpdateTotals Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..BeginUpdateTotals Method
vDataGridView Class See Also Send Feedback
Begins the update totals.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void BeginUpdateTotals()
Visual Basic
Public Sub BeginUpdateTotals
Visual C++
public:
void BeginUpdateTotals()

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


Clear Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..Clear Method
vDataGridView Class See Also Send Feedback
Clears the DataGrid data.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CloseEditor Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CloseEditor Method
vDataGridView Class See Also Send Feedback
Submits a deactivation request to the currently opened editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void CloseEditor(
    bool CancelChanges
)
Visual Basic
Public Sub CloseEditor ( _
    CancelChanges As Boolean _
)
Visual C++
public:
void CloseEditor(
    bool CancelChanges
)

Parameters

CancelChanges
Type: System..::..Boolean
A Flag indicating whether the new value should be canceled or commited

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


DataBind Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..DataBind Method
vDataGridView Class See Also Send Feedback
Binds data from the data source to the control.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void DataBind()
Visual Basic
Public Sub DataBind
Visual C++
public:
void DataBind()

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


DisplayContextMenu Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..DisplayContextMenu Method
vDataGridView Class See Also Send Feedback
Displays the context menu.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void DisplayContextMenu(
    HierarchyItem item
)
Visual Basic
Protected Overridable Sub DisplayContextMenu ( _
    item As HierarchyItem _
)
Visual C++
protected:
virtual void DisplayContextMenu(
    HierarchyItem^ item
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The item.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..Dispose Method
vDataGridView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Control..::..Dispose(Boolean).)

See Also

vDataGridView Class
vDataGridView Members
VIBlend.WinForms.DataGridView Namespace


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..Dispose Method (Boolean)
vDataGridView Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

vDataGridView Class
Dispose Overload
VIBlend.WinForms.DataGridView Namespace


DrillThroughPivotCell Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..DrillThroughPivotCell Method
vDataGridView Class See Also Send Feedback
Gets the indexes of the rows set that is used to calculate the value of the grid cell in the pivot table view.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int[] DrillThroughPivotCell(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Public Function DrillThroughPivotCell ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
) As Integer()
Visual C++
public:
array<int>^ DrillThroughPivotCell(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Row Hierarchy Item of the grid cell.
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
Column Hierarchy Item of the grid cell.

Return Value

Array of row indexes representing the rows set used to calculate the value of the pivot table cell.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


EndUpdateTotals Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..EndUpdateTotals Method
vDataGridView Class See Also Send Feedback
Ends the update totals.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void EndUpdateTotals()
Visual Basic
Public Sub EndUpdateTotals
Visual C++
public:
void EndUpdateTotals()

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


EnsureVisible Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..EnsureVisible Method
vDataGridView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EnsureVisible(GridCell) | Ensures that the specified grid cell is visible within the control, scrolling the contents of the control if necessary.
Public method | EnsureVisible(HierarchyItem) | Ensures that the specified item is visible within the control, scrolling the contents of the control if necessary.

See Also

vDataGridView Class
vDataGridView Members
VIBlend.WinForms.DataGridView Namespace


EnsureVisible Method (GridCell)

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..EnsureVisible Method (GridCell)
vDataGridView Class See Also Send Feedback
Ensures that the specified grid cell is visible within the control, scrolling the contents of the control if necessary.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void EnsureVisible(
    GridCell cell
)
Visual Basic
Public Sub EnsureVisible ( _
    cell As GridCell _
)
Visual C++
public:
void EnsureVisible(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
The GridCell to scroll into view.

See Also

vDataGridView Class
EnsureVisible Overload
VIBlend.WinForms.DataGridView Namespace


EnsureVisible Method (HierarchyItem)

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..EnsureVisible Method (HierarchyItem)
vDataGridView Class See Also Send Feedback
Ensures that the specified item is visible within the control, scrolling the contents of the control if necessary.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void EnsureVisible(
    HierarchyItem item
)
Visual Basic
Public Sub EnsureVisible ( _
    item As HierarchyItem _
)
Visual C++
public:
void EnsureVisible(
    HierarchyItem^ item
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The HierarchyItem to scroll into view.

See Also

vDataGridView Class
EnsureVisible Overload
VIBlend.WinForms.DataGridView Namespace


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GetChildAtPoint Method
vDataGridView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vDataGridView Class
vDataGridView Members
VIBlend.WinForms.DataGridView Namespace


GetHeight Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GetHeight Method
vDataGridView Class See Also Send Feedback
Gets the height of the gridview control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int GetHeight()
Visual Basic
Public Function GetHeight As Integer
Visual C++
public:
int GetHeight()

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


GetWidth Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GetWidth Method
vDataGridView Class See Also Send Feedback
Gets the width of the gridview control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int GetWidth()
Visual Basic
Public Function GetWidth As Integer
Visual C++
public:
int GetWidth()

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HideColumnChooser Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HideColumnChooser Method
vDataGridView Class See Also Send Feedback
Hides the column chooser.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void HideColumnChooser()
Visual Basic
Public Sub HideColumnChooser
Visual C++
public:
void HideColumnChooser()

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..Invalidate Method
vDataGridView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vDataGridView Class
vDataGridView Members
VIBlend.WinForms.DataGridView Namespace


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..Invoke Method
vDataGridView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vDataGridView Class
vDataGridView Members
VIBlend.WinForms.DataGridView Namespace


LoadColumnsLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..LoadColumnsLayout Method
vDataGridView Class See Also Send Feedback
Loads the columns layout.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void LoadColumnsLayout(
    Stream stream
)
Visual Basic
Public Sub LoadColumnsLayout ( _
    stream As Stream _
)
Visual C++
public:
void LoadColumnsLayout(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
The stream.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..MemberwiseClone Method
vDataGridView Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vDataGridView Class
vDataGridView Members
VIBlend.WinForms.DataGridView Namespace


OnAutoScrollPositionChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnAutoScrollPositionChanged Method
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnAutoScrollPositionChanged(
    EventArgs args
)
Visual Basic
Protected Overridable Sub OnAutoScrollPositionChanged ( _
    args As EventArgs _
)
Visual C++
protected:
virtual void OnAutoScrollPositionChanged(
    EventArgs^ args
)

Parameters

args
Type: System..::..EventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnBindingContextChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnBindingContextChanged Method
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnBindingContextChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnBindingContextChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnBindingContextChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnCellBeginEdit Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnCellBeginEdit Method
vDataGridView Class See Also Send Feedback
Raises the CellBedingEdit event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCellBeginEdit(
    CellCancelEventArgs args
)
Visual Basic
Protected Overridable Sub OnCellBeginEdit ( _
    args As CellCancelEventArgs _
)
Visual C++
protected:
virtual void OnCellBeginEdit(
    CellCancelEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..CellCancelEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnCellEndEdit Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnCellEndEdit Method
vDataGridView Class See Also Send Feedback
Raises the CellEndEdit event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCellEndEdit(
    CellCancelEventArgs args
)
Visual Basic
Protected Overridable Sub OnCellEndEdit ( _
    args As CellCancelEventArgs _
)
Visual C++
protected:
virtual void OnCellEndEdit(
    CellCancelEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..CellCancelEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnCellKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnCellKeyDown Method
vDataGridView Class See Also Send Feedback
Raises the [E:CellKeyDown] event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCellKeyDown(
    vDataGridView..::..CellKeyEventArgs args
)
Visual Basic
Protected Overridable Sub OnCellKeyDown ( _
    args As vDataGridView..::..CellKeyEventArgs _
)
Visual C++
protected:
virtual void OnCellKeyDown(
    vDataGridView..::..CellKeyEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..vDataGridView..::..CellKeyEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnCellKeyUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnCellKeyUp Method
vDataGridView Class See Also Send Feedback
Raises the [E:CellKeyUp] event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCellKeyUp(
    vDataGridView..::..CellKeyEventArgs args
)
Visual Basic
Protected Overridable Sub OnCellKeyUp ( _
    args As vDataGridView..::..CellKeyEventArgs _
)
Visual C++
protected:
virtual void OnCellKeyUp(
    vDataGridView..::..CellKeyEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..vDataGridView..::..CellKeyEventArgs
The CellKeyEventArgs instance containing the event data.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnCellMouseClick Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnCellMouseClick Method
vDataGridView Class See Also Send Feedback
Raises the CellMouseClick event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCellMouseClick(
    CellMouseEventArgs args
)
Visual Basic
Protected Overridable Sub OnCellMouseClick ( _
    args As CellMouseEventArgs _
)
Visual C++
protected:
virtual void OnCellMouseClick(
    CellMouseEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..CellMouseEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnCellMousedoubleClick Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnCellMousedoubleClick Method
vDataGridView Class See Also Send Feedback
Raises the CellMousedoubleClick event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCellMousedoubleClick(
    CellMouseEventArgs args
)
Visual Basic
Protected Overridable Sub OnCellMousedoubleClick ( _
    args As CellMouseEventArgs _
)
Visual C++
protected:
virtual void OnCellMousedoubleClick(
    CellMouseEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..CellMouseEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnCellMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnCellMouseDown Method
vDataGridView Class See Also Send Feedback
Raises the CellMouseDown event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCellMouseDown(
    CellMouseEventArgs args
)
Visual Basic
Protected Overridable Sub OnCellMouseDown ( _
    args As CellMouseEventArgs _
)
Visual C++
protected:
virtual void OnCellMouseDown(
    CellMouseEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..CellMouseEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnCellMouseEnter Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnCellMouseEnter Method
vDataGridView Class See Also Send Feedback
Raises the CellMouseEnter event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCellMouseEnter(
    CellEventArgs args
)
Visual Basic
Protected Overridable Sub OnCellMouseEnter ( _
    args As CellEventArgs _
)
Visual C++
protected:
virtual void OnCellMouseEnter(
    CellEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..CellEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnCellMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnCellMouseLeave Method
vDataGridView Class See Also Send Feedback
Raises the CellMouseLeave event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCellMouseLeave(
    CellEventArgs args
)
Visual Basic
Protected Overridable Sub OnCellMouseLeave ( _
    args As CellEventArgs _
)
Visual C++
protected:
virtual void OnCellMouseLeave(
    CellEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..CellEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnCellMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnCellMouseMove Method
vDataGridView Class See Also Send Feedback
Raises the CellMouseMove event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCellMouseMove(
    CellMouseEventArgs args
)
Visual Basic
Protected Overridable Sub OnCellMouseMove ( _
    args As CellMouseEventArgs _
)
Visual C++
protected:
virtual void OnCellMouseMove(
    CellMouseEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..CellMouseEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnCellMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnCellMouseUp Method
vDataGridView Class See Also Send Feedback
Raises the CellMouseUp event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCellMouseUp(
    CellMouseEventArgs args
)
Visual Basic
Protected Overridable Sub OnCellMouseUp ( _
    args As CellMouseEventArgs _
)
Visual C++
protected:
virtual void OnCellMouseUp(
    CellMouseEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..CellMouseEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnCellParsing Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnCellParsing Method
vDataGridView Class See Also Send Feedback
Raises the CellParsing event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCellParsing(
    CellParsingEventArgs args
)
Visual Basic
Protected Overridable Sub OnCellParsing ( _
    args As CellParsingEventArgs _
)
Visual C++
protected:
virtual void OnCellParsing(
    CellParsingEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..CellParsingEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnCellSelectionChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnCellSelectionChanged Method
vDataGridView Class See Also Send Feedback
Raises the CellSelectionChanged event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal void OnCellSelectionChanged(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Protected Friend Sub OnCellSelectionChanged ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
)
Visual C++
protected public:
void OnCellSelectionChanged(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The row of the grid cell.
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The column of the grid cell.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnCellValidated Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnCellValidated Method
vDataGridView Class See Also Send Feedback
Raises the CellValidated event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCellValidated(
    CellEventArgs args
)
Visual Basic
Protected Overridable Sub OnCellValidated ( _
    args As CellEventArgs _
)
Visual C++
protected:
virtual void OnCellValidated(
    CellEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..CellEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnCellValidating Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnCellValidating Method
vDataGridView Class See Also Send Feedback
Raises the CellValidating event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnCellValidating(
    CellCancelEventArgs args
)
Visual Basic
Protected Overridable Sub OnCellValidating ( _
    args As CellCancelEventArgs _
)
Visual C++
protected:
virtual void OnCellValidating(
    CellCancelEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..CellCancelEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnCellValueChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnCellValueChanged Method
vDataGridView Class See Also Send Feedback
Raises the CellValueChanged event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal void OnCellValueChanged(
    HierarchyItem rowItem,
    HierarchyItem columnItem
)
Visual Basic
Protected Friend Sub OnCellValueChanged ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem _
)
Visual C++
protected public:
void OnCellValueChanged(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The row of the grid cell.
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The column of the grid cell.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnCellValueChanging Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnCellValueChanging Method
vDataGridView Class See Also Send Feedback
Raises the CellValueChanging event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected internal bool OnCellValueChanging(
    HierarchyItem rowItem,
    HierarchyItem columnItem,
    Object newValue
)
Visual Basic
Protected Friend Function OnCellValueChanging ( _
    rowItem As HierarchyItem, _
    columnItem As HierarchyItem, _
    newValue As Object _
) As Boolean
Visual C++
protected public:
bool OnCellValueChanging(
    HierarchyItem^ rowItem,
    HierarchyItem^ columnItem,
    Object^ newValue
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The row of the grid cell.
columnItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The column of the grid cell.
newValue
Type: System..::..Object
The new value of the grid cell.

Return Value

Returns True if the event was canceled by the user.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnContextMenuClosed Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnContextMenuClosed Method
vDataGridView Class See Also Send Feedback
Called when the context menu is closed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnContextMenuClosed(
    Object sender,
    EventArgs args
)
Visual Basic
Protected Overridable Sub OnContextMenuClosed ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
protected:
virtual void OnContextMenuClosed(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The EventArgs instance containing the event data.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnContextMenuShowing Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnContextMenuShowing Method
vDataGridView Class See Also Send Feedback
Called when the context menu is showing.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnContextMenuShowing(
    Object sender,
    CancelEventArgs args
)
Visual Basic
Protected Overridable Sub OnContextMenuShowing ( _
    sender As Object, _
    args As CancelEventArgs _
)
Visual C++
protected:
virtual void OnContextMenuShowing(
    Object^ sender,
    CancelEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: System.ComponentModel..::..CancelEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnControlRemoved Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnControlRemoved Method
vDataGridView Class See Also Send Feedback
Raises the ControlRemoved event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnControlRemoved(
    ControlEventArgs e
)
Visual Basic
Protected Overrides Sub OnControlRemoved ( _
    e As ControlEventArgs _
)
Visual C++
protected:
virtual void OnControlRemoved(
    ControlEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..ControlEventArgs
A ControlEventArgs that contains the event data.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnDoubleClick Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnDoubleClick Method
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnDoubleClick(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnDoubleClick ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnDoubleClick(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnGotFocus Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnGotFocus Method
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnGotFocus(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnGotFocus ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnGotFocus(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnHierarchyItemMouseClick Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnHierarchyItemMouseClick Method
vDataGridView Class See Also Send Feedback
Raises the HierarchyItemMouseClick event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnHierarchyItemMouseClick(
    HierarchyItem hierarchyItem,
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub OnHierarchyItemMouseClick ( _
    hierarchyItem As HierarchyItem, _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnHierarchyItemMouseClick(
    HierarchyItem^ hierarchyItem,
    MouseEventArgs^ e
)

Parameters

hierarchyItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnHierarchyItemMouseDoubleClick Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnHierarchyItemMouseDoubleClick Method
vDataGridView Class See Also Send Feedback
Raises the HierarchyItemMouseDoubleClick event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnHierarchyItemMouseDoubleClick(
    HierarchyItem hierarchyItem,
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub OnHierarchyItemMouseDoubleClick ( _
    hierarchyItem As HierarchyItem, _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnHierarchyItemMouseDoubleClick(
    HierarchyItem^ hierarchyItem,
    MouseEventArgs^ e
)

Parameters

hierarchyItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnHierarchyItemMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnHierarchyItemMouseDown Method
vDataGridView Class See Also Send Feedback
Raises the HierarchyItemMouseDown event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnHierarchyItemMouseDown(
    HierarchyItem hierarchyItem,
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub OnHierarchyItemMouseDown ( _
    hierarchyItem As HierarchyItem, _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnHierarchyItemMouseDown(
    HierarchyItem^ hierarchyItem,
    MouseEventArgs^ e
)

Parameters

hierarchyItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnHierarchyItemMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnHierarchyItemMouseUp Method
vDataGridView Class See Also Send Feedback
Raises the HierarchyItemMouseUp event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnHierarchyItemMouseUp(
    HierarchyItem hierarchyItem,
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub OnHierarchyItemMouseUp ( _
    hierarchyItem As HierarchyItem, _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnHierarchyItemMouseUp(
    HierarchyItem^ hierarchyItem,
    MouseEventArgs^ e
)

Parameters

hierarchyItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnHorizontalScrollBarValueChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnHorizontalScrollBarValueChanged Method
vDataGridView Class See Also Send Feedback
Raises the [E:HorizontalScrollBarValueChanged] event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnHorizontalScrollBarValueChanged()
Visual Basic
Protected Overridable Sub OnHorizontalScrollBarValueChanged
Visual C++
protected:
virtual void OnHorizontalScrollBarValueChanged()

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnItemCollapsed Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnItemCollapsed Method
vDataGridView Class See Also Send Feedback
Raises the ItemCollapsed event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnItemCollapsed(
    HierarchyItemEventArgs args
)
Visual Basic
Protected Overridable Sub OnItemCollapsed ( _
    args As HierarchyItemEventArgs _
)
Visual C++
protected:
virtual void OnItemCollapsed(
    HierarchyItemEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..HierarchyItemEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnItemExpanded Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnItemExpanded Method
vDataGridView Class See Also Send Feedback
Raises the ItemExpanded event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnItemExpanded(
    HierarchyItemEventArgs args
)
Visual Basic
Protected Overridable Sub OnItemExpanded ( _
    args As HierarchyItemEventArgs _
)
Visual C++
protected:
virtual void OnItemExpanded(
    HierarchyItemEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..HierarchyItemEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnKeyDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnKeyDown Method
vDataGridView Class See Also Send Feedback
Raises the KeyDown event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
A KeyEventArgs that contains the event data.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnKeyUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnKeyUp Method
vDataGridView Class See Also Send Feedback
Raises the KeyUp event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnKeyUp(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyUp ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyUp(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
A KeyEventArgs that contains the event data.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnListChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnListChanged Method
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnListChanged(
    ListChangedEventArgs args
)
Visual Basic
Protected Overridable Sub OnListChanged ( _
    args As ListChangedEventArgs _
)
Visual C++
protected:
virtual void OnListChanged(
    ListChangedEventArgs^ args
)

Parameters

args
Type: System.ComponentModel..::..ListChangedEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnLostFocus Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnLostFocus Method
vDataGridView Class See Also Send Feedback
Raises the LostFocus event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnLostFocus(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnLostFocus ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLostFocus(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnMouseClick Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnMouseClick Method
vDataGridView Class See Also Send Feedback
Raises the MouseClick event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseClick(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseClick ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseClick(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
An MouseEventArgs that contains the event data.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnMouseDoubleClick Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnMouseDoubleClick Method
vDataGridView Class See Also Send Feedback
Raises the MouseDoubleClick event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDoubleClick(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDoubleClick ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDoubleClick(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
An MouseEventArgs that contains the event data.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnMouseDown Method
vDataGridView Class See Also Send Feedback
Raises the MouseDown event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnMouseEnter Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnMouseEnter Method
vDataGridView Class See Also Send Feedback
Raises the MouseEnter event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseEnter(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseEnter ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseEnter(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnMouseLeave Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnMouseLeave Method
vDataGridView Class See Also Send Feedback
Raises the MouseLeave event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnMouseUp Method
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnMouseWheel Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnMouseWheel Method
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseWheel(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseWheel ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseWheel(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnPropertyChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnPropertyChanged Method
vDataGridView Class See Also Send Feedback
Called when a property is changed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String
Name of the property.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


OnVerticalScrollBarValueChanged Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..OnVerticalScrollBarValueChanged Method
vDataGridView Class See Also Send Feedback
Raises the [E:VerticalScrollBarValueChanged] event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnVerticalScrollBarValueChanged()
Visual Basic
Protected Overridable Sub OnVerticalScrollBarValueChanged
Visual C++
protected:
virtual void OnVerticalScrollBarValueChanged()

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..PerformLayout Method
vDataGridView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vDataGridView Class
vDataGridView Members
VIBlend.WinForms.DataGridView Namespace


RemoveSort Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..RemoveSort Method
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[ObsoleteAttribute("Use the RowsHierarchy.RemoveSort and ColumnsHierarchy.RemoveSort methods.")]
public void RemoveSort()
Visual Basic
<ObsoleteAttribute("Use the RowsHierarchy.RemoveSort and ColumnsHierarchy.RemoveSort methods.")> _
Public Sub RemoveSort
Visual C++
[ObsoleteAttribute(L"Use the RowsHierarchy.RemoveSort and ColumnsHierarchy.RemoveSort methods.")]
public:
void RemoveSort()

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


Render Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..Render Method
vDataGridView Class See Also Send Feedback
Renders the content of the Data Grid Control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Render()
Visual Basic
Public Sub Render
Visual C++
public:
void Render()

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ResumeLayout Method
vDataGridView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vDataGridView Class
vDataGridView Members
VIBlend.WinForms.DataGridView Namespace


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..RtlTranslateAlignment Method
vDataGridView Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vDataGridView Class
vDataGridView Members
VIBlend.WinForms.DataGridView Namespace


SaveColumnsLayout Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..SaveColumnsLayout Method
vDataGridView Class See Also Send Feedback
Saves the layout.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SaveColumnsLayout(
    Stream stream
)
Visual Basic
Public Sub SaveColumnsLayout ( _
    stream As Stream _
)
Visual C++
public:
void SaveColumnsLayout(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream

Return Value

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..Scale Method
vDataGridView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vDataGridView Class
vDataGridView Members
VIBlend.WinForms.DataGridView Namespace


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..Select Method
vDataGridView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vDataGridView Class
vDataGridView Members
VIBlend.WinForms.DataGridView Namespace


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..SetBounds Method
vDataGridView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vDataGridView Class
vDataGridView Members
VIBlend.WinForms.DataGridView Namespace


ShowColumnChooser Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ShowColumnChooser Method
vDataGridView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowColumnChooser()()()() | Shows the column chooser.
Public method | ShowColumnChooser(Point) | Shows the column chooser at a specific location.

See Also

vDataGridView Class
vDataGridView Members
VIBlend.WinForms.DataGridView Namespace


ShowColumnChooser Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ShowColumnChooser Method
vDataGridView Class See Also Send Feedback
Shows the column chooser.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ShowColumnChooser()
Visual Basic
Public Sub ShowColumnChooser
Visual C++
public:
void ShowColumnChooser()

See Also

vDataGridView Class
ShowColumnChooser Overload
VIBlend.WinForms.DataGridView Namespace


ShowColumnChooser Method (Point)

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ShowColumnChooser Method (Point)
vDataGridView Class See Also Send Feedback
Shows the column chooser at a specific location.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ShowColumnChooser(
    Point location
)
Visual Basic
Public Sub ShowColumnChooser ( _
    location As Point _
)
Visual C++
public:
void ShowColumnChooser(
    Point location
)

Parameters

location
Type: System.Drawing..::..Point

See Also

vDataGridView Class
ShowColumnChooser Overload
VIBlend.WinForms.DataGridView Namespace


ShowEditor Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ShowEditor Method
vDataGridView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowEditor(GridCell) | Submits an activation request to a grid cell's editor
Public method | ShowEditor(HierarchyItem, HierarchyItem) | Submits an activation request to a grid cell's editor

See Also

vDataGridView Class
vDataGridView Members
VIBlend.WinForms.DataGridView Namespace


ShowEditor Method (GridCell)

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ShowEditor Method (GridCell)
vDataGridView Class See Also Send Feedback
Submits an activation request to a grid cell's editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ShowEditor(
    GridCell cell
)
Visual Basic
Public Sub ShowEditor ( _
    cell As GridCell _
)
Visual C++
public:
void ShowEditor(
    GridCell^ cell
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell

See Also

vDataGridView Class
ShowEditor Overload
VIBlend.WinForms.DataGridView Namespace


ShowEditor Method (HierarchyItem, HierarchyItem)

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ShowEditor Method (HierarchyItem, HierarchyItem)
vDataGridView Class See Also Send Feedback
Submits an activation request to a grid cell's editor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ShowEditor(
    HierarchyItem rowItem,
    HierarchyItem colItem
)
Visual Basic
Public Sub ShowEditor ( _
    rowItem As HierarchyItem, _
    colItem As HierarchyItem _
)
Visual C++
public:
void ShowEditor(
    HierarchyItem^ rowItem,
    HierarchyItem^ colItem
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
colItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem

See Also

vDataGridView Class
ShowEditor Overload
VIBlend.WinForms.DataGridView Namespace


ShowFilterForm Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ShowFilterForm Method
vDataGridView Class See Also Send Feedback
Shows the filter form.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void ShowFilterForm(
    HierarchyItem filterItem
)
Visual Basic
Public Sub ShowFilterForm ( _
    filterItem As HierarchyItem _
)
Visual C++
public:
void ShowFilterForm(
    HierarchyItem^ filterItem
)

Parameters

filterItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
The filter item.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


SortBy Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..SortBy Method
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
[ObsoleteAttribute("Use the RowsHierarchy.SortBy and ColumnsHierarchy.SortBy methods.")]
public void SortBy(
    HierarchyItem item,
    SortingDirection sortingDirection
)
Visual Basic
<ObsoleteAttribute("Use the RowsHierarchy.SortBy and ColumnsHierarchy.SortBy methods.")> _
Public Sub SortBy ( _
    item As HierarchyItem, _
    sortingDirection As SortingDirection _
)
Visual C++
[ObsoleteAttribute(L"Use the RowsHierarchy.SortBy and ColumnsHierarchy.SortBy methods.")]
public:
void SortBy(
    HierarchyItem^ item,
    SortingDirection sortingDirection
)

Parameters

item
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
sortingDirection
Type: VIBlend.WinForms.DataGridView..::..SortingDirection

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..UpdateBounds Method
vDataGridView Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vDataGridView Class
vDataGridView Members
VIBlend.WinForms.DataGridView Namespace


vDataGridView Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView Properties
vDataGridView Class See Also Send Feedback

The vDataGridView type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowAnimations | Gets or sets whether to use animations when visualizing the content of the grid
Public property | AllowCellMerge | Gets or sets whether the cells could be merged
Public property | AllowClipDrawing | Gets or sets whether the clip drawing is allowed
Public property | AllowContextMenuColumnChooser | Gets or sets a value indicating whether the 'Column Chooser' menu item is enabled.
Public property | AllowContextMenuFiltering | Determines whether to display the sorting options in the grid's context menu
Public property | AllowContextMenuGrouping | Gets or sets a value indicating whether the 'Group by this column' menu item is enabled.
Public property | AllowContextMenuSorting | Determines whether to display the sorting options in the grid's context menu
Public property | AllowCopyPaste | Gets or sets whether to enable copy/paste operations within the grid cells
Public property | AllowDefaultContextMenu | Gets or sets a value indicating whether the built-in context menu can be displayed.
Public property | AllowDragDropIndication | Gets or sets whether the dragging indicator is displayed
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowHeaderItemHighlightOnCellSelection | Gets or sets whether the header item is highlighted on cell selection
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoGenerateColumns | Gets or sets whether the DataGrid will automatically bind to all columns available in the data source.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | AutoUpdateOnListChanged | Gets or sets a value indicating whether the grid's cells are updated when a list changed event occurs.
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BindingProgressEnabled | Gets or sets whether the data binding progress indicator is visible
Public property | BindingProgressSampleRate | Gets or sets the data binding progress sample rate. The value must be between 1,000 and 100,000.
Public property | BindingState | Gets the current data binding state of the grid control
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CellsArea | Gets the cells area
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColumnChooser | Gets the column chooser.
Public property | ColumnsHierarchy | Gets the Columns hierarchy
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Overrides Control..::..ContextMenuStrip.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DataManager |
Public property | DataMember | Gets or sets the DataMember for the grid DataSource
Public property | DataSource | Gets or sets the DataSource of the grid control
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | EnableColumnChooser | "Enables/disables the column chooser which allows you to easily show/hide columns.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableResizeToolTip | Enables/disables the tooltips which are shown when you resize a column/row.
Public property | EnableToolTips | Gets or sets a value indicating whether the tooltips are enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FilterDisplayMode | Gets or sets a value indicating the filtering window display mode.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GridLinesDashStyle | Gets or sets the grid lines dash style.
Public property | GridLinesDisplayMode | Determines how the grid lines will be displayed.
Public property | GroupingDefaultHeaderTextVisible | Gets or sets whether the rows group name and rows count is visible in the rows grouping headers.
Public property | GroupingEnabled | Determines if grouping is enabled or not.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets or sets the horizontal scroll position
Public property | HorizontalScrollBarLargeChange | Gets or sets the LargeChange of the Horizontal ScrollBar.
Public property | HorizontalScrollBarSmallChange | Gets or sets the SmallChange of the Horizontal ScrollBar.
Public property | ImageList | Gets or sets the image list associated to the grid control
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Localization | Gets the localization.
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultipleSelectionEnabled | Gets or sets whether multiple selection is enabled.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PivotColumnsTotalsEnabled | Gets or sets if the Pivot Table Columns Totals are enabled.
Public property | PivotColumnsTotalsMode | Gets or sets the Pivot Table Columns totals display mode.
Public property | PivotRowsTotalsEnabled | Gets or sets if the Pivot Table Rows Totals are enabled.
Public property | PivotRowsTotalsMode | Gets or sets the Pivot Table Rows totals display mode.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | ResizeToolTip | Gets the resize tool tip.
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RowsHierarchy | Gets the Rows hierarchy
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ScrollBarsEnabled | Determines whether the Horizontal and Vertical ScrollBars will be displayed
Public property | SelectionBorderDashStyle | Gets or sets the line dash style of the selection border
Public property | SelectionBorderEnabled | Determines whether the grid should draw a border around the selected grid cells
Public property | SelectionBorderWidth | Gets or sets the width in pixel of the selection border
Public property | SelectionMode | Gets or sets the grid cells selection mode
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme | Gets or sets the grid theme.
Public property | ToolTipDuration | Gets or sets the duration of the tool tip.
Public property | ToolTipShowDelay | Gets or sets the tool tip show delay.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets or sets the vertical scroll position
Public property | VerticalScrollBarLargeChange | Gets or sets the LargeChange of the Vertical ScrollBar.
Public property | VerticalScrollBarSmallChange | Gets or sets the SmallChange of the Vertical ScrollBar.
Public property | VIBlendTheme | Gets or sets the DataGrid's theme.
Public property | VirtualModeCellDefault | Gets or sets whether the grid cells are in virtual mode by default
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


AllowAnimations Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..AllowAnimations Property
vDataGridView Class See Also Send Feedback
Gets or sets whether to use animations when visualizing the content of the grid

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowAnimations { get; set; }
Visual Basic
Public Property AllowAnimations As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowAnimations {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


AllowCellMerge Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..AllowCellMerge Property
vDataGridView Class See Also Send Feedback
Gets or sets whether the cells could be merged

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool AllowCellMerge { get; set; }
Visual Basic
Public Overridable Property AllowCellMerge As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowCellMerge {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


AllowClipDrawing Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..AllowClipDrawing Property
vDataGridView Class See Also Send Feedback
Gets or sets whether the clip drawing is allowed

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool AllowClipDrawing { get; set; }
Visual Basic
Public Overridable Property AllowClipDrawing As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowClipDrawing {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


AllowContextMenuColumnChooser Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..AllowContextMenuColumnChooser Property
vDataGridView Class See Also Send Feedback
Gets or sets a value indicating whether the 'Column Chooser' menu item is enabled.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowContextMenuColumnChooser { get; set; }
Visual Basic
Public Property AllowContextMenuColumnChooser As Boolean
    Get
    Set
Visual C++
public:
property bool AllowContextMenuColumnChooser {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


AllowContextMenuFiltering Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..AllowContextMenuFiltering Property
vDataGridView Class See Also Send Feedback
Determines whether to display the sorting options in the grid's context menu

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowContextMenuFiltering { get; set; }
Visual Basic
Public Property AllowContextMenuFiltering As Boolean
    Get
    Set
Visual C++
public:
property bool AllowContextMenuFiltering {
    bool get ();
    void set (bool value);
}

Remarks

When the user clicks the right mouse button on a HierarchyItem, the grid will display a context menu with multiple actions. The actions may include filtering, sorting, expand/collapse state, and others. The list may vary depending on the flags set at HierarchyItem level itself, and the context menu flags for each action type.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


AllowContextMenuGrouping Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..AllowContextMenuGrouping Property
vDataGridView Class See Also Send Feedback
Gets or sets a value indicating whether the 'Group by this column' menu item is enabled.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowContextMenuGrouping { get; set; }
Visual Basic
Public Property AllowContextMenuGrouping As Boolean
    Get
    Set
Visual C++
public:
property bool AllowContextMenuGrouping {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


AllowContextMenuSorting Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..AllowContextMenuSorting Property
vDataGridView Class See Also Send Feedback
Determines whether to display the sorting options in the grid's context menu

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowContextMenuSorting { get; set; }
Visual Basic
Public Property AllowContextMenuSorting As Boolean
    Get
    Set
Visual C++
public:
property bool AllowContextMenuSorting {
    bool get ();
    void set (bool value);
}

Remarks

When the user clicks the right mouse button on a HierarchyItem, the grid will display a context menu with multiple actions. The actions may include filtering, sorting, expand/collapse state, and others. The list may vary depending on the flags set at HierarchyItem level itself, and the context menu flags for each action type.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


AllowCopyPaste Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..AllowCopyPaste Property
vDataGridView Class See Also Send Feedback
Gets or sets whether to enable copy/paste operations within the grid cells

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowCopyPaste { get; set; }
Visual Basic
Public Property AllowCopyPaste As Boolean
    Get
    Set
Visual C++
public:
property bool AllowCopyPaste {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


AllowDefaultContextMenu Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..AllowDefaultContextMenu Property
vDataGridView Class See Also Send Feedback
Gets or sets a value indicating whether the built-in context menu can be displayed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowDefaultContextMenu { get; set; }
Visual Basic
Public Property AllowDefaultContextMenu As Boolean
    Get
    Set
Visual C++
public:
property bool AllowDefaultContextMenu {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


AllowDragDropIndication Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..AllowDragDropIndication Property
vDataGridView Class See Also Send Feedback
Gets or sets whether the dragging indicator is displayed

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool AllowDragDropIndication { get; set; }
Visual Basic
Public Overridable Property AllowDragDropIndication As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowDragDropIndication {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


AllowHeaderItemHighlightOnCellSelection Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..AllowHeaderItemHighlightOnCellSelection Property
vDataGridView Class See Also Send Feedback
Gets or sets whether the header item is highlighted on cell selection

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool AllowHeaderItemHighlightOnCellSelection { get; set; }
Visual Basic
Public Overridable Property AllowHeaderItemHighlightOnCellSelection As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AllowHeaderItemHighlightOnCellSelection {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


AutoGenerateColumns Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..AutoGenerateColumns Property
vDataGridView Class See Also Send Feedback
Gets or sets whether the DataGrid will automatically bind to all columns available in the data source.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AutoGenerateColumns { get; set; }
Visual Basic
Public Property AutoGenerateColumns As Boolean
    Get
    Set
Visual C++
public:
property bool AutoGenerateColumns {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


AutoUpdateOnListChanged Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..AutoUpdateOnListChanged Property
vDataGridView Class See Also Send Feedback
Gets or sets a value indicating whether the grid's cells are updated when a list changed event occurs.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AutoUpdateOnListChanged { get; set; }
Visual Basic
Public Property AutoUpdateOnListChanged As Boolean
    Get
    Set
Visual C++
public:
property bool AutoUpdateOnListChanged {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


BindingProgressEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..BindingProgressEnabled Property
vDataGridView Class See Also Send Feedback
Gets or sets whether the data binding progress indicator is visible

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool BindingProgressEnabled { get; set; }
Visual Basic
Public Property BindingProgressEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool BindingProgressEnabled {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


BindingProgressSampleRate Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..BindingProgressSampleRate Property
vDataGridView Class See Also Send Feedback
Gets or sets the data binding progress sample rate. The value must be between 1,000 and 100,000.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int BindingProgressSampleRate { get; set; }
Visual Basic
Public Property BindingProgressSampleRate As Integer
    Get
    Set
Visual C++
public:
property int BindingProgressSampleRate {
    int get ();
    void set (int value);
}

Remarks

Uset this value to control how often the binding progress is refreshed. For example setting this value to 1000 means that the progress will be updated approx. every 1000 records.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


BindingState Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..BindingState Property
vDataGridView Class See Also Send Feedback
Gets the current data binding state of the grid control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridBindingState BindingState { get; }
Visual Basic
Public ReadOnly Property BindingState As GridBindingState
    Get
Visual C++
public:
property GridBindingState BindingState {
    GridBindingState get ();
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellsArea Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellsArea Property
vDataGridView Class See Also Send Feedback
Gets the cells area

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellsArea CellsArea { get; }
Visual Basic
Public ReadOnly Property CellsArea As CellsArea
    Get
Visual C++
public:
property CellsArea^ CellsArea {
    CellsArea^ get ();
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


ColumnChooser Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ColumnChooser Property
vDataGridView Class See Also Send Feedback
Gets the column chooser.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ColumnChooser ColumnChooser { get; }
Visual Basic
Public ReadOnly Property ColumnChooser As ColumnChooser
    Get
Visual C++
public:
property ColumnChooser^ ColumnChooser {
    ColumnChooser^ get ();
}

Field Value

The column chooser.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


ColumnsHierarchy Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ColumnsHierarchy Property
vDataGridView Class See Also Send Feedback
Gets the Columns hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ColumnsHierarchy ColumnsHierarchy { get; }
Visual Basic
Public ReadOnly Property ColumnsHierarchy As ColumnsHierarchy
    Get
Visual C++
public:
property ColumnsHierarchy^ ColumnsHierarchy {
    ColumnsHierarchy^ get ();
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


ContextMenuStrip Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ContextMenuStrip Property
vDataGridView Class See Also Send Feedback
Gets or sets the ContextMenuStrip associated with this control.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public override ContextMenuStrip ContextMenuStrip { get; set; }
Visual Basic
Public Overrides Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
Visual C++
public:
virtual property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get () override;
    void set (ContextMenuStrip^ value) override;
}

Field Value

Return Value

The ContextMenuStrip for this control, or null if there is no ContextMenuStrip. The default is null.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


DataManager Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..DataManager Property
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected CurrencyManager DataManager { get; }
Visual Basic
Protected ReadOnly Property DataManager As CurrencyManager
    Get
Visual C++
protected:
property CurrencyManager^ DataManager {
    CurrencyManager^ get ();
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


DataMember Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..DataMember Property
vDataGridView Class See Also Send Feedback
Gets or sets the DataMember for the grid DataSource

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string DataMember { get; set; }
Visual Basic
Public Property DataMember As String
    Get
    Set
Visual C++
public:
property String^ DataMember {
    String^ get ();
    void set (String^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


DataSource Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..DataSource Property
vDataGridView Class See Also Send Feedback
Gets or sets the DataSource of the grid control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Object DataSource { get; set; }
Visual Basic
Public Property DataSource As Object
    Get
    Set
Visual C++
public:
property Object^ DataSource {
    Object^ get ();
    void set (Object^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


EnableColumnChooser Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..EnableColumnChooser Property
vDataGridView Class See Also Send Feedback
"Enables/disables the column chooser which allows you to easily show/hide columns.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableColumnChooser { get; set; }
Visual Basic
Public Property EnableColumnChooser As Boolean
    Get
    Set
Visual C++
public:
property bool EnableColumnChooser {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


EnableResizeToolTip Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..EnableResizeToolTip Property
vDataGridView Class See Also Send Feedback
Enables/disables the tooltips which are shown when you resize a column/row.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool EnableResizeToolTip { get; set; }
Visual Basic
Public Property EnableResizeToolTip As Boolean
    Get
    Set
Visual C++
public:
property bool EnableResizeToolTip {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


EnableToolTips Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..EnableToolTips Property
vDataGridView Class See Also Send Feedback
Gets or sets a value indicating whether the tooltips are enabled.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool EnableToolTips { get; set; }
Visual Basic
Public Overridable Property EnableToolTips As Boolean
    Get
    Set
Visual C++
public:
virtual property bool EnableToolTips {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


FilterDisplayMode Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..FilterDisplayMode Property
vDataGridView Class See Also Send Feedback
Gets or sets a value indicating the filtering window display mode.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public FilterDisplayMode FilterDisplayMode { get; set; }
Visual Basic
Public Property FilterDisplayMode As FilterDisplayMode
    Get
    Set
Visual C++
public:
property FilterDisplayMode FilterDisplayMode {
    FilterDisplayMode get ();
    void set (FilterDisplayMode value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


GridLinesDashStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GridLinesDashStyle Property
vDataGridView Class See Also Send Feedback
Gets or sets the grid lines dash style.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DashStyle GridLinesDashStyle { get; set; }
Visual Basic
Public Property GridLinesDashStyle As DashStyle
    Get
    Set
Visual C++
public:
property DashStyle GridLinesDashStyle {
    DashStyle get ();
    void set (DashStyle value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


GridLinesDisplayMode Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GridLinesDisplayMode Property
vDataGridView Class See Also Send Feedback
Determines how the grid lines will be displayed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridLinesDisplayMode GridLinesDisplayMode { get; set; }
Visual Basic
Public Property GridLinesDisplayMode As GridLinesDisplayMode
    Get
    Set
Visual C++
public:
property GridLinesDisplayMode GridLinesDisplayMode {
    GridLinesDisplayMode get ();
    void set (GridLinesDisplayMode value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


GroupingDefaultHeaderTextVisible Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GroupingDefaultHeaderTextVisible Property
vDataGridView Class See Also Send Feedback
Gets or sets whether the rows group name and rows count is visible in the rows grouping headers.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool GroupingDefaultHeaderTextVisible { get; set; }
Visual Basic
Public Property GroupingDefaultHeaderTextVisible As Boolean
    Get
    Set
Visual C++
public:
property bool GroupingDefaultHeaderTextVisible {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


GroupingEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GroupingEnabled Property
vDataGridView Class See Also Send Feedback
Determines if grouping is enabled or not.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool GroupingEnabled { get; set; }
Visual Basic
Public Property GroupingEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool GroupingEnabled {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HorizontalScroll Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HorizontalScroll Property
vDataGridView Class See Also Send Feedback
Gets or sets the horizontal scroll position

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int HorizontalScroll { get; set; }
Visual Basic
Public Property HorizontalScroll As Integer
    Get
    Set
Visual C++
public:
property int HorizontalScroll {
    int get ();
    void set (int value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HorizontalScrollBarLargeChange Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HorizontalScrollBarLargeChange Property
vDataGridView Class See Also Send Feedback
Gets or sets the LargeChange of the Horizontal ScrollBar.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int HorizontalScrollBarLargeChange { get; set; }
Visual Basic
Public Property HorizontalScrollBarLargeChange As Integer
    Get
    Set
Visual C++
public:
property int HorizontalScrollBarLargeChange {
    int get ();
    void set (int value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HorizontalScrollBarSmallChange Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HorizontalScrollBarSmallChange Property
vDataGridView Class See Also Send Feedback
Gets or sets the SmallChange of the Horizontal ScrollBar.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int HorizontalScrollBarSmallChange { get; set; }
Visual Basic
Public Property HorizontalScrollBarSmallChange As Integer
    Get
    Set
Visual C++
public:
property int HorizontalScrollBarSmallChange {
    int get ();
    void set (int value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


ImageList Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ImageList Property
vDataGridView Class See Also Send Feedback
Gets or sets the image list associated to the grid control

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ImageList ImageList { get; set; }
Visual Basic
Public Property ImageList As ImageList
    Get
    Set
Visual C++
public:
property ImageList^ ImageList {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


Localization Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..Localization Property
vDataGridView Class See Also Send Feedback
Gets the localization.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DataGridLocalizationBase Localization { get; set; }
Visual Basic
Public Property Localization As DataGridLocalizationBase
    Get
    Set
Visual C++
public:
property DataGridLocalizationBase^ Localization {
    DataGridLocalizationBase^ get ();
    void set (DataGridLocalizationBase^ value);
}

Field Value

The localization.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


MultipleSelectionEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..MultipleSelectionEnabled Property
vDataGridView Class See Also Send Feedback
Gets or sets whether multiple selection is enabled.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool MultipleSelectionEnabled { get; set; }
Visual Basic
Public Property MultipleSelectionEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool MultipleSelectionEnabled {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


PivotColumnsTotalsEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..PivotColumnsTotalsEnabled Property
vDataGridView Class See Also Send Feedback
Gets or sets if the Pivot Table Columns Totals are enabled.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PivotColumnsTotalsEnabled { get; set; }
Visual Basic
Public Property PivotColumnsTotalsEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool PivotColumnsTotalsEnabled {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


PivotColumnsTotalsMode Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..PivotColumnsTotalsMode Property
vDataGridView Class See Also Send Feedback
Gets or sets the Pivot Table Columns totals display mode.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public PivotTotalsMode PivotColumnsTotalsMode { get; set; }
Visual Basic
Public Property PivotColumnsTotalsMode As PivotTotalsMode
    Get
    Set
Visual C++
public:
property PivotTotalsMode PivotColumnsTotalsMode {
    PivotTotalsMode get ();
    void set (PivotTotalsMode value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


PivotRowsTotalsEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..PivotRowsTotalsEnabled Property
vDataGridView Class See Also Send Feedback
Gets or sets if the Pivot Table Rows Totals are enabled.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool PivotRowsTotalsEnabled { get; set; }
Visual Basic
Public Property PivotRowsTotalsEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool PivotRowsTotalsEnabled {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


PivotRowsTotalsMode Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..PivotRowsTotalsMode Property
vDataGridView Class See Also Send Feedback
Gets or sets the Pivot Table Rows totals display mode.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public PivotTotalsMode PivotRowsTotalsMode { get; set; }
Visual Basic
Public Property PivotRowsTotalsMode As PivotTotalsMode
    Get
    Set
Visual C++
public:
property PivotTotalsMode PivotRowsTotalsMode {
    PivotTotalsMode get ();
    void set (PivotTotalsMode value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


ResizeToolTip Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ResizeToolTip Property
vDataGridView Class See Also Send Feedback
Gets the resize tool tip.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ToolTip ResizeToolTip { get; }
Visual Basic
Public ReadOnly Property ResizeToolTip As ToolTip
    Get
Visual C++
public:
property ToolTip^ ResizeToolTip {
    ToolTip^ get ();
}

Field Value

The resize tool tip.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


RowsHierarchy Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..RowsHierarchy Property
vDataGridView Class See Also Send Feedback
Gets the Rows hierarchy

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public RowsHierarchy RowsHierarchy { get; }
Visual Basic
Public ReadOnly Property RowsHierarchy As RowsHierarchy
    Get
Visual C++
public:
property RowsHierarchy^ RowsHierarchy {
    RowsHierarchy^ get ();
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


ScrollBarsEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ScrollBarsEnabled Property
vDataGridView Class See Also Send Feedback
Determines whether the Horizontal and Vertical ScrollBars will be displayed

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ScrollBarsEnabled { get; set; }
Visual Basic
Public Property ScrollBarsEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool ScrollBarsEnabled {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


SelectionBorderDashStyle Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..SelectionBorderDashStyle Property
vDataGridView Class See Also Send Feedback
Gets or sets the line dash style of the selection border

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DashStyle SelectionBorderDashStyle { get; set; }
Visual Basic
Public Property SelectionBorderDashStyle As DashStyle
    Get
    Set
Visual C++
public:
property DashStyle SelectionBorderDashStyle {
    DashStyle get ();
    void set (DashStyle value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


SelectionBorderEnabled Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..SelectionBorderEnabled Property
vDataGridView Class See Also Send Feedback
Determines whether the grid should draw a border around the selected grid cells

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool SelectionBorderEnabled { get; set; }
Visual Basic
Public Property SelectionBorderEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool SelectionBorderEnabled {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


SelectionBorderWidth Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..SelectionBorderWidth Property
vDataGridView Class See Also Send Feedback
Gets or sets the width in pixel of the selection border

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int SelectionBorderWidth { get; set; }
Visual Basic
Public Property SelectionBorderWidth As Integer
    Get
    Set
Visual C++
public:
property int SelectionBorderWidth {
    int get ();
    void set (int value);
}

Remarks

For estetic reasons the maximum value of this property is limited to 2 pixels

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


SelectionMode Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..SelectionMode Property
vDataGridView Class See Also Send Feedback
Gets or sets the grid cells selection mode

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDataGridView..::..SELECTION_MODE SelectionMode { get; set; }
Visual Basic
Public Property SelectionMode As vDataGridView..::..SELECTION_MODE
    Get
    Set
Visual C++
public:
property vDataGridView..::..SELECTION_MODE SelectionMode {
    vDataGridView..::..SELECTION_MODE get ();
    void set (vDataGridView..::..SELECTION_MODE value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..Theme Property
vDataGridView Class See Also Send Feedback
Gets or sets the grid theme.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridTheme Theme { get; set; }
Visual Basic
Public Property Theme As GridTheme
    Get
    Set
Visual C++
public:
property GridTheme^ Theme {
    GridTheme^ get ();
    void set (GridTheme^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


ToolTipDuration Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ToolTipDuration Property
vDataGridView Class See Also Send Feedback
Gets or sets the duration of the tool tip.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ToolTipDuration { get; set; }
Visual Basic
Public Property ToolTipDuration As Integer
    Get
    Set
Visual C++
public:
property int ToolTipDuration {
    int get ();
    void set (int value);
}

Field Value

The duration of the tool tip.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


ToolTipShowDelay Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ToolTipShowDelay Property
vDataGridView Class See Also Send Feedback
Gets or sets the tool tip show delay.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ToolTipShowDelay { get; set; }
Visual Basic
Public Property ToolTipShowDelay As Integer
    Get
    Set
Visual C++
public:
property int ToolTipShowDelay {
    int get ();
    void set (int value);
}

Field Value

The tool tip show delay.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


VerticalScroll Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..VerticalScroll Property
vDataGridView Class See Also Send Feedback
Gets or sets the vertical scroll position

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int VerticalScroll { get; set; }
Visual Basic
Public Property VerticalScroll As Integer
    Get
    Set
Visual C++
public:
property int VerticalScroll {
    int get ();
    void set (int value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


VerticalScrollBarLargeChange Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..VerticalScrollBarLargeChange Property
vDataGridView Class See Also Send Feedback
Gets or sets the LargeChange of the Vertical ScrollBar.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int VerticalScrollBarLargeChange { get; set; }
Visual Basic
Public Property VerticalScrollBarLargeChange As Integer
    Get
    Set
Visual C++
public:
property int VerticalScrollBarLargeChange {
    int get ();
    void set (int value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


VerticalScrollBarSmallChange Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..VerticalScrollBarSmallChange Property
vDataGridView Class See Also Send Feedback
Gets or sets the SmallChange of the Vertical ScrollBar.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int VerticalScrollBarSmallChange { get; set; }
Visual Basic
Public Property VerticalScrollBarSmallChange As Integer
    Get
    Set
Visual C++
public:
property int VerticalScrollBarSmallChange {
    int get ();
    void set (int value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..VIBlendTheme Property
vDataGridView Class See Also Send Feedback
Gets or sets the DataGrid's theme.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


VirtualModeCellDefault Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..VirtualModeCellDefault Property
vDataGridView Class See Also Send Feedback
Gets or sets whether the grid cells are in virtual mode by default

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual bool VirtualModeCellDefault { get; set; }
Visual Basic
Public Overridable Property VirtualModeCellDefault As Boolean
    Get
    Set
Visual C++
public:
virtual property bool VirtualModeCellDefault {
    bool get ();
    void set (bool value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


vDataGridView Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView Events
vDataGridView Class See Also Send Feedback

The vDataGridView type exposes the following members.

Events

 | Name | Description
Public event | AutoScrollPositionChanged | Occurs when the scroll position has changed
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindField | Occurs when a the grid binds to data column from the data source
Public event | BindingComplete | Occurs when a data binding operation is complete.
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | BindingProgressChanged | Occurs when the data binding progress changes
Public event | BindingStart | Occurs when a data binding operation is complete.
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | CellBeginEdit | Occurs when a cell edit is begining
Public event | CellCustomPaint | Occurs when a cell is painted
Public event | CellEditorActivate | Occurs when a cell editor is being activated
Public event | CellEditorDeActivate | Occurs when a cell editor is being activated
Public event | CellEndEdit | Occurs when a cell edit is ending
Public event | CellKeyDown | Occurs when a key is down.
Public event | CellKeyUp | Occurs when a key is up.
Public event | CellMouseClick | Occurs when the mouse button is clicked in cell bounds
Public event | CellMouseDoubleClick | Occurs when the mouse button is double clicked inside the cell bounds.
Public event | CellMouseDown | Occurs when the mouse button is down in a cell bounds
Public event | CellMouseEnter | Occurs when the mouse pointer has entered cell bounds
Public event | CellMouseLeave | Occurs when the mouse pointer has left cell bounds
Public event | CellMouseMove | Occurs when a cell edit is ending
Public event | CellMouseUp | Occurs when the mouse button is released
Public event | CellPaintBegin | Occurs when a cell is painted.
Public event | CellParsing | Occurs when a cell date is parsed
Public event | CellSelectionChanged | Occurs when the grid cells selection has changed
Public event | CellValidated | Occurs when a cell is validated
Public event | CellValidating | Occurs when a cell is validating
Public event | CellValueChanged | Occurs after the value of a grid cell changed.
Public event | CellValueChanging | Occurs before a grid cell value changes.
Public event | CellValueNeeded | Occurs before a grid cell painting. Use this event in virtual mode to specify the content of the grid cell
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuClosed | Occurs when the built-in context menu is being closed
Public event | ContextMenuShowing | Occurs when the built-in context menu is being displayed.
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | GroupHeaderCustomTextNeeded | Occurs when a the rows group header is rendered. Use this event customize the text of the rows group headers.
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HierarchyItemCollapsed | Occurs when a HierarchyItem is collapsed
Public event | HierarchyItemCollapsing | Occurs when a HierarchyItem is collapsing
Public event | HierarchyItemCustomPaint | Occurs when a HierarchyItem is painted
Public event | HierarchyItemDrag | Occurs when a header item is dragged.
Public event | HierarchyItemDragEnded | Occurs when a drag operation with header item is ended
Public event | HierarchyItemDragEnding | Occurs when a drag operation with header item is ending
Public event | HierarchyItemDragStarted | Occurs when a drag operation with header item is started
Public event | HierarchyItemDragStarting | Occurs when a drag operation with header item is starting
Public event | HierarchyItemExpanded | Occurs when a HierarchyItem is expanded
Public event | HierarchyItemExpanding | Occurs when a HierarchyItem is expanding
Public event | HierarchyItemMouseClick | Occurs when a HierarchyItem is clicked
Public event | HierarchyItemMouseDoubleClick | Occurs when a HierarchyItem is double clicked.
Public event | HierarchyItemMouseDown | Occurs when the user presses a mouse button over HierarchyItem.
Public event | HierarchyItemMouseUp | Occurs when the user releases a mouse button over HierarchyItem.
Public event | HierarchyItemSelectionChanged | Occurs when the selection of a HierarchyItem has changed.
Public event | HorizontalScrollBarValueChanged | Occurs when the horizontal scrollbar value is changed.
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | ListChanged | Occurs when the CurrencyManager ListChanged event is raised.
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | Occurs when a property is changed.
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | TooltipShow | Occurs before a tooltip is shown and provides a way to customize the tooltip text
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VerticalScrollBarValueChanged | Occurs when the vertical scrollbar value is changed.
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


AutoScrollPositionChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..AutoScrollPositionChanged Event
vDataGridView Class See Also Send Feedback
Occurs when the scroll position has changed

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler AutoScrollPositionChanged
Visual Basic
Public Event AutoScrollPositionChanged As EventHandler
Visual C++
public:
 event EventHandler^ AutoScrollPositionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


BindField Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..BindField Event
vDataGridView Class See Also Send Feedback
Occurs when a the grid binds to data column from the data source

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..GridBindField BindField
Visual Basic
Public Event BindField As vDataGridView..::..GridBindField
Visual C++
public:
 event vDataGridView..::..GridBindField^ BindField {
    void add (vDataGridView..::..GridBindField^ value);
    void remove (vDataGridView..::..GridBindField^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


BindingComplete Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..BindingComplete Event
vDataGridView Class See Also Send Feedback
Occurs when a data binding operation is complete.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..DataBindingCompleteEventHandler BindingComplete
Visual Basic
Public Event BindingComplete As vDataGridView..::..DataBindingCompleteEventHandler
Visual C++
public:
 event vDataGridView..::..DataBindingCompleteEventHandler^ BindingComplete {
    void add (vDataGridView..::..DataBindingCompleteEventHandler^ value);
    void remove (vDataGridView..::..DataBindingCompleteEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


BindingProgressChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..BindingProgressChanged Event
vDataGridView Class See Also Send Feedback
Occurs when the data binding progress changes

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..BindingProgressFormatEventHandler BindingProgressChanged
Visual Basic
Public Event BindingProgressChanged As vDataGridView..::..BindingProgressFormatEventHandler
Visual C++
public:
 event vDataGridView..::..BindingProgressFormatEventHandler^ BindingProgressChanged {
    void add (vDataGridView..::..BindingProgressFormatEventHandler^ value);
    void remove (vDataGridView..::..BindingProgressFormatEventHandler^ value);
}

Remarks

Use this event to monitor the progress of binding and loading data.

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


BindingStart Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..BindingStart Event
vDataGridView Class See Also Send Feedback
Occurs when a data binding operation is complete.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..DataBindingStartEventHandler BindingStart
Visual Basic
Public Event BindingStart As vDataGridView..::..DataBindingStartEventHandler
Visual C++
public:
 event vDataGridView..::..DataBindingStartEventHandler^ BindingStart {
    void add (vDataGridView..::..DataBindingStartEventHandler^ value);
    void remove (vDataGridView..::..DataBindingStartEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellBeginEdit Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellBeginEdit Event
vDataGridView Class See Also Send Feedback
Occurs when a cell edit is begining

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellCancelEventHandler CellBeginEdit
Visual Basic
Public Event CellBeginEdit As vDataGridView..::..CellCancelEventHandler
Visual C++
public:
 event vDataGridView..::..CellCancelEventHandler^ CellBeginEdit {
    void add (vDataGridView..::..CellCancelEventHandler^ value);
    void remove (vDataGridView..::..CellCancelEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellCustomPaint Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellCustomPaint Event
vDataGridView Class See Also Send Feedback
Occurs when a cell is painted

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellPaintEventHandler CellCustomPaint
Visual Basic
Public Event CellCustomPaint As vDataGridView..::..CellPaintEventHandler
Visual C++
public:
 event vDataGridView..::..CellPaintEventHandler^ CellCustomPaint {
    void add (vDataGridView..::..CellPaintEventHandler^ value);
    void remove (vDataGridView..::..CellPaintEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellEditorActivate Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellEditorActivate Event
vDataGridView Class See Also Send Feedback
Occurs when a cell editor is being activated

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellEditorActivateEventHandler CellEditorActivate
Visual Basic
Public Event CellEditorActivate As vDataGridView..::..CellEditorActivateEventHandler
Visual C++
public:
 event vDataGridView..::..CellEditorActivateEventHandler^ CellEditorActivate {
    void add (vDataGridView..::..CellEditorActivateEventHandler^ value);
    void remove (vDataGridView..::..CellEditorActivateEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellEditorDeActivate Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellEditorDeActivate Event
vDataGridView Class See Also Send Feedback
Occurs when a cell editor is being activated

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellEditorActivateEventHandler CellEditorDeActivate
Visual Basic
Public Event CellEditorDeActivate As vDataGridView..::..CellEditorActivateEventHandler
Visual C++
public:
 event vDataGridView..::..CellEditorActivateEventHandler^ CellEditorDeActivate {
    void add (vDataGridView..::..CellEditorActivateEventHandler^ value);
    void remove (vDataGridView..::..CellEditorActivateEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellEndEdit Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellEndEdit Event
vDataGridView Class See Also Send Feedback
Occurs when a cell edit is ending

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellCancelEventHandler CellEndEdit
Visual Basic
Public Event CellEndEdit As vDataGridView..::..CellCancelEventHandler
Visual C++
public:
 event vDataGridView..::..CellCancelEventHandler^ CellEndEdit {
    void add (vDataGridView..::..CellCancelEventHandler^ value);
    void remove (vDataGridView..::..CellCancelEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellKeyDown Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellKeyDown Event
vDataGridView Class See Also Send Feedback
Occurs when a key is down.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<vDataGridView..::..CellKeyEventArgs> CellKeyDown
Visual Basic
Public Event CellKeyDown As EventHandler(Of vDataGridView..::..CellKeyEventArgs)
Visual C++
public:
 event EventHandler<vDataGridView..::..CellKeyEventArgs^>^ CellKeyDown {
    void add (EventHandler<vDataGridView..::..CellKeyEventArgs^>^ value);
    void remove (EventHandler<vDataGridView..::..CellKeyEventArgs^>^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellKeyUp Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellKeyUp Event
vDataGridView Class See Also Send Feedback
Occurs when a key is up.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<vDataGridView..::..CellKeyEventArgs> CellKeyUp
Visual Basic
Public Event CellKeyUp As EventHandler(Of vDataGridView..::..CellKeyEventArgs)
Visual C++
public:
 event EventHandler<vDataGridView..::..CellKeyEventArgs^>^ CellKeyUp {
    void add (EventHandler<vDataGridView..::..CellKeyEventArgs^>^ value);
    void remove (EventHandler<vDataGridView..::..CellKeyEventArgs^>^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellMouseClick Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellMouseClick Event
vDataGridView Class See Also Send Feedback
Occurs when the mouse button is clicked in cell bounds

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellMouseEventHandler CellMouseClick
Visual Basic
Public Event CellMouseClick As vDataGridView..::..CellMouseEventHandler
Visual C++
public:
 event vDataGridView..::..CellMouseEventHandler^ CellMouseClick {
    void add (vDataGridView..::..CellMouseEventHandler^ value);
    void remove (vDataGridView..::..CellMouseEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellMouseDoubleClick Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellMouseDoubleClick Event
vDataGridView Class See Also Send Feedback
Occurs when the mouse button is double clicked inside the cell bounds.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellMouseEventHandler CellMouseDoubleClick
Visual Basic
Public Event CellMouseDoubleClick As vDataGridView..::..CellMouseEventHandler
Visual C++
public:
 event vDataGridView..::..CellMouseEventHandler^ CellMouseDoubleClick {
    void add (vDataGridView..::..CellMouseEventHandler^ value);
    void remove (vDataGridView..::..CellMouseEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellMouseDown Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellMouseDown Event
vDataGridView Class See Also Send Feedback
Occurs when the mouse button is down in a cell bounds

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellMouseEventHandler CellMouseDown
Visual Basic
Public Event CellMouseDown As vDataGridView..::..CellMouseEventHandler
Visual C++
public:
 event vDataGridView..::..CellMouseEventHandler^ CellMouseDown {
    void add (vDataGridView..::..CellMouseEventHandler^ value);
    void remove (vDataGridView..::..CellMouseEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellMouseEnter Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellMouseEnter Event
vDataGridView Class See Also Send Feedback
Occurs when the mouse pointer has entered cell bounds

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellEventHandler CellMouseEnter
Visual Basic
Public Event CellMouseEnter As vDataGridView..::..CellEventHandler
Visual C++
public:
 event vDataGridView..::..CellEventHandler^ CellMouseEnter {
    void add (vDataGridView..::..CellEventHandler^ value);
    void remove (vDataGridView..::..CellEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellMouseLeave Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellMouseLeave Event
vDataGridView Class See Also Send Feedback
Occurs when the mouse pointer has left cell bounds

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellEventHandler CellMouseLeave
Visual Basic
Public Event CellMouseLeave As vDataGridView..::..CellEventHandler
Visual C++
public:
 event vDataGridView..::..CellEventHandler^ CellMouseLeave {
    void add (vDataGridView..::..CellEventHandler^ value);
    void remove (vDataGridView..::..CellEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellMouseMove Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellMouseMove Event
vDataGridView Class See Also Send Feedback
Occurs when a cell edit is ending

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellMouseEventHandler CellMouseMove
Visual Basic
Public Event CellMouseMove As vDataGridView..::..CellMouseEventHandler
Visual C++
public:
 event vDataGridView..::..CellMouseEventHandler^ CellMouseMove {
    void add (vDataGridView..::..CellMouseEventHandler^ value);
    void remove (vDataGridView..::..CellMouseEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellMouseUp Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellMouseUp Event
vDataGridView Class See Also Send Feedback
Occurs when the mouse button is released

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellMouseEventHandler CellMouseUp
Visual Basic
Public Event CellMouseUp As vDataGridView..::..CellMouseEventHandler
Visual C++
public:
 event vDataGridView..::..CellMouseEventHandler^ CellMouseUp {
    void add (vDataGridView..::..CellMouseEventHandler^ value);
    void remove (vDataGridView..::..CellMouseEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellPaintBegin Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellPaintBegin Event
vDataGridView Class See Also Send Feedback
Occurs when a cell is painted.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellCancelEventHandler CellPaintBegin
Visual Basic
Public Event CellPaintBegin As vDataGridView..::..CellCancelEventHandler
Visual C++
public:
 event vDataGridView..::..CellCancelEventHandler^ CellPaintBegin {
    void add (vDataGridView..::..CellCancelEventHandler^ value);
    void remove (vDataGridView..::..CellCancelEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellParsing Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellParsing Event
vDataGridView Class See Also Send Feedback
Occurs when a cell date is parsed

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellParsingEventHandler CellParsing
Visual Basic
Public Event CellParsing As vDataGridView..::..CellParsingEventHandler
Visual C++
public:
 event vDataGridView..::..CellParsingEventHandler^ CellParsing {
    void add (vDataGridView..::..CellParsingEventHandler^ value);
    void remove (vDataGridView..::..CellParsingEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellSelectionChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellSelectionChanged Event
vDataGridView Class See Also Send Feedback
Occurs when the grid cells selection has changed

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellEventHandler CellSelectionChanged
Visual Basic
Public Event CellSelectionChanged As vDataGridView..::..CellEventHandler
Visual C++
public:
 event vDataGridView..::..CellEventHandler^ CellSelectionChanged {
    void add (vDataGridView..::..CellEventHandler^ value);
    void remove (vDataGridView..::..CellEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellValidated Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellValidated Event
vDataGridView Class See Also Send Feedback
Occurs when a cell is validated

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellEventHandler CellValidated
Visual Basic
Public Event CellValidated As vDataGridView..::..CellEventHandler
Visual C++
public:
 event vDataGridView..::..CellEventHandler^ CellValidated {
    void add (vDataGridView..::..CellEventHandler^ value);
    void remove (vDataGridView..::..CellEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellValidating Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellValidating Event
vDataGridView Class See Also Send Feedback
Occurs when a cell is validating

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellCancelEventHandler CellValidating
Visual Basic
Public Event CellValidating As vDataGridView..::..CellCancelEventHandler
Visual C++
public:
 event vDataGridView..::..CellCancelEventHandler^ CellValidating {
    void add (vDataGridView..::..CellCancelEventHandler^ value);
    void remove (vDataGridView..::..CellCancelEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellValueChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellValueChanged Event
vDataGridView Class See Also Send Feedback
Occurs after the value of a grid cell changed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellEventHandler CellValueChanged
Visual Basic
Public Event CellValueChanged As vDataGridView..::..CellEventHandler
Visual C++
public:
 event vDataGridView..::..CellEventHandler^ CellValueChanged {
    void add (vDataGridView..::..CellEventHandler^ value);
    void remove (vDataGridView..::..CellEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellValueChanging Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellValueChanging Event
vDataGridView Class See Also Send Feedback
Occurs before a grid cell value changes.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellValueChangingEventHandler CellValueChanging
Visual Basic
Public Event CellValueChanging As vDataGridView..::..CellValueChangingEventHandler
Visual C++
public:
 event vDataGridView..::..CellValueChangingEventHandler^ CellValueChanging {
    void add (vDataGridView..::..CellValueChangingEventHandler^ value);
    void remove (vDataGridView..::..CellValueChangingEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


CellValueNeeded Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellValueNeeded Event
vDataGridView Class See Also Send Feedback
Occurs before a grid cell painting. Use this event in virtual mode to specify the content of the grid cell

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..CellValueNeededEventHandler CellValueNeeded
Visual Basic
Public Event CellValueNeeded As vDataGridView..::..CellValueNeededEventHandler
Visual C++
public:
 event vDataGridView..::..CellValueNeededEventHandler^ CellValueNeeded {
    void add (vDataGridView..::..CellValueNeededEventHandler^ value);
    void remove (vDataGridView..::..CellValueNeededEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


ContextMenuClosed Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ContextMenuClosed Event
vDataGridView Class See Also Send Feedback
Occurs when the built-in context menu is being closed

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler ContextMenuClosed
Visual Basic
Public Event ContextMenuClosed As EventHandler
Visual C++
public:
 event EventHandler^ ContextMenuClosed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


ContextMenuShowing Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ContextMenuShowing Event
vDataGridView Class See Also Send Feedback
Occurs when the built-in context menu is being displayed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event CancelEventHandler ContextMenuShowing
Visual Basic
Public Event ContextMenuShowing As CancelEventHandler
Visual C++
public:
 event CancelEventHandler^ ContextMenuShowing {
    void add (CancelEventHandler^ value);
    void remove (CancelEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


GroupHeaderCustomTextNeeded Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GroupHeaderCustomTextNeeded Event
vDataGridView Class See Also Send Feedback
Occurs when a the rows group header is rendered. Use this event customize the text of the rows group headers.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..GridGroupHeaderCustomTextNeededEventHandler GroupHeaderCustomTextNeeded
Visual Basic
Public Event GroupHeaderCustomTextNeeded As vDataGridView..::..GridGroupHeaderCustomTextNeededEventHandler
Visual C++
public:
 event vDataGridView..::..GridGroupHeaderCustomTextNeededEventHandler^ GroupHeaderCustomTextNeeded {
    void add (vDataGridView..::..GridGroupHeaderCustomTextNeededEventHandler^ value);
    void remove (vDataGridView..::..GridGroupHeaderCustomTextNeededEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemCollapsed Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemCollapsed Event
vDataGridView Class See Also Send Feedback
Occurs when a HierarchyItem is collapsed

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..HierarchyItemEventHandler HierarchyItemCollapsed
Visual Basic
Public Event HierarchyItemCollapsed As vDataGridView..::..HierarchyItemEventHandler
Visual C++
public:
 event vDataGridView..::..HierarchyItemEventHandler^ HierarchyItemCollapsed {
    void add (vDataGridView..::..HierarchyItemEventHandler^ value);
    void remove (vDataGridView..::..HierarchyItemEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemCollapsing Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemCollapsing Event
vDataGridView Class See Also Send Feedback
Occurs when a HierarchyItem is collapsing

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..HierarchyItemCancelEventHandler HierarchyItemCollapsing
Visual Basic
Public Event HierarchyItemCollapsing As vDataGridView..::..HierarchyItemCancelEventHandler
Visual C++
public:
 event vDataGridView..::..HierarchyItemCancelEventHandler^ HierarchyItemCollapsing {
    void add (vDataGridView..::..HierarchyItemCancelEventHandler^ value);
    void remove (vDataGridView..::..HierarchyItemCancelEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemCustomPaint Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemCustomPaint Event
vDataGridView Class See Also Send Feedback
Occurs when a HierarchyItem is painted

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..HierarchyItemPaintEventHandler HierarchyItemCustomPaint
Visual Basic
Public Event HierarchyItemCustomPaint As vDataGridView..::..HierarchyItemPaintEventHandler
Visual C++
public:
 event vDataGridView..::..HierarchyItemPaintEventHandler^ HierarchyItemCustomPaint {
    void add (vDataGridView..::..HierarchyItemPaintEventHandler^ value);
    void remove (vDataGridView..::..HierarchyItemPaintEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemDrag Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemDrag Event
vDataGridView Class See Also Send Feedback
Occurs when a header item is dragged.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..HierarchyItemDragEventHandler HierarchyItemDrag
Visual Basic
Public Event HierarchyItemDrag As vDataGridView..::..HierarchyItemDragEventHandler
Visual C++
public:
 event vDataGridView..::..HierarchyItemDragEventHandler^ HierarchyItemDrag {
    void add (vDataGridView..::..HierarchyItemDragEventHandler^ value);
    void remove (vDataGridView..::..HierarchyItemDragEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemDragEnded Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemDragEnded Event
vDataGridView Class See Also Send Feedback
Occurs when a drag operation with header item is ended

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..HierarchyItemDragEventHandler HierarchyItemDragEnded
Visual Basic
Public Event HierarchyItemDragEnded As vDataGridView..::..HierarchyItemDragEventHandler
Visual C++
public:
 event vDataGridView..::..HierarchyItemDragEventHandler^ HierarchyItemDragEnded {
    void add (vDataGridView..::..HierarchyItemDragEventHandler^ value);
    void remove (vDataGridView..::..HierarchyItemDragEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemDragEnding Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemDragEnding Event
vDataGridView Class See Also Send Feedback
Occurs when a drag operation with header item is ending

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..HierarchyItemDragCancelEventHandler HierarchyItemDragEnding
Visual Basic
Public Event HierarchyItemDragEnding As vDataGridView..::..HierarchyItemDragCancelEventHandler
Visual C++
public:
 event vDataGridView..::..HierarchyItemDragCancelEventHandler^ HierarchyItemDragEnding {
    void add (vDataGridView..::..HierarchyItemDragCancelEventHandler^ value);
    void remove (vDataGridView..::..HierarchyItemDragCancelEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemDragStarted Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemDragStarted Event
vDataGridView Class See Also Send Feedback
Occurs when a drag operation with header item is started

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..HierarchyItemDragEventHandler HierarchyItemDragStarted
Visual Basic
Public Event HierarchyItemDragStarted As vDataGridView..::..HierarchyItemDragEventHandler
Visual C++
public:
 event vDataGridView..::..HierarchyItemDragEventHandler^ HierarchyItemDragStarted {
    void add (vDataGridView..::..HierarchyItemDragEventHandler^ value);
    void remove (vDataGridView..::..HierarchyItemDragEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemDragStarting Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemDragStarting Event
vDataGridView Class See Also Send Feedback
Occurs when a drag operation with header item is starting

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..HierarchyItemDragCancelEventHandler HierarchyItemDragStarting
Visual Basic
Public Event HierarchyItemDragStarting As vDataGridView..::..HierarchyItemDragCancelEventHandler
Visual C++
public:
 event vDataGridView..::..HierarchyItemDragCancelEventHandler^ HierarchyItemDragStarting {
    void add (vDataGridView..::..HierarchyItemDragCancelEventHandler^ value);
    void remove (vDataGridView..::..HierarchyItemDragCancelEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemExpanded Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemExpanded Event
vDataGridView Class See Also Send Feedback
Occurs when a HierarchyItem is expanded

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..HierarchyItemEventHandler HierarchyItemExpanded
Visual Basic
Public Event HierarchyItemExpanded As vDataGridView..::..HierarchyItemEventHandler
Visual C++
public:
 event vDataGridView..::..HierarchyItemEventHandler^ HierarchyItemExpanded {
    void add (vDataGridView..::..HierarchyItemEventHandler^ value);
    void remove (vDataGridView..::..HierarchyItemEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemExpanding Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemExpanding Event
vDataGridView Class See Also Send Feedback
Occurs when a HierarchyItem is expanding

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..HierarchyItemCancelEventHandler HierarchyItemExpanding
Visual Basic
Public Event HierarchyItemExpanding As vDataGridView..::..HierarchyItemCancelEventHandler
Visual C++
public:
 event vDataGridView..::..HierarchyItemCancelEventHandler^ HierarchyItemExpanding {
    void add (vDataGridView..::..HierarchyItemCancelEventHandler^ value);
    void remove (vDataGridView..::..HierarchyItemCancelEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemMouseClick Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemMouseClick Event
vDataGridView Class See Also Send Feedback
Occurs when a HierarchyItem is clicked

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..HierarchyItemMouseEventHandler HierarchyItemMouseClick
Visual Basic
Public Event HierarchyItemMouseClick As vDataGridView..::..HierarchyItemMouseEventHandler
Visual C++
public:
 event vDataGridView..::..HierarchyItemMouseEventHandler^ HierarchyItemMouseClick {
    void add (vDataGridView..::..HierarchyItemMouseEventHandler^ value);
    void remove (vDataGridView..::..HierarchyItemMouseEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemMouseDoubleClick Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemMouseDoubleClick Event
vDataGridView Class See Also Send Feedback
Occurs when a HierarchyItem is double clicked.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..HierarchyItemMouseEventHandler HierarchyItemMouseDoubleClick
Visual Basic
Public Event HierarchyItemMouseDoubleClick As vDataGridView..::..HierarchyItemMouseEventHandler
Visual C++
public:
 event vDataGridView..::..HierarchyItemMouseEventHandler^ HierarchyItemMouseDoubleClick {
    void add (vDataGridView..::..HierarchyItemMouseEventHandler^ value);
    void remove (vDataGridView..::..HierarchyItemMouseEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemMouseDown Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemMouseDown Event
vDataGridView Class See Also Send Feedback
Occurs when the user presses a mouse button over HierarchyItem.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..HierarchyItemMouseEventHandler HierarchyItemMouseDown
Visual Basic
Public Event HierarchyItemMouseDown As vDataGridView..::..HierarchyItemMouseEventHandler
Visual C++
public:
 event vDataGridView..::..HierarchyItemMouseEventHandler^ HierarchyItemMouseDown {
    void add (vDataGridView..::..HierarchyItemMouseEventHandler^ value);
    void remove (vDataGridView..::..HierarchyItemMouseEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemMouseUp Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemMouseUp Event
vDataGridView Class See Also Send Feedback
Occurs when the user releases a mouse button over HierarchyItem.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..HierarchyItemMouseEventHandler HierarchyItemMouseUp
Visual Basic
Public Event HierarchyItemMouseUp As vDataGridView..::..HierarchyItemMouseEventHandler
Visual C++
public:
 event vDataGridView..::..HierarchyItemMouseEventHandler^ HierarchyItemMouseUp {
    void add (vDataGridView..::..HierarchyItemMouseEventHandler^ value);
    void remove (vDataGridView..::..HierarchyItemMouseEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HierarchyItemSelectionChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemSelectionChanged Event
vDataGridView Class See Also Send Feedback
Occurs when the selection of a HierarchyItem has changed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..HierarchyItemEventHandler HierarchyItemSelectionChanged
Visual Basic
Public Event HierarchyItemSelectionChanged As vDataGridView..::..HierarchyItemEventHandler
Visual C++
public:
 event vDataGridView..::..HierarchyItemEventHandler^ HierarchyItemSelectionChanged {
    void add (vDataGridView..::..HierarchyItemEventHandler^ value);
    void remove (vDataGridView..::..HierarchyItemEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


HorizontalScrollBarValueChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HorizontalScrollBarValueChanged Event
vDataGridView Class See Also Send Feedback
Occurs when the horizontal scrollbar value is changed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler HorizontalScrollBarValueChanged
Visual Basic
Public Event HorizontalScrollBarValueChanged As EventHandler
Visual C++
public:
 event EventHandler^ HorizontalScrollBarValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


ListChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..ListChanged Event
vDataGridView Class See Also Send Feedback
Occurs when the CurrencyManager ListChanged event is raised.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<ListChangedEventArgs> ListChanged
Visual Basic
Public Event ListChanged As EventHandler(Of ListChangedEventArgs)
Visual C++
public:
 event EventHandler<ListChangedEventArgs^>^ ListChanged {
    void add (EventHandler<ListChangedEventArgs^>^ value);
    void remove (EventHandler<ListChangedEventArgs^>^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


PropertyChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..PropertyChanged Event
vDataGridView Class See Also Send Feedback
Occurs when a property is changed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


TooltipShow Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..TooltipShow Event
vDataGridView Class See Also Send Feedback
Occurs before a tooltip is shown and provides a way to customize the tooltip text

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event vDataGridView..::..GridTooltipEventHandler TooltipShow
Visual Basic
Public Event TooltipShow As vDataGridView..::..GridTooltipEventHandler
Visual C++
public:
 event vDataGridView..::..GridTooltipEventHandler^ TooltipShow {
    void add (vDataGridView..::..GridTooltipEventHandler^ value);
    void remove (vDataGridView..::..GridTooltipEventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


VerticalScrollBarValueChanged Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..VerticalScrollBarValueChanged Event
vDataGridView Class See Also Send Feedback
Occurs when the vertical scrollbar value is changed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler VerticalScrollBarValueChanged
Visual Basic
Public Event VerticalScrollBarValueChanged As EventHandler
Visual C++
public:
 event EventHandler^ VerticalScrollBarValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vDataGridView Class
VIBlend.WinForms.DataGridView Namespace


vDataGridView.BindingProgressFormatEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..BindingProgressFormatEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void BindingProgressFormatEventHandler(
    Object sender,
    BindingProgressEventArgs e
)
Visual Basic
Public Delegate Sub BindingProgressFormatEventHandler ( _
    sender As Object, _
    e As BindingProgressEventArgs _
)
Visual C++
public delegate void BindingProgressFormatEventHandler(
    Object^ sender,
    BindingProgressEventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: VIBlend.WinForms.DataGridView..::..BindingProgressEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.CellCancelEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellCancelEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void CellCancelEventHandler(
    Object sender,
    CellCancelEventArgs args
)
Visual Basic
Public Delegate Sub CellCancelEventHandler ( _
    sender As Object, _
    args As CellCancelEventArgs _
)
Visual C++
public delegate void CellCancelEventHandler(
    Object^ sender,
    CellCancelEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.DataGridView..::..CellCancelEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.CellEditorActivateEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellEditorActivateEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void CellEditorActivateEventHandler(
    Object sender,
    EditorActivationCancelEventArgs args
)
Visual Basic
Public Delegate Sub CellEditorActivateEventHandler ( _
    sender As Object, _
    args As EditorActivationCancelEventArgs _
)
Visual C++
public delegate void CellEditorActivateEventHandler(
    Object^ sender,
    EditorActivationCancelEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.DataGridView..::..EditorActivationCancelEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.CellEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void CellEventHandler(
    Object sender,
    CellEventArgs args
)
Visual Basic
Public Delegate Sub CellEventHandler ( _
    sender As Object, _
    args As CellEventArgs _
)
Visual C++
public delegate void CellEventHandler(
    Object^ sender,
    CellEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.DataGridView..::..CellEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.CellKeyEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellKeyEventArgs Class
vDataGridView Class Members See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class CellKeyEventArgs : EventArgs
Visual Basic
Public Class CellKeyEventArgs _
    Inherits EventArgs
Visual C++
public ref class CellKeyEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.DataGridView..::..vDataGridView..::..CellKeyEventArgs

See Also

vDataGridView..::..CellKeyEventArgs Members
VIBlend.WinForms.DataGridView Namespace


vDataGridView.CellKeyEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellKeyEventArgs Members
vDataGridView..::..CellKeyEventArgs Class Constructors Methods Properties See Also Send Feedback

Represents a GridView control

The vDataGridView..::..CellKeyEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | vDataGridView..::..CellKeyEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cell | The grid cell associated with the event
Public property | KeyEventArgs | Returns the MouseEventArgs.

See Also

vDataGridView..::..CellKeyEventArgs Class
VIBlend.WinForms.DataGridView Namespace


vDataGridView.CellKeyEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellKeyEventArgs Constructor
vDataGridView..::..CellKeyEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public CellKeyEventArgs(
    GridCell cell,
    KeyEventArgs args
)
Visual Basic
Public Sub New ( _
    cell As GridCell, _
    args As KeyEventArgs _
)
Visual C++
public:
CellKeyEventArgs(
    GridCell^ cell,
    KeyEventArgs^ args
)

Parameters

cell
Type: VIBlend.WinForms.DataGridView..::..GridCell
GridCell
args
Type: System.Windows.Forms..::..KeyEventArgs
KeyboardEventArgs

See Also

vDataGridView..::..CellKeyEventArgs Class
VIBlend.WinForms.DataGridView Namespace


vDataGridView.CellKeyEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellKeyEventArgs Methods
vDataGridView..::..CellKeyEventArgs Class See Also Send Feedback

The vDataGridView..::..CellKeyEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vDataGridView..::..CellKeyEventArgs Class
VIBlend.WinForms.DataGridView Namespace


vDataGridView.CellKeyEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellKeyEventArgs Properties
vDataGridView..::..CellKeyEventArgs Class See Also Send Feedback

The vDataGridView..::..CellKeyEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cell | The grid cell associated with the event
Public property | KeyEventArgs | Returns the MouseEventArgs.

See Also

vDataGridView..::..CellKeyEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Cell Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellKeyEventArgs..::..Cell Property
vDataGridView..::..CellKeyEventArgs Class See Also Send Feedback
The grid cell associated with the event

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridCell Cell { get; }
Visual Basic
Public ReadOnly Property Cell As GridCell
    Get
Visual C++
public:
property GridCell^ Cell {
    GridCell^ get ();
}

See Also

vDataGridView..::..CellKeyEventArgs Class
VIBlend.WinForms.DataGridView Namespace


KeyEventArgs Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellKeyEventArgs..::..KeyEventArgs Property
vDataGridView..::..CellKeyEventArgs Class See Also Send Feedback
Returns the MouseEventArgs.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public KeyEventArgs KeyEventArgs { get; protected set; }
Visual Basic
Public Property KeyEventArgs As KeyEventArgs
    Get
    Protected Set
Visual C++
public:
property KeyEventArgs^ KeyEventArgs {
    KeyEventArgs^ get ();
    protected: void set (KeyEventArgs^ value);
}

See Also

vDataGridView..::..CellKeyEventArgs Class
VIBlend.WinForms.DataGridView Namespace


vDataGridView.CellMouseEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellMouseEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void CellMouseEventHandler(
    Object sender,
    CellMouseEventArgs args
)
Visual Basic
Public Delegate Sub CellMouseEventHandler ( _
    sender As Object, _
    args As CellMouseEventArgs _
)
Visual C++
public delegate void CellMouseEventHandler(
    Object^ sender,
    CellMouseEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.DataGridView..::..CellMouseEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.CellPaintEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellPaintEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void CellPaintEventHandler(
    Object sender,
    CellPaintEventArgs args
)
Visual Basic
Public Delegate Sub CellPaintEventHandler ( _
    sender As Object, _
    args As CellPaintEventArgs _
)
Visual C++
public delegate void CellPaintEventHandler(
    Object^ sender,
    CellPaintEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.DataGridView..::..CellPaintEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.CellParsingEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellParsingEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void CellParsingEventHandler(
    Object sender,
    CellParsingEventArgs args
)
Visual Basic
Public Delegate Sub CellParsingEventHandler ( _
    sender As Object, _
    args As CellParsingEventArgs _
)
Visual C++
public delegate void CellParsingEventHandler(
    Object^ sender,
    CellParsingEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.DataGridView..::..CellParsingEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.CellValueChangingEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellValueChangingEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void CellValueChangingEventHandler(
    Object sender,
    CellValueChangingEventArgs args
)
Visual Basic
Public Delegate Sub CellValueChangingEventHandler ( _
    sender As Object, _
    args As CellValueChangingEventArgs _
)
Visual C++
public delegate void CellValueChangingEventHandler(
    Object^ sender,
    CellValueChangingEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.DataGridView..::..CellValueChangingEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.CellValueNeededEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CellValueNeededEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void CellValueNeededEventHandler(
    Object sender,
    CellValueNeededEventArgs args
)
Visual Basic
Public Delegate Sub CellValueNeededEventHandler ( _
    sender As Object, _
    args As CellValueNeededEventArgs _
)
Visual C++
public delegate void CellValueNeededEventHandler(
    Object^ sender,
    CellValueNeededEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.DataGridView..::..CellValueNeededEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.CURSOR_TYPE Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..CURSOR_TYPE Enumeration
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected enum CURSOR_TYPE
Visual Basic
Protected Enumeration CURSOR_TYPE
Visual C++
protected enum class CURSOR_TYPE

Members

Member name | Description
ARROW |
CROSS |
COLUMN_RESIZE |
ROW_RESIZE |
HAND |

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.DataBindingCompleteEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..DataBindingCompleteEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void DataBindingCompleteEventHandler(
    Object sender,
    EventArgs e
)
Visual Basic
Public Delegate Sub DataBindingCompleteEventHandler ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
public delegate void DataBindingCompleteEventHandler(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: System..::..EventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.DataBindingStartEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..DataBindingStartEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void DataBindingStartEventHandler(
    Object sender,
    EventArgs e
)
Visual Basic
Public Delegate Sub DataBindingStartEventHandler ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
public delegate void DataBindingStartEventHandler(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: System..::..EventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.GridBindField Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GridBindField Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void GridBindField(
    Object sender,
    BoundFieldEventArgs args
)
Visual Basic
Public Delegate Sub GridBindField ( _
    sender As Object, _
    args As BoundFieldEventArgs _
)
Visual C++
public delegate void GridBindField(
    Object^ sender,
    BoundFieldEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.DataGridView..::..BoundFieldEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.GridGroupHeaderCustomTextNeededEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GridGroupHeaderCustomTextNeededEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void GridGroupHeaderCustomTextNeededEventHandler(
    Object sender,
    vDataGridView..::..GroupHeaderCustomTextNeededEventArgs args
)
Visual Basic
Public Delegate Sub GridGroupHeaderCustomTextNeededEventHandler ( _
    sender As Object, _
    args As vDataGridView..::..GroupHeaderCustomTextNeededEventArgs _
)
Visual C++
public delegate void GridGroupHeaderCustomTextNeededEventHandler(
    Object^ sender,
    vDataGridView..::..GroupHeaderCustomTextNeededEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.DataGridView..::..vDataGridView..::..GroupHeaderCustomTextNeededEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.GridTooltipEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GridTooltipEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void GridTooltipEventHandler(
    Object sender,
    GridToolTipEventArgs args
)
Visual Basic
Public Delegate Sub GridTooltipEventHandler ( _
    sender As Object, _
    args As GridToolTipEventArgs _
)
Visual C++
public delegate void GridTooltipEventHandler(
    Object^ sender,
    GridToolTipEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.DataGridView..::..GridToolTipEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.GroupHeaderCustomTextNeededEventArgs Class

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class
vDataGridView Class Members See Also Send Feedback
Represents a group header custom text needed event arguments.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class GroupHeaderCustomTextNeededEventArgs : EventArgs
Visual Basic
Public Class GroupHeaderCustomTextNeededEventArgs _
    Inherits EventArgs
Visual C++
public ref class GroupHeaderCustomTextNeededEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
VIBlend.WinForms.DataGridView..::..vDataGridView..::..GroupHeaderCustomTextNeededEventArgs

See Also

vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Members
VIBlend.WinForms.DataGridView Namespace


vDataGridView.GroupHeaderCustomTextNeededEventArgs Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Members
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class Constructors Methods Properties See Also Send Feedback

Represents a GridView control

The vDataGridView..::..GroupHeaderCustomTextNeededEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | vDataGridView..::..GroupHeaderCustomTextNeededEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GroupRows | Collection of HierarchyItems that represents the rows in the group.
Public property | HeaderFont | Gets or sets the font of the rows header.
Public property | HeaderText | Gets or sets the custom text of the rows header.
Public property | HeaderTextAlignment | Gets or sets the alignment of the header text.
Public property | HeaderTextColor | Gets or sets the text color of the header text.
Public property | Row | Gets the row.

See Also

vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


vDataGridView.GroupHeaderCustomTextNeededEventArgs Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Constructor
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class See Also Send Feedback
Constructor

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GroupHeaderCustomTextNeededEventArgs(
    HierarchyItem rowItem,
    HierarchyItemsCollection rows
)
Visual Basic
Public Sub New ( _
    rowItem As HierarchyItem, _
    rows As HierarchyItemsCollection _
)
Visual C++
public:
GroupHeaderCustomTextNeededEventArgs(
    HierarchyItem^ rowItem,
    HierarchyItemsCollection^ rows
)

Parameters

rowItem
Type: VIBlend.WinForms.DataGridView..::..HierarchyItem
rows
Type: VIBlend.WinForms.DataGridView..::..HierarchyItemsCollection

See Also

vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


vDataGridView.GroupHeaderCustomTextNeededEventArgs Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Methods
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class See Also Send Feedback

The vDataGridView..::..GroupHeaderCustomTextNeededEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


vDataGridView.GroupHeaderCustomTextNeededEventArgs Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Properties
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class See Also Send Feedback

The vDataGridView..::..GroupHeaderCustomTextNeededEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | GroupRows | Collection of HierarchyItems that represents the rows in the group.
Public property | HeaderFont | Gets or sets the font of the rows header.
Public property | HeaderText | Gets or sets the custom text of the rows header.
Public property | HeaderTextAlignment | Gets or sets the alignment of the header text.
Public property | HeaderTextColor | Gets or sets the text color of the header text.
Public property | Row | Gets the row.

See Also

vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


GroupRows Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs..::..GroupRows Property
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class See Also Send Feedback
Collection of HierarchyItems that represents the rows in the group.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItemsCollection GroupRows { get; }
Visual Basic
Public ReadOnly Property GroupRows As HierarchyItemsCollection
    Get
Visual C++
public:
property HierarchyItemsCollection^ GroupRows {
    HierarchyItemsCollection^ get ();
}

See Also

vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HeaderFont Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs..::..HeaderFont Property
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class See Also Send Feedback
Gets or sets the font of the rows header.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Font HeaderFont { get; set; }
Visual Basic
Public Property HeaderFont As Font
    Get
    Set
Visual C++
public:
property Font^ HeaderFont {
    Font^ get ();
    void set (Font^ value);
}

See Also

vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HeaderText Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs..::..HeaderText Property
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class See Also Send Feedback
Gets or sets the custom text of the rows header.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string HeaderText { get; set; }
Visual Basic
Public Property HeaderText As String
    Get
    Set
Visual C++
public:
property String^ HeaderText {
    String^ get ();
    void set (String^ value);
}

See Also

vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HeaderTextAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs..::..HeaderTextAlignment Property
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class See Also Send Feedback
Gets or sets the alignment of the header text.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ContentAlignment HeaderTextAlignment { get; set; }
Visual Basic
Public Property HeaderTextAlignment As ContentAlignment
    Get
    Set
Visual C++
public:
property ContentAlignment HeaderTextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


HeaderTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs..::..HeaderTextColor Property
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class See Also Send Feedback
Gets or sets the text color of the header text.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color HeaderTextColor { get; set; }
Visual Basic
Public Property HeaderTextColor As Color
    Get
    Set
Visual C++
public:
property Color HeaderTextColor {
    Color get ();
    void set (Color value);
}

See Also

vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


Row Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs..::..Row Property
vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class See Also Send Feedback
Gets the row.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HierarchyItem Row { get; }
Visual Basic
Public ReadOnly Property Row As HierarchyItem
    Get
Visual C++
public:
property HierarchyItem^ Row {
    HierarchyItem^ get ();
}

Field Value

The row.

See Also

vDataGridView..::..GroupHeaderCustomTextNeededEventArgs Class
VIBlend.WinForms.DataGridView Namespace


vDataGridView.HierarchyItemCancelEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemCancelEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void HierarchyItemCancelEventHandler(
    Object sender,
    HierarchyItemCancelEventArgs args
)
Visual Basic
Public Delegate Sub HierarchyItemCancelEventHandler ( _
    sender As Object, _
    args As HierarchyItemCancelEventArgs _
)
Visual C++
public delegate void HierarchyItemCancelEventHandler(
    Object^ sender,
    HierarchyItemCancelEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.DataGridView..::..HierarchyItemCancelEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.HierarchyItemDragCancelEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemDragCancelEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void HierarchyItemDragCancelEventHandler(
    Object sender,
    HierarchyItemDragCancelEventArgs args
)
Visual Basic
Public Delegate Sub HierarchyItemDragCancelEventHandler ( _
    sender As Object, _
    args As HierarchyItemDragCancelEventArgs _
)
Visual C++
public delegate void HierarchyItemDragCancelEventHandler(
    Object^ sender,
    HierarchyItemDragCancelEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.DataGridView..::..HierarchyItemDragCancelEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.HierarchyItemDragEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemDragEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void HierarchyItemDragEventHandler(
    Object sender,
    HierarchyItemDragEventArgs args
)
Visual Basic
Public Delegate Sub HierarchyItemDragEventHandler ( _
    sender As Object, _
    args As HierarchyItemDragEventArgs _
)
Visual C++
public delegate void HierarchyItemDragEventHandler(
    Object^ sender,
    HierarchyItemDragEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.DataGridView..::..HierarchyItemDragEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.HierarchyItemEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void HierarchyItemEventHandler(
    Object sender,
    HierarchyItemEventArgs args
)
Visual Basic
Public Delegate Sub HierarchyItemEventHandler ( _
    sender As Object, _
    args As HierarchyItemEventArgs _
)
Visual C++
public delegate void HierarchyItemEventHandler(
    Object^ sender,
    HierarchyItemEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.DataGridView..::..HierarchyItemEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.HierarchyItemMouseEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemMouseEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void HierarchyItemMouseEventHandler(
    Object sender,
    HierarchyItemMouseEventArgs args
)
Visual Basic
Public Delegate Sub HierarchyItemMouseEventHandler ( _
    sender As Object, _
    args As HierarchyItemMouseEventArgs _
)
Visual C++
public delegate void HierarchyItemMouseEventHandler(
    Object^ sender,
    HierarchyItemMouseEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.DataGridView..::..HierarchyItemMouseEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.HierarchyItemPaintEventHandler Delegate

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..HierarchyItemPaintEventHandler Delegate
vDataGridView Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public delegate void HierarchyItemPaintEventHandler(
    Object sender,
    HierarchyItemPaintEventArgs args
)
Visual Basic
Public Delegate Sub HierarchyItemPaintEventHandler ( _
    sender As Object, _
    args As HierarchyItemPaintEventArgs _
)
Visual C++
public delegate void HierarchyItemPaintEventHandler(
    Object^ sender,
    HierarchyItemPaintEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: VIBlend.WinForms.DataGridView..::..HierarchyItemPaintEventArgs

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridView.SELECTION_MODE Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridView..::..SELECTION_MODE Enumeration
vDataGridView Class See Also Send Feedback
Enumeration of the grid cells selection mode

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum SELECTION_MODE
Visual Basic
Public Enumeration SELECTION_MODE
Visual C++
public enum class SELECTION_MODE

Members

Member name | Description
FULL_ROW_SELECT |
FULL_COLUMN_SELECT |
CELL_SELECT |

See Also

VIBlend.WinForms.DataGridView Namespace


vDataGridViewGroupsHeader Class

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vDataGridViewGroupsHeader : Control
Visual Basic
Public Class vDataGridViewGroupsHeader _
    Inherits Control
Visual C++
public ref class vDataGridViewGroupsHeader : public Control

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
VIBlend.WinForms.DataGridView..::..vDataGridViewGroupsHeader

See Also

vDataGridViewGroupsHeader Members
VIBlend.WinForms.DataGridView Namespace


vDataGridViewGroupsHeader Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader Members
vDataGridViewGroupsHeader Class Constructors Methods Properties Events See Also Send Feedback

The vDataGridViewGroupsHeader type exposes the following members.

Constructors

 | Name | Description
Public method | vDataGridViewGroupsHeader | Initializes a new instance of the vDataGridViewGroupsHeader class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetColumnHeaders | Gets the column headers.
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnded | Raises the [E:DragEnded] event.
Protected method | OnDragEnding | Raises the [E:DragEnding] event.
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDragStarted | Raises the [E:DragStarted] event.
Protected method | OnDragStarting | Raises the [E:DragStarting] event.
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RenderConnectingLines | Renders the connecting lines.
Protected method | RenderContent | Renders the content.
Public method | RenderGroups | Renders the groups.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnwireEvents | Unwires the events.
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | WireEvents | Wires the events.
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDragDrop | Gets or sets a value indicating whether to allow the items drag and drop.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | ConnectingLinesColor | Gets or sets the color of the connecting lines.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataGridView | Gets or sets the associated data grid view.
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | HeaderItemIndent | Gets or sets the header item indent.
Public property | HeaderItemsAlignment | Gets or sets the header items vertical layout.
Public property | HeaderItemsPadding | Gets or sets the header items padding.
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InitialItemsOffset | Gets or sets the initial items offset.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsThemeSynchronized | Gets or sets a value indicating whether this instance is theme synchronized.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | PromptText | Gets or sets the prompt text.
Public property | PromptTextColor | Gets or sets the prompt text color.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ShowConnectingLines | Gets or sets a value indicating whether to show the header items connecting lines.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme |
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnded | Occurs when the Drag operation ended.
Public event | DragEnding | Occurs when the Drag operation is ending.
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DragStarted | Occurs when the drag operation started.
Public event | DragStarting | Occurs when the drag operation is starting.
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


vDataGridViewGroupsHeader Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader Constructor
vDataGridViewGroupsHeader Class See Also Send Feedback
Initializes a new instance of the vDataGridViewGroupsHeader class.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDataGridViewGroupsHeader()
Visual Basic
Public Sub New
Visual C++
public:
vDataGridViewGroupsHeader()

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


vDataGridViewGroupsHeader Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader Methods
vDataGridViewGroupsHeader Class See Also Send Feedback

The vDataGridViewGroupsHeader type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetColumnHeaders | Gets the column headers.
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnded | Raises the [E:DragEnded] event.
Protected method | OnDragEnding | Raises the [E:DragEnding] event.
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDragStarted | Raises the [E:DragStarted] event.
Protected method | OnDragStarting | Raises the [E:DragStarting] event.
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RenderConnectingLines | Renders the connecting lines.
Protected method | RenderContent | Renders the content.
Public method | RenderGroups | Renders the groups.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnwireEvents | Unwires the events.
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | WireEvents | Wires the events.
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..AccessibilityNotifyClients Method
vDataGridViewGroupsHeader Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vDataGridViewGroupsHeader Class
vDataGridViewGroupsHeader Members
VIBlend.WinForms.DataGridView Namespace


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..BeginInvoke Method
vDataGridViewGroupsHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vDataGridViewGroupsHeader Class
vDataGridViewGroupsHeader Members
VIBlend.WinForms.DataGridView Namespace


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..Dispose Method
vDataGridViewGroupsHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Overrides Control..::..Dispose(Boolean).)

See Also

vDataGridViewGroupsHeader Class
vDataGridViewGroupsHeader Members
VIBlend.WinForms.DataGridView Namespace


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..Dispose Method (Boolean)
vDataGridViewGroupsHeader Class See Also Send Feedback
Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

vDataGridViewGroupsHeader Class
Dispose Overload
VIBlend.WinForms.DataGridView Namespace


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..GetChildAtPoint Method
vDataGridViewGroupsHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vDataGridViewGroupsHeader Class
vDataGridViewGroupsHeader Members
VIBlend.WinForms.DataGridView Namespace


GetColumnHeaders Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..GetColumnHeaders Method
vDataGridViewGroupsHeader Class See Also Send Feedback
Gets the column headers.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public List<DataGridGroupHeaderItem> GetColumnHeaders()
Visual Basic
Public Function GetColumnHeaders As List(Of DataGridGroupHeaderItem)
Visual C++
public:
List<DataGridGroupHeaderItem^>^ GetColumnHeaders()

Return Value

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..Invalidate Method
vDataGridViewGroupsHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vDataGridViewGroupsHeader Class
vDataGridViewGroupsHeader Members
VIBlend.WinForms.DataGridView Namespace


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..Invoke Method
vDataGridViewGroupsHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vDataGridViewGroupsHeader Class
vDataGridViewGroupsHeader Members
VIBlend.WinForms.DataGridView Namespace


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..MemberwiseClone Method
vDataGridViewGroupsHeader Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vDataGridViewGroupsHeader Class
vDataGridViewGroupsHeader Members
VIBlend.WinForms.DataGridView Namespace


OnDragEnded Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..OnDragEnded Method
vDataGridViewGroupsHeader Class See Also Send Feedback
Raises the [E:DragEnded] event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnDragEnded(
    GroupHeaderDragEventArgs args
)
Visual Basic
Protected Overridable Sub OnDragEnded ( _
    args As GroupHeaderDragEventArgs _
)
Visual C++
protected:
virtual void OnDragEnded(
    GroupHeaderDragEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..GroupHeaderDragEventArgs
The GroupHeaderDragEventArgs instance containing the event data.

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


OnDragEnding Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..OnDragEnding Method
vDataGridViewGroupsHeader Class See Also Send Feedback
Raises the [E:DragEnding] event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnDragEnding(
    GroupHeaderDragCancelEventArgs args
)
Visual Basic
Protected Overridable Sub OnDragEnding ( _
    args As GroupHeaderDragCancelEventArgs _
)
Visual C++
protected:
virtual void OnDragEnding(
    GroupHeaderDragCancelEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..GroupHeaderDragCancelEventArgs
The GroupHeaderDragCancelEventArgs instance containing the event data.

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


OnDragStarted Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..OnDragStarted Method
vDataGridViewGroupsHeader Class See Also Send Feedback
Raises the [E:DragStarted] event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnDragStarted(
    GroupHeaderDragEventArgs args
)
Visual Basic
Protected Overridable Sub OnDragStarted ( _
    args As GroupHeaderDragEventArgs _
)
Visual C++
protected:
virtual void OnDragStarted(
    GroupHeaderDragEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..GroupHeaderDragEventArgs
The GroupHeaderDragEventArgs instance containing the event data.

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


OnDragStarting Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..OnDragStarting Method
vDataGridViewGroupsHeader Class See Also Send Feedback
Raises the [E:DragStarting] event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnDragStarting(
    GroupHeaderDragCancelEventArgs args
)
Visual Basic
Protected Overridable Sub OnDragStarting ( _
    args As GroupHeaderDragCancelEventArgs _
)
Visual C++
protected:
virtual void OnDragStarting(
    GroupHeaderDragCancelEventArgs^ args
)

Parameters

args
Type: VIBlend.WinForms.DataGridView..::..GroupHeaderDragCancelEventArgs
The GroupHeaderDragCancelEventArgs instance containing the event data.

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


OnMouseDown Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..OnMouseDown Method
vDataGridViewGroupsHeader Class See Also Send Feedback
Raises the MouseDown event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


OnMouseMove Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..OnMouseMove Method
vDataGridViewGroupsHeader Class See Also Send Feedback
Raises the MouseMove event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


OnMouseUp Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..OnMouseUp Method
vDataGridViewGroupsHeader Class See Also Send Feedback
Raises the MouseUp event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


OnPaint Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..OnPaint Method
vDataGridViewGroupsHeader Class See Also Send Feedback
Raises the Paint event.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..PerformLayout Method
vDataGridViewGroupsHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vDataGridViewGroupsHeader Class
vDataGridViewGroupsHeader Members
VIBlend.WinForms.DataGridView Namespace


RenderConnectingLines Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..RenderConnectingLines Method
vDataGridViewGroupsHeader Class See Also Send Feedback
Renders the connecting lines.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void RenderConnectingLines(
    PaintEventArgs e
)
Visual Basic
Protected Overridable Sub RenderConnectingLines ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void RenderConnectingLines(
    PaintEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
The PaintEventArgs instance containing the event data.

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


RenderContent Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..RenderContent Method
vDataGridViewGroupsHeader Class See Also Send Feedback
Renders the content.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void RenderContent(
    PaintEventArgs e
)
Visual Basic
Protected Overridable Sub RenderContent ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void RenderContent(
    PaintEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
The PaintEventArgs instance containing the event data.

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


RenderGroups Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..RenderGroups Method
vDataGridViewGroupsHeader Class See Also Send Feedback
Renders the groups.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void RenderGroups()
Visual Basic
Public Overridable Sub RenderGroups
Visual C++
public:
virtual void RenderGroups()

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..ResumeLayout Method
vDataGridViewGroupsHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vDataGridViewGroupsHeader Class
vDataGridViewGroupsHeader Members
VIBlend.WinForms.DataGridView Namespace


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..RtlTranslateAlignment Method
vDataGridViewGroupsHeader Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vDataGridViewGroupsHeader Class
vDataGridViewGroupsHeader Members
VIBlend.WinForms.DataGridView Namespace


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..Scale Method
vDataGridViewGroupsHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vDataGridViewGroupsHeader Class
vDataGridViewGroupsHeader Members
VIBlend.WinForms.DataGridView Namespace


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..Select Method
vDataGridViewGroupsHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

vDataGridViewGroupsHeader Class
vDataGridViewGroupsHeader Members
VIBlend.WinForms.DataGridView Namespace


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..SetBounds Method
vDataGridViewGroupsHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vDataGridViewGroupsHeader Class
vDataGridViewGroupsHeader Members
VIBlend.WinForms.DataGridView Namespace


UnwireEvents Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..UnwireEvents Method
vDataGridViewGroupsHeader Class See Also Send Feedback
Unwires the events.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void UnwireEvents()
Visual Basic
Public Sub UnwireEvents
Visual C++
public:
void UnwireEvents()

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..UpdateBounds Method
vDataGridViewGroupsHeader Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vDataGridViewGroupsHeader Class
vDataGridViewGroupsHeader Members
VIBlend.WinForms.DataGridView Namespace


WireEvents Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..WireEvents Method
vDataGridViewGroupsHeader Class See Also Send Feedback
Wires the events.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void WireEvents()
Visual Basic
Public Sub WireEvents
Visual C++
public:
void WireEvents()

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


vDataGridViewGroupsHeader Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader Properties
vDataGridViewGroupsHeader Class See Also Send Feedback

The vDataGridViewGroupsHeader type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDragDrop | Gets or sets a value indicating whether to allow the items drag and drop.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | ConnectingLinesColor | Gets or sets the color of the connecting lines.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataGridView | Gets or sets the associated data grid view.
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | HeaderItemIndent | Gets or sets the header item indent.
Public property | HeaderItemsAlignment | Gets or sets the header items vertical layout.
Public property | HeaderItemsPadding | Gets or sets the header items padding.
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InitialItemsOffset | Gets or sets the initial items offset.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsThemeSynchronized | Gets or sets a value indicating whether this instance is theme synchronized.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | PromptText | Gets or sets the prompt text.
Public property | PromptTextColor | Gets or sets the prompt text color.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | ShowConnectingLines | Gets or sets a value indicating whether to show the header items connecting lines.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Theme |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VIBlendTheme |
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


AllowDragDrop Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..AllowDragDrop Property
vDataGridViewGroupsHeader Class See Also Send Feedback
Gets or sets a value indicating whether to allow the items drag and drop.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool AllowDragDrop { get; set; }
Visual Basic
Public Property AllowDragDrop As Boolean
    Get
    Set
Visual C++
public:
property bool AllowDragDrop {
    bool get ();
    void set (bool value);
}

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


ConnectingLinesColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..ConnectingLinesColor Property
vDataGridViewGroupsHeader Class See Also Send Feedback
Gets or sets the color of the connecting lines.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color ConnectingLinesColor { get; set; }
Visual Basic
Public Property ConnectingLinesColor As Color
    Get
    Set
Visual C++
public:
property Color ConnectingLinesColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the connecting lines.

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


DataGridView Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..DataGridView Property
vDataGridViewGroupsHeader Class See Also Send Feedback
Gets or sets the associated data grid view.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDataGridView DataGridView { get; set; }
Visual Basic
Public Property DataGridView As vDataGridView
    Get
    Set
Visual C++
public:
property vDataGridView^ DataGridView {
    vDataGridView^ get ();
    void set (vDataGridView^ value);
}

Field Value

The data grid view.

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


HeaderItemIndent Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..HeaderItemIndent Property
vDataGridViewGroupsHeader Class See Also Send Feedback
Gets or sets the header item indent.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int HeaderItemIndent { get; set; }
Visual Basic
Public Property HeaderItemIndent As Integer
    Get
    Set
Visual C++
public:
property int HeaderItemIndent {
    int get ();
    void set (int value);
}

Field Value

The header item indent.

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


HeaderItemsAlignment Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..HeaderItemsAlignment Property
vDataGridViewGroupsHeader Class See Also Send Feedback
Gets or sets the header items vertical layout.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public HeaderGroupsAlignment HeaderItemsAlignment { get; set; }
Visual Basic
Public Property HeaderItemsAlignment As HeaderGroupsAlignment
    Get
    Set
Visual C++
public:
property HeaderGroupsAlignment HeaderItemsAlignment {
    HeaderGroupsAlignment get ();
    void set (HeaderGroupsAlignment value);
}

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


HeaderItemsPadding Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..HeaderItemsPadding Property
vDataGridViewGroupsHeader Class See Also Send Feedback
Gets or sets the header items padding.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Padding HeaderItemsPadding { get; set; }
Visual Basic
Public Property HeaderItemsPadding As Padding
    Get
    Set
Visual C++
public:
property Padding HeaderItemsPadding {
    Padding get ();
    void set (Padding value);
}

Field Value

The header items padding.

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


InitialItemsOffset Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..InitialItemsOffset Property
vDataGridViewGroupsHeader Class See Also Send Feedback
Gets or sets the initial items offset.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Point InitialItemsOffset { get; set; }
Visual Basic
Public Property InitialItemsOffset As Point
    Get
    Set
Visual C++
public:
property Point InitialItemsOffset {
    Point get ();
    void set (Point value);
}

Field Value

The initial items offset.

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


IsThemeSynchronized Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..IsThemeSynchronized Property
vDataGridViewGroupsHeader Class See Also Send Feedback
Gets or sets a value indicating whether this instance is theme synchronized.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsThemeSynchronized { get; set; }
Visual Basic
Public Property IsThemeSynchronized As Boolean
    Get
    Set
Visual C++
public:
property bool IsThemeSynchronized {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance is theme synchronized; otherwise, false.

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


PromptText Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..PromptText Property
vDataGridViewGroupsHeader Class See Also Send Feedback
Gets or sets the prompt text.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string PromptText { get; set; }
Visual Basic
Public Property PromptText As String
    Get
    Set
Visual C++
public:
property String^ PromptText {
    String^ get ();
    void set (String^ value);
}

Field Value

The prompt text.

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


PromptTextColor Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..PromptTextColor Property
vDataGridViewGroupsHeader Class See Also Send Feedback
Gets or sets the prompt text color.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Color PromptTextColor { get; set; }
Visual Basic
Public Property PromptTextColor As Color
    Get
    Set
Visual C++
public:
property Color PromptTextColor {
    Color get ();
    void set (Color value);
}

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


ShowConnectingLines Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..ShowConnectingLines Property
vDataGridViewGroupsHeader Class See Also Send Feedback
Gets or sets a value indicating whether to show the header items connecting lines.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ShowConnectingLines { get; set; }
Visual Basic
Public Property ShowConnectingLines As Boolean
    Get
    Set
Visual C++
public:
property bool ShowConnectingLines {
    bool get ();
    void set (bool value);
}

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


Theme Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..Theme Property
vDataGridViewGroupsHeader Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridTheme Theme { get; set; }
Visual Basic
Public Property Theme As GridTheme
    Get
    Set
Visual C++
public:
property GridTheme^ Theme {
    GridTheme^ get ();
    void set (GridTheme^ value);
}

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..VIBlendTheme Property
vDataGridViewGroupsHeader Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


vDataGridViewGroupsHeader Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader Events
vDataGridViewGroupsHeader Class See Also Send Feedback

The vDataGridViewGroupsHeader type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnded | Occurs when the Drag operation ended.
Public event | DragEnding | Occurs when the Drag operation is ending.
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DragStarted | Occurs when the drag operation started.
Public event | DragStarting | Occurs when the drag operation is starting.
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


DragEnded Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..DragEnded Event
vDataGridViewGroupsHeader Class See Also Send Feedback
Occurs when the Drag operation ended.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<GroupHeaderDragEventArgs> DragEnded
Visual Basic
Public Event DragEnded As EventHandler(Of GroupHeaderDragEventArgs)
Visual C++
public:
 event EventHandler<GroupHeaderDragEventArgs^>^ DragEnded {
    void add (EventHandler<GroupHeaderDragEventArgs^>^ value);
    void remove (EventHandler<GroupHeaderDragEventArgs^>^ value);
}

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


DragEnding Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..DragEnding Event
vDataGridViewGroupsHeader Class See Also Send Feedback
Occurs when the Drag operation is ending.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<GroupHeaderDragCancelEventArgs> DragEnding
Visual Basic
Public Event DragEnding As EventHandler(Of GroupHeaderDragCancelEventArgs)
Visual C++
public:
 event EventHandler<GroupHeaderDragCancelEventArgs^>^ DragEnding {
    void add (EventHandler<GroupHeaderDragCancelEventArgs^>^ value);
    void remove (EventHandler<GroupHeaderDragCancelEventArgs^>^ value);
}

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


DragStarted Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..DragStarted Event
vDataGridViewGroupsHeader Class See Also Send Feedback
Occurs when the drag operation started.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<GroupHeaderDragEventArgs> DragStarted
Visual Basic
Public Event DragStarted As EventHandler(Of GroupHeaderDragEventArgs)
Visual C++
public:
 event EventHandler<GroupHeaderDragEventArgs^>^ DragStarted {
    void add (EventHandler<GroupHeaderDragEventArgs^>^ value);
    void remove (EventHandler<GroupHeaderDragEventArgs^>^ value);
}

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


DragStarting Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewGroupsHeader..::..DragStarting Event
vDataGridViewGroupsHeader Class See Also Send Feedback
Occurs when the drag operation is starting.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler<GroupHeaderDragCancelEventArgs> DragStarting
Visual Basic
Public Event DragStarting As EventHandler(Of GroupHeaderDragCancelEventArgs)
Visual C++
public:
 event EventHandler<GroupHeaderDragCancelEventArgs^>^ DragStarting {
    void add (EventHandler<GroupHeaderDragCancelEventArgs^>^ value);
    void remove (EventHandler<GroupHeaderDragCancelEventArgs^>^ value);
}

See Also

vDataGridViewGroupsHeader Class
VIBlend.WinForms.DataGridView Namespace


vDataGridViewPivotDesign Class

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign Class
Members See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class vDataGridViewPivotDesign : UserControl
Visual Basic
Public Class vDataGridViewPivotDesign _
    Inherits UserControl
Visual C++
public ref class vDataGridViewPivotDesign : public UserControl

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
VIBlend.WinForms.DataGridView..::..vDataGridViewPivotDesign

See Also

vDataGridViewPivotDesign Members
VIBlend.WinForms.DataGridView Namespace


vDataGridViewPivotDesign Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign Members
vDataGridViewPivotDesign Class Constructors Methods Fields Properties Events See Also Send Feedback

The vDataGridViewPivotDesign type exposes the following members.

Constructors

 | Name | Description
Public method | vDataGridViewPivotDesign | Initializes a new instance of the vDataGridViewPivotDesign class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | ApplyOrientation | Applies the orientation.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Begins the update.
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Ends the update.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetListBoxAtPosition |
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPivotTableUpdated | Called when the pivot table is updated.
Protected method | OnPivotValueFieldTextNeeded | Called when the pivot table is updated.
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Public method | UpdateFields | Updates the fields.
Public method | UpdatePivotTable | Updates the pivot table.
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)

Fields

 | Name | Description
Public field | imageList1 |
Public field | label1 |
Public field | label2 |
Public field | listBoxBoundFields |
Public field | listBoxColumnArea |
Public field | listBoxDataArea |
Public field | listBoxRowArea |
Public field | splitContainer1 |
Public field | vButton1 |
Public field | vButton2 |
Public field | vButton3 |
Public field | vButton4 |
Public field | vCheckBox1 |

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AreasOrientation | Gets or sets the areas orientation.
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataGridView | Gets or sets the associated data grid view.
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Localization | Gets the localization.
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the VIBlend Theme.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PivotTableUpdated | Occurs when the pivot table is updated.
Public event | PivotValueFieldTextNeeded | Occurs when text for the pivot value field is needed.
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


vDataGridViewPivotDesign Constructor

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign Constructor
vDataGridViewPivotDesign Class See Also Send Feedback
Initializes a new instance of the vDataGridViewPivotDesign class.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDataGridViewPivotDesign()
Visual Basic
Public Sub New
Visual C++
public:
vDataGridViewPivotDesign()

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


vDataGridViewPivotDesign Fields

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign Fields
vDataGridViewPivotDesign Class See Also Send Feedback

The vDataGridViewPivotDesign type exposes the following members.

Fields

 | Name | Description
Public field | imageList1 |
Public field | label1 |
Public field | label2 |
Public field | listBoxBoundFields |
Public field | listBoxColumnArea |
Public field | listBoxDataArea |
Public field | listBoxRowArea |
Public field | splitContainer1 |
Public field | vButton1 |
Public field | vButton2 |
Public field | vButton3 |
Public field | vButton4 |
Public field | vCheckBox1 |

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


imageList1 Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..imageList1 Field
vDataGridViewPivotDesign Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public ImageList imageList1
Visual Basic
Public imageList1 As ImageList
Visual C++
public:
ImageList^ imageList1

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


label1 Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..label1 Field
vDataGridViewPivotDesign Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Label label1
Visual Basic
Public label1 As Label
Visual C++
public:
Label^ label1

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


label2 Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..label2 Field
vDataGridViewPivotDesign Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Label label2
Visual Basic
Public label2 As Label
Visual C++
public:
Label^ label2

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


listBoxBoundFields Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..listBoxBoundFields Field
vDataGridViewPivotDesign Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vListBox listBoxBoundFields
Visual Basic
Public listBoxBoundFields As vListBox
Visual C++
public:
vListBox^ listBoxBoundFields

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


listBoxColumnArea Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..listBoxColumnArea Field
vDataGridViewPivotDesign Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vListBox listBoxColumnArea
Visual Basic
Public listBoxColumnArea As vListBox
Visual C++
public:
vListBox^ listBoxColumnArea

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


listBoxDataArea Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..listBoxDataArea Field
vDataGridViewPivotDesign Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vListBox listBoxDataArea
Visual Basic
Public listBoxDataArea As vListBox
Visual C++
public:
vListBox^ listBoxDataArea

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


listBoxRowArea Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..listBoxRowArea Field
vDataGridViewPivotDesign Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vListBox listBoxRowArea
Visual Basic
Public listBoxRowArea As vListBox
Visual C++
public:
vListBox^ listBoxRowArea

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


splitContainer1 Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..splitContainer1 Field
vDataGridViewPivotDesign Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public SplitContainer splitContainer1
Visual Basic
Public splitContainer1 As SplitContainer
Visual C++
public:
SplitContainer^ splitContainer1

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


vButton1 Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..vButton1 Field
vDataGridViewPivotDesign Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vButton vButton1
Visual Basic
Public vButton1 As vButton
Visual C++
public:
vButton^ vButton1

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


vButton2 Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..vButton2 Field
vDataGridViewPivotDesign Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vButton vButton2
Visual Basic
Public vButton2 As vButton
Visual C++
public:
vButton^ vButton2

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


vButton3 Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..vButton3 Field
vDataGridViewPivotDesign Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vButton vButton3
Visual Basic
Public vButton3 As vButton
Visual C++
public:
vButton^ vButton3

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


vButton4 Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..vButton4 Field
vDataGridViewPivotDesign Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vButton vButton4
Visual Basic
Public vButton4 As vButton
Visual C++
public:
vButton^ vButton4

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


vCheckBox1 Field

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..vCheckBox1 Field
vDataGridViewPivotDesign Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vCheckBox vCheckBox1
Visual Basic
Public vCheckBox1 As vCheckBox
Visual C++
public:
vCheckBox^ vCheckBox1

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


vDataGridViewPivotDesign Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign Methods
vDataGridViewPivotDesign Class See Also Send Feedback

The vDataGridViewPivotDesign type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | ApplyOrientation | Applies the orientation.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Begins the update.
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Ends the update.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetListBoxAtPosition |
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPivotTableUpdated | Called when the pivot table is updated.
Protected method | OnPivotValueFieldTextNeeded | Called when the pivot table is updated.
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Public method | UpdateFields | Updates the fields.
Public method | UpdatePivotTable | Updates the pivot table.
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


AccessibilityNotifyClients Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..AccessibilityNotifyClients Method
vDataGridViewPivotDesign Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

vDataGridViewPivotDesign Class
vDataGridViewPivotDesign Members
VIBlend.WinForms.DataGridView Namespace


ApplyOrientation Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..ApplyOrientation Method
vDataGridViewPivotDesign Class See Also Send Feedback
Applies the orientation.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void ApplyOrientation()
Visual Basic
Protected Overridable Sub ApplyOrientation
Visual C++
protected:
virtual void ApplyOrientation()

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


BeginInvoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..BeginInvoke Method
vDataGridViewPivotDesign Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

vDataGridViewPivotDesign Class
vDataGridViewPivotDesign Members
VIBlend.WinForms.DataGridView Namespace


BeginUpdate Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..BeginUpdate Method
vDataGridViewPivotDesign Class See Also Send Feedback
Begins the update.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void BeginUpdate()
Visual Basic
Public Sub BeginUpdate
Visual C++
public:
void BeginUpdate()

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


Dispose Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..Dispose Method
vDataGridViewPivotDesign Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)

See Also

vDataGridViewPivotDesign Class
vDataGridViewPivotDesign Members
VIBlend.WinForms.DataGridView Namespace


Dispose Method (Boolean)

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..Dispose Method (Boolean)
vDataGridViewPivotDesign Class See Also Send Feedback
Clean up any resources being used.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

vDataGridViewPivotDesign Class
Dispose Overload
VIBlend.WinForms.DataGridView Namespace


EndUpdate Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..EndUpdate Method
vDataGridViewPivotDesign Class See Also Send Feedback
Ends the update.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void EndUpdate()
Visual Basic
Public Sub EndUpdate
Visual C++
public:
void EndUpdate()

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


GetChildAtPoint Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..GetChildAtPoint Method
vDataGridViewPivotDesign Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

vDataGridViewPivotDesign Class
vDataGridViewPivotDesign Members
VIBlend.WinForms.DataGridView Namespace


GetListBoxAtPosition Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..GetListBoxAtPosition Method
vDataGridViewPivotDesign Class See Also Send Feedback

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual vListBox GetListBoxAtPosition()
Visual Basic
Protected Overridable Function GetListBoxAtPosition As vListBox
Visual C++
protected:
virtual vListBox^ GetListBoxAtPosition()

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


Invalidate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..Invalidate Method
vDataGridViewPivotDesign Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

vDataGridViewPivotDesign Class
vDataGridViewPivotDesign Members
VIBlend.WinForms.DataGridView Namespace


Invoke Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..Invoke Method
vDataGridViewPivotDesign Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

vDataGridViewPivotDesign Class
vDataGridViewPivotDesign Members
VIBlend.WinForms.DataGridView Namespace


MemberwiseClone Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..MemberwiseClone Method
vDataGridViewPivotDesign Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

vDataGridViewPivotDesign Class
vDataGridViewPivotDesign Members
VIBlend.WinForms.DataGridView Namespace


OnPivotTableUpdated Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..OnPivotTableUpdated Method
vDataGridViewPivotDesign Class See Also Send Feedback
Called when the pivot table is updated.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnPivotTableUpdated()
Visual Basic
Protected Overridable Sub OnPivotTableUpdated
Visual C++
protected:
virtual void OnPivotTableUpdated()

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


OnPivotValueFieldTextNeeded Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..OnPivotValueFieldTextNeeded Method
vDataGridViewPivotDesign Class See Also Send Feedback
Called when the pivot table is updated.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
protected virtual void OnPivotValueFieldTextNeeded(
    BoundValueField field
)
Visual Basic
Protected Overridable Sub OnPivotValueFieldTextNeeded ( _
    field As BoundValueField _
)
Visual C++
protected:
virtual void OnPivotValueFieldTextNeeded(
    BoundValueField^ field
)

Parameters

field
Type: VIBlend.WinForms.DataGridView..::..BoundValueField

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


PerformLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..PerformLayout Method
vDataGridViewPivotDesign Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

vDataGridViewPivotDesign Class
vDataGridViewPivotDesign Members
VIBlend.WinForms.DataGridView Namespace


ResumeLayout Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..ResumeLayout Method
vDataGridViewPivotDesign Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

vDataGridViewPivotDesign Class
vDataGridViewPivotDesign Members
VIBlend.WinForms.DataGridView Namespace


RtlTranslateAlignment Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..RtlTranslateAlignment Method
vDataGridViewPivotDesign Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

vDataGridViewPivotDesign Class
vDataGridViewPivotDesign Members
VIBlend.WinForms.DataGridView Namespace


Scale Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..Scale Method
vDataGridViewPivotDesign Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

vDataGridViewPivotDesign Class
vDataGridViewPivotDesign Members
VIBlend.WinForms.DataGridView Namespace


Select Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..Select Method
vDataGridViewPivotDesign Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

vDataGridViewPivotDesign Class
vDataGridViewPivotDesign Members
VIBlend.WinForms.DataGridView Namespace


SetBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..SetBounds Method
vDataGridViewPivotDesign Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

vDataGridViewPivotDesign Class
vDataGridViewPivotDesign Members
VIBlend.WinForms.DataGridView Namespace


UpdateBounds Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..UpdateBounds Method
vDataGridViewPivotDesign Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

vDataGridViewPivotDesign Class
vDataGridViewPivotDesign Members
VIBlend.WinForms.DataGridView Namespace


UpdateFields Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..UpdateFields Method
vDataGridViewPivotDesign Class See Also Send Feedback
Updates the fields.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void UpdateFields()
Visual Basic
Public Sub UpdateFields
Visual C++
public:
void UpdateFields()

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


UpdatePivotTable Method

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..UpdatePivotTable Method
vDataGridViewPivotDesign Class See Also Send Feedback
Updates the pivot table.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public virtual void UpdatePivotTable()
Visual Basic
Public Overridable Sub UpdatePivotTable
Visual C++
public:
virtual void UpdatePivotTable()

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


Validate Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..Validate Method
vDataGridViewPivotDesign Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

vDataGridViewPivotDesign Class
vDataGridViewPivotDesign Members
VIBlend.WinForms.DataGridView Namespace


ValidateChildren Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..ValidateChildren Method
vDataGridViewPivotDesign Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

vDataGridViewPivotDesign Class
vDataGridViewPivotDesign Members
VIBlend.WinForms.DataGridView Namespace


vDataGridViewPivotDesign Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign Properties
vDataGridViewPivotDesign Class See Also Send Feedback

The vDataGridViewPivotDesign type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AreasOrientation | Gets or sets the areas orientation.
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataGridView | Gets or sets the associated data grid view.
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Localization | Gets the localization.
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | VIBlendTheme | Gets or sets the VIBlend Theme.
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


AreasOrientation Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..AreasOrientation Property
vDataGridViewPivotDesign Class See Also Send Feedback
Gets or sets the areas orientation.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Orientation AreasOrientation { get; set; }
Visual Basic
Public Property AreasOrientation As Orientation
    Get
    Set
Visual C++
public:
property Orientation AreasOrientation {
    Orientation get ();
    void set (Orientation value);
}

Field Value

The areas orientation.

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


DataGridView Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..DataGridView Property
vDataGridViewPivotDesign Class See Also Send Feedback
Gets or sets the associated data grid view.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public vDataGridView DataGridView { get; set; }
Visual Basic
Public Property DataGridView As vDataGridView
    Get
    Set
Visual C++
public:
property vDataGridView^ DataGridView {
    vDataGridView^ get ();
    void set (vDataGridView^ value);
}

Field Value

The data grid view.

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


Localization Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..Localization Property
vDataGridViewPivotDesign Class See Also Send Feedback
Gets the localization.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public PivotDesignPanelLocalizationBase Localization { get; set; }
Visual Basic
Public Property Localization As PivotDesignPanelLocalizationBase
    Get
    Set
Visual C++
public:
property PivotDesignPanelLocalizationBase^ Localization {
    PivotDesignPanelLocalizationBase^ get ();
    void set (PivotDesignPanelLocalizationBase^ value);
}

Field Value

The localization.

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


VIBlendTheme Property

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..VIBlendTheme Property
vDataGridViewPivotDesign Class See Also Send Feedback
Gets or sets the VIBlend Theme.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public VIBLEND_THEME VIBlendTheme { get; set; }
Visual Basic
Public Property VIBlendTheme As VIBLEND_THEME
    Get
    Set
Visual C++
public:
property VIBLEND_THEME VIBlendTheme {
    VIBLEND_THEME get ();
    void set (VIBLEND_THEME value);
}

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


vDataGridViewPivotDesign Events

[image] [image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign Events
vDataGridViewPivotDesign Class See Also Send Feedback

The vDataGridViewPivotDesign type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PivotTableUpdated | Occurs when the pivot table is updated.
Public event | PivotValueFieldTextNeeded | Occurs when text for the pivot value field is needed.
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


PivotTableUpdated Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..PivotTableUpdated Event
vDataGridViewPivotDesign Class See Also Send Feedback
Occurs when the pivot table is updated.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event EventHandler PivotTableUpdated
Visual Basic
Public Event PivotTableUpdated As EventHandler
Visual C++
public:
 event EventHandler^ PivotTableUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


PivotValueFieldTextNeeded Event

[image]

VIBlend Controls for WinForms Help Documentation
vDataGridViewPivotDesign..::..PivotValueFieldTextNeeded Event
vDataGridViewPivotDesign Class See Also Send Feedback
Occurs when text for the pivot value field is needed.

Namespace: VIBlend.WinForms.DataGridView
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public event PivotValueFieldTextNeededEventHandler PivotValueFieldTextNeeded
Visual Basic
Public Event PivotValueFieldTextNeeded As PivotValueFieldTextNeededEventHandler
Visual C++
public:
 event PivotValueFieldTextNeededEventHandler^ PivotValueFieldTextNeeded {
    void add (PivotValueFieldTextNeededEventHandler^ value);
    void remove (PivotValueFieldTextNeededEventHandler^ value);
}

See Also

vDataGridViewPivotDesign Class
VIBlend.WinForms.DataGridView Namespace


VIBlend.WinForms.DataGridView.DataExport Namespace

[image]

VIBlend Controls for WinForms Help Documentation
VIBlend.WinForms.DataGridView.DataExport Namespace
Send Feedback

Classes

 | Class | Description
Public class | GridExport | Represents a Data Export provider for VIBlend GridView

Interfaces

 | Interface | Description
Public interface | IExportWriter | Data export provider for GridView interface definition


GridExport Class

[image]

VIBlend Controls for WinForms Help Documentation
GridExport Class
Members See Also Send Feedback
Represents a Data Export provider for VIBlend GridView

Namespace: VIBlend.WinForms.DataGridView.DataExport
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class GridExport
Visual Basic
Public Class GridExport
Visual C++
public ref class GridExport

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView.DataExport..::..GridExport

See Also

GridExport Members
VIBlend.WinForms.DataGridView.DataExport Namespace


GridExport Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
GridExport Members
GridExport Class Constructors Methods See Also Send Feedback

The GridExport type exposes the following members.

Constructors

 | Name | Description
Public method | GridExport | Initializes a new instance of the GridExport class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Export | Exports the content of the data grid using a custom export provider
Public method | ExportToCSV | Exports the content of the data grid into a CSV file
Public method | ExportToExcelXML | Exports the content of the data grid into a Microsoft Excel compatible XML file
Public method | ExportToHTML | Exports the content of the data grid into a HTML file
Public method | ExportToXML | Exports the content of the data grid into a XML file
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridExport Class
VIBlend.WinForms.DataGridView.DataExport Namespace


GridExport Constructor

[image]

VIBlend Controls for WinForms Help Documentation
GridExport Constructor
GridExport Class See Also Send Feedback
Initializes a new instance of the GridExport class

Namespace: VIBlend.WinForms.DataGridView.DataExport
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public GridExport()
Visual Basic
Public Sub New
Visual C++
public:
GridExport()

See Also

GridExport Class
VIBlend.WinForms.DataGridView.DataExport Namespace


GridExport Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
GridExport Methods
GridExport Class See Also Send Feedback

The GridExport type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Export | Exports the content of the data grid using a custom export provider
Public method | ExportToCSV | Exports the content of the data grid into a CSV file
Public method | ExportToExcelXML | Exports the content of the data grid into a Microsoft Excel compatible XML file
Public method | ExportToHTML | Exports the content of the data grid into a HTML file
Public method | ExportToXML | Exports the content of the data grid into a XML file
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridExport Class
VIBlend.WinForms.DataGridView.DataExport Namespace


Export Method

[image]

VIBlend Controls for WinForms Help Documentation
GridExport..::..Export Method
GridExport Class See Also Send Feedback
Exports the content of the data grid using a custom export provider

Namespace: VIBlend.WinForms.DataGridView.DataExport
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Export(
    vDataGridView grid,
    string fileName,
    IExportWriter writer
)
Visual Basic
Public Function Export ( _
    grid As vDataGridView, _
    fileName As String, _
    writer As IExportWriter _
) As Boolean
Visual C++
public:
bool Export(
    vDataGridView^ grid,
    String^ fileName,
    IExportWriter^ writer
)

Parameters

grid
Type: VIBlend.WinForms.DataGridView..::..vDataGridView
fileName
Type: System..::..String
writer
Type: VIBlend.WinForms.DataGridView.DataExport..::..IExportWriter

See Also

GridExport Class
VIBlend.WinForms.DataGridView.DataExport Namespace


ExportToCSV Method

[image]

VIBlend Controls for WinForms Help Documentation
GridExport..::..ExportToCSV Method
GridExport Class See Also Send Feedback
Exports the content of the data grid into a CSV file

Namespace: VIBlend.WinForms.DataGridView.DataExport
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ExportToCSV(
    vDataGridView grid,
    string fileName
)
Visual Basic
Public Function ExportToCSV ( _
    grid As vDataGridView, _
    fileName As String _
) As Boolean
Visual C++
public:
bool ExportToCSV(
    vDataGridView^ grid,
    String^ fileName
)

Parameters

grid
Type: VIBlend.WinForms.DataGridView..::..vDataGridView
fileName
Type: System..::..String

See Also

GridExport Class
VIBlend.WinForms.DataGridView.DataExport Namespace


ExportToExcelXML Method

[image]

VIBlend Controls for WinForms Help Documentation
GridExport..::..ExportToExcelXML Method
GridExport Class See Also Send Feedback
Exports the content of the data grid into a Microsoft Excel compatible XML file

Namespace: VIBlend.WinForms.DataGridView.DataExport
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ExportToExcelXML(
    vDataGridView grid,
    string fileName
)
Visual Basic
Public Function ExportToExcelXML ( _
    grid As vDataGridView, _
    fileName As String _
) As Boolean
Visual C++
public:
bool ExportToExcelXML(
    vDataGridView^ grid,
    String^ fileName
)

Parameters

grid
Type: VIBlend.WinForms.DataGridView..::..vDataGridView
fileName
Type: System..::..String

See Also

GridExport Class
VIBlend.WinForms.DataGridView.DataExport Namespace


ExportToHTML Method

[image]

VIBlend Controls for WinForms Help Documentation
GridExport..::..ExportToHTML Method
GridExport Class See Also Send Feedback
Exports the content of the data grid into a HTML file

Namespace: VIBlend.WinForms.DataGridView.DataExport
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ExportToHTML(
    vDataGridView grid,
    string fileName
)
Visual Basic
Public Function ExportToHTML ( _
    grid As vDataGridView, _
    fileName As String _
) As Boolean
Visual C++
public:
bool ExportToHTML(
    vDataGridView^ grid,
    String^ fileName
)

Parameters

grid
Type: VIBlend.WinForms.DataGridView..::..vDataGridView
fileName
Type: System..::..String

See Also

GridExport Class
VIBlend.WinForms.DataGridView.DataExport Namespace


ExportToXML Method

[image]

VIBlend Controls for WinForms Help Documentation
GridExport..::..ExportToXML Method
GridExport Class See Also Send Feedback
Exports the content of the data grid into a XML file

Namespace: VIBlend.WinForms.DataGridView.DataExport
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ExportToXML(
    vDataGridView grid,
    string fileName
)
Visual Basic
Public Function ExportToXML ( _
    grid As vDataGridView, _
    fileName As String _
) As Boolean
Visual C++
public:
bool ExportToXML(
    vDataGridView^ grid,
    String^ fileName
)

Parameters

grid
Type: VIBlend.WinForms.DataGridView..::..vDataGridView
fileName
Type: System..::..String

See Also

GridExport Class
VIBlend.WinForms.DataGridView.DataExport Namespace


IExportWriter Interface

[image]

VIBlend Controls for WinForms Help Documentation
IExportWriter Interface
Members See Also Send Feedback
Data export provider for GridView interface definition

Namespace: VIBlend.WinForms.DataGridView.DataExport
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public interface IExportWriter
Visual Basic
Public Interface IExportWriter
Visual C++
public interface class IExportWriter

See Also

IExportWriter Members
VIBlend.WinForms.DataGridView.DataExport Namespace


IExportWriter Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
IExportWriter Members
IExportWriter Interface Methods See Also Send Feedback

The IExportWriter type exposes the following members.

Methods

 | Name | Description
Public method | AddColumn(Object) | Adds a column
Public method | AddColumn(String) | Adds a column
Public method | BeginRow | Starts a grid row
Public method | CloseFile | Closes the output file
Public method | CreateFile | Creates and opens an output file for writing
Public method | EndRow | Ends a grid row

See Also

IExportWriter Interface
VIBlend.WinForms.DataGridView.DataExport Namespace


IExportWriter Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
IExportWriter Methods
IExportWriter Interface See Also Send Feedback

The IExportWriter type exposes the following members.

Methods

 | Name | Description
Public method | AddColumn(Object) | Adds a column
Public method | AddColumn(String) | Adds a column
Public method | BeginRow | Starts a grid row
Public method | CloseFile | Closes the output file
Public method | CreateFile | Creates and opens an output file for writing
Public method | EndRow | Ends a grid row

See Also

IExportWriter Interface
VIBlend.WinForms.DataGridView.DataExport Namespace


AddColumn Method

[image] [image]

VIBlend Controls for WinForms Help Documentation
IExportWriter..::..AddColumn Method
IExportWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | AddColumn(Object) | Adds a column
Public method | AddColumn(String) | Adds a column

See Also

IExportWriter Interface
IExportWriter Members
VIBlend.WinForms.DataGridView.DataExport Namespace


AddColumn Method (Object)

[image]

VIBlend Controls for WinForms Help Documentation
IExportWriter..::..AddColumn Method (Object)
IExportWriter Interface See Also Send Feedback
Adds a column

Namespace: VIBlend.WinForms.DataGridView.DataExport
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
void AddColumn(
    Object value
)
Visual Basic
Sub AddColumn ( _
    value As Object _
)
Visual C++
void AddColumn(
    Object^ value
)

Parameters

value
Type: System..::..Object

See Also

IExportWriter Interface
AddColumn Overload
VIBlend.WinForms.DataGridView.DataExport Namespace


AddColumn Method (String)

[image]

VIBlend Controls for WinForms Help Documentation
IExportWriter..::..AddColumn Method (String)
IExportWriter Interface See Also Send Feedback
Adds a column

Namespace: VIBlend.WinForms.DataGridView.DataExport
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
void AddColumn(
    string text
)
Visual Basic
Sub AddColumn ( _
    text As String _
)
Visual C++
void AddColumn(
    String^ text
)

Parameters

text
Type: System..::..String

See Also

IExportWriter Interface
AddColumn Overload
VIBlend.WinForms.DataGridView.DataExport Namespace


BeginRow Method

[image]

VIBlend Controls for WinForms Help Documentation
IExportWriter..::..BeginRow Method
IExportWriter Interface See Also Send Feedback
Starts a grid row

Namespace: VIBlend.WinForms.DataGridView.DataExport
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
void BeginRow()
Visual Basic
Sub BeginRow
Visual C++
void BeginRow()

See Also

IExportWriter Interface
VIBlend.WinForms.DataGridView.DataExport Namespace


CloseFile Method

[image]

VIBlend Controls for WinForms Help Documentation
IExportWriter..::..CloseFile Method
IExportWriter Interface See Also Send Feedback
Closes the output file

Namespace: VIBlend.WinForms.DataGridView.DataExport
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
void CloseFile()
Visual Basic
Sub CloseFile
Visual C++
void CloseFile()

See Also

IExportWriter Interface
VIBlend.WinForms.DataGridView.DataExport Namespace


CreateFile Method

[image]

VIBlend Controls for WinForms Help Documentation
IExportWriter..::..CreateFile Method
IExportWriter Interface See Also Send Feedback
Creates and opens an output file for writing

Namespace: VIBlend.WinForms.DataGridView.DataExport
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
bool CreateFile(
    string filePath
)
Visual Basic
Function CreateFile ( _
    filePath As String _
) As Boolean
Visual C++
bool CreateFile(
    String^ filePath
)

Parameters

filePath
Type: System..::..String

See Also

IExportWriter Interface
VIBlend.WinForms.DataGridView.DataExport Namespace


EndRow Method

[image]

VIBlend Controls for WinForms Help Documentation
IExportWriter..::..EndRow Method
IExportWriter Interface See Also Send Feedback
Ends a grid row

Namespace: VIBlend.WinForms.DataGridView.DataExport
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
void EndRow()
Visual Basic
Sub EndRow
Visual C++
void EndRow()

See Also

IExportWriter Interface
VIBlend.WinForms.DataGridView.DataExport Namespace


VIBlend.WinForms.DataGridView.Filters Namespace

[image]

VIBlend Controls for WinForms Help Documentation
VIBlend.WinForms.DataGridView.Filters Namespace
Send Feedback

Classes

 | Class | Description
Public class | DateTimeFilter | Represents a DateTime filter
Public class | FilterGroup<(Of <(<'T>)>)> | Represents a group of filters
Public class | NumericFilter | Represents a numeric filter
Public class | SetFilter<(Of <(<'T>)>)> | Represents a Filter that uses a set of filter items with true and false states.
Public class | StringFilter | Represents a filter for string types

Interfaces

 | Interface | Description
Public interface | IFilter<(Of <(<'T>)>)> | Generic filter interface for type T
Public interface | IFilterBase | Represents a base filter interface

Enumerations

 | Enumeration | Description
Public enumeration | DateTimeComparisonOperator | Enumaration of the DateTime filter comparison operators
Public enumeration | FilterOperator | Enumeration of the Filter Operators
Public enumeration | NumericComparisonOperator | Enumaration of the Numeric filter comparison operators
Public enumeration | StringFilterComparisonOperator | Enumeration of the string filter comparison operators


DateTimeComparisonOperator Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeComparisonOperator Enumeration
See Also Send Feedback
Enumaration of the DateTime filter comparison operators

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum DateTimeComparisonOperator
Visual Basic
Public Enumeration DateTimeComparisonOperator
Visual C++
public enum class DateTimeComparisonOperator

Members

Member name | Description
EQUAL |
NOT_EQUAL |
LESS_THAN |
LESS_THAN_OR_EQUAL |
GREATER_THAN |
GREATER_THAN_OR_EQUAL |
NULL |
NOT_NULL |

See Also

VIBlend.WinForms.DataGridView.Filters Namespace


DateTimeFilter Class

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFilter Class
Members See Also Send Feedback
Represents a DateTime filter

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class DateTimeFilter : IFilter<Nullable<DateTime>>,
    IFilterBase
Visual Basic
Public Class DateTimeFilter _
    Implements IFilter(Of Nullable(Of DateTime)),  _
    IFilterBase
Visual C++
public ref class DateTimeFilter : IFilter<Nullable<DateTime>>,
    IFilterBase

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView.Filters..::..DateTimeFilter

See Also

DateTimeFilter Members
VIBlend.WinForms.DataGridView.Filters Namespace


DateTimeFilter Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimeFilter Members
DateTimeFilter Class Constructors Methods Properties See Also Send Feedback

The DateTimeFilter type exposes the following members.

Constructors

 | Name | Description
Public method | DateTimeFilter | Initializes a new instance of the DateTimeFilter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ComparisonOperator | Gets or sets the comparison operator of the filter
Public property | Value | Gets or sets the value of the filter

See Also

DateTimeFilter Class
VIBlend.WinForms.DataGridView.Filters Namespace


DateTimeFilter Constructor

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFilter Constructor
DateTimeFilter Class See Also Send Feedback
Initializes a new instance of the DateTimeFilter class

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTimeFilter()
Visual Basic
Public Sub New
Visual C++
public:
DateTimeFilter()

See Also

DateTimeFilter Class
VIBlend.WinForms.DataGridView.Filters Namespace


DateTimeFilter Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimeFilter Methods
DateTimeFilter Class See Also Send Feedback

The DateTimeFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeFilter Class
VIBlend.WinForms.DataGridView.Filters Namespace


DateTimeFilter Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
DateTimeFilter Properties
DateTimeFilter Class See Also Send Feedback

The DateTimeFilter type exposes the following members.

Properties

 | Name | Description
Public property | ComparisonOperator | Gets or sets the comparison operator of the filter
Public property | Value | Gets or sets the value of the filter

See Also

DateTimeFilter Class
VIBlend.WinForms.DataGridView.Filters Namespace


ComparisonOperator Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFilter..::..ComparisonOperator Property
DateTimeFilter Class See Also Send Feedback
Gets or sets the comparison operator of the filter

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public DateTimeComparisonOperator ComparisonOperator { get; set; }
Visual Basic
Public Property ComparisonOperator As DateTimeComparisonOperator
    Get
    Set
Visual C++
public:
property DateTimeComparisonOperator ComparisonOperator {
    DateTimeComparisonOperator get ();
    void set (DateTimeComparisonOperator value);
}

See Also

DateTimeFilter Class
VIBlend.WinForms.DataGridView.Filters Namespace


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
DateTimeFilter..::..Value Property
DateTimeFilter Class See Also Send Feedback
Gets or sets the value of the filter

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Nullable<DateTime> Value { get; set; }
Visual Basic
Public Property Value As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> Value {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Implements

IFilter<(Of <(<'T>)>)>..::..Value

See Also

DateTimeFilter Class
VIBlend.WinForms.DataGridView.Filters Namespace


FilterGroup(T) Class

[image]

VIBlend Controls for WinForms Help Documentation
FilterGroup<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Represents a group of filters

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class FilterGroup<T> : IFilterBase
Visual Basic
Public Class FilterGroup(Of T) _
    Implements IFilterBase
Visual C++
generic<typename T>
public ref class FilterGroup : IFilterBase

Type Parameters

T

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView.Filters..::..FilterGroup<(Of <(<'T>)>)>

See Also

FilterGroup<(Of <(<'T>)>)> Members
VIBlend.WinForms.DataGridView.Filters Namespace


FilterGroup(T) Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
FilterGroup<(Of <(<'T>)>)> Members
FilterGroup<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The FilterGroup<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | FilterGroup<(Of <(<'T>)>)> | Initializes a new instance of the FilterGroup<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | AddFilter | Adds a filter to the group
Public method | Clear | Removes all filters from the group
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the filter expression represented by the group against a specific value
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFilterAt | Gets a reference to the filter at a specific index
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOperatorAt | Returns the logical operator at a specific index
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveFilter | Removes a filter from the group
Public method | SetFilterAt | Sets the filter at a specific index
Public method | SetOperatorAt | Sets the logical operator at a specific index
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FiltersCount | Gets the number of filters in the group

See Also

FilterGroup<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


FilterGroup(T) Constructor

[image]

VIBlend Controls for WinForms Help Documentation
FilterGroup<(Of <(<'T>)>)> Constructor
FilterGroup<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the FilterGroup<(Of <(<'T>)>)> class

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public FilterGroup()
Visual Basic
Public Sub New
Visual C++
public:
FilterGroup()

See Also

FilterGroup<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


FilterGroup(T) Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
FilterGroup<(Of <(<'T>)>)> Methods
FilterGroup<(Of <(<'T>)>)> Class See Also Send Feedback

The FilterGroup<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AddFilter | Adds a filter to the group
Public method | Clear | Removes all filters from the group
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the filter expression represented by the group against a specific value
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFilterAt | Gets a reference to the filter at a specific index
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOperatorAt | Returns the logical operator at a specific index
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveFilter | Removes a filter from the group
Public method | SetFilterAt | Sets the filter at a specific index
Public method | SetOperatorAt | Sets the logical operator at a specific index
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterGroup<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


AddFilter Method

[image]

VIBlend Controls for WinForms Help Documentation
FilterGroup<(Of <(<'T>)>)>..::..AddFilter Method
FilterGroup<(Of <(<'T>)>)> Class See Also Send Feedback
Adds a filter to the group

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void AddFilter(
    FilterOperator filterOperator,
    IFilterBase filter
)
Visual Basic
Public Sub AddFilter ( _
    filterOperator As FilterOperator, _
    filter As IFilterBase _
)
Visual C++
public:
void AddFilter(
    FilterOperator filterOperator,
    IFilterBase^ filter
)

Parameters

filterOperator
Type: VIBlend.WinForms.DataGridView.Filters..::..FilterOperator
The logical operator which concatinates this filter to the previous filters in the group
filter
Type: VIBlend.WinForms.DataGridView.Filters..::..IFilterBase
The new filter to add

See Also

FilterGroup<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


Clear Method

[image]

VIBlend Controls for WinForms Help Documentation
FilterGroup<(Of <(<'T>)>)>..::..Clear Method
FilterGroup<(Of <(<'T>)>)> Class See Also Send Feedback
Removes all filters from the group

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

FilterGroup<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


Evaluate Method

[image]

VIBlend Controls for WinForms Help Documentation
FilterGroup<(Of <(<'T>)>)>..::..Evaluate Method
FilterGroup<(Of <(<'T>)>)> Class See Also Send Feedback
Evaluates the filter expression represented by the group against a specific value

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool Evaluate(
    Object value
)
Visual Basic
Public Function Evaluate ( _
    value As Object _
) As Boolean
Visual C++
public:
virtual bool Evaluate(
    Object^ value
) sealed

Parameters

value
Type: System..::..Object
The value to evaluate

Return Value

Returns true if the value passes through the filter

Implements

IFilterBase..::..Evaluate(Object)

See Also

FilterGroup<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


GetFilterAt Method

[image]

VIBlend Controls for WinForms Help Documentation
FilterGroup<(Of <(<'T>)>)>..::..GetFilterAt Method
FilterGroup<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a reference to the filter at a specific index

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public IFilterBase GetFilterAt(
    int index
)
Visual Basic
Public Function GetFilterAt ( _
    index As Integer _
) As IFilterBase
Visual C++
public:
IFilterBase^ GetFilterAt(
    int index
)

Parameters

index
Type: System..::..Int32

See Also

FilterGroup<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


GetOperatorAt Method

[image]

VIBlend Controls for WinForms Help Documentation
FilterGroup<(Of <(<'T>)>)>..::..GetOperatorAt Method
FilterGroup<(Of <(<'T>)>)> Class See Also Send Feedback
Returns the logical operator at a specific index

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public FilterOperator GetOperatorAt(
    int index
)
Visual Basic
Public Function GetOperatorAt ( _
    index As Integer _
) As FilterOperator
Visual C++
public:
FilterOperator GetOperatorAt(
    int index
)

Parameters

index
Type: System..::..Int32

See Also

FilterGroup<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


RemoveFilter Method

[image]

VIBlend Controls for WinForms Help Documentation
FilterGroup<(Of <(<'T>)>)>..::..RemoveFilter Method
FilterGroup<(Of <(<'T>)>)> Class See Also Send Feedback
Removes a filter from the group

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void RemoveFilter(
    IFilterBase filter
)
Visual Basic
Public Sub RemoveFilter ( _
    filter As IFilterBase _
)
Visual C++
public:
void RemoveFilter(
    IFilterBase^ filter
)

Parameters

filter
Type: VIBlend.WinForms.DataGridView.Filters..::..IFilterBase
A reference to the filter that will be removed

See Also

FilterGroup<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


SetFilterAt Method

[image]

VIBlend Controls for WinForms Help Documentation
FilterGroup<(Of <(<'T>)>)>..::..SetFilterAt Method
FilterGroup<(Of <(<'T>)>)> Class See Also Send Feedback
Sets the filter at a specific index

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetFilterAt(
    int index,
    IFilterBase filter
)
Visual Basic
Public Sub SetFilterAt ( _
    index As Integer, _
    filter As IFilterBase _
)
Visual C++
public:
void SetFilterAt(
    int index,
    IFilterBase^ filter
)

Parameters

index
Type: System..::..Int32
The index of the filter in the group
filter
Type: VIBlend.WinForms.DataGridView.Filters..::..IFilterBase
A reference to the new filter value

See Also

FilterGroup<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


SetOperatorAt Method

[image]

VIBlend Controls for WinForms Help Documentation
FilterGroup<(Of <(<'T>)>)>..::..SetOperatorAt Method
FilterGroup<(Of <(<'T>)>)> Class See Also Send Feedback
Sets the logical operator at a specific index

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetOperatorAt(
    int index,
    FilterOperator filterOperator
)
Visual Basic
Public Sub SetOperatorAt ( _
    index As Integer, _
    filterOperator As FilterOperator _
)
Visual C++
public:
void SetOperatorAt(
    int index,
    FilterOperator filterOperator
)

Parameters

index
Type: System..::..Int32
filterOperator
Type: VIBlend.WinForms.DataGridView.Filters..::..FilterOperator

See Also

FilterGroup<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


FilterGroup(T) Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
FilterGroup<(Of <(<'T>)>)> Properties
FilterGroup<(Of <(<'T>)>)> Class See Also Send Feedback

The FilterGroup<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | FiltersCount | Gets the number of filters in the group

See Also

FilterGroup<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


FiltersCount Property

[image]

VIBlend Controls for WinForms Help Documentation
FilterGroup<(Of <(<'T>)>)>..::..FiltersCount Property
FilterGroup<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the number of filters in the group

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int FiltersCount { get; }
Visual Basic
Public ReadOnly Property FiltersCount As Integer
    Get
Visual C++
public:
property int FiltersCount {
    int get ();
}

See Also

FilterGroup<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


FilterOperator Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
FilterOperator Enumeration
See Also Send Feedback
Enumeration of the Filter Operators

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum FilterOperator
Visual Basic
Public Enumeration FilterOperator
Visual C++
public enum class FilterOperator

Members

Member name | Description
AND |
OR |

See Also

VIBlend.WinForms.DataGridView.Filters Namespace


IFilter(T) Interface

[image]

VIBlend Controls for WinForms Help Documentation
IFilter<(Of <(<'T>)>)> Interface
Members See Also Send Feedback
Generic filter interface for type T

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public interface IFilter<T> : IFilterBase
Visual Basic
Public Interface IFilter(Of T) _
    Inherits IFilterBase
Visual C++
generic<typename T>
public interface class IFilter : IFilterBase

Type Parameters

T

See Also

IFilter<(Of <(<'T>)>)> Members
VIBlend.WinForms.DataGridView.Filters Namespace


IFilter(T) Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
IFilter<(Of <(<'T>)>)> Members
IFilter<(Of <(<'T>)>)> Interface Methods Properties See Also Send Feedback

The IFilter<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Evaluate | Evalutes a value against the filter (Inherited from IFilterBase.)

Properties

 | Name | Description
Public property | Value | Filter's value

See Also

IFilter<(Of <(<'T>)>)> Interface
VIBlend.WinForms.DataGridView.Filters Namespace


IFilter(T) Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
IFilter<(Of <(<'T>)>)> Methods
IFilter<(Of <(<'T>)>)> Interface See Also Send Feedback

The IFilter<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Evaluate | Evalutes a value against the filter (Inherited from IFilterBase.)

See Also

IFilter<(Of <(<'T>)>)> Interface
VIBlend.WinForms.DataGridView.Filters Namespace


IFilter(T) Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
IFilter<(Of <(<'T>)>)> Properties
IFilter<(Of <(<'T>)>)> Interface See Also Send Feedback

The IFilter<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Value | Filter's value

See Also

IFilter<(Of <(<'T>)>)> Interface
VIBlend.WinForms.DataGridView.Filters Namespace


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
IFilter<(Of <(<'T>)>)>..::..Value Property
IFilter<(Of <(<'T>)>)> Interface See Also Send Feedback
Filter's value

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
T Value { get; set; }
Visual Basic
Property Value As T
    Get
    Set
Visual C++
property T Value {
    T get ();
    void set (T value);
}

See Also

IFilter<(Of <(<'T>)>)> Interface
VIBlend.WinForms.DataGridView.Filters Namespace


IFilterBase Interface

[image]

VIBlend Controls for WinForms Help Documentation
IFilterBase Interface
Members See Also Send Feedback
Represents a base filter interface

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public interface IFilterBase
Visual Basic
Public Interface IFilterBase
Visual C++
public interface class IFilterBase

See Also

IFilterBase Members
VIBlend.WinForms.DataGridView.Filters Namespace


IFilterBase Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
IFilterBase Members
IFilterBase Interface Methods See Also Send Feedback

The IFilterBase type exposes the following members.

Methods

 | Name | Description
Public method | Evaluate | Evalutes a value against the filter

See Also

IFilterBase Interface
VIBlend.WinForms.DataGridView.Filters Namespace


IFilterBase Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
IFilterBase Methods
IFilterBase Interface See Also Send Feedback

The IFilterBase type exposes the following members.

Methods

 | Name | Description
Public method | Evaluate | Evalutes a value against the filter

See Also

IFilterBase Interface
VIBlend.WinForms.DataGridView.Filters Namespace


Evaluate Method

[image]

VIBlend Controls for WinForms Help Documentation
IFilterBase..::..Evaluate Method
IFilterBase Interface See Also Send Feedback
Evalutes a value against the filter

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
bool Evaluate(
    Object value
)
Visual Basic
Function Evaluate ( _
    value As Object _
) As Boolean
Visual C++
bool Evaluate(
    Object^ value
)

Parameters

value
Type: System..::..Object

Return Value

See Also

IFilterBase Interface
VIBlend.WinForms.DataGridView.Filters Namespace


NumericComparisonOperator Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
NumericComparisonOperator Enumeration
See Also Send Feedback
Enumaration of the Numeric filter comparison operators

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum NumericComparisonOperator
Visual Basic
Public Enumeration NumericComparisonOperator
Visual C++
public enum class NumericComparisonOperator

Members

Member name | Description
EQUAL |
NOT_EQUAL |
LESS_THAN |
LESS_THAN_OR_EQUAL |
GREATER_THAN |
GREATER_THAN_OR_EQUAL |
NULL |
NOT_NULL |

See Also

VIBlend.WinForms.DataGridView.Filters Namespace


NumericFilter Class

[image]

VIBlend Controls for WinForms Help Documentation
NumericFilter Class
Members See Also Send Feedback
Represents a numeric filter

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class NumericFilter : IFilter<Nullable<double>>,
    IFilterBase
Visual Basic
Public Class NumericFilter _
    Implements IFilter(Of Nullable(Of Double)),  _
    IFilterBase
Visual C++
public ref class NumericFilter : IFilter<Nullable<double>>,
    IFilterBase

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView.Filters..::..NumericFilter

See Also

NumericFilter Members
VIBlend.WinForms.DataGridView.Filters Namespace


NumericFilter Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericFilter Members
NumericFilter Class Constructors Methods Properties See Also Send Feedback

The NumericFilter type exposes the following members.

Constructors

 | Name | Description
Public method | NumericFilter | Initializes a new instance of the NumericFilter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ComparisonOperator | Gets or sets the comparison operator of the filter
Public property | Value | Gets or sets the value of the filter

See Also

NumericFilter Class
VIBlend.WinForms.DataGridView.Filters Namespace


NumericFilter Constructor

[image]

VIBlend Controls for WinForms Help Documentation
NumericFilter Constructor
NumericFilter Class See Also Send Feedback
Initializes a new instance of the NumericFilter class

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public NumericFilter()
Visual Basic
Public Sub New
Visual C++
public:
NumericFilter()

See Also

NumericFilter Class
VIBlend.WinForms.DataGridView.Filters Namespace


NumericFilter Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericFilter Methods
NumericFilter Class See Also Send Feedback

The NumericFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumericFilter Class
VIBlend.WinForms.DataGridView.Filters Namespace


NumericFilter Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
NumericFilter Properties
NumericFilter Class See Also Send Feedback

The NumericFilter type exposes the following members.

Properties

 | Name | Description
Public property | ComparisonOperator | Gets or sets the comparison operator of the filter
Public property | Value | Gets or sets the value of the filter

See Also

NumericFilter Class
VIBlend.WinForms.DataGridView.Filters Namespace


ComparisonOperator Property

[image]

VIBlend Controls for WinForms Help Documentation
NumericFilter..::..ComparisonOperator Property
NumericFilter Class See Also Send Feedback
Gets or sets the comparison operator of the filter

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public NumericComparisonOperator ComparisonOperator { get; set; }
Visual Basic
Public Property ComparisonOperator As NumericComparisonOperator
    Get
    Set
Visual C++
public:
property NumericComparisonOperator ComparisonOperator {
    NumericComparisonOperator get ();
    void set (NumericComparisonOperator value);
}

See Also

NumericFilter Class
VIBlend.WinForms.DataGridView.Filters Namespace


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
NumericFilter..::..Value Property
NumericFilter Class See Also Send Feedback
Gets or sets the value of the filter

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public Nullable<double> Value { get; set; }
Visual Basic
Public Property Value As Nullable(Of Double)
    Get
    Set
Visual C++
public:
virtual property Nullable<double> Value {
    Nullable<double> get () sealed;
    void set (Nullable<double> value) sealed;
}

Implements

IFilter<(Of <(<'T>)>)>..::..Value

See Also

NumericFilter Class
VIBlend.WinForms.DataGridView.Filters Namespace


SetFilter(T) Class

[image]

VIBlend Controls for WinForms Help Documentation
SetFilter<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Represents a Filter that uses a set of filter items with true and false states.

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class SetFilter<T> : IFilterBase
Visual Basic
Public Class SetFilter(Of T) _
    Implements IFilterBase
Visual C++
generic<typename T>
public ref class SetFilter : IFilterBase

Type Parameters

T

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView.Filters..::..SetFilter<(Of <(<'T>)>)>

See Also

SetFilter<(Of <(<'T>)>)> Members
VIBlend.WinForms.DataGridView.Filters Namespace


SetFilter(T) Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
SetFilter<(Of <(<'T>)>)> Members
SetFilter<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The SetFilter<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | SetFilter<(Of <(<'T>)>)> | Initializes a new instance of the SetFilter<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | AddItem | Adds the item.
Public method | ContainsItem | Determines whether the specified item contains item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemState | Gets the state of the item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveItem | Removes the item.
Public method | SetAllItemsState | Sets the state of all items.
Public method | SetItemState | Sets the state of the item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsStateAllTrue | Gets a value indicating whether this instance is state all true.
Public property | ItemsCount | Gets the items count.

See Also

SetFilter<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


SetFilter(T) Constructor

[image]

VIBlend Controls for WinForms Help Documentation
SetFilter<(Of <(<'T>)>)> Constructor
SetFilter<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the SetFilter<(Of <(<'T>)>)> class

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public SetFilter()
Visual Basic
Public Sub New
Visual C++
public:
SetFilter()

See Also

SetFilter<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


SetFilter(T) Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
SetFilter<(Of <(<'T>)>)> Methods
SetFilter<(Of <(<'T>)>)> Class See Also Send Feedback

The SetFilter<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AddItem | Adds the item.
Public method | ContainsItem | Determines whether the specified item contains item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemState | Gets the state of the item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveItem | Removes the item.
Public method | SetAllItemsState | Sets the state of all items.
Public method | SetItemState | Sets the state of the item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetFilter<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


AddItem Method

[image]

VIBlend Controls for WinForms Help Documentation
SetFilter<(Of <(<'T>)>)>..::..AddItem Method
SetFilter<(Of <(<'T>)>)> Class See Also Send Feedback
Adds the item.

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void AddItem(
    T item
)
Visual Basic
Public Sub AddItem ( _
    item As T _
)
Visual C++
public:
void AddItem(
    T item
)

Parameters

item
Type: T
The item.

See Also

SetFilter<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


ContainsItem Method

[image]

VIBlend Controls for WinForms Help Documentation
SetFilter<(Of <(<'T>)>)>..::..ContainsItem Method
SetFilter<(Of <(<'T>)>)> Class See Also Send Feedback
Determines whether the specified item contains item.

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool ContainsItem(
    T item
)
Visual Basic
Public Function ContainsItem ( _
    item As T _
) As Boolean
Visual C++
public:
bool ContainsItem(
    T item
)

Parameters

item
Type: T
The item.

Return Value

true if the specified item contains item; otherwise, false.

See Also

SetFilter<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


GetItemState Method

[image]

VIBlend Controls for WinForms Help Documentation
SetFilter<(Of <(<'T>)>)>..::..GetItemState Method
SetFilter<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the state of the item.

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool GetItemState(
    T item
)
Visual Basic
Public Function GetItemState ( _
    item As T _
) As Boolean
Visual C++
public:
bool GetItemState(
    T item
)

Parameters

item
Type: T
The item.

Return Value

See Also

SetFilter<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


RemoveItem Method

[image]

VIBlend Controls for WinForms Help Documentation
SetFilter<(Of <(<'T>)>)>..::..RemoveItem Method
SetFilter<(Of <(<'T>)>)> Class See Also Send Feedback
Removes the item.

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void RemoveItem(
    T item
)
Visual Basic
Public Sub RemoveItem ( _
    item As T _
)
Visual C++
public:
void RemoveItem(
    T item
)

Parameters

item
Type: T
The item.

See Also

SetFilter<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


SetAllItemsState Method

[image]

VIBlend Controls for WinForms Help Documentation
SetFilter<(Of <(<'T>)>)>..::..SetAllItemsState Method
SetFilter<(Of <(<'T>)>)> Class See Also Send Feedback
Sets the state of all items.

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetAllItemsState(
    bool state
)
Visual Basic
Public Sub SetAllItemsState ( _
    state As Boolean _
)
Visual C++
public:
void SetAllItemsState(
    bool state
)

Parameters

state
Type: System..::..Boolean
if set to true [state].

See Also

SetFilter<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


SetItemState Method

[image]

VIBlend Controls for WinForms Help Documentation
SetFilter<(Of <(<'T>)>)>..::..SetItemState Method
SetFilter<(Of <(<'T>)>)> Class See Also Send Feedback
Sets the state of the item.

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public void SetItemState(
    T item,
    bool state
)
Visual Basic
Public Sub SetItemState ( _
    item As T, _
    state As Boolean _
)
Visual C++
public:
void SetItemState(
    T item,
    bool state
)

Parameters

item
Type: T
The item.
state
Type: System..::..Boolean
if set to true [state].

See Also

SetFilter<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


SetFilter(T) Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
SetFilter<(Of <(<'T>)>)> Properties
SetFilter<(Of <(<'T>)>)> Class See Also Send Feedback

The SetFilter<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | IsStateAllTrue | Gets a value indicating whether this instance is state all true.
Public property | ItemsCount | Gets the items count.

See Also

SetFilter<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


IsStateAllTrue Property

[image]

VIBlend Controls for WinForms Help Documentation
SetFilter<(Of <(<'T>)>)>..::..IsStateAllTrue Property
SetFilter<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a value indicating whether this instance is state all true.

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public bool IsStateAllTrue { get; }
Visual Basic
Public ReadOnly Property IsStateAllTrue As Boolean
    Get
Visual C++
public:
property bool IsStateAllTrue {
    bool get ();
}

Field Value

true if this instance is state all true; otherwise, false.

See Also

SetFilter<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


ItemsCount Property

[image]

VIBlend Controls for WinForms Help Documentation
SetFilter<(Of <(<'T>)>)>..::..ItemsCount Property
SetFilter<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the items count.

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public int ItemsCount { get; }
Visual Basic
Public ReadOnly Property ItemsCount As Integer
    Get
Visual C++
public:
property int ItemsCount {
    int get ();
}

Field Value

The items count.

See Also

SetFilter<(Of <(<'T>)>)> Class
VIBlend.WinForms.DataGridView.Filters Namespace


StringFilter Class

[image]

VIBlend Controls for WinForms Help Documentation
StringFilter Class
Members See Also Send Feedback
Represents a filter for string types

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public class StringFilter : IFilter<string>,
    IFilterBase
Visual Basic
Public Class StringFilter _
    Implements IFilter(Of String), IFilterBase
Visual C++
public ref class StringFilter : IFilter<String^>,
    IFilterBase

Inheritance Hierarchy

System..::..Object
VIBlend.WinForms.DataGridView.Filters..::..StringFilter

See Also

StringFilter Members
VIBlend.WinForms.DataGridView.Filters Namespace


StringFilter Members

[image] [image]

VIBlend Controls for WinForms Help Documentation
StringFilter Members
StringFilter Class Constructors Methods Properties See Also Send Feedback

The StringFilter type exposes the following members.

Constructors

 | Name | Description
Public method | StringFilter | Initializes a new instance of the StringFilter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ComparisonOperator | Gets or sets the comparision operator of the filter
Public property | Value | Gets or sets the value of the filter

See Also

StringFilter Class
VIBlend.WinForms.DataGridView.Filters Namespace


StringFilter Constructor

[image]

VIBlend Controls for WinForms Help Documentation
StringFilter Constructor
StringFilter Class See Also Send Feedback
Initializes a new instance of the StringFilter class

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public StringFilter()
Visual Basic
Public Sub New
Visual C++
public:
StringFilter()

See Also

StringFilter Class
VIBlend.WinForms.DataGridView.Filters Namespace


StringFilter Methods

[image] [image]

VIBlend Controls for WinForms Help Documentation
StringFilter Methods
StringFilter Class See Also Send Feedback

The StringFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringFilter Class
VIBlend.WinForms.DataGridView.Filters Namespace


StringFilter Properties

[image] [image]

VIBlend Controls for WinForms Help Documentation
StringFilter Properties
StringFilter Class See Also Send Feedback

The StringFilter type exposes the following members.

Properties

 | Name | Description
Public property | ComparisonOperator | Gets or sets the comparision operator of the filter
Public property | Value | Gets or sets the value of the filter

See Also

StringFilter Class
VIBlend.WinForms.DataGridView.Filters Namespace


ComparisonOperator Property

[image]

VIBlend Controls for WinForms Help Documentation
StringFilter..::..ComparisonOperator Property
StringFilter Class See Also Send Feedback
Gets or sets the comparision operator of the filter

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public StringFilterComparisonOperator ComparisonOperator { get; set; }
Visual Basic
Public Property ComparisonOperator As StringFilterComparisonOperator
    Get
    Set
Visual C++
public:
property StringFilterComparisonOperator ComparisonOperator {
    StringFilterComparisonOperator get ();
    void set (StringFilterComparisonOperator value);
}

See Also

StringFilter Class
VIBlend.WinForms.DataGridView.Filters Namespace


Value Property

[image]

VIBlend Controls for WinForms Help Documentation
StringFilter..::..Value Property
StringFilter Class See Also Send Feedback
Gets or sets the value of the filter

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IFilter<(Of <(<'T>)>)>..::..Value

See Also

StringFilter Class
VIBlend.WinForms.DataGridView.Filters Namespace


StringFilterComparisonOperator Enumeration

[image]

VIBlend Controls for WinForms Help Documentation
StringFilterComparisonOperator Enumeration
See Also Send Feedback
Enumeration of the string filter comparison operators

Namespace: VIBlend.WinForms.DataGridView.Filters
Assembly: VIBlend.WinForms.DataGridView (in VIBlend.WinForms.DataGridView.dll) Version: 7.0.0.0 (7.0.0.0)

Syntax

C#
public enum StringFilterComparisonOperator
Visual Basic
Public Enumeration StringFilterComparisonOperator
Visual C++
public enum class StringFilterComparisonOperator

Members

Member name | Description
EMPTY |
NOT_EMPTY |
NULL |
NOT_NULL |
CONTAINS |
CONTAINS_CASE_SENSITIVE |
DOES_NOT_CONTAIN |
DOES_NOT_CONTAIN_CASE_SENSITIVE |
STARTS_WITH |
STARTS_WITH_CASE_SENSITIVE |
ENDS_WITH |
ENDS_WITH_CASE_SENSITIVE |
EQUAL |
EQUAL_CASE_SENSITIVE |
REGEX |

See Also

VIBlend.WinForms.DataGridView.Filters Namespace


OVERVIEW

[image]

VIBlend Controls for WinForms Help Documentation
OVERVIEW
Send Feedback
VIBlend WinForms Controls is a comprehensive library of user interface controls for build professional desktop applications using the Microsoft .NET framework.

Version 8.0 includes the following controls:

  • vDataGridView
  • vComboBox
  • vListBox
  • vMenuExtender
  • vButton
  • vSplitButton
  • vRepeatButton
  • vRadioButton
  • vToggleButton
  • vSplitContainer
  • vCheckBox
  • RibbonForm
  • vVScrollBar
  • vHScrollBar
  • vNumericUpDown
  • vTreeView
  • vTreeViewBox
  • vTrackBar
  • vProgressBar
  • vCircularProgressBar
  • vDateTimePicker
  • vTabControl
  • vTextBox
  • vContextMenu
  • vNavPane
  • vExplorerBarPane
  • vOutlookNavPane
  • vMonthCalendar
  • vDateTimeEditor
  • vMaskedTextBox
  • vRibbonBar
  • vColorPicker
  • vBubbleBar
  • vFieldSet
  • vGroupBox
  • vToolTip
  • vLabel
  • vRatingControl
  • vHorizontalLayoutPanel
  • vPanel
  • vVerticalLayoutPanel
  • vFlowLayoutPanel
  • vImageReflectionControl
  • vControlBox
  • vCheckedListBox
  • vPercentageEditor
  • vCurrencyEditor
  • vFixedPointEditor
  • vDecimalEditor
  • vRadioListBox
  • vNumberEditor


Licensing FAQ

[image]

VIBlend Controls for WinForms Help Documentation
Licensing FAQ
Send Feedback
All VIBlend products are licensed per-developer seat based on an annual subscription model. This means that you get 12 months of priority technical support and free upgrades (both minor and major versions). The 12 months time frame starts from the date of purchase. At the end of the 12 months period you can choose, at your discretion, to pay 50% of the original purchase price to “renew” the subscription and receive another 12 months. If you decide not to renew your subscription, you can continue using the latest version you obtained before the subscription expired. You have the right to use it indefinitely as long as you comply with the EULA.

Do you charge any run time royalties for your products?

We don’t charge any royalties. End user applications developed using VIBlend products can be distributed as needed, and you are not charged additional royalties when distributing our assemblies with your executable. Once other developers start using the product, additional seat licenses must be purchased.

Trial licenses

The Trial licenses are fully-functional and are identical in functionality to the paid versions. However, a message will appear in a popup window to indicate that you are using a trial version.The trial versions include product documentation, APIs reference, and many sample projects. All sample projects come with full C# and VB.NET source code.The trial versions are not for sale, should not be redistributed without permission from VIBlend, and cannot be used for software development purposes except for evaluation. Any use of the trial versions expect for pre-purchase evaluation is in direct violation with the EULA.

How long does the trial version last?

There are no time restrictions. You can use the trial version to fully evaluate and test before you make a purchase decision.

Can I receive technical support during my trial evaluation period?

Yes. All trial licenses come with 2 months FREE Support package, which guarantees a response from the VIBlend support staff. There are no purchase or subscription requirements. If you have questions or need more examples just send us an email to support@viblend.com and we will be happy to assist you.

Developer Licenses

A Developer license is granted per developer seat. Developer licenses have no run-time limitations. Each developer who uses our products must obtain a license. The developer may install and use the product on a primary computer, laptop or another computer as long as no one else will use the software on these machines. If you need more than one license we offer excellent volume discounts. In addition, if you want to obtain licenses for more than 50 developers you can purchase a Site License (per Office location) or an Enterprise License (per Company).The Developer license comes with a Support package which guarantees a 24 hour response time from the VIBlend support staff. It also includes product updates in a period of 1 year after the purchase date. If you have any questions, feel free to send us an email to support@viblend.com

Can I purchase the source code?

You can obtain a license that includes the full source code. Our products (both source code and binary versions) are licensed and not sold. If you are interested in obtaining a license that includes the source code contact us at: sales@viblend.com

I need to modify the source code and redistribute the modified assemblies with my application. Can I do that?

Yes. You can make modifications to our source code and redistribute the modified libraries with your products. However, you cannot use any portion of our software to build and offer competing products or software solutions. This restriction applies both to source code and binary licenses.

How do I receive the invoice for my purchase?

To request an invoice, please send an e-mail to sales@viblend.com We will send you a PDF invoice.

My subscribtion expired. Can I use the product?

Yes, you can continue using the products that were licensed to you during the subscription term even after the subscription expires. However, if you would like to continue receiving product updates and support, you need to renew your subscription.

Do you offer refunds?

We offer refunds only when astolen credit card was used to purchase a VIBlend product license. There are no refunds on source code licenses once the source code has been downloaded. For refunds of licenses without source code, please send us an e-mail at sales@viblend.com with the reason why you are requesting a refund. However, refunds are not guaranteed.

Do you offer competitive upgrades?

Yes, we do offer competitive upgrades. Please contact our

sales team for more information.

Do I need separate licenses for production and build machines?

No. The licensing is not per-machine and therefore you don't need additional licenses for production servers, test and build machines.

Do you offer discounts for academic and non – profit organizations?

Yes, please visit our discounts page for more information.


License Agreement

[image]

VIBlend Controls for WinForms Help Documentation
License Agreement
Send Feedback
VIBLEND WINDOWS FORMS CONTROLS 8.0.0.0 END USER LICENSE AGREEMENT

IMPORTANT NOTE

This "Software", as defined below, is protected by the US and International copyright laws.

If you do not read and agree to be bound by the terms and conditions defined in this document, you are not permitted to use the Software or any portion of it.

END USER LICENSE AGREEMENT (EULA)

DEFINITIONS

The following definitions apply to the terms and conditions included in this EULA.

The term "Software", in the context of this EULA, means VIBlend Windows Forms Controls, its modules, components, controls, all program files, source code, media, and documentation which are part of the Software installation package, as well as any portion of them.

End User

Means you as a particular user of the Software.

TERMS OF AGREEMENT

This is a legal agreement between you, the end user, and VIBlend as provider of the Software. By installing or using this Software, you agree to be bound by the terms of this EULA. If you do not agree to those terms, you may not install or use the Software.

The Software is not sold as a product. It is licensed to the end user. As an end user, you are entitled to install and use your copy of the Software and use it only for software development, design and testing purposes.

"Install" means to permanently copy the software on your computer's permanent storage system. "Use" means to utilize the software for software development, design, testing or evaluation purposes.

If you have purchased a license of the Software, you are allowed to redistribute some of the Software's assemblies (Redistributable modules) with products that you have developed. The software's Redistributable modules include:

VIBlend.WinForms.Controls.dll

VIBlend.WinForms.DataGridView.dll

VIBlend.WinForms.Controls.Design.dll

VIBlend.WinForms.Utilities.dll

You are not allowed to redistribute any other portions of the Software with your products unless you have obtained explicit written permission from VIBlend.

The Software is protected by the United States copyright laws and International treaties. You may not rent or lease the Software. You can transfer the license of the software on a permanent basis. A transfer may happen only with explicit written permission from VIBlend.

TRIAL VERSION RESTRICTIONS

VIBlend provides free trial versions of the Software. The trial versions are fully functional and are not time restricted. You are allowed to download and use the trial versions only for pre-purchase evaluation purposes. The trial versions are not for sale, should not be redistributed without permission from VIBlend, and cannot be used for software development purposes except for evaluation. Any use of the trial versions except for pre-purchase evaluation is in direct violation of this EULA.

INTELECTUAL PROPERTY

All intellectual property rights such as but not limited to patents, trademarks, copyrights or trade secret rights related to the Software are property of VIBlend and/or its partners and suppliers.

You shall not modify, translate, reverse engineer, decompile or disassemble the Software or any portion of it thereof or otherwise attempt to derive source code or create derivative works.

You are not allowed to use any portion of the Software within products that directly compete with VIBlend.

You are not allowed to remove, alter or destroy any proprietary, trademark or copyright markings or notices related to the Software.

YOU EXPRESSLY ACKNOWLEDGE AND AGREE THAT USE OF THE SOFTWARE IS AT YOUR OWN RISK AND THAT THE SOFTWARE IS PROVIDED "AS IS" WITHOUT ANY WARRANTIES OR CONDITIONS WHATSOEVER. VIBLEND AND ITS PARTNERS DOES NOT WARRANT THAT THE FUNCTIONS OF THE SOFTWARE WILL MEET YOUR REQUIREMENTS OR THAT THE OPERATION OF THE SOFTWARE WILL BE UNINTERRUPTED OR ERROR FREE. YOU ASSUME RESPONSIBILITY FOR SELECTING THE SOFTWARE TO ACHIEVE YOUR INTENDED RESULTS, AND FOR THE USE AND THE RESULTS OBTAINED FROM THE SOFTWARE.

YOU ACKNOWLEDGE THAT THE SOFTWARE IS NOT INTENDED FOR USE IN (I) ON-LINE CONTROL OF AIRCRAFT, AIR TRAFFIC, AIRCRAFT NAVIGATION OR AIRCRAFT COMMUNICATIONS; OR (II) IN THE DESIGN, CONSTRUCTION, OPERATION OR MAINTENANCE OF ANY NUCLEAR FACILITY; OR (III) ANY KIND OF UNLAWFUL AND HARMFUL OPERATIONS AND ACTIVITIES.

VIBLEND AND ITS PARTNERS/SUPPLIERS DISCLAIM ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO WARRANTIES RELATED TO: NON-INFRINGEMENT, LACK OF VIRUSES, ACCURACY OR COMPLETENESS OF RESPONSES OR RESULTS, IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.

IN NO EVENT SHALL VIBLEND OR ITS PARTNERS/SUPPLIERS BE LIABLE FOR ANY INDIRECT, INCIDENTAL, SPECIAL OR CONSEQUENTIAL DAMAGES OR FOR ANY DAMAGES WHATSOEVER (INCLUDING BUT NOT LIMITED TO DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, PERSONAL INJURY, LOSS OF PRIVACY OR OTHER PECUNIARY OR OTHER LOSS WHATSOEVER) ARISING OUT OF USE OR INABILITY TO USE THE SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

REGARDLESS OF THE FORM OF ACTION, VIBLEND AND ITS PARTNERS/SUPPLIERS AGGREGATE LIABILITY ARISING OUT OF OR RELATED TO THIS AGREEMENT SHALL NOT EXCEED THE TOTAL AMOUNT PAYABLE BY YOU UNDER THIS AGREEMENT. THE FOREGOING LIMITATIONS, EXCLUSIONS AND DISCLAIMERS SHALL APPLY TO THE MAXIMUM EXTENT ALLOWED BY APPLICABLE LAW.

NOTICE REGARDING OFFICE UI LICENSING

Using VIBlend Windows Forms Controls does not grant you any rights under the Microsoft Office 2007 UI Licensing. The Office 2007 User Interface is intellectual property of Microsoft Corporation and you can license it free of charge. For more information visit: http://msdn.microsoft.com/officeui

The Software may be subject to export or import regulations, and the user agrees to comply strictly with all such laws and regulations. The user agrees not to export, re-export, or use the Software or any part thereof or information pertaining thereto to any country for which a U.S. government agency requires an export license or other governmental approval without first obtaining such license or approval.

Notice to U.S. Government Users: The Software and any associated documentation are "Commercial Items," as that term is defined at 48 C.F.R. 2.101, consisting of "Commercial Computer Software" and "Commercial Computer Software Documentation," as such terms are used in 48 C.F.R. 12.212 or 48 C.F.R. 227.7202, as applicable. Consistent with 48 C.F.R. 12.212 or 48 C.F.R. 227.7202-1 through 227.7202-4, as applicable, the Commercial Computer Software and Commercial Computer Software Documentation are licensed to U.S. Government end users (a) only as Commercial Items and (b) with only those rights as are granted to all other end users pursuant to the terms and conditions herein.

If you have any questions regarding the EULA please contact us by e-mail at:

info@viblend.com

Web site:

www.viblend.com


Installation and Deployment

[image]

VIBlend Controls for WinForms Help Documentation
Installation and Deployment
Send Feedback
How to add VIBlend controls to the Toolbox?

VIBlend Controls for WinForms are automatically added to Visual Studio 2005, Visual Studio 2008 and Visual Studio 2010 Toolbox during the installation process.

However, if they do not appear in the toolbox after the installation, you can do this manually:

  1. Run a new Visual Studio instance.
  2. Create a new Windows Forms application
  3. Right Click on the Toolbox and click the “Add Tab” menu item.
  4. Type VIBlend and press Enter.

    Installationt And Deployment Image 1

  5. Expand the VIBlend tab and right click on the expanded area.
  6. Click on the ‘Choose Items…’menuitem.

    Installationt And Deployment Image 2

  7. Click the ‘Browse’ button and navigate to the VIBlend assemblies. Add the VIBlendControls.dll and VIBlendGrid.dll. The tab is filled with the VIBlend Controls.

    Installationt And Deployment Image 3

  8. References to the VIBlendUtilities.and VIBlend.WinForms.Controls.Design.dll are also needed to run the application and to have a design time support. These references are automatically added when you drag and drop a control into your Form. However, you can also manually add them by right clicking on the ‘Reference’ tree node in the Solution Explorer and then clicking on the ‘Add Reference’ context menu item.

Installationt And Deployment Image 4

Deployment

To use the VIBlend controls in your application, you must add references to the VIBlendControls.dll, VIBlendGrid.dll and VIBlendUtilities.dll. These references are automatically added to your project when you drag and drop a control on your form. These assemblies are required for the application’s run time. To have a design time support, you need to add a reference to the VIBlend.WinForms.Controls.Design.dll. Generally, the assembly references are added automatically and they will refer to the assemblies installed in the GAC by the VIBlend installer. The easiest way to deploy your application to a client machine, could be to use the X Copy deployment. For each assembly reference in the Solution Explorer, right click and set the ‘Copy Local’ flag to true. By doing this, all assemblies will be copied to the Release/Bin, Debug/Bin folders depending on your project’s configuration. To deploy the application you should copy and paste the .exe and .dlls files to your client machines.


SYSTEM REQUIREMENTS

[image]

VIBlend Controls for WinForms Help Documentation
SYSTEM REQUIREMENTS
Send Feedback
VIBlend Controls for Windows Forms 8.0 requires the following minimum configuration:

  • 1 GHz Processor
  • 256 MB RAM
  • 50MB free disk space
  • Windows 2000, XP, Server 2003, Server 2008, Windows Vista or Windows 7
  • 1024x768 video, High Color 16-bit
  • Microsoft compatible mouse or pointing device


SOFTWARE REQUIREMENTS

[image]

VIBlend Controls for WinForms Help Documentation
SOFTWARE REQUIREMENTS
Send Feedback
VIBlend Controls for Windows Forms 8.0 requires the following software:

  • Microsoft .NET Framework 2.0 or later
  • Microsoft Visual Studio 2005, 2008, or 2010
Note Note

Visual Studio Express editions can be used but are not fully supported

This document provides general overview of VIBlend WinForms Controls (version 7.0) and their features. The information and examples are based on best practices and frequently asked question about VIBlend WinFormsControls. If you are not able to find the information you are looking for, please feel free to contact us at support@viblend.com


DataGridView

[image]

VIBlend Controls for WinForms Help Documentation
DataGridView
Send Feedback
  • Namespace: VIBlend.WinForms.DataGridView
  • Assembly: VIBlend.WinForms.DataGridView ( in VIBlend.WinForms.DataGridView.dll)

One of the most flexible controls in the VIBlend WinForms Controls library is the DataGridView. The DataGridView control displays the data from a collection in a tabular format with rows and columns. Some of the advantages of VIBlend DataGridView for WinForms include:

  • Ease of use Getting started with the DataGridView control is easy, and it takes very little code to implement complex scenarios from end to end.
  • Feature richness and flexibility The DataGridView offers a rich set of APIs and is designed to address thousands of common data visualization tasks. It supports data binding, header item templates, styles, cell templates, row details, grouping, pivot tables for OLAP analysis, and more.
  • High performance

The DataGridView control can easily work with thousands, and even millions of rows. The grid cells content can be virtualized and loaded on demand. In addition, the grid utilizes advanced caching methods to achieve optimal performance.


Getting started with the DataGridView control

[image]

VIBlend Controls for WinForms Help Documentation
Getting started with the DataGridView control
Send Feedback
The DataGridView control is represented by the vDataGridView class located in the VIBlend.WinForms.DataGridView namespace. The simplest way to start with the DataGridView is to add it to a Form using the Visual Studio designer. Open the Visual Studio ToolBox, locate the vDataGridView item in the VIBlend controls group and drag it on the form.

The code below adds a vDataGridView to a Form at runtime:

CopyC#
using VIBlend.WinForms.DataGridView;
...
vDataGridViewvDataGridView1 = newvDataGridView();
this.Controls.Add(vDataGridView1);
CopyVB.NET
ImportsVIBlend.WinForms.DataGridView
...
DimvDataGridView1AsvDataGridView = NewvDataGridView()
Me.Controls.Add(vDataGridView1)


DataGridView Basics

[image]

VIBlend Controls for WinForms Help Documentation
DataGridView Basics
Send Feedback
VIBlend DataGridView for WinForms is designed with simplicity and flexibility in mind. It allows you define hierarchical row and column headers and use the same data grid for broad range of scenarios where you would normally need several different controls.

There are several basic concepts that every developer needs to know:

  1. VIBlend DataGridViewcontains three core areas:
    • ColumnsHierarchy – represents the columns header area
    • RowsHierarchy – represents the rows header area
    • CellsArea – represents the grid cells area
  2. Each item (Row or Column) in the header area is represented by the HierarchyItem class. HierarchyItems can have one or more HierarchyItems as child items. The easiest way to understand how this works is to think of the ColumnsHierarchy or the RowsHierarchy as a tree and the HierarchyItems as nodes in the tree.The HierarchyItems are stored under the RowsHierarchy.Items and ColumnsHierarchy.Items collections. The child items of a HierarchyItem are stored in the HierarchyItem.Items collection.
  3. The DataGridView control dynamically calculates the size and rendering properties of the CellsArea depending on the number of rows and columns, their expand/collapse state, scroll position, width and height properties and more.
  4. Grid cells in the CellsArea are implicitly represented as an intersection of a Row HierarchyItem and a Column HierarchyItem. Each grid cell can have its own style, formatting and in-place editor. This unique feature allows you to have different grid cell types within the same row or column.


Adding Rows and Columns in unbound mode

[image]

VIBlend Controls for WinForms Help Documentation
Adding Rows and Columns in unbound mode
Send Feedback
VIBlend DataGridView supports both data binding and unbound mode. We’ll start with a simple unbound example that create the following hierarchical grid view:

Data Grid View Image 1

The following code adds HierarchyItems to the RowsHierarchy and the ColumnsHierarchy:

CopyC#
using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Linq;
using System.Text;
using System.Windows.Forms;
using VIBlend.WinForms.DataGridView;
using VIBlend.Utilities;

namespace WinFormsDemo
{
    public partial class Form1 : Form
    {
        public Form1()
        {
            InitializeComponent();
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            PopulateGridContent();
        }

        private void PopulateGridContent()
        {
            #region Create the rows and columns headers
            HierarchyItem itemAllCountries = vDataGridView1.RowsHierarchy.Items.Add(
            "All Countries");
            HierarchyItem itemUSA = itemAllCountries.Items.Add("USA");
            itemUSA.Items.Add("California");
            itemUSA.Items.Add("Oregon");
            itemUSA.Items.Add("Washington");
            itemUSA.Items.Add("Idaho");

            HierarchyItem itemCanada = itemAllCountries.Items.Add("Canada");
            itemCanada.Items.Add("Ontario");
            itemCanada.Items.Add("Quebec");
            itemCanada.Items.Add("Alberta");

            HierarchyItem itemMexico = itemAllCountries.Items.Add("Mexico");
            itemMexico.Items.Add("Baja California");
            itemMexico.Items.Add("San Luis Potosí");
            itemMexico.Items.Add("Nuevo León");
            itemMexico.Items.Add("Sonora");

            HierarchyItem itemAllCustomers = vDataGridView1.ColumnsHierarchy.Items.Add(
            "All Customers");
            itemAllCustomers.Items.Add("Graduate degree");
            itemAllCustomers.Items.Add("Bachelors degree");
            itemAllCustomers.Items.Add("Associate degree");
            itemAllCustomers.Items.Add("High School diploma");
            HierarchyItem itemTotal = itemAllCustomers.Items.Add("Total");

            #endregion

            vDataGridView1.RowsHierarchy.SetColumnWidth(0, 150);

            vDataGridView1.RowsHierarchy.CompactStyleRenderingEnabled = true;
            vDataGridView1.RowsHierarchy.ExpandAllItems();
            vDataGridView1.ColumnsHierarchy.ExpandAllItems();

            vDataGridView1.ColumnsHierarchy.AutoResize(AutoResizeMode.FIT_ITEM_CONTENT);
        }
    }
}
CopyVB.NET
Imports System
Imports System.Collections.Generic
Imports System.ComponentModel
Imports System.Data
Imports System.Drawing
Imports System.Linq
Imports System.Text
Imports System.Windows.Forms
Imports VIBlend.WinForms.DataGridView
Imports VIBlend.Utilities

Namespace WinFormsDemo
    Partial Public Class Form1
        Inherits Form
        Public Sub New()
            InitializeComponent()
        EndSub

        Private Sub Form1_Load(ByVal sender AsObject,
        ByVal e As EventArgs)
            PopulateGridContent()
        EndSub

        Private Sub PopulateGridContent()
            Dim itemAllCountries As HierarchyItem = vDataGridView1.RowsHierarchy.Items.Add("All Countries")

            Dim itemUSA As HierarchyItem = itemAllCountries.Items.Add("USA")
            itemUSA.Items.Add("California")
            itemUSA.Items.Add("Oregon")
            itemUSA.Items.Add("Washington")
            itemUSA.Items.Add("Idaho")

            Dim itemCanada As HierarchyItem = itemAllCountries.Items.Add("Canada")
            itemCanada.Items.Add("Ontario")
            itemCanada.Items.Add("Quebec")
            itemCanada.Items.Add("Alberta")

            Dim itemMexico As HierarchyItem = itemAllCountries.Items.Add("Mexico")
            itemMexico.Items.Add("Baja California")
            itemMexico.Items.Add("San Luis Potosí")
            itemMexico.Items.Add("Nuevo León")
            itemMexico.Items.Add("Sonora")

            Dim itemAllCustomers As HierarchyItem = vDataGridView1.ColumnsHierarchy.Items.Add("All Customers")
            itemAllCustomers.Items.Add("Graduate degree")
            itemAllCustomers.Items.Add("Bachelors degree")
            itemAllCustomers.Items.Add("Associate degree")
            itemAllCustomers.Items.Add("High School diploma")
            Dim itemTotal As HierarchyItem = itemAllCustomers.Items.Add("Total")

            vDataGridView1.RowsHierarchy.SetColumnWidth(0, 150)
            vDataGridView1.RowsHierarchy.CompactStyleRenderingEnabled = True

            vDataGridView1.RowsHierarchy.ExpandAllItems()
            vDataGridView1.ColumnsHierarchy.ExpandAllItems()

            vDataGridView1.ColumnsHierarchy.AutoResize(
                AutoResizeMode.FIT_ITEM_CONTENT)
        End Sub
    End Class
End Namespace


Modifying Grid Cell values in unbound mode

[image]

VIBlend Controls for WinForms Help Documentation
Modifying Grid Cell values in unbound mode
Send Feedback
In order to modify the grid cell values in unbound mode, you can use the SetCellValue and GetCellValue methods of the DataGrid.CellsArea. Adding some content to the grid cells is very easy, and you can use any object as a grid cell value:

CopyC#
HierarchyItemcolumnGraduateDegree = itemAllCustomers.Items[0];
vDataGridView1.CellsArea.SetCellValue(itemAllCountries, columnGraduateDegree, 22356.89);

CopyVB.NET
DimcolumnGraduateDegreeAs HierarchyItem = itemAllCustomers.Items(0)
vDataGridView1.CellsArea.SetCellValue(itemAllCountries, columnGraduateDegree, 22356.89)


Formatting Grid Cells Content

[image]

VIBlend Controls for WinForms Help Documentation
Formatting Grid Cells Content
Send Feedback
Formatting the value of a grid cell is one of the most common tasks when working with data grids. You may want to format the grid cells as numbers, currencies, dates, hours, and more. VIBlend DataGridView for WinForms allows you to format the content of grid cells using simple expressions which follows the .NET string formatting rules. The value of a grid cell can be any object type and it is up to you to specify how this value will be converted to text. Unless you associate the cell (or its row or column) with a formatting expression, the grid will try to get the text representation of the cell’s value by calling the ToString() method.

The grid cells formatting requires two steps:

  1. Specify the string formatting expression and give it a name by calling the SetFormatter method.
  2. Set the cell formatting for an individual grid cell or for all grid cells in a column or row by calling the SetCellFormatter method.
CopyC#
// Format an individual cell
vDataGridView1.CellsArea.SetCellFormatString(
rowItem, columnItem, "{0:C}");

// Format all cells in a column
vDataGridView1.ColumnsHierarchy.Items[0].CellsFormatString = "{0:C}”;
CopyVB.NET
' Format an individual cell
vDataGridView1.CellsArea.SetCellFormatString(
rowItem, columnItem, "{0:C}")

' Format all cells in a column
vDataGridView1.ColumnsHierarchy.Items[0].CellsFormatString = "{0:C}”


Grid Cells Text Alignment and Wrapping

[image]

VIBlend Controls for WinForms Help Documentation
Grid Cells Text Alignment and Wrapping
Send Feedback
VIBlend DataGridView allows you to specifiy cell text alignment and text wrap mode settings for individual cells, as well as for all cells in a column or row.

CopyC#
// Set MiddleRight text alignment for all cells in the graduate degree columnGraduateDegree.CellTextAlignment = ContentAlignment.MiddleRight;

// Set TextWrap mode for all cells in the graduate degree column
columnGraduateDegree.CellsTextWrap =true;
CopyVB.NET
' Set MiddleRight text alignment for all cells in the graduate degree 'column
columnGraduateDegree.CellTextAlignment = ContentAlignment.MiddleRight

' Set TextWrap mode for all cells in the graduate degree column
columnGraduateDegree.CellsTextWrap = true


Grid Cell Styles

[image]

VIBlend Controls for WinForms Help Documentation
Grid Cell Styles
Send Feedback
In VIBlend DataGridView you can change the color of the cell text, background and border using Styles. Instead of changing many colors and properties for multiple cells, once you define a style you can assign it to any grid cell or to all cells in a row or column.

CopyC#
FillStyle fillStyleNormal = newFillStyleGradient(
Color.Yellow,
Color.OrangeRed,
System.Drawing.Drawing2D.LinearGradientMode.Vertical);

FillStyle fillStyleSelected = newFillStyleGradient(
Color.Orange,
Color.OrangeRed,
System.Drawing.Drawing2D.LinearGradientMode.Vertical);

GridCellStyle style = newGridCellStyle(
// cell background
fillStyleNormal,
// cell background when selected
fillStyleSelected,
// border color
Color.FromArgb(255, 200, 0, 0),
// border color when select
Color.FromArgb(255, 255, 0, 0),
// cell text color
Color.Black,
// cell text color when selected
Color.Red);

vDataGridView1.CellsArea.SetCellDrawStyle(columnGraduateDegree,style);
CopyVB.NET
Dim fillStyleNormal As FillStyle = NewFillStyleGradient(
Color.Yellow,
Color.OrangeRed, System.Drawing.Drawing2D.LinearGradientMode.Vertical)

Dim fillStyleSelected As FillStyle = NewFillStyleGradient(
Color.Orange,
Color.OrangeRed, System.Drawing.Drawing2D.LinearGradientMode.Vertical)

Dim style AsNewGridCellStyle(
fillStyleNormal,
fillStyleSelected,
Color.FromArgb(255, 200, 0, 0),
Color.FromArgb(255, 255, 0, 0),
Color.Black,
Color.Red)

columnGraduateDegree.CellsStyle = style


Data Binding

[image]

VIBlend Controls for WinForms Help Documentation
Data Binding
Send Feedback
VIBlend DataGridView for Windows Forms can bind to multiple data source types like DataTables,arrays, generic lists, and others. To data bind the grid to a data source you need to set the DataSource property.

The DataGridView supports several data binding modes:

  1. Simple data binding with automatic columns generation.

    Prepare the data source and set the DataGridView.DataSource property:

    CopyC#
    public partial class Form1 : Form
{
   public Form1()
   {
     InitializeComponent();
   }

   private void Form1_Load(object sender, EventArgs e)
   {
     PopulateGridContent();
   }

   public class Person
   {
      public Person(string FirstName, string LastName)
      {
         this.FirstName = FirstName;
        this.LastName = LastName;
      }

      public string FirstName { get; set; }
      public string LastName { get; set; }
   }

   private void PopulateGridContent()
   {
       List<Person> list = newList<Person>();
       for (int i = 0; i < 10; i++)
       list.Add(newPerson(
       "First Name " + i,
       "Last Name " + i));

       this.vDataGridView1.DataSource = list;
   }
}
    CopyVB.NET
    Partial Public Class Form1
Inherits Form
Public Sub New()
    InitializeComponent()
EndSub

Private Sub Form1_Load(
ByVal sender As Object,
ByVal e As EventArgs)
    PopulateGridContent()
EndSub

Public Class Person
Public Sub New(
ByVal FirstName As String,
ByVal LastName As String)
Me.FirstName = FirstName
Me.LastName = LastName
End Sub

Private privateFirstName As String
Public Property FirstName() AsString
        Get
            Return privateFirstName
        EndGet
        Set(ByVal value As String)
            privateFirstName = value
        EndSet
    EndProperty

    Private privateLastName As String
    PublicPropertyLastName() As String
        Get
            Return privateLastName
        EndGet
        Set(ByVal value As String)
            privateLastName = value
        EndSet
    EndProperty
EndClass

    Private Sub PopulateGridContent()
    Dim list As New List(Of Person)()
    For i As Integer = 0 To 9
        list.Add(New Person(
        "First Name "& i,
        "Last Name "& i))
    Next i

        Me.vDataGridView1.DataSource = list
    EndSub
EndClass
  2. Data Binding with columns selection

    In the previous example the data grid will bind to all columns or public properties of the objects in the collection. In many case, it is useful to bind only some of them. You can choose which columns or properties to bind and add them to the BoundFields collection of the grid. The BoundField constructor takes two parameters. The first parameter is the text that will appear in the column, and the second parameter is the name of the data column or public property in the data source.

    CopyC#
    private void PopulateGridContent()
{
  List<Person> list = newList<Person>();
  for (int i = 0; i < 10; i++)
     list.Add(newPerson(
    "First Name " + i,
    "Last Name " + i));

  vDataGridView1.BoundFields.Add(newBoundField("First Name","FirstName"));
  vDataGridView1.DataSource = list;
}
    CopyVB.NET
    Private Sub PopulateGridContent()
Dim list As New List(Of Person)()
    For i As Integer = 0 To 9
        list.Add(New Person(
        "First Name "& i,
        "Last Name "& i))
    Next i

    vDataGridView1.BoundFields.Add(New BoundField(
"First Name", "FirstName"))

    vDataGridView1.DataSource = list
EndS ub
  3. Binding and grouping rows by one or more columns

    VIBlend DataGridView for Windows Forms allows you to group the rows by the value of one or more columns.

    Data Binging Image 1

    This can be done by adding BoundFields to the GroupingColumns collection and setting the GroupingEnabled property to true.

    CopyC#
    vDataGridView1.BoundFields.Add(newBoundField("Employee Name", "Name"));
vDataGridView1.BoundFields.Add(newBoundField(
    "Product Name", "ProductName"));
vDataGridView1.BoundFields.Add(newBoundField("Quantity", "Quantity"));
vDataGridView1.BoundFields.Add(newBoundField("Unit Price","UnitPrice"));
vDataGridView1.BoundFields.Add(newBoundField("Total", "SalesAmount"));

vDataGridView1.GroupingColumns.Add(newBoundField(
    "Employee Name", "Name"));
vDataGridView1.GroupingColumns.Add(newBoundField(
    "Product Name", "ProductName"));

vDataGridView1.GroupingEnabled = true;
vDataGridView1.DataSource = list;
    CopyVB.NET
    vDataGridView1.BoundFields.Add(New BoundField("Employee Name", "Name"))
vDataGridView1.BoundFields.Add(New BoundField("Product Name",     "ProductName"))
vDataGridView1.BoundFields.Add(New BoundField("Quantity", "Quantity"))
vDataGridView1.BoundFields.Add(New BoundField("Unit Price", "UnitPrice"))
vDataGridView1.BoundFields.Add(New BoundField("Total", "SalesAmount"))

vDataGridView1.GroupingColumns.Add(New BoundField("Employee Name", "Name"))
vDataGridView1.GroupingColumns.Add(New BoundField("Product Name",     "ProductName"))

vDataGridView1.GroupingEnabled = True
vDataGridView1.DataSource = list
  4. Data Binding and Pivot tables generation for OLAP analysis.

The DataGridView control features a built-in data aggregation engine which is capable of turning any tabular data source into a wide variety of cross tab views. This is similar to the Pivot tables functionality in Excel. In a typical data grid, the data is flat and consists of many rows and columns. The data may contain multiple cells with same values and working with the raw data may not be the best way to spot patterns and analysize trends. The rows grouping feature allows you to group multiple rows by columns where the corresponding grid cells have the same value. Pivot tables go one step further and enable powerful data analysis. A Pivot table usually consits of row, column and data (value/fact) fields. Creating a Pivot table with VIBlend DataGridView for Windows Forms is very easy. In fact, the data binding to the data source requires no changes. You need to choose the columns from the data source and add them to the BoundFields collection:

CopyC#
pivotGrid1.BoundFields.Add(newBoundField("Country", "Country"));
pivotGrid1.BoundFields.Add(newBoundField("Region", "Region"));
pivotGrid1.BoundFields.Add(newBoundField("City", "City"));
pivotGrid1.BoundFields.Add(newBoundField(
"Shipper Company ", "ShipperCompany"));
pivotGrid1.BoundFields.Add(newBoundField(
"ExtendedPrice", "ExtendedPrice"));
CopyVB.NET
pivotGrid1.BoundFields.Add(New BoundField("Country", "Country"))
pivotGrid1.BoundFields.Add(New BoundField("Region", "Region"))
pivotGrid1.BoundFields.Add(New BoundField("City", "City"))
pivotGrid1.BoundFields.Add(New BoundField("Shipper Company ", "ShipperCompany"))
pivotGrid1.BoundFields.Add(New BoundField("ExtendedPrice", "ExtendedPrice"))
 Using this code, if you data bind to the data source, the grid will display many rows and five columns: Country, Region, City, Carrier, Extended Price.

However, let’s look at a scenario where we want to show count of sales, amount of sales, and average sale amount grouped by Country, by Region and by City, and do that for each Shipper Company.

This requires only a few extra lines of code:

  1. Assign the Country, Region and City fields to form the Rows hierarchy:
    CopyC#
    pivotGrid1.BoundPivotRows.Add(newBoundField("Country", "Country"));

pivotGrid1.BoundPivotRows.Add(newBoundField("Region", "Region"));

pivotGrid1.BoundPivotRows.Add(newBoundField("City", "City"));
    CopyVB.NET
    pivotGrid1.BoundPivotRows.Add(New BoundField("Country", "Country"))

pivotGrid1.BoundPivotRows.Add(New BoundField("Region", "Region"))

pivotGrid1.BoundPivotRows.Add(New BoundField("City", "City"))
  2. Assign the ShipperCompany field to form the Columns hierarchy:
    CopyC#
    pivotGrid1.BoundPivotColumns.Add(newBoundField("Shipper Company", "ShipperCompany"));
    CopyVB.NET
    pivotGrid1.BoundPivotColumns.Add(New BoundField("Shipper Company", "ShipperCompany"))
  3. Assign the ExtendedPrice field to form the facts/values for count of sales, sales amount, and average sale amount:
    CopyC#
    pivotGrid1.BoundPivotValues.Add(newBoundValueField("Count of Sales", "ExtendedPrice", PivotFieldFunction.Count));

pivotGrid1.BoundPivotValues.Add(newBoundValueField("Amount of Sales", "ExtendedPrice", PivotFieldFunction.Sum));

pivotGrid1.BoundPivotValues.Add(newBoundValueField("Avg Sale Amount", "ExtendedPrice", PivotFieldFunction.Average));
    CopyVB.NET
    pivotGrid1.BoundPivotValues.Add(New BoundValueField("Count of Sales", "ExtendedPrice", PivotFieldFunction.Count))

pivotGrid1.BoundPivotValues.Add(New BoundValueField("Amount of Sales", "ExtendedPrice", PivotFieldFunction.Sum))

pivotGrid1.BoundPivotValues.Add(New BoundValueField("Avg Sale Amount", "ExtendedPrice", PivotFieldFunction.Average))
  4. Specify if the value/fact columns appear attached to the rows or to the columns:

CopyC#
pivotGrid1.PivotValuesOnRows = false;
CopyVB.NET
pivotGrid1.PivotValuesOnRows = False
 During the data binding process the DataGridView control will identify the cell with identical values, organize and group them on rows and on columns, and compute the respective cell values. The result will be the following pivot table view:

Data Binging Image 2

The following source code contains all required steps to build this example.

CopyC#
PrepareGridData();

pivotGrid1.BoundFields.Add(newBoundField("Country", "Country"));
pivotGrid1.BoundFields.Add(newBoundField("Region", "Region"));
pivotGrid1.BoundFields.Add(newBoundField("City", "City"));
pivotGrid1.BoundFields.Add(
newBoundField("ShipperCompany", "ShipperCompany"));
pivotGrid1.BoundFields.Add(
newBoundField("ExtendedPrice", "ExtendedPrice"));
pivotGrid1.BoundPivotRows.Add(
newBoundField("Country", "Country"));
pivotGrid1.BoundPivotRows.Add(
newBoundField("Region", "Region"));
pivotGrid1.BoundPivotRows.Add(newBoundField("City", "City"));
pivotGrid1.BoundPivotColumns.Add(
newBoundField("Shipper Company", "ShipperCompany"));
pivotGrid1.BoundPivotValues.Add(newBoundValueField("Count of Sales", "ExtendedPrice", PivotFieldFunction.Count));
pivotGrid1.BoundPivotValues.Add(newBoundValueField("Amount of Sales", "ExtendedPrice", PivotFieldFunction.Sum));
pivotGrid1.BoundPivotValues.Add(newBoundValueField("Avg Sale Amount", "ExtendedPrice", PivotFieldFunction.Average));

pivotGrid1.PivotValuesOnRows = false;
pivotGrid1.RowsHierarchy.CompactStyleRenderingEnabled = true;
pivotGrid1.DataSource = salesTable;
pivotGrid1.ColumnsHierarchy.AutoResize(
AutoResizeMode.FIT_ITEM_CONTENT);
pivotGrid1.RowsHierarchy.SetColumnWidth(0, 150);
CopyVB.NET
PrepareGridData()

pivotGrid1.BoundFields.Add(New BoundField("Country","Country"))
pivotGrid1.BoundFields.Add(New BoundField("Region","Region"))
pivotGrid1.BoundFields.Add(New BoundField("City", "City"))
pivotGrid1.BoundFields.Add(New BoundField("Shipper Company", "ShipperCompany"))
pivotGrid1.BoundFields.Add(New BoundField("ExtendedPrice",     "ExtendedPrice"))

pivotGrid1.BoundPivotRows.Add(New BoundField("Country", "Country"))
pivotGrid1.BoundPivotRows.Add(New BoundField("Region", "Region"))
pivotGrid1.BoundPivotRows.Add(New BoundField("City", "City"))
pivotGrid1.BoundPivotColumns.Add(New BoundField(
"ShipperCompany",
"ShipperCompany"))
pivotGrid1.BoundPivotValues.Add(New BoundValueField(
"Count of Sales",
"ExtendedPrice",
PivotFieldFunction.Count))
pivotGrid1.BoundPivotValues.Add(New BoundValueField(
"Amount of Sales",
"ExtendedPrice",
PivotFieldFunction.Sum))

pivotGrid1.BoundPivotValues.Add(New BoundValueField(
    "Avg Sale Amount",
    "ExtendedPrice",
    PivotFieldFunction.Average))

pivotGrid1.PivotValuesOnRows = False

pivotGrid1.RowsHierarchy.CompactStyleRenderingEnabled =True

pivotGrid1.DataSource = salesTable

pivotGrid1.ColumnsHierarchy.AutoResize(
AutoResizeMode.FIT_ITEM_CONTENT)

pivotGrid1.RowsHierarchy.SetColumnWidth(0, 150)


Usingin-place Cell Editors

[image]

VIBlend Controls for WinForms Help Documentation
Usingin-place Cell Editors
Send Feedback
The DataGridView control can host various types of editors. You can specify grid cell editors for individual cells or all cells in a row or a column.

Usingin-place Cell Editors 1

The following example demonstrates the use of in-place cell editors:

Create in-place editors instances:

CopyC#
ComboBoxEditor comboBoxEditorProducts = newComboBoxEditor();
TextBoxEditor textBoxEditorNames = newTextBoxEditor();
TextBoxEditor textBoxEditorUnitPrice = newTextBoxEditor();
DateTimePickerEditor timeEditor = newDateTimePickerEditor();
NumericUpDownEditor updownEditor = newNumericUpDownEditor();
CopyVB.NET
Dim comboBoxEditorProducts As New ComboBoxEditor()
Dim textBoxEditorNames As New TextBoxEditor()
Dim textBoxEditorUnitPrice As New TextBoxEditor()
Dim timeEditor As New DateTimePickerEditor()

Dim updownEditor As New NumericUpDownEditor()

  1. Set the activation and dectivation flags:
    CopyC#
    comboBoxEditorProducts.ActivationFlags = EditorActivationFlags.MOUSE_DBLCLICK;
comboBoxEditorProducts.DeActivationFlags = EditorActivationFlags.MOUSE_CLICK;

updownEditor.ActivationFlags = EditorActivationFlags.MOUSE_DBLCLICK;
updownEditor.DeActivationFlags = EditorActivationFlags.MOUSE_CLICK;

timeEditor.ActivationFlags = EditorActivationFlags.MOUSE_DBLCLICK;
timeEditor.DeActivationFlags = EditorActivationFlags.MOUSE_CLICK;

textBoxEditorNames.ActivationFlags = EditorActivationFlags.MOUSE_DBLCLICK;
textBoxEditorNames.DeActivationFlags =     EditorActivationFlags.MOUSE_CLICK;

textBoxEditorUnitPrice.ActivationFlags = EditorActivationFlags.MOUSE_DBLCLICK;
textBoxEditorUnitPrice.DeActivationFlags = EditorActivationFlags.MOUSE_CLICK;
    CopyVB.NET
    comboBoxEditorProducts.ActivationFlags = EditorActivationFlags.MOUSE_DBLCLICK
comboBoxEditorProducts.DeActivationFlags = EditorActivationFlags.MOUSE_CLICK

updownEditor.ActivationFlags = EditorActivationFlags.MOUSE_DBLCLICK
updownEditor.DeActivationFlags = EditorActivationFlags.MOUSE_CLICK

timeEditor.ActivationFlags = EditorActivationFlags.MOUSE_DBLCLICK
timeEditor.DeActivationFlags = EditorActivationFlags.MOUSE_CLICK

textBoxEditorNames.ActivationFlags = EditorActivationFlags.MOUSE_DBLCLICK
textBoxEditorNames.DeActivationFlags = EditorActivationFlags.MOUSE_CLICK

textBoxEditorUnitPrice.ActivationFlags = EditorActivationFlags.MOUSE_DBLCLICK
textBoxEditorUnitPrice.DeActivationFlags = EditorActivationFlags.MOUSE_CLICK
  2. Set the in-place editors theme:
    CopyC#
    textBoxEditorNames.VIBlendTheme = dataGridView1.VIBlendTheme;
timeEditor.VIBlendTheme = dataGridView1.VIBlendTheme;
comboBoxEditorProducts.VIBlendTheme = dataGridView1.VIBlendTheme;
updownEditor.VIBlendTheme = dataGridView1.VIBlendTheme;
textBoxEditorUnitPrice.VIBlendTheme = dataGridView1.VIBlendTheme;
    CopyVB.NET
    textBoxEditorNames.VIBlendTheme = dataGridView1.VIBlendTheme timeEditor.VIBlendTheme = dataGridView1.VIBlendTheme comboBoxEditorProducts.VIBlendTheme = dataGridView1.VIBlendTheme updownEditor.VIBlendTheme = dataGridView1.VIBlendTheme textBoxEditorUnitPrice.VIBlendTheme = dataGridView1.VIBlendTheme
  3. Associate the editors with grid columns:
CopyC#
dataGridView1.ColumnsHierarchy.Items[0].CellsEditor =textBoxEditorNames;
dataGridView1.ColumnsHierarchy.Items[1].CellsEditor =
timeEditor;

dataGridView1.ColumnsHierarchy.Items[2].CellsEditor =
comboBoxEditorProducts;

dataGridView1.ColumnsHierarchy.Items[3].CellsEditor =
updownEditor;

dataGridView1.ColumnsHierarchy.Items[4].CellsEditor =
textBoxEditorUnitPrice;
CopyVB.NET
dataGridView1.ColumnsHierarchy.Items(0).CellsEditor = textBoxEditorNames dataGridView1.ColumnsHierarchy.Items(1).CellsEditor = timeEditor dataGridView1.ColumnsHierarchy.Items(2).CellsEditor = comboBoxEditorProducts dataGridView1.ColumnsHierarchy.Items(3).CellsEditor = updownEditor dataGridView1.ColumnsHierarchy.Items(4).CellsEditor = textBoxEditorUnitPrice

You can validate the entered data by handling to the CellValidating event:

CopyC#
void DataGridView1_CellValidating(object sender, GridCellCancelEventArgs args)
{
     if (args.Cell.Editor == textBoxEditorNames)
     {
       if (args.Cell.EditValue.ToString().Length == 0 || args.Cell.EditValue.ToString().Length > 100)
       {
         MessageBox.Show("Please enter a valid name.",
         "Validation error",
           MessageBoxButtons.OK,
         MessageBoxIcon.Error);

         args.Cancel = true;
       }
    }
}
CopyVB.NET
Private Sub DataGridView1_CellValidating(ByVal sender As Object, ByVal args As GridCellCancelEventArgs)
     If args.Cell.Editor = textBoxEditorNames Then
       If args.Cell.EditValue.ToString().Length = 0 OrElse args.Cell.EditValue.ToString().Length > 100 Then
         MessageBox.Show("Please enter a valid name.", "Validation error", MessageBoxButtons.OK, MessageBoxIcon.Error)

         args.Cancel = True
       End If
     End If
End Sub
 You can specify the events that trigger the activation (open) and deactivation (close) of the cell editors using the ActivationFlags and DeActivationFlags properties. You can choose one of the following options:

  • MOUSE_MOVE - Activates the editor when the user moves the mouse over the grid cell.
  • MOUSE_CLICK - Activates the editor when the user clicks inside the grid cell.
  • MOUSE_CLICK_SELECTED_CELL - Activates the editor when the user clicks inside a grid cell which is selected.
  • MOUSE_DBLCLICK - Activates the editor when the user double clicks inside the grid cell.
  • KEY_PRESS - Activates the editor when the user presses a key while the grid cell is selected.
  • KEY_PRESS_ENTER - Activates the editor when the user presses the Enter key while the grid cell is selected.
You can also open and close any grid cell editor using API calls. The ShowEditor method activates a cell editor and CloseEditor method deactivates a cell editor which is active. The CloseEditor method allows you specify whether to cancel the changes and keep the original value of the grid cell or to commit the changes and update it.

If you want to find the grid cell which is being edited, you can use the CellsArea.EditCell property. The value of the property is null (Nothing in VB.NET) when there is no active editor. In all other cases it returns a reference a GridCell object. The properties of the GridCell class allow you to easily find the respective RowItem, ColumnItem and cell Value. You can use the Editor property of the GridCell to retrieve the grid cell editor which is being used to edit the cell.

The flexible infrastructure of the VIBlend DataGridView for Windows Forms allows you to implement and use custom grid cell editors. If you have a custom control or other Windows Forms controls which you want to use as an embedded cell editor you need to write a class which wraps the functionality of this control and implements the IEditor interface.


Sorting

[image]

VIBlend Controls for WinForms Help Documentation
Sorting
Send Feedback
VIBlend DataGridView for Windows Forms allows you to sort the data by any grid column. Sorting can be enabled on any column by setting the HierarchyItem.SortMode property:
CopyC#
HierarchyItem column1 = dataGrid.ColumnsHierarchy.Items[0];
column1.SortMode = GridItemSortMode.Automatic;
CopyVB.NET
Dim column1 As HierarchyItem = dataGrid.ColumnsHierarchy.Items(0)
column1.SortMode = GridItemSortMode.Automatic

The SortMode property can be set to Automatic, Default, or NotSortable. In Automatic mode, the user can sort the data by simply clicking on the column. A second click would trigger sorting in the opposite order, and a third click would remove the sorting and restore the data in the original order. In Default mode, you can call the DataViewGrid.SortBy method and specify the HierarchyItem ( row or column) to sort by, and the sort order (Ascending or Descending):

CopyC#
HierarchyItem column1 = dataGrid.ColumnsHierarchy.Items[0];
dataGrid.SortBy(column1, true);
CopyVB.NET
Dim column1 As HierarchyItem = dataGrid.ColumnsHierarchy.Items(0)
dataGrid.SortBy(column1, True)
 You can call the DataGridView.RemoveSort() method to restore the original sorting order.

When the DataGridView control sorts the data, it will properly reorder the rows even if they are organized in row groups or form a pivot table hierarchy.

Finally, the DataGridView allows you to plug-in custom sorting by providing your own GridCell comparison function. The only requirement is to implement the IComparer<GridCell> interface and set the DataGridView.GridCellSortComparer property.

Sorting Image 1


Localization

[image]

VIBlend Controls for WinForms Help Documentation
Localization
Send Feedback
VIBlend DataGridView has a built-in Localization Provider that allows you to easily change ContextMenu and Filter Window strings. In order to localize the DataGridView string, you need to do the following:

  1. Create a new class that inherits the DataGridLocalization class or the DataGridLocalizationBase class.
  2. Override the GetString method and set the appropriate string values.
    CopyC#
    public class GermanLocalizationProvider : DataGridLocalization
{
  public override string GetString(LocalizationNames name)
  {
     switch (name)
     {
         case LocalizationNames.ContextMenuSortSmallestToLargest:
         return "Sortieren in aufsteigende Reihenfolge";
         case LocalizationNames.ContextMenuSortLargestToSmallest:
         return "Sortieren in absteigende Reihenfolge";
         case LocalizationNames.ContextMenuRemoveSort:
         return"Sortieren loschen";
         case LocalizationNames.ContextMenuFilter:
         return"Filter";
         case LocalizationNames.ContextMenuClearFilter:
         return"Filter loschen";
         case LocalizationNames.FilterWindowOrRadioButton:
         return"Oder";
         case LocalizationNames.FilterWindowOkButton:
         return"Anwenden";
         case LocalizationNames.FilterWindowFilterBy:
         return"Filtern nach: ";
         case LocalizationNames.FilterWindowCancelButton:
         return"Stornieren";
         case LocalizationNames.FilterWindowAndRadioButton:
         return"Und";
         case LocalizationNames.FilterOperatorStartsWith:
         return"Beginnt mit";
         case LocalizationNames.FilterOperatorSelect:
         return"Wählen...";
         case LocalizationNames.FilterOperatorRegularExpression:
         return"Regulärer Ausdruck";
         case LocalizationNames.FilterOperatorNotEqual:
         return"Nicht Gleich";
         case LocalizationNames.FilterOperatorLessThanOrEqual:
         return"Weniger als oder gleich";
         case LocalizationNames.FilterOperatorLessThan:
         return"Weniger als";
         case LocalizationNames.FilterOperatorIsNull:
         return"Ist Null";
         case LocalizationNames.FilterOperatorIsNotNull:
         return"Ist Nicht Null";
         case LocalizationNames.FilterOperatorIsNotEmpty:
         return"Nicht leer ist";
         case LocalizationNames.FilterOperatorIsEmpty:
         return"Leer ist";
         case LocalizationNames.FilterOperatorGreaterThanOrEqual:
         return"Größer als oder gleich";
         case LocalizationNames.FilterOperatorGreaterThan:
         return"Größer als";
         case LocalizationNames.FilterOperatorEqual:
         return"Gleich";
         case LocalizationNames.FilterOperatorEndsWith:
         return"Endet mit";
         case LocalizationNames.FilterOperatorDoesNotContain:
         return"Nicht enthalten";
         case LocalizationNames.FilterOperatorContains:
         return"Enthält";
         case LocalizationNames.FilterShowRowsWhereText:
         return"Alle Zeilen, in denen:";
         case LocalizationNames.FilterValueText:
         return"Wert:";
         case LocalizationNames.FilterCriteriaDefinition:
         return"Filter Definition";
    }

    return null;
  }
}
    CopyVB.NET
    Public Class GermanLocalizationProvider
    Inherits DataGridLocalization
  Public Overrides Function GetString(ByVal name As LocalizationNames) As String
     Select Case name
         Case LocalizationNames.ContextMenuSortSmallestToLargest
         Return "Sortieren in aufsteigende Reihenfolge"
         Case LocalizationNames.ContextMenuSortLargestToSmallest
         Return "Sortieren in absteigende Reihenfolge"
         Case LocalizationNames.ContextMenuRemoveSort
         Return"Sortieren loschen"
         Case LocalizationNames.ContextMenuFilter
         Return"Filter"
         Case LocalizationNames.ContextMenuClearFilter
         Return"Filter loschen"
         Case LocalizationNames.FilterWindowOrRadioButton
         Return"Oder"
         Case LocalizationNames.FilterWindowOkButton
         Return"Anwenden"
         Case LocalizationNames.FilterWindowFilterBy
         Return"Filtern nach: "
         Case LocalizationNames.FilterWindowCancelButton
         Return"Stornieren"
         Case LocalizationNames.FilterWindowAndRadioButton
         Return"Und"
         Case LocalizationNames.FilterOperatorStartsWith
         Return"Beginnt mit"
         Case LocalizationNames.FilterOperatorSelect
         Return"Wählen..."
         Case LocalizationNames.FilterOperatorRegularExpression
         Return"Regulärer Ausdruck"
         Case LocalizationNames.FilterOperatorNotEqual
         Return"Nicht Gleich"
         Case LocalizationNames.FilterOperatorLessThanOrEqual
         Return"Weniger als oder gleich"
         Case LocalizationNames.FilterOperatorLessThan
         Return"Weniger als"
         Case LocalizationNames.FilterOperatorIsNull
         Return"Ist Null"
         Case LocalizationNames.FilterOperatorIsNotNull
         Return"Ist Nicht Null"
         Case LocalizationNames.FilterOperatorIsNotEmpty
         Return"Nicht leer ist"
         Case LocalizationNames.FilterOperatorIsEmpty
         Return"Leer ist"
         Case LocalizationNames.FilterOperatorGreaterThanOrEqual
         Return"Größer als oder gleich"
         Case LocalizationNames.FilterOperatorGreaterThan
         Return"Größer als"
         Case LocalizationNames.FilterOperatorEqual
         Return"Gleich"
         Case LocalizationNames.FilterOperatorEndsWith
         Return"Endet mit"
         Case LocalizationNames.FilterOperatorDoesNotContain
         Return"Nicht enthalten"
         Case LocalizationNames.FilterOperatorContains
         Return"Enthält"
         Case LocalizationNames.FilterShowRowsWhereText
         Return"Alle Zeilen, in denen:"
         Case LocalizationNames.FilterValueText
         Return"Wert:"
         Case LocalizationNames.FilterCriteriaDefinition
         Return"Filter Definition"
     End Select

    Return Nothing
  End Function
End Class
  3. Set the Localization property of the DataGridView.
CopyC#
this.Grid1.Localization = newGermanLocalizationProvider();
CopyVB.NET
Me.Grid1.Localization = NewGermanLocalizationProvider()


Filtering

[image]

VIBlend Controls for WinForms Help Documentation
Filtering
Send Feedback
VIBlend DataGridView provides built-in data filtering capabilities. You can enable filtering on any column HierarchyItem by setting the AllowFiltering property to true.
CopyC#
HierarchyItem column1 = dataGrid.ColumnsHierarchy.Items[0];
column1.AllowFiltering = true;
CopyVB.NET
Dim column1 As HierarchyItem = dataGrid.ColumnsHierarchy.Items(0)
column1.AllowFiltering = True

You can filter the grid data by clicking the right mouse button over an item and choose the “Filter” menu item from the popup menu. If you want to clear an existing filter just click the “Clear Filter” menu item.

Filtering Image 1

You can define the filter in the Filter Criteria Definition window:

Filtering Image 2

You can also define a filter programmatically. The following code snippet demonstrates how to create and set a filter:

CopyC#
StringFilter stringFilter1 = newStringFilter();
stringFilter1.ComparisonOperator =     StringFilterComparisonOperator.NOT_EMPTY;
stringFilter1.Value = "";

StringFilter stringFilter2 = newStringFilter();
stringFilter1.ComparisonOperator =     StringFilterComparisonOperator.CONTAINS;
stringFilter1.Value = "a";

FilterGroup<string> filterGroup = newFilterGroup<string>();
filterGroup.AddFilter(FilterOperator.AND, stringFilter1);
filterGroup.AddFilter(FilterOperator.AND, stringFilter2);

HierarchyItemFilter filter = newHierarchyItemFilter();
filter.Item = Grid1.ColumnsHierarchy.Items[3];
filter.Filter = filterGroup;
dataGridView1.RowsHierarchy.Filters.Add(filter);
CopyVB.NET
Dim stringFilter1 As StringFilter = New StringFilter()
stringFilter1.ComparisonOperator =     StringFilterComparisonOperator.NOT_EMPTY
stringFilter1.Value = ""

Dim stringFilter2 As StringFilter = New StringFilter()
stringFilter1.ComparisonOperator =     StringFilterComparisonOperator.CONTAINS
stringFilter1.Value = "a"

Dim filterGroup AsFilterGroup(OfString) = New FilterGroup(OfString)()
filterGroup.AddFilter(FilterOperator.AND, stringFilter1)
filterGroup.AddFilter(FilterOperator.AND, stringFilter2)

Dim filter As HierarchyItemFilter = New HierarchyItemFilter()
filter.Item = Grid1.ColumnsHierarchy.Items(3)
filter.Filter = filterGroup

dataGridView1.RowsHierarchy.Filters.Add(filter)


Conditional Formatting

[image]

VIBlend Controls for WinForms Help Documentation
Conditional Formatting
Send Feedback
VIBlend DataGridView for WinForms provides built-in color scales that you can apply on a group of grid cells.

Conditional Formatting 1

To apply a conditional formatting follow these steps:

  1. Create a conditional formatting groups
    CopyC#
    DataGridView.CellsArea.ConditionalFormattingGroup cfGroup1 = newDataGridViewCellsArea.ConditionalFormattingGroup();

cfGroup1.SetConditionalFormattingColorScale(
GridCellCFColorScale.BLUE_TO_RED);

DataGridView.CellsArea.ConditionalFormattingGroup cfGroup2 = newDataGridView.CellsArea.ConditionalFormattingGroup();

cfGroup2.SetConditionalFormattingColorScale(
GridCellCFColorScale.GREEN_TO_RED);
    CopyVB.NET
    Dim cfGroup1 As DataGridView.CellsArea.ConditionalFormattingGroup = newDataGridViewCellsArea.ConditionalFormattingGroup()

cfGroup1.SetConditionalFormattingColorScale(GridCellCFColorScale.BLUE_TO_RED)

Dim cfGroup2 As DataGridView.CellsArea.ConditionalFormattingGroup = newDataGridView.CellsArea.ConditionalFormattingGroup()

cfGroup2.SetConditionalFormattingColorScale(GridCellCFColorScale.GREEN_TO_RED)
  2. Associate the formatting groups with the data grid:
    CopyC#
    dataGridView1.CellsArea.ConditionalFormattingGroups.Add(
"group1",
cfGroup1);

dataGridView1.CellsArea.ConditionalFormattingGroups.Add(
"group2",
cfGroup2);
    CopyVB.NET
    dataGridView1.CellsArea.ConditionalFormattingGroups.Add(
"group1",
cfGroup1)

dataGridView1.CellsArea.ConditionalFormattingGroups.Add(
"group2",
cfGroup2)
  3. Apply the formatting:
CopyC#
dataGridView1.CellsArea.SetCellConditionalFormattingGroup(
dataGridView1.ColumnsHierarchy.Items[1], "group1");

dataGridView1.CellsArea.SetCellConditionalFormattingGroup(
dataGridView1.ColumnsHierarchy.Items[2], "group2");
CopyVB.NET
dataGridView1.CellsArea.SetCellConditionalFormattingGroup(
dataGridView1.ColumnsHierarchy.Items(1), "group1")

dataGridView1.CellsArea.SetCellConditionalFormattingGroup(
dataGridView1.ColumnsHierarchy.Items(2), "group2")


Validation

[image]

VIBlend Controls for WinForms Help Documentation
Validation
Send Feedback
When you display data entry functionality to users, you frequently have to validate the data entered into your form. The vDataGridView class provides a convenient way to perform validation before data is committed to the data store. You can validate data by handling the CellValidating event, which is raised by the vDataGridView when the current cell changes.

To validate data entered in vDataGridView

  1. Create an ErrorProvider component which will display error messages when entered value did not pass the validation process.
    CopyC#
    ErrorProvider provider = newErrorProvider();
    CopyVB.NET
    Dim provider As New ErrorProvider()
  2. Subscribe to the CellValidating event and implement handler for it. The CellValidating event handler is where you determine whether the value of a cell is valid. If the cell value fails validation, set the Cancel property of the CellCancelEventArgs class to true. This causes the vDataGridView control to prevent the cursor from leaving the cell. Set the error provider text property to an explanatory string which will help users to enter a valid value next time.
The following code example illustrates how to validate data in vDataGridView and display error messages when the cell’s value is not valid.

CopyC#
void Grid1_CellValidating(object sender, CellCancelEventArgs args)
{
    if ( this.Grid1.CellsArea.EditCell.EditValue == null)
    return;

    decimal editValue = decimal.Parse(this.Grid1.CellsArea.EditCell.EditValue.ToString(), CultureInfo.InvariantCulture);

    if (args.Cell.ColumnItem.Caption.Equals("Quantity"))
    {
       if (editValue < 1 || editValue > 10)
       {
          args.Cancel = true;
          this.provider.SetError(this.updownEditor, "The entered quantity value should be between 1 and 10");
       }
    }
    else if (args.Cell.ColumnItem.Caption.Equals("Unit Price"))
    {
       if (editValue < 1 || editValue > 100)
       {
          args.Cancel = true;
          this.provider.SetError(this.textBoxEditorUnitPrice, "The entered currency value should be between 1 and 100");
       }
    }
 }
CopyVB.NET
Private Sub Grid1_CellValidating(ByVal sender As Object, ByVal args As CellCancelEventArgs)
    If Me.Grid1.CellsArea.EditCell.EditValue Is Nothing Then
    Return
    End If

    Dim editValue As Decimal = Decimal.Parse(Me.Grid1.CellsArea.EditCell.EditValue.ToString(), CultureInfo.InvariantCulture)

    If args.Cell.ColumnItem.Caption.Equals("Quantity And quot;) Then
       If editValue And lt; 1 OrElse editValue And gt; 10 Then
          args.Cancel = True
          Me.provider.SetError(Me.updownEditor, "The entered quantity value should be between 1 and 10 And quot;)
       End If
    ElseIf args.Cell.ColumnItem.Caption.Equals("Unit Price And quot;) Then
       If editValue And lt; 1 OrElse editValue And gt; 100 Then
          args.Cancel = True
          Me.provider.SetError(Me.textBoxEditorUnitPrice, "The entered currency value should be between 1 and 100 And quot;)
       End If
    End If
End Sub
 Validation Image 1


Alternating Rows

[image]

VIBlend Controls for WinForms Help Documentation
Alternating Rows
Send Feedback
Tabular data is often presented to users in a ledger-like format where alternating rows have different background colors. This format makes it easier for users to tell which cells are in each row, especially with wide tables that have many columns.

With the vDataGridView control, you can specify complete style information for alternating rows. This enables you to use style characteristics like foreground color and font, in addition to the background color, to differentiate alternating rows.

In order to set the alternating rows styles, you need to do the following:

  1. Create a new GridCellStyle object which represents the cell style that will be applied to the alternating rows.
    CopyC#
    // Apply a new cell style to the grid rows which are even.
GridCellStyle cellStyle = GridTheme.GetDefaultTheme(VIBLEND_THEME.VISTABLUE).GridCellStyle;
cellStyle.FillStyle = newFillStyleSolid(Color.Aqua);
    CopyVB.NET
    Dim cellStyle As GridCellStyle = GridTheme.GetDefaultTheme(VIBLEND_THEME.VISTABLUE).GridCellStyle
cellStyle.FillStyle = NewFillStyleSolid(Color.Aqua)
  2. Apply the alternating rows style.
CopyC#
for (int i = 0; i < this.Grid1.RowsHierarchy.Items.Count; i++)
{
   if (i % 2 == 0)
   {
      this.Grid1.RowsHierarchy.Items[i].CellsStyle = cellStyle;
   }
}
CopyVB.NET
For i As Integer = 0 To Me.Grid1.RowsHierarchy.Items.Count - 1
   If i Mod 2 = 0 Then
      Me.Grid1.RowsHierarchy.Items(i).CellsStyle = cellStyle
   End If
Next i
 The image below illustrates a vDataGridView control with applied alternating rows style.

Alternating Rows Image 1


Grid Headers Styles

[image]

VIBlend Controls for WinForms Help Documentation
Grid Headers Styles
Send Feedback
If you need to create a custom style for vDataGridView headers which is different than the default one, you can do the following:
  1. Create a GridTheme instance
    CopyC#
    GridTheme theme = GridTheme.GetDefaultTheme(VIBLEND_THEME.OFFICE2010BLACK);
    CopyVB.NET
    Dim theme As GridTheme = GridTheme.GetDefaultTheme(VIBLEND_THEME.OFFICE2010BLACK)
  2. Create a new Color instance which represents the Border color and create colors arrays which will be used when the FillStyle instances are created. The scolors array defines the colors used when the HierarchyItem object is selected. The hcolors colors array is used when the HierarchyItem object is highlighted. The colors array defines the HierarchyItem’s colors when it is in the default state.
    CopyC#
    Color borderColor = Color.FromArgb(255, 58, 58, 58);

Color[] colors = newColor[]{Color.FromArgb(255,128,128,128),
Color.FromArgb(255,128,128,128), Color.FromArgb(255,128,128,128),
Color.FromArgb(255,128,128,128)};

Color[] scolors = newColor[]{Color.FromArgb(255,248,163,13),
Color.FromArgb(255,248,163,13), Color.FromArgb(255,248,163,13),
Color.FromArgb(255,248,163,13) };

Color[] hcolors = newColor[]{Color.FromArgb(255,167,205,240),
Color.FromArgb(255,167,205,240), Color.FromArgb(255,167,205,240),
Color.FromArgb(255,167,205,240) };
    CopyVB.NET
    Dim borderColor As Color = Color.FromArgb(255, 58, 58, 58)

Dimcolors() As Color = {Color.FromArgb(255,128,128,128), Color.FromArgb(255,128,128,128), Color.FromArgb(255,128,128,128), Color.FromArgb(255,128,128,128)}

Dim scolors() As Color = {Color.FromArgb(255,248,163,13), Color.FromArgb(255,248,163,13), Color.FromArgb(255,248,163,13), Color.FromArgb(255,248,163,13) }

Dimhcolors() As Color = {Color.FromArgb(255,167,205,240), Color.FromArgb(255,167,205,240), Color.FromArgb(255,167,205,240), Color.FromArgb(255,167,205,240) }
  3. After the color arrays are created, now we need to create FillStyle objects. The FillStyle object is an object used from the theming mechanism. This object defines the gradient styles used in the painting process. The defaultHierarchicalItemFillStyle specifies the fill style when the item is in the default state. The highlightedHierarchicalItemFillStyle uses the hcolors array and it defines the gradient properties of the item when it is highlighted. It sets the gradient angle to 90 degrees and the gradient color offsets to 0.5f and 0.65f. The last FillStyle object, creates a gradient for the item’s selected state.
    CopyC#
    FillStyle defaultHierarchicalItemFillStyle = newFillStyleGradientEx(colors[0], colors[1], colors[2], colors[3], 90, 0.5f, 0.65f);
FillStyle highlightedHierarchicalItemFillStyle = newFillStyleGradientEx(hcolors[0], hcolors[1],
                hcolors[2], hcolors[3], 90, 0.6f, 0.75f);

FillStyle defaultSelectedHierarchicalItemFillStyle = newFillStyleGradientEx(scolors[0], scolors[1],
             scolors[2], scolors[3], 90, 0.6f, 0.75f);
    CopyVB.NET
    Dim defaultHierarchicalItemFillStyle As FillStyle = NewFillStyleGradientEx(colors(0), colors(1), colors(2), colors(3), 90, 0.5f, 0.65f)
Dim highlightedHierarchicalItemFillStyle As FillStyle = NewFillStyleGradientEx(hcolors(0), hcolors(1), hcolors(2), hcolors(3), 90, 0.6f, 0.75f)

Dim defaultSelectedHierarchicalItemFillStyle As FillStyle = NewFillStyleGradientEx(scolors(0), scolors(1), scolors(2), scolors(3), 90, 0.6f, 0.75f)
  4. Create two HierarchyItemStyle instances. The first one is used when the state is in normal and highlighted state, i.e. when the item state is changed from normal to highlighted and from highlighted to normal. For example, when the mouse cursor is moved over the HierarchyItem object, the HierarchyItem’s state is changed to Highlighted. If you click on the HierarchyItem, its state will be changed to Selected. The selected state is handled by the second HierarchyItemStyle object.
    CopyC#
    HierarchyItemStyle itemStyle = newHierarchyItemStyle(defaultHierarchicalItemFillStyle,
highlightedHierarchicalItemFillStyle, borderColor, borderColor, Color.White,
Color.Black);

HierarchyItemStyle selectedItemStyle = newHierarchyItemStyle(defaultSelectedHierarchicalItemFillStyle,
highlightedHierarchicalItemFillStyle, borderColor, borderColor, Color.Black, Color.Black);
    CopyVB.NET
    Dim itemStyle AsNewHierarchyItemStyle(defaultHierarchicalItemFillStyle, highlightedHierarchicalItemFillStyle, borderColor, borderColor, Color.White, Color.Black)

Dim selectedItemStyle AsNewHierarchyItemStyle(defaultSelectedHierarchicalItemFillStyle, highlightedHierarchicalItemFillStyle, borderColor, borderColor, Color.Black, Color.Black)
  5. Apply the HierarchyItemStyle objects to the vDataGridView’s theme object. This will modify the grid theme, and the grid will use the new settings when the HierarchyItems are rendered.
CopyC#
theme.HierarchyItemStyleNormal = itemStyle;
theme.HierarchyItemStyleSelected = selectedItemStyle;

this.Grid1.Theme = theme;
CopyVB.NET
theme.HierarchyItemStyleNormal = itemStyle
theme.HierarchyItemStyleSelected = selectedItemStyle

Me.Grid1.Theme = theme
 Grid Headers Styles 1


Grid Column Styles

[image]

VIBlend Controls for WinForms Help Documentation
Grid Column Styles
Send Feedback
In order to set a style which will be applied to an entire column, you need to create a new GridCellStyle object and then set the CellsStyle property of a HierarchyItem object.
CopyC#
// Apply a new cell style to the grid rows which are even.
GridCellStyle cellStyle = GridTheme.GetDefaultTheme(VIBLEND_THEME.VISTABLUE).GridCellStyle;
cellStyle.FillStyle = newFillStyleSolid(Color.Aqua);

GridCellStyle cellStyle2 = GridTheme.GetDefaultTheme(VIBLEND_THEME.VISTABLUE).GridCellStyle;
cellStyle2.FillStyle = newFillStyleSolid(Color.SkyBlue);

this.Grid1.ColumnsHierarchy.Items[1].CellsStyle = cellStyle;
this.Grid1.ColumnsHierarchy.Items[3].CellsStyle = cellStyle2;
CopyVB.NET
' Apply a new cell style to the grid rows which are even.
Dim cellStyle As GridCellStyle = GridTheme.GetDefaultTheme(VIBLEND_THEME.VISTABLUE).GridCellStyle
cellStyle.FillStyle = NewFillStyleSolid(Color.Aqua)

Dim cellStyle2 As GridCellStyle = GridTheme.GetDefaultTheme(VIBLEND_THEME.VISTABLUE).GridCellStyle
cellStyle2.FillStyle = NewFillStyleSolid(Color.SkyBlue)

Me.Grid1.ColumnsHierarchy.Items(1).CellsStyle = cellStyle
Me.Grid1.ColumnsHierarchy.Items(3).CellsStyle = cellStyle2

Grid Column Styles 1


Cell Lines

[image]

VIBlend Controls for WinForms Help Documentation
Cell Lines
Send Feedback
VIBlend DataGridView for WinForms allows you to show all grid lines, only horizontal lines or only vertical cell lines. By default, the control renders all cell lines.
  • Display all cell lines( default mode )

    Cell Lines Image 1

    CopyC#
    this.Grid1.GridLinesDisplayMode = GridLinesDisplayMode.DISPLAY_ALL;
    CopyVB.NET
    Me.Grid1.GridLinesDisplayMode = GridLinesDisplayMode.DISPLAY_ALL
  • Display horizontal cell lines

    Cell Lines Image 2

    CopyC#
    this.Grid1.GridLinesDisplayMode = GridLinesDisplayMode.DISPLAY_ROW_LINES;
    CopyVB.NET
    Me.Grid1.GridLinesDisplayMode = GridLinesDisplayMode.DISPLAY_ROW_LINES
  • Display vertical cell lines

    Cell Lines Image 3

    CopyC#
    this.Grid1.GridLinesDisplayMode = GridLinesDisplayMode.DISPLAY_COLUMN_LINES;
    CopyVB.NET
    Me.Grid1.GridLinesDisplayMode = GridLinesDisplayMode.DISPLAY_COLUMN_LINES
  • Hide all lines

Cell Lines Image 4

CopyC#
this.Grid1.GridLinesDisplayMode = GridLinesDisplayMode.DISPLAY_NONE;
CopyVB.NET
Me.Grid1.GridLinesDisplayMode = GridLinesDisplayMode.DISPLAY_NONE

In VIBlend DataGridView, you can also change the cells dash style. Use the GridLinesDashStyle property, to change the dash style. By default, the lines dash style is solid. The image below illustrates a vDataGridView control with Dash lines.

Cell Lines Image 5

CopyC#
this.Grid1.GridLinesDashStyle = System.Drawing.Drawing2D.DashStyle.Dash;
CopyVB.NET
Me.Grid1.GridLinesDashStyle = System.Drawing.Drawing2D.DashStyle.Dash


Cell Events

[image]

VIBlend Controls for WinForms Help Documentation
Cell Events
Send Feedback
VIBlend DataGridView for WinForms exposes the following cell events:

  • CellMouseClick – Occurs when the mouse button is clicked in a cell bounds.
  • CellMouseDoubleClick – Occurs when the mouse button is double-clicked in a cell bounds.
  • CellMouseDown – Occurs when a mouse button is down in a cell bounds.
  • CellMouseUp – Occurs when a mouse button is up in a cell bounds.
  • CellMouseEnter – Occurs when the mouse cursor enters a cell bounds.
  • CellMouseLeave – Occurs when the mouse cursor leaves a cell bounds.
  • CellBeginEdit – Occurs when a cell edit is beginning.
  • CellEndEdit – Occurs when a cell edit is ending.
  • CellEditorActivate – Occurs when a cell editor is being activated.
  • CellEditorActivated – Occurs when a cell editor is activated.
  • CellEditorDeActivate – Occurs when a cell editor is being deactivated.
  • CellEditorDeActivated – Occurs when a cell editor is deactivated.
  • CellValidating – Occurs when a cell is validating.
  • CellValidated – Occurs after the CellValidating event, when the cell is validated.
  • CellValueChanging – Occurs when a cell value is being changed.
  • CellValueChanged – Occurs after the CellValueChanging event, when the cell value is changed.
  • CellValueNeeded – Occurs before a grid cell painting. Use this event in virtual mode to specify the content of a grid cell.
  • CellSelectionChanged – Occurs when the cell selection is changed.
  • CellCustomPaint – Occurs when the cell is rendered. You can use this event to modify the default cell’s rendering.


Cell Images

[image]

VIBlend Controls for WinForms Help Documentation
Cell Images
Send Feedback
VIBlend DataGridView for WinForms supports three cell display modes. You can specify a display mode which shows only Text, Image and Text and only Image. When the display mode is set to Image, you can set the image to be shown in the cell’s center, tiled or stretched.

In order to apply an image to a grid cell, you need to create a new ImageList component and associated it to the vDataGridView control.

CopyC#
this.Grid1.ImageList = this.imageList1;
CopyVB.NET
Me.Grid1.ImageList = Me.imageList1

The following code snippet sets an image to a grid cell and the image will be rendered in the cell’s center.

CopyC#
this.Grid1.CellsArea.SetCellDisplaySettings(this.Grid1.RowsHierarchy.Items[i],this.Grid1.ColumnsHierarchy.Items[5], DisplaySettings.ImageOnly);
this.Grid1.CellsArea.SetCellImagePosition(this.Grid1.RowsHierarchy.Items[i], this.Grid1.ColumnsHierarchy.Items[5], ImagePositions.Center);
this.Grid1.CellsArea.SetCellImage(this.Grid1.RowsHierarchy.Items[i], this.Grid1.ColumnsHierarchy.Items[5], index);
CopyVB.NET
Me.Grid1.CellsArea.SetCellDisplaySettings(Me.Grid1.RowsHierarchy.Items(i), Me.Grid1.ColumnsHierarchy.Items(5), DisplaySettings.ImageOnly)

Me.Grid1.CellsArea.SetCellImagePosition(Me.Grid1.RowsHierarchy.Items(i), Me.Grid1.ColumnsHierarchy.Items(5), ImagePositions.Center)

Me.Grid1.CellsArea.SetCellImage(Me.Grid1.RowsHierarchy.Items(i), Me.Grid1.ColumnsHierarchy.Items(5), index)

Cell Images 1

Set the Image position to Stretch.

Cell Images 2

CopyC#
this.Grid1.CellsArea.SetCellDisplaySettings(this.Grid1.RowsHierarchy.Items[i],this.Grid1.ColumnsHierarchy.Items[5], DisplaySettings.ImageOnly);
this.Grid1.CellsArea.SetCellImagePosition(this.Grid1.RowsHierarchy.Items[i], this.Grid1.ColumnsHierarchy.Items[5], ImagePositions.Stretch);
this.Grid1.CellsArea.SetCellImage(this.Grid1.RowsHierarchy.Items[i], this.Grid1.ColumnsHierarchy.Items[5], index);
CopyVB.NET
Me.Grid1.CellsArea.SetCellDisplaySettings(Me.Grid1.RowsHierarchy.Items(i), Me.Grid1.ColumnsHierarchy.Items(5), DisplaySettings.ImageOnly)

Me.Grid1.CellsArea.SetCellImagePosition(Me.Grid1.RowsHierarchy.Items(i), Me.Grid1.ColumnsHierarchy.Items(5), ImagePositions.Stretch)

Me.Grid1.CellsArea.SetCellImage(Me.Grid1.RowsHierarchy.Items(i), Me.Grid1.ColumnsHierarchy.Items(5), index)
 Set the Image position to Tile.

Cell Images 3

CopyC#
this.Grid1.CellsArea.SetCellDisplaySettings(this.Grid1.RowsHierarchy.Items[i], this.Grid1.ColumnsHierarchy.Items[5], DisplaySettings.ImageOnly);
this.Grid1.CellsArea.SetCellImagePosition(this.Grid1.RowsHierarchy.Items[i], this.Grid1.ColumnsHierarchy.Items[5], ImagePositions.Tile);
this.Grid1.CellsArea.SetCellImage(this.Grid1.RowsHierarchy.Items[i], this.Grid1.ColumnsHierarchy.Items[5], index);
CopyVB.NET
Me.Grid1.CellsArea.SetCellDisplaySettings(Me.Grid1.RowsHierarchy.Items(i), Me.Grid1.ColumnsHierarchy.Items(5), DisplaySettings.ImageOnly)

Me.Grid1.CellsArea.SetCellImagePosition(Me.Grid1.RowsHierarchy.Items(i), Me.Grid1.ColumnsHierarchy.Items(5), ImagePositions.Tile)

Me.Grid1.CellsArea.SetCellImage(Me.Grid1.RowsHierarchy.Items(i), Me.Grid1.ColumnsHierarchy.Items(5), index)

To display an image and text in a cell, you should do the following:

CopyC#
this.Grid1.CellsArea.SetCellDisplaySettings(this.Grid1.RowsHierarchy.Items[i],this.Grid1.ColumnsHierarchy.Items[5], DisplaySettings.TextAndImage);
this.Grid1.CellsArea.SetCellImage(this.Grid1.RowsHierarchy.Items[i], this.Grid1.ColumnsHierarchy.Items[5], index);
this.Grid1.CellsArea.SetCellValue(this.Grid1.RowsHierarchy.Items[i], this.Grid1.ColumnsHierarchy.Items[5], "Cell Text");
CopyVB.NET
this.Grid1.CellsArea.SetCellDisplaySettings(this.Grid1.RowsHierarchy.Items[i],this.Grid1.ColumnsHierarchy.Items[5], DisplaySettings.TextAndImage);
this.Grid1.CellsArea.SetCellImage(this.Grid1.RowsHierarchy.Items[i], this.Grid1.ColumnsHierarchy.Items[5], index);
this.Grid1.CellsArea.SetCellValue(this.Grid1.RowsHierarchy.Items[i], this.Grid1.ColumnsHierarchy.Items[5], "Cell Text");

Cell Images 4

You can also change the text and image relation and display the image above the text, text before the image, text above the image, overlay. The following code snippet illustrates how to display an image above the text and how to change the default text alignment and image alignment properties.

CopyC#
this.Grid1.CellsArea.SetCellDisplaySettings(this.Grid1.RowsHierarchy.Items[i], this.Grid1.ColumnsHierarchy.Items[5], DisplaySettings.TextAndImage);
this.Grid1.CellsArea.SetCellImage(this.Grid1.RowsHierarchy.Items[i], this.Grid1.ColumnsHierarchy.Items[5], index);
this.Grid1.CellsArea.SetCellValue(this.Grid1.RowsHierarchy.Items[i], this.Grid1.ColumnsHierarchy.Items[5], "Cell Text");
this.Grid1.CellsArea.SetCellTextImageRelation(this.Grid1.RowsHierarchy.Items[i], this.Grid1.ColumnsHierarchy.Items[5], TextImageRelation.ImageAboveText);
this.Grid1.CellsArea.SetCellTextAlignment(this.Grid1.RowsHierarchy.Items[i], this.Grid1.ColumnsHierarchy.Items[5], ContentAlignment.MiddleCenter);
this.Grid1.CellsArea.SetCellImageAlignment(this.Grid1.RowsHierarchy.Items[i], this.Grid1.ColumnsHierarchy.Items[5], ContentAlignment.MiddleCenter);
CopyVB.NET
Me.Grid1.CellsArea.SetCellDisplaySettings(Me.Grid1.RowsHierarchy.Items(i), Me.Grid1.ColumnsHierarchy.Items(5), DisplaySettings.TextAndImage)

Me.Grid1.CellsArea.SetCellImage(Me.Grid1.RowsHierarchy.Items(i), Me.Grid1.ColumnsHierarchy.Items(5), index)

Me.Grid1.CellsArea.SetCellValue(Me.Grid1.RowsHierarchy.Items(i), Me.Grid1.ColumnsHierarchy.Items(5), "Cell Text")
Me.Grid1.CellsArea.SetCellTextImageRelation(Me.Grid1.RowsHierarchy.Items(i), Me.Grid1.ColumnsHierarchy.Items(5), TextImageRelation.ImageAboveText)

Me.Grid1.CellsArea.SetCellTextAlignment(Me.Grid1.RowsHierarchy.Items(i), Me.Grid1.ColumnsHierarchy.Items(5), ContentAlignment.MiddleCenter)

Me.Grid1.CellsArea.SetCellImageAlignment(Me.Grid1.RowsHierarchy.Items(i), Me.Grid1.ColumnsHierarchy.Items(5), ContentAlignment.MiddleCenter)

Cell Images 5


Row and Column Headers Events

[image]

VIBlend Controls for WinForms Help Documentation
Row and Column Headers Events
Send Feedback
VIBlend DataGridView for WinForms exposes the following HierarchyItem events:

  • HierarchyItemExpanded - Occurs when a HierarchyItem is expanded
  • HierarchyItemMouseClick - Occurs when a HierarchyItem is clicked
  • HierarchyItemMouseDown - Occurs when the user presses a mouse button over HierarchyItem.
  • HierarchyItemMouseUp - Occurs when the user releases a mouse button over HierarchyItem.
  • HierarchyItemMouseDoubleClick - Occurs when a HierarchyItem is double clicked.
  • HierarchyItemCustomPaint - Occurs when a HierarchyItem is painted. You can handle this event to modify the HierarchyItem’s default rendering.
  • HierarchyItemCollapsed - Occurs when a HierarchyItem is collapsed
  • HierarchyItemExpanding - Occurs when a HierarchyItem is expanding
  • HierarchyItemCollapsing - Occurs when a HierarchyItem is collapsing
  • HierarchyItemDragStarted - Occurs when a drag operation with header item is started
  • HierarchyItemDragEnded - Occurs when a drag operation with header item is ended
  • HierarchyItemDragStarting - Occurs when a drag operation with header item is starting
  • HierarchyItemDragEnding - Occurs when a drag operation with header item is ending
  • HierarchyItemSelectionChanged - Occurs when the selection of a HierarchyItem has changed.

Selection

There are three selection modes supported in VIBlend DataGridView. You can choose to select full rows, full columns or a single cell. You can also enable/disable the multiple selection feature. The multiple selection is enabled by default and the selection is set to cell.

  1. Full Row Selection:

    Row And Column Headers Events 1

    CopyC#
    this.Grid1.SelectionMode = vDataGridView.SELECTION_MODE.FULL_ROW_SELECT;
    CopyVB.NET
    Me.Grid1.SelectionMode = vDataGridView.SELECTION_MODE.FULL_ROW_SELECT
  2. Full Column Selection:

    Row And Column Headers Events 2

    CopyC#
    this.Grid1.SelectionMode = vDataGridView.SELECTION_MODE.FULL_COLUMN_SELECT;
    CopyVB.NET
    Me.Grid1.SelectionMode = vDataGridView.SELECTION_MODE.FULL_COLUMN_SELECT
  3. Cell Selection:

Row And Column Headers Events 3

CopyC#
this.Grid1.SelectionMode = vDataGridView.SELECTION_MODE.CELL_SELECT;
CopyVB.NET
Me.Grid1.SelectionMode = vDataGridView.SELECTION_MODE.CELL_SELECT

If you want to enable/disable the multiple selection, use the MultipleSelectionEnabled property of VIBlend DataGridView. By default, the property is set to true.


Column Chooser

[image]

VIBlend Controls for WinForms Help Documentation
Column Chooser
Send Feedback
The Column Chooser allows you to easily show/hide columns in VIBlend DataGridView. You should simply click on some of the check items and the column’s visibility state will be toggled. The column chooser is disabled by default. In order to show a column chooser, you should do the following:

CopyC#
// Enables the Column Chooser.
Grid1.EnableColumnChooser = true;
Grid1.ShowColumnChooser();
CopyVB.NET
' Enables the Column Chooser.
Grid1.EnableColumnChooser = True
Grid1.ShowColumnChooser()

Column Chooser 1

To programmatically hide the column chooser, use the HideColumnChooser method.


Grouping Header control

[image]

VIBlend Controls for WinForms Help Documentation
Grouping Header control
Send Feedback
This control is used as part of the VIBlend DataGridView UI.

Grouping Header Control 1

When a new item is added to the vDataGridViewGroupsHeader control, the control’s height is changed automatically i.e. the control’s size grows and shrinks depending on its content. When you drag and drop a column header from the vDataGridView over the vDataGridViewGroupsHeader control, the dropped column is added to the vDataGridView’s GroupingColumns collection and a grouping operation is performed. You can also remove a grouping column by clicking on a header item’s close button or by performing a drag and drop operation of a header item where it is dragged from the vDataGridViewGroupsHeaderand dropped into the vDataGridView control.

When you add a new instance of the vDataGridViewGroupsHeader control, you should associate it with a vDataGridView control. You can do this by using the DataGridView property.

To hide the header items connecting lines, set the ShowConnectingLines property to false.

If the vDataGridViewGroupsHeader control has no header items, the control displays a prompt text:"Drag a column here to group by this column.". To change this text, use the PromptText property. To change the text display color, use the PromptTextColor property.

When a drag operation is currently performed, the DragStarting, DragStarted, DragEnding and DragEnded events are raised.


Compact Style Rendering

[image]

VIBlend Controls for WinForms Help Documentation
Compact Style Rendering
Send Feedback
VIBlend DataGridView for WinForms offers multiple unique features that cannot be found in other Windows Forms data grid controls. These include multi-level hierarchies on rows and columns, rows grouping, pivot tables, and built-in OLAP capabilities. One of the main drawbacks of the traditional OLAP style rows layout is that it takes a lot of screen space. Compact Style Rendering 1

This could be improved by using the compact style layout. In this mode the rows of the pivot table are rendered in a tree-like structure.

Compact Style Rendering 2

Switching from default to compact style rendering is very easy. It requires setting the value of RowsHierarchy.CompactStyleRendering property to true:

CopyC#
grid.RowsHierarchy.CompactStyleRenderingEnabled = true;
grid.RowsHierarchy.AutoResize();
grid.Invalidate();
CopyVB.NET
grid.RowsHierarchy.CompactStyleRenderingEnabled = True
grid.RowsHierarchy.AutoResize()
grid.Invalidate()


Fixed Headers and Fixed Items

[image]

VIBlend Controls for WinForms Help Documentation
Fixed Headers and Fixed Items
Send Feedback
If you want your rows or columns hierarchies to be fixed (non-scrollable) you can set the Fixed property of the RowsHierarchy or ColumnsHierarchy.

CopyC#
dataGridView1.RowsHierarchy.Fixed = true;
dataGridView1.ColumnsHierarchy.Fixed = true;
CopyVB.NET
dataGridView1.RowsHierarchy.Fixed = True
dataGridView1.ColumnsHierarchy.Fixed = True
 You can also apply the fixed propery to specific rows and columns:
CopyC#
dataGridView1.ColumnsHierarchy.Items[0].Fixed = true;
dataGridView1.RowsHierarchy.Items[0].Fixed = true;
CopyVB.NET
dataGridView1.ColumnsHierarchy.Items(0).Fixed = True
dataGridView1.RowsHierarchy.Items(0).Fixed = True


Exporting data to Excel, CSV, XML, HTML

[image]

VIBlend Controls for WinForms Help Documentation
Exporting data to Excel, CSV, XML, HTML
Send Feedback
VIBlend DataGridView for Windows Forms allows you to export the content of the data grid to several file format.

To export data you use the GridExport class. The GridExport class includes methods like ExportToXML, ExportToHTML, ExportToCSV, and ExportToExcelXML.

The following sample code demonstrates how to export the grid data to an Excel file:

CopyC#
saveFileDialog1.FileName = "";
saveFileDialog1.Filter = "XML Spreadsheet (*.xml)|*.xml";

if (saveFileDialog1.ShowDialog() != DialogResult.OK)
    return;

string filePath = saveFileDialog1.FileName;

GridExport gridExport = newGridExport();
if (gridExport.ExportToExcelXML(grid, filePath))
{
   MessageBox.Show(
    "Export Complete",
    "GridView Export",
    MessageBoxButtons.OK,
    MessageBoxIcon.Information);
}
else
{
   MessageBox.Show(
   "Export Failed",
   "GridView Export APIs",
   MessageBoxButtons.OK,
   MessageBoxIcon.Error);
}
CopyVB.NET
saveFileDialog1.FileName = ""
saveFileDialog1.Filter = "XML Spreadsheet (*.xml)|*.xml"

If saveFileDialog1.ShowDialog() <> DialogResult.OK Then
    Return
End If

Dim filePath As String = saveFileDialog1.FileName

Dim gridExport As GridExport = newGridExport()
If gridExport.ExportToExcelXML(grid, filePath) Then
   MessageBox.Show("Export Complete", "GridView Export", MessageBoxButtons.OK, MessageBoxIcon.Information)
Else
   MessageBox.Show("Export Failed", "GridView Export APIs", MessageBoxButtons.OK, MessageBoxIcon.Error)
End If


Themes

[image]

VIBlend Controls for WinForms Help Documentation
Themes
Send Feedback
VIBlend Controls for Windows Forms ships with several built-in themes. Each control in the library exposes a property called VIBlendTheme. You can use this property to choose one of the built-in themes.

At design time you can change the VIBlendTheme via the control properties. The VIBlendTheme property is located within the Appearance group.

The code below changes the theme of the DataGridView at runtime:

CopyC#
using VIBlend.WinForms.DataGridView;
using VIBlend.Utilities;
...
...
vDataGridView1.VIBlendTheme = VIBLEND_THEME.ULTRABLUE;
CopyVB.NET
Imports VIBlend.WinForms.DataGridView
Imports VIBlend.Utilities
...
...
vDataGridView1.VIBlendTheme = VIBLEND_THEME.ULTRABLUE

All controls in the VIBlend Controls for Windows Forms library expose a Theme property. You can use it to load a custom theme.

The code below loads a user defined theme from a XML file:

CopyC#
private bool SetCustomTheme()
{
   GridTheme theme = newGridTheme();
   if (!theme.LoadFromXml(@"c:\MyThemes\myCustomGridTheme.xml"))
    returnfalse;

   grid.Theme = theme;
   return true;
}
CopyVB.NET
Private Function SetCustomTheme() As Boolean
   Dim theme As GridTheme = newGridTheme()
   If (Not theme.LoadFromXml("c:\MyThemes\myCustomGridTheme.xml")) Then
    returnfalse
   End If

   grid.Theme = theme
   Return True
End Function


TreeView

[image]

VIBlend Controls for WinForms Help Documentation
TreeView
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)
VIBlend TreeView for Windows Forms helps you visualize hierarchical data in expandable nodes. The TreeView control is represented by the vTreeView class in the VIBlend.WinForms.Controls namespace.

Tree View Image 1

The easiest way to add a TreeView to a Form is to use the Visual Studio designer. Open the Toolbox, locate the vTreeView item in the VIBlend controls group and drag it on the form.


Working with nodes

[image]

VIBlend Controls for WinForms Help Documentation
Working with nodes
Send Feedback
The TreeView control contains nodes that are represented by the vTreeNode class. Both vTreeView and vTreeNode include aNodescollection property. You can use the Nodes collection to add and remove tree nodes.

The following example code shows how to add tree nodes:

CopyC#
private void FillNodes(vTreeView tree)
{
   for (int i = 0; i < 3; i++)
   {
     vTreeNode rootNode = new vTreeNode("Node" + i);
     tree.Nodes.Add(rootNode);

     for (int j = 0; j < 3; j++)
     {
        vTreeNode node = new vTreeNode("Node" + i + "." + j);
        rootNode.Nodes.Add(node);
     }
  }
}
CopyVB.NET
Private Sub FillNodes(ByVal tree As vTreeView)
   For i As Integer = 0 To 2
     Dim rootNode As vTreeNode = newvTreeNode("Node And quot; + i)
     tree.Nodes.Add(rootNode)

     For j As Integer = 0 To 2
        Dim node As vTreeNode = newvTreeNode("Node And quot; + i + "." + j)
        rootNode.Nodes.Add(node)
     Next j
   Next i
End Sub

To remove nodes in vTreeView you can use the Remove and RemoveAt methods of vTreeNodeCollection.

CopyC#
tree.Nodes.RemoveAt(0);
CopyVB.NET
tree.Nodes.RemoveAt(0)

You can expand a tree node by calling itsExpand method. If you want to collapse a tree node you can use theCollapse method. The Toggle method will change the current tree node’s state from expanded state to collapsed state or from collapsed state to expanded state.

The vTreeNode class includes several useful properties. The IsExpanded property gives you information about the tree node’s state. The Depth property gives you information about the tree node’s level in the nodes hierarchy. The Font property allows you to modify tree node’s Font. The ForeColor property allows you to change node’s text color. The ImageIndex, SelectedImageIndex and StateImageIndex properties allow you to set a different image to the tree node for its different states.

Adding images to the TreeView nodes requires two steps. First, the Images must be organized in an ImageList component and the ImageList property of the vTreeView control must point to this image list. This can be done either at design time or programmatically. The second step requires setting the ImageIndex andSelectedImageIndex properties of each vTreeNode. The code below performs this step at runtime:

CopyC#
string[] friends = newstring[]
{
  "Andrew Fuller",
  "Nancy Davolio",
  "Michael Suyama"
  "Shelley Burke",
  "Regina Murphy"};
  int imageIndex = 0;

foreach (string name in friends)
{
    vTreeNode node = newvTreeNode(name);
    node.ImageIndex = imageIndex++;
    treeView.Nodes.Add(node);
}
CopyVB.NET
Dim friends() As String = newstring() { "Andrew Fuller", "Nancy Davolio", "Michael Suyama" "Shelley Burke", "Regina Murphy"}
  Dim imageIndex As Integer = 0

For Each name As String In friends
    Dim node As vTreeNode = newvTreeNode(name)
    node.ImageIndex = imageIndex
    imageIndex += 1
    treeView.Nodes.Add(node)
Next name

The nodes of the TreeView control provides nodes editing functionality. The IsLabelEditableproperty allows you to set whether the tree node can be edited. Another useful property is the vTreeNode Tag propery. It allows you to associate an object with a tree node.


Events

[image]

VIBlend Controls for WinForms Help Documentation
Events
Send Feedback
The TreeView control provides the following events:

  • BeforeSelect – occurs when the user selects a node. You can use the event arguments in the event handler to cancel the selection.
  • AfterSelect – occurs right after a selection is made.
  • BeforeExpand – occurs when the user expands a node.
  • AfterExpand – occurs right after the node is expanded.
  • BeforeCollase – occurs when the user collapses a node.
  • AfterCollapse – occurs right after the node is collapsed.
  • BeforeLabelEdit – occurs before a node’s text is edited. You can cancel the edit operation in the event handler using the event argument’s CancelEdit property.
  • AfterLabelEdit – occurs after the edit operation has finished.
  • BeforeDragStart – occurs when the user begins a drag operation. You can use this event to cancel the node dragging.
  • AfterDragStart – occurs after the drag operation start.
  • BeforeDragEnd – occurs before the drop operation. You can use this event to cancel the drop operation.
  • AfterDragEnd – occurs when the drag/drop operation is finished.
  • NodeChecked – occurs when a tree node’s checked state is changed.
  • NodeMouseDown - occurs when the user presses the mouse button over a tree node. You can use this method to get the instance of the node under the mouse cursor.


Appearance Settings

[image]

VIBlend Controls for WinForms Help Documentation
Appearance Settings
Send Feedback
Row selection style

You can enable or disable full row selection mode by using the FullRowSelect property.

Animations

vTreeView supports two different animation types. The first one is the animation of the tree nodes when the user expands or collapses a node. This animation changes the opacity of the tree nodes. You can enable it by using the EnableToggleAnimation property. The second one is the animation of the expand/collapse node indicators. This animation is controlled by the EnableIndicatorsAnimation property of the vTreeView control.

Root lines and node spacing

You can show or hide the Treeview’s root lines by using the ShowRootLines property. You can also change the root lines color via the LineColor property.

The NodesSpacing property allows you to customize the layout of the tree nodes by changing the distance between them.

You can use Vista-style triangular expand/collapse buttons or the default plus/minus buttons. This setting is controled bythe DefaultExpandCollapseIndicators property.

Themes

You can modify the theme by using the VIBlendTheme property.


Navigation methods and properties

[image]

VIBlend Controls for WinForms Help Documentation
Navigation methods and properties
Send Feedback
Scrolling to a TreeNode to make it visible

If you want to ensure that a specific tree node is visible you can use the BringIntoView method of vTreeView.

Finding theTreeNode at specific location

The FindNodeAt method allows you to search for a tree node by using node’s (x, y) coordinates

Expanding andcollapsing all tree nodes

ExpandAll method allows you to expand all tree nodes. CollapseAll method collapses all tree nodes.

Retrieving the currently Selected node

You can use the SelectedNode property to select any tree node or get the instance of the selected node.


Checkboxes and Tri-State checkboxes

[image]

VIBlend Controls for WinForms Help Documentation
Checkboxes and Tri-State checkboxes
Send Feedback
VIBlend TreeView for Windows Forms allows you to add check boxes on the left side of the tree nodes. The check boxes can be in tri-state mode with checked, unchecked and intermediate states.

Checkboxes And Tri-State Checkboxes 1

If you want to display check boxes set the Checkboxes property of the TreeView control to true. Every tree node has a Checked property which allows you to get or set its check state. In addition, the vTreeNodeclass offers the ShowCheckBoxproperty which allows you to show or hide the check box for each individiual node.

Some applications use checkboxes that allow an indeterminate state in addition to the two provided by a normal checkbox. This third state indicates that its state is neither checked nor unchecked. VIBlend TreeView control supports tri-state checkboxes and you can enable this feature by setting the TriStateMode property to true.

When you change the checked state of a tree node TreeView control raises the NodeChecked event.


DragDrop and Nodes Edit

[image]

VIBlend Controls for WinForms Help Documentation
DragDrop and Nodes Edit
Send Feedback
To enable the drag and drop feature in vTreeView set the AllowDragDrop property to true. To enable the node’s editing set the LabelEdit property to true. In addition, you can enable/disable the node text editing of individual tree nodes via the vTreeNode IsLabelEditable property.

When the LabelEdit property is set to true, the node will become editable when you select it and press the 'F2' key.

The BeforeLabelEdit event is raised when you start and edit operation and the AfterLabelEdit event is raised when the edit operation is finished.

Drag And Drop And Nodes Edit


Keyboard navigation

[image]

VIBlend Controls for WinForms Help Documentation
Keyboard navigation
Send Feedback
vTreeViewprovides built-in keyboard navigation support. The following list describes the actions performed by the TreeView control when a key is pressed:
  • Up key – selects the previous node.
  • Down key – selects the next node.
  • Left key – collapses the selected node.
  • Right key – expands the selected node.
  • Home – selects the first visible node.
  • End - selects the last visible node.
  • Space – changes the checked state.
  • Enter – ends the edit operation
  • F2 – starts the edit operation.


TreeView with ContextMenu

[image]

VIBlend Controls for WinForms Help Documentation
TreeView with ContextMenu
Send Feedback
This section shows how to attach a ContextMenuStrip control to a TreeView and implement some common operations like: Edit, Add Child, Add Sibling, Remove. The example code below shows you how to create and associate a ContextMenuStrip control to the VIBlend WinForms TreeView. The LabelEdit property enables the node editing feature.

CopyC#
 this.vTreeView2.LabelEdit = true;
ContextMenuStrip menuStrip = new ContextMenuStrip();
this.vTreeView2.ContextMenuStrip = menuStrip;
menuStrip.Items.Add("Edit");
menuStrip.Items.Add("Add Child");
menuStrip.Items.Add("Add Sibling");
menuStrip.Items.Add("Remove");

menuStrip.ItemClicked += new ToolStripItemClickedEventHandler(menuStrip_ItemClicked);

CopyVB.NET
Me.vTreeView2.LabelEdit = True
Dim menuStrip As New ContextMenuStrip()
Me.vTreeView2.ContextMenuStrip = menuStrip
menuStrip.Items.Add("Edit")
menuStrip.Items.Add("Add Child")
menuStrip.Items.Add("Add Sibling")
menuStrip.Items.Add("Remove")

AddHandler menuStrip.ItemClicked, AddressOf menuStrip_ItemClicked

The next code snippet implements the 'Edit', 'Add Child', 'Add Sibling' and 'Remove' operations in the ContextMenuStrip ItemClicked event handler.

CopyC#
void menuStrip_ItemClicked(object sender, ToolStripItemClickedEventArgs e)
{
   switch (e.ClickedItem.Text)
   {
      case "Edit":
         this.vTreeView2.BeginEdit(this.vTreeView2.SelectedNode.Text);
         break;
      case "Add Child":
         vTreeNode childNode = new vTreeNode("Node " +     this.vTreeView2.SelectedNode.Nodes.Count);
         this.vTreeView2.SelectedNode.Nodes.Add(childNode);
         break;
      case "Add Sibling":
         vTreeNode ownerNode = this.vTreeView2.SelectedNode.Parent;
         vTreeNode siblingNode = new vTreeNode("Sibling Node");

         if (ownerNode != null)
         {
ownerNode.Nodes.Insert(ownerNode.Nodes.IndexOf(this.vTreeView2.SelectedNode) + 1, siblingNode);
         }
         else this.vTreeView2.Nodes.Insert(vTreeView2.Nodes.IndexOf(this.vTreeView2.SelectedNode) + 1, siblingNode);
         break;
       case "Remove":
          this.vTreeView2.SelectedNode.Remove();
       break;
    }
}
CopyVB.NET
Private Sub menuStrip_ItemClicked(ByVal sender As Object, ByVal e As ToolStripItemClickedEventArgs)
   Select Case e.ClickedItem.Text
      Case "Edit"
         Me.vTreeView2.BeginEdit(Me.vTreeView2.SelectedNode.Text)
      Case "Add Child"
         Dim childNode As New vTreeNode("Node " & Me.vTreeView2.SelectedNode.Nodes.Count)
         Me.vTreeView2.SelectedNode.Nodes.Add(childNode)
      Case "Add Sibling"
         Dim ownerNode As vTreeNode = Me.vTreeView2.SelectedNode.Parent
         Dim siblingNode As New vTreeNode("Sibling Node")

         If ownerNode IsNot Nothing Then
ownerNode.Nodes.Insert(ownerNode.Nodes.IndexOf(Me.vTreeView2.SelectedNode) + 1, siblingNode)
         Else
             Me.vTreeView2.Nodes.Insert(vTreeView2.Nodes.IndexOf(Me.vTreeView2.SelectedNode) + 1, siblingNode)
         End If
       Case "Remove"
          Me.vTreeView2.SelectedNode.Remove()
   End Select
End Sub


TabControl

[image]

VIBlend Controls for WinForms Help Documentation
TabControl
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)

VIBlend TabControl for Windows Forms allows you to build stylish tabbed interfaces in popular themes. In addition, the tab control offers features like drag and drop, tabs alignment on any of the four sides of the control, multi-line text, an inated tabs scrolling, and fit to bounds mode.

Tab Control 1


Overview

[image]

VIBlend Controls for WinForms Help Documentation
Overview
Send Feedback
- Tab Pages with close buttons.

VIBlend TabControl for Windows Forms has a built-in feature which allows you to display a close button on each TabPage.

The following code enables the close buttons:

CopyC#
this.vTabControl1.EnableCloseButtons = true;
CopyVB.NET
Me.vTabControl1.EnableCloseButtons = True

- Tab Pages with custom text colors

In order to display TabPages with different text colors you can specify a TabPage color for the selected, highlight and default states. The TabPage uses the Theme's text color by default. In order to override this behavior, you should set the UseThemeTextColor property to false. After that, use the TextColor, HighlightTextColor and PressedTextColor properties to specify your TabPage's text color.

CopyC#
vTabPage page = new vTabPage();
page.Text = "Blue Page";
page.UseThemeTextColor = false;
page.TextColor = Color.Blue;
page.HighlightTextColor = Color.LightBlue;
page.PressedTextColor = Color.DarkBlue;

vTabPage redPage = new vTabPage();
redPage.Text = "Red Page";
redPage.UseThemeTextColor = false;
redPage.TextColor = Color.Red;
redPage.HighlightTextColor = Color.Magenta;
redPage.PressedTextColor = Color.DarkMagenta;

vTabPage yellowPage = new vTabPage();
yellowPage.Text = "Yellow Page";
yellowPage.UseThemeTextColor = false;
yellowPage.TextColor = Color.Yellow;
yellowPage.HighlightTextColor = Color.LightYellow;
yellowPage.PressedTextColor = Color.YellowGreen;

tabControl.TabPages.Add(page);
tabControl.TabPages.Add(redPage);
tabControl.TabPages.Add(yellowPage);
CopyVB.NET
Dim page As New vTabPage()
page.Text = "Blue Page"
page.UseThemeTextColor = False
page.TextColor = Color.Blue
page.HighlightTextColor = Color.LightBlue
page.PressedTextColor = Color.DarkBlue

Dim redPage As New vTabPage()
redPage.Text = "Red Page"
redPage.UseThemeTextColor = False
redPage.TextColor = Color.Red
redPage.HighlightTextColor = Color.Magenta
redPage.PressedTextColor = Color.DarkMagenta

Dim yellowPage As New vTabPage()
yellowPage.Text = "Yellow Page"
yellowPage.UseThemeTextColor = False
yellowPage.TextColor = Color.Yellow
yellowPage.HighlightTextColor = Color.LightYellow
yellowPage.PressedTextColor = Color.YellowGreen

tabControl.TabPages.Add(page)
tabControl.TabPages.Add(redPage)
tabControl.TabPages.Add(yellowPage)

- Tab Pages with Shapes

In order to change the shape of the Tab Pages in the TabControl, you can use the TabsShape property.

The following example code sets the TabsShape property to OneNote style.

CopyC#
this.vTabControl1.TabsShape = VIBlend.WinForms.Controls.TabsShape.OneNote;
CopyVB.NET
Me.vTabControl1.TabsShape = VIBlend.WinForms.Controls.TabsShape.OneNote

The TabControl has 5 built-in TabPage shapes - Office2007, Chrome, OneNote, VisualStudio and RoundedCorners. You can also change the spacing between the Tab Pages by using the TabsSpacing property.

CopyC#
this.vTabControl1.TabsSpacing = -20;
CopyVB.NET
Me.vTabControl1.TabsSpacing = -20

- Tab Pages with Images

If you want to add an image to a Tab Page you need to associate an instance of the vTabControl with an ImageList component by using the ImageList property. Each tab page has an ImageIndex property.

When a tab page is rendering it checks the value of its ImageIndex property and tries to find the corresponding image in the tab control’s ImageList.

The tab control pages also offer the TextImageRelation property the allows you to change the layout between the text and image. You can set the image to appear on any side of the text or to overlap with the text.

- Tab Pages with Multiline Text

In order to display a tab page's text in multiple lines, you should set its MultilineText property to true.

The following code example creates a TabControl with three Tab Pages. Notice the MultilineText property is used to specify that the first tab page displays its text in multiple lines.

CopyC#
vTabControl tabControl = new vTabControl();
this.Controls.Add(tabControl);
vTabPage page = new vTabPage("Tab Page with long text");
vTabPage page2 = new vTabPage("Tab Page 2");
vTabPage page3 = new vTabPage("Tab Page 3");
page.MultilineText = true;
page.Padding = new System.Windows.Forms.Padding(-20, 5,-20,5);
tabControl.AllPagesHeight = 40;
tabControl.TabPages.Add(page);
tabControl.TabPages.Add(page2);
tabControl.TabPages.Add(page3);
CopyVB.NET
Dim tabControl As New vTabControl()
Me.Controls.Add(tabControl)
Dim page As New vTabPage("Tab Page with long text")
Dim page2 As New vTabPage("Tab Page 2")
Dim page3 As New vTabPage("Tab Page 3")
page.MultilineText = True
page.Padding = New System.Windows.Forms.Padding(-20, 5,-20,5)
tabControl.AllPagesHeight = 40
tabControl.TabPages.Add(page)
tabControl.TabPages.Add(page2)
tabControl.TabPages.Add(page3)


Adding, Inserting and DeletingTabs

[image]

VIBlend Controls for WinForms Help Documentation
Adding, Inserting and DeletingTabs
Send Feedback
You can add, remove and modify tabs entirely in design time without writing any code. To open the TabControl’s design time editor, select the control, open the properties window in Visual Studio, and locate theTabPages property, and click the ‘...’ button.

Working with tab pages programatically is also easy. The following code shows how to Add, Insert and Remove a tab page:

Adding a new tab page:

CopyC#
vTabPage page = newvTabPage("TabPage");
this.vTabControl1.TabPages.Add(page);
Removing a tab page:
CopyC#
this.vTabControl1.TabPages.Remove(page);
 Inserting a new tab page:
CopyC#
vTabPage page = newvTabPage("TabPage");
this.vTabControl1.TabPages.Insert(0, page);

Adding a new tab page:

CopyVB.NET
Dim page AsvTabPage = NewvTabPage("TabPage")
Me.vTabControl1.TabPages.Add(page)
Removing a tab page:
CopyVB.NET
Me.vTabControl1.TabPages.Remove(page)
 Inserting a new tab page:
CopyVB.NET
Dim page AsvTabPage = NewvTabPage("TabPage")
Me.vTabControl1.TabPages.Insert(0, page)


Selecting Tab Pages

[image]

VIBlend Controls for WinForms Help Documentation
Selecting Tab Pages
Send Feedback
You can select a tabpage programmatically by using the SelectedTab property of thevTabControl.
CopyC#
this.vTabControl1.SelectedTab = page;
CopyVB.NET
Me.vTabControl1.SelectedTab = page
 You can also select a tab using the SelectedIndex property:
CopyC#
this.vTabControl1.SelectedIndex = 1;
CopyVB.NET
Me.vTabControl1.SelectedIndex = 1

When a tab is selected the tab control raises two events - SelectionIndexChanging and SelectedIndexChanged. You can handle the SelectionIndexChanging event and Cancel the selection using the event argument’s Cancel property.

CopyC#
void vTabControl1_SelectedIndexChanging(
object sender, VTabCancelEventArgs e)
{
   e.Cancel = true;
}
CopyVB.NET
Private Sub vTabControl1_SelectedIndexChanging(ByVal sender As Object, ByVal e As VTabCancelEventArgs)
   e.Cancel = True
End Sub


Drag And Drop

[image]

VIBlend Controls for WinForms Help Documentation
Drag And Drop
Send Feedback
To enable tab pages drag and drop set the AllowDragDrop property of the vTabControl to true.

During drag and drop operations the tab control raises several events that can help you control the drag and drop process.

The TabPageDragStarting event occurs when the user starts the drag operation. If you add an event handler you can use the event arguments of this event to cancel the operation.

The TabPageDragStarted event is raised when the drag operation has already started.

The TabPageDragEnding event is fired when the user drops a tab page to its new location.

Similarily to the the TabPageDragStarting event, you can add an event handler and cancel the drop operation.

TheTabPageDragEnded event is raised when the drag and drop operation is complete.

Tab Control Drag And Drop


Scrolling

[image]

VIBlend Controls for WinForms Help Documentation
Scrolling
Send Feedback

VIBlend vTabControl automatically displays scroll bars when there is not enough space for all tabs. You can also scroll to a tab programmatically using the EnsureTabVisible method.


Tabs Shrinking

[image]

VIBlend Controls for WinForms Help Documentation
Tabs Shrinking
Send Feedback
The fit to bounds mode of vTabControl is ideal when you do not want to have any scrollbars in your tab control and there is not enough space for all tabs. To enable the fit to bounds mode you set the value of theFitTabsToBoundsproperty to true.

Fit To Bounds


Tabs Alignment and TextOrientation

[image]

VIBlend Controls for WinForms Help Documentation
Tabs Alignment and TextOrientation
Send Feedback
VIBlend TabControl for WinForms allows you to change the tab pages location and orientation. You can align the tabs to the top, bottom, left, or right side of the tab control. To change the tabs alignment use the TabsAlignment property.

Tabs Alignment And Text Orientation

You can also change the text orientation to Horizontal and Vertical. This feature is controlled by theTextOrientation property.


Tab Images

[image]

VIBlend Controls for WinForms Help Documentation
Tab Images
Send Feedback

If you want to add an image to a vTabPage you need to associate the vTabControl with an ImageList component by using the ImageList property. Each tab page has an ImageIndex property.

When a tab page is rendering it checks its ImageIndex property and tries to find the corresponding image in the tab control’s imagelist.

The tab control pages also offer the TextImageRelation property the allows you to change the layout between the text and image. You can set the image to appearon any side of the text or to overlap with the text.


Layout and Themes

[image]

VIBlend Controls for WinForms Help Documentation
Layout and Themes
Send Feedback
The tab control provides several layout and theme properties which allow you to fine tune the visual appearance.You can modify the distance between the different tabs using theTabSpacing property of the vTabControl.

To change the initial tab pages offset, use the TabsInitialOffset property:

Tab Control Layout And Themes

Each tab page offers a text alignment property. To change the text alignment of a tab page, use the TextAlignment property of thevTabPage.

Similarily to all VIBlend WinForms controls, the tab controls offers aVIBlendTheme property. This property allows you select one of the built-in themes.In addition, you can change the theme of individual tabs.

CopyC#
vTabPage page = new vTabPage("TabPage");
vTabControl1.TabPages.Add(page);
page.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICE2003SILVER;
page.UseTabControlTheme = false;
CopyVB.NET
Dim page As New vTabPage("TabPage")
vTabControl1.TabPages.Add(page)
page.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICE2003SILVER
page.UseTabControlTheme = False


RibbonBar

[image]

VIBlend Controls for WinForms Help Documentation
RibbonBar
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)

VIBlend RibbonBar for Windows Forms helps you build highly customizable Ribbon interfaces. The Ribbon UI consists of several controls and provides features like key tips, quick access toolbar, collapsing groups, and ribbon gallery control.

Ribbon Bar Image 1

VIBlend Ribbon Bar for Windows Forms is represented by the vRibbonBar control class. It supports two different ribbon styles – Office2007 and Windows7. You can switch the ribbon styles using the RibbonStyle property.


Getting Started

[image]

VIBlend Controls for WinForms Help Documentation
Getting Started
Send Feedback
In order to create a new application using the VIBlend RibbonBar for WinForms, follow the steps below:

  1. Create a new Windows Forms Application.
  2. Create a new Form. Open the Solution Explorer, Right-Click on your project and choose Add>Windows Form… Then type RibbonDemoForm in the name field.

    Ribbon Bar Image 2

  3. Open the RibbonDemoForm in code behind and make it to be derived from the OfficeRibbonForm class.

    Ribbon Bar Image 3

  4. Open the VS toolbox and drag and drop a new instance of the vRibbonBar class. Then set the Form’s Ribbon property to point to the vRibbonBar’s instance.

    Ribbon Bar Image 4

  5. Add Ribbon Tabs and Ribbon Groups at design-time by clicking on the ‘Add Tab’ and ‘Add Ribbon Group’ items.

    Ribbon Bar Image 5

  6. Open the toolbox and drag and drop a new vRibbonBarApplicationButton. When you drop it on the Form, it should look like at the image below.

    Ribbon Bar Image 6

  7. Click on the button in order to open it.

    Ribbon Bar Image 7

  8. Now, you can drag and drop controls in the ApplicationButton’s area.

    Ribbon Bar Image 8

    In order to change the ApplicationButton Content area’s size, use the ApplicationButton’s DropDownWidth and DropDownHeight properties.

    Ribbon Bar Image 9

  9. Associate the ApplicationButton to the RibbonBar by using the RibbonBar’s ApplicationButton property.

    Ribbon Bar Image 10

    Please note that if the ApplicationButton’s Checked property is serialized by the designer, it will be opened when you run the application. In order to avoid this, open your Form’s designer.cs and remove the following:

    CopyC#
    this.vRibbonApplicationButton1.RoundedButton.Toggle = System.Windows.Forms.CheckState.Checked;
  10. In order to add a quick access toolbar to the RibbonBar, open the VS Toolbox and drag and drop a new instance of the QuickAccessToolbar.

    Ribbon Bar Image 11

  11. Click on the arrow shown at the QuickAccessToolbar’s top-right edge in order to open its design-time action list. Now, you can add button, checkbox, etc. to the quick access toolbar.

    Ribbon Bar Image 12

  12. Select the RibbonBar, find its QuickAccessToolbar property and set it to the QuickAccessToolBar’s instance.

    Ribbon Bar Image 13

  13. In order to make the RibbonBar to appear in Office2010 style, change the RibbonStyle property to Office2010. You can also use the Orange and Blue styles of the ApplicationButton by changing the value of the RoundButton’s UseButtonScheme and ButtonScheme properties.
  14. To add controls to the RibbonGroups, open the VS Toolbox, then drag and drop a control into the RibbonGroup’s content area.

    Ribbon Bar Image 14


Adding Ribbon Tabs and Ribbon Groups

[image]

VIBlend Controls for WinForms Help Documentation
Adding Ribbon Tabs and Ribbon Groups
Send Feedback
You can add new ribbon groups in design mode by clicking the “AddRibbonGroup” button. If you want to add a new tab item you can click the “Add New Tab” button. You can also drag and drop a new ribbon group or ribbon gallery from the Visual Studio ToolBox.

Ribbon Bar Image 15

The following code adds a ribbon group programmatically:

CopyC#
if (this.vRibbonBar1.SelectedTab != null)
{
  vRibbonGroup group = newvRibbonGroup();
  group.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE;
  group.Width = 200;
  group.Height = 76;

  if (this.vRibbonBar1.SelectedTab.Controls.Count == 0)
  {
    vRibbonHorizontalLayoutPanel layoutPanel = newvRibbonHorizontalLayoutPanel();
    layoutPanel.Dock = DockStyle.Fill;
    this.vRibbonBar1.SelectedTab.Controls.Add(layoutPanel);
    layoutPanel.BackColor = Color.Transparent;
    layoutPanel.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE;
  }

  this.vRibbonBar1.SelectedTab.LayoutPanel.Controls.Add(group);
  group.Text = "Group" +     this.vRibbonBar1.SelectedTab.LayoutPanel.Controls.Count;
 }
CopyVB.NET
If Me.vRibbonBar1.SelectedTab IsNot Nothing Then
  Dim group As vRibbonGroup = newvRibbonGroup()
  group.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE
  group.Width = 200
  group.Height = 76

  If Me.vRibbonBar1.SelectedTab.Controls.Count = 0 Then
    Dim layoutPanel As vRibbonHorizontalLayoutPanel = newvRibbonHorizontalLayoutPanel()
    layoutPanel.Dock = DockStyle.Fill
    Me.vRibbonBar1.SelectedTab.Controls.Add(layoutPanel)
    layoutPanel.BackColor = Color.Transparent
    layoutPanel.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE
  End If

  Me.vRibbonBar1.SelectedTab.LayoutPanel.Controls.Add(group)
  group.Text = "Group" & Me.vRibbonBar1.SelectedTab.LayoutPanel.Controls.Count
End If

To remove a group in design time, select the group and press the “Delete” button. You can also delete a ribbon group programmatically.

CopyC#
if (this.vRibbonBar1.SelectedTab != null)
{
    vRibbonGroup group = this.vRibbonBar1.SelectedTab.LayoutPanel.Controls[2] as                vRibbonGroup;
    if (group != null)
    {
        this.vRibbonBar1.SelectedTab.
        LayoutPanel.Controls.Remove(group);
    }
}
CopyVB.NET
If Me.vRibbonBar1.SelectedTab IsNot Nothing Then
    Dim group As vRibbonGroup = TryCast(Me.vRibbonBar1.SelectedTab.LayoutPanel.Controls(2), vRibbonGroup)
    If group IsNot Nothing Then
        Me.vRibbonBar1.SelectedTab. LayoutPanel.Controls.Remove(group)
    End If
End If

To add a vRibbonBarGallery control programmatically, first add a ribbon group and then add a ribbon gallery to the group.

Create an AddGroup methodthat return the new vRibbonGroup:

CopyC#
private vRibbonGroup AddGroup()
{
    vRibbonGroup group = newvRibbonGroup();
    group.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE;
    group.Width = 200;
    group.Height = 76;

    if (this.vRibbonBar1.SelectedTab.Controls.Count == 0)
    {
      vRibbonHorizontalLayoutPanel layoutPanel = new vRibbonHorizontalLayoutPanel();
      layoutPanel.Dock = DockStyle.Fill;
      this.vRibbonBar1.SelectedTab.Controls.Add(layoutPanel);
      layoutPanel.BackColor = Color.Transparent;
      layoutPanel.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE;
    }

    this.vRibbonBar1.SelectedTab.LayoutPanel.Controls.Add(group);
    group.Text = "Group" + this.vRibbonBar1.SelectedTab.LayoutPanel.Controls.Count;
    return group;
}
Call the AddGroup method to create a new ribbon group and then add a ribbon gallery:
CopyC#
if (this.vRibbonBar1.SelectedTab != null)
{
    vRibbonGroup myGroup = AddGroup();

    vRibbonBarGallery gallery = newvRibbonBarGallery();

    gallery.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE;
    gallery.Width = 200;
    gallery.Height = 52;
    myGroup.Content.ContentPanel.Controls.Add(gallery);
}

VB .NET:

Create an AddGroup methodthat return the new vRibbonGroup:

CopyVB.NET
Private Function AddGroup() As vRibbonGroup
    Dim group As vRibbonGroup = newvRibbonGroup()
    group.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE
    group.Width = 200
    group.Height = 76

    If Me.vRibbonBar1.SelectedTab.Controls.Count = 0 Then
      Dim layoutPanel As New vRibbonHorizontalLayoutPanel()
      layoutPanel.Dock = DockStyle.Fill
      Me.vRibbonBar1.SelectedTab.Controls.Add(layoutPanel)
      layoutPanel.BackColor = Color.Transparent
      layoutPanel.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE
    End If

    Me.vRibbonBar1.SelectedTab.LayoutPanel.Controls.Add(group)
    group.Text = "Group" & Me.vRibbonBar1.SelectedTab.LayoutPanel.Controls.Count
    Return group
End Function

Call the AddGroup method to create a new ribbon group and then add a ribbon gallery:

CopyVB.NET
If Me.vRibbonBar1.SelectedTab IsNot Nothing Then
    Dim myGroup As vRibbonGroup = AddGroup()

    Dim gallery As vRibbonBarGallery = newvRibbonBarGallery()

    gallery.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE
    gallery.Width = 200
    gallery.Height = 52
    myGroup.Content.ContentPanel.Controls.Add(gallery)
End If


Working with Ribbon Groups

[image]

VIBlend Controls for WinForms Help Documentation
Working with Ribbon Groups
Send Feedback
The easiest way to work with Ribbon Groups is to use the Visual Studio design time environment. You can add controls to the ribbon groups using simple drag-drop operations.You can also delete any control from the ribbon group by selecting it, and pressing the “Delete” key.

Working With Ribbon Bar Groups Image 1

The content of the Ribbon Group can be changed programmatically.The following code shows how to add a button to a Ribbon Group:

CopyC#
vButton button = new vButton();
button.Text = "Text";
button.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE;
this.group.Content.ContentPanel.Controls.Add(button);
CopyVB.NET
Dim button As New vButton()
button.Text = "Text"
button.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE
Me.group.Content.ContentPanel.Controls.Add(button)

You can add an image to a Ribbon Group which is displayed when the group is collapsed. To set the Ribbon Group image, use the ImageIndex, Image and ImageList properties of vRibbonGroup control.

The vRibbonGroup class provides a Content property. The Content property returns an object of type vRibbonGroupContent. The vRibbonGroupContent classcontains a property named Footer which is of type vRibbonGroupFooter and represents the footer area of the ribbon group. The footer area has a small button situated at the bottom-right corner. This button is called footer button. You can get an instance of the footer button via the FooterButton property of the vRibbonGroupFooter class.

The ShowFooterButton property of vRibbonGroup allows you to show or hide the footer button.

The FooterHeight property of vRibbonGroup allows you to set the height of the ribbon group’s footer area.

The VIBlendTheme property allows you to modify the theme of vRibbonGroup.


Working with Ribbon Galleries

[image]

VIBlend Controls for WinForms Help Documentation
Working with Ribbon Galleries
Send Feedback
Ribbon Galleries offer a convenient way to group related images. Ribbon galleries offer items scrolling functionality and an expand/open button. The following screenshot shows a Ribbon Gallery control inside a Ribbon Group:

Working With Ribbon Galleries 1

In VIBlend WinForms Controls the Ribbon galleries are represented by the vRibbonBarGallery control class. You can add on more image buttons or menu items to the ribbon gallery.

The following code adds a gallery button:

CopyC#
GalleryButton button = newGalleryButton();
button.Text = "Button";
button.Width = 50;
button.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE;
this.gallery.GalleryButtons.Add(button);
CopyVB.NET
Dim button As GalleryButton = NewGalleryButton()
button.Text = "Button"
button.Width = 50
button.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE
Me.gallery.GalleryButtons.Add(button)

To add a menu items to the ribbon bar gallery you can use the MenuItems collection.

You can also add one more groups to a Ribbon Gallery control. This can be done programmatically or using the design time environment.

Working With Ribbon Galleries 2

Adding a gallery group in design time:

Working With Ribbon Galleries 3

The sample code below demonstrates how to programmatically add a gallery group to an instance of vRibbonBarGallery and then how to associate an instance of GalleryButton to a specific gallery group.

CopyC#
RibbonBarGalleryGroup galleryGroup = newRibbonBarGalleryGroup();
galleryGroup.GroupName = "Group1";
galleryGroup.GroupHeight = 200;
this.gallery.Groups.Add(galleryGroup);
button.GalleryGroup = galleryGroup;
CopyVB.NET
Dim galleryGroup As RibbonBarGalleryGroup = NewRibbonBarGalleryGroup()
galleryGroup.GroupName = "Group1"
galleryGroup.GroupHeight = 200
Me.gallery.Groups.Add(galleryGroup)
button.GalleryGroup = galleryGroup


Working with Contextual Tabs

[image]

VIBlend Controls for WinForms Help Documentation
Working with Contextual Tabs
Send Feedback
Working With Contextual Tabs Image 1

Adding a contextual tab to vRibbonBarrequires two steps:

  1. Use the TabContext collection editor to add a tab context.

    Working With Contextual Tabs Image 2

    You can do this also programmatically using the TabContext property of vRibbonBar.

  2. To make a tab page a contextual tab you have to associate the tab page to a specific tab context. To do this, use the TabContext property of vTabPage.

Working With Contextual Tabs Image 3


KeyTips and ToolTips

[image]

VIBlend Controls for WinForms Help Documentation
KeyTips and ToolTips
Send Feedback
KeyTips and ToolTips can be used with any control. To associate a control with a key tip you can use the ContentControl property. You can also modify the keytip size which is 16x16 by default . When the Alt key is pressed the key tips are shown. The ActivationKey property specifies the key which activates the keytip. When the activation key is pressed the KeyTipActivationKeyPressed event is raised.

The vTooltip control class has a property named OwnerControl. This property specifies the owner of the vTooltip control. The tool tip will be activated when you move the mouse over the owner control.

In the screenshot below, a vTooltip control is shown when the user moves the mouse over the Font Ribbon group.

Key Tips And Tool Tips

The vToolTip control provides several methods and properties that you need to know.

You can use the IsShown property to check whether the vToolTip’s instance is shown.

The ShowToolTip method allows you to trigger the display of the vToolTip.

Respectively, the HideToolTip method allows you to hide it programmatically.

By default the tooltip will be hidden automatically after some time.

This time interval is controlled by the AutoPopDelay property.

Similarily, the InitialDelay property allows you to specify the time delay before the tool tip is shown.

In addition, you can control the appearance of the vToolTip control using properties such as – FooterText, FooterTextFont, FooterIcon, FooterTextColor, FooterTextAlignment, DescriptionText, DescriptionTextColor, DescriptionTextAlignment, Image, Font, DrawFooterLine, DrawHeaderLine, HeaderText, HeaderTextColor, HeaderTextFont, ImageAlignment, etc.


Quick access toolbar

[image]

VIBlend Controls for WinForms Help Documentation
Quick access toolbar
Send Feedback
The quick access toolbar (QAT) is a small control situated in the top-left corner of the ribbon bar next to the application button.

Quick Access Toolbar Image 1 Quick Access Toolbar Image 2

To add a quick access toolbar to vRibbonBar:

  1. Drag and drop a new instance of quick access toolbar on your Form.
  2. You can add buttons, checkboxes, radiobuttons, separators, textboxes, comboboxes, etc. You can do this entirely in design time by selecting the toolbar and then clicking the little arrow in the top-right corner. Choose one of the items from the popup menu and it will be added to the quick access toolbar:

Quick Access Toolbar Image 3

You can also do this programmatically:

CopyC#
vButton button = newvButton();
button.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE;
button.Size = newSize(16, 16);
button.Margin = newPadding(3, 0, 0, 0);

this.quickAccessToolbar1.Content.Controls.Add(button);
this.quickAccessToolbar1.Invalidate();
this.quickAccessToolbar1.Content.Invalidate();
CopyVB.NET
Dim button AsvButton = NewvButton()
button.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE
button.Size = NewSize(16, 16)
button.Margin = NewPadding(3, 0, 0, 0)

Me.quickAccessToolbar1.Content.Controls.Add(button)
Me.quickAccessToolbar1.Invalidate()
Me.quickAccessToolbar1.Content.Invalidate()

The quick access toolbar contains a drop down menu. To add menu items click the toolbar’s arrow button and a popup menu will be opened. Choose to add a new menu item or to add a separator:

Quick Access Toolbar Image 4

You can also programmatically add controls to the toolbar’s drop drown menu:

CopyC#
vApplicationMenuItem menuItem = newvApplicationMenuItem();
menuItem.Text = "CustomItem";
this.quickAccessToolbar1.DropDown.Items.Add(menuItem);
CopyVB.NET
Dim menuItem AsvApplicationMenuItem = NewvApplicationMenuItem()
menuItem.Text = "CustomItem"
Me.quickAccessToolbar1.DropDown.Items.Add(menuItem)

You can use the quick access toolbar as an independent control but in the most common scenario the control is integrated with the Ribbon Bar. In design mode, you can associate a quick access toolbar witha ribbon bar using the QuickAccessToolbar property of the ribbon bar control.

To associate the quick access toolbar to the ribbon bar programmatically:

CopyC#
this.vRibbonBar1.QuickAccessToolbar = this.quickAccessToolbar1;
this.quickAccessToolbar1.Content.PerformLayout();
this.quickAccessToolbar1.PerformLayout();
this.quickAccessToolbar1.Invalidate();
this.vRibbonBar1.Invalidate();
this.quickAccessToolbar1.Location = newPoint(this.quickAccessToolbar1.Location.X + 5, this.quickAccessToolbar1.Location.Y);
CopyVB.NET
Me.vRibbonBar1.QuickAccessToolbar = Me.quickAccessToolbar1
Me.quickAccessToolbar1.Content.PerformLayout()
Me.quickAccessToolbar1.PerformLayout()
Me.quickAccessToolbar1.Invalidate()
Me.vRibbonBar1.Invalidate()
Me.quickAccessToolbar1.Location = NewPoint(Me.quickAccessToolbar1.Location.X + 5,     Me.quickAccessToolbar1.Location.Y)


Application Button

[image]

VIBlend Controls for WinForms Help Documentation
Application Button
Send Feedback
The Ribbon application button is a rounded toggle drop down button situated in the top-left corner of the ribbon bar. You can add any windows forms control to the button’s content area.

Application Button Image 1

The application button style is slightly different in Windows7 style ribbons as shown on the following screenshot:

Application Button Image 2

To add an application button to the ribbon follow these steps:

  1. Drag and drop a new vRibbonBarApplicationButton on your Form.
  2. Open the button’s content area by clicking on it.
  3. Add controls to the content area of the application button. The content area is a standard Panel control and you can practically add any control.

    The following code snippet shows you how to add controls to the Application button’s content area:

    CopyC#
    vButton button = newvButton();
button.Location = newPoint(50, 50);
button.Text = "Text";
this.vRibbonApplicationButton1.Content.Controls.Add(button);
    CopyVB.NET
    Dim button AsvButton = NewvButton()
button.Location = NewPoint(50, 50)
button.Text = "Text"
Me.vRibbonApplicationButton1.Content.Controls.Add(button)
  4. Modify the size of the content area using the DropDownWidth and DropDownHeight properties.
  5. Associate the application button with the ribbon bar using the vRibbonBar’s ApplicationButton property.

You can also associate the application button programmatically:

CopyC#
this.vRibbonBar1.ApplicationButton = this.vRibbonApplicationButton1;

if (this.vRibbonBar1.QuickAccessToolbar != null)
{
  // reset QAT location
  this.vRibbonBar1.QuickAccessToolbar = null;
  this.vRibbonBar1.QuickAccessToolbar = this.quickAccessToolbar1;
}
CopyVB.NET
Me.vRibbonBar1.ApplicationButton = Me.vRibbonApplicationButton1

If Me.vRibbonBar1.QuickAccessToolbar IsNot Nothing Then
  ' reset QAT location
  Me.vRibbonBar1.QuickAccessToolbar = Nothing
  Me.vRibbonBar1.QuickAccessToolbar = Me.quickAccessToolbar1
End If


Minimizing the RibbonBarControl

[image]

VIBlend Controls for WinForms Help Documentation
Minimizing the RibbonBarControl
Send Feedback
The Ribbon Bar control supports minimized state where most of the content is hidden and you can see only the title, tabs, the quick access toolbar and the application button. To enable this feature set the AllowMinimizeState property to true. To minimize the ribbon bar you can double-click a tab page. To resume the state double-click the tab page again.

Minimizing The Ribbon Bar Control


Collapsing the RibbonBar groups

[image]

VIBlend Controls for WinForms Help Documentation
Collapsing the RibbonBar groups
Send Feedback
In many cases there may not be enough space for all ribbon groups.The ribbon bar automatically collapses the some of the ribbon groups to fit within the available bounds.

Collapsing The Ribbon Bar Groups Image 1

If you want to show the content of a collapsed ribbon group, you will have to click the collapsed group and its content will be shown in a popup control.

Collapsing The Ribbon Bar Groups Image 2


Navigation Controls

[image]

VIBlend Controls for WinForms Help Documentation
Navigation Controls
Send Feedback
The topics in this section will help you to become familiar with the VIBlend Navigation Controls for WinForms
  • Explorer Bar
  • Outlook Pane
  • Navigation Pane


ExplorerBar

[image]

VIBlend Controls for WinForms Help Documentation
ExplorerBar
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)

VIBlend Explorer Bar for Windows Forms is a navigation control which allows you to add and organize content inside expandable groups. The control is represented by the vExplorerBar class. Each explorer bar group is called an ExplorerBar item. The vExplorerBarItem class represents a single item from the vExplorerBar.

Explorer Bar Image 1

The height of the items content area is configurable via the ExpandedHeight property. You can also modify the header area of the items using the HeaderText, HeaderFont and HeaderHeight properties.

You can use the explorer bar control almost entirely in design time without writing any code. When you drag and drop a new instance of vExplorerBar on a Form you can add or remove explorer bar items by using the vExplorerBarItem collection editor.

Explorer Bar Image 2

To expand or collapse a vExplorerBarItem in design mode you should click the “Expand Item” or “Collapse Item” design verbs. You can use the Expanded property of the explorer bar item.

Explorer Bar Image 3

You can change item’s content area background by using the item’s BackColor property:

Explorer Bar Image 4

The item’s content area is a standard Windows Forms Panel which allows you to add any control. This can be done by dragging and dropping a control inside the item’s content area:

Explorer Bar Image 5

These tasks can also be implemented using code:

CopyC#
private vExplorerBarItem AddExplorerBarItem(
string headerText, int    imageIndex)
{
    vExplorerBarItem item = newvExplorerBarItem();
    item.ExpandedHeight = 200;
    item.Padding = Padding.Empty;
    item.Margin = Padding.Empty;
    item.HeaderText = headerText;
    item.ImageIndex = imageIndex;
    this.explorerBarPane.Items.Add(item);
    return item;
}
CopyVB.NET
Private Function AddExplorerBarItem(ByVal headerText As String, ByVal imageIndex As Integer) As vExplorerBarItem
    Dim item As vExplorerBarItem = newvExplorerBarItem()
    item.ExpandedHeight = 200
    item.Padding = Padding.Empty
    item.Margin = Padding.Empty
    item.HeaderText = headerText
    item.ImageIndex = imageIndex
    Me.explorerBarPane.Items.Add(item)
    Return item
End Function

To programmatically add a control to the vExplorerBarItem’s content area you can use the ItemPanel property:

CopyC#
private void AddControlToExplorerBarContent(
    vExplorerBarItem item,
    Control control,
    Point location)
        {
            item.ItemPanel.Controls.Add(control);
            control.Location = location;
        }
CopyVB.NET
Private Sub AddControlToExplorerBarContent(ByVal item As vExplorerBarItem, ByVal control As Control, ByVal location As Point)
            item.ItemPanel.Controls.Add(control)
            control.Location = location
End Sub

You can add an image to the header of an explorer bar item using the Image and ImageIndex properties. When using the ImageIndex property, make sure that the specified index is a correct index within an ImageList component which is associated to the vExplorerBar.

Explorer Bar Image 6

You can also add a spacing between the vExplorerBar items using the Margin property.

vExplorerBarhas a built in support of expand/collapse animations. To enable or disable the animations use the EnableToggleAnimation property. The control also supports tooltips canbe enabled or disabled using the EnableTooltips property.

The explorer bar control provides several different events. The most commonly used events are those associated with the expanding and collapsing explorer bar items. The ExpandedChanged event is raised when a specific item is expanded or collapsed.Similarly, the ExpandedChanging event is raised before the expanded state of an item changes. This even provides the option to cancel the expand or collapse action. To cancel an action simply set the Cancel property of the event arguments to true.

To expand or collapse an item, set the item's Expanded property to true/false.


Outlook Pane

[image]

VIBlend Controls for WinForms Help Documentation
Outlook Pane
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)

The Outlook-style navigation pane control is very similar to the Explorer Bar control. You can add and organize content in groups called Items. Each item in the Explorer Bar control can be expanded at any given time. The Outlook-style navigation pane is slightly different. The items are stacked on each other and at any given time only one of them is expanded. The Outlook-style navigation pane provides a splitter which the user can drag to expand the content area of the select item. It also includes buttons and a drop-down menu for quicker item selection, and items reordering.

Outlook Style Navigation Pane Image 1

The Outlook-style navigation pane is represented by the vOutlookNavPane control class. The items inside the control are represented by the vOutlookItem class. vOutlookItem has properties such as SmallImage, SmallImageIndex, LargeImage and LargeImageIndex. SmallImage and SmallImageIndex. These properties are used to set the item image which will be shown in the status area of vOutlookNavPane when the vOutlookItem is collapsed. The LargeImage and LargeImageIndex properties are used to set an image which will be shown in the item’s header next to the text. Please note that the SmallImageIndex is related to the SmallImageList and the LargeImageIndex is related to the LargeImageList in the VOutlookNavPane.

The vOutlookItem class also includes the HeaderText, HeaderFont and HeaderHeight properties which allow Text, TextFont and Header high customization.

vOutlookItem implements the INotifyPropertyChanged interface. This means that when any property value is changed, then the PropertyChanged event will be fired.

To add a new instance of vOutlookNavPane just drag and drop it on the Form.

You can a add the control programmatically:

CopyC#
private void AddOutlookNavPane()
{
    this.navPane = new vOutlookNavPane();
    this.Controls.Add(this.navPane);
    this.navPane.Dock = DockStyle.Left;
    this.navPane.Width = 250;
    this.navPane.LargeImageList = this.imageList1;
    this.navPane.SmallImageList = this.imageList1;
}
CopyVB.NET
Private Sub AddOutlookNavPane()
    Me.navPane = New vOutlookNavPane()
    Me.Controls.Add(Me.navPane)
    Me.navPane.Dock = DockStyle.Left
    Me.navPane.Width = 250
    Me.navPane.LargeImageList = Me.imageList1
    Me.navPane.SmallImageList = Me.imageList1
End Sub

Adding Items can be done programmatically or using the design-time environment:

Outlook Style Navigation Pane Image 2

CopyC#
private vOutlookItem AddOutlookItem(string headerText, int imageIndex)
{
   vOutlookItem item = new vOutlookItem();
   item.HeaderText = headerText;
   item.LargeImageIndex = imageIndex;
   item.SmallImageIndex = imageIndex;
   this.navPane.Items.Add(item);
   return item;
}
CopyVB.NET
Private Function AddOutlookItem(ByVal headerText As String, ByVal imageIndex As Integer) As vOutlookItem
   Dim item As vOutlookItem = new vOutlookItem()
   item.HeaderText = headerText
   item.LargeImageIndex = imageIndex
   item.SmallImageIndex = imageIndex
   Me.navPane.Items.Add(item)
   Return item
End Function

When you select an item the control raises the SelectionChanging and SelectionChangedevents. You can use the SelectionChanging event to cancel the selection. To cancel the selection handle the SelectionChanging event and change the value of theCancel property of the event arguments to true.When you move the resize grip, the control raises the SplitterPositionChanged event is.

The content area of each item is a standard Windows Forms Panel control. This allows you to add any control to the content area. You can do this entirely in design time without writing any code.

The following code adds a control to the content area of an Outlook-style Navigation Pane item:

CopyC#
private void AddControlToOutlookItemContent(
vOutlookItem item,
Control control,
Point location)
{
   item.Panel.Controls.Add(control);
   control.Location = location;
}
CopyVB.NET
Private Sub AddControlToOutlookItemContent(ByVal item As vOutlookItem, ByVal control As Control, ByVal location As Point)
   item.Panel.Controls.Add(control)
   control.Location = location
End Sub

If you want to hide an Outlook item from the built-in context menu, set the MenuItemVisible property to false.

If you want to disable the auto-hide behavior of the Outlook items, set the AutoHide property to false. By default, the property is set to true.


Navigation Pane

[image]

VIBlend Controls for WinForms Help Documentation
Navigation Pane
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)

The accordion style navigation pane is a type of navigational control. It is similar in functionality to the Outlook-style navigation pane and the Explorer bar controls. The accordion style navigation pane allows you to organize content in groups called items where only one of them is expanded at a time. When the user changes the selected item, the accordion navigation pane animates the transition.

Accordion Navigation Pane Image 1

The Accordion Navigation Pane is represented by the vNavPanecontrol class. You can add this control in design mode by dragging it from the Toolbox onto the Form. You can also do this programmatically by creating a new instance of vNavPane and adding it to the Form’s controls collection:

CopyC#
private void AddAccordionNavigationPane()
{
    this.accordionNavPane = new vNavPane();
    this.Controls.Add(this.accordionNavPane);
    this.accordionNavPane.Dock = DockStyle.Left;
    this.accordionNavPane.Width = 250;
    this.accordionNavPane.ImageList = this.imageList1;
}
CopyVB.NET
Private Sub AddAccordionNavigationPane()
    Me.accordionNavPane = New vNavPane()
    Me.Controls.Add(Me.accordionNavPane)
    Me.accordionNavPane.Dock = DockStyle.Left
    Me.accordionNavPane.Width = 250
    Me.accordionNavPane.ImageList = Me.imageList1
End Sub

Each item in the accordion navigation pane is represented by the vNavPaneItem class. In design mode you can add, remove and modify navigation pane items without writing any code:

Accordion Navigation Pane Image 2

To add a vNavPaneItem programmatically use the Add method of the vNavPane’s Items collection:

CopyC#
private vNavPaneItem AddNavPaneItem(string headerText, int imageIndex)
{
   vNavPaneItem item = newvNavPaneItem();
   item.HeaderText = headerText;
   item.ImageIndex = imageIndex;
   this.accordionNavPane.Items.Add(item);
   return item;
}
CopyVB.NET
Private Function AddNavPaneItem(ByVal headerText As String, ByVal imageIndex As Integer) As vNavPaneItem
   Dim item As vNavPaneItem = newvNavPaneItem()
   item.HeaderText = headerText
   item.ImageIndex = imageIndex
   Me.accordionNavPane.Items.Add(item)
   Return item
End Function

To modify the item’s header use the HeaderText, HeaderFont and HeaderHeight properties. To add an image to the caption you can use either the Image or ImageIndex property. The ImageIndex is used to select an image from the vNavPane’s ImageListimages collection. By default the property value is -1.

If you want to add a control to the vNavPaneItem’s content area, first select a caption and then drag and drop a control into the content area.

Accordion Navigation Pane Image 3

The following code demonstrates how to add a control programmatically using the ItemPanel property:

CopyC#
private void AddControlToNavPaneItemContent(vNavPaneItem item,Control control, Point location)
{
    item.ItemPanel.Controls.Add(control);
    control.Location = location;
}
CopyVB.NET
Private Sub AddControlToNavPaneItemContent(ByVal item As vNavPaneItem, ByVal control As Control, ByVal location As Point)
    item.ItemPanel.Controls.Add(control)
    control.Location = location
End Sub

When you click on a vNavPaneItem, the control raises the ExpandedChanging and ExpandedChanged events. If you want to get information whether the mouse cursor is over any of the vNavPane items you can use the HitTest() method.

vNavPane has built in support of tooltips. You can enable or disable the tooltips functionality by changing the EnableTooltips property.

If you want to programmatically expand an item, call the SelectItem method and pass the instance or the index of the item which you want to expand.

CopyC#
this.navigationPane.SelectItem(0);
CopyVB.NET
Me.navigationPane.SelectItem(0)


List Controls

[image]

VIBlend Controls for WinForms Help Documentation
List Controls
Send Feedback
The topics in this section will help you to become familiar with the VIBlend List Controls for WinForms
  • ComboBox
  • ListBox
  • CheckedListBox


ComboBox

[image]

VIBlend Controls for WinForms Help Documentation
ComboBox
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)

Combo Box Image 1

Getting Started

Te easiest way to add a vComboBox to a Form is through the Visual Studio designer. Open the Toolbox, locate the vComboBox item in the VIBlend controls group and drag it on the form. The code below adds a vComboBox to a Form at runtime:

CopyC#
using VIBlend.Controls;
...
...

vComboBox comboBox = newvComboBox ();
this.Controls.Add(comboBox);

To add or remove items,use the combobox’s Items collection. The code snippet below shows how to add items to the combo box.

CopyC#
string[,] albumNames = newstring[,]
{
   {"Linkin Park - Crawling", "2001 Rock"},
  {"Linkin Park - Dirt Off Your", "Dirt Off Your Shoulder/Lying From You"},
   {"Linkin Park - Faint", "2003 Rock"},
 {"Hybrid Theory", "Hybrid Theory (Bonus Tracks) by Linkin Park"},
   {"In The End, Pt1", "In the End, Pt. 1 by Linkin Park "},
  {"In The End, Live & Rare", "In the End: Live & Rare by Linkin Park "},
{"Karaoke Tribe", "Karaoke Tribute: More Tribute To Linkin Park“},
   {"Linkin Park X-Posed", "Linkin Park X-Posed: The Interview"},
   {"Live In Texas", "Live In Texas by Linkin Park "},
   {"Meteora", "Meteora (Bonus Tracks) by Linkin Park "},
};

for (int i = 0; i < albumNames.Length / 2; i++)
{
   ListItem item = new ListItem();
   item.Text = albumNames[i, 0];
   item.Description = albumNames[i, 1];
   item.ImageIndex = i;

   comboBoxMusicAlbums.Items.Add(item);
}
CopyVB.NET
Dim albumNames AsString(,) = NewString(, )
{ {"Linkin Park - Crawling", "2001 Rock"},
{"Linkin Park - Dirt Off Your", "Dirt Off Your Shoulder/Lying From You"},
{"Linkin Park - Faint", "2003 Rock"},
{"Hybrid Theory","Hybrid Theory (Bonus Tracks) by Linkin Park"},
{"In The End, Pt1", "In the End, Pt. 1 by Linkin Park "},
 {"In The End, Live & Rare", "In the End: Live & Rare by Linkin Park "},
{"Karaoke Tribe", "Karaoke Tribute: More Tribute To Linkin Park"},
 {"Linkin Park X-Posed", "Linkin Park X-Posed: The Interview"},
{"Live In Texas", "Live In Texas by Linkin Park "},
}

For i As Integer = 0 To albumNames.Length / 2 - 1
   Dim item As New ListItem()
   item.Text = albumNames(i, 0)
   item.Description = albumNames(i, 1)
   item.ImageIndex = i

   comboBoxMusicAlbums.Items.Add(item)
Next i

You can use the DropDownHeight and DropDownWidth properties to specify the default size of the combobox’s popup window. Toset the combo item’s height, use the ItemHeight property of the vComboBox class.

vComboBox supports the AutoComplete feature.You can enable/disable it by using the AutoCompleteEnabled property. When a selection is changed, the SelectedIndexChanged event is fired. When the selected item is changed two more events are fired - SelectedItemChanging and SelectedItemChanged events. You can use the SelectedItemChanging event to cancel the selection.

Themes

VIBlend Controls for Windows Forms ships with several built-in themes. Each control in the library exposes a property called VIBlendTheme. Set this property to one of the built-in themes. At design time you can change the VIBlendTheme through the control properties. The VIBlendTheme property is located within the Appearance group of the control properties. The code below changes the theme of a combo box at runtime:

CopyC#
using VIBlend.Controls;
    using VIBlend.Utilities;
    ...
    ...

    comboBox.VIBlendTheme = VIBLEND_THEME.ULTRABLUE;

User Defined Themes

All controls in the VIBlend Controls for Windows Forms library expose a Theme property. You can use it to set a control’s theme to a user defined theme. The code below loads a user defined theme from a XML file and assigns to a combo box control:

CopyC#
private bool SetCustomTheme()
{
  ControlTheme theme = newControlTheme();
  if (false == theme.LoadFromXml(@"c:\MyThemes\myCustomTheme.xml"))
  return false;

  comboBox.Theme = theme;

  return true;
}
CopyVB.NET
Private Function SetCustomTheme() As Boolean
  Dim theme As ControlTheme = newControlTheme()
  If False = theme.LoadFromXml("c:\MyThemes\myCustomTheme.xml") Then
  Return False
  End If

  comboBox.Theme = theme

  Return True
End Function

You can select an item in the ComboBox control by using the SelectedIndex property.

CopyC#
this.comboBoxStockMarket.SelectedIndex = 0;
CopyVB.NET
Me.comboBoxStockMarket.SelectedIndex = 0
 The SelectedIndexChanged event is raised when you set this property.

The VIBlend ComboBox control has a built-in auto complete feature. You can enable it by setting the AutoCompleteEnabled property to true.

You can specify the ComboBox Popup's Size by setting the DropDownWidth and DropDownHeight properties.

For example:

CopyC#
this.comboBoxPropertiesDemo.DropDownWidth = 300;
this.comboBoxPropertiesDemo.DropDownHeight = 300;
CopyVB.NET
Me.comboBoxPropertiesDemo.DropDownWidth = 300
Me.comboBoxPropertiesDemo.DropDownHeight = 300

In order to bind the ComboBox control, you need to set its DataSource property. If you want to sort the items collection call the Sort method. The RemoveSort method allows you to clear the sorting. You can also specify a custom sorting by implementing the IComparer interface. Then you can create a new instance of the custom class and pass it as a parameter to the Sort method. You can use the vFontComboBoxcontrol if you want to choose fonts in your application. The vFontComboBox control automatically loads all fonts from the FontFamily class.


ListBox

[image]

VIBlend Controls for WinForms Help Documentation
ListBox
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)

List Box Image 1

Getting Started

The easiest way to add a vListBox to a Form is through the Visual Studio designer. Open the Toolbox, locate the vListBox item in the VIBlend controls group and drag it on the form.

The code below adds a vListBox to a Form at runtime:

CopyC#
using VIBlend.Controls;
    ...
    ...

    vComboBox comboBox = newvComboBox ();
    this.Controls.Add(listBox);

To add or remove items you can use the listbox’s Items collection. The code snippet below shows how to add items to the listbox.

CopyC#
string[,] albumNames = newstring[,]
{
   {"Linkin Park - Crawling", "2001 Rock"},
  {"Linkin Park - Dirt Off Your", "Dirt Off Your Shoulder/Lying From You"},
   {"Linkin Park - Faint", "2003 Rock"},
 {"Hybrid Theory", "Hybrid Theory (Bonus Tracks) by Linkin Park"},
   {"In The End, Pt1", "In the End, Pt. 1 by Linkin Park "},
  {"In The End, Live & Rare", "In the End: Live & Rare by Linkin Park "},
{"Karaoke Tribe", "Karaoke Tribute: More Tribute To Linkin Park“},
   {"Linkin Park X-Posed", "Linkin Park X-Posed: The Interview"},
   {"Live In Texas", "Live In Texas by Linkin Park "},
   {"Meteora", "Meteora (Bonus Tracks) by Linkin Park "},
};

for (int i = 0; i < albumNames.Length / 2; i++)
{
     ListItem item = newListItem();
     item.Text = albumNames[i, 0];
     item.Description = albumNames[i, 1];
     item.ImageIndex = i;
     listBoxPropertiesDemo.Items.Add(item);
}
CopyVB.NET
Dim albumNames AsString(,) = NewString(, )
{ {"Linkin Park - Crawling", "2001 Rock"},
{"Linkin Park - Dirt Off Your", "Dirt Off Your Shoulder/Lying From You"},
{"Linkin Park - Faint", "2003 Rock"},
{"Hybrid Theory","Hybrid Theory (Bonus Tracks) by Linkin Park"},
{"In The End, Pt1", "In the End, Pt. 1 by Linkin Park "},
 {"In The End, Live & Rare", "In the End: Live & Rare by Linkin Park "},
{"Karaoke Tribe", "Karaoke Tribute: More Tribute To Linkin Park"},
 {"Linkin Park X-Posed", "Linkin Park X-Posed: The Interview"},
{"Live In Texas", "Live In Texas by Linkin Park "},
}

For i As Integer = 0 To albumNames.Length / 2 - 1
     Dim item As ListItem = newListItem()
     item.Text = albumNames(i, 0)
     item.Description = albumNames(i, 1)
     item.ImageIndex = i
     listBoxPropertiesDemo.Items.Add(item)
Next i

If you want to select an item programmatically you can use the SelectedIndex or SelectedItem properties. When a selection is changed, the SelectedIndexChanged event is fired. When the selected item is changed two more events are fired - SelectedItemChanging and SelectedItemChanged events. You can use the SelectedItemChanging event to cancel the selection.

You can enable the mouse hot tracking by using the HotTrack property.

The following code demonstrates how to bind the listbox to a list of strings.

CopyC#
string[] list = newstring[]
{
 "Andrew Fuller",
 "Nancy Davolio",
 "Shelley Burke",
 "Regina Murphy",
 "Yoshi Nagase",
 "Antonio del Valle Saavedra",
 "Mayumi Ohno",
 "Ian Devling",
 "Peter Wilson",
 "Lars Peterson",
 "Petra Winkler",
 "Martin Bein",
 "Sven Petersen",
 "Elio Rossi",
 "Beate Vileid",
 "Cheryl Saylor",
 "Michael Björn",
 "Guylène Nodier"
};

this.listBoxDataBinding.Items.Clear();
this.listBoxDataBinding.DataSource = list;
CopyVB.NET
Dim list AsString() = NewString() { "Andrew Fuller", "Nancy Davolio", "Shelley Burke", "Regina Murphy", "Yoshi Nagase", "Antonio del Valle Saavedra", "Mayumi Ohno", "Ian Devling", "Peter Wilson", "Lars Peterson", "Petra Winkler", "Martin Bein", "Sven Petersen", "Elio Rossi", "Beate Vileid", "Cheryl Saylor", "Michael Björn", "Guylène Nodier" }

Me.listBoxDataBinding.Items.Clear()
Me.listBoxDataBinding.DataSource = list

Themes

VIBlend Controls for Windows Forms ships with several built-in themes. Each control in the library exposes a property called VIBlendTheme. Set this property to one of the built-in themes. At design time you can change the VIBlendTheme through the control properties. The VIBlendTheme property is located within the Appearance group of the control properties. The code below changes the theme of a combo box at runtime:

CopyC#
using VIBlend.Controls;
    using VIBlend.Utilities;
    ...
    ...

    listbox.VIBlendTheme = VIBLEND_THEME.ULTRABLUE;

User Defined Themes

All controls in the VIBlend Controls for Windows Forms library expose a Theme property. You can use it to set a control’s theme to a user defined theme. The code below loads a user defined theme from a XML file and assigns to a listbox control:

CopyC#
private bool SetCustomTheme()
{
  ControlTheme theme = new ControlTheme();
  if (false == theme.LoadFromXml(@"c:\MyThemes\myCustomTheme.xml"))
  returnfalse;

  listbox.Theme = theme;

  return true;
}
CopyVB.NET
Private Function SetCustomTheme() As Boolean
  Dim theme As New ControlTheme()
  If False = theme.LoadFromXml("c:\MyThemes\myCustomTheme.xml") Then
  returnfalse
  End If

  listbox.Theme = theme

  Return True
End Function

- Data Binding to a custom data source.

Create a custom data class that will represent a single item in the ListBox control.

CopyC#
public class EmployeeSales : INotifyPropertyChanged
{
    public EmployeeSales(string Name, DateTime Date, int ProductId, int Quantity)
    {
        this.Name = Name;
        this.Date = Date;
        this.ProductId = ProductId;
        this.Quantity = Quantity;
    }

    #region Private Members
    private string _name;
    private DateTime _date;
    private int _productid;
    private int _quantity;
    #endregion

    #region Properties

    public string Name
    {
        get { return _name; }
        set { _name = value; this.OnPropertyChanged("Name"); }
    }

    public DateTime Date
    {
        get { return _date; }
        set { _date = value; this.OnPropertyChanged("Date"); }
    }

    public string ProductName
    {
        get { return productNames[_productid, 0]; }
        set
        {
            for (int i = 0; i < productNames.Length / 2; i++)
                if (productNames[i, 0] == value)
                {
                    _productid = i;
                    break;
                }

            this.OnPropertyChanged("ProductName");
        }

    }

    public double SalesAmount
    {
        get { return (double)_quantity * UnitPrice; }
    }

    public double UnitPrice
    {
        get
        {
            double unitPrice = double.Parse(productNames[_productid, 1], CultureInfo.InvariantCulture);
            return unitPrice;
        }
    }

    public int Quantity
    {
        get { return _quantity; }
        set
        {
            _quantity = value;
            this.OnPropertyChanged("Quantity");
        }
    }

    public int ProductId
    {
        get { return _productid; }
        set
        {
            _productid = value;
            this.OnPropertyChanged("ProductId");
        }
    }

    #endregion

    #region INotifyPropertyChanged Members

    public event PropertyChangedEventHandler PropertyChanged;

    protected virtual void OnPropertyChanged(string propertyName)
    {
        if (this.PropertyChanged != null)
        {
            this.PropertyChanged(this, new PropertyChangedEventArgs(propertyName));
        }
    }
    #endregion
}
CopyVB.NET
Public Class EmployeeSales
    Implements INotifyPropertyChanged
    Public Sub New(ByVal Name As String, ByVal [Date] As DateTime, ByVal ProductId As Integer, ByVal Quantity As Integer)
        Me.Name = Name
        Me.Date = [Date]
        Me.ProductId = ProductId
        Me.Quantity = Quantity
    End Sub

    #Region "Private Members"
    Private _name As String
    Private _date As DateTime
    Private _productid As Integer
    Private _quantity As Integer
    #End Region

    #Region "Properties"

    Public Property Name() As String
        Get
            Return _name
        End Get
        Set(ByVal value As String)
            _name = value
            Me.OnPropertyChanged("Name")
        End Set
    End Property

    Public Property [Date]() As DateTime
        Get
            Return _date
        End Get
        Set(ByVal value As DateTime)
            _date = value
            Me.OnPropertyChanged("Date")
        End Set
    End Property

    Public Property ProductName() As String
        Get
            Return productNames(_productid, 0)
        End Get
        Set(ByVal value As String)
            For i As Integer = 0 To productNames.Length / 2 - 1
                If productNames(i, 0) = value Then
                    _productid = i
                    Exit For
                End If
            Next i

            Me.OnPropertyChanged("ProductName")
        End Set

    End Property

    Public ReadOnly Property SalesAmount() As Double
        Get
            Return CDbl(_quantity) * UnitPrice
        End Get
    End Property

    Public ReadOnly Property UnitPrice() As Double
        Get
            Dim unitPrice_Renamed As Double = Double.Parse(productNames(_productid, 1), CultureInfo.InvariantCulture)
            Return unitPrice_Renamed
        End Get
    End Property

    Public Property Quantity() As Integer
        Get
            Return _quantity
        End Get
        Set(ByVal value As Integer)
            _quantity = value
            Me.OnPropertyChanged("Quantity")
        End Set
    End Property

    Public Property ProductId() As Integer
        Get
            Return _productid
        End Get
        Set(ByVal value As Integer)
            _productid = value
            Me.OnPropertyChanged("ProductId")
        End Set
    End Property

    #End Region

    #Region "INotifyPropertyChanged Members"

    Public Event PropertyChanged As PropertyChangedEventHandler

    Protected Overridable Sub OnPropertyChanged(ByVal propertyName As String)
        If Me.PropertyChangedEvent IsNot Nothing Then
            RaiseEvent PropertyChanged(Me, New PropertyChangedEventArgs(propertyName))
        End If
    End Sub
    #End Region
End Class

Create data that will be used when we fill a list of EmployeeSales

CopyC#
#region Data
string[] firstNames = new string[]
        {
            "Andrew",
            "Nancy",
            "Shelley",
            "Regina",
            "Yoshi",
            "Antoni",
            "Mayumi",
            "Ian",
            "Peter",
            "Lars",
            "Petra",
            "Martin",
            "Sven",
            "Elio",
            "Beate",
            "Cheryl",
            "Michael",
            "Guylène"
        };

string[] lastNames = new string[]
        {
            "Fuller",
            "Davolio",
            "Burke",
            "Murphy",
            "Nagase",
            "Saavedra",
            "Ohno",
            "Devling",
            "Wilson",
            "Peterson",
            "Winkler",
            "Bein",
            "Petersen",
            "Rossi",
            "Vileid",
            "Saylor",
            "Björn",
            "Nodier"
        };

static string[,] productNames = new string[,]
        {
            {"Black Tea", "1.95"},
            {"Green Tea", "1.95"},
            {"Caffe Espresso", "1.45"},
            {"Doubleshot Espresso", "1.75"},
            {"Caffe Latte", "2.25"},
            {"White Chocolate Mocha", "2.35"},
            {"Cramel Latte", "2.35"},
            {"Caffe Americano", "1.65"},
            {"Cappuccino", "2.10"},
            {"Espresso Truffle", "2.45"},
            {"Espresso con Panna", "1.81"},
            {"Peppermint Mocha Twist", "1.99"}
        };
#endregion
CopyVB.NET
Private firstNames() As String = { "Andrew", "Nancy", "Shelley", "Regina", "Yoshi", "Antoni", "Mayumi", "Ian", "Peter", "Lars", "Petra", "Martin", "Sven", "Elio", "Beate", "Cheryl", "Michael", "Guylène" }

Private lastNames() As String = { "Fuller", "Davolio", "Burke", "Murphy", "Nagase", "Saavedra", "Ohno", "Devling", "Wilson", "Peterson", "Winkler", "Bein", "Petersen", "Rossi", "Vileid", "Saylor", "Björn", "Nodier" }

Private Shared productNames(,) As String = { {"Black Tea", "1.95"}, {"Green Tea", "1.95"}, {"Caffe Espresso", "1.45"}, {"Doubleshot Espresso", "1.75"}, {"Caffe Latte", "2.25"}, {"White Chocolate Mocha", "2.35"}, {"Cramel Latte", "2.35"}, {"Caffe Americano", "1.65"}, {"Cappuccino", "2.10"}, {"Espresso Truffle", "2.45"}, {"Espresso con Panna", "1.81"}, {"Peppermint Mocha Twist", "1.99"} }

Prepare the ListBox data

CopyC#
public BindingList<EmployeeSales> lst = new BindingList<EmployeeSales>();

private void PrepareGridData()
{
    if (lst.Count < rowsToLoad)
    {
        lst.Clear();

        Random rand = new Random();

        for (int i = 0; i < rowsToLoad; i++)
        {
            int productId = rand.Next(0, productNames.Length / 2 - 1);
            int quantity = rand.Next(1, 5);
            lst.Add(new EmployeeSales(
                string.Format("{0} {1}", firstNames[rand.Next(0, firstNames.Length - 1)], lastNames[rand.Next(0, lastNames.Length - 1)]),
                DateTime.Now.AddDays(-rand.Next(10, 100)).AddSeconds(-rand.Next(10, 10000)),
                productId,
                quantity)
                );
        }
    }
}
CopyVB.NET
Public lst As BindingList(Of EmployeeSales) = New BindingList(Of EmployeeSales)()

Private Sub PrepareGridData()
    If lst.Count < rowsToLoad Then
        lst.Clear()

        Dim rand As New Random()

        For i As Integer = 0 To rowsToLoad - 1
            Dim productId As Integer = rand.Next(0, productNames.Length / 2 - 1)
            Dim quantity As Integer = rand.Next(1, 5)
            lst.Add(New EmployeeSales(String.Format("{0} {1}", firstNames(rand.Next(0, firstNames.Length - 1)), lastNames(rand.Next(0, lastNames.Length - 1))), DateTime.Now.AddDays(-rand.Next(10, 100)).AddSeconds(-rand.Next(10, 10000)), productId, quantity))
        Next i
    End If
End Sub

Set the DataSource property of the ListBox to point to the list with EmployeeSales records.

CopyC#
this.listBoxDataBinding.DataSource = lst;
CopyVB.NET
Me.listBoxDataBinding.DataSource = lst

You need to set the DisplayMember property. This property specifies the data-source property that will be displayed as text in the list items.

CopyC#
this.listBoxDataBinding.DisplayMember = "Name";
CopyVB.NET
Me.listBoxDataBinding.DisplayMember = "Name"


CheckedListBox

[image]

VIBlend Controls for WinForms Help Documentation
CheckedListBox
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)

Represents a ListBox control in which a check box is displayed to the left of each item.

Checked List Box Image 1

This control presents a list of items that the user can navigate by using the keyboard or the scrollbar on the right side of the control. The user can place a check-mark on one or more items.

The ListItem object supports two check states: true and false. You must set the state to null in the code because the UI for a vCheckedListBox does not provide a mechanism to do so. If CheckOnClick is true, the ListItem’s state will be changed on every mouse click.

The vCheckedListBox class supports the following collections:

Items collection – presents the list of the vCheckedListBoxItems.

The following code illustrates how you can use the methods of a vCheckedListBox to check and uncheck items:

CopyC#
// checks all list items.
checkedListBox1.CheckAllItems();
// unchecks all list items.
checkedListBox1.UnCheckAllItems();
CopyVB.NET
' checks all list items.
checkedListBox1.CheckAllItems()
' unchecks all list items.
checkedListBox1.UnCheckAllItems()

To check or uncheck an item through the API, use the CheckItem and UnCheckItem methods. The ItemCheckedChanged event occurs when the check state of a ListItem is changed.


Editors

[image]

VIBlend Controls for WinForms Help Documentation
Editors
Send Feedback
The topics in this section will help you to become familiar with the VIBlend Editors for WinForms
  • DateTimePicker and DateTimeEditor
  • Numeric Editors
  • Numeric UpDown


DateTimePicker and DateTimeEditor

[image]

VIBlend Controls for WinForms Help Documentation
DateTimePicker and DateTimeEditor
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)

Date Time Picker And Date Time Editor 1

Working with DateTimePicker and DateTimeEditor

To set a value in vDataTimePicker and in vDateTimeEditor you should use the Value property. The ValueChanged event occurs when the datetime value is changed.

You can restrict the valid date time range in the datetimepicker by using the MaxDate and MinDate properties. If you want to modify the properties of the built-in calendar you can use the Calendar property. To modify the popup calendar’s size you can use the DropDownWidth and DropDownHeight properties. You can also get the instance of the popup control which hosts the calendar by using the DropDown property.

You can modify the formatting of the text by using the FormatValue string property.

To enable the popup resize grip you can use the ShowGrip property.

Date Time Picker And Date Time Editor 2

vDateTimeEditor is the editor control used internally in the vDateTimePicker. You can easily set vDateTimeEditor’s value, formatting and theme in design mode. You can also use the FormatValue property to specify a custom formatting.

Date Time Picker And Date Time Editor 3

Format

To change the format string, use the FormatValue property. Use the DefaultDateTimeFormat property to choose one of the predefined settings such as ShortDatePattern, LongDatePattern,ShortTimePattern, LongTimePattern,UniversalSortableDateTimePattern, RFC1123Pattern, etc. When you modify the DefaultDateTimeFormat property the FormatValue property will be updated. FormatValue property accepts the following standard codes:

d - Short date pattern

D - Long date pattern

f - Full date and time (long date and short time)

F - Full date time pattern (long date and long time)

g - General (short date and short time)

G - General (short date and long time)

m, M -Month day pattern

r, R - RFC1123 pattern

s - Sortable date time pattern (based on ISO 8601) using local time

t -Short time pattern

T - Long time pattern You can also make a custom format string which you can use as a FormatValue string.

dd - numeric day of the month.

ddd - abbreviated name of the day of the week.

M - Month name followed by the numeric day.

MM - numeric month.

MMM - abbreviated name of the month.

MMMM - full name of the month.

y - year numeric

yy - year without the century

yyy - year including the century

h or hh - hour in a 12-hour clock

H or HH - hour in a 24-hour clock

m or mm - minute.

s or ss - second.

t - The first character in the AM/PM designator.

tt - The AM/PM designator.

In vDateTimePicker you can access the built in vDateTimeEditor control by using the DateTimeEditor property.

vDateTimeEditor and vDateTimePicker support a culture specific text and datetime formatting which you can specify by using the Culture property.


Numeric Editors

[image]

VIBlend Controls for WinForms Help Documentation
Numeric Editors
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)
Numeric Editors Image 1

Fraction Part

You can use the DecimalPlaces integer property to modify the number of digits after the decimal separator.

Culture Settings

You can use the CultureInfo property to change the default formatting settings of any editor control. The CultureInfo class is in the System.Globalization namespace.

CopyC#
CultureInfo info = newCultureInfo("fr-FR");
this.CurrencyEditor.CultureInfo = info;
CopyVB.NET
Dim info As CultureInfo = NewCultureInfo("fr-FR")
Me.CurrencyEditor.CultureInfo = info

Spin Behavior

NumberEditor, DecimalEditor, CurrencyEditor, FixedPointEditor and PercentageEditor support four different types of spin behavior – None, SpinDigit, SpinDigitWithWrap and SpinValueBeforeDigit.

CopyC#
this.NumberEditor.SpinType = VIBlend.Controls.SpinType.SpinValueBeforeDigit;
this.CurrencyEditor.SpinType = VIBlend.Controls.SpinType.SpinValueBeforeDigit;
this.PercentageEditor.SpinType = VIBlend.Controls.SpinType.SpinValueBeforeDigit;
this.FixedPointEditor.SpinType = VIBlend.Controls.SpinType.SpinValueBeforeDigit;
this.DecimalEditor.SpinType = VIBlend.Controls.SpinType.SpinValueBeforeDigit;
CopyVB.NET
Me.NumberEditor.SpinType = VIBlend.Controls.SpinType.SpinValueBeforeDigit
Me.CurrencyEditor.SpinType = VIBlend.Controls.SpinType.SpinValueBeforeDigit
Me.PercentageEditor.SpinType = VIBlend.Controls.SpinType.SpinValueBeforeDigit
Me.FixedPointEditor.SpinType = VIBlend.Controls.SpinType.SpinValueBeforeDigit
Me.DecimalEditor.SpinType = VIBlend.Controls.SpinType.SpinValueBeforeDigit

Undo/Redo behavior

NumberEditor, DecimalEditor, CurrencyEditor, FixedPointEditor and PercentageEditor support unlimited undo/redo. If you want to undo the current value you should call the Undo() method. To redo the value call the Redo() method.

Negative values

To make the editor’s Value a negative value you should press the ‘-‘key. If you press the ‘-‘key again the value will be positive.

Keyboard Support

Left key – moves the caret position one position left.

Right key – moves the caret position one position right.

Shift + Left key – expands the selection with one character in the left direction.

Shift + Right key – expands the selection with one character in the right direction.

Up – increments the Value if the SpinType property value is not SpinType.None.

Down – decrements the Value if the SpinType property value Is not SpinType.None.

Home – moves the caret position to the first character.

End – moves the caret position to the last character.

Del – deletes the current character.

Backspace – deletes the current character and moves one position left.

F2 – deletes the whole Value.

Ctrl + C – copy the current selected value.

Ctrl + X – cut the current selected value.

Ctrl + V – paste the saved value.

Ctrl + Y – Redo operation

Ctrl + Z – Undo operation

Ctrl + A – selects all text.

MouseWheel Support

Increments or decrements the current value if the SpinType property value is not SpinType.None.

Events

ValueChanging –occurs when the current value is changing. You can use the event arguments to Cancel the operation.

ValueChanged – occurs when the editor’s value is already changed.

ValidationError –occurs when the Value property of the Editor is not in the valid range specified by the Minimum and Maximum properties.


NumericUpDown

[image]

VIBlend Controls for WinForms Help Documentation
NumericUpDown
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)

Numeric Up Down

You can use the vNumericUpDown control to edit integer values.

If you want to change the value programmatically you can use the Value property.

You can restrict the available values range by using the Maximum and Minimum properties. Use the Increment property to change the step which affects the value when the up or down button is pressed.

When the value is changed, the ValueChanged event is fired. To change the control’s theme, use the VIBlendTheme property.


Common Controls

[image]

VIBlend Controls for WinForms Help Documentation
Common Controls
Send Feedback
The topics in this section will help you to become familiar with the VIBlend Common Controls for WinForms
  • CheckBox
  • RadioButton
  • Month Calendar
  • Progress Bar
  • Track Bar
  • Text Box
  • Buttons
  • TreeViewBox and ColorPicker
  • Panels


Check Box

[image]

VIBlend Controls for WinForms Help Documentation
Check Box
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)
Check Box Image 1

Overview

VIBlend vCheckBox provides a great alternative to the standard Windows Forms CheckBox control.

You can easily make your applications gain the stylish Office 2007 and Windows Vista look and feel in less than a minute.

Features

  • Support for 3-State mode
  • Animations
  • Themes
  • Theme Colors Override
  • RightToLeft style

Example

You can use the vCheckBox control by dragging it from the Toolbox on your form.

The following code example creates and initializes a vCheckBox programmatically:

CopyC#
public void InstantiateMyCheckBox()
{
   // Create and initialize a vCheckBox.
   vCheckBox vCheckBox1 = new vCheckBox();

   // Make the check box control appear as a toggle button
   vCheckBox1.VIBlendTheme = VIBLEND_THEME.BLUEBLEND;
   vCheckBox1.ThreeState = true;

    // Turn off the update of the display on the click of the control
    checkBox1.AutoCheck = false;

    // Add the check box control to the form
    Controls.Add(checkBox1);
}
CopyVB.NET
Public Sub InstantiateMyCheckBox()
   ' Create and initialize a vCheckBox.
   Dim vCheckBox1 As New vCheckBox()

   ' Make the check box control appear as a toggle button
   vCheckBox1.VIBlendTheme = VIBLEND_THEME.BLUEBLEND
   vCheckBox1.ThreeState = True

    ' Turn off the update of the display on the click of the control
    checkBox1.AutoCheck = False

    ' Add the check box control to the form
    Controls.Add(checkBox1)
End Sub

In order to enable the ThreeState mode, you should set the ThreeState property to true. When the three state mode is enabled, the CheckBox control supports the following states: Checked, Unchecked(mixed) and Indeterminate.

CopyC#
vCheckBox1.ThreeState = true;
CopyVB.NET
vCheckBox1.ThreeState = True
 If the ThreeState property is set to false, the CheckState property value can only be set to the Indeterminate value of System.Windows.Forms.CheckState in code and not by user interaction.


Month Calendar

[image]

VIBlend Controls for WinForms Help Documentation
Month Calendar
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)

VIBlend Month Calendar for Windows Forms is a stylish calendar control that gives your application professional look and feel. The control has built-in support for more than fifteen animated themes such as those found in popular Office applications.

Month Calendar Image 1

The calendar control is represented by the vMonthCalendar control class. You can add the control by dragging it from the ToolBox onto your Form, or creating a new instance of vMonthCalendar and adding it to the Form’s Controls collection. The calendar control provides a rich set of APIs. It also offers globalization settings support. You can set any CultureInfo object to the calendar’s Culture property and it will refresh and render itself with the culture specific formatting.

Below is a description of the most common properties, methods and events:

The CurrentDate property allows you to get the currently selected date. You can also set the property and navigate to a specific date . TheNavigationStartDate and NavigationEndDate properties restrict the available navigation range.

The calendar control provides keyboard navigation support which is controlled by the EnableKeyboardNavigation property. If you want to enable or disable the keyboard navigation simply change the property’s value to true or false.

You can use the EnableMultipleSelection and EnableSelection properties enable or disable the selection of multiple items or completely switch on/off the selection feature.

The EnableNavigation property enables or disables the navigation.

The EnableQuickNavigation property enables or disables the navigation when you click on the calendar’s title and use the other calendar views.

Month Calendar Image 2

The ShowRowHeader and ShowColumnHeader properties control the visibility of the headers that show the week numbers and the names of the week days.

You can also change the start day of the week which is rendered by the calendar by using the StartDayOfWeek property.

Month Calendar Image 3

The calendar control allows you to hide the days which are not from the current calendar’s month using the ShowDifferentMonthDates property.

The styles of the weekend cells and the cells with dates which are not from the current month can be enabled or disabled using the DrawCellDifferentMonthStyle and DrawCellWeekendStyle properties.

Sometimes we need to mark a special day such as a business meeting, birthday, etc. on our calendar. A unique feature in VIBlend Calendar for Windows Forms is the appointments functionality.Just create a new instance of the vAppointment class and add it to the Appointments collection of vMonthCalendar.When you add any appointments to the calendar you can show or hide them using the ShowAppointments property.

Month Calendar Image 4

CopyC#
vAppointment appointment = new vAppointment();
appointment.Date = DateTime.Now.Date.AddDays(1);
this.vMonthCalendar1.Appointments.Add(appointment);
this.vMonthCalendar1.CurrentDate = DateTime.Now.Date;
CopyVB.NET
Dim appointment As vAppointment = NewvAppointment()
appointment.Date = DateTime.Now.Date.AddDays(1)
Me.vMonthCalendar1.Appointments.Add(appointment)
Me.vMonthCalendar1.CurrentDate = DateTime.Now.Date

You can also add a recurrence pattern to an appointment using the RecurrenceRule property:

CopyC#
appointment.RecurrenceRule = RecurrenceRule.Daily;
appointment.DayPattern.DaysToNextOccurence = 3;
CopyVB.NET
appointment.RecurrenceRule = RecurrenceRule.Daily
appointment.DayPattern.DaysToNextOccurence = 3

You can also assign a vTooltip control to an appointment using its VToolTip property.

CopyC#
VToolTip toolTip = new VToolTip();
appointment.VToolTip = toolTip;
CopyVB.NET
VToolTip toolTip = NewVToolTip()
appointment.VToolTip = tooltip

Month Calendar Image 5

Use the following code to customize the appearance of the tooltip:

CopyC#
this.vToolTip1.HeaderText = "Travelling to Miami";
this.vToolTip1.HeaderTextAlignment = ContentAlignment.TopLeft;
this.vToolTip1.HeaderTextColor =SystemColors.ControlText;
this.vToolTip1.HeaderTextFont = new System.Drawing.Font(
"Microsoft Sans Serif", 9F, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, ((byte)(204)));
this.vToolTip1.Image = global::IntegratedDemo.Properties.Resources.carImage;
this.vToolTip1.ImageAlignment =ContentAlignment.MiddleCenter;
this.vToolTip1.ImageRelativeSizeProportion = new System.Drawing.SizeF(1F, 0.8F);
CopyVB.NET
Me.vToolTip1.HeaderText = "Travelling to Miami"
Me.vToolTip1.HeaderTextAlignment = ContentAlignment.TopLeft
Me.vToolTip1.HeaderTextColor =SystemColors.ControlText
Me.vToolTip1.HeaderTextFont = New System.Drawing.Font("Microsoft Sans Serif", 9F, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, (CByte(204)))
Me.vToolTip1.Image = Global.IntegratedDemo.Properties.Resources.carImage
Me.vToolTip1.ImageAlignment =ContentAlignment.MiddleCenter
Me.vToolTip1.ImageRelativeSizeProportion = New System.Drawing.SizeF(1F, 0.8F)

The calendar control allows you to mark the item that represents the current day using a different style. This option is controlled by the ShowTodayCell property which you can set to true or false.

The ShowRowHeaderLine and ShowColumnHeaderLine properties allow you to control the visibility of the horizontal and vertical lines which are displayed below the column header and next to the rows header.

The ShowNavigationArrows property allows you to show or hide the calendar’s navigation arrows.

You can change the Font and TextAlignment of the calendar items using the CellFont and CellTextAlignment properties.

You can change calendar’s title height using the TitleHeight property. You can also change the formatting of the strings in the title using the TitleFormatDayString, TitleFormatEndCenturyString, TitleFormatEndYearString, TitleFormatMonthString, TitleFormatStartCenturyString and TitleFormatStartYearString properties.

The SelectedDate property allows you to select a date in the calendar. If you want to get the collection of selected dates or add selected dates, use the SelectedDates property. When the user clicks on a cell, the control raises theSelectionChanging and SelectionChanged events. If you add an event handler for the SelectionChanging event, the event arguments provide a Cancel property. Setting the value of the Cancel property to true allows you to cancel the selection.

If you need to programmatically navigate to a Date, you can use the CurrentDate property of the VIBlend Calendar control to navigate to a specific date.

CopyC#
this.vMonthCalendar1.CurrentDate = DateTime.Now.Date;
CopyVB.NET
Me.vMonthCalendar1.CurrentDate = DateTime.Now.Date


Progress Bars

[image]

VIBlend Controls for WinForms Help Documentation
Progress Bars
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)

Overview

VIBlend vProgressBar and vCircularProgressBar are controls which indicate a progress of a process. A progress bar control visually indicates the progress of a lengthy operation

The Maximum and Minimum properties define the range of values that represent the progress of a task. The Minimum property is typically set to a value of 0, and the Maximum property is typically set to a value indicating the completion of a task. For example, to properly display the progress when copying a group of files, the Maximum property could be set to the total number of files to be copied.

The Value property represents the progress that the application has made toward completing the operation. The value displayed by the vProgressBar only approximates the current value of the Value property. Based on the size of the vProgressBar, the Value property determines when to display the next block or increase the size of the bar.

There are a number of ways to modify the value displayed by the vProgressBar other than changing the Value property directly. You can use the Step property to specify a specific value to increment the Value property by, and then call the PerformStep method to increment the value. To vary the increment value, you can use the Increment method and specify a value with which to increment the Value property.

  • Value - this property indicates the current progress value.
  • Minimum - the lower bound of the progress
  • Maximum - the upper bound of the progress
  • Step - the amount to jump the current value when the PerformStep method is called
  • PerformStep - increments the current value by a specified step
  • PerformStepBack - decrements the current value by a specified step

Getting Started

You can add a vProgressBar to a Form using the Visual Studio designer. Open the Toolbox, locate the vProgressBar item in the VIBlend controls group and drag it on the form.

The code below adds a vProgressBar to a Form at runtime:

CopyC#
using VIBlend.Controls;
...
...

vProgressBar vProgressBar = newvProgressBar ();
this.Controls.Add(vProgressBar);
CopyVB.NET
Imports VIBlend.Controls
..
..
Dim vProgressBar As vProgressBar = New vProgressBar ()
Me.Controls.Add(vProgressBar)

Themes

VIBlend Controls for Windows Forms ships with several built-in themes. Each control in the library exposes a property called VIBlendTheme. Set this property to one of the built-in themes.

At design time you can change the VIBlendTheme through the control properties. The VIBlendTheme property is located within the Appearance group of the control properties.

The code below changes the theme of a vProgressBar runtime:

CopyC#
using VIBlend.Controls;
using VIBlend.Utilities;
…
…

vProgressBar.VIBlendTheme = VIBLEND_THEME.ULTRABLUE;
CopyVB.NET
Imports VIBlend.Controls
Imports VIBlend.Utilities
…
…
vProgressBar.VIBlendTheme = VIBLEND_THEME.ULTRABLUE

User Defined Themes

All controls in the VIBlend Controls for Windows Forms library expose a Theme property. You can use it to set a control’s theme to a user defined theme.

The code below loads a user defined theme from a XML file and assigns to a vProgressBar control:

CopyC#
private bool SetCustomTheme()
{
   ControlTheme theme = new ControlTheme();
   if (false == theme.LoadFromXml(@"c:\MyThemes\myCustomTheme.xml"))
   return false;

   vProgressBar.Theme = theme;
   return true;
}
CopyVB.NET
Private Function SetCustomTheme() As Boolean
   Dim theme As New ControlTheme()
   If False = theme.LoadFromXml("c:\MyThemes\myCustomTheme.xml") Then
   Return False
   End If

   vProgressBar.Theme = theme
   Return True
End Function


Track Bar

[image]

VIBlend Controls for WinForms Help Documentation
Track Bar
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)
Track Bar Image 1

Overview

vTrackBar represents a tracking control similar to the standard MS Track Bar.

The vTrackBar is a scrollable control similar to the VScrollBar control. You can configure ranges through which the value of the Value property of a track bar scrolls by setting the Minimum property to specify the lower end of the range and the Maximum property to specify the upper end of the range.

The LargeChange property defines the increment to add or subtract from the Value property when clicks occur on either side of the scroll box. The track bar can be displayed horizontally or vertically. The Orientation property is used do change the display type of the track bar.

The ValueChanged event is fired when the Value property is changed

The Scrollevent is fired when the slider position is changed.

ThumbRect - gets the thumb bounding rectangle.

ThumbSize - gets or sets the slider's thumb size

Orientation - gets or sets the orientation of the control

Minimum - the lower bound of the slider's value

Maximum - the upper bound of the slider's value

SmallChange - gets or sets the smallChange step of the slider

LargeChange - gets or sets the largeChange step of the slider. It affects the value when the PageUp/PageDown keys are pressed.

GettingStarted

You can add a vTrackBar to a Form using the Visual Studio designer. Open the Toolbox, locate the vTrackBar item in the VIBlend controls group and drag it on the form.

The code below adds a vTrackBar to a Form at runtime:

CopyC#
using VIBlend.Controls;
…
...

vTrackBar vTrackBar = newvTrackBar();
this.Controls.Add(vTrackBar );
CopyVB.NET
Imports VIBlend.Controls
…
    ...
Dim vTrackBar As vTrackBar = NewvTrackBar()
Me.Controls.Add(vTrackBar)

Themes

VIBlend Controls for Windows Forms ships with several built-in themes. Each control in the library exposes a property called VIBlendTheme. Set this property to one of the built-in themes.

At design time you can change the VIBlendTheme through the control properties. The VIBlendTheme property is located within the Appearance group of the control properties.

The code below changes the theme of a vTrackBar runtime:

CopyC#
using VIBlend.Controls;
using VIBlend.Utilities;
…
...
vTrackBar.VIBlendTheme = VIBLEND_THEME.ULTRABLUE;

User Defined Themes

All controls in the VIBlend Controls for Windows Forms library expose a Theme property. You can use it to set a control’s theme to a user defined theme.

The code below loads a user defined theme from a XML file and assigns to a vTrackBar control:

CopyC#
private bool SetCustomTheme()
{
   ControlTheme theme = newControlTheme();
   if (false == theme.LoadFromXml(@"c:\MyThemes\myCustomTheme.xml"))
   return false;

   vTrackBar.Theme = theme;

   return true;
}
CopyVB.NET
Private Function SetCustomTheme() As Boolean
   Dim theme As ControlTheme = newControlTheme()
   If False = theme.LoadFromXml("c:\MyThemes\myCustomTheme.xml") Then
   Return False
   End If

   vTrackBar.Theme = theme

   Return True
End Function


Radio Button

[image]

VIBlend Controls for WinForms Help Documentation
Radio Button
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)

Overview

You can add a vRadioButton to a Form using the Visual Studio designer. Open the Toolbox, locate the vRadioButton item in the VIBlend controls group and drag it on the form.

The code below adds a vRadioButton to a Form at runtime:

CopyC#
using VIBlend.Controls;
...
...
vRadioButton radioButton = newvRadioButton ();
radioButton.Text = "RadioButton 1";
this.Controls.Add(radioButton);
CopyVB.NET
Imports VIBlend.Controls
...
    ...
Dim radioButton As vRadioButton = New vRadioButton ()
radioButton.Text = "RadioButton 1"
Me.Controls.Add(radioButton)

Use the Checked property of the radio button to check or uncheck it.

Radio Button Image 1

Themes

VIBlend Controls for Windows Forms ships with several built-in themes. Each control in the library exposes a property called VIBlendTheme. Set this property to one of the built-in themes.

At design time you can change the VIBlendTheme through the control properties. The VIBlendTheme property is located within the Appearance group of the control properties.

The code below changes the theme of a radio button at runtime:

CopyC#
using VIBlend.Controls;
     using VIBlend.Utilities;
    ...
    ...
    radioButton.VIBlendTheme = VIBLEND_THEME.ULTRABLUE;

User Defined Themes

All controls in the VIBlend Controls for Windows Forms library expose a Theme property. You can use it to set a control’s theme to a user defined theme.

The code below loads a user defined theme from a XML file and assigns to a radio button control:

CopyC#
private bool SetCustomTheme()
{
  ControlTheme theme = new ControlTheme();
  if (false == theme.LoadFromXml(@"c:\MyThemes\myCustomTheme.xml"))
  return false;

  radioButton.Theme = theme;
  return true;
}
CopyVB.NET
Private Function SetCustomTheme() As Boolean
  Dim theme As New ControlTheme()
  If False = theme.LoadFromXml("c:\MyThemes\myCustomTheme.xml") Then
  Return False
  End If

  radioButton.Theme = theme
  Return True
End Function

Radio Button Image 2

You can change the RadioButton check mark's color by setting the UseThemeCheckMarkColors property to false and then set the CheckMarkColor property to a valid Color value.

CopyC#
this.vRadioButton2.UseThemeCheckMarkColors = false;
this.vRadioButton2.CheckMarkColor = Color.Red;

CopyVB.NET
Me.vRadioButton2.UseThemeCheckMarkColors = False
Me.vRadioButton2.CheckMarkColor = Color.Red


Text Box

[image]

VIBlend Controls for WinForms Help Documentation
Text Box
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)

Overview

vTextBox control extends the functionality of the standard Windows Forms TextBox control adding visual styles to and themes support.

Typically, a vTextBoxcontrol is used to display, or accept as input, a single line of text. You can use the Multiline and ScrollBars properties to enable multiple lines of text to be displayed or entered. Set the AcceptsTab and AcceptReturn properties to true to enable greater text manipulation in a multiline TextBox control.

You can limit the amount of text entered into a vTextBox control by setting the МаxLength property to a specific number of characters. TextBox controls can also be used to accept passwords and other sensitive information. You can use the PasswordChar property to mask characters entered in a single-line version of the control.


Button

[image]

VIBlend Controls for WinForms Help Documentation
Button
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)

Overview

VIBlend vButton provides a great alternative to the standard Windows Forms Button.

You can easily make your applications gain the stylish Office 2010, Office2007 and Windows Vista look and feel in less than a minute.

Button Image 1

Getting Started

You can add a vButton to a Form using the Visual Studio designer. Open the Toolbox, locate the vButton item in the VIBlend controls group and drag it on the form.

The code below adds a vButton to a Form at runtime:

CopyC#
using VIBlend.Controls;
...
...
vButton button = newvButton();
button.Text = "My Button";
this.Controls.Add(button);
CopyVB.NET
Imports VIBlend.Controls
...
...
Dim button As vButton = NewvButton()
button.Text = "My Button"
Me.Controls.Add(button)

The control supports various layouts ofits text and image such as ImageBeforeText, ImageAboveText, TextAboveImage, TextBeforeImage, Overlay. You can change this layout by using the TextImageRelation property.

To enable the hover effects of the button,use the HoverEffectsEnabled property. To set an image you can use the Image, ImageIndex and ImageKey properties. If you want to use the ImageIndex and ImageKey properties, please make sure that your images are organized in an ImageList component and the button points to that image list using the ImageList property.

If you are using the toggle button you can change its state by using the Toggle property of the vToggleButton class.

Button Image 2

If you are using the repeat button you can modify the click delay time by using theDelayInterval property. vSplitButton is a special type of button with an associated popup menu.

Button Image 3

To associate a popup menu to the vSplitButton control, you should use the DropDownMenu property and set it to a ContenxtMenuStrip instance.

CopyC#
this.vSplitButton1.DropDownMenu = this.vContextMenu1;
CopyVB.NET
Me.vSplitButton1.DropDownMenu = Me.vContextMenu1

You can modify the dropdown button width by using the DropDownButtonWidth property.

Themes

VIBlend Controls for Windows Forms ships with several built-in themes. Each control in the library exposes a property called VIBlendTheme. Set this property to one of the built-in themes.

At design time you can change the VIBlendTheme through the control properties. The VIBlendTheme property is located within the Appearance group of the control properties.

The code below changes the theme of a button at runtime:

CopyC#
using VIBlend.Controls;
using VIBlend.Utilities;
...
...
vButton1.VIBlendTheme = VIBLEND_THEME.ULTRABLUE;

User Defined Themes

All controls in the VIBlend Controls for Windows Forms library expose a Theme property. You can use it to set a control’s theme to a user defined theme.

The code below loads a user defined theme from a XML file and assigns to a button control:

CopyC#
private bool SetCustomTheme()
{
  ControlTheme theme = newControlTheme();
  if (false == theme.LoadFromXml(@"c:\MyThemes\myCustomTheme.xml"))
  return false;

  vButton1.Theme = theme;

  return true;
}
CopyVB.NET
Private Function SetCustomTheme() As Boolean
  Dim theme As ControlTheme = newControlTheme()
  If False = theme.LoadFromXml("c:\MyThemes\myCustomTheme.xml") Then
  Return False
  End If

  vButton1.Theme = theme

  Return True
End Function

Features

Four different states

Animations

Themes

Theme Colors Override

Rounded Corners with customizable radius

You can use the Button's RoundedCornersMask property to determine which of the corners are rounded.

The example code below shows how to specify that only the Top-Left and Top-Right corners are rounded.

CopyC#
btnCustomCorners.RoundedCornesRadius = 4;
btnCustomCorners.RoundedCornersMask = (byte)(VIBlend.Utilities.RoundedCornersMask.TOP_LEFT | RoundedCornersMask.TOP_RIGHT);
CopyVB.NET
btnCustomCorners.RoundedCornesRadius = 4
btnCustomCorners.RoundedCornersMask = CByte(VIBlend.Utilities.RoundedCornersMask.TOP_LEFT Or RoundedCornersMask.TOP_RIGHT)

You can change the border's rounding radius of the VIBlend Button control by setting the RoundedCornersRadius property.

CopyC#
btnCustomCorners.RoundedCornersRadius = 4;
CopyVB.NET
btnCustomCorners.RoundedCornersRadius = 4


TreeViewBox, FieldSets and ColorPicker

[image]

VIBlend Controls for WinForms Help Documentation
TreeViewBox, FieldSets and ColorPicker
Send Feedback
  1. TreeViewBox

    The TreeViewBox is a control that display a TreeView in a popup control.

    - You can use the TreeViewBox.TreeView property to get the instance of the internal TreeView control.

    - To programmatically show or hide the popup, use the ShowDropDown and CloseDropDown methods.

    - Use the TreeViewBox.DropDown property to get the instance of the Popup control.

    - Use the DropDownWidth and DropDownHeight properties to specify the Popup control's size when opened.

    - To hide the resize grip in the Popup control, set the ShowGrip property to false.

    - To change the TreeViewBox's arrow color, set the UseThemeDropDownArrowColor property to false and set the DropDownArrowColor property to the desired Color value.

  2. Color Picker

    Represents a control that allows you to pick a color. When you select a color, its value is saved in the SelectedTextColorproperty. You can use this property to get or set a color to the control programatically. You can change the popup size by using the DropDownHeight and DropDownWidth properties. If you want to change color picker’s theme, you should use the VIBlendTheme property. To get the instance of the popup control, use theDropDown property. To change the text formatting of the selected color, subscribe to the ColorTextFormat event and use the FormattedText property of the event arguments.

    Tree View Box Field Sets And Color Picker 1

  3. Field Set and Option-Field Set

    Tree View Box Field Sets And Color Picker 2

    You can add or remove checkboxes by using the CheckBoxes Collection Editor. You can open the editor in design time through the action list or by using the Checkboxes property in the

    Tree View Box Field Sets And Color Picker 3

    Property Grid.

    Tree View Box Field Sets And Color Picker 4

    If you are using the vOptionsFieldSet you can use the RadioButtons collection to add and remove radio buttons.


Panels

[image]

VIBlend Controls for WinForms Help Documentation
Panels
Send Feedback
  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)
  1. vPanel

    To programmatically add or remove controls to vPanel you should do the following:

    1. Use theContent property which is an instance of type vContentPanel.
    2. Add or remove controls by using the vContentPanel’s Controls collection.
    Panels Image 1 To add a control In design mode to the vPanel you should drag and drop a control into the panel. If you want to change the theme you can use the VIBlendTheme property.
  2. vGroupBox

    vGroupBox control resembles the standard group box control but uses the VIBlend Themes. vGroupBox also can be expanded or collapsed by using a built in check box control. You can expand or collapse the group box by using itsChecked property. When the Checked property value is changed, the CheckedChanged event is fired. The expand/collapse feature is enhanced with a smooth animation. You can use the CollapsedHeight property to control the height of the collapsed group box.

    Panels Image 2

  3. vHorizontalLayoutPanel, vVerticalLayoutPanel and vFlowLayoutPanel

To add a control to the vFlowLayoutPanel you can the Contols property of the built in content panel. You can get the instance of the content panel by using the ContentPanel property. Panels Image 3

In the vHorizontalLayoutPanel and vVerticalLayoutPanel you should use the Controls property to add or remove controls. These panels layout their child controls in horizontal and vertical order. When there is not enough space for all controls, scroll buttons appear. If you want to change the default theme you can use the VIBlendTheme property. If you want to add a control in design mode you can drag and drop any control to these layout panels. You can use the children controls Margin property to specify a spacing between the controls.

  • Namespace: VIBlend.WinForms.Controls
  • Assembly: VIBlend.WinForms.Controls ( in VIBlend.WinForms.Controls.dll)

vSplitContainer - Represents a control consisting of a movable bar(splitter) that divides a container's display area into two resizable panels.

SplitterDistance - Gets or sets the location of the splitter

Panel1 and Panel2- You can use these properties to get the instances of the panels. To add controls at design-time, you can drag and drop any control from the toolbox into the panel's area.

VIBlendTheme - Gets or sets the SplitContainer's theme.


How To Articles and Tutorials

[image]

VIBlend Controls for WinForms Help Documentation
How To Articles and Tutorials
Send Feedback
The topics in this section will help you to achieve some common scenarios with VIBlend Controls for WinForms
  • Binding DataGrid to a list
  • Enable DataGrid Grouping
  • DataGrid Custom Editors
  • Customizing Grid Cells Style
  • OutlookPane Images
  • Binding a ListBox to a DataTable
  • How to get the clicked row, column or cell?
  • Customizing vListBox Rendering
  • How to display an image in a grid cell?
  • How to programmatically set the value of a grid cell?
  • How to programmatically get the value of a grid cell?
  • How to validate the value of a grid cell?
  • How to add Ribbon Groups at Design-Time?
  • How to add Ribbon Groups at Run-Time?
  • How to hide a column in DataGrid?
  • How to hide a row in DataGrid?
  • How to switch from the traditional OLAP layout to compact style layout?
  • How to set an image to a header item in DataGrid?
  • How to resize a DataGrid header in code?
  • How to add a TabPage?
  • How to add an Application Button to RibbonBar?
  • How to create a QuickAccesToolbar and associate it with the vRibbonBar?
  • DataGrid Cells Formatting?
  • DataGrid Cells Styling?
  • Add an image to a TreeNode.aml?
  • How to set a checkbox editor to a grid column?
  • Sorting DataGrid’s data
  • Creating a Pivot Table
  • DataGrid Filtering
  • Alternating Rows Tutorial
  • ComboBox DropDownList


Binding DataGrid to a list

[image]

VIBlend Controls for WinForms Help Documentation
Binding DataGrid to a list
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms

HOW-TO

Bind the data grid to a list.

SOLUTION

To achieve this, follow these steps:

  1. Create a new instance of the vDataGridView via drag and drop from the toolbox or create it programmatically.
  2. Create a class named Customer
    CopyC#
    public class Customer
 {
     private int id;

     public int Id
     {
         get { return id; }
         set { id = value; }
     }

     private string name;

     public string Name
     {
         get { return name; }
         set { name = value; }
     }

     public Customer() { }

     public Customer(int id, string name)
     {
         this.id = id;
         this.name = name;
     }

     #region INotifyPropertyChanged Members

     public event PropertyChangedEventHandler PropertyChanged;

     private void OnPropertyChanged(string propertyName)
     {
         if (PropertyChanged != null)
             PropertyChanged(this, new PropertyChangedEventArgs(propertyName));
     }

     #endregion
 }
    CopyVB.NET
    Public Class Customer
         Private id_Renamed As Integer

         Public Property Id() As Integer
             Get
                 Return id_Renamed
             End Get
             Set
                 id_Renamed = Value
             End Set
         End Property

         Private name_Renamed As String

         Public Property Name() As String
             Get
                 Return name_Renamed
             End Get
             Set
                 name_Renamed = Value
             End Set
         End Property

         Public Sub New()
         End Sub

         Public Sub New(ByValid_Renamed As Integer, ByValname_Renamed As String)
             Me.id_Renamed = id_Renamed
             Me.name_Renamed = name_Renamed
         End Sub

         #Region "INotifyPropertyChanged Members"

         Public Event PropertyChangedAsPropertyChangedEventHandler

         Private Sub OnPropertyChanged(ByValpropertyName As String)
             If Not PropertyChangedEvent Is Nothing Then
                 RaiseEventPropertyChanged(Me, New PropertyChangedEventArgs(propertyName))
             End If
         End Sub

         #End Region
End Class
  3. In the form's constructor after the InitializeComponent method call or in the form Load event handler use the code snippet below to create a new list and fill it with sample items:
    CopyC#
    List<Customer> customers = new List<Customer>();
customers.Add(new Customer(1, "Andrew"));
customers.Add(new Customer(2, "Nancy"));
customers.Add(new Customer(3, "Shelley"));
customers.Add(new Customer(4, "Regina"));
customers.Add(new Customer(5, "Mayumi"));
customers.Add(new Customer(6, "Ian"));
    CopyVB.NET
    Dim customers As List(Of Customer) = New List(Of Customer)()
customers.Add(New Customer(1, "Andrew"))
customers.Add(New Customer(2, "Nancy"))
customers.Add(New Customer(3, "Shelley"))
customers.Add(New Customer(4, "Regina"))
customers.Add(New Customer(5, "Mayumi"))
customers.Add(New Customer(6, "Ian"))
  4. Finally, in order to bind the grid to the list, use the code snippet below:
CopyC#
BoundField boundField = new BoundField("Customer Name", "Name");
this.vDataGridView1.BoundFields.Add(boundField);
this.vDataGridView1.DataSource = customers;
this.vDataGridView1.DataBind();
CopyVB.NET
Dim boundField As BoundField = New BoundField("Customer Name", "Name")
Me.vDataGridView1.BoundFields.Add(boundField)
Me.vDataGridView1.DataSource = customers
Me.vDataGridView1.DataBind()


Enable DataGrid Grouping

[image]

VIBlend Controls for WinForms Help Documentation
Enable DataGrid Grouping
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms

HOW-TO

Bind the data grid and group the information by a column

SOLUTION

To achieve this, follow these steps:

  1. Create a new instance of the vDataGridView via drag and drop from the toolbox or create it programmatically.
  2. Drag and drop a new NorthWind data set.
  3. Drag and drop Categories and Products table adapters.
  4. Fill the Categories and Products tables.
    CopyC#
    this.categoriesTableAdapter1.Fill(this.nwindDataSet1.Categories);
this.productsTableAdapter1.Fill(this.nwindDataSet1.Products);
    CopyVB.NET
    Me.categoriesTableAdapter1.Fill(Me.nwindDataSet1.Categories)
Me.productsTableAdapter1.Fill(Me.nwindDataSet1.Products)
  5. Create the DataGrid’sBoundFields
    CopyC#
    Grid1.BoundFields.Add(new BoundField("Product Name", "ProductName"));
Grid1.BoundFields.Add(new BoundField("Unit Price", "UnitPrice"));
Grid1.BoundFields.Add(new BoundField("Category", "CategoryName"));
Grid1.BoundFields.Add(new BoundField("Description", "Description"));
    CopyVB.NET
    Grid1.BoundFields.Add(New BoundField("Product Name", "ProductName"))
Grid1.BoundFields.Add(New BoundField("Unit Price", "UnitPrice"))
Grid1.BoundFields.Add(New BoundField("Category", "CategoryName"))
Grid1.BoundFields.Add(New BoundField("Description", "Description"))
  6. Add the data grid’s grouping column and set the GroupingEnabled property to true.
    CopyC#
    Grid1.GroupingColumns.Add(new BoundField("Category", "CategoryName"));
Grid1.GroupingEnabled = true;
    CopyVB.NET
    Grid1.GroupingColumns.Add(New BoundField("Category", "CategoryName"))
Grid1.GroupingEnabled = True
  7. Finally, bind the data grid to the data source
CopyC#
  DataTable table = new DataTable();
            string categoryName = "CategoryName";
            string description = "Description";
            table.Merge(this.nwindDataSet1.Products);
            table.Columns.Add(this.nwindDataSet1.Categories.CategoryNameColumn.Caption);
            table.Columns.Add(this.nwindDataSet1.Categories.DescriptionColumn.Caption);

            for (int i = 0; i < table.Rows.Count; i++)
            {
                int id = (int)table.Rows[i]["CategoryID"];
                if (id < this.nwindDataSet1.Categories.Rows.Count)
                {
                    table.Rows[i][categoryName] = this.nwindDataSet1.Categories.Rows[id][categoryName];
                    table.Rows[i][description] = this.nwindDataSet1.Categories.Rows[id][description];
                }
            }

            Grid1.DataSource = table;
            Grid1.DataBind();
Grid1.ColumnsHierarchy.AutoResize(AutoResizeMode.FIT_ALL);
CopyVB.NET
Dim table As DataTable = New DataTable()
            Dim categoryName As String = "CategoryName"
            Dim description As String = "Description"
            table.Merge(Me.nwindDataSet1.Products)
            table.Columns.Add(Me.nwindDataSet1.Categories.CategoryNameColumn.Caption)
            table.Columns.Add(Me.nwindDataSet1.Categories.DescriptionColumn.Caption)

            Dim i As Integer = 0
            Do While i <table.Rows.Count
                Dim id As Integer = CInt(Fix(table.Rows(i)("CategoryID")))
                If id < Me.nwindDataSet1.Categories.Rows.Count Then
                    table.Rows(i)(categoryName) = Me.nwindDataSet1.Categories.Rows(id)(categoryName)
                    table.Rows(i)(description) = Me.nwindDataSet1.Categories.Rows(id)(description)
                End If
                i += 1
            Loop

            Grid1.DataSource = table
            Grid1.DataBind()
            Grid1.ColumnsHierarchy.AutoResize(AutoResizeMode.FIT_ALL)

Enable Grouping InVIBlend Data Grid View


DataGrid Custom Editors

[image]

VIBlend Controls for WinForms Help Documentation
DataGrid Custom Editors
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms. In this article we will show you how to create a custom editor control.As an example we will implement a color picker editor.

HOW-TO

Create a custom editor.

SOLUTION

To achieve this, follow these steps:

  1. Create a new instance of the vDataGridView via drag and drop from the toolbox or create it programmatically.
  2. Create a new class named ColorPickerEditor which inherits the IEditor interface and the ColorPicker control.
  3. The EditorType property should be set to Custom
  4. The Activation and Deactivation flags allow you to specify on what action the DataGrid should show or close the editor.
  5. EditorValue property represents the editor’s actual value which is used by the DataGrid. In the color picker editor the value is the ColorPicker’sSelectedColor.
  6. LayoutEditor is called when the editor is activated. It allows you to change the editor’s location and size depending on your scenario.
  7. OnOpenEditor and OnCloseEditor methods are called when the editor is opened(respectively closed)
  8. Here is the full source code of the ColorPickerEditor class.
    CopyC#
    public class ColorPickerEditor : vColorPicker, IEditor
{
    /// <summary>
    /// Constructor
    /// </summary>
    public ColorPickerEditor()
    {
    }

    /// <summary>
    /// Gets the type of the grid cell editor
    /// </summary>
    public CellEditorType EditorType
    {
        get
        {
            return CellEditorType.Custom;
        }
    }

    private EditorActivationFlags activationFlags = EditorActivationFlags.MOUSE_DBLCLICK | EditorActivationFlags.PROGRAMMATIC;

    /// <summary>
    /// Gets or sets the editor activation flags
    /// </summary>
    public EditorActivationFlags ActivationFlags
    {
        get { return activationFlags; }
        set
        {
            activationFlags = value;
            activationFlags |= EditorActivationFlags.PROGRAMMATIC;
        }

    }

    private EditorActivationFlags deactivationFlags = EditorActivationFlags.MOUSE_DBLCLICK | EditorActivationFlags.MOUSE_CLICK | EditorActivationFlags.PROGRAMMATIC;

    /// <summary>
    /// Gets or sets the editor activation flags
    /// </summary>
    public EditorActivationFlags DeActivationFlags
    {
        get { return deactivationFlags; }
        set
        {
            deactivationFlags = value;
            deactivationFlags |= EditorActivationFlags.PROGRAMMATIC;
        }

    }

    /// <summary>
    /// Handles grid KeyDown events
    /// </summary>
    /// <param name="args">KeyDown event arguments</param>
    /// <param name="closeEditor">The grid cell where the event occured. This may be null if the event did not occur within a grid cell.</param>
    /// <param name="closeEditor">Output flag indicating whether to keep the editor open or close it instantly</param>
    public void OnGridKeyDown(KeyEventArgs args, GridCell cell, out bool closeEditor)
    {
        if (args.KeyData == Keys.Return || args.KeyData == Keys.Escape)
            closeEditor = true;
        else
            closeEditor = false;
    }

    /// <summary>
    /// Handles the painting of the editor control
    /// </summary>
    /// <param name="graphics">Reference to the GDI+ surface</param>
    /// <param name="gridCell">Reference to the grid cell being rendered</param>
    /// <param name="isDrawHandled">Output flag indicating whether the method handled the drawing or not</param>
    public void DrawEditorControl(Graphics graphics, GridCell gridCell, out bool isDrawHandled)
    {
        isDrawHandled = false;
    }

    /// <summary>
    /// Gets a reference to the underlying control of the editor
    /// </summary>
    public Control Control
    {
        get { return this; }
    }

    private object editorValue;

    /// <summary>
    /// Get's or sets the current value of the editor
    /// </summary>
    public object EditorValue
    {
        get
        {
            this.editorValue = this.SelectedColor;

            return this.editorValue;
        }
        set
        {
            this.editorValue = value;
            LoadColorEditorWithEditorValue();
        }
    }

    private void LoadColorEditorWithEditorValue()
    {
        if (editorValue != null)
        {
            if (this.editorValue.GetType() == typeof(Color))
            {
                this.SelectedColor = (Color)this.editorValue;
            }
            else
            {
                this.SelectedColor = Color.Empty;
            }
        }
        else
        {
            this.SelectedColor = Color.Empty;
        }

    }

    private GridCell currentCell = null;

    /// <summary>
    /// This method is called by the grid control when the editor is being activated
    /// </summary>
    public virtual void OnOpenEditor(GridCell cell)
    {
        if (cell == null)
            return;

        currentCell = cell;
        LoadColorEditorWithEditorValue();
    }

    public virtual void LayoutEditor(GridCell cell)
    {
        this.Width = cell.Bounds.Width;
        this.Height = cell.Bounds.Height;

        Point pt = Point.Empty;

        if (cell.TextAlignment == ContentAlignment.BottomLeft || cell.TextAlignment == ContentAlignment.MiddleLeft || cell.TextAlignment == ContentAlignment.TopLeft)
            pt.X = cell.ColumnItem.X + cell.CellsArea.GridControl.ColumnsHierarchy.X + 2;
        if (cell.TextAlignment == ContentAlignment.BottomRight || cell.TextAlignment == ContentAlignment.MiddleRight || cell.TextAlignment == ContentAlignment.TopRight)
            pt.X = cell.ColumnItem.X + cell.CellsArea.GridControl.ColumnsHierarchy.X + cell.ColumnItem.Width - cell.Bounds.Width - 2;
        if (cell.TextAlignment == ContentAlignment.BottomCenter || cell.TextAlignment == ContentAlignment.MiddleCenter || cell.TextAlignment == ContentAlignment.TopCenter)
            pt.X = cell.ColumnItem.X + cell.CellsArea.GridControl.ColumnsHierarchy.X + (cell.ColumnItem.Width - cell.Bounds.Width) / 2;

        if (cell.TextAlignment == ContentAlignment.TopLeft || cell.TextAlignment == ContentAlignment.TopRight || cell.TextAlignment == ContentAlignment.TopCenter)
            pt.Y = cell.RowItem.Y + cell.CellsArea.GridControl.RowsHierarchy.Y + 2;

        if (cell.TextAlignment == ContentAlignment.BottomLeft || cell.TextAlignment == ContentAlignment.BottomRight || cell.TextAlignment == ContentAlignment.BottomCenter)
            pt.Y = cell.RowItem.Y + cell.RowItem.Height + cell.CellsArea.GridControl.RowsHierarchy.Y - cell.Bounds.Height - 2;
        if (cell.TextAlignment == ContentAlignment.MiddleLeft || cell.TextAlignment == ContentAlignment.MiddleRight || cell.TextAlignment == ContentAlignment.MiddleCenter)
            pt.Y = cell.RowItem.Y + cell.RowItem.Hierarchy.Y + (cell.RowItem.Height - cell.Bounds.Height) / 2;

        this.Location = pt;

    }

    /// <summary>
    /// This method is called by the grid control when at the end of a cell edit operation
    /// </summary>
    public virtual void OnCloseEditor()
    {
        editorValue = this.SelectedColor;
        currentCell = null;
    }
}
    CopyVB.NET
    Public Class ColorPickerEditor
        Inherits vColorPicker
        Implements IEditor
      Public Sub New()
      End Sub

    Public ReadOnly Property EditorType() As CellEditorType
            Get
                Return CellEditorType.Custom
            End Get
    End Property

        Private activationFlags_Renamed As EditorActivationFlags = EditorActivationFlags.MOUSE_DBLCLICK Or EditorActivationFlags.PROGRAMMATIC
        Public Property ActivationFlags() As EditorActivationFlags
            Get
                Return activationFlags_Renamed
            End Get
            Set
                activationFlags_Renamed = Value
                activationFlags_Renamed = activationFlags_Renamed Or EditorActivationFlags.PROGRAMMATIC
            End Set
        End Property

Private Sub LoadColorEditorWithEditorValue()
            If Not editorValue Is Nothing Then
                If Me.editorValue.GetType() Is GetType(Color) Then
                    Me.SelectedColor = CType(Me.editorValue, Color)
                Else
                    Me.SelectedColor = Color.Empty
                End If
            Else
                Me.SelectedColor = Color.Empty
            End If
 End Sub
        Private currentCell As GridCell = Nothing
        Public Overridable Sub OnOpenEditor(ByVal cell As GridCell)
            If cell Is Nothing Then
                Return
            End If

            currentCell = cell
            LoadColorEditorWithEditorValue()
        End Sub

        Public Overridable Sub LayoutEditor(ByVal cell As GridCell)
            Me.Width = cell.Bounds.Width
            Me.Height = cell.Bounds.Height

            Dim pt As Point = Point.Empty

            If cell.TextAlignment = ContentAlignment.BottomLeftOrElsecell.TextAlignment = ContentAlignment.MiddleLeftOrElsecell.TextAlignment = ContentAlignment.TopLeft Then
                pt.X = cell.ColumnItem.X + cell.CellsArea.GridControl.ColumnsHierarchy.X + 2
            End If
            If cell.TextAlignment = ContentAlignment.BottomRightOrElsecell.TextAlignment = ContentAlignment.MiddleRightOrElsecell.TextAlignment = ContentAlignment.TopRight Then
                pt.X = cell.ColumnItem.X + cell.CellsArea.GridControl.ColumnsHierarchy.X + cell.ColumnItem.Width - cell.Bounds.Width - 2
            End If
            If cell.TextAlignment = ContentAlignment.BottomCenterOrElsecell.TextAlignment = ContentAlignment.MiddleCenterOrElsecell.TextAlignment = ContentAlignment.TopCenter Then
                pt.X = cell.ColumnItem.X + cell.CellsArea.GridControl.ColumnsHierarchy.X + (cell.ColumnItem.Width - cell.Bounds.Width) / 2
            End If

            If cell.TextAlignment = ContentAlignment.TopLeftOrElsecell.TextAlignment = ContentAlignment.TopRightOrElsecell.TextAlignment = ContentAlignment.TopCenter Then
                pt.Y = cell.RowItem.Y + cell.CellsArea.GridControl.RowsHierarchy.Y + 2
            End If

            If cell.TextAlignment = ContentAlignment.BottomLeftOrElsecell.TextAlignment = ContentAlignment.BottomRightOrElsecell.TextAlignment = ContentAlignment.BottomCenter Then
                pt.Y = cell.RowItem.Y + cell.RowItem.Height + cell.CellsArea.GridControl.RowsHierarchy.Y - cell.Bounds.Height - 2
            End If
            If cell.TextAlignment = ContentAlignment.MiddleLeftOrElsecell.TextAlignment = ContentAlignment.MiddleRightOrElsecell.TextAlignment = ContentAlignment.MiddleCenter Then
                pt.Y = cell.RowItem.Y + cell.RowItem.Hierarchy.Y + (cell.RowItem.Height - cell.Bounds.Height) / 2
            End If

            Me.Location = pt
        End Sub

        Private deactivationFlags_Renamed As EditorActivationFlags = EditorActivationFlags.MOUSE_DBLCLICK Or EditorActivationFlags.MOUSE_CLICK Or EditorActivationFlags.PROGRAMMATIC
   Public Property DeActivationFlags() As EditorActivationFlags
            Get
                Return deactivationFlags_Renamed
            End Get
            Set
                deactivationFlags_Renamed = Value
                deactivationFlags_Renamed = deactivationFlags_Renamed Or EditorActivationFlags.PROGRAMMATIC
            End Set

   End Property

   Public Sub OnGridKeyDown(ByValargs As KeyEventArgs, ByVal cell As GridCell, <System.Runtime.InteropServices.Out()>ByRefcloseEditor As Boolean)
            If args.KeyData = Keys.ReturnOrElseargs.KeyData = Keys.Escape Then
                closeEditor = True
            Else
                closeEditor = False
            End If
   End Sub

      Public Sub DrawEditorControl(ByVal graphics As Graphics, ByValgridCell As GridCell, <System.Runtime.InteropServices.Out()>ByRefisDrawHandled As Boolean)
            isDrawHandled = False
      End Sub
  Public ReadOnly Property Control() As Control
            Get
                Return Me
            End Get
  End Property

        Private editorValue_Renamed As Object
   Public Property EditorValue() As Object
            Get
                Me.editorValue_Renamed = Me.SelectedColor

                Return Me.editorValue_Renamed
            End Get
            Set
                Me.editorValue_Renamed = Value
                LoadColorEditorWithEditorValue()
            End Set
   End Property

   Public Overridable Sub OnCloseEditor()
            editorValue_Renamed = Me.SelectedColor
            currentCell = Nothing
   End Sub
    End Class
  9. Once the editor is created, you should associate it to the data grid. You can do this by using the following:
CopyC#
dataGrid.ColumnsHierarchy.Items[4].CellsEditor = colorEditor;
CopyVB.NET
dataGrid.ColumnsHierarchy.Items(4).CellsEditor = colorEditor

The code snippet above, associates an instance of the ColorPickerEditor to the fifth column of the data grid. You can also set an editor to a specific a grid cell by using the SetCellEditor method of the CellsArea class:

CopyC#
dataGrid.CellsArea.SetCellEditor(dataGrid.RowsHierarchy.Items[0], dataGrid.ColumnsHierarchy.Items[0], colorEditor);
CopyVB.NET
dataGrid.CellsArea.SetCellEditor(dataGrid.RowsHierarchy.Items(0), dataGrid.ColumnsHierarchy.Items(0), colorEditor)

Create Custom EditorinVIBlend Data Grid View


Customizing Grid Cell Style

[image]

VIBlend Controls for WinForms Help Documentation
Customizing Grid Cell Style
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms

HOW-TO

Customize the data grid cells

SOLUTION

To achieve this, follow these steps:

  1. Create a new instance of the vDataGridView via drag and drop from the toolbox or create it programmatically.
  2. Create rows and columns.
    CopyC#
    // Create grid columns
for (int i = 0; i < 10; i++)
{
   this.vDataGridView1.ColumnsHierarchy.Items.Add("Column" + i);
}

// Create grid rows
for (int j = 0; j < 10; j++)
{
   this.vDataGridView1.RowsHierarchy.Items.Add("Row" + j);
}
    CopyVB.NET
    ' Create grid columns
For i As Integer = 0 To 9
   Me.vDataGridView1.ColumnsHierarchy.Items.Add("Column" & i)
Next i

' Create grid rows
For j As Integer = 0 To 9
   Me.vDataGridView1.RowsHierarchy.Items.Add("Row" & j)
Next j
  3. Fill the grid with sample data
    CopyC#
    // Fill the grid with sample data
for (int i = 0; i < 10; i++)
{
   for (int j = 0; j < 10; j++)
   {
     this.vDataGridView1.CellsArea.SetCellValue(this.vDataGridView1.RowsHierarchy.Items[i],
     this.vDataGridView1.ColumnsHierarchy.Items[j], "Cell" + i + ";" + j);
   }
}

// auto resize grid's columns
this.vDataGridView1.ColumnsHierarchy.AutoResize();
this.vDataGridView1.Invalidate();
    CopyVB.NET
    ' Fill the grid with sample data

For i As Integer = 0 To 9
   For j As Integer = 0 To 9
     Me.vDataGridView1.CellsArea.SetCellValue(Me.vDataGridView1.RowsHierarchy.Items(i), Me.vDataGridView1.ColumnsHierarchy.Items(j), "Cell" & i & ";" & j)
   Next j
Next i
' auto resize grid's columns
Me.vDataGridView1.ColumnsHierarchy.AutoResize()
Me.vDataGridView1.Invalidate()
  4. Get one of the default cell styles.
    CopyC#
    // get a default cell style.
GridTheme theme = GridTheme.GetDefaultTheme(VIBLEND_THEME.OFFICE2010BLACK);
GridCellStylecellStyle = theme.GridCellStyle;
    CopyVB.NET
    ' get a default cell style.
Dim theme As GridTheme = GridTheme.GetDefaultTheme(VIBLEND_THEME.OFFICE2010BLACK)
Dim cellStyle As GridCellStyle = theme.GridCellStyle
  5. Customize the cell’s style. You can set its background and border colors.
    CopyC#
    // customize the cell's style.
cellStyle.BorderColor = Color.Red;
cellStyle.BorderColorSelected = Color.Blue;
cellStyle.TextColor = Color.Green;
cellStyle.Font = new Font(this.Font, FontStyle.Bold);
FillStyleSolidsolidFillStyle = new FillStyleSolid(Color.LightCyan);
cellStyle.FillStyle = solidFillStyle;
    CopyVB.NET
    ' customize the cell's style.
cellStyle.BorderColor = Color.Red
cellStyle.BorderColorSelected = Color.Blue
cellStyle.TextColor = Color.Green
cellStyle.Font = New Font(Me.Font, FontStyle.Bold)
Dim solidFillStyle As FillStyleSolid = New FillStyleSolid(Color.LightCyan)
cellStyle.FillStyle = solidFillStyle
  6. Finally, apply the style to the first grid cell
CopyC#
// apply the style to the first grid cell
this.vDataGridView1.CellsArea.SetCellDrawStyle(this.vDataGridView1.RowsHierarchy.Items[0], this.vDataGridView1.ColumnsHierarchy.Items[0], cellStyle);
CopyVB.NET
' apply the style to the first grid cell
Me.vDataGridView1.CellsArea.SetCellDrawStyle(Me.vDataGridView1.RowsHierarchy.Items(0), Me.vDataGridView1.ColumnsHierarchy.Items(0), cellStyle)

Customizing Grid Cells Style


Adding Images to OutlookPane for WinForms

[image]

VIBlend Controls for WinForms Help Documentation
Adding Images to OutlookPane for WinForms
Send Feedback
Article information

Article relates to vOutlookNavPane for WinForms

HOW-TO

Put an image to vOutlookNavPane

SOLUTION

To achieve this, follow these steps:

  1. Create a new instance of the vOutlookNavPane via drag and drop from the toolbox or create it programmatically.
  2. Create a new instance of the vOutlookItem via using the Add method of the vOutlookNavPaneItems collection.
    CopyC#
    vOutlookItem outlookItem = new vOutlookItem();
outlookItem.HeaderText = "Header Text";
this.outlookNavigationPane.Items.Add(outlookItem);
    CopyVB.NET
    Dim outlookItem As vOutlookItem = New vOutlookItem()
outlookItem.HeaderText = "Header Text"
Me.outlookNavigationPane.Items.Add(outlookItem)
  3. In the form's constructor after the InitializeComponent method call or in the form Load event handler use the code snippet below:
    CopyC#
    outlookItem.LargeImage = this.imageListLargeIcons.Images[0];
outlookItem.SmallImage = this.imageListSmallIcons.Images[0];
    CopyVB.NET
    outlookItem.LargeImage = Me.imageListLargeIcons.Images(0)
outlookItem.SmallImage = Me.imageListSmallIcons.Images(0)
     LargeImage is shown in the item’s header. The SmallImage is shown when the item is collapsed and is situated in the status area.
  4. You can use the SmallImageList and LargeImageList to the Outlook NavigationPane and use the OutlookItem’s SmallImageIndex and LargeImageIndex properties in order to set a large and small images.


Binding a vListBox to a DataTable

[image]

VIBlend Controls for WinForms Help Documentation
Binding a vListBox to a DataTable
Send Feedback
Article information

Article relates to vListBox for WinForms

HOW-TO

Bind the vListBox to a DataTable.

SOLUTION

To achieve this, follow these steps:

  1. Create a new instance of the vListBox via drag and drop from the toolbox or create it programmatically.
  2. Add a connection to the Nwinddata base.
  3. Drag and drop a new NwindDataSet.
  4. Drag and drop a new Employees table adapter.
  5. In the form's constructor after the InitializeComponent method call or in the form Load event handler use the code snippet below to fill the employees table.
    CopyC#
    try
{
    this.employeesTableAdapter1.Fill(this.nwindDataSet1.Employees);
}
catch (System.Exception ex)
{
    MessageBox.Show(ex.Message);
    return;
}
    CopyVB.NET
    Try

Me.employeesTableAdapter1.Fill(Me.nwindDataSet1.Employees)
Catch ex As System.Exception
MessageBox.Show(ex.Message)
Return

End Try
  6. Bind the listbox to the employees table
    CopyC#
    DataTable tbl = this.nwindDataSet1.Employees;
this.listBoxDataBinding.DisplayMember = "FirstName";
this.listBoxDataBinding.ValueMember = "EmployeeID";
this.listBoxDataBinding.DataSource = tbl;
    CopyVB.NET
    Dim tbl As DataTable = Me.nwindDataSet1.Employees
Me.listBoxDataBinding.DisplayMember = "FirstName"
Me.listBoxDataBinding.ValueMember = "EmployeeID"
Me.listBoxDataBinding.DataSource = tbl
  7. Add the description fields to the listbox items(optional)
CopyC#
ImageList imageList = new ImageList();
imageList.ColorDepth = ColorDepth.Depth32Bit;
imageList.ImageSize = new Size(70, 70);
this.listBoxDataBinding.ImageList = imageList;

for (int i = 0; i < this.listBoxDataBinding.Items.Count; i++)
{
    ListItem item = this.listBoxDataBinding.Items[i];

    string itemDescription = "" + tbl.Rows[i]["LastName"] + '\n' + "Address " + tbl.Rows[i]["Address"] + '\n' + "City " + tbl.Rows[i]["City"];
    item.Description = itemDescription;

    byte[] content = (byte[])tbl.Rows[i]["Photo"];
    using (MemoryStream stream = new MemoryStream())
    {
        stream.Write(content, 78, content.Length - 78);
        Bitmap image = new Bitmap(stream);
        imageList.Images.Add(image);
        item.ImageIndex = imageList.Images.Count - 1;
    }
}
CopyVB.NET
Dim imageList As ImageList = New ImageList()
imageList.ColorDepth = ColorDepth.Depth32Bit
imageList.ImageSize = New Size(70, 70)
Me.listBoxDataBinding.ImageList = imageList

Dim i As Integer = 0
Do While i <Me.listBoxDataBinding.Items.Count
    Dim item As ListItem = Me.listBoxDataBinding.Items(i)
    Dim itemDescription As String = "" &tbl.Rows(i)("LastName") + ControlChars.Lf& "Address " &tbl.Rows(i)("Address") + ControlChars.Lf& "City " &tbl.Rows(i)("City")
    item.Description = itemDescription

    Dim content As Byte() = CType(tbl.Rows(i)("Photo"), Byte())
    Using stream As MemoryStream = New MemoryStream()
        stream.Write(content, 78, content.Length - 78)
        Dim image As Bitmap = New Bitmap(stream)
        imageList.Images.Add(image)
        item.ImageIndex = imageList.Images.Count - 1
    End Using
    i += 1
Loop

Here is the result:

BindingVList Box To Data Table


How to get the clicked row, column and cell

[image]

VIBlend Controls for WinForms Help Documentation
How to get the clicked row, column and cell
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms

HOW-TO

Get the current row, column or cell when you click on the vDataGridView

SOLUTION

If you need to get the current row, column or cell when you click on the DataGrid, the best way is to subscribe to the CellMouseClick event and use its event arguments.

CopyC#
void dataGridView_CellMouseClick(object sender, GridCellMouseEventArgs args)
{
  // clicked cell
  GridCell cell = args.Cell;

  // clicked row
  HierarchyItem rowItem = cell.RowItem;

  // clicked column
  HierarchyItem columnItem = cell.ColumnItem;
}
CopyVB.NET
Private Sub dataGridView_CellMouseClick(ByVal sender As Object, ByVal args As GridCellMouseEventArgs)
  ' clicked cell
  Dim cell As GridCell = args.Cell

  ' clicked row
  Dim rowItem As HierarchyItem = cell.RowItem

  ' clicked column
  Dim columnItem As HierarchyItem = cell.ColumnItem
End Sub


Customizing vListBox Rendering

[image]

VIBlend Controls for WinForms Help Documentation
Customizing vListBox Rendering
Send Feedback
Article information

Article relates to VIBlendListBox for WinForms

HOW-TO

Override the default vListBox rendering and draw the information in multiple columns

SOLUTION

  1. First you need to drag and drop a new instance of vListBox into your Form.
  2. Drag and Drop a new Nwind data set as we will bind the vListBox to the Employees table in order to show the Notes column information on the left and the FirstName, LastName and Address information on the right side.
  3. Create 2 variables – an instance of the EmployeesDataTable and a BackgroundElement which will be used to render the background and border of the ListItem

    private ListBox2Columns.NwindDataSet.EmployeesDataTable employees;

    private BackgroundElement backFill;

  4. Bind the ListBox to the Employees data table, initialize the BackgroundElement’s instance and subscribe to the DrawListItem event.
    CopyC#
    NwindDataSet dataSet = new NwindDataSet();
EmployeesTableAdapter adapter = new EmployeesTableAdapter();
adapter.Fill(dataSet.Employees);
this.employees = dataSet.Employees;
this.vListBox1.DataSource = employees;
this.vListBox1.DisplayMember = "FirstName";
this.vListBox1.ItemHeight = 90;
this.vListBox1.DrawListItem += new DrawItemEventHandler(vListBox1_DrawListItem);
this.backFill = new BackgroundElement(Rectangle.Empty, this.vListBox1);
this.backFill.LoadTheme(this.vListBox1.Theme);
    CopyVB.NET
    Dim dataSet As New NwindDataSet()
Dim adapter As New EmployeesTableAdapter()
adapter.Fill(dataSet.Employees)
Me.employees = dataSet.Employees
Me.vListBox1.DataSource = employees
Me.vListBox1.DisplayMember = "FirstName"
Me.vListBox1.ItemHeight = 90
AddHandler vListBox1.DrawListItem, AddressOf vListBox1_DrawListItem
Me.backFill = New BackgroundElement(Rectangle.Empty, Me.vListBox1)
Me.backFill.LoadTheme(Me.vListBox1.Theme)
  5. In the DrawListItem event handler, we need to draw the border and background of the ListItem in its multiple states – Highlight, Selected, Default, Disabled.
    CopyC#
    int firstColumnWidth = this.vListBox1.Width / 2;
int secondColumnWidth = this.vListBox1.Width / 2;

// specify the bounds of the first and second columns.
Rectangle firstColumnBounds = new Rectangle(0, e.Bounds.Y, firstColumnWidth, e.Bounds.Height);
Rectangle secondColumnBounds = new Rectangle(firstColumnWidth + 3, e.Bounds.Y, secondColumnWidth, e.Bounds.Height);

// specify the background element's bounds.
Rectangle backgroundBounds = new Rectangle(0, e.Bounds.Y, this.vListBox1.Width, e.Bounds.Height);

// specify the BackgroundElement's ControlState.
ControlState ctrlState = this.Enabled ? ControlState.Normal : ControlState.Disabled;

if (e.State == DrawItemState.HotLight || e.State == DrawItemState.Focus)
{
  ctrlState = this.Enabled ? ControlState.Hover : ControlState.Disabled;
}
else if (e.State == DrawItemState.Selected)
{
  ctrlState = this.Enabled ? ControlState.Pressed : ControlState.DisabledPressed;
}
else if (e.State == DrawItemState.Disabled)
{
  ctrlState = ControlState.Disabled;
}

// Draw the background and border in the current ListItem's state.
this.backFill.Bounds = backgroundBounds;
if (ctrlState != ControlState.Normal)
{
  this.backFill.DrawElementFill(e.Graphics, ctrlState);
  this.backFill.DrawElementBorder(e.Graphics, ctrlState);
}
    CopyVB.NET
    Dim firstColumnWidth As Integer = Me.vListBox1.Width / 2
Dim secondColumnWidth As Integer = Me.vListBox1.Width / 2

' specify the bounds of the first and second columns.
Dim firstColumnBounds As New Rectangle(0, e.Bounds.Y, firstColumnWidth, e.Bounds.Height)
Dim secondColumnBounds As New Rectangle(firstColumnWidth + 3, e.Bounds.Y, secondColumnWidth, e.Bounds.Height)

' specify the background element's bounds.
Dim backgroundBounds As New Rectangle(0, e.Bounds.Y, Me.vListBox1.Width, e.Bounds.Height)

' specify the BackgroundElement's ControlState.
Dim ctrlState As ControlState = If(Me.Enabled, ControlState.Normal, ControlState.Disabled)

If e.State = DrawItemState.HotLight OrElse e.State = DrawItemState.Focus Then
  ctrlState = If(Me.Enabled, ControlState.Hover, ControlState.Disabled)
ElseIf e.State = DrawItemState.Selected Then
  ctrlState = If(Me.Enabled, ControlState.Pressed, ControlState.DisabledPressed)
ElseIf e.State = DrawItemState.Disabled Then
  ctrlState = ControlState.Disabled
End If

' Draw the background and border in the current ListItem's state.
Me.backFill.Bounds = backgroundBounds
If ctrlState IsNot ControlState.Normal Then
  Me.backFill.DrawElementFill(e.Graphics, ctrlState)
  Me.backFill.DrawElementBorder(e.Graphics, ctrlState)
End If
  6. Finally, we need to draw the ListItem strings in 2 columns. This should be added below the background and border rendering logic in the DrawListItem event handler.
    CopyC#
    // get the strings from the employees data table which correspond to the current ListItem.
string firstName = "First Name: " + this.employees[e.Index].FirstName;
string lastName = "Last Name: " + this.employees[e.Index].LastName;
string address = "Address: " + this.employees[e.Index].Address;
string notes = this.employees[e.Index].Notes;
// Draw the Strings.
e.Graphics.DrawString(notes, e.Font, Brushes.Black, firstColumnBounds);

SizeF firstNameSize = e.Graphics.MeasureString(firstName, e.Font);
SizeF lastNameSize = e.Graphics.MeasureString(lastName, e.Font);
SizeF addressSize = e.Graphics.MeasureString(address, e.Font);

e.Graphics.DrawString(notes, e.Font, Brushes.Black, firstColumnBounds);

float y = 0;
int stringsOffset = 2;
RectangleF firstNameBounds = new RectangleF(firstColumnBounds.Right, e.Bounds.Y + y, firstNameSize.Width, firstNameSize.Height);
e.Graphics.DrawString(firstName, e.Font, Brushes.Blue, firstNameBounds );
y += firstNameBounds.Height + stringsOffset;

RectangleF lastNameBounds = new RectangleF(firstColumnBounds.Right, e.Bounds.Y + y, lastNameSize.Width, lastNameSize.Height);
e.Graphics.DrawString(lastName, e.Font, Brushes.Blue, lastNameBounds);
y += lastNameBounds.Height + stringsOffset;

RectangleF addressBounds = new RectangleF(firstColumnBounds.Right, e.Bounds.Y + y, addressSize.Width, addressSize.Height);
e.Graphics.DrawString(address, e.Font, Brushes.Red, addressBounds);
    CopyVB.NET
    ' get the strings from the employees data table which correspond to the current ListItem.
Dim firstName As String = "First Name: " &Me.employees(e.Index).FirstName
Dim lastName As String = "Last Name: " &Me.employees(e.Index).LastName
Dim address As String = "Address: " &Me.employees(e.Index).Address
Dim notes As String = Me.employees(e.Index).Notes

e.Graphics.DrawString(notes, e.Font, Brushes.Black, firstColumnBounds)

Dim firstNameSize As SizeF = e.Graphics.MeasureString(firstName, e.Font)
Dim lastNameSize As SizeF = e.Graphics.MeasureString(lastName, e.Font)
Dim addressSize As SizeF = e.Graphics.MeasureString(address, e.Font)

e.Graphics.DrawString(notes, e.Font, Brushes.Black, firstColumnBounds)

Dim y As Single = 0
Dim stringsOffset As Integer = 2
Dim firstNameBounds As New RectangleF(firstColumnBounds.Right, e.Bounds.Y + y, firstNameSize.Width, firstNameSize.Height)
e.Graphics.DrawString(firstName, e.Font, Brushes.Blue, firstNameBounds)
y += firstNameBounds.Height + stringsOffset

Dim lastNameBounds As New RectangleF(firstColumnBounds.Right, e.Bounds.Y + y, lastNameSize.Width, lastNameSize.Height)
e.Graphics.DrawString(lastName, e.Font, Brushes.Blue, lastNameBounds)
y += lastNameBounds.Height + stringsOffset

Dim addressBounds As New RectangleF(firstColumnBounds.Right, e.Bounds.Y + y, addressSize.Width, addressSize.Height)
e.Graphics.DrawString(address, e.Font, Brushes.Red, addressBounds)

Override The Defaultv List Box Rendering


How to display an image in a grid cell

[image]

VIBlend Controls for WinForms Help Documentation
How to display an image in a grid cell
Send Feedback
Article information

Article relates to VIBlend DataGridView forWinForms

In this article we will show you how to display an image in a grid cell. The image will be loaded from the NWind Data Base.

HOW-TO

Display an image in a grid cell

SOLUTION

  1. First you need to drag and drop a new instance of vDataGridView into your Form.
  2. Drag and Drop a new Nwind data set as we will bind the vDataGridView to the Employees table.
  3. Bind the vDataGridView to the Employees table
    CopyC#
    NwindDataSet dataSet = new NwindDataSet();
EmployeesTableAdapter adapter = new EmployeesTableAdapter();
adapter.Fill(dataSet.Employees);
this.employees = dataSet.Employees;

this.grid.DataSource = this.employees;
this.grid.VIBlendTheme = VIBLEND_THEME.OFFICE2010BLACK;
this.grid.DataBind();
    CopyVB.NET
    Dim dataSet As New NwindDataSet()
Dim adapter As New EmployeesTableAdapter()
adapter.Fill(dataSet.Employees)
Me.employees = dataSet.Employees

Me.grid.DataSource = Me.employees
Me.grid.VIBlendTheme = VIBLEND_THEME.OFFICE2010BLACK
Me.grid.DataBind()
  4. Set the image column’s display settings to ImageOnly
    CopyC#
    int columnIndex = this.employees.Columns.IndexOf(this.employees.PhotoColumn);
this.grid.ColumnsHierarchy.Items[columnIndex].CellsDisplaySettins = DisplaySettings.ImageOnly;
    CopyVB.NET
    Dim columnIndex As Integer = Me.employees.Columns.IndexOf(Me.employees.PhotoColumn)
Me.grid.ColumnsHierarchy.Items(columnIndex).CellsDisplaySettins = DisplaySettings.ImageOnly
  5. Create a new ImageList instance and associate it to the vDataGridView
    CopyC#
    ImageList imageList = new ImageList();
imageList.ColorDepth = ColorDepth.Depth32Bit;
imageList.ImageSize = new Size(48, 48);
this.grid.ImageList = imageList;
    CopyVB.NET
    Dim imageList As New ImageList()
imageList.ColorDepth = ColorDepth.Depth32Bit
imageList.ImageSize = New Size(48, 48)
Me.grid.ImageList = imageList
  6. Finally, we need to fill the ImageList with images and set the cell’s ImageIndex and ImagePosition properties.
CopyC#
for (int i = 0; i < this.grid.RowsHierarchy.Items.Count; i++)
{
   byte[] content = (byte[])employees.Rows[i]["Photo"];
   using (MemoryStream stream = new MemoryStream())
   {
       stream.Write(content, 78, content.Length - 78);
       Bitmap image = new Bitmap(stream);
       imageList.Images.Add(image);

       HierarchyItem rowItem = this.grid.RowsHierarchy.Items[i];
       this.grid.RowsHierarchy.SetRowHeight(rowItem, 50);

       this.grid.CellsArea.SetCellImagePosition(rowItem, this.grid.ColumnsHierarchy.Items[columnIndex], ImagePositions.Center);
       this.grid.CellsArea.SetCellImage(rowItem, this.grid.ColumnsHierarchy.Items[columnIndex], i);
    }
}
CopyVB.NET
For i As Integer = 0 To Me.grid.RowsHierarchy.Items.Count - 1
Dim content() As Byte = CType(employees.Rows(i)("Photo"), Byte())
Using stream As New MemoryStream()
stream.Write(content, 78, content.Length - 78)
Dim image As New Bitmap(stream)
imageList.Images.Add(image)

Dim rowItem As HierarchyItem = Me.grid.RowsHierarchy.Items(i)
Me.grid.RowsHierarchy.SetRowHeight(rowItem, 50)

Me.grid.CellsArea.SetCellImagePosition(rowItem, Me.grid.ColumnsHierarchy.Items(columnIndex), ImagePositions.Center)
Me.grid.CellsArea.SetCellImage(rowItem, Me.grid.ColumnsHierarchy.Items(columnIndex), i)
End Using
Next i
 The following image example shows a data grid with an image column. The images are loaded from the NWind data base.

Display An Image In Grid Cell


How to programmatically set the value of a grid cell

[image]

VIBlend Controls for WinForms Help Documentation
How to programmatically set the value of a grid cell
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms

HOW-TO

Set a value of a data grid cell.

SOLUTION

To achieve this, follow these steps:

  1. Create a new instance of the vDataGridView via drag and drop from the toolbox or create it programmatically.
  2. Create rows and columns.
    CopyC#
    // Create grid columns
for (int i = 0; i < 10; i++)
{
  this.vDataGridView1.ColumnsHierarchy.Items.Add("Column" + i);
}

// Create grid rows
for (int j = 0; j < 10; j++)
{
  this.vDataGridView1.RowsHierarchy.Items.Add("Row" + j);
}
    CopyVB.NET
    ' Create grid columns
For i As Integer = 0 To 9
  Me.vDataGridView1.ColumnsHierarchy.Items.Add(&amp;quot;Column&amp;quot; &amp;amp; i)
Next i

' Create grid rows
For j As Integer = 0 To 9
  Me.vDataGridView1.RowsHierarchy.Items.Add(&amp;quot;Row&amp;quot; &amp;amp; j)
Next j
  3. Set the cell’s value
CopyC#
Grid1.CellsArea.SetCellValue(Grid1.RowsHierarchy.Items[0], Grid1.ColumnsHierarchy.Items[0], "www.porsche.com");
CopyVB.NET
Grid1.CellsArea.SetCellValue(Grid1.RowsHierarchy.Items(0), Grid1.ColumnsHierarchy.Items(0), "www.porsche.com")


How to programmatically get the value of a grid cell

[image]

VIBlend Controls for WinForms Help Documentation
How to programmatically get the value of a grid cell
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms

HOW-TO

Get the value of a data grid cell.

SOLUTION

To achieve this, follow these steps:

  1. Create a new instance of the vDataGridView via drag and drop from the toolbox or create it programmatically.
  2. Create rows and columns.
    CopyC#
    // Create grid columns
for (int i = 0; i < 10; i++)
{
   this.vDataGridView1.ColumnsHierarchy.Items.Add("Column" + i);
}

// Create grid rows
for (int j = 0; j < 10; j++)
{
   this.vDataGridView1.RowsHierarchy.Items.Add("Row" + j);
}
    CopyVB.NET
    ' Create grid columns
For i As Integer = 0 To 9
   Me.vDataGridView1.ColumnsHierarchy.Items.Add("Column" &amp; i)
Next i

' Create grid rows
For j As Integer = 0 To 9
   Me.vDataGridView1.RowsHierarchy.Items.Add("Row" & j)
Next j
  3. Fill the grid with sample data
    CopyC#
    // Fill the grid with sample data
for (int i = 0; i < 10; i++)
{
   for (int j = 0; j < 10; j++)
   {
      this.vDataGridView1.CellsArea.SetCellValue(this.vDataGridView1.RowsHierarchy.Items[i],
      this.vDataGridView1.ColumnsHierarchy.Items[j], "Cell" + i + ";" + j);
   }
}

// auto resize grid's columns
this.vDataGridView1.ColumnsHierarchy.AutoResize();
this.vDataGridView1.Invalidate();
    CopyVB.NET
    ' Fill the grid with sample data

For i As Integer = 0 To 9
   For j As Integer = 0 To 9
      Me.vDataGridView1.CellsArea.SetCellValue(Me.vDataGridView1.RowsHierarchy.Items(i), Me.vDataGridView1.ColumnsHierarchy.Items(j), "Cell" & i & ";" & j)
   Next j
Next i
' auto resize grid's columns
Me.vDataGridView1.ColumnsHierarchy.AutoResize()
Me.vDataGridView1.Invalidate()
  4. Get the top-left cell’s value
CopyC#
object value = Grid1.CellsArea.GetCellValue(Grid1.RowsHierarchy.Items[0], Grid1.ColumnsHierarchy.Items[0]);
CopyVB.NET
Dim value As Object = Grid1.CellsArea.GetCellValue(Grid1.RowsHierarchy.Items(0), Grid1.ColumnsHierarchy.Items(0))


How to validate the value of a grid cell

[image]

VIBlend Controls for WinForms Help Documentation
How to validate the value of a grid cell
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms

HOW-TO

Validate the new value of a cell

SOLUTION

To achieve this, follow these steps:

  1. Subscribe to the CellValidating event of the DataGridView
  2. In the event handler, show a prompt box which will allow you to approve or deny the new cell’s value.
CopyC#
void Grid1_CellValidating(object sender, GridCellCancelEventArgs args)
{
    DialogResult result = MessageBox.Show("Do you want to save the value", "Edit Validation", MessageBoxButtons.OKCancel, MessageBoxIcon.Question);
    if (result != DialogResult.OK)
    {
        args.Cancel = true;
    }
}
CopyVB.NET
Private Sub Grid1_CellValidating(ByVal sender As Object, ByVal args As GridCellCancelEventArgs)
        Dim result As DialogResult = MessageBox.Show("Do you want to save the value", "Edit Validation", MessageBoxButtons.OKCancel, MessageBoxIcon.Question)
        If result <>System.Windows.Forms.DialogResult.OK Then
        args.Cancel = True
    End If
End Sub
Note Note

The CellValidating event occurs before the update of the cell’s value.

Validate The Value Of Grid Cell


How to add Ribbon Groups at Design-Time

[image]

VIBlend Controls for WinForms Help Documentation
How to add Ribbon Groups at Design-Time
Send Feedback
Article information

Article relates to vRibbonBar for WinForms

HOW-TO

Create and add a RibbonGroup in Design Time

SOLUTION

To achieve this, follow these steps:

  1. Create a new instance of the vRibbonBar via drag and drop from the toolbox or create it programmatically.

    Adding Ribbon Groups In Design Time 1

    Your screen should look like the one above.

  2. Add a new TabPage – click on the “Add New Tab” button

    Adding Ribbon Groups In Design Time 2

  3. Add a new RibbonGroup – click on the “Add Ribbon Group” button

    Adding Ribbon Groups In Design Time 3

  4. If you want to add more ribbon groups in the selected TabPage, continue clicking on the “Add Ribbon Group” button.
  5. In order to resize the group, you need to select it and then drag the horizontal visual indicators to left or right.

    Adding Ribbon Groups In Design Time 4

  6. If you want to add a control to the RibbonGroup, just drag and drop any control from the toolbox in the RibbonGroup’s content

    Adding Ribbon Groups In Design Time 5

  7. To change the RibbonBar’s theme, you need to use the VIBlendTheme property and then select one of the available themes. You can do this by using the Property Window or through the built-in ActionList

Adding Ribbon Groups In Design Time 6

Here is a RibbonBar with Office2010Black Theme

Adding Ribbon Groups In Design Time 7


How to add Ribbon Groups at Run-Time

[image]

VIBlend Controls for WinForms Help Documentation
How to add Ribbon Groups at Run-Time
Send Feedback
Article information

Article relates to vRibbonBar for WinForms

HOW-TO

Create and add a RibbonGroup in Run Time

SOLUTION

To achieve this, follow these steps:

  1. Create a new instance of the vRibbonBar via drag and drop from the toolbox or create it programmatically. Adding Ribbon Groups In Run Time 1

    Your screen should look like the one above.

  2. Add a new vTabPageto the RibbonBar.
    CopyC#
    vTabPage page = new vTabPage("TabPage" + this.vRibbonBar1.TabPages.Count);
this.vRibbonBar1.TabPages.Add(page);
    CopyVB.NET
    Dim page As vTabPage = New vTabPage("TabPage" & Me.vRibbonBar1.TabPages.Count)
Me.vRibbonBar1.TabPages.Add(page)
     Adding Ribbon Groups In Run Time 2
  3. Create a new RibbonGroup, set its Theme and Size properties.Thenadd it to the RibbonBar’s selected tab page.
    CopyC#
    vRibbonGroup group = new vRibbonGroup();
group.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE;
group.Width = 200;
group.Height = 76;

if (this.vRibbonBar1.SelectedTab.Controls.Count == 0)
{
   vRibbonHorizontalLayoutPanel layoutPanel = new vRibbonHorizontalLayoutPanel();
   layoutPanel.Dock = DockStyle.Fill;
   this.vRibbonBar1.SelectedTab.Controls.Add(layoutPanel);
   layoutPanel.BackColor = Color.Transparent;
   layoutPanel.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE;
}

this.vRibbonBar1.SelectedTab.LayoutPanel.Controls.Add(group);
group.Text = "Group";
    CopyVB.NET
    Dim group As vRibbonGroup = New vRibbonGroup()
group.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE
group.Width = 200
group.Height = 76

If Me.vRibbonBar1.SelectedTab.Controls.Count = 0 Then
    Dim layoutPanel As vRibbonHorizontalLayoutPanel = New vRibbonHorizontalLayoutPanel()
    layoutPanel.Dock = DockStyle.Fill
    Me.vRibbonBar1.SelectedTab.Controls.Add(layoutPanel)
    layoutPanel.BackColor = Color.Transparent
    layoutPanel.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE
End If

Me.vRibbonBar1.SelectedTab.LayoutPanel.Controls.Add(group)
group.Text = "Group"
     Adding Ribbon Groups In Run Time 3
  4. If you want to programatically add a control toyourribbon group, do the following:
CopyC#
vButton button = new vButton();
button.Text = "Text";
button.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE;
this.group.Content.ContentPanel.Controls.Add(button);
CopyVB.NET
Dim button As vButton = New vButton()
button.Text = "Text"
button.VIBlendTheme = VIBlend.Utilities.VIBLEND_THEME.OFFICEBLUE
Me.group.Content.ContentPanel.Controls.Add(button)

Adding Ribbon Groups In Run Time 4


How to hide a column in DataGrid

[image]

VIBlend Controls for WinForms Help Documentation
How to hide a column in DataGrid
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms

HOW-TO

Hide a column in VIBlend DataGridView for WinForms

SOLUTION

To achieve this, you need to get the instance of the HierarchyItem to be hidden in the ColumnsHierarchy, and set its Hidden property to true.

CopyC#
this.dataGridView.ColumnsHierarchy.Items[0].Hidden = true;
CopyVB.NET
Me.dataGridView.ColumnsHierarchy.Items(0).Hidden = True


How to hide a row in DataGrid

[image]

VIBlend Controls for WinForms Help Documentation
How to hide a row in DataGrid
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms

HOW-TO

Hide a row in VIBlend DataGridView for WinForms

SOLUTION

To achieve this, you need to get the instance of the HierarchyItem to be hidden in the RowsHierarchy, and set its Hidden property to true.

CopyC#
this.dataGridView.RowsHierarchy.Items[0].Hidden = true;
CopyVB.NET
Me.dataGridView.RowsHierarchy.Items(0).Hidden = True


How to switch from the traditional OLAP layout to compact style layout

[image]

VIBlend Controls for WinForms Help Documentation
How to switch from the traditional OLAP layout to compact style layout
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms

HOW-TO

Switch from traditional OLAP layout to compact style layout

SOLUTION

One of the main drawbacks of the traditional OLAP style rows layout is that it takes a lot of screen space.

Switching From TraditionalOLAPTo Compact Style 1

This could be improved by using the compact style layout. In this mode the rows of the pivot table are rendered in a tree-like structure.

Switching From TraditionalOLAPTo Compact Style 2

Switching from default to compact style rendering is very easy. It requires setting the value of RowsHierarchy.CompactStyleRendering property to true:

CopyC#
grid.RowsHierarchy.CompactStyleRenderingEnabled = true;
grid.RowsHierarchy.AutoResize();
grid.Invalidate();
CopyVB.NET
grid.RowsHierarchy.CompactStyleRenderingEnabled = True
grid.RowsHierarchy.AutoResize()
grid.Invalidate()


How to set an image to a header item in DataGrid

[image]

VIBlend Controls for WinForms Help Documentation
How to set an image to a header item in DataGrid
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms

HOW-TO

Set an image to a header item in VIBlend DataGridView for WinForms

SOLUTION

To achieve this, you need to do the following:

  1. Create a new ImageList and add images to it.
  2. Associate the ImageList to vDataGridView’s instance
  3. Set the ImageIndex property of an HierarchyItem instance
CopyC#
this.dataGridView.ImageList = this.imageList1;
this.dataGridView.ColumnsHierarchy.Items[0].ImageIndex = 0;
CopyVB.NET
Me.dataGridView.ImageList = Me.imageList1
Me.dataGridView.ColumnsHierarchy.Items(0).ImageIndex = 0

Setting Image To Header Item


How to resize a DataGrid header in code

[image]

VIBlend Controls for WinForms Help Documentation
How to resize a DataGrid header in code
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms

HOW-TO

Resize a header item in VIBlend DataGridView for WinForms

SOLUTION

To resize an item from the RowsHierarchy, you need to do the following:

CopyC#
dataGridView.RowsHierarchy.Items[0].Height = 200;
CopyVB.NET
dataGridView.RowsHierarchy.Items(0).Height = 200

You can also use the Width property, in order to set the row header item’s width.

To resize an item from the ColumnsHierarchy, you need to do the following:

CopyC#
dataGridView.ColumnsHierarchy.Items[0].Width = 200;
CopyVB.NET
dataGridView.ColumnsHierarchy.Items(0).Width = 200
 You can also use the Height property, in order to set the column header item’s height.

Data Grid Header Resize Image


How to add an image to a TabPage in WinForms TabControl

[image]

VIBlend Controls for WinForms Help Documentation
How to add an image to a TabPage in WinForms TabControl
Send Feedback
Article information

Article relates to VIBlend TabControl for WinForms

HOW-TO

Add an image to a tab page

SOLUTION

To achieve this, you need to do the following:

  1. Create a new ImageList
  2. Add images to the ImageList’s Images collection
  3. Associate the ImageList to the vTabControl
  4. Set the ImageIndex property of a vTabPage instance.
CopyC#
this.vTabPage1.ImageIndex = 0;
CopyVB.NET
Me.vTabPage1.ImageIndex = 0

VIBlend Tab Page Image


How to add TabPages programatically

[image]

VIBlend Controls for WinForms Help Documentation
How to add TabPages programatically
Send Feedback
Article information

Article relates to VIBlendTabControl for WinForms

HOW-TO

Add a vTabPage to the vTabControl

SOLUTION

In order to add a tab page programmatically, you need to use the Add method of the TabPages collection

CopyC#
for (int i = 0; i < 10; i++)
{
   vTabPage page = new vTabPage("Page" + i);
   this.vTabControl1.TabPages.Add(page);
}
CopyVB.NET
For i As Integer = 0 To 9
    Dim page As vTabPage = New vTabPage("Page" & i)
    Me.vTabControl1.TabPages.Add(page)
Next i
 If you want to remove a tab page, use the Remove and RemoveAt methods of the TabPages collection.

Here is the result:

Tab Page Programatically


How to add an Application Button to RibbonBar

[image]

VIBlend Controls for WinForms Help Documentation
How to add an Application Button to RibbonBar
Send Feedback
Article information

Article relates to VIBlend ApplicationButton and vRibbonBar for WinForms

HOW-TO

Add controls to the ApplicationButton and associate it to the vRibbonBar

SOLUTION

You can add any control to the ApplicationButton in design time by using the ApplicationButton’s designer

Tutorial Application Button Image 1

You can also change the Size of the ApplicationButton by using itsDropDownHeight and DropDownWidth properties.

Tutorial Application Button Image 2

In order to add a button to the ApplicationButton programmatically, you need to do the following:

CopyC#
vButton button = new vButton();
button.Location = new Point(50, 50);
button.Text = "Text";
this.vButton4.Enabled = false;
this.vRibbonApplicationButton1.Content.Controls.Add(button);
CopyVB.NET
Dim button As New vButton()
button.Location = New Point(50, 50)
button.Text = "Text"
Me.vButton4.Enabled = False
Me.vRibbonApplicationButton1.Content.Controls.Add(button)

You can associate the ApplicationButton to the vRibbonBar by using the vRibbonBar’sApplicationButton property.

Tutorial Application Button Image 3

If you want to programmatically associate the ApplicationButton to the vRibbonBar, you need to do the following:

CopyC#
this.vRibbonBar1.ApplicationButton = this.vRibbonApplicationButton1;

if (this.vRibbonBar1.QuickAccessToolbar != null)
{
      // reset QAT location
      this.vRibbonBar1.QuickAccessToolbar = null;
      this.vRibbonBar1.QuickAccessToolbar = this.quickAccessToolbar1;
}
CopyVB.NET
Me.vRibbonBar1.ApplicationButton = Me.vRibbonApplicationButton1

If Me.vRibbonBar1.QuickAccessToolbar IsNot Nothing Then
  ' reset QAT location
  Me.vRibbonBar1.QuickAccessToolbar = Nothing
  Me.vRibbonBar1.QuickAccessToolbar = Me.quickAccessToolbar1
End If


How to create a QuickAccesToolbar and associate it with the vRibbonBar

[image]

VIBlend Controls for WinForms Help Documentation
How to create a QuickAccesToolbar and associate it with the vRibbonBar
Send Feedback
Article information

Article relates to VIBlend QuickAccessToolbar and vRibbonBar for WinForms

HOW-TO

Add a button to the QuickAccessToolbar and associate it to the vRibbonBar

SOLUTION

You can add a button, radio button, checkbox, etc. to the QAT in design time by using the QAT’s ActionList

In order to add a button to the QAT programmatically, you need to do the following:

CopyC#
vHorizontalLayoutPanel panel = (vHorizontalLayoutPanel)this.quickAccessToolbar1.Controls[0];
vButton button = new vButton();
button.Size = new Size(16, 16);
this.quickAccessToolbar1.Content.Controls.Add(button);
CopyVB.NET
Dim panel As vHorizontalLayoutPanel = CType(Me.quickAccessToolbar1.Controls(0), vHorizontalLayoutPanel)
Dim button As New vButton()
button.Size = New Size(16, 16)
Me.quickAccessToolbar1.Content.Controls.Add(button)

You can associate the QAT to the vRibbonBar by using the vRibbonBar’sQuickAccessToolbar property.

If you want to programmatically add the QAT to the vRibbonBar, you can do the following:

CopyC#
this.vRibbonBar1.QuickAccessToolbar = this.quickAccessToolbar1;
this.AssociateQAT.Enabled = false;
this.quickAccessToolbar1.Content.PerformLayout();
this.quickAccessToolbar1.PerformLayout();
this.quickAccessToolbar1.Invalidate();
this.vRibbonBar1.Invalidate();
this.quickAccessToolbar1.Location = new Point(this.quickAccessToolbar1.Location.X + 5, this.quickAccessToolbar1.Location.Y);
CopyVB.NET
Me.vRibbonBar1.QuickAccessToolbar = Me.quickAccessToolbar1
Me.AssociateQAT.Enabled = False
Me.quickAccessToolbar1.Content.PerformLayout()
Me.quickAccessToolbar1.PerformLayout()
Me.quickAccessToolbar1.Invalidate()
Me.vRibbonBar1.Invalidate()
Me.quickAccessToolbar1.Location = New Point(Me.quickAccessToolbar1.Location.X + 5, Me.quickAccessToolbar1.Location.Y)


Cells Formatting

[image]

VIBlend Controls for WinForms Help Documentation
Cells Formatting
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms

HOW-TO

Format cells values in vDataGridView for WinForms

SOLUTION

To achieve this, follow these steps:

  1. Create a new instance of the vDataGridView via drag and drop from the toolbox or create it programmatically.
  2. Bind the DataGrid to the Invoices table
    CopyC#
    NwindDataSetTableAdapters.InvoicesTableAdapter adapter = new DataBindingAndEditors.NwindDataSetTableAdapters.InvoicesTableAdapter();
adapter.Fill(nwindDataSet1.Invoices);

DataTable tbl = this.nwindDataSet1.Invoices;

vDataGridView1.BoundFields.Clear();
vDataGridView1.BoundPivotColumns.Clear();
vDataGridView1.BoundPivotRows.Clear();
vDataGridView1.BoundPivotValues.Clear();
vDataGridView1.DataSource = null;

for (int i = 0; i < tbl.Columns.Count; i++)
{
  DataColumn col = tbl.Columns[i];
  BoundField boundField = newBoundField(col.Caption, col.ColumnName);
  vDataGridView1.BoundFields.Add(boundField);
}

vDataGridView1.DataSource = tbl;
vDataGridView1.ColumnsHierarchy.AutoResize();
vDataGridView1.RowsHierarchy.AutoResize();
vDataGridView1.Refresh();
    CopyVB.NET
    Dim adapter AsNwindDataSetTableAdapters.InvoicesTableAdapter = NewDataBindingAndEditors.NwindDataSetTableAdapters.InvoicesTableAdapter()
adapter.Fill(nwindDataSet1.Invoices)

Dimt bl As DataTable = Me.nwindDataSet1.Invoices
vDataGridView1.BoundFields.Clear()
vDataGridView1.BoundPivotColumns.Clear()
vDataGridView1.BoundPivotRows.Clear()
vDataGridView1.BoundPivotValues.Clear()
vDataGridView1.DataSource = Nothing

Dim i As Integer = 0
Do While i <tbl.Columns.Count
    Dim col AsDataColumn = tbl.Columns(i)
    Dim boundField As BoundField = New BoundField(col.Caption, col.ColumnName)
    vDataGridView1.BoundFields.Add(boundField)
        i += 1
Loop

vDataGridView1.DataSource = tbl

vDataGridView1.ColumnsHierarchy.AutoResize()
vDataGridView1.RowsHierarchy.AutoResize()
vDataGridView1.Refresh()
  3. Set a custom format string to an entire column.
CopyC#
int columnIndex = this.nwindDataSet1.Invoices.Columns.IndexOf(this.nwindDataSet1.Invoices.RequiredDateColumn);
vDataGridView1.ColumnsHierarchy.Items[columnIndex].CellsFormatString = "{0:yyyy/MMMM/dd}";
CopyVB.NET
DimcolumnIndexAsInteger = Me.nwindDataSet1.Invoices.Columns.IndexOf(Me.nwindDataSet1.Invoices.RequiredDateColumn)
vDataGridView1.ColumnsHierarchy.Items(columnIndex).CellsFormatString = "{0:yyyy/MMMM/dd}"
 The image below emphasizes the “RequiredDate” column which uses a custom format string


DataGrid Cells Styling

[image]

VIBlend Controls for WinForms Help Documentation
DataGrid Cells Styling
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms

HOW-TO

Set a cell style to an entire column in vDataGridView for WinForms

SOLUTION

To achieve this, follow these steps:

  1. Create a new instance of the GridCellStyle
  2. Set its FillStyle property which defines the cell’s background.
  3. Set its text color property which defines the cell’s text color
  4. Set the cell’s border color through the GridCellStyle’sBorderColor property.
  5. Apply the cell style to a column item by using the CellStyle property.
CopyC#
GridCellStyle cellStyle = GridTheme.GetDefaultTheme(dataGrid.VIBlendTheme).GridCellStyle;
cellStyle.FillStyle = newFillStyleSolid(Color.Blue);
cellStyle.TextColor = Color.Yellow;
cellStyle.BorderColor = Color.Red;
dataGrid.ColumnsHierarchy.Items[0].CellsStyle = cellStyle;
CopyVB.NET
Dim cellStyle As GridCellStyle = GridTheme.GetDefaultTheme(dataGrid.VIBlendTheme).GridCellStyle
cellStyle.FillStyle = newFillStyleSolid(Color.Blue)
cellStyle.TextColor = Color.Yellow
cellStyle.BorderColor = Color.Red
dataGrid.ColumnsHierarchy.Items(0).CellsStyle = cellStyle
 The image below shows an example which uses the GridCellStyle which we have just created.

Data Grid Cells Styling


Add an image to a TreeNode

[image]

VIBlend Controls for WinForms Help Documentation
Add an image to a TreeNode
Send Feedback
Article information

Article relates to VIBlend TreeView for WinForms

HOW-TO

Add an image to a TreeNode

SOLUTION

To achieve this, follow these steps:

  1. Create a new instance of the vTreeViewcontrol.
  2. Create a new instance of the ImageList component and fill it with images using the Images collection.
  3. Add tree nodes through the Nodes collection of the vTreeView
  4. Associate the ImageList to the vTreeView by using the ImageList property
  5. Use the ImageIndex property to associate an image from the ImageList to a TreeNode. You can also use the SelectedImageIndex property which will set an image for the selected state of the TreeNode, or the StateImageIndex property which will set an image when the TreeNode is expanded.
CopyC#
this.vTreeNode1.ImageIndex = 0;
this.vTreeNode1.SelectedImageIndex = 1;
this.vTreeNode1.StateImageIndex = 2;
CopyVB.NET
Me.vTreeNode1.ImageIndex = 0
Me.vTreeNode1.SelectedImageIndex = 1
Me.vTreeNode1.StateImageIndex = 2
 Below is shown an image of a sample TreeView with images


How to set a checkbox editor to a grid column

[image]

VIBlend Controls for WinForms Help Documentation
How to set a checkbox editor to a grid column
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms

HOW-TO

Assign an editor to a grid column.

SOLUTION

To achieve this, follow these steps:

  1. Create a new instance of CheckBoxEditor
  2. Set the CellsTextAlignment property of the column
  3. Set the CellsEditor property of the column
CopyC#
CheckBoxEditor editor = new CheckBoxEditor();
this.dataGridView.ColumnsHierarchy.Items[1].CellsTextAlignment = ContentAlignment.MiddleCenter;
this.dataGridView.ColumnsHierarchy.Items[1].CellsEditor = editor;
CopyVB.NET
Dim editor As New CheckBoxEditor()
Me.dataGridView.ColumnsHierarchy.Items(1).CellsTextAlignment = ContentAlignment.MiddleCenter
Me.dataGridView.ColumnsHierarchy.Items(1).CellsEditor = editor
 Below is shown an image of a DataGrid with CheckBoxEditor


Sorting DataGridView’s data

[image]

VIBlend Controls for WinForms Help Documentation
Sorting DataGridView’s data
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms

HOW-TO

Apply sorting to a hierarchy item

SOLUTION

To achieve this, follow these steps:

  1. Create a new instance of the vDataGridView via drag and drop from the toolbox or create it programmatically.
  2. Bind the grid and set the SortMode property of the bound fields.
    CopyC#
    NwindDataSetTableAdapters.InvoicesTableAdapter adapter = new DataBindingPivotTable.NwindDataSetTableAdapters.InvoicesTableAdapter();
adapter.Fill(nwindDataSet1.Invoices);
DataTable tbl = this.nwindDataSet1.Invoices;
foreach (DataColumn col in tbl.Columns)
{
   BoundField boundField = new BoundField(col.Caption, col.ColumnName);
   boundField.SortMode = GridItemSortMode.Automatic;
   dataGridView.BoundFields.Add(boundField);
}

dataGridView.DataSource = tbl;
dataGridView.DataBind();

dataGridView.ColumnsHierarchy.ExpandAllItems();
dataGridView.ColumnsHierarchy.AutoResize();
dataGridView.RowsHierarchy.AutoResize();

dataGridView.Refresh();
    CopyVB.NET
    Dim adapter As NwindDataSetTableAdapters.InvoicesTableAdapter = New DataBindingPivotTable.NwindDataSetTableAdapters.InvoicesTableAdapter()
adapter.Fill(nwindDataSet1.Invoices)
Dim tbl As DataTable = Me.nwindDataSet1.Invoices
For Each col As DataColumn In tbl.Columns
   Dim boundField As New BoundField(col.Caption, col.ColumnName)
   boundField.SortMode = GridItemSortMode.Automatic
   dataGridView.BoundFields.Add(boundField)
Next col

dataGridView.DataSource = tbl
dataGridView.DataBind()

dataGridView.ColumnsHierarchy.ExpandAllItems()
dataGridView.ColumnsHierarchy.AutoResize()
dataGridView.RowsHierarchy.AutoResize()

dataGridView.Refresh()
  3. After you bind the data grid, you need to call the SortBy method to sort its content. The SortBy method can be found in the ColumnsHierarchy and in the RowsHierarchy. This means that you can apply sorting either by rows or by columns. The following code example sorts the data grid’s RowsHierarchy in ascending sort order.
CopyC#
dataGridView.RowsHierarchy.SortBy(this.dataGridView.ColumnsHierarchy.Items[0], SortingDirection.Ascending);
CopyVB.NET
dataGridView.RowsHierarchy.SortBy(Me.dataGridView.ColumnsHierarchy.Items(0), SortingDirection.Ascending)
 Here is the result:

Sorting Data Grid View’s Data


Creating a Pivot Table

[image]

VIBlend Controls for WinForms Help Documentation
Creating a Pivot Table
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms

HOW-TO

Create a pivot table.

SOLUTION

To achieve this, follow these steps:

  1. Create a new instance of the vDataGridView via drag and drop from the toolbox or create it programmatically.
  2. Bind the grid to the Invoices table. Add the pivot rows to the BoundPivotRows collection. In this example, we use “Country” and “City”. Add a pivot column to the BoundPivotColumns collection. The demo uses the Shippers_Company as a column. Finally add the pivot values. You can see the result in the picture below the source code.
CopyC#
dataGridView.ColumnsHierarchy.AllowResize = true;
dataGridView.RowsHierarchy.AllowResize = true;

NwindDataSetTableAdapters.InvoicesTableAdapter adapter = new DataBindingPivotTable.NwindDataSetTableAdapters.InvoicesTableAdapter();
adapter.Fill(nwindDataSet1.Invoices);

DataTable tbl = this.nwindDataSet1.Invoices;

dataGridView.BoundPivotRows.Add(newBoundField("Country", "Country"));
dataGridView.BoundPivotRows.Add(newBoundField("City", "City"));
dataGridView.BoundPivotColumns.Add(newBoundField("Carrier", "Shippers_CompanyName"));
dataGridView.BoundPivotValues.Add(newBoundValueField("Count of Sales", "ExtendedPrice", PivotFieldFunction.Count));
dataGridView.BoundPivotValues.Add(newBoundValueField("Amount of Sales", "ExtendedPrice", PivotFieldFunction.Sum));
dataGridView.BoundPivotValues.Add(newBoundValueField("Avg Sale Amount", "ExtendedPrice", PivotFieldFunction.Average));

for (int i = 0; i < dataGridView.BoundPivotValues.Count; i++)
{
    dataGridView.BoundPivotValues[i].CellsFormatString = "{0:C}";
    dataGridView.BoundPivotValues[i].CellsTextAlignment = ContentAlignment.MiddleRight;
}

dataGridView.PivotValuesOnRows = false;

dataGridView.DataSource = tbl;
dataGridView.DataBind();
CopyVB.NET
dataGridView.ColumnsHierarchy.AllowResize = True
dataGridView.RowsHierarchy.AllowResize = True

Dim adapter As NwindDataSetTableAdapters.InvoicesTableAdapter = New DataBindingPivotTable.NwindDataSetTableAdapters.InvoicesTableAdapter()
adapter.Fill(nwindDataSet1.Invoices)

Dimt bl As DataTable = Me.nwindDataSet1.Invoices

dataGridView.BoundPivotRows.Add(NewBoundField("Country", "Country"))
dataGridView.BoundPivotRows.Add(NewBoundField("City", "City"))
dataGridView.BoundPivotColumns.Add(NewBoundField("Carrier", "Shippers_CompanyName"))
dataGridView.BoundPivotValues.Add(NewBoundValueField("Count of Sales", "ExtendedPrice", PivotFieldFunction.Count))
dataGridView.BoundPivotValues.Add(NewBoundValueField("Amount of Sales", "ExtendedPrice", PivotFieldFunction.Sum))
dataGridView.BoundPivotValues.Add(NewBoundValueField("Avg Sale Amount", "ExtendedPrice", PivotFieldFunction.Average))

For i AsInteger = 0 TodataGridView.BoundPivotValues.Count - 1
    dataGridView.BoundPivotValues(i).CellsFormatString = "{0:C}"
    dataGridView.BoundPivotValues(i).CellsTextAlignment = ContentAlignment.MiddleRight
Next i

dataGridView.PivotValuesOnRows = False

dataGridView.DataSource = tbl
dataGridView.DataBind()

Creating Pivot Table 1

You can also add a totals column by using the following:

CopyC#
dataGridView.PivotColumnsTotalsEnabled = true;
CopyVB.NET
dataGridView.PivotColumnsTotalsEnabled = True

Creating Pivot Table 2


DataGrid Filtering

[image]

VIBlend Controls for WinForms Help Documentation
DataGrid Filtering
Send Feedback
Article information

Article relates to VIBlend DataGridView for WinForms

HOW-TO

Create and apply filtering to VIBlend DataGridView

SOLUTION

To achieve this, follow these steps:

  1. Create a new instance of the vDataGridView via drag and drop from the toolbox or create it programmatically.
  2. Bind the data grid to the Invoices table.
    CopyC#
    try
{
   NwindDataSet_InovicesTableAdapters.InvoicesTableAdapter adapter = new IntegratedDemo.NwindDataSet_InovicesTableAdapters.InvoicesTableAdapter();
   adapter.Fill(nwindDataSet_Inovices.Invoices);
}
catch (System.Exception ex)
{
   MessageBox.Show(ex.Message);
   return;
}

DataTable tbl = this.nwindDataSet_Inovices.Invoices;

Grid1.BoundFields.Clear();
Grid1.BoundPivotColumns.Clear();
Grid1.BoundPivotRows.Clear();
Grid1.BoundPivotValues.Clear();
Grid1.DataSource = null;

Grid1.PivotValuesOnRows = false;

int iColumns = 0;
foreach (DataColumn col in tbl.Columns)
{
  BoundField boundField = new BoundField(col.Caption, col.ColumnName);
  Grid1.BoundFields.Add(boundField);

  if (++iColumns == 5)
  break;
}

Grid1.DataSource = tbl.DefaultView;
Grid1.DataBind();
    CopyVB.NET
    Try
   Dim adapter As NwindDataSet_InovicesTableAdapters.InvoicesTableAdapter = New IntegratedDemo.NwindDataSet_InovicesTableAdapters.InvoicesTableAdapter()
   adapter.Fill(nwindDataSet_Inovices.Invoices)
Catch ex As System.Exception
   MessageBox.Show(ex.Message)
   Return
End Try

Dim tbl As DataTable = Me.nwindDataSet_Inovices.Invoices

Grid1.BoundFields.Clear()
Grid1.BoundPivotColumns.Clear()
Grid1.BoundPivotRows.Clear()
Grid1.BoundPivotValues.Clear()
Grid1.DataSource = Nothing

Grid1.PivotValuesOnRows = False

Dim iColumns As Integer = 0
For Each col As DataColumn In tbl.Columns
  Dim boundField As New BoundField(col.Caption, col.ColumnName)
  Grid1.BoundFields.Add(boundField)
  iColumns = iColumns + 1
  If iColumns = 5 Then
  Exit For
  End If
Next col

Grid1.DataSource = tbl.DefaultView
Grid1.DataBind()
  3. AutoResize data grid columns. The following will resize them to their contents.
    CopyC#
    Grid1.ColumnsHierarchy.AutoResize();
Grid1.RowsHierarchy.AutoResize();
    CopyVB.NET
    Grid1.ColumnsHierarchy.AutoResize()
Grid1.RowsHierarchy.AutoResize()
  4. Create a filter group which contains two string filters.
    CopyC#
    StringFilter stringFilter1 = newStringFilter();
stringFilter1.ComparisonOperator = StringFilterComparisonOperator.NOT_EMPTY;
stringFilter1.Value = "";

StringFilter stringFilter2 = newStringFilter();
stringFilter1.ComparisonOperator = StringFilterComparisonOperator.CONTAINS;
stringFilter1.Value = "a";

FilterGroup<string> filterGroup = newFilterGroup<string>();
filterGroup.AddFilter(FilterOperator.AND, stringFilter1);
filterGroup.AddFilter(FilterOperator.AND, stringFilter2);
    CopyVB.NET
    Dim stringFilter1 As New StringFilter()
stringFilter1.ComparisonOperator = StringFilterComparisonOperator.NOT_EMPTY
stringFilter1.Value = ""

Dim stringFilter2 As New StringFilter()
stringFilter1.ComparisonOperator = StringFilterComparisonOperator.CONTAINS
stringFilter1.Value = "a"

Dim filterGroup As New FilterGroup(OfString)()
filterGroup.AddFilter(FilterOperator.AND, stringFilter1)
filterGroup.AddFilter(FilterOperator.AND, stringFilter2)
  5. Create a new HierarchyItemFilter and set its Filter property to the filter group.
    CopyC#
    HierarchyItemFilter filter = newHierarchyItemFilter();
filter.Item = Grid1.ColumnsHierarchy.Items[3];
filter.Filter = filterGroup;
    CopyVB.NET
    Dim filter AsNewHierarchyItemFilter()
filter.Item = Grid1.ColumnsHierarchy.Items(3)
filter.Filter = filterGroup
  6. Apply the filter to the RowHierarchy’s Filters collection
CopyC#
Grid1.RowsHierarchy.Filters.Add(filter);
CopyVB.NET
Grid1.RowsHierarchy.Filters.Add(filter)
 The following image shows a VIBlend DataGrid which uses the applied filter.

Filter Data Grid’s Data


Alternating DataGrid Rows

[image]

VIBlend Controls for WinForms Help Documentation
Alternating DataGrid Rows
Send Feedback
Article information

Article relates to VIBlendDataGridView for WinForms

HOW-TO

Apply different styles on alternating rows

SOLUTION

To achieve this, follow these steps:

  1. Create a new instance of the vDataGridView via drag and drop from the toolbox or create it programmatically.
  2. Bind the data grid to the Invoices table.
    CopyC#
    try
{
   NwindDataSet_InovicesTableAdapters.InvoicesTableAdapter adapter = new IntegratedDemo.NwindDataSet_InovicesTableAdapters.InvoicesTableAdapter();
   adapter.Fill(nwindDataSet_Inovices.Invoices);
}
catch (System.Exception ex)
{
   MessageBox.Show(ex.Message);
   return;
}

DataTable tbl = this.nwindDataSet_Inovices.Invoices;
Grid1.BoundFields.Clear();
Grid1.BoundPivotColumns.Clear();
Grid1.BoundPivotRows.Clear();
Grid1.BoundPivotValues.Clear();
Grid1.DataSource = null;
Grid1.PivotValuesOnRows = false;

int iColumns = 0;
foreach (DataColumn col in tbl.Columns)
{
  BoundField boundField = new BoundField(col.Caption, col.ColumnName);
  Grid1.BoundFields.Add(boundField);

  if (++iColumns == 5)
  break;
}

Grid1.DataSource = tbl.DefaultView;
Grid1.DataBind();
    CopyVB.NET
    Try
   Dim adapter As NwindDataSet_InovicesTableAdapters.InvoicesTableAdapter = New IntegratedDemo.NwindDataSet_InovicesTableAdapters.InvoicesTableAdapter()
   adapter.Fill(nwindDataSet_Inovices.Invoices)
Catch ex As System.Exception
   MessageBox.Show(ex.Message)
   Return
End Try

Dim tbl As DataTable = Me.nwindDataSet_Inovices.Invoices
Grid1.BoundFields.Clear()
Grid1.BoundPivotColumns.Clear()
Grid1.BoundPivotRows.Clear()
Grid1.BoundPivotValues.Clear()
Grid1.DataSource = Nothing
Grid1.PivotValuesOnRows = False

Dim iColumns As Integer = 0
For Each col As DataColumn In tbl.Columns
  Dim boundField As New BoundField(col.Caption, col.ColumnName)
  Grid1.BoundFields.Add(boundField)

  iColumns = iColumns + 1

  If iColumns = 5 Then
  Exit For
  End If
Next col

Grid1.DataSource = tbl.DefaultView
Grid1.DataBind()
  3. AutoResize the columns to their contents.
    CopyC#
    Grid1.ColumnsHierarchy.AutoResize();
Grid1.RowsHierarchy.AutoResize();
    CopyVB.NET
    Grid1.ColumnsHierarchy.AutoResize()
Grid1.RowsHierarchy.AutoResize()
  4. Get a default cell style and modify it to use a different back color for the grid cells
    CopyC#
    GridCellStyle style = GridTheme.GetDefaultTheme(VIBLEND_THEME.OFFICE2003BLUE).GridCellStyle;
style.FillStyle = newFillStyleSolid(Color.Aqua);
     Create a new HierarchyItemFilter which uses the filter group.
    CopyVB.NET
    Dim style As GridCellStyle = GridTheme.GetDefaultTheme(VIBLEND_THEME.OFFICE2003BLUE).GridCellStyle
style.FillStyle = NewFillStyleSolid(Color.Aqua)
  5. Finally apply the cell style to the alternating grid rows
CopyC#
for (int i = 0; i <this.Grid1.RowsHierarchy.Items.Count; i++)
{
   if (i % 2 != 0)
   {
       this.Grid1.RowsHierarchy.Items[i].CellsStyle = style;
   }
}
CopyVB.NET
For i AsInteger = 0 ToMe.Grid1.RowsHierarchy.Items.Count - 1
   If i Mod 2 <> 0 Then
   Me.Grid1.RowsHierarchy.Items(i).CellsStyle = style
End If
Next i
 The following image shows a VIBlendDataGridView with alternating rows.

Alternating Rows Tutorials


ComboBox DropDownList

[image]

VIBlend Controls for WinForms Help Documentation
ComboBox DropDownList
Send Feedback
Article information

Article relates to VIBlend ComboBox for WinForms

HOW-TO

Use vComboBox as a DropDownList

SOLUTION

To achieve this, follow these steps:

  1. Create a new vComboBox instance and add some items to it.
    CopyC#
    vComboBox comboBox = newvComboBox();

for (int i = 0; i < 10; i++)
{
    comboBox.Items.Add("Item" + i);
}
    CopyVB.NET
    Dim comboBox As vComboBox = New vComboBox()

For i AsInteger = 0 To 9
    comboBox.Items.Add("Item" & i)
Next i
  2. Set the DropDownList property of the vComboBox
CopyC#
comboBox.DropDownList = true;
CopyVB.NET
comboBox.DropDownList = True
 Here is the result:

Combo Box Drop Down List


Customizing Button Style

[image]

VIBlend Controls for WinForms Help Documentation
Customizing Button Style
Send Feedback
This topic describes how to customize the VIBlend Button Style. 1. Create custom colors for the default, highlight and pressed states.
CopyC#
Color[] colors = new Color[]{Color.FromArgb(255,39,94,176),
        Color.FromArgb(255, 37, 92, 175), Color.FromArgb(255,51,105,206),
        Color.FromArgb(255,53,135,226)};

Color[] highlightColors = new Color[]{Color.FromArgb(255,59,114,196),
        Color.FromArgb(255, 57, 112, 185), Color.FromArgb(255,71,125,226),
        Color.FromArgb(255,73,155,246)};

Color[] pressedColors = new Color[]{Color.FromArgb(255,79,134,216),
        Color.FromArgb(255, 77, 132, 215), Color.FromArgb(255,91,145,246),
        Color.FromArgb(255,93,175,255)};

float[] offsets = new float[] { 0f, 0.7f, 0.9f, 1f };
CopyVB.NET
Dim colors() As Color = {Color.FromArgb(255,39,94,176), Color.FromArgb(255, 37, 92, 175), Color.FromArgb(255,51,105,206), Color.FromArgb(255,53,135,226)}

Dim highlightColors() As Color = {Color.FromArgb(255,59,114,196), Color.FromArgb(255, 57, 112, 185), Color.FromArgb(255,71,125,226), Color.FromArgb(255,73,155,246)}

Dim pressedColors() As Color = {Color.FromArgb(255,79,134,216), Color.FromArgb(255, 77, 132, 215), Color.FromArgb(255,91,145,246), Color.FromArgb(255,93,175,255)}

Dim offsets() As Single = { 0f, 0.7f, 0.9f, 1f }
 2. Create a copy of one of the already built-in themes.
CopyC#
ControlTheme theme = ControlTheme.GetDefaultTheme(VIBLEND_THEME.OFFICEBLUE).CreateCopy();
CopyVB.NET
Dim theme As ControlTheme = ControlTheme.GetDefaultTheme(VIBLEND_THEME.OFFICEBLUE).CreateCopy()
 3. Create new instances of the FillStyleGradientEx object for the button states. The FillStyleGradientEx object is used for the background rendering of the VIBlend controls.
CopyC#
FillStyleGradientEx normalStyle = new FillStyleGradientEx(colors[0], colors[1],
    colors[2], colors[3], 90, 0.7f, 0.9f);

FillStyleGradientEx highlightStyle = new FillStyleGradientEx(highlightColors[0], highlightColors[1],
 highlightColors[2], highlightColors[3], 90, 0.7f, 0.9f);

FillStyleGradientEx pressedStyle = new FillStyleGradientEx(pressedColors[0], pressedColors[1],
 pressedColors[2], pressedColors[3], 90, 0.7f, 0.9f);
CopyVB.NET
Dim normalStyle As New FillStyleGradientEx(colors(0), colors(1), colors(2), colors(3), 90, 0.7f, 0.9f)

Dim highlightStyle As New FillStyleGradientEx(highlightColors(0), highlightColors(1), highlightColors(2), highlightColors(3), 90, 0.7f, 0.9f)

Dim pressedStyle As New FillStyleGradientEx(pressedColors(0), pressedColors(1), pressedColors(2), pressedColors(3), 90, 0.7f, 0.9f)
 4. Set the theme's FillStyle, BorderColor and TextColor properties used in the rendering of controls background, border and text color.
CopyC#
Color borderColor = Color.FromArgb(31, 72, 161);

theme.StyleNormal.FillStyle = normalStyle;
theme.StyleNormal.BorderColor = borderColor;
theme.StyleNormal.TextColor = Color.White;

theme.StyleHighlight.FillStyle = highlightStyle;
theme.StyleHighlight.BorderColor = borderColor;
theme.StyleHighlight.TextColor = Color.White;

theme.StylePressed.FillStyle = pressedStyle;
theme.StylePressed.BorderColor = borderColor;
theme.StylePressed.TextColor = Color.White;
CopyVB.NET
Dim borderColor As Color = Color.FromArgb(31, 72, 161)

theme.StyleNormal.FillStyle = normalStyle
theme.StyleNormal.BorderColor = borderColor
theme.StyleNormal.TextColor = Color.White

theme.StyleHighlight.FillStyle = highlightStyle
theme.StyleHighlight.BorderColor = borderColor
theme.StyleHighlight.TextColor = Color.White

theme.StylePressed.FillStyle = pressedStyle
theme.StylePressed.BorderColor = borderColor
theme.StylePressed.TextColor = Color.White
 5. Apply the custom theme to the Button. Please note that you need to set the StyleKey property before applying the Theme.
CopyC#
this.vButton4.StyleKey = "ButtonNewStyle";
this.vButton4.Theme = theme;
CopyVB.NET
Me.vButton4.StyleKey = "ButtonNewStyle"
Me.vButton4.Theme = theme